CelloSaaS.Billing.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Billing.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | BillingAudit | Billing audit model
Public class | BillingAuditSearchCondition | Billing audit search condition class
Public class | BillingConstants | Billing module constants
Public class | BillingConstants..::..CalculationTypeConstants | Calculation type constants
Public class | BillingConstants..::..UsageCodes | Usage code constants
Public class | BillingException | Billing exception class
Public class | BillingSetting | Billing start/charge frequency day setting
Public class | BillStatistics | Bill statistics model
Public class | BillStatisticsSearchCondition | Bill statistics search condition class
Public class | CreditCardAccount | Credit card payment account model
Public class | CreditCardInfo | Credit card info model
Public class | DuplicatePricePlanException | Dulicate price plan exception
Public class | InvalidCreditCardException | Invalid credit card exception class
Public class | InvalidPaymentAPIAccountException | Invalid payment api account
Public class | Invoice | Invoice model
Public class | InvoiceLineItem | Invoice line item model
Public class | InvoicePayment | Invoice payment model
Public class | InvoiceSearchCondition | Invoice search condition class
Public class | InvoiceSearchResult | Invoice search result class
Public class | PaymentAccount | Payment account model
Public class | PaymentAccountSetting | Payment account setting model
Public class | PaymentApiAccount | Payment API Account model
Public class | PaymentAudit | Payment audit model
Public class | PaymentAuditSearchCondition | Payment audit search condition model
Public class | PaymentAuditSearchResult | Payment audit search result model
Public class | PayPalAccount | Paypal payment account model
Public class | PreapprovalDetails | Preapproval details model
Public class | PreapprovalRequest | Preapproval request model
Public class | PreapprovalResponse | Preapproval response model
Public class | PricePlan | Price plan model
Public class | PricePlanLineItem | Price plan line item model
Public class | PriceSlab | Price slab model
Public class | PriceTable | Price table model
Public class | ShippingAddress | Shipping address model
Public class | TaxRate | Tax rate model
Public class | TenantTaxRate | Tenant tax rate model

Enumerations

 | Enumeration | Description
Public enumeration | BillFrequency | Bill cycle enumeration
Public enumeration | BillingAuditStatus | Billing audit status enumeration
Public enumeration | CreditCardType | Credit card type enumeration
Public enumeration | FactorType | Bill calculation factor type enumeration
Public enumeration | InvoiceStatus | Invoice status enumeration
Public enumeration | PaymentAccountType | Payment account type enumeration
Public enumeration | PaymentMode | Payment mode enumeration


BillFrequency Enumeration

[image]

A Sandcastle Documented Class Library
BillFrequency Enumeration
See Also Send Feedback
Bill cycle enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum BillFrequency
Visual Basic
Public Enumeration BillFrequency
Visual C++
public enum class BillFrequency

Members

Member name | Value | Description
Monthly | 0 | Monthly
Quarterly | 1 | Quarterly
Semiannual | 2 | Half yearly
Annual | 3 | Yearly

See Also

CelloSaaS.Billing.Model Namespace


BillingAudit Class

[image]

A Sandcastle Documented Class Library
BillingAudit Class
Members See Also Send Feedback
Billing audit model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BillingAudit
Visual Basic
<SerializableAttribute>
Public Class BillingAudit
Visual C++
[SerializableAttribute]
public ref class BillingAudit

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillingAudit

See Also

BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit Members

[image] [image]

A Sandcastle Documented Class Library
BillingAudit Members
BillingAudit Class Constructors Methods Properties See Also Send Feedback

The BillingAudit type exposes the following members.

Constructors

 | Name | Description
Public method | BillingAudit | Initializes a new instance of the BillingAudit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BillFrequency | Gets or sets bill frequency
Public property | BillingAuditStatus | Gets or sets bill status
Public property | BillingAuditStatusValue | Gets or sets status value
Public property | BillingFrequencyValue | Gets or sets bill frequency value
Public property | Duration | Gets or sets duration
Public property | ExceptionDetails | Gets or sets exception details
Public property | Id | Gets or sets id
Public property | InvoiceDate | Gets or sets invoice date
Public property | InvoiceId | Gets or sets invoice id
Public property | InvoiceNo | Gets or sets invoice no
Public property | PackageId | Gets or sets package id
Public property | ParentTenantId | Gets or sets parent tenant di
Public property | PricePlanId | Gets or sets price plan id
Public property | TenantId | Gets or sets tenant id
Public property | TimeStamp | Gets or sets timestamp

See Also

BillingAudit Class
CelloSaaS.Billing.Model Namespace


BillingAudit Constructor

[image]

A Sandcastle Documented Class Library
BillingAudit Constructor
BillingAudit Class See Also Send Feedback
Initializes a new instance of the BillingAudit class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingAudit()
Visual Basic
Public Sub New
Visual C++
public:
BillingAudit()

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit Methods

[image] [image]

A Sandcastle Documented Class Library
BillingAudit Methods
BillingAudit Class See Also Send Feedback

The BillingAudit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BillingAudit Class
CelloSaaS.Billing.Model Namespace


BillingAudit Properties

[image] [image]

A Sandcastle Documented Class Library
BillingAudit Properties
BillingAudit Class See Also Send Feedback

The BillingAudit type exposes the following members.

Properties

 | Name | Description
Public property | BillFrequency | Gets or sets bill frequency
Public property | BillingAuditStatus | Gets or sets bill status
Public property | BillingAuditStatusValue | Gets or sets status value
Public property | BillingFrequencyValue | Gets or sets bill frequency value
Public property | Duration | Gets or sets duration
Public property | ExceptionDetails | Gets or sets exception details
Public property | Id | Gets or sets id
Public property | InvoiceDate | Gets or sets invoice date
Public property | InvoiceId | Gets or sets invoice id
Public property | InvoiceNo | Gets or sets invoice no
Public property | PackageId | Gets or sets package id
Public property | ParentTenantId | Gets or sets parent tenant di
Public property | PricePlanId | Gets or sets price plan id
Public property | TenantId | Gets or sets tenant id
Public property | TimeStamp | Gets or sets timestamp

See Also

BillingAudit Class
CelloSaaS.Billing.Model Namespace


BillingAudit.BillFrequency Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..BillFrequency Property
BillingAudit Class See Also Send Feedback
Gets or sets bill frequency

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillFrequency BillFrequency { get; set; }
Visual Basic
Public Property BillFrequency As BillFrequency
    Get
    Set
Visual C++
public:
property BillFrequency BillFrequency {
    BillFrequency get ();
    void set (BillFrequency value);
}

Property Value

Type: BillFrequency

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.BillingAuditStatus Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..BillingAuditStatus Property
BillingAudit Class See Also Send Feedback
Gets or sets bill status

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingAuditStatus BillingAuditStatus { get; set; }
Visual Basic
Public Property BillingAuditStatus As BillingAuditStatus
    Get
    Set
Visual C++
public:
property BillingAuditStatus BillingAuditStatus {
    BillingAuditStatus get ();
    void set (BillingAuditStatus value);
}

Property Value

Type: BillingAuditStatus

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.BillingAuditStatusValue Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..BillingAuditStatusValue Property
BillingAudit Class See Also Send Feedback
Gets or sets status value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BillingAuditStatusValue { get; set; }
Visual Basic
Public Property BillingAuditStatusValue As Integer
    Get
    Set
Visual C++
public:
property int BillingAuditStatusValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.BillingFrequencyValue Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..BillingFrequencyValue Property
BillingAudit Class See Also Send Feedback
Gets or sets bill frequency value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> BillingFrequencyValue { get; set; }
Visual Basic
Public Property BillingFrequencyValue As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> BillingFrequencyValue {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.Duration Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..Duration Property
BillingAudit Class See Also Send Feedback
Gets or sets duration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> Duration { get; set; }
Visual Basic
Public Property Duration As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Duration {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.ExceptionDetails Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..ExceptionDetails Property
BillingAudit Class See Also Send Feedback
Gets or sets exception details

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExceptionDetails { get; set; }
Visual Basic
Public Property ExceptionDetails As String
    Get
    Set
Visual C++
public:
property String^ ExceptionDetails {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.Id Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..Id Property
BillingAudit Class See Also Send Feedback
Gets or sets id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.InvoiceDate Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..InvoiceDate Property
BillingAudit Class See Also Send Feedback
Gets or sets invoice date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime InvoiceDate { get; set; }
Visual Basic
Public Property InvoiceDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime InvoiceDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.InvoiceId Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..InvoiceId Property
BillingAudit Class See Also Send Feedback
Gets or sets invoice id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> InvoiceId { get; set; }
Visual Basic
Public Property InvoiceId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> InvoiceId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.InvoiceNo Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..InvoiceNo Property
BillingAudit Class See Also Send Feedback
Gets or sets invoice no

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string InvoiceNo { get; set; }
Visual Basic
Public Property InvoiceNo As String
    Get
    Set
Visual C++
public:
property String^ InvoiceNo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.PackageId Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..PackageId Property
BillingAudit Class See Also Send Feedback
Gets or sets package id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> PackageId { get; set; }
Visual Basic
Public Property PackageId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> PackageId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..ParentTenantId Property
BillingAudit Class See Also Send Feedback
Gets or sets parent tenant di

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As Guid
    Get
    Set
Visual C++
public:
property Guid ParentTenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.PricePlanId Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..PricePlanId Property
BillingAudit Class See Also Send Feedback
Gets or sets price plan id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> PricePlanId { get; set; }
Visual Basic
Public Property PricePlanId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> PricePlanId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.TenantId Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..TenantId Property
BillingAudit Class See Also Send Feedback
Gets or sets tenant id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAudit.TimeStamp Property

[image]

A Sandcastle Documented Class Library
BillingAudit..::..TimeStamp Property
BillingAudit Class See Also Send Feedback
Gets or sets timestamp

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

BillingAudit Class
BillingAudit Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition Class

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition Class
Members See Also Send Feedback
Billing audit search condition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BillingAuditSearchCondition
Visual Basic
Public Class BillingAuditSearchCondition
Visual C++
public ref class BillingAuditSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillingAuditSearchCondition

See Also

BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition Members
BillingAuditSearchCondition Class Constructors Methods Properties See Also Send Feedback

The BillingAuditSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | BillingAuditSearchCondition | Initializes a new instance of the BillingAuditSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BillFrequency | Gets or sets bill frequency
Public property | BillingAuditStatus | Gets or sets billing audit status
Public property | InvoiceDate | Gets or sets invoice date
Public property | InvoiceId | Gets or sets invoice id
Public property | InvoiceNo | Gets or sets invoice number
Public property | PageNo | Gets or sets page no
Public property | PageSize | Gets or sets page size
Public property | TenantId | Gets or sets tenant id

See Also

BillingAuditSearchCondition Class
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition Constructor
BillingAuditSearchCondition Class See Also Send Feedback
Initializes a new instance of the BillingAuditSearchCondition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingAuditSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
BillingAuditSearchCondition()

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition Methods
BillingAuditSearchCondition Class See Also Send Feedback

The BillingAuditSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BillingAuditSearchCondition Class
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition Properties
BillingAuditSearchCondition Class See Also Send Feedback

The BillingAuditSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | BillFrequency | Gets or sets bill frequency
Public property | BillingAuditStatus | Gets or sets billing audit status
Public property | InvoiceDate | Gets or sets invoice date
Public property | InvoiceId | Gets or sets invoice id
Public property | InvoiceNo | Gets or sets invoice number
Public property | PageNo | Gets or sets page no
Public property | PageSize | Gets or sets page size
Public property | TenantId | Gets or sets tenant id

See Also

BillingAuditSearchCondition Class
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.BillFrequency Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..BillFrequency Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets bill frequency

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<BillFrequency> BillFrequency { get; set; }
Visual Basic
Public Property BillFrequency As Nullable(Of BillFrequency)
    Get
    Set
Visual C++
public:
property Nullable<BillFrequency> BillFrequency {
    Nullable<BillFrequency> get ();
    void set (Nullable<BillFrequency> value);
}

Property Value

Type: Nullable<(Of <(<' BillFrequency >)>)>

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.BillingAuditStatus Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..BillingAuditStatus Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets billing audit status

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<BillingAuditStatus> BillingAuditStatus { get; set; }
Visual Basic
Public Property BillingAuditStatus As Nullable(Of BillingAuditStatus)
    Get
    Set
Visual C++
public:
property Nullable<BillingAuditStatus> BillingAuditStatus {
    Nullable<BillingAuditStatus> get ();
    void set (Nullable<BillingAuditStatus> value);
}

Property Value

Type: Nullable<(Of <(<' BillingAuditStatus >)>)>

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.InvoiceDate Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..InvoiceDate Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets invoice date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> InvoiceDate { get; set; }
Visual Basic
Public Property InvoiceDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> InvoiceDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.InvoiceId Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..InvoiceId Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets invoice id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> InvoiceId { get; set; }
Visual Basic
Public Property InvoiceId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> InvoiceId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.InvoiceNo Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..InvoiceNo Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets invoice number

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string InvoiceNo { get; set; }
Visual Basic
Public Property InvoiceNo As String
    Get
    Set
Visual C++
public:
property String^ InvoiceNo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..PageNo Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets page no

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..PageSize Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets page size

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
BillingAuditSearchCondition..::..TenantId Property
BillingAuditSearchCondition Class See Also Send Feedback
Gets or sets tenant id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> TenantId { get; set; }
Visual Basic
Public Property TenantId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> TenantId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

BillingAuditSearchCondition Class
BillingAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillingAuditStatus Enumeration

[image]

A Sandcastle Documented Class Library
BillingAuditStatus Enumeration
See Also Send Feedback
Billing audit status enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[FlagsAttribute]
public enum BillingAuditStatus
Visual Basic
<FlagsAttribute>
Public Enumeration BillingAuditStatus
Visual C++
[FlagsAttribute]
public enum class BillingAuditStatus

Members

Member name | Value | Description
Progress | 1 | In Progress
Success | 2 | Sucess
Failed | 4 | Failed

See Also

CelloSaaS.Billing.Model Namespace


BillingConstants Class

[image]

A Sandcastle Documented Class Library
BillingConstants Class
Members See Also Send Feedback
Billing module constants

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class BillingConstants
Visual Basic
Public NotInheritable Class BillingConstants
Visual C++
public ref class BillingConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillingConstants

See Also

BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants Members

[image] [image]

A Sandcastle Documented Class Library
BillingConstants Members
BillingConstants Class Fields Properties See Also Send Feedback

The BillingConstants type exposes the following members.

Fields

Name | Description
BillGeneratedNotificationId | Bill generated notification id
ConnectionString | Billing connection string
PaymentFailureNotificationId | Payment failure notification id
PaymentSuccessNotificationId | Payment success notification id

Properties

Name | Description
DefaultInvoiceNote | Default invocie note to be added for the newly created bills
RoundDecimals | Round decimals

See Also

BillingConstants Class
CelloSaaS.Billing.Model Namespace


BillingConstants Fields

[image] [image]

A Sandcastle Documented Class Library
BillingConstants Fields
BillingConstants Class See Also Send Feedback

The BillingConstants type exposes the following members.

Fields

Name | Description
BillGeneratedNotificationId | Bill generated notification id
ConnectionString | Billing connection string
PaymentFailureNotificationId | Payment failure notification id
PaymentSuccessNotificationId | Payment success notification id

See Also

BillingConstants Class
CelloSaaS.Billing.Model Namespace


BillingConstants.BillGeneratedNotificationId Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..BillGeneratedNotificationId Field
BillingConstants Class See Also Send Feedback
Bill generated notification id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillGeneratedNotificationId
Visual Basic
Public Const BillGeneratedNotificationId As String
Visual C++
public:
literal String^ BillGeneratedNotificationId

Field Value

Type: String

See Also

BillingConstants Class
BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.ConnectionString Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..ConnectionString Field
BillingConstants Class See Also Send Feedback
Billing connection string

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ConnectionString
Visual Basic
Public Const ConnectionString As String
Visual C++
public:
literal String^ ConnectionString

Field Value

Type: String

See Also

BillingConstants Class
BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.PaymentFailureNotificationId Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..PaymentFailureNotificationId Field
BillingConstants Class See Also Send Feedback
Payment failure notification id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PaymentFailureNotificationId
Visual Basic
Public Const PaymentFailureNotificationId As String
Visual C++
public:
literal String^ PaymentFailureNotificationId

Field Value

Type: String

See Also

BillingConstants Class
BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.PaymentSuccessNotificationId Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..PaymentSuccessNotificationId Field
BillingConstants Class See Also Send Feedback
Payment success notification id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PaymentSuccessNotificationId
Visual Basic
Public Const PaymentSuccessNotificationId As String
Visual C++
public:
literal String^ PaymentSuccessNotificationId

Field Value

Type: String

See Also

BillingConstants Class
BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants Properties

[image] [image]

A Sandcastle Documented Class Library
BillingConstants Properties
BillingConstants Class See Also Send Feedback

The BillingConstants type exposes the following members.

Properties

Name | Description
DefaultInvoiceNote | Default invocie note to be added for the newly created bills
RoundDecimals | Round decimals

See Also

BillingConstants Class
CelloSaaS.Billing.Model Namespace


BillingConstants.DefaultInvoiceNote Property

[image]

A Sandcastle Documented Class Library
BillingConstants..::..DefaultInvoiceNote Property
BillingConstants Class See Also Send Feedback
Default invocie note to be added for the newly created bills

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DefaultInvoiceNote { get; }
Visual Basic
Public Shared ReadOnly Property DefaultInvoiceNote As String
    Get
Visual C++
public:
static property String^ DefaultInvoiceNote {
    String^ get ();
}

Property Value

Type: String

See Also

BillingConstants Class
BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.RoundDecimals Property

[image]

A Sandcastle Documented Class Library
BillingConstants..::..RoundDecimals Property
BillingConstants Class See Also Send Feedback
Round decimals

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static int RoundDecimals { get; }
Visual Basic
Public Shared ReadOnly Property RoundDecimals As Integer
    Get
Visual C++
public:
static property int RoundDecimals {
    int get ();
}

Property Value

Type: Int32

See Also

BillingConstants Class
BillingConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.CalculationTypeConstants Class

[image]

A Sandcastle Documented Class Library
BillingConstants..::..CalculationTypeConstants Class
BillingConstants Class Members See Also Send Feedback
Calculation type constants

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class CalculationTypeConstants
Visual Basic
Public NotInheritable Class CalculationTypeConstants
Visual C++
public ref class CalculationTypeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillingConstants..::..CalculationTypeConstants

See Also

BillingConstants..::..CalculationTypeConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.CalculationTypeConstants Members

[image] [image]

A Sandcastle Documented Class Library
BillingConstants..::..CalculationTypeConstants Members
BillingConstants..::..CalculationTypeConstants Class Fields See Also Send Feedback

The BillingConstants..::..CalculationTypeConstants type exposes the following members.

Fields

Name | Description
StepPricing | Step pricing if slab 1-100 is $5, 101-200 is $3.33 and usage is 110 then Net Amt = (100*$5) + (10*$3.33)
ThresholdPricing | Threshold Pricing if slab 1-100 is $5 and usage is 90 then amt = 90*$5

See Also

BillingConstants..::..CalculationTypeConstants Class
CelloSaaS.Billing.Model Namespace


BillingConstants.CalculationTypeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
BillingConstants..::..CalculationTypeConstants Fields
BillingConstants..::..CalculationTypeConstants Class See Also Send Feedback

The BillingConstants..::..CalculationTypeConstants type exposes the following members.

Fields

Name | Description
StepPricing | Step pricing if slab 1-100 is $5, 101-200 is $3.33 and usage is 110 then Net Amt = (100*$5) + (10*$3.33)
ThresholdPricing | Threshold Pricing if slab 1-100 is $5 and usage is 90 then amt = 90*$5

See Also

BillingConstants..::..CalculationTypeConstants Class
CelloSaaS.Billing.Model Namespace


BillingConstants.CalculationTypeConstants.StepPricing Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..CalculationTypeConstants..::..StepPricing Field
BillingConstants..::..CalculationTypeConstants Class See Also Send Feedback
Step pricing if slab 1-100 is $5, 101-200 is $3.33 and usage is 110 then Net Amt = (100*$5) + (10*$3.33)

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string StepPricing
Visual Basic
Public Const StepPricing As String
Visual C++
public:
literal String^ StepPricing

Field Value

Type: String

See Also

BillingConstants..::..CalculationTypeConstants Class
BillingConstants..::..CalculationTypeConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.CalculationTypeConstants.ThresholdPricing Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..CalculationTypeConstants..::..ThresholdPricing Field
BillingConstants..::..CalculationTypeConstants Class See Also Send Feedback
Threshold Pricing if slab 1-100 is $5 and usage is 90 then amt = 90*$5

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ThresholdPricing
Visual Basic
Public Const ThresholdPricing As String
Visual C++
public:
literal String^ ThresholdPricing

Field Value

Type: String

See Also

BillingConstants..::..CalculationTypeConstants Class
BillingConstants..::..CalculationTypeConstants Members
CelloSaaS.Billing.Model Namespace


BillingConstants.UsageCodes Class

[image]

A Sandcastle Documented Class Library
BillingConstants..::..UsageCodes Class
BillingConstants Class Members See Also Send Feedback
Usage code constants

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class UsageCodes
Visual Basic
Public NotInheritable Class UsageCodes
Visual C++
public ref class UsageCodes abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillingConstants..::..UsageCodes

See Also

BillingConstants..::..UsageCodes Members
CelloSaaS.Billing.Model Namespace


BillingConstants.UsageCodes Members

[image] [image]

A Sandcastle Documented Class Library
BillingConstants..::..UsageCodes Members
BillingConstants..::..UsageCodes Class Fields See Also Send Feedback

The BillingConstants..::..UsageCodes type exposes the following members.

Fields

Name | Description
BillingInvoiceAmount | Billing invoice amount
BillingInvoiceYTD | Billing invoice Yearly amount (YTD)

See Also

BillingConstants..::..UsageCodes Class
CelloSaaS.Billing.Model Namespace


BillingConstants.UsageCodes Fields

[image] [image]

A Sandcastle Documented Class Library
BillingConstants..::..UsageCodes Fields
BillingConstants..::..UsageCodes Class See Also Send Feedback

The BillingConstants..::..UsageCodes type exposes the following members.

Fields

Name | Description
BillingInvoiceAmount | Billing invoice amount
BillingInvoiceYTD | Billing invoice Yearly amount (YTD)

See Also

BillingConstants..::..UsageCodes Class
CelloSaaS.Billing.Model Namespace


BillingConstants.UsageCodes.BillingInvoiceAmount Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..UsageCodes..::..BillingInvoiceAmount Field
BillingConstants..::..UsageCodes Class See Also Send Feedback
Billing invoice amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillingInvoiceAmount
Visual Basic
Public Const BillingInvoiceAmount As String
Visual C++
public:
literal String^ BillingInvoiceAmount

Field Value

Type: String

See Also

BillingConstants..::..UsageCodes Class
BillingConstants..::..UsageCodes Members
CelloSaaS.Billing.Model Namespace


BillingConstants.UsageCodes.BillingInvoiceYTD Field

[image]

A Sandcastle Documented Class Library
BillingConstants..::..UsageCodes..::..BillingInvoiceYTD Field
BillingConstants..::..UsageCodes Class See Also Send Feedback
Billing invoice Yearly amount (YTD)

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillingInvoiceYTD
Visual Basic
Public Const BillingInvoiceYTD As String
Visual C++
public:
literal String^ BillingInvoiceYTD

Field Value

Type: String

See Also

BillingConstants..::..UsageCodes Class
BillingConstants..::..UsageCodes Members
CelloSaaS.Billing.Model Namespace


BillingException Class

[image]

A Sandcastle Documented Class Library
BillingException Class
Members See Also Send Feedback
Billing exception class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public sealed class BillingException : BaseException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class BillingException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class BillingException sealed : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Billing.Model..::..BillingException

See Also

BillingException Members
CelloSaaS.Billing.Model Namespace


BillingException Members

[image] [image]

A Sandcastle Documented Class Library
BillingException Members
BillingException Class Constructors Methods Properties Events See Also Send Feedback

The BillingException type exposes the following members.

Constructors

 | Name | Description
Public method | BillingException()()()() | Billing exception
Public method | BillingException(String) | Billing exception
Public method | BillingException(String, Exception) | Billing exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BillingException Class
CelloSaaS.Billing.Model Namespace


BillingException Constructor

[image] [image]

A Sandcastle Documented Class Library
BillingException Constructor
BillingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BillingException()()()() | Billing exception
Public method | BillingException(String) | Billing exception
Public method | BillingException(String, Exception) | Billing exception

See Also

BillingException Class
BillingException Members
CelloSaaS.Billing.Model Namespace


BillingException Constructor

[image]

A Sandcastle Documented Class Library
BillingException Constructor
BillingException Class See Also Send Feedback
Billing exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingException()
Visual Basic
Public Sub New
Visual C++
public:
BillingException()

See Also

BillingException Class
BillingException Members
BillingException Overload
CelloSaaS.Billing.Model Namespace


BillingException Constructor (String)

[image]

A Sandcastle Documented Class Library
BillingException Constructor (String)
BillingException Class See Also Send Feedback
Billing exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
BillingException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

BillingException Class
BillingException Members
BillingException Overload
CelloSaaS.Billing.Model Namespace


BillingException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
BillingException Constructor (String, Exception)
BillingException Class See Also Send Feedback
Billing exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
BillingException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
ex
Type: System..::..Exception

See Also

BillingException Class
BillingException Members
BillingException Overload
CelloSaaS.Billing.Model Namespace


BillingException Methods

[image] [image]

A Sandcastle Documented Class Library
BillingException Methods
BillingException Class See Also Send Feedback

The BillingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BillingException Class
CelloSaaS.Billing.Model Namespace


BillingException Properties

[image] [image]

A Sandcastle Documented Class Library
BillingException Properties
BillingException Class See Also Send Feedback

The BillingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BillingException Class
CelloSaaS.Billing.Model Namespace


BillingException Events

[image] [image]

A Sandcastle Documented Class Library
BillingException Events
BillingException Class See Also Send Feedback

The BillingException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BillingException Class
CelloSaaS.Billing.Model Namespace


BillingSetting Class

[image]

A Sandcastle Documented Class Library
BillingSetting Class
Members See Also Send Feedback
Billing start/charge frequency day setting

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BillingSetting
Visual Basic
<SerializableAttribute>
Public Class BillingSetting
Visual C++
[SerializableAttribute]
public ref class BillingSetting

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillingSetting

See Also

BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting Members

[image] [image]

A Sandcastle Documented Class Library
BillingSetting Members
BillingSetting Class Constructors Methods Properties See Also Send Feedback

The BillingSetting type exposes the following members.

Constructors

 | Name | Description
Public method | BillingSetting | Initializes a new instance of the BillingSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BillFrequency | Billing fequency int value
Public property | BillFrequencyValue | Billing frequency
Public property | ChargeDay | Billing charge day
Public property | Id | Identifier
Public property | StartDay | Billing start date
Public property | TenantId | Gets or sets tenant id

See Also

BillingSetting Class
CelloSaaS.Billing.Model Namespace


BillingSetting Constructor

[image]

A Sandcastle Documented Class Library
BillingSetting Constructor
BillingSetting Class See Also Send Feedback
Initializes a new instance of the BillingSetting class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillingSetting()
Visual Basic
Public Sub New
Visual C++
public:
BillingSetting()

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting Methods

[image] [image]

A Sandcastle Documented Class Library
BillingSetting Methods
BillingSetting Class See Also Send Feedback

The BillingSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BillingSetting Class
CelloSaaS.Billing.Model Namespace


BillingSetting Properties

[image] [image]

A Sandcastle Documented Class Library
BillingSetting Properties
BillingSetting Class See Also Send Feedback

The BillingSetting type exposes the following members.

Properties

 | Name | Description
Public property | BillFrequency | Billing fequency int value
Public property | BillFrequencyValue | Billing frequency
Public property | ChargeDay | Billing charge day
Public property | Id | Identifier
Public property | StartDay | Billing start date
Public property | TenantId | Gets or sets tenant id

See Also

BillingSetting Class
CelloSaaS.Billing.Model Namespace


BillingSetting.BillFrequency Property

[image]

A Sandcastle Documented Class Library
BillingSetting..::..BillFrequency Property
BillingSetting Class See Also Send Feedback
Billing fequency int value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillFrequency BillFrequency { get; set; }
Visual Basic
Public Property BillFrequency As BillFrequency
    Get
    Set
Visual C++
public:
property BillFrequency BillFrequency {
    BillFrequency get ();
    void set (BillFrequency value);
}

Property Value

Type: BillFrequency

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting.BillFrequencyValue Property

[image]

A Sandcastle Documented Class Library
BillingSetting..::..BillFrequencyValue Property
BillingSetting Class See Also Send Feedback
Billing frequency

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BillFrequencyValue { get; set; }
Visual Basic
Public Property BillFrequencyValue As Integer
    Get
    Set
Visual C++
public:
property int BillFrequencyValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting.ChargeDay Property

[image]

A Sandcastle Documented Class Library
BillingSetting..::..ChargeDay Property
BillingSetting Class See Also Send Feedback
Billing charge day

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ChargeDay { get; set; }
Visual Basic
Public Property ChargeDay As Integer
    Get
    Set
Visual C++
public:
property int ChargeDay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting.Id Property

[image]

A Sandcastle Documented Class Library
BillingSetting..::..Id Property
BillingSetting Class See Also Send Feedback
Identifier

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting.StartDay Property

[image]

A Sandcastle Documented Class Library
BillingSetting..::..StartDay Property
BillingSetting Class See Also Send Feedback
Billing start date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int StartDay { get; set; }
Visual Basic
Public Property StartDay As Integer
    Get
    Set
Visual C++
public:
property int StartDay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillingSetting.TenantId Property

[image]

A Sandcastle Documented Class Library
BillingSetting..::..TenantId Property
BillingSetting Class See Also Send Feedback
Gets or sets tenant id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> TenantId { get; set; }
Visual Basic
Public Property TenantId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> TenantId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

BillingSetting Class
BillingSetting Members
CelloSaaS.Billing.Model Namespace


BillStatistics Class

[image]

A Sandcastle Documented Class Library
BillStatistics Class
Members See Also Send Feedback
Bill statistics model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BillStatistics
Visual Basic
<SerializableAttribute>
Public Class BillStatistics
Visual C++
[SerializableAttribute]
public ref class BillStatistics

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillStatistics

See Also

BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatistics Members

[image] [image]

A Sandcastle Documented Class Library
BillStatistics Members
BillStatistics Class Constructors Methods Properties See Also Send Feedback

The BillStatistics type exposes the following members.

Constructors

 | Name | Description
Public method | BillStatistics | Initializes a new instance of the BillStatistics class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Overdue | Gets overdue amount
Public property | TenantId | Gets or Sets tenant id
Public property | TotalAmount | Gets or Sets total amount
Public property | TotalBills | Gets or Sets total bills
Public property | TotalPaid | Gets or Sets total paid

See Also

BillStatistics Class
CelloSaaS.Billing.Model Namespace


BillStatistics Constructor

[image]

A Sandcastle Documented Class Library
BillStatistics Constructor
BillStatistics Class See Also Send Feedback
Initializes a new instance of the BillStatistics class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillStatistics()
Visual Basic
Public Sub New
Visual C++
public:
BillStatistics()

See Also

BillStatistics Class
BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatistics Methods

[image] [image]

A Sandcastle Documented Class Library
BillStatistics Methods
BillStatistics Class See Also Send Feedback

The BillStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BillStatistics Class
CelloSaaS.Billing.Model Namespace


BillStatistics Properties

[image] [image]

A Sandcastle Documented Class Library
BillStatistics Properties
BillStatistics Class See Also Send Feedback

The BillStatistics type exposes the following members.

Properties

 | Name | Description
Public property | Overdue | Gets overdue amount
Public property | TenantId | Gets or Sets tenant id
Public property | TotalAmount | Gets or Sets total amount
Public property | TotalBills | Gets or Sets total bills
Public property | TotalPaid | Gets or Sets total paid

See Also

BillStatistics Class
CelloSaaS.Billing.Model Namespace


BillStatistics.Overdue Property

[image]

A Sandcastle Documented Class Library
BillStatistics..::..Overdue Property
BillStatistics Class See Also Send Feedback
Gets overdue amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Overdue { get; }
Visual Basic
Public ReadOnly Property Overdue As Double
    Get
Visual C++
public:
property double Overdue {
    double get ();
}

Property Value

Type: Double

See Also

BillStatistics Class
BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatistics.TenantId Property

[image]

A Sandcastle Documented Class Library
BillStatistics..::..TenantId Property
BillStatistics Class See Also Send Feedback
Gets or Sets tenant id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

BillStatistics Class
BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatistics.TotalAmount Property

[image]

A Sandcastle Documented Class Library
BillStatistics..::..TotalAmount Property
BillStatistics Class See Also Send Feedback
Gets or Sets total amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double TotalAmount { get; set; }
Visual Basic
Public Property TotalAmount As Double
    Get
    Set
Visual C++
public:
property double TotalAmount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BillStatistics Class
BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatistics.TotalBills Property

[image]

A Sandcastle Documented Class Library
BillStatistics..::..TotalBills Property
BillStatistics Class See Also Send Feedback
Gets or Sets total bills

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalBills { get; set; }
Visual Basic
Public Property TotalBills As Integer
    Get
    Set
Visual C++
public:
property int TotalBills {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillStatistics Class
BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatistics.TotalPaid Property

[image]

A Sandcastle Documented Class Library
BillStatistics..::..TotalPaid Property
BillStatistics Class See Also Send Feedback
Gets or Sets total paid

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double TotalPaid { get; set; }
Visual Basic
Public Property TotalPaid As Double
    Get
    Set
Visual C++
public:
property double TotalPaid {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BillStatistics Class
BillStatistics Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition Class

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition Class
Members See Also Send Feedback
Bill statistics search condition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BillStatisticsSearchCondition
Visual Basic
<SerializableAttribute>
Public Class BillStatisticsSearchCondition
Visual C++
[SerializableAttribute]
public ref class BillStatisticsSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..BillStatisticsSearchCondition

See Also

BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition Members
BillStatisticsSearchCondition Class Constructors Methods Properties See Also Send Feedback

The BillStatisticsSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | BillStatisticsSearchCondition | Initializes a new instance of the BillStatisticsSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FromDate | Gets or Sets from date
Public property | MaxOverdueAmount | Gets or Sets max over due amount
Public property | MaxTotalAmount | Gets or Sets max total amount
Public property | MinOverdueAmount | Gets or Sets min over due amount
Public property | MinTotalAmount | Gets or Sets min total amount
Public property | OnlyOverdue | Gets or Sets only over due
Public property | TenantIds | Gets or Sets tenant ids
Public property | ToDate | Gets or Sets to date
Public property | TopTenants | Gets or Sets fetch top tenants count

See Also

BillStatisticsSearchCondition Class
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition Constructor
BillStatisticsSearchCondition Class See Also Send Feedback
Initializes a new instance of the BillStatisticsSearchCondition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillStatisticsSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
BillStatisticsSearchCondition()

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition Methods
BillStatisticsSearchCondition Class See Also Send Feedback

The BillStatisticsSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BillStatisticsSearchCondition Class
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition Properties
BillStatisticsSearchCondition Class See Also Send Feedback

The BillStatisticsSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | FromDate | Gets or Sets from date
Public property | MaxOverdueAmount | Gets or Sets max over due amount
Public property | MaxTotalAmount | Gets or Sets max total amount
Public property | MinOverdueAmount | Gets or Sets min over due amount
Public property | MinTotalAmount | Gets or Sets min total amount
Public property | OnlyOverdue | Gets or Sets only over due
Public property | TenantIds | Gets or Sets tenant ids
Public property | ToDate | Gets or Sets to date
Public property | TopTenants | Gets or Sets fetch top tenants count

See Also

BillStatisticsSearchCondition Class
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.FromDate Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..FromDate Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets from date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromDate { get; set; }
Visual Basic
Public Property FromDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.MaxOverdueAmount Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..MaxOverdueAmount Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets max over due amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MaxOverdueAmount { get; set; }
Visual Basic
Public Property MaxOverdueAmount As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaxOverdueAmount {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.MaxTotalAmount Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..MaxTotalAmount Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets max total amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MaxTotalAmount { get; set; }
Visual Basic
Public Property MaxTotalAmount As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaxTotalAmount {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.MinOverdueAmount Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..MinOverdueAmount Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets min over due amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MinOverdueAmount { get; set; }
Visual Basic
Public Property MinOverdueAmount As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinOverdueAmount {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.MinTotalAmount Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..MinTotalAmount Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets min total amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MinTotalAmount { get; set; }
Visual Basic
Public Property MinTotalAmount As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinTotalAmount {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.OnlyOverdue Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..OnlyOverdue Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets only over due

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool OnlyOverdue { get; set; }
Visual Basic
Public Property OnlyOverdue As Boolean
    Get
    Set
Visual C++
public:
property bool OnlyOverdue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..TenantIds Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets tenant ids

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ TenantIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.ToDate Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..ToDate Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets to date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToDate { get; set; }
Visual Basic
Public Property ToDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


BillStatisticsSearchCondition.TopTenants Property

[image]

A Sandcastle Documented Class Library
BillStatisticsSearchCondition..::..TopTenants Property
BillStatisticsSearchCondition Class See Also Send Feedback
Gets or Sets fetch top tenants count

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TopTenants { get; set; }
Visual Basic
Public Property TopTenants As Integer
    Get
    Set
Visual C++
public:
property int TopTenants {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BillStatisticsSearchCondition Class
BillStatisticsSearchCondition Members
CelloSaaS.Billing.Model Namespace


CreditCardAccount Class

[image]

A Sandcastle Documented Class Library
CreditCardAccount Class
Members See Also Send Feedback
Credit card payment account model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CreditCardAccount : PaymentAccount
Visual Basic
<SerializableAttribute>
Public Class CreditCardAccount
    Inherits PaymentAccount
Visual C++
[SerializableAttribute]
public ref class CreditCardAccount : public PaymentAccount

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAccount
CelloSaaS.Billing.Model..::..CreditCardAccount

See Also

CreditCardAccount Members
CelloSaaS.Billing.Model Namespace


CreditCardAccount Members

[image] [image]

A Sandcastle Documented Class Library
CreditCardAccount Members
CreditCardAccount Class Constructors Methods Properties See Also Send Feedback

The CreditCardAccount type exposes the following members.

Constructors

 | Name | Description
Public method | CreditCardAccount | Initializes a new instance of the CreditCardAccount class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType (Inherited from PaymentAccount.)
Public property | AccountTypeValue | Gets or Sets AccountTypeValue (Inherited from PaymentAccount.)
Public property | CreatedBy | Gets or Sets CreatedBy (Inherited from PaymentAccount.)
Public property | CreatedOn | Gets or Sets CreatedOn (Inherited from PaymentAccount.)
Public property | CreditCardInfo | Gets or Sets CreditCardInfo
Public property | CurrencyCode | Gets or Sets CurrencyCode (Inherited from PaymentAccount.)
Public property | Email | Gets or Sets Email (Inherited from PaymentAccount.)
Public property | Status | Gets or Sets Status (Inherited from PaymentAccount.)
Public property | StoreKey | Gets or Sets StoreKey (Inherited from PaymentAccount.)
Public property | TenantId | Gets or Sets TenantId (Inherited from PaymentAccount.)
Public property | UpdatedBy | Gets or Sets UpdatedBy (Inherited from PaymentAccount.)
Public property | UpdatedOn | Gets or Sets UpdatedOn (Inherited from PaymentAccount.)

See Also

CreditCardAccount Class
CelloSaaS.Billing.Model Namespace


CreditCardAccount Constructor

[image]

A Sandcastle Documented Class Library
CreditCardAccount Constructor
CreditCardAccount Class See Also Send Feedback
Initializes a new instance of the CreditCardAccount class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CreditCardAccount()
Visual Basic
Public Sub New
Visual C++
public:
CreditCardAccount()

See Also

CreditCardAccount Class
CreditCardAccount Members
CelloSaaS.Billing.Model Namespace


CreditCardAccount Methods

[image] [image]

A Sandcastle Documented Class Library
CreditCardAccount Methods
CreditCardAccount Class See Also Send Feedback

The CreditCardAccount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CreditCardAccount Class
CelloSaaS.Billing.Model Namespace


CreditCardAccount Properties

[image] [image]

A Sandcastle Documented Class Library
CreditCardAccount Properties
CreditCardAccount Class See Also Send Feedback

The CreditCardAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType (Inherited from PaymentAccount.)
Public property | AccountTypeValue | Gets or Sets AccountTypeValue (Inherited from PaymentAccount.)
Public property | CreatedBy | Gets or Sets CreatedBy (Inherited from PaymentAccount.)
Public property | CreatedOn | Gets or Sets CreatedOn (Inherited from PaymentAccount.)
Public property | CreditCardInfo | Gets or Sets CreditCardInfo
Public property | CurrencyCode | Gets or Sets CurrencyCode (Inherited from PaymentAccount.)
Public property | Email | Gets or Sets Email (Inherited from PaymentAccount.)
Public property | Status | Gets or Sets Status (Inherited from PaymentAccount.)
Public property | StoreKey | Gets or Sets StoreKey (Inherited from PaymentAccount.)
Public property | TenantId | Gets or Sets TenantId (Inherited from PaymentAccount.)
Public property | UpdatedBy | Gets or Sets UpdatedBy (Inherited from PaymentAccount.)
Public property | UpdatedOn | Gets or Sets UpdatedOn (Inherited from PaymentAccount.)

See Also

CreditCardAccount Class
CelloSaaS.Billing.Model Namespace


CreditCardAccount.CreditCardInfo Property

[image]

A Sandcastle Documented Class Library
CreditCardAccount..::..CreditCardInfo Property
CreditCardAccount Class See Also Send Feedback
Gets or Sets CreditCardInfo

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CreditCardInfo CreditCardInfo { get; set; }
Visual Basic
Public Property CreditCardInfo As CreditCardInfo
    Get
    Set
Visual C++
public:
property CreditCardInfo^ CreditCardInfo {
    CreditCardInfo^ get ();
    void set (CreditCardInfo^ value);
}

Property Value

Type: CreditCardInfo

See Also

CreditCardAccount Class
CreditCardAccount Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo Class

[image]

A Sandcastle Documented Class Library
CreditCardInfo Class
Members See Also Send Feedback
Credit card info model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CreditCardInfo
Visual Basic
<SerializableAttribute>
Public Class CreditCardInfo
Visual C++
[SerializableAttribute]
public ref class CreditCardInfo

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..CreditCardInfo

See Also

CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo Members

[image] [image]

A Sandcastle Documented Class Library
CreditCardInfo Members
CreditCardInfo Class Constructors Methods Properties See Also Send Feedback

The CreditCardInfo type exposes the following members.

Constructors

 | Name | Description
Public method | CreditCardInfo | Initializes a new instance of the CreditCardInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | Gets or Sets the Address
Public property | CardNumber | Gets or Sets the CardNumber
Public property | CardType | Gets or Sets the CardType
Public property | CCV | Gets or Sets the CCV
Public property | CustomerProfileId | Gets or Sets the CustomerProfileId
Public property | ExpireMonth | Gets or Sets the ExpireMonth
Public property | ExpireYear | Gets or Sets the ExpireYear
Public property | PaymentProfileId | Gets or Sets the PaymentProfileId

See Also

CreditCardInfo Class
CelloSaaS.Billing.Model Namespace


CreditCardInfo Constructor

[image]

A Sandcastle Documented Class Library
CreditCardInfo Constructor
CreditCardInfo Class See Also Send Feedback
Initializes a new instance of the CreditCardInfo class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CreditCardInfo()
Visual Basic
Public Sub New
Visual C++
public:
CreditCardInfo()

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo Methods

[image] [image]

A Sandcastle Documented Class Library
CreditCardInfo Methods
CreditCardInfo Class See Also Send Feedback

The CreditCardInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CreditCardInfo Class
CelloSaaS.Billing.Model Namespace


CreditCardInfo Properties

[image] [image]

A Sandcastle Documented Class Library
CreditCardInfo Properties
CreditCardInfo Class See Also Send Feedback

The CreditCardInfo type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets or Sets the Address
Public property | CardNumber | Gets or Sets the CardNumber
Public property | CardType | Gets or Sets the CardType
Public property | CCV | Gets or Sets the CCV
Public property | CustomerProfileId | Gets or Sets the CustomerProfileId
Public property | ExpireMonth | Gets or Sets the ExpireMonth
Public property | ExpireYear | Gets or Sets the ExpireYear
Public property | PaymentProfileId | Gets or Sets the PaymentProfileId

See Also

CreditCardInfo Class
CelloSaaS.Billing.Model Namespace


CreditCardInfo.Address Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..Address Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the Address

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ShippingAddress Address { get; set; }
Visual Basic
Public Property Address As ShippingAddress
    Get
    Set
Visual C++
public:
property ShippingAddress^ Address {
    ShippingAddress^ get ();
    void set (ShippingAddress^ value);
}

Property Value

Type: ShippingAddress

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.CardNumber Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..CardNumber Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the CardNumber

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CardNumber { get; set; }
Visual Basic
Public Property CardNumber As String
    Get
    Set
Visual C++
public:
property String^ CardNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.CardType Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..CardType Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the CardType

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CardType { get; set; }
Visual Basic
Public Property CardType As String
    Get
    Set
Visual C++
public:
property String^ CardType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.CCV Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..CCV Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the CCV

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CCV { get; set; }
Visual Basic
Public Property CCV As String
    Get
    Set
Visual C++
public:
property String^ CCV {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.CustomerProfileId Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..CustomerProfileId Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the CustomerProfileId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CustomerProfileId { get; set; }
Visual Basic
Public Property CustomerProfileId As String
    Get
    Set
Visual C++
public:
property String^ CustomerProfileId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.ExpireMonth Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..ExpireMonth Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the ExpireMonth

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ExpireMonth { get; set; }
Visual Basic
Public Property ExpireMonth As Integer
    Get
    Set
Visual C++
public:
property int ExpireMonth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.ExpireYear Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..ExpireYear Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the ExpireYear

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ExpireYear { get; set; }
Visual Basic
Public Property ExpireYear As Integer
    Get
    Set
Visual C++
public:
property int ExpireYear {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardInfo.PaymentProfileId Property

[image]

A Sandcastle Documented Class Library
CreditCardInfo..::..PaymentProfileId Property
CreditCardInfo Class See Also Send Feedback
Gets or Sets the PaymentProfileId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PaymentProfileId { get; set; }
Visual Basic
Public Property PaymentProfileId As String
    Get
    Set
Visual C++
public:
property String^ PaymentProfileId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

CreditCardInfo Class
CreditCardInfo Members
CelloSaaS.Billing.Model Namespace


CreditCardType Enumeration

[image]

A Sandcastle Documented Class Library
CreditCardType Enumeration
See Also Send Feedback
Credit card type enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum CreditCardType
Visual Basic
Public Enumeration CreditCardType
Visual C++
public enum class CreditCardType

Members

Member name | Value | Description
MasterCard | 0 | Master card
Visa | 1 | Visa
Discover | 2 | Discover
AmericanExpress | 3 | American express

See Also

CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Class

[image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Class
Members See Also Send Feedback
Dulicate price plan exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public sealed class DuplicatePricePlanException : BaseException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class DuplicatePricePlanException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicatePricePlanException sealed : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Billing.Model..::..DuplicatePricePlanException

See Also

DuplicatePricePlanException Members
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Members
DuplicatePricePlanException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicatePricePlanException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicatePricePlanException()()()() | Duplicate price plan exception
Public method | DuplicatePricePlanException(String) | Duplicate price plan exception
Public method | DuplicatePricePlanException(String, Exception) | Duplicate price plan exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicatePricePlanException Class
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Constructor
DuplicatePricePlanException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicatePricePlanException()()()() | Duplicate price plan exception
Public method | DuplicatePricePlanException(String) | Duplicate price plan exception
Public method | DuplicatePricePlanException(String, Exception) | Duplicate price plan exception

See Also

DuplicatePricePlanException Class
DuplicatePricePlanException Members
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Constructor

[image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Constructor
DuplicatePricePlanException Class See Also Send Feedback
Duplicate price plan exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicatePricePlanException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicatePricePlanException()

See Also

DuplicatePricePlanException Class
DuplicatePricePlanException Members
DuplicatePricePlanException Overload
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Constructor (String)
DuplicatePricePlanException Class See Also Send Feedback
Duplicate price plan exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicatePricePlanException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicatePricePlanException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

DuplicatePricePlanException Class
DuplicatePricePlanException Members
DuplicatePricePlanException Overload
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Constructor (String, Exception)
DuplicatePricePlanException Class See Also Send Feedback
Duplicate price plan exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicatePricePlanException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
DuplicatePricePlanException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
ex
Type: System..::..Exception

See Also

DuplicatePricePlanException Class
DuplicatePricePlanException Members
DuplicatePricePlanException Overload
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Methods
DuplicatePricePlanException Class See Also Send Feedback

The DuplicatePricePlanException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicatePricePlanException Class
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Properties
DuplicatePricePlanException Class See Also Send Feedback

The DuplicatePricePlanException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicatePricePlanException Class
CelloSaaS.Billing.Model Namespace


DuplicatePricePlanException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicatePricePlanException Events
DuplicatePricePlanException Class See Also Send Feedback

The DuplicatePricePlanException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicatePricePlanException Class
CelloSaaS.Billing.Model Namespace


FactorType Enumeration

[image]

A Sandcastle Documented Class Library
FactorType Enumeration
See Also Send Feedback
Bill calculation factor type enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum FactorType
Visual Basic
Public Enumeration FactorType
Visual C++
public enum class FactorType

Members

Member name | Value | Description
Flat | 0 | Flat calcualtion
Each | 1 | Each percentage calcualtion

See Also

CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Class

[image]

A Sandcastle Documented Class Library
InvalidCreditCardException Class
Members See Also Send Feedback
Invalid credit card exception class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public sealed class InvalidCreditCardException : BaseException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class InvalidCreditCardException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidCreditCardException sealed : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Billing.Model..::..InvalidCreditCardException

See Also

InvalidCreditCardException Members
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidCreditCardException Members
InvalidCreditCardException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidCreditCardException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidCreditCardException()()()() | Invalid credit card exception
Public method | InvalidCreditCardException(String) | Invalid credit card exception
Public method | InvalidCreditCardException(String, Exception) | Invalid credit card exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidCreditCardException Class
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidCreditCardException Constructor
InvalidCreditCardException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidCreditCardException()()()() | Invalid credit card exception
Public method | InvalidCreditCardException(String) | Invalid credit card exception
Public method | InvalidCreditCardException(String, Exception) | Invalid credit card exception

See Also

InvalidCreditCardException Class
InvalidCreditCardException Members
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Constructor

[image]

A Sandcastle Documented Class Library
InvalidCreditCardException Constructor
InvalidCreditCardException Class See Also Send Feedback
Invalid credit card exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidCreditCardException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidCreditCardException()

See Also

InvalidCreditCardException Class
InvalidCreditCardException Members
InvalidCreditCardException Overload
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidCreditCardException Constructor (String)
InvalidCreditCardException Class See Also Send Feedback
Invalid credit card exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidCreditCardException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidCreditCardException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

InvalidCreditCardException Class
InvalidCreditCardException Members
InvalidCreditCardException Overload
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidCreditCardException Constructor (String, Exception)
InvalidCreditCardException Class See Also Send Feedback
Invalid credit card exception

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidCreditCardException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
InvalidCreditCardException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
ex
Type: System..::..Exception

See Also

InvalidCreditCardException Class
InvalidCreditCardException Members
InvalidCreditCardException Overload
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidCreditCardException Methods
InvalidCreditCardException Class See Also Send Feedback

The InvalidCreditCardException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidCreditCardException Class
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidCreditCardException Properties
InvalidCreditCardException Class See Also Send Feedback

The InvalidCreditCardException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidCreditCardException Class
CelloSaaS.Billing.Model Namespace


InvalidCreditCardException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidCreditCardException Events
InvalidCreditCardException Class See Also Send Feedback

The InvalidCreditCardException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidCreditCardException Class
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Class

[image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Class
Members See Also Send Feedback
Invalid payment api account

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public sealed class InvalidPaymentAPIAccountException : BaseException
Visual Basic
<SerializableAttribute>
Public NotInheritable Class InvalidPaymentAPIAccountException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidPaymentAPIAccountException sealed : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Billing.Model..::..InvalidPaymentAPIAccountException

See Also

InvalidPaymentAPIAccountException Members
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Members
InvalidPaymentAPIAccountException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidPaymentAPIAccountException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidPaymentAPIAccountException()()()() | Invalid Payment API Account
Public method | InvalidPaymentAPIAccountException(String) | Invalid Payment API Account
Public method | InvalidPaymentAPIAccountException(String, Exception) | Invalid Payment API Account

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidPaymentAPIAccountException Class
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Constructor
InvalidPaymentAPIAccountException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidPaymentAPIAccountException()()()() | Invalid Payment API Account
Public method | InvalidPaymentAPIAccountException(String) | Invalid Payment API Account
Public method | InvalidPaymentAPIAccountException(String, Exception) | Invalid Payment API Account

See Also

InvalidPaymentAPIAccountException Class
InvalidPaymentAPIAccountException Members
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Constructor

[image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Constructor
InvalidPaymentAPIAccountException Class See Also Send Feedback
Invalid Payment API Account

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidPaymentAPIAccountException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidPaymentAPIAccountException()

See Also

InvalidPaymentAPIAccountException Class
InvalidPaymentAPIAccountException Members
InvalidPaymentAPIAccountException Overload
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Constructor (String)
InvalidPaymentAPIAccountException Class See Also Send Feedback
Invalid Payment API Account

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidPaymentAPIAccountException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidPaymentAPIAccountException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

InvalidPaymentAPIAccountException Class
InvalidPaymentAPIAccountException Members
InvalidPaymentAPIAccountException Overload
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Constructor (String, Exception)
InvalidPaymentAPIAccountException Class See Also Send Feedback
Invalid Payment API Account

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidPaymentAPIAccountException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
InvalidPaymentAPIAccountException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
ex
Type: System..::..Exception

See Also

InvalidPaymentAPIAccountException Class
InvalidPaymentAPIAccountException Members
InvalidPaymentAPIAccountException Overload
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Methods
InvalidPaymentAPIAccountException Class See Also Send Feedback

The InvalidPaymentAPIAccountException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidPaymentAPIAccountException Class
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Properties
InvalidPaymentAPIAccountException Class See Also Send Feedback

The InvalidPaymentAPIAccountException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidPaymentAPIAccountException Class
CelloSaaS.Billing.Model Namespace


InvalidPaymentAPIAccountException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidPaymentAPIAccountException Events
InvalidPaymentAPIAccountException Class See Also Send Feedback

The InvalidPaymentAPIAccountException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidPaymentAPIAccountException Class
CelloSaaS.Billing.Model Namespace


Invoice Class

[image]

A Sandcastle Documented Class Library
Invoice Class
Members See Also Send Feedback
Invoice model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Invoice : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class Invoice
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class Invoice : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Billing.Model..::..Invoice

See Also

Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice Members

[image] [image]

A Sandcastle Documented Class Library
Invoice Members
Invoice Class Constructors Methods Properties See Also Send Feedback

The Invoice type exposes the following members.

Constructors

 | Name | Description
Public method | Invoice | Initializes a new instance of the Invoice class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Amount | Total bill amount (sum of all line items amount)
Public property | BalanceAmount | Current bill balance amount (current bill amount - paid amount)
Public property | BillFrequency | Gets or Sets BillFrequency
Public property | BillFrequencyValue | Gets or Sets BillFrequencyValue
Public property | CreatedBy | Gets or Sets CreatedBy
Public property | CreatedOn | Gets or Sets CreatedOn
Public property | DueDate | Gets or Sets DueDate
Public property | EndDate | Gets or Sets EndDate
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or Sets Id
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | InvoiceDate | Gets or Sets InvoiceDate
Public property | InvoiceNo | Gets or Sets InvoiceNo
Public property | InvoiceStatus | Gets or Sets InvoiceStatus
Public property | InvoiceStatusValue | Gets or Sets InvoiceStatusValue
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LineItems | Gets or Sets LineItems
Public property | Memo | Gets or Sets Memo
Public property | NetAmount | Balance amount + current bill amount
Public property | NextInvoiceDate | Gets or Sets NextInvoiceDate
Public property | PackageId | Gets or Sets PackageId
Public property | PaidAmount | Paid amount
Public property | ParentTenantId | Gets or Sets ParentTenantId
Public property | Payments | Gets or Sets Payments
Public property | PendingBalance | Gets or Sets PendingBalance
Public property | PricePlanId | Gets or Sets PricePlanId
Public property | StartDate | Gets or Sets StartDate
Public property | Subtotal | Without tax components
Public property | TaxAmount | Tax total amount
Public property | TenantId | Gets or Sets TenantId
Public property | TotalLineItem | Total line items count
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or Sets UpdatedBy
Public property | UpdatedOn | Gets or Sets UpdatedOn

See Also

Invoice Class
CelloSaaS.Billing.Model Namespace


Invoice Constructor

[image]

A Sandcastle Documented Class Library
Invoice Constructor
Invoice Class See Also Send Feedback
Initializes a new instance of the Invoice class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Invoice()
Visual Basic
Public Sub New
Visual C++
public:
Invoice()

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice Methods

[image] [image]

A Sandcastle Documented Class Library
Invoice Methods
Invoice Class See Also Send Feedback

The Invoice type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

Invoice Class
CelloSaaS.Billing.Model Namespace


Invoice Properties

[image] [image]

A Sandcastle Documented Class Library
Invoice Properties
Invoice Class See Also Send Feedback

The Invoice type exposes the following members.

Properties

 | Name | Description
Public property | Amount | Total bill amount (sum of all line items amount)
Public property | BalanceAmount | Current bill balance amount (current bill amount - paid amount)
Public property | BillFrequency | Gets or Sets BillFrequency
Public property | BillFrequencyValue | Gets or Sets BillFrequencyValue
Public property | CreatedBy | Gets or Sets CreatedBy
Public property | CreatedOn | Gets or Sets CreatedOn
Public property | DueDate | Gets or Sets DueDate
Public property | EndDate | Gets or Sets EndDate
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or Sets Id
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | InvoiceDate | Gets or Sets InvoiceDate
Public property | InvoiceNo | Gets or Sets InvoiceNo
Public property | InvoiceStatus | Gets or Sets InvoiceStatus
Public property | InvoiceStatusValue | Gets or Sets InvoiceStatusValue
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LineItems | Gets or Sets LineItems
Public property | Memo | Gets or Sets Memo
Public property | NetAmount | Balance amount + current bill amount
Public property | NextInvoiceDate | Gets or Sets NextInvoiceDate
Public property | PackageId | Gets or Sets PackageId
Public property | PaidAmount | Paid amount
Public property | ParentTenantId | Gets or Sets ParentTenantId
Public property | Payments | Gets or Sets Payments
Public property | PendingBalance | Gets or Sets PendingBalance
Public property | PricePlanId | Gets or Sets PricePlanId
Public property | StartDate | Gets or Sets StartDate
Public property | Subtotal | Without tax components
Public property | TaxAmount | Tax total amount
Public property | TenantId | Gets or Sets TenantId
Public property | TotalLineItem | Total line items count
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or Sets UpdatedBy
Public property | UpdatedOn | Gets or Sets UpdatedOn

See Also

Invoice Class
CelloSaaS.Billing.Model Namespace


Invoice.Amount Property

[image]

A Sandcastle Documented Class Library
Invoice..::..Amount Property
Invoice Class See Also Send Feedback
Total bill amount (sum of all line items amount)

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.BalanceAmount Property

[image]

A Sandcastle Documented Class Library
Invoice..::..BalanceAmount Property
Invoice Class See Also Send Feedback
Current bill balance amount (current bill amount - paid amount)

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double BalanceAmount { get; set; }
Visual Basic
Public Property BalanceAmount As Double
    Get
    Set
Visual C++
public:
property double BalanceAmount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.BillFrequency Property

[image]

A Sandcastle Documented Class Library
Invoice..::..BillFrequency Property
Invoice Class See Also Send Feedback
Gets or Sets BillFrequency

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillFrequency BillFrequency { get; set; }
Visual Basic
Public Property BillFrequency As BillFrequency
    Get
    Set
Visual C++
public:
property BillFrequency BillFrequency {
    BillFrequency get ();
    void set (BillFrequency value);
}

Property Value

Type: BillFrequency

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.BillFrequencyValue Property

[image]

A Sandcastle Documented Class Library
Invoice..::..BillFrequencyValue Property
Invoice Class See Also Send Feedback
Gets or Sets BillFrequencyValue

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BillFrequencyValue { get; set; }
Visual Basic
Public Property BillFrequencyValue As Integer
    Get
    Set
Visual C++
public:
property int BillFrequencyValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Invoice..::..CreatedBy Property
Invoice Class See Also Send Feedback
Gets or Sets CreatedBy

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Invoice..::..CreatedOn Property
Invoice Class See Also Send Feedback
Gets or Sets CreatedOn

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.DueDate Property

[image]

A Sandcastle Documented Class Library
Invoice..::..DueDate Property
Invoice Class See Also Send Feedback
Gets or Sets DueDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime DueDate { get; set; }
Visual Basic
Public Property DueDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime DueDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.EndDate Property

[image]

A Sandcastle Documented Class Library
Invoice..::..EndDate Property
Invoice Class See Also Send Feedback
Gets or Sets EndDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.Id Property

[image]

A Sandcastle Documented Class Library
Invoice..::..Id Property
Invoice Class See Also Send Feedback
Gets or Sets Id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.InvoiceDate Property

[image]

A Sandcastle Documented Class Library
Invoice..::..InvoiceDate Property
Invoice Class See Also Send Feedback
Gets or Sets InvoiceDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime InvoiceDate { get; set; }
Visual Basic
Public Property InvoiceDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime InvoiceDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.InvoiceNo Property

[image]

A Sandcastle Documented Class Library
Invoice..::..InvoiceNo Property
Invoice Class See Also Send Feedback
Gets or Sets InvoiceNo

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string InvoiceNo { get; set; }
Visual Basic
Public Property InvoiceNo As String
    Get
    Set
Visual C++
public:
property String^ InvoiceNo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.InvoiceStatus Property

[image]

A Sandcastle Documented Class Library
Invoice..::..InvoiceStatus Property
Invoice Class See Also Send Feedback
Gets or Sets InvoiceStatus

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvoiceStatus InvoiceStatus { get; set; }
Visual Basic
Public Property InvoiceStatus As InvoiceStatus
    Get
    Set
Visual C++
public:
property InvoiceStatus InvoiceStatus {
    InvoiceStatus get ();
    void set (InvoiceStatus value);
}

Property Value

Type: InvoiceStatus

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.InvoiceStatusValue Property

[image]

A Sandcastle Documented Class Library
Invoice..::..InvoiceStatusValue Property
Invoice Class See Also Send Feedback
Gets or Sets InvoiceStatusValue

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int InvoiceStatusValue { get; set; }
Visual Basic
Public Property InvoiceStatusValue As Integer
    Get
    Set
Visual C++
public:
property int InvoiceStatusValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.LineItems Property

[image]

A Sandcastle Documented Class Library
Invoice..::..LineItems Property
Invoice Class See Also Send Feedback
Gets or Sets LineItems

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<InvoiceLineItem> LineItems { get; set; }
Visual Basic
Public Property LineItems As ICollection(Of InvoiceLineItem)
    Get
    Set
Visual C++
public:
property ICollection<InvoiceLineItem^>^ LineItems {
    ICollection<InvoiceLineItem^>^ get ();
    void set (ICollection<InvoiceLineItem^>^ value);
}

Property Value

Type: ICollection<(Of <(<' InvoiceLineItem >)>)>

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.Memo Property

[image]

A Sandcastle Documented Class Library
Invoice..::..Memo Property
Invoice Class See Also Send Feedback
Gets or Sets Memo

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Memo { get; set; }
Visual Basic
Public Property Memo As String
    Get
    Set
Visual C++
public:
property String^ Memo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.NetAmount Property

[image]

A Sandcastle Documented Class Library
Invoice..::..NetAmount Property
Invoice Class See Also Send Feedback
Balance amount + current bill amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double NetAmount { get; set; }
Visual Basic
Public Property NetAmount As Double
    Get
    Set
Visual C++
public:
property double NetAmount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.NextInvoiceDate Property

[image]

A Sandcastle Documented Class Library
Invoice..::..NextInvoiceDate Property
Invoice Class See Also Send Feedback
Gets or Sets NextInvoiceDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime NextInvoiceDate { get; set; }
Visual Basic
Public Property NextInvoiceDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime NextInvoiceDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.PackageId Property

[image]

A Sandcastle Documented Class Library
Invoice..::..PackageId Property
Invoice Class See Also Send Feedback
Gets or Sets PackageId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid PackageId { get; set; }
Visual Basic
Public Property PackageId As Guid
    Get
    Set
Visual C++
public:
property Guid PackageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.PaidAmount Property

[image]

A Sandcastle Documented Class Library
Invoice..::..PaidAmount Property
Invoice Class See Also Send Feedback
Paid amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double PaidAmount { get; set; }
Visual Basic
Public Property PaidAmount As Double
    Get
    Set
Visual C++
public:
property double PaidAmount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
Invoice..::..ParentTenantId Property
Invoice Class See Also Send Feedback
Gets or Sets ParentTenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As Guid
    Get
    Set
Visual C++
public:
property Guid ParentTenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.Payments Property

[image]

A Sandcastle Documented Class Library
Invoice..::..Payments Property
Invoice Class See Also Send Feedback
Gets or Sets Payments

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<InvoicePayment> Payments { get; set; }
Visual Basic
Public Property Payments As ICollection(Of InvoicePayment)
    Get
    Set
Visual C++
public:
property ICollection<InvoicePayment^>^ Payments {
    ICollection<InvoicePayment^>^ get ();
    void set (ICollection<InvoicePayment^>^ value);
}

Property Value

Type: ICollection<(Of <(<' InvoicePayment >)>)>

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.PendingBalance Property

[image]

A Sandcastle Documented Class Library
Invoice..::..PendingBalance Property
Invoice Class See Also Send Feedback
Gets or Sets PendingBalance

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double PendingBalance { get; set; }
Visual Basic
Public Property PendingBalance As Double
    Get
    Set
Visual C++
public:
property double PendingBalance {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.PricePlanId Property

[image]

A Sandcastle Documented Class Library
Invoice..::..PricePlanId Property
Invoice Class See Also Send Feedback
Gets or Sets PricePlanId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid PricePlanId { get; set; }
Visual Basic
Public Property PricePlanId As Guid
    Get
    Set
Visual C++
public:
property Guid PricePlanId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.StartDate Property

[image]

A Sandcastle Documented Class Library
Invoice..::..StartDate Property
Invoice Class See Also Send Feedback
Gets or Sets StartDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.Subtotal Property

[image]

A Sandcastle Documented Class Library
Invoice..::..Subtotal Property
Invoice Class See Also Send Feedback
Without tax components

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Subtotal { get; set; }
Visual Basic
Public Property Subtotal As Double
    Get
    Set
Visual C++
public:
property double Subtotal {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.TaxAmount Property

[image]

A Sandcastle Documented Class Library
Invoice..::..TaxAmount Property
Invoice Class See Also Send Feedback
Tax total amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double TaxAmount { get; set; }
Visual Basic
Public Property TaxAmount As Double
    Get
    Set
Visual C++
public:
property double TaxAmount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.TenantId Property

[image]

A Sandcastle Documented Class Library
Invoice..::..TenantId Property
Invoice Class See Also Send Feedback
Gets or Sets TenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.TotalLineItem Property

[image]

A Sandcastle Documented Class Library
Invoice..::..TotalLineItem Property
Invoice Class See Also Send Feedback
Total line items count

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double TotalLineItem { get; set; }
Visual Basic
Public Property TotalLineItem As Double
    Get
    Set
Visual C++
public:
property double TotalLineItem {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Invoice..::..UpdatedBy Property
Invoice Class See Also Send Feedback
Gets or Sets UpdatedBy

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


Invoice.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Invoice..::..UpdatedOn Property
Invoice Class See Also Send Feedback
Gets or Sets UpdatedOn

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

Invoice Class
Invoice Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem Class

[image]

A Sandcastle Documented Class Library
InvoiceLineItem Class
Members See Also Send Feedback
Invoice line item model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvoiceLineItem
Visual Basic
<SerializableAttribute>
Public Class InvoiceLineItem
Visual C++
[SerializableAttribute]
public ref class InvoiceLineItem

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..InvoiceLineItem

See Also

InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem Members

[image] [image]

A Sandcastle Documented Class Library
InvoiceLineItem Members
InvoiceLineItem Class Constructors Methods Properties See Also Send Feedback

The InvoiceLineItem type exposes the following members.

Constructors

 | Name | Description
Public method | InvoiceLineItem | Initializes a new instance of the InvoiceLineItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Amount | Gets or Sets Amount
Public property | Description | Gets or Sets Description
Public property | Id | Gets or Sets Id
Public property | InvoiceId | Gets or Sets InvoiceId
Public property | IsUserAdded | Gets or Sets IsUserAdded
Public property | Name | Gets or Sets Name
Public property | ParentTenantId | Gets or Sets ParentTenantId
Public property | TenantId | Gets or Sets TenantId
Public property | Type | Gets or Sets Type
Public property | Usage | Gets or Sets Usage

See Also

InvoiceLineItem Class
CelloSaaS.Billing.Model Namespace


InvoiceLineItem Constructor

[image]

A Sandcastle Documented Class Library
InvoiceLineItem Constructor
InvoiceLineItem Class See Also Send Feedback
Initializes a new instance of the InvoiceLineItem class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvoiceLineItem()
Visual Basic
Public Sub New
Visual C++
public:
InvoiceLineItem()

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem Methods

[image] [image]

A Sandcastle Documented Class Library
InvoiceLineItem Methods
InvoiceLineItem Class See Also Send Feedback

The InvoiceLineItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InvoiceLineItem Class
CelloSaaS.Billing.Model Namespace


InvoiceLineItem Properties

[image] [image]

A Sandcastle Documented Class Library
InvoiceLineItem Properties
InvoiceLineItem Class See Also Send Feedback

The InvoiceLineItem type exposes the following members.

Properties

 | Name | Description
Public property | Amount | Gets or Sets Amount
Public property | Description | Gets or Sets Description
Public property | Id | Gets or Sets Id
Public property | InvoiceId | Gets or Sets InvoiceId
Public property | IsUserAdded | Gets or Sets IsUserAdded
Public property | Name | Gets or Sets Name
Public property | ParentTenantId | Gets or Sets ParentTenantId
Public property | TenantId | Gets or Sets TenantId
Public property | Type | Gets or Sets Type
Public property | Usage | Gets or Sets Usage

See Also

InvoiceLineItem Class
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.Amount Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..Amount Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets Amount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.Description Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..Description Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets Description

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.Id Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..Id Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets Id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.InvoiceId Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..InvoiceId Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets InvoiceId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid InvoiceId { get; set; }
Visual Basic
Public Property InvoiceId As Guid
    Get
    Set
Visual C++
public:
property Guid InvoiceId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.IsUserAdded Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..IsUserAdded Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets IsUserAdded

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsUserAdded { get; set; }
Visual Basic
Public Property IsUserAdded As Boolean
    Get
    Set
Visual C++
public:
property bool IsUserAdded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.Name Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..Name Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets Name

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..ParentTenantId Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets ParentTenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As Guid
    Get
    Set
Visual C++
public:
property Guid ParentTenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.TenantId Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..TenantId Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets TenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.Type Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..Type Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets Type

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoiceLineItem.Usage Property

[image]

A Sandcastle Documented Class Library
InvoiceLineItem..::..Usage Property
InvoiceLineItem Class See Also Send Feedback
Gets or Sets Usage

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Usage { get; set; }
Visual Basic
Public Property Usage As String
    Get
    Set
Visual C++
public:
property String^ Usage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoiceLineItem Class
InvoiceLineItem Members
CelloSaaS.Billing.Model Namespace


InvoicePayment Class

[image]

A Sandcastle Documented Class Library
InvoicePayment Class
Members See Also Send Feedback
Invoice payment model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvoicePayment
Visual Basic
<SerializableAttribute>
Public Class InvoicePayment
Visual C++
[SerializableAttribute]
public ref class InvoicePayment

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..InvoicePayment

See Also

InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment Members

[image] [image]

A Sandcastle Documented Class Library
InvoicePayment Members
InvoicePayment Class Constructors Methods Properties See Also Send Feedback

The InvoicePayment type exposes the following members.

Constructors

 | Name | Description
Public method | InvoicePayment | Initializes a new instance of the InvoicePayment class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or Sets CreatedBy
Public property | Id | Gets or Sets Id
Public property | InvoiceId | Gets or Sets InvoiceId
Public property | Notes | Gets or Sets Notes
Public property | PaidAmount | Gets or Sets PaidAmount
Public property | ParentTenantId | Gets or Sets ParentTenantId
Public property | PaymentDate | Gets or Sets PaymentDate
Public property | PaymentMode | Gets or Sets PaymentMode
Public property | PaymentModeValue | Gets or Sets PaymentModeValue
Public property | TenantId | Gets or Sets TenantId

See Also

InvoicePayment Class
CelloSaaS.Billing.Model Namespace


InvoicePayment Constructor

[image]

A Sandcastle Documented Class Library
InvoicePayment Constructor
InvoicePayment Class See Also Send Feedback
Initializes a new instance of the InvoicePayment class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvoicePayment()
Visual Basic
Public Sub New
Visual C++
public:
InvoicePayment()

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment Methods

[image] [image]

A Sandcastle Documented Class Library
InvoicePayment Methods
InvoicePayment Class See Also Send Feedback

The InvoicePayment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InvoicePayment Class
CelloSaaS.Billing.Model Namespace


InvoicePayment Properties

[image] [image]

A Sandcastle Documented Class Library
InvoicePayment Properties
InvoicePayment Class See Also Send Feedback

The InvoicePayment type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or Sets CreatedBy
Public property | Id | Gets or Sets Id
Public property | InvoiceId | Gets or Sets InvoiceId
Public property | Notes | Gets or Sets Notes
Public property | PaidAmount | Gets or Sets PaidAmount
Public property | ParentTenantId | Gets or Sets ParentTenantId
Public property | PaymentDate | Gets or Sets PaymentDate
Public property | PaymentMode | Gets or Sets PaymentMode
Public property | PaymentModeValue | Gets or Sets PaymentModeValue
Public property | TenantId | Gets or Sets TenantId

See Also

InvoicePayment Class
CelloSaaS.Billing.Model Namespace


InvoicePayment.CreatedBy Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..CreatedBy Property
InvoicePayment Class See Also Send Feedback
Gets or Sets CreatedBy

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.Id Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..Id Property
InvoicePayment Class See Also Send Feedback
Gets or Sets Id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.InvoiceId Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..InvoiceId Property
InvoicePayment Class See Also Send Feedback
Gets or Sets InvoiceId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid InvoiceId { get; set; }
Visual Basic
Public Property InvoiceId As Guid
    Get
    Set
Visual C++
public:
property Guid InvoiceId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.Notes Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..Notes Property
InvoicePayment Class See Also Send Feedback
Gets or Sets Notes

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Notes { get; set; }
Visual Basic
Public Property Notes As String
    Get
    Set
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.PaidAmount Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..PaidAmount Property
InvoicePayment Class See Also Send Feedback
Gets or Sets PaidAmount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double PaidAmount { get; set; }
Visual Basic
Public Property PaidAmount As Double
    Get
    Set
Visual C++
public:
property double PaidAmount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..ParentTenantId Property
InvoicePayment Class See Also Send Feedback
Gets or Sets ParentTenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As Guid
    Get
    Set
Visual C++
public:
property Guid ParentTenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.PaymentDate Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..PaymentDate Property
InvoicePayment Class See Also Send Feedback
Gets or Sets PaymentDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime PaymentDate { get; set; }
Visual Basic
Public Property PaymentDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime PaymentDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.PaymentMode Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..PaymentMode Property
InvoicePayment Class See Also Send Feedback
Gets or Sets PaymentMode

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentMode PaymentMode { get; set; }
Visual Basic
Public Property PaymentMode As PaymentMode
    Get
    Set
Visual C++
public:
property PaymentMode PaymentMode {
    PaymentMode get ();
    void set (PaymentMode value);
}

Property Value

Type: PaymentMode

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.PaymentModeValue Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..PaymentModeValue Property
InvoicePayment Class See Also Send Feedback
Gets or Sets PaymentModeValue

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PaymentModeValue { get; set; }
Visual Basic
Public Property PaymentModeValue As Integer
    Get
    Set
Visual C++
public:
property int PaymentModeValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoicePayment.TenantId Property

[image]

A Sandcastle Documented Class Library
InvoicePayment..::..TenantId Property
InvoicePayment Class See Also Send Feedback
Gets or Sets TenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

InvoicePayment Class
InvoicePayment Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition Class

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition Class
Members See Also Send Feedback
Invoice search condition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvoiceSearchCondition
Visual Basic
<SerializableAttribute>
Public Class InvoiceSearchCondition
Visual C++
[SerializableAttribute]
public ref class InvoiceSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..InvoiceSearchCondition

See Also

InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
InvoiceSearchCondition Members
InvoiceSearchCondition Class Constructors Methods Properties See Also Send Feedback

The InvoiceSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | InvoiceSearchCondition | Initializes a new instance of the InvoiceSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BillFrequency | Gets or Sets
Public property | DueDate | Gets or Sets
Public property | EndDate | Gets or Sets
Public property | FromInvoiceDate | Gets or Sets
Public property | InvoiceIds | Gets or Sets
Public property | InvoiceStatus | Gets or Sets
Public property | PageNo | Gets or Sets
Public property | PageSize | Gets or Sets
Public property | SortDirection | Gets or Sets
Public property | SortField | Gets or Sets
Public property | StartDate | Gets or Sets
Public property | TenantIds | Gets or Sets
Public property | ToInvoiceDate | Gets or Sets

See Also

InvoiceSearchCondition Class
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition Constructor
InvoiceSearchCondition Class See Also Send Feedback
Initializes a new instance of the InvoiceSearchCondition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvoiceSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
InvoiceSearchCondition()

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
InvoiceSearchCondition Methods
InvoiceSearchCondition Class See Also Send Feedback

The InvoiceSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InvoiceSearchCondition Class
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
InvoiceSearchCondition Properties
InvoiceSearchCondition Class See Also Send Feedback

The InvoiceSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | BillFrequency | Gets or Sets
Public property | DueDate | Gets or Sets
Public property | EndDate | Gets or Sets
Public property | FromInvoiceDate | Gets or Sets
Public property | InvoiceIds | Gets or Sets
Public property | InvoiceStatus | Gets or Sets
Public property | PageNo | Gets or Sets
Public property | PageSize | Gets or Sets
Public property | SortDirection | Gets or Sets
Public property | SortField | Gets or Sets
Public property | StartDate | Gets or Sets
Public property | TenantIds | Gets or Sets
Public property | ToInvoiceDate | Gets or Sets

See Also

InvoiceSearchCondition Class
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.BillFrequency Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..BillFrequency Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<BillFrequency> BillFrequency { get; set; }
Visual Basic
Public Property BillFrequency As Nullable(Of BillFrequency)
    Get
    Set
Visual C++
public:
property Nullable<BillFrequency> BillFrequency {
    Nullable<BillFrequency> get ();
    void set (Nullable<BillFrequency> value);
}

Property Value

Type: Nullable<(Of <(<' BillFrequency >)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.DueDate Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..DueDate Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> DueDate { get; set; }
Visual Basic
Public Property DueDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DueDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.EndDate Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..EndDate Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> EndDate { get; set; }
Visual Basic
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.FromInvoiceDate Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..FromInvoiceDate Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromInvoiceDate { get; set; }
Visual Basic
Public Property FromInvoiceDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromInvoiceDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.InvoiceIds Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..InvoiceIds Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] InvoiceIds { get; set; }
Visual Basic
Public Property InvoiceIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ InvoiceIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.InvoiceStatus Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..InvoiceStatus Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<InvoiceStatus> InvoiceStatus { get; set; }
Visual Basic
Public Property InvoiceStatus As Nullable(Of InvoiceStatus)
    Get
    Set
Visual C++
public:
property Nullable<InvoiceStatus> InvoiceStatus {
    Nullable<InvoiceStatus> get ();
    void set (Nullable<InvoiceStatus> value);
}

Property Value

Type: Nullable<(Of <(<' InvoiceStatus >)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..PageNo Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..PageSize Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..SortDirection Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.SortField Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..SortField Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortField { get; set; }
Visual Basic
Public Property SortField As String
    Get
    Set
Visual C++
public:
property String^ SortField {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.StartDate Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..StartDate Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> StartDate { get; set; }
Visual Basic
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..TenantIds Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ TenantIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchCondition.ToInvoiceDate Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchCondition..::..ToInvoiceDate Property
InvoiceSearchCondition Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToInvoiceDate { get; set; }
Visual Basic
Public Property ToInvoiceDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToInvoiceDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

InvoiceSearchCondition Class
InvoiceSearchCondition Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult Class

[image]

A Sandcastle Documented Class Library
InvoiceSearchResult Class
Members See Also Send Feedback
Invoice search result class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvoiceSearchResult
Visual Basic
<SerializableAttribute>
Public Class InvoiceSearchResult
Visual C++
[SerializableAttribute]
public ref class InvoiceSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..InvoiceSearchResult

See Also

InvoiceSearchResult Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
InvoiceSearchResult Members
InvoiceSearchResult Class Constructors Methods Properties See Also Send Feedback

The InvoiceSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | InvoiceSearchResult | Initializes a new instance of the InvoiceSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Gets or Sets search result
Public property | TotalCount | Gets or Sets seach total count of records

See Also

InvoiceSearchResult Class
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult Constructor

[image]

A Sandcastle Documented Class Library
InvoiceSearchResult Constructor
InvoiceSearchResult Class See Also Send Feedback
Initializes a new instance of the InvoiceSearchResult class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvoiceSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
InvoiceSearchResult()

See Also

InvoiceSearchResult Class
InvoiceSearchResult Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
InvoiceSearchResult Methods
InvoiceSearchResult Class See Also Send Feedback

The InvoiceSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InvoiceSearchResult Class
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
InvoiceSearchResult Properties
InvoiceSearchResult Class See Also Send Feedback

The InvoiceSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets or Sets search result
Public property | TotalCount | Gets or Sets seach total count of records

See Also

InvoiceSearchResult Class
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult.Items Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchResult..::..Items Property
InvoiceSearchResult Class See Also Send Feedback
Gets or Sets search result

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<Guid, Invoice> Items { get; set; }
Visual Basic
Public Property Items As Dictionary(Of Guid, Invoice)
    Get
    Set
Visual C++
public:
property Dictionary<Guid, Invoice^>^ Items {
    Dictionary<Guid, Invoice^>^ get ();
    void set (Dictionary<Guid, Invoice^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'Guid, Invoice >)>)>

See Also

InvoiceSearchResult Class
InvoiceSearchResult Members
CelloSaaS.Billing.Model Namespace


InvoiceSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
InvoiceSearchResult..::..TotalCount Property
InvoiceSearchResult Class See Also Send Feedback
Gets or Sets seach total count of records

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

InvoiceSearchResult Class
InvoiceSearchResult Members
CelloSaaS.Billing.Model Namespace


InvoiceStatus Enumeration

[image]

A Sandcastle Documented Class Library
InvoiceStatus Enumeration
See Also Send Feedback
Invoice status enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum InvoiceStatus
Visual Basic
Public Enumeration InvoiceStatus
Visual C++
public enum class InvoiceStatus

Members

Member name | Value | Description
Current | 0 | Current invoice
Paid | 1 | Paid
UnPaid | 2 | Unpaid
Other | 3 | Other

See Also

CelloSaaS.Billing.Model Namespace


PaymentAccount Class

[image]

A Sandcastle Documented Class Library
PaymentAccount Class
Members See Also Send Feedback
Payment account model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PaymentAccount
Visual Basic
<SerializableAttribute>
Public Class PaymentAccount
Visual C++
[SerializableAttribute]
public ref class PaymentAccount

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAccount
CelloSaaS.Billing.Model..::..CreditCardAccount
CelloSaaS.Billing.Model..::..PaymentAccountSetting
CelloSaaS.Billing.Model..::..PayPalAccount

See Also

PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount Members

[image] [image]

A Sandcastle Documented Class Library
PaymentAccount Members
PaymentAccount Class Constructors Methods Properties See Also Send Feedback

The PaymentAccount type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentAccount | Initializes a new instance of the PaymentAccount class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType
Public property | AccountTypeValue | Gets or Sets AccountTypeValue
Public property | CreatedBy | Gets or Sets CreatedBy
Public property | CreatedOn | Gets or Sets CreatedOn
Public property | CurrencyCode | Gets or Sets CurrencyCode
Public property | Email | Gets or Sets Email
Public property | Status | Gets or Sets Status
Public property | StoreKey | Gets or Sets StoreKey
Public property | TenantId | Gets or Sets TenantId
Public property | UpdatedBy | Gets or Sets UpdatedBy
Public property | UpdatedOn | Gets or Sets UpdatedOn

See Also

PaymentAccount Class
CelloSaaS.Billing.Model Namespace


PaymentAccount Constructor

[image]

A Sandcastle Documented Class Library
PaymentAccount Constructor
PaymentAccount Class See Also Send Feedback
Initializes a new instance of the PaymentAccount class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAccount()
Visual Basic
Public Sub New
Visual C++
public:
PaymentAccount()

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount Methods

[image] [image]

A Sandcastle Documented Class Library
PaymentAccount Methods
PaymentAccount Class See Also Send Feedback

The PaymentAccount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaymentAccount Class
CelloSaaS.Billing.Model Namespace


PaymentAccount Properties

[image] [image]

A Sandcastle Documented Class Library
PaymentAccount Properties
PaymentAccount Class See Also Send Feedback

The PaymentAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType
Public property | AccountTypeValue | Gets or Sets AccountTypeValue
Public property | CreatedBy | Gets or Sets CreatedBy
Public property | CreatedOn | Gets or Sets CreatedOn
Public property | CurrencyCode | Gets or Sets CurrencyCode
Public property | Email | Gets or Sets Email
Public property | Status | Gets or Sets Status
Public property | StoreKey | Gets or Sets StoreKey
Public property | TenantId | Gets or Sets TenantId
Public property | UpdatedBy | Gets or Sets UpdatedBy
Public property | UpdatedOn | Gets or Sets UpdatedOn

See Also

PaymentAccount Class
CelloSaaS.Billing.Model Namespace


PaymentAccount.AccountType Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..AccountType Property
PaymentAccount Class See Also Send Feedback
Gets or Sets AccountType

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAccountType AccountType { get; set; }
Visual Basic
Public Property AccountType As PaymentAccountType
    Get
    Set
Visual C++
public:
property PaymentAccountType AccountType {
    PaymentAccountType get ();
    void set (PaymentAccountType value);
}

Property Value

Type: PaymentAccountType

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.AccountTypeValue Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..AccountTypeValue Property
PaymentAccount Class See Also Send Feedback
Gets or Sets AccountTypeValue

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int AccountTypeValue { get; set; }
Visual Basic
Public Property AccountTypeValue As Integer
    Get
    Set
Visual C++
public:
property int AccountTypeValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..CreatedBy Property
PaymentAccount Class See Also Send Feedback
Gets or Sets CreatedBy

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..CreatedOn Property
PaymentAccount Class See Also Send Feedback
Gets or Sets CreatedOn

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.CurrencyCode Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..CurrencyCode Property
PaymentAccount Class See Also Send Feedback
Gets or Sets CurrencyCode

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CurrencyCode { get; set; }
Visual Basic
Public Property CurrencyCode As String
    Get
    Set
Visual C++
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.Email Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..Email Property
PaymentAccount Class See Also Send Feedback
Gets or Sets Email

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.Status Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..Status Property
PaymentAccount Class See Also Send Feedback
Gets or Sets Status

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.StoreKey Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..StoreKey Property
PaymentAccount Class See Also Send Feedback
Gets or Sets StoreKey

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string StoreKey { get; set; }
Visual Basic
Public Property StoreKey As String
    Get
    Set
Visual C++
public:
property String^ StoreKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.TenantId Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..TenantId Property
PaymentAccount Class See Also Send Feedback
Gets or Sets TenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..UpdatedBy Property
PaymentAccount Class See Also Send Feedback
Gets or Sets UpdatedBy

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccount.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PaymentAccount..::..UpdatedOn Property
PaymentAccount Class See Also Send Feedback
Gets or Sets UpdatedOn

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

PaymentAccount Class
PaymentAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAccountSetting Class

[image]

A Sandcastle Documented Class Library
PaymentAccountSetting Class
Members See Also Send Feedback
Payment account setting model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PaymentAccountSetting : PaymentAccount
Visual Basic
<SerializableAttribute>
Public Class PaymentAccountSetting
    Inherits PaymentAccount
Visual C++
[SerializableAttribute]
public ref class PaymentAccountSetting : public PaymentAccount

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAccount
CelloSaaS.Billing.Model..::..PaymentAccountSetting

See Also

PaymentAccountSetting Members
CelloSaaS.Billing.Model Namespace


PaymentAccountSetting Members

[image] [image]

A Sandcastle Documented Class Library
PaymentAccountSetting Members
PaymentAccountSetting Class Constructors Methods Properties See Also Send Feedback

The PaymentAccountSetting type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentAccountSetting | Initializes a new instance of the PaymentAccountSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType (Inherited from PaymentAccount.)
Public property | AccountTypeValue | Gets or Sets AccountTypeValue (Inherited from PaymentAccount.)
Public property | CreatedBy | Gets or Sets CreatedBy (Inherited from PaymentAccount.)
Public property | CreatedOn | Gets or Sets CreatedOn (Inherited from PaymentAccount.)
Public property | CurrencyCode | Gets or Sets CurrencyCode (Inherited from PaymentAccount.)
Public property | Email | Gets or Sets Email (Inherited from PaymentAccount.)
Public property | Status | Gets or Sets Status (Inherited from PaymentAccount.)
Public property | StoreKey | Gets or Sets StoreKey (Inherited from PaymentAccount.)
Public property | TenantId | Gets or Sets TenantId (Inherited from PaymentAccount.)
Public property | UpdatedBy | Gets or Sets UpdatedBy (Inherited from PaymentAccount.)
Public property | UpdatedOn | Gets or Sets UpdatedOn (Inherited from PaymentAccount.)

See Also

PaymentAccountSetting Class
CelloSaaS.Billing.Model Namespace


PaymentAccountSetting Constructor

[image]

A Sandcastle Documented Class Library
PaymentAccountSetting Constructor
PaymentAccountSetting Class See Also Send Feedback
Initializes a new instance of the PaymentAccountSetting class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAccountSetting()
Visual Basic
Public Sub New
Visual C++
public:
PaymentAccountSetting()

See Also

PaymentAccountSetting Class
PaymentAccountSetting Members
CelloSaaS.Billing.Model Namespace


PaymentAccountSetting Methods

[image] [image]

A Sandcastle Documented Class Library
PaymentAccountSetting Methods
PaymentAccountSetting Class See Also Send Feedback

The PaymentAccountSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaymentAccountSetting Class
CelloSaaS.Billing.Model Namespace


PaymentAccountSetting Properties

[image] [image]

A Sandcastle Documented Class Library
PaymentAccountSetting Properties
PaymentAccountSetting Class See Also Send Feedback

The PaymentAccountSetting type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType (Inherited from PaymentAccount.)
Public property | AccountTypeValue | Gets or Sets AccountTypeValue (Inherited from PaymentAccount.)
Public property | CreatedBy | Gets or Sets CreatedBy (Inherited from PaymentAccount.)
Public property | CreatedOn | Gets or Sets CreatedOn (Inherited from PaymentAccount.)
Public property | CurrencyCode | Gets or Sets CurrencyCode (Inherited from PaymentAccount.)
Public property | Email | Gets or Sets Email (Inherited from PaymentAccount.)
Public property | Status | Gets or Sets Status (Inherited from PaymentAccount.)
Public property | StoreKey | Gets or Sets StoreKey (Inherited from PaymentAccount.)
Public property | TenantId | Gets or Sets TenantId (Inherited from PaymentAccount.)
Public property | UpdatedBy | Gets or Sets UpdatedBy (Inherited from PaymentAccount.)
Public property | UpdatedOn | Gets or Sets UpdatedOn (Inherited from PaymentAccount.)

See Also

PaymentAccountSetting Class
CelloSaaS.Billing.Model Namespace


PaymentAccountType Enumeration

[image]

A Sandcastle Documented Class Library
PaymentAccountType Enumeration
See Also Send Feedback
Payment account type enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum PaymentAccountType
Visual Basic
Public Enumeration PaymentAccountType
Visual C++
public enum class PaymentAccountType

Members

Member name | Value | Description
PayPal | 0 | PayPal
CreditCard | 1 | Credit card
Other | 2 | Other type

See Also

CelloSaaS.Billing.Model Namespace


PaymentApiAccount Class

[image]

A Sandcastle Documented Class Library
PaymentApiAccount Class
Members See Also Send Feedback
Payment API Account model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PaymentApiAccount
Visual Basic
<SerializableAttribute>
Public Class PaymentApiAccount
Visual C++
[SerializableAttribute]
public ref class PaymentApiAccount

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentApiAccount

See Also

PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount Members

[image] [image]

A Sandcastle Documented Class Library
PaymentApiAccount Members
PaymentApiAccount Class Constructors Methods Properties See Also Send Feedback

The PaymentApiAccount type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentApiAccount | Initializes a new instance of the PaymentApiAccount class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets
Public property | AccountTypeValue | Gets or Sets
Public property | AppId | Gets or Sets
Public property | Email | Gets or Sets
Public property | Id | Gets or Sets
Public property | Mode | True (live mode) / False (test mode)
Public property | Password | Gets or Sets
Public property | Signature | Gets or Sets
Public property | TenantId | Gets or Sets
Public property | UserName | Gets or Sets

See Also

PaymentApiAccount Class
CelloSaaS.Billing.Model Namespace


PaymentApiAccount Constructor

[image]

A Sandcastle Documented Class Library
PaymentApiAccount Constructor
PaymentApiAccount Class See Also Send Feedback
Initializes a new instance of the PaymentApiAccount class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentApiAccount()
Visual Basic
Public Sub New
Visual C++
public:
PaymentApiAccount()

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount Methods

[image] [image]

A Sandcastle Documented Class Library
PaymentApiAccount Methods
PaymentApiAccount Class See Also Send Feedback

The PaymentApiAccount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaymentApiAccount Class
CelloSaaS.Billing.Model Namespace


PaymentApiAccount Properties

[image] [image]

A Sandcastle Documented Class Library
PaymentApiAccount Properties
PaymentApiAccount Class See Also Send Feedback

The PaymentApiAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets
Public property | AccountTypeValue | Gets or Sets
Public property | AppId | Gets or Sets
Public property | Email | Gets or Sets
Public property | Id | Gets or Sets
Public property | Mode | True (live mode) / False (test mode)
Public property | Password | Gets or Sets
Public property | Signature | Gets or Sets
Public property | TenantId | Gets or Sets
Public property | UserName | Gets or Sets

See Also

PaymentApiAccount Class
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.AccountType Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..AccountType Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAccountType AccountType { get; set; }
Visual Basic
Public Property AccountType As PaymentAccountType
    Get
    Set
Visual C++
public:
property PaymentAccountType AccountType {
    PaymentAccountType get ();
    void set (PaymentAccountType value);
}

Property Value

Type: PaymentAccountType

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.AccountTypeValue Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..AccountTypeValue Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int AccountTypeValue { get; set; }
Visual Basic
Public Property AccountTypeValue As Integer
    Get
    Set
Visual C++
public:
property int AccountTypeValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.AppId Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..AppId Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AppId { get; set; }
Visual Basic
Public Property AppId As String
    Get
    Set
Visual C++
public:
property String^ AppId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.Email Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..Email Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.Id Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..Id Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.Mode Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..Mode Property
PaymentApiAccount Class See Also Send Feedback
True (live mode) / False (test mode)

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Mode { get; set; }
Visual Basic
Public Property Mode As Boolean
    Get
    Set
Visual C++
public:
property bool Mode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.Password Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..Password Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.Signature Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..Signature Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Signature { get; set; }
Visual Basic
Public Property Signature As String
    Get
    Set
Visual C++
public:
property String^ Signature {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.TenantId Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..TenantId Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentApiAccount.UserName Property

[image]

A Sandcastle Documented Class Library
PaymentApiAccount..::..UserName Property
PaymentApiAccount Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentApiAccount Class
PaymentApiAccount Members
CelloSaaS.Billing.Model Namespace


PaymentAudit Class

[image]

A Sandcastle Documented Class Library
PaymentAudit Class
Members See Also Send Feedback
Payment audit model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PaymentAudit
Visual Basic
<SerializableAttribute>
Public Class PaymentAudit
Visual C++
[SerializableAttribute]
public ref class PaymentAudit

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAudit

See Also

PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit Members

[image] [image]

A Sandcastle Documented Class Library
PaymentAudit Members
PaymentAudit Class Constructors Methods Properties See Also Send Feedback

The PaymentAudit type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentAudit | Initializes a new instance of the PaymentAudit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets
Public property | AccountTypeValue | Gets or Sets
Public property | Amount | Gets or Sets
Public property | Attempt | Gets or Sets
Public property | Details | Gets or Sets
Public property | Id | Gets or Sets
Public property | InvoiceId | Gets or Sets
Public property | InvoiceNo | Gets or Sets
Public property | Status | Gets or Sets
Public property | TenantId | Gets or Sets
Public property | TransactionDate | Gets or Sets
Public property | TransactionId | Gets or Sets

See Also

PaymentAudit Class
CelloSaaS.Billing.Model Namespace


PaymentAudit Constructor

[image]

A Sandcastle Documented Class Library
PaymentAudit Constructor
PaymentAudit Class See Also Send Feedback
Initializes a new instance of the PaymentAudit class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAudit()
Visual Basic
Public Sub New
Visual C++
public:
PaymentAudit()

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit Methods

[image] [image]

A Sandcastle Documented Class Library
PaymentAudit Methods
PaymentAudit Class See Also Send Feedback

The PaymentAudit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaymentAudit Class
CelloSaaS.Billing.Model Namespace


PaymentAudit Properties

[image] [image]

A Sandcastle Documented Class Library
PaymentAudit Properties
PaymentAudit Class See Also Send Feedback

The PaymentAudit type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets
Public property | AccountTypeValue | Gets or Sets
Public property | Amount | Gets or Sets
Public property | Attempt | Gets or Sets
Public property | Details | Gets or Sets
Public property | Id | Gets or Sets
Public property | InvoiceId | Gets or Sets
Public property | InvoiceNo | Gets or Sets
Public property | Status | Gets or Sets
Public property | TenantId | Gets or Sets
Public property | TransactionDate | Gets or Sets
Public property | TransactionId | Gets or Sets

See Also

PaymentAudit Class
CelloSaaS.Billing.Model Namespace


PaymentAudit.AccountType Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..AccountType Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAccountType AccountType { get; set; }
Visual Basic
Public Property AccountType As PaymentAccountType
    Get
    Set
Visual C++
public:
property PaymentAccountType AccountType {
    PaymentAccountType get ();
    void set (PaymentAccountType value);
}

Property Value

Type: PaymentAccountType

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.AccountTypeValue Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..AccountTypeValue Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int AccountTypeValue { get; set; }
Visual Basic
Public Property AccountTypeValue As Integer
    Get
    Set
Visual C++
public:
property int AccountTypeValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.Amount Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..Amount Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.Attempt Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..Attempt Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Attempt { get; set; }
Visual Basic
Public Property Attempt As Integer
    Get
    Set
Visual C++
public:
property int Attempt {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.Details Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..Details Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Details { get; set; }
Visual Basic
Public Property Details As String
    Get
    Set
Visual C++
public:
property String^ Details {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.Id Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..Id Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.InvoiceId Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..InvoiceId Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid InvoiceId { get; set; }
Visual Basic
Public Property InvoiceId As Guid
    Get
    Set
Visual C++
public:
property Guid InvoiceId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.InvoiceNo Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..InvoiceNo Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string InvoiceNo { get; set; }
Visual Basic
Public Property InvoiceNo As String
    Get
    Set
Visual C++
public:
property String^ InvoiceNo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.Status Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..Status Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.TenantId Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..TenantId Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.TransactionDate Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..TransactionDate Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime TransactionDate { get; set; }
Visual Basic
Public Property TransactionDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime TransactionDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAudit.TransactionId Property

[image]

A Sandcastle Documented Class Library
PaymentAudit..::..TransactionId Property
PaymentAudit Class See Also Send Feedback
Gets or Sets

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TransactionId { get; set; }
Visual Basic
Public Property TransactionId As String
    Get
    Set
Visual C++
public:
property String^ TransactionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAudit Class
PaymentAudit Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition Class

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition Class
Members See Also Send Feedback
Payment audit search condition model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PaymentAuditSearchCondition
Visual Basic
<SerializableAttribute>
Public Class PaymentAuditSearchCondition
Visual C++
[SerializableAttribute]
public ref class PaymentAuditSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAuditSearchCondition

See Also

PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition Members
PaymentAuditSearchCondition Class Constructors Methods Properties See Also Send Feedback

The PaymentAuditSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentAuditSearchCondition | Initializes a new instance of the PaymentAuditSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType
Public property | FromDate | Gets or Sets FromDate
Public property | InvoiceId | Gets or Sets InvoiceId
Public property | InvoiceNo | Gets or Sets InvoiceNo
Public property | MaxAmount | Gets or Sets MaxAmount
Public property | MinAmount | Gets or Sets MinAmount
Public property | PageNo | Gets or Sets PageNo
Public property | PageSize | Gets or Sets PageSize
Public property | Status | Gets or Sets Status
Public property | TenantIds | Gets or Sets TenantIds
Public property | ToDate | Gets or Sets ToDate
Public property | TransactionId | Gets or Sets TransactionId

See Also

PaymentAuditSearchCondition Class
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition Constructor
PaymentAuditSearchCondition Class See Also Send Feedback
Initializes a new instance of the PaymentAuditSearchCondition class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAuditSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
PaymentAuditSearchCondition()

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition Methods
PaymentAuditSearchCondition Class See Also Send Feedback

The PaymentAuditSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaymentAuditSearchCondition Class
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition Properties
PaymentAuditSearchCondition Class See Also Send Feedback

The PaymentAuditSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType
Public property | FromDate | Gets or Sets FromDate
Public property | InvoiceId | Gets or Sets InvoiceId
Public property | InvoiceNo | Gets or Sets InvoiceNo
Public property | MaxAmount | Gets or Sets MaxAmount
Public property | MinAmount | Gets or Sets MinAmount
Public property | PageNo | Gets or Sets PageNo
Public property | PageSize | Gets or Sets PageSize
Public property | Status | Gets or Sets Status
Public property | TenantIds | Gets or Sets TenantIds
Public property | ToDate | Gets or Sets ToDate
Public property | TransactionId | Gets or Sets TransactionId

See Also

PaymentAuditSearchCondition Class
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.AccountType Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..AccountType Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets AccountType

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<PaymentAccountType> AccountType { get; set; }
Visual Basic
Public Property AccountType As Nullable(Of PaymentAccountType)
    Get
    Set
Visual C++
public:
property Nullable<PaymentAccountType> AccountType {
    Nullable<PaymentAccountType> get ();
    void set (Nullable<PaymentAccountType> value);
}

Property Value

Type: Nullable<(Of <(<' PaymentAccountType >)>)>

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.FromDate Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..FromDate Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets FromDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromDate { get; set; }
Visual Basic
Public Property FromDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.InvoiceId Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..InvoiceId Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets InvoiceId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> InvoiceId { get; set; }
Visual Basic
Public Property InvoiceId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> InvoiceId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.InvoiceNo Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..InvoiceNo Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets InvoiceNo

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string InvoiceNo { get; set; }
Visual Basic
Public Property InvoiceNo As String
    Get
    Set
Visual C++
public:
property String^ InvoiceNo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.MaxAmount Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..MaxAmount Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets MaxAmount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MaxAmount { get; set; }
Visual Basic
Public Property MaxAmount As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaxAmount {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.MinAmount Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..MinAmount Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets MinAmount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MinAmount { get; set; }
Visual Basic
Public Property MinAmount As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinAmount {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..PageNo Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets PageNo

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..PageSize Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets PageSize

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.Status Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..Status Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets Status

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..TenantIds Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets TenantIds

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ TenantIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.ToDate Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..ToDate Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets ToDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToDate { get; set; }
Visual Basic
Public Property ToDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchCondition.TransactionId Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchCondition..::..TransactionId Property
PaymentAuditSearchCondition Class See Also Send Feedback
Gets or Sets TransactionId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TransactionId { get; set; }
Visual Basic
Public Property TransactionId As String
    Get
    Set
Visual C++
public:
property String^ TransactionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PaymentAuditSearchCondition Class
PaymentAuditSearchCondition Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult Class

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult Class
Members See Also Send Feedback
Payment audit search result model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PaymentAuditSearchResult
Visual Basic
<SerializableAttribute>
Public Class PaymentAuditSearchResult
Visual C++
[SerializableAttribute]
public ref class PaymentAuditSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAuditSearchResult

See Also

PaymentAuditSearchResult Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult Members
PaymentAuditSearchResult Class Constructors Methods Properties See Also Send Feedback

The PaymentAuditSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentAuditSearchResult | Initializes a new instance of the PaymentAuditSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Gets or Sets search result
Public property | TotalCount | Gets or Sets search total count

See Also

PaymentAuditSearchResult Class
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult Constructor

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult Constructor
PaymentAuditSearchResult Class See Also Send Feedback
Initializes a new instance of the PaymentAuditSearchResult class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PaymentAuditSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
PaymentAuditSearchResult()

See Also

PaymentAuditSearchResult Class
PaymentAuditSearchResult Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult Methods
PaymentAuditSearchResult Class See Also Send Feedback

The PaymentAuditSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaymentAuditSearchResult Class
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult Properties
PaymentAuditSearchResult Class See Also Send Feedback

The PaymentAuditSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets or Sets search result
Public property | TotalCount | Gets or Sets search total count

See Also

PaymentAuditSearchResult Class
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult.Items Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult..::..Items Property
PaymentAuditSearchResult Class See Also Send Feedback
Gets or Sets search result

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<Guid, PaymentAudit> Items { get; set; }
Visual Basic
Public Property Items As Dictionary(Of Guid, PaymentAudit)
    Get
    Set
Visual C++
public:
property Dictionary<Guid, PaymentAudit^>^ Items {
    Dictionary<Guid, PaymentAudit^>^ get ();
    void set (Dictionary<Guid, PaymentAudit^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'Guid, PaymentAudit >)>)>

See Also

PaymentAuditSearchResult Class
PaymentAuditSearchResult Members
CelloSaaS.Billing.Model Namespace


PaymentAuditSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
PaymentAuditSearchResult..::..TotalCount Property
PaymentAuditSearchResult Class See Also Send Feedback
Gets or Sets search total count

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PaymentAuditSearchResult Class
PaymentAuditSearchResult Members
CelloSaaS.Billing.Model Namespace


PaymentMode Enumeration

[image]

A Sandcastle Documented Class Library
PaymentMode Enumeration
See Also Send Feedback
Payment mode enumeration

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum PaymentMode
Visual Basic
Public Enumeration PaymentMode
Visual C++
public enum class PaymentMode

Members

Member name | Value | Description
Card | 0 | Card
Cash | 1 | Cash
Manual | 2 | Manaual
Credit | 3 | Credit

See Also

CelloSaaS.Billing.Model Namespace


PayPalAccount Class

[image]

A Sandcastle Documented Class Library
PayPalAccount Class
Members See Also Send Feedback
Paypal payment account model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PayPalAccount : PaymentAccount
Visual Basic
<SerializableAttribute>
Public Class PayPalAccount
    Inherits PaymentAccount
Visual C++
[SerializableAttribute]
public ref class PayPalAccount : public PaymentAccount

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PaymentAccount
CelloSaaS.Billing.Model..::..PayPalAccount

See Also

PayPalAccount Members
CelloSaaS.Billing.Model Namespace


PayPalAccount Members

[image] [image]

A Sandcastle Documented Class Library
PayPalAccount Members
PayPalAccount Class Constructors Methods Properties See Also Send Feedback

The PayPalAccount type exposes the following members.

Constructors

 | Name | Description
Public method | PayPalAccount | Initializes a new instance of the PayPalAccount class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType (Inherited from PaymentAccount.)
Public property | AccountTypeValue | Gets or Sets AccountTypeValue (Inherited from PaymentAccount.)
Public property | CreatedBy | Gets or Sets CreatedBy (Inherited from PaymentAccount.)
Public property | CreatedOn | Gets or Sets CreatedOn (Inherited from PaymentAccount.)
Public property | CurrencyCode | Gets or Sets CurrencyCode (Inherited from PaymentAccount.)
Public property | Email | Gets or Sets Email (Inherited from PaymentAccount.)
Public property | PreapprovalDetails | Gets or Sets PreapprovalDetails
Public property | PreApprovalKey | Gets or Sets PreApprovalKey
Public property | Status | Gets or Sets Status (Inherited from PaymentAccount.)
Public property | StoreKey | Gets or Sets StoreKey (Inherited from PaymentAccount.)
Public property | TenantId | Gets or Sets TenantId (Inherited from PaymentAccount.)
Public property | UpdatedBy | Gets or Sets UpdatedBy (Inherited from PaymentAccount.)
Public property | UpdatedOn | Gets or Sets UpdatedOn (Inherited from PaymentAccount.)

See Also

PayPalAccount Class
CelloSaaS.Billing.Model Namespace


PayPalAccount Constructor

[image]

A Sandcastle Documented Class Library
PayPalAccount Constructor
PayPalAccount Class See Also Send Feedback
Initializes a new instance of the PayPalAccount class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PayPalAccount()
Visual Basic
Public Sub New
Visual C++
public:
PayPalAccount()

See Also

PayPalAccount Class
PayPalAccount Members
CelloSaaS.Billing.Model Namespace


PayPalAccount Methods

[image] [image]

A Sandcastle Documented Class Library
PayPalAccount Methods
PayPalAccount Class See Also Send Feedback

The PayPalAccount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PayPalAccount Class
CelloSaaS.Billing.Model Namespace


PayPalAccount Properties

[image] [image]

A Sandcastle Documented Class Library
PayPalAccount Properties
PayPalAccount Class See Also Send Feedback

The PayPalAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountType | Gets or Sets AccountType (Inherited from PaymentAccount.)
Public property | AccountTypeValue | Gets or Sets AccountTypeValue (Inherited from PaymentAccount.)
Public property | CreatedBy | Gets or Sets CreatedBy (Inherited from PaymentAccount.)
Public property | CreatedOn | Gets or Sets CreatedOn (Inherited from PaymentAccount.)
Public property | CurrencyCode | Gets or Sets CurrencyCode (Inherited from PaymentAccount.)
Public property | Email | Gets or Sets Email (Inherited from PaymentAccount.)
Public property | PreapprovalDetails | Gets or Sets PreapprovalDetails
Public property | PreApprovalKey | Gets or Sets PreApprovalKey
Public property | Status | Gets or Sets Status (Inherited from PaymentAccount.)
Public property | StoreKey | Gets or Sets StoreKey (Inherited from PaymentAccount.)
Public property | TenantId | Gets or Sets TenantId (Inherited from PaymentAccount.)
Public property | UpdatedBy | Gets or Sets UpdatedBy (Inherited from PaymentAccount.)
Public property | UpdatedOn | Gets or Sets UpdatedOn (Inherited from PaymentAccount.)

See Also

PayPalAccount Class
CelloSaaS.Billing.Model Namespace


PayPalAccount.PreapprovalDetails Property

[image]

A Sandcastle Documented Class Library
PayPalAccount..::..PreapprovalDetails Property
PayPalAccount Class See Also Send Feedback
Gets or Sets PreapprovalDetails

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PreapprovalDetails PreapprovalDetails { get; set; }
Visual Basic
Public Property PreapprovalDetails As PreapprovalDetails
    Get
    Set
Visual C++
public:
property PreapprovalDetails^ PreapprovalDetails {
    PreapprovalDetails^ get ();
    void set (PreapprovalDetails^ value);
}

Property Value

Type: PreapprovalDetails

See Also

PayPalAccount Class
PayPalAccount Members
CelloSaaS.Billing.Model Namespace


PayPalAccount.PreApprovalKey Property

[image]

A Sandcastle Documented Class Library
PayPalAccount..::..PreApprovalKey Property
PayPalAccount Class See Also Send Feedback
Gets or Sets PreApprovalKey

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PreApprovalKey { get; set; }
Visual Basic
Public Property PreApprovalKey As String
    Get
    Set
Visual C++
public:
property String^ PreApprovalKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PayPalAccount Class
PayPalAccount Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails Class

[image]

A Sandcastle Documented Class Library
PreapprovalDetails Class
Members See Also Send Feedback
Preapproval details model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PreapprovalDetails
Visual Basic
<SerializableAttribute>
Public Class PreapprovalDetails
Visual C++
[SerializableAttribute]
public ref class PreapprovalDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PreapprovalDetails

See Also

PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails Members

[image] [image]

A Sandcastle Documented Class Library
PreapprovalDetails Members
PreapprovalDetails Class Constructors Methods Properties See Also Send Feedback

The PreapprovalDetails type exposes the following members.

Constructors

 | Name | Description
Public method | PreapprovalDetails | Initializes a new instance of the PreapprovalDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Approved | Gets or Sets Approved
Public property | CancelUrl | Gets or Sets CancelUrl
Public property | CurPayments | Gets or Sets CurPayments
Public property | CurPaymentsAmount | Gets or Sets CurPaymentsAmount
Public property | CurPeriodAttempts | Gets or Sets CurPeriodAttempts
Public property | CurPeriodEndingDate | Gets or Sets CurPeriodEndingDate
Public property | CurrencyCode | Gets or Sets CurrencyCode
Public property | DateOfMonth | Gets or Sets DateOfMonth
Public property | DayOfWeek | Gets or Sets DayOfWeek
Public property | DisplayMaxTotalAmount | Gets or Sets DisplayMaxTotalAmount
Public property | EndingDate | Gets or Sets EndingDate
Public property | FeesPayer | Gets or Sets FeesPayer
Public property | MaxAmountPerPayment | Gets or Sets MaxAmountPerPayment
Public property | MaxNumberOfPayments | Gets or Sets MaxNumberOfPayments
Public property | MaxNumberOfPaymentsPerPeriod | Gets or Sets MaxNumberOfPaymentsPerPeriod
Public property | MaxTotalAmountOfAllPayments | Gets or Sets MaxTotalAmountOfAllPayments
Public property | Memo | Gets or Sets Memo
Public property | PaymentPeriod | Gets or Sets PaymentPeriod
Public property | PinType | Gets or Sets PinType
Public property | RedirectUrl | Gets or Sets RedirectUrl
Public property | ReturnUrl | Gets or Sets ReturnUrl
Public property | SenderEmail | Gets or Sets SenderEmail
Public property | StartingDate | Gets or Sets StartingDate
Public property | Status | Gets or Sets Status

See Also

PreapprovalDetails Class
CelloSaaS.Billing.Model Namespace


PreapprovalDetails Constructor

[image]

A Sandcastle Documented Class Library
PreapprovalDetails Constructor
PreapprovalDetails Class See Also Send Feedback
Initializes a new instance of the PreapprovalDetails class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PreapprovalDetails()
Visual Basic
Public Sub New
Visual C++
public:
PreapprovalDetails()

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails Methods

[image] [image]

A Sandcastle Documented Class Library
PreapprovalDetails Methods
PreapprovalDetails Class See Also Send Feedback

The PreapprovalDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PreapprovalDetails Class
CelloSaaS.Billing.Model Namespace


PreapprovalDetails Properties

[image] [image]

A Sandcastle Documented Class Library
PreapprovalDetails Properties
PreapprovalDetails Class See Also Send Feedback

The PreapprovalDetails type exposes the following members.

Properties

 | Name | Description
Public property | Approved | Gets or Sets Approved
Public property | CancelUrl | Gets or Sets CancelUrl
Public property | CurPayments | Gets or Sets CurPayments
Public property | CurPaymentsAmount | Gets or Sets CurPaymentsAmount
Public property | CurPeriodAttempts | Gets or Sets CurPeriodAttempts
Public property | CurPeriodEndingDate | Gets or Sets CurPeriodEndingDate
Public property | CurrencyCode | Gets or Sets CurrencyCode
Public property | DateOfMonth | Gets or Sets DateOfMonth
Public property | DayOfWeek | Gets or Sets DayOfWeek
Public property | DisplayMaxTotalAmount | Gets or Sets DisplayMaxTotalAmount
Public property | EndingDate | Gets or Sets EndingDate
Public property | FeesPayer | Gets or Sets FeesPayer
Public property | MaxAmountPerPayment | Gets or Sets MaxAmountPerPayment
Public property | MaxNumberOfPayments | Gets or Sets MaxNumberOfPayments
Public property | MaxNumberOfPaymentsPerPeriod | Gets or Sets MaxNumberOfPaymentsPerPeriod
Public property | MaxTotalAmountOfAllPayments | Gets or Sets MaxTotalAmountOfAllPayments
Public property | Memo | Gets or Sets Memo
Public property | PaymentPeriod | Gets or Sets PaymentPeriod
Public property | PinType | Gets or Sets PinType
Public property | RedirectUrl | Gets or Sets RedirectUrl
Public property | ReturnUrl | Gets or Sets ReturnUrl
Public property | SenderEmail | Gets or Sets SenderEmail
Public property | StartingDate | Gets or Sets StartingDate
Public property | Status | Gets or Sets Status

See Also

PreapprovalDetails Class
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.Approved Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..Approved Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets Approved

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Approved { get; set; }
Visual Basic
Public Property Approved As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Approved {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.CancelUrl Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..CancelUrl Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets CancelUrl

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CancelUrl { get; set; }
Visual Basic
Public Property CancelUrl As String
    Get
    Set
Visual C++
public:
property String^ CancelUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.CurPayments Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..CurPayments Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets CurPayments

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> CurPayments { get; set; }
Visual Basic
Public Property CurPayments As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> CurPayments {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.CurPaymentsAmount Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..CurPaymentsAmount Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets CurPaymentsAmount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<decimal> CurPaymentsAmount { get; set; }
Visual Basic
Public Property CurPaymentsAmount As Nullable(Of Decimal)
    Get
    Set
Visual C++
public:
property Nullable<Decimal> CurPaymentsAmount {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Property Value

Type: Nullable<(Of <(<'Decimal>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.CurPeriodAttempts Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..CurPeriodAttempts Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets CurPeriodAttempts

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> CurPeriodAttempts { get; set; }
Visual Basic
Public Property CurPeriodAttempts As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> CurPeriodAttempts {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.CurPeriodEndingDate Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..CurPeriodEndingDate Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets CurPeriodEndingDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CurPeriodEndingDate { get; set; }
Visual Basic
Public Property CurPeriodEndingDate As String
    Get
    Set
Visual C++
public:
property String^ CurPeriodEndingDate {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.CurrencyCode Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..CurrencyCode Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets CurrencyCode

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CurrencyCode { get; set; }
Visual Basic
Public Property CurrencyCode As String
    Get
    Set
Visual C++
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.DateOfMonth Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..DateOfMonth Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets DateOfMonth

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> DateOfMonth { get; set; }
Visual Basic
Public Property DateOfMonth As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> DateOfMonth {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.DayOfWeek Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..DayOfWeek Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets DayOfWeek

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DayOfWeek { get; set; }
Visual Basic
Public Property DayOfWeek As String
    Get
    Set
Visual C++
public:
property String^ DayOfWeek {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.DisplayMaxTotalAmount Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..DisplayMaxTotalAmount Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets DisplayMaxTotalAmount

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> DisplayMaxTotalAmount { get; set; }
Visual Basic
Public Property DisplayMaxTotalAmount As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> DisplayMaxTotalAmount {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.EndingDate Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..EndingDate Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets EndingDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EndingDate { get; set; }
Visual Basic
Public Property EndingDate As String
    Get
    Set
Visual C++
public:
property String^ EndingDate {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.FeesPayer Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..FeesPayer Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets FeesPayer

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeesPayer { get; set; }
Visual Basic
Public Property FeesPayer As String
    Get
    Set
Visual C++
public:
property String^ FeesPayer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.MaxAmountPerPayment Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..MaxAmountPerPayment Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets MaxAmountPerPayment

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<decimal> MaxAmountPerPayment { get; set; }
Visual Basic
Public Property MaxAmountPerPayment As Nullable(Of Decimal)
    Get
    Set
Visual C++
public:
property Nullable<Decimal> MaxAmountPerPayment {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Property Value

Type: Nullable<(Of <(<'Decimal>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.MaxNumberOfPayments Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..MaxNumberOfPayments Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets MaxNumberOfPayments

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> MaxNumberOfPayments { get; set; }
Visual Basic
Public Property MaxNumberOfPayments As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> MaxNumberOfPayments {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.MaxNumberOfPaymentsPerPeriod Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..MaxNumberOfPaymentsPerPeriod Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets MaxNumberOfPaymentsPerPeriod

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> MaxNumberOfPaymentsPerPeriod { get; set; }
Visual Basic
Public Property MaxNumberOfPaymentsPerPeriod As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> MaxNumberOfPaymentsPerPeriod {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.MaxTotalAmountOfAllPayments Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..MaxTotalAmountOfAllPayments Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets MaxTotalAmountOfAllPayments

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<decimal> MaxTotalAmountOfAllPayments { get; set; }
Visual Basic
Public Property MaxTotalAmountOfAllPayments As Nullable(Of Decimal)
    Get
    Set
Visual C++
public:
property Nullable<Decimal> MaxTotalAmountOfAllPayments {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}

Property Value

Type: Nullable<(Of <(<'Decimal>)>)>

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.Memo Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..Memo Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets Memo

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Memo { get; set; }
Visual Basic
Public Property Memo As String
    Get
    Set
Visual C++
public:
property String^ Memo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.PaymentPeriod Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..PaymentPeriod Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets PaymentPeriod

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PaymentPeriod { get; set; }
Visual Basic
Public Property PaymentPeriod As String
    Get
    Set
Visual C++
public:
property String^ PaymentPeriod {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.PinType Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..PinType Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets PinType

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PinType { get; set; }
Visual Basic
Public Property PinType As String
    Get
    Set
Visual C++
public:
property String^ PinType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.RedirectUrl Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..RedirectUrl Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets RedirectUrl

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RedirectUrl { get; set; }
Visual Basic
Public Property RedirectUrl As String
    Get
    Set
Visual C++
public:
property String^ RedirectUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.ReturnUrl Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..ReturnUrl Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets ReturnUrl

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReturnUrl { get; set; }
Visual Basic
Public Property ReturnUrl As String
    Get
    Set
Visual C++
public:
property String^ ReturnUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.SenderEmail Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..SenderEmail Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets SenderEmail

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SenderEmail { get; set; }
Visual Basic
Public Property SenderEmail As String
    Get
    Set
Visual C++
public:
property String^ SenderEmail {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.StartingDate Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..StartingDate Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets StartingDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string StartingDate { get; set; }
Visual Basic
Public Property StartingDate As String
    Get
    Set
Visual C++
public:
property String^ StartingDate {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalDetails.Status Property

[image]

A Sandcastle Documented Class Library
PreapprovalDetails..::..Status Property
PreapprovalDetails Class See Also Send Feedback
Gets or Sets Status

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalDetails Class
PreapprovalDetails Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest Class

[image]

A Sandcastle Documented Class Library
PreapprovalRequest Class
Members See Also Send Feedback
Preapproval request model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PreapprovalRequest
Visual Basic
<SerializableAttribute>
Public Class PreapprovalRequest
Visual C++
[SerializableAttribute]
public ref class PreapprovalRequest

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PreapprovalRequest

See Also

PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest Members

[image] [image]

A Sandcastle Documented Class Library
PreapprovalRequest Members
PreapprovalRequest Class Constructors Methods Properties See Also Send Feedback

The PreapprovalRequest type exposes the following members.

Constructors

 | Name | Description
Public method | PreapprovalRequest | Initializes a new instance of the PreapprovalRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CancelUrl | Gets or Sets CancelUrl
Public property | CurrencyCode | Gets or Sets CurrencyCode
Public property | Email | Gets or Sets Email
Public property | EndingDate | Gets or Sets EndingDate
Public property | ReturnUrl | Gets or Sets ReturnUrl
Public property | StartingDate | Gets or Sets StartingDate
Public property | TenantId | Gets or Sets TenantId

See Also

PreapprovalRequest Class
CelloSaaS.Billing.Model Namespace


PreapprovalRequest Constructor

[image]

A Sandcastle Documented Class Library
PreapprovalRequest Constructor
PreapprovalRequest Class See Also Send Feedback
Initializes a new instance of the PreapprovalRequest class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PreapprovalRequest()
Visual Basic
Public Sub New
Visual C++
public:
PreapprovalRequest()

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest Methods

[image] [image]

A Sandcastle Documented Class Library
PreapprovalRequest Methods
PreapprovalRequest Class See Also Send Feedback

The PreapprovalRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PreapprovalRequest Class
CelloSaaS.Billing.Model Namespace


PreapprovalRequest Properties

[image] [image]

A Sandcastle Documented Class Library
PreapprovalRequest Properties
PreapprovalRequest Class See Also Send Feedback

The PreapprovalRequest type exposes the following members.

Properties

 | Name | Description
Public property | CancelUrl | Gets or Sets CancelUrl
Public property | CurrencyCode | Gets or Sets CurrencyCode
Public property | Email | Gets or Sets Email
Public property | EndingDate | Gets or Sets EndingDate
Public property | ReturnUrl | Gets or Sets ReturnUrl
Public property | StartingDate | Gets or Sets StartingDate
Public property | TenantId | Gets or Sets TenantId

See Also

PreapprovalRequest Class
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.CancelUrl Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..CancelUrl Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets CancelUrl

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CancelUrl { get; set; }
Visual Basic
Public Property CancelUrl As String
    Get
    Set
Visual C++
public:
property String^ CancelUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.CurrencyCode Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..CurrencyCode Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets CurrencyCode

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CurrencyCode { get; set; }
Visual Basic
Public Property CurrencyCode As String
    Get
    Set
Visual C++
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.Email Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..Email Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets Email

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.EndingDate Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..EndingDate Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets EndingDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime EndingDate { get; set; }
Visual Basic
Public Property EndingDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndingDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.ReturnUrl Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..ReturnUrl Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets ReturnUrl

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReturnUrl { get; set; }
Visual Basic
Public Property ReturnUrl As String
    Get
    Set
Visual C++
public:
property String^ ReturnUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.StartingDate Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..StartingDate Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets StartingDate

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime StartingDate { get; set; }
Visual Basic
Public Property StartingDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartingDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalRequest.TenantId Property

[image]

A Sandcastle Documented Class Library
PreapprovalRequest..::..TenantId Property
PreapprovalRequest Class See Also Send Feedback
Gets or Sets TenantId

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PreapprovalRequest Class
PreapprovalRequest Members
CelloSaaS.Billing.Model Namespace


PreapprovalResponse Class

[image]

A Sandcastle Documented Class Library
PreapprovalResponse Class
Members See Also Send Feedback
Preapproval response model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PreapprovalResponse
Visual Basic
<SerializableAttribute>
Public Class PreapprovalResponse
Visual C++
[SerializableAttribute]
public ref class PreapprovalResponse

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PreapprovalResponse

See Also

PreapprovalResponse Members
CelloSaaS.Billing.Model Namespace


PreapprovalResponse Members

[image] [image]

A Sandcastle Documented Class Library
PreapprovalResponse Members
PreapprovalResponse Class Constructors Methods Properties See Also Send Feedback

The PreapprovalResponse type exposes the following members.

Constructors

 | Name | Description
Public method | PreapprovalResponse | Initializes a new instance of the PreapprovalResponse class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PreapprovalKey | Gets or Sets preapproval key
Public property | ReturnUrl | Gets or Sets return url

See Also

PreapprovalResponse Class
CelloSaaS.Billing.Model Namespace


PreapprovalResponse Constructor

[image]

A Sandcastle Documented Class Library
PreapprovalResponse Constructor
PreapprovalResponse Class See Also Send Feedback
Initializes a new instance of the PreapprovalResponse class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PreapprovalResponse()
Visual Basic
Public Sub New
Visual C++
public:
PreapprovalResponse()

See Also

PreapprovalResponse Class
PreapprovalResponse Members
CelloSaaS.Billing.Model Namespace


PreapprovalResponse Methods

[image] [image]

A Sandcastle Documented Class Library
PreapprovalResponse Methods
PreapprovalResponse Class See Also Send Feedback

The PreapprovalResponse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PreapprovalResponse Class
CelloSaaS.Billing.Model Namespace


PreapprovalResponse Properties

[image] [image]

A Sandcastle Documented Class Library
PreapprovalResponse Properties
PreapprovalResponse Class See Also Send Feedback

The PreapprovalResponse type exposes the following members.

Properties

 | Name | Description
Public property | PreapprovalKey | Gets or Sets preapproval key
Public property | ReturnUrl | Gets or Sets return url

See Also

PreapprovalResponse Class
CelloSaaS.Billing.Model Namespace


PreapprovalResponse.PreapprovalKey Property

[image]

A Sandcastle Documented Class Library
PreapprovalResponse..::..PreapprovalKey Property
PreapprovalResponse Class See Also Send Feedback
Gets or Sets preapproval key

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PreapprovalKey { get; set; }
Visual Basic
Public Property PreapprovalKey As String
    Get
    Set
Visual C++
public:
property String^ PreapprovalKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalResponse Class
PreapprovalResponse Members
CelloSaaS.Billing.Model Namespace


PreapprovalResponse.ReturnUrl Property

[image]

A Sandcastle Documented Class Library
PreapprovalResponse..::..ReturnUrl Property
PreapprovalResponse Class See Also Send Feedback
Gets or Sets return url

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReturnUrl { get; set; }
Visual Basic
Public Property ReturnUrl As String
    Get
    Set
Visual C++
public:
property String^ ReturnUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PreapprovalResponse Class
PreapprovalResponse Members
CelloSaaS.Billing.Model Namespace


PricePlan Class

[image]

A Sandcastle Documented Class Library
PricePlan Class
Members See Also Send Feedback
Price plan model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PricePlan
Visual Basic
<SerializableAttribute>
Public Class PricePlan
Visual C++
[SerializableAttribute]
public ref class PricePlan

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PricePlan

See Also

PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan Members

[image] [image]

A Sandcastle Documented Class Library
PricePlan Members
PricePlan Class Constructors Methods Properties See Also Send Feedback

The PricePlan type exposes the following members.

Constructors

 | Name | Description
Public method | PricePlan | Initializes a new instance of the PricePlan class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BillFrequency | Gets or Sets bill frequency
Public property | BillFrequencyValue | Gets or Sets bill frequency value
Public property | CreatedBy | Gets or Sets created by user id
Public property | CreatedOn | Gets or Sets created on date
Public property | Description | Gets or Sets plan description
Public property | Id | Gets or Sets plan id (PK)
Public property | LineItems | Gets or Sets plan line items
Public property | Name | Gets or Sets plan name
Public property | PackageId | Gets or Sets subscription package id
Public property | Price | Gets or Sets plan price
Public property | SkipCalculation | Gets or Sets skip calculation
Public property | Status | Gets or Sets record status
Public property | TenantId | Gets or Sets tenant id
Public property | UpdatedBy | Gets or Sets updated by user id
Public property | UpdatedOn | Gets or Sets updated on date

See Also

PricePlan Class
CelloSaaS.Billing.Model Namespace


PricePlan Constructor

[image]

A Sandcastle Documented Class Library
PricePlan Constructor
PricePlan Class See Also Send Feedback
Initializes a new instance of the PricePlan class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PricePlan()
Visual Basic
Public Sub New
Visual C++
public:
PricePlan()

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan Methods

[image] [image]

A Sandcastle Documented Class Library
PricePlan Methods
PricePlan Class See Also Send Feedback

The PricePlan type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PricePlan Class
CelloSaaS.Billing.Model Namespace


PricePlan Properties

[image] [image]

A Sandcastle Documented Class Library
PricePlan Properties
PricePlan Class See Also Send Feedback

The PricePlan type exposes the following members.

Properties

 | Name | Description
Public property | BillFrequency | Gets or Sets bill frequency
Public property | BillFrequencyValue | Gets or Sets bill frequency value
Public property | CreatedBy | Gets or Sets created by user id
Public property | CreatedOn | Gets or Sets created on date
Public property | Description | Gets or Sets plan description
Public property | Id | Gets or Sets plan id (PK)
Public property | LineItems | Gets or Sets plan line items
Public property | Name | Gets or Sets plan name
Public property | PackageId | Gets or Sets subscription package id
Public property | Price | Gets or Sets plan price
Public property | SkipCalculation | Gets or Sets skip calculation
Public property | Status | Gets or Sets record status
Public property | TenantId | Gets or Sets tenant id
Public property | UpdatedBy | Gets or Sets updated by user id
Public property | UpdatedOn | Gets or Sets updated on date

See Also

PricePlan Class
CelloSaaS.Billing.Model Namespace


PricePlan.BillFrequency Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..BillFrequency Property
PricePlan Class See Also Send Feedback
Gets or Sets bill frequency

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BillFrequency BillFrequency { get; set; }
Visual Basic
Public Property BillFrequency As BillFrequency
    Get
    Set
Visual C++
public:
property BillFrequency BillFrequency {
    BillFrequency get ();
    void set (BillFrequency value);
}

Property Value

Type: BillFrequency

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.BillFrequencyValue Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..BillFrequencyValue Property
PricePlan Class See Also Send Feedback
Gets or Sets bill frequency value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BillFrequencyValue { get; set; }
Visual Basic
Public Property BillFrequencyValue As Integer
    Get
    Set
Visual C++
public:
property int BillFrequencyValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..CreatedBy Property
PricePlan Class See Also Send Feedback
Gets or Sets created by user id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..CreatedOn Property
PricePlan Class See Also Send Feedback
Gets or Sets created on date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.Description Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..Description Property
PricePlan Class See Also Send Feedback
Gets or Sets plan description

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.Id Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..Id Property
PricePlan Class See Also Send Feedback
Gets or Sets plan id (PK)

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.LineItems Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..LineItems Property
PricePlan Class See Also Send Feedback
Gets or Sets plan line items

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<PricePlanLineItem> LineItems { get; set; }
Visual Basic
Public Property LineItems As ICollection(Of PricePlanLineItem)
    Get
    Set
Visual C++
public:
property ICollection<PricePlanLineItem^>^ LineItems {
    ICollection<PricePlanLineItem^>^ get ();
    void set (ICollection<PricePlanLineItem^>^ value);
}

Property Value

Type: ICollection<(Of <(<' PricePlanLineItem >)>)>

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.Name Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..Name Property
PricePlan Class See Also Send Feedback
Gets or Sets plan name

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.PackageId Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..PackageId Property
PricePlan Class See Also Send Feedback
Gets or Sets subscription package id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid PackageId { get; set; }
Visual Basic
Public Property PackageId As Guid
    Get
    Set
Visual C++
public:
property Guid PackageId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.Price Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..Price Property
PricePlan Class See Also Send Feedback
Gets or Sets plan price

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Price { get; set; }
Visual Basic
Public Property Price As Double
    Get
    Set
Visual C++
public:
property double Price {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.SkipCalculation Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..SkipCalculation Property
PricePlan Class See Also Send Feedback
Gets or Sets skip calculation

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool SkipCalculation { get; set; }
Visual Basic
Public Property SkipCalculation As Boolean
    Get
    Set
Visual C++
public:
property bool SkipCalculation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.Status Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..Status Property
PricePlan Class See Also Send Feedback
Gets or Sets record status

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.TenantId Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..TenantId Property
PricePlan Class See Also Send Feedback
Gets or Sets tenant id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..UpdatedBy Property
PricePlan Class See Also Send Feedback
Gets or Sets updated by user id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlan.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PricePlan..::..UpdatedOn Property
PricePlan Class See Also Send Feedback
Gets or Sets updated on date

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

PricePlan Class
PricePlan Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem Class

[image]

A Sandcastle Documented Class Library
PricePlanLineItem Class
Members See Also Send Feedback
Price plan line item model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PricePlanLineItem
Visual Basic
<SerializableAttribute>
Public Class PricePlanLineItem
Visual C++
[SerializableAttribute]
public ref class PricePlanLineItem

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PricePlanLineItem

See Also

PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem Members

[image] [image]

A Sandcastle Documented Class Library
PricePlanLineItem Members
PricePlanLineItem Class Constructors Methods Properties See Also Send Feedback

The PricePlanLineItem type exposes the following members.

Constructors

 | Name | Description
Public method | PricePlanLineItem | Initializes a new instance of the PricePlanLineItem class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or Sets item description
Public property | Id | Gets or Sets id
Public property | Name | Gets or Sets item name
Public property | PricePlanId | Gets or Sets price plan id
Public property | PriceTable | Gets or Sets price table object
Public property | PriceTableId | Gets or Sets price table id

See Also

PricePlanLineItem Class
CelloSaaS.Billing.Model Namespace


PricePlanLineItem Constructor

[image]

A Sandcastle Documented Class Library
PricePlanLineItem Constructor
PricePlanLineItem Class See Also Send Feedback
Initializes a new instance of the PricePlanLineItem class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PricePlanLineItem()
Visual Basic
Public Sub New
Visual C++
public:
PricePlanLineItem()

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem Methods

[image] [image]

A Sandcastle Documented Class Library
PricePlanLineItem Methods
PricePlanLineItem Class See Also Send Feedback

The PricePlanLineItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PricePlanLineItem Class
CelloSaaS.Billing.Model Namespace


PricePlanLineItem Properties

[image] [image]

A Sandcastle Documented Class Library
PricePlanLineItem Properties
PricePlanLineItem Class See Also Send Feedback

The PricePlanLineItem type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or Sets item description
Public property | Id | Gets or Sets id
Public property | Name | Gets or Sets item name
Public property | PricePlanId | Gets or Sets price plan id
Public property | PriceTable | Gets or Sets price table object
Public property | PriceTableId | Gets or Sets price table id

See Also

PricePlanLineItem Class
CelloSaaS.Billing.Model Namespace


PricePlanLineItem.Description Property

[image]

A Sandcastle Documented Class Library
PricePlanLineItem..::..Description Property
PricePlanLineItem Class See Also Send Feedback
Gets or Sets item description

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem.Id Property

[image]

A Sandcastle Documented Class Library
PricePlanLineItem..::..Id Property
PricePlanLineItem Class See Also Send Feedback
Gets or Sets id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem.Name Property

[image]

A Sandcastle Documented Class Library
PricePlanLineItem..::..Name Property
PricePlanLineItem Class See Also Send Feedback
Gets or Sets item name

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem.PricePlanId Property

[image]

A Sandcastle Documented Class Library
PricePlanLineItem..::..PricePlanId Property
PricePlanLineItem Class See Also Send Feedback
Gets or Sets price plan id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid PricePlanId { get; set; }
Visual Basic
Public Property PricePlanId As Guid
    Get
    Set
Visual C++
public:
property Guid PricePlanId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem.PriceTable Property

[image]

A Sandcastle Documented Class Library
PricePlanLineItem..::..PriceTable Property
PricePlanLineItem Class See Also Send Feedback
Gets or Sets price table object

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PriceTable PriceTable { get; set; }
Visual Basic
Public Property PriceTable As PriceTable
    Get
    Set
Visual C++
public:
property PriceTable^ PriceTable {
    PriceTable^ get ();
    void set (PriceTable^ value);
}

Property Value

Type: PriceTable

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PricePlanLineItem.PriceTableId Property

[image]

A Sandcastle Documented Class Library
PricePlanLineItem..::..PriceTableId Property
PricePlanLineItem Class See Also Send Feedback
Gets or Sets price table id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid PriceTableId { get; set; }
Visual Basic
Public Property PriceTableId As Guid
    Get
    Set
Visual C++
public:
property Guid PriceTableId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PricePlanLineItem Class
PricePlanLineItem Members
CelloSaaS.Billing.Model Namespace


PriceSlab Class

[image]

A Sandcastle Documented Class Library
PriceSlab Class
Members See Also Send Feedback
Price slab model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PriceSlab
Visual Basic
<SerializableAttribute>
Public Class PriceSlab
Visual C++
[SerializableAttribute]
public ref class PriceSlab

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PriceSlab

See Also

PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceSlab Members

[image] [image]

A Sandcastle Documented Class Library
PriceSlab Members
PriceSlab Class Constructors Methods Properties See Also Send Feedback

The PriceSlab type exposes the following members.

Constructors

 | Name | Description
Public method | PriceSlab | Initializes a new instance of the PriceSlab class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndValue | Gets or Sets end value
Public property | Factor | Gets or Sets factor value
Public property | Id | Gets or Sets id
Public property | PriceTableId | Gets or Sets price table id
Public property | StartValue | Gets or Sets start value

See Also

PriceSlab Class
CelloSaaS.Billing.Model Namespace


PriceSlab Constructor

[image]

A Sandcastle Documented Class Library
PriceSlab Constructor
PriceSlab Class See Also Send Feedback
Initializes a new instance of the PriceSlab class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PriceSlab()
Visual Basic
Public Sub New
Visual C++
public:
PriceSlab()

See Also

PriceSlab Class
PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceSlab Methods

[image] [image]

A Sandcastle Documented Class Library
PriceSlab Methods
PriceSlab Class See Also Send Feedback

The PriceSlab type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PriceSlab Class
CelloSaaS.Billing.Model Namespace


PriceSlab Properties

[image] [image]

A Sandcastle Documented Class Library
PriceSlab Properties
PriceSlab Class See Also Send Feedback

The PriceSlab type exposes the following members.

Properties

 | Name | Description
Public property | EndValue | Gets or Sets end value
Public property | Factor | Gets or Sets factor value
Public property | Id | Gets or Sets id
Public property | PriceTableId | Gets or Sets price table id
Public property | StartValue | Gets or Sets start value

See Also

PriceSlab Class
CelloSaaS.Billing.Model Namespace


PriceSlab.EndValue Property

[image]

A Sandcastle Documented Class Library
PriceSlab..::..EndValue Property
PriceSlab Class See Also Send Feedback
Gets or Sets end value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> EndValue { get; set; }
Visual Basic
Public Property EndValue As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> EndValue {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

PriceSlab Class
PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceSlab.Factor Property

[image]

A Sandcastle Documented Class Library
PriceSlab..::..Factor Property
PriceSlab Class See Also Send Feedback
Gets or Sets factor value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Factor { get; set; }
Visual Basic
Public Property Factor As Double
    Get
    Set
Visual C++
public:
property double Factor {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

PriceSlab Class
PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceSlab.Id Property

[image]

A Sandcastle Documented Class Library
PriceSlab..::..Id Property
PriceSlab Class See Also Send Feedback
Gets or Sets id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PriceSlab Class
PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceSlab.PriceTableId Property

[image]

A Sandcastle Documented Class Library
PriceSlab..::..PriceTableId Property
PriceSlab Class See Also Send Feedback
Gets or Sets price table id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid PriceTableId { get; set; }
Visual Basic
Public Property PriceTableId As Guid
    Get
    Set
Visual C++
public:
property Guid PriceTableId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PriceSlab Class
PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceSlab.StartValue Property

[image]

A Sandcastle Documented Class Library
PriceSlab..::..StartValue Property
PriceSlab Class See Also Send Feedback
Gets or Sets start value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double StartValue { get; set; }
Visual Basic
Public Property StartValue As Double
    Get
    Set
Visual C++
public:
property double StartValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

PriceSlab Class
PriceSlab Members
CelloSaaS.Billing.Model Namespace


PriceTable Class

[image]

A Sandcastle Documented Class Library
PriceTable Class
Members See Also Send Feedback
Price table model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PriceTable
Visual Basic
<SerializableAttribute>
Public Class PriceTable
Visual C++
[SerializableAttribute]
public ref class PriceTable

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..PriceTable

See Also

PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable Members

[image] [image]

A Sandcastle Documented Class Library
PriceTable Members
PriceTable Class Constructors Methods Properties See Also Send Feedback

The PriceTable type exposes the following members.

Constructors

 | Name | Description
Public method | PriceTable | Initializes a new instance of the PriceTable class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActedOnMeterVariable | Gets or Sets acted on meter variable
Public property | CalculationType | Gets or Sets calculation
Public property | FactorType | Gets or Sets factor type
Public property | FactorTypeValue | Gets or Sets factor type value
Public property | Id | Gets or Sets id
Public property | PriceSlabs | Gets or Sets price slabs collection
Public property | SlabMeterVariable | Gets or Sets slab meter variable

See Also

PriceTable Class
CelloSaaS.Billing.Model Namespace


PriceTable Constructor

[image]

A Sandcastle Documented Class Library
PriceTable Constructor
PriceTable Class See Also Send Feedback
Initializes a new instance of the PriceTable class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PriceTable()
Visual Basic
Public Sub New
Visual C++
public:
PriceTable()

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable Methods

[image] [image]

A Sandcastle Documented Class Library
PriceTable Methods
PriceTable Class See Also Send Feedback

The PriceTable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PriceTable Class
CelloSaaS.Billing.Model Namespace


PriceTable Properties

[image] [image]

A Sandcastle Documented Class Library
PriceTable Properties
PriceTable Class See Also Send Feedback

The PriceTable type exposes the following members.

Properties

 | Name | Description
Public property | ActedOnMeterVariable | Gets or Sets acted on meter variable
Public property | CalculationType | Gets or Sets calculation
Public property | FactorType | Gets or Sets factor type
Public property | FactorTypeValue | Gets or Sets factor type value
Public property | Id | Gets or Sets id
Public property | PriceSlabs | Gets or Sets price slabs collection
Public property | SlabMeterVariable | Gets or Sets slab meter variable

See Also

PriceTable Class
CelloSaaS.Billing.Model Namespace


PriceTable.ActedOnMeterVariable Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..ActedOnMeterVariable Property
PriceTable Class See Also Send Feedback
Gets or Sets acted on meter variable

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActedOnMeterVariable { get; set; }
Visual Basic
Public Property ActedOnMeterVariable As String
    Get
    Set
Visual C++
public:
property String^ ActedOnMeterVariable {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable.CalculationType Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..CalculationType Property
PriceTable Class See Also Send Feedback
Gets or Sets calculation

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CalculationType { get; set; }
Visual Basic
Public Property CalculationType As String
    Get
    Set
Visual C++
public:
property String^ CalculationType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable.FactorType Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..FactorType Property
PriceTable Class See Also Send Feedback
Gets or Sets factor type

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FactorType FactorType { get; set; }
Visual Basic
Public Property FactorType As FactorType
    Get
    Set
Visual C++
public:
property FactorType FactorType {
    FactorType get ();
    void set (FactorType value);
}

Property Value

Type: FactorType

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable.FactorTypeValue Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..FactorTypeValue Property
PriceTable Class See Also Send Feedback
Gets or Sets factor type value

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int FactorTypeValue { get; set; }
Visual Basic
Public Property FactorTypeValue As Integer
    Get
    Set
Visual C++
public:
property int FactorTypeValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable.Id Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..Id Property
PriceTable Class See Also Send Feedback
Gets or Sets id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable.PriceSlabs Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..PriceSlabs Property
PriceTable Class See Also Send Feedback
Gets or Sets price slabs collection

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<PriceSlab> PriceSlabs { get; set; }
Visual Basic
Public Property PriceSlabs As ICollection(Of PriceSlab)
    Get
    Set
Visual C++
public:
property ICollection<PriceSlab^>^ PriceSlabs {
    ICollection<PriceSlab^>^ get ();
    void set (ICollection<PriceSlab^>^ value);
}

Property Value

Type: ICollection<(Of <(<' PriceSlab >)>)>

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


PriceTable.SlabMeterVariable Property

[image]

A Sandcastle Documented Class Library
PriceTable..::..SlabMeterVariable Property
PriceTable Class See Also Send Feedback
Gets or Sets slab meter variable

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SlabMeterVariable { get; set; }
Visual Basic
Public Property SlabMeterVariable As String
    Get
    Set
Visual C++
public:
property String^ SlabMeterVariable {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PriceTable Class
PriceTable Members
CelloSaaS.Billing.Model Namespace


ShippingAddress Class

[image]

A Sandcastle Documented Class Library
ShippingAddress Class
Members See Also Send Feedback
Shipping address model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ShippingAddress
Visual Basic
<SerializableAttribute>
Public Class ShippingAddress
Visual C++
[SerializableAttribute]
public ref class ShippingAddress

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..ShippingAddress

See Also

ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress Members

[image] [image]

A Sandcastle Documented Class Library
ShippingAddress Members
ShippingAddress Class Constructors Methods Properties See Also Send Feedback

The ShippingAddress type exposes the following members.

Constructors

 | Name | Description
Public method | ShippingAddress | Initializes a new instance of the ShippingAddress class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | City | Gets or Sets City
Public property | Company | Gets or Sets Company
Public property | Country | Gets or Sets Country
Public property | Fax | Gets or Sets Fax
Public property | First | Gets or Sets First
Public property | Last | Gets or Sets Last
Public property | Phone | Gets or Sets Phone
Public property | State | Gets or Sets State
Public property | Street | Gets or Sets Street
Public property | Zip | Gets or Sets Zip

See Also

ShippingAddress Class
CelloSaaS.Billing.Model Namespace


ShippingAddress Constructor

[image]

A Sandcastle Documented Class Library
ShippingAddress Constructor
ShippingAddress Class See Also Send Feedback
Initializes a new instance of the ShippingAddress class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ShippingAddress()
Visual Basic
Public Sub New
Visual C++
public:
ShippingAddress()

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress Methods

[image] [image]

A Sandcastle Documented Class Library
ShippingAddress Methods
ShippingAddress Class See Also Send Feedback

The ShippingAddress type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ShippingAddress Class
CelloSaaS.Billing.Model Namespace


ShippingAddress Properties

[image] [image]

A Sandcastle Documented Class Library
ShippingAddress Properties
ShippingAddress Class See Also Send Feedback

The ShippingAddress type exposes the following members.

Properties

 | Name | Description
Public property | City | Gets or Sets City
Public property | Company | Gets or Sets Company
Public property | Country | Gets or Sets Country
Public property | Fax | Gets or Sets Fax
Public property | First | Gets or Sets First
Public property | Last | Gets or Sets Last
Public property | Phone | Gets or Sets Phone
Public property | State | Gets or Sets State
Public property | Street | Gets or Sets Street
Public property | Zip | Gets or Sets Zip

See Also

ShippingAddress Class
CelloSaaS.Billing.Model Namespace


ShippingAddress.City Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..City Property
ShippingAddress Class See Also Send Feedback
Gets or Sets City

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Company Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Company Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Company

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Company { get; set; }
Visual Basic
Public Property Company As String
    Get
    Set
Visual C++
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Country Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Country Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Country

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Country { get; set; }
Visual Basic
Public Property Country As String
    Get
    Set
Visual C++
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Fax Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Fax Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Fax

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set
Visual C++
public:
property String^ Fax {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.First Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..First Property
ShippingAddress Class See Also Send Feedback
Gets or Sets First

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string First { get; set; }
Visual Basic
Public Property First As String
    Get
    Set
Visual C++
public:
property String^ First {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Last Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Last Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Last

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Last { get; set; }
Visual Basic
Public Property Last As String
    Get
    Set
Visual C++
public:
property String^ Last {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Phone Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Phone Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Phone

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Phone { get; set; }
Visual Basic
Public Property Phone As String
    Get
    Set
Visual C++
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.State Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..State Property
ShippingAddress Class See Also Send Feedback
Gets or Sets State

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Street Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Street Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Street

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Street { get; set; }
Visual Basic
Public Property Street As String
    Get
    Set
Visual C++
public:
property String^ Street {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


ShippingAddress.Zip Property

[image]

A Sandcastle Documented Class Library
ShippingAddress..::..Zip Property
ShippingAddress Class See Also Send Feedback
Gets or Sets Zip

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Zip { get; set; }
Visual Basic
Public Property Zip As String
    Get
    Set
Visual C++
public:
property String^ Zip {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ShippingAddress Class
ShippingAddress Members
CelloSaaS.Billing.Model Namespace


TaxRate Class

[image]

A Sandcastle Documented Class Library
TaxRate Class
Members See Also Send Feedback
Tax rate model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaxRate
Visual Basic
<SerializableAttribute>
Public Class TaxRate
Visual C++
[SerializableAttribute]
public ref class TaxRate

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..TaxRate

See Also

TaxRate Members
CelloSaaS.Billing.Model Namespace


TaxRate Members

[image] [image]

A Sandcastle Documented Class Library
TaxRate Members
TaxRate Class Constructors Methods Properties See Also Send Feedback

The TaxRate type exposes the following members.

Constructors

 | Name | Description
Public method | TaxRate | Initializes a new instance of the TaxRate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets description
Public property | TaxRateId | Identifier
Public property | TenantId | Gets or sets tenant id
Public property | TenantTaxRates | Gets or sets tenant tax rates

See Also

TaxRate Class
CelloSaaS.Billing.Model Namespace


TaxRate Constructor

[image]

A Sandcastle Documented Class Library
TaxRate Constructor
TaxRate Class See Also Send Feedback
Initializes a new instance of the TaxRate class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaxRate()
Visual Basic
Public Sub New
Visual C++
public:
TaxRate()

See Also

TaxRate Class
TaxRate Members
CelloSaaS.Billing.Model Namespace


TaxRate Methods

[image] [image]

A Sandcastle Documented Class Library
TaxRate Methods
TaxRate Class See Also Send Feedback

The TaxRate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaxRate Class
CelloSaaS.Billing.Model Namespace


TaxRate Properties

[image] [image]

A Sandcastle Documented Class Library
TaxRate Properties
TaxRate Class See Also Send Feedback

The TaxRate type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets description
Public property | TaxRateId | Identifier
Public property | TenantId | Gets or sets tenant id
Public property | TenantTaxRates | Gets or sets tenant tax rates

See Also

TaxRate Class
CelloSaaS.Billing.Model Namespace


TaxRate.Description Property

[image]

A Sandcastle Documented Class Library
TaxRate..::..Description Property
TaxRate Class See Also Send Feedback
Gets or sets description

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaxRate Class
TaxRate Members
CelloSaaS.Billing.Model Namespace


TaxRate.TaxRateId Property

[image]

A Sandcastle Documented Class Library
TaxRate..::..TaxRateId Property
TaxRate Class See Also Send Feedback
Identifier

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TaxRateId { get; set; }
Visual Basic
Public Property TaxRateId As Guid
    Get
    Set
Visual C++
public:
property Guid TaxRateId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TaxRate Class
TaxRate Members
CelloSaaS.Billing.Model Namespace


TaxRate.TenantId Property

[image]

A Sandcastle Documented Class Library
TaxRate..::..TenantId Property
TaxRate Class See Also Send Feedback
Gets or sets tenant id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> TenantId { get; set; }
Visual Basic
Public Property TenantId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> TenantId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>

See Also

TaxRate Class
TaxRate Members
CelloSaaS.Billing.Model Namespace


TaxRate.TenantTaxRates Property

[image]

A Sandcastle Documented Class Library
TaxRate..::..TenantTaxRates Property
TaxRate Class See Also Send Feedback
Gets or sets tenant tax rates

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<TenantTaxRate> TenantTaxRates { get; set; }
Visual Basic
Public Property TenantTaxRates As ICollection(Of TenantTaxRate)
    Get
    Set
Visual C++
public:
property ICollection<TenantTaxRate^>^ TenantTaxRates {
    ICollection<TenantTaxRate^>^ get ();
    void set (ICollection<TenantTaxRate^>^ value);
}

Property Value

Type: ICollection<(Of <(<' TenantTaxRate >)>)>

See Also

TaxRate Class
TaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate Class

[image]

A Sandcastle Documented Class Library
TenantTaxRate Class
Members See Also Send Feedback
Tenant tax rate model

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantTaxRate
Visual Basic
<SerializableAttribute>
Public Class TenantTaxRate
Visual C++
[SerializableAttribute]
public ref class TenantTaxRate

Inheritance Hierarchy

System..::..Object
CelloSaaS.Billing.Model..::..TenantTaxRate

See Also

TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate Members

[image] [image]

A Sandcastle Documented Class Library
TenantTaxRate Members
TenantTaxRate Class Constructors Methods Properties See Also Send Feedback

The TenantTaxRate type exposes the following members.

Constructors

 | Name | Description
Public method | TenantTaxRate | Initializes a new instance of the TenantTaxRate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | Gets or sets description
Public property | Name | Gets or sets name
Public property | Percentage | Gets or sets percentage
Public property | TaxOrder | Gets or sets order
Public property | TaxRateId | Gets or sets taxrate id
Public property | TenantTaxRateId | Identifier

See Also

TenantTaxRate Class
CelloSaaS.Billing.Model Namespace


TenantTaxRate Constructor

[image]

A Sandcastle Documented Class Library
TenantTaxRate Constructor
TenantTaxRate Class See Also Send Feedback
Initializes a new instance of the TenantTaxRate class

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantTaxRate()
Visual Basic
Public Sub New
Visual C++
public:
TenantTaxRate()

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate Methods

[image] [image]

A Sandcastle Documented Class Library
TenantTaxRate Methods
TenantTaxRate Class See Also Send Feedback

The TenantTaxRate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantTaxRate Class
CelloSaaS.Billing.Model Namespace


TenantTaxRate Properties

[image] [image]

A Sandcastle Documented Class Library
TenantTaxRate Properties
TenantTaxRate Class See Also Send Feedback

The TenantTaxRate type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets or sets description
Public property | Name | Gets or sets name
Public property | Percentage | Gets or sets percentage
Public property | TaxOrder | Gets or sets order
Public property | TaxRateId | Gets or sets taxrate id
Public property | TenantTaxRateId | Identifier

See Also

TenantTaxRate Class
CelloSaaS.Billing.Model Namespace


TenantTaxRate.Description Property

[image]

A Sandcastle Documented Class Library
TenantTaxRate..::..Description Property
TenantTaxRate Class See Also Send Feedback
Gets or sets description

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate.Name Property

[image]

A Sandcastle Documented Class Library
TenantTaxRate..::..Name Property
TenantTaxRate Class See Also Send Feedback
Gets or sets name

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate.Percentage Property

[image]

A Sandcastle Documented Class Library
TenantTaxRate..::..Percentage Property
TenantTaxRate Class See Also Send Feedback
Gets or sets percentage

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Percentage { get; set; }
Visual Basic
Public Property Percentage As Double
    Get
    Set
Visual C++
public:
property double Percentage {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate.TaxOrder Property

[image]

A Sandcastle Documented Class Library
TenantTaxRate..::..TaxOrder Property
TenantTaxRate Class See Also Send Feedback
Gets or sets order

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public short TaxOrder { get; set; }
Visual Basic
Public Property TaxOrder As Short
    Get
    Set
Visual C++
public:
property short TaxOrder {
    short get ();
    void set (short value);
}

Property Value

Type: Int16

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate.TaxRateId Property

[image]

A Sandcastle Documented Class Library
TenantTaxRate..::..TaxRateId Property
TenantTaxRate Class See Also Send Feedback
Gets or sets taxrate id

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TaxRateId { get; set; }
Visual Basic
Public Property TaxRateId As Guid
    Get
    Set
Visual C++
public:
property Guid TaxRateId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


TenantTaxRate.TenantTaxRateId Property

[image]

A Sandcastle Documented Class Library
TenantTaxRate..::..TenantTaxRateId Property
TenantTaxRate Class See Also Send Feedback
Identifier

Namespace: CelloSaaS.Billing.Model
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantTaxRateId { get; set; }
Visual Basic
Public Property TenantTaxRateId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantTaxRateId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TenantTaxRate Class
TenantTaxRate Members
CelloSaaS.Billing.Model Namespace


CelloSaaS.Billing.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Billing.ServiceContracts Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | IBillingAuditService | Billing audit service interface
Public interface | IBillingPlanService | Tenant Package billing plans service contract
Public interface | IBillingService | Billing service interface
Public interface | IPaymentService | Bill payment service interface
Public interface | ITaxService | Tax service interface


IBillingAuditService Interface

[image]

A Sandcastle Documented Class Library
IBillingAuditService Interface
Members See Also Send Feedback
Billing audit service interface

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBillingAuditService
Visual Basic
Public Interface IBillingAuditService
Visual C++
public interface class IBillingAuditService

See Also

IBillingAuditService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingAuditService Members

[image] [image]

A Sandcastle Documented Class Library
IBillingAuditService Members
IBillingAuditService Interface Methods See Also Send Feedback

The IBillingAuditService type exposes the following members.

Methods

 | Name | Description
Public method | CreateAudit | Creates a new billing audit record
Public method | SearchBillAudits | Searches the billing audit according to the given search condition
Public method | UpdateAudit | Updates the billing audit record

See Also

IBillingAuditService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IBillingAuditService Methods

[image] [image]

A Sandcastle Documented Class Library
IBillingAuditService Methods
IBillingAuditService Interface See Also Send Feedback

The IBillingAuditService type exposes the following members.

Methods

 | Name | Description
Public method | CreateAudit | Creates a new billing audit record
Public method | SearchBillAudits | Searches the billing audit according to the given search condition
Public method | UpdateAudit | Updates the billing audit record

See Also

IBillingAuditService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IBillingAuditService.CreateAudit Method

[image]

A Sandcastle Documented Class Library
IBillingAuditService..::..CreateAudit Method
IBillingAuditService Interface See Also Send Feedback
Creates a new billing audit record

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid CreateAudit(
    BillingAudit entity
)
Visual Basic
Function CreateAudit (
    entity As BillingAudit
) As Guid
Visual C++
Guid CreateAudit(
    BillingAudit^ entity
)

Parameters

entity
Type: CelloSaaS.Billing.Model..::..BillingAudit
billing audit entity

Return Value

Type: Guid
returns newly created records primary key

See Also

IBillingAuditService Interface
IBillingAuditService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingAuditService.SearchBillAudits Method

[image]

A Sandcastle Documented Class Library
IBillingAuditService..::..SearchBillAudits Method
IBillingAuditService Interface See Also Send Feedback
Searches the billing audit according to the given search condition

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ICollection<BillingAudit> SearchBillAudits(
    BillingAuditSearchCondition searchCondition
)
Visual Basic
Function SearchBillAudits (
    searchCondition As BillingAuditSearchCondition
) As ICollection(Of BillingAudit)
Visual C++
ICollection<BillingAudit^>^ SearchBillAudits(
    BillingAuditSearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.Billing.Model..::..BillingAuditSearchCondition
billing audit search condition

Return Value

Type: ICollection<(Of <(<' BillingAudit >)>)>
retuns the filtered billing audit collection

See Also

IBillingAuditService Interface
IBillingAuditService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingAuditService.UpdateAudit Method

[image]

A Sandcastle Documented Class Library
IBillingAuditService..::..UpdateAudit Method
IBillingAuditService Interface See Also Send Feedback
Updates the billing audit record

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateAudit(
    BillingAudit entity
)
Visual Basic
Sub UpdateAudit (
    entity As BillingAudit
)
Visual C++
void UpdateAudit(
    BillingAudit^ entity
)

Parameters

entity
Type: CelloSaaS.Billing.Model..::..BillingAudit
billing audit entity

See Also

IBillingAuditService Interface
IBillingAuditService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService Interface

[image]

A Sandcastle Documented Class Library
IBillingPlanService Interface
Members See Also Send Feedback
Tenant Package billing plans service contract

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBillingPlanService
Visual Basic
Public Interface IBillingPlanService
Visual C++
public interface class IBillingPlanService

See Also

IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService Members

[image] [image]

A Sandcastle Documented Class Library
IBillingPlanService Members
IBillingPlanService Interface Methods See Also Send Feedback

The IBillingPlanService type exposes the following members.

Methods

 | Name | Description
Public method | AddPricePlan | Add a new package price plan
Public method | DeletePricePlan | Delete the package price plan
Public method | GetPricePlan | Get all price plans for the given package identifier
Public method | GetPricePlans | Get price plans for the given price plan identifiers
Public method | GetPricePlansByPackageId | Get price plan details for the given identifier
Public method | UpdatePricePlan | Update package price plan

See Also

IBillingPlanService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService Methods

[image] [image]

A Sandcastle Documented Class Library
IBillingPlanService Methods
IBillingPlanService Interface See Also Send Feedback

The IBillingPlanService type exposes the following members.

Methods

 | Name | Description
Public method | AddPricePlan | Add a new package price plan
Public method | DeletePricePlan | Delete the package price plan
Public method | GetPricePlan | Get all price plans for the given package identifier
Public method | GetPricePlans | Get price plans for the given price plan identifiers
Public method | GetPricePlansByPackageId | Get price plan details for the given identifier
Public method | UpdatePricePlan | Update package price plan

See Also

IBillingPlanService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService.AddPricePlan Method

[image]

A Sandcastle Documented Class Library
IBillingPlanService..::..AddPricePlan Method
IBillingPlanService Interface See Also Send Feedback
Add a new package price plan

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddPricePlan(
    PricePlan pricePlan
)
Visual Basic
Function AddPricePlan (
    pricePlan As PricePlan
) As Guid
Visual C++
Guid AddPricePlan(
    PricePlan^ pricePlan
)

Parameters

pricePlan
Type: CelloSaaS.Billing.Model..::..PricePlan
price plan details

Return Value

Type: Guid

See Also

IBillingPlanService Interface
IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService.DeletePricePlan Method

[image]

A Sandcastle Documented Class Library
IBillingPlanService..::..DeletePricePlan Method
IBillingPlanService Interface See Also Send Feedback
Delete the package price plan

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeletePricePlan(
    Guid pricePlanId,
    Guid tenantId
)
Visual Basic
Sub DeletePricePlan (
    pricePlanId As Guid,
    tenantId As Guid
)
Visual C++
void DeletePricePlan(
    Guid pricePlanId,
    Guid tenantId
)

Parameters

pricePlanId
Type: System..::..Guid
price plan identifier
tenantId
Type: System..::..Guid
tenant identifier

See Also

IBillingPlanService Interface
IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService.GetPricePlan Method

[image]

A Sandcastle Documented Class Library
IBillingPlanService..::..GetPricePlan Method
IBillingPlanService Interface See Also Send Feedback
Get all price plans for the given package identifier

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PricePlan GetPricePlan(
    Guid pricePlanId,
    Guid tenantId
)
Visual Basic
Function GetPricePlan (
    pricePlanId As Guid,
    tenantId As Guid
) As PricePlan
Visual C++
PricePlan^ GetPricePlan(
    Guid pricePlanId,
    Guid tenantId
)

Parameters

pricePlanId
Type: System..::..Guid
pricePlanId
tenantId
Type: System..::..Guid
tenant identifier

Return Value

Type: PricePlan

See Also

IBillingPlanService Interface
IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService.GetPricePlans Method

[image]

A Sandcastle Documented Class Library
IBillingPlanService..::..GetPricePlans Method
IBillingPlanService Interface See Also Send Feedback
Get price plans for the given price plan identifiers

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, PricePlan> GetPricePlans(
    Guid[] pricePlanIds,
    Guid tenantId
)
Visual Basic
Function GetPricePlans (
    pricePlanIds As Guid(),
    tenantId As Guid
) As Dictionary(Of Guid, PricePlan)
Visual C++
Dictionary<Guid, PricePlan^>^ GetPricePlans(
    array<Guid>^ pricePlanIds,
    Guid tenantId
)

Parameters

pricePlanIds
Type: array<System..::..Guid>[]()[][]
pricePlanIds
tenantId
Type: System..::..Guid
tenant identifier

Return Value

Type: Dictionary<(Of <(<'Guid, PricePlan >)>)>

See Also

IBillingPlanService Interface
IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService.GetPricePlansByPackageId Method

[image]

A Sandcastle Documented Class Library
IBillingPlanService..::..GetPricePlansByPackageId Method
IBillingPlanService Interface See Also Send Feedback
Get price plan details for the given identifier

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, PricePlan> GetPricePlansByPackageId(
    Guid packageId,
    Guid tenantId
)
Visual Basic
Function GetPricePlansByPackageId (
    packageId As Guid,
    tenantId As Guid
) As Dictionary(Of Guid, PricePlan)
Visual C++
Dictionary<Guid, PricePlan^>^ GetPricePlansByPackageId(
    Guid packageId,
    Guid tenantId
)

Parameters

packageId
Type: System..::..Guid
price plan details identifier
tenantId
Type: System..::..Guid
tenant identifier

Return Value

Type: Dictionary<(Of <(<'Guid, PricePlan >)>)>

See Also

IBillingPlanService Interface
IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingPlanService.UpdatePricePlan Method

[image]

A Sandcastle Documented Class Library
IBillingPlanService..::..UpdatePricePlan Method
IBillingPlanService Interface See Also Send Feedback
Update package price plan

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdatePricePlan(
    PricePlan pricePlan
)
Visual Basic
Sub UpdatePricePlan (
    pricePlan As PricePlan
)
Visual C++
void UpdatePricePlan(
    PricePlan^ pricePlan
)

Parameters

pricePlan
Type: CelloSaaS.Billing.Model..::..PricePlan
price plan details to update

See Also

IBillingPlanService Interface
IBillingPlanService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService Interface

[image]

A Sandcastle Documented Class Library
IBillingService Interface
Members See Also Send Feedback
Billing service interface

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBillingService
Visual Basic
Public Interface IBillingService
Visual C++
public interface class IBillingService

See Also

IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService Members

[image] [image]

A Sandcastle Documented Class Library
IBillingService Members
IBillingService Interface Methods See Also Send Feedback

The IBillingService type exposes the following members.

Methods

 | Name | Description
Public method | AddBillingSetting | Add billing setting
Public method | AddInvoiceLineItem | Add invoice line items
Public method | AddInvoicePayment | Add the given payment to the invoice
Public method | CreateInvoice | Create new invoice
Public method | DeleteBillingSetting | Deletes the given billing setting record
Public method | DeleteInvoice | Deletes the given invoice record
Public method | GetBillingSetting | Retrives the billing settings for the given bill frequency
Public method | GetBillStatistics | Returns the tenant wise bill statistics
Public method | GetCurrentInvoice | Generates the current invoice for the given tenant id
Public method | GetGlobalBillingSettings | Retrives all the global billing settings
Public method | GetInvoiceById | Returns the invoice details
Public method | GetRevnues | Get total bill revnues for the given date range
Public method | GetTenantOverdues | Get tenant overdue amounts
Public method | SearchInvoices | Searches the invoices (Current invoices are not searched!)
Public method | UpdateBillingSetting | Update billing setting
Public method | UpdateInvoice | Update invoice details
Public method | UpdateInvoiceMemo | Updated invoice notes

See Also

IBillingService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService Methods

[image] [image]

A Sandcastle Documented Class Library
IBillingService Methods
IBillingService Interface See Also Send Feedback

The IBillingService type exposes the following members.

Methods

 | Name | Description
Public method | AddBillingSetting | Add billing setting
Public method | AddInvoiceLineItem | Add invoice line items
Public method | AddInvoicePayment | Add the given payment to the invoice
Public method | CreateInvoice | Create new invoice
Public method | DeleteBillingSetting | Deletes the given billing setting record
Public method | DeleteInvoice | Deletes the given invoice record
Public method | GetBillingSetting | Retrives the billing settings for the given bill frequency
Public method | GetBillStatistics | Returns the tenant wise bill statistics
Public method | GetCurrentInvoice | Generates the current invoice for the given tenant id
Public method | GetGlobalBillingSettings | Retrives all the global billing settings
Public method | GetInvoiceById | Returns the invoice details
Public method | GetRevnues | Get total bill revnues for the given date range
Public method | GetTenantOverdues | Get tenant overdue amounts
Public method | SearchInvoices | Searches the invoices (Current invoices are not searched!)
Public method | UpdateBillingSetting | Update billing setting
Public method | UpdateInvoice | Update invoice details
Public method | UpdateInvoiceMemo | Updated invoice notes

See Also

IBillingService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.AddBillingSetting Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..AddBillingSetting Method
IBillingService Interface See Also Send Feedback
Add billing setting

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddBillingSetting(
    BillingSetting entity
)
Visual Basic
Function AddBillingSetting (
    entity As BillingSetting
) As Guid
Visual C++
Guid AddBillingSetting(
    BillingSetting^ entity
)

Parameters

entity
Type: CelloSaaS.Billing.Model..::..BillingSetting
bill setting object

Return Value

Type: Guid
Returns newly created records primary key

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.AddInvoiceLineItem Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..AddInvoiceLineItem Method
IBillingService Interface See Also Send Feedback
Add invoice line items

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddInvoiceLineItem(
    Guid invoiceId,
    Guid tenantId,
    List<InvoiceLineItem> lineItems
)
Visual Basic
Sub AddInvoiceLineItem (
    invoiceId As Guid,
    tenantId As Guid,
    lineItems As List(Of InvoiceLineItem)
)
Visual C++
void AddInvoiceLineItem(
    Guid invoiceId,
    Guid tenantId,
    List<InvoiceLineItem^>^ lineItems
)

Parameters

invoiceId
Type: System..::..Guid
invoice id
tenantId
Type: System..::..Guid
tenant id
lineItems
Type: System.Collections.Generic..::..List<(Of <(<' InvoiceLineItem >)>)>
line items

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.AddInvoicePayment Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..AddInvoicePayment Method
IBillingService Interface See Also Send Feedback
Add the given payment to the invoice

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddInvoicePayment(
    InvoicePayment payment
)
Visual Basic
Sub AddInvoicePayment (
    payment As InvoicePayment
)
Visual C++
void AddInvoicePayment(
    InvoicePayment^ payment
)

Parameters

payment
Type: CelloSaaS.Billing.Model..::..InvoicePayment
payment details

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.CreateInvoice Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..CreateInvoice Method
IBillingService Interface See Also Send Feedback
Create new invoice

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid CreateInvoice(
    Invoice entity
)
Visual Basic
Function CreateInvoice (
    entity As Invoice
) As Guid
Visual C++
Guid CreateInvoice(
    Invoice^ entity
)

Parameters

entity
Type: CelloSaaS.Billing.Model..::..Invoice
invoice entity

Return Value

Type: Guid

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.DeleteBillingSetting Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..DeleteBillingSetting Method
IBillingService Interface See Also Send Feedback
Deletes the given billing setting record

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteBillingSetting(
    Guid id,
    Guid tenantId
)
Visual Basic
Sub DeleteBillingSetting (
    id As Guid,
    tenantId As Guid
)
Visual C++
void DeleteBillingSetting(
    Guid id,
    Guid tenantId
)

Parameters

id
Type: System..::..Guid
billing setting primary key id
tenantId
Type: System..::..Guid
tenant id

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.DeleteInvoice Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..DeleteInvoice Method
IBillingService Interface See Also Send Feedback
Deletes the given invoice record

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteInvoice(
    Guid invoiceId,
    Guid tenantId
)
Visual Basic
Sub DeleteInvoice (
    invoiceId As Guid,
    tenantId As Guid
)
Visual C++
void DeleteInvoice(
    Guid invoiceId,
    Guid tenantId
)

Parameters

invoiceId
Type: System..::..Guid
invoice primary key
tenantId
Type: System..::..Guid
tenant id

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetBillingSetting Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetBillingSetting Method
IBillingService Interface See Also Send Feedback
Retrives the billing settings for the given bill frequency

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
BillingSetting GetBillingSetting(
    BillFrequency frequency,
    Guid tenantId
)
Visual Basic
Function GetBillingSetting (
    frequency As BillFrequency,
    tenantId As Guid
) As BillingSetting
Visual C++
BillingSetting^ GetBillingSetting(
    BillFrequency frequency,
    Guid tenantId
)

Parameters

frequency
Type: CelloSaaS.Billing.Model..::..BillFrequency
bill frequency
tenantId
Type: System..::..Guid
tenant id

Return Value

Type: BillingSetting
returns billing setting object if found

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetBillStatistics Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetBillStatistics Method
IBillingService Interface See Also Send Feedback
Returns the tenant wise bill statistics

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, BillStatistics> GetBillStatistics(
    BillStatisticsSearchCondition condition
)
Visual Basic
Function GetBillStatistics (
    condition As BillStatisticsSearchCondition
) As Dictionary(Of Guid, BillStatistics)
Visual C++
Dictionary<Guid, BillStatistics^>^ GetBillStatistics(
    BillStatisticsSearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.Billing.Model..::..BillStatisticsSearchCondition
search condition

Return Value

Type: Dictionary<(Of <(<'Guid, BillStatistics >)>)>
returns the bill statistics

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetCurrentInvoice Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetCurrentInvoice Method
IBillingService Interface See Also Send Feedback
Generates the current invoice for the given tenant id

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Invoice GetCurrentInvoice(
    Guid tenantId
)
Visual Basic
Function GetCurrentInvoice (
    tenantId As Guid
) As Invoice
Visual C++
Invoice^ GetCurrentInvoice(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid
tenant id (must be immediate child of product tenant)

Return Value

Type: Invoice
retuns the invoice details

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetGlobalBillingSettings Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetGlobalBillingSettings Method
IBillingService Interface See Also Send Feedback
Retrives all the global billing settings

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<BillingSetting> GetGlobalBillingSettings()
Visual Basic
Function GetGlobalBillingSettings As List(Of BillingSetting)
Visual C++
List<BillingSetting^>^ GetGlobalBillingSettings()

Return Value

Type: List<(Of <(<' BillingSetting >)>)>

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetInvoiceById Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetInvoiceById Method
IBillingService Interface See Also Send Feedback
Returns the invoice details

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Invoice GetInvoiceById(
    Guid id,
    Guid tenantId
)
Visual Basic
Function GetInvoiceById (
    id As Guid,
    tenantId As Guid
) As Invoice
Visual C++
Invoice^ GetInvoiceById(
    Guid id,
    Guid tenantId
)

Parameters

id
Type: System..::..Guid
invoice primary key
tenantId
Type: System..::..Guid
tenant id

Return Value

Type: Invoice
returns the invoice entity if found else null

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetRevnues Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetRevnues Method
IBillingService Interface See Also Send Feedback
Get total bill revnues for the given date range

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<DateTime, Tuple<int, double, double>> GetRevnues(
    Nullable<DateTime> fromDate,
    Nullable<DateTime> toDate,
    string childTenantId
)
Visual Basic
Function GetRevnues (
    fromDate As Nullable(Of DateTime),
    toDate As Nullable(Of DateTime),
    childTenantId As String
) As Dictionary(Of DateTime, Tuple(Of Integer, Double, Double))
Visual C++
Dictionary<DateTime, Tuple<int, double, double>^>^ GetRevnues(
    Nullable<DateTime> fromDate,
    Nullable<DateTime> toDate,
    String^ childTenantId
)

Parameters

fromDate
Type: System..::..Nullable<(Of <(<'DateTime>)>)>
from date(optional)
toDate
Type: System..::..Nullable<(Of <(<'DateTime>)>)>
to date(optional)
childTenantId
Type: System..::..String
child tenant id (optional)

Return Value

Type: Dictionary<(Of <(<'DateTime, Tuple<(Of <(<'Int32, Double, Double>)>)>>)>)>
date, (total bill amount,total paid)

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.GetTenantOverdues Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..GetTenantOverdues Method
IBillingService Interface See Also Send Feedback
Get tenant overdue amounts

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, double> GetTenantOverdues(
    Guid[] tenantIds
)
Visual Basic
Function GetTenantOverdues (
    tenantIds As Guid()
) As Dictionary(Of Guid, Double)
Visual C++
Dictionary<Guid, double>^ GetTenantOverdues(
    array<Guid>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..Guid>[]()[][]

Return Value

Type: Dictionary<(Of <(<'Guid, Double>)>)>

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.SearchInvoices Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..SearchInvoices Method
IBillingService Interface See Also Send Feedback
Searches the invoices (Current invoices are not searched!)

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
InvoiceSearchResult SearchInvoices(
    InvoiceSearchCondition condition
)
Visual Basic
Function SearchInvoices (
    condition As InvoiceSearchCondition
) As InvoiceSearchResult
Visual C++
InvoiceSearchResult^ SearchInvoices(
    InvoiceSearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.Billing.Model..::..InvoiceSearchCondition
search condition

Return Value

Type: InvoiceSearchResult

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.UpdateBillingSetting Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..UpdateBillingSetting Method
IBillingService Interface See Also Send Feedback
Update billing setting

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateBillingSetting(
    BillingSetting entity
)
Visual Basic
Sub UpdateBillingSetting (
    entity As BillingSetting
)
Visual C++
void UpdateBillingSetting(
    BillingSetting^ entity
)

Parameters

entity
Type: CelloSaaS.Billing.Model..::..BillingSetting
bill setting object

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.UpdateInvoice Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..UpdateInvoice Method
IBillingService Interface See Also Send Feedback
Update invoice details

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateInvoice(
    Invoice entity
)
Visual Basic
Sub UpdateInvoice (
    entity As Invoice
)
Visual C++
void UpdateInvoice(
    Invoice^ entity
)

Parameters

entity
Type: CelloSaaS.Billing.Model..::..Invoice
invoice entity

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IBillingService.UpdateInvoiceMemo Method

[image]

A Sandcastle Documented Class Library
IBillingService..::..UpdateInvoiceMemo Method
IBillingService Interface See Also Send Feedback
Updated invoice notes

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateInvoiceMemo(
    Guid invoiceId,
    Guid tenantId,
    string memo
)
Visual Basic
Sub UpdateInvoiceMemo (
    invoiceId As Guid,
    tenantId As Guid,
    memo As String
)
Visual C++
void UpdateInvoiceMemo(
    Guid invoiceId,
    Guid tenantId,
    String^ memo
)

Parameters

invoiceId
Type: System..::..Guid
invoice id
tenantId
Type: System..::..Guid
tenant id
memo
Type: System..::..String
memo

See Also

IBillingService Interface
IBillingService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService Interface

[image]

A Sandcastle Documented Class Library
IPaymentService Interface
Members See Also Send Feedback
Bill payment service interface

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IPaymentService
Visual Basic
Public Interface IPaymentService
Visual C++
public interface class IPaymentService

See Also

IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService Members

[image] [image]

A Sandcastle Documented Class Library
IPaymentService Members
IPaymentService Interface Methods See Also Send Feedback

The IPaymentService type exposes the following members.

Methods

 | Name | Description
Public method | CreateAccount | Creates payment account details
Public method | CreateApiAccount | Creates a payment api account
Public method | CreateAuthorizeNetCustomerProfile | Creates the tenant profile in Authorize.net
Public method | CreateCreditCardAccount | Creates a credit card account using authorize.net api
Public method | CreatePreapprovalRequest | Creates paypal preapproval request and returns the preapproval key
Public method | DeleteAccount | Deletes the payment account details of the tenant
Public method | DeleteApiAccount | Deletes the payment api account
Public method | GetAccountDetails | Get payment account details of the given tenant
Public method | GetAccountSetting | Get payment account setting associated with the given tenant
Public method | GetApiAccount | Get Payment API account for the given tenant and payment account type
Public method | GetApiAccounts | Get all the payment api accounts associated with the given tenant
Public method | GetAuthorizeNetHostedFormToken | Creates an unique token for using in Hosted Form customer payment profile
Public method | GetChildAccountSettings | Get child tenant payment account settings
Public method | Pay | Pays the given invoice
Public method | SaveAuthorizeNetPaymentProfile | Save the payment profile after redirect from authorize.net page
Public method | SearchPaymentAudits | Searchs the payment audit details
Public method | UpdateAccount | Updates the payment account details
Public method | UpdateApiAccount | Updates the payment api account

See Also

IPaymentService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService Methods

[image] [image]

A Sandcastle Documented Class Library
IPaymentService Methods
IPaymentService Interface See Also Send Feedback

The IPaymentService type exposes the following members.

Methods

 | Name | Description
Public method | CreateAccount | Creates payment account details
Public method | CreateApiAccount | Creates a payment api account
Public method | CreateAuthorizeNetCustomerProfile | Creates the tenant profile in Authorize.net
Public method | CreateCreditCardAccount | Creates a credit card account using authorize.net api
Public method | CreatePreapprovalRequest | Creates paypal preapproval request and returns the preapproval key
Public method | DeleteAccount | Deletes the payment account details of the tenant
Public method | DeleteApiAccount | Deletes the payment api account
Public method | GetAccountDetails | Get payment account details of the given tenant
Public method | GetAccountSetting | Get payment account setting associated with the given tenant
Public method | GetApiAccount | Get Payment API account for the given tenant and payment account type
Public method | GetApiAccounts | Get all the payment api accounts associated with the given tenant
Public method | GetAuthorizeNetHostedFormToken | Creates an unique token for using in Hosted Form customer payment profile
Public method | GetChildAccountSettings | Get child tenant payment account settings
Public method | Pay | Pays the given invoice
Public method | SaveAuthorizeNetPaymentProfile | Save the payment profile after redirect from authorize.net page
Public method | SearchPaymentAudits | Searchs the payment audit details
Public method | UpdateAccount | Updates the payment account details
Public method | UpdateApiAccount | Updates the payment api account

See Also

IPaymentService Interface
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.CreateAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..CreateAccount Method
IPaymentService Interface See Also Send Feedback
Creates payment account details

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CreateAccount(
    PaymentAccount account
)
Visual Basic
Sub CreateAccount (
    account As PaymentAccount
)
Visual C++
void CreateAccount(
    PaymentAccount^ account
)

Parameters

account
Type: CelloSaaS.Billing.Model..::..PaymentAccount
payment account

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.CreateApiAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..CreateApiAccount Method
IPaymentService Interface See Also Send Feedback
Creates a payment api account

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid CreateApiAccount(
    PaymentApiAccount account
)
Visual Basic
Function CreateApiAccount (
    account As PaymentApiAccount
) As Guid
Visual C++
Guid CreateApiAccount(
    PaymentApiAccount^ account
)

Parameters

account
Type: CelloSaaS.Billing.Model..::..PaymentApiAccount
payment api account

Return Value

Type: Guid

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.CreateAuthorizeNetCustomerProfile Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..CreateAuthorizeNetCustomerProfile Method
IPaymentService Interface See Also Send Feedback
Creates the tenant profile in Authorize.net

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreateAuthorizeNetCustomerProfile(
    Guid tenantId
)
Visual Basic
Function CreateAuthorizeNetCustomerProfile (
    tenantId As Guid
) As String
Visual C++
String^ CreateAuthorizeNetCustomerProfile(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid

Return Value

Type: String

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.CreateCreditCardAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..CreateCreditCardAccount Method
IPaymentService Interface See Also Send Feedback
Creates a credit card account using authorize.net api

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CreateCreditCardAccount(
    CreditCardAccount account
)
Visual Basic
Sub CreateCreditCardAccount (
    account As CreditCardAccount
)
Visual C++
void CreateCreditCardAccount(
    CreditCardAccount^ account
)

Parameters

account
Type: CelloSaaS.Billing.Model..::..CreditCardAccount
credit card account details

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.CreatePreapprovalRequest Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..CreatePreapprovalRequest Method
IPaymentService Interface See Also Send Feedback
Creates paypal preapproval request and returns the preapproval key

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PreapprovalResponse CreatePreapprovalRequest(
    PreapprovalRequest request
)
Visual Basic
Function CreatePreapprovalRequest (
    request As PreapprovalRequest
) As PreapprovalResponse
Visual C++
PreapprovalResponse^ CreatePreapprovalRequest(
    PreapprovalRequest^ request
)

Parameters

request
Type: CelloSaaS.Billing.Model..::..PreapprovalRequest
preapproval request details

Return Value

Type: PreapprovalResponse

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.DeleteAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..DeleteAccount Method
IPaymentService Interface See Also Send Feedback
Deletes the payment account details of the tenant

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteAccount(
    Guid tenantId
)
Visual Basic
Sub DeleteAccount (
    tenantId As Guid
)
Visual C++
void DeleteAccount(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid
tenant id

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.DeleteApiAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..DeleteApiAccount Method
IPaymentService Interface See Also Send Feedback
Deletes the payment api account

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteApiAccount(
    Guid tenantId,
    PaymentAccountType type
)
Visual Basic
Sub DeleteApiAccount (
    tenantId As Guid,
    type As PaymentAccountType
)
Visual C++
void DeleteApiAccount(
    Guid tenantId,
    PaymentAccountType type
)

Parameters

tenantId
Type: System..::..Guid
tenant id
type
Type: CelloSaaS.Billing.Model..::..PaymentAccountType
payment account type

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.GetAccountDetails Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..GetAccountDetails Method
IPaymentService Interface See Also Send Feedback
Get payment account details of the given tenant

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PaymentAccount GetAccountDetails(
    Guid tenantId
)
Visual Basic
Function GetAccountDetails (
    tenantId As Guid
) As PaymentAccount
Visual C++
PaymentAccount^ GetAccountDetails(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid
tenant id

Return Value

Type: PaymentAccount

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.GetAccountSetting Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..GetAccountSetting Method
IPaymentService Interface See Also Send Feedback
Get payment account setting associated with the given tenant

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PaymentAccountSetting GetAccountSetting(
    Guid tenantId
)
Visual Basic
Function GetAccountSetting (
    tenantId As Guid
) As PaymentAccountSetting
Visual C++
PaymentAccountSetting^ GetAccountSetting(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid
tenant id

Return Value

Type: PaymentAccountSetting

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.GetApiAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..GetApiAccount Method
IPaymentService Interface See Also Send Feedback
Get Payment API account for the given tenant and payment account type

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PaymentApiAccount GetApiAccount(
    Guid tenantId,
    PaymentAccountType type
)
Visual Basic
Function GetApiAccount (
    tenantId As Guid,
    type As PaymentAccountType
) As PaymentApiAccount
Visual C++
PaymentApiAccount^ GetApiAccount(
    Guid tenantId,
    PaymentAccountType type
)

Parameters

tenantId
Type: System..::..Guid
tenant id
type
Type: CelloSaaS.Billing.Model..::..PaymentAccountType
Payment account type

Return Value

Type: PaymentApiAccount

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.GetApiAccounts Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..GetApiAccounts Method
IPaymentService Interface See Also Send Feedback
Get all the payment api accounts associated with the given tenant

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, PaymentApiAccount> GetApiAccounts(
    Guid tenantId
)
Visual Basic
Function GetApiAccounts (
    tenantId As Guid
) As Dictionary(Of Guid, PaymentApiAccount)
Visual C++
Dictionary<Guid, PaymentApiAccount^>^ GetApiAccounts(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid
tenant id

Return Value

Type: Dictionary<(Of <(<'Guid, PaymentApiAccount >)>)>

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.GetAuthorizeNetHostedFormToken Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..GetAuthorizeNetHostedFormToken Method
IPaymentService Interface See Also Send Feedback
Creates an unique token for using in Hosted Form customer payment profile

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetAuthorizeNetHostedFormToken(
    Guid tenantId,
    string returnUrl,
    string returnUrlText
)
Visual Basic
Function GetAuthorizeNetHostedFormToken (
    tenantId As Guid,
    returnUrl As String,
    returnUrlText As String
) As String
Visual C++
String^ GetAuthorizeNetHostedFormToken(
    Guid tenantId,
    String^ returnUrl,
    String^ returnUrlText
)

Parameters

tenantId
Type: System..::..Guid
tenant id
returnUrl
Type: System..::..String
Return url
returnUrlText
Type: System..::..String
return url text

Return Value

Type: String

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.GetChildAccountSettings Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..GetChildAccountSettings Method
IPaymentService Interface See Also Send Feedback
Get child tenant payment account settings

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, PaymentAccountSetting> GetChildAccountSettings(
    Guid[] tenantIds
)
Visual Basic
Function GetChildAccountSettings (
    tenantIds As Guid()
) As Dictionary(Of Guid, PaymentAccountSetting)
Visual C++
Dictionary<Guid, PaymentAccountSetting^>^ GetChildAccountSettings(
    array<Guid>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..Guid>[]()[][]

Return Value

Type: Dictionary<(Of <(<'Guid, PaymentAccountSetting >)>)>

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.Pay Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..Pay Method
IPaymentService Interface See Also Send Feedback
Pays the given invoice

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
double Pay(
    Invoice invoiceDetails
)
Visual Basic
Function Pay (
    invoiceDetails As Invoice
) As Double
Visual C++
double Pay(
    Invoice^ invoiceDetails
)

Parameters

invoiceDetails
Type: CelloSaaS.Billing.Model..::..Invoice
invoice entity

Return Value

Type: Double

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.SaveAuthorizeNetPaymentProfile Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..SaveAuthorizeNetPaymentProfile Method
IPaymentService Interface See Also Send Feedback
Save the payment profile after redirect from authorize.net page

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveAuthorizeNetPaymentProfile(
    Guid tenantId
)
Visual Basic
Sub SaveAuthorizeNetPaymentProfile (
    tenantId As Guid
)
Visual C++
void SaveAuthorizeNetPaymentProfile(
    Guid tenantId
)

Parameters

tenantId
Type: System..::..Guid

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.SearchPaymentAudits Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..SearchPaymentAudits Method
IPaymentService Interface See Also Send Feedback
Searchs the payment audit details

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PaymentAuditSearchResult SearchPaymentAudits(
    PaymentAuditSearchCondition condition
)
Visual Basic
Function SearchPaymentAudits (
    condition As PaymentAuditSearchCondition
) As PaymentAuditSearchResult
Visual C++
PaymentAuditSearchResult^ SearchPaymentAudits(
    PaymentAuditSearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.Billing.Model..::..PaymentAuditSearchCondition
search condition

Return Value

Type: PaymentAuditSearchResult

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.UpdateAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..UpdateAccount Method
IPaymentService Interface See Also Send Feedback
Updates the payment account details

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateAccount(
    PaymentAccount account
)
Visual Basic
Sub UpdateAccount (
    account As PaymentAccount
)
Visual C++
void UpdateAccount(
    PaymentAccount^ account
)

Parameters

account
Type: CelloSaaS.Billing.Model..::..PaymentAccount
payment account

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


IPaymentService.UpdateApiAccount Method

[image]

A Sandcastle Documented Class Library
IPaymentService..::..UpdateApiAccount Method
IPaymentService Interface See Also Send Feedback
Updates the payment api account

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateApiAccount(
    PaymentApiAccount account
)
Visual Basic
Sub UpdateApiAccount (
    account As PaymentApiAccount
)
Visual C++
void UpdateApiAccount(
    PaymentApiAccount^ account
)

Parameters

account
Type: CelloSaaS.Billing.Model..::..PaymentApiAccount
payment api account

See Also

IPaymentService Interface
IPaymentService Members
CelloSaaS.Billing.ServiceContracts Namespace


ITaxService Interface

[image]

A Sandcastle Documented Class Library
ITaxService Interface
Members See Also Send Feedback
Tax service interface

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaxService
Visual Basic
Public Interface ITaxService
Visual C++
public interface class ITaxService

See Also

ITaxService Members
CelloSaaS.Billing.ServiceContracts Namespace


ITaxService Members

[image] [image]

A Sandcastle Documented Class Library
ITaxService Members
ITaxService Interface Methods See Also Send Feedback

The ITaxService type exposes the following members.

Methods

 | Name | Description
Public method | AddTaxRate | Add a new tax rate
Public method | GetTaxRateByTenantId | Get tax rate details for the given tenantId

See Also

ITaxService Interface
CelloSaaS.Billing.ServiceContracts Namespace


ITaxService Methods

[image] [image]

A Sandcastle Documented Class Library
ITaxService Methods
ITaxService Interface See Also Send Feedback

The ITaxService type exposes the following members.

Methods

 | Name | Description
Public method | AddTaxRate | Add a new tax rate
Public method | GetTaxRateByTenantId | Get tax rate details for the given tenantId

See Also

ITaxService Interface
CelloSaaS.Billing.ServiceContracts Namespace


ITaxService.AddTaxRate Method

[image]

A Sandcastle Documented Class Library
ITaxService..::..AddTaxRate Method
ITaxService Interface See Also Send Feedback
Add a new tax rate

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddTaxRate(
    TaxRate taxRate
)
Visual Basic
Function AddTaxRate (
    taxRate As TaxRate
) As Guid
Visual C++
Guid AddTaxRate(
    TaxRate^ taxRate
)

Parameters

taxRate
Type: CelloSaaS.Billing.Model..::..TaxRate
tax Rate details

Return Value

Type: Guid

See Also

ITaxService Interface
ITaxService Members
CelloSaaS.Billing.ServiceContracts Namespace


ITaxService.GetTaxRateByTenantId Method

[image]

A Sandcastle Documented Class Library
ITaxService..::..GetTaxRateByTenantId Method
ITaxService Interface See Also Send Feedback
Get tax rate details for the given tenantId

Namespace: CelloSaaS.Billing.ServiceContracts
Assembly: CelloSaaS.Billing (in CelloSaaS.Billing.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TaxRate GetTaxRateByTenantId(
    Nullable<Guid> tenantId
)
Visual Basic
Function GetTaxRateByTenantId (
    tenantId As Nullable(Of Guid)
) As TaxRate
Visual C++
TaxRate^ GetTaxRateByTenantId(
    Nullable<Guid> tenantId
)

Parameters

tenantId
Type: System..::..Nullable<(Of <(<'Guid>)>)>

Return Value

Type: TaxRate

See Also

ITaxService Interface
ITaxService Members
CelloSaaS.Billing.ServiceContracts Namespace


CelloSaaS.Constants.AccessControlManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Constants.AccessControlManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | ManageEntityPermissionUserEntityPermissionConstants | UserEntityPermission Constants


ManageEntityPermissionUserEntityPermissionConstants Class

[image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants Class
Members See Also Send Feedback
UserEntityPermission Constants

Namespace: CelloSaaS.Constants.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ManageEntityPermissionUserEntityPermissionConstants
Visual Basic
Public Class ManageEntityPermissionUserEntityPermissionConstants
Visual C++
public ref class ManageEntityPermissionUserEntityPermissionConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.Constants.AccessControlManagement..::..ManageEntityPermissionUserEntityPermissionConstants

See Also

ManageEntityPermissionUserEntityPermissionConstants Members
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants Members

[image] [image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants Members
ManageEntityPermissionUserEntityPermissionConstants Class Constructors Methods Fields See Also Send Feedback

The ManageEntityPermissionUserEntityPermissionConstants type exposes the following members.

Constructors

 | Name | Description
Public method | ManageEntityPermissionUserEntityPermissionConstants | Initializes a new instance of the ManageEntityPermissionUserEntityPermissionConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AddUserEntityPermission | Add entity permission
DeleteUserEntityPermission | Delete entity permission
EditUserEntityPermission | Edit entity permission
ViewUserEntityPermission | View entity permission

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants Constructor

[image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants Constructor
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback
Initializes a new instance of the ManageEntityPermissionUserEntityPermissionConstants class

Namespace: CelloSaaS.Constants.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ManageEntityPermissionUserEntityPermissionConstants()
Visual Basic
Public Sub New
Visual C++
public:
ManageEntityPermissionUserEntityPermissionConstants()

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
ManageEntityPermissionUserEntityPermissionConstants Members
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants Fields

[image] [image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants Fields
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback

The ManageEntityPermissionUserEntityPermissionConstants type exposes the following members.

Fields

Name | Description
AddUserEntityPermission | Add entity permission
DeleteUserEntityPermission | Delete entity permission
EditUserEntityPermission | Edit entity permission
ViewUserEntityPermission | View entity permission

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants.AddUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants..::..AddUserEntityPermission Field
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback
Add entity permission

Namespace: CelloSaaS.Constants.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddUserEntityPermission
Visual Basic
Public Const AddUserEntityPermission As String
Visual C++
public:
literal String^ AddUserEntityPermission

Field Value

Type: String

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
ManageEntityPermissionUserEntityPermissionConstants Members
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants.DeleteUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants..::..DeleteUserEntityPermission Field
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback
Delete entity permission

Namespace: CelloSaaS.Constants.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeleteUserEntityPermission
Visual Basic
Public Const DeleteUserEntityPermission As String
Visual C++
public:
literal String^ DeleteUserEntityPermission

Field Value

Type: String

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
ManageEntityPermissionUserEntityPermissionConstants Members
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants.EditUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants..::..EditUserEntityPermission Field
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback
Edit entity permission

Namespace: CelloSaaS.Constants.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditUserEntityPermission
Visual Basic
Public Const EditUserEntityPermission As String
Visual C++
public:
literal String^ EditUserEntityPermission

Field Value

Type: String

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
ManageEntityPermissionUserEntityPermissionConstants Members
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants.ViewUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants..::..ViewUserEntityPermission Field
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback
View entity permission

Namespace: CelloSaaS.Constants.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewUserEntityPermission
Visual Basic
Public Const ViewUserEntityPermission As String
Visual C++
public:
literal String^ ViewUserEntityPermission

Field Value

Type: String

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
ManageEntityPermissionUserEntityPermissionConstants Members
CelloSaaS.Constants.AccessControlManagement Namespace


ManageEntityPermissionUserEntityPermissionConstants Methods

[image] [image]

A Sandcastle Documented Class Library
ManageEntityPermissionUserEntityPermissionConstants Methods
ManageEntityPermissionUserEntityPermissionConstants Class See Also Send Feedback

The ManageEntityPermissionUserEntityPermissionConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ManageEntityPermissionUserEntityPermissionConstants Class
CelloSaaS.Constants.AccessControlManagement Namespace


CelloSaaS.DataBackup.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.DataBackup.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | BackupRequest | Backup request class
Public class | BackupRequestException | Backup request module exception
Public class | BackupRequestSearchCondition | Backup search condition class
Public class | BackupRequestSearchResult | Backup request search result class
Public class | ColumnDetails | Column details class
Public class | DBBackupDestination |
Public class | FileBackupDestination |
Public class | FTPDetails |
Public class | TableDetails | Table details

Interfaces

 | Interface | Description
Public interface | IBackupDestination | Backup destination interface

Enumerations

 | Enumeration | Description
Public enumeration | BackupDestinationType | Backup destination types
Public enumeration | BackupMode | Backup modes
Public enumeration | BackupStatus | Backup statuses
Public enumeration | ExportDataFormat | Export data format


BackupDestinationType Enumeration

[image]

A Sandcastle Documented Class Library
BackupDestinationType Enumeration
See Also Send Feedback
Backup destination types

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum BackupDestinationType
Visual Basic
<SerializableAttribute>
Public Enumeration BackupDestinationType
Visual C++
[SerializableAttribute]
public enum class BackupDestinationType

Members

Member name | Value | Description
Database | 0 | Database
File | 1 | File

See Also

CelloSaaS.DataBackup.Model Namespace


BackupMode Enumeration

[image]

A Sandcastle Documented Class Library
BackupMode Enumeration
See Also Send Feedback
Backup modes

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum BackupMode
Visual Basic
Public Enumeration BackupMode
Visual C++
public enum class BackupMode

Members

Member name | Value | Description
None | 0 | Tables without TenantId column will not be copied
Full | 1 | Copies common/master data also. Table with TenantId Column only the specied tenantId data will be copied.

See Also

CelloSaaS.DataBackup.Model Namespace


BackupRequest Class

[image]

A Sandcastle Documented Class Library
BackupRequest Class
Members See Also Send Feedback
Backup request class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BackupRequest
Visual Basic
Public Class BackupRequest
Visual C++
public ref class BackupRequest

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..BackupRequest

See Also

BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest Members

[image] [image]

A Sandcastle Documented Class Library
BackupRequest Members
BackupRequest Class Constructors Methods Properties See Also Send Feedback

The BackupRequest type exposes the following members.

Constructors

 | Name | Description
Public method | BackupRequest | Initializes a new instance of the BackupRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackupMode | Backup mode
Public property | BackupSize | Size of the backup of execution if file then total size in MB if database then database size in MB you should not set this
Public property | BackupStatus | Backup request status you should not set this
Public property | CompletedDate | Backup completed dated you should not set this
Public property | Description | Description of the backup request
Public property | DestinationDetails | Destination details
Public property | DestinationType | Backup destination type
Public property | ExceptionDetails | Exception details if the request encountered any execption when running. you should not set this
Public property | PrimaryTenantId | Primary tenant id for which data backup is initiated
Public property | RequestBy | Requested user id
Public property | RequestDate | Requested date
Public property | RequestId | Unique request id
Public property | Source | Source database connection string
Public property | StartDate | Backup start date you should not set this
Public property | TenantIds | Contains primary, child tenantids

See Also

BackupRequest Class
CelloSaaS.DataBackup.Model Namespace


BackupRequest Constructor

[image]

A Sandcastle Documented Class Library
BackupRequest Constructor
BackupRequest Class See Also Send Feedback
Initializes a new instance of the BackupRequest class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupRequest()
Visual Basic
Public Sub New
Visual C++
public:
BackupRequest()

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest Methods

[image] [image]

A Sandcastle Documented Class Library
BackupRequest Methods
BackupRequest Class See Also Send Feedback

The BackupRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BackupRequest Class
CelloSaaS.DataBackup.Model Namespace


BackupRequest Properties

[image] [image]

A Sandcastle Documented Class Library
BackupRequest Properties
BackupRequest Class See Also Send Feedback

The BackupRequest type exposes the following members.

Properties

 | Name | Description
Public property | BackupMode | Backup mode
Public property | BackupSize | Size of the backup of execution if file then total size in MB if database then database size in MB you should not set this
Public property | BackupStatus | Backup request status you should not set this
Public property | CompletedDate | Backup completed dated you should not set this
Public property | Description | Description of the backup request
Public property | DestinationDetails | Destination details
Public property | DestinationType | Backup destination type
Public property | ExceptionDetails | Exception details if the request encountered any execption when running. you should not set this
Public property | PrimaryTenantId | Primary tenant id for which data backup is initiated
Public property | RequestBy | Requested user id
Public property | RequestDate | Requested date
Public property | RequestId | Unique request id
Public property | Source | Source database connection string
Public property | StartDate | Backup start date you should not set this
Public property | TenantIds | Contains primary, child tenantids

See Also

BackupRequest Class
CelloSaaS.DataBackup.Model Namespace


BackupRequest.BackupMode Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..BackupMode Property
BackupRequest Class See Also Send Feedback
Backup mode

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupMode BackupMode { get; set; }
Visual Basic
Public Property BackupMode As BackupMode
    Get
    Set
Visual C++
public:
property BackupMode BackupMode {
    BackupMode get ();
    void set (BackupMode value);
}

Property Value

Type: BackupMode

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.BackupSize Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..BackupSize Property
BackupRequest Class See Also Send Feedback
Size of the backup of execution if file then total size in MB if database then database size in MB you should not set this

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double BackupSize { get; set; }
Visual Basic
Public Property BackupSize As Double
    Get
    Set
Visual C++
public:
property double BackupSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.BackupStatus Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..BackupStatus Property
BackupRequest Class See Also Send Feedback
Backup request status you should not set this

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupStatus BackupStatus { get; set; }
Visual Basic
Public Property BackupStatus As BackupStatus
    Get
    Set
Visual C++
public:
property BackupStatus BackupStatus {
    BackupStatus get ();
    void set (BackupStatus value);
}

Property Value

Type: BackupStatus

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.CompletedDate Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..CompletedDate Property
BackupRequest Class See Also Send Feedback
Backup completed dated you should not set this

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CompletedDate { get; set; }
Visual Basic
Public Property CompletedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime CompletedDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.Description Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..Description Property
BackupRequest Class See Also Send Feedback
Description of the backup request

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.DestinationDetails Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..DestinationDetails Property
BackupRequest Class See Also Send Feedback
Destination details

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IBackupDestination DestinationDetails { get; set; }
Visual Basic
Public Property DestinationDetails As IBackupDestination
    Get
    Set
Visual C++
public:
property IBackupDestination^ DestinationDetails {
    IBackupDestination^ get ();
    void set (IBackupDestination^ value);
}

Property Value

Type: IBackupDestination

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.DestinationType Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..DestinationType Property
BackupRequest Class See Also Send Feedback
Backup destination type

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupDestinationType DestinationType { get; set; }
Visual Basic
Public Property DestinationType As BackupDestinationType
    Get
    Set
Visual C++
public:
property BackupDestinationType DestinationType {
    BackupDestinationType get ();
    void set (BackupDestinationType value);
}

Property Value

Type: BackupDestinationType

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.ExceptionDetails Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..ExceptionDetails Property
BackupRequest Class See Also Send Feedback
Exception details if the request encountered any execption when running. you should not set this

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExceptionDetails { get; set; }
Visual Basic
Public Property ExceptionDetails As String
    Get
    Set
Visual C++
public:
property String^ ExceptionDetails {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.PrimaryTenantId Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..PrimaryTenantId Property
BackupRequest Class See Also Send Feedback
Primary tenant id for which data backup is initiated

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrimaryTenantId { get; set; }
Visual Basic
Public Property PrimaryTenantId As String
    Get
    Set
Visual C++
public:
property String^ PrimaryTenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.RequestBy Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..RequestBy Property
BackupRequest Class See Also Send Feedback
Requested user id

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RequestBy { get; set; }
Visual Basic
Public Property RequestBy As String
    Get
    Set
Visual C++
public:
property String^ RequestBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.RequestDate Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..RequestDate Property
BackupRequest Class See Also Send Feedback
Requested date

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime RequestDate { get; set; }
Visual Basic
Public Property RequestDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime RequestDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.RequestId Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..RequestId Property
BackupRequest Class See Also Send Feedback
Unique request id

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RequestId { get; set; }
Visual Basic
Public Property RequestId As String
    Get
    Set
Visual C++
public:
property String^ RequestId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.Source Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..Source Property
BackupRequest Class See Also Send Feedback
Source database connection string

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Source { get; set; }
Visual Basic
Public Property Source As String
    Get
    Set
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.StartDate Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..StartDate Property
BackupRequest Class See Also Send Feedback
Backup start date you should not set this

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequest.TenantIds Property

[image]

A Sandcastle Documented Class Library
BackupRequest..::..TenantIds Property
BackupRequest Class See Also Send Feedback
Contains primary, child tenantids

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ TenantIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

BackupRequest Class
BackupRequest Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Class

[image]

A Sandcastle Documented Class Library
BackupRequestException Class
Members See Also Send Feedback
Backup request module exception

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BackupRequestException : BaseException
Visual Basic
<SerializableAttribute>
Public Class BackupRequestException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class BackupRequestException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.DataBackup.Model..::..BackupRequestException

See Also

BackupRequestException Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Members

[image] [image]

A Sandcastle Documented Class Library
BackupRequestException Members
BackupRequestException Class Constructors Methods Properties Events See Also Send Feedback

The BackupRequestException type exposes the following members.

Constructors

 | Name | Description
Public method | BackupRequestException()()()() | Initializes a new instance of the BackupRequestException class.
Public method | BackupRequestException(String) | Initializes a new instance of the BackupRequestException class.
Protected method | BackupRequestException(SerializationInfo, StreamingContext) | Initializes a new instance of the BackupRequestException class.
Public method | BackupRequestException(String, Exception) | Initializes a new instance of the BackupRequestException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BackupRequestException Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Constructor

[image] [image]

A Sandcastle Documented Class Library
BackupRequestException Constructor
BackupRequestException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BackupRequestException()()()() | Initializes a new instance of the BackupRequestException class.
Public method | BackupRequestException(String) | Initializes a new instance of the BackupRequestException class.
Protected method | BackupRequestException(SerializationInfo, StreamingContext) | Initializes a new instance of the BackupRequestException class.
Public method | BackupRequestException(String, Exception) | Initializes a new instance of the BackupRequestException class.

See Also

BackupRequestException Class
BackupRequestException Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Constructor

[image]

A Sandcastle Documented Class Library
BackupRequestException Constructor
BackupRequestException Class See Also Send Feedback
Initializes a new instance of the BackupRequestException class.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupRequestException()
Visual Basic
Public Sub New
Visual C++
public:
BackupRequestException()

See Also

BackupRequestException Class
BackupRequestException Members
BackupRequestException Overload
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Constructor (String)

[image]

A Sandcastle Documented Class Library
BackupRequestException Constructor (String)
BackupRequestException Class See Also Send Feedback
Initializes a new instance of the BackupRequestException class.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupRequestException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
BackupRequestException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

BackupRequestException Class
BackupRequestException Members
BackupRequestException Overload
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
BackupRequestException Constructor (SerializationInfo, StreamingContext)
BackupRequestException Class See Also Send Feedback
Initializes a new instance of the BackupRequestException class.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected BackupRequestException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
BackupRequestException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

BackupRequestException Class
BackupRequestException Members
BackupRequestException Overload
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
BackupRequestException Constructor (String, Exception)
BackupRequestException Class See Also Send Feedback
Initializes a new instance of the BackupRequestException class.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupRequestException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
BackupRequestException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

BackupRequestException Class
BackupRequestException Members
BackupRequestException Overload
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Methods

[image] [image]

A Sandcastle Documented Class Library
BackupRequestException Methods
BackupRequestException Class See Also Send Feedback

The BackupRequestException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BackupRequestException Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Properties

[image] [image]

A Sandcastle Documented Class Library
BackupRequestException Properties
BackupRequestException Class See Also Send Feedback

The BackupRequestException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BackupRequestException Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestException Events

[image] [image]

A Sandcastle Documented Class Library
BackupRequestException Events
BackupRequestException Class See Also Send Feedback

The BackupRequestException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BackupRequestException Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition Class

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition Class
Members See Also Send Feedback
Backup search condition class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BackupRequestSearchCondition
Visual Basic
Public Class BackupRequestSearchCondition
Visual C++
public ref class BackupRequestSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..BackupRequestSearchCondition

See Also

BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition Members
BackupRequestSearchCondition Class Constructors Methods Properties See Also Send Feedback

The BackupRequestSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | BackupRequestSearchCondition | Initializes a new instance of the BackupRequestSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackupDestinationType | Gets or sets the type of the backup destination.
Public property | BackupMode | Gets or sets the backup mode.
Public property | BackupStatus | Gets or sets the backup status.
Public property | FromRequestDate | Gets or sets from request date.
Public property | PageNo | Gets or sets the page no.
Public property | PageSize | Gets or sets the size of the page.
Public property | PrimaryTenantId | Gets or sets the primary tenant id.
Public property | RequestIds | Gets or sets the request ids.
Public property | SortDirection | Gets or sets the sort direction.
Public property | SortString | Gets or sets the sort string.
Public property | ToRequestDate | Gets or sets to request date.

See Also

BackupRequestSearchCondition Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition Constructor
BackupRequestSearchCondition Class See Also Send Feedback
Initializes a new instance of the BackupRequestSearchCondition class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupRequestSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
BackupRequestSearchCondition()

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition Methods
BackupRequestSearchCondition Class See Also Send Feedback

The BackupRequestSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BackupRequestSearchCondition Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition Properties
BackupRequestSearchCondition Class See Also Send Feedback

The BackupRequestSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | BackupDestinationType | Gets or sets the type of the backup destination.
Public property | BackupMode | Gets or sets the backup mode.
Public property | BackupStatus | Gets or sets the backup status.
Public property | FromRequestDate | Gets or sets from request date.
Public property | PageNo | Gets or sets the page no.
Public property | PageSize | Gets or sets the size of the page.
Public property | PrimaryTenantId | Gets or sets the primary tenant id.
Public property | RequestIds | Gets or sets the request ids.
Public property | SortDirection | Gets or sets the sort direction.
Public property | SortString | Gets or sets the sort string.
Public property | ToRequestDate | Gets or sets to request date.

See Also

BackupRequestSearchCondition Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.BackupDestinationType Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..BackupDestinationType Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the type of the backup destination.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<BackupDestinationType> BackupDestinationType { get; set; }
Visual Basic
Public Property BackupDestinationType As Nullable(Of BackupDestinationType)
    Get
    Set
Visual C++
public:
property Nullable<BackupDestinationType> BackupDestinationType {
    Nullable<BackupDestinationType> get ();
    void set (Nullable<BackupDestinationType> value);
}

Property Value

Type: Nullable<(Of <(<' BackupDestinationType >)>)>
The type of the backup destination.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.BackupMode Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..BackupMode Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the backup mode.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<BackupMode> BackupMode { get; set; }
Visual Basic
Public Property BackupMode As Nullable(Of BackupMode)
    Get
    Set
Visual C++
public:
property Nullable<BackupMode> BackupMode {
    Nullable<BackupMode> get ();
    void set (Nullable<BackupMode> value);
}

Property Value

Type: Nullable<(Of <(<' BackupMode >)>)>
The backup mode.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.BackupStatus Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..BackupStatus Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the backup status.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<BackupStatus> BackupStatus { get; set; }
Visual Basic
Public Property BackupStatus As Nullable(Of BackupStatus)
    Get
    Set
Visual C++
public:
property Nullable<BackupStatus> BackupStatus {
    Nullable<BackupStatus> get ();
    void set (Nullable<BackupStatus> value);
}

Property Value

Type: Nullable<(Of <(<' BackupStatus >)>)>
The backup status.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.FromRequestDate Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..FromRequestDate Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets from request date.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromRequestDate { get; set; }
Visual Basic
Public Property FromRequestDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromRequestDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
From request date.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..PageNo Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the page no.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The page no.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..PageSize Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the size of the page.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The size of the page.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.PrimaryTenantId Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..PrimaryTenantId Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the primary tenant id.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrimaryTenantId { get; set; }
Visual Basic
Public Property PrimaryTenantId As String
    Get
    Set
Visual C++
public:
property String^ PrimaryTenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The primary tenant id.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.RequestIds Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..RequestIds Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the request ids.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] RequestIds { get; set; }
Visual Basic
Public Property RequestIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ RequestIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The request ids.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..SortDirection Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the sort direction.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort direction.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..SortString Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets the sort string.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort string.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchCondition.ToRequestDate Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchCondition..::..ToRequestDate Property
BackupRequestSearchCondition Class See Also Send Feedback
Gets or sets to request date.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToRequestDate { get; set; }
Visual Basic
Public Property ToRequestDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToRequestDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
To request date.

See Also

BackupRequestSearchCondition Class
BackupRequestSearchCondition Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult Class

[image]

A Sandcastle Documented Class Library
BackupRequestSearchResult Class
Members See Also Send Feedback
Backup request search result class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BackupRequestSearchResult
Visual Basic
Public Class BackupRequestSearchResult
Visual C++
public ref class BackupRequestSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..BackupRequestSearchResult

See Also

BackupRequestSearchResult Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
BackupRequestSearchResult Members
BackupRequestSearchResult Class Constructors Methods Properties See Also Send Feedback

The BackupRequestSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | BackupRequestSearchResult | Initializes a new instance of the BackupRequestSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

BackupRequestSearchResult Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult Constructor

[image]

A Sandcastle Documented Class Library
BackupRequestSearchResult Constructor
BackupRequestSearchResult Class See Also Send Feedback
Initializes a new instance of the BackupRequestSearchResult class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupRequestSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
BackupRequestSearchResult()

See Also

BackupRequestSearchResult Class
BackupRequestSearchResult Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
BackupRequestSearchResult Methods
BackupRequestSearchResult Class See Also Send Feedback

The BackupRequestSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BackupRequestSearchResult Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
BackupRequestSearchResult Properties
BackupRequestSearchResult Class See Also Send Feedback

The BackupRequestSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

BackupRequestSearchResult Class
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult.Result Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchResult..::..Result Property
BackupRequestSearchResult Class See Also Send Feedback
Gets or sets the result.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, BackupRequest> Result { get; set; }
Visual Basic
Public Property Result As Dictionary(Of String, BackupRequest)
    Get
    Set
Visual C++
public:
property Dictionary<String^, BackupRequest^>^ Result {
    Dictionary<String^, BackupRequest^>^ get ();
    void set (Dictionary<String^, BackupRequest^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, BackupRequest >)>)>
The result.

See Also

BackupRequestSearchResult Class
BackupRequestSearchResult Members
CelloSaaS.DataBackup.Model Namespace


BackupRequestSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
BackupRequestSearchResult..::..TotalCount Property
BackupRequestSearchResult Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

BackupRequestSearchResult Class
BackupRequestSearchResult Members
CelloSaaS.DataBackup.Model Namespace


BackupStatus Enumeration

[image]

A Sandcastle Documented Class Library
BackupStatus Enumeration
See Also Send Feedback
Backup statuses

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum BackupStatus
Visual Basic
Public Enumeration BackupStatus
Visual C++
public enum class BackupStatus

Members

Member name | Value | Description
New | 0 | The request is put to the queue and not yet processed.
Started | 1 | Backup has Started processing
Completed | 2 | Backup is completed
Canceled | 3 | The backup request is cancelled before processing
Errored | 4 | Error occured while processing

See Also

CelloSaaS.DataBackup.Model Namespace


ColumnDetails Class

[image]

A Sandcastle Documented Class Library
ColumnDetails Class
Members See Also Send Feedback
Column details class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ColumnDetails
Visual Basic
Public Class ColumnDetails
Visual C++
public ref class ColumnDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..ColumnDetails

See Also

ColumnDetails Members
CelloSaaS.DataBackup.Model Namespace


ColumnDetails Members

[image] [image]

A Sandcastle Documented Class Library
ColumnDetails Members
ColumnDetails Class Constructors Methods Properties See Also Send Feedback

The ColumnDetails type exposes the following members.

Constructors

 | Name | Description
Public method | ColumnDetails | Initializes a new instance of the ColumnDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataType | Gets or sets the type of the data.
Public property | Name | Gets or sets the name.

See Also

ColumnDetails Class
CelloSaaS.DataBackup.Model Namespace


ColumnDetails Constructor

[image]

A Sandcastle Documented Class Library
ColumnDetails Constructor
ColumnDetails Class See Also Send Feedback
Initializes a new instance of the ColumnDetails class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ColumnDetails()
Visual Basic
Public Sub New
Visual C++
public:
ColumnDetails()

See Also

ColumnDetails Class
ColumnDetails Members
CelloSaaS.DataBackup.Model Namespace


ColumnDetails Methods

[image] [image]

A Sandcastle Documented Class Library
ColumnDetails Methods
ColumnDetails Class See Also Send Feedback

The ColumnDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColumnDetails Class
CelloSaaS.DataBackup.Model Namespace


ColumnDetails Properties

[image] [image]

A Sandcastle Documented Class Library
ColumnDetails Properties
ColumnDetails Class See Also Send Feedback

The ColumnDetails type exposes the following members.

Properties

 | Name | Description
Public property | DataType | Gets or sets the type of the data.
Public property | Name | Gets or sets the name.

See Also

ColumnDetails Class
CelloSaaS.DataBackup.Model Namespace


ColumnDetails.DataType Property

[image]

A Sandcastle Documented Class Library
ColumnDetails..::..DataType Property
ColumnDetails Class See Also Send Feedback
Gets or sets the type of the data.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataType DataType { get; set; }
Visual Basic
Public Property DataType As DataType
    Get
    Set
Visual C++
public:
property DataType^ DataType {
    DataType^ get ();
    void set (DataType^ value);
}

Property Value

Type: DataType
The type of the data.

See Also

ColumnDetails Class
ColumnDetails Members
CelloSaaS.DataBackup.Model Namespace


ColumnDetails.Name Property

[image]

A Sandcastle Documented Class Library
ColumnDetails..::..Name Property
ColumnDetails Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

ColumnDetails Class
ColumnDetails Members
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination Class

[image]

A Sandcastle Documented Class Library
DBBackupDestination Class
Members See Also Send Feedback

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DBBackupDestination : IBackupDestination
Visual Basic
<SerializableAttribute>
Public Class DBBackupDestination
    Implements IBackupDestination
Visual C++
[SerializableAttribute]
public ref class DBBackupDestination : IBackupDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..DBBackupDestination

See Also

DBBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination Members

[image] [image]

A Sandcastle Documented Class Library
DBBackupDestination Members
DBBackupDestination Class Constructors Methods Properties See Also Send Feedback

The DBBackupDestination type exposes the following members.

Constructors

 | Name | Description
Public method | DBBackupDestination | Initializes a new instance of the DBBackupDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DBName | Gets or sets the name of the DB.
Public property | Password | Gets or sets the password.
Public property | ServerName | Gets or sets the name of the server.
Public property | UserName | Gets or sets the name of the user.

See Also

DBBackupDestination Class
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination Constructor

[image]

A Sandcastle Documented Class Library
DBBackupDestination Constructor
DBBackupDestination Class See Also Send Feedback
Initializes a new instance of the DBBackupDestination class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DBBackupDestination()
Visual Basic
Public Sub New
Visual C++
public:
DBBackupDestination()

See Also

DBBackupDestination Class
DBBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination Methods

[image] [image]

A Sandcastle Documented Class Library
DBBackupDestination Methods
DBBackupDestination Class See Also Send Feedback

The DBBackupDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DBBackupDestination Class
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination Properties

[image] [image]

A Sandcastle Documented Class Library
DBBackupDestination Properties
DBBackupDestination Class See Also Send Feedback

The DBBackupDestination type exposes the following members.

Properties

 | Name | Description
Public property | DBName | Gets or sets the name of the DB.
Public property | Password | Gets or sets the password.
Public property | ServerName | Gets or sets the name of the server.
Public property | UserName | Gets or sets the name of the user.

See Also

DBBackupDestination Class
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination.DBName Property

[image]

A Sandcastle Documented Class Library
DBBackupDestination..::..DBName Property
DBBackupDestination Class See Also Send Feedback
Gets or sets the name of the DB.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DBName { get; set; }
Visual Basic
Public Property DBName As String
    Get
    Set
Visual C++
public:
property String^ DBName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the DB.

See Also

DBBackupDestination Class
DBBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination.Password Property

[image]

A Sandcastle Documented Class Library
DBBackupDestination..::..Password Property
DBBackupDestination Class See Also Send Feedback
Gets or sets the password.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The password.

See Also

DBBackupDestination Class
DBBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination.ServerName Property

[image]

A Sandcastle Documented Class Library
DBBackupDestination..::..ServerName Property
DBBackupDestination Class See Also Send Feedback
Gets or sets the name of the server.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServerName { get; set; }
Visual Basic
Public Property ServerName As String
    Get
    Set
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the server.

See Also

DBBackupDestination Class
DBBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


DBBackupDestination.UserName Property

[image]

A Sandcastle Documented Class Library
DBBackupDestination..::..UserName Property
DBBackupDestination Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the user.

See Also

DBBackupDestination Class
DBBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


ExportDataFormat Enumeration

[image]

A Sandcastle Documented Class Library
ExportDataFormat Enumeration
See Also Send Feedback
Export data format

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum ExportDataFormat
Visual Basic
<SerializableAttribute>
Public Enumeration ExportDataFormat
Visual C++
[SerializableAttribute]
public enum class ExportDataFormat

Members

Member name | Value | Description
CSV | 0 |
XML | 1 |
SQL | 2 |

See Also

CelloSaaS.DataBackup.Model Namespace


FileBackupDestination Class

[image]

A Sandcastle Documented Class Library
FileBackupDestination Class
Members See Also Send Feedback

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FileBackupDestination : IBackupDestination
Visual Basic
<SerializableAttribute>
Public Class FileBackupDestination
    Implements IBackupDestination
Visual C++
[SerializableAttribute]
public ref class FileBackupDestination : IBackupDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..FileBackupDestination

See Also

FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination Members

[image] [image]

A Sandcastle Documented Class Library
FileBackupDestination Members
FileBackupDestination Class Constructors Methods Properties See Also Send Feedback

The FileBackupDestination type exposes the following members.

Constructors

 | Name | Description
Public method | FileBackupDestination | Initializes a new instance of the FileBackupDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataFormat | Gets or sets the data format.
Public property | FilePath | Gets or sets the file path.
Public property | FtpDetails | Gets or sets the FTP details.
Public property | UploadToFtp | Gets or sets a value indicating whether [upload to FTP].
Public property | ZipFiles | Gets or sets a value indicating whether [zip files].

See Also

FileBackupDestination Class
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination Constructor

[image]

A Sandcastle Documented Class Library
FileBackupDestination Constructor
FileBackupDestination Class See Also Send Feedback
Initializes a new instance of the FileBackupDestination class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FileBackupDestination()
Visual Basic
Public Sub New
Visual C++
public:
FileBackupDestination()

See Also

FileBackupDestination Class
FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination Methods

[image] [image]

A Sandcastle Documented Class Library
FileBackupDestination Methods
FileBackupDestination Class See Also Send Feedback

The FileBackupDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileBackupDestination Class
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination Properties

[image] [image]

A Sandcastle Documented Class Library
FileBackupDestination Properties
FileBackupDestination Class See Also Send Feedback

The FileBackupDestination type exposes the following members.

Properties

 | Name | Description
Public property | DataFormat | Gets or sets the data format.
Public property | FilePath | Gets or sets the file path.
Public property | FtpDetails | Gets or sets the FTP details.
Public property | UploadToFtp | Gets or sets a value indicating whether [upload to FTP].
Public property | ZipFiles | Gets or sets a value indicating whether [zip files].

See Also

FileBackupDestination Class
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination.DataFormat Property

[image]

A Sandcastle Documented Class Library
FileBackupDestination..::..DataFormat Property
FileBackupDestination Class See Also Send Feedback
Gets or sets the data format.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExportDataFormat DataFormat { get; set; }
Visual Basic
Public Property DataFormat As ExportDataFormat
    Get
    Set
Visual C++
public:
property ExportDataFormat DataFormat {
    ExportDataFormat get ();
    void set (ExportDataFormat value);
}

Property Value

Type: ExportDataFormat
The data format.

See Also

FileBackupDestination Class
FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination.FilePath Property

[image]

A Sandcastle Documented Class Library
FileBackupDestination..::..FilePath Property
FileBackupDestination Class See Also Send Feedback
Gets or sets the file path.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The file path.

See Also

FileBackupDestination Class
FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination.FtpDetails Property

[image]

A Sandcastle Documented Class Library
FileBackupDestination..::..FtpDetails Property
FileBackupDestination Class See Also Send Feedback
Gets or sets the FTP details.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FTPDetails FtpDetails { get; set; }
Visual Basic
Public Property FtpDetails As FTPDetails
    Get
    Set
Visual C++
public:
property FTPDetails^ FtpDetails {
    FTPDetails^ get ();
    void set (FTPDetails^ value);
}

Property Value

Type: FTPDetails
The FTP details.

See Also

FileBackupDestination Class
FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination.UploadToFtp Property

[image]

A Sandcastle Documented Class Library
FileBackupDestination..::..UploadToFtp Property
FileBackupDestination Class See Also Send Feedback
Gets or sets a value indicating whether [upload to FTP].

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool UploadToFtp { get; set; }
Visual Basic
Public Property UploadToFtp As Boolean
    Get
    Set
Visual C++
public:
property bool UploadToFtp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [upload to FTP]; otherwise, false.

See Also

FileBackupDestination Class
FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FileBackupDestination.ZipFiles Property

[image]

A Sandcastle Documented Class Library
FileBackupDestination..::..ZipFiles Property
FileBackupDestination Class See Also Send Feedback
Gets or sets a value indicating whether [zip files].

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool ZipFiles { get; set; }
Visual Basic
Public Property ZipFiles As Boolean
    Get
    Set
Visual C++
public:
property bool ZipFiles {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [zip files]; otherwise, false.

See Also

FileBackupDestination Class
FileBackupDestination Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails Class

[image]

A Sandcastle Documented Class Library
FTPDetails Class
Members See Also Send Feedback

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FTPDetails
Visual Basic
<SerializableAttribute>
Public Class FTPDetails
Visual C++
[SerializableAttribute]
public ref class FTPDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..FTPDetails

See Also

FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails Members

[image] [image]

A Sandcastle Documented Class Library
FTPDetails Members
FTPDetails Class Constructors Methods Properties See Also Send Feedback

The FTPDetails type exposes the following members.

Constructors

 | Name | Description
Public method | FTPDetails | Initializes a new instance of the FTPDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Password | Gets or sets the password.
Public property | Path | Gets or sets the path.
Public property | PortNo | Gets or sets the port no.
Public property | ServerName | Gets or sets the name of the server.
Public property | UserName | Gets or sets the name of the user.

See Also

FTPDetails Class
CelloSaaS.DataBackup.Model Namespace


FTPDetails Constructor

[image]

A Sandcastle Documented Class Library
FTPDetails Constructor
FTPDetails Class See Also Send Feedback
Initializes a new instance of the FTPDetails class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FTPDetails()
Visual Basic
Public Sub New
Visual C++
public:
FTPDetails()

See Also

FTPDetails Class
FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails Methods

[image] [image]

A Sandcastle Documented Class Library
FTPDetails Methods
FTPDetails Class See Also Send Feedback

The FTPDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FTPDetails Class
CelloSaaS.DataBackup.Model Namespace


FTPDetails Properties

[image] [image]

A Sandcastle Documented Class Library
FTPDetails Properties
FTPDetails Class See Also Send Feedback

The FTPDetails type exposes the following members.

Properties

 | Name | Description
Public property | Password | Gets or sets the password.
Public property | Path | Gets or sets the path.
Public property | PortNo | Gets or sets the port no.
Public property | ServerName | Gets or sets the name of the server.
Public property | UserName | Gets or sets the name of the user.

See Also

FTPDetails Class
CelloSaaS.DataBackup.Model Namespace


FTPDetails.Password Property

[image]

A Sandcastle Documented Class Library
FTPDetails..::..Password Property
FTPDetails Class See Also Send Feedback
Gets or sets the password.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The password.

See Also

FTPDetails Class
FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails.Path Property

[image]

A Sandcastle Documented Class Library
FTPDetails..::..Path Property
FTPDetails Class See Also Send Feedback
Gets or sets the path.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The path.

See Also

FTPDetails Class
FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails.PortNo Property

[image]

A Sandcastle Documented Class Library
FTPDetails..::..PortNo Property
FTPDetails Class See Also Send Feedback
Gets or sets the port no.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PortNo { get; set; }
Visual Basic
Public Property PortNo As Integer
    Get
    Set
Visual C++
public:
property int PortNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The port no.

See Also

FTPDetails Class
FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails.ServerName Property

[image]

A Sandcastle Documented Class Library
FTPDetails..::..ServerName Property
FTPDetails Class See Also Send Feedback
Gets or sets the name of the server.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServerName { get; set; }
Visual Basic
Public Property ServerName As String
    Get
    Set
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the server.

See Also

FTPDetails Class
FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


FTPDetails.UserName Property

[image]

A Sandcastle Documented Class Library
FTPDetails..::..UserName Property
FTPDetails Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the user.

See Also

FTPDetails Class
FTPDetails Members
CelloSaaS.DataBackup.Model Namespace


IBackupDestination Interface

[image]

A Sandcastle Documented Class Library
IBackupDestination Interface
See Also Send Feedback
Backup destination interface

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBackupDestination
Visual Basic
Public Interface IBackupDestination
Visual C++
public interface class IBackupDestination

See Also

CelloSaaS.DataBackup.Model Namespace


TableDetails Class

[image]

A Sandcastle Documented Class Library
TableDetails Class
Members See Also Send Feedback
Table details

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class TableDetails
Visual Basic
Public Class TableDetails
Visual C++
public ref class TableDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.Model..::..TableDetails

See Also

TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails Members

[image] [image]

A Sandcastle Documented Class Library
TableDetails Members
TableDetails Class Constructors Methods Properties See Also Send Feedback

The TableDetails type exposes the following members.

Constructors

 | Name | Description
Public method | TableDetails | Initializes a new instance of the TableDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Columns | Gets or sets the columns.
Public property | HasTenantIdColumn | Gets a value indicating whether this instance has tenant id column.
Public property | Name | Gets or sets the name.
Public property | Schema | Gets or sets the schema.
Public property | SchemaTableName | Gets the name of the schema table.
Public property | TenantIdColumnName | Gets or sets the name of the tenant id column.
Public property | Urn | Gets or sets the urn.

See Also

TableDetails Class
CelloSaaS.DataBackup.Model Namespace


TableDetails Constructor

[image]

A Sandcastle Documented Class Library
TableDetails Constructor
TableDetails Class See Also Send Feedback
Initializes a new instance of the TableDetails class

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TableDetails()
Visual Basic
Public Sub New
Visual C++
public:
TableDetails()

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails Methods

[image] [image]

A Sandcastle Documented Class Library
TableDetails Methods
TableDetails Class See Also Send Feedback

The TableDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableDetails Class
CelloSaaS.DataBackup.Model Namespace


TableDetails Properties

[image] [image]

A Sandcastle Documented Class Library
TableDetails Properties
TableDetails Class See Also Send Feedback

The TableDetails type exposes the following members.

Properties

 | Name | Description
Public property | Columns | Gets or sets the columns.
Public property | HasTenantIdColumn | Gets a value indicating whether this instance has tenant id column.
Public property | Name | Gets or sets the name.
Public property | Schema | Gets or sets the schema.
Public property | SchemaTableName | Gets the name of the schema table.
Public property | TenantIdColumnName | Gets or sets the name of the tenant id column.
Public property | Urn | Gets or sets the urn.

See Also

TableDetails Class
CelloSaaS.DataBackup.Model Namespace


TableDetails.Columns Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..Columns Property
TableDetails Class See Also Send Feedback
Gets or sets the columns.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IList<ColumnDetails> Columns { get; set; }
Visual Basic
Public Property Columns As IList(Of ColumnDetails)
    Get
    Set
Visual C++
public:
property IList<ColumnDetails^>^ Columns {
    IList<ColumnDetails^>^ get ();
    void set (IList<ColumnDetails^>^ value);
}

Property Value

Type: IList<(Of <(<' ColumnDetails >)>)>
The columns.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails.HasTenantIdColumn Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..HasTenantIdColumn Property
TableDetails Class See Also Send Feedback
Gets a value indicating whether this instance has tenant id column.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool HasTenantIdColumn { get; }
Visual Basic
Public ReadOnly Property HasTenantIdColumn As Boolean
    Get
Visual C++
public:
property bool HasTenantIdColumn {
    bool get ();
}

Property Value

Type: Boolean
true if this instance has tenant id column; otherwise, false.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails.Name Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..Name Property
TableDetails Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails.Schema Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..Schema Property
TableDetails Class See Also Send Feedback
Gets or sets the schema.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Schema { get; set; }
Visual Basic
Public Property Schema As String
    Get
    Set
Visual C++
public:
property String^ Schema {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The schema.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails.SchemaTableName Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..SchemaTableName Property
TableDetails Class See Also Send Feedback
Gets the name of the schema table.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SchemaTableName { get; }
Visual Basic
Public ReadOnly Property SchemaTableName As String
    Get
Visual C++
public:
property String^ SchemaTableName {
    String^ get ();
}

Property Value

Type: String
The name of the schema table.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails.TenantIdColumnName Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..TenantIdColumnName Property
TableDetails Class See Also Send Feedback
Gets or sets the name of the tenant id column.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantIdColumnName { get; set; }
Visual Basic
Public Property TenantIdColumnName As String
    Get
    Set
Visual C++
public:
property String^ TenantIdColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the tenant id column.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


TableDetails.Urn Property

[image]

A Sandcastle Documented Class Library
TableDetails..::..Urn Property
TableDetails Class See Also Send Feedback
Gets or sets the urn.

Namespace: CelloSaaS.DataBackup.Model
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Urn Urn { get; set; }
Visual Basic
Public Property Urn As Urn
    Get
    Set
Visual C++
public:
property Urn^ Urn {
    Urn^ get ();
    void set (Urn^ value);
}

Property Value

Type: Urn
The urn.

See Also

TableDetails Class
TableDetails Members
CelloSaaS.DataBackup.Model Namespace


CelloSaaS.DataBackup.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.DataBackup.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | BackupSetting | Contains backup settings

Interfaces

 | Interface | Description
Public interface | IBackupRequestService | Data Backup request service interface
Public interface | IBackupService | Backup service interface


BackupSetting Class

[image]

A Sandcastle Documented Class Library
BackupSetting Class
Members See Also Send Feedback
Contains backup settings

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BackupSetting
Visual Basic
Public Class BackupSetting
Visual C++
public ref class BackupSetting

Inheritance Hierarchy

System..::..Object
CelloSaaS.DataBackup.ServiceContracts..::..BackupSetting

See Also

BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting Members

[image] [image]

A Sandcastle Documented Class Library
BackupSetting Members
BackupSetting Class Constructors Methods Properties See Also Send Feedback

The BackupSetting type exposes the following members.

Constructors

 | Name | Description
Public method | BackupSetting | Initializes a new instance of the BackupSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackupProcessInterval | Gets or sets the backup process interval.
Public property | BatchSize | Gets or sets the size of the batch.
Public property | BulkCopyTimeout | Gets or sets the bulk copy timeout.
Public property | MaxParallelThread | Gets or sets the max parallel thread.
Public property | MaxTableParallelThread | Gets or sets the max table parallel thread.
Public property | NotifyAfter | Gets or sets the notify after no. of records processed.

See Also

BackupSetting Class
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting Constructor

[image]

A Sandcastle Documented Class Library
BackupSetting Constructor
BackupSetting Class See Also Send Feedback
Initializes a new instance of the BackupSetting class

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BackupSetting()
Visual Basic
Public Sub New
Visual C++
public:
BackupSetting()

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting Methods

[image] [image]

A Sandcastle Documented Class Library
BackupSetting Methods
BackupSetting Class See Also Send Feedback

The BackupSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BackupSetting Class
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting Properties

[image] [image]

A Sandcastle Documented Class Library
BackupSetting Properties
BackupSetting Class See Also Send Feedback

The BackupSetting type exposes the following members.

Properties

 | Name | Description
Public property | BackupProcessInterval | Gets or sets the backup process interval.
Public property | BatchSize | Gets or sets the size of the batch.
Public property | BulkCopyTimeout | Gets or sets the bulk copy timeout.
Public property | MaxParallelThread | Gets or sets the max parallel thread.
Public property | MaxTableParallelThread | Gets or sets the max table parallel thread.
Public property | NotifyAfter | Gets or sets the notify after no. of records processed.

See Also

BackupSetting Class
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting.BackupProcessInterval Property

[image]

A Sandcastle Documented Class Library
BackupSetting..::..BackupProcessInterval Property
BackupSetting Class See Also Send Feedback
Gets or sets the backup process interval.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public long BackupProcessInterval { get; set; }
Visual Basic
Public Property BackupProcessInterval As Long
    Get
    Set
Visual C++
public:
property long long BackupProcessInterval {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
The backup process interval.

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting.BatchSize Property

[image]

A Sandcastle Documented Class Library
BackupSetting..::..BatchSize Property
BackupSetting Class See Also Send Feedback
Gets or sets the size of the batch.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BatchSize { get; set; }
Visual Basic
Public Property BatchSize As Integer
    Get
    Set
Visual C++
public:
property int BatchSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The size of the batch.

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting.BulkCopyTimeout Property

[image]

A Sandcastle Documented Class Library
BackupSetting..::..BulkCopyTimeout Property
BackupSetting Class See Also Send Feedback
Gets or sets the bulk copy timeout.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BulkCopyTimeout { get; set; }
Visual Basic
Public Property BulkCopyTimeout As Integer
    Get
    Set
Visual C++
public:
property int BulkCopyTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The bulk copy timeout in milliseconds.

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting.MaxParallelThread Property

[image]

A Sandcastle Documented Class Library
BackupSetting..::..MaxParallelThread Property
BackupSetting Class See Also Send Feedback
Gets or sets the max parallel thread.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int MaxParallelThread { get; set; }
Visual Basic
Public Property MaxParallelThread As Integer
    Get
    Set
Visual C++
public:
property int MaxParallelThread {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The max parallel thread number.

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting.MaxTableParallelThread Property

[image]

A Sandcastle Documented Class Library
BackupSetting..::..MaxTableParallelThread Property
BackupSetting Class See Also Send Feedback
Gets or sets the max table parallel thread.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int MaxTableParallelThread { get; set; }
Visual Basic
Public Property MaxTableParallelThread As Integer
    Get
    Set
Visual C++
public:
property int MaxTableParallelThread {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The max table parallel thread number.

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


BackupSetting.NotifyAfter Property

[image]

A Sandcastle Documented Class Library
BackupSetting..::..NotifyAfter Property
BackupSetting Class See Also Send Feedback
Gets or sets the notify after no. of records processed.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int NotifyAfter { get; set; }
Visual Basic
Public Property NotifyAfter As Integer
    Get
    Set
Visual C++
public:
property int NotifyAfter {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
An integer value

See Also

BackupSetting Class
BackupSetting Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService Interface

[image]

A Sandcastle Documented Class Library
IBackupRequestService Interface
Members See Also Send Feedback
Data Backup request service interface

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBackupRequestService
Visual Basic
Public Interface IBackupRequestService
Visual C++
public interface class IBackupRequestService

See Also

IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService Members

[image] [image]

A Sandcastle Documented Class Library
IBackupRequestService Members
IBackupRequestService Interface Methods See Also Send Feedback

The IBackupRequestService type exposes the following members.

Methods

 | Name | Description
Public method | CancelBackupRequest | Cancels the backup request.
Public method | CreateBackupRequest | Creates the backup request.
Public method | GetBackupRequestDetails | Gets the backup request details.
Public method | SearchBackupRequest | Searches the backup request with the given search condition.
Public method | UpdateBackupRequest | Updates the backup request.
Public method | UpdateRequestStatus | Updates the request status.

See Also

IBackupRequestService Interface
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService Methods

[image] [image]

A Sandcastle Documented Class Library
IBackupRequestService Methods
IBackupRequestService Interface See Also Send Feedback

The IBackupRequestService type exposes the following members.

Methods

 | Name | Description
Public method | CancelBackupRequest | Cancels the backup request.
Public method | CreateBackupRequest | Creates the backup request.
Public method | GetBackupRequestDetails | Gets the backup request details.
Public method | SearchBackupRequest | Searches the backup request with the given search condition.
Public method | UpdateBackupRequest | Updates the backup request.
Public method | UpdateRequestStatus | Updates the request status.

See Also

IBackupRequestService Interface
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService.CancelBackupRequest Method

[image]

A Sandcastle Documented Class Library
IBackupRequestService..::..CancelBackupRequest Method
IBackupRequestService Interface See Also Send Feedback
Cancels the backup request.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CancelBackupRequest(
    string requestId
)
Visual Basic
Function CancelBackupRequest (
    requestId As String
) As Boolean
Visual C++
bool CancelBackupRequest(
    String^ requestId
)

Parameters

requestId
Type: System..::..String
The request id.

Return Value

Type: Boolean

Exceptions

Exception | Condition
System..::..ArgumentNullException | if the requestId is null or empty
CelloSaaS.DataBackup.Model..::..BackupRequestException | throws when any database related error occurred.

See Also

IBackupRequestService Interface
IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService.CreateBackupRequest Method

[image]

A Sandcastle Documented Class Library
IBackupRequestService..::..CreateBackupRequest Method
IBackupRequestService Interface See Also Send Feedback
Creates the backup request.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreateBackupRequest(
    BackupRequest request
)
Visual Basic
Function CreateBackupRequest (
    request As BackupRequest
) As String
Visual C++
String^ CreateBackupRequest(
    BackupRequest^ request
)

Parameters

request
Type: CelloSaaS.DataBackup.Model..::..BackupRequest
The request.

Return Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentException | throws when the request object contains invalid values
CelloSaaS.DataBackup.Model..::..BackupRequestException | throws when any database related error occurred.

See Also

IBackupRequestService Interface
IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService.GetBackupRequestDetails Method

[image]

A Sandcastle Documented Class Library
IBackupRequestService..::..GetBackupRequestDetails Method
IBackupRequestService Interface See Also Send Feedback
Gets the backup request details.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
BackupRequest GetBackupRequestDetails(
    string requestId
)
Visual Basic
Function GetBackupRequestDetails (
    requestId As String
) As BackupRequest
Visual C++
BackupRequest^ GetBackupRequestDetails(
    String^ requestId
)

Parameters

requestId
Type: System..::..String
The request id.

Return Value

Type: BackupRequest

Exceptions

Exception | Condition
System..::..ArgumentException | if the requestId is null or empty
CelloSaaS.DataBackup.Model..::..BackupRequestException | throws when any database related error occurred.

See Also

IBackupRequestService Interface
IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService.SearchBackupRequest Method

[image]

A Sandcastle Documented Class Library
IBackupRequestService..::..SearchBackupRequest Method
IBackupRequestService Interface See Also Send Feedback
Searches the backup request with the given search condition.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
BackupRequestSearchResult SearchBackupRequest(
    BackupRequestSearchCondition condition
)
Visual Basic
Function SearchBackupRequest (
    condition As BackupRequestSearchCondition
) As BackupRequestSearchResult
Visual C++
BackupRequestSearchResult^ SearchBackupRequest(
    BackupRequestSearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.DataBackup.Model..::..BackupRequestSearchCondition
The condition.

Return Value

Type: BackupRequestSearchResult

Exceptions

Exception | Condition
System..::..ArgumentNullException | if the search condition object is null.
CelloSaaS.DataBackup.Model..::..BackupRequestException | throws when any database related error occurred.

See Also

IBackupRequestService Interface
IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService.UpdateBackupRequest Method

[image]

A Sandcastle Documented Class Library
IBackupRequestService..::..UpdateBackupRequest Method
IBackupRequestService Interface See Also Send Feedback
Updates the backup request.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateBackupRequest(
    BackupRequest request
)
Visual Basic
Sub UpdateBackupRequest (
    request As BackupRequest
)
Visual C++
void UpdateBackupRequest(
    BackupRequest^ request
)

Parameters

request
Type: CelloSaaS.DataBackup.Model..::..BackupRequest
The request.

Exceptions

Exception | Condition
System..::..ArgumentException | throws when the request object contains invalid values
CelloSaaS.DataBackup.Model..::..BackupRequestException | throws when any database related error occurred.

See Also

IBackupRequestService Interface
IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupRequestService.UpdateRequestStatus Method

[image]

A Sandcastle Documented Class Library
IBackupRequestService..::..UpdateRequestStatus Method
IBackupRequestService Interface See Also Send Feedback
Updates the request status.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRequestStatus(
    string[] requestIds,
    BackupStatus backupStatus
)
Visual Basic
Sub UpdateRequestStatus (
    requestIds As String(),
    backupStatus As BackupStatus
)
Visual C++
void UpdateRequestStatus(
    array<String^>^ requestIds,
    BackupStatus backupStatus
)

Parameters

requestIds
Type: array<System..::..String>[]()[][]
The request ids.
backupStatus
Type: CelloSaaS.DataBackup.Model..::..BackupStatus
The backup status.

Exceptions

Exception | Condition
System..::..ArgumentException | if the requestIds is null or empty
CelloSaaS.DataBackup.Model..::..BackupRequestException | throws when any database related error occurred.

See Also

IBackupRequestService Interface
IBackupRequestService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupService Interface

[image]

A Sandcastle Documented Class Library
IBackupService Interface
Members See Also Send Feedback
Backup service interface

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBackupService
Visual Basic
Public Interface IBackupService
Visual C++
public interface class IBackupService

See Also

IBackupService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupService Members

[image] [image]

A Sandcastle Documented Class Library
IBackupService Members
IBackupService Interface Methods See Also Send Feedback

The IBackupService type exposes the following members.

Methods

 | Name | Description
Public method | Process | Processes the specified backup request.

See Also

IBackupService Interface
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupService Methods

[image] [image]

A Sandcastle Documented Class Library
IBackupService Methods
IBackupService Interface See Also Send Feedback

The IBackupService type exposes the following members.

Methods

 | Name | Description
Public method | Process | Processes the specified backup request.

See Also

IBackupService Interface
CelloSaaS.DataBackup.ServiceContracts Namespace


IBackupService.Process Method

[image]

A Sandcastle Documented Class Library
IBackupService..::..Process Method
IBackupService Interface See Also Send Feedback
Processes the specified backup request.

Namespace: CelloSaaS.DataBackup.ServiceContracts
Assembly: CelloSaaS.DataBackup (in CelloSaaS.DataBackup.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void Process(
    BackupRequest request,
    BackupSetting setting
)
Visual Basic
Sub Process (
    request As BackupRequest,
    setting As BackupSetting
)
Visual C++
void Process(
    BackupRequest^ request,
    BackupSetting^ setting
)

Parameters

request
Type: CelloSaaS.DataBackup.Model..::..BackupRequest
The request.
setting
Type: CelloSaaS.DataBackup.ServiceContracts..::..BackupSetting
The setting.

See Also

IBackupService Interface
IBackupService Members
CelloSaaS.DataBackup.ServiceContracts Namespace


CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace
Send Feedback

Classes

 | Class | Description
Public class | EventAuditServiceQueue |
Public class | EventSchedulerConstants | This class contain Event scheduler Constants
Public class | EventSchedulerException | Represents errors that occur during Event scheduler manager execution.


EventAuditServiceQueue Class

[image]

A Sandcastle Documented Class Library
EventAuditServiceQueue Class
Members See Also Send Feedback

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class EventAuditServiceQueue
Visual Basic
Public NotInheritable Class EventAuditServiceQueue
Visual C++
public ref class EventAuditServiceQueue abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.EventAuditSchedulerService..::..EventAuditServiceQueue

See Also

EventAuditServiceQueue Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventAuditServiceQueue Members

[image] [image]

A Sandcastle Documented Class Library
EventAuditServiceQueue Members
EventAuditServiceQueue Class Methods See Also Send Feedback

The EventAuditServiceQueue type exposes the following members.

Methods

Name | Description
FillEventSchedulerQueue | Gets a list of Event audit from the database and fills to the Event audit Queue.
Initialize | This method that will be called in order to initialize the class.

See Also

EventAuditServiceQueue Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventAuditServiceQueue Methods

[image] [image]

A Sandcastle Documented Class Library
EventAuditServiceQueue Methods
EventAuditServiceQueue Class See Also Send Feedback

The EventAuditServiceQueue type exposes the following members.

Methods

Name | Description
FillEventSchedulerQueue | Gets a list of Event audit from the database and fills to the Event audit Queue.
Initialize | This method that will be called in order to initialize the class.

See Also

EventAuditServiceQueue Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventAuditServiceQueue.FillEventSchedulerQueue Method

[image]

A Sandcastle Documented Class Library
EventAuditServiceQueue..::..FillEventSchedulerQueue Method
EventAuditServiceQueue Class See Also Send Feedback
Gets a list of Event audit from the database and fills to the Event audit Queue.

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void FillEventSchedulerQueue()
Visual Basic
Public Shared Sub FillEventSchedulerQueue
Visual C++
public:
static void FillEventSchedulerQueue()

See Also

EventAuditServiceQueue Class
EventAuditServiceQueue Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventAuditServiceQueue.Initialize Method

[image]

A Sandcastle Documented Class Library
EventAuditServiceQueue..::..Initialize Method
EventAuditServiceQueue Class See Also Send Feedback
This method that will be called in order to initialize the class.

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void Initialize()
Visual Basic
Public Shared Sub Initialize
Visual C++
public:
static void Initialize()

See Also

EventAuditServiceQueue Class
EventAuditServiceQueue Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants Class

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants Class
Members See Also Send Feedback
This class contain Event scheduler Constants

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class EventSchedulerConstants
Visual Basic
Public NotInheritable Class EventSchedulerConstants
Visual C++
public ref class EventSchedulerConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.EventAuditSchedulerService..::..EventSchedulerConstants

See Also

EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants Members

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerConstants Members
EventSchedulerConstants Class Fields See Also Send Feedback

The EventSchedulerConstants type exposes the following members.

Fields

Name | Description
BatchSize | Batch Size
DefaultBatchSize | Default Batch Size
DefaultFillQueueTime | Default Fill Queue Time
DefaultParallelThreadSize | Default Parallel Thread Size
DelayTimeAfterDispatch | Delay Time After Dispatch
FillQueueTime | Fill Queue Time
LogDispatchDetails | Log Event scheduler Performance
ParallelThreadSize | Parallel Thread Size

See Also

EventSchedulerConstants Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants Fields

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerConstants Fields
EventSchedulerConstants Class See Also Send Feedback

The EventSchedulerConstants type exposes the following members.

Fields

Name | Description
BatchSize | Batch Size
DefaultBatchSize | Default Batch Size
DefaultFillQueueTime | Default Fill Queue Time
DefaultParallelThreadSize | Default Parallel Thread Size
DelayTimeAfterDispatch | Delay Time After Dispatch
FillQueueTime | Fill Queue Time
LogDispatchDetails | Log Event scheduler Performance
ParallelThreadSize | Parallel Thread Size

See Also

EventSchedulerConstants Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.BatchSize Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..BatchSize Field
EventSchedulerConstants Class See Also Send Feedback
Batch Size

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BatchSize
Visual Basic
Public Const BatchSize As String
Visual C++
public:
literal String^ BatchSize

Field Value

Type: String

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.DefaultBatchSize Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..DefaultBatchSize Field
EventSchedulerConstants Class See Also Send Feedback
Default Batch Size

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultBatchSize
Visual Basic
Public Const DefaultBatchSize As Integer
Visual C++
public:
literal int DefaultBatchSize

Field Value

Type: Int32

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.DefaultFillQueueTime Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..DefaultFillQueueTime Field
EventSchedulerConstants Class See Also Send Feedback
Default Fill Queue Time

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultFillQueueTime
Visual Basic
Public Const DefaultFillQueueTime As Integer
Visual C++
public:
literal int DefaultFillQueueTime

Field Value

Type: Int32

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.DefaultParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..DefaultParallelThreadSize Field
EventSchedulerConstants Class See Also Send Feedback
Default Parallel Thread Size

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultParallelThreadSize
Visual Basic
Public Const DefaultParallelThreadSize As Integer
Visual C++
public:
literal int DefaultParallelThreadSize

Field Value

Type: Int32

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.DelayTimeAfterDispatch Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..DelayTimeAfterDispatch Field
EventSchedulerConstants Class See Also Send Feedback
Delay Time After Dispatch

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DelayTimeAfterDispatch
Visual Basic
Public Const DelayTimeAfterDispatch As Integer
Visual C++
public:
literal int DelayTimeAfterDispatch

Field Value

Type: Int32

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.FillQueueTime Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..FillQueueTime Field
EventSchedulerConstants Class See Also Send Feedback
Fill Queue Time

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string FillQueueTime
Visual Basic
Public Const FillQueueTime As String
Visual C++
public:
literal String^ FillQueueTime

Field Value

Type: String

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.LogDispatchDetails Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..LogDispatchDetails Field
EventSchedulerConstants Class See Also Send Feedback
Log Event scheduler Performance

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LogDispatchDetails
Visual Basic
Public Const LogDispatchDetails As String
Visual C++
public:
literal String^ LogDispatchDetails

Field Value

Type: String

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerConstants.ParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
EventSchedulerConstants..::..ParallelThreadSize Field
EventSchedulerConstants Class See Also Send Feedback
Parallel Thread Size

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ParallelThreadSize
Visual Basic
Public Const ParallelThreadSize As String
Visual C++
public:
literal String^ ParallelThreadSize

Field Value

Type: String

See Also

EventSchedulerConstants Class
EventSchedulerConstants Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Class

[image]

A Sandcastle Documented Class Library
EventSchedulerException Class
Members See Also Send Feedback
Represents errors that occur during Event scheduler manager execution.

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventSchedulerException : BaseException
Visual Basic
<SerializableAttribute>
Public Class EventSchedulerException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class EventSchedulerException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.EventAuditSchedulerService..::..EventSchedulerException

See Also

EventSchedulerException Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Members

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerException Members
EventSchedulerException Class Constructors Methods Properties Events See Also Send Feedback

The EventSchedulerException type exposes the following members.

Constructors

 | Name | Description
Public method | EventSchedulerException()()()() | Initializes a new instance of the [!:BatchManagerException] class.
Public method | EventSchedulerException(String) | Initializes a new instance of the [!:BatchManagerException] class with a specified error message.
Protected method | EventSchedulerException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventSchedulerException class
Public method | EventSchedulerException(String, Exception) | Initializes a new instance of the [!:BatchManagerException] class with a specified error message and a reference to the inner exception that is the cause of this exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventSchedulerException Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Constructor

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerException Constructor
EventSchedulerException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventSchedulerException()()()() | Initializes a new instance of the [!:BatchManagerException] class.
Public method | EventSchedulerException(String) | Initializes a new instance of the [!:BatchManagerException] class with a specified error message.
Protected method | EventSchedulerException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventSchedulerException class
Public method | EventSchedulerException(String, Exception) | Initializes a new instance of the [!:BatchManagerException] class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

EventSchedulerException Class
EventSchedulerException Members
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Constructor

[image]

A Sandcastle Documented Class Library
EventSchedulerException Constructor
EventSchedulerException Class See Also Send Feedback
Initializes a new instance of the [!:BatchManagerException] class.

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventSchedulerException()
Visual Basic
Public Sub New
Visual C++
public:
EventSchedulerException()

See Also

EventSchedulerException Class
EventSchedulerException Members
EventSchedulerException Overload
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Constructor (String)

[image]

A Sandcastle Documented Class Library
EventSchedulerException Constructor (String)
EventSchedulerException Class See Also Send Feedback
Initializes a new instance of the [!:BatchManagerException] class with a specified error message.

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventSchedulerException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
EventSchedulerException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

EventSchedulerException Class
EventSchedulerException Members
EventSchedulerException Overload
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
EventSchedulerException Constructor (SerializationInfo, StreamingContext)
EventSchedulerException Class See Also Send Feedback
Initializes a new instance of the EventSchedulerException class

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected EventSchedulerException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
EventSchedulerException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

EventSchedulerException Class
EventSchedulerException Members
EventSchedulerException Overload
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
EventSchedulerException Constructor (String, Exception)
EventSchedulerException Class See Also Send Feedback
Initializes a new instance of the [!:BatchManagerException] class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CelloSaaS.EventScheduler.EventAuditSchedulerService
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventSchedulerException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
EventSchedulerException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message that describes the error.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

EventSchedulerException Class
EventSchedulerException Members
EventSchedulerException Overload
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Methods

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerException Methods
EventSchedulerException Class See Also Send Feedback

The EventSchedulerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EventSchedulerException Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Properties

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerException Properties
EventSchedulerException Class See Also Send Feedback

The EventSchedulerException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EventSchedulerException Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


EventSchedulerException Events

[image] [image]

A Sandcastle Documented Class Library
EventSchedulerException Events
EventSchedulerException Class See Also Send Feedback

The EventSchedulerException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventSchedulerException Class
CelloSaaS.EventScheduler.EventAuditSchedulerService Namespace


CelloSaaS.EventScheduler.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.EventScheduler.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | EventAuditSearchCondition | This class defines activity even log parameters
Public class | EventAuditSearchResult | This class defines Event Audit Search Results
Public class | EventMetadata | The Event Meta data Class
Public class | EventSortStringConstants | Event Sort String Constants
Public class | EventTemplate | EventTemplate
Public class | EventTemplateException | EventTemplate Exception
Public class | EventTemplateSearchcondition | This class defines Event Template Search Parameters
Public class | Job | Jobs Class contains job name and type
Public class | JobAudit | The Job Audit class
Public class | JobAuditSearchCondition | This class defines/constructs the job audit details search parameters
Public class | JobAuditSearchResult | This class contains the job audit search result objects
Public class | JobParameters | Job Parameters
Public class | JobSearchCondition | This class defines/constructs the job details search parameters
Public class | Schedule | The Schedules class
Public class | ScheduleSearchCondition | This class defines/constructs the schedule details search parameters
Public class | WFJobParameter | WFJobParameter


EventAuditSearchCondition Class

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition Class
Members See Also Send Feedback
This class defines activity even log parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventAuditSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class EventAuditSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class EventAuditSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..EventAuditSearchCondition

See Also

EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
EventAuditSearchCondition Members
EventAuditSearchCondition Class Constructors Methods Properties See Also Send Feedback

The EventAuditSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | EventAuditSearchCondition | Initializes a new instance of the EventAuditSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityEventLogId | ActivityEventLogId
Public property | ActivityLogId | ActivityLogId
Public property | Condition | Condition
Public property | ContextId | ContextId
Public property | ContextType | ContextType
Public property | EventId | EventId
Public property | EventIds | EventIds
Public property | EventStatus | EventStatus
Public property | FromLogTime | FromLogTime
Public property | LocaleId | LocaleId
Public property | LogTime | LogTime
Public property | RecordEnd | RecordEnd
Public property | RecordStart | RecordStart
Public property | SetTotalCount | SetTotalCount
Public property | SortExpression | SortExpression
Public property | SortString | SortString
Public property | SubjectId | SubjectId
Public property | SubjectType | SubjectType
Public property | TargetId | TargetId
Public property | TargetType | TargetType
Public property | TenantId | TenantId
Public property | ToLogTime | ToLogTime
Public property | UserId | UserId

See Also

EventAuditSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition Constructor
EventAuditSearchCondition Class See Also Send Feedback
Initializes a new instance of the EventAuditSearchCondition class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventAuditSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
EventAuditSearchCondition()

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
EventAuditSearchCondition Methods
EventAuditSearchCondition Class See Also Send Feedback

The EventAuditSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EventAuditSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
EventAuditSearchCondition Properties
EventAuditSearchCondition Class See Also Send Feedback

The EventAuditSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | ActivityEventLogId | ActivityEventLogId
Public property | ActivityLogId | ActivityLogId
Public property | Condition | Condition
Public property | ContextId | ContextId
Public property | ContextType | ContextType
Public property | EventId | EventId
Public property | EventIds | EventIds
Public property | EventStatus | EventStatus
Public property | FromLogTime | FromLogTime
Public property | LocaleId | LocaleId
Public property | LogTime | LogTime
Public property | RecordEnd | RecordEnd
Public property | RecordStart | RecordStart
Public property | SetTotalCount | SetTotalCount
Public property | SortExpression | SortExpression
Public property | SortString | SortString
Public property | SubjectId | SubjectId
Public property | SubjectType | SubjectType
Public property | TargetId | TargetId
Public property | TargetType | TargetType
Public property | TenantId | TenantId
Public property | ToLogTime | ToLogTime
Public property | UserId | UserId

See Also

EventAuditSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.ActivityEventLogId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..ActivityEventLogId Property
EventAuditSearchCondition Class See Also Send Feedback
ActivityEventLogId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivityEventLogId { get; set; }
Visual Basic
Public Property ActivityEventLogId As String
    Get
    Set
Visual C++
public:
property String^ ActivityEventLogId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.ActivityLogId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..ActivityLogId Property
EventAuditSearchCondition Class See Also Send Feedback
ActivityLogId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivityLogId { get; set; }
Visual Basic
Public Property ActivityLogId As String
    Get
    Set
Visual C++
public:
property String^ ActivityLogId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..Condition Property
EventAuditSearchCondition Class See Also Send Feedback
Condition

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.ContextId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..ContextId Property
EventAuditSearchCondition Class See Also Send Feedback
ContextId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContextId { get; set; }
Visual Basic
Public Property ContextId As String
    Get
    Set
Visual C++
public:
property String^ ContextId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.ContextType Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..ContextType Property
EventAuditSearchCondition Class See Also Send Feedback
ContextType

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContextType { get; set; }
Visual Basic
Public Property ContextType As String
    Get
    Set
Visual C++
public:
property String^ ContextType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.EventId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..EventId Property
EventAuditSearchCondition Class See Also Send Feedback
EventId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.EventIds Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..EventIds Property
EventAuditSearchCondition Class See Also Send Feedback
EventIds

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] EventIds { get; set; }
Visual Basic
Public Property EventIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ EventIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.EventStatus Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..EventStatus Property
EventAuditSearchCondition Class See Also Send Feedback
EventStatus

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventStatus { get; set; }
Visual Basic
Public Property EventStatus As String
    Get
    Set
Visual C++
public:
property String^ EventStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.FromLogTime Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..FromLogTime Property
EventAuditSearchCondition Class See Also Send Feedback
FromLogTime

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromLogTime { get; set; }
Visual Basic
Public Property FromLogTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromLogTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.LocaleId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..LocaleId Property
EventAuditSearchCondition Class See Also Send Feedback
LocaleId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
property String^ LocaleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.LogTime Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..LogTime Property
EventAuditSearchCondition Class See Also Send Feedback
LogTime

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> LogTime { get; set; }
Visual Basic
Public Property LogTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> LogTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.RecordEnd Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..RecordEnd Property
EventAuditSearchCondition Class See Also Send Feedback
RecordEnd

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordEnd { get; set; }
Visual Basic
Public Property RecordEnd As Integer
    Get
    Set
Visual C++
public:
property int RecordEnd {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.RecordStart Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..RecordStart Property
EventAuditSearchCondition Class See Also Send Feedback
RecordStart

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordStart { get; set; }
Visual Basic
Public Property RecordStart As Integer
    Get
    Set
Visual C++
public:
property int RecordStart {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..SetTotalCount Property
EventAuditSearchCondition Class See Also Send Feedback
SetTotalCount

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Boolean
    Get
    Set
Visual C++
public:
property bool SetTotalCount {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.SortExpression Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..SortExpression Property
EventAuditSearchCondition Class See Also Send Feedback
SortExpression

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortExpression { get; set; }
Visual Basic
Public Property SortExpression As String
    Get
    Set
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..SortString Property
EventAuditSearchCondition Class See Also Send Feedback
SortString

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.SubjectId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..SubjectId Property
EventAuditSearchCondition Class See Also Send Feedback
SubjectId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SubjectId { get; set; }
Visual Basic
Public Property SubjectId As String
    Get
    Set
Visual C++
public:
property String^ SubjectId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.SubjectType Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..SubjectType Property
EventAuditSearchCondition Class See Also Send Feedback
SubjectType

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SubjectType { get; set; }
Visual Basic
Public Property SubjectType As String
    Get
    Set
Visual C++
public:
property String^ SubjectType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.TargetId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..TargetId Property
EventAuditSearchCondition Class See Also Send Feedback
TargetId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetId { get; set; }
Visual Basic
Public Property TargetId As String
    Get
    Set
Visual C++
public:
property String^ TargetId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.TargetType Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..TargetType Property
EventAuditSearchCondition Class See Also Send Feedback
TargetType

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetType { get; set; }
Visual Basic
Public Property TargetType As String
    Get
    Set
Visual C++
public:
property String^ TargetType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..TenantId Property
EventAuditSearchCondition Class See Also Send Feedback
TenantId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.ToLogTime Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..ToLogTime Property
EventAuditSearchCondition Class See Also Send Feedback
ToLogTime

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToLogTime { get; set; }
Visual Basic
Public Property ToLogTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToLogTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchCondition.UserId Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchCondition..::..UserId Property
EventAuditSearchCondition Class See Also Send Feedback
UserId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventAuditSearchCondition Class
EventAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult Class

[image]

A Sandcastle Documented Class Library
EventAuditSearchResult Class
Members See Also Send Feedback
This class defines Event Audit Search Results

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventAuditSearchResult
Visual Basic
<SerializableAttribute>
Public Class EventAuditSearchResult
Visual C++
[SerializableAttribute]
public ref class EventAuditSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..EventAuditSearchResult

See Also

EventAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
EventAuditSearchResult Members
EventAuditSearchResult Class Constructors Methods Properties See Also Send Feedback

The EventAuditSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | EventAuditSearchResult | Initializes a new instance of the EventAuditSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

EventAuditSearchResult Class
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult Constructor

[image]

A Sandcastle Documented Class Library
EventAuditSearchResult Constructor
EventAuditSearchResult Class See Also Send Feedback
Initializes a new instance of the EventAuditSearchResult class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventAuditSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
EventAuditSearchResult()

See Also

EventAuditSearchResult Class
EventAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
EventAuditSearchResult Methods
EventAuditSearchResult Class See Also Send Feedback

The EventAuditSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EventAuditSearchResult Class
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
EventAuditSearchResult Properties
EventAuditSearchResult Class See Also Send Feedback

The EventAuditSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

EventAuditSearchResult Class
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult.Result Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchResult..::..Result Property
EventAuditSearchResult Class See Also Send Feedback
Gets or sets the result.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Event> Result { get; set; }
Visual Basic
Public Property Result As Dictionary(Of String, Event)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Event^>^ Result {
    Dictionary<String^, Event^>^ get ();
    void set (Dictionary<String^, Event^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Event>)>)>
The result.

See Also

EventAuditSearchResult Class
EventAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


EventAuditSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
EventAuditSearchResult..::..TotalCount Property
EventAuditSearchResult Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

EventAuditSearchResult Class
EventAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata Class

[image]

A Sandcastle Documented Class Library
EventMetadata Class
Members See Also Send Feedback
The Event Meta data Class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventMetadata
Visual Basic
<SerializableAttribute>
Public Class EventMetadata
Visual C++
[SerializableAttribute]
public ref class EventMetadata

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..EventMetadata

See Also

EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata Members

[image] [image]

A Sandcastle Documented Class Library
EventMetadata Members
EventMetadata Class Constructors Methods Properties See Also Send Feedback

The EventMetadata type exposes the following members.

Constructors

 | Name | Description
Public method | EventMetadata | Initializes a new instance of the EventMetadata class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Description | Gets or sets the description.
Public property | EventId | Gets or sets the event id.
Public property | EventName | Gets or sets the name of the event.
Public property | Template | Template
Public property | TemplateId | Gets or sets the template id.
Public property | TenantId | Gets or sets the tenant id.

See Also

EventMetadata Class
CelloSaaS.EventScheduler.Model Namespace


EventMetadata Constructor

[image]

A Sandcastle Documented Class Library
EventMetadata Constructor
EventMetadata Class See Also Send Feedback
Initializes a new instance of the EventMetadata class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventMetadata()
Visual Basic
Public Sub New
Visual C++
public:
EventMetadata()

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata Methods

[image] [image]

A Sandcastle Documented Class Library
EventMetadata Methods
EventMetadata Class See Also Send Feedback

The EventMetadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EventMetadata Class
CelloSaaS.EventScheduler.Model Namespace


EventMetadata Properties

[image] [image]

A Sandcastle Documented Class Library
EventMetadata Properties
EventMetadata Class See Also Send Feedback

The EventMetadata type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | Description | Gets or sets the description.
Public property | EventId | Gets or sets the event id.
Public property | EventName | Gets or sets the name of the event.
Public property | Template | Template
Public property | TemplateId | Gets or sets the template id.
Public property | TenantId | Gets or sets the tenant id.

See Also

EventMetadata Class
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.Category Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..Category Property
EventMetadata Class See Also Send Feedback
Gets or sets the category.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The category.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.Description Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..Description Property
EventMetadata Class See Also Send Feedback
Gets or sets the description.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.EventId Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..EventId Property
EventMetadata Class See Also Send Feedback
Gets or sets the event id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The event id.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.EventName Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..EventName Property
EventMetadata Class See Also Send Feedback
Gets or sets the name of the event.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventName { get; set; }
Visual Basic
Public Property EventName As String
    Get
    Set
Visual C++
public:
property String^ EventName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the event.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.Template Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..Template Property
EventMetadata Class See Also Send Feedback
Template

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TemplateDetail Template { get; set; }
Visual Basic
Public Property Template As TemplateDetail
    Get
    Set
Visual C++
public:
property TemplateDetail^ Template {
    TemplateDetail^ get ();
    void set (TemplateDetail^ value);
}

Property Value

Type: TemplateDetail
The template.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.TemplateId Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..TemplateId Property
EventMetadata Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The template id.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventMetadata.TenantId Property

[image]

A Sandcastle Documented Class Library
EventMetadata..::..TenantId Property
EventMetadata Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

EventMetadata Class
EventMetadata Members
CelloSaaS.EventScheduler.Model Namespace


EventSortStringConstants Class

[image]

A Sandcastle Documented Class Library
EventSortStringConstants Class
Members See Also Send Feedback
Event Sort String Constants

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class EventSortStringConstants
Visual Basic
Public NotInheritable Class EventSortStringConstants
Visual C++
public ref class EventSortStringConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..EventSortStringConstants

See Also

EventSortStringConstants Members
CelloSaaS.EventScheduler.Model Namespace


EventSortStringConstants Members

[image] [image]

A Sandcastle Documented Class Library
EventSortStringConstants Members
EventSortStringConstants Class Fields See Also Send Feedback

The EventSortStringConstants type exposes the following members.

Fields

Name | Description
EventAuditCreatedOn | EventAudit CreatedOn
EventAuditEventStatus | EventAudit EventStatus
EventName | Event Name

See Also

EventSortStringConstants Class
CelloSaaS.EventScheduler.Model Namespace


EventSortStringConstants Fields

[image] [image]

A Sandcastle Documented Class Library
EventSortStringConstants Fields
EventSortStringConstants Class See Also Send Feedback

The EventSortStringConstants type exposes the following members.

Fields

Name | Description
EventAuditCreatedOn | EventAudit CreatedOn
EventAuditEventStatus | EventAudit EventStatus
EventName | Event Name

See Also

EventSortStringConstants Class
CelloSaaS.EventScheduler.Model Namespace


EventSortStringConstants.EventAuditCreatedOn Field

[image]

A Sandcastle Documented Class Library
EventSortStringConstants..::..EventAuditCreatedOn Field
EventSortStringConstants Class See Also Send Feedback
EventAudit CreatedOn

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EventAuditCreatedOn
Visual Basic
Public Const EventAuditCreatedOn As String
Visual C++
public:
literal String^ EventAuditCreatedOn

Field Value

Type: String

See Also

EventSortStringConstants Class
EventSortStringConstants Members
CelloSaaS.EventScheduler.Model Namespace


EventSortStringConstants.EventAuditEventStatus Field

[image]

A Sandcastle Documented Class Library
EventSortStringConstants..::..EventAuditEventStatus Field
EventSortStringConstants Class See Also Send Feedback
EventAudit EventStatus

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EventAuditEventStatus
Visual Basic
Public Const EventAuditEventStatus As String
Visual C++
public:
literal String^ EventAuditEventStatus

Field Value

Type: String

See Also

EventSortStringConstants Class
EventSortStringConstants Members
CelloSaaS.EventScheduler.Model Namespace


EventSortStringConstants.EventName Field

[image]

A Sandcastle Documented Class Library
EventSortStringConstants..::..EventName Field
EventSortStringConstants Class See Also Send Feedback
Event Name

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EventName
Visual Basic
Public Const EventName As String
Visual C++
public:
literal String^ EventName

Field Value

Type: String

See Also

EventSortStringConstants Class
EventSortStringConstants Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplate Class

[image]

A Sandcastle Documented Class Library
EventTemplate Class
Members See Also Send Feedback
EventTemplate

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventTemplate
Visual Basic
<SerializableAttribute>
Public Class EventTemplate
Visual C++
[SerializableAttribute]
public ref class EventTemplate

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..EventTemplate

See Also

EventTemplate Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplate Members

[image] [image]

A Sandcastle Documented Class Library
EventTemplate Members
EventTemplate Class Constructors Methods Properties See Also Send Feedback

The EventTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | EventTemplate | Initializes a new instance of the EventTemplate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventId | Gets or sets the event id.
Public property | EventTemplateId | Gets or sets the event template id.
Public property | TemplateId | Gets or sets the template id.
Public property | TenantId | Gets or sets the tenant id.

See Also

EventTemplate Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplate Constructor

[image]

A Sandcastle Documented Class Library
EventTemplate Constructor
EventTemplate Class See Also Send Feedback
Initializes a new instance of the EventTemplate class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventTemplate()
Visual Basic
Public Sub New
Visual C++
public:
EventTemplate()

See Also

EventTemplate Class
EventTemplate Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
EventTemplate Methods
EventTemplate Class See Also Send Feedback

The EventTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EventTemplate Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
EventTemplate Properties
EventTemplate Class See Also Send Feedback

The EventTemplate type exposes the following members.

Properties

 | Name | Description
Public property | EventId | Gets or sets the event id.
Public property | EventTemplateId | Gets or sets the event template id.
Public property | TemplateId | Gets or sets the template id.
Public property | TenantId | Gets or sets the tenant id.

See Also

EventTemplate Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplate.EventId Property

[image]

A Sandcastle Documented Class Library
EventTemplate..::..EventId Property
EventTemplate Class See Also Send Feedback
Gets or sets the event id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The event id.

See Also

EventTemplate Class
EventTemplate Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplate.EventTemplateId Property

[image]

A Sandcastle Documented Class Library
EventTemplate..::..EventTemplateId Property
EventTemplate Class See Also Send Feedback
Gets or sets the event template id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventTemplateId { get; set; }
Visual Basic
Public Property EventTemplateId As String
    Get
    Set
Visual C++
public:
property String^ EventTemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The event template id.

See Also

EventTemplate Class
EventTemplate Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
EventTemplate..::..TemplateId Property
EventTemplate Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The template id.

See Also

EventTemplate Class
EventTemplate Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplate.TenantId Property

[image]

A Sandcastle Documented Class Library
EventTemplate..::..TenantId Property
EventTemplate Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

EventTemplate Class
EventTemplate Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Class

[image]

A Sandcastle Documented Class Library
EventTemplateException Class
Members See Also Send Feedback
EventTemplate Exception

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventTemplateException : BaseException
Visual Basic
<SerializableAttribute>
Public Class EventTemplateException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class EventTemplateException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.Model..::..EventTemplateException

See Also

EventTemplateException Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Members

[image] [image]

A Sandcastle Documented Class Library
EventTemplateException Members
EventTemplateException Class Constructors Methods Properties Events See Also Send Feedback

The EventTemplateException type exposes the following members.

Constructors

 | Name | Description
Public method | EventTemplateException()()()() | EventTemplateException
Public method | EventTemplateException(String) | EventTemplateException with message
Protected method | EventTemplateException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventTemplateException class.
Public method | EventTemplateException(String, Exception) | EventTemplateException with message and inner exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventTemplateException Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Constructor

[image] [image]

A Sandcastle Documented Class Library
EventTemplateException Constructor
EventTemplateException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventTemplateException()()()() | EventTemplateException
Public method | EventTemplateException(String) | EventTemplateException with message
Protected method | EventTemplateException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventTemplateException class.
Public method | EventTemplateException(String, Exception) | EventTemplateException with message and inner exception

See Also

EventTemplateException Class
EventTemplateException Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Constructor

[image]

A Sandcastle Documented Class Library
EventTemplateException Constructor
EventTemplateException Class See Also Send Feedback
EventTemplateException

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventTemplateException()
Visual Basic
Public Sub New
Visual C++
public:
EventTemplateException()

See Also

EventTemplateException Class
EventTemplateException Members
EventTemplateException Overload
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Constructor (String)

[image]

A Sandcastle Documented Class Library
EventTemplateException Constructor (String)
EventTemplateException Class See Also Send Feedback
EventTemplateException with message

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventTemplateException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
EventTemplateException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

EventTemplateException Class
EventTemplateException Members
EventTemplateException Overload
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
EventTemplateException Constructor (SerializationInfo, StreamingContext)
EventTemplateException Class See Also Send Feedback
Initializes a new instance of the EventTemplateException class.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected EventTemplateException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
EventTemplateException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

EventTemplateException Class
EventTemplateException Members
EventTemplateException Overload
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
EventTemplateException Constructor (String, Exception)
EventTemplateException Class See Also Send Feedback
EventTemplateException with message and inner exception

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventTemplateException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
EventTemplateException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
message
innerException
Type: System..::..Exception
innerException

See Also

EventTemplateException Class
EventTemplateException Members
EventTemplateException Overload
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Methods

[image] [image]

A Sandcastle Documented Class Library
EventTemplateException Methods
EventTemplateException Class See Also Send Feedback

The EventTemplateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EventTemplateException Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Properties

[image] [image]

A Sandcastle Documented Class Library
EventTemplateException Properties
EventTemplateException Class See Also Send Feedback

The EventTemplateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EventTemplateException Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateException Events

[image] [image]

A Sandcastle Documented Class Library
EventTemplateException Events
EventTemplateException Class See Also Send Feedback

The EventTemplateException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventTemplateException Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition Class

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition Class
Members See Also Send Feedback
This class defines Event Template Search Parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventTemplateSearchcondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class EventTemplateSearchcondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class EventTemplateSearchcondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..EventTemplateSearchcondition

See Also

EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition Members

[image] [image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition Members
EventTemplateSearchcondition Class Constructors Methods Properties See Also Send Feedback

The EventTemplateSearchcondition type exposes the following members.

Constructors

 | Name | Description
Public method | EventTemplateSearchcondition | Initializes a new instance of the EventTemplateSearchcondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EventId | EventId
Public property | JobId | JobId
Public property | TemplateId | TemplateId
Public property | TenantId | TenantId

See Also

EventTemplateSearchcondition Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition Constructor

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition Constructor
EventTemplateSearchcondition Class See Also Send Feedback
Initializes a new instance of the EventTemplateSearchcondition class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventTemplateSearchcondition()
Visual Basic
Public Sub New
Visual C++
public:
EventTemplateSearchcondition()

See Also

EventTemplateSearchcondition Class
EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition Methods

[image] [image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition Methods
EventTemplateSearchcondition Class See Also Send Feedback

The EventTemplateSearchcondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EventTemplateSearchcondition Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition Properties

[image] [image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition Properties
EventTemplateSearchcondition Class See Also Send Feedback

The EventTemplateSearchcondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EventId | EventId
Public property | JobId | JobId
Public property | TemplateId | TemplateId
Public property | TenantId | TenantId

See Also

EventTemplateSearchcondition Class
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition.Condition Property

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition..::..Condition Property
EventTemplateSearchcondition Class See Also Send Feedback
Condition

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

EventTemplateSearchcondition Class
EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition.EventId Property

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition..::..EventId Property
EventTemplateSearchcondition Class See Also Send Feedback
EventId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventTemplateSearchcondition Class
EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition.JobId Property

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition..::..JobId Property
EventTemplateSearchcondition Class See Also Send Feedback
JobId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventTemplateSearchcondition Class
EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition.TemplateId Property

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition..::..TemplateId Property
EventTemplateSearchcondition Class See Also Send Feedback
TemplateId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventTemplateSearchcondition Class
EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


EventTemplateSearchcondition.TenantId Property

[image]

A Sandcastle Documented Class Library
EventTemplateSearchcondition..::..TenantId Property
EventTemplateSearchcondition Class See Also Send Feedback
TenantId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EventTemplateSearchcondition Class
EventTemplateSearchcondition Members
CelloSaaS.EventScheduler.Model Namespace


Job Class

[image]

A Sandcastle Documented Class Library
Job Class
Members See Also Send Feedback
Jobs Class contains job name and type

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Job
Visual Basic
<SerializableAttribute>
Public Class Job
Visual C++
[SerializableAttribute]
public ref class Job

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..Job

See Also

Job Members
CelloSaaS.EventScheduler.Model Namespace


Job Members

[image] [image]

A Sandcastle Documented Class Library
Job Members
Job Class Constructors Methods Properties See Also Send Feedback

The Job type exposes the following members.

Constructors

 | Name | Description
Public method | Job | Initializes a new instance of the Job class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the created user id
Public property | CreatedOn | Get or Sets the created date
Public property | Description | Gets or Sets the job description
Public property | JobId | Get or Sets the job id (primary key)
Public property | JobType | Get or Sets the job type
Public property | Name | Get or Sets the job name
Public property | Status | Gets or Sets status of the schedule
Public property | UpdatedBy | Get or Sets the updated user id
Public property | UpdatedOn | Get or Sets the updated time

See Also

Job Class
CelloSaaS.EventScheduler.Model Namespace


Job Constructor

[image]

A Sandcastle Documented Class Library
Job Constructor
Job Class See Also Send Feedback
Initializes a new instance of the Job class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Job()
Visual Basic
Public Sub New
Visual C++
public:
Job()

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job Methods

[image] [image]

A Sandcastle Documented Class Library
Job Methods
Job Class See Also Send Feedback

The Job type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Job Class
CelloSaaS.EventScheduler.Model Namespace


Job Properties

[image] [image]

A Sandcastle Documented Class Library
Job Properties
Job Class See Also Send Feedback

The Job type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the created user id
Public property | CreatedOn | Get or Sets the created date
Public property | Description | Gets or Sets the job description
Public property | JobId | Get or Sets the job id (primary key)
Public property | JobType | Get or Sets the job type
Public property | Name | Get or Sets the job name
Public property | Status | Gets or Sets status of the schedule
Public property | UpdatedBy | Get or Sets the updated user id
Public property | UpdatedOn | Get or Sets the updated time

See Also

Job Class
CelloSaaS.EventScheduler.Model Namespace


Job.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Job..::..CreatedBy Property
Job Class See Also Send Feedback
Get or Sets the created user id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Job..::..CreatedOn Property
Job Class See Also Send Feedback
Get or Sets the created date

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.Description Property

[image]

A Sandcastle Documented Class Library
Job..::..Description Property
Job Class See Also Send Feedback
Gets or Sets the job description

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.JobId Property

[image]

A Sandcastle Documented Class Library
Job..::..JobId Property
Job Class See Also Send Feedback
Get or Sets the job id (primary key)

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job id.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.JobType Property

[image]

A Sandcastle Documented Class Library
Job..::..JobType Property
Job Class See Also Send Feedback
Get or Sets the job type

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobType { get; set; }
Visual Basic
Public Property JobType As String
    Get
    Set
Visual C++
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The type of the job.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.Name Property

[image]

A Sandcastle Documented Class Library
Job..::..Name Property
Job Class See Also Send Feedback
Get or Sets the job name

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.Status Property

[image]

A Sandcastle Documented Class Library
Job..::..Status Property
Job Class See Also Send Feedback
Gets or Sets status of the schedule

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Job..::..UpdatedBy Property
Job Class See Also Send Feedback
Get or Sets the updated user id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


Job.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Job..::..UpdatedOn Property
Job Class See Also Send Feedback
Get or Sets the updated time

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

Job Class
Job Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit Class

[image]

A Sandcastle Documented Class Library
JobAudit Class
Members See Also Send Feedback
The Job Audit class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobAudit
Visual Basic
<SerializableAttribute>
Public Class JobAudit
Visual C++
[SerializableAttribute]
public ref class JobAudit

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..JobAudit

See Also

JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit Members

[image] [image]

A Sandcastle Documented Class Library
JobAudit Members
JobAudit Class Constructors Methods Properties See Also Send Feedback

The JobAudit type exposes the following members.

Constructors

 | Name | Description
Public method | JobAudit | Initializes a new instance of the JobAudit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the created user id
Public property | CreatedOn | Get or Sets the created date
Public property | EndTime | Get or Sets the job end time
Public property | ExceptionDetails | Get or Sets the exception details
Public property | ExecutionStatus | Get or Sets the job completion status (success/failure) if failure set exception details (stack trace)
Public property | JobAuditId | Get or Sets the job audit id
Public property | JobId | Get or Sets the job id
Public property | JobName | Gets or sets the name of the job.
Public property | Parameters | Get or Sets the job parameters
Public property | StartTime | Get or Sets the job start time
Public property | Status | Gets or Sets status of the schedule
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Get or Sets the updated user id
Public property | UpdatedOn | Get or Sets the updated time

See Also

JobAudit Class
CelloSaaS.EventScheduler.Model Namespace


JobAudit Constructor

[image]

A Sandcastle Documented Class Library
JobAudit Constructor
JobAudit Class See Also Send Feedback
Initializes a new instance of the JobAudit class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobAudit()
Visual Basic
Public Sub New
Visual C++
public:
JobAudit()

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit Methods

[image] [image]

A Sandcastle Documented Class Library
JobAudit Methods
JobAudit Class See Also Send Feedback

The JobAudit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JobAudit Class
CelloSaaS.EventScheduler.Model Namespace


JobAudit Properties

[image] [image]

A Sandcastle Documented Class Library
JobAudit Properties
JobAudit Class See Also Send Feedback

The JobAudit type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the created user id
Public property | CreatedOn | Get or Sets the created date
Public property | EndTime | Get or Sets the job end time
Public property | ExceptionDetails | Get or Sets the exception details
Public property | ExecutionStatus | Get or Sets the job completion status (success/failure) if failure set exception details (stack trace)
Public property | JobAuditId | Get or Sets the job audit id
Public property | JobId | Get or Sets the job id
Public property | JobName | Gets or sets the name of the job.
Public property | Parameters | Get or Sets the job parameters
Public property | StartTime | Get or Sets the job start time
Public property | Status | Gets or Sets status of the schedule
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Get or Sets the updated user id
Public property | UpdatedOn | Get or Sets the updated time

See Also

JobAudit Class
CelloSaaS.EventScheduler.Model Namespace


JobAudit.CreatedBy Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..CreatedBy Property
JobAudit Class See Also Send Feedback
Get or Sets the created user id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.CreatedOn Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..CreatedOn Property
JobAudit Class See Also Send Feedback
Get or Sets the created date

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.EndTime Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..EndTime Property
JobAudit Class See Also Send Feedback
Get or Sets the job end time

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The end time.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.ExceptionDetails Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..ExceptionDetails Property
JobAudit Class See Also Send Feedback
Get or Sets the exception details

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Object ExceptionDetails { get; set; }
Visual Basic
Public Property ExceptionDetails As Object
    Get
    Set
Visual C++
public:
property Object^ ExceptionDetails {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
The exception details.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.ExecutionStatus Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..ExecutionStatus Property
JobAudit Class See Also Send Feedback
Get or Sets the job completion status (success/failure) if failure set exception details (stack trace)

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool ExecutionStatus { get; set; }
Visual Basic
Public Property ExecutionStatus As Boolean
    Get
    Set
Visual C++
public:
property bool ExecutionStatus {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.JobAuditId Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..JobAuditId Property
JobAudit Class See Also Send Feedback
Get or Sets the job audit id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobAuditId { get; set; }
Visual Basic
Public Property JobAuditId As String
    Get
    Set
Visual C++
public:
property String^ JobAuditId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job audit id.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.JobId Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..JobId Property
JobAudit Class See Also Send Feedback
Get or Sets the job id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job id.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.JobName Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..JobName Property
JobAudit Class See Also Send Feedback
Gets or sets the name of the job.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobName { get; set; }
Visual Basic
Public Property JobName As String
    Get
    Set
Visual C++
public:
property String^ JobName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the job.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.Parameters Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..Parameters Property
JobAudit Class See Also Send Feedback
Get or Sets the job parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Parameters { get; set; }
Visual Basic
Public Property Parameters As String
    Get
    Set
Visual C++
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The parameters.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.StartTime Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..StartTime Property
JobAudit Class See Also Send Feedback
Get or Sets the job start time

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The start time.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.Status Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..Status Property
JobAudit Class See Also Send Feedback
Gets or Sets status of the schedule

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.TenantId Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..TenantId Property
JobAudit Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..UpdatedBy Property
JobAudit Class See Also Send Feedback
Get or Sets the updated user id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAudit.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
JobAudit..::..UpdatedOn Property
JobAudit Class See Also Send Feedback
Get or Sets the updated time

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

JobAudit Class
JobAudit Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition Class

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition Class
Members See Also Send Feedback
This class defines/constructs the job audit details search parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobAuditSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class JobAuditSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class JobAuditSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..JobAuditSearchCondition

See Also

JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
JobAuditSearchCondition Members
JobAuditSearchCondition Class Constructors Methods Properties See Also Send Feedback

The JobAuditSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | JobAuditSearchCondition | Initializes a new instance of the JobAuditSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EndTime | EndTime
Public property | EventId | EventId
Public property | ExecutionStatus | ExecutionStatus
Public property | JobIds | JobIds
Public property | JobName | TenantId
Public property | PageNo | Sets or gets the page number
Public property | PageSize | Sets or gets the page size
Public property | SetTotalCount |
Public property | SortDirection | Sets or gets the sort direction
Public property | SortString | Sets or gets Sort column name
Public property | StartTime | StartTime
Public property | TenantId | TenantId

See Also

JobAuditSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition Constructor
JobAuditSearchCondition Class See Also Send Feedback
Initializes a new instance of the JobAuditSearchCondition class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobAuditSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
JobAuditSearchCondition()

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
JobAuditSearchCondition Methods
JobAuditSearchCondition Class See Also Send Feedback

The JobAuditSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JobAuditSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
JobAuditSearchCondition Properties
JobAuditSearchCondition Class See Also Send Feedback

The JobAuditSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EndTime | EndTime
Public property | EventId | EventId
Public property | ExecutionStatus | ExecutionStatus
Public property | JobIds | JobIds
Public property | JobName | TenantId
Public property | PageNo | Sets or gets the page number
Public property | PageSize | Sets or gets the page size
Public property | SetTotalCount |
Public property | SortDirection | Sets or gets the sort direction
Public property | SortString | Sets or gets Sort column name
Public property | StartTime | StartTime
Public property | TenantId | TenantId

See Also

JobAuditSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..Condition Property
JobAuditSearchCondition Class See Also Send Feedback
Condition

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.EndTime Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..EndTime Property
JobAuditSearchCondition Class See Also Send Feedback
EndTime

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> EndTime { get; set; }
Visual Basic
Public Property EndTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> EndTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.EventId Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..EventId Property
JobAuditSearchCondition Class See Also Send Feedback
EventId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.ExecutionStatus Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..ExecutionStatus Property
JobAuditSearchCondition Class See Also Send Feedback
ExecutionStatus

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> ExecutionStatus { get; set; }
Visual Basic
Public Property ExecutionStatus As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> ExecutionStatus {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.JobIds Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..JobIds Property
JobAuditSearchCondition Class See Also Send Feedback
JobIds

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] JobIds { get; set; }
Visual Basic
Public Property JobIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ JobIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.JobName Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..JobName Property
JobAuditSearchCondition Class See Also Send Feedback
TenantId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobName { get; set; }
Visual Basic
Public Property JobName As String
    Get
    Set
Visual C++
public:
property String^ JobName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..PageNo Property
JobAuditSearchCondition Class See Also Send Feedback
Sets or gets the page number

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..PageSize Property
JobAuditSearchCondition Class See Also Send Feedback
Sets or gets the page size

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..SetTotalCount Property
JobAuditSearchCondition Class See Also Send Feedback

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Boolean
    Get
    Set
Visual C++
public:
property bool SetTotalCount {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..SortDirection Property
JobAuditSearchCondition Class See Also Send Feedback
Sets or gets the sort direction

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..SortString Property
JobAuditSearchCondition Class See Also Send Feedback
Sets or gets Sort column name

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.StartTime Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..StartTime Property
JobAuditSearchCondition Class See Also Send Feedback
StartTime

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> StartTime { get; set; }
Visual Basic
Public Property StartTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> StartTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchCondition..::..TenantId Property
JobAuditSearchCondition Class See Also Send Feedback
TenantId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

JobAuditSearchCondition Class
JobAuditSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult Class

[image]

A Sandcastle Documented Class Library
JobAuditSearchResult Class
Members See Also Send Feedback
This class contains the job audit search result objects

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobAuditSearchResult
Visual Basic
<SerializableAttribute>
Public Class JobAuditSearchResult
Visual C++
[SerializableAttribute]
public ref class JobAuditSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..JobAuditSearchResult

See Also

JobAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
JobAuditSearchResult Members
JobAuditSearchResult Class Constructors Methods Properties See Also Send Feedback

The JobAuditSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | JobAuditSearchResult | Initializes a new instance of the JobAuditSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | JobAuditsList | Result of the search criteria
Public property | TotalCount | Total count the job audit record for the given search criteria

See Also

JobAuditSearchResult Class
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult Constructor

[image]

A Sandcastle Documented Class Library
JobAuditSearchResult Constructor
JobAuditSearchResult Class See Also Send Feedback
Initializes a new instance of the JobAuditSearchResult class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobAuditSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
JobAuditSearchResult()

See Also

JobAuditSearchResult Class
JobAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
JobAuditSearchResult Methods
JobAuditSearchResult Class See Also Send Feedback

The JobAuditSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JobAuditSearchResult Class
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
JobAuditSearchResult Properties
JobAuditSearchResult Class See Also Send Feedback

The JobAuditSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | JobAuditsList | Result of the search criteria
Public property | TotalCount | Total count the job audit record for the given search criteria

See Also

JobAuditSearchResult Class
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult.JobAuditsList Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchResult..::..JobAuditsList Property
JobAuditSearchResult Class See Also Send Feedback
Result of the search criteria

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, JobAudit> JobAuditsList { get; set; }
Visual Basic
Public Property JobAuditsList As Dictionary(Of String, JobAudit)
    Get
    Set
Visual C++
public:
property Dictionary<String^, JobAudit^>^ JobAuditsList {
    Dictionary<String^, JobAudit^>^ get ();
    void set (Dictionary<String^, JobAudit^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, JobAudit >)>)>

See Also

JobAuditSearchResult Class
JobAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


JobAuditSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
JobAuditSearchResult..::..TotalCount Property
JobAuditSearchResult Class See Also Send Feedback
Total count the job audit record for the given search criteria

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public long TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Long
    Get
    Set
Visual C++
public:
property long long TotalCount {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64

See Also

JobAuditSearchResult Class
JobAuditSearchResult Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters Class

[image]

A Sandcastle Documented Class Library
JobParameters Class
Members See Also Send Feedback
Job Parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobParameters
Visual Basic
<SerializableAttribute>
Public Class JobParameters
Visual C++
[SerializableAttribute]
public ref class JobParameters

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..JobParameters

See Also

JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters Members

[image] [image]

A Sandcastle Documented Class Library
JobParameters Members
JobParameters Class Constructors Methods Properties See Also Send Feedback

The JobParameters type exposes the following members.

Constructors

 | Name | Description
Public method | JobParameters | Initializes a new instance of the JobParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the CreatedBy
Public property | CreatedOn | Get or Sets the CreatedOn
Public property | EventId | Get or Sets the EventId
Public property | EventJobParameter | Get or Sets the EventJobParameter
Public property | JobId | Get or Sets the JobId
Public property | JobParameterId | Get or Sets the JobParameterId
Public property | ParameterXML | Get or Sets the ParameterXML
Public property | Status | Get or Sets the Status
Public property | TenantId | Get or Sets the TenantId
Public property | UpdatedBy | Get or Sets the UpdatedBy
Public property | UpdatedOn | Get or Sets the UpdatedOn

See Also

JobParameters Class
CelloSaaS.EventScheduler.Model Namespace


JobParameters Constructor

[image]

A Sandcastle Documented Class Library
JobParameters Constructor
JobParameters Class See Also Send Feedback
Initializes a new instance of the JobParameters class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobParameters()
Visual Basic
Public Sub New
Visual C++
public:
JobParameters()

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters Methods

[image] [image]

A Sandcastle Documented Class Library
JobParameters Methods
JobParameters Class See Also Send Feedback

The JobParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JobParameters Class
CelloSaaS.EventScheduler.Model Namespace


JobParameters Properties

[image] [image]

A Sandcastle Documented Class Library
JobParameters Properties
JobParameters Class See Also Send Feedback

The JobParameters type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the CreatedBy
Public property | CreatedOn | Get or Sets the CreatedOn
Public property | EventId | Get or Sets the EventId
Public property | EventJobParameter | Get or Sets the EventJobParameter
Public property | JobId | Get or Sets the JobId
Public property | JobParameterId | Get or Sets the JobParameterId
Public property | ParameterXML | Get or Sets the ParameterXML
Public property | Status | Get or Sets the Status
Public property | TenantId | Get or Sets the TenantId
Public property | UpdatedBy | Get or Sets the UpdatedBy
Public property | UpdatedOn | Get or Sets the UpdatedOn

See Also

JobParameters Class
CelloSaaS.EventScheduler.Model Namespace


JobParameters.CreatedBy Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..CreatedBy Property
JobParameters Class See Also Send Feedback
Get or Sets the CreatedBy

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.CreatedOn Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..CreatedOn Property
JobParameters Class See Also Send Feedback
Get or Sets the CreatedOn

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.EventId Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..EventId Property
JobParameters Class See Also Send Feedback
Get or Sets the EventId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The event id.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.EventJobParameter Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..EventJobParameter Property
JobParameters Class See Also Send Feedback
Get or Sets the EventJobParameter

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IEventParameter EventJobParameter { get; set; }
Visual Basic
Public Property EventJobParameter As IEventParameter
    Get
    Set
Visual C++
public:
property IEventParameter^ EventJobParameter {
    IEventParameter^ get ();
    void set (IEventParameter^ value);
}

Property Value

Type: IEventParameter
The event job parameter.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.JobId Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..JobId Property
JobParameters Class See Also Send Feedback
Get or Sets the JobId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job id.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.JobParameterId Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..JobParameterId Property
JobParameters Class See Also Send Feedback
Get or Sets the JobParameterId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobParameterId { get; set; }
Visual Basic
Public Property JobParameterId As String
    Get
    Set
Visual C++
public:
property String^ JobParameterId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job parameter id.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.ParameterXML Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..ParameterXML Property
JobParameters Class See Also Send Feedback
Get or Sets the ParameterXML

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ParameterXML { get; set; }
Visual Basic
Public Property ParameterXML As String
    Get
    Set
Visual C++
public:
property String^ ParameterXML {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The parameter XML.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.Status Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..Status Property
JobParameters Class See Also Send Feedback
Get or Sets the Status

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.TenantId Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..TenantId Property
JobParameters Class See Also Send Feedback
Get or Sets the TenantId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..UpdatedBy Property
JobParameters Class See Also Send Feedback
Get or Sets the UpdatedBy

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobParameters.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
JobParameters..::..UpdatedOn Property
JobParameters Class See Also Send Feedback
Get or Sets the UpdatedOn

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

JobParameters Class
JobParameters Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition Class

[image]

A Sandcastle Documented Class Library
JobSearchCondition Class
Members See Also Send Feedback
This class defines/constructs the job details search parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class JobSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class JobSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..JobSearchCondition

See Also

JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
JobSearchCondition Members
JobSearchCondition Class Constructors Methods Properties See Also Send Feedback

The JobSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | JobSearchCondition | Initializes a new instance of the JobSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EventIds | Gets or sets the event ids.
Public property | JobId | Gets or sets the job id.
Public property | JobIds | Gets or sets the job ids.
Public property | JobName | Gets or sets the name of the job.
Public property | ScheduleIds | Gets or sets the schedule ids.
Public property | TenantId | Gets or sets the tenant id.
Public property | TenantIds | Gets or sets the tenant ids.

See Also

JobSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
JobSearchCondition Constructor
JobSearchCondition Class See Also Send Feedback
Initializes a new instance of the JobSearchCondition class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
JobSearchCondition()

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
JobSearchCondition Methods
JobSearchCondition Class See Also Send Feedback

The JobSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JobSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
JobSearchCondition Properties
JobSearchCondition Class See Also Send Feedback

The JobSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EventIds | Gets or sets the event ids.
Public property | JobId | Gets or sets the job id.
Public property | JobIds | Gets or sets the job ids.
Public property | JobName | Gets or sets the name of the job.
Public property | ScheduleIds | Gets or sets the schedule ids.
Public property | TenantId | Gets or sets the tenant id.
Public property | TenantIds | Gets or sets the tenant ids.

See Also

JobSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..Condition Property
JobSearchCondition Class See Also Send Feedback
Condition

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.EventIds Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..EventIds Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the event ids.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] EventIds { get; set; }
Visual Basic
Public Property EventIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ EventIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The event ids.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.JobId Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..JobId Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the job id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job id.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.JobIds Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..JobIds Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the job ids.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] JobIds { get; set; }
Visual Basic
Public Property JobIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ JobIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The job ids.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.JobName Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..JobName Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the name of the job.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobName { get; set; }
Visual Basic
Public Property JobName As String
    Get
    Set
Visual C++
public:
property String^ JobName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the job.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.ScheduleIds Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..ScheduleIds Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the schedule ids.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] ScheduleIds { get; set; }
Visual Basic
Public Property ScheduleIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ ScheduleIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The schedule ids.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..TenantId Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


JobSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
JobSearchCondition..::..TenantIds Property
JobSearchCondition Class See Also Send Feedback
Gets or sets the tenant ids.

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ TenantIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The tenant ids.

See Also

JobSearchCondition Class
JobSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


Schedule Class

[image]

A Sandcastle Documented Class Library
Schedule Class
Members See Also Send Feedback
The Schedules class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Schedule
Visual Basic
<SerializableAttribute>
Public Class Schedule
Visual C++
[SerializableAttribute]
public ref class Schedule

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..Schedule

See Also

Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule Members

[image] [image]

A Sandcastle Documented Class Library
Schedule Members
Schedule Class Constructors Methods Properties See Also Send Feedback

The Schedule type exposes the following members.

Constructors

 | Name | Description
Public method | Schedule | Initializes a new instance of the Schedule class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the created user id
Public property | CreatedOn | Get or Sets the created date
Public property | Description | Gets or Sets the schedule description
Public property | Jobs | Gets or Sets the jobs for the schedule
Public property | Name | Gets or Sets the schedule name
Public property | ScheduleId | Get or Sets the schedule primary key
Public property | Status | Gets or Sets status of the schedule
Public property | TenantId | Gets or Sets the tenant id (foreign key)
Public property | UpdatedBy | Get or Sets the updated user id
Public property | UpdatedOn | Get or Sets the updated time

See Also

Schedule Class
CelloSaaS.EventScheduler.Model Namespace


Schedule Constructor

[image]

A Sandcastle Documented Class Library
Schedule Constructor
Schedule Class See Also Send Feedback
Initializes a new instance of the Schedule class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Schedule()
Visual Basic
Public Sub New
Visual C++
public:
Schedule()

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule Methods

[image] [image]

A Sandcastle Documented Class Library
Schedule Methods
Schedule Class See Also Send Feedback

The Schedule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Schedule Class
CelloSaaS.EventScheduler.Model Namespace


Schedule Properties

[image] [image]

A Sandcastle Documented Class Library
Schedule Properties
Schedule Class See Also Send Feedback

The Schedule type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or Sets the created user id
Public property | CreatedOn | Get or Sets the created date
Public property | Description | Gets or Sets the schedule description
Public property | Jobs | Gets or Sets the jobs for the schedule
Public property | Name | Gets or Sets the schedule name
Public property | ScheduleId | Get or Sets the schedule primary key
Public property | Status | Gets or Sets status of the schedule
Public property | TenantId | Gets or Sets the tenant id (foreign key)
Public property | UpdatedBy | Get or Sets the updated user id
Public property | UpdatedOn | Get or Sets the updated time

See Also

Schedule Class
CelloSaaS.EventScheduler.Model Namespace


Schedule.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Schedule..::..CreatedBy Property
Schedule Class See Also Send Feedback
Get or Sets the created user id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Schedule..::..CreatedOn Property
Schedule Class See Also Send Feedback
Get or Sets the created date

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.Description Property

[image]

A Sandcastle Documented Class Library
Schedule..::..Description Property
Schedule Class See Also Send Feedback
Gets or Sets the schedule description

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.Jobs Property

[image]

A Sandcastle Documented Class Library
Schedule..::..Jobs Property
Schedule Class See Also Send Feedback
Gets or Sets the jobs for the schedule

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IList<Job> Jobs { get; set; }
Visual Basic
Public Property Jobs As IList(Of Job)
    Get
    Set
Visual C++
public:
property IList<Job^>^ Jobs {
    IList<Job^>^ get ();
    void set (IList<Job^>^ value);
}

Property Value

Type: IList<(Of <(<' Job >)>)>
The jobs.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.Name Property

[image]

A Sandcastle Documented Class Library
Schedule..::..Name Property
Schedule Class See Also Send Feedback
Gets or Sets the schedule name

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.ScheduleId Property

[image]

A Sandcastle Documented Class Library
Schedule..::..ScheduleId Property
Schedule Class See Also Send Feedback
Get or Sets the schedule primary key

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ScheduleId { get; set; }
Visual Basic
Public Property ScheduleId As String
    Get
    Set
Visual C++
public:
property String^ ScheduleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The schedule id.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.Status Property

[image]

A Sandcastle Documented Class Library
Schedule..::..Status Property
Schedule Class See Also Send Feedback
Gets or Sets status of the schedule

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.TenantId Property

[image]

A Sandcastle Documented Class Library
Schedule..::..TenantId Property
Schedule Class See Also Send Feedback
Gets or Sets the tenant id (foreign key)

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Schedule..::..UpdatedBy Property
Schedule Class See Also Send Feedback
Get or Sets the updated user id

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


Schedule.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Schedule..::..UpdatedOn Property
Schedule Class See Also Send Feedback
Get or Sets the updated time

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

Schedule Class
Schedule Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition Class

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition Class
Members See Also Send Feedback
This class defines/constructs the schedule details search parameters

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ScheduleSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class ScheduleSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class ScheduleSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..ScheduleSearchCondition

See Also

ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
ScheduleSearchCondition Members
ScheduleSearchCondition Class Constructors Methods Properties See Also Send Feedback

The ScheduleSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleSearchCondition | Initializes a new instance of the ScheduleSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EventId | EventId
Public property | EventIds | EventIds
Public property | Name | Name
Public property | ScheduleId | ScheduleId
Public property | ScheduleIds | ScheduleIds
Public property | TenantId | TenantId
Public property | TenantIds | TenantIds

See Also

ScheduleSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition Constructor
ScheduleSearchCondition Class See Also Send Feedback
Initializes a new instance of the ScheduleSearchCondition class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleSearchCondition()

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
ScheduleSearchCondition Methods
ScheduleSearchCondition Class See Also Send Feedback

The ScheduleSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ScheduleSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ScheduleSearchCondition Properties
ScheduleSearchCondition Class See Also Send Feedback

The ScheduleSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition
Public property | EventId | EventId
Public property | EventIds | EventIds
Public property | Name | Name
Public property | ScheduleId | ScheduleId
Public property | ScheduleIds | ScheduleIds
Public property | TenantId | TenantId
Public property | TenantIds | TenantIds

See Also

ScheduleSearchCondition Class
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..Condition Property
ScheduleSearchCondition Class See Also Send Feedback
Condition

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.EventId Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..EventId Property
ScheduleSearchCondition Class See Also Send Feedback
EventId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set
Visual C++
public:
property String^ EventId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.EventIds Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..EventIds Property
ScheduleSearchCondition Class See Also Send Feedback
EventIds

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] EventIds { get; set; }
Visual Basic
Public Property EventIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ EventIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.Name Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..Name Property
ScheduleSearchCondition Class See Also Send Feedback
Name

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.ScheduleId Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..ScheduleId Property
ScheduleSearchCondition Class See Also Send Feedback
ScheduleId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ScheduleId { get; set; }
Visual Basic
Public Property ScheduleId As String
    Get
    Set
Visual C++
public:
property String^ ScheduleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.ScheduleIds Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..ScheduleIds Property
ScheduleSearchCondition Class See Also Send Feedback
ScheduleIds

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] ScheduleIds { get; set; }
Visual Basic
Public Property ScheduleIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ ScheduleIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..TenantId Property
ScheduleSearchCondition Class See Also Send Feedback
TenantId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


ScheduleSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
ScheduleSearchCondition..::..TenantIds Property
ScheduleSearchCondition Class See Also Send Feedback
TenantIds

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ TenantIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

ScheduleSearchCondition Class
ScheduleSearchCondition Members
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter Class

[image]

A Sandcastle Documented Class Library
WFJobParameter Class
Members See Also Send Feedback
WFJobParameter

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WFJobParameter : IEventParameter
Visual Basic
<SerializableAttribute>
Public Class WFJobParameter
    Implements IEventParameter
Visual C++
[SerializableAttribute]
public ref class WFJobParameter : IEventParameter

Inheritance Hierarchy

System..::..Object
CelloSaaS.EventScheduler.Model..::..WFJobParameter

See Also

WFJobParameter Members
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter Members

[image] [image]

A Sandcastle Documented Class Library
WFJobParameter Members
WFJobParameter Class Constructors Methods Properties See Also Send Feedback

The WFJobParameter type exposes the following members.

Constructors

 | Name | Description
Public method | WFJobParameter | Initializes a new instance of the WFJobParameter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MapIdXPath | Get or Sets the MapIdXPath
Public property | ServiceEndpointId | Get or Sets the ServiceEndpointId
Public property | WFName | Get or Sets the WFName
Public property | XSLString | Get or Sets the XSLString

See Also

WFJobParameter Class
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter Constructor

[image]

A Sandcastle Documented Class Library
WFJobParameter Constructor
WFJobParameter Class See Also Send Feedback
Initializes a new instance of the WFJobParameter class

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFJobParameter()
Visual Basic
Public Sub New
Visual C++
public:
WFJobParameter()

See Also

WFJobParameter Class
WFJobParameter Members
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter Methods

[image] [image]

A Sandcastle Documented Class Library
WFJobParameter Methods
WFJobParameter Class See Also Send Feedback

The WFJobParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFJobParameter Class
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter Properties

[image] [image]

A Sandcastle Documented Class Library
WFJobParameter Properties
WFJobParameter Class See Also Send Feedback

The WFJobParameter type exposes the following members.

Properties

 | Name | Description
Public property | MapIdXPath | Get or Sets the MapIdXPath
Public property | ServiceEndpointId | Get or Sets the ServiceEndpointId
Public property | WFName | Get or Sets the WFName
Public property | XSLString | Get or Sets the XSLString

See Also

WFJobParameter Class
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter.MapIdXPath Property

[image]

A Sandcastle Documented Class Library
WFJobParameter..::..MapIdXPath Property
WFJobParameter Class See Also Send Feedback
Get or Sets the MapIdXPath

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapIdXPath { get; set; }
Visual Basic
Public Property MapIdXPath As String
    Get
    Set
Visual C++
public:
property String^ MapIdXPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id X path.

See Also

WFJobParameter Class
WFJobParameter Members
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter.ServiceEndpointId Property

[image]

A Sandcastle Documented Class Library
WFJobParameter..::..ServiceEndpointId Property
WFJobParameter Class See Also Send Feedback
Get or Sets the ServiceEndpointId

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceEndpointId { get; set; }
Visual Basic
Public Property ServiceEndpointId As String
    Get
    Set
Visual C++
public:
property String^ ServiceEndpointId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The service endpoint id.

See Also

WFJobParameter Class
WFJobParameter Members
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter.WFName Property

[image]

A Sandcastle Documented Class Library
WFJobParameter..::..WFName Property
WFJobParameter Class See Also Send Feedback
Get or Sets the WFName

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFName { get; set; }
Visual Basic
Public Property WFName As String
    Get
    Set
Visual C++
public:
property String^ WFName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the WF.

See Also

WFJobParameter Class
WFJobParameter Members
CelloSaaS.EventScheduler.Model Namespace


WFJobParameter.XSLString Property

[image]

A Sandcastle Documented Class Library
WFJobParameter..::..XSLString Property
WFJobParameter Class See Also Send Feedback
Get or Sets the XSLString

Namespace: CelloSaaS.EventScheduler.Model
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string XSLString { get; set; }
Visual Basic
Public Property XSLString As String
    Get
    Set
Visual C++
public:
property String^ XSLString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The XSL string.

See Also

WFJobParameter Class
WFJobParameter Members
CelloSaaS.EventScheduler.Model Namespace


CelloSaaS.EventScheduler.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.EventScheduler.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | DuplicateEventNameException | Thrown when duplicate event name entry found
Public class | EventActivityException | Represents the event activity exception
Public class | EventDetailsException | Represents the event details exception
Public class | EventScheduleException | Represents the event schedule exception
Public class | JobAuditException | Represents the schedule audit exception
Public class | JobException | Represents the job exception
Public class | ScheduleException | Represents the schedule exception
Public class | ScheduleJobsException | Represents the schedule jobs exception

Interfaces

 | Interface | Description
Public interface | IEventAuditService | EventAudit Service Interface
Public interface | IEventMetadataService | Event meta data service interface
Public interface | IEventSchedulerService | The interface to be implemented for event scheduler service
Public interface | IEventTemplateService | EventTemplate Service Interface
Public interface | IJobAuditService | The interface to be implemented for the event schedule audit service
Public interface | IJobParameterService | Interface for the Job Parameter Service
Public interface | ISchedulerService | This provides interface for scheduler service


DuplicateEventNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateEventNameException Class
Members See Also Send Feedback
Thrown when duplicate event name entry found

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateEventNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateEventNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateEventNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..DuplicateEventNameException

See Also

DuplicateEventNameException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateEventNameException Members
DuplicateEventNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateEventNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateEventNameException()()()() | Initializes a new instance of the DuplicateEventNameException class.
Public method | DuplicateEventNameException(String) | Initializes a new instance of the DuplicateEventNameException class.
Protected method | DuplicateEventNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateEventNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateEventNameException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateEventNameException Constructor
DuplicateEventNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateEventNameException()()()() | Initializes a new instance of the DuplicateEventNameException class.
Public method | DuplicateEventNameException(String) | Initializes a new instance of the DuplicateEventNameException class.
Protected method | DuplicateEventNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateEventNameException class.

See Also

DuplicateEventNameException Class
DuplicateEventNameException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateEventNameException Constructor
DuplicateEventNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateEventNameException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateEventNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateEventNameException()

See Also

DuplicateEventNameException Class
DuplicateEventNameException Members
DuplicateEventNameException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateEventNameException Constructor (String)
DuplicateEventNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateEventNameException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateEventNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateEventNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateEventNameException Class
DuplicateEventNameException Members
DuplicateEventNameException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateEventNameException Constructor (SerializationInfo, StreamingContext)
DuplicateEventNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateEventNameException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateEventNameException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
DuplicateEventNameException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

DuplicateEventNameException Class
DuplicateEventNameException Members
DuplicateEventNameException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateEventNameException Methods
DuplicateEventNameException Class See Also Send Feedback

The DuplicateEventNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateEventNameException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateEventNameException Properties
DuplicateEventNameException Class See Also Send Feedback

The DuplicateEventNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateEventNameException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


DuplicateEventNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateEventNameException Events
DuplicateEventNameException Class See Also Send Feedback

The DuplicateEventNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateEventNameException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Class

[image]

A Sandcastle Documented Class Library
EventActivityException Class
Members See Also Send Feedback
Represents the event activity exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventActivityException : BaseException
Visual Basic
<SerializableAttribute>
Public Class EventActivityException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class EventActivityException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException

See Also

EventActivityException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Members

[image] [image]

A Sandcastle Documented Class Library
EventActivityException Members
EventActivityException Class Constructors Methods Properties Events See Also Send Feedback

The EventActivityException type exposes the following members.

Constructors

 | Name | Description
Public method | EventActivityException()()()() | Initializes a new instance of the EventActivityException class.
Public method | EventActivityException(String) | Initializes a new instance of the EventActivityException class.
Protected method | EventActivityException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventActivityException class.
Public method | EventActivityException(String, Exception) | Initializes a new instance of the EventActivityException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventActivityException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Constructor

[image] [image]

A Sandcastle Documented Class Library
EventActivityException Constructor
EventActivityException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventActivityException()()()() | Initializes a new instance of the EventActivityException class.
Public method | EventActivityException(String) | Initializes a new instance of the EventActivityException class.
Protected method | EventActivityException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventActivityException class.
Public method | EventActivityException(String, Exception) | Initializes a new instance of the EventActivityException class.

See Also

EventActivityException Class
EventActivityException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Constructor

[image]

A Sandcastle Documented Class Library
EventActivityException Constructor
EventActivityException Class See Also Send Feedback
Initializes a new instance of the EventActivityException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventActivityException()
Visual Basic
Public Sub New
Visual C++
public:
EventActivityException()

See Also

EventActivityException Class
EventActivityException Members
EventActivityException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Constructor (String)

[image]

A Sandcastle Documented Class Library
EventActivityException Constructor (String)
EventActivityException Class See Also Send Feedback
Initializes a new instance of the EventActivityException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventActivityException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
EventActivityException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

EventActivityException Class
EventActivityException Members
EventActivityException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
EventActivityException Constructor (SerializationInfo, StreamingContext)
EventActivityException Class See Also Send Feedback
Initializes a new instance of the EventActivityException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected EventActivityException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
EventActivityException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

EventActivityException Class
EventActivityException Members
EventActivityException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
EventActivityException Constructor (String, Exception)
EventActivityException Class See Also Send Feedback
Initializes a new instance of the EventActivityException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventActivityException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
EventActivityException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

EventActivityException Class
EventActivityException Members
EventActivityException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Methods

[image] [image]

A Sandcastle Documented Class Library
EventActivityException Methods
EventActivityException Class See Also Send Feedback

The EventActivityException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EventActivityException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Properties

[image] [image]

A Sandcastle Documented Class Library
EventActivityException Properties
EventActivityException Class See Also Send Feedback

The EventActivityException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EventActivityException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventActivityException Events

[image] [image]

A Sandcastle Documented Class Library
EventActivityException Events
EventActivityException Class See Also Send Feedback

The EventActivityException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventActivityException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Class

[image]

A Sandcastle Documented Class Library
EventDetailsException Class
Members See Also Send Feedback
Represents the event details exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventDetailsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class EventDetailsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class EventDetailsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException

See Also

EventDetailsException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Members

[image] [image]

A Sandcastle Documented Class Library
EventDetailsException Members
EventDetailsException Class Constructors Methods Properties Events See Also Send Feedback

The EventDetailsException type exposes the following members.

Constructors

 | Name | Description
Public method | EventDetailsException()()()() | Initializes a new instance of the EventDetailsException class.
Public method | EventDetailsException(String) | Initializes a new instance of the EventDetailsException class.
Protected method | EventDetailsException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventDetailsException class.
Public method | EventDetailsException(String, Exception) | Initializes a new instance of the EventDetailsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventDetailsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Constructor

[image] [image]

A Sandcastle Documented Class Library
EventDetailsException Constructor
EventDetailsException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventDetailsException()()()() | Initializes a new instance of the EventDetailsException class.
Public method | EventDetailsException(String) | Initializes a new instance of the EventDetailsException class.
Protected method | EventDetailsException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventDetailsException class.
Public method | EventDetailsException(String, Exception) | Initializes a new instance of the EventDetailsException class.

See Also

EventDetailsException Class
EventDetailsException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Constructor

[image]

A Sandcastle Documented Class Library
EventDetailsException Constructor
EventDetailsException Class See Also Send Feedback
Initializes a new instance of the EventDetailsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventDetailsException()
Visual Basic
Public Sub New
Visual C++
public:
EventDetailsException()

See Also

EventDetailsException Class
EventDetailsException Members
EventDetailsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Constructor (String)

[image]

A Sandcastle Documented Class Library
EventDetailsException Constructor (String)
EventDetailsException Class See Also Send Feedback
Initializes a new instance of the EventDetailsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventDetailsException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
EventDetailsException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

EventDetailsException Class
EventDetailsException Members
EventDetailsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
EventDetailsException Constructor (SerializationInfo, StreamingContext)
EventDetailsException Class See Also Send Feedback
Initializes a new instance of the EventDetailsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected EventDetailsException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
EventDetailsException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

EventDetailsException Class
EventDetailsException Members
EventDetailsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
EventDetailsException Constructor (String, Exception)
EventDetailsException Class See Also Send Feedback
Initializes a new instance of the EventDetailsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventDetailsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
EventDetailsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

EventDetailsException Class
EventDetailsException Members
EventDetailsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Methods

[image] [image]

A Sandcastle Documented Class Library
EventDetailsException Methods
EventDetailsException Class See Also Send Feedback

The EventDetailsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EventDetailsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Properties

[image] [image]

A Sandcastle Documented Class Library
EventDetailsException Properties
EventDetailsException Class See Also Send Feedback

The EventDetailsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EventDetailsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventDetailsException Events

[image] [image]

A Sandcastle Documented Class Library
EventDetailsException Events
EventDetailsException Class See Also Send Feedback

The EventDetailsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventDetailsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Class

[image]

A Sandcastle Documented Class Library
EventScheduleException Class
Members See Also Send Feedback
Represents the event schedule exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EventScheduleException : BaseException
Visual Basic
<SerializableAttribute>
Public Class EventScheduleException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class EventScheduleException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..EventScheduleException

See Also

EventScheduleException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Members

[image] [image]

A Sandcastle Documented Class Library
EventScheduleException Members
EventScheduleException Class Constructors Methods Properties Events See Also Send Feedback

The EventScheduleException type exposes the following members.

Constructors

 | Name | Description
Public method | EventScheduleException()()()() | Initializes a new instance of the EventScheduleException class.
Public method | EventScheduleException(String) | Initializes a new instance of the EventScheduleException class.
Protected method | EventScheduleException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventScheduleException class.
Public method | EventScheduleException(String, Exception) | Initializes a new instance of the EventScheduleException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Constructor

[image] [image]

A Sandcastle Documented Class Library
EventScheduleException Constructor
EventScheduleException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventScheduleException()()()() | Initializes a new instance of the EventScheduleException class.
Public method | EventScheduleException(String) | Initializes a new instance of the EventScheduleException class.
Protected method | EventScheduleException(SerializationInfo, StreamingContext) | Initializes a new instance of the EventScheduleException class.
Public method | EventScheduleException(String, Exception) | Initializes a new instance of the EventScheduleException class.

See Also

EventScheduleException Class
EventScheduleException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Constructor

[image]

A Sandcastle Documented Class Library
EventScheduleException Constructor
EventScheduleException Class See Also Send Feedback
Initializes a new instance of the EventScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventScheduleException()
Visual Basic
Public Sub New
Visual C++
public:
EventScheduleException()

See Also

EventScheduleException Class
EventScheduleException Members
EventScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Constructor (String)

[image]

A Sandcastle Documented Class Library
EventScheduleException Constructor (String)
EventScheduleException Class See Also Send Feedback
Initializes a new instance of the EventScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventScheduleException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
EventScheduleException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

EventScheduleException Class
EventScheduleException Members
EventScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
EventScheduleException Constructor (SerializationInfo, StreamingContext)
EventScheduleException Class See Also Send Feedback
Initializes a new instance of the EventScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected EventScheduleException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
EventScheduleException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

EventScheduleException Class
EventScheduleException Members
EventScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
EventScheduleException Constructor (String, Exception)
EventScheduleException Class See Also Send Feedback
Initializes a new instance of the EventScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EventScheduleException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
EventScheduleException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

EventScheduleException Class
EventScheduleException Members
EventScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Methods

[image] [image]

A Sandcastle Documented Class Library
EventScheduleException Methods
EventScheduleException Class See Also Send Feedback

The EventScheduleException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EventScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Properties

[image] [image]

A Sandcastle Documented Class Library
EventScheduleException Properties
EventScheduleException Class See Also Send Feedback

The EventScheduleException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EventScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


EventScheduleException Events

[image] [image]

A Sandcastle Documented Class Library
EventScheduleException Events
EventScheduleException Class See Also Send Feedback

The EventScheduleException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

EventScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService Interface

[image]

A Sandcastle Documented Class Library
IEventAuditService Interface
Members See Also Send Feedback
EventAudit Service Interface

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IEventAuditService
Visual Basic
Public Interface IEventAuditService
Visual C++
public interface class IEventAuditService

See Also

IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService Members

[image] [image]

A Sandcastle Documented Class Library
IEventAuditService Members
IEventAuditService Interface Methods See Also Send Feedback

The IEventAuditService type exposes the following members.

Methods

 | Name | Description
Public method | CreateEventAudit | Add the ActivityEventLog details
Public method | GetActivityEventLogByEventId | Gets the activity event log by event id.
Public method | GetEventAuditById(String) | Get ActivityEventLog details by ActivityEventLogId
Public method | GetEventAuditById(String, String) | Get ActivityEventLog details by ActivityEventLogId
Public method | GetEventAuditDetails | Searches the event audit details.
Public method | GetEventAudits | Get ActivityEventLog details by eventId,tenantid
Public method | GetEventAuditsByUserId | Get all ActivityEventLog details for the tenantId.
Public method | SearchEventAuditDetails | Obsolete. Searches the event audit details.
Public method | UpdateActivityEventLog | Updates ActivityEventLog Details
Public method | UpdateEventAuditStatus | Update the event audit status by event audit id

See Also

IEventAuditService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService Methods

[image] [image]

A Sandcastle Documented Class Library
IEventAuditService Methods
IEventAuditService Interface See Also Send Feedback

The IEventAuditService type exposes the following members.

Methods

 | Name | Description
Public method | CreateEventAudit | Add the ActivityEventLog details
Public method | GetActivityEventLogByEventId | Gets the activity event log by event id.
Public method | GetEventAuditById(String) | Get ActivityEventLog details by ActivityEventLogId
Public method | GetEventAuditById(String, String) | Get ActivityEventLog details by ActivityEventLogId
Public method | GetEventAuditDetails | Searches the event audit details.
Public method | GetEventAudits | Get ActivityEventLog details by eventId,tenantid
Public method | GetEventAuditsByUserId | Get all ActivityEventLog details for the tenantId.
Public method | SearchEventAuditDetails | Obsolete. Searches the event audit details.
Public method | UpdateActivityEventLog | Updates ActivityEventLog Details
Public method | UpdateEventAuditStatus | Update the event audit status by event audit id

See Also

IEventAuditService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.CreateEventAudit Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..CreateEventAudit Method
IEventAuditService Interface See Also Send Feedback
Add the ActivityEventLog details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreateEventAudit(
    Event eventLog
)
Visual Basic
Function CreateEventAudit (
    eventLog As Event
) As String
Visual C++
String^ CreateEventAudit(
    Event^ eventLog
)

Parameters

eventLog
Type: Event
The event log.

Return Value

Type: String
Event Log Id

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetActivityEventLogByEventId Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetActivityEventLogByEventId Method
IEventAuditService Interface See Also Send Feedback
Gets the activity event log by event id.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Event> GetActivityEventLogByEventId(
    string eventId
)
Visual Basic
Function GetActivityEventLogByEventId (
    eventId As String
) As Dictionary(Of String, Event)
Visual C++
Dictionary<String^, Event^>^ GetActivityEventLogByEventId(
    String^ eventId
)

Parameters

eventId
Type: System..::..String
The event id.

Return Value

Type: Dictionary<(Of <(<'String, Event>)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetEventAuditById Method

[image] [image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetEventAuditById Method
IEventAuditService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEventAuditById(String) | Get ActivityEventLog details by ActivityEventLogId
Public method | GetEventAuditById(String, String) | Get ActivityEventLog details by ActivityEventLogId

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetEventAuditById Method (String)

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetEventAuditById Method (String)
IEventAuditService Interface See Also Send Feedback
Get ActivityEventLog details by ActivityEventLogId

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Event GetEventAuditById(
    string id
)
Visual Basic
Function GetEventAuditById (
    id As String
) As Event
Visual C++
Event^ GetEventAuditById(
    String^ id
)

Parameters

id
Type: System..::..String
The activity event log id.

Return Value

Type: Event
ActivityEventLog

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
GetEventAuditById Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetEventAuditById Method (String, String)

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetEventAuditById Method (String, String)
IEventAuditService Interface See Also Send Feedback
Get ActivityEventLog details by ActivityEventLogId

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Event GetEventAuditById(
    string id,
    string tenantId
)
Visual Basic
Function GetEventAuditById (
    id As String,
    tenantId As String
) As Event
Visual C++
Event^ GetEventAuditById(
    String^ id,
    String^ tenantId
)

Parameters

id
Type: System..::..String
The activity event log id.
tenantId
Type: System..::..String
tenant identifier

Return Value

Type: Event
ActivityEventLog

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
GetEventAuditById Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetEventAuditDetails Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetEventAuditDetails Method
IEventAuditService Interface See Also Send Feedback
Searches the event audit details.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EventAuditSearchResult GetEventAuditDetails(
    EventAuditSearchCondition eventAuditSearchCondition
)
Visual Basic
Function GetEventAuditDetails (
    eventAuditSearchCondition As EventAuditSearchCondition
) As EventAuditSearchResult
Visual C++
EventAuditSearchResult^ GetEventAuditDetails(
    EventAuditSearchCondition^ eventAuditSearchCondition
)

Parameters

eventAuditSearchCondition
Type: CelloSaaS.EventScheduler.Model..::..EventAuditSearchCondition
The event audit search condition.

Return Value

Type: EventAuditSearchResult

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetEventAudits Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetEventAudits Method
IEventAuditService Interface See Also Send Feedback
Get ActivityEventLog details by eventId,tenantid

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Event> GetEventAudits(
    string eventId,
    string tenantId
)
Visual Basic
Function GetEventAudits (
    eventId As String,
    tenantId As String
) As Dictionary(Of String, Event)
Visual C++
Dictionary<String^, Event^>^ GetEventAudits(
    String^ eventId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Event>)>)>
ActivityEventLog

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.GetEventAuditsByUserId Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..GetEventAuditsByUserId Method
IEventAuditService Interface See Also Send Feedback
Get all ActivityEventLog details for the tenantId.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Event> GetEventAuditsByUserId(
    string userId
)
Visual Basic
Function GetEventAuditsByUserId (
    userId As String
) As Dictionary(Of String, Event)
Visual C++
Dictionary<String^, Event^>^ GetEventAuditsByUserId(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Dictionary<(Of <(<'String, Event>)>)>
Dictionary

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.SearchEventAuditDetails Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..SearchEventAuditDetails Method
IEventAuditService Interface See Also Send Feedback
Searches the event audit details.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
Dictionary<string, Event> SearchEventAuditDetails(
    EventAuditSearchCondition eventAuditSearchCondition
)
Visual Basic
<ObsoleteAttribute>
Function SearchEventAuditDetails (
    eventAuditSearchCondition As EventAuditSearchCondition
) As Dictionary(Of String, Event)
Visual C++
[ObsoleteAttribute]
Dictionary<String^, Event^>^ SearchEventAuditDetails(
    EventAuditSearchCondition^ eventAuditSearchCondition
)

Parameters

eventAuditSearchCondition
Type: CelloSaaS.EventScheduler.Model..::..EventAuditSearchCondition
The event audit search condition.

Return Value

Type: Dictionary<(Of <(<'String, Event>)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.UpdateActivityEventLog Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..UpdateActivityEventLog Method
IEventAuditService Interface See Also Send Feedback
Updates ActivityEventLog Details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateActivityEventLog(
    Event eventLog
)
Visual Basic
Sub UpdateActivityEventLog (
    eventLog As Event
)
Visual C++
void UpdateActivityEventLog(
    Event^ eventLog
)

Parameters

eventLog
Type: Event
event Log

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventAuditService.UpdateEventAuditStatus Method

[image]

A Sandcastle Documented Class Library
IEventAuditService..::..UpdateEventAuditStatus Method
IEventAuditService Interface See Also Send Feedback
Update the event audit status by event audit id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateEventAuditStatus(
    string eventAuditId,
    string eventAuditStatus
)
Visual Basic
Sub UpdateEventAuditStatus (
    eventAuditId As String,
    eventAuditStatus As String
)
Visual C++
void UpdateEventAuditStatus(
    String^ eventAuditId,
    String^ eventAuditStatus
)

Parameters

eventAuditId
Type: System..::..String
The event audit id.
eventAuditStatus
Type: System..::..String
The event audit status.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IEventAuditService Interface
IEventAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService Interface

[image]

A Sandcastle Documented Class Library
IEventMetadataService Interface
Members See Also Send Feedback
Event meta data service interface

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IEventMetadataService
Visual Basic
Public Interface IEventMetadataService
Visual C++
public interface class IEventMetadataService

See Also

IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService Members

[image] [image]

A Sandcastle Documented Class Library
IEventMetadataService Members
IEventMetadataService Interface Methods See Also Send Feedback

The IEventMetadataService type exposes the following members.

Methods

 | Name | Description
Public method | AddEventMetadata | Adds the event meta data.
Public method | DeleteEventMetadata | Deletes the event meta data.
Public method | GetAllEventMetadata | Gets all event meta data.
Public method | GetEventMetadataByEventId | Gets the event meta data by event id.
Public method | GetEventMetadataByIds | Gets the event meta data by ids.
Public method | GetEventMetadataByName | Gets the name of the event meta data by.
Public method | UpdateEventMetadata | Updates the event meta data.

See Also

IEventMetadataService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService Methods

[image] [image]

A Sandcastle Documented Class Library
IEventMetadataService Methods
IEventMetadataService Interface See Also Send Feedback

The IEventMetadataService type exposes the following members.

Methods

 | Name | Description
Public method | AddEventMetadata | Adds the event meta data.
Public method | DeleteEventMetadata | Deletes the event meta data.
Public method | GetAllEventMetadata | Gets all event meta data.
Public method | GetEventMetadataByEventId | Gets the event meta data by event id.
Public method | GetEventMetadataByIds | Gets the event meta data by ids.
Public method | GetEventMetadataByName | Gets the name of the event meta data by.
Public method | UpdateEventMetadata | Updates the event meta data.

See Also

IEventMetadataService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.AddEventMetadata Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..AddEventMetadata Method
IEventMetadataService Interface See Also Send Feedback
Adds the event meta data.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddEventMetadata(
    EventMetadata eventMetadata
)
Visual Basic
Function AddEventMetadata (
    eventMetadata As EventMetadata
) As String
Visual C++
String^ AddEventMetadata(
    EventMetadata^ eventMetadata
)

Parameters

eventMetadata
Type: CelloSaaS.EventScheduler.Model..::..EventMetadata
The event metadata.

Return Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentException |
CelloSaaS.EventScheduler.ServiceContracts..::..DuplicateEventNameException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.DeleteEventMetadata Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..DeleteEventMetadata Method
IEventMetadataService Interface See Also Send Feedback
Deletes the event meta data.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteEventMetadata(
    string eventId
)
Visual Basic
Sub DeleteEventMetadata (
    eventId As String
)
Visual C++
void DeleteEventMetadata(
    String^ eventId
)

Parameters

eventId
Type: System..::..String
The event id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.GetAllEventMetadata Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..GetAllEventMetadata Method
IEventMetadataService Interface See Also Send Feedback
Gets all event meta data.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EventMetadata> GetAllEventMetadata(
    string tenantId
)
Visual Basic
Function GetAllEventMetadata (
    tenantId As String
) As Dictionary(Of String, EventMetadata)
Visual C++
Dictionary<String^, EventMetadata^>^ GetAllEventMetadata(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, EventMetadata >)>)>

Exceptions

Exception | Condition
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.GetEventMetadataByEventId Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..GetEventMetadataByEventId Method
IEventMetadataService Interface See Also Send Feedback
Gets the event meta data by event id.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EventMetadata GetEventMetadataByEventId(
    string eventId,
    string tenantId
)
Visual Basic
Function GetEventMetadataByEventId (
    eventId As String,
    tenantId As String
) As EventMetadata
Visual C++
EventMetadata^ GetEventMetadataByEventId(
    String^ eventId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: EventMetadata

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.GetEventMetadataByIds Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..GetEventMetadataByIds Method
IEventMetadataService Interface See Also Send Feedback
Gets the event meta data by ids.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EventMetadata> GetEventMetadataByIds(
    string[] eventIds,
    string tenantId
)
Visual Basic
Function GetEventMetadataByIds (
    eventIds As String(),
    tenantId As String
) As Dictionary(Of String, EventMetadata)
Visual C++
Dictionary<String^, EventMetadata^>^ GetEventMetadataByIds(
    array<String^>^ eventIds,
    String^ tenantId
)

Parameters

eventIds
Type: array<System..::..String>[]()[][]
The event ids.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, EventMetadata >)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.GetEventMetadataByName Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..GetEventMetadataByName Method
IEventMetadataService Interface See Also Send Feedback
Gets the name of the event meta data by.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EventMetadata GetEventMetadataByName(
    string eventName,
    string tenantId
)
Visual Basic
Function GetEventMetadataByName (
    eventName As String,
    tenantId As String
) As EventMetadata
Visual C++
EventMetadata^ GetEventMetadataByName(
    String^ eventName,
    String^ tenantId
)

Parameters

eventName
Type: System..::..String
Name of the event.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: EventMetadata

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventMetadataService.UpdateEventMetadata Method

[image]

A Sandcastle Documented Class Library
IEventMetadataService..::..UpdateEventMetadata Method
IEventMetadataService Interface See Also Send Feedback
Updates the event meta data.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateEventMetadata(
    EventMetadata eventMetadata
)
Visual Basic
Sub UpdateEventMetadata (
    eventMetadata As EventMetadata
)
Visual C++
void UpdateEventMetadata(
    EventMetadata^ eventMetadata
)

Parameters

eventMetadata
Type: CelloSaaS.EventScheduler.Model..::..EventMetadata
The event metadata.

Exceptions

Exception | Condition
System..::..ArgumentException |
CelloSaaS.EventScheduler.ServiceContracts..::..DuplicateEventNameException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventActivityException |

See Also

IEventMetadataService Interface
IEventMetadataService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService Interface

[image]

A Sandcastle Documented Class Library
IEventSchedulerService Interface
Members See Also Send Feedback
The interface to be implemented for event scheduler service

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IEventSchedulerService
Visual Basic
Public Interface IEventSchedulerService
Visual C++
public interface class IEventSchedulerService

See Also

IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService Members

[image] [image]

A Sandcastle Documented Class Library
IEventSchedulerService Members
IEventSchedulerService Interface Methods See Also Send Feedback

The IEventSchedulerService type exposes the following members.

Methods

 | Name | Description
Public method | AddEvent | Obsolete. Adds the event.
Public method | AddEventJob | Adds the given job to the event.
Public method | AddEventSchedule | This service will create new event schedule relations
Public method | DeleteEvent | Obsolete. Deletes the event.
Public method | DeleteEventJob | Deletes the job from the event.
Public method | DeleteEventSchedule | This method will delete the given event schedule relation ship
Public method | GetEventByName | Obsolete. This method gets the event identifier form the event name
Public method | GetEvents | Obsolete. This method fetches all the event names
Public method | GetJobs | This method will search for the jobs with the given event and tenant id
Public method | GetSchedules(array<String>[]()[][]) | This method fetches schedule details for the given event id
Public method | GetSchedules(String, String) | This method fetches schedule details for the given event id and tenant id
Public method | UpdateEventSchedule | This service will update the given event schedule relations

See Also

IEventSchedulerService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService Methods

[image] [image]

A Sandcastle Documented Class Library
IEventSchedulerService Methods
IEventSchedulerService Interface See Also Send Feedback

The IEventSchedulerService type exposes the following members.

Methods

 | Name | Description
Public method | AddEvent | Obsolete. Adds the event.
Public method | AddEventJob | Adds the given job to the event.
Public method | AddEventSchedule | This service will create new event schedule relations
Public method | DeleteEvent | Obsolete. Deletes the event.
Public method | DeleteEventJob | Deletes the job from the event.
Public method | DeleteEventSchedule | This method will delete the given event schedule relation ship
Public method | GetEventByName | Obsolete. This method gets the event identifier form the event name
Public method | GetEvents | Obsolete. This method fetches all the event names
Public method | GetJobs | This method will search for the jobs with the given event and tenant id
Public method | GetSchedules(array<String>[]()[][]) | This method fetches schedule details for the given event id
Public method | GetSchedules(String, String) | This method fetches schedule details for the given event id and tenant id
Public method | UpdateEventSchedule | This service will update the given event schedule relations

See Also

IEventSchedulerService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.AddEvent Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..AddEvent Method
IEventSchedulerService Interface See Also Send Feedback
Adds the event.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use IEventMetadataService")]
string AddEvent(
    string eventName
)
Visual Basic
<ObsoleteAttribute("Use IEventMetadataService")>
Function AddEvent (
    eventName As String
) As String
Visual C++
[ObsoleteAttribute(L"Use IEventMetadataService")]
String^ AddEvent(
    String^ eventName
)

Parameters

eventName
Type: System..::..String
Name of the event.

Return Value

Type: String
newly created event identifier

Exceptions

Exception | Condition
CelloSaaS.EventScheduler.ServiceContracts..::..DuplicateEventNameException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.AddEventJob Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..AddEventJob Method
IEventSchedulerService Interface See Also Send Feedback
Adds the given job to the event.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddEventJob(
    string eventId,
    string jobId,
    string tenantId
)
Visual Basic
Sub AddEventJob (
    eventId As String,
    jobId As String,
    tenantId As String
)
Visual C++
void AddEventJob(
    String^ eventId,
    String^ jobId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
jobId
Type: System..::..String
The job id.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventScheduleException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.AddEventSchedule Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..AddEventSchedule Method
IEventSchedulerService Interface See Also Send Feedback
This service will create new event schedule relations

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddEventSchedule(
    string eventId,
    string[] scheduleIds
)
Visual Basic
Sub AddEventSchedule (
    eventId As String,
    scheduleIds As String()
)
Visual C++
void AddEventSchedule(
    String^ eventId,
    array<String^>^ scheduleIds
)

Parameters

eventId
Type: System..::..String
event identifier
scheduleIds
Type: array<System..::..String>[]()[][]
array of schedule ids

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventScheduleException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.DeleteEvent Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..DeleteEvent Method
IEventSchedulerService Interface See Also Send Feedback
Deletes the event.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use IEventMetadataService")]
void DeleteEvent(
    string eventId
)
Visual Basic
<ObsoleteAttribute("Use IEventMetadataService")>
Sub DeleteEvent (
    eventId As String
)
Visual C++
[ObsoleteAttribute(L"Use IEventMetadataService")]
void DeleteEvent(
    String^ eventId
)

Parameters

eventId
Type: System..::..String
The event identifier.

Exceptions

Exception | Condition
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.DeleteEventJob Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..DeleteEventJob Method
IEventSchedulerService Interface See Also Send Feedback
Deletes the job from the event.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteEventJob(
    string eventId,
    string jobId,
    string tenantId
)
Visual Basic
Sub DeleteEventJob (
    eventId As String,
    jobId As String,
    tenantId As String
)
Visual C++
void DeleteEventJob(
    String^ eventId,
    String^ jobId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
jobId
Type: System..::..String
The job id.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.DeleteEventSchedule Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..DeleteEventSchedule Method
IEventSchedulerService Interface See Also Send Feedback
This method will delete the given event schedule relation ship

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteEventSchedule(
    string eventId
)
Visual Basic
Sub DeleteEventSchedule (
    eventId As String
)
Visual C++
void DeleteEventSchedule(
    String^ eventId
)

Parameters

eventId
Type: System..::..String
event identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventScheduleException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.GetEventByName Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..GetEventByName Method
IEventSchedulerService Interface See Also Send Feedback
This method gets the event identifier form the event name

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use IEventMetadataService")]
string GetEventByName(
    string eventName
)
Visual Basic
<ObsoleteAttribute("Use IEventMetadataService")>
Function GetEventByName (
    eventName As String
) As String
Visual C++
[ObsoleteAttribute(L"Use IEventMetadataService")]
String^ GetEventByName(
    String^ eventName
)

Parameters

eventName
Type: System..::..String
Name of the event.

Return Value

Type: String
returns event identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.GetEvents Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..GetEvents Method
IEventSchedulerService Interface See Also Send Feedback
This method fetches all the event names

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use IEventMetadataService")]
Dictionary<string, string> GetEvents()
Visual Basic
<ObsoleteAttribute("Use IEventMetadataService")>
Function GetEvents As Dictionary(Of String, String)
Visual C++
[ObsoleteAttribute(L"Use IEventMetadataService")]
Dictionary<String^, String^>^ GetEvents()

Return Value

Type: Dictionary<(Of <(<'String, String>)>)>
returns a dictionary of event id/name

Exceptions

Exception | Condition
CelloSaaS.EventScheduler.ServiceContracts..::..EventDetailsException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.GetJobs Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..GetJobs Method
IEventSchedulerService Interface See Also Send Feedback
This method will search for the jobs with the given event and tenant id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobs(
    string eventId,
    string tenantId
)
Visual Basic
Function GetJobs (
    eventId As String,
    tenantId As String
) As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobs(
    String^ eventId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
event identifier
tenantId
Type: System..::..String
tenant identifier

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>
returns found jobs in dictionary object

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.GetSchedules Method

[image] [image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..GetSchedules Method
IEventSchedulerService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSchedules(array<String>[]()[][]) | This method fetches schedule details for the given event id
Public method | GetSchedules(String, String) | This method fetches schedule details for the given event id and tenant id

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.GetSchedules Method (String[])

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..GetSchedules Method (array<String>[]()[][])
IEventSchedulerService Interface See Also Send Feedback
This method fetches schedule details for the given event id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Schedule> GetSchedules(
    string[] eventIds
)
Visual Basic
Function GetSchedules (
    eventIds As String()
) As Dictionary(Of String, Schedule)
Visual C++
Dictionary<String^, Schedule^>^ GetSchedules(
    array<String^>^ eventIds
)

Parameters

eventIds
Type: array<System..::..String>[]()[][]
array of event identifier

Return Value

Type: Dictionary<(Of <(<'String, Schedule >)>)>
returns a dictionary of schedule details

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
GetSchedules Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.GetSchedules Method (String, String)

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..GetSchedules Method (String, String)
IEventSchedulerService Interface See Also Send Feedback
This method fetches schedule details for the given event id and tenant id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Schedule> GetSchedules(
    string eventId,
    string tenantId
)
Visual Basic
Function GetSchedules (
    eventId As String,
    tenantId As String
) As Dictionary(Of String, Schedule)
Visual C++
Dictionary<String^, Schedule^>^ GetSchedules(
    String^ eventId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
event identifier
tenantId
Type: System..::..String
tenant identifier

Return Value

Type: Dictionary<(Of <(<'String, Schedule >)>)>
returns a dictionary of schedule details

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
GetSchedules Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventSchedulerService.UpdateEventSchedule Method

[image]

A Sandcastle Documented Class Library
IEventSchedulerService..::..UpdateEventSchedule Method
IEventSchedulerService Interface See Also Send Feedback
This service will update the given event schedule relations

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateEventSchedule(
    string eventId,
    string[] scheduleIds
)
Visual Basic
Sub UpdateEventSchedule (
    eventId As String,
    scheduleIds As String()
)
Visual C++
void UpdateEventSchedule(
    String^ eventId,
    array<String^>^ scheduleIds
)

Parameters

eventId
Type: System..::..String
event identifier
scheduleIds
Type: array<System..::..String>[]()[][]
array of schedule identifiers

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..EventScheduleException |

See Also

IEventSchedulerService Interface
IEventSchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService Interface

[image]

A Sandcastle Documented Class Library
IEventTemplateService Interface
Members See Also Send Feedback
EventTemplate Service Interface

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IEventTemplateService
Visual Basic
Public Interface IEventTemplateService
Visual C++
public interface class IEventTemplateService

See Also

IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService Members

[image] [image]

A Sandcastle Documented Class Library
IEventTemplateService Members
IEventTemplateService Interface Methods See Also Send Feedback

The IEventTemplateService type exposes the following members.

Methods

 | Name | Description
Public method | AddEventTemplate | Add the EventTemplate details
Public method | DeleteEventTemplate | Deletes EventTemplate details
Public method | GetEventTemplate | Get the template id based on event id and tenant id
Public method | GetEventTemplateByEventTemplateId | Get Event Template details by EventTemplateId
Public method | GetEventTemplateContent | Get the event template content
Public method | GetEventTemplateDetails | Get Event Template details by Ids
Public method | MapEventTemplate | Mapping Event to Template
Public method | UpdateEventTemplate | Updates EventTemplate Details

See Also

IEventTemplateService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService Methods

[image] [image]

A Sandcastle Documented Class Library
IEventTemplateService Methods
IEventTemplateService Interface See Also Send Feedback

The IEventTemplateService type exposes the following members.

Methods

 | Name | Description
Public method | AddEventTemplate | Add the EventTemplate details
Public method | DeleteEventTemplate | Deletes EventTemplate details
Public method | GetEventTemplate | Get the template id based on event id and tenant id
Public method | GetEventTemplateByEventTemplateId | Get Event Template details by EventTemplateId
Public method | GetEventTemplateContent | Get the event template content
Public method | GetEventTemplateDetails | Get Event Template details by Ids
Public method | MapEventTemplate | Mapping Event to Template
Public method | UpdateEventTemplate | Updates EventTemplate Details

See Also

IEventTemplateService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.AddEventTemplate Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..AddEventTemplate Method
IEventTemplateService Interface See Also Send Feedback
Add the EventTemplate details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddEventTemplate(
    EventTemplate eventTemplate
)
Visual Basic
Function AddEventTemplate (
    eventTemplate As EventTemplate
) As String
Visual C++
String^ AddEventTemplate(
    EventTemplate^ eventTemplate
)

Parameters

eventTemplate
Type: CelloSaaS.EventScheduler.Model..::..EventTemplate
The event template.

Return Value

Type: String
EventTemplateId

Exceptions

Exception | Condition
System..::..ArgumentException |
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.DeleteEventTemplate Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..DeleteEventTemplate Method
IEventTemplateService Interface See Also Send Feedback
Deletes EventTemplate details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteEventTemplate(
    string eventTemplateId
)
Visual Basic
Sub DeleteEventTemplate (
    eventTemplateId As String
)
Visual C++
void DeleteEventTemplate(
    String^ eventTemplateId
)

Parameters

eventTemplateId
Type: System..::..String
The event template id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.GetEventTemplate Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..GetEventTemplate Method
IEventTemplateService Interface See Also Send Feedback
Get the template id based on event id and tenant id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetEventTemplate(
    string eventId,
    string tenantId
)
Visual Basic
Function GetEventTemplate (
    eventId As String,
    tenantId As String
) As String
Visual C++
String^ GetEventTemplate(
    String^ eventId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.GetEventTemplateByEventTemplateId Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..GetEventTemplateByEventTemplateId Method
IEventTemplateService Interface See Also Send Feedback
Get Event Template details by EventTemplateId

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EventTemplate GetEventTemplateByEventTemplateId(
    string eventTemplateId
)
Visual Basic
Function GetEventTemplateByEventTemplateId (
    eventTemplateId As String
) As EventTemplate
Visual C++
EventTemplate^ GetEventTemplateByEventTemplateId(
    String^ eventTemplateId
)

Parameters

eventTemplateId
Type: System..::..String
Event Template Id

Return Value

Type: EventTemplate
EventTemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.GetEventTemplateContent Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..GetEventTemplateContent Method
IEventTemplateService Interface See Also Send Feedback
Get the event template content

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetEventTemplateContent(
    string eventId,
    string tenantId,
    string localeId
)
Visual Basic
Function GetEventTemplateContent (
    eventId As String,
    tenantId As String,
    localeId As String
) As String
Visual C++
String^ GetEventTemplateContent(
    String^ eventId,
    String^ tenantId,
    String^ localeId
)

Parameters

eventId
Type: System..::..String
The event id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.

Return Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.GetEventTemplateDetails Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..GetEventTemplateDetails Method
IEventTemplateService Interface See Also Send Feedback
Get Event Template details by Ids

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EventTemplate> GetEventTemplateDetails(
    string tenantId,
    string eventId,
    string templateId
)
Visual Basic
Function GetEventTemplateDetails (
    tenantId As String,
    eventId As String,
    templateId As String
) As Dictionary(Of String, EventTemplate)
Visual C++
Dictionary<String^, EventTemplate^>^ GetEventTemplateDetails(
    String^ tenantId,
    String^ eventId,
    String^ templateId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
eventId
Type: System..::..String
The event id.
templateId
Type: System..::..String
The template id.

Return Value

Type: Dictionary<(Of <(<'String, EventTemplate >)>)>
Dictionary

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.MapEventTemplate Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..MapEventTemplate Method
IEventTemplateService Interface See Also Send Feedback
Mapping Event to Template

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void MapEventTemplate(
    string eventId,
    string templateId,
    string tenantId
)
Visual Basic
Sub MapEventTemplate (
    eventId As String,
    templateId As String,
    tenantId As String
)
Visual C++
void MapEventTemplate(
    String^ eventId,
    String^ templateId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
templateId
Type: System..::..String
The template id.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IEventTemplateService.UpdateEventTemplate Method

[image]

A Sandcastle Documented Class Library
IEventTemplateService..::..UpdateEventTemplate Method
IEventTemplateService Interface See Also Send Feedback
Updates EventTemplate Details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateEventTemplate(
    EventTemplate eventTemplate
)
Visual Basic
Sub UpdateEventTemplate (
    eventTemplate As EventTemplate
)
Visual C++
void UpdateEventTemplate(
    EventTemplate^ eventTemplate
)

Parameters

eventTemplate
Type: CelloSaaS.EventScheduler.Model..::..EventTemplate
eventTemplate

Exceptions

Exception | Condition
System..::..ArgumentException |
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.Model..::..EventTemplateException |

See Also

IEventTemplateService Interface
IEventTemplateService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService Interface

[image]

A Sandcastle Documented Class Library
IJobAuditService Interface
Members See Also Send Feedback
The interface to be implemented for the event schedule audit service

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IJobAuditService
Visual Basic
Public Interface IJobAuditService
Visual C++
public interface class IJobAuditService

See Also

IJobAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService Members

[image] [image]

A Sandcastle Documented Class Library
IJobAuditService Members
IJobAuditService Interface Methods See Also Send Feedback

The IJobAuditService type exposes the following members.

Methods

 | Name | Description
Public method | AddJobAuditDetails(JobAudit) | This method creates new job audit record in database
Public method | AddJobAuditDetails(String, DateTime, DateTime, Boolean, Object, String) | This method creates new job audit record
Public method | DeleteJobAuditDetails | THis method deletes the given jobIds form the job audit
Public method | SearchJobAudits | Searchs the job audits with the given conditions.
Public method | UpdateJobAuditDetails | This method updates the given job audit details

See Also

IJobAuditService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService Methods

[image] [image]

A Sandcastle Documented Class Library
IJobAuditService Methods
IJobAuditService Interface See Also Send Feedback

The IJobAuditService type exposes the following members.

Methods

 | Name | Description
Public method | AddJobAuditDetails(JobAudit) | This method creates new job audit record in database
Public method | AddJobAuditDetails(String, DateTime, DateTime, Boolean, Object, String) | This method creates new job audit record
Public method | DeleteJobAuditDetails | THis method deletes the given jobIds form the job audit
Public method | SearchJobAudits | Searchs the job audits with the given conditions.
Public method | UpdateJobAuditDetails | This method updates the given job audit details

See Also

IJobAuditService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService.AddJobAuditDetails Method

[image] [image]

A Sandcastle Documented Class Library
IJobAuditService..::..AddJobAuditDetails Method
IJobAuditService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddJobAuditDetails(JobAudit) | This method creates new job audit record in database
Public method | AddJobAuditDetails(String, DateTime, DateTime, Boolean, Object, String) | This method creates new job audit record

See Also

IJobAuditService Interface
IJobAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService.AddJobAuditDetails Method (JobAudit)

[image]

A Sandcastle Documented Class Library
IJobAuditService..::..AddJobAuditDetails Method (JobAudit)
IJobAuditService Interface See Also Send Feedback
This method creates new job audit record in database

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddJobAuditDetails(
    JobAudit jobAudit
)
Visual Basic
Sub AddJobAuditDetails (
    jobAudit As JobAudit
)
Visual C++
void AddJobAuditDetails(
    JobAudit^ jobAudit
)

Parameters

jobAudit
Type: CelloSaaS.EventScheduler.Model..::..JobAudit
The job audit.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobAuditException |

See Also

IJobAuditService Interface
IJobAuditService Members
AddJobAuditDetails Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService.AddJobAuditDetails Method (String, DateTime, DateTime, Boolean, Object, String)

[image]

A Sandcastle Documented Class Library
IJobAuditService..::..AddJobAuditDetails Method (String, DateTime, DateTime, Boolean, Object, String)
IJobAuditService Interface See Also Send Feedback
This method creates new job audit record

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddJobAuditDetails(
    string jobId,
    DateTime startTime,
    DateTime endTime,
    bool executionStatus,
    Object exceptionDetails,
    string userId
)
Visual Basic
Sub AddJobAuditDetails (
    jobId As String,
    startTime As DateTime,
    endTime As DateTime,
    executionStatus As Boolean,
    exceptionDetails As Object,
    userId As String
)
Visual C++
void AddJobAuditDetails(
    String^ jobId,
    DateTime startTime,
    DateTime endTime,
    bool executionStatus,
    Object^ exceptionDetails,
    String^ userId
)

Parameters

jobId
Type: System..::..String
job identifier
startTime
Type: System..::..DateTime
start time of job execution
endTime
Type: System..::..DateTime
end time of the job execution
executionStatus
Type: System..::..Boolean
Failure / Success
exceptionDetails
Type: System..::..Object
Exception object
userId
Type: System..::..String
user identifier executing the job

See Also

IJobAuditService Interface
IJobAuditService Members
AddJobAuditDetails Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService.DeleteJobAuditDetails Method

[image]

A Sandcastle Documented Class Library
IJobAuditService..::..DeleteJobAuditDetails Method
IJobAuditService Interface See Also Send Feedback
THis method deletes the given jobIds form the job audit

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteJobAuditDetails(
    string[] jobIds
)
Visual Basic
Sub DeleteJobAuditDetails (
    jobIds As String()
)
Visual C++
void DeleteJobAuditDetails(
    array<String^>^ jobIds
)

Parameters

jobIds
Type: array<System..::..String>[]()[][]
array of job ids to delete

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobAuditException |

See Also

IJobAuditService Interface
IJobAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService.SearchJobAudits Method

[image]

A Sandcastle Documented Class Library
IJobAuditService..::..SearchJobAudits Method
IJobAuditService Interface See Also Send Feedback
Searchs the job audits with the given conditions.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
JobAuditSearchResult SearchJobAudits(
    JobAuditSearchCondition searchCondition
)
Visual Basic
Function SearchJobAudits (
    searchCondition As JobAuditSearchCondition
) As JobAuditSearchResult
Visual C++
JobAuditSearchResult^ SearchJobAudits(
    JobAuditSearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.EventScheduler.Model..::..JobAuditSearchCondition
search condition

Return Value

Type: JobAuditSearchResult

Exceptions

Exception | Condition
System..::..ArgumentException |
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobAuditException |

See Also

IJobAuditService Interface
IJobAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobAuditService.UpdateJobAuditDetails Method

[image]

A Sandcastle Documented Class Library
IJobAuditService..::..UpdateJobAuditDetails Method
IJobAuditService Interface See Also Send Feedback
This method updates the given job audit details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateJobAuditDetails(
    JobAudit jobAudit
)
Visual Basic
Sub UpdateJobAuditDetails (
    jobAudit As JobAudit
)
Visual C++
void UpdateJobAuditDetails(
    JobAudit^ jobAudit
)

Parameters

jobAudit
Type: CelloSaaS.EventScheduler.Model..::..JobAudit
job audit details

Exceptions

Exception | Condition
System..::..ArgumentException |
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobAuditException |

See Also

IJobAuditService Interface
IJobAuditService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService Interface

[image]

A Sandcastle Documented Class Library
IJobParameterService Interface
Members See Also Send Feedback
Interface for the Job Parameter Service

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IJobParameterService
Visual Basic
Public Interface IJobParameterService
Visual C++
public interface class IJobParameterService

See Also

IJobParameterService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService Members

[image] [image]

A Sandcastle Documented Class Library
IJobParameterService Members
IJobParameterService Interface Methods See Also Send Feedback

The IJobParameterService type exposes the following members.

Methods

 | Name | Description
Public method | AddJobParameter | Adding JobParameter Details
Public method | DeleteJobParameter(String) | Deleting JobParameter Details
Public method | DeleteJobParameter(String, String, String) | Deletes the job parameter.
Public method | GetJobParameterDetails | GetJobParameterDetails by using tenantId
Public method | GetJobParameterDetailsByJobParameterId | GetJobParameter Details by jobParameterId
Public method | UpdateJobParameter | Updates the job parameter.

See Also

IJobParameterService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService Methods

[image] [image]

A Sandcastle Documented Class Library
IJobParameterService Methods
IJobParameterService Interface See Also Send Feedback

The IJobParameterService type exposes the following members.

Methods

 | Name | Description
Public method | AddJobParameter | Adding JobParameter Details
Public method | DeleteJobParameter(String) | Deleting JobParameter Details
Public method | DeleteJobParameter(String, String, String) | Deletes the job parameter.
Public method | GetJobParameterDetails | GetJobParameterDetails by using tenantId
Public method | GetJobParameterDetailsByJobParameterId | GetJobParameter Details by jobParameterId
Public method | UpdateJobParameter | Updates the job parameter.

See Also

IJobParameterService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.AddJobParameter Method

[image]

A Sandcastle Documented Class Library
IJobParameterService..::..AddJobParameter Method
IJobParameterService Interface See Also Send Feedback
Adding JobParameter Details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddJobParameter(
    JobParameters jobParameter
)
Visual Basic
Function AddJobParameter (
    jobParameter As JobParameters
) As String
Visual C++
String^ AddJobParameter(
    JobParameters^ jobParameter
)

Parameters

jobParameter
Type: CelloSaaS.EventScheduler.Model..::..JobParameters
jobParameter

Return Value

Type: String
string

Exceptions

Exception | Condition
System..::..ArgumentException |
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IJobParameterService Interface
IJobParameterService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.DeleteJobParameter Method

[image] [image]

A Sandcastle Documented Class Library
IJobParameterService..::..DeleteJobParameter Method
IJobParameterService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteJobParameter(String) | Deleting JobParameter Details
Public method | DeleteJobParameter(String, String, String) | Deletes the job parameter.

See Also

IJobParameterService Interface
IJobParameterService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.DeleteJobParameter Method (String)

[image]

A Sandcastle Documented Class Library
IJobParameterService..::..DeleteJobParameter Method (String)
IJobParameterService Interface See Also Send Feedback
Deleting JobParameter Details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteJobParameter(
    string jobParameterId
)
Visual Basic
Sub DeleteJobParameter (
    jobParameterId As String
)
Visual C++
void DeleteJobParameter(
    String^ jobParameterId
)

Parameters

jobParameterId
Type: System..::..String
jobParameterId

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IJobParameterService Interface
IJobParameterService Members
DeleteJobParameter Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.DeleteJobParameter Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IJobParameterService..::..DeleteJobParameter Method (String, String, String)
IJobParameterService Interface See Also Send Feedback
Deletes the job parameter.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteJobParameter(
    string eventId,
    string jobId,
    string tenantId
)
Visual Basic
Sub DeleteJobParameter (
    eventId As String,
    jobId As String,
    tenantId As String
)
Visual C++
void DeleteJobParameter(
    String^ eventId,
    String^ jobId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
The event id.
jobId
Type: System..::..String
The job id.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IJobParameterService Interface
IJobParameterService Members
DeleteJobParameter Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.GetJobParameterDetails Method

[image]

A Sandcastle Documented Class Library
IJobParameterService..::..GetJobParameterDetails Method
IJobParameterService Interface See Also Send Feedback
GetJobParameterDetails by using tenantId

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
JobParameters GetJobParameterDetails(
    string eventId,
    string jobId,
    string tenantId
)
Visual Basic
Function GetJobParameterDetails (
    eventId As String,
    jobId As String,
    tenantId As String
) As JobParameters
Visual C++
JobParameters^ GetJobParameterDetails(
    String^ eventId,
    String^ jobId,
    String^ tenantId
)

Parameters

eventId
Type: System..::..String
eventId
jobId
Type: System..::..String
jobId
tenantId
Type: System..::..String
tenantId

Return Value

Type: JobParameters

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IJobParameterService Interface
IJobParameterService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.GetJobParameterDetailsByJobParameterId Method

[image]

A Sandcastle Documented Class Library
IJobParameterService..::..GetJobParameterDetailsByJobParameterId Method
IJobParameterService Interface See Also Send Feedback
GetJobParameter Details by jobParameterId

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
JobParameters GetJobParameterDetailsByJobParameterId(
    string jobParameterId
)
Visual Basic
Function GetJobParameterDetailsByJobParameterId (
    jobParameterId As String
) As JobParameters
Visual C++
JobParameters^ GetJobParameterDetailsByJobParameterId(
    String^ jobParameterId
)

Parameters

jobParameterId
Type: System..::..String
jobParameterId

Return Value

Type: JobParameters
JobParameter

Exceptions

Exception | Condition
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IJobParameterService Interface
IJobParameterService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


IJobParameterService.UpdateJobParameter Method

[image]

A Sandcastle Documented Class Library
IJobParameterService..::..UpdateJobParameter Method
IJobParameterService Interface See Also Send Feedback
Updates the job parameter.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateJobParameter(
    JobParameters jobParameter
)
Visual Basic
Sub UpdateJobParameter (
    jobParameter As JobParameters
)
Visual C++
void UpdateJobParameter(
    JobParameters^ jobParameter
)

Parameters

jobParameter
Type: CelloSaaS.EventScheduler.Model..::..JobParameters
The job parameter.

Exceptions

Exception | Condition
System..::..ArgumentException |
System..::..ArgumentNullException |
[!:CelloSaaS.EventScheduler.Model.ActivityEventLogException] |

See Also

IJobParameterService Interface
IJobParameterService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService Interface

[image]

A Sandcastle Documented Class Library
ISchedulerService Interface
Members See Also Send Feedback
This provides interface for scheduler service

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ISchedulerService
Visual Basic
Public Interface ISchedulerService
Visual C++
public interface class ISchedulerService

See Also

ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService Members

[image] [image]

A Sandcastle Documented Class Library
ISchedulerService Members
ISchedulerService Interface Methods See Also Send Feedback

The ISchedulerService type exposes the following members.

Methods

 | Name | Description
Public method | AddJob | This service will add a new job record
Public method | AddSchedule | This service will add a new schedule record
Public method | DeleteJob | This service will delete the given job id
Public method | DeleteSchedule | This method will delete the given schedule id
Public method | DeleteScheduleJobsRelations | This service will delete the schedule jobs relation from the database
Public method | GetJob | This method fetches the job details for the given job id
Public method | GetJobs()()()() | This method retrieves all the job details
Public method | GetJobs(array<String>[]()[][]) | This method retrieves the job details for the given schedule id
Public method | GetJobs(array<String>[]()[][], array<String>[]()[][]) | This method retrieves all the jobs details for the given event id and tenant id
Public method | GetJobsByName | This method retrieves the job details by job name
Public method | GetJobsByScheduleAndTenantId | Gets the jobs by schedule and tenant id.
Public method | GetJobsByTenant | This method retrieves the job details for the given tenant
Public method | GetSchedules()()()() | This method fetches all the schedules details for all the tenants
Public method | GetSchedules(array<String>[]()[][]) | This method fetches all the schedules details for all the tenants
Public method | GetSchedules(array<String>[]()[][], array<String>[]()[][]) | This method fetches all the schedules details for all the tenants
Public method | GetSchedulesByTenant | This method fetches schedule details for the given tenant id
Public method | MapScheduleJobs | This service will map the given schedule job relation details (Note: This will delete the previous entries and adds new entries)
Public method | UpdateJob | This service will update the given job details
Public method | UpdateSchedule | This method will update the given schedule details

See Also

ISchedulerService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService Methods

[image] [image]

A Sandcastle Documented Class Library
ISchedulerService Methods
ISchedulerService Interface See Also Send Feedback

The ISchedulerService type exposes the following members.

Methods

 | Name | Description
Public method | AddJob | This service will add a new job record
Public method | AddSchedule | This service will add a new schedule record
Public method | DeleteJob | This service will delete the given job id
Public method | DeleteSchedule | This method will delete the given schedule id
Public method | DeleteScheduleJobsRelations | This service will delete the schedule jobs relation from the database
Public method | GetJob | This method fetches the job details for the given job id
Public method | GetJobs()()()() | This method retrieves all the job details
Public method | GetJobs(array<String>[]()[][]) | This method retrieves the job details for the given schedule id
Public method | GetJobs(array<String>[]()[][], array<String>[]()[][]) | This method retrieves all the jobs details for the given event id and tenant id
Public method | GetJobsByName | This method retrieves the job details by job name
Public method | GetJobsByScheduleAndTenantId | Gets the jobs by schedule and tenant id.
Public method | GetJobsByTenant | This method retrieves the job details for the given tenant
Public method | GetSchedules()()()() | This method fetches all the schedules details for all the tenants
Public method | GetSchedules(array<String>[]()[][]) | This method fetches all the schedules details for all the tenants
Public method | GetSchedules(array<String>[]()[][], array<String>[]()[][]) | This method fetches all the schedules details for all the tenants
Public method | GetSchedulesByTenant | This method fetches schedule details for the given tenant id
Public method | MapScheduleJobs | This service will map the given schedule job relation details (Note: This will delete the previous entries and adds new entries)
Public method | UpdateJob | This service will update the given job details
Public method | UpdateSchedule | This method will update the given schedule details

See Also

ISchedulerService Interface
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.AddJob Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..AddJob Method
ISchedulerService Interface See Also Send Feedback
This service will add a new job record

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddJob(
    Job job
)
Visual Basic
Function AddJob (
    job As Job
) As String
Visual C++
String^ AddJob(
    Job^ job
)

Parameters

job
Type: CelloSaaS.EventScheduler.Model..::..Job
job details to be added

Return Value

Type: String
returns the newly created job identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.AddSchedule Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..AddSchedule Method
ISchedulerService Interface See Also Send Feedback
This service will add a new schedule record

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddSchedule(
    Schedule schedule
)
Visual Basic
Function AddSchedule (
    schedule As Schedule
) As String
Visual C++
String^ AddSchedule(
    Schedule^ schedule
)

Parameters

schedule
Type: CelloSaaS.EventScheduler.Model..::..Schedule
schedule details object

Return Value

Type: String
returns the newly added schedule identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.DeleteJob Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..DeleteJob Method
ISchedulerService Interface See Also Send Feedback
This service will delete the given job id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteJob(
    string jobId
)
Visual Basic
Sub DeleteJob (
    jobId As String
)
Visual C++
void DeleteJob(
    String^ jobId
)

Parameters

jobId
Type: System..::..String
job identifier to delete

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.DeleteSchedule Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..DeleteSchedule Method
ISchedulerService Interface See Also Send Feedback
This method will delete the given schedule id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteSchedule(
    string scheduleId
)
Visual Basic
Sub DeleteSchedule (
    scheduleId As String
)
Visual C++
void DeleteSchedule(
    String^ scheduleId
)

Parameters

scheduleId
Type: System..::..String
schedule identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.DeleteScheduleJobsRelations Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..DeleteScheduleJobsRelations Method
ISchedulerService Interface See Also Send Feedback
This service will delete the schedule jobs relation from the database

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteScheduleJobsRelations(
    string scheduleId
)
Visual Basic
Sub DeleteScheduleJobsRelations (
    scheduleId As String
)
Visual C++
void DeleteScheduleJobsRelations(
    String^ scheduleId
)

Parameters

scheduleId
Type: System..::..String
relation schedule id to be deleted

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleJobsException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJob Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJob Method
ISchedulerService Interface See Also Send Feedback
This method fetches the job details for the given job id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Job GetJob(
    string jobId
)
Visual Basic
Function GetJob (
    jobId As String
) As Job
Visual C++
Job^ GetJob(
    String^ jobId
)

Parameters

jobId
Type: System..::..String
job identifier

Return Value

Type: Job
returns the job details if found or null is returned

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobs Method

[image] [image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobs Method
ISchedulerService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetJobs()()()() | This method retrieves all the job details
Public method | GetJobs(array<String>[]()[][]) | This method retrieves the job details for the given schedule id
Public method | GetJobs(array<String>[]()[][], array<String>[]()[][]) | This method retrieves all the jobs details for the given event id and tenant id

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobs Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobs Method
ISchedulerService Interface See Also Send Feedback
This method retrieves all the job details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobs()
Visual Basic
Function GetJobs As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobs()

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>
returns a dictionary of job details

See Also

ISchedulerService Interface
ISchedulerService Members
GetJobs Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobs Method (String[])

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobs Method (array<String>[]()[][])
ISchedulerService Interface See Also Send Feedback
This method retrieves the job details for the given schedule id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobs(
    string[] scheduleIds
)
Visual Basic
Function GetJobs (
    scheduleIds As String()
) As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobs(
    array<String^>^ scheduleIds
)

Parameters

scheduleIds
Type: array<System..::..String>[]()[][]
array of schedule identifier

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>
returns dictionary of jobs details

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
GetJobs Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobs Method (String[], String[])

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobs Method (array<String>[]()[][], array<String>[]()[][])
ISchedulerService Interface See Also Send Feedback
This method retrieves all the jobs details for the given event id and tenant id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobs(
    string[] scheduleIds,
    string[] tenantIds
)
Visual Basic
Function GetJobs (
    scheduleIds As String(),
    tenantIds As String()
) As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobs(
    array<String^>^ scheduleIds,
    array<String^>^ tenantIds
)

Parameters

scheduleIds
Type: array<System..::..String>[]()[][]
array of schedule identifier
tenantIds
Type: array<System..::..String>[]()[][]
array of tenant identifier

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>
returns dictionary of jobs details

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
GetJobs Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobsByName Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobsByName Method
ISchedulerService Interface See Also Send Feedback
This method retrieves the job details by job name

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobsByName(
    string jobName
)
Visual Basic
Function GetJobsByName (
    jobName As String
) As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobsByName(
    String^ jobName
)

Parameters

jobName
Type: System..::..String
Name of the job.

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>
returns a dictionary of job details

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobsByScheduleAndTenantId Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobsByScheduleAndTenantId Method
ISchedulerService Interface See Also Send Feedback
Gets the jobs by schedule and tenant id.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobsByScheduleAndTenantId(
    string scheduleId,
    string tenantId
)
Visual Basic
Function GetJobsByScheduleAndTenantId (
    scheduleId As String,
    tenantId As String
) As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobsByScheduleAndTenantId(
    String^ scheduleId,
    String^ tenantId
)

Parameters

scheduleId
Type: System..::..String
The schedule id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetJobsByTenant Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetJobsByTenant Method
ISchedulerService Interface See Also Send Feedback
This method retrieves the job details for the given tenant

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Job> GetJobsByTenant(
    string[] tenantIds
)
Visual Basic
Function GetJobsByTenant (
    tenantIds As String()
) As Dictionary(Of String, Job)
Visual C++
Dictionary<String^, Job^>^ GetJobsByTenant(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
array of tenant identifier

Return Value

Type: Dictionary<(Of <(<'String, Job >)>)>
returns dictionary of jobs details

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetSchedules Method

[image] [image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetSchedules Method
ISchedulerService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSchedules()()()() | This method fetches all the schedules details for all the tenants
Public method | GetSchedules(array<String>[]()[][]) | This method fetches all the schedules details for all the tenants
Public method | GetSchedules(array<String>[]()[][], array<String>[]()[][]) | This method fetches all the schedules details for all the tenants

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetSchedules Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetSchedules Method
ISchedulerService Interface See Also Send Feedback
This method fetches all the schedules details for all the tenants

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Schedule> GetSchedules()
Visual Basic
Function GetSchedules As Dictionary(Of String, Schedule)
Visual C++
Dictionary<String^, Schedule^>^ GetSchedules()

Return Value

Type: Dictionary<(Of <(<'String, Schedule >)>)>
returns Dictionary of schedules

See Also

ISchedulerService Interface
ISchedulerService Members
GetSchedules Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetSchedules Method (String[])

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetSchedules Method (array<String>[]()[][])
ISchedulerService Interface See Also Send Feedback
This method fetches all the schedules details for all the tenants

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Schedule> GetSchedules(
    string[] scheduleIds
)
Visual Basic
Function GetSchedules (
    scheduleIds As String()
) As Dictionary(Of String, Schedule)
Visual C++
Dictionary<String^, Schedule^>^ GetSchedules(
    array<String^>^ scheduleIds
)

Parameters

scheduleIds
Type: array<System..::..String>[]()[][]
array of schedule identifiers

Return Value

Type: Dictionary<(Of <(<'String, Schedule >)>)>
returns dictionary of schedules

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
GetSchedules Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetSchedules Method (String[], String[])

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetSchedules Method (array<String>[]()[][], array<String>[]()[][])
ISchedulerService Interface See Also Send Feedback
This method fetches all the schedules details for all the tenants

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Schedule> GetSchedules(
    string[] scheduleIds,
    string[] tenantIds
)
Visual Basic
Function GetSchedules (
    scheduleIds As String(),
    tenantIds As String()
) As Dictionary(Of String, Schedule)
Visual C++
Dictionary<String^, Schedule^>^ GetSchedules(
    array<String^>^ scheduleIds,
    array<String^>^ tenantIds
)

Parameters

scheduleIds
Type: array<System..::..String>[]()[][]
array of schedule identifiers
tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Return Value

Type: Dictionary<(Of <(<'String, Schedule >)>)>
returns dictionary of schedules

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
GetSchedules Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.GetSchedulesByTenant Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..GetSchedulesByTenant Method
ISchedulerService Interface See Also Send Feedback
This method fetches schedule details for the given tenant id

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Schedule> GetSchedulesByTenant(
    string[] tenantIds
)
Visual Basic
Function GetSchedulesByTenant (
    tenantIds As String()
) As Dictionary(Of String, Schedule)
Visual C++
Dictionary<String^, Schedule^>^ GetSchedulesByTenant(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Return Value

Type: Dictionary<(Of <(<'String, Schedule >)>)>
returns a dictionary of schedule details

Exceptions

Exception | Condition
System..::..ArgumentNullException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.MapScheduleJobs Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..MapScheduleJobs Method
ISchedulerService Interface See Also Send Feedback
This service will map the given schedule job relation details (Note: This will delete the previous entries and adds new entries)

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void MapScheduleJobs(
    string scheduleId,
    string[] jobIds
)
Visual Basic
Sub MapScheduleJobs (
    scheduleId As String,
    jobIds As String()
)
Visual C++
void MapScheduleJobs(
    String^ scheduleId,
    array<String^>^ jobIds
)

Parameters

scheduleId
Type: System..::..String
schedule identifier
jobIds
Type: array<System..::..String>[]()[][]
array of job identifiers

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleException |
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleJobsException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.UpdateJob Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..UpdateJob Method
ISchedulerService Interface See Also Send Feedback
This service will update the given job details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateJob(
    Job job
)
Visual Basic
Sub UpdateJob (
    job As Job
)
Visual C++
void UpdateJob(
    Job^ job
)

Parameters

job
Type: CelloSaaS.EventScheduler.Model..::..Job
job details to be updated

Exceptions

Exception | Condition
System..::..ArgumentNullException |
CelloSaaS.EventScheduler.ServiceContracts..::..JobException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ISchedulerService.UpdateSchedule Method

[image]

A Sandcastle Documented Class Library
ISchedulerService..::..UpdateSchedule Method
ISchedulerService Interface See Also Send Feedback
This method will update the given schedule details

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateSchedule(
    Schedule schedule
)
Visual Basic
Sub UpdateSchedule (
    schedule As Schedule
)
Visual C++
void UpdateSchedule(
    Schedule^ schedule
)

Parameters

schedule
Type: CelloSaaS.EventScheduler.Model..::..Schedule
schedule details object

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |

See Also

ISchedulerService Interface
ISchedulerService Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Class

[image]

A Sandcastle Documented Class Library
JobAuditException Class
Members See Also Send Feedback
Represents the schedule audit exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobAuditException : BaseException
Visual Basic
<SerializableAttribute>
Public Class JobAuditException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class JobAuditException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..JobAuditException

See Also

JobAuditException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Members

[image] [image]

A Sandcastle Documented Class Library
JobAuditException Members
JobAuditException Class Constructors Methods Properties Events See Also Send Feedback

The JobAuditException type exposes the following members.

Constructors

 | Name | Description
Public method | JobAuditException()()()() | Initializes a new instance of the JobAuditException class.
Public method | JobAuditException(String) | Initializes a new instance of the JobAuditException class.
Public method | JobAuditException(String, Exception) | Initializes a new instance of the JobAuditException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

JobAuditException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Constructor

[image] [image]

A Sandcastle Documented Class Library
JobAuditException Constructor
JobAuditException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobAuditException()()()() | Initializes a new instance of the JobAuditException class.
Public method | JobAuditException(String) | Initializes a new instance of the JobAuditException class.
Public method | JobAuditException(String, Exception) | Initializes a new instance of the JobAuditException class.

See Also

JobAuditException Class
JobAuditException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Constructor

[image]

A Sandcastle Documented Class Library
JobAuditException Constructor
JobAuditException Class See Also Send Feedback
Initializes a new instance of the JobAuditException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobAuditException()
Visual Basic
Public Sub New
Visual C++
public:
JobAuditException()

See Also

JobAuditException Class
JobAuditException Members
JobAuditException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Constructor (String)

[image]

A Sandcastle Documented Class Library
JobAuditException Constructor (String)
JobAuditException Class See Also Send Feedback
Initializes a new instance of the JobAuditException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobAuditException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
JobAuditException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

JobAuditException Class
JobAuditException Members
JobAuditException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
JobAuditException Constructor (String, Exception)
JobAuditException Class See Also Send Feedback
Initializes a new instance of the JobAuditException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobAuditException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
JobAuditException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

JobAuditException Class
JobAuditException Members
JobAuditException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Methods

[image] [image]

A Sandcastle Documented Class Library
JobAuditException Methods
JobAuditException Class See Also Send Feedback

The JobAuditException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

JobAuditException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Properties

[image] [image]

A Sandcastle Documented Class Library
JobAuditException Properties
JobAuditException Class See Also Send Feedback

The JobAuditException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

JobAuditException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobAuditException Events

[image] [image]

A Sandcastle Documented Class Library
JobAuditException Events
JobAuditException Class See Also Send Feedback

The JobAuditException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

JobAuditException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Class

[image]

A Sandcastle Documented Class Library
JobException Class
Members See Also Send Feedback
Represents the job exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobException : BaseException
Visual Basic
<SerializableAttribute>
Public Class JobException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class JobException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..JobException

See Also

JobException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Members

[image] [image]

A Sandcastle Documented Class Library
JobException Members
JobException Class Constructors Methods Properties Events See Also Send Feedback

The JobException type exposes the following members.

Constructors

 | Name | Description
Public method | JobException()()()() | Initializes a new instance of the JobException class.
Public method | JobException(String) | Initializes a new instance of the JobException class.
Protected method | JobException(SerializationInfo, StreamingContext) | Initializes a new instance of the JobException class.
Public method | JobException(String, Exception) | Initializes a new instance of the JobException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

JobException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Constructor

[image] [image]

A Sandcastle Documented Class Library
JobException Constructor
JobException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JobException()()()() | Initializes a new instance of the JobException class.
Public method | JobException(String) | Initializes a new instance of the JobException class.
Protected method | JobException(SerializationInfo, StreamingContext) | Initializes a new instance of the JobException class.
Public method | JobException(String, Exception) | Initializes a new instance of the JobException class.

See Also

JobException Class
JobException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Constructor

[image]

A Sandcastle Documented Class Library
JobException Constructor
JobException Class See Also Send Feedback
Initializes a new instance of the JobException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobException()
Visual Basic
Public Sub New
Visual C++
public:
JobException()

See Also

JobException Class
JobException Members
JobException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Constructor (String)

[image]

A Sandcastle Documented Class Library
JobException Constructor (String)
JobException Class See Also Send Feedback
Initializes a new instance of the JobException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
JobException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

JobException Class
JobException Members
JobException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
JobException Constructor (SerializationInfo, StreamingContext)
JobException Class See Also Send Feedback
Initializes a new instance of the JobException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected JobException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
JobException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

JobException Class
JobException Members
JobException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
JobException Constructor (String, Exception)
JobException Class See Also Send Feedback
Initializes a new instance of the JobException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
JobException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

JobException Class
JobException Members
JobException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Methods

[image] [image]

A Sandcastle Documented Class Library
JobException Methods
JobException Class See Also Send Feedback

The JobException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

JobException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Properties

[image] [image]

A Sandcastle Documented Class Library
JobException Properties
JobException Class See Also Send Feedback

The JobException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

JobException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


JobException Events

[image] [image]

A Sandcastle Documented Class Library
JobException Events
JobException Class See Also Send Feedback

The JobException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

JobException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Class

[image]

A Sandcastle Documented Class Library
ScheduleException Class
Members See Also Send Feedback
Represents the schedule exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ScheduleException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ScheduleException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ScheduleException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleException

See Also

ScheduleException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Members

[image] [image]

A Sandcastle Documented Class Library
ScheduleException Members
ScheduleException Class Constructors Methods Properties Events See Also Send Feedback

The ScheduleException type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleException()()()() | Initializes a new instance of the ScheduleException class.
Public method | ScheduleException(String) | Initializes a new instance of the ScheduleException class.
Protected method | ScheduleException(SerializationInfo, StreamingContext) | Initializes a new instance of the ScheduleException class.
Public method | ScheduleException(String, Exception) | Initializes a new instance of the ScheduleException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Constructor

[image] [image]

A Sandcastle Documented Class Library
ScheduleException Constructor
ScheduleException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduleException()()()() | Initializes a new instance of the ScheduleException class.
Public method | ScheduleException(String) | Initializes a new instance of the ScheduleException class.
Protected method | ScheduleException(SerializationInfo, StreamingContext) | Initializes a new instance of the ScheduleException class.
Public method | ScheduleException(String, Exception) | Initializes a new instance of the ScheduleException class.

See Also

ScheduleException Class
ScheduleException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Constructor

[image]

A Sandcastle Documented Class Library
ScheduleException Constructor
ScheduleException Class See Also Send Feedback
Initializes a new instance of the ScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleException()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleException()

See Also

ScheduleException Class
ScheduleException Members
ScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Constructor (String)

[image]

A Sandcastle Documented Class Library
ScheduleException Constructor (String)
ScheduleException Class See Also Send Feedback
Initializes a new instance of the ScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ScheduleException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ScheduleException Class
ScheduleException Members
ScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
ScheduleException Constructor (SerializationInfo, StreamingContext)
ScheduleException Class See Also Send Feedback
Initializes a new instance of the ScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected ScheduleException(
    SerializationInfo serializationInfo,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
ScheduleException(
    SerializationInfo^ serializationInfo,
    StreamingContext context
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

ScheduleException Class
ScheduleException Members
ScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ScheduleException Constructor (String, Exception)
ScheduleException Class See Also Send Feedback
Initializes a new instance of the ScheduleException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ScheduleException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

ScheduleException Class
ScheduleException Members
ScheduleException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Methods

[image] [image]

A Sandcastle Documented Class Library
ScheduleException Methods
ScheduleException Class See Also Send Feedback

The ScheduleException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Properties

[image] [image]

A Sandcastle Documented Class Library
ScheduleException Properties
ScheduleException Class See Also Send Feedback

The ScheduleException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleException Events

[image] [image]

A Sandcastle Documented Class Library
ScheduleException Events
ScheduleException Class See Also Send Feedback

The ScheduleException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ScheduleException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Class

[image]

A Sandcastle Documented Class Library
ScheduleJobsException Class
Members See Also Send Feedback
Represents the schedule jobs exception

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ScheduleJobsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ScheduleJobsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ScheduleJobsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.EventScheduler.ServiceContracts..::..ScheduleJobsException

See Also

ScheduleJobsException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Members

[image] [image]

A Sandcastle Documented Class Library
ScheduleJobsException Members
ScheduleJobsException Class Constructors Methods Properties Events See Also Send Feedback

The ScheduleJobsException type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleJobsException()()()() | Initializes a new instance of the ScheduleJobsException class.
Public method | ScheduleJobsException(String) | Initializes a new instance of the ScheduleJobsException class.
Public method | ScheduleJobsException(String, Exception) | Initializes a new instance of the ScheduleJobsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ScheduleJobsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Constructor

[image] [image]

A Sandcastle Documented Class Library
ScheduleJobsException Constructor
ScheduleJobsException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduleJobsException()()()() | Initializes a new instance of the ScheduleJobsException class.
Public method | ScheduleJobsException(String) | Initializes a new instance of the ScheduleJobsException class.
Public method | ScheduleJobsException(String, Exception) | Initializes a new instance of the ScheduleJobsException class.

See Also

ScheduleJobsException Class
ScheduleJobsException Members
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Constructor

[image]

A Sandcastle Documented Class Library
ScheduleJobsException Constructor
ScheduleJobsException Class See Also Send Feedback
Initializes a new instance of the ScheduleJobsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleJobsException()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleJobsException()

See Also

ScheduleJobsException Class
ScheduleJobsException Members
ScheduleJobsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Constructor (String)

[image]

A Sandcastle Documented Class Library
ScheduleJobsException Constructor (String)
ScheduleJobsException Class See Also Send Feedback
Initializes a new instance of the ScheduleJobsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleJobsException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ScheduleJobsException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ScheduleJobsException Class
ScheduleJobsException Members
ScheduleJobsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ScheduleJobsException Constructor (String, Exception)
ScheduleJobsException Class See Also Send Feedback
Initializes a new instance of the ScheduleJobsException class.

Namespace: CelloSaaS.EventScheduler.ServiceContracts
Assembly: CelloSaaS.EventScheduler (in CelloSaaS.EventScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ScheduleJobsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ScheduleJobsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

ScheduleJobsException Class
ScheduleJobsException Members
ScheduleJobsException Overload
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Methods

[image] [image]

A Sandcastle Documented Class Library
ScheduleJobsException Methods
ScheduleJobsException Class See Also Send Feedback

The ScheduleJobsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ScheduleJobsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Properties

[image] [image]

A Sandcastle Documented Class Library
ScheduleJobsException Properties
ScheduleJobsException Class See Also Send Feedback

The ScheduleJobsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ScheduleJobsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


ScheduleJobsException Events

[image] [image]

A Sandcastle Documented Class Library
ScheduleJobsException Events
ScheduleJobsException Class See Also Send Feedback

The ScheduleJobsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ScheduleJobsException Class
CelloSaaS.EventScheduler.ServiceContracts Namespace


CelloSaaS.Integration.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Integration.ServiceContracts Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | ICelloServiceEndpointManager | WCF Service management interface


ICelloServiceEndpointManager Interface

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager Interface
Members See Also Send Feedback
WCF Service management interface

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ICelloServiceEndpointManager
Visual Basic
Public Interface ICelloServiceEndpointManager
Visual C++
public interface class ICelloServiceEndpointManager

See Also

ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager Members

[image] [image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager Members
ICelloServiceEndpointManager Interface Methods See Also Send Feedback

The ICelloServiceEndpointManager type exposes the following members.

Methods

 | Name | Description
Public method | AddServiceEndpoint | Adds the service endpoint metadata to database.
Public method | DeleteServiceEndpoint | Deletes the given endpoint metadata identifier from the database
Public method | GetServiceEndpoint | Gets the service endpoint metadata from the database
Public method | GetServiceEndpointByName | Searchs the endpoint metadata by given endpoint name in the database.
Public method | GetServiceEndpointByTenantId | Searchs all the endpoint metadata's for the given tenant identifier
Public method | InvokeService | Invokes web service directly from given endpoint url and xml.
Public method | InvokeServiceById | Calls the given web service with the inputXml and returns the output xml.
Public method | InvokeServiceByName | Calls the given web service with the inputXml and returns the output xml.
Public method | UpdateServiceEndpoint | Update the service endpoint metadata in the database.

See Also

ICelloServiceEndpointManager Interface
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager Methods

[image] [image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager Methods
ICelloServiceEndpointManager Interface See Also Send Feedback

The ICelloServiceEndpointManager type exposes the following members.

Methods

 | Name | Description
Public method | AddServiceEndpoint | Adds the service endpoint metadata to database.
Public method | DeleteServiceEndpoint | Deletes the given endpoint metadata identifier from the database
Public method | GetServiceEndpoint | Gets the service endpoint metadata from the database
Public method | GetServiceEndpointByName | Searchs the endpoint metadata by given endpoint name in the database.
Public method | GetServiceEndpointByTenantId | Searchs all the endpoint metadata's for the given tenant identifier
Public method | InvokeService | Invokes web service directly from given endpoint url and xml.
Public method | InvokeServiceById | Calls the given web service with the inputXml and returns the output xml.
Public method | InvokeServiceByName | Calls the given web service with the inputXml and returns the output xml.
Public method | UpdateServiceEndpoint | Update the service endpoint metadata in the database.

See Also

ICelloServiceEndpointManager Interface
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.AddServiceEndpoint Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..AddServiceEndpoint Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Adds the service endpoint metadata to database.

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddServiceEndpoint(
    CelloServiceEndpoint endpoint
)
Visual Basic
Function AddServiceEndpoint (
    endpoint As CelloServiceEndpoint
) As String
Visual C++
String^ AddServiceEndpoint(
    CelloServiceEndpoint^ endpoint
)

Parameters

endpoint
Type: CelloServiceEndpoint
The endpoint.

Return Value

Type: String

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.DeleteServiceEndpoint Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..DeleteServiceEndpoint Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Deletes the given endpoint metadata identifier from the database

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteServiceEndpoint(
    string endpointId,
    string tenantId
)
Visual Basic
Sub DeleteServiceEndpoint (
    endpointId As String,
    tenantId As String
)
Visual C++
void DeleteServiceEndpoint(
    String^ endpointId,
    String^ tenantId
)

Parameters

endpointId
Type: System..::..String
Endpoint identifier
tenantId
Type: System..::..String
Tenant identifier

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.GetServiceEndpoint Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..GetServiceEndpoint Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Gets the service endpoint metadata from the database

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
CelloServiceEndpoint GetServiceEndpoint(
    string endpointId,
    string tenantId
)
Visual Basic
Function GetServiceEndpoint (
    endpointId As String,
    tenantId As String
) As CelloServiceEndpoint
Visual C++
CelloServiceEndpoint^ GetServiceEndpoint(
    String^ endpointId,
    String^ tenantId
)

Parameters

endpointId
Type: System..::..String
tenantId
Type: System..::..String

Return Value

Type: CelloServiceEndpoint

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.GetServiceEndpointByName Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..GetServiceEndpointByName Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Searchs the endpoint metadata by given endpoint name in the database.

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
CelloServiceEndpoint GetServiceEndpointByName(
    string name,
    string tenantId
)
Visual Basic
Function GetServiceEndpointByName (
    name As String,
    tenantId As String
) As CelloServiceEndpoint
Visual C++
CelloServiceEndpoint^ GetServiceEndpointByName(
    String^ name,
    String^ tenantId
)

Parameters

name
Type: System..::..String
endpoint name to search.
tenantId
Type: System..::..String
tenant identifier

Return Value

Type: CelloServiceEndpoint

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.GetServiceEndpointByTenantId Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..GetServiceEndpointByTenantId Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Searchs all the endpoint metadata's for the given tenant identifier

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, CelloServiceEndpoint> GetServiceEndpointByTenantId(
    string tenantId
)
Visual Basic
Function GetServiceEndpointByTenantId (
    tenantId As String
) As Dictionary(Of String, CelloServiceEndpoint)
Visual C++
Dictionary<String^, CelloServiceEndpoint^>^ GetServiceEndpointByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
tenant identifier

Return Value

Type: Dictionary<(Of <(<'String, CelloServiceEndpoint>)>)>

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.InvokeService Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..InvokeService Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Invokes web service directly from given endpoint url and xml.

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InvokeService(
    CelloServiceEndpoint endpointDetails,
    string inputXml
)
Visual Basic
Function InvokeService (
    endpointDetails As CelloServiceEndpoint,
    inputXml As String
) As String
Visual C++
String^ InvokeService(
    CelloServiceEndpoint^ endpointDetails,
    String^ inputXml
)

Parameters

endpointDetails
Type: CelloServiceEndpoint
service endpoint url
inputXml
Type: System..::..String
input xml.

Return Value

Type: String

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.InvokeServiceById Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..InvokeServiceById Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Calls the given web service with the inputXml and returns the output xml.

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InvokeServiceById(
    string serviceEndpointId,
    string tenantId,
    string inputXml
)
Visual Basic
Function InvokeServiceById (
    serviceEndpointId As String,
    tenantId As String,
    inputXml As String
) As String
Visual C++
String^ InvokeServiceById(
    String^ serviceEndpointId,
    String^ tenantId,
    String^ inputXml
)

Parameters

serviceEndpointId
Type: System..::..String
service endpoint primary key
tenantId
Type: System..::..String
tenant identifier
inputXml
Type: System..::..String
body xml string

Return Value

Type: String

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.InvokeServiceByName Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..InvokeServiceByName Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Calls the given web service with the inputXml and returns the output xml.

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InvokeServiceByName(
    string serviceEndpointName,
    string tenantId,
    string inputXml
)
Visual Basic
Function InvokeServiceByName (
    serviceEndpointName As String,
    tenantId As String,
    inputXml As String
) As String
Visual C++
String^ InvokeServiceByName(
    String^ serviceEndpointName,
    String^ tenantId,
    String^ inputXml
)

Parameters

serviceEndpointName
Type: System..::..String
service endpoint name
tenantId
Type: System..::..String
tenant identifier
inputXml
Type: System..::..String
body xml string

Return Value

Type: String

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


ICelloServiceEndpointManager.UpdateServiceEndpoint Method

[image]

A Sandcastle Documented Class Library
ICelloServiceEndpointManager..::..UpdateServiceEndpoint Method
ICelloServiceEndpointManager Interface See Also Send Feedback
Update the service endpoint metadata in the database.

Namespace: CelloSaaS.Integration.ServiceContracts
Assembly: CelloSaaS.Integration (in CelloSaaS.Integration.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateServiceEndpoint(
    CelloServiceEndpoint endpoint
)
Visual Basic
Sub UpdateServiceEndpoint (
    endpoint As CelloServiceEndpoint
)
Visual C++
void UpdateServiceEndpoint(
    CelloServiceEndpoint^ endpoint
)

Parameters

endpoint
Type: CelloServiceEndpoint
Endpoint metadata to update.

See Also

ICelloServiceEndpointManager Interface
ICelloServiceEndpointManager Members
CelloSaaS.Integration.ServiceContracts Namespace


CelloSaaS.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | ActionEventArgs | Action Event Args
Public class | BaseEntity | Base Entity Properties
Public class | CelloDbContext | CelloSaaS wrapper for DbContext
Public class | CelloEntityObject | Cello entity object for EF
Public class | CelloEventConstant | This Class represents the Cello Event Constants
Public class | CelloObjectContext | CelloSaaS wrapper for ObjectContext
Public class | CreateEventArgs | Create Event Args
Public class | DeleteEventArgs | Delete Event Args
Public class | EntityAction | Entity Action Properties
Public class | EntityConstants | Entity constants
Public class | EntityDescriptorAttribute | This attribute contains properties which will be used to auto-generate the entity configuration.
Public class | EntityFieldDescriptor | This attribute describes the field details so that the entity configuration can be auto-generated
Public class | EntityIdentifierAttribute | Entity Identifier Attribute Properties
Public class | EntityMetadataTypeAttribute | This attribute tells where to look for the metadata of this entity
Public class | FetchEventArgs | Fetch Event Args
Public class | InvalidSearchConditionException | Invalid Condition Format Exception
Public class | PickupListConstants | Pickup list constants class
Public class | SearchCondition | Search condition properties
Public class | SearchParameters | Search parameter properties
Public class | SearchString | Search Entity Column Model
Public class | SearchSummary | Search summary properties
Public class | SettingsTemplateConstants | Settings template constants class
Public class | SortExpressionConstants | Sort expression constants
Public class | TenantTransactionalEntity | This class contain Tenant Id property
Public class | TransactionalBaseEntity | This class contains guid and integer identifiers
Public class | UpdateEventArgs | Update Event Args

Interfaces

 | Interface | Description
Public interface | ISearchCondition | Search condition Interface

Enumerations

 | Enumeration | Description
Public enumeration | EntityOperation | Entity Operation type
Public enumeration | FetchType | Data Fetch type enumeration
Public enumeration | IdentifierType | Identifier Type


ActionEventArgs Class

[image]

A Sandcastle Documented Class Library
ActionEventArgs Class
Members See Also Send Feedback
Action Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ActionEventArgs : EventArgs
Visual Basic
Public Class ActionEventArgs
    Inherits EventArgs
Visual C++
public ref class ActionEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
CelloSaaS.Model..::..ActionEventArgs
CelloSaaS.Model..::..CreateEventArgs
CelloSaaS.Model..::..DeleteEventArgs
CelloSaaS.Model..::..FetchEventArgs
CelloSaaS.Model..::..UpdateEventArgs

See Also

ActionEventArgs Members
CelloSaaS.Model Namespace


ActionEventArgs Members

[image] [image]

A Sandcastle Documented Class Library
ActionEventArgs Members
ActionEventArgs Class Constructors Methods Properties See Also Send Feedback

The ActionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ActionEventArgs | Constructor for Action Event Args

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not
Public property | CurrentContextModel | Gets or sets the base entity properties
Public property | EntityAction | Gets or sets the entity action properties
Public property | EntityIdentifier | Gets or sets the entity identifier
Public property | Exception | Gets or sets the exception

See Also

ActionEventArgs Class
CelloSaaS.Model Namespace


ActionEventArgs Constructor

[image]

A Sandcastle Documented Class Library
ActionEventArgs Constructor
ActionEventArgs Class See Also Send Feedback
Constructor for Action Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ActionEventArgs(
    string entityIdentifier,
    BaseEntity currentContextModel,
    EntityAction entityAction
)
Visual Basic
Public Sub New (
    entityIdentifier As String,
    currentContextModel As BaseEntity,
    entityAction As EntityAction
)
Visual C++
public:
ActionEventArgs(
    String^ entityIdentifier,
    BaseEntity^ currentContextModel,
    EntityAction^ entityAction
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
currentContextModel
Type: CelloSaaS.Model..::..BaseEntity
Current object model
entityAction
Type: CelloSaaS.Model..::..EntityAction
Entity Action Properties

See Also

ActionEventArgs Class
ActionEventArgs Members
CelloSaaS.Model Namespace


ActionEventArgs Methods

[image] [image]

A Sandcastle Documented Class Library
ActionEventArgs Methods
ActionEventArgs Class See Also Send Feedback

The ActionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ActionEventArgs Class
CelloSaaS.Model Namespace


ActionEventArgs Properties

[image] [image]

A Sandcastle Documented Class Library
ActionEventArgs Properties
ActionEventArgs Class See Also Send Feedback

The ActionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not
Public property | CurrentContextModel | Gets or sets the base entity properties
Public property | EntityAction | Gets or sets the entity action properties
Public property | EntityIdentifier | Gets or sets the entity identifier
Public property | Exception | Gets or sets the exception

See Also

ActionEventArgs Class
CelloSaaS.Model Namespace


ActionEventArgs.Canceled Property

[image]

A Sandcastle Documented Class Library
ActionEventArgs..::..Canceled Property
ActionEventArgs Class See Also Send Feedback
Gets or sets whether this is cancelled or not

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Canceled { get; set; }
Visual Basic
Public Property Canceled As Boolean
    Get
    Set
Visual C++
public:
property bool Canceled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ActionEventArgs Class
ActionEventArgs Members
CelloSaaS.Model Namespace


ActionEventArgs.CurrentContextModel Property

[image]

A Sandcastle Documented Class Library
ActionEventArgs..::..CurrentContextModel Property
ActionEventArgs Class See Also Send Feedback
Gets or sets the base entity properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BaseEntity CurrentContextModel { get; set; }
Visual Basic
Public Property CurrentContextModel As BaseEntity
    Get
    Set
Visual C++
public:
property BaseEntity^ CurrentContextModel {
    BaseEntity^ get ();
    void set (BaseEntity^ value);
}

Property Value

Type: BaseEntity

See Also

ActionEventArgs Class
ActionEventArgs Members
CelloSaaS.Model Namespace


ActionEventArgs.EntityAction Property

[image]

A Sandcastle Documented Class Library
ActionEventArgs..::..EntityAction Property
ActionEventArgs Class See Also Send Feedback
Gets or sets the entity action properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityAction EntityAction { get; set; }
Visual Basic
Public Property EntityAction As EntityAction
    Get
    Set
Visual C++
public:
property EntityAction^ EntityAction {
    EntityAction^ get ();
    void set (EntityAction^ value);
}

Property Value

Type: EntityAction

See Also

ActionEventArgs Class
ActionEventArgs Members
CelloSaaS.Model Namespace


ActionEventArgs.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
ActionEventArgs..::..EntityIdentifier Property
ActionEventArgs Class See Also Send Feedback
Gets or sets the entity identifier

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityIdentifier { get; set; }
Visual Basic
Public Property EntityIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ActionEventArgs Class
ActionEventArgs Members
CelloSaaS.Model Namespace


ActionEventArgs.Exception Property

[image]

A Sandcastle Documented Class Library
ActionEventArgs..::..Exception Property
ActionEventArgs Class See Also Send Feedback
Gets or sets the exception

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic
Public Property Exception As Exception
    Get
    Set
Visual C++
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}

Property Value

Type: Exception

See Also

ActionEventArgs Class
ActionEventArgs Members
CelloSaaS.Model Namespace


BaseEntity Class

[image]

A Sandcastle Documented Class Library
BaseEntity Class
Members See Also Send Feedback
Base Entity Properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public abstract class BaseEntity : ITrackable
Visual Basic
<SerializableAttribute>
Public MustInherit Class BaseEntity
    Implements ITrackable
Visual C++
[SerializableAttribute]
public ref class BaseEntity abstract : ITrackable

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Billing.Model..::..Invoice
CelloSaaS.Model.AccessControlManagement..::..Role
CelloSaaS.Model.LicenseManagement..::..LicensePackage
CelloSaaS.Model.LicenseManagement..::..PackageDetails
CelloSaaS.Model.MasterDataManagement..::..MasterDataEntity
CelloSaaS.Model.ProductAnalytics..::..ProductAnalytics
CelloSaaS.Model.SettingsManagement..::..SettingsTemplate
CelloSaaS.Model.SettingsManagement..::..TenantSettingsTemplate
CelloSaaS.Model.TenantManagement..::..Address
CelloSaaS.Model.TenantManagement..::..ContactDetails
CelloSaaS.Model.TenantManagement..::..Tenant
CelloSaaS.Model.TenantManagement..::..TenantDetails
CelloSaaS.Model.TenantManagement..::..TenantRelation
CelloSaaS.Model.TenantManagement..::..TenantRelationMapping
CelloSaaS.Model.TenantManagement..::..TenantRelationType
CelloSaaS.Model.TenantManagement..::..TenantType
CelloSaaS.Model..::..TransactionalBaseEntity
CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
CelloSaaS.Model.UserManagement..::..MembershipDetails
CelloSaaS.Model.UserManagement..::..User
CelloSaaS.Model.UserManagement..::..UserDetails
CelloSaaS.Model.UserManagement..::..UserPasswordExpiry
CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntity

See Also

BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity Members

[image] [image]

A Sandcastle Documented Class Library
BaseEntity Members
BaseEntity Class Constructors Methods Properties See Also Send Feedback

The BaseEntity type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseEntity | Initializes a new instance of the BaseEntity class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity
Public method | GetDeletedChanges | This method is used to get delete values in the entity
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier
Public property | ExtendedRow | Gets or sets the extended entity row properties
Public property | Identifier | Gets or sets the Entity Identifier
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not.
Public property | TrackingAdapter | Gets or sets tracking adapter property

See Also

BaseEntity Class
CelloSaaS.Model Namespace


BaseEntity Constructor

[image]

A Sandcastle Documented Class Library
BaseEntity Constructor
BaseEntity Class See Also Send Feedback
Initializes a new instance of the BaseEntity class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected BaseEntity()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseEntity()

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity Methods

[image] [image]

A Sandcastle Documented Class Library
BaseEntity Methods
BaseEntity Class See Also Send Feedback

The BaseEntity type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity
Public method | GetDeletedChanges | This method is used to get delete values in the entity
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity

See Also

BaseEntity Class
CelloSaaS.Model Namespace


BaseEntity.ApplyChanges Method

[image]

A Sandcastle Documented Class Library
BaseEntity..::..ApplyChanges Method
BaseEntity Class See Also Send Feedback
This method is used to apply changes in the entity

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual void ApplyChanges()
Visual Basic
Public Overridable Sub ApplyChanges
Visual C++
public:
virtual void ApplyChanges()

Implements

ITrackableApplyChanges()()()()

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.GetChanges Method

[image]

A Sandcastle Documented Class Library
BaseEntity..::..GetChanges Method
BaseEntity Class See Also Send Feedback
This mehod is used to get changes done in entity

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual Changes GetChanges()
Visual Basic
Public Overridable Function GetChanges As Changes
Visual C++
public:
virtual Changes^ GetChanges()

Return Value

Type: Changes
Change details

Implements

ITrackableGetChanges()()()()

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.GetDeletedChanges Method

[image]

A Sandcastle Documented Class Library
BaseEntity..::..GetDeletedChanges Method
BaseEntity Class See Also Send Feedback
This method is used to get delete values in the entity

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual Changes GetDeletedChanges()
Visual Basic
Public Overridable Function GetDeletedChanges As Changes
Visual C++
public:
virtual Changes^ GetDeletedChanges()

Return Value

Type: Changes
Deleted Details

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.TrackChanges Method

[image]

A Sandcastle Documented Class Library
BaseEntity..::..TrackChanges Method
BaseEntity Class See Also Send Feedback
This is used to track changes in the entity

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual void TrackChanges()
Visual Basic
Public Overridable Sub TrackChanges
Visual C++
public:
virtual void TrackChanges()

Implements

ITrackableTrackChanges()()()()

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity Properties

[image] [image]

A Sandcastle Documented Class Library
BaseEntity Properties
BaseEntity Class See Also Send Feedback

The BaseEntity type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier
Public property | ExtendedRow | Gets or sets the extended entity row properties
Public property | Identifier | Gets or sets the Entity Identifier
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not.
Public property | TrackingAdapter | Gets or sets tracking adapter property

See Also

BaseEntity Class
CelloSaaS.Model Namespace


BaseEntity.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
BaseEntity..::..EntityIdentifier Property
BaseEntity Class See Also Send Feedback
Gets the entity Identifier

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual string EntityIdentifier { get; protected set; }
Visual Basic
Public Overridable Property EntityIdentifier As String
    Get
    Protected Set
Visual C++
public:
virtual property String^ EntityIdentifier {
    String^ get ();
    protected: void set (String^ value);
}

Property Value

Type: String
The entity identifier.

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.ExtendedRow Property

[image]

A Sandcastle Documented Class Library
BaseEntity..::..ExtendedRow Property
BaseEntity Class See Also Send Feedback
Gets or sets the extended entity row properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual ExtendedEntityRow ExtendedRow { get; set; }
Visual Basic
Public Overridable Property ExtendedRow As ExtendedEntityRow
    Get
    Set
Visual C++
public:
virtual property ExtendedEntityRow^ ExtendedRow {
    ExtendedEntityRow^ get ();
    void set (ExtendedEntityRow^ value);
}

Property Value

Type: ExtendedEntityRow

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.Identifier Property

[image]

A Sandcastle Documented Class Library
BaseEntity..::..Identifier Property
BaseEntity Class See Also Send Feedback
Gets or sets the Entity Identifier

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual string Identifier { get; set; }
Visual Basic
Public Overridable Property Identifier As String
    Get
    Set
Visual C++
public:
virtual property String^ Identifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.IsTrackingOn Property

[image]

A Sandcastle Documented Class Library
BaseEntity..::..IsTrackingOn Property
BaseEntity Class See Also Send Feedback
Gets or sets whether entity has trackability or not.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual bool IsTrackingOn { get; set; }
Visual Basic
Public Overridable Property IsTrackingOn As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsTrackingOn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ITrackableIsTrackingOn

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


BaseEntity.TrackingAdapter Property

[image]

A Sandcastle Documented Class Library
BaseEntity..::..TrackingAdapter Property
BaseEntity Class See Also Send Feedback
Gets or sets tracking adapter property

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual ITrackingAdapter TrackingAdapter { get; set; }
Visual Basic
Public Overridable Property TrackingAdapter As ITrackingAdapter
    Get
    Set
Visual C++
public:
virtual property ITrackingAdapter^ TrackingAdapter {
    ITrackingAdapter^ get ();
    void set (ITrackingAdapter^ value);
}

Property Value

Type: ITrackingAdapter

See Also

BaseEntity Class
BaseEntity Members
CelloSaaS.Model Namespace


CelloDbContext Class

[image]

A Sandcastle Documented Class Library
CelloDbContext Class
Members See Also Send Feedback
CelloSaaS wrapper for DbContext

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class CelloDbContext : DbContext
Visual Basic
Public Class CelloDbContext
    Inherits DbContext
Visual C++
public ref class CelloDbContext : public DbContext

Inheritance Hierarchy

System..::..Object
DbContext
CelloSaaS.Model..::..CelloDbContext

See Also

CelloDbContext Members
CelloSaaS.Model Namespace


CelloDbContext Members

[image] [image]

A Sandcastle Documented Class Library
CelloDbContext Members
CelloDbContext Class Constructors Methods Properties See Also Send Feedback

The CelloDbContext type exposes the following members.

Constructors

 | Name | Description
Public method | CelloDbContext(DbConnection) | Creates Db Context with the given db connection object
Public method | CelloDbContext(String, String) | Creates Db Context with the given connection string name and metadata

Methods

 | Name | Description
Public method | ApplySecurity<(Of <<'(TEntity>)>>) | Applies tenant filter for the given query
Public method | Dispose()()()() | (Inherited from DbContext.)
Protected method | Dispose(Boolean) | (Inherited from DbContext.)
Public method | Entry(Object) | (Inherited from DbContext.)
Public method | Entry``1(UMP) | (Inherited from DbContext.)
Public method | Equals | (Inherited from DbContext.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCelloDbConnection | Creates DbConnection object for use in DbContext Connection string will be automatically changed according to logged in tenant setting
 | GetEntityConnectionString | Forms EntityFramework connection string with metadata infered from context type
Public method | GetHashCode | (Inherited from DbContext.)
Public method | GetQueryable<(Of <<'(TEntity>)>>) | Creates queryable object by applying tenant filter and returns it
Public method | GetType | (Inherited from DbContext.)
Public method | GetValidationErrors | (Inherited from DbContext.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnModelCreating | (Inherited from DbContext.)
Public method | SaveChanges | (Inherited from DbContext.)
Public method | SaveChangesAsync()()()() | (Inherited from DbContext.)
Public method | SaveChangesAsync(CancellationToken) | (Inherited from DbContext.)
Public method | Set(Type) | (Inherited from DbContext.)
Public method | Set``1()()()() | (Inherited from DbContext.)
Protected method | ShouldValidateEntity | (Inherited from DbContext.)
Public method | ToString | (Inherited from DbContext.)
Protected method | ValidateEntity | (Inherited from DbContext.)

Properties

 | Name | Description
Public property | ChangeTracker | (Inherited from DbContext.)
Public property | Configuration | (Inherited from DbContext.)
Public property | Database | (Inherited from DbContext.)

See Also

CelloDbContext Class
CelloSaaS.Model Namespace


CelloDbContext Constructor

[image] [image]

A Sandcastle Documented Class Library
CelloDbContext Constructor
CelloDbContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CelloDbContext(DbConnection) | Creates Db Context with the given db connection object
Public method | CelloDbContext(String, String) | Creates Db Context with the given connection string name and metadata

See Also

CelloDbContext Class
CelloDbContext Members
CelloSaaS.Model Namespace


CelloDbContext Constructor (DbConnection)

[image]

A Sandcastle Documented Class Library
CelloDbContext Constructor (DbConnection)
CelloDbContext Class See Also Send Feedback
Creates Db Context with the given db connection object

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloDbContext(
    DbConnection connection
)
Visual Basic
Public Sub New (
    connection As DbConnection
)
Visual C++
public:
CelloDbContext(
    DbConnection^ connection
)

Parameters

connection
Type: System.Data.Common..::..DbConnection
db connection object

See Also

CelloDbContext Class
CelloDbContext Members
CelloDbContext Overload
CelloSaaS.Model Namespace


CelloDbContext Constructor (String, String)

[image]

A Sandcastle Documented Class Library
CelloDbContext Constructor (String, String)
CelloDbContext Class See Also Send Feedback
Creates Db Context with the given connection string name and metadata

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloDbContext(
    string connectionStringName,
    string metadata = "res://*/"
)
Visual Basic
Public Sub New (
    connectionStringName As String,
    Optional metadata As String = "res://*/"
)
Visual C++
public:
CelloDbContext(
    String^ connectionStringName,
    String^ metadata = L"res://*/"
)

Parameters

connectionStringName
Type: System..::..String
connection string name e.g.: ApplicationConnectionString
metadata (Optional)
Type: System..::..String
metadata url

See Also

CelloDbContext Class
CelloDbContext Members
CelloDbContext Overload
CelloSaaS.Model Namespace


CelloDbContext Methods

[image] [image]

A Sandcastle Documented Class Library
CelloDbContext Methods
CelloDbContext Class See Also Send Feedback

The CelloDbContext type exposes the following members.

Methods

 | Name | Description
Public method | ApplySecurity<(Of <<'(TEntity>)>>) | Applies tenant filter for the given query
Public method | Dispose()()()() | (Inherited from DbContext.)
Protected method | Dispose(Boolean) | (Inherited from DbContext.)
Public method | Entry(Object) | (Inherited from DbContext.)
Public method | Entry``1(UMP) | (Inherited from DbContext.)
Public method | Equals | (Inherited from DbContext.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCelloDbConnection | Creates DbConnection object for use in DbContext Connection string will be automatically changed according to logged in tenant setting
 | GetEntityConnectionString | Forms EntityFramework connection string with metadata infered from context type
Public method | GetHashCode | (Inherited from DbContext.)
Public method | GetQueryable<(Of <<'(TEntity>)>>) | Creates queryable object by applying tenant filter and returns it
Public method | GetType | (Inherited from DbContext.)
Public method | GetValidationErrors | (Inherited from DbContext.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnModelCreating | (Inherited from DbContext.)
Public method | SaveChanges | (Inherited from DbContext.)
Public method | SaveChangesAsync()()()() | (Inherited from DbContext.)
Public method | SaveChangesAsync(CancellationToken) | (Inherited from DbContext.)
Public method | Set(Type) | (Inherited from DbContext.)
Public method | Set``1()()()() | (Inherited from DbContext.)
Protected method | ShouldValidateEntity | (Inherited from DbContext.)
Public method | ToString | (Inherited from DbContext.)
Protected method | ValidateEntity | (Inherited from DbContext.)

See Also

CelloDbContext Class
CelloSaaS.Model Namespace


CelloDbContext.ApplySecurity(TEntity) Method

[image]

A Sandcastle Documented Class Library
CelloDbContext..::..ApplySecurity<(Of <(<'TEntity>)>)> Method
CelloDbContext Class See Also Send Feedback
Applies tenant filter for the given query

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IQueryable<TEntity> ApplySecurity<TEntity>(
    IQueryable<TEntity> query
)
where TEntity : TenantTransactionalEntity
Visual Basic
Public Function ApplySecurity(Of TEntity As TenantTransactionalEntity) (
    query As IQueryable(Of TEntity)
) As IQueryable(Of TEntity)
Visual C++
public:
generic<typename TEntity>
where TEntity : TenantTransactionalEntity
IQueryable<TEntity>^ ApplySecurity(
    IQueryable<TEntity>^ query
)

Parameters

query
Type: System.Linq..::..IQueryable<(Of <(<'TEntity>)>)>
queryable object

Type Parameters

TEntity
Business entity must inherit from TenantTransactionalEntity

Return Value

Type: IQueryable<(Of <(<'TEntity>)>)>

See Also

CelloDbContext Class
CelloDbContext Members
CelloSaaS.Model Namespace


CelloDbContext.GetCelloDbConnection Method

[image]

A Sandcastle Documented Class Library
CelloDbContext..::..GetCelloDbConnection Method
CelloDbContext Class See Also Send Feedback
Creates DbConnection object for use in DbContext Connection string will be automatically changed according to logged in tenant setting

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected static DbConnection GetCelloDbConnection(
    string connectionStringName
)
Visual Basic
Protected Shared Function GetCelloDbConnection (
    connectionStringName As String
) As DbConnection
Visual C++
protected:
static DbConnection^ GetCelloDbConnection(
    String^ connectionStringName
)

Parameters

connectionStringName
Type: System..::..String

Return Value

Type: DbConnection

See Also

CelloDbContext Class
CelloDbContext Members
CelloSaaS.Model Namespace


CelloDbContext.GetEntityConnectionString Method

[image]

A Sandcastle Documented Class Library
CelloDbContext..::..GetEntityConnectionString Method
CelloDbContext Class See Also Send Feedback
Forms EntityFramework connection string with metadata infered from context type

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected static string GetEntityConnectionString(
    string connectionStringName,
    Type ctxType = null,
    string metadata = "res://*/"
)
Visual Basic
Protected Shared Function GetEntityConnectionString (
    connectionStringName As String,
    Optional ctxType As Type = Nothing,
    Optional metadata As String = "res://*/"
) As String
Visual C++
protected:
static String^ GetEntityConnectionString(
    String^ connectionStringName,
    Type^ ctxType = nullptr,
    String^ metadata = L"res://*/"
)

Parameters

connectionStringName
Type: System..::..String
connection string name
ctxType (Optional)
Type: System..::..Type
db context type
metadata (Optional)
Type: System..::..String

Return Value

Type: String

See Also

CelloDbContext Class
CelloDbContext Members
CelloSaaS.Model Namespace


CelloDbContext.GetQueryable(TEntity) Method

[image]

A Sandcastle Documented Class Library
CelloDbContext..::..GetQueryable<(Of <(<'TEntity>)>)> Method
CelloDbContext Class See Also Send Feedback
Creates queryable object by applying tenant filter and returns it

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IQueryable<TEntity> GetQueryable<TEntity>()
where TEntity : TenantTransactionalEntity
Visual Basic
Public Function GetQueryable(Of TEntity As TenantTransactionalEntity) As IQueryable(Of TEntity)
Visual C++
public:
generic<typename TEntity>
where TEntity : TenantTransactionalEntity
IQueryable<TEntity>^ GetQueryable()

Type Parameters

TEntity
Business entity must inherit from TenantTransactionalEntity

Return Value

Type: IQueryable<(Of <(<'TEntity>)>)>

See Also

CelloDbContext Class
CelloDbContext Members
CelloSaaS.Model Namespace


CelloDbContext Properties

[image] [image]

A Sandcastle Documented Class Library
CelloDbContext Properties
CelloDbContext Class See Also Send Feedback

The CelloDbContext type exposes the following members.

Properties

 | Name | Description
Public property | ChangeTracker | (Inherited from DbContext.)
Public property | Configuration | (Inherited from DbContext.)
Public property | Database | (Inherited from DbContext.)

See Also

CelloDbContext Class
CelloSaaS.Model Namespace


CelloEntityObject Class

[image]

A Sandcastle Documented Class Library
CelloEntityObject Class
Members See Also Send Feedback
Cello entity object for EF

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CelloEntityObject : EntityObject
Visual Basic
<SerializableAttribute>
Public Class CelloEntityObject
    Inherits EntityObject
Visual C++
[SerializableAttribute]
public ref class CelloEntityObject : public EntityObject

Inheritance Hierarchy

System..::..Object
StructuralObject
EntityObject
CelloSaaS.Model..::..CelloEntityObject

See Also

CelloEntityObject Members
CelloSaaS.Model Namespace


CelloEntityObject Members

[image] [image]

A Sandcastle Documented Class Library
CelloEntityObject Members
CelloEntityObject Class Constructors Methods Properties Events See Also Send Feedback

The CelloEntityObject type exposes the following members.

Constructors

 | Name | Description
Public method | CelloEntityObject | Initializes a new instance of the CelloEntityObject class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidValue``1 | (Inherited from StructuralObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from StructuralObject.)
Protected method | OnPropertyChanging | (Inherited from StructuralObject.)
Protected method | ReportPropertyChanged | (Inherited from EntityObject.)
Protected method | ReportPropertyChanging | (Inherited from EntityObject.)
Protected method | SetValidValue``1 | (Inherited from StructuralObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntityKey | (Inherited from EntityObject.)
Public property | EntityState | (Inherited from EntityObject.)
Public property | TenantId | Gets or sets the tenant id.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from StructuralObject.)
Public event | PropertyChanging | (Inherited from StructuralObject.)

See Also

CelloEntityObject Class
CelloSaaS.Model Namespace


CelloEntityObject Constructor

[image]

A Sandcastle Documented Class Library
CelloEntityObject Constructor
CelloEntityObject Class See Also Send Feedback
Initializes a new instance of the CelloEntityObject class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloEntityObject()
Visual Basic
Public Sub New
Visual C++
public:
CelloEntityObject()

See Also

CelloEntityObject Class
CelloEntityObject Members
CelloSaaS.Model Namespace


CelloEntityObject Methods

[image] [image]

A Sandcastle Documented Class Library
CelloEntityObject Methods
CelloEntityObject Class See Also Send Feedback

The CelloEntityObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValidValue``1 | (Inherited from StructuralObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from StructuralObject.)
Protected method | OnPropertyChanging | (Inherited from StructuralObject.)
Protected method | ReportPropertyChanged | (Inherited from EntityObject.)
Protected method | ReportPropertyChanging | (Inherited from EntityObject.)
Protected method | SetValidValue``1 | (Inherited from StructuralObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CelloEntityObject Class
CelloSaaS.Model Namespace


CelloEntityObject Properties

[image] [image]

A Sandcastle Documented Class Library
CelloEntityObject Properties
CelloEntityObject Class See Also Send Feedback

The CelloEntityObject type exposes the following members.

Properties

 | Name | Description
Public property | EntityKey | (Inherited from EntityObject.)
Public property | EntityState | (Inherited from EntityObject.)
Public property | TenantId | Gets or sets the tenant id.

See Also

CelloEntityObject Class
CelloSaaS.Model Namespace


CelloEntityObject.TenantId Property

[image]

A Sandcastle Documented Class Library
CelloEntityObject..::..TenantId Property
CelloEntityObject Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TenantId { get; set; }
Visual Basic
Public Property TenantId As Guid
    Get
    Set
Visual C++
public:
property Guid TenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The tenant id.

See Also

CelloEntityObject Class
CelloEntityObject Members
CelloSaaS.Model Namespace


CelloEntityObject Events

[image] [image]

A Sandcastle Documented Class Library
CelloEntityObject Events
CelloEntityObject Class See Also Send Feedback

The CelloEntityObject type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from StructuralObject.)
Public event | PropertyChanging | (Inherited from StructuralObject.)

See Also

CelloEntityObject Class
CelloSaaS.Model Namespace


CelloEventConstant Class

[image]

A Sandcastle Documented Class Library
CelloEventConstant Class
Members See Also Send Feedback
This Class represents the Cello Event Constants

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class CelloEventConstant
Visual Basic
Public Class CelloEventConstant
Visual C++
public ref class CelloEventConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..CelloEventConstant

See Also

CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant Members

[image] [image]

A Sandcastle Documented Class Library
CelloEventConstant Members
CelloEventConstant Class Constructors Methods Fields See Also Send Feedback

The CelloEventConstant type exposes the following members.

Constructors

 | Name | Description
Public method | CelloEventConstant | Initializes a new instance of the CelloEventConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ActivateUserEvent | Activate User Constant
ActivateUserEventId | Activate User EventId
AddTenantEvent | Add Tenant Constant
AddTenantEventId | Add Tenant EventId
AddUserEvent | User Creation Constant
AddUserEventId | User Creation EventId
BillGeneratedEventId | Bill generated event id
BillPaymentFailureEventId | Bill payment failure event id
BillPaymentSuccessEventId | Bill payment success event id
DeactivateUserEvent | Deactivate User Constant
DeactivateUserEventId | Deactivate User EventId
LoginEventId | Login event id
LoginPasswordFailureEvent | Login Password Failure Constant
LoginPasswordFailureEventId | Login Password Failure EventId
LogOutEventId | Logout event id
SubscriptionChangedEventId | Raised when tenant changes subscription
SubscriptionEndedEventId | Raised when tenant subscription ends
TenantActivatedEventId | Add Tenant EventId
TenantApprovalEvent | The Tenant Approval Constant
TenantApprovalEventId | Tenant Approval EventId
TenantDeactivatedEventId | Add Tenant EventId
TenantRejectEvent | The Tenant Reject Constant
TenantRejectEventId | Tenant Reject EventId
TenantRequestEvent | The Tenant Request Constant
TenantRequestEventId | Tenant Request EventId
TrialEndedEventId | Raised when tenant trail period ends
UserApprovalEvent | The User Approval Constant
UserApprovalEventId | User Approval EventId
UserRejectEvent | The User Reject Constant
UserRejectEventId | User Reject EventId
UserRequestEvent | The User Request Constant
UserRequestEventId | User Request EventId

See Also

CelloEventConstant Class
CelloSaaS.Model Namespace


CelloEventConstant Constructor

[image]

A Sandcastle Documented Class Library
CelloEventConstant Constructor
CelloEventConstant Class See Also Send Feedback
Initializes a new instance of the CelloEventConstant class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloEventConstant()
Visual Basic
Public Sub New
Visual C++
public:
CelloEventConstant()

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant Fields

[image] [image]

A Sandcastle Documented Class Library
CelloEventConstant Fields
CelloEventConstant Class See Also Send Feedback

The CelloEventConstant type exposes the following members.

Fields

Name | Description
ActivateUserEvent | Activate User Constant
ActivateUserEventId | Activate User EventId
AddTenantEvent | Add Tenant Constant
AddTenantEventId | Add Tenant EventId
AddUserEvent | User Creation Constant
AddUserEventId | User Creation EventId
BillGeneratedEventId | Bill generated event id
BillPaymentFailureEventId | Bill payment failure event id
BillPaymentSuccessEventId | Bill payment success event id
DeactivateUserEvent | Deactivate User Constant
DeactivateUserEventId | Deactivate User EventId
LoginEventId | Login event id
LoginPasswordFailureEvent | Login Password Failure Constant
LoginPasswordFailureEventId | Login Password Failure EventId
LogOutEventId | Logout event id
SubscriptionChangedEventId | Raised when tenant changes subscription
SubscriptionEndedEventId | Raised when tenant subscription ends
TenantActivatedEventId | Add Tenant EventId
TenantApprovalEvent | The Tenant Approval Constant
TenantApprovalEventId | Tenant Approval EventId
TenantDeactivatedEventId | Add Tenant EventId
TenantRejectEvent | The Tenant Reject Constant
TenantRejectEventId | Tenant Reject EventId
TenantRequestEvent | The Tenant Request Constant
TenantRequestEventId | Tenant Request EventId
TrialEndedEventId | Raised when tenant trail period ends
UserApprovalEvent | The User Approval Constant
UserApprovalEventId | User Approval EventId
UserRejectEvent | The User Reject Constant
UserRejectEventId | User Reject EventId
UserRequestEvent | The User Request Constant
UserRequestEventId | User Request EventId

See Also

CelloEventConstant Class
CelloSaaS.Model Namespace


CelloEventConstant.ActivateUserEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..ActivateUserEvent Field
CelloEventConstant Class See Also Send Feedback
Activate User Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ActivateUserEvent
Visual Basic
Public Const ActivateUserEvent As String
Visual C++
public:
literal String^ ActivateUserEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.ActivateUserEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..ActivateUserEventId Field
CelloEventConstant Class See Also Send Feedback
Activate User EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ActivateUserEventId
Visual Basic
Public Const ActivateUserEventId As String
Visual C++
public:
literal String^ ActivateUserEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.AddTenantEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..AddTenantEvent Field
CelloEventConstant Class See Also Send Feedback
Add Tenant Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddTenantEvent
Visual Basic
Public Const AddTenantEvent As String
Visual C++
public:
literal String^ AddTenantEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.AddTenantEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..AddTenantEventId Field
CelloEventConstant Class See Also Send Feedback
Add Tenant EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddTenantEventId
Visual Basic
Public Const AddTenantEventId As String
Visual C++
public:
literal String^ AddTenantEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.AddUserEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..AddUserEvent Field
CelloEventConstant Class See Also Send Feedback
User Creation Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddUserEvent
Visual Basic
Public Const AddUserEvent As String
Visual C++
public:
literal String^ AddUserEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.AddUserEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..AddUserEventId Field
CelloEventConstant Class See Also Send Feedback
User Creation EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddUserEventId
Visual Basic
Public Const AddUserEventId As String
Visual C++
public:
literal String^ AddUserEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.BillGeneratedEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..BillGeneratedEventId Field
CelloEventConstant Class See Also Send Feedback
Bill generated event id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillGeneratedEventId
Visual Basic
Public Const BillGeneratedEventId As String
Visual C++
public:
literal String^ BillGeneratedEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.BillPaymentFailureEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..BillPaymentFailureEventId Field
CelloEventConstant Class See Also Send Feedback
Bill payment failure event id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillPaymentFailureEventId
Visual Basic
Public Const BillPaymentFailureEventId As String
Visual C++
public:
literal String^ BillPaymentFailureEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.BillPaymentSuccessEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..BillPaymentSuccessEventId Field
CelloEventConstant Class See Also Send Feedback
Bill payment success event id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillPaymentSuccessEventId
Visual Basic
Public Const BillPaymentSuccessEventId As String
Visual C++
public:
literal String^ BillPaymentSuccessEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.DeactivateUserEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..DeactivateUserEvent Field
CelloEventConstant Class See Also Send Feedback
Deactivate User Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeactivateUserEvent
Visual Basic
Public Const DeactivateUserEvent As String
Visual C++
public:
literal String^ DeactivateUserEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.DeactivateUserEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..DeactivateUserEventId Field
CelloEventConstant Class See Also Send Feedback
Deactivate User EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeactivateUserEventId
Visual Basic
Public Const DeactivateUserEventId As String
Visual C++
public:
literal String^ DeactivateUserEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.LoginEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..LoginEventId Field
CelloEventConstant Class See Also Send Feedback
Login event id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LoginEventId
Visual Basic
Public Const LoginEventId As String
Visual C++
public:
literal String^ LoginEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.LoginPasswordFailureEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..LoginPasswordFailureEvent Field
CelloEventConstant Class See Also Send Feedback
Login Password Failure Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LoginPasswordFailureEvent
Visual Basic
Public Const LoginPasswordFailureEvent As String
Visual C++
public:
literal String^ LoginPasswordFailureEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.LoginPasswordFailureEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..LoginPasswordFailureEventId Field
CelloEventConstant Class See Also Send Feedback
Login Password Failure EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LoginPasswordFailureEventId
Visual Basic
Public Const LoginPasswordFailureEventId As String
Visual C++
public:
literal String^ LoginPasswordFailureEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.LogOutEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..LogOutEventId Field
CelloEventConstant Class See Also Send Feedback
Logout event id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LogOutEventId
Visual Basic
Public Const LogOutEventId As String
Visual C++
public:
literal String^ LogOutEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.SubscriptionChangedEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..SubscriptionChangedEventId Field
CelloEventConstant Class See Also Send Feedback
Raised when tenant changes subscription

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SubscriptionChangedEventId
Visual Basic
Public Const SubscriptionChangedEventId As String
Visual C++
public:
literal String^ SubscriptionChangedEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.SubscriptionEndedEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..SubscriptionEndedEventId Field
CelloEventConstant Class See Also Send Feedback
Raised when tenant subscription ends

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SubscriptionEndedEventId
Visual Basic
Public Const SubscriptionEndedEventId As String
Visual C++
public:
literal String^ SubscriptionEndedEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantActivatedEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantActivatedEventId Field
CelloEventConstant Class See Also Send Feedback
Add Tenant EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantActivatedEventId
Visual Basic
Public Const TenantActivatedEventId As String
Visual C++
public:
literal String^ TenantActivatedEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantApprovalEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantApprovalEvent Field
CelloEventConstant Class See Also Send Feedback
The Tenant Approval Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantApprovalEvent
Visual Basic
Public Const TenantApprovalEvent As String
Visual C++
public:
literal String^ TenantApprovalEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantApprovalEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantApprovalEventId Field
CelloEventConstant Class See Also Send Feedback
Tenant Approval EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantApprovalEventId
Visual Basic
Public Const TenantApprovalEventId As String
Visual C++
public:
literal String^ TenantApprovalEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantDeactivatedEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantDeactivatedEventId Field
CelloEventConstant Class See Also Send Feedback
Add Tenant EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantDeactivatedEventId
Visual Basic
Public Const TenantDeactivatedEventId As String
Visual C++
public:
literal String^ TenantDeactivatedEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantRejectEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantRejectEvent Field
CelloEventConstant Class See Also Send Feedback
The Tenant Reject Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantRejectEvent
Visual Basic
Public Const TenantRejectEvent As String
Visual C++
public:
literal String^ TenantRejectEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantRejectEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantRejectEventId Field
CelloEventConstant Class See Also Send Feedback
Tenant Reject EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantRejectEventId
Visual Basic
Public Const TenantRejectEventId As String
Visual C++
public:
literal String^ TenantRejectEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantRequestEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantRequestEvent Field
CelloEventConstant Class See Also Send Feedback
The Tenant Request Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantRequestEvent
Visual Basic
Public Const TenantRequestEvent As String
Visual C++
public:
literal String^ TenantRequestEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TenantRequestEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TenantRequestEventId Field
CelloEventConstant Class See Also Send Feedback
Tenant Request EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantRequestEventId
Visual Basic
Public Const TenantRequestEventId As String
Visual C++
public:
literal String^ TenantRequestEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.TrialEndedEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..TrialEndedEventId Field
CelloEventConstant Class See Also Send Feedback
Raised when tenant trail period ends

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TrialEndedEventId
Visual Basic
Public Const TrialEndedEventId As String
Visual C++
public:
literal String^ TrialEndedEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.UserApprovalEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..UserApprovalEvent Field
CelloEventConstant Class See Also Send Feedback
The User Approval Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserApprovalEvent
Visual Basic
Public Const UserApprovalEvent As String
Visual C++
public:
literal String^ UserApprovalEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.UserApprovalEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..UserApprovalEventId Field
CelloEventConstant Class See Also Send Feedback
User Approval EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserApprovalEventId
Visual Basic
Public Const UserApprovalEventId As String
Visual C++
public:
literal String^ UserApprovalEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.UserRejectEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..UserRejectEvent Field
CelloEventConstant Class See Also Send Feedback
The User Reject Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserRejectEvent
Visual Basic
Public Const UserRejectEvent As String
Visual C++
public:
literal String^ UserRejectEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.UserRejectEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..UserRejectEventId Field
CelloEventConstant Class See Also Send Feedback
User Reject EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserRejectEventId
Visual Basic
Public Const UserRejectEventId As String
Visual C++
public:
literal String^ UserRejectEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.UserRequestEvent Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..UserRequestEvent Field
CelloEventConstant Class See Also Send Feedback
The User Request Constant

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserRequestEvent
Visual Basic
Public Const UserRequestEvent As String
Visual C++
public:
literal String^ UserRequestEvent

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant.UserRequestEventId Field

[image]

A Sandcastle Documented Class Library
CelloEventConstant..::..UserRequestEventId Field
CelloEventConstant Class See Also Send Feedback
User Request EventId

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserRequestEventId
Visual Basic
Public Const UserRequestEventId As String
Visual C++
public:
literal String^ UserRequestEventId

Field Value

Type: String

See Also

CelloEventConstant Class
CelloEventConstant Members
CelloSaaS.Model Namespace


CelloEventConstant Methods

[image] [image]

A Sandcastle Documented Class Library
CelloEventConstant Methods
CelloEventConstant Class See Also Send Feedback

The CelloEventConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CelloEventConstant Class
CelloSaaS.Model Namespace


CelloObjectContext Class

[image]

A Sandcastle Documented Class Library
CelloObjectContext Class
Members See Also Send Feedback
CelloSaaS wrapper for ObjectContext

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class CelloObjectContext : ObjectContext
Visual Basic
Public Class CelloObjectContext
    Inherits ObjectContext
Visual C++
public ref class CelloObjectContext : public ObjectContext

Inheritance Hierarchy

System..::..Object
ObjectContext
CelloSaaS.Model..::..CelloObjectContext

See Also

CelloObjectContext Members
CelloSaaS.Model Namespace


CelloObjectContext Members

[image] [image]

A Sandcastle Documented Class Library
CelloObjectContext Members
CelloObjectContext Class Constructors Methods Properties Events See Also Send Feedback

The CelloObjectContext type exposes the following members.

Constructors

 | Name | Description
Public method | CelloObjectContext(EntityConnection, String) | Creates a Object context
Public method | CelloObjectContext(String, String, String) | Creates Object Context

Methods

 | Name | Description
Public method | AcceptAllChanges | (Inherited from ObjectContext.)
Public method | AddObject | (Inherited from ObjectContext.)
Public method | ApplyCurrentValues``1 | (Inherited from ObjectContext.)
Public method | ApplyOriginalValues``1 | (Inherited from ObjectContext.)
Public method | ApplyPropertyChanges | Obsolete. (Inherited from ObjectContext.)
Public method | ApplySecurity<(Of <<'(TEntity>)>>) | Applies tenant filter for the given query
Public method | Attach | (Inherited from ObjectContext.)
Public method | AttachTo | (Inherited from ObjectContext.)
Public method | CreateDatabase | (Inherited from ObjectContext.)
Public method | CreateDatabaseScript | (Inherited from ObjectContext.)
Public method | CreateEntityKey | (Inherited from ObjectContext.)
Public method | CreateObject``1 | (Inherited from ObjectContext.)
Public method | CreateObjectSet``1()()()() | (Inherited from ObjectContext.)
Public method | CreateObjectSet``1(String) | (Inherited from ObjectContext.)
Public method | CreateProxyTypes | (Inherited from ObjectContext.)
Public method | CreateQuery``1 | (Inherited from ObjectContext.)
Public method | DatabaseExists | (Inherited from ObjectContext.)
Public method | DeleteDatabase | (Inherited from ObjectContext.)
Public method | DeleteObject | (Inherited from ObjectContext.)
Public method | Detach | (Inherited from ObjectContext.)
Public method | DetectChanges | (Inherited from ObjectContext.)
Public method | Dispose()()()() | (Inherited from ObjectContext.)
Protected method | Dispose(Boolean) | (Inherited from ObjectContext.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteFunction``1(String, array<ObjectParameter>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteFunction``1(String, MergeOption, array<ObjectParameter>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteFunction``1(String, ExecutionOptions, array<ObjectParameter>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommand(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommand(TransactionalBehavior, String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(TransactionalBehavior, String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(String, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(TransactionalBehavior, String, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, String, MergeOption, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, ExecutionOptions, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, String, ExecutionOptions, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEntityConnectionObject | Creates EF entity connection string object. Connection string will be automatically changed according to logged in tenant setting
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectByKey | (Inherited from ObjectContext.)
Public method | GetQueryable<(Of <<'(TEntity>)>>) | Creates queryable object by applying tenant filter and returns it
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty(Object, String) | (Inherited from ObjectContext.)
Public method | LoadProperty(Object, String, MergeOption) | (Inherited from ObjectContext.)
Public method | LoadProperty``1(UMP, Expression<(Of <<'(Func<(Of <<'(UMP, Object>)>>)>)>>)) | (Inherited from ObjectContext.)
Public method | LoadProperty``1(UMP, Expression<(Of <<'(Func<(Of <<'(UMP, Object>)>>)>)>>), MergeOption) | (Inherited from ObjectContext.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh(RefreshMode, IEnumerable) | (Inherited from ObjectContext.)
Public method | Refresh(RefreshMode, Object) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, IEnumerable) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, Object) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, IEnumerable, CancellationToken) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, Object, CancellationToken) | (Inherited from ObjectContext.)
Public method | SaveChanges()()()() | (Inherited from ObjectContext.)
Public method | SaveChanges(Boolean) | Obsolete. (Inherited from ObjectContext.)
Public method | SaveChanges(SaveOptions) | (Inherited from ObjectContext.)
Public method | SaveChangesAsync()()()() | (Inherited from ObjectContext.)
Public method | SaveChangesAsync(CancellationToken) | (Inherited from ObjectContext.)
Public method | SaveChangesAsync(SaveOptions) | (Inherited from ObjectContext.)
Public method | SaveChangesAsync(SaveOptions, CancellationToken) | (Inherited from ObjectContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate``1(DbDataReader) | (Inherited from ObjectContext.)
Public method | Translate``1(DbDataReader, String, MergeOption) | (Inherited from ObjectContext.)
Public method | TryGetObjectByKey | (Inherited from ObjectContext.)

Properties

 | Name | Description
Public property | CommandTimeout | (Inherited from ObjectContext.)
Public property | Connection | (Inherited from ObjectContext.)
Public property | ContextOptions | (Inherited from ObjectContext.)
Public property | DefaultContainerName | (Inherited from ObjectContext.)
Public property | MetadataWorkspace | (Inherited from ObjectContext.)
Public property | ObjectStateManager | (Inherited from ObjectContext.)
Protected property | QueryProvider | (Inherited from ObjectContext.)

Events

 | Name | Description
Public event | ObjectMaterialized | (Inherited from ObjectContext.)
Public event | SavingChanges | (Inherited from ObjectContext.)

See Also

CelloObjectContext Class
CelloSaaS.Model Namespace


CelloObjectContext Constructor

[image] [image]

A Sandcastle Documented Class Library
CelloObjectContext Constructor
CelloObjectContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CelloObjectContext(EntityConnection, String) | Creates a Object context
Public method | CelloObjectContext(String, String, String) | Creates Object Context

See Also

CelloObjectContext Class
CelloObjectContext Members
CelloSaaS.Model Namespace


CelloObjectContext Constructor (EntityConnection, String)

[image]

A Sandcastle Documented Class Library
CelloObjectContext Constructor (EntityConnection, String)
CelloObjectContext Class See Also Send Feedback
Creates a Object context

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloObjectContext(
    EntityConnection connection,
    string defaultContainerName
)
Visual Basic
Public Sub New (
    connection As EntityConnection,
    defaultContainerName As String
)
Visual C++
public:
CelloObjectContext(
    EntityConnection^ connection,
    String^ defaultContainerName
)

Parameters

connection
Type: EntityConnection
entity connection object
defaultContainerName
Type: System..::..String
EF model container name

See Also

CelloObjectContext Class
CelloObjectContext Members
CelloObjectContext Overload
CelloSaaS.Model Namespace


CelloObjectContext Constructor (String, String, String)

[image]

A Sandcastle Documented Class Library
CelloObjectContext Constructor (String, String, String)
CelloObjectContext Class See Also Send Feedback
Creates Object Context

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloObjectContext(
    string connectionStringName,
    string defaultContainerName,
    string metadata = "res://*/"
)
Visual Basic
Public Sub New (
    connectionStringName As String,
    defaultContainerName As String,
    Optional metadata As String = "res://*/"
)
Visual C++
public:
CelloObjectContext(
    String^ connectionStringName,
    String^ defaultContainerName,
    String^ metadata = L"res://*/"
)

Parameters

connectionStringName
Type: System..::..String
connection string name e.g.: ApplicationConnectionString
defaultContainerName
Type: System..::..String
EF model container name
metadata (Optional)
Type: System..::..String
metadata url

See Also

CelloObjectContext Class
CelloObjectContext Members
CelloObjectContext Overload
CelloSaaS.Model Namespace


CelloObjectContext Methods

[image] [image]

A Sandcastle Documented Class Library
CelloObjectContext Methods
CelloObjectContext Class See Also Send Feedback

The CelloObjectContext type exposes the following members.

Methods

 | Name | Description
Public method | AcceptAllChanges | (Inherited from ObjectContext.)
Public method | AddObject | (Inherited from ObjectContext.)
Public method | ApplyCurrentValues``1 | (Inherited from ObjectContext.)
Public method | ApplyOriginalValues``1 | (Inherited from ObjectContext.)
Public method | ApplyPropertyChanges | Obsolete. (Inherited from ObjectContext.)
Public method | ApplySecurity<(Of <<'(TEntity>)>>) | Applies tenant filter for the given query
Public method | Attach | (Inherited from ObjectContext.)
Public method | AttachTo | (Inherited from ObjectContext.)
Public method | CreateDatabase | (Inherited from ObjectContext.)
Public method | CreateDatabaseScript | (Inherited from ObjectContext.)
Public method | CreateEntityKey | (Inherited from ObjectContext.)
Public method | CreateObject``1 | (Inherited from ObjectContext.)
Public method | CreateObjectSet``1()()()() | (Inherited from ObjectContext.)
Public method | CreateObjectSet``1(String) | (Inherited from ObjectContext.)
Public method | CreateProxyTypes | (Inherited from ObjectContext.)
Public method | CreateQuery``1 | (Inherited from ObjectContext.)
Public method | DatabaseExists | (Inherited from ObjectContext.)
Public method | DeleteDatabase | (Inherited from ObjectContext.)
Public method | DeleteObject | (Inherited from ObjectContext.)
Public method | Detach | (Inherited from ObjectContext.)
Public method | DetectChanges | (Inherited from ObjectContext.)
Public method | Dispose()()()() | (Inherited from ObjectContext.)
Protected method | Dispose(Boolean) | (Inherited from ObjectContext.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteFunction``1(String, array<ObjectParameter>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteFunction``1(String, MergeOption, array<ObjectParameter>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteFunction``1(String, ExecutionOptions, array<ObjectParameter>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommand(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommand(TransactionalBehavior, String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(TransactionalBehavior, String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(String, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreCommandAsync(TransactionalBehavior, String, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, String, MergeOption, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQuery``1(String, String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, ExecutionOptions, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, String, ExecutionOptions, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Public method | ExecuteStoreQueryAsync``1(String, String, ExecutionOptions, CancellationToken, array<Object>[]()[][]) | (Inherited from ObjectContext.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEntityConnectionObject | Creates EF entity connection string object. Connection string will be automatically changed according to logged in tenant setting
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectByKey | (Inherited from ObjectContext.)
Public method | GetQueryable<(Of <<'(TEntity>)>>) | Creates queryable object by applying tenant filter and returns it
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty(Object, String) | (Inherited from ObjectContext.)
Public method | LoadProperty(Object, String, MergeOption) | (Inherited from ObjectContext.)
Public method | LoadProperty``1(UMP, Expression<(Of <<'(Func<(Of <<'(UMP, Object>)>>)>)>>)) | (Inherited from ObjectContext.)
Public method | LoadProperty``1(UMP, Expression<(Of <<'(Func<(Of <<'(UMP, Object>)>>)>)>>), MergeOption) | (Inherited from ObjectContext.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh(RefreshMode, IEnumerable) | (Inherited from ObjectContext.)
Public method | Refresh(RefreshMode, Object) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, IEnumerable) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, Object) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, IEnumerable, CancellationToken) | (Inherited from ObjectContext.)
Public method | RefreshAsync(RefreshMode, Object, CancellationToken) | (Inherited from ObjectContext.)
Public method | SaveChanges()()()() | (Inherited from ObjectContext.)
Public method | SaveChanges(Boolean) | Obsolete. (Inherited from ObjectContext.)
Public method | SaveChanges(SaveOptions) | (Inherited from ObjectContext.)
Public method | SaveChangesAsync()()()() | (Inherited from ObjectContext.)
Public method | SaveChangesAsync(CancellationToken) | (Inherited from ObjectContext.)
Public method | SaveChangesAsync(SaveOptions) | (Inherited from ObjectContext.)
Public method | SaveChangesAsync(SaveOptions, CancellationToken) | (Inherited from ObjectContext.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Translate``1(DbDataReader) | (Inherited from ObjectContext.)
Public method | Translate``1(DbDataReader, String, MergeOption) | (Inherited from ObjectContext.)
Public method | TryGetObjectByKey | (Inherited from ObjectContext.)

See Also

CelloObjectContext Class
CelloSaaS.Model Namespace


CelloObjectContext.ApplySecurity(TEntity) Method

[image]

A Sandcastle Documented Class Library
CelloObjectContext..::..ApplySecurity<(Of <(<'TEntity>)>)> Method
CelloObjectContext Class See Also Send Feedback
Applies tenant filter for the given query

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IQueryable<TEntity> ApplySecurity<TEntity>(
    IQueryable<TEntity> query
)
where TEntity : TenantTransactionalEntity
Visual Basic
Public Function ApplySecurity(Of TEntity As TenantTransactionalEntity) (
    query As IQueryable(Of TEntity)
) As IQueryable(Of TEntity)
Visual C++
public:
generic<typename TEntity>
where TEntity : TenantTransactionalEntity
IQueryable<TEntity>^ ApplySecurity(
    IQueryable<TEntity>^ query
)

Parameters

query
Type: System.Linq..::..IQueryable<(Of <(<'TEntity>)>)>
queryable object

Type Parameters

TEntity
Business entity must inherit from TenantTransactionalEntity

Return Value

Type: IQueryable<(Of <(<'TEntity>)>)>

See Also

CelloObjectContext Class
CelloObjectContext Members
CelloSaaS.Model Namespace


CelloObjectContext.GetEntityConnectionObject Method

[image]

A Sandcastle Documented Class Library
CelloObjectContext..::..GetEntityConnectionObject Method
CelloObjectContext Class See Also Send Feedback
Creates EF entity connection string object. Connection string will be automatically changed according to logged in tenant setting

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected static EntityConnection GetEntityConnectionObject(
    string connectionStringName,
    string metadata = "res://*/"
)
Visual Basic
Protected Shared Function GetEntityConnectionObject (
    connectionStringName As String,
    Optional metadata As String = "res://*/"
) As EntityConnection
Visual C++
protected:
static EntityConnection^ GetEntityConnectionObject(
    String^ connectionStringName,
    String^ metadata = L"res://*/"
)

Parameters

connectionStringName
Type: System..::..String
connection string name e.g.: ApplicationConnectionString
metadata (Optional)
Type: System..::..String
metadata url

Return Value

Type: EntityConnection

See Also

CelloObjectContext Class
CelloObjectContext Members
CelloSaaS.Model Namespace


CelloObjectContext.GetQueryable(TEntity) Method

[image]

A Sandcastle Documented Class Library
CelloObjectContext..::..GetQueryable<(Of <(<'TEntity>)>)> Method
CelloObjectContext Class See Also Send Feedback
Creates queryable object by applying tenant filter and returns it

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IQueryable<TEntity> GetQueryable<TEntity>(
    string entityName
)
where TEntity : TenantTransactionalEntity
Visual Basic
Public Function GetQueryable(Of TEntity As TenantTransactionalEntity) (
    entityName As String
) As IQueryable(Of TEntity)
Visual C++
public:
generic<typename TEntity>
where TEntity : TenantTransactionalEntity
IQueryable<TEntity>^ GetQueryable(
    String^ entityName
)

Parameters

entityName
Type: System..::..String
entity name

Type Parameters

TEntity
Business entity must inherit from TenantTransactionalEntity

Return Value

Type: IQueryable<(Of <(<'TEntity>)>)>

See Also

CelloObjectContext Class
CelloObjectContext Members
CelloSaaS.Model Namespace


CelloObjectContext Properties

[image] [image]

A Sandcastle Documented Class Library
CelloObjectContext Properties
CelloObjectContext Class See Also Send Feedback

The CelloObjectContext type exposes the following members.

Properties

 | Name | Description
Public property | CommandTimeout | (Inherited from ObjectContext.)
Public property | Connection | (Inherited from ObjectContext.)
Public property | ContextOptions | (Inherited from ObjectContext.)
Public property | DefaultContainerName | (Inherited from ObjectContext.)
Public property | MetadataWorkspace | (Inherited from ObjectContext.)
Public property | ObjectStateManager | (Inherited from ObjectContext.)
Protected property | QueryProvider | (Inherited from ObjectContext.)

See Also

CelloObjectContext Class
CelloSaaS.Model Namespace


CelloObjectContext Events

[image] [image]

A Sandcastle Documented Class Library
CelloObjectContext Events
CelloObjectContext Class See Also Send Feedback

The CelloObjectContext type exposes the following members.

Events

 | Name | Description
Public event | ObjectMaterialized | (Inherited from ObjectContext.)
Public event | SavingChanges | (Inherited from ObjectContext.)

See Also

CelloObjectContext Class
CelloSaaS.Model Namespace


CreateEventArgs Class

[image]

A Sandcastle Documented Class Library
CreateEventArgs Class
Members See Also Send Feedback
Create Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class CreateEventArgs : ActionEventArgs
Visual Basic
Public Class CreateEventArgs
    Inherits ActionEventArgs
Visual C++
public ref class CreateEventArgs : public ActionEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
CelloSaaS.Model..::..ActionEventArgs
CelloSaaS.Model..::..CreateEventArgs

See Also

CreateEventArgs Members
CelloSaaS.Model Namespace


CreateEventArgs Members

[image] [image]

A Sandcastle Documented Class Library
CreateEventArgs Members
CreateEventArgs Class Constructors Methods Properties See Also Send Feedback

The CreateEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CreateEventArgs | Constructor of Create Event Args

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

CreateEventArgs Class
CelloSaaS.Model Namespace


CreateEventArgs Constructor

[image]

A Sandcastle Documented Class Library
CreateEventArgs Constructor
CreateEventArgs Class See Also Send Feedback
Constructor of Create Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CreateEventArgs(
    string entityIdentifier,
    BaseEntity crrentContextModel,
    EntityAction entityAction
)
Visual Basic
Public Sub New (
    entityIdentifier As String,
    crrentContextModel As BaseEntity,
    entityAction As EntityAction
)
Visual C++
public:
CreateEventArgs(
    String^ entityIdentifier,
    BaseEntity^ crrentContextModel,
    EntityAction^ entityAction
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
crrentContextModel
Type: CelloSaaS.Model..::..BaseEntity
Current object model
entityAction
Type: CelloSaaS.Model..::..EntityAction
Entity Action Properties

See Also

CreateEventArgs Class
CreateEventArgs Members
CelloSaaS.Model Namespace


CreateEventArgs Methods

[image] [image]

A Sandcastle Documented Class Library
CreateEventArgs Methods
CreateEventArgs Class See Also Send Feedback

The CreateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CreateEventArgs Class
CelloSaaS.Model Namespace


CreateEventArgs Properties

[image] [image]

A Sandcastle Documented Class Library
CreateEventArgs Properties
CreateEventArgs Class See Also Send Feedback

The CreateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

CreateEventArgs Class
CelloSaaS.Model Namespace


DeleteEventArgs Class

[image]

A Sandcastle Documented Class Library
DeleteEventArgs Class
Members See Also Send Feedback
Delete Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DeleteEventArgs : ActionEventArgs
Visual Basic
Public Class DeleteEventArgs
    Inherits ActionEventArgs
Visual C++
public ref class DeleteEventArgs : public ActionEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
CelloSaaS.Model..::..ActionEventArgs
CelloSaaS.Model..::..DeleteEventArgs

See Also

DeleteEventArgs Members
CelloSaaS.Model Namespace


DeleteEventArgs Members

[image] [image]

A Sandcastle Documented Class Library
DeleteEventArgs Members
DeleteEventArgs Class Constructors Methods Properties See Also Send Feedback

The DeleteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DeleteEventArgs | Constructor of Delete Event Args

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

DeleteEventArgs Class
CelloSaaS.Model Namespace


DeleteEventArgs Constructor

[image]

A Sandcastle Documented Class Library
DeleteEventArgs Constructor
DeleteEventArgs Class See Also Send Feedback
Constructor of Delete Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DeleteEventArgs(
    string entityIdentifier,
    BaseEntity crrentContextModel,
    EntityAction entityAction
)
Visual Basic
Public Sub New (
    entityIdentifier As String,
    crrentContextModel As BaseEntity,
    entityAction As EntityAction
)
Visual C++
public:
DeleteEventArgs(
    String^ entityIdentifier,
    BaseEntity^ crrentContextModel,
    EntityAction^ entityAction
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
crrentContextModel
Type: CelloSaaS.Model..::..BaseEntity
Current object model
entityAction
Type: CelloSaaS.Model..::..EntityAction
Entity Action Properties

See Also

DeleteEventArgs Class
DeleteEventArgs Members
CelloSaaS.Model Namespace


DeleteEventArgs Methods

[image] [image]

A Sandcastle Documented Class Library
DeleteEventArgs Methods
DeleteEventArgs Class See Also Send Feedback

The DeleteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DeleteEventArgs Class
CelloSaaS.Model Namespace


DeleteEventArgs Properties

[image] [image]

A Sandcastle Documented Class Library
DeleteEventArgs Properties
DeleteEventArgs Class See Also Send Feedback

The DeleteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

DeleteEventArgs Class
CelloSaaS.Model Namespace


EntityAction Class

[image]

A Sandcastle Documented Class Library
EntityAction Class
Members See Also Send Feedback
Entity Action Properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityAction
Visual Basic
<SerializableAttribute>
Public Class EntityAction
Visual C++
[SerializableAttribute]
public ref class EntityAction

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..EntityAction

See Also

EntityAction Members
CelloSaaS.Model Namespace


EntityAction Members

[image] [image]

A Sandcastle Documented Class Library
EntityAction Members
EntityAction Class Constructors Methods Properties See Also Send Feedback

The EntityAction type exposes the following members.

Constructors

 | Name | Description
Public method | EntityAction | Constructor of Entity Action with permission context

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Operation | Getsor sets the entity poeration properties
Public property | PrivilegeContext | Gets or sets the privilege context

See Also

EntityAction Class
CelloSaaS.Model Namespace


EntityAction Constructor

[image]

A Sandcastle Documented Class Library
EntityAction Constructor
EntityAction Class See Also Send Feedback
Constructor of Entity Action with permission context

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityAction(
    string permissionContext
)
Visual Basic
Public Sub New (
    permissionContext As String
)
Visual C++
public:
EntityAction(
    String^ permissionContext
)

Parameters

permissionContext
Type: System..::..String
Permission Context

See Also

EntityAction Class
EntityAction Members
CelloSaaS.Model Namespace


EntityAction Methods

[image] [image]

A Sandcastle Documented Class Library
EntityAction Methods
EntityAction Class See Also Send Feedback

The EntityAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityAction Class
CelloSaaS.Model Namespace


EntityAction Properties

[image] [image]

A Sandcastle Documented Class Library
EntityAction Properties
EntityAction Class See Also Send Feedback

The EntityAction type exposes the following members.

Properties

 | Name | Description
Public property | Operation | Getsor sets the entity poeration properties
Public property | PrivilegeContext | Gets or sets the privilege context

See Also

EntityAction Class
CelloSaaS.Model Namespace


EntityAction.Operation Property

[image]

A Sandcastle Documented Class Library
EntityAction..::..Operation Property
EntityAction Class See Also Send Feedback
Getsor sets the entity poeration properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityOperation Operation { get; set; }
Visual Basic
Public Property Operation As EntityOperation
    Get
    Set
Visual C++
public:
property EntityOperation Operation {
    EntityOperation get ();
    void set (EntityOperation value);
}

Property Value

Type: EntityOperation

See Also

EntityAction Class
EntityAction Members
CelloSaaS.Model Namespace


EntityAction.PrivilegeContext Property

[image]

A Sandcastle Documented Class Library
EntityAction..::..PrivilegeContext Property
EntityAction Class See Also Send Feedback
Gets or sets the privilege context

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrivilegeContext { get; set; }
Visual Basic
Public Property PrivilegeContext As String
    Get
    Set
Visual C++
public:
property String^ PrivilegeContext {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityAction Class
EntityAction Members
CelloSaaS.Model Namespace


EntityConstants Class

[image]

A Sandcastle Documented Class Library
EntityConstants Class
Members See Also Send Feedback
Entity constants

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class EntityConstants
Visual Basic
Public NotInheritable Class EntityConstants
Visual C++
public ref class EntityConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..EntityConstants

See Also

EntityConstants Members
CelloSaaS.Model Namespace


EntityConstants Members

[image] [image]

A Sandcastle Documented Class Library
EntityConstants Members
EntityConstants Class Fields See Also Send Feedback

The EntityConstants type exposes the following members.

Fields

Name | Description
TenantEntity |

See Also

EntityConstants Class
CelloSaaS.Model Namespace


EntityConstants Fields

[image] [image]

A Sandcastle Documented Class Library
EntityConstants Fields
EntityConstants Class See Also Send Feedback

The EntityConstants type exposes the following members.

Fields

Name | Description
TenantEntity |

See Also

EntityConstants Class
CelloSaaS.Model Namespace


EntityConstants.TenantEntity Field

[image]

A Sandcastle Documented Class Library
EntityConstants..::..TenantEntity Field
EntityConstants Class See Also Send Feedback

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantEntity
Visual Basic
Public Const TenantEntity As String
Visual C++
public:
literal String^ TenantEntity

Field Value

Type: String

See Also

EntityConstants Class
EntityConstants Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute Class

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute Class
Members See Also Send Feedback
This attribute contains properties which will be used to auto-generate the entity configuration.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public sealed class EntityDescriptorAttribute : Attribute
Visual Basic
Public NotInheritable Class EntityDescriptorAttribute
    Inherits Attribute
Visual C++
public ref class EntityDescriptorAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
CelloSaaS.Model..::..EntityDescriptorAttribute

See Also

EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute Members

[image] [image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute Members
EntityDescriptorAttribute Class Constructors Methods Properties See Also Send Feedback

The EntityDescriptorAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EntityDescriptorAttribute | Constructor

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayColumnName | Gets or sets the table column name to display in the related entity.
Public property | EntityName | Gets or sets entity name
Public property | ExtnSchemaTableConnectionStringName | Set the connection string name where this entity's extended table can be found
Public property | ExtnSchemaTableName | Set the extended table name where the extended fields of this entity are stored
Public property | Features | Give ',' [comma] seperated feature ids
Public property | IsExtensible | Set whether this entity can be extendable or not
Public property | PrimaryKeyName | Set the primary key column name of this entity
Public property | Privileges | Give ',' comma seperated privilege ids
Public property | SchemaTableConnectionStringName | Set the connection string name where this entity's table can be found
Public property | SchemaTableName | Set the table name where this entity is presisted
Public property | TenantIdColumnName | Gets or sets tenant id column name
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityDescriptorAttribute Class
CelloSaaS.Model Namespace


EntityDescriptorAttribute Constructor

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute Constructor
EntityDescriptorAttribute Class See Also Send Feedback
Constructor

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityDescriptorAttribute()
Visual Basic
Public Sub New
Visual C++
public:
EntityDescriptorAttribute()

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute Methods

[image] [image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute Methods
EntityDescriptorAttribute Class See Also Send Feedback

The EntityDescriptorAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityDescriptorAttribute Class
CelloSaaS.Model Namespace


EntityDescriptorAttribute Properties

[image] [image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute Properties
EntityDescriptorAttribute Class See Also Send Feedback

The EntityDescriptorAttribute type exposes the following members.

Properties

 | Name | Description
Public property | DisplayColumnName | Gets or sets the table column name to display in the related entity.
Public property | EntityName | Gets or sets entity name
Public property | ExtnSchemaTableConnectionStringName | Set the connection string name where this entity's extended table can be found
Public property | ExtnSchemaTableName | Set the extended table name where the extended fields of this entity are stored
Public property | Features | Give ',' [comma] seperated feature ids
Public property | IsExtensible | Set whether this entity can be extendable or not
Public property | PrimaryKeyName | Set the primary key column name of this entity
Public property | Privileges | Give ',' comma seperated privilege ids
Public property | SchemaTableConnectionStringName | Set the connection string name where this entity's table can be found
Public property | SchemaTableName | Set the table name where this entity is presisted
Public property | TenantIdColumnName | Gets or sets tenant id column name
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityDescriptorAttribute Class
CelloSaaS.Model Namespace


EntityDescriptorAttribute.DisplayColumnName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..DisplayColumnName Property
EntityDescriptorAttribute Class See Also Send Feedback
Gets or sets the table column name to display in the related entity.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DisplayColumnName { get; set; }
Visual Basic
Public Property DisplayColumnName As String
    Get
    Set
Visual C++
public:
property String^ DisplayColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The display name of the column.

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.EntityName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..EntityName Property
EntityDescriptorAttribute Class See Also Send Feedback
Gets or sets entity name

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityName { get; set; }
Visual Basic
Public Property EntityName As String
    Get
    Set
Visual C++
public:
property String^ EntityName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.ExtnSchemaTableConnectionStringName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..ExtnSchemaTableConnectionStringName Property
EntityDescriptorAttribute Class See Also Send Feedback
Set the connection string name where this entity's extended table can be found

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExtnSchemaTableConnectionStringName { get; set; }
Visual Basic
Public Property ExtnSchemaTableConnectionStringName As String
    Get
    Set
Visual C++
public:
property String^ ExtnSchemaTableConnectionStringName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.ExtnSchemaTableName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..ExtnSchemaTableName Property
EntityDescriptorAttribute Class See Also Send Feedback
Set the extended table name where the extended fields of this entity are stored

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExtnSchemaTableName { get; set; }
Visual Basic
Public Property ExtnSchemaTableName As String
    Get
    Set
Visual C++
public:
property String^ ExtnSchemaTableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.Features Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..Features Property
EntityDescriptorAttribute Class See Also Send Feedback
Give ',' [comma] seperated feature ids

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Features { get; set; }
Visual Basic
Public Property Features As String
    Get
    Set
Visual C++
public:
property String^ Features {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.IsExtensible Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..IsExtensible Property
EntityDescriptorAttribute Class See Also Send Feedback
Set whether this entity can be extendable or not

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsExtensible { get; set; }
Visual Basic
Public Property IsExtensible As Boolean
    Get
    Set
Visual C++
public:
property bool IsExtensible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.PrimaryKeyName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..PrimaryKeyName Property
EntityDescriptorAttribute Class See Also Send Feedback
Set the primary key column name of this entity

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrimaryKeyName { get; set; }
Visual Basic
Public Property PrimaryKeyName As String
    Get
    Set
Visual C++
public:
property String^ PrimaryKeyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.Privileges Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..Privileges Property
EntityDescriptorAttribute Class Example See Also Send Feedback
Give ',' comma seperated privilege ids

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Privileges { get; set; }
Visual Basic
Public Property Privileges As String
    Get
    Set
Visual C++
public:
property String^ Privileges {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Examples

Add_User,View_User,Edit_User,Delete_User

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.SchemaTableConnectionStringName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..SchemaTableConnectionStringName Property
EntityDescriptorAttribute Class See Also Send Feedback
Set the connection string name where this entity's table can be found

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SchemaTableConnectionStringName { get; set; }
Visual Basic
Public Property SchemaTableConnectionStringName As String
    Get
    Set
Visual C++
public:
property String^ SchemaTableConnectionStringName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.SchemaTableName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..SchemaTableName Property
EntityDescriptorAttribute Class See Also Send Feedback
Set the table name where this entity is presisted

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SchemaTableName { get; set; }
Visual Basic
Public Property SchemaTableName As String
    Get
    Set
Visual C++
public:
property String^ SchemaTableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityDescriptorAttribute.TenantIdColumnName Property

[image]

A Sandcastle Documented Class Library
EntityDescriptorAttribute..::..TenantIdColumnName Property
EntityDescriptorAttribute Class See Also Send Feedback
Gets or sets tenant id column name

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantIdColumnName { get; set; }
Visual Basic
Public Property TenantIdColumnName As String
    Get
    Set
Visual C++
public:
property String^ TenantIdColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityDescriptorAttribute Class
EntityDescriptorAttribute Members
CelloSaaS.Model Namespace


EntityFieldDescriptor Class

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor Class
Members See Also Send Feedback
This attribute describes the field details so that the entity configuration can be auto-generated

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public sealed class EntityFieldDescriptor : Attribute
Visual Basic
Public NotInheritable Class EntityFieldDescriptor
    Inherits Attribute
Visual C++
public ref class EntityFieldDescriptor sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
CelloSaaS.Model..::..EntityFieldDescriptor

See Also

EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor Members

[image] [image]

A Sandcastle Documented Class Library
EntityFieldDescriptor Members
EntityFieldDescriptor Class Constructors Methods Properties See Also Send Feedback

The EntityFieldDescriptor type exposes the following members.

Constructors

 | Name | Description
Public method | EntityFieldDescriptor | Initializes a new instance of the EntityFieldDescriptor class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntityId | Gets or sets the entity id.
Public property | FieldId | Entity field identifier
Public property | FieldName | Field Name/Display name
Public property | FieldTypeId | Datatype of the field like pickuplist or int, float etc
Public property | Ignore | Ignore this field. i.e don't include it in entity fields or data view fields
Public property | IsUnique | Whether the data should be unique or not
Public property | PickupListId | If the field is pickuplist then set the pickuplist id
Public property | ReferenceColumnName | If the field is reference field, then set the column name of the referenced table to subsititute for the data
Public property | ReferenceEntityId | If the field is reference field, set the reference entity identifier from which the data to be used for display.
Public property | ReferenceTableName | If the field is reference field, set the reference table name from which the data is subsitituted
Public property | RegExpression | Regular expression used to validate the field data
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityFieldDescriptor Class
CelloSaaS.Model Namespace


EntityFieldDescriptor Constructor

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor Constructor
EntityFieldDescriptor Class See Also Send Feedback
Initializes a new instance of the EntityFieldDescriptor class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityFieldDescriptor()
Visual Basic
Public Sub New
Visual C++
public:
EntityFieldDescriptor()

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor Methods

[image] [image]

A Sandcastle Documented Class Library
EntityFieldDescriptor Methods
EntityFieldDescriptor Class See Also Send Feedback

The EntityFieldDescriptor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityFieldDescriptor Class
CelloSaaS.Model Namespace


EntityFieldDescriptor Properties

[image] [image]

A Sandcastle Documented Class Library
EntityFieldDescriptor Properties
EntityFieldDescriptor Class See Also Send Feedback

The EntityFieldDescriptor type exposes the following members.

Properties

 | Name | Description
Public property | EntityId | Gets or sets the entity id.
Public property | FieldId | Entity field identifier
Public property | FieldName | Field Name/Display name
Public property | FieldTypeId | Datatype of the field like pickuplist or int, float etc
Public property | Ignore | Ignore this field. i.e don't include it in entity fields or data view fields
Public property | IsUnique | Whether the data should be unique or not
Public property | PickupListId | If the field is pickuplist then set the pickuplist id
Public property | ReferenceColumnName | If the field is reference field, then set the column name of the referenced table to subsititute for the data
Public property | ReferenceEntityId | If the field is reference field, set the reference entity identifier from which the data to be used for display.
Public property | ReferenceTableName | If the field is reference field, set the reference table name from which the data is subsitituted
Public property | RegExpression | Regular expression used to validate the field data
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityFieldDescriptor Class
CelloSaaS.Model Namespace


EntityFieldDescriptor.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..EntityId Property
EntityFieldDescriptor Class See Also Send Feedback
Gets or sets the entity id.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The entity id.

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.FieldId Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..FieldId Property
EntityFieldDescriptor Class See Also Send Feedback
Entity field identifier

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldId { get; set; }
Visual Basic
Public Property FieldId As String
    Get
    Set
Visual C++
public:
property String^ FieldId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.FieldName Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..FieldName Property
EntityFieldDescriptor Class See Also Send Feedback
Field Name/Display name

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldName { get; set; }
Visual Basic
Public Property FieldName As String
    Get
    Set
Visual C++
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.FieldTypeId Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..FieldTypeId Property
EntityFieldDescriptor Class See Also Send Feedback
Datatype of the field like pickuplist or int, float etc

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldTypeId { get; set; }
Visual Basic
Public Property FieldTypeId As String
    Get
    Set
Visual C++
public:
property String^ FieldTypeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.Ignore Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..Ignore Property
EntityFieldDescriptor Class See Also Send Feedback
Ignore this field. i.e don't include it in entity fields or data view fields

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Ignore { get; set; }
Visual Basic
Public Property Ignore As Boolean
    Get
    Set
Visual C++
public:
property bool Ignore {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.IsUnique Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..IsUnique Property
EntityFieldDescriptor Class See Also Send Feedback
Whether the data should be unique or not

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsUnique { get; set; }
Visual Basic
Public Property IsUnique As Boolean
    Get
    Set
Visual C++
public:
property bool IsUnique {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.PickupListId Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..PickupListId Property
EntityFieldDescriptor Class See Also Send Feedback
If the field is pickuplist then set the pickuplist id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PickupListId { get; set; }
Visual Basic
Public Property PickupListId As String
    Get
    Set
Visual C++
public:
property String^ PickupListId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.ReferenceColumnName Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..ReferenceColumnName Property
EntityFieldDescriptor Class See Also Send Feedback
If the field is reference field, then set the column name of the referenced table to subsititute for the data

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceColumnName { get; set; }
Visual Basic
Public Property ReferenceColumnName As String
    Get
    Set
Visual C++
public:
property String^ ReferenceColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.ReferenceEntityId Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..ReferenceEntityId Property
EntityFieldDescriptor Class See Also Send Feedback
If the field is reference field, set the reference entity identifier from which the data to be used for display.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceEntityId { get; set; }
Visual Basic
Public Property ReferenceEntityId As String
    Get
    Set
Visual C++
public:
property String^ ReferenceEntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.ReferenceTableName Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..ReferenceTableName Property
EntityFieldDescriptor Class See Also Send Feedback
If the field is reference field, set the reference table name from which the data is subsitituted

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceTableName { get; set; }
Visual Basic
Public Property ReferenceTableName As String
    Get
    Set
Visual C++
public:
property String^ ReferenceTableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityFieldDescriptor.RegExpression Property

[image]

A Sandcastle Documented Class Library
EntityFieldDescriptor..::..RegExpression Property
EntityFieldDescriptor Class See Also Send Feedback
Regular expression used to validate the field data

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RegExpression { get; set; }
Visual Basic
Public Property RegExpression As String
    Get
    Set
Visual C++
public:
property String^ RegExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldDescriptor Class
EntityFieldDescriptor Members
CelloSaaS.Model Namespace


EntityIdentifierAttribute Class

[image]

A Sandcastle Documented Class Library
EntityIdentifierAttribute Class
Members See Also Send Feedback
Entity Identifier Attribute Properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public sealed class EntityIdentifierAttribute : Attribute
Visual Basic
Public NotInheritable Class EntityIdentifierAttribute
    Inherits Attribute
Visual C++
public ref class EntityIdentifierAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
CelloSaaS.Model..::..EntityIdentifierAttribute

See Also

EntityIdentifierAttribute Members
CelloSaaS.Model Namespace


EntityIdentifierAttribute Members

[image] [image]

A Sandcastle Documented Class Library
EntityIdentifierAttribute Members
EntityIdentifierAttribute Class Constructors Methods Properties See Also Send Feedback

The EntityIdentifierAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EntityIdentifierAttribute | Initializes a new instance of the EntityIdentifierAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets or sets the Name
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityIdentifierAttribute Class
CelloSaaS.Model Namespace


EntityIdentifierAttribute Constructor

[image]

A Sandcastle Documented Class Library
EntityIdentifierAttribute Constructor
EntityIdentifierAttribute Class See Also Send Feedback
Initializes a new instance of the EntityIdentifierAttribute class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityIdentifierAttribute()
Visual Basic
Public Sub New
Visual C++
public:
EntityIdentifierAttribute()

See Also

EntityIdentifierAttribute Class
EntityIdentifierAttribute Members
CelloSaaS.Model Namespace


EntityIdentifierAttribute Methods

[image] [image]

A Sandcastle Documented Class Library
EntityIdentifierAttribute Methods
EntityIdentifierAttribute Class See Also Send Feedback

The EntityIdentifierAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityIdentifierAttribute Class
CelloSaaS.Model Namespace


EntityIdentifierAttribute Properties

[image] [image]

A Sandcastle Documented Class Library
EntityIdentifierAttribute Properties
EntityIdentifierAttribute Class See Also Send Feedback

The EntityIdentifierAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets or sets the Name
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityIdentifierAttribute Class
CelloSaaS.Model Namespace


EntityIdentifierAttribute.Name Property

[image]

A Sandcastle Documented Class Library
EntityIdentifierAttribute..::..Name Property
EntityIdentifierAttribute Class See Also Send Feedback
Gets or sets the Name

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityIdentifierAttribute Class
EntityIdentifierAttribute Members
CelloSaaS.Model Namespace


EntityMetadataTypeAttribute Class

[image]

A Sandcastle Documented Class Library
EntityMetadataTypeAttribute Class
Members See Also Send Feedback
This attribute tells where to look for the metadata of this entity

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public sealed class EntityMetadataTypeAttribute : Attribute
Visual Basic
Public NotInheritable Class EntityMetadataTypeAttribute
    Inherits Attribute
Visual C++
public ref class EntityMetadataTypeAttribute sealed : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
CelloSaaS.Model..::..EntityMetadataTypeAttribute

See Also

EntityMetadataTypeAttribute Members
CelloSaaS.Model Namespace


EntityMetadataTypeAttribute Members

[image] [image]

A Sandcastle Documented Class Library
EntityMetadataTypeAttribute Members
EntityMetadataTypeAttribute Class Constructors Methods Properties See Also Send Feedback

The EntityMetadataTypeAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | EntityMetadataTypeAttribute | Constructor

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MetadataProviderType | Entity metadata provider type class
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityMetadataTypeAttribute Class
CelloSaaS.Model Namespace


EntityMetadataTypeAttribute Constructor

[image]

A Sandcastle Documented Class Library
EntityMetadataTypeAttribute Constructor
EntityMetadataTypeAttribute Class See Also Send Feedback
Constructor

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityMetadataTypeAttribute(
    Type type
)
Visual Basic
Public Sub New (
    type As Type
)
Visual C++
public:
EntityMetadataTypeAttribute(
    Type^ type
)

Parameters

type
Type: System..::..Type

See Also

EntityMetadataTypeAttribute Class
EntityMetadataTypeAttribute Members
CelloSaaS.Model Namespace


EntityMetadataTypeAttribute Methods

[image] [image]

A Sandcastle Documented Class Library
EntityMetadataTypeAttribute Methods
EntityMetadataTypeAttribute Class See Also Send Feedback

The EntityMetadataTypeAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityMetadataTypeAttribute Class
CelloSaaS.Model Namespace


EntityMetadataTypeAttribute Properties

[image] [image]

A Sandcastle Documented Class Library
EntityMetadataTypeAttribute Properties
EntityMetadataTypeAttribute Class See Also Send Feedback

The EntityMetadataTypeAttribute type exposes the following members.

Properties

 | Name | Description
Public property | MetadataProviderType | Entity metadata provider type class
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

EntityMetadataTypeAttribute Class
CelloSaaS.Model Namespace


EntityMetadataTypeAttribute.MetadataProviderType Property

[image]

A Sandcastle Documented Class Library
EntityMetadataTypeAttribute..::..MetadataProviderType Property
EntityMetadataTypeAttribute Class See Also Send Feedback
Entity metadata provider type class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Type MetadataProviderType { get; private set; }
Visual Basic
Public Property MetadataProviderType As Type
    Get
    Private Set
Visual C++
public:
property Type^ MetadataProviderType {
    Type^ get ();
    private: void set (Type^ value);
}

Property Value

Type: Type

See Also

EntityMetadataTypeAttribute Class
EntityMetadataTypeAttribute Members
CelloSaaS.Model Namespace


EntityOperation Enumeration

[image]

A Sandcastle Documented Class Library
EntityOperation Enumeration
See Also Send Feedback
Entity Operation type

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum EntityOperation
Visual Basic
<SerializableAttribute>
Public Enumeration EntityOperation
Visual C++
[SerializableAttribute]
public enum class EntityOperation

Members

Member name | Value | Description
Create | 0 | Creaet Entity
Read | 1 | Read Entity
Update | 2 | Update Entity
Delete | 3 | Delete Entity

See Also

CelloSaaS.Model Namespace


FetchEventArgs Class

[image]

A Sandcastle Documented Class Library
FetchEventArgs Class
Members See Also Send Feedback
Fetch Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class FetchEventArgs : ActionEventArgs
Visual Basic
Public Class FetchEventArgs
    Inherits ActionEventArgs
Visual C++
public ref class FetchEventArgs : public ActionEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
CelloSaaS.Model..::..ActionEventArgs
CelloSaaS.Model..::..FetchEventArgs

See Also

FetchEventArgs Members
CelloSaaS.Model Namespace


FetchEventArgs Members

[image] [image]

A Sandcastle Documented Class Library
FetchEventArgs Members
FetchEventArgs Class Constructors Methods Properties See Also Send Feedback

The FetchEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FetchEventArgs | Constructor of Fetch Event Args

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | CurrentContextModels | Gets or sets the current object model properties
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

FetchEventArgs Class
CelloSaaS.Model Namespace


FetchEventArgs Constructor

[image]

A Sandcastle Documented Class Library
FetchEventArgs Constructor
FetchEventArgs Class See Also Send Feedback
Constructor of Fetch Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FetchEventArgs(
    string entityIdentifier,
    BaseEntity crrentContextModel,
    EntityAction entityAction
)
Visual Basic
Public Sub New (
    entityIdentifier As String,
    crrentContextModel As BaseEntity,
    entityAction As EntityAction
)
Visual C++
public:
FetchEventArgs(
    String^ entityIdentifier,
    BaseEntity^ crrentContextModel,
    EntityAction^ entityAction
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
crrentContextModel
Type: CelloSaaS.Model..::..BaseEntity
Current object model
entityAction
Type: CelloSaaS.Model..::..EntityAction
Entity Action Properties

See Also

FetchEventArgs Class
FetchEventArgs Members
CelloSaaS.Model Namespace


FetchEventArgs Methods

[image] [image]

A Sandcastle Documented Class Library
FetchEventArgs Methods
FetchEventArgs Class See Also Send Feedback

The FetchEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FetchEventArgs Class
CelloSaaS.Model Namespace


FetchEventArgs Properties

[image] [image]

A Sandcastle Documented Class Library
FetchEventArgs Properties
FetchEventArgs Class See Also Send Feedback

The FetchEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | CurrentContextModels | Gets or sets the current object model properties
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

FetchEventArgs Class
CelloSaaS.Model Namespace


FetchEventArgs.CurrentContextModels Property

[image]

A Sandcastle Documented Class Library
FetchEventArgs..::..CurrentContextModels Property
FetchEventArgs Class See Also Send Feedback
Gets or sets the current object model properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, BaseEntity> CurrentContextModels { get; set; }
Visual Basic
Public Property CurrentContextModels As Dictionary(Of String, BaseEntity)
    Get
    Set
Visual C++
public:
property Dictionary<String^, BaseEntity^>^ CurrentContextModels {
    Dictionary<String^, BaseEntity^>^ get ();
    void set (Dictionary<String^, BaseEntity^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, BaseEntity >)>)>

See Also

FetchEventArgs Class
FetchEventArgs Members
CelloSaaS.Model Namespace


FetchType Enumeration

[image]

A Sandcastle Documented Class Library
FetchType Enumeration
See Also Send Feedback
Data Fetch type enumeration

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum FetchType
Visual Basic
<SerializableAttribute>
Public Enumeration FetchType
Visual C++
[SerializableAttribute]
public enum class FetchType

Members

Member name | Value | Description
View | 0 | Fetch for viewing
Edit | 1 | Fetch for editing
Delete | 2 | Fetch for deleting

See Also

CelloSaaS.Model Namespace


IdentifierType Enumeration

[image]

A Sandcastle Documented Class Library
IdentifierType Enumeration
See Also Send Feedback
Identifier Type

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum IdentifierType
Visual Basic
<SerializableAttribute>
Public Enumeration IdentifierType
Visual C++
[SerializableAttribute]
public enum class IdentifierType

Members

Member name | Value | Description
StringType | 0 | String PK
IntegerType | 1 | Int PK
GuidType | 2 | Uniqueidentifier PK

See Also

CelloSaaS.Model Namespace


InvalidSearchConditionException Class

[image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Class
Members See Also Send Feedback
Invalid Condition Format Exception

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidSearchConditionException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidSearchConditionException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidSearchConditionException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Model..::..InvalidSearchConditionException

See Also

InvalidSearchConditionException Members
CelloSaaS.Model Namespace


InvalidSearchConditionException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Members
InvalidSearchConditionException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidSearchConditionException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidSearchConditionException()()()() | Initializes a new instance of the InvalidSearchConditionException class.
Public method | InvalidSearchConditionException(String) | Initializes a new instance of the InvalidSearchConditionException class.
Public method | InvalidSearchConditionException(String, Exception) | Initializes a new instance of the InvalidSearchConditionException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidSearchConditionException Class
CelloSaaS.Model Namespace


InvalidSearchConditionException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Constructor
InvalidSearchConditionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidSearchConditionException()()()() | Initializes a new instance of the InvalidSearchConditionException class.
Public method | InvalidSearchConditionException(String) | Initializes a new instance of the InvalidSearchConditionException class.
Public method | InvalidSearchConditionException(String, Exception) | Initializes a new instance of the InvalidSearchConditionException class.

See Also

InvalidSearchConditionException Class
InvalidSearchConditionException Members
CelloSaaS.Model Namespace


InvalidSearchConditionException Constructor

[image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Constructor
InvalidSearchConditionException Class See Also Send Feedback
Initializes a new instance of the InvalidSearchConditionException class.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidSearchConditionException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidSearchConditionException()

See Also

InvalidSearchConditionException Class
InvalidSearchConditionException Members
InvalidSearchConditionException Overload
CelloSaaS.Model Namespace


InvalidSearchConditionException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Constructor (String)
InvalidSearchConditionException Class See Also Send Feedback
Initializes a new instance of the InvalidSearchConditionException class.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidSearchConditionException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidSearchConditionException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidSearchConditionException Class
InvalidSearchConditionException Members
InvalidSearchConditionException Overload
CelloSaaS.Model Namespace


InvalidSearchConditionException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Constructor (String, Exception)
InvalidSearchConditionException Class See Also Send Feedback
Initializes a new instance of the InvalidSearchConditionException class.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidSearchConditionException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidSearchConditionException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidSearchConditionException Class
InvalidSearchConditionException Members
InvalidSearchConditionException Overload
CelloSaaS.Model Namespace


InvalidSearchConditionException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Methods
InvalidSearchConditionException Class See Also Send Feedback

The InvalidSearchConditionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidSearchConditionException Class
CelloSaaS.Model Namespace


InvalidSearchConditionException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Properties
InvalidSearchConditionException Class See Also Send Feedback

The InvalidSearchConditionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidSearchConditionException Class
CelloSaaS.Model Namespace


InvalidSearchConditionException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidSearchConditionException Events
InvalidSearchConditionException Class See Also Send Feedback

The InvalidSearchConditionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidSearchConditionException Class
CelloSaaS.Model Namespace


ISearchCondition Interface

[image]

A Sandcastle Documented Class Library
ISearchCondition Interface
Members See Also Send Feedback
Search condition Interface

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ISearchCondition
Visual Basic
Public Interface ISearchCondition
Visual C++
public interface class ISearchCondition

See Also

ISearchCondition Members
CelloSaaS.Model Namespace


ISearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
ISearchCondition Members
ISearchCondition Interface Properties See Also Send Feedback

The ISearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition

See Also

ISearchCondition Interface
CelloSaaS.Model Namespace


ISearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ISearchCondition Properties
ISearchCondition Interface See Also Send Feedback

The ISearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition

See Also

ISearchCondition Interface
CelloSaaS.Model Namespace


ISearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
ISearchCondition..::..Condition Property
ISearchCondition Interface See Also Send Feedback
Condition

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string Condition { get; set; }
Visual Basic
Property Condition As String
    Get
    Set
Visual C++
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ISearchCondition Interface
ISearchCondition Members
CelloSaaS.Model Namespace


PickupListConstants Class

[image]

A Sandcastle Documented Class Library
PickupListConstants Class
Members See Also Send Feedback
Pickup list constants class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class PickupListConstants
Visual Basic
Public NotInheritable Class PickupListConstants
Visual C++
public ref class PickupListConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..PickupListConstants

See Also

PickupListConstants Members
CelloSaaS.Model Namespace


PickupListConstants Members

[image] [image]

A Sandcastle Documented Class Library
PickupListConstants Members
PickupListConstants Class Fields See Also Send Feedback

The PickupListConstants type exposes the following members.

Fields

Name | Description
CompanySizePickupList | Company size pickup list
SelfRegistrationPackagePickupList | Self registration package pickup list

See Also

PickupListConstants Class
CelloSaaS.Model Namespace


PickupListConstants Fields

[image] [image]

A Sandcastle Documented Class Library
PickupListConstants Fields
PickupListConstants Class See Also Send Feedback

The PickupListConstants type exposes the following members.

Fields

Name | Description
CompanySizePickupList | Company size pickup list
SelfRegistrationPackagePickupList | Self registration package pickup list

See Also

PickupListConstants Class
CelloSaaS.Model Namespace


PickupListConstants.CompanySizePickupList Field

[image]

A Sandcastle Documented Class Library
PickupListConstants..::..CompanySizePickupList Field
PickupListConstants Class See Also Send Feedback
Company size pickup list

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CompanySizePickupList
Visual Basic
Public Const CompanySizePickupList As String
Visual C++
public:
literal String^ CompanySizePickupList

Field Value

Type: String

See Also

PickupListConstants Class
PickupListConstants Members
CelloSaaS.Model Namespace


PickupListConstants.SelfRegistrationPackagePickupList Field

[image]

A Sandcastle Documented Class Library
PickupListConstants..::..SelfRegistrationPackagePickupList Field
PickupListConstants Class See Also Send Feedback
Self registration package pickup list

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SelfRegistrationPackagePickupList
Visual Basic
Public Const SelfRegistrationPackagePickupList As String
Visual C++
public:
literal String^ SelfRegistrationPackagePickupList

Field Value

Type: String

See Also

PickupListConstants Class
PickupListConstants Members
CelloSaaS.Model Namespace


SearchCondition Class

[image]

A Sandcastle Documented Class Library
SearchCondition Class
Members See Also Send Feedback
Search condition properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class SearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class SearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.AccessControlManagement..::..RoleDetailsSearchCondition
CelloSaaS.Model.AccessControlManagement..::..UserEntityPermissionSearchCondition
CelloSaaS.Model.TenantManagement..::..TenantRelationSearchCondition
CelloSaaS.Model.TenantManagement..::..TenantTypeSearchCondition
CelloSaaS.Model.UserManagement..::..UserDetailsSearchCondition
CelloSaaS.Model.UserManagement..::..UserPasswordExpirySearchCondition
CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntitySearchCondition

See Also

SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
SearchCondition Members
SearchCondition Class Constructors Methods Properties See Also Send Feedback

The SearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | SearchCondition | Initializes a new instance of the SearchCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition
Public property | RecordEnd | Ending record number
Public property | RecordStart | Starting record number
Public property | SearchStringList | Search string list
Public property | SetTotalCount | Set total count - Whether need to set total count or not.
Public property | SortExpression | Sorting order
Public property | SortString | Sort string

See Also

SearchCondition Class
CelloSaaS.Model Namespace


SearchCondition Constructor

[image]

A Sandcastle Documented Class Library
SearchCondition Constructor
SearchCondition Class See Also Send Feedback
Initializes a new instance of the SearchCondition class.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
SearchCondition()

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
SearchCondition Methods
SearchCondition Class See Also Send Feedback

The SearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchCondition Class
CelloSaaS.Model Namespace


SearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
SearchCondition Properties
SearchCondition Class See Also Send Feedback

The SearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition
Public property | RecordEnd | Ending record number
Public property | RecordStart | Starting record number
Public property | SearchStringList | Search string list
Public property | SetTotalCount | Set total count - Whether need to set total count or not.
Public property | SortExpression | Sorting order
Public property | SortString | Sort string

See Also

SearchCondition Class
CelloSaaS.Model Namespace


SearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..Condition Property
SearchCondition Class See Also Send Feedback
Condition

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition.RecordEnd Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..RecordEnd Property
SearchCondition Class See Also Send Feedback
Ending record number

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordEnd { get; set; }
Visual Basic
Public Property RecordEnd As Integer
    Get
    Set
Visual C++
public:
property int RecordEnd {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition.RecordStart Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..RecordStart Property
SearchCondition Class See Also Send Feedback
Starting record number

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordStart { get; set; }
Visual Basic
Public Property RecordStart As Integer
    Get
    Set
Visual C++
public:
property int RecordStart {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition.SearchStringList Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..SearchStringList Property
SearchCondition Class See Also Send Feedback
Search string list

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<SearchString> SearchStringList { get; set; }
Visual Basic
Public Property SearchStringList As List(Of SearchString)
    Get
    Set
Visual C++
public:
property List<SearchString^>^ SearchStringList {
    List<SearchString^>^ get ();
    void set (List<SearchString^>^ value);
}

Property Value

Type: List<(Of <(<' SearchString >)>)>

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..SetTotalCount Property
SearchCondition Class See Also Send Feedback
Set total count - Whether need to set total count or not.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> SetTotalCount {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition.SortExpression Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..SortExpression Property
SearchCondition Class See Also Send Feedback
Sorting order

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortExpression { get; set; }
Visual Basic
Public Property SortExpression As String
    Get
    Set
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
SearchCondition..::..SortString Property
SearchCondition Class See Also Send Feedback
Sort string

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SearchCondition Class
SearchCondition Members
CelloSaaS.Model Namespace


SearchParameters Class

[image]

A Sandcastle Documented Class Library
SearchParameters Class
Members See Also Send Feedback
Search parameter properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SearchParameters
Visual Basic
<SerializableAttribute>
Public Class SearchParameters
Visual C++
[SerializableAttribute]
public ref class SearchParameters

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchParameters

See Also

SearchParameters Members
CelloSaaS.Model Namespace


SearchParameters Members

[image] [image]

A Sandcastle Documented Class Library
SearchParameters Members
SearchParameters Class Constructors Methods Properties See Also Send Feedback

The SearchParameters type exposes the following members.

Constructors

 | Name | Description
Public method | SearchParameters | Initializes a new instance of the SearchParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | searchCondition | Search Condition
Public property | SearchSummary | Search summary

See Also

SearchParameters Class
CelloSaaS.Model Namespace


SearchParameters Constructor

[image]

A Sandcastle Documented Class Library
SearchParameters Constructor
SearchParameters Class See Also Send Feedback
Initializes a new instance of the SearchParameters class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SearchParameters()
Visual Basic
Public Sub New
Visual C++
public:
SearchParameters()

See Also

SearchParameters Class
SearchParameters Members
CelloSaaS.Model Namespace


SearchParameters Methods

[image] [image]

A Sandcastle Documented Class Library
SearchParameters Methods
SearchParameters Class See Also Send Feedback

The SearchParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchParameters Class
CelloSaaS.Model Namespace


SearchParameters Properties

[image] [image]

A Sandcastle Documented Class Library
SearchParameters Properties
SearchParameters Class See Also Send Feedback

The SearchParameters type exposes the following members.

Properties

 | Name | Description
Public property | searchCondition | Search Condition
Public property | SearchSummary | Search summary

See Also

SearchParameters Class
CelloSaaS.Model Namespace


SearchParameters.searchCondition Property

[image]

A Sandcastle Documented Class Library
SearchParameters..::..searchCondition Property
SearchParameters Class See Also Send Feedback
Search Condition

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SearchCondition searchCondition { get; set; }
Visual Basic
Public Property searchCondition As SearchCondition
    Get
    Set
Visual C++
public:
property SearchCondition^ searchCondition {
    SearchCondition^ get ();
    void set (SearchCondition^ value);
}

Property Value

Type: SearchCondition

See Also

SearchParameters Class
SearchParameters Members
CelloSaaS.Model Namespace


SearchParameters.SearchSummary Property

[image]

A Sandcastle Documented Class Library
SearchParameters..::..SearchSummary Property
SearchParameters Class See Also Send Feedback
Search summary

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SearchSummary SearchSummary { get; set; }
Visual Basic
Public Property SearchSummary As SearchSummary
    Get
    Set
Visual C++
public:
property SearchSummary^ SearchSummary {
    SearchSummary^ get ();
    void set (SearchSummary^ value);
}

Property Value

Type: SearchSummary

See Also

SearchParameters Class
SearchParameters Members
CelloSaaS.Model Namespace


SearchString Class

[image]

A Sandcastle Documented Class Library
SearchString Class
Members See Also Send Feedback
Search Entity Column Model

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SearchString
Visual Basic
<SerializableAttribute>
Public Class SearchString
Visual C++
[SerializableAttribute]
public ref class SearchString

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchString

See Also

SearchString Members
CelloSaaS.Model Namespace


SearchString Members

[image] [image]

A Sandcastle Documented Class Library
SearchString Members
SearchString Class Constructors Methods Properties See Also Send Feedback

The SearchString type exposes the following members.

Constructors

 | Name | Description
Public method | SearchString | Initializes a new instance of the SearchString class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SearchColumn | Gets or sets the search column.
Public property | SearchValue | Gets or sets the search value.

See Also

SearchString Class
CelloSaaS.Model Namespace


SearchString Constructor

[image]

A Sandcastle Documented Class Library
SearchString Constructor
SearchString Class See Also Send Feedback
Initializes a new instance of the SearchString class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SearchString()
Visual Basic
Public Sub New
Visual C++
public:
SearchString()

See Also

SearchString Class
SearchString Members
CelloSaaS.Model Namespace


SearchString Methods

[image] [image]

A Sandcastle Documented Class Library
SearchString Methods
SearchString Class See Also Send Feedback

The SearchString type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchString Class
CelloSaaS.Model Namespace


SearchString Properties

[image] [image]

A Sandcastle Documented Class Library
SearchString Properties
SearchString Class See Also Send Feedback

The SearchString type exposes the following members.

Properties

 | Name | Description
Public property | SearchColumn | Gets or sets the search column.
Public property | SearchValue | Gets or sets the search value.

See Also

SearchString Class
CelloSaaS.Model Namespace


SearchString.SearchColumn Property

[image]

A Sandcastle Documented Class Library
SearchString..::..SearchColumn Property
SearchString Class See Also Send Feedback
Gets or sets the search column.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchColumn { get; set; }
Visual Basic
Public Property SearchColumn As String
    Get
    Set
Visual C++
public:
property String^ SearchColumn {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The search column.

See Also

SearchString Class
SearchString Members
CelloSaaS.Model Namespace


SearchString.SearchValue Property

[image]

A Sandcastle Documented Class Library
SearchString..::..SearchValue Property
SearchString Class See Also Send Feedback
Gets or sets the search value.

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchValue { get; set; }
Visual Basic
Public Property SearchValue As String
    Get
    Set
Visual C++
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The search value.

See Also

SearchString Class
SearchString Members
CelloSaaS.Model Namespace


SearchSummary Class

[image]

A Sandcastle Documented Class Library
SearchSummary Class
Members See Also Send Feedback
Search summary properties

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SearchSummary
Visual Basic
<SerializableAttribute>
Public Class SearchSummary
Visual C++
[SerializableAttribute]
public ref class SearchSummary

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchSummary

See Also

SearchSummary Members
CelloSaaS.Model Namespace


SearchSummary Members

[image] [image]

A Sandcastle Documented Class Library
SearchSummary Members
SearchSummary Class Constructors Methods Properties See Also Send Feedback

The SearchSummary type exposes the following members.

Constructors

 | Name | Description
Public method | SearchSummary | Initializes a new instance of the SearchSummary class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TotalCount | Total count

See Also

SearchSummary Class
CelloSaaS.Model Namespace


SearchSummary Constructor

[image]

A Sandcastle Documented Class Library
SearchSummary Constructor
SearchSummary Class See Also Send Feedback
Initializes a new instance of the SearchSummary class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SearchSummary()
Visual Basic
Public Sub New
Visual C++
public:
SearchSummary()

See Also

SearchSummary Class
SearchSummary Members
CelloSaaS.Model Namespace


SearchSummary Methods

[image] [image]

A Sandcastle Documented Class Library
SearchSummary Methods
SearchSummary Class See Also Send Feedback

The SearchSummary type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SearchSummary Class
CelloSaaS.Model Namespace


SearchSummary Properties

[image] [image]

A Sandcastle Documented Class Library
SearchSummary Properties
SearchSummary Class See Also Send Feedback

The SearchSummary type exposes the following members.

Properties

 | Name | Description
Public property | TotalCount | Total count

See Also

SearchSummary Class
CelloSaaS.Model Namespace


SearchSummary.TotalCount Property

[image]

A Sandcastle Documented Class Library
SearchSummary..::..TotalCount Property
SearchSummary Class See Also Send Feedback
Total count

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

SearchSummary Class
SearchSummary Members
CelloSaaS.Model Namespace


SettingsTemplateConstants Class

[image]

A Sandcastle Documented Class Library
SettingsTemplateConstants Class
Members See Also Send Feedback
Settings template constants class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class SettingsTemplateConstants
Visual Basic
Public NotInheritable Class SettingsTemplateConstants
Visual C++
public ref class SettingsTemplateConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SettingsTemplateConstants

See Also

SettingsTemplateConstants Members
CelloSaaS.Model Namespace


SettingsTemplateConstants Members

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateConstants Members
SettingsTemplateConstants Class Fields See Also Send Feedback

The SettingsTemplateConstants type exposes the following members.

Fields

Name | Description
DefaultCustomTemplate | Default custom template id
DefaultProviderTemplate | Default provider template id

See Also

SettingsTemplateConstants Class
CelloSaaS.Model Namespace


SettingsTemplateConstants Fields

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateConstants Fields
SettingsTemplateConstants Class See Also Send Feedback

The SettingsTemplateConstants type exposes the following members.

Fields

Name | Description
DefaultCustomTemplate | Default custom template id
DefaultProviderTemplate | Default provider template id

See Also

SettingsTemplateConstants Class
CelloSaaS.Model Namespace


SettingsTemplateConstants.DefaultCustomTemplate Field

[image]

A Sandcastle Documented Class Library
SettingsTemplateConstants..::..DefaultCustomTemplate Field
SettingsTemplateConstants Class See Also Send Feedback
Default custom template id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DefaultCustomTemplate
Visual Basic
Public Const DefaultCustomTemplate As String
Visual C++
public:
literal String^ DefaultCustomTemplate

Field Value

Type: String

See Also

SettingsTemplateConstants Class
SettingsTemplateConstants Members
CelloSaaS.Model Namespace


SettingsTemplateConstants.DefaultProviderTemplate Field

[image]

A Sandcastle Documented Class Library
SettingsTemplateConstants..::..DefaultProviderTemplate Field
SettingsTemplateConstants Class See Also Send Feedback
Default provider template id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DefaultProviderTemplate
Visual Basic
Public Const DefaultProviderTemplate As String
Visual C++
public:
literal String^ DefaultProviderTemplate

Field Value

Type: String

See Also

SettingsTemplateConstants Class
SettingsTemplateConstants Members
CelloSaaS.Model Namespace


SortExpressionConstants Class

[image]

A Sandcastle Documented Class Library
SortExpressionConstants Class
Members See Also Send Feedback
Sort expression constants

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class SortExpressionConstants
Visual Basic
Public NotInheritable Class SortExpressionConstants
Visual C++
public ref class SortExpressionConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SortExpressionConstants

See Also

SortExpressionConstants Members
CelloSaaS.Model Namespace


SortExpressionConstants Members

[image] [image]

A Sandcastle Documented Class Library
SortExpressionConstants Members
SortExpressionConstants Class Fields See Also Send Feedback

The SortExpressionConstants type exposes the following members.

Fields

Name | Description
Ascending | Ascending Order
Decending | Descending Order

See Also

SortExpressionConstants Class
CelloSaaS.Model Namespace


SortExpressionConstants Fields

[image] [image]

A Sandcastle Documented Class Library
SortExpressionConstants Fields
SortExpressionConstants Class See Also Send Feedback

The SortExpressionConstants type exposes the following members.

Fields

Name | Description
Ascending | Ascending Order
Decending | Descending Order

See Also

SortExpressionConstants Class
CelloSaaS.Model Namespace


SortExpressionConstants.Ascending Field

[image]

A Sandcastle Documented Class Library
SortExpressionConstants..::..Ascending Field
SortExpressionConstants Class See Also Send Feedback
Ascending Order

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Ascending
Visual Basic
Public Const Ascending As String
Visual C++
public:
literal String^ Ascending

Field Value

Type: String

See Also

SortExpressionConstants Class
SortExpressionConstants Members
CelloSaaS.Model Namespace


SortExpressionConstants.Decending Field

[image]

A Sandcastle Documented Class Library
SortExpressionConstants..::..Decending Field
SortExpressionConstants Class See Also Send Feedback
Descending Order

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Decending
Visual Basic
Public Const Decending As String
Visual C++
public:
literal String^ Decending

Field Value

Type: String

See Also

SortExpressionConstants Class
SortExpressionConstants Members
CelloSaaS.Model Namespace


TenantTransactionalEntity Class

[image]

A Sandcastle Documented Class Library
TenantTransactionalEntity Class
Members See Also Send Feedback
This class contain Tenant Id property

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantTransactionalEntity : TransactionalBaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantTransactionalEntity
    Inherits TransactionalBaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantTransactionalEntity : public TransactionalBaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model..::..TransactionalBaseEntity
CelloSaaS.Model..::..TenantTransactionalEntity

See Also

TenantTransactionalEntity Members
CelloSaaS.Model Namespace


TenantTransactionalEntity Members

[image] [image]

A Sandcastle Documented Class Library
TenantTransactionalEntity Members
TenantTransactionalEntity Class Constructors Methods Properties See Also Send Feedback

The TenantTransactionalEntity type exposes the following members.

Constructors

 | Name | Description
Public method | TenantTransactionalEntity | Initializes a new instance of the TenantTransactionalEntity class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | GuidIdentifier | Gets or sets guid identifier (Inherited from TransactionalBaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegerIdentifier | Gets or sets identiger identifier (Inherited from TransactionalBaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TenantId | Gets the tenant id
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

TenantTransactionalEntity Class
CelloSaaS.Model Namespace


TenantTransactionalEntity Constructor

[image]

A Sandcastle Documented Class Library
TenantTransactionalEntity Constructor
TenantTransactionalEntity Class See Also Send Feedback
Initializes a new instance of the TenantTransactionalEntity class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantTransactionalEntity()
Visual Basic
Public Sub New
Visual C++
public:
TenantTransactionalEntity()

See Also

TenantTransactionalEntity Class
TenantTransactionalEntity Members
CelloSaaS.Model Namespace


TenantTransactionalEntity Methods

[image] [image]

A Sandcastle Documented Class Library
TenantTransactionalEntity Methods
TenantTransactionalEntity Class See Also Send Feedback

The TenantTransactionalEntity type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantTransactionalEntity Class
CelloSaaS.Model Namespace


TenantTransactionalEntity Properties

[image] [image]

A Sandcastle Documented Class Library
TenantTransactionalEntity Properties
TenantTransactionalEntity Class See Also Send Feedback

The TenantTransactionalEntity type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | GuidIdentifier | Gets or sets guid identifier (Inherited from TransactionalBaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegerIdentifier | Gets or sets identiger identifier (Inherited from TransactionalBaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TenantId | Gets the tenant id
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

TenantTransactionalEntity Class
CelloSaaS.Model Namespace


TenantTransactionalEntity.TenantId Property

[image]

A Sandcastle Documented Class Library
TenantTransactionalEntity..::..TenantId Property
TenantTransactionalEntity Class See Also Send Feedback
Gets the tenant id

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual string TenantId { get; set; }
Visual Basic
Public Overridable Property TenantId As String
    Get
    Set
Visual C++
public:
virtual property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantTransactionalEntity Class
TenantTransactionalEntity Members
CelloSaaS.Model Namespace


TransactionalBaseEntity Class

[image]

A Sandcastle Documented Class Library
TransactionalBaseEntity Class
Members See Also Send Feedback
This class contains guid and integer identifiers

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public abstract class TransactionalBaseEntity : BaseEntity
Visual Basic
<SerializableAttribute>
Public MustInherit Class TransactionalBaseEntity
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TransactionalBaseEntity abstract : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model..::..TransactionalBaseEntity
CelloSaaS.Model..::..TenantTransactionalEntity

See Also

TransactionalBaseEntity Members
CelloSaaS.Model Namespace


TransactionalBaseEntity Members

[image] [image]

A Sandcastle Documented Class Library
TransactionalBaseEntity Members
TransactionalBaseEntity Class Constructors Methods Properties See Also Send Feedback

The TransactionalBaseEntity type exposes the following members.

Constructors

 | Name | Description
Protected method | TransactionalBaseEntity | Initializes a new instance of the TransactionalBaseEntity class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | GuidIdentifier | Gets or sets guid identifier
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegerIdentifier | Gets or sets identiger identifier
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

TransactionalBaseEntity Class
CelloSaaS.Model Namespace


TransactionalBaseEntity Constructor

[image]

A Sandcastle Documented Class Library
TransactionalBaseEntity Constructor
TransactionalBaseEntity Class See Also Send Feedback
Initializes a new instance of the TransactionalBaseEntity class

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TransactionalBaseEntity()
Visual Basic
Protected Sub New
Visual C++
protected:
TransactionalBaseEntity()

See Also

TransactionalBaseEntity Class
TransactionalBaseEntity Members
CelloSaaS.Model Namespace


TransactionalBaseEntity Methods

[image] [image]

A Sandcastle Documented Class Library
TransactionalBaseEntity Methods
TransactionalBaseEntity Class See Also Send Feedback

The TransactionalBaseEntity type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TransactionalBaseEntity Class
CelloSaaS.Model Namespace


TransactionalBaseEntity Properties

[image] [image]

A Sandcastle Documented Class Library
TransactionalBaseEntity Properties
TransactionalBaseEntity Class See Also Send Feedback

The TransactionalBaseEntity type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | GuidIdentifier | Gets or sets guid identifier
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegerIdentifier | Gets or sets identiger identifier
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

TransactionalBaseEntity Class
CelloSaaS.Model Namespace


TransactionalBaseEntity.GuidIdentifier Property

[image]

A Sandcastle Documented Class Library
TransactionalBaseEntity..::..GuidIdentifier Property
TransactionalBaseEntity Class See Also Send Feedback
Gets or sets guid identifier

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual Guid GuidIdentifier { get; set; }
Visual Basic
Public Overridable Property GuidIdentifier As Guid
    Get
    Set
Visual C++
public:
virtual property Guid GuidIdentifier {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TransactionalBaseEntity Class
TransactionalBaseEntity Members
CelloSaaS.Model Namespace


TransactionalBaseEntity.IntegerIdentifier Property

[image]

A Sandcastle Documented Class Library
TransactionalBaseEntity..::..IntegerIdentifier Property
TransactionalBaseEntity Class See Also Send Feedback
Gets or sets identiger identifier

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual int IntegerIdentifier { get; set; }
Visual Basic
Public Overridable Property IntegerIdentifier As Integer
    Get
    Set
Visual C++
public:
virtual property int IntegerIdentifier {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TransactionalBaseEntity Class
TransactionalBaseEntity Members
CelloSaaS.Model Namespace


UpdateEventArgs Class

[image]

A Sandcastle Documented Class Library
UpdateEventArgs Class
Members See Also Send Feedback
Update Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class UpdateEventArgs : ActionEventArgs
Visual Basic
Public Class UpdateEventArgs
    Inherits ActionEventArgs
Visual C++
public ref class UpdateEventArgs : public ActionEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
CelloSaaS.Model..::..ActionEventArgs
CelloSaaS.Model..::..UpdateEventArgs

See Also

UpdateEventArgs Members
CelloSaaS.Model Namespace


UpdateEventArgs Members

[image] [image]

A Sandcastle Documented Class Library
UpdateEventArgs Members
UpdateEventArgs Class Constructors Methods Properties See Also Send Feedback

The UpdateEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | UpdateEventArgs | Constructor of Update Event Args

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

UpdateEventArgs Class
CelloSaaS.Model Namespace


UpdateEventArgs Constructor

[image]

A Sandcastle Documented Class Library
UpdateEventArgs Constructor
UpdateEventArgs Class See Also Send Feedback
Constructor of Update Event Args

Namespace: CelloSaaS.Model
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UpdateEventArgs(
    string entityIdentifier,
    BaseEntity crrentContextModel,
    EntityAction entityAction
)
Visual Basic
Public Sub New (
    entityIdentifier As String,
    crrentContextModel As BaseEntity,
    entityAction As EntityAction
)
Visual C++
public:
UpdateEventArgs(
    String^ entityIdentifier,
    BaseEntity^ crrentContextModel,
    EntityAction^ entityAction
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
crrentContextModel
Type: CelloSaaS.Model..::..BaseEntity
Current object model
entityAction
Type: CelloSaaS.Model..::..EntityAction
Entity Action Properties

See Also

UpdateEventArgs Class
UpdateEventArgs Members
CelloSaaS.Model Namespace


UpdateEventArgs Methods

[image] [image]

A Sandcastle Documented Class Library
UpdateEventArgs Methods
UpdateEventArgs Class See Also Send Feedback

The UpdateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UpdateEventArgs Class
CelloSaaS.Model Namespace


UpdateEventArgs Properties

[image] [image]

A Sandcastle Documented Class Library
UpdateEventArgs Properties
UpdateEventArgs Class See Also Send Feedback

The UpdateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Canceled | Gets or sets whether this is cancelled or not (Inherited from ActionEventArgs.)
Public property | CurrentContextModel | Gets or sets the base entity properties (Inherited from ActionEventArgs.)
Public property | EntityAction | Gets or sets the entity action properties (Inherited from ActionEventArgs.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from ActionEventArgs.)
Public property | Exception | Gets or sets the exception (Inherited from ActionEventArgs.)

See Also

UpdateEventArgs Class
CelloSaaS.Model Namespace


CelloSaaS.Model.AccessControlManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.AccessControlManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | DataScope | Data Scope Properties
Public class | DataScopeConstant | Data scope constant class
Public class | DynamicDatascopeValue | Dynamic datascope value properties.
Public class | DynamicVariable | Dynamic variable properties.
Public class | EntityBasedDataScope | Entity Based Data Scope Properties
Public class | EntityBasedTenantScope | Entity based tenant scope class
Public class | EntityPrivilege | Entity Privilege Properties
Public class | EntityTenantScope | Entity tenant scope class
Public class | Filter | Filter Properties
Public class | Privilege | Privilege Properties
Public class | Role | Role properties
Public class | RoleBasedScope | Role Based Scope Properties
Public class | RoleDetailsSearchCondition | The SearchCondition to get the role details.
Public class | RoleFeature | Role Feature Properties
Public class | RolePrivilege | Role Privilege properties
Public class | TenantScope | Tenant Scope class
Public class | TenantScopeConstant | Tenant scope constant class
Public class | UserEntityOtherPrivilege | User entity other privilege class
Public class | UserEntityPermission | UserEntityPermission
Public class | UserEntityPermissionSearchCondition | UserEntityPermission Search Condition Class


DataScope Class

[image]

A Sandcastle Documented Class Library
DataScope Class
Members See Also Send Feedback
Data Scope Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataScope
Visual Basic
<SerializableAttribute>
Public Class DataScope
Visual C++
[SerializableAttribute]
public ref class DataScope

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..DataScope

See Also

DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope Members

[image] [image]

A Sandcastle Documented Class Library
DataScope Members
DataScope Class Constructors Methods Properties See Also Send Feedback

The DataScope type exposes the following members.

Constructors

 | Name | Description
Public method | DataScope | Initializes a new instance of the DataScope class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TransformDataScopeCondtion | This method is used to transform data scope condition

Properties

 | Name | Description
Public property | AccessLevel | Gets or sets the access level of data scope
Public property | CreatedBy | Gets or sets the name/id of user who created this data scope details.
Public property | CreatedOn | Gets or sets the date time when this data scope details created.
Public property | DynamicVariables | Gets or sets the dynamic variables.
Public property | Filter | Gets or sets the filter properties
Public property | FilterableAttributes | Gets or sets the filterable attributes
Public property | Id | Gets or sets the data scope identifier
Public property | IsDynamic | Gets or sets a value indicating whether this instance is dynamic.
Public property | Name | Gets or sets the name of the data scope
Public property | Rule | Gets or sets the rule for data scope
Public property | Status | Gets or sets the status of the data scope details.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this data scope details.
Public property | UpdatedOn | Gets or sets the date time when this data scope details recently updated.

See Also

DataScope Class
CelloSaaS.Model.AccessControlManagement Namespace


DataScope Constructor

[image]

A Sandcastle Documented Class Library
DataScope Constructor
DataScope Class See Also Send Feedback
Initializes a new instance of the DataScope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataScope()
Visual Basic
Public Sub New
Visual C++
public:
DataScope()

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope Methods

[image] [image]

A Sandcastle Documented Class Library
DataScope Methods
DataScope Class See Also Send Feedback

The DataScope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TransformDataScopeCondtion | This method is used to transform data scope condition

See Also

DataScope Class
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.TransformDataScopeCondtion Method

[image]

A Sandcastle Documented Class Library
DataScope..::..TransformDataScopeCondtion Method
DataScope Class See Also Send Feedback
This method is used to transform data scope condition

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string TransformDataScopeCondtion(
    string dataScopeCondition,
    Dictionary<string, DynamicVariable> dynamicVariables
)
Visual Basic
Public Shared Function TransformDataScopeCondtion (
    dataScopeCondition As String,
    dynamicVariables As Dictionary(Of String, DynamicVariable)
) As String
Visual C++
public:
static String^ TransformDataScopeCondtion(
    String^ dataScopeCondition,
    Dictionary<String^, DynamicVariable^>^ dynamicVariables
)

Parameters

dataScopeCondition
Type: System..::..String
Data scope condition
dynamicVariables
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, DynamicVariable >)>)>
The dynamic variables.

Return Value

Type: String
Condition with values

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope Properties

[image] [image]

A Sandcastle Documented Class Library
DataScope Properties
DataScope Class See Also Send Feedback

The DataScope type exposes the following members.

Properties

 | Name | Description
Public property | AccessLevel | Gets or sets the access level of data scope
Public property | CreatedBy | Gets or sets the name/id of user who created this data scope details.
Public property | CreatedOn | Gets or sets the date time when this data scope details created.
Public property | DynamicVariables | Gets or sets the dynamic variables.
Public property | Filter | Gets or sets the filter properties
Public property | FilterableAttributes | Gets or sets the filterable attributes
Public property | Id | Gets or sets the data scope identifier
Public property | IsDynamic | Gets or sets a value indicating whether this instance is dynamic.
Public property | Name | Gets or sets the name of the data scope
Public property | Rule | Gets or sets the rule for data scope
Public property | Status | Gets or sets the status of the data scope details.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this data scope details.
Public property | UpdatedOn | Gets or sets the date time when this data scope details recently updated.

See Also

DataScope Class
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.AccessLevel Property

[image]

A Sandcastle Documented Class Library
DataScope..::..AccessLevel Property
DataScope Class See Also Send Feedback
Gets or sets the access level of data scope

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int AccessLevel { get; set; }
Visual Basic
Public Property AccessLevel As Integer
    Get
    Set
Visual C++
public:
property int AccessLevel {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DataScope..::..CreatedBy Property
DataScope Class See Also Send Feedback
Gets or sets the name/id of user who created this data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DataScope..::..CreatedOn Property
DataScope Class See Also Send Feedback
Gets or sets the date time when this data scope details created.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.DynamicVariables Property

[image]

A Sandcastle Documented Class Library
DataScope..::..DynamicVariables Property
DataScope Class See Also Send Feedback
Gets or sets the dynamic variables.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, DynamicVariable> DynamicVariables { get; set; }
Visual Basic
Public Property DynamicVariables As Dictionary(Of String, DynamicVariable)
    Get
    Set
Visual C++
public:
property Dictionary<String^, DynamicVariable^>^ DynamicVariables {
    Dictionary<String^, DynamicVariable^>^ get ();
    void set (Dictionary<String^, DynamicVariable^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, DynamicVariable >)>)>
The dynamic variables.

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.Filter Property

[image]

A Sandcastle Documented Class Library
DataScope..::..Filter Property
DataScope Class See Also Send Feedback
Gets or sets the filter properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Filter Filter { get; set; }
Visual Basic
Public Property Filter As Filter
    Get
    Set
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
    void set (Filter^ value);
}

Property Value

Type: Filter

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.FilterableAttributes Property

[image]

A Sandcastle Documented Class Library
DataScope..::..FilterableAttributes Property
DataScope Class See Also Send Feedback
Gets or sets the filterable attributes

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] FilterableAttributes { get; set; }
Visual Basic
Public Property FilterableAttributes As String()
    Get
    Set
Visual C++
public:
property array<String^>^ FilterableAttributes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.Id Property

[image]

A Sandcastle Documented Class Library
DataScope..::..Id Property
DataScope Class See Also Send Feedback
Gets or sets the data scope identifier

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.IsDynamic Property

[image]

A Sandcastle Documented Class Library
DataScope..::..IsDynamic Property
DataScope Class See Also Send Feedback
Gets or sets a value indicating whether this instance is dynamic.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsDynamic { get; set; }
Visual Basic
Public Property IsDynamic As Boolean
    Get
    Set
Visual C++
public:
property bool IsDynamic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is dynamic; otherwise, false.

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.Name Property

[image]

A Sandcastle Documented Class Library
DataScope..::..Name Property
DataScope Class See Also Send Feedback
Gets or sets the name of the data scope

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.Rule Property

[image]

A Sandcastle Documented Class Library
DataScope..::..Rule Property
DataScope Class See Also Send Feedback
Gets or sets the rule for data scope

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Rule { get; set; }
Visual Basic
Public Property Rule As String
    Get
    Set
Visual C++
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.Status Property

[image]

A Sandcastle Documented Class Library
DataScope..::..Status Property
DataScope Class See Also Send Feedback
Gets or sets the status of the data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DataScope..::..UpdatedBy Property
DataScope Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScope.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DataScope..::..UpdatedOn Property
DataScope Class See Also Send Feedback
Gets or sets the date time when this data scope details recently updated.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DataScope Class
DataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScopeConstant Class

[image]

A Sandcastle Documented Class Library
DataScopeConstant Class
Members See Also Send Feedback
Data scope constant class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DataScopeConstant
Visual Basic
Public Class DataScopeConstant
Visual C++
public ref class DataScopeConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..DataScopeConstant

See Also

DataScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScopeConstant Members

[image] [image]

A Sandcastle Documented Class Library
DataScopeConstant Members
DataScopeConstant Class Constructors Methods Fields See Also Send Feedback

The DataScopeConstant type exposes the following members.

Constructors

 | Name | Description
Public method | DataScopeConstant | Initializes a new instance of the DataScopeConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
NIL_DATASCOPE | Nil datascope constant

See Also

DataScopeConstant Class
CelloSaaS.Model.AccessControlManagement Namespace


DataScopeConstant Constructor

[image]

A Sandcastle Documented Class Library
DataScopeConstant Constructor
DataScopeConstant Class See Also Send Feedback
Initializes a new instance of the DataScopeConstant class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataScopeConstant()
Visual Basic
Public Sub New
Visual C++
public:
DataScopeConstant()

See Also

DataScopeConstant Class
DataScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScopeConstant Fields

[image] [image]

A Sandcastle Documented Class Library
DataScopeConstant Fields
DataScopeConstant Class See Also Send Feedback

The DataScopeConstant type exposes the following members.

Fields

Name | Description
NIL_DATASCOPE | Nil datascope constant

See Also

DataScopeConstant Class
CelloSaaS.Model.AccessControlManagement Namespace


DataScopeConstant.NIL_DATASCOPE Field

[image]

A Sandcastle Documented Class Library
DataScopeConstant..::..NIL_DATASCOPE Field
DataScopeConstant Class See Also Send Feedback
Nil datascope constant

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string NIL_DATASCOPE
Visual Basic
Public Const NIL_DATASCOPE As String
Visual C++
public:
literal String^ NIL_DATASCOPE

Field Value

Type: String

See Also

DataScopeConstant Class
DataScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


DataScopeConstant Methods

[image] [image]

A Sandcastle Documented Class Library
DataScopeConstant Methods
DataScopeConstant Class See Also Send Feedback

The DataScopeConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataScopeConstant Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue Class

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue Class
Members See Also Send Feedback
Dynamic datascope value properties.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DynamicDatascopeValue
Visual Basic
<SerializableAttribute>
Public Class DynamicDatascopeValue
Visual C++
[SerializableAttribute]
public ref class DynamicDatascopeValue

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..DynamicDatascopeValue

See Also

DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue Members

[image] [image]

A Sandcastle Documented Class Library
DynamicDatascopeValue Members
DynamicDatascopeValue Class Constructors Methods Properties See Also Send Feedback

The DynamicDatascopeValue type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicDatascopeValue | Initializes a new instance of the DynamicDatascopeValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/id of user who created this data scope details.
Public property | CreatedOn | Gets or sets the date time when this data scope details created.
Public property | DynamicDatascopeValueId | Gets or sets the dynamic datascope value id.
Public property | DynamicVariableId | Gets or sets the data variable id.
Public property | RolePrivilegeId | Gets or sets the role privilege id.
Public property | Status | Gets or sets the status of the data scope details.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this data scope details.
Public property | UpdatedOn | Gets or sets the date time when this data scope details recently updated.
Public property | Value | Gets or sets the value.

See Also

DynamicDatascopeValue Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue Constructor

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue Constructor
DynamicDatascopeValue Class See Also Send Feedback
Initializes a new instance of the DynamicDatascopeValue class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DynamicDatascopeValue()
Visual Basic
Public Sub New
Visual C++
public:
DynamicDatascopeValue()

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue Methods

[image] [image]

A Sandcastle Documented Class Library
DynamicDatascopeValue Methods
DynamicDatascopeValue Class See Also Send Feedback

The DynamicDatascopeValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DynamicDatascopeValue Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue Properties

[image] [image]

A Sandcastle Documented Class Library
DynamicDatascopeValue Properties
DynamicDatascopeValue Class See Also Send Feedback

The DynamicDatascopeValue type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/id of user who created this data scope details.
Public property | CreatedOn | Gets or sets the date time when this data scope details created.
Public property | DynamicDatascopeValueId | Gets or sets the dynamic datascope value id.
Public property | DynamicVariableId | Gets or sets the data variable id.
Public property | RolePrivilegeId | Gets or sets the role privilege id.
Public property | Status | Gets or sets the status of the data scope details.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this data scope details.
Public property | UpdatedOn | Gets or sets the date time when this data scope details recently updated.
Public property | Value | Gets or sets the value.

See Also

DynamicDatascopeValue Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..CreatedBy Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the name/id of user who created this data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..CreatedOn Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the date time when this data scope details created.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.DynamicDatascopeValueId Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..DynamicDatascopeValueId Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the dynamic datascope value id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DynamicDatascopeValueId { get; set; }
Visual Basic
Public Property DynamicDatascopeValueId As String
    Get
    Set
Visual C++
public:
property String^ DynamicDatascopeValueId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The dynamic datascope value id.

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.DynamicVariableId Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..DynamicVariableId Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the data variable id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DynamicVariableId { get; set; }
Visual Basic
Public Property DynamicVariableId As String
    Get
    Set
Visual C++
public:
property String^ DynamicVariableId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The data variable id.

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.RolePrivilegeId Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..RolePrivilegeId Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the role privilege id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RolePrivilegeId { get; set; }
Visual Basic
Public Property RolePrivilegeId As String
    Get
    Set
Visual C++
public:
property String^ RolePrivilegeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The role privilege id.

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.Status Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..Status Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the status of the data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..UpdatedBy Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..UpdatedOn Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the date time when this data scope details recently updated.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicDatascopeValue.Value Property

[image]

A Sandcastle Documented Class Library
DynamicDatascopeValue..::..Value Property
DynamicDatascopeValue Class See Also Send Feedback
Gets or sets the value.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The value.

See Also

DynamicDatascopeValue Class
DynamicDatascopeValue Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable Class

[image]

A Sandcastle Documented Class Library
DynamicVariable Class
Members See Also Send Feedback
Dynamic variable properties.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DynamicVariable
Visual Basic
<SerializableAttribute>
Public Class DynamicVariable
Visual C++
[SerializableAttribute]
public ref class DynamicVariable

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..DynamicVariable

See Also

DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable Members

[image] [image]

A Sandcastle Documented Class Library
DynamicVariable Members
DynamicVariable Class Constructors Methods Properties See Also Send Feedback

The DynamicVariable type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicVariable | Initializes a new instance of the DynamicVariable class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/id of user who created this data scope details.
Public property | CreatedOn | Gets or sets the date time when this data scope details created.
Public property | DataScopeId | Gets or sets the data scope id.
Public property | DataTypeId | Gets or sets the data type id.
Public property | DynamicDatascopeValue | Gets or sets the dynamic datascope value.
Public property | DynamicValueQuery | Gets or sets the dynamic value query.
Public property | DynamicValues | Gets or sets the dynamic values.
Public property | DynamicVariableId | Gets or sets the dynamic variable id.
Public property | FieldTypeId | Gets or sets the field type id.
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets the status of the data scope details.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this data scope details.
Public property | UpdatedOn | Gets or sets the date time when this data scope details recently updated.
Public property | VariableName | Gets or sets the name of the variable.

See Also

DynamicVariable Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable Constructor

[image]

A Sandcastle Documented Class Library
DynamicVariable Constructor
DynamicVariable Class See Also Send Feedback
Initializes a new instance of the DynamicVariable class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DynamicVariable()
Visual Basic
Public Sub New
Visual C++
public:
DynamicVariable()

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable Methods

[image] [image]

A Sandcastle Documented Class Library
DynamicVariable Methods
DynamicVariable Class See Also Send Feedback

The DynamicVariable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DynamicVariable Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable Properties

[image] [image]

A Sandcastle Documented Class Library
DynamicVariable Properties
DynamicVariable Class See Also Send Feedback

The DynamicVariable type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/id of user who created this data scope details.
Public property | CreatedOn | Gets or sets the date time when this data scope details created.
Public property | DataScopeId | Gets or sets the data scope id.
Public property | DataTypeId | Gets or sets the data type id.
Public property | DynamicDatascopeValue | Gets or sets the dynamic datascope value.
Public property | DynamicValueQuery | Gets or sets the dynamic value query.
Public property | DynamicValues | Gets or sets the dynamic values.
Public property | DynamicVariableId | Gets or sets the dynamic variable id.
Public property | FieldTypeId | Gets or sets the field type id.
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets the status of the data scope details.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this data scope details.
Public property | UpdatedOn | Gets or sets the date time when this data scope details recently updated.
Public property | VariableName | Gets or sets the name of the variable.

See Also

DynamicVariable Class
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..CreatedBy Property
DynamicVariable Class See Also Send Feedback
Gets or sets the name/id of user who created this data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..CreatedOn Property
DynamicVariable Class See Also Send Feedback
Gets or sets the date time when this data scope details created.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.DataScopeId Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..DataScopeId Property
DynamicVariable Class See Also Send Feedback
Gets or sets the data scope id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataScopeId { get; set; }
Visual Basic
Public Property DataScopeId As String
    Get
    Set
Visual C++
public:
property String^ DataScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The data scope id.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.DataTypeId Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..DataTypeId Property
DynamicVariable Class See Also Send Feedback
Gets or sets the data type id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataTypeId { get; set; }
Visual Basic
Public Property DataTypeId As String
    Get
    Set
Visual C++
public:
property String^ DataTypeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The data type id.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.DynamicDatascopeValue Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..DynamicDatascopeValue Property
DynamicVariable Class See Also Send Feedback
Gets or sets the dynamic datascope value.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DynamicDatascopeValue DynamicDatascopeValue { get; set; }
Visual Basic
Public Property DynamicDatascopeValue As DynamicDatascopeValue
    Get
    Set
Visual C++
public:
property DynamicDatascopeValue^ DynamicDatascopeValue {
    DynamicDatascopeValue^ get ();
    void set (DynamicDatascopeValue^ value);
}

Property Value

Type: DynamicDatascopeValue
The dynamic datascope value.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.DynamicValueQuery Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..DynamicValueQuery Property
DynamicVariable Class See Also Send Feedback
Gets or sets the dynamic value query.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DynamicValueQuery { get; set; }
Visual Basic
Public Property DynamicValueQuery As String
    Get
    Set
Visual C++
public:
property String^ DynamicValueQuery {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The dynamic value query.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.DynamicValues Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..DynamicValues Property
DynamicVariable Class See Also Send Feedback
Gets or sets the dynamic values.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, string> DynamicValues { get; set; }
Visual Basic
Public Property DynamicValues As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ DynamicValues {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, String>)>)>
The dynamic values.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.DynamicVariableId Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..DynamicVariableId Property
DynamicVariable Class See Also Send Feedback
Gets or sets the dynamic variable id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DynamicVariableId { get; set; }
Visual Basic
Public Property DynamicVariableId As String
    Get
    Set
Visual C++
public:
property String^ DynamicVariableId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The dynamic variable id.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.FieldTypeId Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..FieldTypeId Property
DynamicVariable Class See Also Send Feedback
Gets or sets the field type id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldType FieldTypeId { get; set; }
Visual Basic
Public Property FieldTypeId As FieldType
    Get
    Set
Visual C++
public:
property FieldType FieldTypeId {
    FieldType get ();
    void set (FieldType value);
}

Property Value

Type: FieldType
The field type id.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.Name Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..Name Property
DynamicVariable Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.Status Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..Status Property
DynamicVariable Class See Also Send Feedback
Gets or sets the status of the data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..UpdatedBy Property
DynamicVariable Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this data scope details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..UpdatedOn Property
DynamicVariable Class See Also Send Feedback
Gets or sets the date time when this data scope details recently updated.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


DynamicVariable.VariableName Property

[image]

A Sandcastle Documented Class Library
DynamicVariable..::..VariableName Property
DynamicVariable Class See Also Send Feedback
Gets or sets the name of the variable.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string VariableName { get; set; }
Visual Basic
Public Property VariableName As String
    Get
    Set
Visual C++
public:
property String^ VariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the variable.

See Also

DynamicVariable Class
DynamicVariable Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope Class

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope Class
Members See Also Send Feedback
Entity Based Data Scope Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityBasedDataScope
Visual Basic
<SerializableAttribute>
Public Class EntityBasedDataScope
Visual C++
[SerializableAttribute]
public ref class EntityBasedDataScope

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..EntityBasedDataScope

See Also

EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope Members

[image] [image]

A Sandcastle Documented Class Library
EntityBasedDataScope Members
EntityBasedDataScope Class Constructors Methods Properties See Also Send Feedback

The EntityBasedDataScope type exposes the following members.

Constructors

 | Name | Description
Public method | EntityBasedDataScope | Initializes a new instance of the EntityBasedDataScope class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BridgeFilter | Gets or sets the bridge filetr properties
Public property | BridgeSubjectReplacements | Gets or sets the bridge subject replacements
Public property | CreatedBy | Gets or sets the name/id of user who created this entity based data scope.
Public property | CreatedOn | Gets or sets the date time when this entity based data scope created.
Public property | DataScopeId | Gets or sets the data scope identifier
Public property | DataScopeName | Gets or sets the data scope name
Public property | EntityIdentifier | Gets or sets the entity identifier
Public property | Filter | Gets or sets the filter properties
Public property | Id | Gets or sets the identifier
Public property | Status | Gets or sets the status of the entity based data scope.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this entity based data scope.
Public property | UpdatedOn | Gets or sets the date time when this entity based data scope recently updated.

See Also

EntityBasedDataScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope Constructor

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope Constructor
EntityBasedDataScope Class See Also Send Feedback
Initializes a new instance of the EntityBasedDataScope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityBasedDataScope()
Visual Basic
Public Sub New
Visual C++
public:
EntityBasedDataScope()

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope Methods

[image] [image]

A Sandcastle Documented Class Library
EntityBasedDataScope Methods
EntityBasedDataScope Class See Also Send Feedback

The EntityBasedDataScope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityBasedDataScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope Properties

[image] [image]

A Sandcastle Documented Class Library
EntityBasedDataScope Properties
EntityBasedDataScope Class See Also Send Feedback

The EntityBasedDataScope type exposes the following members.

Properties

 | Name | Description
Public property | BridgeFilter | Gets or sets the bridge filetr properties
Public property | BridgeSubjectReplacements | Gets or sets the bridge subject replacements
Public property | CreatedBy | Gets or sets the name/id of user who created this entity based data scope.
Public property | CreatedOn | Gets or sets the date time when this entity based data scope created.
Public property | DataScopeId | Gets or sets the data scope identifier
Public property | DataScopeName | Gets or sets the data scope name
Public property | EntityIdentifier | Gets or sets the entity identifier
Public property | Filter | Gets or sets the filter properties
Public property | Id | Gets or sets the identifier
Public property | Status | Gets or sets the status of the entity based data scope.
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this entity based data scope.
Public property | UpdatedOn | Gets or sets the date time when this entity based data scope recently updated.

See Also

EntityBasedDataScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.BridgeFilter Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..BridgeFilter Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the bridge filetr properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Filter BridgeFilter { get; set; }
Visual Basic
Public Property BridgeFilter As Filter
    Get
    Set
Visual C++
public:
property Filter^ BridgeFilter {
    Filter^ get ();
    void set (Filter^ value);
}

Property Value

Type: Filter

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.BridgeSubjectReplacements Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..BridgeSubjectReplacements Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the bridge subject replacements

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, string> BridgeSubjectReplacements { get; set; }
Visual Basic
Public Property BridgeSubjectReplacements As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ BridgeSubjectReplacements {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, String>)>)>

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..CreatedBy Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the name/id of user who created this entity based data scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..CreatedOn Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the date time when this entity based data scope created.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.DataScopeId Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..DataScopeId Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the data scope identifier

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataScopeId { get; set; }
Visual Basic
Public Property DataScopeId As String
    Get
    Set
Visual C++
public:
property String^ DataScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.DataScopeName Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..DataScopeName Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the data scope name

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataScopeName { get; set; }
Visual Basic
Public Property DataScopeName As String
    Get
    Set
Visual C++
public:
property String^ DataScopeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..EntityIdentifier Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the entity identifier

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityIdentifier { get; set; }
Visual Basic
Public Property EntityIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.Filter Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..Filter Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the filter properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Filter Filter { get; set; }
Visual Basic
Public Property Filter As Filter
    Get
    Set
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
    void set (Filter^ value);
}

Property Value

Type: Filter

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.Id Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..Id Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the identifier

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.Status Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..Status Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the status of the entity based data scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..UpdatedBy Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this entity based data scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedDataScope.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EntityBasedDataScope..::..UpdatedOn Property
EntityBasedDataScope Class See Also Send Feedback
Gets or sets the date time when this entity based data scope recently updated.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

EntityBasedDataScope Class
EntityBasedDataScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope Class

[image]

A Sandcastle Documented Class Library
EntityBasedTenantScope Class
Members See Also Send Feedback
Entity based tenant scope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityBasedTenantScope
Visual Basic
<SerializableAttribute>
Public Class EntityBasedTenantScope
Visual C++
[SerializableAttribute]
public ref class EntityBasedTenantScope

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..EntityBasedTenantScope

See Also

EntityBasedTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope Members

[image] [image]

A Sandcastle Documented Class Library
EntityBasedTenantScope Members
EntityBasedTenantScope Class Constructors Methods Properties See Also Send Feedback

The EntityBasedTenantScope type exposes the following members.

Constructors

 | Name | Description
Public method | EntityBasedTenantScope | Initializes a new instance of the EntityBasedTenantScope class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BridgeCondition | Gets or sets the bridge condition.
Public property | EntityId | Gets or sets the entity id.
Public property | Id | Gets or sets the id.

See Also

EntityBasedTenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope Constructor

[image]

A Sandcastle Documented Class Library
EntityBasedTenantScope Constructor
EntityBasedTenantScope Class See Also Send Feedback
Initializes a new instance of the EntityBasedTenantScope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityBasedTenantScope()
Visual Basic
Public Sub New
Visual C++
public:
EntityBasedTenantScope()

See Also

EntityBasedTenantScope Class
EntityBasedTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope Methods

[image] [image]

A Sandcastle Documented Class Library
EntityBasedTenantScope Methods
EntityBasedTenantScope Class See Also Send Feedback

The EntityBasedTenantScope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityBasedTenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope Properties

[image] [image]

A Sandcastle Documented Class Library
EntityBasedTenantScope Properties
EntityBasedTenantScope Class See Also Send Feedback

The EntityBasedTenantScope type exposes the following members.

Properties

 | Name | Description
Public property | BridgeCondition | Gets or sets the bridge condition.
Public property | EntityId | Gets or sets the entity id.
Public property | Id | Gets or sets the id.

See Also

EntityBasedTenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope.BridgeCondition Property

[image]

A Sandcastle Documented Class Library
EntityBasedTenantScope..::..BridgeCondition Property
EntityBasedTenantScope Class See Also Send Feedback
Gets or sets the bridge condition.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BridgeCondition { get; set; }
Visual Basic
Public Property BridgeCondition As String
    Get
    Set
Visual C++
public:
property String^ BridgeCondition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The bridge condition.

See Also

EntityBasedTenantScope Class
EntityBasedTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityBasedTenantScope..::..EntityId Property
EntityBasedTenantScope Class See Also Send Feedback
Gets or sets the entity id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The entity id.

See Also

EntityBasedTenantScope Class
EntityBasedTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityBasedTenantScope.Id Property

[image]

A Sandcastle Documented Class Library
EntityBasedTenantScope..::..Id Property
EntityBasedTenantScope Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

EntityBasedTenantScope Class
EntityBasedTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege Class

[image]

A Sandcastle Documented Class Library
EntityPrivilege Class
Members See Also Send Feedback
Entity Privilege Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityPrivilege
Visual Basic
<SerializableAttribute>
Public Class EntityPrivilege
Visual C++
[SerializableAttribute]
public ref class EntityPrivilege

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..EntityPrivilege

See Also

EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege Members

[image] [image]

A Sandcastle Documented Class Library
EntityPrivilege Members
EntityPrivilege Class Constructors Methods Properties See Also Send Feedback

The EntityPrivilege type exposes the following members.

Constructors

 | Name | Description
Public method | EntityPrivilege | Initializes a new instance of the EntityPrivilege class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name of the entity privilege.
Public property | CreatedOn | This used to get or set created date of the entity privilege.
Public property | EntityId | This used to get or set Id of the Entity.
Public property | Id | This used to get or set id of the entity privilege.
Public property | PrivilegeId | This used to get or set Id of the privilege.
Public property | Status | This used to get or set status of the entity privilege.
Public property | UpdatedBy | This used to get or set last updated by id/name of the entity privilege.
Public property | UpdatedOn | This used to get or set last updated date of the entity privilege.

See Also

EntityPrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege Constructor

[image]

A Sandcastle Documented Class Library
EntityPrivilege Constructor
EntityPrivilege Class See Also Send Feedback
Initializes a new instance of the EntityPrivilege class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityPrivilege()
Visual Basic
Public Sub New
Visual C++
public:
EntityPrivilege()

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege Methods

[image] [image]

A Sandcastle Documented Class Library
EntityPrivilege Methods
EntityPrivilege Class See Also Send Feedback

The EntityPrivilege type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityPrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege Properties

[image] [image]

A Sandcastle Documented Class Library
EntityPrivilege Properties
EntityPrivilege Class See Also Send Feedback

The EntityPrivilege type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name of the entity privilege.
Public property | CreatedOn | This used to get or set created date of the entity privilege.
Public property | EntityId | This used to get or set Id of the Entity.
Public property | Id | This used to get or set id of the entity privilege.
Public property | PrivilegeId | This used to get or set Id of the privilege.
Public property | Status | This used to get or set status of the entity privilege.
Public property | UpdatedBy | This used to get or set last updated by id/name of the entity privilege.
Public property | UpdatedOn | This used to get or set last updated date of the entity privilege.

See Also

EntityPrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..CreatedBy Property
EntityPrivilege Class See Also Send Feedback
This used to get or set created by id/name of the entity privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..CreatedOn Property
EntityPrivilege Class See Also Send Feedback
This used to get or set created date of the entity privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..EntityId Property
EntityPrivilege Class See Also Send Feedback
This used to get or set Id of the Entity.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.Id Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..Id Property
EntityPrivilege Class See Also Send Feedback
This used to get or set id of the entity privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.PrivilegeId Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..PrivilegeId Property
EntityPrivilege Class See Also Send Feedback
This used to get or set Id of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrivilegeId { get; set; }
Visual Basic
Public Property PrivilegeId As String
    Get
    Set
Visual C++
public:
property String^ PrivilegeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.Status Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..Status Property
EntityPrivilege Class See Also Send Feedback
This used to get or set status of the entity privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..UpdatedBy Property
EntityPrivilege Class See Also Send Feedback
This used to get or set last updated by id/name of the entity privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityPrivilege.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EntityPrivilege..::..UpdatedOn Property
EntityPrivilege Class See Also Send Feedback
This used to get or set last updated date of the entity privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

EntityPrivilege Class
EntityPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope Class

[image]

A Sandcastle Documented Class Library
EntityTenantScope Class
Members See Also Send Feedback
Entity tenant scope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityTenantScope
Visual Basic
<SerializableAttribute>
Public Class EntityTenantScope
Visual C++
[SerializableAttribute]
public ref class EntityTenantScope

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..EntityTenantScope

See Also

EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope Members

[image] [image]

A Sandcastle Documented Class Library
EntityTenantScope Members
EntityTenantScope Class Constructors Methods Properties See Also Send Feedback

The EntityTenantScope type exposes the following members.

Constructors

 | Name | Description
Public method | EntityTenantScope | Initializes a new instance of the EntityTenantScope class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DeleteSelectiveTenant | Gets or sets the delete selective tenant.
Public property | DeleteTenantScope | Gets or sets the delete tenant scope.
Public property | DeleteTenantScopeId | Gets or sets the delete tenant scope id.
Public property | EditSelectiveTenant | Gets or sets the edit selective tenant.
Public property | EditTenantScope | Gets or sets the edit tenant scope.
Public property | EditTenantScopeId | Gets or sets the edit tenant scope id.
Public property | EntityBasedTenantScope | Gets or sets the entity based tenant scope.
Public property | EntityId | Gets or sets the entity id.
Public property | Id | Gets or sets the id.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | ViewSelectiveTenant | Gets or sets the view selective tenant.
Public property | ViewTenantScope | Gets or sets the view tenant scope.
Public property | ViewTenantScopeId | Gets or sets the view tenant scope id.

See Also

EntityTenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope Constructor

[image]

A Sandcastle Documented Class Library
EntityTenantScope Constructor
EntityTenantScope Class See Also Send Feedback
Initializes a new instance of the EntityTenantScope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityTenantScope()
Visual Basic
Public Sub New
Visual C++
public:
EntityTenantScope()

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope Methods

[image] [image]

A Sandcastle Documented Class Library
EntityTenantScope Methods
EntityTenantScope Class See Also Send Feedback

The EntityTenantScope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityTenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope Properties

[image] [image]

A Sandcastle Documented Class Library
EntityTenantScope Properties
EntityTenantScope Class See Also Send Feedback

The EntityTenantScope type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DeleteSelectiveTenant | Gets or sets the delete selective tenant.
Public property | DeleteTenantScope | Gets or sets the delete tenant scope.
Public property | DeleteTenantScopeId | Gets or sets the delete tenant scope id.
Public property | EditSelectiveTenant | Gets or sets the edit selective tenant.
Public property | EditTenantScope | Gets or sets the edit tenant scope.
Public property | EditTenantScopeId | Gets or sets the edit tenant scope id.
Public property | EntityBasedTenantScope | Gets or sets the entity based tenant scope.
Public property | EntityId | Gets or sets the entity id.
Public property | Id | Gets or sets the id.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | ViewSelectiveTenant | Gets or sets the view selective tenant.
Public property | ViewTenantScope | Gets or sets the view tenant scope.
Public property | ViewTenantScopeId | Gets or sets the view tenant scope id.

See Also

EntityTenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..CreatedBy Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..CreatedOn Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.DeleteSelectiveTenant Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..DeleteSelectiveTenant Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the delete selective tenant.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DeleteSelectiveTenant { get; set; }
Visual Basic
Public Property DeleteSelectiveTenant As String
    Get
    Set
Visual C++
public:
property String^ DeleteSelectiveTenant {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The delete selective tenant.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.DeleteTenantScope Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..DeleteTenantScope Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the delete tenant scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantScope DeleteTenantScope { get; set; }
Visual Basic
Public Property DeleteTenantScope As TenantScope
    Get
    Set
Visual C++
public:
property TenantScope^ DeleteTenantScope {
    TenantScope^ get ();
    void set (TenantScope^ value);
}

Property Value

Type: TenantScope
The delete tenant scope.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.DeleteTenantScopeId Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..DeleteTenantScopeId Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the delete tenant scope id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DeleteTenantScopeId { get; set; }
Visual Basic
Public Property DeleteTenantScopeId As String
    Get
    Set
Visual C++
public:
property String^ DeleteTenantScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The delete tenant scope id.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.EditSelectiveTenant Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..EditSelectiveTenant Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the edit selective tenant.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EditSelectiveTenant { get; set; }
Visual Basic
Public Property EditSelectiveTenant As String
    Get
    Set
Visual C++
public:
property String^ EditSelectiveTenant {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The edit selective tenant.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.EditTenantScope Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..EditTenantScope Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the edit tenant scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantScope EditTenantScope { get; set; }
Visual Basic
Public Property EditTenantScope As TenantScope
    Get
    Set
Visual C++
public:
property TenantScope^ EditTenantScope {
    TenantScope^ get ();
    void set (TenantScope^ value);
}

Property Value

Type: TenantScope
The edit tenant scope.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.EditTenantScopeId Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..EditTenantScopeId Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the edit tenant scope id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EditTenantScopeId { get; set; }
Visual Basic
Public Property EditTenantScopeId As String
    Get
    Set
Visual C++
public:
property String^ EditTenantScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The edit tenant scope id.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.EntityBasedTenantScope Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..EntityBasedTenantScope Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the entity based tenant scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityBasedTenantScope EntityBasedTenantScope { get; set; }
Visual Basic
Public Property EntityBasedTenantScope As EntityBasedTenantScope
    Get
    Set
Visual C++
public:
property EntityBasedTenantScope^ EntityBasedTenantScope {
    EntityBasedTenantScope^ get ();
    void set (EntityBasedTenantScope^ value);
}

Property Value

Type: EntityBasedTenantScope
The entity based tenant scope.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..EntityId Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the entity id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The entity id.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.Id Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..Id Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.Status Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..Status Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.TenantId Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..TenantId Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..UpdatedBy Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..UpdatedOn Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.ViewSelectiveTenant Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..ViewSelectiveTenant Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the view selective tenant.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ViewSelectiveTenant { get; set; }
Visual Basic
Public Property ViewSelectiveTenant As String
    Get
    Set
Visual C++
public:
property String^ ViewSelectiveTenant {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The view selective tenant.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.ViewTenantScope Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..ViewTenantScope Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the view tenant scope.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantScope ViewTenantScope { get; set; }
Visual Basic
Public Property ViewTenantScope As TenantScope
    Get
    Set
Visual C++
public:
property TenantScope^ ViewTenantScope {
    TenantScope^ get ();
    void set (TenantScope^ value);
}

Property Value

Type: TenantScope
The view tenant scope.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


EntityTenantScope.ViewTenantScopeId Property

[image]

A Sandcastle Documented Class Library
EntityTenantScope..::..ViewTenantScopeId Property
EntityTenantScope Class See Also Send Feedback
Gets or sets the view tenant scope id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ViewTenantScopeId { get; set; }
Visual Basic
Public Property ViewTenantScopeId As String
    Get
    Set
Visual C++
public:
property String^ ViewTenantScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The view tenant scope id.

See Also

EntityTenantScope Class
EntityTenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


Filter Class

[image]

A Sandcastle Documented Class Library
Filter Class
Members See Also Send Feedback
Filter Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Filter
Visual Basic
<SerializableAttribute>
Public Class Filter
Visual C++
[SerializableAttribute]
public ref class Filter

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..Filter

See Also

Filter Members
CelloSaaS.Model.AccessControlManagement Namespace


Filter Members

[image] [image]

A Sandcastle Documented Class Library
Filter Members
Filter Class Constructors Methods Properties See Also Send Feedback

The Filter type exposes the following members.

Constructors

 | Name | Description
Public method | Filter | Initializes a new instance of the Filter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition
Public property | ConditionProperty | Gets or sets the condition property
Public property | ContainsCondition | Gets or sets the contains condition
Public property | SelectList | Gets or sets the select list

See Also

Filter Class
CelloSaaS.Model.AccessControlManagement Namespace


Filter Constructor

[image]

A Sandcastle Documented Class Library
Filter Constructor
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Filter()
Visual Basic
Public Sub New
Visual C++
public:
Filter()

See Also

Filter Class
Filter Members
CelloSaaS.Model.AccessControlManagement Namespace


Filter Methods

[image] [image]

A Sandcastle Documented Class Library
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Filter Class
CelloSaaS.Model.AccessControlManagement Namespace


Filter Properties

[image] [image]

A Sandcastle Documented Class Library
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition
Public property | ConditionProperty | Gets or sets the condition property
Public property | ContainsCondition | Gets or sets the contains condition
Public property | SelectList | Gets or sets the select list

See Also

Filter Class
CelloSaaS.Model.AccessControlManagement Namespace


Filter.Condition Property

[image]

A Sandcastle Documented Class Library
Filter..::..Condition Property
Filter Class See Also Send Feedback
Gets or sets the condition

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Filter Class
Filter Members
CelloSaaS.Model.AccessControlManagement Namespace


Filter.ConditionProperty Property

[image]

A Sandcastle Documented Class Library
Filter..::..ConditionProperty Property
Filter Class See Also Send Feedback
Gets or sets the condition property

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConditionProperty { get; set; }
Visual Basic
Public Property ConditionProperty As String
    Get
    Set
Visual C++
public:
property String^ ConditionProperty {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Filter Class
Filter Members
CelloSaaS.Model.AccessControlManagement Namespace


Filter.ContainsCondition Property

[image]

A Sandcastle Documented Class Library
Filter..::..ContainsCondition Property
Filter Class See Also Send Feedback
Gets or sets the contains condition

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContainsCondition { get; set; }
Visual Basic
Public Property ContainsCondition As String
    Get
    Set
Visual C++
public:
property String^ ContainsCondition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Filter Class
Filter Members
CelloSaaS.Model.AccessControlManagement Namespace


Filter.SelectList Property

[image]

A Sandcastle Documented Class Library
Filter..::..SelectList Property
Filter Class See Also Send Feedback
Gets or sets the select list

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SelectList { get; set; }
Visual Basic
Public Property SelectList As String
    Get
    Set
Visual C++
public:
property String^ SelectList {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Filter Class
Filter Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege Class

[image]

A Sandcastle Documented Class Library
Privilege Class
Members See Also Send Feedback
Privilege Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Privilege
Visual Basic
<SerializableAttribute>
Public Class Privilege
Visual C++
[SerializableAttribute]
public ref class Privilege

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..Privilege

See Also

Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege Members

[image] [image]

A Sandcastle Documented Class Library
Privilege Members
Privilege Class Constructors Methods Properties See Also Send Feedback

The Privilege type exposes the following members.

Constructors

 | Name | Description
Public method | Privilege | Initializes a new instance of the Privilege class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BasePrivilege | Gets or sets the base privilege of current privilege
Public property | CreatedBy | Gets or sets created by id/name of the privilege.
Public property | CreatedOn | Gets or sets created date of the privilege.
Public property | Description | Gets or sets description of the privilege.
Public property | Id | Gets or sets id of the privilege.
Public property | Name | Gets or sets name of the privilege.
Public property | Status | Gets or sets status of the privilege.
Public property | TenantId | Gets or sets tenant id
Public property | UpdatedBy | Gets or sets last updated by id/name of the privilege.
Public property | UpdatedOn | Gets or sets last updated date of the privilege.

See Also

Privilege Class
CelloSaaS.Model.AccessControlManagement Namespace


Privilege Constructor

[image]

A Sandcastle Documented Class Library
Privilege Constructor
Privilege Class See Also Send Feedback
Initializes a new instance of the Privilege class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Privilege()
Visual Basic
Public Sub New
Visual C++
public:
Privilege()

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege Methods

[image] [image]

A Sandcastle Documented Class Library
Privilege Methods
Privilege Class See Also Send Feedback

The Privilege type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Privilege Class
CelloSaaS.Model.AccessControlManagement Namespace


Privilege Properties

[image] [image]

A Sandcastle Documented Class Library
Privilege Properties
Privilege Class See Also Send Feedback

The Privilege type exposes the following members.

Properties

 | Name | Description
Public property | BasePrivilege | Gets or sets the base privilege of current privilege
Public property | CreatedBy | Gets or sets created by id/name of the privilege.
Public property | CreatedOn | Gets or sets created date of the privilege.
Public property | Description | Gets or sets description of the privilege.
Public property | Id | Gets or sets id of the privilege.
Public property | Name | Gets or sets name of the privilege.
Public property | Status | Gets or sets status of the privilege.
Public property | TenantId | Gets or sets tenant id
Public property | UpdatedBy | Gets or sets last updated by id/name of the privilege.
Public property | UpdatedOn | Gets or sets last updated date of the privilege.

See Also

Privilege Class
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.BasePrivilege Property

[image]

A Sandcastle Documented Class Library
Privilege..::..BasePrivilege Property
Privilege Class See Also Send Feedback
Gets or sets the base privilege of current privilege

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BasePrivilege { get; set; }
Visual Basic
Public Property BasePrivilege As String
    Get
    Set
Visual C++
public:
property String^ BasePrivilege {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Privilege..::..CreatedBy Property
Privilege Class See Also Send Feedback
Gets or sets created by id/name of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Privilege..::..CreatedOn Property
Privilege Class See Also Send Feedback
Gets or sets created date of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.Description Property

[image]

A Sandcastle Documented Class Library
Privilege..::..Description Property
Privilege Class See Also Send Feedback
Gets or sets description of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.Id Property

[image]

A Sandcastle Documented Class Library
Privilege..::..Id Property
Privilege Class See Also Send Feedback
Gets or sets id of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.Name Property

[image]

A Sandcastle Documented Class Library
Privilege..::..Name Property
Privilege Class See Also Send Feedback
Gets or sets name of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.Status Property

[image]

A Sandcastle Documented Class Library
Privilege..::..Status Property
Privilege Class See Also Send Feedback
Gets or sets status of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.TenantId Property

[image]

A Sandcastle Documented Class Library
Privilege..::..TenantId Property
Privilege Class See Also Send Feedback
Gets or sets tenant id

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Privilege..::..UpdatedBy Property
Privilege Class See Also Send Feedback
Gets or sets last updated by id/name of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Privilege.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Privilege..::..UpdatedOn Property
Privilege Class See Also Send Feedback
Gets or sets last updated date of the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Privilege Class
Privilege Members
CelloSaaS.Model.AccessControlManagement Namespace


Role Class

[image]

A Sandcastle Documented Class Library
Role Class
Members See Also Send Feedback
Role properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Role : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class Role
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class Role : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.AccessControlManagement..::..Role

See Also

Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role Members

[image] [image]

A Sandcastle Documented Class Library
Role Members
Role Class Constructors Methods Properties See Also Send Feedback

The Role type exposes the following members.

Constructors

 | Name | Description
Public method | Role | Initializes a new instance of the Role class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by id/name of the role.
Public property | CreatedOn | Gets or sets created date of the role.
Public property | Description | Gets or sets description of the role.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsGlobal | Gets or sets the role is global or tenant based.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | RoleId | Gets or sets Id of the role.
Public property | RoleName | Gets or sets name of the role.
Public property | Services | Gets and sets services.
Public property | Status | Gets or set status of the role.
Public property | TenantId | Gets or sets tenant id of the role.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets last updated by id/name of the role.
Public property | UpdatedOn | Gets or sets last updated date of the role.

See Also

Role Class
CelloSaaS.Model.AccessControlManagement Namespace


Role Constructor

[image]

A Sandcastle Documented Class Library
Role Constructor
Role Class See Also Send Feedback
Initializes a new instance of the Role class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Role()
Visual Basic
Public Sub New
Visual C++
public:
Role()

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role Methods

[image] [image]

A Sandcastle Documented Class Library
Role Methods
Role Class See Also Send Feedback

The Role type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

Role Class
CelloSaaS.Model.AccessControlManagement Namespace


Role Properties

[image] [image]

A Sandcastle Documented Class Library
Role Properties
Role Class See Also Send Feedback

The Role type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by id/name of the role.
Public property | CreatedOn | Gets or sets created date of the role.
Public property | Description | Gets or sets description of the role.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsGlobal | Gets or sets the role is global or tenant based.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | RoleId | Gets or sets Id of the role.
Public property | RoleName | Gets or sets name of the role.
Public property | Services | Gets and sets services.
Public property | Status | Gets or set status of the role.
Public property | TenantId | Gets or sets tenant id of the role.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets last updated by id/name of the role.
Public property | UpdatedOn | Gets or sets last updated date of the role.

See Also

Role Class
CelloSaaS.Model.AccessControlManagement Namespace


Role.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Role..::..CreatedBy Property
Role Class See Also Send Feedback
Gets or sets created by id/name of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Role..::..CreatedOn Property
Role Class See Also Send Feedback
Gets or sets created date of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.Description Property

[image]

A Sandcastle Documented Class Library
Role..::..Description Property
Role Class See Also Send Feedback
Gets or sets description of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.IsGlobal Property

[image]

A Sandcastle Documented Class Library
Role..::..IsGlobal Property
Role Class See Also Send Feedback
Gets or sets the role is global or tenant based.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsGlobal { get; set; }
Visual Basic
Public Property IsGlobal As Boolean
    Get
    Set
Visual C++
public:
property bool IsGlobal {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.RoleId Property

[image]

A Sandcastle Documented Class Library
Role..::..RoleId Property
Role Class See Also Send Feedback
Gets or sets Id of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.RoleName Property

[image]

A Sandcastle Documented Class Library
Role..::..RoleName Property
Role Class See Also Send Feedback
Gets or sets name of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleName { get; set; }
Visual Basic
Public Property RoleName As String
    Get
    Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.Services Property

[image]

A Sandcastle Documented Class Library
Role..::..Services Property
Role Class See Also Send Feedback
Gets and sets services.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Service> Services { get; set; }
Visual Basic
Public Property Services As Dictionary(Of String, Service)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Service^>^ Services {
    Dictionary<String^, Service^>^ get ();
    void set (Dictionary<String^, Service^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Service >)>)>

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.Status Property

[image]

A Sandcastle Documented Class Library
Role..::..Status Property
Role Class See Also Send Feedback
Gets or set status of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.TenantId Property

[image]

A Sandcastle Documented Class Library
Role..::..TenantId Property
Role Class See Also Send Feedback
Gets or sets tenant id of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Role..::..UpdatedBy Property
Role Class See Also Send Feedback
Gets or sets last updated by id/name of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


Role.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Role..::..UpdatedOn Property
Role Class See Also Send Feedback
Gets or sets last updated date of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Role Class
Role Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope Class

[image]

A Sandcastle Documented Class Library
RoleBasedScope Class
Members See Also Send Feedback
Role Based Scope Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoleBasedScope
Visual Basic
<SerializableAttribute>
Public Class RoleBasedScope
Visual C++
[SerializableAttribute]
public ref class RoleBasedScope

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..RoleBasedScope

See Also

RoleBasedScope Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope Members

[image] [image]

A Sandcastle Documented Class Library
RoleBasedScope Members
RoleBasedScope Class Constructors Methods Properties See Also Send Feedback

The RoleBasedScope type exposes the following members.

Constructors

 | Name | Description
Public method | RoleBasedScope | Initializes a new instance of the RoleBasedScope class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataScopeName | Obsolete. Obsolete:Return the data scope with highest access points
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PermissionName | Gets or Sets the permission name
Public property | RoleBasedDefaultScope | Gets or sets the data scope properties

See Also

RoleBasedScope Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope Constructor

[image]

A Sandcastle Documented Class Library
RoleBasedScope Constructor
RoleBasedScope Class See Also Send Feedback
Initializes a new instance of the RoleBasedScope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleBasedScope()
Visual Basic
Public Sub New
Visual C++
public:
RoleBasedScope()

See Also

RoleBasedScope Class
RoleBasedScope Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope Methods

[image] [image]

A Sandcastle Documented Class Library
RoleBasedScope Methods
RoleBasedScope Class See Also Send Feedback

The RoleBasedScope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDataScopeName | Obsolete. Obsolete:Return the data scope with highest access points
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoleBasedScope Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope.GetDataScopeName Method

[image]

A Sandcastle Documented Class Library
RoleBasedScope..::..GetDataScopeName Method
RoleBasedScope Class See Also Send Feedback
Obsolete:Return the data scope with highest access points

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
public static string GetDataScopeName(
    string[] roles
)
Visual Basic
<ObsoleteAttribute>
Public Shared Function GetDataScopeName (
    roles As String()
) As String
Visual C++
public:
[ObsoleteAttribute]
static String^ GetDataScopeName(
    array<String^>^ roles
)

Parameters

roles
Type: array<System..::..String>[]()[][]
Role Identifiers

Return Value

Type: String

See Also

RoleBasedScope Class
RoleBasedScope Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope Properties

[image] [image]

A Sandcastle Documented Class Library
RoleBasedScope Properties
RoleBasedScope Class See Also Send Feedback

The RoleBasedScope type exposes the following members.

Properties

 | Name | Description
Public property | PermissionName | Gets or Sets the permission name
Public property | RoleBasedDefaultScope | Gets or sets the data scope properties

See Also

RoleBasedScope Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope.PermissionName Property

[image]

A Sandcastle Documented Class Library
RoleBasedScope..::..PermissionName Property
RoleBasedScope Class See Also Send Feedback
Gets or Sets the permission name

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PermissionName { get; set; }
Visual Basic
Public Property PermissionName As String
    Get
    Set
Visual C++
public:
property String^ PermissionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleBasedScope Class
RoleBasedScope Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleBasedScope.RoleBasedDefaultScope Property

[image]

A Sandcastle Documented Class Library
RoleBasedScope..::..RoleBasedDefaultScope Property
RoleBasedScope Class See Also Send Feedback
Gets or sets the data scope properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, DataScope> RoleBasedDefaultScope { get; set; }
Visual Basic
Public Property RoleBasedDefaultScope As Dictionary(Of String, DataScope)
    Get
    Set
Visual C++
public:
property Dictionary<String^, DataScope^>^ RoleBasedDefaultScope {
    Dictionary<String^, DataScope^>^ get ();
    void set (Dictionary<String^, DataScope^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, DataScope >)>)>

See Also

RoleBasedScope Class
RoleBasedScope Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition Class

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition Class
Members See Also Send Feedback
The SearchCondition to get the role details.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class RoleDetailsSearchCondition : SearchCondition
Visual Basic
Public Class RoleDetailsSearchCondition
    Inherits SearchCondition
Visual C++
public ref class RoleDetailsSearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.AccessControlManagement..::..RoleDetailsSearchCondition

See Also

RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition Members
RoleDetailsSearchCondition Class Constructors Methods Properties See Also Send Feedback

The RoleDetailsSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | RoleDetailsSearchCondition | Initializes a new instance of the RoleDetailsSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | IsGlobal | Gets or sets the is global.
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | RoleId | Gets or sets the role id.
Public property | RoleIds | Gets or sets the role ids.
Public property | RoleName | Gets or sets the name of the role.
Public property | RoleNames | Gets or sets the role names.
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | Status | Gets or sets a value indicating whether this RoleDetailsSearchCondition is status.
Public property | TenantId | Gets or sets the tenant id.

See Also

RoleDetailsSearchCondition Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition Constructor
RoleDetailsSearchCondition Class See Also Send Feedback
Initializes a new instance of the RoleDetailsSearchCondition class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleDetailsSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
RoleDetailsSearchCondition()

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition Methods
RoleDetailsSearchCondition Class See Also Send Feedback

The RoleDetailsSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoleDetailsSearchCondition Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition Properties
RoleDetailsSearchCondition Class See Also Send Feedback

The RoleDetailsSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | IsGlobal | Gets or sets the is global.
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | RoleId | Gets or sets the role id.
Public property | RoleIds | Gets or sets the role ids.
Public property | RoleName | Gets or sets the name of the role.
Public property | RoleNames | Gets or sets the role names.
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | Status | Gets or sets a value indicating whether this RoleDetailsSearchCondition is status.
Public property | TenantId | Gets or sets the tenant id.

See Also

RoleDetailsSearchCondition Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.IsGlobal Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..IsGlobal Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets the is global.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> IsGlobal { get; set; }
Visual Basic
Public Property IsGlobal As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> IsGlobal {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The is global.

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.RoleId Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..RoleId Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets the role id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The role id.

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.RoleIds Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..RoleIds Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets the role ids.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> RoleIds { get; set; }
Visual Basic
Public Property RoleIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ RoleIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The role ids List

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.RoleName Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..RoleName Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets the name of the role.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleName { get; set; }
Visual Basic
Public Property RoleName As String
    Get
    Set
Visual C++
public:
property String^ RoleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the role.

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.RoleNames Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..RoleNames Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets the role names.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> RoleNames { get; set; }
Visual Basic
Public Property RoleNames As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ RoleNames {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The role names List

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.Status Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..Status Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets a value indicating whether this RoleDetailsSearchCondition is status.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleDetailsSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
RoleDetailsSearchCondition..::..TenantId Property
RoleDetailsSearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

RoleDetailsSearchCondition Class
RoleDetailsSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature Class

[image]

A Sandcastle Documented Class Library
RoleFeature Class
Members See Also Send Feedback
Role Feature Properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoleFeature
Visual Basic
<SerializableAttribute>
Public Class RoleFeature
Visual C++
[SerializableAttribute]
public ref class RoleFeature

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..RoleFeature

See Also

RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature Members

[image] [image]

A Sandcastle Documented Class Library
RoleFeature Members
RoleFeature Class Constructors Methods Properties See Also Send Feedback

The RoleFeature type exposes the following members.

Constructors

 | Name | Description
Public method | RoleFeature | Initializes a new instance of the RoleFeature class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by id/name of the role feature.
Public property | CreatedOn | Gets or sets created date of the role feature.
Public property | DataScopeId | Gets or sets data scope id of the role feature.
Public property | FeatureId | Gets or sets feature id of the role feature.
Public property | Id | Gets or sets id of the role privilege.
Public property | RoleId | Gets or sets role id of the role feature.
Public property | Status | Gets or sets status of the role feature.
Public property | TenantId | Gets or sets tenant id of the role feature.
Public property | UpdatedBy | Gets or sets last updated by id/name of the role feature.
Public property | UpdatedOn | Gets or sets last updated date of the role feature.

See Also

RoleFeature Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature Constructor

[image]

A Sandcastle Documented Class Library
RoleFeature Constructor
RoleFeature Class See Also Send Feedback
Initializes a new instance of the RoleFeature class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleFeature()
Visual Basic
Public Sub New
Visual C++
public:
RoleFeature()

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature Methods

[image] [image]

A Sandcastle Documented Class Library
RoleFeature Methods
RoleFeature Class See Also Send Feedback

The RoleFeature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoleFeature Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature Properties

[image] [image]

A Sandcastle Documented Class Library
RoleFeature Properties
RoleFeature Class See Also Send Feedback

The RoleFeature type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by id/name of the role feature.
Public property | CreatedOn | Gets or sets created date of the role feature.
Public property | DataScopeId | Gets or sets data scope id of the role feature.
Public property | FeatureId | Gets or sets feature id of the role feature.
Public property | Id | Gets or sets id of the role privilege.
Public property | RoleId | Gets or sets role id of the role feature.
Public property | Status | Gets or sets status of the role feature.
Public property | TenantId | Gets or sets tenant id of the role feature.
Public property | UpdatedBy | Gets or sets last updated by id/name of the role feature.
Public property | UpdatedOn | Gets or sets last updated date of the role feature.

See Also

RoleFeature Class
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.CreatedBy Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..CreatedBy Property
RoleFeature Class See Also Send Feedback
Gets or sets created by id/name of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.CreatedOn Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..CreatedOn Property
RoleFeature Class See Also Send Feedback
Gets or sets created date of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.DataScopeId Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..DataScopeId Property
RoleFeature Class See Also Send Feedback
Gets or sets data scope id of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataScopeId { get; set; }
Visual Basic
Public Property DataScopeId As String
    Get
    Set
Visual C++
public:
property String^ DataScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.FeatureId Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..FeatureId Property
RoleFeature Class See Also Send Feedback
Gets or sets feature id of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureId { get; set; }
Visual Basic
Public Property FeatureId As String
    Get
    Set
Visual C++
public:
property String^ FeatureId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.Id Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..Id Property
RoleFeature Class See Also Send Feedback
Gets or sets id of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.RoleId Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..RoleId Property
RoleFeature Class See Also Send Feedback
Gets or sets role id of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.Status Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..Status Property
RoleFeature Class See Also Send Feedback
Gets or sets status of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.TenantId Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..TenantId Property
RoleFeature Class See Also Send Feedback
Gets or sets tenant id of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..UpdatedBy Property
RoleFeature Class See Also Send Feedback
Gets or sets last updated by id/name of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RoleFeature.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
RoleFeature..::..UpdatedOn Property
RoleFeature Class See Also Send Feedback
Gets or sets last updated date of the role feature.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

RoleFeature Class
RoleFeature Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege Class

[image]

A Sandcastle Documented Class Library
RolePrivilege Class
Members See Also Send Feedback
Role Privilege properties

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RolePrivilege
Visual Basic
<SerializableAttribute>
Public Class RolePrivilege
Visual C++
[SerializableAttribute]
public ref class RolePrivilege

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..RolePrivilege

See Also

RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege Members

[image] [image]

A Sandcastle Documented Class Library
RolePrivilege Members
RolePrivilege Class Constructors Methods Properties See Also Send Feedback

The RolePrivilege type exposes the following members.

Constructors

 | Name | Description
Public method | RolePrivilege | Initializes a new instance of the RolePrivilege class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by id/name of the role privilege.
Public property | CreatedOn | Gets or sets created date of the role privilege.
Public property | DataScopeId | Gets or sets data scope id of the role privilege.
Public property | DataScopeName | Gets or sets data scope name of the role privilege.
Public property | DynamicDatascopeValues | Gets or sets the dynamic datascope value.
Public property | Id | Gets or sets id of the role privilege.
Public property | PrivilegeId | Gets or sets privilege id of the role privilege.
Public property | PrivilegeName | Gets or sets privilege name of the role privilege.
Public property | RoleId | Gets or sets role id of the role privilege.
Public property | Status | Gets or sets status of the role privilege.
Public property | TenantId | Gets or sets tenant id of the role privilege.
Public property | UpdaetdBy | Gets or sets last updated by id/name of the role privilege.
Public property | UpdatedOn | Gets or sets last updated date of the role privilege.

See Also

RolePrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege Constructor

[image]

A Sandcastle Documented Class Library
RolePrivilege Constructor
RolePrivilege Class See Also Send Feedback
Initializes a new instance of the RolePrivilege class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RolePrivilege()
Visual Basic
Public Sub New
Visual C++
public:
RolePrivilege()

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege Methods

[image] [image]

A Sandcastle Documented Class Library
RolePrivilege Methods
RolePrivilege Class See Also Send Feedback

The RolePrivilege type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RolePrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege Properties

[image] [image]

A Sandcastle Documented Class Library
RolePrivilege Properties
RolePrivilege Class See Also Send Feedback

The RolePrivilege type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by id/name of the role privilege.
Public property | CreatedOn | Gets or sets created date of the role privilege.
Public property | DataScopeId | Gets or sets data scope id of the role privilege.
Public property | DataScopeName | Gets or sets data scope name of the role privilege.
Public property | DynamicDatascopeValues | Gets or sets the dynamic datascope value.
Public property | Id | Gets or sets id of the role privilege.
Public property | PrivilegeId | Gets or sets privilege id of the role privilege.
Public property | PrivilegeName | Gets or sets privilege name of the role privilege.
Public property | RoleId | Gets or sets role id of the role privilege.
Public property | Status | Gets or sets status of the role privilege.
Public property | TenantId | Gets or sets tenant id of the role privilege.
Public property | UpdaetdBy | Gets or sets last updated by id/name of the role privilege.
Public property | UpdatedOn | Gets or sets last updated date of the role privilege.

See Also

RolePrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.CreatedBy Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..CreatedBy Property
RolePrivilege Class See Also Send Feedback
Gets or sets created by id/name of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.CreatedOn Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..CreatedOn Property
RolePrivilege Class See Also Send Feedback
Gets or sets created date of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.DataScopeId Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..DataScopeId Property
RolePrivilege Class See Also Send Feedback
Gets or sets data scope id of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataScopeId { get; set; }
Visual Basic
Public Property DataScopeId As String
    Get
    Set
Visual C++
public:
property String^ DataScopeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.DataScopeName Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..DataScopeName Property
RolePrivilege Class See Also Send Feedback
Gets or sets data scope name of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataScopeName { get; set; }
Visual Basic
Public Property DataScopeName As String
    Get
    Set
Visual C++
public:
property String^ DataScopeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.DynamicDatascopeValues Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..DynamicDatascopeValues Property
RolePrivilege Class See Also Send Feedback
Gets or sets the dynamic datascope value.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, DynamicDatascopeValue> DynamicDatascopeValues { get; set; }
Visual Basic
Public Property DynamicDatascopeValues As Dictionary(Of String, DynamicDatascopeValue)
    Get
    Set
Visual C++
public:
property Dictionary<String^, DynamicDatascopeValue^>^ DynamicDatascopeValues {
    Dictionary<String^, DynamicDatascopeValue^>^ get ();
    void set (Dictionary<String^, DynamicDatascopeValue^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, DynamicDatascopeValue >)>)>
The dynamic datascope value.

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.Id Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..Id Property
RolePrivilege Class See Also Send Feedback
Gets or sets id of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.PrivilegeId Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..PrivilegeId Property
RolePrivilege Class See Also Send Feedback
Gets or sets privilege id of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrivilegeId { get; set; }
Visual Basic
Public Property PrivilegeId As String
    Get
    Set
Visual C++
public:
property String^ PrivilegeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.PrivilegeName Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..PrivilegeName Property
RolePrivilege Class See Also Send Feedback
Gets or sets privilege name of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrivilegeName { get; set; }
Visual Basic
Public Property PrivilegeName As String
    Get
    Set
Visual C++
public:
property String^ PrivilegeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.RoleId Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..RoleId Property
RolePrivilege Class See Also Send Feedback
Gets or sets role id of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.Status Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..Status Property
RolePrivilege Class See Also Send Feedback
Gets or sets status of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.TenantId Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..TenantId Property
RolePrivilege Class See Also Send Feedback
Gets or sets tenant id of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.UpdaetdBy Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..UpdaetdBy Property
RolePrivilege Class See Also Send Feedback
Gets or sets last updated by id/name of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdaetdBy { get; set; }
Visual Basic
Public Property UpdaetdBy As String
    Get
    Set
Visual C++
public:
property String^ UpdaetdBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


RolePrivilege.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
RolePrivilege..::..UpdatedOn Property
RolePrivilege Class See Also Send Feedback
Gets or sets last updated date of the role privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

RolePrivilege Class
RolePrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope Class

[image]

A Sandcastle Documented Class Library
TenantScope Class
Members See Also Send Feedback
Tenant Scope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantScope
Visual Basic
<SerializableAttribute>
Public Class TenantScope
Visual C++
[SerializableAttribute]
public ref class TenantScope

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..TenantScope

See Also

TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope Members

[image] [image]

A Sandcastle Documented Class Library
TenantScope Members
TenantScope Class Constructors Methods Properties See Also Send Feedback

The TenantScope type exposes the following members.

Constructors

 | Name | Description
Public method | TenantScope | Initializes a new instance of the TenantScope class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TransformTenantScopeCondtion | Transforms the tenant scope condtion.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | FilterQuery | Gets or sets the select query.
Public property | Id | Gets or sets the id.
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets the status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope Constructor

[image]

A Sandcastle Documented Class Library
TenantScope Constructor
TenantScope Class See Also Send Feedback
Initializes a new instance of the TenantScope class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantScope()
Visual Basic
Public Sub New
Visual C++
public:
TenantScope()

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope Methods

[image] [image]

A Sandcastle Documented Class Library
TenantScope Methods
TenantScope Class See Also Send Feedback

The TenantScope type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TransformTenantScopeCondtion | Transforms the tenant scope condtion.

See Also

TenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.TransformTenantScopeCondtion Method

[image]

A Sandcastle Documented Class Library
TenantScope..::..TransformTenantScopeCondtion Method
TenantScope Class See Also Send Feedback
Transforms the tenant scope condtion.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string TransformTenantScopeCondtion(
    string tenantScopeCondition,
    string operationalTenantId
)
Visual Basic
Public Shared Function TransformTenantScopeCondtion (
    tenantScopeCondition As String,
    operationalTenantId As String
) As String
Visual C++
public:
static String^ TransformTenantScopeCondtion(
    String^ tenantScopeCondition,
    String^ operationalTenantId
)

Parameters

tenantScopeCondition
Type: System..::..String
The tenant scope condition.
operationalTenantId
Type: System..::..String
operational tenantId

Return Value

Type: String

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope Properties

[image] [image]

A Sandcastle Documented Class Library
TenantScope Properties
TenantScope Class See Also Send Feedback

The TenantScope type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | FilterQuery | Gets or sets the select query.
Public property | Id | Gets or sets the id.
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets the status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantScope Class
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..CreatedBy Property
TenantScope Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..CreatedOn Property
TenantScope Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.Description Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..Description Property
TenantScope Class See Also Send Feedback
Gets or sets the description.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.FilterQuery Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..FilterQuery Property
TenantScope Class See Also Send Feedback
Gets or sets the select query.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilterQuery { get; set; }
Visual Basic
Public Property FilterQuery As String
    Get
    Set
Visual C++
public:
property String^ FilterQuery {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The select query.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.Id Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..Id Property
TenantScope Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.Name Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..Name Property
TenantScope Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.Status Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..Status Property
TenantScope Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..UpdatedBy Property
TenantScope Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScope.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantScope..::..UpdatedOn Property
TenantScope Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

TenantScope Class
TenantScope Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant Class

[image]

A Sandcastle Documented Class Library
TenantScopeConstant Class
Members See Also Send Feedback
Tenant scope constant class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class TenantScopeConstant
Visual Basic
Public Class TenantScopeConstant
Visual C++
public ref class TenantScopeConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..TenantScopeConstant

See Also

TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant Members

[image] [image]

A Sandcastle Documented Class Library
TenantScopeConstant Members
TenantScopeConstant Class Constructors Methods Fields See Also Send Feedback

The TenantScopeConstant type exposes the following members.

Constructors

 | Name | Description
Public method | TenantScopeConstant | Initializes a new instance of the TenantScopeConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ALL | All constant key
CHILD_TENANT_SCOPE | Child tenant scope constant key
DEFAULT_TENANT_SCOPE | Default tenant scope constant key
IMMEDIATE_CHILD_TENANT_SCOPE | Immediate child tenant scope constant key
SELECTIVE_TENANT_SCOPE | Selective tenant scope constant key

See Also

TenantScopeConstant Class
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant Constructor

[image]

A Sandcastle Documented Class Library
TenantScopeConstant Constructor
TenantScopeConstant Class See Also Send Feedback
Initializes a new instance of the TenantScopeConstant class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantScopeConstant()
Visual Basic
Public Sub New
Visual C++
public:
TenantScopeConstant()

See Also

TenantScopeConstant Class
TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant Fields

[image] [image]

A Sandcastle Documented Class Library
TenantScopeConstant Fields
TenantScopeConstant Class See Also Send Feedback

The TenantScopeConstant type exposes the following members.

Fields

Name | Description
ALL | All constant key
CHILD_TENANT_SCOPE | Child tenant scope constant key
DEFAULT_TENANT_SCOPE | Default tenant scope constant key
IMMEDIATE_CHILD_TENANT_SCOPE | Immediate child tenant scope constant key
SELECTIVE_TENANT_SCOPE | Selective tenant scope constant key

See Also

TenantScopeConstant Class
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant.ALL Field

[image]

A Sandcastle Documented Class Library
TenantScopeConstant..::..ALL Field
TenantScopeConstant Class See Also Send Feedback
All constant key

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ALL
Visual Basic
Public Const ALL As String
Visual C++
public:
literal String^ ALL

Field Value

Type: String

See Also

TenantScopeConstant Class
TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant.CHILD_TENANT_SCOPE Field

[image]

A Sandcastle Documented Class Library
TenantScopeConstant..::..CHILD_TENANT_SCOPE Field
TenantScopeConstant Class See Also Send Feedback
Child tenant scope constant key

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CHILD_TENANT_SCOPE
Visual Basic
Public Const CHILD_TENANT_SCOPE As String
Visual C++
public:
literal String^ CHILD_TENANT_SCOPE

Field Value

Type: String

See Also

TenantScopeConstant Class
TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant.DEFAULT_TENANT_SCOPE Field

[image]

A Sandcastle Documented Class Library
TenantScopeConstant..::..DEFAULT_TENANT_SCOPE Field
TenantScopeConstant Class See Also Send Feedback
Default tenant scope constant key

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DEFAULT_TENANT_SCOPE
Visual Basic
Public Const DEFAULT_TENANT_SCOPE As String
Visual C++
public:
literal String^ DEFAULT_TENANT_SCOPE

Field Value

Type: String

See Also

TenantScopeConstant Class
TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant.IMMEDIATE_CHILD_TENANT_SCOPE Field

[image]

A Sandcastle Documented Class Library
TenantScopeConstant..::..IMMEDIATE_CHILD_TENANT_SCOPE Field
TenantScopeConstant Class See Also Send Feedback
Immediate child tenant scope constant key

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string IMMEDIATE_CHILD_TENANT_SCOPE
Visual Basic
Public Const IMMEDIATE_CHILD_TENANT_SCOPE As String
Visual C++
public:
literal String^ IMMEDIATE_CHILD_TENANT_SCOPE

Field Value

Type: String

See Also

TenantScopeConstant Class
TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant.SELECTIVE_TENANT_SCOPE Field

[image]

A Sandcastle Documented Class Library
TenantScopeConstant..::..SELECTIVE_TENANT_SCOPE Field
TenantScopeConstant Class See Also Send Feedback
Selective tenant scope constant key

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SELECTIVE_TENANT_SCOPE
Visual Basic
Public Const SELECTIVE_TENANT_SCOPE As String
Visual C++
public:
literal String^ SELECTIVE_TENANT_SCOPE

Field Value

Type: String

See Also

TenantScopeConstant Class
TenantScopeConstant Members
CelloSaaS.Model.AccessControlManagement Namespace


TenantScopeConstant Methods

[image] [image]

A Sandcastle Documented Class Library
TenantScopeConstant Methods
TenantScopeConstant Class See Also Send Feedback

The TenantScopeConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantScopeConstant Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege Class

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege Class
Members See Also Send Feedback
User entity other privilege class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserEntityOtherPrivilege
Visual Basic
<SerializableAttribute>
Public Class UserEntityOtherPrivilege
Visual C++
[SerializableAttribute]
public ref class UserEntityOtherPrivilege

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..UserEntityOtherPrivilege

See Also

UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege Members

[image] [image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege Members
UserEntityOtherPrivilege Class Constructors Methods Properties See Also Send Feedback

The UserEntityOtherPrivilege type exposes the following members.

Constructors

 | Name | Description
Public method | UserEntityOtherPrivilege | Initializes a new instance of the UserEntityOtherPrivilege class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the CreatedBy.
Public property | CreatedOn | Gets or sets the CreatedOn.
Public property | OtherPermissionId | Gets or sets the other permission id.
Public property | Privilege | Gets or sets the privilege.
Public property | Status | Gets or sets the Status.
Public property | UpdatedBy | Gets or sets the UpdatedBy.
Public property | UpdatedOn | Gets or sets the UpdatedOn.
Public property | UserEntityPermissionId | Gets or sets the user entity permission id.

See Also

UserEntityOtherPrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege Constructor

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege Constructor
UserEntityOtherPrivilege Class See Also Send Feedback
Initializes a new instance of the UserEntityOtherPrivilege class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserEntityOtherPrivilege()
Visual Basic
Public Sub New
Visual C++
public:
UserEntityOtherPrivilege()

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege Methods

[image] [image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege Methods
UserEntityOtherPrivilege Class See Also Send Feedback

The UserEntityOtherPrivilege type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserEntityOtherPrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege Properties

[image] [image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege Properties
UserEntityOtherPrivilege Class See Also Send Feedback

The UserEntityOtherPrivilege type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the CreatedBy.
Public property | CreatedOn | Gets or sets the CreatedOn.
Public property | OtherPermissionId | Gets or sets the other permission id.
Public property | Privilege | Gets or sets the privilege.
Public property | Status | Gets or sets the Status.
Public property | UpdatedBy | Gets or sets the UpdatedBy.
Public property | UpdatedOn | Gets or sets the UpdatedOn.
Public property | UserEntityPermissionId | Gets or sets the user entity permission id.

See Also

UserEntityOtherPrivilege Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.CreatedBy Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..CreatedBy Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the CreatedBy.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The CreatedBy.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.CreatedOn Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..CreatedOn Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the CreatedOn.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The CreatedOn.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.OtherPermissionId Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..OtherPermissionId Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the other permission id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string OtherPermissionId { get; set; }
Visual Basic
Public Property OtherPermissionId As String
    Get
    Set
Visual C++
public:
property String^ OtherPermissionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The other permission id.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.Privilege Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..Privilege Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the privilege.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Privilege { get; set; }
Visual Basic
Public Property Privilege As String
    Get
    Set
Visual C++
public:
property String^ Privilege {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The privilege.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.Status Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..Status Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the Status.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The Status.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..UpdatedBy Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the UpdatedBy.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The UpdatedBy.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..UpdatedOn Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the UpdatedOn.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The UpdatedOn.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityOtherPrivilege.UserEntityPermissionId Property

[image]

A Sandcastle Documented Class Library
UserEntityOtherPrivilege..::..UserEntityPermissionId Property
UserEntityOtherPrivilege Class See Also Send Feedback
Gets or sets the user entity permission id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserEntityPermissionId { get; set; }
Visual Basic
Public Property UserEntityPermissionId As String
    Get
    Set
Visual C++
public:
property String^ UserEntityPermissionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user entity permission id.

See Also

UserEntityOtherPrivilege Class
UserEntityOtherPrivilege Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission Class

[image]

A Sandcastle Documented Class Library
UserEntityPermission Class
Members See Also Send Feedback
UserEntityPermission

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserEntityPermission
Visual Basic
<SerializableAttribute>
Public Class UserEntityPermission
Visual C++
[SerializableAttribute]
public ref class UserEntityPermission

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.AccessControlManagement..::..UserEntityPermission

See Also

UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission Members

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermission Members
UserEntityPermission Class Constructors Methods Properties See Also Send Feedback

The UserEntityPermission type exposes the following members.

Constructors

 | Name | Description
Public method | UserEntityPermission | Initializes a new instance of the UserEntityPermission class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddPermission | Gets or sets the Add.
Public property | CreatedBy | Gets or sets the CreatedBy.
Public property | CreatedOn | Gets or sets the CreatedOn.
Public property | DeletePermission | Gets or sets the Delete.
Public property | EditPermission | Gets or sets the Edit.
Public property | EntityId | Gets or sets the EntityId.
Public property | FieldIdentifier | Gets or sets the FieldIdentifier.
Public property | Id | Gets or sets the Id.
Public property | ReferenceId | Gets or sets the RefernceId.
Public property | ReferenceName | Gets or sets the ReferenceName.
Public property | RoleId | Gets or sets the role id.
Public property | RoleIds | Gets or sets the role ids.
Public property | Status | Gets or sets the Status.
Public property | TenantId | Gets or sets the TenantId.
Public property | UpdatedBy | Gets or sets the UpdatedBy.
Public property | UpdatedOn | Gets or sets the UpdatedOn.
Public property | UserEntityOtherPrivileges | Gets or sets the User Entity Other Permissions.
Public property | UserId | Gets or sets the UserId.
Public property | ViewPermission | Gets or sets the View.

See Also

UserEntityPermission Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission Constructor

[image]

A Sandcastle Documented Class Library
UserEntityPermission Constructor
UserEntityPermission Class See Also Send Feedback
Initializes a new instance of the UserEntityPermission class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserEntityPermission()
Visual Basic
Public Sub New
Visual C++
public:
UserEntityPermission()

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission Methods

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermission Methods
UserEntityPermission Class See Also Send Feedback

The UserEntityPermission type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserEntityPermission Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission Properties

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermission Properties
UserEntityPermission Class See Also Send Feedback

The UserEntityPermission type exposes the following members.

Properties

 | Name | Description
Public property | AddPermission | Gets or sets the Add.
Public property | CreatedBy | Gets or sets the CreatedBy.
Public property | CreatedOn | Gets or sets the CreatedOn.
Public property | DeletePermission | Gets or sets the Delete.
Public property | EditPermission | Gets or sets the Edit.
Public property | EntityId | Gets or sets the EntityId.
Public property | FieldIdentifier | Gets or sets the FieldIdentifier.
Public property | Id | Gets or sets the Id.
Public property | ReferenceId | Gets or sets the RefernceId.
Public property | ReferenceName | Gets or sets the ReferenceName.
Public property | RoleId | Gets or sets the role id.
Public property | RoleIds | Gets or sets the role ids.
Public property | Status | Gets or sets the Status.
Public property | TenantId | Gets or sets the TenantId.
Public property | UpdatedBy | Gets or sets the UpdatedBy.
Public property | UpdatedOn | Gets or sets the UpdatedOn.
Public property | UserEntityOtherPrivileges | Gets or sets the User Entity Other Permissions.
Public property | UserId | Gets or sets the UserId.
Public property | ViewPermission | Gets or sets the View.

See Also

UserEntityPermission Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.AddPermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..AddPermission Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the Add.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> AddPermission { get; set; }
Visual Basic
Public Property AddPermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> AddPermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The Add.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.CreatedBy Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..CreatedBy Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the CreatedBy.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The CreatedBy.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.CreatedOn Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..CreatedOn Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the CreatedOn.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The CreatedOn.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.DeletePermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..DeletePermission Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the Delete.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> DeletePermission { get; set; }
Visual Basic
Public Property DeletePermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> DeletePermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The Delete.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.EditPermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..EditPermission Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the Edit.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> EditPermission { get; set; }
Visual Basic
Public Property EditPermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> EditPermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The Edit.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.EntityId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..EntityId Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the EntityId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The EntityId.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.FieldIdentifier Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..FieldIdentifier Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the FieldIdentifier.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldIdentifier { get; set; }
Visual Basic
Public Property FieldIdentifier As String
    Get
    Set
Visual C++
public:
property String^ FieldIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The FieldIdentifier.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.Id Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..Id Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the Id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Id.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.ReferenceId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..ReferenceId Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the RefernceId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceId { get; set; }
Visual Basic
Public Property ReferenceId As String
    Get
    Set
Visual C++
public:
property String^ ReferenceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The RefernceId.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.ReferenceName Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..ReferenceName Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the ReferenceName.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceName { get; set; }
Visual Basic
Public Property ReferenceName As String
    Get
    Set
Visual C++
public:
property String^ ReferenceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The ReferenceName.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.RoleId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..RoleId Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the role id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The role id.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.RoleIds Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..RoleIds Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the role ids.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> RoleIds { get; set; }
Visual Basic
Public Property RoleIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ RoleIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The role ids.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.Status Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..Status Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the Status.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The Status.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.TenantId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..TenantId Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the TenantId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The TenantId.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..UpdatedBy Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the UpdatedBy.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The UpdatedBy.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..UpdatedOn Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the UpdatedOn.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The UpdatedOn.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.UserEntityOtherPrivileges Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..UserEntityOtherPrivileges Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the User Entity Other Permissions.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<UserEntityOtherPrivilege> UserEntityOtherPrivileges { get; set; }
Visual Basic
Public Property UserEntityOtherPrivileges As List(Of UserEntityOtherPrivilege)
    Get
    Set
Visual C++
public:
property List<UserEntityOtherPrivilege^>^ UserEntityOtherPrivileges {
    List<UserEntityOtherPrivilege^>^ get ();
    void set (List<UserEntityOtherPrivilege^>^ value);
}

Property Value

Type: List<(Of <(<' UserEntityOtherPrivilege >)>)>
The UserEntityOtherPermissions.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.UserId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..UserId Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the UserId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The UserId.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermission.ViewPermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermission..::..ViewPermission Property
UserEntityPermission Class See Also Send Feedback
Gets or sets the View.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> ViewPermission { get; set; }
Visual Basic
Public Property ViewPermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> ViewPermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The View.

See Also

UserEntityPermission Class
UserEntityPermission Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition Class

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition Class
Members See Also Send Feedback
UserEntityPermission Search Condition Class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserEntityPermissionSearchCondition : SearchCondition
Visual Basic
<SerializableAttribute>
Public Class UserEntityPermissionSearchCondition
    Inherits SearchCondition
Visual C++
[SerializableAttribute]
public ref class UserEntityPermissionSearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.AccessControlManagement..::..UserEntityPermissionSearchCondition

See Also

UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition Members
UserEntityPermissionSearchCondition Class Constructors Methods Properties See Also Send Feedback

The UserEntityPermissionSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | UserEntityPermissionSearchCondition | Initializes a new instance of the UserEntityPermissionSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddPermission | Gets or sets the Add.
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | CreatedBy | Gets or sets the CreatedBy.
Public property | CreatedOn | Gets or sets the CreatedOn.
Public property | DeletePermission | Gets or sets the Delete.
Public property | EditPermission | Gets or sets the Edit.
Public property | EntityId | Gets or sets the EntityId.
Public property | FieldIdentifier | Gets or sets the FieldIdentifier.
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | ReferenceId | Gets or sets the RefernceId.
Public property | ReferenceName | Gets or sets the ReferenceName.
Public property | RoleId | Gets or sets the role id.
Public property | RoleIds | Gets or sets the role ids.
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | Status | Gets or sets the Status.
Public property | TenantId | Gets or sets the TenantId.
Public property | UpdatedBy | Gets or sets the UpdatedBy.
Public property | UpdatedOn | Gets or sets the UpdatedOn.
Public property | UserEntityOtherPermissions | Gets or sets the user entity other permissions.
Public property | UserId | Gets or sets the UserId.
Public property | ViewPermission | Gets or sets the View.

See Also

UserEntityPermissionSearchCondition Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition Constructor
UserEntityPermissionSearchCondition Class See Also Send Feedback
Initializes a new instance of the UserEntityPermissionSearchCondition class

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserEntityPermissionSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
UserEntityPermissionSearchCondition()

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition Methods
UserEntityPermissionSearchCondition Class See Also Send Feedback

The UserEntityPermissionSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserEntityPermissionSearchCondition Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition Properties
UserEntityPermissionSearchCondition Class See Also Send Feedback

The UserEntityPermissionSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | AddPermission | Gets or sets the Add.
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | CreatedBy | Gets or sets the CreatedBy.
Public property | CreatedOn | Gets or sets the CreatedOn.
Public property | DeletePermission | Gets or sets the Delete.
Public property | EditPermission | Gets or sets the Edit.
Public property | EntityId | Gets or sets the EntityId.
Public property | FieldIdentifier | Gets or sets the FieldIdentifier.
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | ReferenceId | Gets or sets the RefernceId.
Public property | ReferenceName | Gets or sets the ReferenceName.
Public property | RoleId | Gets or sets the role id.
Public property | RoleIds | Gets or sets the role ids.
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | Status | Gets or sets the Status.
Public property | TenantId | Gets or sets the TenantId.
Public property | UpdatedBy | Gets or sets the UpdatedBy.
Public property | UpdatedOn | Gets or sets the UpdatedOn.
Public property | UserEntityOtherPermissions | Gets or sets the user entity other permissions.
Public property | UserId | Gets or sets the UserId.
Public property | ViewPermission | Gets or sets the View.

See Also

UserEntityPermissionSearchCondition Class
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.AddPermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..AddPermission Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the Add.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> AddPermission { get; set; }
Visual Basic
Public Property AddPermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> AddPermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The Add.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.CreatedBy Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..CreatedBy Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the CreatedBy.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The CreatedBy.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.CreatedOn Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..CreatedOn Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the CreatedOn.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The CreatedOn.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.DeletePermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..DeletePermission Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the Delete.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> DeletePermission { get; set; }
Visual Basic
Public Property DeletePermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> DeletePermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The Delete.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.EditPermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..EditPermission Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the Edit.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> EditPermission { get; set; }
Visual Basic
Public Property EditPermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> EditPermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The Edit.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.EntityId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..EntityId Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the EntityId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The EntityId.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.FieldIdentifier Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..FieldIdentifier Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the FieldIdentifier.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldIdentifier { get; set; }
Visual Basic
Public Property FieldIdentifier As String
    Get
    Set
Visual C++
public:
property String^ FieldIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The FieldIdentifier.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.ReferenceId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..ReferenceId Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the RefernceId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceId { get; set; }
Visual Basic
Public Property ReferenceId As String
    Get
    Set
Visual C++
public:
property String^ ReferenceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The RefernceId.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.ReferenceName Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..ReferenceName Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the ReferenceName.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceName { get; set; }
Visual Basic
Public Property ReferenceName As String
    Get
    Set
Visual C++
public:
property String^ ReferenceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The ReferenceName.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.RoleId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..RoleId Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the role id.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The role id.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.RoleIds Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..RoleIds Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the role ids.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> RoleIds { get; set; }
Visual Basic
Public Property RoleIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ RoleIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The role ids.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.Status Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..Status Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the Status.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The Status.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..TenantId Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the TenantId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The TenantId.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..UpdatedBy Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the UpdatedBy.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The UpdatedBy.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..UpdatedOn Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the UpdatedOn.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The UpdatedOn.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.UserEntityOtherPermissions Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..UserEntityOtherPermissions Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the user entity other permissions.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<UserEntityOtherPrivilege> UserEntityOtherPermissions { get; set; }
Visual Basic
Public Property UserEntityOtherPermissions As List(Of UserEntityOtherPrivilege)
    Get
    Set
Visual C++
public:
property List<UserEntityOtherPrivilege^>^ UserEntityOtherPermissions {
    List<UserEntityOtherPrivilege^>^ get ();
    void set (List<UserEntityOtherPrivilege^>^ value);
}

Property Value

Type: List<(Of <(<' UserEntityOtherPrivilege >)>)>
The user entity other permissions.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.UserId Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..UserId Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the UserId.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The UserId.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


UserEntityPermissionSearchCondition.ViewPermission Property

[image]

A Sandcastle Documented Class Library
UserEntityPermissionSearchCondition..::..ViewPermission Property
UserEntityPermissionSearchCondition Class See Also Send Feedback
Gets or sets the View.

Namespace: CelloSaaS.Model.AccessControlManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> ViewPermission { get; set; }
Visual Basic
Public Property ViewPermission As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> ViewPermission {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The View.

See Also

UserEntityPermissionSearchCondition Class
UserEntityPermissionSearchCondition Members
CelloSaaS.Model.AccessControlManagement Namespace


CelloSaaS.Model.Configuration Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.Configuration Namespace
Send Feedback

Classes

 | Class | Description
Public class | ConfigurationSettingValueConstant | Configuration Setting Value Constants
Public class | ModuleConfiguration | Module Configuration Model
Public class | ModuleConfigurationConstant | Module Configuration Constants
Public class | PickupList | Pick up list properties
Public class | PickupListFilter | Pickup List Filter properties
Public class | PickupListValue | Pick up list values properties
Public class | PickupListValueMapping | Pickup List Value Mapping Properties
Public class | RelationshipMetaData | Pickup List Relationship Meta Data Properties

Enumerations

 | Enumeration | Description
Public enumeration | Relation | Pickup list Relation type


ConfigurationSettingValueConstant Class

[image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant Class
Members See Also Send Feedback
Configuration Setting Value Constants

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ConfigurationSettingValueConstant
Visual Basic
Public Class ConfigurationSettingValueConstant
Visual C++
public ref class ConfigurationSettingValueConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..ConfigurationSettingValueConstant

See Also

ConfigurationSettingValueConstant Members
CelloSaaS.Model.Configuration Namespace


ConfigurationSettingValueConstant Members

[image] [image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant Members
ConfigurationSettingValueConstant Class Constructors Methods Fields See Also Send Feedback

The ConfigurationSettingValueConstant type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationSettingValueConstant | Initializes a new instance of the ConfigurationSettingValueConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
LOOKUP_PARENT_SETTING | Look up parent setting constant key
OWN_SETTING | Own setting constant key

See Also

ConfigurationSettingValueConstant Class
CelloSaaS.Model.Configuration Namespace


ConfigurationSettingValueConstant Constructor

[image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant Constructor
ConfigurationSettingValueConstant Class See Also Send Feedback
Initializes a new instance of the ConfigurationSettingValueConstant class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ConfigurationSettingValueConstant()
Visual Basic
Public Sub New
Visual C++
public:
ConfigurationSettingValueConstant()

See Also

ConfigurationSettingValueConstant Class
ConfigurationSettingValueConstant Members
CelloSaaS.Model.Configuration Namespace


ConfigurationSettingValueConstant Fields

[image] [image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant Fields
ConfigurationSettingValueConstant Class See Also Send Feedback

The ConfigurationSettingValueConstant type exposes the following members.

Fields

Name | Description
LOOKUP_PARENT_SETTING | Look up parent setting constant key
OWN_SETTING | Own setting constant key

See Also

ConfigurationSettingValueConstant Class
CelloSaaS.Model.Configuration Namespace


ConfigurationSettingValueConstant.LOOKUP_PARENT_SETTING Field

[image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant..::..LOOKUP_PARENT_SETTING Field
ConfigurationSettingValueConstant Class See Also Send Feedback
Look up parent setting constant key

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LOOKUP_PARENT_SETTING
Visual Basic
Public Const LOOKUP_PARENT_SETTING As String
Visual C++
public:
literal String^ LOOKUP_PARENT_SETTING

Field Value

Type: String

See Also

ConfigurationSettingValueConstant Class
ConfigurationSettingValueConstant Members
CelloSaaS.Model.Configuration Namespace


ConfigurationSettingValueConstant.OWN_SETTING Field

[image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant..::..OWN_SETTING Field
ConfigurationSettingValueConstant Class See Also Send Feedback
Own setting constant key

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string OWN_SETTING
Visual Basic
Public Const OWN_SETTING As String
Visual C++
public:
literal String^ OWN_SETTING

Field Value

Type: String

See Also

ConfigurationSettingValueConstant Class
ConfigurationSettingValueConstant Members
CelloSaaS.Model.Configuration Namespace


ConfigurationSettingValueConstant Methods

[image] [image]

A Sandcastle Documented Class Library
ConfigurationSettingValueConstant Methods
ConfigurationSettingValueConstant Class See Also Send Feedback

The ConfigurationSettingValueConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConfigurationSettingValueConstant Class
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration Class

[image]

A Sandcastle Documented Class Library
ModuleConfiguration Class
Members See Also Send Feedback
Module Configuration Model

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ModuleConfiguration
Visual Basic
<SerializableAttribute>
Public Class ModuleConfiguration
Visual C++
[SerializableAttribute]
public ref class ModuleConfiguration

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..ModuleConfiguration

See Also

ModuleConfiguration Members
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration Members

[image] [image]

A Sandcastle Documented Class Library
ModuleConfiguration Members
ModuleConfiguration Class Constructors Methods Properties See Also Send Feedback

The ModuleConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleConfiguration | Initializes a new instance of the ModuleConfiguration class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | This used to get or set the description of the ModuleConfiguration
Public property | Id | This used to get or set the id of ModuleConfiguration
Public property | Name | This used to get or set the name of ModuleConfiguration

See Also

ModuleConfiguration Class
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration Constructor

[image]

A Sandcastle Documented Class Library
ModuleConfiguration Constructor
ModuleConfiguration Class See Also Send Feedback
Initializes a new instance of the ModuleConfiguration class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleConfiguration()
Visual Basic
Public Sub New
Visual C++
public:
ModuleConfiguration()

See Also

ModuleConfiguration Class
ModuleConfiguration Members
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration Methods

[image] [image]

A Sandcastle Documented Class Library
ModuleConfiguration Methods
ModuleConfiguration Class See Also Send Feedback

The ModuleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModuleConfiguration Class
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration Properties

[image] [image]

A Sandcastle Documented Class Library
ModuleConfiguration Properties
ModuleConfiguration Class See Also Send Feedback

The ModuleConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Description | This used to get or set the description of the ModuleConfiguration
Public property | Id | This used to get or set the id of ModuleConfiguration
Public property | Name | This used to get or set the name of ModuleConfiguration

See Also

ModuleConfiguration Class
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration.Description Property

[image]

A Sandcastle Documented Class Library
ModuleConfiguration..::..Description Property
ModuleConfiguration Class See Also Send Feedback
This used to get or set the description of the ModuleConfiguration

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

ModuleConfiguration Class
ModuleConfiguration Members
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration.Id Property

[image]

A Sandcastle Documented Class Library
ModuleConfiguration..::..Id Property
ModuleConfiguration Class See Also Send Feedback
This used to get or set the id of ModuleConfiguration

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

ModuleConfiguration Class
ModuleConfiguration Members
CelloSaaS.Model.Configuration Namespace


ModuleConfiguration.Name Property

[image]

A Sandcastle Documented Class Library
ModuleConfiguration..::..Name Property
ModuleConfiguration Class See Also Send Feedback
This used to get or set the name of ModuleConfiguration

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

ModuleConfiguration Class
ModuleConfiguration Members
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant Class

[image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant Class
Members See Also Send Feedback
Module Configuration Constants

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ModuleConfigurationConstant
Visual Basic
Public Class ModuleConfigurationConstant
Visual C++
public ref class ModuleConfigurationConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..ModuleConfigurationConstant

See Also

ModuleConfigurationConstant Members
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant Members

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant Members
ModuleConfigurationConstant Class Constructors Methods Fields See Also Send Feedback

The ModuleConfigurationConstant type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleConfigurationConstant | Initializes a new instance of the ModuleConfigurationConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
BUSINESSRULE | ModuleConfigurationConstant for BUSINESS RULES
EXTENDED_FIELD | ModuleConfigurationConstant for EXTENDED_FIELD
WORKFLOW | ModuleConfigurationConstant for WORKFLOW

See Also

ModuleConfigurationConstant Class
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant Constructor

[image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant Constructor
ModuleConfigurationConstant Class See Also Send Feedback
Initializes a new instance of the ModuleConfigurationConstant class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleConfigurationConstant()
Visual Basic
Public Sub New
Visual C++
public:
ModuleConfigurationConstant()

See Also

ModuleConfigurationConstant Class
ModuleConfigurationConstant Members
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant Fields

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant Fields
ModuleConfigurationConstant Class See Also Send Feedback

The ModuleConfigurationConstant type exposes the following members.

Fields

Name | Description
BUSINESSRULE | ModuleConfigurationConstant for BUSINESS RULES
EXTENDED_FIELD | ModuleConfigurationConstant for EXTENDED_FIELD
WORKFLOW | ModuleConfigurationConstant for WORKFLOW

See Also

ModuleConfigurationConstant Class
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant.BUSINESSRULE Field

[image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant..::..BUSINESSRULE Field
ModuleConfigurationConstant Class See Also Send Feedback
ModuleConfigurationConstant for BUSINESS RULES

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BUSINESSRULE
Visual Basic
Public Const BUSINESSRULE As String
Visual C++
public:
literal String^ BUSINESSRULE

Field Value

Type: String

See Also

ModuleConfigurationConstant Class
ModuleConfigurationConstant Members
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant.EXTENDED_FIELD Field

[image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant..::..EXTENDED_FIELD Field
ModuleConfigurationConstant Class See Also Send Feedback
ModuleConfigurationConstant for EXTENDED_FIELD

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EXTENDED_FIELD
Visual Basic
Public Const EXTENDED_FIELD As String
Visual C++
public:
literal String^ EXTENDED_FIELD

Field Value

Type: String

See Also

ModuleConfigurationConstant Class
ModuleConfigurationConstant Members
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant.WORKFLOW Field

[image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant..::..WORKFLOW Field
ModuleConfigurationConstant Class See Also Send Feedback
ModuleConfigurationConstant for WORKFLOW

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WORKFLOW
Visual Basic
Public Const WORKFLOW As String
Visual C++
public:
literal String^ WORKFLOW

Field Value

Type: String

See Also

ModuleConfigurationConstant Class
ModuleConfigurationConstant Members
CelloSaaS.Model.Configuration Namespace


ModuleConfigurationConstant Methods

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationConstant Methods
ModuleConfigurationConstant Class See Also Send Feedback

The ModuleConfigurationConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModuleConfigurationConstant Class
CelloSaaS.Model.Configuration Namespace


PickupList Class

[image]

A Sandcastle Documented Class Library
PickupList Class
Members See Also Send Feedback
Pick up list properties

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupList
Visual Basic
<SerializableAttribute>
Public Class PickupList
Visual C++
[SerializableAttribute]
public ref class PickupList

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..PickupList

See Also

PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList Members

[image] [image]

A Sandcastle Documented Class Library
PickupList Members
PickupList Class Constructors Methods Properties See Also Send Feedback

The PickupList type exposes the following members.

Constructors

 | Name | Description
Public method | PickupList | Initializes a new instance of the PickupList class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name of the pickup list.
Public property | CreatedOn | This used to get or set created date of the pickup list.
Public property | Id | This used to get or set id of the pickup list.
Public property | Name | This used to get or set name of the pickup list.
Public property | Status | This used to get or set status of the pickup list.
Public property | TableName | This used to get or set table name of the pickup list.
Public property | TenantCode | This used to get or set tenant code of the pickup list.
Public property | UpdatedBy | This used to get or set last updated by id/name of the pickup list.
Public property | UpdatedOn | This used to get or set last updated date of the pickup list.

See Also

PickupList Class
CelloSaaS.Model.Configuration Namespace


PickupList Constructor

[image]

A Sandcastle Documented Class Library
PickupList Constructor
PickupList Class See Also Send Feedback
Initializes a new instance of the PickupList class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupList()
Visual Basic
Public Sub New
Visual C++
public:
PickupList()

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList Methods

[image] [image]

A Sandcastle Documented Class Library
PickupList Methods
PickupList Class See Also Send Feedback

The PickupList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PickupList Class
CelloSaaS.Model.Configuration Namespace


PickupList Properties

[image] [image]

A Sandcastle Documented Class Library
PickupList Properties
PickupList Class See Also Send Feedback

The PickupList type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name of the pickup list.
Public property | CreatedOn | This used to get or set created date of the pickup list.
Public property | Id | This used to get or set id of the pickup list.
Public property | Name | This used to get or set name of the pickup list.
Public property | Status | This used to get or set status of the pickup list.
Public property | TableName | This used to get or set table name of the pickup list.
Public property | TenantCode | This used to get or set tenant code of the pickup list.
Public property | UpdatedBy | This used to get or set last updated by id/name of the pickup list.
Public property | UpdatedOn | This used to get or set last updated date of the pickup list.

See Also

PickupList Class
CelloSaaS.Model.Configuration Namespace


PickupList.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PickupList..::..CreatedBy Property
PickupList Class See Also Send Feedback
This used to get or set created by id/name of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PickupList..::..CreatedOn Property
PickupList Class See Also Send Feedback
This used to get or set created date of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.Id Property

[image]

A Sandcastle Documented Class Library
PickupList..::..Id Property
PickupList Class See Also Send Feedback
This used to get or set id of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.Name Property

[image]

A Sandcastle Documented Class Library
PickupList..::..Name Property
PickupList Class See Also Send Feedback
This used to get or set name of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.Status Property

[image]

A Sandcastle Documented Class Library
PickupList..::..Status Property
PickupList Class See Also Send Feedback
This used to get or set status of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.TableName Property

[image]

A Sandcastle Documented Class Library
PickupList..::..TableName Property
PickupList Class See Also Send Feedback
This used to get or set table name of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TableName { get; set; }
Visual Basic
Public Property TableName As String
    Get
    Set
Visual C++
public:
property String^ TableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.TenantCode Property

[image]

A Sandcastle Documented Class Library
PickupList..::..TenantCode Property
PickupList Class See Also Send Feedback
This used to get or set tenant code of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantCode { get; set; }
Visual Basic
Public Property TenantCode As String
    Get
    Set
Visual C++
public:
property String^ TenantCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PickupList..::..UpdatedBy Property
PickupList Class See Also Send Feedback
This used to get or set last updated by id/name of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupList.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PickupList..::..UpdatedOn Property
PickupList Class See Also Send Feedback
This used to get or set last updated date of the pickup list.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PickupList Class
PickupList Members
CelloSaaS.Model.Configuration Namespace


PickupListFilter Class

[image]

A Sandcastle Documented Class Library
PickupListFilter Class
Members See Also Send Feedback
Pickup List Filter properties

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListFilter
Visual Basic
<SerializableAttribute>
Public Class PickupListFilter
Visual C++
[SerializableAttribute]
public ref class PickupListFilter

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..PickupListFilter

See Also

PickupListFilter Members
CelloSaaS.Model.Configuration Namespace


PickupListFilter Members

[image] [image]

A Sandcastle Documented Class Library
PickupListFilter Members
PickupListFilter Class Constructors Methods Properties See Also Send Feedback

The PickupListFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListFilter | Initializes a new instance of the PickupListFilter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PickupListId | This used to get or set Pickup List Id
Public property | PickupListValueId | This used to get or set Pickup List Value Id

See Also

PickupListFilter Class
CelloSaaS.Model.Configuration Namespace


PickupListFilter Constructor

[image]

A Sandcastle Documented Class Library
PickupListFilter Constructor
PickupListFilter Class See Also Send Feedback
Initializes a new instance of the PickupListFilter class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListFilter()
Visual Basic
Public Sub New
Visual C++
public:
PickupListFilter()

See Also

PickupListFilter Class
PickupListFilter Members
CelloSaaS.Model.Configuration Namespace


PickupListFilter Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListFilter Methods
PickupListFilter Class See Also Send Feedback

The PickupListFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PickupListFilter Class
CelloSaaS.Model.Configuration Namespace


PickupListFilter Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListFilter Properties
PickupListFilter Class See Also Send Feedback

The PickupListFilter type exposes the following members.

Properties

 | Name | Description
Public property | PickupListId | This used to get or set Pickup List Id
Public property | PickupListValueId | This used to get or set Pickup List Value Id

See Also

PickupListFilter Class
CelloSaaS.Model.Configuration Namespace


PickupListFilter.PickupListId Property

[image]

A Sandcastle Documented Class Library
PickupListFilter..::..PickupListId Property
PickupListFilter Class See Also Send Feedback
This used to get or set Pickup List Id

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PickupListId { get; set; }
Visual Basic
Public Property PickupListId As String
    Get
    Set
Visual C++
public:
property String^ PickupListId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListFilter Class
PickupListFilter Members
CelloSaaS.Model.Configuration Namespace


PickupListFilter.PickupListValueId Property

[image]

A Sandcastle Documented Class Library
PickupListFilter..::..PickupListValueId Property
PickupListFilter Class See Also Send Feedback
This used to get or set Pickup List Value Id

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PickupListValueId { get; set; }
Visual Basic
Public Property PickupListValueId As String
    Get
    Set
Visual C++
public:
property String^ PickupListValueId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListFilter Class
PickupListFilter Members
CelloSaaS.Model.Configuration Namespace


PickupListValue Class

[image]

A Sandcastle Documented Class Library
PickupListValue Class
Members See Also Send Feedback
Pick up list values properties

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListValue
Visual Basic
<SerializableAttribute>
Public Class PickupListValue
Visual C++
[SerializableAttribute]
public ref class PickupListValue

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..PickupListValue

See Also

PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue Members

[image] [image]

A Sandcastle Documented Class Library
PickupListValue Members
PickupListValue Class Constructors Methods Properties See Also Send Feedback

The PickupListValue type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListValue | Initializes a new instance of the PickupListValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name of the pickup list value.
Public property | CreatedOn | This used to get or set created date of the pickup list value.
Public property | Description | This used to get or set description/name of the pickup list value.
Public property | Details | This used to get or set details
Public property | Id | This used to get or set id of the pickup list value.
Public property | ItemId | This used to get or set value of the pickup list value.
Public property | ItemName | This used to get or set value of the pickup list value.
Public property | PickupListId | This used to get or set pickup list id of the pickup list value.
Public property | Status | This used to get or set status of the pickup list value.
Public property | TenantCode | This used to get or set tenant code of the pickup list value.
Public property | UpdatedBy | This used to get or set last updated by id/name of the pickup list value.
Public property | UpdatedOn | This used to get or set last updated date of the pickup list value.

See Also

PickupListValue Class
CelloSaaS.Model.Configuration Namespace


PickupListValue Constructor

[image]

A Sandcastle Documented Class Library
PickupListValue Constructor
PickupListValue Class See Also Send Feedback
Initializes a new instance of the PickupListValue class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValue()
Visual Basic
Public Sub New
Visual C++
public:
PickupListValue()

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListValue Methods
PickupListValue Class See Also Send Feedback

The PickupListValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PickupListValue Class
CelloSaaS.Model.Configuration Namespace


PickupListValue Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListValue Properties
PickupListValue Class See Also Send Feedback

The PickupListValue type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name of the pickup list value.
Public property | CreatedOn | This used to get or set created date of the pickup list value.
Public property | Description | This used to get or set description/name of the pickup list value.
Public property | Details | This used to get or set details
Public property | Id | This used to get or set id of the pickup list value.
Public property | ItemId | This used to get or set value of the pickup list value.
Public property | ItemName | This used to get or set value of the pickup list value.
Public property | PickupListId | This used to get or set pickup list id of the pickup list value.
Public property | Status | This used to get or set status of the pickup list value.
Public property | TenantCode | This used to get or set tenant code of the pickup list value.
Public property | UpdatedBy | This used to get or set last updated by id/name of the pickup list value.
Public property | UpdatedOn | This used to get or set last updated date of the pickup list value.

See Also

PickupListValue Class
CelloSaaS.Model.Configuration Namespace


PickupListValue.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..CreatedBy Property
PickupListValue Class See Also Send Feedback
This used to get or set created by id/name of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..CreatedOn Property
PickupListValue Class See Also Send Feedback
This used to get or set created date of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.Description Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..Description Property
PickupListValue Class See Also Send Feedback
This used to get or set description/name of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.Details Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..Details Property
PickupListValue Class See Also Send Feedback
This used to get or set details

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataRow Details { get; set; }
Visual Basic
Public Property Details As DataRow
    Get
    Set
Visual C++
public:
property DataRow^ Details {
    DataRow^ get ();
    void set (DataRow^ value);
}

Property Value

Type: DataRow

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.Id Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..Id Property
PickupListValue Class See Also Send Feedback
This used to get or set id of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.ItemId Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..ItemId Property
PickupListValue Class See Also Send Feedback
This used to get or set value of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ItemId { get; set; }
Visual Basic
Public Property ItemId As String
    Get
    Set
Visual C++
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.ItemName Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..ItemName Property
PickupListValue Class See Also Send Feedback
This used to get or set value of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ItemName { get; set; }
Visual Basic
Public Property ItemName As String
    Get
    Set
Visual C++
public:
property String^ ItemName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.PickupListId Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..PickupListId Property
PickupListValue Class See Also Send Feedback
This used to get or set pickup list id of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PickupListId { get; set; }
Visual Basic
Public Property PickupListId As String
    Get
    Set
Visual C++
public:
property String^ PickupListId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.Status Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..Status Property
PickupListValue Class See Also Send Feedback
This used to get or set status of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.TenantCode Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..TenantCode Property
PickupListValue Class See Also Send Feedback
This used to get or set tenant code of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantCode { get; set; }
Visual Basic
Public Property TenantCode As String
    Get
    Set
Visual C++
public:
property String^ TenantCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..UpdatedBy Property
PickupListValue Class See Also Send Feedback
This used to get or set last updated by id/name of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValue.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PickupListValue..::..UpdatedOn Property
PickupListValue Class See Also Send Feedback
This used to get or set last updated date of the pickup list value.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PickupListValue Class
PickupListValue Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping Class

[image]

A Sandcastle Documented Class Library
PickupListValueMapping Class
Members See Also Send Feedback
Pickup List Value Mapping Properties

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListValueMapping
Visual Basic
<SerializableAttribute>
Public Class PickupListValueMapping
Visual C++
[SerializableAttribute]
public ref class PickupListValueMapping

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..PickupListValueMapping

See Also

PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping Members

[image] [image]

A Sandcastle Documented Class Library
PickupListValueMapping Members
PickupListValueMapping Class Constructors Methods Properties See Also Send Feedback

The PickupListValueMapping type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListValueMapping | Initializes a new instance of the PickupListValueMapping class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name
Public property | CreatedOn | This used to get or set the created on.
Public property | Id | This used to get or set ID
Public property | RelationshipMetaDataId | This used to get or set Relationship Meta Data Id
Public property | SourceValueId | This used to get or set Source Value ID
Public property | Status | This used to get or set status
Public property | TargetValueId | This used to get or set Target Value ID
Public property | TenantId | This used to get or set Tenant ID
Public property | UpdatedBy | This used to get or set last updated by id/name
Public property | UpdatedOn | This used to get or set last updated date

See Also

PickupListValueMapping Class
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping Constructor

[image]

A Sandcastle Documented Class Library
PickupListValueMapping Constructor
PickupListValueMapping Class See Also Send Feedback
Initializes a new instance of the PickupListValueMapping class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueMapping()
Visual Basic
Public Sub New
Visual C++
public:
PickupListValueMapping()

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListValueMapping Methods
PickupListValueMapping Class See Also Send Feedback

The PickupListValueMapping type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PickupListValueMapping Class
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListValueMapping Properties
PickupListValueMapping Class See Also Send Feedback

The PickupListValueMapping type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name
Public property | CreatedOn | This used to get or set the created on.
Public property | Id | This used to get or set ID
Public property | RelationshipMetaDataId | This used to get or set Relationship Meta Data Id
Public property | SourceValueId | This used to get or set Source Value ID
Public property | Status | This used to get or set status
Public property | TargetValueId | This used to get or set Target Value ID
Public property | TenantId | This used to get or set Tenant ID
Public property | UpdatedBy | This used to get or set last updated by id/name
Public property | UpdatedOn | This used to get or set last updated date

See Also

PickupListValueMapping Class
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..CreatedBy Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set created by id/name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..CreatedOn Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set the created on.

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.Id Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..Id Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set ID

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.RelationshipMetaDataId Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..RelationshipMetaDataId Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set Relationship Meta Data Id

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RelationshipMetaDataId { get; set; }
Visual Basic
Public Property RelationshipMetaDataId As String
    Get
    Set
Visual C++
public:
property String^ RelationshipMetaDataId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.SourceValueId Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..SourceValueId Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set Source Value ID

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SourceValueId { get; set; }
Visual Basic
Public Property SourceValueId As String
    Get
    Set
Visual C++
public:
property String^ SourceValueId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.Status Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..Status Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set status

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.TargetValueId Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..TargetValueId Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set Target Value ID

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetValueId { get; set; }
Visual Basic
Public Property TargetValueId As String
    Get
    Set
Visual C++
public:
property String^ TargetValueId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.TenantId Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..TenantId Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set Tenant ID

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..UpdatedBy Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set last updated by id/name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


PickupListValueMapping.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PickupListValueMapping..::..UpdatedOn Property
PickupListValueMapping Class See Also Send Feedback
This used to get or set last updated date

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

PickupListValueMapping Class
PickupListValueMapping Members
CelloSaaS.Model.Configuration Namespace


Relation Enumeration

[image]

A Sandcastle Documented Class Library
Relation Enumeration
See Also Send Feedback
Pickup list Relation type

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum Relation
Visual Basic
<SerializableAttribute>
Public Enumeration Relation
Visual C++
[SerializableAttribute]
public enum class Relation

Members

Member name | Value | Description
Parent | 0 | Parent type
Child | 1 | Child type

See Also

CelloSaaS.Model.Configuration Namespace


RelationshipMetaData Class

[image]

A Sandcastle Documented Class Library
RelationshipMetaData Class
Members See Also Send Feedback
Pickup List Relationship Meta Data Properties

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RelationshipMetaData
Visual Basic
<SerializableAttribute>
Public Class RelationshipMetaData
Visual C++
[SerializableAttribute]
public ref class RelationshipMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Configuration..::..RelationshipMetaData

See Also

RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData Members

[image] [image]

A Sandcastle Documented Class Library
RelationshipMetaData Members
RelationshipMetaData Class Constructors Methods Properties See Also Send Feedback

The RelationshipMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | RelationshipMetaData | Initializes a new instance of the RelationshipMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name
Public property | CreatedOn | This used to get or set created date
Public property | Id | This used to get or set Relationship Meta Data Id
Public property | RelationType | This used to get or set Relationship Type (Parent/Child)
Public property | SourceId | This used to get or set Source Id
Public property | SourceName | This used to get or set Source Name
Public property | Status | This used to get or set status
Public property | TargetDisplayName | This used to get or set Target Display Name
Public property | TargetId | This used to get or set Target Id
Public property | TargetKeyName | This used to get or set Target Key Name
Public property | TargetName | This used to get or set Target Name
Public property | TargetType | This used to get or set Target Type (PickupList/Entity)
Public property | TenantId | This used to get or set Tenant ID
Public property | UpdatedBy | This used to get or set last updated by id/name
Public property | UpdatedOn | This used to get or set last updated date

See Also

RelationshipMetaData Class
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData Constructor

[image]

A Sandcastle Documented Class Library
RelationshipMetaData Constructor
RelationshipMetaData Class See Also Send Feedback
Initializes a new instance of the RelationshipMetaData class

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RelationshipMetaData()
Visual Basic
Public Sub New
Visual C++
public:
RelationshipMetaData()

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
RelationshipMetaData Methods
RelationshipMetaData Class See Also Send Feedback

The RelationshipMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RelationshipMetaData Class
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
RelationshipMetaData Properties
RelationshipMetaData Class See Also Send Feedback

The RelationshipMetaData type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | This used to get or set created by id/name
Public property | CreatedOn | This used to get or set created date
Public property | Id | This used to get or set Relationship Meta Data Id
Public property | RelationType | This used to get or set Relationship Type (Parent/Child)
Public property | SourceId | This used to get or set Source Id
Public property | SourceName | This used to get or set Source Name
Public property | Status | This used to get or set status
Public property | TargetDisplayName | This used to get or set Target Display Name
Public property | TargetId | This used to get or set Target Id
Public property | TargetKeyName | This used to get or set Target Key Name
Public property | TargetName | This used to get or set Target Name
Public property | TargetType | This used to get or set Target Type (PickupList/Entity)
Public property | TenantId | This used to get or set Tenant ID
Public property | UpdatedBy | This used to get or set last updated by id/name
Public property | UpdatedOn | This used to get or set last updated date

See Also

RelationshipMetaData Class
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.CreatedBy Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..CreatedBy Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set created by id/name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.CreatedOn Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..CreatedOn Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set created date

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.Id Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..Id Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Relationship Meta Data Id

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.RelationType Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..RelationType Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Relationship Type (Parent/Child)

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RelationType { get; set; }
Visual Basic
Public Property RelationType As String
    Get
    Set
Visual C++
public:
property String^ RelationType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.SourceId Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..SourceId Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Source Id

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SourceId { get; set; }
Visual Basic
Public Property SourceId As String
    Get
    Set
Visual C++
public:
property String^ SourceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.SourceName Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..SourceName Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Source Name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SourceName { get; set; }
Visual Basic
Public Property SourceName As String
    Get
    Set
Visual C++
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.Status Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..Status Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set status

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.TargetDisplayName Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..TargetDisplayName Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Target Display Name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetDisplayName { get; set; }
Visual Basic
Public Property TargetDisplayName As String
    Get
    Set
Visual C++
public:
property String^ TargetDisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.TargetId Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..TargetId Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Target Id

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetId { get; set; }
Visual Basic
Public Property TargetId As String
    Get
    Set
Visual C++
public:
property String^ TargetId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.TargetKeyName Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..TargetKeyName Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Target Key Name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetKeyName { get; set; }
Visual Basic
Public Property TargetKeyName As String
    Get
    Set
Visual C++
public:
property String^ TargetKeyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.TargetName Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..TargetName Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Target Name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetName { get; set; }
Visual Basic
Public Property TargetName As String
    Get
    Set
Visual C++
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.TargetType Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..TargetType Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Target Type (PickupList/Entity)

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TargetType { get; set; }
Visual Basic
Public Property TargetType As String
    Get
    Set
Visual C++
public:
property String^ TargetType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.TenantId Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..TenantId Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set Tenant ID

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..UpdatedBy Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set last updated by id/name

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


RelationshipMetaData.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
RelationshipMetaData..::..UpdatedOn Property
RelationshipMetaData Class See Also Send Feedback
This used to get or set last updated date

Namespace: CelloSaaS.Model.Configuration
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

RelationshipMetaData Class
RelationshipMetaData Members
CelloSaaS.Model.Configuration Namespace


CelloSaaS.Model.DataManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.DataManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccessPolicy | Access Policy Properties
Public class | BracketCondition | The class that inherit the class "condition" that includes bracket for the expression
Public class | Condition | Properties of Extended fields search condition that inherits the interface "Icondition"
Public class | CustomColumnProperty | This class havibg custom column property constats
Public class | DataFieldType | This class having data field type constants
Public class | EntityExtendedColumnDetails | Entity extended column details class
Public class | EntityFieldMetaData | Entity Field Meta Data Properties
Public class | EntityMetaData | Entity Meta Data Properties
Public class | EntityPrivilegePrefix | Entity Privilege Prefix Constants
Public class | ExtendedEntityColumn | Properties of Extended Entity Column
Public class | ExtendedEntityRow | Properties of Extended Entity Row
Public class | ExtendedFieldsConstants | Extended Fields Search Operator Constants
Public class | ExtendedFieldsSearchCondition | Properties of Extended fields search condition
Public class | FieldCondition | The class that inherits the interface "Icondition"
Public class | FieldDataType | Field Data Type Properties
Public class | ValueCondition | The class that inherits the interface "Icondition"

Interfaces

 | Interface | Description
Public interface | ICondition | Interface that defines the property "Value"

Enumerations

 | Enumeration | Description
Public enumeration | AccessMode | Access Mode Type
Public enumeration | EFPrimaryKeyDataType | Entity framework primary key data type
Public enumeration | EntityRelationCardinality | Entity Relationship Cardinality
Public enumeration | ExtendedFieldDataType | Field data type enumeration
Public enumeration | ExtendedFieldsOperators | Enum of extended fields operators
Public enumeration | ExtendedFieldSorting | Sort direction enum


AccessMode Enumeration

[image]

A Sandcastle Documented Class Library
AccessMode Enumeration
See Also Send Feedback
Access Mode Type

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum AccessMode
Visual Basic
<SerializableAttribute>
Public Enumeration AccessMode
Visual C++
[SerializableAttribute]
public enum class AccessMode

Members

Member name | Value | Description
Read | 0 | Read Access
Update | 1 | Update Access
Create | 2 | Create Access
Delete | 3 | Delete Access

See Also

CelloSaaS.Model.DataManagement Namespace


AccessPolicy Class

[image]

A Sandcastle Documented Class Library
AccessPolicy Class
Members See Also Send Feedback
Access Policy Properties

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AccessPolicy
Visual Basic
<SerializableAttribute>
Public Class AccessPolicy
Visual C++
[SerializableAttribute]
public ref class AccessPolicy

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..AccessPolicy

See Also

AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


AccessPolicy Members

[image] [image]

A Sandcastle Documented Class Library
AccessPolicy Members
AccessPolicy Class Constructors Methods Properties See Also Send Feedback

The AccessPolicy type exposes the following members.

Constructors

 | Name | Description
Public method | AccessPolicy | Initializes a new instance of the AccessPolicy class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreationPriviligeRule | This rule is satisfied then the field will be able to create.
Public property | DeletionPriviligeRule | This rule is satisfied then the field will be able to delete.
Public property | PriviligeAccessModes | If the current context permission has the accessmode privilige, in grid the field would be shown
Public property | ReadPriviligeRule | This rule is satisfied then the field will be able to read.
Public property | UpdationPriviligeRule | This rule is satisfied then the field will be able to update.

See Also

AccessPolicy Class
CelloSaaS.Model.DataManagement Namespace


AccessPolicy Constructor

[image]

A Sandcastle Documented Class Library
AccessPolicy Constructor
AccessPolicy Class See Also Send Feedback
Initializes a new instance of the AccessPolicy class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AccessPolicy()
Visual Basic
Public Sub New
Visual C++
public:
AccessPolicy()

See Also

AccessPolicy Class
AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


AccessPolicy Methods

[image] [image]

A Sandcastle Documented Class Library
AccessPolicy Methods
AccessPolicy Class See Also Send Feedback

The AccessPolicy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AccessPolicy Class
CelloSaaS.Model.DataManagement Namespace


AccessPolicy Properties

[image] [image]

A Sandcastle Documented Class Library
AccessPolicy Properties
AccessPolicy Class See Also Send Feedback

The AccessPolicy type exposes the following members.

Properties

 | Name | Description
Public property | CreationPriviligeRule | This rule is satisfied then the field will be able to create.
Public property | DeletionPriviligeRule | This rule is satisfied then the field will be able to delete.
Public property | PriviligeAccessModes | If the current context permission has the accessmode privilige, in grid the field would be shown
Public property | ReadPriviligeRule | This rule is satisfied then the field will be able to read.
Public property | UpdationPriviligeRule | This rule is satisfied then the field will be able to update.

See Also

AccessPolicy Class
CelloSaaS.Model.DataManagement Namespace


AccessPolicy.CreationPriviligeRule Property

[image]

A Sandcastle Documented Class Library
AccessPolicy..::..CreationPriviligeRule Property
AccessPolicy Class See Also Send Feedback
This rule is satisfied then the field will be able to create.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreationPriviligeRule { get; set; }
Visual Basic
Public Property CreationPriviligeRule As String
    Get
    Set
Visual C++
public:
property String^ CreationPriviligeRule {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AccessPolicy Class
AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


AccessPolicy.DeletionPriviligeRule Property

[image]

A Sandcastle Documented Class Library
AccessPolicy..::..DeletionPriviligeRule Property
AccessPolicy Class See Also Send Feedback
This rule is satisfied then the field will be able to delete.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DeletionPriviligeRule { get; set; }
Visual Basic
Public Property DeletionPriviligeRule As String
    Get
    Set
Visual C++
public:
property String^ DeletionPriviligeRule {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AccessPolicy Class
AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


AccessPolicy.PriviligeAccessModes Property

[image]

A Sandcastle Documented Class Library
AccessPolicy..::..PriviligeAccessModes Property
AccessPolicy Class See Also Send Feedback
If the current context permission has the accessmode privilige, in grid the field would be shown

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AccessMode[]> PriviligeAccessModes { get; set; }
Visual Basic
Public Property PriviligeAccessModes As Dictionary(Of String, AccessMode())
    Get
    Set
Visual C++
public:
property Dictionary<String^, array<AccessMode>^>^ PriviligeAccessModes {
    Dictionary<String^, array<AccessMode>^>^ get ();
    void set (Dictionary<String^, array<AccessMode>^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, array< AccessMode >[]()[][]>)>)>

See Also

AccessPolicy Class
AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


AccessPolicy.ReadPriviligeRule Property

[image]

A Sandcastle Documented Class Library
AccessPolicy..::..ReadPriviligeRule Property
AccessPolicy Class See Also Send Feedback
This rule is satisfied then the field will be able to read.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReadPriviligeRule { get; set; }
Visual Basic
Public Property ReadPriviligeRule As String
    Get
    Set
Visual C++
public:
property String^ ReadPriviligeRule {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AccessPolicy Class
AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


AccessPolicy.UpdationPriviligeRule Property

[image]

A Sandcastle Documented Class Library
AccessPolicy..::..UpdationPriviligeRule Property
AccessPolicy Class See Also Send Feedback
This rule is satisfied then the field will be able to update.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdationPriviligeRule { get; set; }
Visual Basic
Public Property UpdationPriviligeRule As String
    Get
    Set
Visual C++
public:
property String^ UpdationPriviligeRule {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AccessPolicy Class
AccessPolicy Members
CelloSaaS.Model.DataManagement Namespace


BracketCondition Class

[image]

A Sandcastle Documented Class Library
BracketCondition Class
Members See Also Send Feedback
The class that inherit the class "condition" that includes bracket for the expression

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BracketCondition : Condition
Visual Basic
<SerializableAttribute>
Public Class BracketCondition
    Inherits Condition
Visual C++
[SerializableAttribute]
public ref class BracketCondition : public Condition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..Condition
CelloSaaS.Model.DataManagement..::..BracketCondition

See Also

BracketCondition Members
CelloSaaS.Model.DataManagement Namespace


BracketCondition Members

[image] [image]

A Sandcastle Documented Class Library
BracketCondition Members
BracketCondition Class Constructors Methods Properties See Also Send Feedback

The BracketCondition type exposes the following members.

Constructors

 | Name | Description
Public method | BracketCondition | Initializes a new instance of the BracketCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LHSOperand | Gets or sets the left hand side Operand(May be another expression or left hand side operand) (Inherited from Condition.)
Public property | Operator | Gets or sets the operator operates between the hand left hand side operand and the right hand side operand (Inherited from Condition.)
Public property | RHSOperand | Gets or sets the right hand side Operand(May be another expression or right hand side operand) (Inherited from Condition.)
Public property | Value | Gets or sets the value (Inherited from Condition.)

See Also

BracketCondition Class
CelloSaaS.Model.DataManagement Namespace


BracketCondition Constructor

[image]

A Sandcastle Documented Class Library
BracketCondition Constructor
BracketCondition Class See Also Send Feedback
Initializes a new instance of the BracketCondition class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BracketCondition()
Visual Basic
Public Sub New
Visual C++
public:
BracketCondition()

See Also

BracketCondition Class
BracketCondition Members
CelloSaaS.Model.DataManagement Namespace


BracketCondition Methods

[image] [image]

A Sandcastle Documented Class Library
BracketCondition Methods
BracketCondition Class See Also Send Feedback

The BracketCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BracketCondition Class
CelloSaaS.Model.DataManagement Namespace


BracketCondition Properties

[image] [image]

A Sandcastle Documented Class Library
BracketCondition Properties
BracketCondition Class See Also Send Feedback

The BracketCondition type exposes the following members.

Properties

 | Name | Description
Public property | LHSOperand | Gets or sets the left hand side Operand(May be another expression or left hand side operand) (Inherited from Condition.)
Public property | Operator | Gets or sets the operator operates between the hand left hand side operand and the right hand side operand (Inherited from Condition.)
Public property | RHSOperand | Gets or sets the right hand side Operand(May be another expression or right hand side operand) (Inherited from Condition.)
Public property | Value | Gets or sets the value (Inherited from Condition.)

See Also

BracketCondition Class
CelloSaaS.Model.DataManagement Namespace


Condition Class

[image]

A Sandcastle Documented Class Library
Condition Class
Members See Also Send Feedback
Properties of Extended fields search condition that inherits the interface "Icondition"

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Condition : ICondition
Visual Basic
<SerializableAttribute>
Public Class Condition
    Implements ICondition
Visual C++
[SerializableAttribute]
public ref class Condition : ICondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..Condition
CelloSaaS.Model.DataManagement..::..BracketCondition

See Also

Condition Members
CelloSaaS.Model.DataManagement Namespace


Condition Members

[image] [image]

A Sandcastle Documented Class Library
Condition Members
Condition Class Constructors Methods Properties See Also Send Feedback

The Condition type exposes the following members.

Constructors

 | Name | Description
Public method | Condition | Initializes a new instance of the Condition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LHSOperand | Gets or sets the left hand side Operand(May be another expression or left hand side operand)
Public property | Operator | Gets or sets the operator operates between the hand left hand side operand and the right hand side operand
Public property | RHSOperand | Gets or sets the right hand side Operand(May be another expression or right hand side operand)
Public property | Value | Gets or sets the value

See Also

Condition Class
CelloSaaS.Model.DataManagement Namespace


Condition Constructor

[image]

A Sandcastle Documented Class Library
Condition Constructor
Condition Class See Also Send Feedback
Initializes a new instance of the Condition class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Condition()
Visual Basic
Public Sub New
Visual C++
public:
Condition()

See Also

Condition Class
Condition Members
CelloSaaS.Model.DataManagement Namespace


Condition Methods

[image] [image]

A Sandcastle Documented Class Library
Condition Methods
Condition Class See Also Send Feedback

The Condition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Condition Class
CelloSaaS.Model.DataManagement Namespace


Condition Properties

[image] [image]

A Sandcastle Documented Class Library
Condition Properties
Condition Class See Also Send Feedback

The Condition type exposes the following members.

Properties

 | Name | Description
Public property | LHSOperand | Gets or sets the left hand side Operand(May be another expression or left hand side operand)
Public property | Operator | Gets or sets the operator operates between the hand left hand side operand and the right hand side operand
Public property | RHSOperand | Gets or sets the right hand side Operand(May be another expression or right hand side operand)
Public property | Value | Gets or sets the value

See Also

Condition Class
CelloSaaS.Model.DataManagement Namespace


Condition.LHSOperand Property

[image]

A Sandcastle Documented Class Library
Condition..::..LHSOperand Property
Condition Class See Also Send Feedback
Gets or sets the left hand side Operand(May be another expression or left hand side operand)

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICondition LHSOperand { get; set; }
Visual Basic
Public Property LHSOperand As ICondition
    Get
    Set
Visual C++
public:
property ICondition^ LHSOperand {
    ICondition^ get ();
    void set (ICondition^ value);
}

Property Value

Type: ICondition

See Also

Condition Class
Condition Members
CelloSaaS.Model.DataManagement Namespace


Condition.Operator Property

[image]

A Sandcastle Documented Class Library
Condition..::..Operator Property
Condition Class See Also Send Feedback
Gets or sets the operator operates between the hand left hand side operand and the right hand side operand

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<ExtendedFieldsOperators> Operator { get; set; }
Visual Basic
Public Property Operator As Nullable(Of ExtendedFieldsOperators)
    Get
    Set
Visual C++
public:
property Nullable<ExtendedFieldsOperators> Operator {
    Nullable<ExtendedFieldsOperators> get ();
    void set (Nullable<ExtendedFieldsOperators> value);
}

Property Value

Type: Nullable<(Of <(<' ExtendedFieldsOperators >)>)>

See Also

Condition Class
Condition Members
CelloSaaS.Model.DataManagement Namespace


Condition.RHSOperand Property

[image]

A Sandcastle Documented Class Library
Condition..::..RHSOperand Property
Condition Class See Also Send Feedback
Gets or sets the right hand side Operand(May be another expression or right hand side operand)

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICondition RHSOperand { get; set; }
Visual Basic
Public Property RHSOperand As ICondition
    Get
    Set
Visual C++
public:
property ICondition^ RHSOperand {
    ICondition^ get ();
    void set (ICondition^ value);
}

Property Value

Type: ICondition

See Also

Condition Class
Condition Members
CelloSaaS.Model.DataManagement Namespace


Condition.Value Property

[image]

A Sandcastle Documented Class Library
Condition..::..Value Property
Condition Class See Also Send Feedback
Gets or sets the value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICondition..::..Value

See Also

Condition Class
Condition Members
CelloSaaS.Model.DataManagement Namespace


CustomColumnProperty Class

[image]

A Sandcastle Documented Class Library
CustomColumnProperty Class
Members See Also Send Feedback
This class havibg custom column property constats

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class CustomColumnProperty
Visual Basic
Public NotInheritable Class CustomColumnProperty
Visual C++
public ref class CustomColumnProperty abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..CustomColumnProperty

See Also

CustomColumnProperty Members
CelloSaaS.Model.DataManagement Namespace


CustomColumnProperty Members

[image] [image]

A Sandcastle Documented Class Library
CustomColumnProperty Members
CustomColumnProperty Class Fields See Also Send Feedback

The CustomColumnProperty type exposes the following members.

Fields

Name | Description
defaultMaxLength | Default maximun length value

See Also

CustomColumnProperty Class
CelloSaaS.Model.DataManagement Namespace


CustomColumnProperty Fields

[image] [image]

A Sandcastle Documented Class Library
CustomColumnProperty Fields
CustomColumnProperty Class See Also Send Feedback

The CustomColumnProperty type exposes the following members.

Fields

Name | Description
defaultMaxLength | Default maximun length value

See Also

CustomColumnProperty Class
CelloSaaS.Model.DataManagement Namespace


CustomColumnProperty.defaultMaxLength Field

[image]

A Sandcastle Documented Class Library
CustomColumnProperty..::..defaultMaxLength Field
CustomColumnProperty Class See Also Send Feedback
Default maximun length value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int defaultMaxLength
Visual Basic
Public Const defaultMaxLength As Integer
Visual C++
public:
literal int defaultMaxLength

Field Value

Type: Int32

See Also

CustomColumnProperty Class
CustomColumnProperty Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType Class

[image]

A Sandcastle Documented Class Library
DataFieldType Class
Members See Also Send Feedback
This class having data field type constants

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class DataFieldType
Visual Basic
Public NotInheritable Class DataFieldType
Visual C++
public ref class DataFieldType abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..DataFieldType

See Also

DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType Members

[image] [image]

A Sandcastle Documented Class Library
DataFieldType Members
DataFieldType Class Fields See Also Send Feedback

The DataFieldType type exposes the following members.

Fields

Name | Description
Boolean | Boolean field identifier
Date | Date time field identifier
Entity | Entity Field
Float | Float field identifier
Int | Integer field identifier
PickUpField | Pickup field identifier
Varchar | Varchar field identifier

See Also

DataFieldType Class
CelloSaaS.Model.DataManagement Namespace


DataFieldType Fields

[image] [image]

A Sandcastle Documented Class Library
DataFieldType Fields
DataFieldType Class See Also Send Feedback

The DataFieldType type exposes the following members.

Fields

Name | Description
Boolean | Boolean field identifier
Date | Date time field identifier
Entity | Entity Field
Float | Float field identifier
Int | Integer field identifier
PickUpField | Pickup field identifier
Varchar | Varchar field identifier

See Also

DataFieldType Class
CelloSaaS.Model.DataManagement Namespace


DataFieldType.Boolean Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..Boolean Field
DataFieldType Class See Also Send Feedback
Boolean field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Boolean
Visual Basic
Public Const Boolean As String
Visual C++
public:
literal String^ Boolean

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType.Date Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..Date Field
DataFieldType Class See Also Send Feedback
Date time field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Date
Visual Basic
Public Const Date As String
Visual C++
public:
literal String^ Date

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType.Entity Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..Entity Field
DataFieldType Class See Also Send Feedback
Entity Field

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Entity
Visual Basic
Public Const Entity As String
Visual C++
public:
literal String^ Entity

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType.Float Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..Float Field
DataFieldType Class See Also Send Feedback
Float field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Float
Visual Basic
Public Const Float As String
Visual C++
public:
literal String^ Float

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType.Int Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..Int Field
DataFieldType Class See Also Send Feedback
Integer field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Int
Visual Basic
Public Const Int As String
Visual C++
public:
literal String^ Int

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType.PickUpField Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..PickUpField Field
DataFieldType Class See Also Send Feedback
Pickup field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PickUpField
Visual Basic
Public Const PickUpField As String
Visual C++
public:
literal String^ PickUpField

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


DataFieldType.Varchar Field

[image]

A Sandcastle Documented Class Library
DataFieldType..::..Varchar Field
DataFieldType Class See Also Send Feedback
Varchar field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Varchar
Visual Basic
Public Const Varchar As String
Visual C++
public:
literal String^ Varchar

Field Value

Type: String

See Also

DataFieldType Class
DataFieldType Members
CelloSaaS.Model.DataManagement Namespace


EFPrimaryKeyDataType Enumeration

[image]

A Sandcastle Documented Class Library
EFPrimaryKeyDataType Enumeration
See Also Send Feedback
Entity framework primary key data type

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum EFPrimaryKeyDataType
Visual Basic
Public Enumeration EFPrimaryKeyDataType
Visual C++
public enum class EFPrimaryKeyDataType

Members

Member name | Value | Description
GUID | 0 | Guid as primary key
INT | 1 | Integer primary key
STRING | 2 | Varchar primary key

See Also

CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails Class

[image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails Class
Members See Also Send Feedback
Entity extended column details class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityExtendedColumnDetails
Visual Basic
<SerializableAttribute>
Public Class EntityExtendedColumnDetails
Visual C++
[SerializableAttribute]
public ref class EntityExtendedColumnDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..EntityExtendedColumnDetails

See Also

EntityExtendedColumnDetails Members
CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails Members

[image] [image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails Members
EntityExtendedColumnDetails Class Constructors Methods Properties See Also Send Feedback

The EntityExtendedColumnDetails type exposes the following members.

Constructors

 | Name | Description
Public method | EntityExtendedColumnDetails | Initializes a new instance of the EntityExtendedColumnDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | This used to get or set the name of the column.
Public property | Id | This used to get or set the id.

See Also

EntityExtendedColumnDetails Class
CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails Constructor

[image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails Constructor
EntityExtendedColumnDetails Class See Also Send Feedback
Initializes a new instance of the EntityExtendedColumnDetails class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityExtendedColumnDetails()
Visual Basic
Public Sub New
Visual C++
public:
EntityExtendedColumnDetails()

See Also

EntityExtendedColumnDetails Class
EntityExtendedColumnDetails Members
CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails Methods

[image] [image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails Methods
EntityExtendedColumnDetails Class See Also Send Feedback

The EntityExtendedColumnDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityExtendedColumnDetails Class
CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails Properties

[image] [image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails Properties
EntityExtendedColumnDetails Class See Also Send Feedback

The EntityExtendedColumnDetails type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | This used to get or set the name of the column.
Public property | Id | This used to get or set the id.

See Also

EntityExtendedColumnDetails Class
CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails.ColumnName Property

[image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails..::..ColumnName Property
EntityExtendedColumnDetails Class See Also Send Feedback
This used to get or set the name of the column.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ColumnName { get; set; }
Visual Basic
Public Property ColumnName As String
    Get
    Set
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the column.

See Also

EntityExtendedColumnDetails Class
EntityExtendedColumnDetails Members
CelloSaaS.Model.DataManagement Namespace


EntityExtendedColumnDetails.Id Property

[image]

A Sandcastle Documented Class Library
EntityExtendedColumnDetails..::..Id Property
EntityExtendedColumnDetails Class See Also Send Feedback
This used to get or set the id.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

EntityExtendedColumnDetails Class
EntityExtendedColumnDetails Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData Class

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData Class
Members See Also Send Feedback
Entity Field Meta Data Properties

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityFieldMetaData
Visual Basic
<SerializableAttribute>
Public Class EntityFieldMetaData
Visual C++
[SerializableAttribute]
public ref class EntityFieldMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..EntityFieldMetaData

See Also

EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData Members

[image] [image]

A Sandcastle Documented Class Library
EntityFieldMetaData Members
EntityFieldMetaData Class Constructors Methods Properties See Also Send Feedback

The EntityFieldMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | EntityFieldMetaData | Initializes a new instance of the EntityFieldMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessPolicy | This used to get or set the access policy of entity field
Public property | ActivatedDate | This used to get or set the activated date.
Public property | AvailableInMainSchema | This used to get or set whether entity field is in main schema or not
Public property | DeactivatedDate | This used to get or set the deactivated date.
Public property | entityExtnColumnDetails | This used to get or set the entity extn column details.
Public property | EntityFieldIdentifier | This used to get or set entity field identifier
Public property | EntityId | Gets or sets the entity id.
Public property | ExtnColumnDetailsId | This used to get or set entity extn Column Details Id
Public property | IsUnique | This used to get or set whether entity field is unique or not
Public property | Length | This used to get or set the length of entity field
Public property | MappedColumnName | Mapped Column Name for this entity field and db table column name
Public property | Name | This used to get or set entity field name
Public property | PickupListId | This used to get or set the pickup list identifier of entity field
Public property | ReferenceColumnName | This used to get or set the name of the reference column.
Public property | ReferenceEntityId | This used to get or set the reference entity id.
Public property | ReferenceTableName | This used to get or set the name of the reference table.
Public property | TenantId | This used to get or set tenant identifier
Public property | TypeID | This used to get or set entity field type identifier
Public property | ValidationRegEx | This used to get or set the entity field regular expression

See Also

EntityFieldMetaData Class
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData Constructor

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData Constructor
EntityFieldMetaData Class See Also Send Feedback
Initializes a new instance of the EntityFieldMetaData class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityFieldMetaData()
Visual Basic
Public Sub New
Visual C++
public:
EntityFieldMetaData()

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
EntityFieldMetaData Methods
EntityFieldMetaData Class See Also Send Feedback

The EntityFieldMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityFieldMetaData Class
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
EntityFieldMetaData Properties
EntityFieldMetaData Class See Also Send Feedback

The EntityFieldMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AccessPolicy | This used to get or set the access policy of entity field
Public property | ActivatedDate | This used to get or set the activated date.
Public property | AvailableInMainSchema | This used to get or set whether entity field is in main schema or not
Public property | DeactivatedDate | This used to get or set the deactivated date.
Public property | entityExtnColumnDetails | This used to get or set the entity extn column details.
Public property | EntityFieldIdentifier | This used to get or set entity field identifier
Public property | EntityId | Gets or sets the entity id.
Public property | ExtnColumnDetailsId | This used to get or set entity extn Column Details Id
Public property | IsUnique | This used to get or set whether entity field is unique or not
Public property | Length | This used to get or set the length of entity field
Public property | MappedColumnName | Mapped Column Name for this entity field and db table column name
Public property | Name | This used to get or set entity field name
Public property | PickupListId | This used to get or set the pickup list identifier of entity field
Public property | ReferenceColumnName | This used to get or set the name of the reference column.
Public property | ReferenceEntityId | This used to get or set the reference entity id.
Public property | ReferenceTableName | This used to get or set the name of the reference table.
Public property | TenantId | This used to get or set tenant identifier
Public property | TypeID | This used to get or set entity field type identifier
Public property | ValidationRegEx | This used to get or set the entity field regular expression

See Also

EntityFieldMetaData Class
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.AccessPolicy Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..AccessPolicy Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the access policy of entity field

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AccessPolicy AccessPolicy { get; set; }
Visual Basic
Public Property AccessPolicy As AccessPolicy
    Get
    Set
Visual C++
public:
property AccessPolicy^ AccessPolicy {
    AccessPolicy^ get ();
    void set (AccessPolicy^ value);
}

Property Value

Type: AccessPolicy

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.ActivatedDate Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..ActivatedDate Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the activated date.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ActivatedDate { get; set; }
Visual Basic
Public Property ActivatedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime ActivatedDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The activated date.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.AvailableInMainSchema Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..AvailableInMainSchema Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set whether entity field is in main schema or not

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool AvailableInMainSchema { get; set; }
Visual Basic
Public Property AvailableInMainSchema As Boolean
    Get
    Set
Visual C++
public:
property bool AvailableInMainSchema {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.DeactivatedDate Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..DeactivatedDate Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the deactivated date.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime DeactivatedDate { get; set; }
Visual Basic
Public Property DeactivatedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime DeactivatedDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The deactivated date.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.entityExtnColumnDetails Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..entityExtnColumnDetails Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the entity extn column details.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityExtendedColumnDetails entityExtnColumnDetails { get; set; }
Visual Basic
Public Property entityExtnColumnDetails As EntityExtendedColumnDetails
    Get
    Set
Visual C++
public:
property EntityExtendedColumnDetails^ entityExtnColumnDetails {
    EntityExtendedColumnDetails^ get ();
    void set (EntityExtendedColumnDetails^ value);
}

Property Value

Type: EntityExtendedColumnDetails
The entity extn column details.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.EntityFieldIdentifier Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..EntityFieldIdentifier Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set entity field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityFieldIdentifier { get; set; }
Visual Basic
Public Property EntityFieldIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityFieldIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..EntityId Property
EntityFieldMetaData Class See Also Send Feedback
Gets or sets the entity id.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The entity id.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.ExtnColumnDetailsId Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..ExtnColumnDetailsId Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set entity extn Column Details Id

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExtnColumnDetailsId { get; set; }
Visual Basic
Public Property ExtnColumnDetailsId As String
    Get
    Set
Visual C++
public:
property String^ ExtnColumnDetailsId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.IsUnique Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..IsUnique Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set whether entity field is unique or not

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsUnique { get; set; }
Visual Basic
Public Property IsUnique As Boolean
    Get
    Set
Visual C++
public:
property bool IsUnique {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.Length Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..Length Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the length of entity field

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Length { get; set; }
Visual Basic
Public Property Length As Integer
    Get
    Set
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.MappedColumnName Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..MappedColumnName Property
EntityFieldMetaData Class See Also Send Feedback
Mapped Column Name for this entity field and db table column name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MappedColumnName { get; set; }
Visual Basic
Public Property MappedColumnName As String
    Get
    Set
Visual C++
public:
property String^ MappedColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.Name Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..Name Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set entity field name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.PickupListId Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..PickupListId Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the pickup list identifier of entity field

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PickupListId { get; set; }
Visual Basic
Public Property PickupListId As String
    Get
    Set
Visual C++
public:
property String^ PickupListId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.ReferenceColumnName Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..ReferenceColumnName Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the name of the reference column.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceColumnName { get; set; }
Visual Basic
Public Property ReferenceColumnName As String
    Get
    Set
Visual C++
public:
property String^ ReferenceColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the reference column.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.ReferenceEntityId Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..ReferenceEntityId Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the reference entity id.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceEntityId { get; set; }
Visual Basic
Public Property ReferenceEntityId As String
    Get
    Set
Visual C++
public:
property String^ ReferenceEntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The reference entity id.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.ReferenceTableName Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..ReferenceTableName Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the name of the reference table.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceTableName { get; set; }
Visual Basic
Public Property ReferenceTableName As String
    Get
    Set
Visual C++
public:
property String^ ReferenceTableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the reference table.

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.TenantId Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..TenantId Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set tenant identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.TypeID Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..TypeID Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set entity field type identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeID { get; set; }
Visual Basic
Public Property TypeID As String
    Get
    Set
Visual C++
public:
property String^ TypeID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityFieldMetaData.ValidationRegEx Property

[image]

A Sandcastle Documented Class Library
EntityFieldMetaData..::..ValidationRegEx Property
EntityFieldMetaData Class See Also Send Feedback
This used to get or set the entity field regular expression

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ValidationRegEx { get; set; }
Visual Basic
Public Property ValidationRegEx As String
    Get
    Set
Visual C++
public:
property String^ ValidationRegEx {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityFieldMetaData Class
EntityFieldMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData Class

[image]

A Sandcastle Documented Class Library
EntityMetaData Class
Members See Also Send Feedback
Entity Meta Data Properties

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityMetaData
Visual Basic
<SerializableAttribute>
Public Class EntityMetaData
Visual C++
[SerializableAttribute]
public ref class EntityMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..EntityMetaData

See Also

EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData Members

[image] [image]

A Sandcastle Documented Class Library
EntityMetaData Members
EntityMetaData Class Constructors Methods Properties See Also Send Feedback

The EntityMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | EntityMetaData | Initializes a new instance of the EntityMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyName | This used to get or set assembly name
Public property | CreatedBy | This used to get or set the created by.
Public property | CreatedOn | This used to get or set the created on.
Public property | DisplayColumnName | Gets or sets the display name of the column.
Public property | EntityFeatures | This used to get or set the feature ids which this entity belongs to.
Public property | EntityIdentifier | This used to get or set entity identifier
Public property | EntityName | Gets or sets Entity name
Public property | EntityPrivileges | This used to get or set the entity privileges
Public property | EntitySchema | This used to get or set the entity schema.
Public property | EntitySchemaTableConnectionStringName | This used to get or set the name of the entity schema table connection string.
Public property | ExtendedSchemaTableName | This used to get or set the table name of extended schema
Public property | ExtnSchemaTableConnectionName | This used to get or set the name of the extn schema table connection.
Public property | FieldsMetaData | This used to get or set Entity meta data properties
Public property | IsExtensible | This used to get or set a value indicating whether this instance is extensible.
Public property | IsTenantBasedExtension | This used to get or set a value indicating whether this instance is tenant based extensio.
Public property | PrimaryKeyName | This used to get or set primary key name
Public property | ReferencedSchema | This used to get or set the referenced schema.
Public property | SchemaTableName | This used to get or set schema table name
Public property | Status | This used to get or set a value indicating whether this EntityMetaData is status.
Public property | TenantId | Gets or sets Tenant Id
Public property | TenantIdColumnName | Gets or sets Tenant Id column name
Public property | TypeName | This used to get or set type name
Public property | UpdatedBy | This used to get or set the created by.
Public property | UpdatedOn | This used to get or set the created on.

See Also

EntityMetaData Class
CelloSaaS.Model.DataManagement Namespace


EntityMetaData Constructor

[image]

A Sandcastle Documented Class Library
EntityMetaData Constructor
EntityMetaData Class See Also Send Feedback
Initializes a new instance of the EntityMetaData class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityMetaData()
Visual Basic
Public Sub New
Visual C++
public:
EntityMetaData()

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
EntityMetaData Methods
EntityMetaData Class See Also Send Feedback

The EntityMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityMetaData Class
CelloSaaS.Model.DataManagement Namespace


EntityMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
EntityMetaData Properties
EntityMetaData Class See Also Send Feedback

The EntityMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | This used to get or set assembly name
Public property | CreatedBy | This used to get or set the created by.
Public property | CreatedOn | This used to get or set the created on.
Public property | DisplayColumnName | Gets or sets the display name of the column.
Public property | EntityFeatures | This used to get or set the feature ids which this entity belongs to.
Public property | EntityIdentifier | This used to get or set entity identifier
Public property | EntityName | Gets or sets Entity name
Public property | EntityPrivileges | This used to get or set the entity privileges
Public property | EntitySchema | This used to get or set the entity schema.
Public property | EntitySchemaTableConnectionStringName | This used to get or set the name of the entity schema table connection string.
Public property | ExtendedSchemaTableName | This used to get or set the table name of extended schema
Public property | ExtnSchemaTableConnectionName | This used to get or set the name of the extn schema table connection.
Public property | FieldsMetaData | This used to get or set Entity meta data properties
Public property | IsExtensible | This used to get or set a value indicating whether this instance is extensible.
Public property | IsTenantBasedExtension | This used to get or set a value indicating whether this instance is tenant based extensio.
Public property | PrimaryKeyName | This used to get or set primary key name
Public property | ReferencedSchema | This used to get or set the referenced schema.
Public property | SchemaTableName | This used to get or set schema table name
Public property | Status | This used to get or set a value indicating whether this EntityMetaData is status.
Public property | TenantId | Gets or sets Tenant Id
Public property | TenantIdColumnName | Gets or sets Tenant Id column name
Public property | TypeName | This used to get or set type name
Public property | UpdatedBy | This used to get or set the created by.
Public property | UpdatedOn | This used to get or set the created on.

See Also

EntityMetaData Class
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.AssemblyName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..AssemblyName Property
EntityMetaData Class See Also Send Feedback
This used to get or set assembly name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..CreatedBy Property
EntityMetaData Class See Also Send Feedback
This used to get or set the created by.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..CreatedOn Property
EntityMetaData Class See Also Send Feedback
This used to get or set the created on.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.DisplayColumnName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..DisplayColumnName Property
EntityMetaData Class See Also Send Feedback
Gets or sets the display name of the column.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DisplayColumnName { get; set; }
Visual Basic
Public Property DisplayColumnName As String
    Get
    Set
Visual C++
public:
property String^ DisplayColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The display name of the column.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.EntityFeatures Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..EntityFeatures Property
EntityMetaData Class See Also Send Feedback
This used to get or set the feature ids which this entity belongs to.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> EntityFeatures { get; set; }
Visual Basic
Public Property EntityFeatures As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ EntityFeatures {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..EntityIdentifier Property
EntityMetaData Class See Also Send Feedback
This used to get or set entity identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityIdentifier { get; set; }
Visual Basic
Public Property EntityIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.EntityName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..EntityName Property
EntityMetaData Class See Also Send Feedback
Gets or sets Entity name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityName { get; set; }
Visual Basic
Public Property EntityName As String
    Get
    Set
Visual C++
public:
property String^ EntityName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.EntityPrivileges Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..EntityPrivileges Property
EntityMetaData Class See Also Send Feedback
This used to get or set the entity privileges

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> EntityPrivileges { get; set; }
Visual Basic
Public Property EntityPrivileges As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ EntityPrivileges {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.EntitySchema Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..EntitySchema Property
EntityMetaData Class See Also Send Feedback
This used to get or set the entity schema.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntitySchema { get; set; }
Visual Basic
Public Property EntitySchema As String
    Get
    Set
Visual C++
public:
property String^ EntitySchema {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The entity schema.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.EntitySchemaTableConnectionStringName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..EntitySchemaTableConnectionStringName Property
EntityMetaData Class See Also Send Feedback
This used to get or set the name of the entity schema table connection string.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntitySchemaTableConnectionStringName { get; set; }
Visual Basic
Public Property EntitySchemaTableConnectionStringName As String
    Get
    Set
Visual C++
public:
property String^ EntitySchemaTableConnectionStringName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the entity schema table connection string.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.ExtendedSchemaTableName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..ExtendedSchemaTableName Property
EntityMetaData Class See Also Send Feedback
This used to get or set the table name of extended schema

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExtendedSchemaTableName { get; set; }
Visual Basic
Public Property ExtendedSchemaTableName As String
    Get
    Set
Visual C++
public:
property String^ ExtendedSchemaTableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.ExtnSchemaTableConnectionName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..ExtnSchemaTableConnectionName Property
EntityMetaData Class See Also Send Feedback
This used to get or set the name of the extn schema table connection.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExtnSchemaTableConnectionName { get; set; }
Visual Basic
Public Property ExtnSchemaTableConnectionName As String
    Get
    Set
Visual C++
public:
property String^ ExtnSchemaTableConnectionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the extn schema table connection.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.FieldsMetaData Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..FieldsMetaData Property
EntityMetaData Class See Also Send Feedback
This used to get or set Entity meta data properties

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, EntityFieldMetaData> FieldsMetaData { get; set; }
Visual Basic
Public Property FieldsMetaData As Dictionary(Of String, EntityFieldMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, EntityFieldMetaData^>^ FieldsMetaData {
    Dictionary<String^, EntityFieldMetaData^>^ get ();
    void set (Dictionary<String^, EntityFieldMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.IsExtensible Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..IsExtensible Property
EntityMetaData Class See Also Send Feedback
This used to get or set a value indicating whether this instance is extensible.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsExtensible { get; set; }
Visual Basic
Public Property IsExtensible As Boolean
    Get
    Set
Visual C++
public:
property bool IsExtensible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is extensible; otherwise, false.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.IsTenantBasedExtension Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..IsTenantBasedExtension Property
EntityMetaData Class See Also Send Feedback
This used to get or set a value indicating whether this instance is tenant based extensio.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsTenantBasedExtension { get; set; }
Visual Basic
Public Property IsTenantBasedExtension As Boolean
    Get
    Set
Visual C++
public:
property bool IsTenantBasedExtension {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is tenant based extensio; otherwise, false.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.PrimaryKeyName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..PrimaryKeyName Property
EntityMetaData Class See Also Send Feedback
This used to get or set primary key name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrimaryKeyName { get; set; }
Visual Basic
Public Property PrimaryKeyName As String
    Get
    Set
Visual C++
public:
property String^ PrimaryKeyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.ReferencedSchema Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..ReferencedSchema Property
EntityMetaData Class See Also Send Feedback
This used to get or set the referenced schema.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferencedSchema { get; set; }
Visual Basic
Public Property ReferencedSchema As String
    Get
    Set
Visual C++
public:
property String^ ReferencedSchema {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The referenced schema.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.SchemaTableName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..SchemaTableName Property
EntityMetaData Class See Also Send Feedback
This used to get or set schema table name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SchemaTableName { get; set; }
Visual Basic
Public Property SchemaTableName As String
    Get
    Set
Visual C++
public:
property String^ SchemaTableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.Status Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..Status Property
EntityMetaData Class See Also Send Feedback
This used to get or set a value indicating whether this EntityMetaData is status.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.TenantId Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..TenantId Property
EntityMetaData Class See Also Send Feedback
Gets or sets Tenant Id

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.TenantIdColumnName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..TenantIdColumnName Property
EntityMetaData Class See Also Send Feedback
Gets or sets Tenant Id column name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantIdColumnName { get; set; }
Visual Basic
Public Property TenantIdColumnName As String
    Get
    Set
Visual C++
public:
property String^ TenantIdColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.TypeName Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..TypeName Property
EntityMetaData Class See Also Send Feedback
This used to get or set type name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..UpdatedBy Property
EntityMetaData Class See Also Send Feedback
This used to get or set the created by.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityMetaData.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EntityMetaData..::..UpdatedOn Property
EntityMetaData Class See Also Send Feedback
This used to get or set the created on.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

EntityMetaData Class
EntityMetaData Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix Class

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix Class
Members See Also Send Feedback
Entity Privilege Prefix Constants

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class EntityPrivilegePrefix
Visual Basic
Public NotInheritable Class EntityPrivilegePrefix
Visual C++
public ref class EntityPrivilegePrefix abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..EntityPrivilegePrefix

See Also

EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix Members

[image] [image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix Members
EntityPrivilegePrefix Class Properties See Also Send Feedback

The EntityPrivilegePrefix type exposes the following members.

Properties

Name | Description
AddPrefix | This used to get the add prefix Name.
DeletePrefix | This used to get the delete prefix Name.
EditPrefix | This used to get the edit prefix Name.
ExecutePrefix | This used to get the execute prefix Name.
SearchPrefix | This used to get the search prefix Name.
ViewPrefix | This used to get the view prefix Name.

See Also

EntityPrivilegePrefix Class
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix Properties

[image] [image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix Properties
EntityPrivilegePrefix Class See Also Send Feedback

The EntityPrivilegePrefix type exposes the following members.

Properties

Name | Description
AddPrefix | This used to get the add prefix Name.
DeletePrefix | This used to get the delete prefix Name.
EditPrefix | This used to get the edit prefix Name.
ExecutePrefix | This used to get the execute prefix Name.
SearchPrefix | This used to get the search prefix Name.
ViewPrefix | This used to get the view prefix Name.

See Also

EntityPrivilegePrefix Class
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix.AddPrefix Property

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix..::..AddPrefix Property
EntityPrivilegePrefix Class See Also Send Feedback
This used to get the add prefix Name.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddPrefix { get; }
Visual Basic
Public Shared ReadOnly Property AddPrefix As String
    Get
Visual C++
public:
static property String^ AddPrefix {
    String^ get ();
}

Property Value

Type: String

See Also

EntityPrivilegePrefix Class
EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix.DeletePrefix Property

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix..::..DeletePrefix Property
EntityPrivilegePrefix Class See Also Send Feedback
This used to get the delete prefix Name.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeletePrefix { get; }
Visual Basic
Public Shared ReadOnly Property DeletePrefix As String
    Get
Visual C++
public:
static property String^ DeletePrefix {
    String^ get ();
}

Property Value

Type: String

See Also

EntityPrivilegePrefix Class
EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix.EditPrefix Property

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix..::..EditPrefix Property
EntityPrivilegePrefix Class See Also Send Feedback
This used to get the edit prefix Name.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditPrefix { get; }
Visual Basic
Public Shared ReadOnly Property EditPrefix As String
    Get
Visual C++
public:
static property String^ EditPrefix {
    String^ get ();
}

Property Value

Type: String

See Also

EntityPrivilegePrefix Class
EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix.ExecutePrefix Property

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix..::..ExecutePrefix Property
EntityPrivilegePrefix Class See Also Send Feedback
This used to get the execute prefix Name.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ExecutePrefix { get; }
Visual Basic
Public Shared ReadOnly Property ExecutePrefix As String
    Get
Visual C++
public:
static property String^ ExecutePrefix {
    String^ get ();
}

Property Value

Type: String

See Also

EntityPrivilegePrefix Class
EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix.SearchPrefix Property

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix..::..SearchPrefix Property
EntityPrivilegePrefix Class See Also Send Feedback
This used to get the search prefix Name.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string SearchPrefix { get; }
Visual Basic
Public Shared ReadOnly Property SearchPrefix As String
    Get
Visual C++
public:
static property String^ SearchPrefix {
    String^ get ();
}

Property Value

Type: String

See Also

EntityPrivilegePrefix Class
EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityPrivilegePrefix.ViewPrefix Property

[image]

A Sandcastle Documented Class Library
EntityPrivilegePrefix..::..ViewPrefix Property
EntityPrivilegePrefix Class See Also Send Feedback
This used to get the view prefix Name.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewPrefix { get; }
Visual Basic
Public Shared ReadOnly Property ViewPrefix As String
    Get
Visual C++
public:
static property String^ ViewPrefix {
    String^ get ();
}

Property Value

Type: String

See Also

EntityPrivilegePrefix Class
EntityPrivilegePrefix Members
CelloSaaS.Model.DataManagement Namespace


EntityRelationCardinality Enumeration

[image]

A Sandcastle Documented Class Library
EntityRelationCardinality Enumeration
See Also Send Feedback
Entity Relationship Cardinality

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum EntityRelationCardinality
Visual Basic
<SerializableAttribute>
Public Enumeration EntityRelationCardinality
Visual C++
[SerializableAttribute]
public enum class EntityRelationCardinality

Members

Member name | Value | Description
OneToOne | 0 | One to one relation
OneToMany | 1 | One to many relation
ManyToMany | 2 | Many to many relation
ManyToOne | 3 | Many to one relation

See Also

CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Class

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Class
Members See Also Send Feedback
Properties of Extended Entity Column

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ExtendedEntityColumn
Visual Basic
<SerializableAttribute>
Public Class ExtendedEntityColumn
Visual C++
[SerializableAttribute]
public ref class ExtendedEntityColumn

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..ExtendedEntityColumn

See Also

ExtendedEntityColumn Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Members

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Members
ExtendedEntityColumn Class Constructors Methods Properties See Also Send Feedback

The ExtendedEntityColumn type exposes the following members.

Constructors

 | Name | Description
Public method | ExtendedEntityColumn()()()() | Default Constructor of extended entity column
Public method | ExtendedEntityColumn(String) | Constructor of extended entity column with entity field identifier
Public method | ExtendedEntityColumn(String, String) | Constructor of extended entity column with entity field identifer and value

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntityFieldIdentifier | This used to get or set entity field identifier
Public property | Id | This used to get or set identifier
Public property | Value | This used to get or set value

See Also

ExtendedEntityColumn Class
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Constructor

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Constructor
ExtendedEntityColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExtendedEntityColumn()()()() | Default Constructor of extended entity column
Public method | ExtendedEntityColumn(String) | Constructor of extended entity column with entity field identifier
Public method | ExtendedEntityColumn(String, String) | Constructor of extended entity column with entity field identifer and value

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Constructor

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Constructor
ExtendedEntityColumn Class See Also Send Feedback
Default Constructor of extended entity column

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedEntityColumn()
Visual Basic
Public Sub New
Visual C++
public:
ExtendedEntityColumn()

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
ExtendedEntityColumn Overload
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Constructor (String)

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Constructor (String)
ExtendedEntityColumn Class See Also Send Feedback
Constructor of extended entity column with entity field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedEntityColumn(
    string entityFieldIdentifier
)
Visual Basic
Public Sub New (
    entityFieldIdentifier As String
)
Visual C++
public:
ExtendedEntityColumn(
    String^ entityFieldIdentifier
)

Parameters

entityFieldIdentifier
Type: System..::..String
Entity Field Identifier

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
ExtendedEntityColumn Overload
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Constructor (String, String)

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Constructor (String, String)
ExtendedEntityColumn Class See Also Send Feedback
Constructor of extended entity column with entity field identifer and value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedEntityColumn(
    string entityFieldIdentifier,
    string value
)
Visual Basic
Public Sub New (
    entityFieldIdentifier As String,
    value As String
)
Visual C++
public:
ExtendedEntityColumn(
    String^ entityFieldIdentifier,
    String^ value
)

Parameters

entityFieldIdentifier
Type: System..::..String
Entity Field Identifier
value
Type: System..::..String
Value

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
ExtendedEntityColumn Overload
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Methods

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Methods
ExtendedEntityColumn Class See Also Send Feedback

The ExtendedEntityColumn type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExtendedEntityColumn Class
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn Properties

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityColumn Properties
ExtendedEntityColumn Class See Also Send Feedback

The ExtendedEntityColumn type exposes the following members.

Properties

 | Name | Description
Public property | EntityFieldIdentifier | This used to get or set entity field identifier
Public property | Id | This used to get or set identifier
Public property | Value | This used to get or set value

See Also

ExtendedEntityColumn Class
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn.EntityFieldIdentifier Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn..::..EntityFieldIdentifier Property
ExtendedEntityColumn Class See Also Send Feedback
This used to get or set entity field identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityFieldIdentifier { get; set; }
Visual Basic
Public Property EntityFieldIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityFieldIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn.Id Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn..::..Id Property
ExtendedEntityColumn Class See Also Send Feedback
This used to get or set identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityColumn.Value Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityColumn..::..Value Property
ExtendedEntityColumn Class See Also Send Feedback
This used to get or set value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityColumn Class
ExtendedEntityColumn Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow Class

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow Class
Members See Also Send Feedback
Properties of Extended Entity Row

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ExtendedEntityRow
Visual Basic
<SerializableAttribute>
Public Class ExtendedEntityRow
Visual C++
[SerializableAttribute]
public ref class ExtendedEntityRow

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..ExtendedEntityRow

See Also

ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow Members

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityRow Members
ExtendedEntityRow Class Constructors Methods Properties See Also Send Feedback

The ExtendedEntityRow type exposes the following members.

Constructors

 | Name | Description
Public method | ExtendedEntityRow | Initializes a new instance of the ExtendedEntityRow class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntityIdentifier | This used to get or set the entity identifier
Public property | ExtendedEntityColumnValues | This used to get or set the extended entity column properties
Public property | Id | This used to get or set the identifier
Public property | ReferenceId | This used to get or set the reference identifier
Public property | TenantId | This used to get or set teh tenant identifier

See Also

ExtendedEntityRow Class
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow Constructor

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow Constructor
ExtendedEntityRow Class See Also Send Feedback
Initializes a new instance of the ExtendedEntityRow class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedEntityRow()
Visual Basic
Public Sub New
Visual C++
public:
ExtendedEntityRow()

See Also

ExtendedEntityRow Class
ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow Methods

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityRow Methods
ExtendedEntityRow Class See Also Send Feedback

The ExtendedEntityRow type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExtendedEntityRow Class
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow Properties

[image] [image]

A Sandcastle Documented Class Library
ExtendedEntityRow Properties
ExtendedEntityRow Class See Also Send Feedback

The ExtendedEntityRow type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | This used to get or set the entity identifier
Public property | ExtendedEntityColumnValues | This used to get or set the extended entity column properties
Public property | Id | This used to get or set the identifier
Public property | ReferenceId | This used to get or set the reference identifier
Public property | TenantId | This used to get or set teh tenant identifier

See Also

ExtendedEntityRow Class
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow..::..EntityIdentifier Property
ExtendedEntityRow Class See Also Send Feedback
This used to get or set the entity identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityIdentifier { get; set; }
Visual Basic
Public Property EntityIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityRow Class
ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow.ExtendedEntityColumnValues Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow..::..ExtendedEntityColumnValues Property
ExtendedEntityRow Class See Also Send Feedback
This used to get or set the extended entity column properties

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, ExtendedEntityColumn> ExtendedEntityColumnValues { get; set; }
Visual Basic
Public Property ExtendedEntityColumnValues As Dictionary(Of String, ExtendedEntityColumn)
    Get
    Set
Visual C++
public:
property Dictionary<String^, ExtendedEntityColumn^>^ ExtendedEntityColumnValues {
    Dictionary<String^, ExtendedEntityColumn^>^ get ();
    void set (Dictionary<String^, ExtendedEntityColumn^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, ExtendedEntityColumn >)>)>

See Also

ExtendedEntityRow Class
ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow.Id Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow..::..Id Property
ExtendedEntityRow Class See Also Send Feedback
This used to get or set the identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityRow Class
ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow.ReferenceId Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow..::..ReferenceId Property
ExtendedEntityRow Class See Also Send Feedback
This used to get or set the reference identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ReferenceId { get; set; }
Visual Basic
Public Property ReferenceId As String
    Get
    Set
Visual C++
public:
property String^ ReferenceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityRow Class
ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedEntityRow.TenantId Property

[image]

A Sandcastle Documented Class Library
ExtendedEntityRow..::..TenantId Property
ExtendedEntityRow Class See Also Send Feedback
This used to get or set teh tenant identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedEntityRow Class
ExtendedEntityRow Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldDataType Enumeration

[image]

A Sandcastle Documented Class Library
ExtendedFieldDataType Enumeration
See Also Send Feedback
Field data type enumeration

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum ExtendedFieldDataType
Visual Basic
Public Enumeration ExtendedFieldDataType
Visual C++
public enum class ExtendedFieldDataType

Members

Member name | Value | Description
Varchar | 0 | String type
Int | 1 | Integer type
Float | 2 | Floating point type
Boolean | 3 | Boolean type
Date | 4 | Datetime type

See Also

CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants Class

[image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants Class
Members See Also Send Feedback
Extended Fields Search Operator Constants

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class ExtendedFieldsConstants
Visual Basic
Public NotInheritable Class ExtendedFieldsConstants
Visual C++
public ref class ExtendedFieldsConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..ExtendedFieldsConstants

See Also

ExtendedFieldsConstants Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants Members

[image] [image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants Members
ExtendedFieldsConstants Class Methods Fields See Also Send Feedback

The ExtendedFieldsConstants type exposes the following members.

Methods

Name | Description
GetOperator | Gets the operator.

Fields

Name | Description
Comma | Comma constant
SingleQuotes | Single quotes constant

See Also

ExtendedFieldsConstants Class
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants Fields

[image] [image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants Fields
ExtendedFieldsConstants Class See Also Send Feedback

The ExtendedFieldsConstants type exposes the following members.

Fields

Name | Description
Comma | Comma constant
SingleQuotes | Single quotes constant

See Also

ExtendedFieldsConstants Class
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants.Comma Field

[image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants..::..Comma Field
ExtendedFieldsConstants Class See Also Send Feedback
Comma constant

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const char Comma
Visual Basic
Public Const Comma As Char
Visual C++
public:
literal wchar_t Comma

Field Value

Type: Char

See Also

ExtendedFieldsConstants Class
ExtendedFieldsConstants Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants.SingleQuotes Field

[image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants..::..SingleQuotes Field
ExtendedFieldsConstants Class See Also Send Feedback
Single quotes constant

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const char SingleQuotes
Visual Basic
Public Const SingleQuotes As Char
Visual C++
public:
literal wchar_t SingleQuotes

Field Value

Type: Char

See Also

ExtendedFieldsConstants Class
ExtendedFieldsConstants Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants Methods

[image] [image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants Methods
ExtendedFieldsConstants Class See Also Send Feedback

The ExtendedFieldsConstants type exposes the following members.

Methods

Name | Description
GetOperator | Gets the operator.

See Also

ExtendedFieldsConstants Class
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsConstants.GetOperator Method

[image]

A Sandcastle Documented Class Library
ExtendedFieldsConstants..::..GetOperator Method
ExtendedFieldsConstants Class See Also Send Feedback
Gets the operator.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string GetOperator(
    Nullable<ExtendedFieldsOperators> op
)
Visual Basic
Public Shared Function GetOperator (
    op As Nullable(Of ExtendedFieldsOperators)
) As String
Visual C++
public:
static String^ GetOperator(
    Nullable<ExtendedFieldsOperators> op
)

Parameters

op
Type: System..::..Nullable<(Of <(<' ExtendedFieldsOperators >)>)>
The op.

Return Value

Type: String

See Also

ExtendedFieldsConstants Class
ExtendedFieldsConstants Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsOperators Enumeration

[image]

A Sandcastle Documented Class Library
ExtendedFieldsOperators Enumeration
See Also Send Feedback
Enum of extended fields operators

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum ExtendedFieldsOperators
Visual Basic
Public Enumeration ExtendedFieldsOperators
Visual C++
public enum class ExtendedFieldsOperators

Members

Member name | Value | Description
And | 0 | And operator
Or | 1 | Or operator
Equals | 2 | Equals operator
NotEquals | 3 | Not equals (!=) operator
GreaterThan | 4 | > operator
LesserThan | 5 | < operator
GreaterThanAndEqualTo | 6 | >= operator
LesserThanAndEqualTo | 7 | <= operator
Like | 8 | Like operator
In | 9 | In operator
Between | 10 | Between operator

See Also

CelloSaaS.Model.DataManagement Namespace


ExtendedFieldSorting Enumeration

[image]

A Sandcastle Documented Class Library
ExtendedFieldSorting Enumeration
See Also Send Feedback
Sort direction enum

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum ExtendedFieldSorting
Visual Basic
Public Enumeration ExtendedFieldSorting
Visual C++
public enum class ExtendedFieldSorting

Members

Member name | Value | Description
ASC | 0 | Sort by ascending order
DESC | 1 | Sort by descending order

See Also

CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition Class

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition Class
Members See Also Send Feedback
Properties of Extended fields search condition

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ExtendedFieldsSearchCondition
Visual Basic
<SerializableAttribute>
Public Class ExtendedFieldsSearchCondition
Visual C++
[SerializableAttribute]
public ref class ExtendedFieldsSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..ExtendedFieldsSearchCondition

See Also

ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition Members
ExtendedFieldsSearchCondition Class Constructors Methods Properties See Also Send Feedback

The ExtendedFieldsSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | ExtendedFieldsSearchCondition | Initializes a new instance of the ExtendedFieldsSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | final condition should be appended in this property
Public property | EntityIdentifier | Entity Identifier
Public property | SearchCondition | Extended fields search condition as model
Public property | SearchValue | Extended Field Value
Public property | SortDirection | SortFieldDirection
Public property | SortFieldName | SortFieldName
Public property | TenantIdentifier | Tenant Identifier

See Also

ExtendedFieldsSearchCondition Class
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition Constructor
ExtendedFieldsSearchCondition Class See Also Send Feedback
Initializes a new instance of the ExtendedFieldsSearchCondition class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedFieldsSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
ExtendedFieldsSearchCondition()

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition Methods
ExtendedFieldsSearchCondition Class See Also Send Feedback

The ExtendedFieldsSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExtendedFieldsSearchCondition Class
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition Properties
ExtendedFieldsSearchCondition Class See Also Send Feedback

The ExtendedFieldsSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | final condition should be appended in this property
Public property | EntityIdentifier | Entity Identifier
Public property | SearchCondition | Extended fields search condition as model
Public property | SearchValue | Extended Field Value
Public property | SortDirection | SortFieldDirection
Public property | SortFieldName | SortFieldName
Public property | TenantIdentifier | Tenant Identifier

See Also

ExtendedFieldsSearchCondition Class
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..Condition Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
final condition should be appended in this property

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..EntityIdentifier Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
Entity Identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityIdentifier { get; set; }
Visual Basic
Public Property EntityIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.SearchCondition Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..SearchCondition Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
Extended fields search condition as model

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Condition SearchCondition { get; set; }
Visual Basic
Public Property SearchCondition As Condition
    Get
    Set
Visual C++
public:
property Condition^ SearchCondition {
    Condition^ get ();
    void set (Condition^ value);
}

Property Value

Type: Condition

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.SearchValue Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..SearchValue Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
Extended Field Value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchValue { get; set; }
Visual Basic
Public Property SearchValue As String
    Get
    Set
Visual C++
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..SortDirection Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
SortFieldDirection

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedFieldSorting SortDirection { get; set; }
Visual Basic
Public Property SortDirection As ExtendedFieldSorting
    Get
    Set
Visual C++
public:
property ExtendedFieldSorting SortDirection {
    ExtendedFieldSorting get ();
    void set (ExtendedFieldSorting value);
}

Property Value

Type: ExtendedFieldSorting

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.SortFieldName Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..SortFieldName Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
SortFieldName

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortFieldName { get; set; }
Visual Basic
Public Property SortFieldName As String
    Get
    Set
Visual C++
public:
property String^ SortFieldName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


ExtendedFieldsSearchCondition.TenantIdentifier Property

[image]

A Sandcastle Documented Class Library
ExtendedFieldsSearchCondition..::..TenantIdentifier Property
ExtendedFieldsSearchCondition Class See Also Send Feedback
Tenant Identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantIdentifier { get; set; }
Visual Basic
Public Property TenantIdentifier As String
    Get
    Set
Visual C++
public:
property String^ TenantIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ExtendedFieldsSearchCondition Class
ExtendedFieldsSearchCondition Members
CelloSaaS.Model.DataManagement Namespace


FieldCondition Class

[image]

A Sandcastle Documented Class Library
FieldCondition Class
Members See Also Send Feedback
The class that inherits the interface "Icondition"

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FieldCondition : ICondition
Visual Basic
<SerializableAttribute>
Public Class FieldCondition
    Implements ICondition
Visual C++
[SerializableAttribute]
public ref class FieldCondition : ICondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..FieldCondition

See Also

FieldCondition Members
CelloSaaS.Model.DataManagement Namespace


FieldCondition Members

[image] [image]

A Sandcastle Documented Class Library
FieldCondition Members
FieldCondition Class Constructors Methods Properties See Also Send Feedback

The FieldCondition type exposes the following members.

Constructors

 | Name | Description
Public method | FieldCondition | Initializes a new instance of the FieldCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataType | Gets or sets the type of the data.
Public property | Value | Gets or sets the value

See Also

FieldCondition Class
CelloSaaS.Model.DataManagement Namespace


FieldCondition Constructor

[image]

A Sandcastle Documented Class Library
FieldCondition Constructor
FieldCondition Class See Also Send Feedback
Initializes a new instance of the FieldCondition class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldCondition()
Visual Basic
Public Sub New
Visual C++
public:
FieldCondition()

See Also

FieldCondition Class
FieldCondition Members
CelloSaaS.Model.DataManagement Namespace


FieldCondition Methods

[image] [image]

A Sandcastle Documented Class Library
FieldCondition Methods
FieldCondition Class See Also Send Feedback

The FieldCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FieldCondition Class
CelloSaaS.Model.DataManagement Namespace


FieldCondition Properties

[image] [image]

A Sandcastle Documented Class Library
FieldCondition Properties
FieldCondition Class See Also Send Feedback

The FieldCondition type exposes the following members.

Properties

 | Name | Description
Public property | DataType | Gets or sets the type of the data.
Public property | Value | Gets or sets the value

See Also

FieldCondition Class
CelloSaaS.Model.DataManagement Namespace


FieldCondition.DataType Property

[image]

A Sandcastle Documented Class Library
FieldCondition..::..DataType Property
FieldCondition Class See Also Send Feedback
Gets or sets the type of the data.

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedFieldDataType DataType { get; set; }
Visual Basic
Public Property DataType As ExtendedFieldDataType
    Get
    Set
Visual C++
public:
property ExtendedFieldDataType DataType {
    ExtendedFieldDataType get ();
    void set (ExtendedFieldDataType value);
}

Property Value

Type: ExtendedFieldDataType
The type of the data.

See Also

FieldCondition Class
FieldCondition Members
CelloSaaS.Model.DataManagement Namespace


FieldCondition.Value Property

[image]

A Sandcastle Documented Class Library
FieldCondition..::..Value Property
FieldCondition Class See Also Send Feedback
Gets or sets the value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICondition..::..Value

See Also

FieldCondition Class
FieldCondition Members
CelloSaaS.Model.DataManagement Namespace


FieldDataType Class

[image]

A Sandcastle Documented Class Library
FieldDataType Class
Members See Also Send Feedback
Field Data Type Properties

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FieldDataType
Visual Basic
<SerializableAttribute>
Public Class FieldDataType
Visual C++
[SerializableAttribute]
public ref class FieldDataType

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..FieldDataType

See Also

FieldDataType Members
CelloSaaS.Model.DataManagement Namespace


FieldDataType Members

[image] [image]

A Sandcastle Documented Class Library
FieldDataType Members
FieldDataType Class Constructors Methods Properties See Also Send Feedback

The FieldDataType type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDataType | Initializes a new instance of the FieldDataType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeIdentifier | This used to get or set the type Identifier
Public property | TypeName | This used to get or set type name

See Also

FieldDataType Class
CelloSaaS.Model.DataManagement Namespace


FieldDataType Constructor

[image]

A Sandcastle Documented Class Library
FieldDataType Constructor
FieldDataType Class See Also Send Feedback
Initializes a new instance of the FieldDataType class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldDataType()
Visual Basic
Public Sub New
Visual C++
public:
FieldDataType()

See Also

FieldDataType Class
FieldDataType Members
CelloSaaS.Model.DataManagement Namespace


FieldDataType Methods

[image] [image]

A Sandcastle Documented Class Library
FieldDataType Methods
FieldDataType Class See Also Send Feedback

The FieldDataType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FieldDataType Class
CelloSaaS.Model.DataManagement Namespace


FieldDataType Properties

[image] [image]

A Sandcastle Documented Class Library
FieldDataType Properties
FieldDataType Class See Also Send Feedback

The FieldDataType type exposes the following members.

Properties

 | Name | Description
Public property | TypeIdentifier | This used to get or set the type Identifier
Public property | TypeName | This used to get or set type name

See Also

FieldDataType Class
CelloSaaS.Model.DataManagement Namespace


FieldDataType.TypeIdentifier Property

[image]

A Sandcastle Documented Class Library
FieldDataType..::..TypeIdentifier Property
FieldDataType Class See Also Send Feedback
This used to get or set the type Identifier

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeIdentifier { get; set; }
Visual Basic
Public Property TypeIdentifier As String
    Get
    Set
Visual C++
public:
property String^ TypeIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FieldDataType Class
FieldDataType Members
CelloSaaS.Model.DataManagement Namespace


FieldDataType.TypeName Property

[image]

A Sandcastle Documented Class Library
FieldDataType..::..TypeName Property
FieldDataType Class See Also Send Feedback
This used to get or set type name

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FieldDataType Class
FieldDataType Members
CelloSaaS.Model.DataManagement Namespace


ICondition Interface

[image]

A Sandcastle Documented Class Library
ICondition Interface
Members See Also Send Feedback
Interface that defines the property "Value"

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ICondition
Visual Basic
Public Interface ICondition
Visual C++
public interface class ICondition

See Also

ICondition Members
CelloSaaS.Model.DataManagement Namespace


ICondition Members

[image] [image]

A Sandcastle Documented Class Library
ICondition Members
ICondition Interface Properties See Also Send Feedback

The ICondition type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value

See Also

ICondition Interface
CelloSaaS.Model.DataManagement Namespace


ICondition Properties

[image] [image]

A Sandcastle Documented Class Library
ICondition Properties
ICondition Interface See Also Send Feedback

The ICondition type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value

See Also

ICondition Interface
CelloSaaS.Model.DataManagement Namespace


ICondition.Value Property

[image]

A Sandcastle Documented Class Library
ICondition..::..Value Property
ICondition Interface See Also Send Feedback
Gets or sets the value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string Value { get; set; }
Visual Basic
Property Value As String
    Get
    Set
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ICondition Interface
ICondition Members
CelloSaaS.Model.DataManagement Namespace


ValueCondition Class

[image]

A Sandcastle Documented Class Library
ValueCondition Class
Members See Also Send Feedback
The class that inherits the interface "Icondition"

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ValueCondition : ICondition
Visual Basic
<SerializableAttribute>
Public Class ValueCondition
    Implements ICondition
Visual C++
[SerializableAttribute]
public ref class ValueCondition : ICondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.DataManagement..::..ValueCondition

See Also

ValueCondition Members
CelloSaaS.Model.DataManagement Namespace


ValueCondition Members

[image] [image]

A Sandcastle Documented Class Library
ValueCondition Members
ValueCondition Class Constructors Methods Properties See Also Send Feedback

The ValueCondition type exposes the following members.

Constructors

 | Name | Description
Public method | ValueCondition | Initializes a new instance of the ValueCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Value | Gets or sets the value

See Also

ValueCondition Class
CelloSaaS.Model.DataManagement Namespace


ValueCondition Constructor

[image]

A Sandcastle Documented Class Library
ValueCondition Constructor
ValueCondition Class See Also Send Feedback
Initializes a new instance of the ValueCondition class

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ValueCondition()
Visual Basic
Public Sub New
Visual C++
public:
ValueCondition()

See Also

ValueCondition Class
ValueCondition Members
CelloSaaS.Model.DataManagement Namespace


ValueCondition Methods

[image] [image]

A Sandcastle Documented Class Library
ValueCondition Methods
ValueCondition Class See Also Send Feedback

The ValueCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueCondition Class
CelloSaaS.Model.DataManagement Namespace


ValueCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ValueCondition Properties
ValueCondition Class See Also Send Feedback

The ValueCondition type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets or sets the value

See Also

ValueCondition Class
CelloSaaS.Model.DataManagement Namespace


ValueCondition.Value Property

[image]

A Sandcastle Documented Class Library
ValueCondition..::..Value Property
ValueCondition Class See Also Send Feedback
Gets or sets the value

Namespace: CelloSaaS.Model.DataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICondition..::..Value

See Also

ValueCondition Class
ValueCondition Members
CelloSaaS.Model.DataManagement Namespace


CelloSaaS.Model.Encryption Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.Encryption Namespace
Send Feedback

Classes

 | Class | Description
Public class | TenantKey | Tenant Key Properties


TenantKey Class

[image]

A Sandcastle Documented Class Library
TenantKey Class
Members See Also Send Feedback
Tenant Key Properties

Namespace: CelloSaaS.Model.Encryption
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantKey
Visual Basic
<SerializableAttribute>
Public Class TenantKey
Visual C++
[SerializableAttribute]
public ref class TenantKey

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Encryption..::..TenantKey

See Also

TenantKey Members
CelloSaaS.Model.Encryption Namespace


TenantKey Members

[image] [image]

A Sandcastle Documented Class Library
TenantKey Members
TenantKey Class Constructors Methods Properties See Also Send Feedback

The TenantKey type exposes the following members.

Constructors

 | Name | Description
Public method | TenantKey | Initializes a new instance of the TenantKey class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EncryptionKey | Gets or sets encryption key
Public property | PrivateKey | Gets or sets private key
Public property | PublicKey | Gets or sets public key
Public property | PublicPrivateKeyXML | Gets or sets the xml of public and private key

See Also

TenantKey Class
CelloSaaS.Model.Encryption Namespace


TenantKey Constructor

[image]

A Sandcastle Documented Class Library
TenantKey Constructor
TenantKey Class See Also Send Feedback
Initializes a new instance of the TenantKey class

Namespace: CelloSaaS.Model.Encryption
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantKey()
Visual Basic
Public Sub New
Visual C++
public:
TenantKey()

See Also

TenantKey Class
TenantKey Members
CelloSaaS.Model.Encryption Namespace


TenantKey Methods

[image] [image]

A Sandcastle Documented Class Library
TenantKey Methods
TenantKey Class See Also Send Feedback

The TenantKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantKey Class
CelloSaaS.Model.Encryption Namespace


TenantKey Properties

[image] [image]

A Sandcastle Documented Class Library
TenantKey Properties
TenantKey Class See Also Send Feedback

The TenantKey type exposes the following members.

Properties

 | Name | Description
Public property | EncryptionKey | Gets or sets encryption key
Public property | PrivateKey | Gets or sets private key
Public property | PublicKey | Gets or sets public key
Public property | PublicPrivateKeyXML | Gets or sets the xml of public and private key

See Also

TenantKey Class
CelloSaaS.Model.Encryption Namespace


TenantKey.EncryptionKey Property

[image]

A Sandcastle Documented Class Library
TenantKey..::..EncryptionKey Property
TenantKey Class See Also Send Feedback
Gets or sets encryption key

Namespace: CelloSaaS.Model.Encryption
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EncryptionKey { get; set; }
Visual Basic
Public Property EncryptionKey As String
    Get
    Set
Visual C++
public:
property String^ EncryptionKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantKey Class
TenantKey Members
CelloSaaS.Model.Encryption Namespace


TenantKey.PrivateKey Property

[image]

A Sandcastle Documented Class Library
TenantKey..::..PrivateKey Property
TenantKey Class See Also Send Feedback
Gets or sets private key

Namespace: CelloSaaS.Model.Encryption
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PrivateKey { get; set; }
Visual Basic
Public Property PrivateKey As String
    Get
    Set
Visual C++
public:
property String^ PrivateKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantKey Class
TenantKey Members
CelloSaaS.Model.Encryption Namespace


TenantKey.PublicKey Property

[image]

A Sandcastle Documented Class Library
TenantKey..::..PublicKey Property
TenantKey Class See Also Send Feedback
Gets or sets public key

Namespace: CelloSaaS.Model.Encryption
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PublicKey { get; set; }
Visual Basic
Public Property PublicKey As String
    Get
    Set
Visual C++
public:
property String^ PublicKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantKey Class
TenantKey Members
CelloSaaS.Model.Encryption Namespace


TenantKey.PublicPrivateKeyXML Property

[image]

A Sandcastle Documented Class Library
TenantKey..::..PublicPrivateKeyXML Property
TenantKey Class See Also Send Feedback
Gets or sets the xml of public and private key

Namespace: CelloSaaS.Model.Encryption
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PublicPrivateKeyXML { get; set; }
Visual Basic
Public Property PublicPrivateKeyXML As String
    Get
    Set
Visual C++
public:
property String^ PublicPrivateKeyXML {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantKey Class
TenantKey Members
CelloSaaS.Model.Encryption Namespace


CelloSaaS.Model.EntityExtnManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.EntityExtnManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | EntityExtnAvailableColumnDetails | Entity extn available column details class
Public class | EntityExtnColumnDetails | The EntityExtnColumnDetails Model
Public class | EntityExtnColumnMetadata | The EntityExtnColumnMetadata Model


EntityExtnAvailableColumnDetails Class

[image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails Class
Members See Also Send Feedback
Entity extn available column details class

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityExtnAvailableColumnDetails
Visual Basic
<SerializableAttribute>
Public Class EntityExtnAvailableColumnDetails
Visual C++
[SerializableAttribute]
public ref class EntityExtnAvailableColumnDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.EntityExtnManagement..::..EntityExtnAvailableColumnDetails

See Also

EntityExtnAvailableColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnAvailableColumnDetails Members

[image] [image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails Members
EntityExtnAvailableColumnDetails Class Constructors Methods Properties See Also Send Feedback

The EntityExtnAvailableColumnDetails type exposes the following members.

Constructors

 | Name | Description
Public method | EntityExtnAvailableColumnDetails | Initializes a new instance of the EntityExtnAvailableColumnDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntityExtnAvailableColumnId | EntityExtnColumnDetails Identifier
Public property | EntityExtnAvailableColumnName | ColumnName of the extended Field

See Also

EntityExtnAvailableColumnDetails Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnAvailableColumnDetails Constructor

[image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails Constructor
EntityExtnAvailableColumnDetails Class See Also Send Feedback
Initializes a new instance of the EntityExtnAvailableColumnDetails class

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityExtnAvailableColumnDetails()
Visual Basic
Public Sub New
Visual C++
public:
EntityExtnAvailableColumnDetails()

See Also

EntityExtnAvailableColumnDetails Class
EntityExtnAvailableColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnAvailableColumnDetails Methods

[image] [image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails Methods
EntityExtnAvailableColumnDetails Class See Also Send Feedback

The EntityExtnAvailableColumnDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityExtnAvailableColumnDetails Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnAvailableColumnDetails Properties

[image] [image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails Properties
EntityExtnAvailableColumnDetails Class See Also Send Feedback

The EntityExtnAvailableColumnDetails type exposes the following members.

Properties

 | Name | Description
Public property | EntityExtnAvailableColumnId | EntityExtnColumnDetails Identifier
Public property | EntityExtnAvailableColumnName | ColumnName of the extended Field

See Also

EntityExtnAvailableColumnDetails Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnAvailableColumnDetails.EntityExtnAvailableColumnId Property

[image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails..::..EntityExtnAvailableColumnId Property
EntityExtnAvailableColumnDetails Class See Also Send Feedback
EntityExtnColumnDetails Identifier

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityExtnAvailableColumnId { get; set; }
Visual Basic
Public Property EntityExtnAvailableColumnId As String
    Get
    Set
Visual C++
public:
property String^ EntityExtnAvailableColumnId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnAvailableColumnDetails Class
EntityExtnAvailableColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnAvailableColumnDetails.EntityExtnAvailableColumnName Property

[image]

A Sandcastle Documented Class Library
EntityExtnAvailableColumnDetails..::..EntityExtnAvailableColumnName Property
EntityExtnAvailableColumnDetails Class See Also Send Feedback
ColumnName of the extended Field

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityExtnAvailableColumnName { get; set; }
Visual Basic
Public Property EntityExtnAvailableColumnName As String
    Get
    Set
Visual C++
public:
property String^ EntityExtnAvailableColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnAvailableColumnDetails Class
EntityExtnAvailableColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails Class

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails Class
Members See Also Send Feedback
The EntityExtnColumnDetails Model

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityExtnColumnDetails
Visual Basic
<SerializableAttribute>
Public Class EntityExtnColumnDetails
Visual C++
[SerializableAttribute]
public ref class EntityExtnColumnDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.EntityExtnManagement..::..EntityExtnColumnDetails

See Also

EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails Members

[image] [image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails Members
EntityExtnColumnDetails Class Constructors Methods Properties See Also Send Feedback

The EntityExtnColumnDetails type exposes the following members.

Constructors

 | Name | Description
Public method | EntityExtnColumnDetails | Initializes a new instance of the EntityExtnColumnDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnMetadataId | ColumnMetaDataId of the ExtendedFields
Public property | ColumnName | ColumnName for the extended Field
Public property | EntityId | EntityId Identifier
Public property | Id | EntityExtnColumnDetails Identifier
Public property | IsInUse | status of the extended Field

See Also

EntityExtnColumnDetails Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails Constructor

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails Constructor
EntityExtnColumnDetails Class See Also Send Feedback
Initializes a new instance of the EntityExtnColumnDetails class

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityExtnColumnDetails()
Visual Basic
Public Sub New
Visual C++
public:
EntityExtnColumnDetails()

See Also

EntityExtnColumnDetails Class
EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails Methods

[image] [image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails Methods
EntityExtnColumnDetails Class See Also Send Feedback

The EntityExtnColumnDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityExtnColumnDetails Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails Properties

[image] [image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails Properties
EntityExtnColumnDetails Class See Also Send Feedback

The EntityExtnColumnDetails type exposes the following members.

Properties

 | Name | Description
Public property | ColumnMetadataId | ColumnMetaDataId of the ExtendedFields
Public property | ColumnName | ColumnName for the extended Field
Public property | EntityId | EntityId Identifier
Public property | Id | EntityExtnColumnDetails Identifier
Public property | IsInUse | status of the extended Field

See Also

EntityExtnColumnDetails Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails.ColumnMetadataId Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails..::..ColumnMetadataId Property
EntityExtnColumnDetails Class See Also Send Feedback
ColumnMetaDataId of the ExtendedFields

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ColumnMetadataId { get; set; }
Visual Basic
Public Property ColumnMetadataId As String
    Get
    Set
Visual C++
public:
property String^ ColumnMetadataId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnDetails Class
EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails.ColumnName Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails..::..ColumnName Property
EntityExtnColumnDetails Class See Also Send Feedback
ColumnName for the extended Field

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ColumnName { get; set; }
Visual Basic
Public Property ColumnName As String
    Get
    Set
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnDetails Class
EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails..::..EntityId Property
EntityExtnColumnDetails Class See Also Send Feedback
EntityId Identifier

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnDetails Class
EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails.Id Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails..::..Id Property
EntityExtnColumnDetails Class See Also Send Feedback
EntityExtnColumnDetails Identifier

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnDetails Class
EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnDetails.IsInUse Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnDetails..::..IsInUse Property
EntityExtnColumnDetails Class See Also Send Feedback
status of the extended Field

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsInUse { get; set; }
Visual Basic
Public Property IsInUse As Boolean
    Get
    Set
Visual C++
public:
property bool IsInUse {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityExtnColumnDetails Class
EntityExtnColumnDetails Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata Class

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata Class
Members See Also Send Feedback
The EntityExtnColumnMetadata Model

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityExtnColumnMetadata
Visual Basic
<SerializableAttribute>
Public Class EntityExtnColumnMetadata
Visual C++
[SerializableAttribute]
public ref class EntityExtnColumnMetadata

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.EntityExtnManagement..::..EntityExtnColumnMetadata

See Also

EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata Members

[image] [image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata Members
EntityExtnColumnMetadata Class Constructors Methods Properties See Also Send Feedback

The EntityExtnColumnMetadata type exposes the following members.

Constructors

 | Name | Description
Public method | EntityExtnColumnMetadata | Initializes a new instance of the EntityExtnColumnMetadata class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataType | DataType of the Metadata of ExtendedFields
Public property | Dimension | Length of the extended Field
Public property | EntityId | EntityId Identifier
Public property | Id | EntityExtnColumnMetadata Identifier
Public property | NoOfColumn | No of column alloted for the extended Field

See Also

EntityExtnColumnMetadata Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata Constructor

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata Constructor
EntityExtnColumnMetadata Class See Also Send Feedback
Initializes a new instance of the EntityExtnColumnMetadata class

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityExtnColumnMetadata()
Visual Basic
Public Sub New
Visual C++
public:
EntityExtnColumnMetadata()

See Also

EntityExtnColumnMetadata Class
EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata Methods

[image] [image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata Methods
EntityExtnColumnMetadata Class See Also Send Feedback

The EntityExtnColumnMetadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityExtnColumnMetadata Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata Properties

[image] [image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata Properties
EntityExtnColumnMetadata Class See Also Send Feedback

The EntityExtnColumnMetadata type exposes the following members.

Properties

 | Name | Description
Public property | DataType | DataType of the Metadata of ExtendedFields
Public property | Dimension | Length of the extended Field
Public property | EntityId | EntityId Identifier
Public property | Id | EntityExtnColumnMetadata Identifier
Public property | NoOfColumn | No of column alloted for the extended Field

See Also

EntityExtnColumnMetadata Class
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata.DataType Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata..::..DataType Property
EntityExtnColumnMetadata Class See Also Send Feedback
DataType of the Metadata of ExtendedFields

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataType { get; set; }
Visual Basic
Public Property DataType As String
    Get
    Set
Visual C++
public:
property String^ DataType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnMetadata Class
EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata.Dimension Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata..::..Dimension Property
EntityExtnColumnMetadata Class See Also Send Feedback
Length of the extended Field

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Dimension { get; set; }
Visual Basic
Public Property Dimension As String
    Get
    Set
Visual C++
public:
property String^ Dimension {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnMetadata Class
EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata.EntityId Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata..::..EntityId Property
EntityExtnColumnMetadata Class See Also Send Feedback
EntityId Identifier

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnMetadata Class
EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata.Id Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata..::..Id Property
EntityExtnColumnMetadata Class See Also Send Feedback
EntityExtnColumnMetadata Identifier

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EntityExtnColumnMetadata Class
EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


EntityExtnColumnMetadata.NoOfColumn Property

[image]

A Sandcastle Documented Class Library
EntityExtnColumnMetadata..::..NoOfColumn Property
EntityExtnColumnMetadata Class See Also Send Feedback
No of column alloted for the extended Field

Namespace: CelloSaaS.Model.EntityExtnManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int NoOfColumn { get; set; }
Visual Basic
Public Property NoOfColumn As Integer
    Get
    Set
Visual C++
public:
property int NoOfColumn {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

EntityExtnColumnMetadata Class
EntityExtnColumnMetadata Members
CelloSaaS.Model.EntityExtnManagement Namespace


CelloSaaS.Model.LicenseManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.LicenseManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | Feature | Feature model
Public class | LicenseFeature | License Feature class
Public class | LicenseModule | License module class
Public class | LicensePackage | License package model
Public class | LicenseServiceMapping | License Service Mapping class
Public class | LicenseUsage | License usage class
Public class | MeteringLog | Metering Log model
Public class | MeteringSearchCondition | Metering search condition class
Public class | MeteringSearchResult | Metering search result class
Public class | Module | Module class
Public class | PackageDetails | Subscription Package details model
Public class | PackageFeature | Package feature class
Public class | PackageModule | Package module class
Public class | PackageService | Package service modle
Public class | PackageUsage | Package usage class
Public class | Service | Service model
Public class | TenantLicense | Tenant License class
Public class | TenantLicenseSearchCondition | Tenant license search condition class
Public class | TenantServiceMapping | Tenant service mapping class
Public class | Usage | Usage model.
Public class | UsageConstants | Usage constants
Public class | UsageDetail | Usage Details
Public class | UsageSearchCondition | License usage search condition
Public class | UsageSearchResult | License usage search result

Enumerations

 | Enumeration | Description
Public enumeration | TenantLicenseStatus | Tenant license status enumeration


Feature Class

[image]

A Sandcastle Documented Class Library
Feature Class
Members See Also Send Feedback
Feature model

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Feature
Visual Basic
<SerializableAttribute>
Public Class Feature
Visual C++
[SerializableAttribute]
public ref class Feature

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..Feature

See Also

Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature Members

[image] [image]

A Sandcastle Documented Class Library
Feature Members
Feature Class Constructors Methods Properties See Also Send Feedback

The Feature type exposes the following members.

Constructors

 | Name | Description
Public method | Feature | Initializes a new instance of the Feature class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | FeatureCode | Gets or sets fature code.
Public property | FeatureModuleCode | Gets or sets featuremodulecode.
Public property | FeatureName | Gets or sets feature name.
Public property | Status | Gets or sets status.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.

See Also

Feature Class
CelloSaaS.Model.LicenseManagement Namespace


Feature Constructor

[image]

A Sandcastle Documented Class Library
Feature Constructor
Feature Class See Also Send Feedback
Initializes a new instance of the Feature class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Feature()
Visual Basic
Public Sub New
Visual C++
public:
Feature()

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature Methods

[image] [image]

A Sandcastle Documented Class Library
Feature Methods
Feature Class See Also Send Feedback

The Feature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Feature Class
CelloSaaS.Model.LicenseManagement Namespace


Feature Properties

[image] [image]

A Sandcastle Documented Class Library
Feature Properties
Feature Class See Also Send Feedback

The Feature type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | FeatureCode | Gets or sets fature code.
Public property | FeatureModuleCode | Gets or sets featuremodulecode.
Public property | FeatureName | Gets or sets feature name.
Public property | Status | Gets or sets status.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.

See Also

Feature Class
CelloSaaS.Model.LicenseManagement Namespace


Feature.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Feature..::..CreatedBy Property
Feature Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Feature..::..CreatedOn Property
Feature Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.FeatureCode Property

[image]

A Sandcastle Documented Class Library
Feature..::..FeatureCode Property
Feature Class See Also Send Feedback
Gets or sets fature code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureCode { get; set; }
Visual Basic
Public Property FeatureCode As String
    Get
    Set
Visual C++
public:
property String^ FeatureCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.FeatureModuleCode Property

[image]

A Sandcastle Documented Class Library
Feature..::..FeatureModuleCode Property
Feature Class See Also Send Feedback
Gets or sets featuremodulecode.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureModuleCode { get; set; }
Visual Basic
Public Property FeatureModuleCode As String
    Get
    Set
Visual C++
public:
property String^ FeatureModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.FeatureName Property

[image]

A Sandcastle Documented Class Library
Feature..::..FeatureName Property
Feature Class See Also Send Feedback
Gets or sets feature name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureName { get; set; }
Visual Basic
Public Property FeatureName As String
    Get
    Set
Visual C++
public:
property String^ FeatureName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.Status Property

[image]

A Sandcastle Documented Class Library
Feature..::..Status Property
Feature Class See Also Send Feedback
Gets or sets status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Feature..::..UpdatedBy Property
Feature Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


Feature.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Feature..::..UpdatedOn Property
Feature Class See Also Send Feedback
Gets or sets updated on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Feature Class
Feature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature Class

[image]

A Sandcastle Documented Class Library
LicenseFeature Class
Members See Also Send Feedback
License Feature class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicenseFeature
Visual Basic
<SerializableAttribute>
Public Class LicenseFeature
Visual C++
[SerializableAttribute]
public ref class LicenseFeature

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..LicenseFeature

See Also

LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature Members

[image] [image]

A Sandcastle Documented Class Library
LicenseFeature Members
LicenseFeature Class Constructors Methods Properties See Also Send Feedback

The LicenseFeature type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseFeature | Initializes a new instance of the LicenseFeature class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created on.
Public property | CreatedOn | Gets or sets
Public property | FeatureCode | Gets or sets feature code
Public property | LicenseFeatureID | Gets or sets license feature id.
Public property | Status | Gets or sets status.
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.
Public property | ValidityEndDate | Gets or sets validity end date.
Public property | ValidityStartDate | Gets or sets validity start date.

See Also

LicenseFeature Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature Constructor

[image]

A Sandcastle Documented Class Library
LicenseFeature Constructor
LicenseFeature Class See Also Send Feedback
Initializes a new instance of the LicenseFeature class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseFeature()
Visual Basic
Public Sub New
Visual C++
public:
LicenseFeature()

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseFeature Methods
LicenseFeature Class See Also Send Feedback

The LicenseFeature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LicenseFeature Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature Properties

[image] [image]

A Sandcastle Documented Class Library
LicenseFeature Properties
LicenseFeature Class See Also Send Feedback

The LicenseFeature type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created on.
Public property | CreatedOn | Gets or sets
Public property | FeatureCode | Gets or sets feature code
Public property | LicenseFeatureID | Gets or sets license feature id.
Public property | Status | Gets or sets status.
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.
Public property | ValidityEndDate | Gets or sets validity end date.
Public property | ValidityStartDate | Gets or sets validity start date.

See Also

LicenseFeature Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..CreatedBy Property
LicenseFeature Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..CreatedOn Property
LicenseFeature Class See Also Send Feedback
Gets or sets

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.FeatureCode Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..FeatureCode Property
LicenseFeature Class See Also Send Feedback
Gets or sets feature code

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureCode { get; set; }
Visual Basic
Public Property FeatureCode As String
    Get
    Set
Visual C++
public:
property String^ FeatureCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.LicenseFeatureID Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..LicenseFeatureID Property
LicenseFeature Class See Also Send Feedback
Gets or sets license feature id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LicenseFeatureID { get; set; }
Visual Basic
Public Property LicenseFeatureID As String
    Get
    Set
Visual C++
public:
property String^ LicenseFeatureID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.Status Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..Status Property
LicenseFeature Class See Also Send Feedback
Gets or sets status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.TenantLicenseCode Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..TenantLicenseCode Property
LicenseFeature Class See Also Send Feedback
Gets or sets tenant license code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantLicenseCode { get; set; }
Visual Basic
Public Property TenantLicenseCode As String
    Get
    Set
Visual C++
public:
property String^ TenantLicenseCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..UpdatedBy Property
LicenseFeature Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..UpdatedOn Property
LicenseFeature Class See Also Send Feedback
Gets or sets updated on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.ValidityEndDate Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..ValidityEndDate Property
LicenseFeature Class See Also Send Feedback
Gets or sets validity end date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ValidityEndDate { get; set; }
Visual Basic
Public Property ValidityEndDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ValidityEndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseFeature.ValidityStartDate Property

[image]

A Sandcastle Documented Class Library
LicenseFeature..::..ValidityStartDate Property
LicenseFeature Class See Also Send Feedback
Gets or sets validity start date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ValidityStartDate { get; set; }
Visual Basic
Public Property ValidityStartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidityStartDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseFeature Class
LicenseFeature Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule Class

[image]

A Sandcastle Documented Class Library
LicenseModule Class
Members See Also Send Feedback
License module class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicenseModule
Visual Basic
<SerializableAttribute>
Public Class LicenseModule
Visual C++
[SerializableAttribute]
public ref class LicenseModule

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..LicenseModule

See Also

LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule Members

[image] [image]

A Sandcastle Documented Class Library
LicenseModule Members
LicenseModule Class Constructors Methods Properties See Also Send Feedback

The LicenseModule type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseModule | Initializes a new instance of the LicenseModule class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | ModuleLicenseId | Gets or sets module license id
Public property | NumberOfUsers | Gets or sets number of user.
Public property | PurchasedModuleCode | Gets or sets module code.
Public property | Status | Gets or sets status
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on
Public property | ValidityEnd | Gets or sets validity end date.
Public property | ValidityStart | Gets or sets validity start date.

See Also

LicenseModule Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule Constructor

[image]

A Sandcastle Documented Class Library
LicenseModule Constructor
LicenseModule Class See Also Send Feedback
Initializes a new instance of the LicenseModule class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseModule()
Visual Basic
Public Sub New
Visual C++
public:
LicenseModule()

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseModule Methods
LicenseModule Class See Also Send Feedback

The LicenseModule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LicenseModule Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule Properties

[image] [image]

A Sandcastle Documented Class Library
LicenseModule Properties
LicenseModule Class See Also Send Feedback

The LicenseModule type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | ModuleLicenseId | Gets or sets module license id
Public property | NumberOfUsers | Gets or sets number of user.
Public property | PurchasedModuleCode | Gets or sets module code.
Public property | Status | Gets or sets status
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on
Public property | ValidityEnd | Gets or sets validity end date.
Public property | ValidityStart | Gets or sets validity start date.

See Also

LicenseModule Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..CreatedBy Property
LicenseModule Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..CreatedOn Property
LicenseModule Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.ModuleLicenseId Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..ModuleLicenseId Property
LicenseModule Class See Also Send Feedback
Gets or sets module license id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleLicenseId { get; set; }
Visual Basic
Public Property ModuleLicenseId As String
    Get
    Set
Visual C++
public:
property String^ ModuleLicenseId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.NumberOfUsers Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..NumberOfUsers Property
LicenseModule Class See Also Send Feedback
Gets or sets number of user.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> NumberOfUsers { get; set; }
Visual Basic
Public Property NumberOfUsers As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> NumberOfUsers {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.PurchasedModuleCode Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..PurchasedModuleCode Property
LicenseModule Class See Also Send Feedback
Gets or sets module code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PurchasedModuleCode { get; set; }
Visual Basic
Public Property PurchasedModuleCode As String
    Get
    Set
Visual C++
public:
property String^ PurchasedModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.Status Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..Status Property
LicenseModule Class See Also Send Feedback
Gets or sets status

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.TenantLicenseCode Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..TenantLicenseCode Property
LicenseModule Class See Also Send Feedback
Gets or sets tenant license code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantLicenseCode { get; set; }
Visual Basic
Public Property TenantLicenseCode As String
    Get
    Set
Visual C++
public:
property String^ TenantLicenseCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..UpdatedBy Property
LicenseModule Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..UpdatedOn Property
LicenseModule Class See Also Send Feedback
Gets or sets updated on

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.ValidityEnd Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..ValidityEnd Property
LicenseModule Class See Also Send Feedback
Gets or sets validity end date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ValidityEnd { get; set; }
Visual Basic
Public Property ValidityEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ValidityEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseModule.ValidityStart Property

[image]

A Sandcastle Documented Class Library
LicenseModule..::..ValidityStart Property
LicenseModule Class See Also Send Feedback
Gets or sets validity start date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ValidityStart { get; set; }
Visual Basic
Public Property ValidityStart As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidityStart {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseModule Class
LicenseModule Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage Class

[image]

A Sandcastle Documented Class Library
LicensePackage Class
Members See Also Send Feedback
License package model

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicensePackage : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class LicensePackage
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class LicensePackage : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.LicenseManagement..::..LicensePackage

See Also

LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage Members

[image] [image]

A Sandcastle Documented Class Library
LicensePackage Members
LicensePackage Class Constructors Methods Properties See Also Send Feedback

The LicensePackage type exposes the following members.

Constructors

 | Name | Description
Public method | LicensePackage | Initializes a new instance of the LicensePackage class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | Description | Gets or sets description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExpiryDays | Gets the trial period days
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegrateForBilling | Tells whether this package billing is managed by third part billing providers
Public property | IsEvaluation | True if this package is for evaluation only.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LicensepackageId | Gets or sets license package id..
Public property | Name | Gets or sets name.
Public property | Status | Gets or sets status.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updaded on.

See Also

LicensePackage Class
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage Constructor

[image]

A Sandcastle Documented Class Library
LicensePackage Constructor
LicensePackage Class See Also Send Feedback
Initializes a new instance of the LicensePackage class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicensePackage()
Visual Basic
Public Sub New
Visual C++
public:
LicensePackage()

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage Methods

[image] [image]

A Sandcastle Documented Class Library
LicensePackage Methods
LicensePackage Class See Also Send Feedback

The LicensePackage type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

LicensePackage Class
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage Properties

[image] [image]

A Sandcastle Documented Class Library
LicensePackage Properties
LicensePackage Class See Also Send Feedback

The LicensePackage type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | Description | Gets or sets description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExpiryDays | Gets the trial period days
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegrateForBilling | Tells whether this package billing is managed by third part billing providers
Public property | IsEvaluation | True if this package is for evaluation only.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LicensepackageId | Gets or sets license package id..
Public property | Name | Gets or sets name.
Public property | Status | Gets or sets status.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updaded on.

See Also

LicensePackage Class
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..CreatedBy Property
LicensePackage Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..CreatedOn Property
LicensePackage Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.Description Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..Description Property
LicensePackage Class See Also Send Feedback
Gets or sets description

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.ExpiryDays Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..ExpiryDays Property
LicensePackage Class See Also Send Feedback
Gets the trial period days

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ExpiryDays { get; set; }
Visual Basic
Public Property ExpiryDays As Integer
    Get
    Set
Visual C++
public:
property int ExpiryDays {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.IntegrateForBilling Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..IntegrateForBilling Property
LicensePackage Class See Also Send Feedback
Tells whether this package billing is managed by third part billing providers

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IntegrateForBilling { get; set; }
Visual Basic
Public Property IntegrateForBilling As Boolean
    Get
    Set
Visual C++
public:
property bool IntegrateForBilling {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.IsEvaluation Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..IsEvaluation Property
LicensePackage Class See Also Send Feedback
True if this package is for evaluation only.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsEvaluation { get; set; }
Visual Basic
Public Property IsEvaluation As Boolean
    Get
    Set
Visual C++
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.LicensepackageId Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..LicensepackageId Property
LicensePackage Class See Also Send Feedback
Gets or sets license package id..

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LicensepackageId { get; set; }
Visual Basic
Public Property LicensepackageId As String
    Get
    Set
Visual C++
public:
property String^ LicensepackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.Name Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..Name Property
LicensePackage Class See Also Send Feedback
Gets or sets name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.Status Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..Status Property
LicensePackage Class See Also Send Feedback
Gets or sets status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.TenantId Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..TenantId Property
LicensePackage Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..UpdatedBy Property
LicensePackage Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicensePackage.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LicensePackage..::..UpdatedOn Property
LicensePackage Class See Also Send Feedback
Gets or sets updaded on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicensePackage Class
LicensePackage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping Class

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping Class
Members See Also Send Feedback
License Service Mapping class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicenseServiceMapping
Visual Basic
<SerializableAttribute>
Public Class LicenseServiceMapping
Visual C++
[SerializableAttribute]
public ref class LicenseServiceMapping

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..LicenseServiceMapping

See Also

LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping Members

[image] [image]

A Sandcastle Documented Class Library
LicenseServiceMapping Members
LicenseServiceMapping Class Constructors Methods Properties See Also Send Feedback

The LicenseServiceMapping type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseServiceMapping | Initializes a new instance of the LicenseServiceMapping class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | LicenseServiceMappingId | Gets or sets service license id
Public property | PurchasedServiceCode | Gets or sets service code.
Public property | Status | Gets or sets status
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on
Public property | ValidityEnd | Gets or sets validity end date.
Public property | ValidityStart | Gets or sets validity start date.

See Also

LicenseServiceMapping Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping Constructor

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping Constructor
LicenseServiceMapping Class See Also Send Feedback
Initializes a new instance of the LicenseServiceMapping class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseServiceMapping()
Visual Basic
Public Sub New
Visual C++
public:
LicenseServiceMapping()

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseServiceMapping Methods
LicenseServiceMapping Class See Also Send Feedback

The LicenseServiceMapping type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LicenseServiceMapping Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping Properties

[image] [image]

A Sandcastle Documented Class Library
LicenseServiceMapping Properties
LicenseServiceMapping Class See Also Send Feedback

The LicenseServiceMapping type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | LicenseServiceMappingId | Gets or sets service license id
Public property | PurchasedServiceCode | Gets or sets service code.
Public property | Status | Gets or sets status
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on
Public property | ValidityEnd | Gets or sets validity end date.
Public property | ValidityStart | Gets or sets validity start date.

See Also

LicenseServiceMapping Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..CreatedBy Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..CreatedOn Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.LicenseServiceMappingId Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..LicenseServiceMappingId Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets service license id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LicenseServiceMappingId { get; set; }
Visual Basic
Public Property LicenseServiceMappingId As String
    Get
    Set
Visual C++
public:
property String^ LicenseServiceMappingId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.PurchasedServiceCode Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..PurchasedServiceCode Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets service code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PurchasedServiceCode { get; set; }
Visual Basic
Public Property PurchasedServiceCode As String
    Get
    Set
Visual C++
public:
property String^ PurchasedServiceCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.Status Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..Status Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets status

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.TenantLicenseCode Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..TenantLicenseCode Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets tenant license code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantLicenseCode { get; set; }
Visual Basic
Public Property TenantLicenseCode As String
    Get
    Set
Visual C++
public:
property String^ TenantLicenseCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..UpdatedBy Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..UpdatedOn Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets updated on

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.ValidityEnd Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..ValidityEnd Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets validity end date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ValidityEnd { get; set; }
Visual Basic
Public Property ValidityEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ValidityEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseServiceMapping.ValidityStart Property

[image]

A Sandcastle Documented Class Library
LicenseServiceMapping..::..ValidityStart Property
LicenseServiceMapping Class See Also Send Feedback
Gets or sets validity start date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ValidityStart { get; set; }
Visual Basic
Public Property ValidityStart As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidityStart {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseServiceMapping Class
LicenseServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage Class

[image]

A Sandcastle Documented Class Library
LicenseUsage Class
Members See Also Send Feedback
License usage class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicenseUsage
Visual Basic
<SerializableAttribute>
Public Class LicenseUsage
Visual C++
[SerializableAttribute]
public ref class LicenseUsage

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..LicenseUsage

See Also

LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage Members

[image] [image]

A Sandcastle Documented Class Library
LicenseUsage Members
LicenseUsage Class Constructors Methods Properties See Also Send Feedback

The LicenseUsage type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseUsage | Initializes a new instance of the LicenseUsage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowOverUsage | Gets or sets allow over usage.
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | LicenseUsageCode | Gets or sets license usage code.
Public property | MaximumCapacity | Gets or sets maximum capacity.
Public property | MinimumCapacity | Gets or sets minimum capacity
Public property | ModuleCode | Gets or sets module code.
Public property | NumberPurchased | Gets or sets number purchased.
Public property | PaymentTypeCode | Gets or sets payment type code.
Public property | Status | Gets or sets status.
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.
Public property | UsageCode | Gets or sets usage code.
Public property | UsageName | Gets or sets usage name.

See Also

LicenseUsage Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage Constructor

[image]

A Sandcastle Documented Class Library
LicenseUsage Constructor
LicenseUsage Class See Also Send Feedback
Initializes a new instance of the LicenseUsage class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseUsage()
Visual Basic
Public Sub New
Visual C++
public:
LicenseUsage()

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseUsage Methods
LicenseUsage Class See Also Send Feedback

The LicenseUsage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LicenseUsage Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage Properties

[image] [image]

A Sandcastle Documented Class Library
LicenseUsage Properties
LicenseUsage Class See Also Send Feedback

The LicenseUsage type exposes the following members.

Properties

 | Name | Description
Public property | AllowOverUsage | Gets or sets allow over usage.
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | LicenseUsageCode | Gets or sets license usage code.
Public property | MaximumCapacity | Gets or sets maximum capacity.
Public property | MinimumCapacity | Gets or sets minimum capacity
Public property | ModuleCode | Gets or sets module code.
Public property | NumberPurchased | Gets or sets number purchased.
Public property | PaymentTypeCode | Gets or sets payment type code.
Public property | Status | Gets or sets status.
Public property | TenantLicenseCode | Gets or sets tenant license code.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.
Public property | UsageCode | Gets or sets usage code.
Public property | UsageName | Gets or sets usage name.

See Also

LicenseUsage Class
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.AllowOverUsage Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..AllowOverUsage Property
LicenseUsage Class See Also Send Feedback
Gets or sets allow over usage.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> AllowOverUsage { get; set; }
Visual Basic
Public Property AllowOverUsage As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> AllowOverUsage {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..CreatedBy Property
LicenseUsage Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..CreatedOn Property
LicenseUsage Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.LicenseUsageCode Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..LicenseUsageCode Property
LicenseUsage Class See Also Send Feedback
Gets or sets license usage code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LicenseUsageCode { get; set; }
Visual Basic
Public Property LicenseUsageCode As String
    Get
    Set
Visual C++
public:
property String^ LicenseUsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.MaximumCapacity Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..MaximumCapacity Property
LicenseUsage Class See Also Send Feedback
Gets or sets maximum capacity.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MaximumCapacity { get; set; }
Visual Basic
Public Property MaximumCapacity As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaximumCapacity {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.MinimumCapacity Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..MinimumCapacity Property
LicenseUsage Class See Also Send Feedback
Gets or sets minimum capacity

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MinimumCapacity { get; set; }
Visual Basic
Public Property MinimumCapacity As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinimumCapacity {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.ModuleCode Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..ModuleCode Property
LicenseUsage Class See Also Send Feedback
Gets or sets module code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleCode { get; set; }
Visual Basic
Public Property ModuleCode As String
    Get
    Set
Visual C++
public:
property String^ ModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.NumberPurchased Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..NumberPurchased Property
LicenseUsage Class See Also Send Feedback
Gets or sets number purchased.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> NumberPurchased { get; set; }
Visual Basic
Public Property NumberPurchased As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> NumberPurchased {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.PaymentTypeCode Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..PaymentTypeCode Property
LicenseUsage Class See Also Send Feedback
Gets or sets payment type code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PaymentTypeCode { get; set; }
Visual Basic
Public Property PaymentTypeCode As String
    Get
    Set
Visual C++
public:
property String^ PaymentTypeCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.Status Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..Status Property
LicenseUsage Class See Also Send Feedback
Gets or sets status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.TenantLicenseCode Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..TenantLicenseCode Property
LicenseUsage Class See Also Send Feedback
Gets or sets tenant license code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantLicenseCode { get; set; }
Visual Basic
Public Property TenantLicenseCode As String
    Get
    Set
Visual C++
public:
property String^ TenantLicenseCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..UpdatedBy Property
LicenseUsage Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..UpdatedOn Property
LicenseUsage Class See Also Send Feedback
Gets or sets updated on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.UsageCode Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..UsageCode Property
LicenseUsage Class See Also Send Feedback
Gets or sets usage code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageCode { get; set; }
Visual Basic
Public Property UsageCode As String
    Get
    Set
Visual C++
public:
property String^ UsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


LicenseUsage.UsageName Property

[image]

A Sandcastle Documented Class Library
LicenseUsage..::..UsageName Property
LicenseUsage Class See Also Send Feedback
Gets or sets usage name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageName { get; set; }
Visual Basic
Public Property UsageName As String
    Get
    Set
Visual C++
public:
property String^ UsageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LicenseUsage Class
LicenseUsage Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog Class

[image]

A Sandcastle Documented Class Library
MeteringLog Class
Members See Also Send Feedback
Metering Log model

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MeteringLog
Visual Basic
<SerializableAttribute>
Public Class MeteringLog
Visual C++
[SerializableAttribute]
public ref class MeteringLog

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..MeteringLog

See Also

MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog Members

[image] [image]

A Sandcastle Documented Class Library
MeteringLog Members
MeteringLog Class Constructors Methods Properties See Also Send Feedback

The MeteringLog type exposes the following members.

Constructors

 | Name | Description
Public method | MeteringLog | Initializes a new instance of the MeteringLog class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Amount | Gets or sets the usage amount
Public property | Id | Gets or sets the Metering Log Identifeir
Public property | LoggedBy | Gets or sets the identifier of user who created log
Public property | LoggedDate | Gets or sets the date time of log created
Public property | TenantId | Gets or sets the Tenant Identifeir
Public property | UsageCode | Gets or sets usag code

See Also

MeteringLog Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog Constructor

[image]

A Sandcastle Documented Class Library
MeteringLog Constructor
MeteringLog Class See Also Send Feedback
Initializes a new instance of the MeteringLog class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MeteringLog()
Visual Basic
Public Sub New
Visual C++
public:
MeteringLog()

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog Methods

[image] [image]

A Sandcastle Documented Class Library
MeteringLog Methods
MeteringLog Class See Also Send Feedback

The MeteringLog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MeteringLog Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog Properties

[image] [image]

A Sandcastle Documented Class Library
MeteringLog Properties
MeteringLog Class See Also Send Feedback

The MeteringLog type exposes the following members.

Properties

 | Name | Description
Public property | Amount | Gets or sets the usage amount
Public property | Id | Gets or sets the Metering Log Identifeir
Public property | LoggedBy | Gets or sets the identifier of user who created log
Public property | LoggedDate | Gets or sets the date time of log created
Public property | TenantId | Gets or sets the Tenant Identifeir
Public property | UsageCode | Gets or sets usag code

See Also

MeteringLog Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog.Amount Property

[image]

A Sandcastle Documented Class Library
MeteringLog..::..Amount Property
MeteringLog Class See Also Send Feedback
Gets or sets the usage amount

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog.Id Property

[image]

A Sandcastle Documented Class Library
MeteringLog..::..Id Property
MeteringLog Class See Also Send Feedback
Gets or sets the Metering Log Identifeir

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog.LoggedBy Property

[image]

A Sandcastle Documented Class Library
MeteringLog..::..LoggedBy Property
MeteringLog Class See Also Send Feedback
Gets or sets the identifier of user who created log

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LoggedBy { get; set; }
Visual Basic
Public Property LoggedBy As String
    Get
    Set
Visual C++
public:
property String^ LoggedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog.LoggedDate Property

[image]

A Sandcastle Documented Class Library
MeteringLog..::..LoggedDate Property
MeteringLog Class See Also Send Feedback
Gets or sets the date time of log created

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime LoggedDate { get; set; }
Visual Basic
Public Property LoggedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime LoggedDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog.TenantId Property

[image]

A Sandcastle Documented Class Library
MeteringLog..::..TenantId Property
MeteringLog Class See Also Send Feedback
Gets or sets the Tenant Identifeir

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringLog.UsageCode Property

[image]

A Sandcastle Documented Class Library
MeteringLog..::..UsageCode Property
MeteringLog Class See Also Send Feedback
Gets or sets usag code

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageCode { get; set; }
Visual Basic
Public Property UsageCode As String
    Get
    Set
Visual C++
public:
property String^ UsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringLog Class
MeteringLog Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition Class

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition Class
Members See Also Send Feedback
Metering search condition class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MeteringSearchCondition
Visual Basic
<SerializableAttribute>
Public Class MeteringSearchCondition
Visual C++
[SerializableAttribute]
public ref class MeteringSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..MeteringSearchCondition

See Also

MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
MeteringSearchCondition Members
MeteringSearchCondition Class Constructors Methods Properties See Also Send Feedback

The MeteringSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | MeteringSearchCondition | Initializes a new instance of the MeteringSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndDate | Gets or sets the Start Date
Public property | LoggedBy | Gets or sets the identifier of user who created log
Public property | PageNumber | Page number to fetch
Public property | PageSize | Page Size to fetch
Public property | SetTotalCount | Set Total Count of records found by the search criteria
Public property | SortExpression | Sort direction ASC OR DESC
Public property | SortString | Sort Column name
Public property | StartDate | Gets or sets the Start Date
Public property | TenantId | Gets or sets the Tenant Identifier
Public property | UsageCode | Gets or sets usag code

See Also

MeteringSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition Constructor
MeteringSearchCondition Class See Also Send Feedback
Initializes a new instance of the MeteringSearchCondition class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MeteringSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
MeteringSearchCondition()

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
MeteringSearchCondition Methods
MeteringSearchCondition Class See Also Send Feedback

The MeteringSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MeteringSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
MeteringSearchCondition Properties
MeteringSearchCondition Class See Also Send Feedback

The MeteringSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | EndDate | Gets or sets the Start Date
Public property | LoggedBy | Gets or sets the identifier of user who created log
Public property | PageNumber | Page number to fetch
Public property | PageSize | Page Size to fetch
Public property | SetTotalCount | Set Total Count of records found by the search criteria
Public property | SortExpression | Sort direction ASC OR DESC
Public property | SortString | Sort Column name
Public property | StartDate | Gets or sets the Start Date
Public property | TenantId | Gets or sets the Tenant Identifier
Public property | UsageCode | Gets or sets usag code

See Also

MeteringSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.EndDate Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..EndDate Property
MeteringSearchCondition Class See Also Send Feedback
Gets or sets the Start Date

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.LoggedBy Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..LoggedBy Property
MeteringSearchCondition Class See Also Send Feedback
Gets or sets the identifier of user who created log

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LoggedBy { get; set; }
Visual Basic
Public Property LoggedBy As String
    Get
    Set
Visual C++
public:
property String^ LoggedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.PageNumber Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..PageNumber Property
MeteringSearchCondition Class See Also Send Feedback
Page number to fetch

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Set
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..PageSize Property
MeteringSearchCondition Class See Also Send Feedback
Page Size to fetch

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..SetTotalCount Property
MeteringSearchCondition Class See Also Send Feedback
Set Total Count of records found by the search criteria

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Boolean
    Get
    Set
Visual C++
public:
property bool SetTotalCount {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.SortExpression Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..SortExpression Property
MeteringSearchCondition Class See Also Send Feedback
Sort direction ASC OR DESC

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortExpression { get; set; }
Visual Basic
Public Property SortExpression As String
    Get
    Set
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..SortString Property
MeteringSearchCondition Class See Also Send Feedback
Sort Column name

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.StartDate Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..StartDate Property
MeteringSearchCondition Class See Also Send Feedback
Gets or sets the Start Date

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..TenantId Property
MeteringSearchCondition Class See Also Send Feedback
Gets or sets the Tenant Identifier

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchCondition.UsageCode Property

[image]

A Sandcastle Documented Class Library
MeteringSearchCondition..::..UsageCode Property
MeteringSearchCondition Class See Also Send Feedback
Gets or sets usag code

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageCode { get; set; }
Visual Basic
Public Property UsageCode As String
    Get
    Set
Visual C++
public:
property String^ UsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MeteringSearchCondition Class
MeteringSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult Class

[image]

A Sandcastle Documented Class Library
MeteringSearchResult Class
Members See Also Send Feedback
Metering search result class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MeteringSearchResult
Visual Basic
<SerializableAttribute>
Public Class MeteringSearchResult
Visual C++
[SerializableAttribute]
public ref class MeteringSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..MeteringSearchResult

See Also

MeteringSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
MeteringSearchResult Members
MeteringSearchResult Class Constructors Methods Properties See Also Send Feedback

The MeteringSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | MeteringSearchResult | Initializes a new instance of the MeteringSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

MeteringSearchResult Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult Constructor

[image]

A Sandcastle Documented Class Library
MeteringSearchResult Constructor
MeteringSearchResult Class See Also Send Feedback
Initializes a new instance of the MeteringSearchResult class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MeteringSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
MeteringSearchResult()

See Also

MeteringSearchResult Class
MeteringSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
MeteringSearchResult Methods
MeteringSearchResult Class See Also Send Feedback

The MeteringSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MeteringSearchResult Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
MeteringSearchResult Properties
MeteringSearchResult Class See Also Send Feedback

The MeteringSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

MeteringSearchResult Class
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult.Result Property

[image]

A Sandcastle Documented Class Library
MeteringSearchResult..::..Result Property
MeteringSearchResult Class See Also Send Feedback
Gets or sets the result.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, MeteringLog> Result { get; set; }
Visual Basic
Public Property Result As Dictionary(Of String, MeteringLog)
    Get
    Set
Visual C++
public:
property Dictionary<String^, MeteringLog^>^ Result {
    Dictionary<String^, MeteringLog^>^ get ();
    void set (Dictionary<String^, MeteringLog^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, MeteringLog >)>)>
The result.

See Also

MeteringSearchResult Class
MeteringSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


MeteringSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
MeteringSearchResult..::..TotalCount Property
MeteringSearchResult Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

MeteringSearchResult Class
MeteringSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


Module Class

[image]

A Sandcastle Documented Class Library
Module Class
Members See Also Send Feedback
Module class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Module
Visual Basic
<SerializableAttribute>
Public Class Module
Visual C++
[SerializableAttribute]
public ref class Module

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..Module

See Also

Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module Members

[image] [image]

A Sandcastle Documented Class Library
Module Members
Module Class Constructors Methods Properties See Also Send Feedback

The Module type exposes the following members.

Constructors

 | Name | Description
Public method | Module | Initializes a new instance of the Module class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | Description | Gets or Sets the module description
Public property | FeatureDetails | Gets or sets the Feature Details
Public property | ModuleCode | Gets or sets module code.
Public property | ModuleName | Gets or sets module name.
Public property | ModuleValidityEnd | Gets or sets validity end date.
Public property | ModuleValidityStart | Gets or sets validity start date.
Public property | ServiceCode |
Public property | Status | Gets or sets status.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets update on.
Public property | UsageDetails | Gets or sets the usage details

See Also

Module Class
CelloSaaS.Model.LicenseManagement Namespace


Module Constructor

[image]

A Sandcastle Documented Class Library
Module Constructor
Module Class See Also Send Feedback
Initializes a new instance of the Module class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Module()
Visual Basic
Public Sub New
Visual C++
public:
Module()

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module Methods

[image] [image]

A Sandcastle Documented Class Library
Module Methods
Module Class See Also Send Feedback

The Module type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Module Class
CelloSaaS.Model.LicenseManagement Namespace


Module Properties

[image] [image]

A Sandcastle Documented Class Library
Module Properties
Module Class See Also Send Feedback

The Module type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | Description | Gets or Sets the module description
Public property | FeatureDetails | Gets or sets the Feature Details
Public property | ModuleCode | Gets or sets module code.
Public property | ModuleName | Gets or sets module name.
Public property | ModuleValidityEnd | Gets or sets validity end date.
Public property | ModuleValidityStart | Gets or sets validity start date.
Public property | ServiceCode |
Public property | Status | Gets or sets status.
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets update on.
Public property | UsageDetails | Gets or sets the usage details

See Also

Module Class
CelloSaaS.Model.LicenseManagement Namespace


Module.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Module..::..CreatedBy Property
Module Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Module..::..CreatedOn Property
Module Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.Description Property

[image]

A Sandcastle Documented Class Library
Module..::..Description Property
Module Class See Also Send Feedback
Gets or Sets the module description

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.FeatureDetails Property

[image]

A Sandcastle Documented Class Library
Module..::..FeatureDetails Property
Module Class See Also Send Feedback
Gets or sets the Feature Details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Feature> FeatureDetails { get; set; }
Visual Basic
Public Property FeatureDetails As Dictionary(Of String, Feature)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Feature^>^ FeatureDetails {
    Dictionary<String^, Feature^>^ get ();
    void set (Dictionary<String^, Feature^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Feature >)>)>

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.ModuleCode Property

[image]

A Sandcastle Documented Class Library
Module..::..ModuleCode Property
Module Class See Also Send Feedback
Gets or sets module code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleCode { get; set; }
Visual Basic
Public Property ModuleCode As String
    Get
    Set
Visual C++
public:
property String^ ModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.ModuleName Property

[image]

A Sandcastle Documented Class Library
Module..::..ModuleName Property
Module Class See Also Send Feedback
Gets or sets module name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleName { get; set; }
Visual Basic
Public Property ModuleName As String
    Get
    Set
Visual C++
public:
property String^ ModuleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.ModuleValidityEnd Property

[image]

A Sandcastle Documented Class Library
Module..::..ModuleValidityEnd Property
Module Class See Also Send Feedback
Gets or sets validity end date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ModuleValidityEnd { get; set; }
Visual Basic
Public Property ModuleValidityEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ModuleValidityEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.ModuleValidityStart Property

[image]

A Sandcastle Documented Class Library
Module..::..ModuleValidityStart Property
Module Class See Also Send Feedback
Gets or sets validity start date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ModuleValidityStart { get; set; }
Visual Basic
Public Property ModuleValidityStart As DateTime
    Get
    Set
Visual C++
public:
property DateTime ModuleValidityStart {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.ServiceCode Property

[image]

A Sandcastle Documented Class Library
Module..::..ServiceCode Property
Module Class See Also Send Feedback

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceCode { get; set; }
Visual Basic
Public Property ServiceCode As String
    Get
    Set
Visual C++
public:
property String^ ServiceCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.Status Property

[image]

A Sandcastle Documented Class Library
Module..::..Status Property
Module Class See Also Send Feedback
Gets or sets status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Module..::..UpdatedBy Property
Module Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Module..::..UpdatedOn Property
Module Class See Also Send Feedback
Gets or sets update on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


Module.UsageDetails Property

[image]

A Sandcastle Documented Class Library
Module..::..UsageDetails Property
Module Class See Also Send Feedback
Gets or sets the usage details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Usage> UsageDetails { get; set; }
Visual Basic
Public Property UsageDetails As Dictionary(Of String, Usage)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Usage^>^ UsageDetails {
    Dictionary<String^, Usage^>^ get ();
    void set (Dictionary<String^, Usage^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Usage >)>)>

See Also

Module Class
Module Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails Class

[image]

A Sandcastle Documented Class Library
PackageDetails Class
Members See Also Send Feedback
Subscription Package details model

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageDetails : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class PackageDetails
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class PackageDetails : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.LicenseManagement..::..PackageDetails

See Also

PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails Members

[image] [image]

A Sandcastle Documented Class Library
PackageDetails Members
PackageDetails Class Constructors Methods Properties See Also Send Feedback

The PackageDetails type exposes the following members.

Constructors

 | Name | Description
Public method | PackageDetails | Initializes a new instance of the PackageDetails class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExpiryDays | Gets the trial period days
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegrateForBilling | Tells whether this package billing is managed by third part billing providers
Public property | IsEvaluation | True if this package is for evaluation purpose only.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | PacakageModuleDetails | Get or set pacakge module details.
Public property | PacakgeFeatureDetails | Get or set package feature details.
Public property | PackageDescription | Get or set package description.
Public property | PackageId | Get or set packageid.
Public property | PackageName | Get or set package name.
Public property | PackageServiceDetails | Get and set service details
Public property | PackageUsageDetails | Get or set package usage details.
Public property | Status | Get or set status.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

PackageDetails Class
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails Constructor

[image]

A Sandcastle Documented Class Library
PackageDetails Constructor
PackageDetails Class See Also Send Feedback
Initializes a new instance of the PackageDetails class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageDetails()
Visual Basic
Public Sub New
Visual C++
public:
PackageDetails()

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails Methods

[image] [image]

A Sandcastle Documented Class Library
PackageDetails Methods
PackageDetails Class See Also Send Feedback

The PackageDetails type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

PackageDetails Class
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails Properties

[image] [image]

A Sandcastle Documented Class Library
PackageDetails Properties
PackageDetails Class See Also Send Feedback

The PackageDetails type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExpiryDays | Gets the trial period days
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IntegrateForBilling | Tells whether this package billing is managed by third part billing providers
Public property | IsEvaluation | True if this package is for evaluation purpose only.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | PacakageModuleDetails | Get or set pacakge module details.
Public property | PacakgeFeatureDetails | Get or set package feature details.
Public property | PackageDescription | Get or set package description.
Public property | PackageId | Get or set packageid.
Public property | PackageName | Get or set package name.
Public property | PackageServiceDetails | Get and set service details
Public property | PackageUsageDetails | Get or set package usage details.
Public property | Status | Get or set status.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

PackageDetails Class
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.ExpiryDays Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..ExpiryDays Property
PackageDetails Class See Also Send Feedback
Gets the trial period days

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ExpiryDays { get; set; }
Visual Basic
Public Property ExpiryDays As Integer
    Get
    Set
Visual C++
public:
property int ExpiryDays {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.IntegrateForBilling Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..IntegrateForBilling Property
PackageDetails Class See Also Send Feedback
Tells whether this package billing is managed by third part billing providers

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IntegrateForBilling { get; set; }
Visual Basic
Public Property IntegrateForBilling As Boolean
    Get
    Set
Visual C++
public:
property bool IntegrateForBilling {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.IsEvaluation Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..IsEvaluation Property
PackageDetails Class See Also Send Feedback
True if this package is for evaluation purpose only.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsEvaluation { get; set; }
Visual Basic
Public Property IsEvaluation As Boolean
    Get
    Set
Visual C++
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PacakageModuleDetails Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PacakageModuleDetails Property
PackageDetails Class See Also Send Feedback
Get or set pacakge module details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageModule> PacakageModuleDetails { get; set; }
Visual Basic
Public Property PacakageModuleDetails As Dictionary(Of String, PackageModule)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageModule^>^ PacakageModuleDetails {
    Dictionary<String^, PackageModule^>^ get ();
    void set (Dictionary<String^, PackageModule^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageModule >)>)>

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PacakgeFeatureDetails Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PacakgeFeatureDetails Property
PackageDetails Class See Also Send Feedback
Get or set package feature details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageFeature> PacakgeFeatureDetails { get; set; }
Visual Basic
Public Property PacakgeFeatureDetails As Dictionary(Of String, PackageFeature)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageFeature^>^ PacakgeFeatureDetails {
    Dictionary<String^, PackageFeature^>^ get ();
    void set (Dictionary<String^, PackageFeature^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageFeature >)>)>

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PackageDescription Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PackageDescription Property
PackageDetails Class See Also Send Feedback
Get or set package description.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageDescription { get; set; }
Visual Basic
Public Property PackageDescription As String
    Get
    Set
Visual C++
public:
property String^ PackageDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PackageId Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PackageId Property
PackageDetails Class See Also Send Feedback
Get or set packageid.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PackageName Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PackageName Property
PackageDetails Class See Also Send Feedback
Get or set package name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageName { get; set; }
Visual Basic
Public Property PackageName As String
    Get
    Set
Visual C++
public:
property String^ PackageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PackageServiceDetails Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PackageServiceDetails Property
PackageDetails Class See Also Send Feedback
Get and set service details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageService> PackageServiceDetails { get; set; }
Visual Basic
Public Property PackageServiceDetails As Dictionary(Of String, PackageService)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageService^>^ PackageServiceDetails {
    Dictionary<String^, PackageService^>^ get ();
    void set (Dictionary<String^, PackageService^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageService >)>)>

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.PackageUsageDetails Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..PackageUsageDetails Property
PackageDetails Class See Also Send Feedback
Get or set package usage details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageUsage> PackageUsageDetails { get; set; }
Visual Basic
Public Property PackageUsageDetails As Dictionary(Of String, PackageUsage)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageUsage^>^ PackageUsageDetails {
    Dictionary<String^, PackageUsage^>^ get ();
    void set (Dictionary<String^, PackageUsage^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageUsage >)>)>

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.Status Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..Status Property
PackageDetails Class See Also Send Feedback
Get or set status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageDetails.TenantId Property

[image]

A Sandcastle Documented Class Library
PackageDetails..::..TenantId Property
PackageDetails Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

PackageDetails Class
PackageDetails Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature Class

[image]

A Sandcastle Documented Class Library
PackageFeature Class
Members See Also Send Feedback
Package feature class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageFeature
Visual Basic
<SerializableAttribute>
Public Class PackageFeature
Visual C++
[SerializableAttribute]
public ref class PackageFeature

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..PackageFeature

See Also

PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature Members

[image] [image]

A Sandcastle Documented Class Library
PackageFeature Members
PackageFeature Class Constructors Methods Properties See Also Send Feedback

The PackageFeature type exposes the following members.

Constructors

 | Name | Description
Public method | PackageFeature | Initializes a new instance of the PackageFeature class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on.
Public property | FeatureId | Get or set featureId.
Public property | FeatureName | Get or set feature name.
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | ModuleId | Get or set moduleId.
Public property | PackageFeatureId | Get or set pacakge featureId.
Public property | PackageId | Get or set packageId.
Public property | Status | Get or set status.
Public property | UpdatedBy | Get or set updated by.
Public property | UpdatedOn | Get or set updated on.

See Also

PackageFeature Class
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature Constructor

[image]

A Sandcastle Documented Class Library
PackageFeature Constructor
PackageFeature Class See Also Send Feedback
Initializes a new instance of the PackageFeature class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageFeature()
Visual Basic
Public Sub New
Visual C++
public:
PackageFeature()

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature Methods

[image] [image]

A Sandcastle Documented Class Library
PackageFeature Methods
PackageFeature Class See Also Send Feedback

The PackageFeature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackageFeature Class
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature Properties

[image] [image]

A Sandcastle Documented Class Library
PackageFeature Properties
PackageFeature Class See Also Send Feedback

The PackageFeature type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on.
Public property | FeatureId | Get or set featureId.
Public property | FeatureName | Get or set feature name.
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | ModuleId | Get or set moduleId.
Public property | PackageFeatureId | Get or set pacakge featureId.
Public property | PackageId | Get or set packageId.
Public property | Status | Get or set status.
Public property | UpdatedBy | Get or set updated by.
Public property | UpdatedOn | Get or set updated on.

See Also

PackageFeature Class
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..CreatedBy Property
PackageFeature Class See Also Send Feedback
Get or set created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..CreatedOn Property
PackageFeature Class See Also Send Feedback
Get or set created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.FeatureId Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..FeatureId Property
PackageFeature Class See Also Send Feedback
Get or set featureId.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureId { get; set; }
Visual Basic
Public Property FeatureId As String
    Get
    Set
Visual C++
public:
property String^ FeatureId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.FeatureName Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..FeatureName Property
PackageFeature Class See Also Send Feedback
Get or set feature name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureName { get; set; }
Visual Basic
Public Property FeatureName As String
    Get
    Set
Visual C++
public:
property String^ FeatureName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.IsAssignable Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..IsAssignable Property
PackageFeature Class See Also Send Feedback
Gets or sets the is assignable.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsAssignable { get; set; }
Visual Basic
Public Property IsAssignable As Boolean
    Get
    Set
Visual C++
public:
property bool IsAssignable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is assignable.

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.IsPossessed Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..IsPossessed Property
PackageFeature Class See Also Send Feedback
Gets or sets the is possessed.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsPossessed { get; set; }
Visual Basic
Public Property IsPossessed As Boolean
    Get
    Set
Visual C++
public:
property bool IsPossessed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is possessed.

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.ModuleId Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..ModuleId Property
PackageFeature Class See Also Send Feedback
Get or set moduleId.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleId { get; set; }
Visual Basic
Public Property ModuleId As String
    Get
    Set
Visual C++
public:
property String^ ModuleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.PackageFeatureId Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..PackageFeatureId Property
PackageFeature Class See Also Send Feedback
Get or set pacakge featureId.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageFeatureId { get; set; }
Visual Basic
Public Property PackageFeatureId As String
    Get
    Set
Visual C++
public:
property String^ PackageFeatureId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.PackageId Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..PackageId Property
PackageFeature Class See Also Send Feedback
Get or set packageId.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.Status Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..Status Property
PackageFeature Class See Also Send Feedback
Get or set status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..UpdatedBy Property
PackageFeature Class See Also Send Feedback
Get or set updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageFeature.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PackageFeature..::..UpdatedOn Property
PackageFeature Class See Also Send Feedback
Get or set updated on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageFeature Class
PackageFeature Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule Class

[image]

A Sandcastle Documented Class Library
PackageModule Class
Members See Also Send Feedback
Package module class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageModule
Visual Basic
<SerializableAttribute>
Public Class PackageModule
Visual C++
[SerializableAttribute]
public ref class PackageModule

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..PackageModule

See Also

PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule Members

[image] [image]

A Sandcastle Documented Class Library
PackageModule Members
PackageModule Class Constructors Methods Properties See Also Send Feedback

The PackageModule type exposes the following members.

Constructors

 | Name | Description
Public method | PackageModule | Initializes a new instance of the PackageModule class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on
Public property | FeatureDetails | Gets or sets feature details.
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | ModuleCode | Gets or sets module id.
Public property | ModuleName | Gets or sets the module name
Public property | PackageId | Gets or sets package id.
Public property | PackageModuleId | Gets or sets pacakge module id.
Public property | ServiceId | Gets and sets service Id
Public property | Status | Get or set status
Public property | UpdatedBy | Get or set updated by
Public property | UpdatedOn | Get or set updated on
Public property | UsageDetails | Gets or sets usage details.

See Also

PackageModule Class
CelloSaaS.Model.LicenseManagement Namespace


PackageModule Constructor

[image]

A Sandcastle Documented Class Library
PackageModule Constructor
PackageModule Class See Also Send Feedback
Initializes a new instance of the PackageModule class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageModule()
Visual Basic
Public Sub New
Visual C++
public:
PackageModule()

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule Methods

[image] [image]

A Sandcastle Documented Class Library
PackageModule Methods
PackageModule Class See Also Send Feedback

The PackageModule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackageModule Class
CelloSaaS.Model.LicenseManagement Namespace


PackageModule Properties

[image] [image]

A Sandcastle Documented Class Library
PackageModule Properties
PackageModule Class See Also Send Feedback

The PackageModule type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on
Public property | FeatureDetails | Gets or sets feature details.
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | ModuleCode | Gets or sets module id.
Public property | ModuleName | Gets or sets the module name
Public property | PackageId | Gets or sets package id.
Public property | PackageModuleId | Gets or sets pacakge module id.
Public property | ServiceId | Gets and sets service Id
Public property | Status | Get or set status
Public property | UpdatedBy | Get or set updated by
Public property | UpdatedOn | Get or set updated on
Public property | UsageDetails | Gets or sets usage details.

See Also

PackageModule Class
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..CreatedBy Property
PackageModule Class See Also Send Feedback
Get or set created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..CreatedOn Property
PackageModule Class See Also Send Feedback
Get or set created on

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.FeatureDetails Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..FeatureDetails Property
PackageModule Class See Also Send Feedback
Gets or sets feature details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageFeature> FeatureDetails { get; set; }
Visual Basic
Public Property FeatureDetails As Dictionary(Of String, PackageFeature)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageFeature^>^ FeatureDetails {
    Dictionary<String^, PackageFeature^>^ get ();
    void set (Dictionary<String^, PackageFeature^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageFeature >)>)>

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.IsAssignable Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..IsAssignable Property
PackageModule Class See Also Send Feedback
Gets or sets the is assignable.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsAssignable { get; set; }
Visual Basic
Public Property IsAssignable As Boolean
    Get
    Set
Visual C++
public:
property bool IsAssignable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is assignable.

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.IsPossessed Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..IsPossessed Property
PackageModule Class See Also Send Feedback
Gets or sets the is possessed.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsPossessed { get; set; }
Visual Basic
Public Property IsPossessed As Boolean
    Get
    Set
Visual C++
public:
property bool IsPossessed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is possessed.

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.ModuleCode Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..ModuleCode Property
PackageModule Class See Also Send Feedback
Gets or sets module id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleCode { get; set; }
Visual Basic
Public Property ModuleCode As String
    Get
    Set
Visual C++
public:
property String^ ModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.ModuleName Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..ModuleName Property
PackageModule Class See Also Send Feedback
Gets or sets the module name

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleName { get; set; }
Visual Basic
Public Property ModuleName As String
    Get
    Set
Visual C++
public:
property String^ ModuleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.PackageId Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..PackageId Property
PackageModule Class See Also Send Feedback
Gets or sets package id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.PackageModuleId Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..PackageModuleId Property
PackageModule Class See Also Send Feedback
Gets or sets pacakge module id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageModuleId { get; set; }
Visual Basic
Public Property PackageModuleId As String
    Get
    Set
Visual C++
public:
property String^ PackageModuleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.ServiceId Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..ServiceId Property
PackageModule Class See Also Send Feedback
Gets and sets service Id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceId { get; set; }
Visual Basic
Public Property ServiceId As String
    Get
    Set
Visual C++
public:
property String^ ServiceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.Status Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..Status Property
PackageModule Class See Also Send Feedback
Get or set status

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..UpdatedBy Property
PackageModule Class See Also Send Feedback
Get or set updated by

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..UpdatedOn Property
PackageModule Class See Also Send Feedback
Get or set updated on

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageModule.UsageDetails Property

[image]

A Sandcastle Documented Class Library
PackageModule..::..UsageDetails Property
PackageModule Class See Also Send Feedback
Gets or sets usage details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageUsage> UsageDetails { get; set; }
Visual Basic
Public Property UsageDetails As Dictionary(Of String, PackageUsage)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageUsage^>^ UsageDetails {
    Dictionary<String^, PackageUsage^>^ get ();
    void set (Dictionary<String^, PackageUsage^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageUsage >)>)>

See Also

PackageModule Class
PackageModule Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService Class

[image]

A Sandcastle Documented Class Library
PackageService Class
Members See Also Send Feedback
Package service modle

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageService
Visual Basic
<SerializableAttribute>
Public Class PackageService
Visual C++
[SerializableAttribute]
public ref class PackageService

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..PackageService

See Also

PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService Members

[image] [image]

A Sandcastle Documented Class Library
PackageService Members
PackageService Class Constructors Methods Properties See Also Send Feedback

The PackageService type exposes the following members.

Constructors

 | Name | Description
Public method | PackageService | Initializes a new instance of the PackageService class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | ModuleDetails | Gets or sets module details
Public property | PackageId | Gets or sets package id.
Public property | PackageServiceId | Gets or sets pacakge service id.
Public property | ServiceCode | Gets or sets service id.
Public property | ServiceDescription | Gets and sets serviceDescription
Public property | ServiceName | Gets or sets the service name
Public property | Status | Get or set status
Public property | UpdatedBy | Get or set updated by
Public property | UpdatedOn | Get or set updated on

See Also

PackageService Class
CelloSaaS.Model.LicenseManagement Namespace


PackageService Constructor

[image]

A Sandcastle Documented Class Library
PackageService Constructor
PackageService Class See Also Send Feedback
Initializes a new instance of the PackageService class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageService()
Visual Basic
Public Sub New
Visual C++
public:
PackageService()

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService Methods

[image] [image]

A Sandcastle Documented Class Library
PackageService Methods
PackageService Class See Also Send Feedback

The PackageService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackageService Class
CelloSaaS.Model.LicenseManagement Namespace


PackageService Properties

[image] [image]

A Sandcastle Documented Class Library
PackageService Properties
PackageService Class See Also Send Feedback

The PackageService type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | ModuleDetails | Gets or sets module details
Public property | PackageId | Gets or sets package id.
Public property | PackageServiceId | Gets or sets pacakge service id.
Public property | ServiceCode | Gets or sets service id.
Public property | ServiceDescription | Gets and sets serviceDescription
Public property | ServiceName | Gets or sets the service name
Public property | Status | Get or set status
Public property | UpdatedBy | Get or set updated by
Public property | UpdatedOn | Get or set updated on

See Also

PackageService Class
CelloSaaS.Model.LicenseManagement Namespace


PackageService.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PackageService..::..CreatedBy Property
PackageService Class See Also Send Feedback
Get or set created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PackageService..::..CreatedOn Property
PackageService Class See Also Send Feedback
Get or set created on

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.IsAssignable Property

[image]

A Sandcastle Documented Class Library
PackageService..::..IsAssignable Property
PackageService Class See Also Send Feedback
Gets or sets the is assignable.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsAssignable { get; set; }
Visual Basic
Public Property IsAssignable As Boolean
    Get
    Set
Visual C++
public:
property bool IsAssignable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is assignable.

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.IsPossessed Property

[image]

A Sandcastle Documented Class Library
PackageService..::..IsPossessed Property
PackageService Class See Also Send Feedback
Gets or sets the is possessed.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsPossessed { get; set; }
Visual Basic
Public Property IsPossessed As Boolean
    Get
    Set
Visual C++
public:
property bool IsPossessed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is possessed.

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.ModuleDetails Property

[image]

A Sandcastle Documented Class Library
PackageService..::..ModuleDetails Property
PackageService Class See Also Send Feedback
Gets or sets module details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, PackageModule> ModuleDetails { get; set; }
Visual Basic
Public Property ModuleDetails As Dictionary(Of String, PackageModule)
    Get
    Set
Visual C++
public:
property Dictionary<String^, PackageModule^>^ ModuleDetails {
    Dictionary<String^, PackageModule^>^ get ();
    void set (Dictionary<String^, PackageModule^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, PackageModule >)>)>

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.PackageId Property

[image]

A Sandcastle Documented Class Library
PackageService..::..PackageId Property
PackageService Class See Also Send Feedback
Gets or sets package id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.PackageServiceId Property

[image]

A Sandcastle Documented Class Library
PackageService..::..PackageServiceId Property
PackageService Class See Also Send Feedback
Gets or sets pacakge service id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageServiceId { get; set; }
Visual Basic
Public Property PackageServiceId As String
    Get
    Set
Visual C++
public:
property String^ PackageServiceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.ServiceCode Property

[image]

A Sandcastle Documented Class Library
PackageService..::..ServiceCode Property
PackageService Class See Also Send Feedback
Gets or sets service id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceCode { get; set; }
Visual Basic
Public Property ServiceCode As String
    Get
    Set
Visual C++
public:
property String^ ServiceCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.ServiceDescription Property

[image]

A Sandcastle Documented Class Library
PackageService..::..ServiceDescription Property
PackageService Class See Also Send Feedback
Gets and sets serviceDescription

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceDescription { get; set; }
Visual Basic
Public Property ServiceDescription As String
    Get
    Set
Visual C++
public:
property String^ ServiceDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.ServiceName Property

[image]

A Sandcastle Documented Class Library
PackageService..::..ServiceName Property
PackageService Class See Also Send Feedback
Gets or sets the service name

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceName { get; set; }
Visual Basic
Public Property ServiceName As String
    Get
    Set
Visual C++
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.Status Property

[image]

A Sandcastle Documented Class Library
PackageService..::..Status Property
PackageService Class See Also Send Feedback
Get or set status

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PackageService..::..UpdatedBy Property
PackageService Class See Also Send Feedback
Get or set updated by

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageService.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PackageService..::..UpdatedOn Property
PackageService Class See Also Send Feedback
Get or set updated on

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageService Class
PackageService Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage Class

[image]

A Sandcastle Documented Class Library
PackageUsage Class
Members See Also Send Feedback
Package usage class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageUsage
Visual Basic
<SerializableAttribute>
Public Class PackageUsage
Visual C++
[SerializableAttribute]
public ref class PackageUsage

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..PackageUsage

See Also

PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage Members

[image] [image]

A Sandcastle Documented Class Library
PackageUsage Members
PackageUsage Class Constructors Methods Properties See Also Send Feedback

The PackageUsage type exposes the following members.

Constructors

 | Name | Description
Public method | PackageUsage | Initializes a new instance of the PackageUsage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowOverUsage | Get or setAllow Over Usage
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on.
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | MaximumCapacity | Get or set Maximum Capacity
Public property | MinimumCapacity | Get or set Minimum capacity
Public property | ModuleId | Get or set module id
Public property | NumberPurchased | Get or set Number purchased
Public property | PackageId | Get or set pacakge id.
Public property | PackageusageId | Get or set package usage id.
Public property | Status | Get or set status.
Public property | UpdatedBy | Get or set updated by.
Public property | UpdatedOn | Get or set updated on.
Public property | UsageCode | Get or set usage code.
Public property | UsageName | Get or set usage name.
Public property | UsageThreshold | Gets or sets usage alert threshold in percentage.
Public property | UsageTypeCode | Gets or sets usage type code.
Public property | UsageTypeName | Gets or sets usage type name.

See Also

PackageUsage Class
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage Constructor

[image]

A Sandcastle Documented Class Library
PackageUsage Constructor
PackageUsage Class See Also Send Feedback
Initializes a new instance of the PackageUsage class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageUsage()
Visual Basic
Public Sub New
Visual C++
public:
PackageUsage()

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage Methods

[image] [image]

A Sandcastle Documented Class Library
PackageUsage Methods
PackageUsage Class See Also Send Feedback

The PackageUsage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackageUsage Class
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage Properties

[image] [image]

A Sandcastle Documented Class Library
PackageUsage Properties
PackageUsage Class See Also Send Feedback

The PackageUsage type exposes the following members.

Properties

 | Name | Description
Public property | AllowOverUsage | Get or setAllow Over Usage
Public property | CreatedBy | Get or set created by.
Public property | CreatedOn | Get or set created on.
Public property | IsAssignable | Gets or sets the is assignable.
Public property | IsPossessed | Gets or sets the is possessed.
Public property | MaximumCapacity | Get or set Maximum Capacity
Public property | MinimumCapacity | Get or set Minimum capacity
Public property | ModuleId | Get or set module id
Public property | NumberPurchased | Get or set Number purchased
Public property | PackageId | Get or set pacakge id.
Public property | PackageusageId | Get or set package usage id.
Public property | Status | Get or set status.
Public property | UpdatedBy | Get or set updated by.
Public property | UpdatedOn | Get or set updated on.
Public property | UsageCode | Get or set usage code.
Public property | UsageName | Get or set usage name.
Public property | UsageThreshold | Gets or sets usage alert threshold in percentage.
Public property | UsageTypeCode | Gets or sets usage type code.
Public property | UsageTypeName | Gets or sets usage type name.

See Also

PackageUsage Class
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.AllowOverUsage Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..AllowOverUsage Property
PackageUsage Class See Also Send Feedback
Get or setAllow Over Usage

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> AllowOverUsage { get; set; }
Visual Basic
Public Property AllowOverUsage As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> AllowOverUsage {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.CreatedBy Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..CreatedBy Property
PackageUsage Class See Also Send Feedback
Get or set created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.CreatedOn Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..CreatedOn Property
PackageUsage Class See Also Send Feedback
Get or set created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.IsAssignable Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..IsAssignable Property
PackageUsage Class See Also Send Feedback
Gets or sets the is assignable.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsAssignable { get; set; }
Visual Basic
Public Property IsAssignable As Boolean
    Get
    Set
Visual C++
public:
property bool IsAssignable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is assignable.

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.IsPossessed Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..IsPossessed Property
PackageUsage Class See Also Send Feedback
Gets or sets the is possessed.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsPossessed { get; set; }
Visual Basic
Public Property IsPossessed As Boolean
    Get
    Set
Visual C++
public:
property bool IsPossessed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The is possessed.

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.MaximumCapacity Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..MaximumCapacity Property
PackageUsage Class See Also Send Feedback
Get or set Maximum Capacity

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MaximumCapacity { get; set; }
Visual Basic
Public Property MaximumCapacity As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaximumCapacity {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.MinimumCapacity Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..MinimumCapacity Property
PackageUsage Class See Also Send Feedback
Get or set Minimum capacity

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MinimumCapacity { get; set; }
Visual Basic
Public Property MinimumCapacity As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinimumCapacity {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.ModuleId Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..ModuleId Property
PackageUsage Class See Also Send Feedback
Get or set module id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleId { get; set; }
Visual Basic
Public Property ModuleId As String
    Get
    Set
Visual C++
public:
property String^ ModuleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.NumberPurchased Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..NumberPurchased Property
PackageUsage Class See Also Send Feedback
Get or set Number purchased

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> NumberPurchased { get; set; }
Visual Basic
Public Property NumberPurchased As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> NumberPurchased {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.PackageId Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..PackageId Property
PackageUsage Class See Also Send Feedback
Get or set pacakge id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.PackageusageId Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..PackageusageId Property
PackageUsage Class See Also Send Feedback
Get or set package usage id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageusageId { get; set; }
Visual Basic
Public Property PackageusageId As String
    Get
    Set
Visual C++
public:
property String^ PackageusageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.Status Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..Status Property
PackageUsage Class See Also Send Feedback
Get or set status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UpdatedBy Property
PackageUsage Class See Also Send Feedback
Get or set updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UpdatedOn Property
PackageUsage Class See Also Send Feedback
Get or set updated on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UsageCode Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UsageCode Property
PackageUsage Class See Also Send Feedback
Get or set usage code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageCode { get; set; }
Visual Basic
Public Property UsageCode As String
    Get
    Set
Visual C++
public:
property String^ UsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UsageName Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UsageName Property
PackageUsage Class See Also Send Feedback
Get or set usage name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageName { get; set; }
Visual Basic
Public Property UsageName As String
    Get
    Set
Visual C++
public:
property String^ UsageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UsageThreshold Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UsageThreshold Property
PackageUsage Class See Also Send Feedback
Gets or sets usage alert threshold in percentage.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double UsageThreshold { get; set; }
Visual Basic
Public Property UsageThreshold As Double
    Get
    Set
Visual C++
public:
property double UsageThreshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UsageTypeCode Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UsageTypeCode Property
PackageUsage Class See Also Send Feedback
Gets or sets usage type code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageTypeCode { get; set; }
Visual Basic
Public Property UsageTypeCode As String
    Get
    Set
Visual C++
public:
property String^ UsageTypeCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


PackageUsage.UsageTypeName Property

[image]

A Sandcastle Documented Class Library
PackageUsage..::..UsageTypeName Property
PackageUsage Class See Also Send Feedback
Gets or sets usage type name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageTypeName { get; set; }
Visual Basic
Public Property UsageTypeName As String
    Get
    Set
Visual C++
public:
property String^ UsageTypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageUsage Class
PackageUsage Members
CelloSaaS.Model.LicenseManagement Namespace


Service Class

[image]

A Sandcastle Documented Class Library
Service Class
Members See Also Send Feedback
Service model

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Service
Visual Basic
<SerializableAttribute>
Public Class Service
Visual C++
[SerializableAttribute]
public ref class Service

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..Service

See Also

Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service Members

[image] [image]

A Sandcastle Documented Class Library
Service Members
Service Class Constructors Methods Properties See Also Send Feedback

The Service type exposes the following members.

Constructors

 | Name | Description
Public method | Service | Initializes a new instance of the Service class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | FeatureDetails | Gets and sets feature details
Public property | ModuleDetails | Gets and sets module details
Public property | ServiceCode | Gets and sets serviceCode.
Public property | ServiceDescription | Gets and sets service description.
Public property | ServiceName | Gets and sets service name.
Public property | Status | Gets and sets status
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updaded on.

See Also

Service Class
CelloSaaS.Model.LicenseManagement Namespace


Service Constructor

[image]

A Sandcastle Documented Class Library
Service Constructor
Service Class See Also Send Feedback
Initializes a new instance of the Service class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Service()
Visual Basic
Public Sub New
Visual C++
public:
Service()

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service Methods

[image] [image]

A Sandcastle Documented Class Library
Service Methods
Service Class See Also Send Feedback

The Service type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Service Class
CelloSaaS.Model.LicenseManagement Namespace


Service Properties

[image] [image]

A Sandcastle Documented Class Library
Service Properties
Service Class See Also Send Feedback

The Service type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | FeatureDetails | Gets and sets feature details
Public property | ModuleDetails | Gets and sets module details
Public property | ServiceCode | Gets and sets serviceCode.
Public property | ServiceDescription | Gets and sets service description.
Public property | ServiceName | Gets and sets service name.
Public property | Status | Gets and sets status
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updaded on.

See Also

Service Class
CelloSaaS.Model.LicenseManagement Namespace


Service.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Service..::..CreatedBy Property
Service Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Service..::..CreatedOn Property
Service Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.FeatureDetails Property

[image]

A Sandcastle Documented Class Library
Service..::..FeatureDetails Property
Service Class See Also Send Feedback
Gets and sets feature details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Feature> FeatureDetails { get; set; }
Visual Basic
Public Property FeatureDetails As Dictionary(Of String, Feature)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Feature^>^ FeatureDetails {
    Dictionary<String^, Feature^>^ get ();
    void set (Dictionary<String^, Feature^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Feature >)>)>

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.ModuleDetails Property

[image]

A Sandcastle Documented Class Library
Service..::..ModuleDetails Property
Service Class See Also Send Feedback
Gets and sets module details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Module> ModuleDetails { get; set; }
Visual Basic
Public Property ModuleDetails As Dictionary(Of String, Module)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Module^>^ ModuleDetails {
    Dictionary<String^, Module^>^ get ();
    void set (Dictionary<String^, Module^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Module >)>)>

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.ServiceCode Property

[image]

A Sandcastle Documented Class Library
Service..::..ServiceCode Property
Service Class See Also Send Feedback
Gets and sets serviceCode.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceCode { get; set; }
Visual Basic
Public Property ServiceCode As String
    Get
    Set
Visual C++
public:
property String^ ServiceCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.ServiceDescription Property

[image]

A Sandcastle Documented Class Library
Service..::..ServiceDescription Property
Service Class See Also Send Feedback
Gets and sets service description.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceDescription { get; set; }
Visual Basic
Public Property ServiceDescription As String
    Get
    Set
Visual C++
public:
property String^ ServiceDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.ServiceName Property

[image]

A Sandcastle Documented Class Library
Service..::..ServiceName Property
Service Class See Also Send Feedback
Gets and sets service name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceName { get; set; }
Visual Basic
Public Property ServiceName As String
    Get
    Set
Visual C++
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.Status Property

[image]

A Sandcastle Documented Class Library
Service..::..Status Property
Service Class See Also Send Feedback
Gets and sets status

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Service..::..UpdatedBy Property
Service Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


Service.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Service..::..UpdatedOn Property
Service Class See Also Send Feedback
Gets or sets updaded on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Service Class
Service Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense Class

[image]

A Sandcastle Documented Class Library
TenantLicense Class
Members See Also Send Feedback
Tenant License class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantLicense
Visual Basic
<SerializableAttribute>
Public Class TenantLicense
Visual C++
[SerializableAttribute]
public ref class TenantLicense

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..TenantLicense

See Also

TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense Members

[image] [image]

A Sandcastle Documented Class Library
TenantLicense Members
TenantLicense Class Constructors Methods Properties See Also Send Feedback

The TenantLicense type exposes the following members.

Constructors

 | Name | Description
Public method | TenantLicense | Initializes a new instance of the TenantLicense class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LicenseFeatureDetails | Gets or sets license feeature details.
Public property | LicenseModuleDetails | Gets or sets license module details.
Public property | LicensePrivilegeDetails | Gets or sets license privilege details.
Public property | LicenseServiceDetails | Gets and sets license service details
Public property | LicenseUsageDetails | Gets or sets license usage details.
Public property | NumberOfUsers | Gets or sets Number of user.
Public property | PackageId | Gets or sets packageId
Public property | PackageName | Gets or sets package name.
Public property | PricePlanId | Gets or sets package price plan Id
Public property | TenantId | Gets or sets tenantId.
Public property | TenantLicenseCode | Gets or sets tenantlicense code
Public property | TrialEndDate | Gets or sets the Trial End date
Public property | ValidityEnd | Gets or sets validity end date.
Public property | ValidityStart | Gets or sets validity start date.

See Also

TenantLicense Class
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense Constructor

[image]

A Sandcastle Documented Class Library
TenantLicense Constructor
TenantLicense Class See Also Send Feedback
Initializes a new instance of the TenantLicense class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantLicense()
Visual Basic
Public Sub New
Visual C++
public:
TenantLicense()

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense Methods

[image] [image]

A Sandcastle Documented Class Library
TenantLicense Methods
TenantLicense Class See Also Send Feedback

The TenantLicense type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantLicense Class
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense Properties

[image] [image]

A Sandcastle Documented Class Library
TenantLicense Properties
TenantLicense Class See Also Send Feedback

The TenantLicense type exposes the following members.

Properties

 | Name | Description
Public property | LicenseFeatureDetails | Gets or sets license feeature details.
Public property | LicenseModuleDetails | Gets or sets license module details.
Public property | LicensePrivilegeDetails | Gets or sets license privilege details.
Public property | LicenseServiceDetails | Gets and sets license service details
Public property | LicenseUsageDetails | Gets or sets license usage details.
Public property | NumberOfUsers | Gets or sets Number of user.
Public property | PackageId | Gets or sets packageId
Public property | PackageName | Gets or sets package name.
Public property | PricePlanId | Gets or sets package price plan Id
Public property | TenantId | Gets or sets tenantId.
Public property | TenantLicenseCode | Gets or sets tenantlicense code
Public property | TrialEndDate | Gets or sets the Trial End date
Public property | ValidityEnd | Gets or sets validity end date.
Public property | ValidityStart | Gets or sets validity start date.

See Also

TenantLicense Class
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.LicenseFeatureDetails Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..LicenseFeatureDetails Property
TenantLicense Class See Also Send Feedback
Gets or sets license feeature details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Feature> LicenseFeatureDetails { get; set; }
Visual Basic
Public Property LicenseFeatureDetails As Dictionary(Of String, Feature)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Feature^>^ LicenseFeatureDetails {
    Dictionary<String^, Feature^>^ get ();
    void set (Dictionary<String^, Feature^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Feature >)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.LicenseModuleDetails Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..LicenseModuleDetails Property
TenantLicense Class See Also Send Feedback
Gets or sets license module details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Module> LicenseModuleDetails { get; set; }
Visual Basic
Public Property LicenseModuleDetails As Dictionary(Of String, Module)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Module^>^ LicenseModuleDetails {
    Dictionary<String^, Module^>^ get ();
    void set (Dictionary<String^, Module^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Module >)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.LicensePrivilegeDetails Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..LicensePrivilegeDetails Property
TenantLicense Class See Also Send Feedback
Gets or sets license privilege details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Privilege> LicensePrivilegeDetails { get; set; }
Visual Basic
Public Property LicensePrivilegeDetails As Dictionary(Of String, Privilege)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Privilege^>^ LicensePrivilegeDetails {
    Dictionary<String^, Privilege^>^ get ();
    void set (Dictionary<String^, Privilege^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.LicenseServiceDetails Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..LicenseServiceDetails Property
TenantLicense Class See Also Send Feedback
Gets and sets license service details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Service> LicenseServiceDetails { get; set; }
Visual Basic
Public Property LicenseServiceDetails As Dictionary(Of String, Service)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Service^>^ LicenseServiceDetails {
    Dictionary<String^, Service^>^ get ();
    void set (Dictionary<String^, Service^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Service >)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.LicenseUsageDetails Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..LicenseUsageDetails Property
TenantLicense Class See Also Send Feedback
Gets or sets license usage details.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Usage> LicenseUsageDetails { get; set; }
Visual Basic
Public Property LicenseUsageDetails As Dictionary(Of String, Usage)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Usage^>^ LicenseUsageDetails {
    Dictionary<String^, Usage^>^ get ();
    void set (Dictionary<String^, Usage^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Usage >)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.NumberOfUsers Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..NumberOfUsers Property
TenantLicense Class See Also Send Feedback
Gets or sets Number of user.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> NumberOfUsers { get; set; }
Visual Basic
Public Property NumberOfUsers As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> NumberOfUsers {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.PackageId Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..PackageId Property
TenantLicense Class See Also Send Feedback
Gets or sets packageId

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.PackageName Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..PackageName Property
TenantLicense Class See Also Send Feedback
Gets or sets package name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageName { get; set; }
Visual Basic
Public Property PackageName As String
    Get
    Set
Visual C++
public:
property String^ PackageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.PricePlanId Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..PricePlanId Property
TenantLicense Class See Also Send Feedback
Gets or sets package price plan Id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PricePlanId { get; set; }
Visual Basic
Public Property PricePlanId As String
    Get
    Set
Visual C++
public:
property String^ PricePlanId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.TenantId Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..TenantId Property
TenantLicense Class See Also Send Feedback
Gets or sets tenantId.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.TenantLicenseCode Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..TenantLicenseCode Property
TenantLicense Class See Also Send Feedback
Gets or sets tenantlicense code

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantLicenseCode { get; set; }
Visual Basic
Public Property TenantLicenseCode As String
    Get
    Set
Visual C++
public:
property String^ TenantLicenseCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.TrialEndDate Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..TrialEndDate Property
TenantLicense Class See Also Send Feedback
Gets or sets the Trial End date

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> TrialEndDate { get; set; }
Visual Basic
Public Property TrialEndDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> TrialEndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.ValidityEnd Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..ValidityEnd Property
TenantLicense Class See Also Send Feedback
Gets or sets validity end date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ValidityEnd { get; set; }
Visual Basic
Public Property ValidityEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ValidityEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicense.ValidityStart Property

[image]

A Sandcastle Documented Class Library
TenantLicense..::..ValidityStart Property
TenantLicense Class See Also Send Feedback
Gets or sets validity start date.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ValidityStart { get; set; }
Visual Basic
Public Property ValidityStart As DateTime
    Get
    Set
Visual C++
public:
property DateTime ValidityStart {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantLicense Class
TenantLicense Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition Class

[image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition Class
Members See Also Send Feedback
Tenant license search condition class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantLicenseSearchCondition
Visual Basic
<SerializableAttribute>
Public Class TenantLicenseSearchCondition
Visual C++
[SerializableAttribute]
public ref class TenantLicenseSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..TenantLicenseSearchCondition

See Also

TenantLicenseSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition Members
TenantLicenseSearchCondition Class Constructors Methods Properties See Also Send Feedback

The TenantLicenseSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TenantLicenseSearchCondition | Initializes a new instance of the TenantLicenseSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LicenseStatus | Gets or sets LicenseStatus
Public property | PackageIds | Gets or sets the subscription package ids
Public property | PricePlanIds | Gets or sets price plan ids
Public property | TenantIds | Gets or sets TenantIds

See Also

TenantLicenseSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition Constructor
TenantLicenseSearchCondition Class See Also Send Feedback
Initializes a new instance of the TenantLicenseSearchCondition class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantLicenseSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
TenantLicenseSearchCondition()

See Also

TenantLicenseSearchCondition Class
TenantLicenseSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition Methods
TenantLicenseSearchCondition Class See Also Send Feedback

The TenantLicenseSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantLicenseSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition Properties
TenantLicenseSearchCondition Class See Also Send Feedback

The TenantLicenseSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | LicenseStatus | Gets or sets LicenseStatus
Public property | PackageIds | Gets or sets the subscription package ids
Public property | PricePlanIds | Gets or sets price plan ids
Public property | TenantIds | Gets or sets TenantIds

See Also

TenantLicenseSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition.LicenseStatus Property

[image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition..::..LicenseStatus Property
TenantLicenseSearchCondition Class See Also Send Feedback
Gets or sets LicenseStatus

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<TenantLicenseStatus> LicenseStatus { get; set; }
Visual Basic
Public Property LicenseStatus As Nullable(Of TenantLicenseStatus)
    Get
    Set
Visual C++
public:
property Nullable<TenantLicenseStatus> LicenseStatus {
    Nullable<TenantLicenseStatus> get ();
    void set (Nullable<TenantLicenseStatus> value);
}

Property Value

Type: Nullable<(Of <(<' TenantLicenseStatus >)>)>

See Also

TenantLicenseSearchCondition Class
TenantLicenseSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition.PackageIds Property

[image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition..::..PackageIds Property
TenantLicenseSearchCondition Class See Also Send Feedback
Gets or sets the subscription package ids

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] PackageIds { get; set; }
Visual Basic
Public Property PackageIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ PackageIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

TenantLicenseSearchCondition Class
TenantLicenseSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition.PricePlanIds Property

[image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition..::..PricePlanIds Property
TenantLicenseSearchCondition Class See Also Send Feedback
Gets or sets price plan ids

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] PricePlanIds { get; set; }
Visual Basic
Public Property PricePlanIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ PricePlanIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

TenantLicenseSearchCondition Class
TenantLicenseSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
TenantLicenseSearchCondition..::..TenantIds Property
TenantLicenseSearchCondition Class See Also Send Feedback
Gets or sets TenantIds

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ TenantIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

TenantLicenseSearchCondition Class
TenantLicenseSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


TenantLicenseStatus Enumeration

[image]

A Sandcastle Documented Class Library
TenantLicenseStatus Enumeration
See Also Send Feedback
Tenant license status enumeration

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum TenantLicenseStatus
Visual Basic
<SerializableAttribute>
Public Enumeration TenantLicenseStatus
Visual C++
[SerializableAttribute]
public enum class TenantLicenseStatus

Members

Member name | Value | Description
Active | 0 | Having active subscription
Deactivated | 1 | Do not have active subscription
Trial | 2 | Currenlty in trail period

See Also

CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping Class

[image]

A Sandcastle Documented Class Library
TenantServiceMapping Class
Members See Also Send Feedback
Tenant service mapping class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantServiceMapping
Visual Basic
<SerializableAttribute>
Public Class TenantServiceMapping
Visual C++
[SerializableAttribute]
public ref class TenantServiceMapping

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..TenantServiceMapping

See Also

TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping Members

[image] [image]

A Sandcastle Documented Class Library
TenantServiceMapping Members
TenantServiceMapping Class Constructors Methods Properties See Also Send Feedback

The TenantServiceMapping type exposes the following members.

Constructors

 | Name | Description
Public method | TenantServiceMapping | Initializes a new instance of the TenantServiceMapping class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or Sets the created by user id
Public property | CreatedOn | Gets or Sets the created on datetime
Public property | EndDate | Gets or Sets the end date value
Public property | ServiceId | Gets or Sets the service id
Public property | StartDate | Gets or Sets the start date value
Public property | Status | Gets or Sets the status
Public property | TenantId | Gets or Sets the tenant id
Public property | TenantServiceMappingId | Gets or Sets the id (PK)
Public property | UpdatedBy | Gets or Sets the updated by user id
Public property | UpdatedOn | Gets or Sets the update on datetime

See Also

TenantServiceMapping Class
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping Constructor

[image]

A Sandcastle Documented Class Library
TenantServiceMapping Constructor
TenantServiceMapping Class See Also Send Feedback
Initializes a new instance of the TenantServiceMapping class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantServiceMapping()
Visual Basic
Public Sub New
Visual C++
public:
TenantServiceMapping()

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping Methods

[image] [image]

A Sandcastle Documented Class Library
TenantServiceMapping Methods
TenantServiceMapping Class See Also Send Feedback

The TenantServiceMapping type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantServiceMapping Class
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping Properties

[image] [image]

A Sandcastle Documented Class Library
TenantServiceMapping Properties
TenantServiceMapping Class See Also Send Feedback

The TenantServiceMapping type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or Sets the created by user id
Public property | CreatedOn | Gets or Sets the created on datetime
Public property | EndDate | Gets or Sets the end date value
Public property | ServiceId | Gets or Sets the service id
Public property | StartDate | Gets or Sets the start date value
Public property | Status | Gets or Sets the status
Public property | TenantId | Gets or Sets the tenant id
Public property | TenantServiceMappingId | Gets or Sets the id (PK)
Public property | UpdatedBy | Gets or Sets the updated by user id
Public property | UpdatedOn | Gets or Sets the update on datetime

See Also

TenantServiceMapping Class
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..CreatedBy Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the created by user id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..CreatedOn Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the created on datetime

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.EndDate Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..EndDate Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the end date value

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> EndDate { get; set; }
Visual Basic
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.ServiceId Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..ServiceId Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the service id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServiceId { get; set; }
Visual Basic
Public Property ServiceId As String
    Get
    Set
Visual C++
public:
property String^ ServiceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.StartDate Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..StartDate Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the start date value

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> StartDate { get; set; }
Visual Basic
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.Status Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..Status Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the status

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.TenantId Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..TenantId Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the tenant id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.TenantServiceMappingId Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..TenantServiceMappingId Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the id (PK)

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantServiceMappingId { get; set; }
Visual Basic
Public Property TenantServiceMappingId As String
    Get
    Set
Visual C++
public:
property String^ TenantServiceMappingId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..UpdatedBy Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the updated by user id

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


TenantServiceMapping.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantServiceMapping..::..UpdatedOn Property
TenantServiceMapping Class See Also Send Feedback
Gets or Sets the update on datetime

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TenantServiceMapping Class
TenantServiceMapping Members
CelloSaaS.Model.LicenseManagement Namespace


Usage Class

[image]

A Sandcastle Documented Class Library
Usage Class
Members See Also Send Feedback
Usage model.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Usage
Visual Basic
<SerializableAttribute>
Public Class Usage
Visual C++
[SerializableAttribute]
public ref class Usage

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..Usage

See Also

Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage Members

[image] [image]

A Sandcastle Documented Class Library
Usage Members
Usage Class Constructors Methods Properties See Also Send Feedback

The Usage type exposes the following members.

Constructors

 | Name | Description
Public method | Usage | Initializes a new instance of the Usage class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowOverUsage | Gets or sets allow over usage.
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | MaximumCapacityUsage | Gets or sets maximum capacity usage.
Public property | MinimumCapacityUsage | Gets or sets minimum capacity usage.
Public property | Status | Gets or sets status.
Public property | Threshold | Gets or sets usage alert threshold in percentage
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.
Public property | UsageCode | Gets or sets usage code.
Public property | UsageModuleCode | Gets or sets usage module code.
Public property | UsageName | Gets or sets usage name.
Public property | UsageTypeCode | Gets or sets usage type code.
Public property | UsageTypeName | Gets or sets usage type name.

See Also

Usage Class
CelloSaaS.Model.LicenseManagement Namespace


Usage Constructor

[image]

A Sandcastle Documented Class Library
Usage Constructor
Usage Class See Also Send Feedback
Initializes a new instance of the Usage class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Usage()
Visual Basic
Public Sub New
Visual C++
public:
Usage()

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage Methods

[image] [image]

A Sandcastle Documented Class Library
Usage Methods
Usage Class See Also Send Feedback

The Usage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Usage Class
CelloSaaS.Model.LicenseManagement Namespace


Usage Properties

[image] [image]

A Sandcastle Documented Class Library
Usage Properties
Usage Class See Also Send Feedback

The Usage type exposes the following members.

Properties

 | Name | Description
Public property | AllowOverUsage | Gets or sets allow over usage.
Public property | CreatedBy | Gets or sets created by.
Public property | CreatedOn | Gets or sets created on.
Public property | MaximumCapacityUsage | Gets or sets maximum capacity usage.
Public property | MinimumCapacityUsage | Gets or sets minimum capacity usage.
Public property | Status | Gets or sets status.
Public property | Threshold | Gets or sets usage alert threshold in percentage
Public property | UpdatedBy | Gets or sets updated by.
Public property | UpdatedOn | Gets or sets updated on.
Public property | UsageCode | Gets or sets usage code.
Public property | UsageModuleCode | Gets or sets usage module code.
Public property | UsageName | Gets or sets usage name.
Public property | UsageTypeCode | Gets or sets usage type code.
Public property | UsageTypeName | Gets or sets usage type name.

See Also

Usage Class
CelloSaaS.Model.LicenseManagement Namespace


Usage.AllowOverUsage Property

[image]

A Sandcastle Documented Class Library
Usage..::..AllowOverUsage Property
Usage Class See Also Send Feedback
Gets or sets allow over usage.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> AllowOverUsage { get; set; }
Visual Basic
Public Property AllowOverUsage As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> AllowOverUsage {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Usage..::..CreatedBy Property
Usage Class See Also Send Feedback
Gets or sets created by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Usage..::..CreatedOn Property
Usage Class See Also Send Feedback
Gets or sets created on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.MaximumCapacityUsage Property

[image]

A Sandcastle Documented Class Library
Usage..::..MaximumCapacityUsage Property
Usage Class See Also Send Feedback
Gets or sets maximum capacity usage.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MaximumCapacityUsage { get; set; }
Visual Basic
Public Property MaximumCapacityUsage As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MaximumCapacityUsage {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.MinimumCapacityUsage Property

[image]

A Sandcastle Documented Class Library
Usage..::..MinimumCapacityUsage Property
Usage Class See Also Send Feedback
Gets or sets minimum capacity usage.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<double> MinimumCapacityUsage { get; set; }
Visual Basic
Public Property MinimumCapacityUsage As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> MinimumCapacityUsage {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable<(Of <(<'Double>)>)>

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.Status Property

[image]

A Sandcastle Documented Class Library
Usage..::..Status Property
Usage Class See Also Send Feedback
Gets or sets status.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.Threshold Property

[image]

A Sandcastle Documented Class Library
Usage..::..Threshold Property
Usage Class See Also Send Feedback
Gets or sets usage alert threshold in percentage

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Threshold { get; set; }
Visual Basic
Public Property Threshold As Double
    Get
    Set
Visual C++
public:
property double Threshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Usage..::..UpdatedBy Property
Usage Class See Also Send Feedback
Gets or sets updated by.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Usage..::..UpdatedOn Property
Usage Class See Also Send Feedback
Gets or sets updated on.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UsageCode Property

[image]

A Sandcastle Documented Class Library
Usage..::..UsageCode Property
Usage Class See Also Send Feedback
Gets or sets usage code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageCode { get; set; }
Visual Basic
Public Property UsageCode As String
    Get
    Set
Visual C++
public:
property String^ UsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UsageModuleCode Property

[image]

A Sandcastle Documented Class Library
Usage..::..UsageModuleCode Property
Usage Class See Also Send Feedback
Gets or sets usage module code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageModuleCode { get; set; }
Visual Basic
Public Property UsageModuleCode As String
    Get
    Set
Visual C++
public:
property String^ UsageModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UsageName Property

[image]

A Sandcastle Documented Class Library
Usage..::..UsageName Property
Usage Class See Also Send Feedback
Gets or sets usage name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageName { get; set; }
Visual Basic
Public Property UsageName As String
    Get
    Set
Visual C++
public:
property String^ UsageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UsageTypeCode Property

[image]

A Sandcastle Documented Class Library
Usage..::..UsageTypeCode Property
Usage Class See Also Send Feedback
Gets or sets usage type code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageTypeCode { get; set; }
Visual Basic
Public Property UsageTypeCode As String
    Get
    Set
Visual C++
public:
property String^ UsageTypeCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


Usage.UsageTypeName Property

[image]

A Sandcastle Documented Class Library
Usage..::..UsageTypeName Property
Usage Class See Also Send Feedback
Gets or sets usage type name.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageTypeName { get; set; }
Visual Basic
Public Property UsageTypeName As String
    Get
    Set
Visual C++
public:
property String^ UsageTypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Usage Class
Usage Members
CelloSaaS.Model.LicenseManagement Namespace


UsageConstants Class

[image]

A Sandcastle Documented Class Library
UsageConstants Class
Members See Also Send Feedback
Usage constants

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class UsageConstants
Visual Basic
Public NotInheritable Class UsageConstants
Visual C++
public ref class UsageConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..UsageConstants

See Also

UsageConstants Members
CelloSaaS.Model.LicenseManagement Namespace


UsageConstants Members

[image] [image]

A Sandcastle Documented Class Library
UsageConstants Members
UsageConstants Class Fields See Also Send Feedback

The UsageConstants type exposes the following members.

Fields

Name | Description
User | User usage constant

See Also

UsageConstants Class
CelloSaaS.Model.LicenseManagement Namespace


UsageConstants Fields

[image] [image]

A Sandcastle Documented Class Library
UsageConstants Fields
UsageConstants Class See Also Send Feedback

The UsageConstants type exposes the following members.

Fields

Name | Description
User | User usage constant

See Also

UsageConstants Class
CelloSaaS.Model.LicenseManagement Namespace


UsageConstants.User Field

[image]

A Sandcastle Documented Class Library
UsageConstants..::..User Field
UsageConstants Class See Also Send Feedback
User usage constant

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string User
Visual Basic
Public Const User As String
Visual C++
public:
literal String^ User

Field Value

Type: String

See Also

UsageConstants Class
UsageConstants Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail Class

[image]

A Sandcastle Documented Class Library
UsageDetail Class
Members See Also Send Feedback
Usage Details

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UsageDetail
Visual Basic
<SerializableAttribute>
Public Class UsageDetail
Visual C++
[SerializableAttribute]
public ref class UsageDetail

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..UsageDetail

See Also

UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail Members

[image] [image]

A Sandcastle Documented Class Library
UsageDetail Members
UsageDetail Class Constructors Methods Properties See Also Send Feedback

The UsageDetail type exposes the following members.

Constructors

 | Name | Description
Public method | UsageDetail | Initializes a new instance of the UsageDetail class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Amount | Gets or sets the amount.
Public property | ModuleCode | Gets or sets the module code.
Public property | TenantId | Gets or sets the tenant id.
Public property | Threshold | Gets or sets usage alert threshold in percentage
Public property | UsageCode | Gets or sets the usage code.
Public property | UsageName | Gets or sets the name of the usage.
Public property | UsageType | Gets or sets the usage type

See Also

UsageDetail Class
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail Constructor

[image]

A Sandcastle Documented Class Library
UsageDetail Constructor
UsageDetail Class See Also Send Feedback
Initializes a new instance of the UsageDetail class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UsageDetail()
Visual Basic
Public Sub New
Visual C++
public:
UsageDetail()

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail Methods

[image] [image]

A Sandcastle Documented Class Library
UsageDetail Methods
UsageDetail Class See Also Send Feedback

The UsageDetail type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UsageDetail Class
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail Properties

[image] [image]

A Sandcastle Documented Class Library
UsageDetail Properties
UsageDetail Class See Also Send Feedback

The UsageDetail type exposes the following members.

Properties

 | Name | Description
Public property | Amount | Gets or sets the amount.
Public property | ModuleCode | Gets or sets the module code.
Public property | TenantId | Gets or sets the tenant id.
Public property | Threshold | Gets or sets usage alert threshold in percentage
Public property | UsageCode | Gets or sets the usage code.
Public property | UsageName | Gets or sets the name of the usage.
Public property | UsageType | Gets or sets the usage type

See Also

UsageDetail Class
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.Amount Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..Amount Property
UsageDetail Class See Also Send Feedback
Gets or sets the amount.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Amount { get; set; }
Visual Basic
Public Property Amount As Double
    Get
    Set
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

Property Value

Type: Double
The amount.

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.ModuleCode Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..ModuleCode Property
UsageDetail Class See Also Send Feedback
Gets or sets the module code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleCode { get; set; }
Visual Basic
Public Property ModuleCode As String
    Get
    Set
Visual C++
public:
property String^ ModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The module code.

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.TenantId Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..TenantId Property
UsageDetail Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.Threshold Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..Threshold Property
UsageDetail Class See Also Send Feedback
Gets or sets usage alert threshold in percentage

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double Threshold { get; set; }
Visual Basic
Public Property Threshold As Double
    Get
    Set
Visual C++
public:
property double Threshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.UsageCode Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..UsageCode Property
UsageDetail Class See Also Send Feedback
Gets or sets the usage code.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageCode { get; set; }
Visual Basic
Public Property UsageCode As String
    Get
    Set
Visual C++
public:
property String^ UsageCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The usage code.

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.UsageName Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..UsageName Property
UsageDetail Class See Also Send Feedback
Gets or sets the name of the usage.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageName { get; set; }
Visual Basic
Public Property UsageName As String
    Get
    Set
Visual C++
public:
property String^ UsageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the usage.

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageDetail.UsageType Property

[image]

A Sandcastle Documented Class Library
UsageDetail..::..UsageType Property
UsageDetail Class See Also Send Feedback
Gets or sets the usage type

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UsageType { get; set; }
Visual Basic
Public Property UsageType As String
    Get
    Set
Visual C++
public:
property String^ UsageType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UsageDetail Class
UsageDetail Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition Class

[image]

A Sandcastle Documented Class Library
UsageSearchCondition Class
Members See Also Send Feedback
License usage search condition

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UsageSearchCondition
Visual Basic
<SerializableAttribute>
Public Class UsageSearchCondition
Visual C++
[SerializableAttribute]
public ref class UsageSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..UsageSearchCondition

See Also

UsageSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
UsageSearchCondition Members
UsageSearchCondition Class Constructors Methods Properties See Also Send Feedback

The UsageSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | UsageSearchCondition | Initializes a new instance of the UsageSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ModuleCodes | Gets or sets the module codes.
Public property | TenantId | Gets or sets the tenant id.
Public property | UsageCodes | Gets or sets the usage codes.

See Also

UsageSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
UsageSearchCondition Constructor
UsageSearchCondition Class See Also Send Feedback
Initializes a new instance of the UsageSearchCondition class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UsageSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
UsageSearchCondition()

See Also

UsageSearchCondition Class
UsageSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
UsageSearchCondition Methods
UsageSearchCondition Class See Also Send Feedback

The UsageSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UsageSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
UsageSearchCondition Properties
UsageSearchCondition Class See Also Send Feedback

The UsageSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | ModuleCodes | Gets or sets the module codes.
Public property | TenantId | Gets or sets the tenant id.
Public property | UsageCodes | Gets or sets the usage codes.

See Also

UsageSearchCondition Class
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition.ModuleCodes Property

[image]

A Sandcastle Documented Class Library
UsageSearchCondition..::..ModuleCodes Property
UsageSearchCondition Class See Also Send Feedback
Gets or sets the module codes.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] ModuleCodes { get; set; }
Visual Basic
Public Property ModuleCodes As String()
    Get
    Set
Visual C++
public:
property array<String^>^ ModuleCodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The module codes.

See Also

UsageSearchCondition Class
UsageSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
UsageSearchCondition..::..TenantId Property
UsageSearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

UsageSearchCondition Class
UsageSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchCondition.UsageCodes Property

[image]

A Sandcastle Documented Class Library
UsageSearchCondition..::..UsageCodes Property
UsageSearchCondition Class See Also Send Feedback
Gets or sets the usage codes.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] UsageCodes { get; set; }
Visual Basic
Public Property UsageCodes As String()
    Get
    Set
Visual C++
public:
property array<String^>^ UsageCodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The usage codes.

See Also

UsageSearchCondition Class
UsageSearchCondition Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult Class

[image]

A Sandcastle Documented Class Library
UsageSearchResult Class
Members See Also Send Feedback
License usage search result

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UsageSearchResult
Visual Basic
<SerializableAttribute>
Public Class UsageSearchResult
Visual C++
[SerializableAttribute]
public ref class UsageSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.LicenseManagement..::..UsageSearchResult

See Also

UsageSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
UsageSearchResult Members
UsageSearchResult Class Constructors Methods Properties See Also Send Feedback

The UsageSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | UsageSearchResult | Initializes a new instance of the UsageSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

UsageSearchResult Class
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult Constructor

[image]

A Sandcastle Documented Class Library
UsageSearchResult Constructor
UsageSearchResult Class See Also Send Feedback
Initializes a new instance of the UsageSearchResult class

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UsageSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
UsageSearchResult()

See Also

UsageSearchResult Class
UsageSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
UsageSearchResult Methods
UsageSearchResult Class See Also Send Feedback

The UsageSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UsageSearchResult Class
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
UsageSearchResult Properties
UsageSearchResult Class See Also Send Feedback

The UsageSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Result | Gets or sets the result.
Public property | TotalCount | Gets or sets the total count.

See Also

UsageSearchResult Class
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult.Result Property

[image]

A Sandcastle Documented Class Library
UsageSearchResult..::..Result Property
UsageSearchResult Class See Also Send Feedback
Gets or sets the result.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<UsageDetail> Result { get; set; }
Visual Basic
Public Property Result As ICollection(Of UsageDetail)
    Get
    Set
Visual C++
public:
property ICollection<UsageDetail^>^ Result {
    ICollection<UsageDetail^>^ get ();
    void set (ICollection<UsageDetail^>^ value);
}

Property Value

Type: ICollection<(Of <(<' UsageDetail >)>)>
The result.

See Also

UsageSearchResult Class
UsageSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


UsageSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
UsageSearchResult..::..TotalCount Property
UsageSearchResult Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.Model.LicenseManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

UsageSearchResult Class
UsageSearchResult Members
CelloSaaS.Model.LicenseManagement Namespace


CelloSaaS.Model.Logger Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.Logger Namespace
Send Feedback

Classes

 | Class | Description
Public class | CelloLogEntry | Cello Logger Model.
Public class | CelloLogEntrySearchCondition | Cello LogEntry SearchCondition class
Public class | CelloLogEntrySearchResult | Cello log entiry search result class


CelloLogEntry Class

[image]

A Sandcastle Documented Class Library
CelloLogEntry Class
Members See Also Send Feedback
Cello Logger Model.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CelloLogEntry
Visual Basic
<SerializableAttribute>
Public Class CelloLogEntry
Visual C++
[SerializableAttribute]
public ref class CelloLogEntry

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Logger..::..CelloLogEntry

See Also

CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry Members

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntry Members
CelloLogEntry Class Constructors Methods Properties See Also Send Feedback

The CelloLogEntry type exposes the following members.

Constructors

 | Name | Description
Public method | CelloLogEntry | Initializes a new instance of the CelloLogEntry class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppDomainName | Gets or sets the App Domain Name
Public property | CategoryName | Gets or sets the log user name.
Public property | EventId | Gets or sets the event id.
Public property | FormattedMessage | Gets or sets the formatted message
Public property | LogId | Gets or sets the log id.
Public property | MachineName | Gets or sets the Machine Name
Public property | Message | Gets or sets the Message
Public property | Priority | Gets or sets the Priority
Public property | ProcessID | Gets or sets the ProcessID
Public property | ProcessName | Gets or sets the Process Name
Public property | Severity | Gets or sets the Severity
Public property | TenantId | Gets or sets the log tenant id.
Public property | TenantName | Gets or sets the log tenant name.
Public property | ThreadName | Gets or sets the Thread Name
Public property | Timestamp | Gets or sets the Time stamp
Public property | Title | Gets or sets the Title
Public property | UserId | Gets or sets the log user id.
Public property | UserName | Gets or sets the log user name.
Public property | Win32ThreadId | Gets or sets the Win32ThreadId

See Also

CelloLogEntry Class
CelloSaaS.Model.Logger Namespace


CelloLogEntry Constructor

[image]

A Sandcastle Documented Class Library
CelloLogEntry Constructor
CelloLogEntry Class See Also Send Feedback
Initializes a new instance of the CelloLogEntry class

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloLogEntry()
Visual Basic
Public Sub New
Visual C++
public:
CelloLogEntry()

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry Methods

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntry Methods
CelloLogEntry Class See Also Send Feedback

The CelloLogEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CelloLogEntry Class
CelloSaaS.Model.Logger Namespace


CelloLogEntry Properties

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntry Properties
CelloLogEntry Class See Also Send Feedback

The CelloLogEntry type exposes the following members.

Properties

 | Name | Description
Public property | AppDomainName | Gets or sets the App Domain Name
Public property | CategoryName | Gets or sets the log user name.
Public property | EventId | Gets or sets the event id.
Public property | FormattedMessage | Gets or sets the formatted message
Public property | LogId | Gets or sets the log id.
Public property | MachineName | Gets or sets the Machine Name
Public property | Message | Gets or sets the Message
Public property | Priority | Gets or sets the Priority
Public property | ProcessID | Gets or sets the ProcessID
Public property | ProcessName | Gets or sets the Process Name
Public property | Severity | Gets or sets the Severity
Public property | TenantId | Gets or sets the log tenant id.
Public property | TenantName | Gets or sets the log tenant name.
Public property | ThreadName | Gets or sets the Thread Name
Public property | Timestamp | Gets or sets the Time stamp
Public property | Title | Gets or sets the Title
Public property | UserId | Gets or sets the log user id.
Public property | UserName | Gets or sets the log user name.
Public property | Win32ThreadId | Gets or sets the Win32ThreadId

See Also

CelloLogEntry Class
CelloSaaS.Model.Logger Namespace


CelloLogEntry.AppDomainName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..AppDomainName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the App Domain Name

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AppDomainName { get; set; }
Visual Basic
Public Property AppDomainName As String
    Get
    Set
Visual C++
public:
property String^ AppDomainName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The App Domain Name

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.CategoryName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..CategoryName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the log user name.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CategoryName { get; set; }
Visual Basic
Public Property CategoryName As String
    Get
    Set
Visual C++
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log user Name.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.EventId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..EventId Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the event id.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int EventId { get; set; }
Visual Basic
Public Property EventId As Integer
    Get
    Set
Visual C++
public:
property int EventId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The event id.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.FormattedMessage Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..FormattedMessage Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the formatted message

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FormattedMessage { get; set; }
Visual Basic
Public Property FormattedMessage As String
    Get
    Set
Visual C++
public:
property String^ FormattedMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The formatted message

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.LogId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..LogId Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the log id.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int LogId { get; set; }
Visual Basic
Public Property LogId As Integer
    Get
    Set
Visual C++
public:
property int LogId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The log id.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.MachineName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..MachineName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Machine Name

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MachineName { get; set; }
Visual Basic
Public Property MachineName As String
    Get
    Set
Visual C++
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Machine Name

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.Message Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..Message Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Message

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Message

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.Priority Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..Priority Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Priority

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Priority { get; set; }
Visual Basic
Public Property Priority As Integer
    Get
    Set
Visual C++
public:
property int Priority {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The Priority

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.ProcessID Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..ProcessID Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the ProcessID

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ProcessID { get; set; }
Visual Basic
Public Property ProcessID As String
    Get
    Set
Visual C++
public:
property String^ ProcessID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Process ID

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.ProcessName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..ProcessName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Process Name

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ProcessName { get; set; }
Visual Basic
Public Property ProcessName As String
    Get
    Set
Visual C++
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Process Name

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.Severity Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..Severity Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Severity

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Severity { get; set; }
Visual Basic
Public Property Severity As String
    Get
    Set
Visual C++
public:
property String^ Severity {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Severity

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.TenantId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..TenantId Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the log tenant id.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log tenant id.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.TenantName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..TenantName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the log tenant name.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantName { get; set; }
Visual Basic
Public Property TenantName As String
    Get
    Set
Visual C++
public:
property String^ TenantName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log tenant Name.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.ThreadName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..ThreadName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Thread Name

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ThreadName { get; set; }
Visual Basic
Public Property ThreadName As String
    Get
    Set
Visual C++
public:
property String^ ThreadName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Thread Name

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.Timestamp Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..Timestamp Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Time stamp

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The Time stamp

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.Title Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..Title Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Title

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Title

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.UserId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..UserId Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the log user id.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log user id.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.UserName Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..UserName Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the log user name.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log user Name.

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntry.Win32ThreadId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntry..::..Win32ThreadId Property
CelloLogEntry Class See Also Send Feedback
Gets or sets the Win32ThreadId

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Win32ThreadId { get; set; }
Visual Basic
Public Property Win32ThreadId As String
    Get
    Set
Visual C++
public:
property String^ Win32ThreadId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Win32ThreadId

See Also

CelloLogEntry Class
CelloLogEntry Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition Class

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition Class
Members See Also Send Feedback
Cello LogEntry SearchCondition class

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CelloLogEntrySearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class CelloLogEntrySearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class CelloLogEntrySearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Logger..::..CelloLogEntrySearchCondition

See Also

CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition Members
CelloLogEntrySearchCondition Class Constructors Methods Properties See Also Send Feedback

The CelloLogEntrySearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CelloLogEntrySearchCondition | Initializes a new instance of the CelloLogEntrySearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition [Not Used]
Public property | FromDate | Gets or sets from date.
Public property | Offset | Gets or sets the offset.
Public property | PageSize | Gets or sets the size of the page.
Public property | SearchType | Gets or sets the search type.
Public property | SearchValue | Gets or sets the search value.
Public property | SessionId | Gets or sets the session id.
Public property | Severage | Gets or sets the severage
Public property | SortDirection | Gets or sets the sort direction.
Public property | SortString | Gets or sets the sort string.
Public property | TenantId | Gets or sets the tenant id.
Public property | ToDate | Gets or sets to date.

See Also

CelloLogEntrySearchCondition Class
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition Constructor

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition Constructor
CelloLogEntrySearchCondition Class See Also Send Feedback
Initializes a new instance of the CelloLogEntrySearchCondition class

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloLogEntrySearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
CelloLogEntrySearchCondition()

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition Methods
CelloLogEntrySearchCondition Class See Also Send Feedback

The CelloLogEntrySearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CelloLogEntrySearchCondition Class
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition Properties
CelloLogEntrySearchCondition Class See Also Send Feedback

The CelloLogEntrySearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition [Not Used]
Public property | FromDate | Gets or sets from date.
Public property | Offset | Gets or sets the offset.
Public property | PageSize | Gets or sets the size of the page.
Public property | SearchType | Gets or sets the search type.
Public property | SearchValue | Gets or sets the search value.
Public property | SessionId | Gets or sets the session id.
Public property | Severage | Gets or sets the severage
Public property | SortDirection | Gets or sets the sort direction.
Public property | SortString | Gets or sets the sort string.
Public property | TenantId | Gets or sets the tenant id.
Public property | ToDate | Gets or sets to date.

See Also

CelloLogEntrySearchCondition Class
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..Condition Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Condition [Not Used]

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.FromDate Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..FromDate Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets from date.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromDate { get; set; }
Visual Basic
Public Property FromDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
From date.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.Offset Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..Offset Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the offset.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Offset { get; set; }
Visual Basic
Public Property Offset As Integer
    Get
    Set
Visual C++
public:
property int Offset {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The offset.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..PageSize Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the size of the page.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The size of the page.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.SearchType Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..SearchType Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the search type.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchType { get; set; }
Visual Basic
Public Property SearchType As String
    Get
    Set
Visual C++
public:
property String^ SearchType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The search type

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.SearchValue Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..SearchValue Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the search value.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchValue { get; set; }
Visual Basic
Public Property SearchValue As String
    Get
    Set
Visual C++
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The search value

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.SessionId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..SessionId Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the session id.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SessionId { get; set; }
Visual Basic
Public Property SessionId As String
    Get
    Set
Visual C++
public:
property String^ SessionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The session id.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.Severage Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..Severage Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the severage

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Severage { get; set; }
Visual Basic
Public Property Severage As String
    Get
    Set
Visual C++
public:
property String^ Severage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The severage.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..SortDirection Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the sort direction.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort direction.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..SortString Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the sort string.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort string.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..TenantId Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchCondition.ToDate Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchCondition..::..ToDate Property
CelloLogEntrySearchCondition Class See Also Send Feedback
Gets or sets to date.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToDate { get; set; }
Visual Basic
Public Property ToDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
To date.

See Also

CelloLogEntrySearchCondition Class
CelloLogEntrySearchCondition Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult Class

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult Class
Members See Also Send Feedback
Cello log entiry search result class

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CelloLogEntrySearchResult
Visual Basic
<SerializableAttribute>
Public Class CelloLogEntrySearchResult
Visual C++
[SerializableAttribute]
public ref class CelloLogEntrySearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Logger..::..CelloLogEntrySearchResult

See Also

CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult Members

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult Members
CelloLogEntrySearchResult Class Constructors Methods Properties See Also Send Feedback

The CelloLogEntrySearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | CelloLogEntrySearchResult | Initializes a new instance of the CelloLogEntrySearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Gets or sets the items collection
Public property | TotalCount | Gets or sets the total count.
Public property | TotalCritical | Gets or sets the total Critical.
Public property | TotalError | Gets or sets the total error.
Public property | TotalWarning | Gets or sets the total warning.

See Also

CelloLogEntrySearchResult Class
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult Constructor

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult Constructor
CelloLogEntrySearchResult Class See Also Send Feedback
Initializes a new instance of the CelloLogEntrySearchResult class

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CelloLogEntrySearchResult()
Visual Basic
Public Sub New
Visual C++
public:
CelloLogEntrySearchResult()

See Also

CelloLogEntrySearchResult Class
CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult Methods
CelloLogEntrySearchResult Class See Also Send Feedback

The CelloLogEntrySearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CelloLogEntrySearchResult Class
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult Properties
CelloLogEntrySearchResult Class See Also Send Feedback

The CelloLogEntrySearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets or sets the items collection
Public property | TotalCount | Gets or sets the total count.
Public property | TotalCritical | Gets or sets the total Critical.
Public property | TotalError | Gets or sets the total error.
Public property | TotalWarning | Gets or sets the total warning.

See Also

CelloLogEntrySearchResult Class
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult.Items Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult..::..Items Property
CelloLogEntrySearchResult Class See Also Send Feedback
Gets or sets the items collection

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<CelloLogEntry> Items { get; set; }
Visual Basic
Public Property Items As ICollection(Of CelloLogEntry)
    Get
    Set
Visual C++
public:
property ICollection<CelloLogEntry^>^ Items {
    ICollection<CelloLogEntry^>^ get ();
    void set (ICollection<CelloLogEntry^>^ value);
}

Property Value

Type: ICollection<(Of <(<' CelloLogEntry >)>)>

See Also

CelloLogEntrySearchResult Class
CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult..::..TotalCount Property
CelloLogEntrySearchResult Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

CelloLogEntrySearchResult Class
CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult.TotalCritical Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult..::..TotalCritical Property
CelloLogEntrySearchResult Class See Also Send Feedback
Gets or sets the total Critical.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCritical { get; set; }
Visual Basic
Public Property TotalCritical As Integer
    Get
    Set
Visual C++
public:
property int TotalCritical {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total Critical.

See Also

CelloLogEntrySearchResult Class
CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult.TotalError Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult..::..TotalError Property
CelloLogEntrySearchResult Class See Also Send Feedback
Gets or sets the total error.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalError { get; set; }
Visual Basic
Public Property TotalError As Integer
    Get
    Set
Visual C++
public:
property int TotalError {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total error.

See Also

CelloLogEntrySearchResult Class
CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloLogEntrySearchResult.TotalWarning Property

[image]

A Sandcastle Documented Class Library
CelloLogEntrySearchResult..::..TotalWarning Property
CelloLogEntrySearchResult Class See Also Send Feedback
Gets or sets the total warning.

Namespace: CelloSaaS.Model.Logger
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalWarning { get; set; }
Visual Basic
Public Property TotalWarning As Integer
    Get
    Set
Visual C++
public:
property int TotalWarning {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total warning.

See Also

CelloLogEntrySearchResult Class
CelloLogEntrySearchResult Members
CelloSaaS.Model.Logger Namespace


CelloSaaS.Model.MasterData Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.MasterData Namespace
Send Feedback

Classes

 | Class | Description
Public class | Country | Country Properties
Public class | Language | Language Properties


Country Class

[image]

A Sandcastle Documented Class Library
Country Class
Members See Also Send Feedback
Country Properties

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Country
Visual Basic
<SerializableAttribute>
Public Class Country
Visual C++
[SerializableAttribute]
public ref class Country

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.MasterData..::..Country

See Also

Country Members
CelloSaaS.Model.MasterData Namespace


Country Members

[image] [image]

A Sandcastle Documented Class Library
Country Members
Country Class Constructors Methods Properties See Also Send Feedback

The Country type exposes the following members.

Constructors

 | Name | Description
Public method | Country | Initializes a new instance of the Country class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CountryId | This used to get or set Identifier of the country.
Public property | CreatedBy | This used to get or set created by Identifier/name of the country.
Public property | CreatedOn | This used to get or set created date of the country.
Public property | Name | This used to get or set name of the country.
Public property | Status | This used to get or set status of the country.
Public property | UpdatedBy | This used to get or set last updated by Identifier/name of the country.
Public property | UpdatedOn | This used to get or set last updated date of the country.

See Also

Country Class
CelloSaaS.Model.MasterData Namespace


Country Constructor

[image]

A Sandcastle Documented Class Library
Country Constructor
Country Class See Also Send Feedback
Initializes a new instance of the Country class

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Country()
Visual Basic
Public Sub New
Visual C++
public:
Country()

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country Methods

[image] [image]

A Sandcastle Documented Class Library
Country Methods
Country Class See Also Send Feedback

The Country type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Country Class
CelloSaaS.Model.MasterData Namespace


Country Properties

[image] [image]

A Sandcastle Documented Class Library
Country Properties
Country Class See Also Send Feedback

The Country type exposes the following members.

Properties

 | Name | Description
Public property | CountryId | This used to get or set Identifier of the country.
Public property | CreatedBy | This used to get or set created by Identifier/name of the country.
Public property | CreatedOn | This used to get or set created date of the country.
Public property | Name | This used to get or set name of the country.
Public property | Status | This used to get or set status of the country.
Public property | UpdatedBy | This used to get or set last updated by Identifier/name of the country.
Public property | UpdatedOn | This used to get or set last updated date of the country.

See Also

Country Class
CelloSaaS.Model.MasterData Namespace


Country.CountryId Property

[image]

A Sandcastle Documented Class Library
Country..::..CountryId Property
Country Class See Also Send Feedback
This used to get or set Identifier of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CountryId { get; set; }
Visual Basic
Public Property CountryId As String
    Get
    Set
Visual C++
public:
property String^ CountryId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Country..::..CreatedBy Property
Country Class See Also Send Feedback
This used to get or set created by Identifier/name of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Country..::..CreatedOn Property
Country Class See Also Send Feedback
This used to get or set created date of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country.Name Property

[image]

A Sandcastle Documented Class Library
Country..::..Name Property
Country Class See Also Send Feedback
This used to get or set name of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country.Status Property

[image]

A Sandcastle Documented Class Library
Country..::..Status Property
Country Class See Also Send Feedback
This used to get or set status of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Country..::..UpdatedBy Property
Country Class See Also Send Feedback
This used to get or set last updated by Identifier/name of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Country.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Country..::..UpdatedOn Property
Country Class See Also Send Feedback
This used to get or set last updated date of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Country Class
Country Members
CelloSaaS.Model.MasterData Namespace


Language Class

[image]

A Sandcastle Documented Class Library
Language Class
Members See Also Send Feedback
Language Properties

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Language
Visual Basic
<SerializableAttribute>
Public Class Language
Visual C++
[SerializableAttribute]
public ref class Language

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.MasterData..::..Language

See Also

Language Members
CelloSaaS.Model.MasterData Namespace


Language Members

[image] [image]

A Sandcastle Documented Class Library
Language Members
Language Class Constructors Methods Properties See Also Send Feedback

The Language type exposes the following members.

Constructors

 | Name | Description
Public method | Language | Initializes a new instance of the Language class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Code | This used to get or set the language code.
Public property | CreatedBy | This used to get or set the created by.
Public property | CreatedOn | This used to get or set the created on.
Public property | Id | This used to get or set the language id.
Public property | Name | This used to get or set the language Name.
Public property | Status | This used to get or set status of the country.
Public property | UpdatedBy | This used to get or set last updated by Identifier/name of the language.
Public property | UpdatedOn | This used to get or set last updated date of the language.

See Also

Language Class
CelloSaaS.Model.MasterData Namespace


Language Constructor

[image]

A Sandcastle Documented Class Library
Language Constructor
Language Class See Also Send Feedback
Initializes a new instance of the Language class

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Language()
Visual Basic
Public Sub New
Visual C++
public:
Language()

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language Methods

[image] [image]

A Sandcastle Documented Class Library
Language Methods
Language Class See Also Send Feedback

The Language type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Language Class
CelloSaaS.Model.MasterData Namespace


Language Properties

[image] [image]

A Sandcastle Documented Class Library
Language Properties
Language Class See Also Send Feedback

The Language type exposes the following members.

Properties

 | Name | Description
Public property | Code | This used to get or set the language code.
Public property | CreatedBy | This used to get or set the created by.
Public property | CreatedOn | This used to get or set the created on.
Public property | Id | This used to get or set the language id.
Public property | Name | This used to get or set the language Name.
Public property | Status | This used to get or set status of the country.
Public property | UpdatedBy | This used to get or set last updated by Identifier/name of the language.
Public property | UpdatedOn | This used to get or set last updated date of the language.

See Also

Language Class
CelloSaaS.Model.MasterData Namespace


Language.Code Property

[image]

A Sandcastle Documented Class Library
Language..::..Code Property
Language Class See Also Send Feedback
This used to get or set the language code.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The code.

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Language..::..CreatedBy Property
Language Class See Also Send Feedback
This used to get or set the created by.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Language..::..CreatedOn Property
Language Class See Also Send Feedback
This used to get or set the created on.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.Id Property

[image]

A Sandcastle Documented Class Library
Language..::..Id Property
Language Class See Also Send Feedback
This used to get or set the language id.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The language id.

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.Name Property

[image]

A Sandcastle Documented Class Library
Language..::..Name Property
Language Class See Also Send Feedback
This used to get or set the language Name.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.Status Property

[image]

A Sandcastle Documented Class Library
Language..::..Status Property
Language Class See Also Send Feedback
This used to get or set status of the country.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Language..::..UpdatedBy Property
Language Class See Also Send Feedback
This used to get or set last updated by Identifier/name of the language.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


Language.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Language..::..UpdatedOn Property
Language Class See Also Send Feedback
This used to get or set last updated date of the language.

Namespace: CelloSaaS.Model.MasterData
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Language Class
Language Members
CelloSaaS.Model.MasterData Namespace


CelloSaaS.Model.MasterDataManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.MasterDataManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | ChildData | This class holds collection of Ids and Values
Public class | ChildRelationData | This class holds list of child data.
Public class | ColumnMetadata | This class holds metaData of column.
Public class | GenericMasterData | Generic Meta Data properties
Public class | MasterDataEntity | This class holds the properties of masterData
Public class | MasterDataSearchCondition | This class holds master data search condition properties.

Enumerations

 | Enumeration | Description
Public enumeration | ChildType | Enum of childType


ChildData Class

[image]

A Sandcastle Documented Class Library
ChildData Class
Members See Also Send Feedback
This class holds collection of Ids and Values

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ChildData
Visual Basic
<SerializableAttribute>
Public Class ChildData
Visual C++
[SerializableAttribute]
public ref class ChildData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.MasterDataManagement..::..ChildData

See Also

ChildData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildData Members

[image] [image]

A Sandcastle Documented Class Library
ChildData Members
ChildData Class Constructors Methods Properties See Also Send Feedback

The ChildData type exposes the following members.

Constructors

 | Name | Description
Public method | ChildData | Initializes a new instance of the ChildData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildType | Gets and sets childType
Public property | IdValueCollection | Gets and sets IdValue collections

See Also

ChildData Class
CelloSaaS.Model.MasterDataManagement Namespace


ChildData Constructor

[image]

A Sandcastle Documented Class Library
ChildData Constructor
ChildData Class See Also Send Feedback
Initializes a new instance of the ChildData class

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ChildData()
Visual Basic
Public Sub New
Visual C++
public:
ChildData()

See Also

ChildData Class
ChildData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildData Methods

[image] [image]

A Sandcastle Documented Class Library
ChildData Methods
ChildData Class See Also Send Feedback

The ChildData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ChildData Class
CelloSaaS.Model.MasterDataManagement Namespace


ChildData Properties

[image] [image]

A Sandcastle Documented Class Library
ChildData Properties
ChildData Class See Also Send Feedback

The ChildData type exposes the following members.

Properties

 | Name | Description
Public property | ChildType | Gets and sets childType
Public property | IdValueCollection | Gets and sets IdValue collections

See Also

ChildData Class
CelloSaaS.Model.MasterDataManagement Namespace


ChildData.ChildType Property

[image]

A Sandcastle Documented Class Library
ChildData..::..ChildType Property
ChildData Class See Also Send Feedback
Gets and sets childType

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ChildType ChildType { get; set; }
Visual Basic
Public Property ChildType As ChildType
    Get
    Set
Visual C++
public:
property ChildType ChildType {
    ChildType get ();
    void set (ChildType value);
}

Property Value

Type: ChildType

See Also

ChildData Class
ChildData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildData.IdValueCollection Property

[image]

A Sandcastle Documented Class Library
ChildData..::..IdValueCollection Property
ChildData Class See Also Send Feedback
Gets and sets IdValue collections

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, string> IdValueCollection { get; set; }
Visual Basic
Public Property IdValueCollection As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ IdValueCollection {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, String>)>)>

See Also

ChildData Class
ChildData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData Class

[image]

A Sandcastle Documented Class Library
ChildRelationData Class
Members See Also Send Feedback
This class holds list of child data.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ChildRelationData
Visual Basic
<SerializableAttribute>
Public Class ChildRelationData
Visual C++
[SerializableAttribute]
public ref class ChildRelationData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.MasterDataManagement..::..ChildRelationData

See Also

ChildRelationData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData Members

[image] [image]

A Sandcastle Documented Class Library
ChildRelationData Members
ChildRelationData Class Constructors Methods Properties See Also Send Feedback

The ChildRelationData type exposes the following members.

Constructors

 | Name | Description
Public method | ChildRelationData | Initializes a new instance of the ChildRelationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildData | Gets and sets the collection of childData
Public property | MasterDataName | Gets and sets masterDataName.

See Also

ChildRelationData Class
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData Constructor

[image]

A Sandcastle Documented Class Library
ChildRelationData Constructor
ChildRelationData Class See Also Send Feedback
Initializes a new instance of the ChildRelationData class

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ChildRelationData()
Visual Basic
Public Sub New
Visual C++
public:
ChildRelationData()

See Also

ChildRelationData Class
ChildRelationData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData Methods

[image] [image]

A Sandcastle Documented Class Library
ChildRelationData Methods
ChildRelationData Class See Also Send Feedback

The ChildRelationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ChildRelationData Class
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData Properties

[image] [image]

A Sandcastle Documented Class Library
ChildRelationData Properties
ChildRelationData Class See Also Send Feedback

The ChildRelationData type exposes the following members.

Properties

 | Name | Description
Public property | ChildData | Gets and sets the collection of childData
Public property | MasterDataName | Gets and sets masterDataName.

See Also

ChildRelationData Class
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData.ChildData Property

[image]

A Sandcastle Documented Class Library
ChildRelationData..::..ChildData Property
ChildRelationData Class See Also Send Feedback
Gets and sets the collection of childData

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, ChildData> ChildData { get; set; }
Visual Basic
Public Property ChildData As Dictionary(Of String, ChildData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, ChildData^>^ ChildData {
    Dictionary<String^, ChildData^>^ get ();
    void set (Dictionary<String^, ChildData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, ChildData >)>)>

See Also

ChildRelationData Class
ChildRelationData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildRelationData.MasterDataName Property

[image]

A Sandcastle Documented Class Library
ChildRelationData..::..MasterDataName Property
ChildRelationData Class See Also Send Feedback
Gets and sets masterDataName.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MasterDataName { get; set; }
Visual Basic
Public Property MasterDataName As String
    Get
    Set
Visual C++
public:
property String^ MasterDataName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ChildRelationData Class
ChildRelationData Members
CelloSaaS.Model.MasterDataManagement Namespace


ChildType Enumeration

[image]

A Sandcastle Documented Class Library
ChildType Enumeration
See Also Send Feedback
Enum of childType

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum ChildType
Visual Basic
Public Enumeration ChildType
Visual C++
public enum class ChildType

Members

Member name | Value | Description
PickupList | 0 | Pickup List Type
DropDownList | 1 | Drop Down List Type

See Also

CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata Class

[image]

A Sandcastle Documented Class Library
ColumnMetadata Class
Members See Also Send Feedback
This class holds metaData of column.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ColumnMetadata
Visual Basic
<SerializableAttribute>
Public Class ColumnMetadata
Visual C++
[SerializableAttribute]
public ref class ColumnMetadata

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.MasterDataManagement..::..ColumnMetadata

See Also

ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata Members

[image] [image]

A Sandcastle Documented Class Library
ColumnMetadata Members
ColumnMetadata Class Constructors Methods Properties See Also Send Feedback

The ColumnMetadata type exposes the following members.

Constructors

 | Name | Description
Public method | ColumnMetadata | Initializes a new instance of the ColumnMetadata class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowDBNull | Indicates if the column has AllowDBNull property
Public property | IsIdentity | Indicates if the column is an identity column
Public property | IsKey | Indicates if the column is a key
Public property | Name | Name of the column
Public property | Type | Gets and sets DB Type

See Also

ColumnMetadata Class
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata Constructor

[image]

A Sandcastle Documented Class Library
ColumnMetadata Constructor
ColumnMetadata Class See Also Send Feedback
Initializes a new instance of the ColumnMetadata class

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ColumnMetadata()
Visual Basic
Public Sub New
Visual C++
public:
ColumnMetadata()

See Also

ColumnMetadata Class
ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata Methods

[image] [image]

A Sandcastle Documented Class Library
ColumnMetadata Methods
ColumnMetadata Class See Also Send Feedback

The ColumnMetadata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColumnMetadata Class
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata Properties

[image] [image]

A Sandcastle Documented Class Library
ColumnMetadata Properties
ColumnMetadata Class See Also Send Feedback

The ColumnMetadata type exposes the following members.

Properties

 | Name | Description
Public property | AllowDBNull | Indicates if the column has AllowDBNull property
Public property | IsIdentity | Indicates if the column is an identity column
Public property | IsKey | Indicates if the column is a key
Public property | Name | Name of the column
Public property | Type | Gets and sets DB Type

See Also

ColumnMetadata Class
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata.AllowDBNull Property

[image]

A Sandcastle Documented Class Library
ColumnMetadata..::..AllowDBNull Property
ColumnMetadata Class See Also Send Feedback
Indicates if the column has AllowDBNull property

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool AllowDBNull { get; set; }
Visual Basic
Public Property AllowDBNull As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDBNull {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ColumnMetadata Class
ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata.IsIdentity Property

[image]

A Sandcastle Documented Class Library
ColumnMetadata..::..IsIdentity Property
ColumnMetadata Class See Also Send Feedback
Indicates if the column is an identity column

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsIdentity { get; set; }
Visual Basic
Public Property IsIdentity As Boolean
    Get
    Set
Visual C++
public:
property bool IsIdentity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ColumnMetadata Class
ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata.IsKey Property

[image]

A Sandcastle Documented Class Library
ColumnMetadata..::..IsKey Property
ColumnMetadata Class See Also Send Feedback
Indicates if the column is a key

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsKey { get; set; }
Visual Basic
Public Property IsKey As Boolean
    Get
    Set
Visual C++
public:
property bool IsKey {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ColumnMetadata Class
ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata.Name Property

[image]

A Sandcastle Documented Class Library
ColumnMetadata..::..Name Property
ColumnMetadata Class See Also Send Feedback
Name of the column

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ColumnMetadata Class
ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


ColumnMetadata.Type Property

[image]

A Sandcastle Documented Class Library
ColumnMetadata..::..Type Property
ColumnMetadata Class See Also Send Feedback
Gets and sets DB Type

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DbType Type { get; set; }
Visual Basic
Public Property Type As DbType
    Get
    Set
Visual C++
public:
property DbType Type {
    DbType get ();
    void set (DbType value);
}

Property Value

Type: DbType

See Also

ColumnMetadata Class
ColumnMetadata Members
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Class

[image]

A Sandcastle Documented Class Library
GenericMasterData Class
Members See Also Send Feedback
Generic Meta Data properties

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class GenericMasterData : MasterDataEntity
Visual Basic
Public Class GenericMasterData
    Inherits MasterDataEntity
Visual C++
public ref class GenericMasterData : public MasterDataEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.MasterDataManagement..::..MasterDataEntity
CelloSaaS.Model.MasterDataManagement..::..GenericMasterData

See Also

GenericMasterData Members
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Members

[image] [image]

A Sandcastle Documented Class Library
GenericMasterData Members
GenericMasterData Class Constructors Methods Properties See Also Send Feedback

The GenericMasterData type exposes the following members.

Constructors

 | Name | Description
Public method | GenericMasterData()()()() | Default constructor
Public method | GenericMasterData(String) | Constructor of Generic Meta Data with entity identifier

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Create | This method is used to create object (Overrides MasterDataEntity..::..Create(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEntityIdentifier | Set entity Identifier (Inherited from MasterDataEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | EntityIdentifier | Overrides get property of entityIdentifier (Inherited from MasterDataEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MasterDataName | Gets and sets masterDataName (Inherited from MasterDataEntity.)
Public property | Properties | It has collection of column values with column Identifier as key. This column Identifier should be column name. (Inherited from MasterDataEntity.)
Public property | Status | Gets and sets status (Inherited from MasterDataEntity.)
Public property | TenantId | Gets and sets Tenant Identifier (Inherited from MasterDataEntity.)
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

GenericMasterData Class
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Constructor

[image] [image]

A Sandcastle Documented Class Library
GenericMasterData Constructor
GenericMasterData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GenericMasterData()()()() | Default constructor
Public method | GenericMasterData(String) | Constructor of Generic Meta Data with entity identifier

See Also

GenericMasterData Class
GenericMasterData Members
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Constructor

[image]

A Sandcastle Documented Class Library
GenericMasterData Constructor
GenericMasterData Class See Also Send Feedback
Default constructor

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public GenericMasterData()
Visual Basic
Public Sub New
Visual C++
public:
GenericMasterData()

See Also

GenericMasterData Class
GenericMasterData Members
GenericMasterData Overload
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Constructor (String)

[image]

A Sandcastle Documented Class Library
GenericMasterData Constructor (String)
GenericMasterData Class See Also Send Feedback
Constructor of Generic Meta Data with entity identifier

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public GenericMasterData(
    string entityIdentifier
)
Visual Basic
Public Sub New (
    entityIdentifier As String
)
Visual C++
public:
GenericMasterData(
    String^ entityIdentifier
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier

See Also

GenericMasterData Class
GenericMasterData Members
GenericMasterData Overload
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Methods

[image] [image]

A Sandcastle Documented Class Library
GenericMasterData Methods
GenericMasterData Class See Also Send Feedback

The GenericMasterData type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Create | This method is used to create object (Overrides MasterDataEntity..::..Create(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEntityIdentifier | Set entity Identifier (Inherited from MasterDataEntity.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

GenericMasterData Class
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData.Create Method

[image]

A Sandcastle Documented Class Library
GenericMasterData..::..Create Method
GenericMasterData Class See Also Send Feedback
This method is used to create object

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override Object Create(
    string entityIdentifier
)
Visual Basic
Public Overrides Function Create (
    entityIdentifier As String
) As Object
Visual C++
public:
virtual Object^ Create(
    String^ entityIdentifier
) override

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier

Return Value

Type: Object
Object

See Also

GenericMasterData Class
GenericMasterData Members
CelloSaaS.Model.MasterDataManagement Namespace


GenericMasterData Properties

[image] [image]

A Sandcastle Documented Class Library
GenericMasterData Properties
GenericMasterData Class See Also Send Feedback

The GenericMasterData type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Overrides get property of entityIdentifier (Inherited from MasterDataEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MasterDataName | Gets and sets masterDataName (Inherited from MasterDataEntity.)
Public property | Properties | It has collection of column values with column Identifier as key. This column Identifier should be column name. (Inherited from MasterDataEntity.)
Public property | Status | Gets and sets status (Inherited from MasterDataEntity.)
Public property | TenantId | Gets and sets Tenant Identifier (Inherited from MasterDataEntity.)
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

GenericMasterData Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity Class

[image]

A Sandcastle Documented Class Library
MasterDataEntity Class
Members See Also Send Feedback
This class holds the properties of masterData

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public abstract class MasterDataEntity : BaseEntity
Visual Basic
<SerializableAttribute>
Public MustInherit Class MasterDataEntity
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class MasterDataEntity abstract : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.MasterDataManagement..::..MasterDataEntity
CelloSaaS.Model.MasterDataManagement..::..GenericMasterData

See Also

MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity Members

[image] [image]

A Sandcastle Documented Class Library
MasterDataEntity Members
MasterDataEntity Class Constructors Methods Properties See Also Send Feedback

The MasterDataEntity type exposes the following members.

Constructors

 | Name | Description
Protected method | MasterDataEntity | Initializes a new instance of the MasterDataEntity class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Create | This method is used to create object based on the entity identifier
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEntityIdentifier | Set entity Identifier
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | EntityIdentifier | Overrides get property of entityIdentifier (Overrides BaseEntity..::..EntityIdentifier.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MasterDataName | Gets and sets masterDataName
Public property | Properties | It has collection of column values with column Identifier as key. This column Identifier should be column name.
Public property | Status | Gets and sets status
Public property | TenantId | Gets and sets Tenant Identifier
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

MasterDataEntity Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity Constructor

[image]

A Sandcastle Documented Class Library
MasterDataEntity Constructor
MasterDataEntity Class See Also Send Feedback
Initializes a new instance of the MasterDataEntity class

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected MasterDataEntity()
Visual Basic
Protected Sub New
Visual C++
protected:
MasterDataEntity()

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity Methods

[image] [image]

A Sandcastle Documented Class Library
MasterDataEntity Methods
MasterDataEntity Class See Also Send Feedback

The MasterDataEntity type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Create | This method is used to create object based on the entity identifier
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEntityIdentifier | Set entity Identifier
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

MasterDataEntity Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.Create Method

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..Create Method
MasterDataEntity Class See Also Send Feedback
This method is used to create object based on the entity identifier

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public abstract Object Create(
    string entityIdentifier
)
Visual Basic
Public MustOverride Function Create (
    entityIdentifier As String
) As Object
Visual C++
public:
virtual Object^ Create(
    String^ entityIdentifier
) abstract

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier

Return Value

Type: Object
Object

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.SetEntityIdentifier Method

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..SetEntityIdentifier Method
MasterDataEntity Class See Also Send Feedback
Set entity Identifier

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected void SetEntityIdentifier(
    string entityIdentifier
)
Visual Basic
Protected Sub SetEntityIdentifier (
    entityIdentifier As String
)
Visual C++
protected:
void SetEntityIdentifier(
    String^ entityIdentifier
)

Parameters

entityIdentifier
Type: System..::..String

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity Properties

[image] [image]

A Sandcastle Documented Class Library
MasterDataEntity Properties
MasterDataEntity Class See Also Send Feedback

The MasterDataEntity type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Overrides get property of entityIdentifier (Overrides BaseEntity..::..EntityIdentifier.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MasterDataName | Gets and sets masterDataName
Public property | Properties | It has collection of column values with column Identifier as key. This column Identifier should be column name.
Public property | Status | Gets and sets status
Public property | TenantId | Gets and sets Tenant Identifier
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

MasterDataEntity Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..EntityIdentifier Property
MasterDataEntity Class See Also Send Feedback
Overrides get property of entityIdentifier

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string EntityIdentifier { get; }
Visual Basic
Public Overrides ReadOnly Property EntityIdentifier As String
    Get
Visual C++
public:
virtual property String^ EntityIdentifier {
    String^ get () override;
}

Property Value

Type: String

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.MasterDataName Property

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..MasterDataName Property
MasterDataEntity Class See Also Send Feedback
Gets and sets masterDataName

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MasterDataName { get; set; }
Visual Basic
Public Property MasterDataName As String
    Get
    Set
Visual C++
public:
property String^ MasterDataName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.Properties Property

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..Properties Property
MasterDataEntity Class See Also Send Feedback
It has collection of column values with column Identifier as key. This column Identifier should be column name.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Object> Properties { get; set; }
Visual Basic
Public Property Properties As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ Properties {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Object>)>)>

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.Status Property

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..Status Property
MasterDataEntity Class See Also Send Feedback
Gets and sets status

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataEntity.TenantId Property

[image]

A Sandcastle Documented Class Library
MasterDataEntity..::..TenantId Property
MasterDataEntity Class See Also Send Feedback
Gets and sets Tenant Identifier

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MasterDataEntity Class
MasterDataEntity Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition Class

[image]

A Sandcastle Documented Class Library
MasterDataSearchCondition Class
Members See Also Send Feedback
This class holds master data search condition properties.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MasterDataSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class MasterDataSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class MasterDataSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.MasterDataManagement..::..MasterDataSearchCondition

See Also

MasterDataSearchCondition Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
MasterDataSearchCondition Members
MasterDataSearchCondition Class Constructors Methods Properties See Also Send Feedback

The MasterDataSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | MasterDataSearchCondition | Initializes a new instance of the MasterDataSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Gets and sets condition.
Public property | Status | Gets and sets status.
Public property | TenantId | Gets and sets TenantId.

See Also

MasterDataSearchCondition Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
MasterDataSearchCondition Constructor
MasterDataSearchCondition Class See Also Send Feedback
Initializes a new instance of the MasterDataSearchCondition class

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
MasterDataSearchCondition()

See Also

MasterDataSearchCondition Class
MasterDataSearchCondition Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
MasterDataSearchCondition Methods
MasterDataSearchCondition Class See Also Send Feedback

The MasterDataSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MasterDataSearchCondition Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
MasterDataSearchCondition Properties
MasterDataSearchCondition Class See Also Send Feedback

The MasterDataSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Gets and sets condition.
Public property | Status | Gets and sets status.
Public property | TenantId | Gets and sets TenantId.

See Also

MasterDataSearchCondition Class
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
MasterDataSearchCondition..::..Condition Property
MasterDataSearchCondition Class See Also Send Feedback
Gets and sets condition.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

MasterDataSearchCondition Class
MasterDataSearchCondition Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition.Status Property

[image]

A Sandcastle Documented Class Library
MasterDataSearchCondition..::..Status Property
MasterDataSearchCondition Class See Also Send Feedback
Gets and sets status.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MasterDataSearchCondition Class
MasterDataSearchCondition Members
CelloSaaS.Model.MasterDataManagement Namespace


MasterDataSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
MasterDataSearchCondition..::..TenantId Property
MasterDataSearchCondition Class See Also Send Feedback
Gets and sets TenantId.

Namespace: CelloSaaS.Model.MasterDataManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MasterDataSearchCondition Class
MasterDataSearchCondition Members
CelloSaaS.Model.MasterDataManagement Namespace


CelloSaaS.Model.ProductAnalytics Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.ProductAnalytics Namespace
Send Feedback

Classes

 | Class | Description
Public class | HotTrialSearchResult | Hot tenant trial search result class
Public class | ProductAnalytics | Product Analytics Model.
Public class | ProductAnalyticsSearchCondition | Product Analytics Search Condition class
Public class | ProductAnalyticsTrial | Product Analytics Report model
Public class | ProductAnalyticsTrialSearchCondition | Product analytics trial search conditin class


HotTrialSearchResult Class

[image]

A Sandcastle Documented Class Library
HotTrialSearchResult Class
Members See Also Send Feedback
Hot tenant trial search result class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class HotTrialSearchResult
Visual Basic
<SerializableAttribute>
Public Class HotTrialSearchResult
Visual C++
[SerializableAttribute]
public ref class HotTrialSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ProductAnalytics..::..HotTrialSearchResult

See Also

HotTrialSearchResult Members
CelloSaaS.Model.ProductAnalytics Namespace


HotTrialSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
HotTrialSearchResult Members
HotTrialSearchResult Class Constructors Methods Properties See Also Send Feedback

The HotTrialSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | HotTrialSearchResult | Initializes a new instance of the HotTrialSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Holds the record collection
Public property | TotalCount | Contains total records count

See Also

HotTrialSearchResult Class
CelloSaaS.Model.ProductAnalytics Namespace


HotTrialSearchResult Constructor

[image]

A Sandcastle Documented Class Library
HotTrialSearchResult Constructor
HotTrialSearchResult Class See Also Send Feedback
Initializes a new instance of the HotTrialSearchResult class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public HotTrialSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
HotTrialSearchResult()

See Also

HotTrialSearchResult Class
HotTrialSearchResult Members
CelloSaaS.Model.ProductAnalytics Namespace


HotTrialSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
HotTrialSearchResult Methods
HotTrialSearchResult Class See Also Send Feedback

The HotTrialSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HotTrialSearchResult Class
CelloSaaS.Model.ProductAnalytics Namespace


HotTrialSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
HotTrialSearchResult Properties
HotTrialSearchResult Class See Also Send Feedback

The HotTrialSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Items | Holds the record collection
Public property | TotalCount | Contains total records count

See Also

HotTrialSearchResult Class
CelloSaaS.Model.ProductAnalytics Namespace


HotTrialSearchResult.Items Property

[image]

A Sandcastle Documented Class Library
HotTrialSearchResult..::..Items Property
HotTrialSearchResult Class See Also Send Feedback
Holds the record collection

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ProductAnalyticsTrial> Items { get; set; }
Visual Basic
Public Property Items As List(Of ProductAnalyticsTrial)
    Get
    Set
Visual C++
public:
property List<ProductAnalyticsTrial^>^ Items {
    List<ProductAnalyticsTrial^>^ get ();
    void set (List<ProductAnalyticsTrial^>^ value);
}

Property Value

Type: List<(Of <(<' ProductAnalyticsTrial >)>)>

See Also

HotTrialSearchResult Class
HotTrialSearchResult Members
CelloSaaS.Model.ProductAnalytics Namespace


HotTrialSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
HotTrialSearchResult..::..TotalCount Property
HotTrialSearchResult Class See Also Send Feedback
Contains total records count

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

HotTrialSearchResult Class
HotTrialSearchResult Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics Class

[image]

A Sandcastle Documented Class Library
ProductAnalytics Class
Members See Also Send Feedback
Product Analytics Model.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ProductAnalytics : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class ProductAnalytics
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class ProductAnalytics : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.ProductAnalytics..::..ProductAnalytics

See Also

ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics Members

[image] [image]

A Sandcastle Documented Class Library
ProductAnalytics Members
ProductAnalytics Class Constructors Methods Properties See Also Send Feedback

The ProductAnalytics type exposes the following members.

Constructors

 | Name | Description
Public method | ProductAnalytics | Initializes a new instance of the ProductAnalytics class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | ActionName | Gets or sets the name of the action.
Public property | BrowserDetails | Gets or sets the log browser details.
Public property | ControllerName | Gets or sets the name of the controller.
Public property | CreatedBy | Gets or sets the log created by.
Public property | CreatedOn | Gets or sets the log created on.
Public property | CurrentUrl | Gets or sets the log current execution file path.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExceptionDetails | Gets or sets the log exeption details.
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the log id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IPAddress | Gets or sets the log IP address.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MachineName | Gets or sets the name of the log machine.
Public property | RequestMethod | Gets or sets the log HTTP method used.
Public property | RequestMode | Gets or sets the log call initiator.
Public property | ResponseDescription | Gets or sets the log response status description.
Public property | ResponseLength | Gets or sets the response length
Public property | ResponseStatusCode | Gets or sets the log response status code.
Public property | SessionId | Gets or sets the session id for this log entry.
Public property | Status | Gets or sets a value indicating whether [log status].
Public property | TenantId | Gets or sets the log tenant id.
Public property | TenantName | Gets or sets the log tenant Name.
Public property | TimeStamp | Gets or sets the log time stamp.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UserId | Gets or sets the log user id.
Public property | UserName | Gets or sets the name of the user.

See Also

ProductAnalytics Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics Constructor

[image]

A Sandcastle Documented Class Library
ProductAnalytics Constructor
ProductAnalytics Class See Also Send Feedback
Initializes a new instance of the ProductAnalytics class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ProductAnalytics()
Visual Basic
Public Sub New
Visual C++
public:
ProductAnalytics()

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics Methods

[image] [image]

A Sandcastle Documented Class Library
ProductAnalytics Methods
ProductAnalytics Class See Also Send Feedback

The ProductAnalytics type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

ProductAnalytics Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ToString Method

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ToString Method
ProductAnalytics Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents this instance.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics Properties

[image] [image]

A Sandcastle Documented Class Library
ProductAnalytics Properties
ProductAnalytics Class See Also Send Feedback

The ProductAnalytics type exposes the following members.

Properties

 | Name | Description
Public property | ActionName | Gets or sets the name of the action.
Public property | BrowserDetails | Gets or sets the log browser details.
Public property | ControllerName | Gets or sets the name of the controller.
Public property | CreatedBy | Gets or sets the log created by.
Public property | CreatedOn | Gets or sets the log created on.
Public property | CurrentUrl | Gets or sets the log current execution file path.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExceptionDetails | Gets or sets the log exeption details.
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the log id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IPAddress | Gets or sets the log IP address.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MachineName | Gets or sets the name of the log machine.
Public property | RequestMethod | Gets or sets the log HTTP method used.
Public property | RequestMode | Gets or sets the log call initiator.
Public property | ResponseDescription | Gets or sets the log response status description.
Public property | ResponseLength | Gets or sets the response length
Public property | ResponseStatusCode | Gets or sets the log response status code.
Public property | SessionId | Gets or sets the session id for this log entry.
Public property | Status | Gets or sets a value indicating whether [log status].
Public property | TenantId | Gets or sets the log tenant id.
Public property | TenantName | Gets or sets the log tenant Name.
Public property | TimeStamp | Gets or sets the log time stamp.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UserId | Gets or sets the log user id.
Public property | UserName | Gets or sets the name of the user.

See Also

ProductAnalytics Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ActionName Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ActionName Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the name of the action.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActionName { get; set; }
Visual Basic
Public Property ActionName As String
    Get
    Set
Visual C++
public:
property String^ ActionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the action.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.BrowserDetails Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..BrowserDetails Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log browser details.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BrowserDetails { get; set; }
Visual Basic
Public Property BrowserDetails As String
    Get
    Set
Visual C++
public:
property String^ BrowserDetails {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log browser details.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ControllerName Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ControllerName Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the name of the controller.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ControllerName { get; set; }
Visual Basic
Public Property ControllerName As String
    Get
    Set
Visual C++
public:
property String^ ControllerName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the controller.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.CreatedBy Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..CreatedBy Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log created by.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log created by.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.CreatedOn Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..CreatedOn Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log created on.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The log created on.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.CurrentUrl Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..CurrentUrl Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log current execution file path.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CurrentUrl { get; set; }
Visual Basic
Public Property CurrentUrl As String
    Get
    Set
Visual C++
public:
property String^ CurrentUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log current execution file path.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ExceptionDetails Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ExceptionDetails Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log exeption details.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExceptionDetails { get; set; }
Visual Basic
Public Property ExceptionDetails As String
    Get
    Set
Visual C++
public:
property String^ ExceptionDetails {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log exeption details.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.Id Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..Id Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log id.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.IPAddress Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..IPAddress Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log IP address.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string IPAddress { get; set; }
Visual Basic
Public Property IPAddress As String
    Get
    Set
Visual C++
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log IP address.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.MachineName Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..MachineName Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the name of the log machine.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MachineName { get; set; }
Visual Basic
Public Property MachineName As String
    Get
    Set
Visual C++
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the log machine.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.RequestMethod Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..RequestMethod Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log HTTP method used.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RequestMethod { get; set; }
Visual Basic
Public Property RequestMethod As String
    Get
    Set
Visual C++
public:
property String^ RequestMethod {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log HTTP method used.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.RequestMode Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..RequestMode Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log call initiator.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RequestMode { get; set; }
Visual Basic
Public Property RequestMode As String
    Get
    Set
Visual C++
public:
property String^ RequestMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log call initiator.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ResponseDescription Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ResponseDescription Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log response status description.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ResponseDescription { get; set; }
Visual Basic
Public Property ResponseDescription As String
    Get
    Set
Visual C++
public:
property String^ ResponseDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log response status description.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ResponseLength Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ResponseLength Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the response length

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public long ResponseLength { get; set; }
Visual Basic
Public Property ResponseLength As Long
    Get
    Set
Visual C++
public:
property long long ResponseLength {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.ResponseStatusCode Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..ResponseStatusCode Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log response status code.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> ResponseStatusCode { get; set; }
Visual Basic
Public Property ResponseStatusCode As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> ResponseStatusCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>
The log response status code.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.SessionId Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..SessionId Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the session id for this log entry.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SessionId { get; set; }
Visual Basic
Public Property SessionId As String
    Get
    Set
Visual C++
public:
property String^ SessionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The session id.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.Status Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..Status Property
ProductAnalytics Class See Also Send Feedback
Gets or sets a value indicating whether [log status].

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [log status]; otherwise, false.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.TenantId Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..TenantId Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log tenant id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log tenant id.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.TenantName Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..TenantName Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log tenant Name.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantName { get; set; }
Visual Basic
Public Property TenantName As String
    Get
    Set
Visual C++
public:
property String^ TenantName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log tenant id.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.TimeStamp Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..TimeStamp Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log time stamp.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime TimeStamp { get; set; }
Visual Basic
Public Property TimeStamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime TimeStamp {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The log time stamp.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.UserId Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..UserId Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the log user id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The log user id.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalytics.UserName Property

[image]

A Sandcastle Documented Class Library
ProductAnalytics..::..UserName Property
ProductAnalytics Class See Also Send Feedback
Gets or sets the name of the user.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the user.

See Also

ProductAnalytics Class
ProductAnalytics Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition Class

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition Class
Members See Also Send Feedback
Product Analytics Search Condition class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ProductAnalyticsSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class ProductAnalyticsSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class ProductAnalyticsSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsSearchCondition

See Also

ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition Members
ProductAnalyticsSearchCondition Class Constructors Methods Properties See Also Send Feedback

The ProductAnalyticsSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | ProductAnalyticsSearchCondition | Initializes a new instance of the ProductAnalyticsSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionName | Gets or sets the name of the action.
Public property | AvgPageSize | Gets or sets the average page size.
Public property | AvgResponseTime | Gets or sets the total count.
Public property | Condition | Condition [Not Used]
Public property | ControllerName | Gets or sets the name of the controller.
Public property | FromDate | Gets or sets from date.
Public property | HasError | Gets or sets the response time of the page.
Public property | Offset | Gets or sets the offset.
Public property | PageSize | Gets or sets the size of the page.
Public property | ResponseLength | Gets or sets the response length of the page.
Public property | ResponseTime | Gets or sets the response time of the page.
Public property | SessionId | Gets or sets the session id.
Public property | SortDirection | Gets or sets the sort direction.
Public property | SortString | Gets or sets the sort string.
Public property | TenantId | Gets or sets the tenant id.
Public property | ToDate | Gets or sets to date.
Public property | TotalCount | Gets or sets the total count.
Public property | UserId | Gets or sets the user id.
Public property | UserIP | Gets or sets the user IP.
Public property | UserName | Gets or sets the user name.

See Also

ProductAnalyticsSearchCondition Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition Constructor
ProductAnalyticsSearchCondition Class See Also Send Feedback
Initializes a new instance of the ProductAnalyticsSearchCondition class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ProductAnalyticsSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
ProductAnalyticsSearchCondition()

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition Methods
ProductAnalyticsSearchCondition Class See Also Send Feedback

The ProductAnalyticsSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProductAnalyticsSearchCondition Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition Properties
ProductAnalyticsSearchCondition Class See Also Send Feedback

The ProductAnalyticsSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | ActionName | Gets or sets the name of the action.
Public property | AvgPageSize | Gets or sets the average page size.
Public property | AvgResponseTime | Gets or sets the total count.
Public property | Condition | Condition [Not Used]
Public property | ControllerName | Gets or sets the name of the controller.
Public property | FromDate | Gets or sets from date.
Public property | HasError | Gets or sets the response time of the page.
Public property | Offset | Gets or sets the offset.
Public property | PageSize | Gets or sets the size of the page.
Public property | ResponseLength | Gets or sets the response length of the page.
Public property | ResponseTime | Gets or sets the response time of the page.
Public property | SessionId | Gets or sets the session id.
Public property | SortDirection | Gets or sets the sort direction.
Public property | SortString | Gets or sets the sort string.
Public property | TenantId | Gets or sets the tenant id.
Public property | ToDate | Gets or sets to date.
Public property | TotalCount | Gets or sets the total count.
Public property | UserId | Gets or sets the user id.
Public property | UserIP | Gets or sets the user IP.
Public property | UserName | Gets or sets the user name.

See Also

ProductAnalyticsSearchCondition Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.ActionName Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..ActionName Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the name of the action.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActionName { get; set; }
Visual Basic
Public Property ActionName As String
    Get
    Set
Visual C++
public:
property String^ ActionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the action.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.AvgPageSize Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..AvgPageSize Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the average page size.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public decimal AvgPageSize { get; set; }
Visual Basic
Public Property AvgPageSize As Decimal
    Get
    Set
Visual C++
public:
property Decimal AvgPageSize {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
The total count.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.AvgResponseTime Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..AvgResponseTime Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public decimal AvgResponseTime { get; set; }
Visual Basic
Public Property AvgResponseTime As Decimal
    Get
    Set
Visual C++
public:
property Decimal AvgResponseTime {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
The total count.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..Condition Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Condition [Not Used]

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.ControllerName Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..ControllerName Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the name of the controller.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ControllerName { get; set; }
Visual Basic
Public Property ControllerName As String
    Get
    Set
Visual C++
public:
property String^ ControllerName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the controller.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.FromDate Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..FromDate Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets from date.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> FromDate { get; set; }
Visual Basic
Public Property FromDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> FromDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
From date.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.HasError Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..HasError Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the response time of the page.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool HasError { get; set; }
Visual Basic
Public Property HasError As Boolean
    Get
    Set
Visual C++
public:
property bool HasError {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The response time of the page.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.Offset Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..Offset Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the offset.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Offset { get; set; }
Visual Basic
Public Property Offset As Integer
    Get
    Set
Visual C++
public:
property int Offset {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The offset.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..PageSize Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the size of the page.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The size of the page.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.ResponseLength Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..ResponseLength Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the response length of the page.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ResponseLength { get; set; }
Visual Basic
Public Property ResponseLength As Integer
    Get
    Set
Visual C++
public:
property int ResponseLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The response length of the page.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.ResponseTime Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..ResponseTime Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the response time of the page.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ResponseTime { get; set; }
Visual Basic
Public Property ResponseTime As Integer
    Get
    Set
Visual C++
public:
property int ResponseTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The response time of the page.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.SessionId Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..SessionId Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the session id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SessionId { get; set; }
Visual Basic
Public Property SessionId As String
    Get
    Set
Visual C++
public:
property String^ SessionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The session id.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..SortDirection Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the sort direction.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort direction.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..SortString Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the sort string.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort string.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..TenantId Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.ToDate Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..ToDate Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets to date.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> ToDate { get; set; }
Visual Basic
Public Property ToDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> ToDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
To date.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.TotalCount Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..TotalCount Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.UserId Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..UserId Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the user id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user id.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.UserIP Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..UserIP Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the user IP.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserIP { get; set; }
Visual Basic
Public Property UserIP As String
    Get
    Set
Visual C++
public:
property String^ UserIP {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user IP.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsSearchCondition.UserName Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsSearchCondition..::..UserName Property
ProductAnalyticsSearchCondition Class See Also Send Feedback
Gets or sets the user name.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user name.

See Also

ProductAnalyticsSearchCondition Class
ProductAnalyticsSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial Class

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial Class
Members See Also Send Feedback
Product Analytics Report model

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ProductAnalyticsTrial
Visual Basic
<SerializableAttribute>
Public Class ProductAnalyticsTrial
Visual C++
[SerializableAttribute]
public ref class ProductAnalyticsTrial

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsTrial

See Also

ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial Members

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial Members
ProductAnalyticsTrial Class Constructors Methods Properties See Also Send Feedback

The ProductAnalyticsTrial type exposes the following members.

Constructors

 | Name | Description
Public method | ProductAnalyticsTrial | Initializes a new instance of the ProductAnalyticsTrial class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AverageHits | Gets or sets the Average Hit.
Public property | LastActivity | Gets or sets trial from date
Public property | Name | Gets or sets tenant name.
Public property | TenantId | Gets or sets the tenant id.
Public property | TotalHits | Gets or sets the total hit.
Public property | TrialDays | Gets or sets trial days.
Public property | TrialFromDate | Gets or sets trial from date
Public property | TrialToDate | Gets or sets trial from date
Public property | UsedDays | Gets or sets used days.
Public property | UsedPercentage | Gets or sets used percentage
Public property | UserCounts | Gets or sets the user count.
Public property | visitFrequency | Gets or sets used percentage

See Also

ProductAnalyticsTrial Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial Constructor

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial Constructor
ProductAnalyticsTrial Class See Also Send Feedback
Initializes a new instance of the ProductAnalyticsTrial class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ProductAnalyticsTrial()
Visual Basic
Public Sub New
Visual C++
public:
ProductAnalyticsTrial()

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial Methods

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial Methods
ProductAnalyticsTrial Class See Also Send Feedback

The ProductAnalyticsTrial type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProductAnalyticsTrial Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial Properties

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial Properties
ProductAnalyticsTrial Class See Also Send Feedback

The ProductAnalyticsTrial type exposes the following members.

Properties

 | Name | Description
Public property | AverageHits | Gets or sets the Average Hit.
Public property | LastActivity | Gets or sets trial from date
Public property | Name | Gets or sets tenant name.
Public property | TenantId | Gets or sets the tenant id.
Public property | TotalHits | Gets or sets the total hit.
Public property | TrialDays | Gets or sets trial days.
Public property | TrialFromDate | Gets or sets trial from date
Public property | TrialToDate | Gets or sets trial from date
Public property | UsedDays | Gets or sets used days.
Public property | UsedPercentage | Gets or sets used percentage
Public property | UserCounts | Gets or sets the user count.
Public property | visitFrequency | Gets or sets used percentage

See Also

ProductAnalyticsTrial Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.AverageHits Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..AverageHits Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets the Average Hit.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public decimal AverageHits { get; set; }
Visual Basic
Public Property AverageHits As Decimal
    Get
    Set
Visual C++
public:
property Decimal AverageHits {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
The Average Hit.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.LastActivity Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..LastActivity Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets trial from date

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> LastActivity { get; set; }
Visual Basic
Public Property LastActivity As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> LastActivity {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The Name.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.Name Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..Name Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets tenant name.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Name.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.TenantId Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..TenantId Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.TotalHits Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..TotalHits Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets the total hit.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public long TotalHits { get; set; }
Visual Basic
Public Property TotalHits As Long
    Get
    Set
Visual C++
public:
property long long TotalHits {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
The Total Hit.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.TrialDays Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..TrialDays Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets trial days.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TrialDays { get; set; }
Visual Basic
Public Property TrialDays As Integer
    Get
    Set
Visual C++
public:
property int TrialDays {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Trial Days

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.TrialFromDate Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..TrialFromDate Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets trial from date

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> TrialFromDate { get; set; }
Visual Basic
Public Property TrialFromDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> TrialFromDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The Name.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.TrialToDate Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..TrialToDate Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets trial from date

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> TrialToDate { get; set; }
Visual Basic
Public Property TrialToDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> TrialToDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The Name.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.UsedDays Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..UsedDays Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets used days.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int UsedDays { get; set; }
Visual Basic
Public Property UsedDays As Integer
    Get
    Set
Visual C++
public:
property int UsedDays {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Used Days.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.UsedPercentage Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..UsedPercentage Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets used percentage

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public decimal UsedPercentage { get; set; }
Visual Basic
Public Property UsedPercentage As Decimal
    Get
    Set
Visual C++
public:
property Decimal UsedPercentage {
    Decimal get ();
    void set (Decimal value);
}

Property Value

Type: Decimal
used percentage

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.UserCounts Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..UserCounts Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets the user count.

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int UserCounts { get; set; }
Visual Basic
Public Property UserCounts As Integer
    Get
    Set
Visual C++
public:
property int UserCounts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The User Count.

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrial.visitFrequency Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrial..::..visitFrequency Property
ProductAnalyticsTrial Class See Also Send Feedback
Gets or sets used percentage

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string visitFrequency { get; set; }
Visual Basic
Public Property visitFrequency As String
    Get
    Set
Visual C++
public:
property String^ visitFrequency {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
used percentage

See Also

ProductAnalyticsTrial Class
ProductAnalyticsTrial Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition Class

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition Class
Members See Also Send Feedback
Product analytics trial search conditin class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ProductAnalyticsTrialSearchCondition
Visual Basic
<SerializableAttribute>
Public Class ProductAnalyticsTrialSearchCondition
Visual C++
[SerializableAttribute]
public ref class ProductAnalyticsTrialSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsTrialSearchCondition

See Also

ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition Members
ProductAnalyticsTrialSearchCondition Class Constructors Methods Properties See Also Send Feedback

The ProductAnalyticsTrialSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | ProductAnalyticsTrialSearchCondition | Initializes a new instance of the ProductAnalyticsTrialSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PageNo | Gets or sets page no
Public property | PageSize | Gets or sets page size
Public property | SinceLastActivity | Gets or sets since last activity
Public property | SortDirection | Gets or sets sort direction
Public property | SortString | Gets or sets sort string
Public property | TotalCount | Gets or sets total records
Public property | TrialFromDate | Gets or sets the trial from date
Public property | TrialToDate | Gets or sets trial to date
Public property | UserCount | Gets or sets the user count
Public property | VisitFrequently | Gets or sets visit frequently

See Also

ProductAnalyticsTrialSearchCondition Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition Constructor
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Initializes a new instance of the ProductAnalyticsTrialSearchCondition class

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ProductAnalyticsTrialSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
ProductAnalyticsTrialSearchCondition()

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition Methods
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback

The ProductAnalyticsTrialSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProductAnalyticsTrialSearchCondition Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition Properties
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback

The ProductAnalyticsTrialSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | PageNo | Gets or sets page no
Public property | PageSize | Gets or sets page size
Public property | SinceLastActivity | Gets or sets since last activity
Public property | SortDirection | Gets or sets sort direction
Public property | SortString | Gets or sets sort string
Public property | TotalCount | Gets or sets total records
Public property | TrialFromDate | Gets or sets the trial from date
Public property | TrialToDate | Gets or sets trial to date
Public property | UserCount | Gets or sets the user count
Public property | VisitFrequently | Gets or sets visit frequently

See Also

ProductAnalyticsTrialSearchCondition Class
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..PageNo Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets page no

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..PageSize Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets page size

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.SinceLastActivity Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..SinceLastActivity Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets since last activity

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int SinceLastActivity { get; set; }
Visual Basic
Public Property SinceLastActivity As Integer
    Get
    Set
Visual C++
public:
property int SinceLastActivity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..SortDirection Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets sort direction

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..SortString Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets sort string

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.TotalCount Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..TotalCount Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets total records

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.TrialFromDate Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..TrialFromDate Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets the trial from date

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> TrialFromDate { get; set; }
Visual Basic
Public Property TrialFromDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> TrialFromDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.TrialToDate Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..TrialToDate Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets trial to date

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> TrialToDate { get; set; }
Visual Basic
Public Property TrialToDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> TrialToDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.UserCount Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..UserCount Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets the user count

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int UserCount { get; set; }
Visual Basic
Public Property UserCount As Integer
    Get
    Set
Visual C++
public:
property int UserCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


ProductAnalyticsTrialSearchCondition.VisitFrequently Property

[image]

A Sandcastle Documented Class Library
ProductAnalyticsTrialSearchCondition..::..VisitFrequently Property
ProductAnalyticsTrialSearchCondition Class See Also Send Feedback
Gets or sets visit frequently

Namespace: CelloSaaS.Model.ProductAnalytics
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string VisitFrequently { get; set; }
Visual Basic
Public Property VisitFrequently As String
    Get
    Set
Visual C++
public:
property String^ VisitFrequently {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ProductAnalyticsTrialSearchCondition Class
ProductAnalyticsTrialSearchCondition Members
CelloSaaS.Model.ProductAnalytics Namespace


CelloSaaS.Model.Reporting Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.Reporting Namespace
Send Feedback

Classes

 | Class | Description
Public class | EntityFieldInfo | To Contain the Field Information for a given field in an Entity


EntityFieldInfo Class

[image]

A Sandcastle Documented Class Library
EntityFieldInfo Class
Members See Also Send Feedback
To Contain the Field Information for a given field in an Entity

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EntityFieldInfo
Visual Basic
<SerializableAttribute>
Public Class EntityFieldInfo
Visual C++
[SerializableAttribute]
public ref class EntityFieldInfo

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Reporting..::..EntityFieldInfo

See Also

EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo Members

[image] [image]

A Sandcastle Documented Class Library
EntityFieldInfo Members
EntityFieldInfo Class Constructors Methods Properties See Also Send Feedback

The EntityFieldInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EntityFieldInfo | Initializes a new instance of the EntityFieldInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name.
Public property | EntityName | Gets or sets the name of the entity.
Public property | FieldIdentifier | Gets or sets the field identifier.This is mainly used for client Script. DO NOT Utilize this property in Service, otherwise
Public property | HasPrivilege | To indicate whether this field has the privilege
Public property | IsExpressionColumn | Gets or sets a value indicating whether this instance is expression column.
Public property | IsExtensionField | Gets or sets a value indicating whether this instance is extension field.
Public property | IsIdentity | Gets or sets a value indicating whether this instance is identity.
Public property | IsNullable | Gets or sets a value indicating whether this instance is nullable.
Public property | IsReferenceField | Gets or sets a value indicating whether this instance is reference field.
Public property | IsVisible | Gets or sets a value indicating whether this instance is visible.
Public property | MappedFieldName | Gets or sets the name of the mapped field.
Public property | MaxLength | Gets or sets the length of the max.
Public property | Type | Gets or sets the type of the db data.

See Also

EntityFieldInfo Class
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo Constructor

[image]

A Sandcastle Documented Class Library
EntityFieldInfo Constructor
EntityFieldInfo Class See Also Send Feedback
Initializes a new instance of the EntityFieldInfo class.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityFieldInfo()
Visual Basic
Public Sub New
Visual C++
public:
EntityFieldInfo()

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo Methods

[image] [image]

A Sandcastle Documented Class Library
EntityFieldInfo Methods
EntityFieldInfo Class See Also Send Feedback

The EntityFieldInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EntityFieldInfo Class
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo Properties

[image] [image]

A Sandcastle Documented Class Library
EntityFieldInfo Properties
EntityFieldInfo Class See Also Send Feedback

The EntityFieldInfo type exposes the following members.

Properties

 | Name | Description
Public property | DisplayName | Gets or sets the display name.
Public property | EntityName | Gets or sets the name of the entity.
Public property | FieldIdentifier | Gets or sets the field identifier.This is mainly used for client Script. DO NOT Utilize this property in Service, otherwise
Public property | HasPrivilege | To indicate whether this field has the privilege
Public property | IsExpressionColumn | Gets or sets a value indicating whether this instance is expression column.
Public property | IsExtensionField | Gets or sets a value indicating whether this instance is extension field.
Public property | IsIdentity | Gets or sets a value indicating whether this instance is identity.
Public property | IsNullable | Gets or sets a value indicating whether this instance is nullable.
Public property | IsReferenceField | Gets or sets a value indicating whether this instance is reference field.
Public property | IsVisible | Gets or sets a value indicating whether this instance is visible.
Public property | MappedFieldName | Gets or sets the name of the mapped field.
Public property | MaxLength | Gets or sets the length of the max.
Public property | Type | Gets or sets the type of the db data.

See Also

EntityFieldInfo Class
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.DisplayName Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..DisplayName Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets the display name.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The display name.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.EntityName Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..EntityName Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets the name of the entity.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityName { get; set; }
Visual Basic
Public Property EntityName As String
    Get
    Set
Visual C++
public:
property String^ EntityName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the entity.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.FieldIdentifier Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..FieldIdentifier Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets the field identifier.This is mainly used for client Script. DO NOT Utilize this property in Service, otherwise

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldIdentifier { get; set; }
Visual Basic
Public Property FieldIdentifier As String
    Get
    Set
Visual C++
public:
property String^ FieldIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The field identifier. to uniquely identify this field among the other filter clause fields.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.HasPrivilege Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..HasPrivilege Property
EntityFieldInfo Class See Also Send Feedback
To indicate whether this field has the privilege

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool HasPrivilege { get; set; }
Visual Basic
Public Property HasPrivilege As Boolean
    Get
    Set
Visual C++
public:
property bool HasPrivilege {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.IsExpressionColumn Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..IsExpressionColumn Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is expression column.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsExpressionColumn { get; set; }
Visual Basic
Public Property IsExpressionColumn As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpressionColumn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is expression column; otherwise, false.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.IsExtensionField Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..IsExtensionField Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is extension field.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsExtensionField { get; set; }
Visual Basic
Public Property IsExtensionField As Boolean
    Get
    Set
Visual C++
public:
property bool IsExtensionField {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is extension field; otherwise, false.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.IsIdentity Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..IsIdentity Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is identity.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsIdentity { get; set; }
Visual Basic
Public Property IsIdentity As Boolean
    Get
    Set
Visual C++
public:
property bool IsIdentity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is identity; otherwise, false.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.IsNullable Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..IsNullable Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is nullable.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsNullable { get; set; }
Visual Basic
Public Property IsNullable As Boolean
    Get
    Set
Visual C++
public:
property bool IsNullable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is nullable; otherwise, false.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.IsReferenceField Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..IsReferenceField Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is reference field.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsReferenceField { get; set; }
Visual Basic
Public Property IsReferenceField As Boolean
    Get
    Set
Visual C++
public:
property bool IsReferenceField {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is reference field; otherwise, false.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.IsVisible Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..IsVisible Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets a value indicating whether this instance is visible.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is visible; otherwise, false.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.MappedFieldName Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..MappedFieldName Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets the name of the mapped field.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MappedFieldName { get; set; }
Visual Basic
Public Property MappedFieldName As String
    Get
    Set
Visual C++
public:
property String^ MappedFieldName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the mapped field.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.MaxLength Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..MaxLength Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets the length of the max.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The length of the max.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


EntityFieldInfo.Type Property

[image]

A Sandcastle Documented Class Library
EntityFieldInfo..::..Type Property
EntityFieldInfo Class See Also Send Feedback
Gets or sets the type of the db data.

Namespace: CelloSaaS.Model.Reporting
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The type of the db data.

See Also

EntityFieldInfo Class
EntityFieldInfo Members
CelloSaaS.Model.Reporting Namespace


CelloSaaS.Model.Reporting.ChartBuilder Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.Reporting.ChartBuilder Namespace
Send Feedback

Classes

 | Class | Description
Public class | ChartBuilderPrivilegeConstants | ChartBuilder Privilege Constants


ChartBuilderPrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants Class
Members See Also Send Feedback
ChartBuilder Privilege Constants

Namespace: CelloSaaS.Model.Reporting.ChartBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ChartBuilderPrivilegeConstants
Visual Basic
Public Class ChartBuilderPrivilegeConstants
Visual C++
public ref class ChartBuilderPrivilegeConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.Reporting.ChartBuilder..::..ChartBuilderPrivilegeConstants

See Also

ChartBuilderPrivilegeConstants Members
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants Members
ChartBuilderPrivilegeConstants Class Constructors Methods Properties See Also Send Feedback

The ChartBuilderPrivilegeConstants type exposes the following members.

Constructors

 | Name | Description
Public method | ChartBuilderPrivilegeConstants | Initializes a new instance of the ChartBuilderPrivilegeConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AddChart | Add Chart Privilege
DeleteChart | Delete Chart Privilege
EditChart | Edit Chart Privilege
ViewChart | View Chart Privilege

See Also

ChartBuilderPrivilegeConstants Class
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants Constructor

[image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants Constructor
ChartBuilderPrivilegeConstants Class See Also Send Feedback
Initializes a new instance of the ChartBuilderPrivilegeConstants class

Namespace: CelloSaaS.Model.Reporting.ChartBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ChartBuilderPrivilegeConstants()
Visual Basic
Public Sub New
Visual C++
public:
ChartBuilderPrivilegeConstants()

See Also

ChartBuilderPrivilegeConstants Class
ChartBuilderPrivilegeConstants Members
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants Methods

[image] [image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants Methods
ChartBuilderPrivilegeConstants Class See Also Send Feedback

The ChartBuilderPrivilegeConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ChartBuilderPrivilegeConstants Class
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants Properties

[image] [image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants Properties
ChartBuilderPrivilegeConstants Class See Also Send Feedback

The ChartBuilderPrivilegeConstants type exposes the following members.

Properties

Name | Description
AddChart | Add Chart Privilege
DeleteChart | Delete Chart Privilege
EditChart | Edit Chart Privilege
ViewChart | View Chart Privilege

See Also

ChartBuilderPrivilegeConstants Class
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants.AddChart Property

[image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants..::..AddChart Property
ChartBuilderPrivilegeConstants Class See Also Send Feedback
Add Chart Privilege

Namespace: CelloSaaS.Model.Reporting.ChartBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddChart { get; }
Visual Basic
Public Shared ReadOnly Property AddChart As String
    Get
Visual C++
public:
static property String^ AddChart {
    String^ get ();
}

Property Value

Type: String

See Also

ChartBuilderPrivilegeConstants Class
ChartBuilderPrivilegeConstants Members
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants.DeleteChart Property

[image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants..::..DeleteChart Property
ChartBuilderPrivilegeConstants Class See Also Send Feedback
Delete Chart Privilege

Namespace: CelloSaaS.Model.Reporting.ChartBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteChart { get; }
Visual Basic
Public Shared ReadOnly Property DeleteChart As String
    Get
Visual C++
public:
static property String^ DeleteChart {
    String^ get ();
}

Property Value

Type: String

See Also

ChartBuilderPrivilegeConstants Class
ChartBuilderPrivilegeConstants Members
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants.EditChart Property

[image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants..::..EditChart Property
ChartBuilderPrivilegeConstants Class See Also Send Feedback
Edit Chart Privilege

Namespace: CelloSaaS.Model.Reporting.ChartBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditChart { get; }
Visual Basic
Public Shared ReadOnly Property EditChart As String
    Get
Visual C++
public:
static property String^ EditChart {
    String^ get ();
}

Property Value

Type: String

See Also

ChartBuilderPrivilegeConstants Class
ChartBuilderPrivilegeConstants Members
CelloSaaS.Model.Reporting.ChartBuilder Namespace


ChartBuilderPrivilegeConstants.ViewChart Property

[image]

A Sandcastle Documented Class Library
ChartBuilderPrivilegeConstants..::..ViewChart Property
ChartBuilderPrivilegeConstants Class See Also Send Feedback
View Chart Privilege

Namespace: CelloSaaS.Model.Reporting.ChartBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewChart { get; }
Visual Basic
Public Shared ReadOnly Property ViewChart As String
    Get
Visual C++
public:
static property String^ ViewChart {
    String^ get ();
}

Property Value

Type: String

See Also

ChartBuilderPrivilegeConstants Class
ChartBuilderPrivilegeConstants Members
CelloSaaS.Model.Reporting.ChartBuilder Namespace


CelloSaaS.Model.Reporting.ExpressionBuilder Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExpressionException | Expression Exception Thrown whenever there is an exception encountered while handling the exceptions


ExpressionException Class

[image]

A Sandcastle Documented Class Library
ExpressionException Class
Members See Also Send Feedback
Expression Exception

Thrown whenever there is an exception encountered while handling the exceptions

Namespace: CelloSaaS.Model.Reporting.ExpressionBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ExpressionException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ExpressionException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ExpressionException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Model.Reporting.ExpressionBuilder..::..ExpressionException

See Also

ExpressionException Members
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Members

[image] [image]

A Sandcastle Documented Class Library
ExpressionException Members
ExpressionException Class Constructors Methods Properties Events See Also Send Feedback

The ExpressionException type exposes the following members.

Constructors

 | Name | Description
Public method | ExpressionException()()()() | Initializes a new instance of the ExpressionException class.
Public method | ExpressionException(String) | Initializes a new instance of the ExpressionException class.
Protected method | ExpressionException(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpressionException class.
Public method | ExpressionException(String, Exception) | Initializes a new instance of the ExpressionException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ExpressionException Class
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Constructor

[image] [image]

A Sandcastle Documented Class Library
ExpressionException Constructor
ExpressionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExpressionException()()()() | Initializes a new instance of the ExpressionException class.
Public method | ExpressionException(String) | Initializes a new instance of the ExpressionException class.
Protected method | ExpressionException(SerializationInfo, StreamingContext) | Initializes a new instance of the ExpressionException class.
Public method | ExpressionException(String, Exception) | Initializes a new instance of the ExpressionException class.

See Also

ExpressionException Class
ExpressionException Members
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Constructor

[image]

A Sandcastle Documented Class Library
ExpressionException Constructor
ExpressionException Class See Also Send Feedback
Initializes a new instance of the ExpressionException class.

Namespace: CelloSaaS.Model.Reporting.ExpressionBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExpressionException()
Visual Basic
Public Sub New
Visual C++
public:
ExpressionException()

See Also

ExpressionException Class
ExpressionException Members
ExpressionException Overload
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Constructor (String)

[image]

A Sandcastle Documented Class Library
ExpressionException Constructor (String)
ExpressionException Class See Also Send Feedback
Initializes a new instance of the ExpressionException class.

Namespace: CelloSaaS.Model.Reporting.ExpressionBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExpressionException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ExpressionException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ExpressionException Class
ExpressionException Members
ExpressionException Overload
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
ExpressionException Constructor (SerializationInfo, StreamingContext)
ExpressionException Class See Also Send Feedback
Initializes a new instance of the ExpressionException class.

Namespace: CelloSaaS.Model.Reporting.ExpressionBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected ExpressionException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
ExpressionException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

ExpressionException Class
ExpressionException Members
ExpressionException Overload
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ExpressionException Constructor (String, Exception)
ExpressionException Class See Also Send Feedback
Initializes a new instance of the ExpressionException class.

Namespace: CelloSaaS.Model.Reporting.ExpressionBuilder
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExpressionException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ExpressionException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

ExpressionException Class
ExpressionException Members
ExpressionException Overload
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Methods

[image] [image]

A Sandcastle Documented Class Library
ExpressionException Methods
ExpressionException Class See Also Send Feedback

The ExpressionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ExpressionException Class
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Properties

[image] [image]

A Sandcastle Documented Class Library
ExpressionException Properties
ExpressionException Class See Also Send Feedback

The ExpressionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExpressionException Class
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


ExpressionException Events

[image] [image]

A Sandcastle Documented Class Library
ExpressionException Events
ExpressionException Class See Also Send Feedback

The ExpressionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ExpressionException Class
CelloSaaS.Model.Reporting.ExpressionBuilder Namespace


CelloSaaS.Model.SettingsManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.SettingsManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | AttributeMetaData | Attribute Meta Data properties
Public class | AttributeSetSettingsMetaData | Attribute Set Settings Meta Data Properties
Public class | AuthenticateSettingAttributeConstant | This class defines the constants used for the tenant specific settings management.
Public class | FeatureSettingsMetaData | Feature Settings Meta Data Properties
Public class | ModuleSettingsMetaData | Module Settings Meta Data Properties
Public class | PackageSetting | Package Setting Properties
Public class | RoleSetting | Role Setting Properties
Public class | Settings | Settings Properties
Public class | SettingsAttribute | Individual Setting Attribute Model
Public class | SettingsMetaData | Settings Meta Data Properties
Public class | SettingsTemplate | SettingsTemplate Model
Public class | SettingsTemplatePrivilegeConstants | SettingsTemplate Privilege Constants
Public class | TenantSetting | Tenant Setting Properties
Public class | TenantSettingsTemplate | Tenant Settings Template Model
Public class | TenantSettingsTemplatePrivilegeConstants | TenantSettingsTemplate Privilege Constants
Public class | TenantSettingTemplateConstants | Constants for Tenant Settings Template
Public class | UserSettings | User Settings Properties

Enumerations

 | Enumeration | Description
Public enumeration | SettingTemplateType | Settings Template Type


AttributeMetaData Class

[image]

A Sandcastle Documented Class Library
AttributeMetaData Class
Members See Also Send Feedback
Attribute Meta Data properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AttributeMetaData
Visual Basic
<SerializableAttribute>
Public Class AttributeMetaData
Visual C++
[SerializableAttribute]
public ref class AttributeMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..AttributeMetaData

See Also

AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData Members

[image] [image]

A Sandcastle Documented Class Library
AttributeMetaData Members
AttributeMetaData Class Constructors Methods Properties See Also Send Feedback

The AttributeMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeMetaData | Initializes a new instance of the AttributeMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeId | Gets or sets attribute id.
Public property | AttributeName | Gets or sets attribute name.
Public property | AttributeSetId | Gets or sets attribute set id.
Public property | DataFieldTypeId | Gets or sets data field type id.
Public property | FeatureCode | Gets or sets feature code.
Public property | ModuleCode | Gets or sets module code.

See Also

AttributeMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData Constructor

[image]

A Sandcastle Documented Class Library
AttributeMetaData Constructor
AttributeMetaData Class See Also Send Feedback
Initializes a new instance of the AttributeMetaData class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AttributeMetaData()
Visual Basic
Public Sub New
Visual C++
public:
AttributeMetaData()

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
AttributeMetaData Methods
AttributeMetaData Class See Also Send Feedback

The AttributeMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AttributeMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
AttributeMetaData Properties
AttributeMetaData Class See Also Send Feedback

The AttributeMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AttributeId | Gets or sets attribute id.
Public property | AttributeName | Gets or sets attribute name.
Public property | AttributeSetId | Gets or sets attribute set id.
Public property | DataFieldTypeId | Gets or sets data field type id.
Public property | FeatureCode | Gets or sets feature code.
Public property | ModuleCode | Gets or sets module code.

See Also

AttributeMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData.AttributeId Property

[image]

A Sandcastle Documented Class Library
AttributeMetaData..::..AttributeId Property
AttributeMetaData Class See Also Send Feedback
Gets or sets attribute id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeId { get; set; }
Visual Basic
Public Property AttributeId As String
    Get
    Set
Visual C++
public:
property String^ AttributeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData.AttributeName Property

[image]

A Sandcastle Documented Class Library
AttributeMetaData..::..AttributeName Property
AttributeMetaData Class See Also Send Feedback
Gets or sets attribute name.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeName { get; set; }
Visual Basic
Public Property AttributeName As String
    Get
    Set
Visual C++
public:
property String^ AttributeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData.AttributeSetId Property

[image]

A Sandcastle Documented Class Library
AttributeMetaData..::..AttributeSetId Property
AttributeMetaData Class See Also Send Feedback
Gets or sets attribute set id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeSetId { get; set; }
Visual Basic
Public Property AttributeSetId As String
    Get
    Set
Visual C++
public:
property String^ AttributeSetId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData.DataFieldTypeId Property

[image]

A Sandcastle Documented Class Library
AttributeMetaData..::..DataFieldTypeId Property
AttributeMetaData Class See Also Send Feedback
Gets or sets data field type id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataFieldTypeId { get; set; }
Visual Basic
Public Property DataFieldTypeId As String
    Get
    Set
Visual C++
public:
property String^ DataFieldTypeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData.FeatureCode Property

[image]

A Sandcastle Documented Class Library
AttributeMetaData..::..FeatureCode Property
AttributeMetaData Class See Also Send Feedback
Gets or sets feature code.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureCode { get; set; }
Visual Basic
Public Property FeatureCode As String
    Get
    Set
Visual C++
public:
property String^ FeatureCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeMetaData.ModuleCode Property

[image]

A Sandcastle Documented Class Library
AttributeMetaData..::..ModuleCode Property
AttributeMetaData Class See Also Send Feedback
Gets or sets module code.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleCode { get; set; }
Visual Basic
Public Property ModuleCode As String
    Get
    Set
Visual C++
public:
property String^ ModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeMetaData Class
AttributeMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData Class

[image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData Class
Members See Also Send Feedback
Attribute Set Settings Meta Data Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AttributeSetSettingsMetaData
Visual Basic
<SerializableAttribute>
Public Class AttributeSetSettingsMetaData
Visual C++
[SerializableAttribute]
public ref class AttributeSetSettingsMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..AttributeSetSettingsMetaData

See Also

AttributeSetSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData Members

[image] [image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData Members
AttributeSetSettingsMetaData Class Constructors Methods Properties See Also Send Feedback

The AttributeSetSettingsMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeSetSettingsMetaData | Initializes a new instance of the AttributeSetSettingsMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets attribute meta data.
Public property | AttributeSetId | Gets or sets attribute set id.
Public property | AttributeSetName | Gets or sets attribute set name.

See Also

AttributeSetSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData Constructor

[image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData Constructor
AttributeSetSettingsMetaData Class See Also Send Feedback
Initializes a new instance of the AttributeSetSettingsMetaData class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AttributeSetSettingsMetaData()
Visual Basic
Public Sub New
Visual C++
public:
AttributeSetSettingsMetaData()

See Also

AttributeSetSettingsMetaData Class
AttributeSetSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData Methods
AttributeSetSettingsMetaData Class See Also Send Feedback

The AttributeSetSettingsMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AttributeSetSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData Properties
AttributeSetSettingsMetaData Class See Also Send Feedback

The AttributeSetSettingsMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets attribute meta data.
Public property | AttributeSetId | Gets or sets attribute set id.
Public property | AttributeSetName | Gets or sets attribute set name.

See Also

AttributeSetSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData.AttributeMetaData Property

[image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData..::..AttributeMetaData Property
AttributeSetSettingsMetaData Class See Also Send Feedback
Gets or sets attribute meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeMetaData> AttributeMetaData { get; set; }
Visual Basic
Public Property AttributeMetaData As Dictionary(Of String, AttributeMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeMetaData^>^ AttributeMetaData {
    Dictionary<String^, AttributeMetaData^>^ get ();
    void set (Dictionary<String^, AttributeMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeMetaData >)>)>

See Also

AttributeSetSettingsMetaData Class
AttributeSetSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData.AttributeSetId Property

[image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData..::..AttributeSetId Property
AttributeSetSettingsMetaData Class See Also Send Feedback
Gets or sets attribute set id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeSetId { get; set; }
Visual Basic
Public Property AttributeSetId As String
    Get
    Set
Visual C++
public:
property String^ AttributeSetId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeSetSettingsMetaData Class
AttributeSetSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AttributeSetSettingsMetaData.AttributeSetName Property

[image]

A Sandcastle Documented Class Library
AttributeSetSettingsMetaData..::..AttributeSetName Property
AttributeSetSettingsMetaData Class See Also Send Feedback
Gets or sets attribute set name.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeSetName { get; set; }
Visual Basic
Public Property AttributeSetName As String
    Get
    Set
Visual C++
public:
property String^ AttributeSetName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

AttributeSetSettingsMetaData Class
AttributeSetSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant Class

[image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant Class
Members See Also Send Feedback
This class defines the constants used for the tenant specific settings management.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class AuthenticateSettingAttributeConstant
Visual Basic
Public Class AuthenticateSettingAttributeConstant
Visual C++
public ref class AuthenticateSettingAttributeConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..AuthenticateSettingAttributeConstant

See Also

AuthenticateSettingAttributeConstant Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant Members

[image] [image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant Members
AuthenticateSettingAttributeConstant Class Constructors Methods Fields See Also Send Feedback

The AuthenticateSettingAttributeConstant type exposes the following members.

Constructors

 | Name | Description
Public method | AuthenticateSettingAttributeConstant | Initializes a new instance of the AuthenticateSettingAttributeConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
NumberOfPasswordAnswerFailureAttempts | Represents the Maximum number of security answer failure attempts that the user can make while retrieving password through security question portal.
NumberOfPasswordFailureAttempts | Represents the Maximum number of password failure attempts that the user can make while login.
PinGenerationLogic | Represents the pin generation logic string.
UserNameField | Represents the User name filed.

See Also

AuthenticateSettingAttributeConstant Class
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant Constructor

[image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant Constructor
AuthenticateSettingAttributeConstant Class See Also Send Feedback
Initializes a new instance of the AuthenticateSettingAttributeConstant class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AuthenticateSettingAttributeConstant()
Visual Basic
Public Sub New
Visual C++
public:
AuthenticateSettingAttributeConstant()

See Also

AuthenticateSettingAttributeConstant Class
AuthenticateSettingAttributeConstant Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant Fields

[image] [image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant Fields
AuthenticateSettingAttributeConstant Class See Also Send Feedback

The AuthenticateSettingAttributeConstant type exposes the following members.

Fields

Name | Description
NumberOfPasswordAnswerFailureAttempts | Represents the Maximum number of security answer failure attempts that the user can make while retrieving password through security question portal.
NumberOfPasswordFailureAttempts | Represents the Maximum number of password failure attempts that the user can make while login.
PinGenerationLogic | Represents the pin generation logic string.
UserNameField | Represents the User name filed.

See Also

AuthenticateSettingAttributeConstant Class
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant.NumberOfPasswordAnswerFailureAttempts Field

[image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant..::..NumberOfPasswordAnswerFailureAttempts Field
AuthenticateSettingAttributeConstant Class See Also Send Feedback
Represents the Maximum number of security answer failure attempts that the user can make while retrieving password through security question portal.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string NumberOfPasswordAnswerFailureAttempts
Visual Basic
Public Const NumberOfPasswordAnswerFailureAttempts As String
Visual C++
public:
literal String^ NumberOfPasswordAnswerFailureAttempts

Field Value

Type: String

See Also

AuthenticateSettingAttributeConstant Class
AuthenticateSettingAttributeConstant Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant.NumberOfPasswordFailureAttempts Field

[image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant..::..NumberOfPasswordFailureAttempts Field
AuthenticateSettingAttributeConstant Class See Also Send Feedback
Represents the Maximum number of password failure attempts that the user can make while login.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string NumberOfPasswordFailureAttempts
Visual Basic
Public Const NumberOfPasswordFailureAttempts As String
Visual C++
public:
literal String^ NumberOfPasswordFailureAttempts

Field Value

Type: String

See Also

AuthenticateSettingAttributeConstant Class
AuthenticateSettingAttributeConstant Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant.PinGenerationLogic Field

[image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant..::..PinGenerationLogic Field
AuthenticateSettingAttributeConstant Class See Also Send Feedback
Represents the pin generation logic string.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PinGenerationLogic
Visual Basic
Public Const PinGenerationLogic As String
Visual C++
public:
literal String^ PinGenerationLogic

Field Value

Type: String

See Also

AuthenticateSettingAttributeConstant Class
AuthenticateSettingAttributeConstant Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant.UserNameField Field

[image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant..::..UserNameField Field
AuthenticateSettingAttributeConstant Class See Also Send Feedback
Represents the User name filed.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserNameField
Visual Basic
Public Const UserNameField As String
Visual C++
public:
literal String^ UserNameField

Field Value

Type: String

See Also

AuthenticateSettingAttributeConstant Class
AuthenticateSettingAttributeConstant Members
CelloSaaS.Model.SettingsManagement Namespace


AuthenticateSettingAttributeConstant Methods

[image] [image]

A Sandcastle Documented Class Library
AuthenticateSettingAttributeConstant Methods
AuthenticateSettingAttributeConstant Class See Also Send Feedback

The AuthenticateSettingAttributeConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AuthenticateSettingAttributeConstant Class
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData Class

[image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData Class
Members See Also Send Feedback
Feature Settings Meta Data Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FeatureSettingsMetaData
Visual Basic
<SerializableAttribute>
Public Class FeatureSettingsMetaData
Visual C++
[SerializableAttribute]
public ref class FeatureSettingsMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..FeatureSettingsMetaData

See Also

FeatureSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData Members

[image] [image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData Members
FeatureSettingsMetaData Class Constructors Methods Properties See Also Send Feedback

The FeatureSettingsMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | FeatureSettingsMetaData | Initializes a new instance of the FeatureSettingsMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets Attribute meta data.
Public property | AttributeSetSettingsMetaData | Gets or sets Attribute set settings meta data.
Public property | FeatureCode | Gets or sets feature code.
Public property | FeatureName | Gets or sets feature name.

See Also

FeatureSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData Constructor

[image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData Constructor
FeatureSettingsMetaData Class See Also Send Feedback
Initializes a new instance of the FeatureSettingsMetaData class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FeatureSettingsMetaData()
Visual Basic
Public Sub New
Visual C++
public:
FeatureSettingsMetaData()

See Also

FeatureSettingsMetaData Class
FeatureSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData Methods
FeatureSettingsMetaData Class See Also Send Feedback

The FeatureSettingsMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FeatureSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData Properties
FeatureSettingsMetaData Class See Also Send Feedback

The FeatureSettingsMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets Attribute meta data.
Public property | AttributeSetSettingsMetaData | Gets or sets Attribute set settings meta data.
Public property | FeatureCode | Gets or sets feature code.
Public property | FeatureName | Gets or sets feature name.

See Also

FeatureSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData.AttributeMetaData Property

[image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData..::..AttributeMetaData Property
FeatureSettingsMetaData Class See Also Send Feedback
Gets or sets Attribute meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeMetaData> AttributeMetaData { get; set; }
Visual Basic
Public Property AttributeMetaData As Dictionary(Of String, AttributeMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeMetaData^>^ AttributeMetaData {
    Dictionary<String^, AttributeMetaData^>^ get ();
    void set (Dictionary<String^, AttributeMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeMetaData >)>)>

See Also

FeatureSettingsMetaData Class
FeatureSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData.AttributeSetSettingsMetaData Property

[image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData..::..AttributeSetSettingsMetaData Property
FeatureSettingsMetaData Class See Also Send Feedback
Gets or sets Attribute set settings meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeSetSettingsMetaData> AttributeSetSettingsMetaData { get; set; }
Visual Basic
Public Property AttributeSetSettingsMetaData As Dictionary(Of String, AttributeSetSettingsMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeSetSettingsMetaData^>^ AttributeSetSettingsMetaData {
    Dictionary<String^, AttributeSetSettingsMetaData^>^ get ();
    void set (Dictionary<String^, AttributeSetSettingsMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeSetSettingsMetaData >)>)>

See Also

FeatureSettingsMetaData Class
FeatureSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData.FeatureCode Property

[image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData..::..FeatureCode Property
FeatureSettingsMetaData Class See Also Send Feedback
Gets or sets feature code.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureCode { get; set; }
Visual Basic
Public Property FeatureCode As String
    Get
    Set
Visual C++
public:
property String^ FeatureCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FeatureSettingsMetaData Class
FeatureSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


FeatureSettingsMetaData.FeatureName Property

[image]

A Sandcastle Documented Class Library
FeatureSettingsMetaData..::..FeatureName Property
FeatureSettingsMetaData Class See Also Send Feedback
Gets or sets feature name.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FeatureName { get; set; }
Visual Basic
Public Property FeatureName As String
    Get
    Set
Visual C++
public:
property String^ FeatureName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FeatureSettingsMetaData Class
FeatureSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData Class

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData Class
Members See Also Send Feedback
Module Settings Meta Data Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ModuleSettingsMetaData
Visual Basic
<SerializableAttribute>
Public Class ModuleSettingsMetaData
Visual C++
[SerializableAttribute]
public ref class ModuleSettingsMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..ModuleSettingsMetaData

See Also

ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData Members

[image] [image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData Members
ModuleSettingsMetaData Class Constructors Methods Properties See Also Send Feedback

The ModuleSettingsMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleSettingsMetaData | Initializes a new instance of the ModuleSettingsMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets Attribute meta data.
Public property | AttributeSetSettingsMetaData | Gets or sets Attribute set settings meta data.
Public property | FeatureSettingsMetaData | Gets or sets Feature settings meta data.
Public property | ModuleCode | Gets or sets module code.
Public property | ModuleName | Gets or sets module name.

See Also

ModuleSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData Constructor

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData Constructor
ModuleSettingsMetaData Class See Also Send Feedback
Initializes a new instance of the ModuleSettingsMetaData class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleSettingsMetaData()
Visual Basic
Public Sub New
Visual C++
public:
ModuleSettingsMetaData()

See Also

ModuleSettingsMetaData Class
ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData Methods
ModuleSettingsMetaData Class See Also Send Feedback

The ModuleSettingsMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModuleSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData Properties
ModuleSettingsMetaData Class See Also Send Feedback

The ModuleSettingsMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets Attribute meta data.
Public property | AttributeSetSettingsMetaData | Gets or sets Attribute set settings meta data.
Public property | FeatureSettingsMetaData | Gets or sets Feature settings meta data.
Public property | ModuleCode | Gets or sets module code.
Public property | ModuleName | Gets or sets module name.

See Also

ModuleSettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData.AttributeMetaData Property

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData..::..AttributeMetaData Property
ModuleSettingsMetaData Class See Also Send Feedback
Gets or sets Attribute meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeMetaData> AttributeMetaData { get; set; }
Visual Basic
Public Property AttributeMetaData As Dictionary(Of String, AttributeMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeMetaData^>^ AttributeMetaData {
    Dictionary<String^, AttributeMetaData^>^ get ();
    void set (Dictionary<String^, AttributeMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeMetaData >)>)>

See Also

ModuleSettingsMetaData Class
ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData.AttributeSetSettingsMetaData Property

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData..::..AttributeSetSettingsMetaData Property
ModuleSettingsMetaData Class See Also Send Feedback
Gets or sets Attribute set settings meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeSetSettingsMetaData> AttributeSetSettingsMetaData { get; set; }
Visual Basic
Public Property AttributeSetSettingsMetaData As Dictionary(Of String, AttributeSetSettingsMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeSetSettingsMetaData^>^ AttributeSetSettingsMetaData {
    Dictionary<String^, AttributeSetSettingsMetaData^>^ get ();
    void set (Dictionary<String^, AttributeSetSettingsMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeSetSettingsMetaData >)>)>

See Also

ModuleSettingsMetaData Class
ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData.FeatureSettingsMetaData Property

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData..::..FeatureSettingsMetaData Property
ModuleSettingsMetaData Class See Also Send Feedback
Gets or sets Feature settings meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, FeatureSettingsMetaData> FeatureSettingsMetaData { get; set; }
Visual Basic
Public Property FeatureSettingsMetaData As Dictionary(Of String, FeatureSettingsMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, FeatureSettingsMetaData^>^ FeatureSettingsMetaData {
    Dictionary<String^, FeatureSettingsMetaData^>^ get ();
    void set (Dictionary<String^, FeatureSettingsMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, FeatureSettingsMetaData >)>)>

See Also

ModuleSettingsMetaData Class
ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData.ModuleCode Property

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData..::..ModuleCode Property
ModuleSettingsMetaData Class See Also Send Feedback
Gets or sets module code.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleCode { get; set; }
Visual Basic
Public Property ModuleCode As String
    Get
    Set
Visual C++
public:
property String^ ModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ModuleSettingsMetaData Class
ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


ModuleSettingsMetaData.ModuleName Property

[image]

A Sandcastle Documented Class Library
ModuleSettingsMetaData..::..ModuleName Property
ModuleSettingsMetaData Class See Also Send Feedback
Gets or sets module name.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ModuleName { get; set; }
Visual Basic
Public Property ModuleName As String
    Get
    Set
Visual C++
public:
property String^ ModuleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ModuleSettingsMetaData Class
ModuleSettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting Class

[image]

A Sandcastle Documented Class Library
PackageSetting Class
Members See Also Send Feedback
Package Setting Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageSetting
Visual Basic
<SerializableAttribute>
Public Class PackageSetting
Visual C++
[SerializableAttribute]
public ref class PackageSetting

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..PackageSetting

See Also

PackageSetting Members
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting Members

[image] [image]

A Sandcastle Documented Class Library
PackageSetting Members
PackageSetting Class Constructors Methods Properties See Also Send Feedback

The PackageSetting type exposes the following members.

Constructors

 | Name | Description
Public method | PackageSetting | Initializes a new instance of the PackageSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PackageId | Gets or sets package id.
Public property | Setting | Gets or sets the list of attribute's Name and its value for a Package. Dictionary [Attribute Id, Attribute Value]

See Also

PackageSetting Class
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting Constructor

[image]

A Sandcastle Documented Class Library
PackageSetting Constructor
PackageSetting Class See Also Send Feedback
Initializes a new instance of the PackageSetting class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageSetting()
Visual Basic
Public Sub New
Visual C++
public:
PackageSetting()

See Also

PackageSetting Class
PackageSetting Members
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting Methods

[image] [image]

A Sandcastle Documented Class Library
PackageSetting Methods
PackageSetting Class See Also Send Feedback

The PackageSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackageSetting Class
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting Properties

[image] [image]

A Sandcastle Documented Class Library
PackageSetting Properties
PackageSetting Class See Also Send Feedback

The PackageSetting type exposes the following members.

Properties

 | Name | Description
Public property | PackageId | Gets or sets package id.
Public property | Setting | Gets or sets the list of attribute's Name and its value for a Package. Dictionary [Attribute Id, Attribute Value]

See Also

PackageSetting Class
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting.PackageId Property

[image]

A Sandcastle Documented Class Library
PackageSetting..::..PackageId Property
PackageSetting Class See Also Send Feedback
Gets or sets package id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PackageId { get; set; }
Visual Basic
Public Property PackageId As String
    Get
    Set
Visual C++
public:
property String^ PackageId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PackageSetting Class
PackageSetting Members
CelloSaaS.Model.SettingsManagement Namespace


PackageSetting.Setting Property

[image]

A Sandcastle Documented Class Library
PackageSetting..::..Setting Property
PackageSetting Class See Also Send Feedback
Gets or sets the list of attribute's Name and its value for a Package. Dictionary [Attribute Id, Attribute Value]

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Settings Setting { get; set; }
Visual Basic
Public Property Setting As Settings
    Get
    Set
Visual C++
public:
property Settings^ Setting {
    Settings^ get ();
    void set (Settings^ value);
}

Property Value

Type: Settings

See Also

PackageSetting Class
PackageSetting Members
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting Class

[image]

A Sandcastle Documented Class Library
RoleSetting Class
Members See Also Send Feedback
Role Setting Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoleSetting
Visual Basic
<SerializableAttribute>
Public Class RoleSetting
Visual C++
[SerializableAttribute]
public ref class RoleSetting

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..RoleSetting

See Also

RoleSetting Members
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting Members

[image] [image]

A Sandcastle Documented Class Library
RoleSetting Members
RoleSetting Class Constructors Methods Properties See Also Send Feedback

The RoleSetting type exposes the following members.

Constructors

 | Name | Description
Public method | RoleSetting | Initializes a new instance of the RoleSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleId | Gets or sets role id.
Public property | Setting | Gets or sets the list of attribute's Name and its value for a Role. Dictionary [Attribute Id, Attribute Value]

See Also

RoleSetting Class
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting Constructor

[image]

A Sandcastle Documented Class Library
RoleSetting Constructor
RoleSetting Class See Also Send Feedback
Initializes a new instance of the RoleSetting class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleSetting()
Visual Basic
Public Sub New
Visual C++
public:
RoleSetting()

See Also

RoleSetting Class
RoleSetting Members
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting Methods

[image] [image]

A Sandcastle Documented Class Library
RoleSetting Methods
RoleSetting Class See Also Send Feedback

The RoleSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoleSetting Class
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting Properties

[image] [image]

A Sandcastle Documented Class Library
RoleSetting Properties
RoleSetting Class See Also Send Feedback

The RoleSetting type exposes the following members.

Properties

 | Name | Description
Public property | RoleId | Gets or sets role id.
Public property | Setting | Gets or sets the list of attribute's Name and its value for a Role. Dictionary [Attribute Id, Attribute Value]

See Also

RoleSetting Class
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting.RoleId Property

[image]

A Sandcastle Documented Class Library
RoleSetting..::..RoleId Property
RoleSetting Class See Also Send Feedback
Gets or sets role id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleId { get; set; }
Visual Basic
Public Property RoleId As String
    Get
    Set
Visual C++
public:
property String^ RoleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RoleSetting Class
RoleSetting Members
CelloSaaS.Model.SettingsManagement Namespace


RoleSetting.Setting Property

[image]

A Sandcastle Documented Class Library
RoleSetting..::..Setting Property
RoleSetting Class See Also Send Feedback
Gets or sets the list of attribute's Name and its value for a Role. Dictionary [Attribute Id, Attribute Value]

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Settings Setting { get; set; }
Visual Basic
Public Property Setting As Settings
    Get
    Set
Visual C++
public:
property Settings^ Setting {
    Settings^ get ();
    void set (Settings^ value);
}

Property Value

Type: Settings

See Also

RoleSetting Class
RoleSetting Members
CelloSaaS.Model.SettingsManagement Namespace


Settings Class

[image]

A Sandcastle Documented Class Library
Settings Class
Members See Also Send Feedback
Settings Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Settings
Visual Basic
<SerializableAttribute>
Public Class Settings
Visual C++
[SerializableAttribute]
public ref class Settings

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..Settings

See Also

Settings Members
CelloSaaS.Model.SettingsManagement Namespace


Settings Members

[image] [image]

A Sandcastle Documented Class Library
Settings Members
Settings Class Constructors Methods Properties See Also Send Feedback

The Settings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings | Initializes a new instance of the Settings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the list of attribute's Name and its value. Dictionary [Attribute Id, Attribute Value]

See Also

Settings Class
CelloSaaS.Model.SettingsManagement Namespace


Settings Constructor

[image]

A Sandcastle Documented Class Library
Settings Constructor
Settings Class See Also Send Feedback
Initializes a new instance of the Settings class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Settings()
Visual Basic
Public Sub New
Visual C++
public:
Settings()

See Also

Settings Class
Settings Members
CelloSaaS.Model.SettingsManagement Namespace


Settings Methods

[image] [image]

A Sandcastle Documented Class Library
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Settings Class
CelloSaaS.Model.SettingsManagement Namespace


Settings Properties

[image] [image]

A Sandcastle Documented Class Library
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the list of attribute's Name and its value. Dictionary [Attribute Id, Attribute Value]

See Also

Settings Class
CelloSaaS.Model.SettingsManagement Namespace


Settings.Attributes Property

[image]

A Sandcastle Documented Class Library
Settings..::..Attributes Property
Settings Class See Also Send Feedback
Gets or sets the list of attribute's Name and its value. Dictionary [Attribute Id, Attribute Value]

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, string> Attributes { get; set; }
Visual Basic
Public Property Attributes As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, String>)>)>

See Also

Settings Class
Settings Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute Class

[image]

A Sandcastle Documented Class Library
SettingsAttribute Class
Members See Also Send Feedback
Individual Setting Attribute Model

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SettingsAttribute
Visual Basic
<SerializableAttribute>
Public Class SettingsAttribute
Visual C++
[SerializableAttribute]
public ref class SettingsAttribute

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..SettingsAttribute

See Also

SettingsAttribute Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute Members

[image] [image]

A Sandcastle Documented Class Library
SettingsAttribute Members
SettingsAttribute Class Constructors Methods Properties See Also Send Feedback

The SettingsAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsAttribute | Initializes a new instance of the SettingsAttribute class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeId | Gets or sets the attribute id.
Public property | AttributeSetId | Gets or sets the attribute id.
Public property | AttributeValue | Gets or sets the attribute value.
Public property | IsSelected | Gets or sets a value indicating whether this attribute is selected.

See Also

SettingsAttribute Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute Constructor

[image]

A Sandcastle Documented Class Library
SettingsAttribute Constructor
SettingsAttribute Class See Also Send Feedback
Initializes a new instance of the SettingsAttribute class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsAttribute()
Visual Basic
Public Sub New
Visual C++
public:
SettingsAttribute()

See Also

SettingsAttribute Class
SettingsAttribute Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute Methods

[image] [image]

A Sandcastle Documented Class Library
SettingsAttribute Methods
SettingsAttribute Class See Also Send Feedback

The SettingsAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SettingsAttribute Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute Properties

[image] [image]

A Sandcastle Documented Class Library
SettingsAttribute Properties
SettingsAttribute Class See Also Send Feedback

The SettingsAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeId | Gets or sets the attribute id.
Public property | AttributeSetId | Gets or sets the attribute id.
Public property | AttributeValue | Gets or sets the attribute value.
Public property | IsSelected | Gets or sets a value indicating whether this attribute is selected.

See Also

SettingsAttribute Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute.AttributeId Property

[image]

A Sandcastle Documented Class Library
SettingsAttribute..::..AttributeId Property
SettingsAttribute Class See Also Send Feedback
Gets or sets the attribute id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeId { get; set; }
Visual Basic
Public Property AttributeId As String
    Get
    Set
Visual C++
public:
property String^ AttributeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The attribute id.

See Also

SettingsAttribute Class
SettingsAttribute Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute.AttributeSetId Property

[image]

A Sandcastle Documented Class Library
SettingsAttribute..::..AttributeSetId Property
SettingsAttribute Class See Also Send Feedback
Gets or sets the attribute id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeSetId { get; set; }
Visual Basic
Public Property AttributeSetId As String
    Get
    Set
Visual C++
public:
property String^ AttributeSetId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The attribute id.

See Also

SettingsAttribute Class
SettingsAttribute Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute.AttributeValue Property

[image]

A Sandcastle Documented Class Library
SettingsAttribute..::..AttributeValue Property
SettingsAttribute Class See Also Send Feedback
Gets or sets the attribute value.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttributeValue { get; set; }
Visual Basic
Public Property AttributeValue As String
    Get
    Set
Visual C++
public:
property String^ AttributeValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The attribute value.

See Also

SettingsAttribute Class
SettingsAttribute Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsAttribute.IsSelected Property

[image]

A Sandcastle Documented Class Library
SettingsAttribute..::..IsSelected Property
SettingsAttribute Class See Also Send Feedback
Gets or sets a value indicating whether this attribute is selected.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this attribute is selected; otherwise, false.

See Also

SettingsAttribute Class
SettingsAttribute Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData Class

[image]

A Sandcastle Documented Class Library
SettingsMetaData Class
Members See Also Send Feedback
Settings Meta Data Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SettingsMetaData
Visual Basic
<SerializableAttribute>
Public Class SettingsMetaData
Visual C++
[SerializableAttribute]
public ref class SettingsMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..SettingsMetaData

See Also

SettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData Members

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaData Members
SettingsMetaData Class Constructors Methods Properties See Also Send Feedback

The SettingsMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsMetaData | Initializes a new instance of the SettingsMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets Attribute meta data.
Public property | AttributeSetSettingsMetaData | Gets or sets Attribute set settings meta data.
Public property | ModuleSettingsMetaData | Gets or sets Module settings meta data.

See Also

SettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData Constructor

[image]

A Sandcastle Documented Class Library
SettingsMetaData Constructor
SettingsMetaData Class See Also Send Feedback
Initializes a new instance of the SettingsMetaData class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsMetaData()
Visual Basic
Public Sub New
Visual C++
public:
SettingsMetaData()

See Also

SettingsMetaData Class
SettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaData Methods
SettingsMetaData Class See Also Send Feedback

The SettingsMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaData Properties
SettingsMetaData Class See Also Send Feedback

The SettingsMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AttributeMetaData | Gets or sets Attribute meta data.
Public property | AttributeSetSettingsMetaData | Gets or sets Attribute set settings meta data.
Public property | ModuleSettingsMetaData | Gets or sets Module settings meta data.

See Also

SettingsMetaData Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData.AttributeMetaData Property

[image]

A Sandcastle Documented Class Library
SettingsMetaData..::..AttributeMetaData Property
SettingsMetaData Class See Also Send Feedback
Gets or sets Attribute meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeMetaData> AttributeMetaData { get; set; }
Visual Basic
Public Property AttributeMetaData As Dictionary(Of String, AttributeMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeMetaData^>^ AttributeMetaData {
    Dictionary<String^, AttributeMetaData^>^ get ();
    void set (Dictionary<String^, AttributeMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeMetaData >)>)>

See Also

SettingsMetaData Class
SettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData.AttributeSetSettingsMetaData Property

[image]

A Sandcastle Documented Class Library
SettingsMetaData..::..AttributeSetSettingsMetaData Property
SettingsMetaData Class See Also Send Feedback
Gets or sets Attribute set settings meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, AttributeSetSettingsMetaData> AttributeSetSettingsMetaData { get; set; }
Visual Basic
Public Property AttributeSetSettingsMetaData As Dictionary(Of String, AttributeSetSettingsMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, AttributeSetSettingsMetaData^>^ AttributeSetSettingsMetaData {
    Dictionary<String^, AttributeSetSettingsMetaData^>^ get ();
    void set (Dictionary<String^, AttributeSetSettingsMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, AttributeSetSettingsMetaData >)>)>

See Also

SettingsMetaData Class
SettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsMetaData.ModuleSettingsMetaData Property

[image]

A Sandcastle Documented Class Library
SettingsMetaData..::..ModuleSettingsMetaData Property
SettingsMetaData Class See Also Send Feedback
Gets or sets Module settings meta data.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, ModuleSettingsMetaData> ModuleSettingsMetaData { get; set; }
Visual Basic
Public Property ModuleSettingsMetaData As Dictionary(Of String, ModuleSettingsMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, ModuleSettingsMetaData^>^ ModuleSettingsMetaData {
    Dictionary<String^, ModuleSettingsMetaData^>^ get ();
    void set (Dictionary<String^, ModuleSettingsMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, ModuleSettingsMetaData >)>)>

See Also

SettingsMetaData Class
SettingsMetaData Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate Class

[image]

A Sandcastle Documented Class Library
SettingsTemplate Class
Members See Also Send Feedback
SettingsTemplate Model

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SettingsTemplate : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class SettingsTemplate
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class SettingsTemplate : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.SettingsManagement..::..SettingsTemplate

See Also

SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate Members

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplate Members
SettingsTemplate Class Constructors Methods Properties See Also Send Feedback

The SettingsTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsTemplate | Initializes a new instance of the SettingsTemplate class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the Settings Template Id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsGlobal | Gets or sets a value indicating whether this template is global.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | Name | Gets or sets the Settings Template Name.
Public property | Status | Gets or sets a value indicating whether this SettingsTemplate is status.
Public property | TemplateType | Gets or sets the type of the template.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SettingsTemplate Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate Constructor

[image]

A Sandcastle Documented Class Library
SettingsTemplate Constructor
SettingsTemplate Class See Also Send Feedback
Initializes a new instance of the SettingsTemplate class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsTemplate()
Visual Basic
Public Sub New
Visual C++
public:
SettingsTemplate()

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplate Methods
SettingsTemplate Class See Also Send Feedback

The SettingsTemplate type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

SettingsTemplate Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplate Properties
SettingsTemplate Class See Also Send Feedback

The SettingsTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the Settings Template Id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsGlobal | Gets or sets a value indicating whether this template is global.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | Name | Gets or sets the Settings Template Name.
Public property | Status | Gets or sets a value indicating whether this SettingsTemplate is status.
Public property | TemplateType | Gets or sets the type of the template.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SettingsTemplate Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.Attributes Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..Attributes Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the attributes.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<SettingsAttribute> Attributes { get; set; }
Visual Basic
Public Property Attributes As List(Of SettingsAttribute)
    Get
    Set
Visual C++
public:
property List<SettingsAttribute^>^ Attributes {
    List<SettingsAttribute^>^ get ();
    void set (List<SettingsAttribute^>^ value);
}

Property Value

Type: List<(Of <(<' SettingsAttribute >)>)>
The attributes.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..CreatedBy Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..CreatedOn Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.Id Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..Id Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the Settings Template Id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> Id { get; set; }
Visual Basic
Public Property Id As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> Id {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>
Id.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.IsGlobal Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..IsGlobal Property
SettingsTemplate Class See Also Send Feedback
Gets or sets a value indicating whether this template is global.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsGlobal { get; set; }
Visual Basic
Public Property IsGlobal As Boolean
    Get
    Set
Visual C++
public:
property bool IsGlobal {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is global; otherwise, false.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.Name Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..Name Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the Settings Template Name.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.Status Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..Status Property
SettingsTemplate Class See Also Send Feedback
Gets or sets a value indicating whether this SettingsTemplate is status.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.TemplateType Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..TemplateType Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the type of the template.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingTemplateType TemplateType { get; set; }
Visual Basic
Public Property TemplateType As SettingTemplateType
    Get
    Set
Visual C++
public:
property SettingTemplateType TemplateType {
    SettingTemplateType get ();
    void set (SettingTemplateType value);
}

Property Value

Type: SettingTemplateType
The type of the template.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.TenantId Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..TenantId Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..UpdatedBy Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
SettingsTemplate..::..UpdatedOn Property
SettingsTemplate Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

SettingsTemplate Class
SettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants Class
Members See Also Send Feedback
SettingsTemplate Privilege Constants

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class SettingsTemplatePrivilegeConstants
Visual Basic
Public NotInheritable Class SettingsTemplatePrivilegeConstants
Visual C++
public ref class SettingsTemplatePrivilegeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..SettingsTemplatePrivilegeConstants

See Also

SettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants Members
SettingsTemplatePrivilegeConstants Class Properties See Also Send Feedback

The SettingsTemplatePrivilegeConstants type exposes the following members.

Properties

Name | Description
AddSettingsTemplate | Add Settings Template Privilege
DeleteSettingsTemplate | Delete Settings Template Privilege
EditSettingsTemplate | Edit Settings Template Privilege
ViewSettingsTemplate | View Settings Template Privilege

See Also

SettingsTemplatePrivilegeConstants Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants Properties

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants Properties
SettingsTemplatePrivilegeConstants Class See Also Send Feedback

The SettingsTemplatePrivilegeConstants type exposes the following members.

Properties

Name | Description
AddSettingsTemplate | Add Settings Template Privilege
DeleteSettingsTemplate | Delete Settings Template Privilege
EditSettingsTemplate | Edit Settings Template Privilege
ViewSettingsTemplate | View Settings Template Privilege

See Also

SettingsTemplatePrivilegeConstants Class
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants.AddSettingsTemplate Property

[image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants..::..AddSettingsTemplate Property
SettingsTemplatePrivilegeConstants Class See Also Send Feedback
Add Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddSettingsTemplate { get; }
Visual Basic
Public Shared ReadOnly Property AddSettingsTemplate As String
    Get
Visual C++
public:
static property String^ AddSettingsTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

SettingsTemplatePrivilegeConstants Class
SettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants.DeleteSettingsTemplate Property

[image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants..::..DeleteSettingsTemplate Property
SettingsTemplatePrivilegeConstants Class See Also Send Feedback
Delete Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteSettingsTemplate { get; }
Visual Basic
Public Shared ReadOnly Property DeleteSettingsTemplate As String
    Get
Visual C++
public:
static property String^ DeleteSettingsTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

SettingsTemplatePrivilegeConstants Class
SettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants.EditSettingsTemplate Property

[image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants..::..EditSettingsTemplate Property
SettingsTemplatePrivilegeConstants Class See Also Send Feedback
Edit Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditSettingsTemplate { get; }
Visual Basic
Public Shared ReadOnly Property EditSettingsTemplate As String
    Get
Visual C++
public:
static property String^ EditSettingsTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

SettingsTemplatePrivilegeConstants Class
SettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


SettingsTemplatePrivilegeConstants.ViewSettingsTemplate Property

[image]

A Sandcastle Documented Class Library
SettingsTemplatePrivilegeConstants..::..ViewSettingsTemplate Property
SettingsTemplatePrivilegeConstants Class See Also Send Feedback
View Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewSettingsTemplate { get; }
Visual Basic
Public Shared ReadOnly Property ViewSettingsTemplate As String
    Get
Visual C++
public:
static property String^ ViewSettingsTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

SettingsTemplatePrivilegeConstants Class
SettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


SettingTemplateType Enumeration

[image]

A Sandcastle Documented Class Library
SettingTemplateType Enumeration
See Also Send Feedback
Settings Template Type

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public enum SettingTemplateType
Visual Basic
<SerializableAttribute>
Public Enumeration SettingTemplateType
Visual C++
[SerializableAttribute]
public enum class SettingTemplateType

Members

Member name | Value | Description
Fixed | 0 | Fixed Type
Customized | 1 | Customized Type

See Also

CelloSaaS.Model.SettingsManagement Namespace


TenantSetting Class

[image]

A Sandcastle Documented Class Library
TenantSetting Class
Members See Also Send Feedback
Tenant Setting Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantSetting
Visual Basic
<SerializableAttribute>
Public Class TenantSetting
Visual C++
[SerializableAttribute]
public ref class TenantSetting

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..TenantSetting

See Also

TenantSetting Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSetting Members

[image] [image]

A Sandcastle Documented Class Library
TenantSetting Members
TenantSetting Class Constructors Methods Properties See Also Send Feedback

The TenantSetting type exposes the following members.

Constructors

 | Name | Description
Public method | TenantSetting | Initializes a new instance of the TenantSetting class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Setting | Gets or sets the list of attribute's Name and its value for a tenant. Dictionary [Attribute Id, Attribute Value]
Public property | TenantID | Gets or sets tenant id.

See Also

TenantSetting Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSetting Constructor

[image]

A Sandcastle Documented Class Library
TenantSetting Constructor
TenantSetting Class See Also Send Feedback
Initializes a new instance of the TenantSetting class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantSetting()
Visual Basic
Public Sub New
Visual C++
public:
TenantSetting()

See Also

TenantSetting Class
TenantSetting Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSetting Methods

[image] [image]

A Sandcastle Documented Class Library
TenantSetting Methods
TenantSetting Class See Also Send Feedback

The TenantSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantSetting Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSetting Properties

[image] [image]

A Sandcastle Documented Class Library
TenantSetting Properties
TenantSetting Class See Also Send Feedback

The TenantSetting type exposes the following members.

Properties

 | Name | Description
Public property | Setting | Gets or sets the list of attribute's Name and its value for a tenant. Dictionary [Attribute Id, Attribute Value]
Public property | TenantID | Gets or sets tenant id.

See Also

TenantSetting Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSetting.Setting Property

[image]

A Sandcastle Documented Class Library
TenantSetting..::..Setting Property
TenantSetting Class See Also Send Feedback
Gets or sets the list of attribute's Name and its value for a tenant. Dictionary [Attribute Id, Attribute Value]

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Settings Setting { get; set; }
Visual Basic
Public Property Setting As Settings
    Get
    Set
Visual C++
public:
property Settings^ Setting {
    Settings^ get ();
    void set (Settings^ value);
}

Property Value

Type: Settings

See Also

TenantSetting Class
TenantSetting Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSetting.TenantID Property

[image]

A Sandcastle Documented Class Library
TenantSetting..::..TenantID Property
TenantSetting Class See Also Send Feedback
Gets or sets tenant id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantID { get; set; }
Visual Basic
Public Property TenantID As String
    Get
    Set
Visual C++
public:
property String^ TenantID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantSetting Class
TenantSetting Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate Class

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate Class
Members See Also Send Feedback
Tenant Settings Template Model

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantSettingsTemplate : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantSettingsTemplate
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantSettingsTemplate : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.SettingsManagement..::..TenantSettingsTemplate

See Also

TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate Members

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsTemplate Members
TenantSettingsTemplate Class Constructors Methods Properties See Also Send Feedback

The TenantSettingsTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | TenantSettingsTemplate | Initializes a new instance of the TenantSettingsTemplate class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | SettingsTemplate | Gets or sets the template settings.
Public property | Status | Gets or sets a value indicating whether this SettingsTemplate is status.
Public property | TemplateId | Gets or sets the template id.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantSettingsTemplate Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate Constructor

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate Constructor
TenantSettingsTemplate Class See Also Send Feedback
Initializes a new instance of the TenantSettingsTemplate class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantSettingsTemplate()
Visual Basic
Public Sub New
Visual C++
public:
TenantSettingsTemplate()

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsTemplate Methods
TenantSettingsTemplate Class See Also Send Feedback

The TenantSettingsTemplate type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantSettingsTemplate Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsTemplate Properties
TenantSettingsTemplate Class See Also Send Feedback

The TenantSettingsTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | Gets or sets the attributes.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | SettingsTemplate | Gets or sets the template settings.
Public property | Status | Gets or sets a value indicating whether this SettingsTemplate is status.
Public property | TemplateId | Gets or sets the template id.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantSettingsTemplate Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.Attributes Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..Attributes Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the attributes.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<SettingsAttribute> Attributes { get; set; }
Visual Basic
Public Property Attributes As List(Of SettingsAttribute)
    Get
    Set
Visual C++
public:
property List<SettingsAttribute^>^ Attributes {
    List<SettingsAttribute^>^ get ();
    void set (List<SettingsAttribute^>^ value);
}

Property Value

Type: List<(Of <(<' SettingsAttribute >)>)>
The attributes.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..CreatedBy Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..CreatedOn Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.Id Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..Id Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.SettingsTemplate Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..SettingsTemplate Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the template settings.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsTemplate SettingsTemplate { get; set; }
Visual Basic
Public Property SettingsTemplate As SettingsTemplate
    Get
    Set
Visual C++
public:
property SettingsTemplate^ SettingsTemplate {
    SettingsTemplate^ get ();
    void set (SettingsTemplate^ value);
}

Property Value

Type: SettingsTemplate
The template settings.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.Status Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..Status Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets a value indicating whether this SettingsTemplate is status.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..TemplateId Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The template id.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.TenantId Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..TenantId Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..UpdatedBy Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplate..::..UpdatedOn Property
TenantSettingsTemplate Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

TenantSettingsTemplate Class
TenantSettingsTemplate Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants Class
Members See Also Send Feedback
TenantSettingsTemplate Privilege Constants

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantSettingsTemplatePrivilegeConstants
Visual Basic
Public NotInheritable Class TenantSettingsTemplatePrivilegeConstants
Visual C++
public ref class TenantSettingsTemplatePrivilegeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..TenantSettingsTemplatePrivilegeConstants

See Also

TenantSettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants Members
TenantSettingsTemplatePrivilegeConstants Class Properties See Also Send Feedback

The TenantSettingsTemplatePrivilegeConstants type exposes the following members.

Properties

Name | Description
AddTenantTemplate | Add Tenant Settings Template Privilege
DeleteTenantTemplate | Delete Tenant Settings Template Privilege
EditTenantTemplate | Edit Tenant Settings Template Privilege
ViewTenantTemplate | View Tenant Settings Template Privilege

See Also

TenantSettingsTemplatePrivilegeConstants Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants Properties

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants Properties
TenantSettingsTemplatePrivilegeConstants Class See Also Send Feedback

The TenantSettingsTemplatePrivilegeConstants type exposes the following members.

Properties

Name | Description
AddTenantTemplate | Add Tenant Settings Template Privilege
DeleteTenantTemplate | Delete Tenant Settings Template Privilege
EditTenantTemplate | Edit Tenant Settings Template Privilege
ViewTenantTemplate | View Tenant Settings Template Privilege

See Also

TenantSettingsTemplatePrivilegeConstants Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants.AddTenantTemplate Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants..::..AddTenantTemplate Property
TenantSettingsTemplatePrivilegeConstants Class See Also Send Feedback
Add Tenant Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddTenantTemplate { get; }
Visual Basic
Public Shared ReadOnly Property AddTenantTemplate As String
    Get
Visual C++
public:
static property String^ AddTenantTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

TenantSettingsTemplatePrivilegeConstants Class
TenantSettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants.DeleteTenantTemplate Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants..::..DeleteTenantTemplate Property
TenantSettingsTemplatePrivilegeConstants Class See Also Send Feedback
Delete Tenant Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteTenantTemplate { get; }
Visual Basic
Public Shared ReadOnly Property DeleteTenantTemplate As String
    Get
Visual C++
public:
static property String^ DeleteTenantTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

TenantSettingsTemplatePrivilegeConstants Class
TenantSettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants.EditTenantTemplate Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants..::..EditTenantTemplate Property
TenantSettingsTemplatePrivilegeConstants Class See Also Send Feedback
Edit Tenant Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditTenantTemplate { get; }
Visual Basic
Public Shared ReadOnly Property EditTenantTemplate As String
    Get
Visual C++
public:
static property String^ EditTenantTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

TenantSettingsTemplatePrivilegeConstants Class
TenantSettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingsTemplatePrivilegeConstants.ViewTenantTemplate Property

[image]

A Sandcastle Documented Class Library
TenantSettingsTemplatePrivilegeConstants..::..ViewTenantTemplate Property
TenantSettingsTemplatePrivilegeConstants Class See Also Send Feedback
View Tenant Settings Template Privilege

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewTenantTemplate { get; }
Visual Basic
Public Shared ReadOnly Property ViewTenantTemplate As String
    Get
Visual C++
public:
static property String^ ViewTenantTemplate {
    String^ get ();
}

Property Value

Type: String

See Also

TenantSettingsTemplatePrivilegeConstants Class
TenantSettingsTemplatePrivilegeConstants Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingTemplateConstants Class

[image]

A Sandcastle Documented Class Library
TenantSettingTemplateConstants Class
Members See Also Send Feedback
Constants for Tenant Settings Template

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantSettingTemplateConstants
Visual Basic
Public NotInheritable Class TenantSettingTemplateConstants
Visual C++
public ref class TenantSettingTemplateConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..TenantSettingTemplateConstants

See Also

TenantSettingTemplateConstants Members
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingTemplateConstants Members

[image] [image]

A Sandcastle Documented Class Library
TenantSettingTemplateConstants Members
TenantSettingTemplateConstants Class Properties See Also Send Feedback

The TenantSettingTemplateConstants type exposes the following members.

Properties

Name | Description
DefaultTemplateId | Gets the default template id.

See Also

TenantSettingTemplateConstants Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingTemplateConstants Properties

[image] [image]

A Sandcastle Documented Class Library
TenantSettingTemplateConstants Properties
TenantSettingTemplateConstants Class See Also Send Feedback

The TenantSettingTemplateConstants type exposes the following members.

Properties

Name | Description
DefaultTemplateId | Gets the default template id.

See Also

TenantSettingTemplateConstants Class
CelloSaaS.Model.SettingsManagement Namespace


TenantSettingTemplateConstants.DefaultTemplateId Property

[image]

A Sandcastle Documented Class Library
TenantSettingTemplateConstants..::..DefaultTemplateId Property
TenantSettingTemplateConstants Class See Also Send Feedback
Gets the default template id.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DefaultTemplateId { get; }
Visual Basic
Public Shared ReadOnly Property DefaultTemplateId As String
    Get
Visual C++
public:
static property String^ DefaultTemplateId {
    String^ get ();
}

Property Value

Type: String
The default template id.

See Also

TenantSettingTemplateConstants Class
TenantSettingTemplateConstants Members
CelloSaaS.Model.SettingsManagement Namespace


UserSettings Class

[image]

A Sandcastle Documented Class Library
UserSettings Class
Members See Also Send Feedback
User Settings Properties

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserSettings
Visual Basic
<SerializableAttribute>
Public Class UserSettings
Visual C++
[SerializableAttribute]
public ref class UserSettings

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.SettingsManagement..::..UserSettings

See Also

UserSettings Members
CelloSaaS.Model.SettingsManagement Namespace


UserSettings Members

[image] [image]

A Sandcastle Documented Class Library
UserSettings Members
UserSettings Class Constructors Methods Properties See Also Send Feedback

The UserSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserSettings | Initializes a new instance of the UserSettings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddedBy | Gets or sets the name/id of user who added this user settings.
Public property | Setting | Gets or sets the list of attribute's Name and its value for a User Id. Dictionary [Attribute Id, Attribute Value]
Public property | UserId | Gets or sets user identifier.

See Also

UserSettings Class
CelloSaaS.Model.SettingsManagement Namespace


UserSettings Constructor

[image]

A Sandcastle Documented Class Library
UserSettings Constructor
UserSettings Class See Also Send Feedback
Initializes a new instance of the UserSettings class

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserSettings()
Visual Basic
Public Sub New
Visual C++
public:
UserSettings()

See Also

UserSettings Class
UserSettings Members
CelloSaaS.Model.SettingsManagement Namespace


UserSettings Methods

[image] [image]

A Sandcastle Documented Class Library
UserSettings Methods
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserSettings Class
CelloSaaS.Model.SettingsManagement Namespace


UserSettings Properties

[image] [image]

A Sandcastle Documented Class Library
UserSettings Properties
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Properties

 | Name | Description
Public property | AddedBy | Gets or sets the name/id of user who added this user settings.
Public property | Setting | Gets or sets the list of attribute's Name and its value for a User Id. Dictionary [Attribute Id, Attribute Value]
Public property | UserId | Gets or sets user identifier.

See Also

UserSettings Class
CelloSaaS.Model.SettingsManagement Namespace


UserSettings.AddedBy Property

[image]

A Sandcastle Documented Class Library
UserSettings..::..AddedBy Property
UserSettings Class See Also Send Feedback
Gets or sets the name/id of user who added this user settings.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AddedBy { get; set; }
Visual Basic
Public Property AddedBy As String
    Get
    Set
Visual C++
public:
property String^ AddedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserSettings Class
UserSettings Members
CelloSaaS.Model.SettingsManagement Namespace


UserSettings.Setting Property

[image]

A Sandcastle Documented Class Library
UserSettings..::..Setting Property
UserSettings Class See Also Send Feedback
Gets or sets the list of attribute's Name and its value for a User Id. Dictionary [Attribute Id, Attribute Value]

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Settings Setting { get; set; }
Visual Basic
Public Property Setting As Settings
    Get
    Set
Visual C++
public:
property Settings^ Setting {
    Settings^ get ();
    void set (Settings^ value);
}

Property Value

Type: Settings

See Also

UserSettings Class
UserSettings Members
CelloSaaS.Model.SettingsManagement Namespace


UserSettings.UserId Property

[image]

A Sandcastle Documented Class Library
UserSettings..::..UserId Property
UserSettings Class See Also Send Feedback
Gets or sets user identifier.

Namespace: CelloSaaS.Model.SettingsManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserSettings Class
UserSettings Members
CelloSaaS.Model.SettingsManagement Namespace


CelloSaaS.Model.TenantManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.TenantManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | Address | Properties for address entity.
Public class | ContactDetails | Properties for contactdetails entity.
Public class | Tenant | Properties for Tenant Entity.
Public class | TenantActivationDetails | This calss in used for Tenant Activation Details
Public class | TenantApprovalStatus | Tenant Approval status constants
Public class | TenantDetails | Property for tenant details entity.
Public class | TenantDetailsSearchCondition | Tenant Details Search condition Properties
Public class | TenantDetailsSearchResult | Tenant details search result class
Public class | TenantRelation | Represents tenant relations
Public class | TenantRelationConstant | Tenant relation constant class
Public class | TenantRelationMapping | Tenant Relations Mappings class
Public class | TenantRelationSearchCondition | tenant relations search condition
Public class | TenantRelationType | Tenant Realation type class
Public class | TenantType | Tenant Types Entity
Public class | TenantTypeConstants | Tenant types constants
Public class | TenantTypeSearchCondition | To search the tenant types

Enumerations

 | Enumeration | Description
Public enumeration | TenantProvisionStatus | Tenant Creation/Updation Status Details


Address Class

[image]

A Sandcastle Documented Class Library
Address Class
Members See Also Send Feedback
Properties for address entity.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Address : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class Address
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class Address : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..Address

See Also

Address Members
CelloSaaS.Model.TenantManagement Namespace


Address Members

[image] [image]

A Sandcastle Documented Class Library
Address Members
Address Class Constructors Methods Properties See Also Send Feedback

The Address type exposes the following members.

Constructors

 | Name | Description
Public method | Address | Initializes a new instance of the Address class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Address1 | Gets or sets the address1
Public property | Address2 | Gets or sets the address2
Public property | AddressId | Gets or sets the address id
Public property | City | Gets or sets the city
Public property | CountryId | Gets or sets the county id
Public property | CountryName | Gets or sets the country name.
Public property | CreatedBy | Gets or sets the name/id of user who created this address details.
Public property | CreatedOn | Gets or sets the date time when this address details created.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | PostalCode | Gets or sets the postal code
Public property | State | Gets or sets the state
Public property | Status | Gets or sets the status of the address details.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UniqueId | Gets or sets the unique id
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this address details.
Public property | UpdatedOn | Gets or sets the date time when this address details recently updated.

See Also

Address Class
CelloSaaS.Model.TenantManagement Namespace


Address Constructor

[image]

A Sandcastle Documented Class Library
Address Constructor
Address Class See Also Send Feedback
Initializes a new instance of the Address class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Address()
Visual Basic
Public Sub New
Visual C++
public:
Address()

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address Methods

[image] [image]

A Sandcastle Documented Class Library
Address Methods
Address Class See Also Send Feedback

The Address type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

Address Class
CelloSaaS.Model.TenantManagement Namespace


Address Properties

[image] [image]

A Sandcastle Documented Class Library
Address Properties
Address Class See Also Send Feedback

The Address type exposes the following members.

Properties

 | Name | Description
Public property | Address1 | Gets or sets the address1
Public property | Address2 | Gets or sets the address2
Public property | AddressId | Gets or sets the address id
Public property | City | Gets or sets the city
Public property | CountryId | Gets or sets the county id
Public property | CountryName | Gets or sets the country name.
Public property | CreatedBy | Gets or sets the name/id of user who created this address details.
Public property | CreatedOn | Gets or sets the date time when this address details created.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | PostalCode | Gets or sets the postal code
Public property | State | Gets or sets the state
Public property | Status | Gets or sets the status of the address details.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UniqueId | Gets or sets the unique id
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this address details.
Public property | UpdatedOn | Gets or sets the date time when this address details recently updated.

See Also

Address Class
CelloSaaS.Model.TenantManagement Namespace


Address.Address1 Property

[image]

A Sandcastle Documented Class Library
Address..::..Address1 Property
Address Class See Also Send Feedback
Gets or sets the address1

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Address1 { get; set; }
Visual Basic
Public Property Address1 As String
    Get
    Set
Visual C++
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.Address2 Property

[image]

A Sandcastle Documented Class Library
Address..::..Address2 Property
Address Class See Also Send Feedback
Gets or sets the address2

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Address2 { get; set; }
Visual Basic
Public Property Address2 As String
    Get
    Set
Visual C++
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.AddressId Property

[image]

A Sandcastle Documented Class Library
Address..::..AddressId Property
Address Class See Also Send Feedback
Gets or sets the address id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AddressId { get; set; }
Visual Basic
Public Property AddressId As String
    Get
    Set
Visual C++
public:
property String^ AddressId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.City Property

[image]

A Sandcastle Documented Class Library
Address..::..City Property
Address Class See Also Send Feedback
Gets or sets the city

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string City { get; set; }
Visual Basic
Public Property City As String
    Get
    Set
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.CountryId Property

[image]

A Sandcastle Documented Class Library
Address..::..CountryId Property
Address Class See Also Send Feedback
Gets or sets the county id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CountryId { get; set; }
Visual Basic
Public Property CountryId As String
    Get
    Set
Visual C++
public:
property String^ CountryId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.CountryName Property

[image]

A Sandcastle Documented Class Library
Address..::..CountryName Property
Address Class See Also Send Feedback
Gets or sets the country name.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CountryName { get; set; }
Visual Basic
Public Property CountryName As String
    Get
    Set
Visual C++
public:
property String^ CountryName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.CreatedBy Property

[image]

A Sandcastle Documented Class Library
Address..::..CreatedBy Property
Address Class See Also Send Feedback
Gets or sets the name/id of user who created this address details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.CreatedOn Property

[image]

A Sandcastle Documented Class Library
Address..::..CreatedOn Property
Address Class See Also Send Feedback
Gets or sets the date time when this address details created.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.PostalCode Property

[image]

A Sandcastle Documented Class Library
Address..::..PostalCode Property
Address Class See Also Send Feedback
Gets or sets the postal code

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PostalCode { get; set; }
Visual Basic
Public Property PostalCode As String
    Get
    Set
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.State Property

[image]

A Sandcastle Documented Class Library
Address..::..State Property
Address Class See Also Send Feedback
Gets or sets the state

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string State { get; set; }
Visual Basic
Public Property State As String
    Get
    Set
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.Status Property

[image]

A Sandcastle Documented Class Library
Address..::..Status Property
Address Class See Also Send Feedback
Gets or sets the status of the address details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.UniqueId Property

[image]

A Sandcastle Documented Class Library
Address..::..UniqueId Property
Address Class See Also Send Feedback
Gets or sets the unique id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UniqueId { get; set; }
Visual Basic
Public Property UniqueId As String
    Get
    Set
Visual C++
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
Address..::..UpdatedBy Property
Address Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this address details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


Address.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
Address..::..UpdatedOn Property
Address Class See Also Send Feedback
Gets or sets the date time when this address details recently updated.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

Address Class
Address Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails Class

[image]

A Sandcastle Documented Class Library
ContactDetails Class
Members See Also Send Feedback
Properties for contactdetails entity.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ContactDetails : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class ContactDetails
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class ContactDetails : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..ContactDetails

See Also

ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails Members

[image] [image]

A Sandcastle Documented Class Library
ContactDetails Members
ContactDetails Class Constructors Methods Properties See Also Send Feedback

The ContactDetails type exposes the following members.

Constructors

 | Name | Description
Public method | ContactDetails | Initializes a new instance of the ContactDetails class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | ContactId | Gets or sets the contact id
Public property | CreatedBy | Gets or sets the name/id of user who created this contact details.
Public property | CreatedOn | Gets or sets the date time when this contact details created.
Public property | Email | Gets or sets the email.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Fax | Gets or sets the fax
Public property | FirstName | Gets or sets the first name.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LastName | Gets or sets the last name.
Public property | Phone | Gets or sets the phone number.
Public property | Status | Gets or sets the status of the contact details.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this contact details.
Public property | UpdatedOn | Gets or sets the date time when this contact details recently updated.

See Also

ContactDetails Class
CelloSaaS.Model.TenantManagement Namespace


ContactDetails Constructor

[image]

A Sandcastle Documented Class Library
ContactDetails Constructor
ContactDetails Class See Also Send Feedback
Initializes a new instance of the ContactDetails class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ContactDetails()
Visual Basic
Public Sub New
Visual C++
public:
ContactDetails()

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails Methods

[image] [image]

A Sandcastle Documented Class Library
ContactDetails Methods
ContactDetails Class See Also Send Feedback

The ContactDetails type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

ContactDetails Class
CelloSaaS.Model.TenantManagement Namespace


ContactDetails Properties

[image] [image]

A Sandcastle Documented Class Library
ContactDetails Properties
ContactDetails Class See Also Send Feedback

The ContactDetails type exposes the following members.

Properties

 | Name | Description
Public property | ContactId | Gets or sets the contact id
Public property | CreatedBy | Gets or sets the name/id of user who created this contact details.
Public property | CreatedOn | Gets or sets the date time when this contact details created.
Public property | Email | Gets or sets the email.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Fax | Gets or sets the fax
Public property | FirstName | Gets or sets the first name.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LastName | Gets or sets the last name.
Public property | Phone | Gets or sets the phone number.
Public property | Status | Gets or sets the status of the contact details.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this contact details.
Public property | UpdatedOn | Gets or sets the date time when this contact details recently updated.

See Also

ContactDetails Class
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.ContactId Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..ContactId Property
ContactDetails Class See Also Send Feedback
Gets or sets the contact id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContactId { get; set; }
Visual Basic
Public Property ContactId As String
    Get
    Set
Visual C++
public:
property String^ ContactId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..CreatedBy Property
ContactDetails Class See Also Send Feedback
Gets or sets the name/id of user who created this contact details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..CreatedOn Property
ContactDetails Class See Also Send Feedback
Gets or sets the date time when this contact details created.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.Email Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..Email Property
ContactDetails Class See Also Send Feedback
Gets or sets the email.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Email { get; set; }
Visual Basic
Public Property Email As String
    Get
    Set
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.Fax Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..Fax Property
ContactDetails Class See Also Send Feedback
Gets or sets the fax

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Fax { get; set; }
Visual Basic
Public Property Fax As String
    Get
    Set
Visual C++
public:
property String^ Fax {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.FirstName Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..FirstName Property
ContactDetails Class See Also Send Feedback
Gets or sets the first name.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.LastName Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..LastName Property
ContactDetails Class See Also Send Feedback
Gets or sets the last name.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.Phone Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..Phone Property
ContactDetails Class See Also Send Feedback
Gets or sets the phone number.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Phone { get; set; }
Visual Basic
Public Property Phone As String
    Get
    Set
Visual C++
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.Status Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..Status Property
ContactDetails Class See Also Send Feedback
Gets or sets the status of the contact details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..UpdatedBy Property
ContactDetails Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this contact details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


ContactDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
ContactDetails..::..UpdatedOn Property
ContactDetails Class See Also Send Feedback
Gets or sets the date time when this contact details recently updated.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

ContactDetails Class
ContactDetails Members
CelloSaaS.Model.TenantManagement Namespace


Tenant Class

[image]

A Sandcastle Documented Class Library
Tenant Class
Members See Also Send Feedback
Properties for Tenant Entity.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Tenant : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class Tenant
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class Tenant : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..Tenant

See Also

Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant Members

[image] [image]

A Sandcastle Documented Class Library
Tenant Members
Tenant Class Constructors Methods Properties See Also Send Feedback

The Tenant type exposes the following members.

Constructors

 | Name | Description
Public method | Tenant()()()() | Default Constructor for Tenant Entity
Public method | Tenant(TenantDetails, Address, ContactDetails, User, MembershipDetails) | Tenant Constructor with Tenant Details, Address, Contact, User, Membership details

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Address | Gets or Sets the CelloSaaS.Model.TenantManagement.Address
Public property | ContactDetail | Gets or Sets the CelloSaaS.Model.TenantManagement.ContactDetails
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TenantAdminMembershipdetail | Gets or Sets the CelloSaaS.Model.UserManagement.MembershipDetails
Public property | TenantAdminUserdetail | Gets or Sets the CelloSaaS.Model.UserManagement.User
Public property | TenantDetails | Gets or Sets the CelloSaaS.Model.TenantManagement.TenantDetails
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | Types | Gets or Sets the CelloSaaS.Model.TenantManagemant.TenantTypes

See Also

Tenant Class
CelloSaaS.Model.TenantManagement Namespace


Tenant Constructor

[image] [image]

A Sandcastle Documented Class Library
Tenant Constructor
Tenant Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tenant()()()() | Default Constructor for Tenant Entity
Public method | Tenant(TenantDetails, Address, ContactDetails, User, MembershipDetails) | Tenant Constructor with Tenant Details, Address, Contact, User, Membership details

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant Constructor

[image]

A Sandcastle Documented Class Library
Tenant Constructor
Tenant Class See Also Send Feedback
Default Constructor for Tenant Entity

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Tenant()
Visual Basic
Public Sub New
Visual C++
public:
Tenant()

See Also

Tenant Class
Tenant Members
Tenant Overload
CelloSaaS.Model.TenantManagement Namespace


Tenant Constructor (TenantDetails, Address, ContactDetails, User, MembershipDetails)

[image]

A Sandcastle Documented Class Library
Tenant Constructor (TenantDetails, Address, ContactDetails, User, MembershipDetails)
Tenant Class See Also Send Feedback
Tenant Constructor with Tenant Details, Address, Contact, User, Membership details

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Tenant(
    TenantDetails tenantDetials,
    Address address,
    ContactDetails contactDetails,
    User user,
    MembershipDetails membershipDetails
)
Visual Basic
Public Sub New (
    tenantDetials As TenantDetails,
    address As Address,
    contactDetails As ContactDetails,
    user As User,
    membershipDetails As MembershipDetails
)
Visual C++
public:
Tenant(
    TenantDetails^ tenantDetials,
    Address^ address,
    ContactDetails^ contactDetails,
    User^ user,
    MembershipDetails^ membershipDetails
)

Parameters

tenantDetials
Type: CelloSaaS.Model.TenantManagement..::..TenantDetails
Tenant Details
address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address Details
contactDetails
Type: CelloSaaS.Model.TenantManagement..::..ContactDetails
Contact Details
user
Type: CelloSaaS.Model.UserManagement..::..User
User Details
membershipDetails
Type: CelloSaaS.Model.UserManagement..::..MembershipDetails
Membership Details

See Also

Tenant Class
Tenant Members
Tenant Overload
CelloSaaS.Model.TenantManagement Namespace


Tenant Methods

[image] [image]

A Sandcastle Documented Class Library
Tenant Methods
Tenant Class See Also Send Feedback

The Tenant type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

Tenant Class
CelloSaaS.Model.TenantManagement Namespace


Tenant Properties

[image] [image]

A Sandcastle Documented Class Library
Tenant Properties
Tenant Class See Also Send Feedback

The Tenant type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets or Sets the CelloSaaS.Model.TenantManagement.Address
Public property | ContactDetail | Gets or Sets the CelloSaaS.Model.TenantManagement.ContactDetails
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TenantAdminMembershipdetail | Gets or Sets the CelloSaaS.Model.UserManagement.MembershipDetails
Public property | TenantAdminUserdetail | Gets or Sets the CelloSaaS.Model.UserManagement.User
Public property | TenantDetails | Gets or Sets the CelloSaaS.Model.TenantManagement.TenantDetails
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | Types | Gets or Sets the CelloSaaS.Model.TenantManagemant.TenantTypes

See Also

Tenant Class
CelloSaaS.Model.TenantManagement Namespace


Tenant.Address Property

[image]

A Sandcastle Documented Class Library
Tenant..::..Address Property
Tenant Class See Also Send Feedback
Gets or Sets the CelloSaaS.Model.TenantManagement.Address

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Address Address { get; set; }
Visual Basic
Public Property Address As Address
    Get
    Set
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}

Property Value

Type: Address

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant.ContactDetail Property

[image]

A Sandcastle Documented Class Library
Tenant..::..ContactDetail Property
Tenant Class See Also Send Feedback
Gets or Sets the CelloSaaS.Model.TenantManagement.ContactDetails

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ContactDetails ContactDetail { get; set; }
Visual Basic
Public Property ContactDetail As ContactDetails
    Get
    Set
Visual C++
public:
property ContactDetails^ ContactDetail {
    ContactDetails^ get ();
    void set (ContactDetails^ value);
}

Property Value

Type: ContactDetails

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant.TenantAdminMembershipdetail Property

[image]

A Sandcastle Documented Class Library
Tenant..::..TenantAdminMembershipdetail Property
Tenant Class See Also Send Feedback
Gets or Sets the CelloSaaS.Model.UserManagement.MembershipDetails

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MembershipDetails TenantAdminMembershipdetail { get; set; }
Visual Basic
Public Property TenantAdminMembershipdetail As MembershipDetails
    Get
    Set
Visual C++
public:
property MembershipDetails^ TenantAdminMembershipdetail {
    MembershipDetails^ get ();
    void set (MembershipDetails^ value);
}

Property Value

Type: MembershipDetails

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant.TenantAdminUserdetail Property

[image]

A Sandcastle Documented Class Library
Tenant..::..TenantAdminUserdetail Property
Tenant Class See Also Send Feedback
Gets or Sets the CelloSaaS.Model.UserManagement.User

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public User TenantAdminUserdetail { get; set; }
Visual Basic
Public Property TenantAdminUserdetail As User
    Get
    Set
Visual C++
public:
property User^ TenantAdminUserdetail {
    User^ get ();
    void set (User^ value);
}

Property Value

Type: User

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant.TenantDetails Property

[image]

A Sandcastle Documented Class Library
Tenant..::..TenantDetails Property
Tenant Class See Also Send Feedback
Gets or Sets the CelloSaaS.Model.TenantManagement.TenantDetails

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantDetails TenantDetails { get; set; }
Visual Basic
Public Property TenantDetails As TenantDetails
    Get
    Set
Visual C++
public:
property TenantDetails^ TenantDetails {
    TenantDetails^ get ();
    void set (TenantDetails^ value);
}

Property Value

Type: TenantDetails

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


Tenant.Types Property

[image]

A Sandcastle Documented Class Library
Tenant..::..Types Property
Tenant Class See Also Send Feedback
Gets or Sets the CelloSaaS.Model.TenantManagemant.TenantTypes

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<TenantType> Types { get; set; }
Visual Basic
Public Property Types As List(Of TenantType)
    Get
    Set
Visual C++
public:
property List<TenantType^>^ Types {
    List<TenantType^>^ get ();
    void set (List<TenantType^>^ value);
}

Property Value

Type: List<(Of <(<' TenantType >)>)>

See Also

Tenant Class
Tenant Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails Class

[image]

A Sandcastle Documented Class Library
TenantActivationDetails Class
Members See Also Send Feedback
This calss in used for Tenant Activation Details

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantActivationDetails
Visual Basic
<SerializableAttribute>
Public Class TenantActivationDetails
Visual C++
[SerializableAttribute]
public ref class TenantActivationDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.TenantManagement..::..TenantActivationDetails

See Also

TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails Members

[image] [image]

A Sandcastle Documented Class Library
TenantActivationDetails Members
TenantActivationDetails Class Constructors Methods Properties See Also Send Feedback

The TenantActivationDetails type exposes the following members.

Constructors

 | Name | Description
Public method | TenantActivationDetails | Initializes a new instance of the TenantActivationDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationKey | Gets or sets the activation key.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | ExpirationDate | Gets or sets the expiration date.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantActivationDetails Class
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails Constructor

[image]

A Sandcastle Documented Class Library
TenantActivationDetails Constructor
TenantActivationDetails Class See Also Send Feedback
Initializes a new instance of the TenantActivationDetails class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationDetails()
Visual Basic
Public Sub New
Visual C++
public:
TenantActivationDetails()

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails Methods

[image] [image]

A Sandcastle Documented Class Library
TenantActivationDetails Methods
TenantActivationDetails Class See Also Send Feedback

The TenantActivationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantActivationDetails Class
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails Properties

[image] [image]

A Sandcastle Documented Class Library
TenantActivationDetails Properties
TenantActivationDetails Class See Also Send Feedback

The TenantActivationDetails type exposes the following members.

Properties

 | Name | Description
Public property | ActivationKey | Gets or sets the activation key.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | ExpirationDate | Gets or sets the expiration date.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantActivationDetails Class
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.ActivationKey Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..ActivationKey Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the activation key.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivationKey { get; set; }
Visual Basic
Public Property ActivationKey As String
    Get
    Set
Visual C++
public:
property String^ ActivationKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The activation key.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..CreatedBy Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..CreatedOn Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.ExpirationDate Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..ExpirationDate Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the expiration date.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ExpirationDate { get; set; }
Visual Basic
Public Property ExpirationDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The expiration date.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.Status Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..Status Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.TenantId Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..TenantId Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..UpdatedBy Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantActivationDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantActivationDetails..::..UpdatedOn Property
TenantActivationDetails Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

TenantActivationDetails Class
TenantActivationDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantApprovalStatus Class

[image]

A Sandcastle Documented Class Library
TenantApprovalStatus Class
Members See Also Send Feedback
Tenant Approval status constants

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantApprovalStatus
Visual Basic
Public NotInheritable Class TenantApprovalStatus
Visual C++
public ref class TenantApprovalStatus abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.TenantManagement..::..TenantApprovalStatus

See Also

TenantApprovalStatus Members
CelloSaaS.Model.TenantManagement Namespace


TenantApprovalStatus Members

[image] [image]

A Sandcastle Documented Class Library
TenantApprovalStatus Members
TenantApprovalStatus Class Fields See Also Send Feedback

The TenantApprovalStatus type exposes the following members.

Fields

Name | Description
APPROVED |
REJECTED |
WAITINGFORAPPROVAL |

See Also

TenantApprovalStatus Class
CelloSaaS.Model.TenantManagement Namespace


TenantApprovalStatus Fields

[image] [image]

A Sandcastle Documented Class Library
TenantApprovalStatus Fields
TenantApprovalStatus Class See Also Send Feedback

The TenantApprovalStatus type exposes the following members.

Fields

Name | Description
APPROVED |
REJECTED |
WAITINGFORAPPROVAL |

See Also

TenantApprovalStatus Class
CelloSaaS.Model.TenantManagement Namespace


TenantApprovalStatus.APPROVED Field

[image]

A Sandcastle Documented Class Library
TenantApprovalStatus..::..APPROVED Field
TenantApprovalStatus Class See Also Send Feedback

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string APPROVED
Visual Basic
Public Const APPROVED As String
Visual C++
public:
literal String^ APPROVED

Field Value

Type: String

See Also

TenantApprovalStatus Class
TenantApprovalStatus Members
CelloSaaS.Model.TenantManagement Namespace


TenantApprovalStatus.REJECTED Field

[image]

A Sandcastle Documented Class Library
TenantApprovalStatus..::..REJECTED Field
TenantApprovalStatus Class See Also Send Feedback

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string REJECTED
Visual Basic
Public Const REJECTED As String
Visual C++
public:
literal String^ REJECTED

Field Value

Type: String

See Also

TenantApprovalStatus Class
TenantApprovalStatus Members
CelloSaaS.Model.TenantManagement Namespace


TenantApprovalStatus.WAITINGFORAPPROVAL Field

[image]

A Sandcastle Documented Class Library
TenantApprovalStatus..::..WAITINGFORAPPROVAL Field
TenantApprovalStatus Class See Also Send Feedback

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WAITINGFORAPPROVAL
Visual Basic
Public Const WAITINGFORAPPROVAL As String
Visual C++
public:
literal String^ WAITINGFORAPPROVAL

Field Value

Type: String

See Also

TenantApprovalStatus Class
TenantApprovalStatus Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails Class

[image]

A Sandcastle Documented Class Library
TenantDetails Class
Members See Also Send Feedback
Property for tenant details entity.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantDetails : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantDetails
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantDetails : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..TenantDetails

See Also

TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails Members

[image] [image]

A Sandcastle Documented Class Library
TenantDetails Members
TenantDetails Class Constructors Methods Properties See Also Send Feedback

The TenantDetails type exposes the following members.

Constructors

 | Name | Description
Public method | TenantDetails | Initializes a new instance of the TenantDetails class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | AddressID | Gets or sets the address id.
Public property | ApprovalStatus | Gets or sets the approval status.
Public property | BillingAddressId | Gets or sets the billing address id.
Public property | BillingContactId | Gets or sets the billing contact id.
Public property | BillingType | Gets or sets the billing type.
Public property | BillOther | Gets or sets the bill other.
Public property | childTenant | Gets or sets the child tenant.
Public property | CompanySize | Gets or sets the size of the company.
Public property | ContactId | Gets or sets the contact id
Public property | CreatedBy | Gets or sets the name/id of user who created this tenant details.
Public property | CreatedOn | Gets or sets the date time when this tenant details created.
Public property | DataPartitionId | Gets or Sets DataPartitionId value Used in partitioning database
Public property | Description | Gets or sets the description
Public property | EnableAutoDebit | Gets or sets IsAuotDebit value If true then the bills will be automatically debited
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsProductAdmin | Gets or sets whether current user is product admin or not.
Public property | IsSelfRegistered | Gets or Sets IsSelfRegistered value If true then tenant is self registered
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | ParentTenant | Gets or sets the parent tenant.
Public property | ParentTenantId | Gets or sets the parent tenant id.
Public property | PaymentType | Gets or sets the payment type.
Public property | Status | Gets or sets the status of the tenant details.
Public property | TenantCode | Gets or sets the tenant code.
Public property | TenantCodeString | Gets or sets the tenant code string.
Public property | TenantName | Gets or sets the tenant name.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this tenant details.
Public property | UpdatedOn | Gets or sets the date time when this tenant details recently updated.
Public property | URL | Gets or sets the url of tenant.
Public property | Website | Gets or sets the website

See Also

TenantDetails Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetails Constructor

[image]

A Sandcastle Documented Class Library
TenantDetails Constructor
TenantDetails Class See Also Send Feedback
Initializes a new instance of the TenantDetails class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantDetails()
Visual Basic
Public Sub New
Visual C++
public:
TenantDetails()

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails Methods

[image] [image]

A Sandcastle Documented Class Library
TenantDetails Methods
TenantDetails Class See Also Send Feedback

The TenantDetails type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantDetails Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetails Properties

[image] [image]

A Sandcastle Documented Class Library
TenantDetails Properties
TenantDetails Class See Also Send Feedback

The TenantDetails type exposes the following members.

Properties

 | Name | Description
Public property | AddressID | Gets or sets the address id.
Public property | ApprovalStatus | Gets or sets the approval status.
Public property | BillingAddressId | Gets or sets the billing address id.
Public property | BillingContactId | Gets or sets the billing contact id.
Public property | BillingType | Gets or sets the billing type.
Public property | BillOther | Gets or sets the bill other.
Public property | childTenant | Gets or sets the child tenant.
Public property | CompanySize | Gets or sets the size of the company.
Public property | ContactId | Gets or sets the contact id
Public property | CreatedBy | Gets or sets the name/id of user who created this tenant details.
Public property | CreatedOn | Gets or sets the date time when this tenant details created.
Public property | DataPartitionId | Gets or Sets DataPartitionId value Used in partitioning database
Public property | Description | Gets or sets the description
Public property | EnableAutoDebit | Gets or sets IsAuotDebit value If true then the bills will be automatically debited
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsProductAdmin | Gets or sets whether current user is product admin or not.
Public property | IsSelfRegistered | Gets or Sets IsSelfRegistered value If true then tenant is self registered
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | ParentTenant | Gets or sets the parent tenant.
Public property | ParentTenantId | Gets or sets the parent tenant id.
Public property | PaymentType | Gets or sets the payment type.
Public property | Status | Gets or sets the status of the tenant details.
Public property | TenantCode | Gets or sets the tenant code.
Public property | TenantCodeString | Gets or sets the tenant code string.
Public property | TenantName | Gets or sets the tenant name.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this tenant details.
Public property | UpdatedOn | Gets or sets the date time when this tenant details recently updated.
Public property | URL | Gets or sets the url of tenant.
Public property | Website | Gets or sets the website

See Also

TenantDetails Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.AddressID Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..AddressID Property
TenantDetails Class See Also Send Feedback
Gets or sets the address id.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AddressID { get; set; }
Visual Basic
Public Property AddressID As String
    Get
    Set
Visual C++
public:
property String^ AddressID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.ApprovalStatus Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..ApprovalStatus Property
TenantDetails Class See Also Send Feedback
Gets or sets the approval status.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ApprovalStatus { get; set; }
Visual Basic
Public Property ApprovalStatus As String
    Get
    Set
Visual C++
public:
property String^ ApprovalStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The approval status.

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.BillingAddressId Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..BillingAddressId Property
TenantDetails Class See Also Send Feedback
Gets or sets the billing address id.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BillingAddressId { get; set; }
Visual Basic
Public Property BillingAddressId As String
    Get
    Set
Visual C++
public:
property String^ BillingAddressId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.BillingContactId Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..BillingContactId Property
TenantDetails Class See Also Send Feedback
Gets or sets the billing contact id.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BillingContactId { get; set; }
Visual Basic
Public Property BillingContactId As String
    Get
    Set
Visual C++
public:
property String^ BillingContactId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.BillingType Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..BillingType Property
TenantDetails Class See Also Send Feedback
Gets or sets the billing type.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BillingType { get; set; }
Visual Basic
Public Property BillingType As String
    Get
    Set
Visual C++
public:
property String^ BillingType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.BillOther Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..BillOther Property
TenantDetails Class See Also Send Feedback
Gets or sets the bill other.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool BillOther { get; set; }
Visual Basic
Public Property BillOther As Boolean
    Get
    Set
Visual C++
public:
property bool BillOther {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.childTenant Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..childTenant Property
TenantDetails Class See Also Send Feedback
Gets or sets the child tenant.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, TenantDetails> childTenant { get; set; }
Visual Basic
Public Property childTenant As Dictionary(Of String, TenantDetails)
    Get
    Set
Visual C++
public:
property Dictionary<String^, TenantDetails^>^ childTenant {
    Dictionary<String^, TenantDetails^>^ get ();
    void set (Dictionary<String^, TenantDetails^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
The child tenant.

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.CompanySize Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..CompanySize Property
TenantDetails Class See Also Send Feedback
Gets or sets the size of the company.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CompanySize { get; set; }
Visual Basic
Public Property CompanySize As String
    Get
    Set
Visual C++
public:
property String^ CompanySize {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The size of the company.

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.ContactId Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..ContactId Property
TenantDetails Class See Also Send Feedback
Gets or sets the contact id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContactId { get; set; }
Visual Basic
Public Property ContactId As String
    Get
    Set
Visual C++
public:
property String^ ContactId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..CreatedBy Property
TenantDetails Class See Also Send Feedback
Gets or sets the name/id of user who created this tenant details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..CreatedOn Property
TenantDetails Class See Also Send Feedback
Gets or sets the date time when this tenant details created.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.DataPartitionId Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..DataPartitionId Property
TenantDetails Class See Also Send Feedback
Gets or Sets DataPartitionId value Used in partitioning database

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataPartitionId { get; set; }
Visual Basic
Public Property DataPartitionId As String
    Get
    Set
Visual C++
public:
property String^ DataPartitionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.Description Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..Description Property
TenantDetails Class See Also Send Feedback
Gets or sets the description

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.EnableAutoDebit Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..EnableAutoDebit Property
TenantDetails Class See Also Send Feedback
Gets or sets IsAuotDebit value If true then the bills will be automatically debited

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool EnableAutoDebit { get; set; }
Visual Basic
Public Property EnableAutoDebit As Boolean
    Get
    Set
Visual C++
public:
property bool EnableAutoDebit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.IsProductAdmin Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..IsProductAdmin Property
TenantDetails Class See Also Send Feedback
Gets or sets whether current user is product admin or not.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsProductAdmin { get; set; }
Visual Basic
Public Property IsProductAdmin As Boolean
    Get
    Set
Visual C++
public:
property bool IsProductAdmin {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.IsSelfRegistered Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..IsSelfRegistered Property
TenantDetails Class See Also Send Feedback
Gets or Sets IsSelfRegistered value If true then tenant is self registered

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsSelfRegistered { get; set; }
Visual Basic
Public Property IsSelfRegistered As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelfRegistered {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.ParentTenant Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..ParentTenant Property
TenantDetails Class See Also Send Feedback
Gets or sets the parent tenant.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantDetails ParentTenant { get; set; }
Visual Basic
Public Property ParentTenant As TenantDetails
    Get
    Set
Visual C++
public:
property TenantDetails^ ParentTenant {
    TenantDetails^ get ();
    void set (TenantDetails^ value);
}

Property Value

Type: TenantDetails
The parent tenant.

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..ParentTenantId Property
TenantDetails Class See Also Send Feedback
Gets or sets the parent tenant id.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As String
    Get
    Set
Visual C++
public:
property String^ ParentTenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The parent tenant id.

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.PaymentType Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..PaymentType Property
TenantDetails Class See Also Send Feedback
Gets or sets the payment type.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PaymentType { get; set; }
Visual Basic
Public Property PaymentType As String
    Get
    Set
Visual C++
public:
property String^ PaymentType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.Status Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..Status Property
TenantDetails Class See Also Send Feedback
Gets or sets the status of the tenant details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.TenantCode Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..TenantCode Property
TenantDetails Class See Also Send Feedback
Gets or sets the tenant code.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantCode { get; set; }
Visual Basic
Public Property TenantCode As String
    Get
    Set
Visual C++
public:
property String^ TenantCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.TenantCodeString Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..TenantCodeString Property
TenantDetails Class See Also Send Feedback
Gets or sets the tenant code string.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantCodeString { get; set; }
Visual Basic
Public Property TenantCodeString As String
    Get
    Set
Visual C++
public:
property String^ TenantCodeString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.TenantName Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..TenantName Property
TenantDetails Class See Also Send Feedback
Gets or sets the tenant name.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantName { get; set; }
Visual Basic
Public Property TenantName As String
    Get
    Set
Visual C++
public:
property String^ TenantName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..UpdatedBy Property
TenantDetails Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this tenant details.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..UpdatedOn Property
TenantDetails Class See Also Send Feedback
Gets or sets the date time when this tenant details recently updated.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.URL Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..URL Property
TenantDetails Class See Also Send Feedback
Gets or sets the url of tenant.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string URL { get; set; }
Visual Basic
Public Property URL As String
    Get
    Set
Visual C++
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetails.Website Property

[image]

A Sandcastle Documented Class Library
TenantDetails..::..Website Property
TenantDetails Class See Also Send Feedback
Gets or sets the website

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Website { get; set; }
Visual Basic
Public Property Website As String
    Get
    Set
Visual C++
public:
property String^ Website {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetails Class
TenantDetails Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition Class

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition Class
Members See Also Send Feedback
Tenant Details Search condition Properties

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantDetailsSearchCondition : ISearchCondition
Visual Basic
<SerializableAttribute>
Public Class TenantDetailsSearchCondition
    Implements ISearchCondition
Visual C++
[SerializableAttribute]
public ref class TenantDetailsSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.TenantManagement..::..TenantDetailsSearchCondition

See Also

TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition Members
TenantDetailsSearchCondition Class Constructors Methods Properties See Also Send Feedback

The TenantDetailsSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TenantDetailsSearchCondition | Initializes a new instance of the TenantDetailsSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApprovalStatus | Searches by tenant approval status
Public property | Condition | Gets or sets the search condition text (not used)
Public property | ContactEmail | Search by tenant contact email (= operator)
Public property | ContactPhone | Search by tenant contact Phone (like operator)
Public property | CreatedYear | Searchs by tenant created year
Public property | DataPartitionId | Search by data partition id
Public property | EnableAutoDebit | True returns only auto debit enabled tenant False returns auto debit disabled tenants Null both
Public property | HasChildTenants | True searches tenant who has child tenants False searches tenant who does not have child tenants Null both
Public property | HasOnlineUsers | True searches tenant who has online users False searches tenant who does not have online users Null both
Public property | IsSelfRegistered | True returns only self registered tenant False returns not self registered tenants Null both
Public property | PageNo | Gets or sets the page no (default 1)
Public property | PageSize | Gets or sets the page size (default 20)
Public property | ParentTenantId | If set this tenant id will be used as parent tenant id else current logged in tenant id will be used for searching
Public property | SearchValue | Gets or Sets the Search Value
Public property | SortDirection | Gets or sets the sort direction "ASC" or "DESC"
Public property | SortString | Gets or Sets the sort string "Tenant_Name", "Tenant_CreatedOn"
Public property | Status | True returns only active tenants
Public property | TenantCodeString | Search by company code (= operator)
Public property | TenantIds | Search by tenant pk
Public property | TenantName | Search by tenant name (like operator)
Public property | TenantTypeId | Search by tenant type
Public property | Url | Gets or Sets the Url of Tenant
Public property | WebSite | Gets or Sets the Website of Tenant
Public property | WithOutPaymentAccount | True searches tenant without payment account False searches tenant with payment account Null both

See Also

TenantDetailsSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition Constructor
TenantDetailsSearchCondition Class See Also Send Feedback
Initializes a new instance of the TenantDetailsSearchCondition class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantDetailsSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
TenantDetailsSearchCondition()

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition Methods
TenantDetailsSearchCondition Class See Also Send Feedback

The TenantDetailsSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantDetailsSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition Properties
TenantDetailsSearchCondition Class See Also Send Feedback

The TenantDetailsSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | ApprovalStatus | Searches by tenant approval status
Public property | Condition | Gets or sets the search condition text (not used)
Public property | ContactEmail | Search by tenant contact email (= operator)
Public property | ContactPhone | Search by tenant contact Phone (like operator)
Public property | CreatedYear | Searchs by tenant created year
Public property | DataPartitionId | Search by data partition id
Public property | EnableAutoDebit | True returns only auto debit enabled tenant False returns auto debit disabled tenants Null both
Public property | HasChildTenants | True searches tenant who has child tenants False searches tenant who does not have child tenants Null both
Public property | HasOnlineUsers | True searches tenant who has online users False searches tenant who does not have online users Null both
Public property | IsSelfRegistered | True returns only self registered tenant False returns not self registered tenants Null both
Public property | PageNo | Gets or sets the page no (default 1)
Public property | PageSize | Gets or sets the page size (default 20)
Public property | ParentTenantId | If set this tenant id will be used as parent tenant id else current logged in tenant id will be used for searching
Public property | SearchValue | Gets or Sets the Search Value
Public property | SortDirection | Gets or sets the sort direction "ASC" or "DESC"
Public property | SortString | Gets or Sets the sort string "Tenant_Name", "Tenant_CreatedOn"
Public property | Status | True returns only active tenants
Public property | TenantCodeString | Search by company code (= operator)
Public property | TenantIds | Search by tenant pk
Public property | TenantName | Search by tenant name (like operator)
Public property | TenantTypeId | Search by tenant type
Public property | Url | Gets or Sets the Url of Tenant
Public property | WebSite | Gets or Sets the Website of Tenant
Public property | WithOutPaymentAccount | True searches tenant without payment account False searches tenant with payment account Null both

See Also

TenantDetailsSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.ApprovalStatus Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..ApprovalStatus Property
TenantDetailsSearchCondition Class See Also Send Feedback
Searches by tenant approval status

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] ApprovalStatus { get; set; }
Visual Basic
Public Property ApprovalStatus As String()
    Get
    Set
Visual C++
public:
property array<String^>^ ApprovalStatus {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..Condition Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or sets the search condition text (not used)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.ContactEmail Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..ContactEmail Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by tenant contact email (= operator)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContactEmail { get; set; }
Visual Basic
Public Property ContactEmail As String
    Get
    Set
Visual C++
public:
property String^ ContactEmail {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.ContactPhone Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..ContactPhone Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by tenant contact Phone (like operator)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContactPhone { get; set; }
Visual Basic
Public Property ContactPhone As String
    Get
    Set
Visual C++
public:
property String^ ContactPhone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.CreatedYear Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..CreatedYear Property
TenantDetailsSearchCondition Class See Also Send Feedback
Searchs by tenant created year

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int CreatedYear { get; set; }
Visual Basic
Public Property CreatedYear As Integer
    Get
    Set
Visual C++
public:
property int CreatedYear {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.DataPartitionId Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..DataPartitionId Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by data partition id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid DataPartitionId { get; set; }
Visual Basic
Public Property DataPartitionId As Guid
    Get
    Set
Visual C++
public:
property Guid DataPartitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.EnableAutoDebit Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..EnableAutoDebit Property
TenantDetailsSearchCondition Class See Also Send Feedback
True returns only auto debit enabled tenant False returns auto debit disabled tenants Null both

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> EnableAutoDebit { get; set; }
Visual Basic
Public Property EnableAutoDebit As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> EnableAutoDebit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.HasChildTenants Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..HasChildTenants Property
TenantDetailsSearchCondition Class See Also Send Feedback
True searches tenant who has child tenants False searches tenant who does not have child tenants Null both

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> HasChildTenants { get; set; }
Visual Basic
Public Property HasChildTenants As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> HasChildTenants {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.HasOnlineUsers Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..HasOnlineUsers Property
TenantDetailsSearchCondition Class See Also Send Feedback
True searches tenant who has online users False searches tenant who does not have online users Null both

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> HasOnlineUsers { get; set; }
Visual Basic
Public Property HasOnlineUsers As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> HasOnlineUsers {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.IsSelfRegistered Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..IsSelfRegistered Property
TenantDetailsSearchCondition Class See Also Send Feedback
True returns only self registered tenant False returns not self registered tenants Null both

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> IsSelfRegistered { get; set; }
Visual Basic
Public Property IsSelfRegistered As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> IsSelfRegistered {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.PageNo Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..PageNo Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or sets the page no (default 1)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNo { get; set; }
Visual Basic
Public Property PageNo As Integer
    Get
    Set
Visual C++
public:
property int PageNo {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..PageSize Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or sets the page size (default 20)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..ParentTenantId Property
TenantDetailsSearchCondition Class See Also Send Feedback
If set this tenant id will be used as parent tenant id else current logged in tenant id will be used for searching

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As Guid
    Get
    Set
Visual C++
public:
property Guid ParentTenantId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.SearchValue Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..SearchValue Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or Sets the Search Value

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchValue { get; set; }
Visual Basic
Public Property SearchValue As String
    Get
    Set
Visual C++
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.SortDirection Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..SortDirection Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or sets the sort direction "ASC" or "DESC"

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortDirection { get; set; }
Visual Basic
Public Property SortDirection As String
    Get
    Set
Visual C++
public:
property String^ SortDirection {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..SortString Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or Sets the sort string "Tenant_Name", "Tenant_CreatedOn"

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.Status Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..Status Property
TenantDetailsSearchCondition Class See Also Send Feedback
True returns only active tenants

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.TenantCodeString Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..TenantCodeString Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by company code (= operator)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantCodeString { get; set; }
Visual Basic
Public Property TenantCodeString As String
    Get
    Set
Visual C++
public:
property String^ TenantCodeString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..TenantIds Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by tenant pk

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As Guid()
    Get
    Set
Visual C++
public:
property array<Guid>^ TenantIds {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: array<Guid>[]()[][]

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.TenantName Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..TenantName Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by tenant name (like operator)

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantName { get; set; }
Visual Basic
Public Property TenantName As String
    Get
    Set
Visual C++
public:
property String^ TenantName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.TenantTypeId Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..TenantTypeId Property
TenantDetailsSearchCondition Class See Also Send Feedback
Search by tenant type

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantTypeId { get; set; }
Visual Basic
Public Property TenantTypeId As String
    Get
    Set
Visual C++
public:
property String^ TenantTypeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.Url Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..Url Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or Sets the Url of Tenant

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.WebSite Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..WebSite Property
TenantDetailsSearchCondition Class See Also Send Feedback
Gets or Sets the Website of Tenant

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WebSite { get; set; }
Visual Basic
Public Property WebSite As String
    Get
    Set
Visual C++
public:
property String^ WebSite {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchCondition.WithOutPaymentAccount Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchCondition..::..WithOutPaymentAccount Property
TenantDetailsSearchCondition Class See Also Send Feedback
True searches tenant without payment account False searches tenant with payment account Null both

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> WithOutPaymentAccount { get; set; }
Visual Basic
Public Property WithOutPaymentAccount As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> WithOutPaymentAccount {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

TenantDetailsSearchCondition Class
TenantDetailsSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult Class

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult Class
Members See Also Send Feedback
Tenant details search result class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantDetailsSearchResult
Visual Basic
<SerializableAttribute>
Public Class TenantDetailsSearchResult
Visual C++
[SerializableAttribute]
public ref class TenantDetailsSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.TenantManagement..::..TenantDetailsSearchResult

See Also

TenantDetailsSearchResult Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult Members
TenantDetailsSearchResult Class Constructors Methods Properties See Also Send Feedback

The TenantDetailsSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | TenantDetailsSearchResult | Initializes a new instance of the TenantDetailsSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Gets the Tenant details filterd by search criteria
Public property | TotalCount | Gets the total records found for the search criteria

See Also

TenantDetailsSearchResult Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult Constructor

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult Constructor
TenantDetailsSearchResult Class See Also Send Feedback
Initializes a new instance of the TenantDetailsSearchResult class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantDetailsSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
TenantDetailsSearchResult()

See Also

TenantDetailsSearchResult Class
TenantDetailsSearchResult Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult Methods
TenantDetailsSearchResult Class See Also Send Feedback

The TenantDetailsSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantDetailsSearchResult Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult Properties
TenantDetailsSearchResult Class See Also Send Feedback

The TenantDetailsSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets the Tenant details filterd by search criteria
Public property | TotalCount | Gets the total records found for the search criteria

See Also

TenantDetailsSearchResult Class
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult.Items Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult..::..Items Property
TenantDetailsSearchResult Class See Also Send Feedback
Gets the Tenant details filterd by search criteria

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Tenant> Items { get; set; }
Visual Basic
Public Property Items As Dictionary(Of String, Tenant)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Tenant^>^ Items {
    Dictionary<String^, Tenant^>^ get ();
    void set (Dictionary<String^, Tenant^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Tenant >)>)>

See Also

TenantDetailsSearchResult Class
TenantDetailsSearchResult Members
CelloSaaS.Model.TenantManagement Namespace


TenantDetailsSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
TenantDetailsSearchResult..::..TotalCount Property
TenantDetailsSearchResult Class See Also Send Feedback
Gets the total records found for the search criteria

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TenantDetailsSearchResult Class
TenantDetailsSearchResult Members
CelloSaaS.Model.TenantManagement Namespace


TenantProvisionStatus Enumeration

[image]

A Sandcastle Documented Class Library
TenantProvisionStatus Enumeration
See Also Send Feedback
Tenant Creation/Updation Status Details

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum TenantProvisionStatus
Visual Basic
Public Enumeration TenantProvisionStatus
Visual C++
public enum class TenantProvisionStatus

Members

Member name | Value | Description
Success | 0 | Successful Creation/Update of Tenant
DuplicateUserName | 1 | Duplicate User Name of Tenant
DuplicateEmail | 3 | Duplicate Email of Tenant
DuplicateTenantName | 4 | Duplicate Tenant Name
Error | 5 | Any error occur in the tenant creation/update
DuplicateURL | 6 | Duplicate URL of tenant
DuplicateWebsite | 7 | Duplicate Website of Tenant
DuplicateTenantCode | 8 | Duplicate Tenant Code

See Also

CelloSaaS.Model.TenantManagement Namespace


TenantRelation Class

[image]

A Sandcastle Documented Class Library
TenantRelation Class
Members See Also Send Feedback
Represents tenant relations

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantRelation : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantRelation
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantRelation : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..TenantRelation

See Also

TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation Members

[image] [image]

A Sandcastle Documented Class Library
TenantRelation Members
TenantRelation Class Constructors Methods Properties See Also Send Feedback

The TenantRelation type exposes the following members.

Constructors

 | Name | Description
Public method | TenantRelation | Initializes a new instance of the TenantRelation class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | ChildTenantId | Gets or sets the child tenant Id
Public property | CreatedBy | Gets or sets the created by
Public property | CreatedOn | Gets or sets the created on date
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Gets or sets the Identifier
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | ParentTenantId | Gets or sets the Parent Tenant Id
Public property | RelationTypeName | Gets or sets the relation type
Public property | Status | Gets or sets the status field
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by value
Public property | UpdatedOn | Gets or sets the updated on date

See Also

TenantRelation Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelation Constructor

[image]

A Sandcastle Documented Class Library
TenantRelation Constructor
TenantRelation Class See Also Send Feedback
Initializes a new instance of the TenantRelation class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelation()
Visual Basic
Public Sub New
Visual C++
public:
TenantRelation()

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation Methods

[image] [image]

A Sandcastle Documented Class Library
TenantRelation Methods
TenantRelation Class See Also Send Feedback

The TenantRelation type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantRelation Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelation Properties

[image] [image]

A Sandcastle Documented Class Library
TenantRelation Properties
TenantRelation Class See Also Send Feedback

The TenantRelation type exposes the following members.

Properties

 | Name | Description
Public property | ChildTenantId | Gets or sets the child tenant Id
Public property | CreatedBy | Gets or sets the created by
Public property | CreatedOn | Gets or sets the created on date
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Gets or sets the Identifier
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | ParentTenantId | Gets or sets the Parent Tenant Id
Public property | RelationTypeName | Gets or sets the relation type
Public property | Status | Gets or sets the status field
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by value
Public property | UpdatedOn | Gets or sets the updated on date

See Also

TenantRelation Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.ChildTenantId Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..ChildTenantId Property
TenantRelation Class See Also Send Feedback
Gets or sets the child tenant Id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ChildTenantId { get; set; }
Visual Basic
Public Property ChildTenantId As String
    Get
    Set
Visual C++
public:
property String^ ChildTenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..CreatedBy Property
TenantRelation Class See Also Send Feedback
Gets or sets the created by

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..CreatedOn Property
TenantRelation Class See Also Send Feedback
Gets or sets the created on date

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.ID Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..ID Property
TenantRelation Class See Also Send Feedback
Gets or sets the Identifier

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.ParentTenantId Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..ParentTenantId Property
TenantRelation Class See Also Send Feedback
Gets or sets the Parent Tenant Id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ParentTenantId { get; set; }
Visual Basic
Public Property ParentTenantId As String
    Get
    Set
Visual C++
public:
property String^ ParentTenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.RelationTypeName Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..RelationTypeName Property
TenantRelation Class See Also Send Feedback
Gets or sets the relation type

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RelationTypeName { get; set; }
Visual Basic
Public Property RelationTypeName As String
    Get
    Set
Visual C++
public:
property String^ RelationTypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.Status Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..Status Property
TenantRelation Class See Also Send Feedback
Gets or sets the status field

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..UpdatedBy Property
TenantRelation Class See Also Send Feedback
Gets or sets the updated by value

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelation.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantRelation..::..UpdatedOn Property
TenantRelation Class See Also Send Feedback
Gets or sets the updated on date

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantRelation Class
TenantRelation Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationConstant Class

[image]

A Sandcastle Documented Class Library
TenantRelationConstant Class
Members See Also Send Feedback
Tenant relation constant class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantRelationConstant
Visual Basic
Public NotInheritable Class TenantRelationConstant
Visual C++
public ref class TenantRelationConstant abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.TenantManagement..::..TenantRelationConstant

See Also

TenantRelationConstant Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationConstant Members

[image] [image]

A Sandcastle Documented Class Library
TenantRelationConstant Members
TenantRelationConstant Class Fields See Also Send Feedback

The TenantRelationConstant type exposes the following members.

Fields

Name | Description
SUBTENANT | Sub tenant key constant

See Also

TenantRelationConstant Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationConstant Fields

[image] [image]

A Sandcastle Documented Class Library
TenantRelationConstant Fields
TenantRelationConstant Class See Also Send Feedback

The TenantRelationConstant type exposes the following members.

Fields

Name | Description
SUBTENANT | Sub tenant key constant

See Also

TenantRelationConstant Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationConstant.SUBTENANT Field

[image]

A Sandcastle Documented Class Library
TenantRelationConstant..::..SUBTENANT Field
TenantRelationConstant Class See Also Send Feedback
Sub tenant key constant

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SUBTENANT
Visual Basic
Public Const SUBTENANT As String
Visual C++
public:
literal String^ SUBTENANT

Field Value

Type: String

See Also

TenantRelationConstant Class
TenantRelationConstant Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping Class

[image]

A Sandcastle Documented Class Library
TenantRelationMapping Class
Members See Also Send Feedback
Tenant Relations Mappings class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantRelationMapping : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantRelationMapping
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantRelationMapping : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..TenantRelationMapping

See Also

TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping Members

[image] [image]

A Sandcastle Documented Class Library
TenantRelationMapping Members
TenantRelationMapping Class Constructors Methods Properties See Also Send Feedback

The TenantRelationMapping type exposes the following members.

Constructors

 | Name | Description
Public method | TenantRelationMapping | Initializes a new instance of the TenantRelationMapping class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | ChildTenantID | Gets or sets the child tenant ID.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Gets or sets the ID.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | ParentTenantID | Gets or sets the parent tenant ID.
Public property | Status | Gets or sets a value indicating whether this TenantRelationMapping is status.
Public property | TenantRelationTypeID | Gets or sets the tenant relation type ID.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantRelationMapping Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping Constructor

[image]

A Sandcastle Documented Class Library
TenantRelationMapping Constructor
TenantRelationMapping Class See Also Send Feedback
Initializes a new instance of the TenantRelationMapping class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelationMapping()
Visual Basic
Public Sub New
Visual C++
public:
TenantRelationMapping()

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping Methods

[image] [image]

A Sandcastle Documented Class Library
TenantRelationMapping Methods
TenantRelationMapping Class See Also Send Feedback

The TenantRelationMapping type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantRelationMapping Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping Properties

[image] [image]

A Sandcastle Documented Class Library
TenantRelationMapping Properties
TenantRelationMapping Class See Also Send Feedback

The TenantRelationMapping type exposes the following members.

Properties

 | Name | Description
Public property | ChildTenantID | Gets or sets the child tenant ID.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Gets or sets the ID.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | ParentTenantID | Gets or sets the parent tenant ID.
Public property | Status | Gets or sets a value indicating whether this TenantRelationMapping is status.
Public property | TenantRelationTypeID | Gets or sets the tenant relation type ID.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantRelationMapping Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.ChildTenantID Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..ChildTenantID Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the child tenant ID.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ChildTenantID { get; set; }
Visual Basic
Public Property ChildTenantID As String
    Get
    Set
Visual C++
public:
property String^ ChildTenantID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The child tenant ID.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..CreatedBy Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..CreatedOn Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.ID Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..ID Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the ID.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The ID.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.ParentTenantID Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..ParentTenantID Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the parent tenant ID.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ParentTenantID { get; set; }
Visual Basic
Public Property ParentTenantID As String
    Get
    Set
Visual C++
public:
property String^ ParentTenantID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The parent tenant ID.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.Status Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..Status Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets a value indicating whether this TenantRelationMapping is status.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.TenantRelationTypeID Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..TenantRelationTypeID Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the tenant relation type ID.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantRelationTypeID { get; set; }
Visual Basic
Public Property TenantRelationTypeID As String
    Get
    Set
Visual C++
public:
property String^ TenantRelationTypeID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant relation type ID.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..UpdatedBy Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationMapping.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantRelationMapping..::..UpdatedOn Property
TenantRelationMapping Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

TenantRelationMapping Class
TenantRelationMapping Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition Class

[image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition Class
Members See Also Send Feedback
tenant relations search condition

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantRelationSearchCondition : SearchCondition
Visual Basic
<SerializableAttribute>
Public Class TenantRelationSearchCondition
    Inherits SearchCondition
Visual C++
[SerializableAttribute]
public ref class TenantRelationSearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.TenantManagement..::..TenantRelationSearchCondition

See Also

TenantRelationSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition Members
TenantRelationSearchCondition Class Constructors Methods Properties See Also Send Feedback

The TenantRelationSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TenantRelationSearchCondition | Initializes a new instance of the TenantRelationSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChildTenantID | search by child tenant id
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | ParentTenantID | search by source tenant id
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | TenantRelationTypeID | search by relation type

See Also

TenantRelationSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition Constructor
TenantRelationSearchCondition Class See Also Send Feedback
Initializes a new instance of the TenantRelationSearchCondition class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelationSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
TenantRelationSearchCondition()

See Also

TenantRelationSearchCondition Class
TenantRelationSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition Methods
TenantRelationSearchCondition Class See Also Send Feedback

The TenantRelationSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantRelationSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition Properties
TenantRelationSearchCondition Class See Also Send Feedback

The TenantRelationSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | ChildTenantID | search by child tenant id
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | ParentTenantID | search by source tenant id
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | TenantRelationTypeID | search by relation type

See Also

TenantRelationSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition.ChildTenantID Property

[image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition..::..ChildTenantID Property
TenantRelationSearchCondition Class See Also Send Feedback
search by child tenant id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ChildTenantID { get; set; }
Visual Basic
Public Property ChildTenantID As String
    Get
    Set
Visual C++
public:
property String^ ChildTenantID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelationSearchCondition Class
TenantRelationSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition.ParentTenantID Property

[image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition..::..ParentTenantID Property
TenantRelationSearchCondition Class See Also Send Feedback
search by source tenant id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ParentTenantID { get; set; }
Visual Basic
Public Property ParentTenantID As String
    Get
    Set
Visual C++
public:
property String^ ParentTenantID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelationSearchCondition Class
TenantRelationSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationSearchCondition.TenantRelationTypeID Property

[image]

A Sandcastle Documented Class Library
TenantRelationSearchCondition..::..TenantRelationTypeID Property
TenantRelationSearchCondition Class See Also Send Feedback
search by relation type

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantRelationTypeID { get; set; }
Visual Basic
Public Property TenantRelationTypeID As String
    Get
    Set
Visual C++
public:
property String^ TenantRelationTypeID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantRelationSearchCondition Class
TenantRelationSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType Class

[image]

A Sandcastle Documented Class Library
TenantRelationType Class
Members See Also Send Feedback
Tenant Realation type class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantRelationType : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantRelationType
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantRelationType : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..TenantRelationType

See Also

TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType Members

[image] [image]

A Sandcastle Documented Class Library
TenantRelationType Members
TenantRelationType Class Constructors Methods Properties See Also Send Feedback

The TenantRelationType type exposes the following members.

Constructors

 | Name | Description
Public method | TenantRelationType | Initializes a new instance of the TenantRelationType class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Gets or sets the ID.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets a value indicating whether this TenantRelationType is status.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantRelationType Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType Constructor

[image]

A Sandcastle Documented Class Library
TenantRelationType Constructor
TenantRelationType Class See Also Send Feedback
Initializes a new instance of the TenantRelationType class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelationType()
Visual Basic
Public Sub New
Visual C++
public:
TenantRelationType()

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType Methods

[image] [image]

A Sandcastle Documented Class Library
TenantRelationType Methods
TenantRelationType Class See Also Send Feedback

The TenantRelationType type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantRelationType Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType Properties

[image] [image]

A Sandcastle Documented Class Library
TenantRelationType Properties
TenantRelationType Class See Also Send Feedback

The TenantRelationType type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Gets or sets the ID.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets a value indicating whether this TenantRelationType is status.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TenantRelationType Class
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..CreatedBy Property
TenantRelationType Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..CreatedOn Property
TenantRelationType Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.ID Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..ID Property
TenantRelationType Class See Also Send Feedback
Gets or sets the ID.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The ID.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.Name Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..Name Property
TenantRelationType Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.Status Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..Status Property
TenantRelationType Class See Also Send Feedback
Gets or sets a value indicating whether this TenantRelationType is status.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..UpdatedBy Property
TenantRelationType Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantRelationType.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantRelationType..::..UpdatedOn Property
TenantRelationType Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

TenantRelationType Class
TenantRelationType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType Class

[image]

A Sandcastle Documented Class Library
TenantType Class
Members See Also Send Feedback
Tenant Types Entity

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantType : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class TenantType
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class TenantType : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.TenantManagement..::..TenantType

See Also

TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType Members

[image] [image]

A Sandcastle Documented Class Library
TenantType Members
TenantType Class Constructors Methods Properties See Also Send Feedback

The TenantType type exposes the following members.

Constructors

 | Name | Description
Public method | TenantType | Initializes a new instance of the TenantType class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | AccessLevel | Gets or sets the tenant Type Access Level
Public property | CreatedBy | Gets or sets the userid who created the TenantType
Public property | CreatedOn | Gets or sets the datetime on which this TenantType Created
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Get or Sets the TenantTypes ID
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | Name | Gets or sets the Tenant Type name
Public property | Status | Indicates the status of the record
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the userid who Updated this tenant type
Public property | UpdatedOn | Gets or sets the datetime on which this tenant type is updated

See Also

TenantType Class
CelloSaaS.Model.TenantManagement Namespace


TenantType Constructor

[image]

A Sandcastle Documented Class Library
TenantType Constructor
TenantType Class See Also Send Feedback
Initializes a new instance of the TenantType class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantType()
Visual Basic
Public Sub New
Visual C++
public:
TenantType()

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType Methods

[image] [image]

A Sandcastle Documented Class Library
TenantType Methods
TenantType Class See Also Send Feedback

The TenantType type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

TenantType Class
CelloSaaS.Model.TenantManagement Namespace


TenantType Properties

[image] [image]

A Sandcastle Documented Class Library
TenantType Properties
TenantType Class See Also Send Feedback

The TenantType type exposes the following members.

Properties

 | Name | Description
Public property | AccessLevel | Gets or sets the tenant Type Access Level
Public property | CreatedBy | Gets or sets the userid who created the TenantType
Public property | CreatedOn | Gets or sets the datetime on which this TenantType Created
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | ID | Get or Sets the TenantTypes ID
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | Name | Gets or sets the Tenant Type name
Public property | Status | Indicates the status of the record
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the userid who Updated this tenant type
Public property | UpdatedOn | Gets or sets the datetime on which this tenant type is updated

See Also

TenantType Class
CelloSaaS.Model.TenantManagement Namespace


TenantType.AccessLevel Property

[image]

A Sandcastle Documented Class Library
TenantType..::..AccessLevel Property
TenantType Class See Also Send Feedback
Gets or sets the tenant Type Access Level

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public short AccessLevel { get; set; }
Visual Basic
Public Property AccessLevel As Short
    Get
    Set
Visual C++
public:
property short AccessLevel {
    short get ();
    void set (short value);
}

Property Value

Type: Int16

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TenantType..::..CreatedBy Property
TenantType Class See Also Send Feedback
Gets or sets the userid who created the TenantType

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TenantType..::..CreatedOn Property
TenantType Class See Also Send Feedback
Gets or sets the datetime on which this TenantType Created

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.ID Property

[image]

A Sandcastle Documented Class Library
TenantType..::..ID Property
TenantType Class See Also Send Feedback
Get or Sets the TenantTypes ID

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ID { get; set; }
Visual Basic
Public Property ID As String
    Get
    Set
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.Name Property

[image]

A Sandcastle Documented Class Library
TenantType..::..Name Property
TenantType Class See Also Send Feedback
Gets or sets the Tenant Type name

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.Status Property

[image]

A Sandcastle Documented Class Library
TenantType..::..Status Property
TenantType Class See Also Send Feedback
Indicates the status of the record

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TenantType..::..UpdatedBy Property
TenantType Class See Also Send Feedback
Gets or sets the userid who Updated this tenant type

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantType.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TenantType..::..UpdatedOn Property
TenantType Class See Also Send Feedback
Gets or sets the datetime on which this tenant type is updated

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TenantType Class
TenantType Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants Class

[image]

A Sandcastle Documented Class Library
TenantTypeConstants Class
Members See Also Send Feedback
Tenant types constants

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantTypeConstants
Visual Basic
Public NotInheritable Class TenantTypeConstants
Visual C++
public ref class TenantTypeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.TenantManagement..::..TenantTypeConstants

See Also

TenantTypeConstants Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants Members

[image] [image]

A Sandcastle Documented Class Library
TenantTypeConstants Members
TenantTypeConstants Class Fields See Also Send Feedback

The TenantTypeConstants type exposes the following members.

Fields

Name | Description
Enterprise | Enterprise tenant Under ISV/Reseller
ISV | ISV/Product Admin tenant
OrgUnit | Organization units/barnches/location based tenants can be under SMB/Enterprise
Reseller | Resellet tenant Under ISV only
SMB | Small Medium Business tenant Under ISV/Reseller

See Also

TenantTypeConstants Class
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
TenantTypeConstants Fields
TenantTypeConstants Class See Also Send Feedback

The TenantTypeConstants type exposes the following members.

Fields

Name | Description
Enterprise | Enterprise tenant Under ISV/Reseller
ISV | ISV/Product Admin tenant
OrgUnit | Organization units/barnches/location based tenants can be under SMB/Enterprise
Reseller | Resellet tenant Under ISV only
SMB | Small Medium Business tenant Under ISV/Reseller

See Also

TenantTypeConstants Class
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants.Enterprise Field

[image]

A Sandcastle Documented Class Library
TenantTypeConstants..::..Enterprise Field
TenantTypeConstants Class See Also Send Feedback
Enterprise tenant Under ISV/Reseller

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Enterprise
Visual Basic
Public Const Enterprise As String
Visual C++
public:
literal String^ Enterprise

Field Value

Type: String

See Also

TenantTypeConstants Class
TenantTypeConstants Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants.ISV Field

[image]

A Sandcastle Documented Class Library
TenantTypeConstants..::..ISV Field
TenantTypeConstants Class See Also Send Feedback
ISV/Product Admin tenant

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ISV
Visual Basic
Public Const ISV As String
Visual C++
public:
literal String^ ISV

Field Value

Type: String

See Also

TenantTypeConstants Class
TenantTypeConstants Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants.OrgUnit Field

[image]

A Sandcastle Documented Class Library
TenantTypeConstants..::..OrgUnit Field
TenantTypeConstants Class See Also Send Feedback
Organization units/barnches/location based tenants can be under SMB/Enterprise

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string OrgUnit
Visual Basic
Public Const OrgUnit As String
Visual C++
public:
literal String^ OrgUnit

Field Value

Type: String

See Also

TenantTypeConstants Class
TenantTypeConstants Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants.Reseller Field

[image]

A Sandcastle Documented Class Library
TenantTypeConstants..::..Reseller Field
TenantTypeConstants Class See Also Send Feedback
Resellet tenant Under ISV only

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Reseller
Visual Basic
Public Const Reseller As String
Visual C++
public:
literal String^ Reseller

Field Value

Type: String

See Also

TenantTypeConstants Class
TenantTypeConstants Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeConstants.SMB Field

[image]

A Sandcastle Documented Class Library
TenantTypeConstants..::..SMB Field
TenantTypeConstants Class See Also Send Feedback
Small Medium Business tenant Under ISV/Reseller

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SMB
Visual Basic
Public Const SMB As String
Visual C++
public:
literal String^ SMB

Field Value

Type: String

See Also

TenantTypeConstants Class
TenantTypeConstants Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition Class

[image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition Class
Members See Also Send Feedback
To search the tenant types

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class TenantTypeSearchCondition : SearchCondition
Visual Basic
Public Class TenantTypeSearchCondition
    Inherits SearchCondition
Visual C++
public ref class TenantTypeSearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.TenantManagement..::..TenantTypeSearchCondition

See Also

TenantTypeSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition Members
TenantTypeSearchCondition Class Constructors Methods Properties See Also Send Feedback

The TenantTypeSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TenantTypeSearchCondition | Initializes a new instance of the TenantTypeSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessLevel | search by access level
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | Priority | search by priority
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | TenantId | search by tenant id
Public property | TenantIds | Gets or sets the tenant ids.

See Also

TenantTypeSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition Constructor
TenantTypeSearchCondition Class See Also Send Feedback
Initializes a new instance of the TenantTypeSearchCondition class

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantTypeSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
TenantTypeSearchCondition()

See Also

TenantTypeSearchCondition Class
TenantTypeSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition Methods
TenantTypeSearchCondition Class See Also Send Feedback

The TenantTypeSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TenantTypeSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition Properties
TenantTypeSearchCondition Class See Also Send Feedback

The TenantTypeSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | AccessLevel | search by access level
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | Priority | search by priority
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | TenantId | search by tenant id
Public property | TenantIds | Gets or sets the tenant ids.

See Also

TenantTypeSearchCondition Class
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition.AccessLevel Property

[image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition..::..AccessLevel Property
TenantTypeSearchCondition Class See Also Send Feedback
search by access level

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<short> AccessLevel { get; set; }
Visual Basic
Public Property AccessLevel As Nullable(Of Short)
    Get
    Set
Visual C++
public:
property Nullable<short> AccessLevel {
    Nullable<short> get ();
    void set (Nullable<short> value);
}

Property Value

Type: Nullable<(Of <(<'Int16>)>)>

See Also

TenantTypeSearchCondition Class
TenantTypeSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition.Priority Property

[image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition..::..Priority Property
TenantTypeSearchCondition Class See Also Send Feedback
search by priority

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<short> Priority { get; set; }
Visual Basic
Public Property Priority As Nullable(Of Short)
    Get
    Set
Visual C++
public:
property Nullable<short> Priority {
    Nullable<short> get ();
    void set (Nullable<short> value);
}

Property Value

Type: Nullable<(Of <(<'Int16>)>)>

See Also

TenantTypeSearchCondition Class
TenantTypeSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition..::..TenantId Property
TenantTypeSearchCondition Class See Also Send Feedback
search by tenant id

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TenantTypeSearchCondition Class
TenantTypeSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


TenantTypeSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
TenantTypeSearchCondition..::..TenantIds Property
TenantTypeSearchCondition Class See Also Send Feedback
Gets or sets the tenant ids.

Namespace: CelloSaaS.Model.TenantManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ TenantIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The tenant ids.

See Also

TenantTypeSearchCondition Class
TenantTypeSearchCondition Members
CelloSaaS.Model.TenantManagement Namespace


CelloSaaS.Model.UserManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.UserManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | LinkedTenantUsers | This class contains linked tenant users details
Public class | MembershipDetails | Properties of Membership Details Entity
Public class | PasswordValidationStatus | Use this object for processing the status of the password validation
Public class | TenantUserAssociationConstants | This Class contains TenantUserAssociation Constants
Public class | User | Properties of User Entity
Public class | UserActivity | The UserActivity Model
Public class | UserBulkInsertError | Properties of User Bulk Insert Error
Public class | UserDetails | Properties of User Entity
Public class | UserDetailsSearchCondition | User Details Search condition properties
Public class | UserDetailsSortStringConstants | User Details Sort string constants
Public class | UserPasswordExpiry | User Password Expiry Properties
Public class | UserPasswordExpirySearchCondition | User Password Expiry Search condition properties

Enumerations

 | Enumeration | Description
Public enumeration | RequestStatus | User sharing request status enumeration


LinkedTenantUsers Class

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers Class
Members See Also Send Feedback
This class contains linked tenant users details

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LinkedTenantUsers : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class LinkedTenantUsers
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class LinkedTenantUsers : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.UserManagement..::..LinkedTenantUsers

See Also

LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers Members

[image] [image]

A Sandcastle Documented Class Library
LinkedTenantUsers Members
LinkedTenantUsers Class Constructors Methods Properties See Also Send Feedback

The LinkedTenantUsers type exposes the following members.

Constructors

 | Name | Description
Public method | LinkedTenantUsers | Initializes a new instance of the LinkedTenantUsers class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Comments | Gets or sets the comments.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | RequestedBy | Gets or sets the request by.
Public property | RequestStatus | Gets or sets the request status.
Public property | Status | Gets or sets a value indicating whether this LinkedTenantUsers is status.
Public property | TenantDetails | Gets or sets the tenant details.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | UserDetails | Gets or sets the user details.
Public property | UserId | Gets or sets the user id.

See Also

LinkedTenantUsers Class
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers Constructor

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers Constructor
LinkedTenantUsers Class See Also Send Feedback
Initializes a new instance of the LinkedTenantUsers class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LinkedTenantUsers()
Visual Basic
Public Sub New
Visual C++
public:
LinkedTenantUsers()

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers Methods

[image] [image]

A Sandcastle Documented Class Library
LinkedTenantUsers Methods
LinkedTenantUsers Class See Also Send Feedback

The LinkedTenantUsers type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

LinkedTenantUsers Class
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers Properties

[image] [image]

A Sandcastle Documented Class Library
LinkedTenantUsers Properties
LinkedTenantUsers Class See Also Send Feedback

The LinkedTenantUsers type exposes the following members.

Properties

 | Name | Description
Public property | Comments | Gets or sets the comments.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Id | Gets or sets the id.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | RequestedBy | Gets or sets the request by.
Public property | RequestStatus | Gets or sets the request status.
Public property | Status | Gets or sets a value indicating whether this LinkedTenantUsers is status.
Public property | TenantDetails | Gets or sets the tenant details.
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | UserDetails | Gets or sets the user details.
Public property | UserId | Gets or sets the user id.

See Also

LinkedTenantUsers Class
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.Comments Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..Comments Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the comments.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The comments.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..CreatedBy Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..CreatedOn Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.Id Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..Id Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.RequestedBy Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..RequestedBy Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the request by.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RequestedBy { get; set; }
Visual Basic
Public Property RequestedBy As String
    Get
    Set
Visual C++
public:
property String^ RequestedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The request by.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.RequestStatus Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..RequestStatus Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the request status.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RequestStatus RequestStatus { get; set; }
Visual Basic
Public Property RequestStatus As RequestStatus
    Get
    Set
Visual C++
public:
property RequestStatus RequestStatus {
    RequestStatus get ();
    void set (RequestStatus value);
}

Property Value

Type: RequestStatus
The request status.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.Status Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..Status Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets a value indicating whether this LinkedTenantUsers is status.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.TenantDetails Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..TenantDetails Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the tenant details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantDetails TenantDetails { get; set; }
Visual Basic
Public Property TenantDetails As TenantDetails
    Get
    Set
Visual C++
public:
property TenantDetails^ TenantDetails {
    TenantDetails^ get ();
    void set (TenantDetails^ value);
}

Property Value

Type: TenantDetails
The tenant details.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.TenantId Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..TenantId Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..UpdatedBy Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..UpdatedOn Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.UserDetails Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..UserDetails Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the user details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetails UserDetails { get; set; }
Visual Basic
Public Property UserDetails As UserDetails
    Get
    Set
Visual C++
public:
property UserDetails^ UserDetails {
    UserDetails^ get ();
    void set (UserDetails^ value);
}

Property Value

Type: UserDetails
The user details.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


LinkedTenantUsers.UserId Property

[image]

A Sandcastle Documented Class Library
LinkedTenantUsers..::..UserId Property
LinkedTenantUsers Class See Also Send Feedback
Gets or sets the user id.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user id.

See Also

LinkedTenantUsers Class
LinkedTenantUsers Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails Class

[image]

A Sandcastle Documented Class Library
MembershipDetails Class
Members See Also Send Feedback
Properties of Membership Details Entity

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MembershipDetails : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class MembershipDetails
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class MembershipDetails : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.UserManagement..::..MembershipDetails

See Also

MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails Members

[image] [image]

A Sandcastle Documented Class Library
MembershipDetails Members
MembershipDetails Class Constructors Methods Properties See Also Send Feedback

The MembershipDetails type exposes the following members.

Constructors

 | Name | Description
Public method | MembershipDetails | Initializes a new instance of the MembershipDetails class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Comment | Gets or sets additional text about the user.
Public property | CreationDate | Gets or sets date and time of the user account created.
Public property | EmailId | Gets or sets email id of the user.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | FailedPasswordAnswerAttemptCount | Gets or sets number of consecutive failed password answer attempts of the user.
Public property | FailedPasswordAnswerAttemptWindowStart | Gets or sets Date and time of first failed login if FailedPasswordAnswerAttemptCount is nonzero.
Public property | FailedPasswordAttemptCount | Gets or sets Number of consecutive failed login attempts of the user.
Public property | FailedPasswordAttemptWindowStart | Gets or sets Date and time of first failed login if FailedPasswordAttemptCount is nonzero.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsApproved | Gets or sets user account is approved or not.
Public property | IsFirstTimeUser | Tell whether he is first time login to the system
Public property | IsLockedOut | Gets or sets the user account is locked or not.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | IsUserPasswordChangeForced | Set to true if the password change is forced for this particular user.
Public property | LastActivityDate | Gets or sets date and time of the user activity.
Public property | LastLockedOutDate | Gets or sets date and time of the user was last locked out.
Public property | LastLogonDate | Gets or sets date and time of the user last login.
Public property | LastPasswordChangedDate | Gets or sets date and time of the user password last changed.
Public property | MembershipId | Gets or sets membership id.
Public property | Password | Gets or sets password of the user.
Public property | PasswordAnswer | Gets or sets password answer of the user.
Public property | PasswordQuestion | Gets or sets password question of the user.
Public property | Status | Gets or sets status of the user.
Public property | TenantCode | Gets or sets tenant code of the user.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UserName | Gets or sets user name of the user.

See Also

MembershipDetails Class
CelloSaaS.Model.UserManagement Namespace


MembershipDetails Constructor

[image]

A Sandcastle Documented Class Library
MembershipDetails Constructor
MembershipDetails Class See Also Send Feedback
Initializes a new instance of the MembershipDetails class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MembershipDetails()
Visual Basic
Public Sub New
Visual C++
public:
MembershipDetails()

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails Methods

[image] [image]

A Sandcastle Documented Class Library
MembershipDetails Methods
MembershipDetails Class See Also Send Feedback

The MembershipDetails type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

MembershipDetails Class
CelloSaaS.Model.UserManagement Namespace


MembershipDetails Properties

[image] [image]

A Sandcastle Documented Class Library
MembershipDetails Properties
MembershipDetails Class See Also Send Feedback

The MembershipDetails type exposes the following members.

Properties

 | Name | Description
Public property | Comment | Gets or sets additional text about the user.
Public property | CreationDate | Gets or sets date and time of the user account created.
Public property | EmailId | Gets or sets email id of the user.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | FailedPasswordAnswerAttemptCount | Gets or sets number of consecutive failed password answer attempts of the user.
Public property | FailedPasswordAnswerAttemptWindowStart | Gets or sets Date and time of first failed login if FailedPasswordAnswerAttemptCount is nonzero.
Public property | FailedPasswordAttemptCount | Gets or sets Number of consecutive failed login attempts of the user.
Public property | FailedPasswordAttemptWindowStart | Gets or sets Date and time of first failed login if FailedPasswordAttemptCount is nonzero.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsApproved | Gets or sets user account is approved or not.
Public property | IsFirstTimeUser | Tell whether he is first time login to the system
Public property | IsLockedOut | Gets or sets the user account is locked or not.
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | IsUserPasswordChangeForced | Set to true if the password change is forced for this particular user.
Public property | LastActivityDate | Gets or sets date and time of the user activity.
Public property | LastLockedOutDate | Gets or sets date and time of the user was last locked out.
Public property | LastLogonDate | Gets or sets date and time of the user last login.
Public property | LastPasswordChangedDate | Gets or sets date and time of the user password last changed.
Public property | MembershipId | Gets or sets membership id.
Public property | Password | Gets or sets password of the user.
Public property | PasswordAnswer | Gets or sets password answer of the user.
Public property | PasswordQuestion | Gets or sets password question of the user.
Public property | Status | Gets or sets status of the user.
Public property | TenantCode | Gets or sets tenant code of the user.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UserName | Gets or sets user name of the user.

See Also

MembershipDetails Class
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.Comment Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..Comment Property
MembershipDetails Class See Also Send Feedback
Gets or sets additional text about the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Comment { get; set; }
Visual Basic
Public Property Comment As String
    Get
    Set
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.CreationDate Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..CreationDate Property
MembershipDetails Class See Also Send Feedback
Gets or sets date and time of the user account created.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreationDate { get; set; }
Visual Basic
Public Property CreationDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.EmailId Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..EmailId Property
MembershipDetails Class See Also Send Feedback
Gets or sets email id of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EmailId { get; set; }
Visual Basic
Public Property EmailId As String
    Get
    Set
Visual C++
public:
property String^ EmailId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.FailedPasswordAnswerAttemptCount Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..FailedPasswordAnswerAttemptCount Property
MembershipDetails Class See Also Send Feedback
Gets or sets number of consecutive failed password answer attempts of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int FailedPasswordAnswerAttemptCount { get; set; }
Visual Basic
Public Property FailedPasswordAnswerAttemptCount As Integer
    Get
    Set
Visual C++
public:
property int FailedPasswordAnswerAttemptCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.FailedPasswordAnswerAttemptWindowStart Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..FailedPasswordAnswerAttemptWindowStart Property
MembershipDetails Class See Also Send Feedback
Gets or sets Date and time of first failed login if FailedPasswordAnswerAttemptCount is nonzero.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime FailedPasswordAnswerAttemptWindowStart { get; set; }
Visual Basic
Public Property FailedPasswordAnswerAttemptWindowStart As DateTime
    Get
    Set
Visual C++
public:
property DateTime FailedPasswordAnswerAttemptWindowStart {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.FailedPasswordAttemptCount Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..FailedPasswordAttemptCount Property
MembershipDetails Class See Also Send Feedback
Gets or sets Number of consecutive failed login attempts of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int FailedPasswordAttemptCount { get; set; }
Visual Basic
Public Property FailedPasswordAttemptCount As Integer
    Get
    Set
Visual C++
public:
property int FailedPasswordAttemptCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.FailedPasswordAttemptWindowStart Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..FailedPasswordAttemptWindowStart Property
MembershipDetails Class See Also Send Feedback
Gets or sets Date and time of first failed login if FailedPasswordAttemptCount is nonzero.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime FailedPasswordAttemptWindowStart { get; set; }
Visual Basic
Public Property FailedPasswordAttemptWindowStart As DateTime
    Get
    Set
Visual C++
public:
property DateTime FailedPasswordAttemptWindowStart {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.IsApproved Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..IsApproved Property
MembershipDetails Class See Also Send Feedback
Gets or sets user account is approved or not.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsApproved { get; set; }
Visual Basic
Public Property IsApproved As Boolean
    Get
    Set
Visual C++
public:
property bool IsApproved {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.IsFirstTimeUser Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..IsFirstTimeUser Property
MembershipDetails Class See Also Send Feedback
Tell whether he is first time login to the system

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsFirstTimeUser { get; set; }
Visual Basic
Public Property IsFirstTimeUser As Boolean
    Get
    Set
Visual C++
public:
property bool IsFirstTimeUser {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.IsLockedOut Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..IsLockedOut Property
MembershipDetails Class See Also Send Feedback
Gets or sets the user account is locked or not.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsLockedOut { get; set; }
Visual Basic
Public Property IsLockedOut As Boolean
    Get
    Set
Visual C++
public:
property bool IsLockedOut {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.IsUserPasswordChangeForced Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..IsUserPasswordChangeForced Property
MembershipDetails Class See Also Send Feedback
Set to true if the password change is forced for this particular user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsUserPasswordChangeForced { get; set; }
Visual Basic
Public Property IsUserPasswordChangeForced As Boolean
    Get
    Set
Visual C++
public:
property bool IsUserPasswordChangeForced {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.LastActivityDate Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..LastActivityDate Property
MembershipDetails Class See Also Send Feedback
Gets or sets date and time of the user activity.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime LastActivityDate { get; set; }
Visual Basic
Public Property LastActivityDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastActivityDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.LastLockedOutDate Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..LastLockedOutDate Property
MembershipDetails Class See Also Send Feedback
Gets or sets date and time of the user was last locked out.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime LastLockedOutDate { get; set; }
Visual Basic
Public Property LastLockedOutDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastLockedOutDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.LastLogonDate Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..LastLogonDate Property
MembershipDetails Class See Also Send Feedback
Gets or sets date and time of the user last login.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime LastLogonDate { get; set; }
Visual Basic
Public Property LastLogonDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastLogonDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.LastPasswordChangedDate Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..LastPasswordChangedDate Property
MembershipDetails Class See Also Send Feedback
Gets or sets date and time of the user password last changed.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime LastPasswordChangedDate { get; set; }
Visual Basic
Public Property LastPasswordChangedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime LastPasswordChangedDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.MembershipId Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..MembershipId Property
MembershipDetails Class See Also Send Feedback
Gets or sets membership id.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MembershipId { get; set; }
Visual Basic
Public Property MembershipId As String
    Get
    Set
Visual C++
public:
property String^ MembershipId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.Password Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..Password Property
MembershipDetails Class See Also Send Feedback
Gets or sets password of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.PasswordAnswer Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..PasswordAnswer Property
MembershipDetails Class See Also Send Feedback
Gets or sets password answer of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PasswordAnswer { get; set; }
Visual Basic
Public Property PasswordAnswer As String
    Get
    Set
Visual C++
public:
property String^ PasswordAnswer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.PasswordQuestion Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..PasswordQuestion Property
MembershipDetails Class See Also Send Feedback
Gets or sets password question of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PasswordQuestion { get; set; }
Visual Basic
Public Property PasswordQuestion As String
    Get
    Set
Visual C++
public:
property String^ PasswordQuestion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.Status Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..Status Property
MembershipDetails Class See Also Send Feedback
Gets or sets status of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.TenantCode Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..TenantCode Property
MembershipDetails Class See Also Send Feedback
Gets or sets tenant code of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantCode { get; set; }
Visual Basic
Public Property TenantCode As String
    Get
    Set
Visual C++
public:
property String^ TenantCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


MembershipDetails.UserName Property

[image]

A Sandcastle Documented Class Library
MembershipDetails..::..UserName Property
MembershipDetails Class See Also Send Feedback
Gets or sets user name of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

MembershipDetails Class
MembershipDetails Members
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus Class

[image]

A Sandcastle Documented Class Library
PasswordValidationStatus Class
Members See Also Send Feedback
Use this object for processing the status of the password validation

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PasswordValidationStatus
Visual Basic
<SerializableAttribute>
Public Class PasswordValidationStatus
Visual C++
[SerializableAttribute]
public ref class PasswordValidationStatus

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.UserManagement..::..PasswordValidationStatus

See Also

PasswordValidationStatus Members
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus Members

[image] [image]

A Sandcastle Documented Class Library
PasswordValidationStatus Members
PasswordValidationStatus Class Constructors Methods Properties See Also Send Feedback

The PasswordValidationStatus type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordValidationStatus | Initializes a new instance of the PasswordValidationStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPasswordValid | To set the status of the password validation as true or false. True : If the password is found to be valid False : If the password is found to be Invalid
Public property | Message | The message string to be displayed to the user

See Also

PasswordValidationStatus Class
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus Constructor

[image]

A Sandcastle Documented Class Library
PasswordValidationStatus Constructor
PasswordValidationStatus Class See Also Send Feedback
Initializes a new instance of the PasswordValidationStatus class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PasswordValidationStatus()
Visual Basic
Public Sub New
Visual C++
public:
PasswordValidationStatus()

See Also

PasswordValidationStatus Class
PasswordValidationStatus Members
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus Methods

[image] [image]

A Sandcastle Documented Class Library
PasswordValidationStatus Methods
PasswordValidationStatus Class See Also Send Feedback

The PasswordValidationStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PasswordValidationStatus Class
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus Properties

[image] [image]

A Sandcastle Documented Class Library
PasswordValidationStatus Properties
PasswordValidationStatus Class See Also Send Feedback

The PasswordValidationStatus type exposes the following members.

Properties

 | Name | Description
Public property | IsPasswordValid | To set the status of the password validation as true or false. True : If the password is found to be valid False : If the password is found to be Invalid
Public property | Message | The message string to be displayed to the user

See Also

PasswordValidationStatus Class
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus.IsPasswordValid Property

[image]

A Sandcastle Documented Class Library
PasswordValidationStatus..::..IsPasswordValid Property
PasswordValidationStatus Class See Also Send Feedback
To set the status of the password validation as true or false. True : If the password is found to be valid False : If the password is found to be Invalid

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsPasswordValid { get; set; }
Visual Basic
Public Property IsPasswordValid As Boolean
    Get
    Set
Visual C++
public:
property bool IsPasswordValid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PasswordValidationStatus Class
PasswordValidationStatus Members
CelloSaaS.Model.UserManagement Namespace


PasswordValidationStatus.Message Property

[image]

A Sandcastle Documented Class Library
PasswordValidationStatus..::..Message Property
PasswordValidationStatus Class See Also Send Feedback
The message string to be displayed to the user

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PasswordValidationStatus Class
PasswordValidationStatus Members
CelloSaaS.Model.UserManagement Namespace


RequestStatus Enumeration

[image]

A Sandcastle Documented Class Library
RequestStatus Enumeration
See Also Send Feedback
User sharing request status enumeration

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum RequestStatus
Visual Basic
Public Enumeration RequestStatus
Visual C++
public enum class RequestStatus

Members

Member name | Value | Description
Open | 0 | Open status
WaitingForTenantApproval | 1 | Waiting for tenant approval status
WaitingForUserApproval | 2 | Waiting for user approval status
Approved | 3 | Approved status
Rejected | 4 | Rejected status

See Also

CelloSaaS.Model.UserManagement Namespace


TenantUserAssociationConstants Class

[image]

A Sandcastle Documented Class Library
TenantUserAssociationConstants Class
Members See Also Send Feedback
This Class contains TenantUserAssociation Constants

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantUserAssociationConstants
Visual Basic
Public NotInheritable Class TenantUserAssociationConstants
Visual C++
public ref class TenantUserAssociationConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.UserManagement..::..TenantUserAssociationConstants

See Also

TenantUserAssociationConstants Members
CelloSaaS.Model.UserManagement Namespace


TenantUserAssociationConstants Members

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationConstants Members
TenantUserAssociationConstants Class Fields See Also Send Feedback

The TenantUserAssociationConstants type exposes the following members.

Fields

Name | Description
Admin | Admin
Success | Success
User | User

See Also

TenantUserAssociationConstants Class
CelloSaaS.Model.UserManagement Namespace


TenantUserAssociationConstants Fields

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationConstants Fields
TenantUserAssociationConstants Class See Also Send Feedback

The TenantUserAssociationConstants type exposes the following members.

Fields

Name | Description
Admin | Admin
Success | Success
User | User

See Also

TenantUserAssociationConstants Class
CelloSaaS.Model.UserManagement Namespace


TenantUserAssociationConstants.Admin Field

[image]

A Sandcastle Documented Class Library
TenantUserAssociationConstants..::..Admin Field
TenantUserAssociationConstants Class See Also Send Feedback
Admin

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Admin
Visual Basic
Public Const Admin As String
Visual C++
public:
literal String^ Admin

Field Value

Type: String

See Also

TenantUserAssociationConstants Class
TenantUserAssociationConstants Members
CelloSaaS.Model.UserManagement Namespace


TenantUserAssociationConstants.Success Field

[image]

A Sandcastle Documented Class Library
TenantUserAssociationConstants..::..Success Field
TenantUserAssociationConstants Class See Also Send Feedback
Success

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Success
Visual Basic
Public Const Success As String
Visual C++
public:
literal String^ Success

Field Value

Type: String

See Also

TenantUserAssociationConstants Class
TenantUserAssociationConstants Members
CelloSaaS.Model.UserManagement Namespace


TenantUserAssociationConstants.User Field

[image]

A Sandcastle Documented Class Library
TenantUserAssociationConstants..::..User Field
TenantUserAssociationConstants Class See Also Send Feedback
User

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string User
Visual Basic
Public Const User As String
Visual C++
public:
literal String^ User

Field Value

Type: String

See Also

TenantUserAssociationConstants Class
TenantUserAssociationConstants Members
CelloSaaS.Model.UserManagement Namespace


User Class

[image]

A Sandcastle Documented Class Library
User Class
Members See Also Send Feedback
Properties of User Entity

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class User : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class User
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class User : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.UserManagement..::..User

See Also

User Members
CelloSaaS.Model.UserManagement Namespace


User Members

[image] [image]

A Sandcastle Documented Class Library
User Members
User Class Constructors Methods Properties See Also Send Feedback

The User type exposes the following members.

Constructors

 | Name | Description
Public method | User | Initializes a new instance of the User class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | AddressId | Gets or sets address id of the user.
Public property | CreatedBy | Gets or sets created by id/name of the user.
Public property | CreatedOn | Gets or sets created date of the user.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | FirstName | Gets or sets first name of the user.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LastName | Gets or sets last name of the user.
Public property | MembershipId | Gets or sets id of the user membership.
Public property | Status | Gets or sets status of the user.
Public property | TenantId | Tenant Id
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets last updated by id/name of the user.
Public property | UpdatedOn | Gets or sets last updated date of the user.
Public property | User_Description | A short description of the user
Public property | UserId | Gets or sets id of the user.

See Also

User Class
CelloSaaS.Model.UserManagement Namespace


User Constructor

[image]

A Sandcastle Documented Class Library
User Constructor
User Class See Also Send Feedback
Initializes a new instance of the User class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public User()
Visual Basic
Public Sub New
Visual C++
public:
User()

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User Methods

[image] [image]

A Sandcastle Documented Class Library
User Methods
User Class See Also Send Feedback

The User type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

User Class
CelloSaaS.Model.UserManagement Namespace


User Properties

[image] [image]

A Sandcastle Documented Class Library
User Properties
User Class See Also Send Feedback

The User type exposes the following members.

Properties

 | Name | Description
Public property | AddressId | Gets or sets address id of the user.
Public property | CreatedBy | Gets or sets created by id/name of the user.
Public property | CreatedOn | Gets or sets created date of the user.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | FirstName | Gets or sets first name of the user.
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | LastName | Gets or sets last name of the user.
Public property | MembershipId | Gets or sets id of the user membership.
Public property | Status | Gets or sets status of the user.
Public property | TenantId | Tenant Id
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | Gets or sets last updated by id/name of the user.
Public property | UpdatedOn | Gets or sets last updated date of the user.
Public property | User_Description | A short description of the user
Public property | UserId | Gets or sets id of the user.

See Also

User Class
CelloSaaS.Model.UserManagement Namespace


User.AddressId Property

[image]

A Sandcastle Documented Class Library
User..::..AddressId Property
User Class See Also Send Feedback
Gets or sets address id of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AddressId { get; set; }
Visual Basic
Public Property AddressId As String
    Get
    Set
Visual C++
public:
property String^ AddressId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.CreatedBy Property

[image]

A Sandcastle Documented Class Library
User..::..CreatedBy Property
User Class See Also Send Feedback
Gets or sets created by id/name of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.CreatedOn Property

[image]

A Sandcastle Documented Class Library
User..::..CreatedOn Property
User Class See Also Send Feedback
Gets or sets created date of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.FirstName Property

[image]

A Sandcastle Documented Class Library
User..::..FirstName Property
User Class See Also Send Feedback
Gets or sets first name of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic
Public Property FirstName As String
    Get
    Set
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.LastName Property

[image]

A Sandcastle Documented Class Library
User..::..LastName Property
User Class See Also Send Feedback
Gets or sets last name of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic
Public Property LastName As String
    Get
    Set
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.MembershipId Property

[image]

A Sandcastle Documented Class Library
User..::..MembershipId Property
User Class See Also Send Feedback
Gets or sets id of the user membership.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MembershipId { get; set; }
Visual Basic
Public Property MembershipId As String
    Get
    Set
Visual C++
public:
property String^ MembershipId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.Status Property

[image]

A Sandcastle Documented Class Library
User..::..Status Property
User Class See Also Send Feedback
Gets or sets status of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.TenantId Property

[image]

A Sandcastle Documented Class Library
User..::..TenantId Property
User Class See Also Send Feedback
Tenant Id

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
User..::..UpdatedBy Property
User Class See Also Send Feedback
Gets or sets last updated by id/name of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
User..::..UpdatedOn Property
User Class See Also Send Feedback
Gets or sets last updated date of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.User_Description Property

[image]

A Sandcastle Documented Class Library
User..::..User_Description Property
User Class See Also Send Feedback
A short description of the user

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string User_Description { get; set; }
Visual Basic
Public Property User_Description As String
    Get
    Set
Visual C++
public:
property String^ User_Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


User.UserId Property

[image]

A Sandcastle Documented Class Library
User..::..UserId Property
User Class See Also Send Feedback
Gets or sets id of the user.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

User Class
User Members
CelloSaaS.Model.UserManagement Namespace


UserActivity Class

[image]

A Sandcastle Documented Class Library
UserActivity Class
Members See Also Send Feedback
The UserActivity Model

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserActivity
Visual Basic
<SerializableAttribute>
Public Class UserActivity
Visual C++
[SerializableAttribute]
public ref class UserActivity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.UserManagement..::..UserActivity

See Also

UserActivity Members
CelloSaaS.Model.UserManagement Namespace


UserActivity Members

[image] [image]

A Sandcastle Documented Class Library
UserActivity Members
UserActivity Class Constructors Methods Properties See Also Send Feedback

The UserActivity type exposes the following members.

Constructors

 | Name | Description
Public method | UserActivity | Initializes a new instance of the UserActivity class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityId | Activity Identifier
Public property | ActivityTimeStamp | TimeStamp for the Activity
Public property | UserId | User Identifier

See Also

UserActivity Class
CelloSaaS.Model.UserManagement Namespace


UserActivity Constructor

[image]

A Sandcastle Documented Class Library
UserActivity Constructor
UserActivity Class See Also Send Feedback
Initializes a new instance of the UserActivity class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserActivity()
Visual Basic
Public Sub New
Visual C++
public:
UserActivity()

See Also

UserActivity Class
UserActivity Members
CelloSaaS.Model.UserManagement Namespace


UserActivity Methods

[image] [image]

A Sandcastle Documented Class Library
UserActivity Methods
UserActivity Class See Also Send Feedback

The UserActivity type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserActivity Class
CelloSaaS.Model.UserManagement Namespace


UserActivity Properties

[image] [image]

A Sandcastle Documented Class Library
UserActivity Properties
UserActivity Class See Also Send Feedback

The UserActivity type exposes the following members.

Properties

 | Name | Description
Public property | ActivityId | Activity Identifier
Public property | ActivityTimeStamp | TimeStamp for the Activity
Public property | UserId | User Identifier

See Also

UserActivity Class
CelloSaaS.Model.UserManagement Namespace


UserActivity.ActivityId Property

[image]

A Sandcastle Documented Class Library
UserActivity..::..ActivityId Property
UserActivity Class See Also Send Feedback
Activity Identifier

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivityId { get; set; }
Visual Basic
Public Property ActivityId As String
    Get
    Set
Visual C++
public:
property String^ ActivityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserActivity Class
UserActivity Members
CelloSaaS.Model.UserManagement Namespace


UserActivity.ActivityTimeStamp Property

[image]

A Sandcastle Documented Class Library
UserActivity..::..ActivityTimeStamp Property
UserActivity Class See Also Send Feedback
TimeStamp for the Activity

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ActivityTimeStamp { get; set; }
Visual Basic
Public Property ActivityTimeStamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime ActivityTimeStamp {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserActivity Class
UserActivity Members
CelloSaaS.Model.UserManagement Namespace


UserActivity.UserId Property

[image]

A Sandcastle Documented Class Library
UserActivity..::..UserId Property
UserActivity Class See Also Send Feedback
User Identifier

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserActivity Class
UserActivity Members
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError Class

[image]

A Sandcastle Documented Class Library
UserBulkInsertError Class
Members See Also Send Feedback
Properties of User Bulk Insert Error

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserBulkInsertError
Visual Basic
<SerializableAttribute>
Public Class UserBulkInsertError
Visual C++
[SerializableAttribute]
public ref class UserBulkInsertError

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.UserManagement..::..UserBulkInsertError

See Also

UserBulkInsertError Members
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError Members

[image] [image]

A Sandcastle Documented Class Library
UserBulkInsertError Members
UserBulkInsertError Class Constructors Methods Properties See Also Send Feedback

The UserBulkInsertError type exposes the following members.

Constructors

 | Name | Description
Public method | UserBulkInsertError | Initializes a new instance of the UserBulkInsertError class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorMessage | Gets or sets Error message
Public property | UserDetails | Gets or sets user details

See Also

UserBulkInsertError Class
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError Constructor

[image]

A Sandcastle Documented Class Library
UserBulkInsertError Constructor
UserBulkInsertError Class See Also Send Feedback
Initializes a new instance of the UserBulkInsertError class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserBulkInsertError()
Visual Basic
Public Sub New
Visual C++
public:
UserBulkInsertError()

See Also

UserBulkInsertError Class
UserBulkInsertError Members
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError Methods

[image] [image]

A Sandcastle Documented Class Library
UserBulkInsertError Methods
UserBulkInsertError Class See Also Send Feedback

The UserBulkInsertError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserBulkInsertError Class
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError Properties

[image] [image]

A Sandcastle Documented Class Library
UserBulkInsertError Properties
UserBulkInsertError Class See Also Send Feedback

The UserBulkInsertError type exposes the following members.

Properties

 | Name | Description
Public property | ErrorMessage | Gets or sets Error message
Public property | UserDetails | Gets or sets user details

See Also

UserBulkInsertError Class
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError.ErrorMessage Property

[image]

A Sandcastle Documented Class Library
UserBulkInsertError..::..ErrorMessage Property
UserBulkInsertError Class See Also Send Feedback
Gets or sets Error message

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ErrorMessage { get; set; }
Visual Basic
Public Property ErrorMessage As String
    Get
    Set
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserBulkInsertError Class
UserBulkInsertError Members
CelloSaaS.Model.UserManagement Namespace


UserBulkInsertError.UserDetails Property

[image]

A Sandcastle Documented Class Library
UserBulkInsertError..::..UserDetails Property
UserBulkInsertError Class See Also Send Feedback
Gets or sets user details

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetails UserDetails { get; set; }
Visual Basic
Public Property UserDetails As UserDetails
    Get
    Set
Visual C++
public:
property UserDetails^ UserDetails {
    UserDetails^ get ();
    void set (UserDetails^ value);
}

Property Value

Type: UserDetails

See Also

UserBulkInsertError Class
UserBulkInsertError Members
CelloSaaS.Model.UserManagement Namespace


UserDetails Class

[image]

A Sandcastle Documented Class Library
UserDetails Class
Members See Also Send Feedback
Properties of User Entity

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserDetails : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class UserDetails
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class UserDetails : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.UserManagement..::..UserDetails

See Also

UserDetails Members
CelloSaaS.Model.UserManagement Namespace


UserDetails Members

[image] [image]

A Sandcastle Documented Class Library
UserDetails Members
UserDetails Class Constructors Methods Properties See Also Send Feedback

The UserDetails type exposes the following members.

Constructors

 | Name | Description
Public method | UserDetails()()()() | Gets or sets user details.
Public method | UserDetails(Address, MembershipDetails, User) | Gets or sets user details.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | Address | Gets or sets address details.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MembershipDetails | Gets or sets membership details.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | User | Gets or sets user details.

See Also

UserDetails Class
CelloSaaS.Model.UserManagement Namespace


UserDetails Constructor

[image] [image]

A Sandcastle Documented Class Library
UserDetails Constructor
UserDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserDetails()()()() | Gets or sets user details.
Public method | UserDetails(Address, MembershipDetails, User) | Gets or sets user details.

See Also

UserDetails Class
UserDetails Members
CelloSaaS.Model.UserManagement Namespace


UserDetails Constructor

[image]

A Sandcastle Documented Class Library
UserDetails Constructor
UserDetails Class See Also Send Feedback
Gets or sets user details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetails()
Visual Basic
Public Sub New
Visual C++
public:
UserDetails()

See Also

UserDetails Class
UserDetails Members
UserDetails Overload
CelloSaaS.Model.UserManagement Namespace


UserDetails Constructor (Address, MembershipDetails, User)

[image]

A Sandcastle Documented Class Library
UserDetails Constructor (Address, MembershipDetails, User)
UserDetails Class See Also Send Feedback
Gets or sets user details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetails(
    Address address,
    MembershipDetails membershipDetails,
    User user
)
Visual Basic
Public Sub New (
    address As Address,
    membershipDetails As MembershipDetails,
    user As User
)
Visual C++
public:
UserDetails(
    Address^ address,
    MembershipDetails^ membershipDetails,
    User^ user
)

Parameters

address
Type: CelloSaaS.Model.TenantManagement..::..Address
membershipDetails
Type: CelloSaaS.Model.UserManagement..::..MembershipDetails
user
Type: CelloSaaS.Model.UserManagement..::..User

See Also

UserDetails Class
UserDetails Members
UserDetails Overload
CelloSaaS.Model.UserManagement Namespace


UserDetails Methods

[image] [image]

A Sandcastle Documented Class Library
UserDetails Methods
UserDetails Class See Also Send Feedback

The UserDetails type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

UserDetails Class
CelloSaaS.Model.UserManagement Namespace


UserDetails Properties

[image] [image]

A Sandcastle Documented Class Library
UserDetails Properties
UserDetails Class See Also Send Feedback

The UserDetails type exposes the following members.

Properties

 | Name | Description
Public property | Address | Gets or sets address details.
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MembershipDetails | Gets or sets membership details.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | User | Gets or sets user details.

See Also

UserDetails Class
CelloSaaS.Model.UserManagement Namespace


UserDetails.Address Property

[image]

A Sandcastle Documented Class Library
UserDetails..::..Address Property
UserDetails Class See Also Send Feedback
Gets or sets address details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Address Address { get; set; }
Visual Basic
Public Property Address As Address
    Get
    Set
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}

Property Value

Type: Address

See Also

UserDetails Class
UserDetails Members
CelloSaaS.Model.UserManagement Namespace


UserDetails.MembershipDetails Property

[image]

A Sandcastle Documented Class Library
UserDetails..::..MembershipDetails Property
UserDetails Class See Also Send Feedback
Gets or sets membership details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MembershipDetails MembershipDetails { get; set; }
Visual Basic
Public Property MembershipDetails As MembershipDetails
    Get
    Set
Visual C++
public:
property MembershipDetails^ MembershipDetails {
    MembershipDetails^ get ();
    void set (MembershipDetails^ value);
}

Property Value

Type: MembershipDetails

See Also

UserDetails Class
UserDetails Members
CelloSaaS.Model.UserManagement Namespace


UserDetails.User Property

[image]

A Sandcastle Documented Class Library
UserDetails..::..User Property
UserDetails Class See Also Send Feedback
Gets or sets user details.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public User User { get; set; }
Visual Basic
Public Property User As User
    Get
    Set
Visual C++
public:
property User^ User {
    User^ get ();
    void set (User^ value);
}

Property Value

Type: User

See Also

UserDetails Class
UserDetails Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition Class

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition Class
Members See Also Send Feedback
User Details Search condition properties

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserDetailsSearchCondition : SearchCondition
Visual Basic
<SerializableAttribute>
Public Class UserDetailsSearchCondition
    Inherits SearchCondition
Visual C++
[SerializableAttribute]
public ref class UserDetailsSearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.UserManagement..::..UserDetailsSearchCondition

See Also

UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition Members
UserDetailsSearchCondition Class Constructors Methods Properties See Also Send Feedback

The UserDetailsSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | UserDetailsSearchCondition | Initializes a new instance of the UserDetailsSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressId | Gets or sets Address ID
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | EmailId | Gets or sets Email ID
Public property | IsUserPasswordChangeForced | To query for the user's who have been forced to change their passwords.
Public property | MembershipId | Gets or sets Membership ID
Public property | Password | Gets or sets Password
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SearchValue | Gets or sets Search Value
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | Status | Gets or sets Status
Public property | TenantId | Gets or sets Tenant ID
Public property | UserName | Gets or sets User Name

See Also

UserDetailsSearchCondition Class
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition Constructor
UserDetailsSearchCondition Class See Also Send Feedback
Initializes a new instance of the UserDetailsSearchCondition class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetailsSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
UserDetailsSearchCondition()

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition Methods
UserDetailsSearchCondition Class See Also Send Feedback

The UserDetailsSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserDetailsSearchCondition Class
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition Properties
UserDetailsSearchCondition Class See Also Send Feedback

The UserDetailsSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | AddressId | Gets or sets Address ID
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | EmailId | Gets or sets Email ID
Public property | IsUserPasswordChangeForced | To query for the user's who have been forced to change their passwords.
Public property | MembershipId | Gets or sets Membership ID
Public property | Password | Gets or sets Password
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SearchValue | Gets or sets Search Value
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | Status | Gets or sets Status
Public property | TenantId | Gets or sets Tenant ID
Public property | UserName | Gets or sets User Name

See Also

UserDetailsSearchCondition Class
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.AddressId Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..AddressId Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Address ID

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AddressId { get; set; }
Visual Basic
Public Property AddressId As String
    Get
    Set
Visual C++
public:
property String^ AddressId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.EmailId Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..EmailId Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Email ID

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EmailId { get; set; }
Visual Basic
Public Property EmailId As String
    Get
    Set
Visual C++
public:
property String^ EmailId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.IsUserPasswordChangeForced Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..IsUserPasswordChangeForced Property
UserDetailsSearchCondition Class See Also Send Feedback
To query for the user's who have been forced to change their passwords.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsUserPasswordChangeForced { get; set; }
Visual Basic
Public Property IsUserPasswordChangeForced As Boolean
    Get
    Set
Visual C++
public:
property bool IsUserPasswordChangeForced {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.MembershipId Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..MembershipId Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Membership ID

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MembershipId { get; set; }
Visual Basic
Public Property MembershipId As String
    Get
    Set
Visual C++
public:
property String^ MembershipId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.Password Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..Password Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Password

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.SearchValue Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..SearchValue Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Search Value

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SearchValue { get; set; }
Visual Basic
Public Property SearchValue As String
    Get
    Set
Visual C++
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.Status Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..Status Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Status

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..TenantId Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets Tenant ID

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSearchCondition.UserName Property

[image]

A Sandcastle Documented Class Library
UserDetailsSearchCondition..::..UserName Property
UserDetailsSearchCondition Class See Also Send Feedback
Gets or sets User Name

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserDetailsSearchCondition Class
UserDetailsSearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants Class

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants Class
Members See Also Send Feedback
User Details Sort string constants

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class UserDetailsSortStringConstants
Visual Basic
Public NotInheritable Class UserDetailsSortStringConstants
Visual C++
public ref class UserDetailsSortStringConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.UserManagement..::..UserDetailsSortStringConstants

See Also

UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants Members

[image] [image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants Members
UserDetailsSortStringConstants Class Fields See Also Send Feedback

The UserDetailsSortStringConstants type exposes the following members.

Fields

Name | Description
EmailId | Field - Email ID
FirstName | Field - First Name
IsLocked | Field - Is user account Loced out
LastName | Field - Last Name
UserId | Field - User ID
UserName | Field - User Name

See Also

UserDetailsSortStringConstants Class
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants Fields

[image] [image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants Fields
UserDetailsSortStringConstants Class See Also Send Feedback

The UserDetailsSortStringConstants type exposes the following members.

Fields

Name | Description
EmailId | Field - Email ID
FirstName | Field - First Name
IsLocked | Field - Is user account Loced out
LastName | Field - Last Name
UserId | Field - User ID
UserName | Field - User Name

See Also

UserDetailsSortStringConstants Class
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants.EmailId Field

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants..::..EmailId Field
UserDetailsSortStringConstants Class See Also Send Feedback
Field - Email ID

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EmailId
Visual Basic
Public Const EmailId As String
Visual C++
public:
literal String^ EmailId

Field Value

Type: String

See Also

UserDetailsSortStringConstants Class
UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants.FirstName Field

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants..::..FirstName Field
UserDetailsSortStringConstants Class See Also Send Feedback
Field - First Name

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string FirstName
Visual Basic
Public Const FirstName As String
Visual C++
public:
literal String^ FirstName

Field Value

Type: String

See Also

UserDetailsSortStringConstants Class
UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants.IsLocked Field

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants..::..IsLocked Field
UserDetailsSortStringConstants Class See Also Send Feedback
Field - Is user account Loced out

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string IsLocked
Visual Basic
Public Const IsLocked As String
Visual C++
public:
literal String^ IsLocked

Field Value

Type: String

See Also

UserDetailsSortStringConstants Class
UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants.LastName Field

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants..::..LastName Field
UserDetailsSortStringConstants Class See Also Send Feedback
Field - Last Name

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LastName
Visual Basic
Public Const LastName As String
Visual C++
public:
literal String^ LastName

Field Value

Type: String

See Also

UserDetailsSortStringConstants Class
UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants.UserId Field

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants..::..UserId Field
UserDetailsSortStringConstants Class See Also Send Feedback
Field - User ID

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserId
Visual Basic
Public Const UserId As String
Visual C++
public:
literal String^ UserId

Field Value

Type: String

See Also

UserDetailsSortStringConstants Class
UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserDetailsSortStringConstants.UserName Field

[image]

A Sandcastle Documented Class Library
UserDetailsSortStringConstants..::..UserName Field
UserDetailsSortStringConstants Class See Also Send Feedback
Field - User Name

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserName
Visual Basic
Public Const UserName As String
Visual C++
public:
literal String^ UserName

Field Value

Type: String

See Also

UserDetailsSortStringConstants Class
UserDetailsSortStringConstants Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry Class

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry Class
Members See Also Send Feedback
User Password Expiry Properties

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserPasswordExpiry : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class UserPasswordExpiry
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class UserPasswordExpiry : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.UserManagement..::..UserPasswordExpiry

See Also

UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry Members

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpiry Members
UserPasswordExpiry Class Constructors Methods Properties See Also Send Feedback

The UserPasswordExpiry type exposes the following members.

Constructors

 | Name | Description
Public method | UserPasswordExpiry | Initializes a new instance of the UserPasswordExpiry class

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | CreatedBy | gets or sets the created by userdetails
Public property | CreatedOn | gets or sets the creation date
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExpirationDate | gets or sets the expiration date
Public property | ExpirationId | get or set the expiration id
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsExpired | gets or sets the expiration status
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MembershipId | gets or sets the membership id for expiry
Public property | PasswordChangedDate | gets or sets the password change date
Public property | Status | gets or sets the status of the expiry
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | gets or sets the updated user details
Public property | UpdatedOn | gets or sets the updated on date

See Also

UserPasswordExpiry Class
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry Constructor

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry Constructor
UserPasswordExpiry Class See Also Send Feedback
Initializes a new instance of the UserPasswordExpiry class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserPasswordExpiry()
Visual Basic
Public Sub New
Visual C++
public:
UserPasswordExpiry()

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry Methods

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpiry Methods
UserPasswordExpiry Class See Also Send Feedback

The UserPasswordExpiry type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

UserPasswordExpiry Class
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry Properties

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpiry Properties
UserPasswordExpiry Class See Also Send Feedback

The UserPasswordExpiry type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | gets or sets the created by userdetails
Public property | CreatedOn | gets or sets the creation date
Public property | EntityIdentifier | Gets the entity Identifier (Inherited from BaseEntity.)
Public property | ExpirationDate | gets or sets the expiration date
Public property | ExpirationId | get or set the expiration id
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsExpired | gets or sets the expiration status
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | MembershipId | gets or sets the membership id for expiry
Public property | PasswordChangedDate | gets or sets the password change date
Public property | Status | gets or sets the status of the expiry
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)
Public property | UpdatedBy | gets or sets the updated user details
Public property | UpdatedOn | gets or sets the updated on date

See Also

UserPasswordExpiry Class
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.CreatedBy Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..CreatedBy Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the created by userdetails

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.CreatedOn Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..CreatedOn Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the creation date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.ExpirationDate Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..ExpirationDate Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the expiration date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ExpirationDate { get; set; }
Visual Basic
Public Property ExpirationDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.ExpirationId Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..ExpirationId Property
UserPasswordExpiry Class See Also Send Feedback
get or set the expiration id

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ExpirationId { get; set; }
Visual Basic
Public Property ExpirationId As String
    Get
    Set
Visual C++
public:
property String^ ExpirationId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.IsExpired Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..IsExpired Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the expiration status

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsExpired { get; set; }
Visual Basic
Public Property IsExpired As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.MembershipId Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..MembershipId Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the membership id for expiry

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MembershipId { get; set; }
Visual Basic
Public Property MembershipId As String
    Get
    Set
Visual C++
public:
property String^ MembershipId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.PasswordChangedDate Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..PasswordChangedDate Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the password change date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime PasswordChangedDate { get; set; }
Visual Basic
Public Property PasswordChangedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime PasswordChangedDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.Status Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..Status Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the status of the expiry

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..UpdatedBy Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the updated user details

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpiry.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpiry..::..UpdatedOn Property
UserPasswordExpiry Class See Also Send Feedback
gets or sets the updated on date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpiry Class
UserPasswordExpiry Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition Class

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition Class
Members See Also Send Feedback
User Password Expiry Search condition properties

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserPasswordExpirySearchCondition : SearchCondition
Visual Basic
<SerializableAttribute>
Public Class UserPasswordExpirySearchCondition
    Inherits SearchCondition
Visual C++
[SerializableAttribute]
public ref class UserPasswordExpirySearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.UserManagement..::..UserPasswordExpirySearchCondition

See Also

UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition Members
UserPasswordExpirySearchCondition Class Constructors Methods Properties See Also Send Feedback

The UserPasswordExpirySearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | UserPasswordExpirySearchCondition | Initializes a new instance of the UserPasswordExpirySearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | CreatedOn | Gets or Sets the expiration creation date
Public property | ExpirationStatus | Gets or Sets the User Password Expiration Status
Public property | ExpiryDate | Gets or Sets the password expiration date
Public property | IsPasswordExpired | Gets or Sets the status whether the password has expired or not
Public property | MembershipId | Gets or Sets the membership id associated with the expiry
Public property | PasswordChangeDate | Gets or Sets the last password changed date
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | tenantId | Gets or Sets the tenant Identifier for getting the related settings for the user password expiry.
Public property | UpdatedOn | Gets or Sets the expiration's last updated date

See Also

UserPasswordExpirySearchCondition Class
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition Constructor

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition Constructor
UserPasswordExpirySearchCondition Class See Also Send Feedback
Initializes a new instance of the UserPasswordExpirySearchCondition class

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserPasswordExpirySearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
UserPasswordExpirySearchCondition()

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition Methods
UserPasswordExpirySearchCondition Class See Also Send Feedback

The UserPasswordExpirySearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UserPasswordExpirySearchCondition Class
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition Properties
UserPasswordExpirySearchCondition Class See Also Send Feedback

The UserPasswordExpirySearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | CreatedOn | Gets or Sets the expiration creation date
Public property | ExpirationStatus | Gets or Sets the User Password Expiration Status
Public property | ExpiryDate | Gets or Sets the password expiration date
Public property | IsPasswordExpired | Gets or Sets the status whether the password has expired or not
Public property | MembershipId | Gets or Sets the membership id associated with the expiry
Public property | PasswordChangeDate | Gets or Sets the last password changed date
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | tenantId | Gets or Sets the tenant Identifier for getting the related settings for the user password expiry.
Public property | UpdatedOn | Gets or Sets the expiration's last updated date

See Also

UserPasswordExpirySearchCondition Class
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.CreatedOn Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..CreatedOn Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the expiration creation date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.ExpirationStatus Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..ExpirationStatus Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the User Password Expiration Status

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool ExpirationStatus { get; set; }
Visual Basic
Public Property ExpirationStatus As Boolean
    Get
    Set
Visual C++
public:
property bool ExpirationStatus {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.ExpiryDate Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..ExpiryDate Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the password expiration date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ExpiryDate { get; set; }
Visual Basic
Public Property ExpiryDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime ExpiryDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.IsPasswordExpired Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..IsPasswordExpired Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the status whether the password has expired or not

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsPasswordExpired { get; set; }
Visual Basic
Public Property IsPasswordExpired As Boolean
    Get
    Set
Visual C++
public:
property bool IsPasswordExpired {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.MembershipId Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..MembershipId Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the membership id associated with the expiry

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MembershipId { get; set; }
Visual Basic
Public Property MembershipId As String
    Get
    Set
Visual C++
public:
property String^ MembershipId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.PasswordChangeDate Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..PasswordChangeDate Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the last password changed date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime PasswordChangeDate { get; set; }
Visual Basic
Public Property PasswordChangeDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime PasswordChangeDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.tenantId Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..tenantId Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the tenant Identifier for getting the related settings for the user password expiry.

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string tenantId { get; set; }
Visual Basic
Public Property tenantId As String
    Get
    Set
Visual C++
public:
property String^ tenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


UserPasswordExpirySearchCondition.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
UserPasswordExpirySearchCondition..::..UpdatedOn Property
UserPasswordExpirySearchCondition Class See Also Send Feedback
Gets or Sets the expiration's last updated date

Namespace: CelloSaaS.Model.UserManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

UserPasswordExpirySearchCondition Class
UserPasswordExpirySearchCondition Members
CelloSaaS.Model.UserManagement Namespace


CelloSaaS.Model.ViewManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.ViewManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | CascadePickupListMetaData | Cascade Pickup List Meta Data Properties
Public class | DataView | Data View Propertiees
Public class | DataViewFieldMetaData | Data View Field Meta Data Properties
Public class | DataViewMetaData | Data View Meta Data Properties
Public class | PickupListMetaData | Pickup List Meta Data Properties
Public class | ViewMetaData | View Meta Data Properties

Enumerations

 | Enumeration | Description
Public enumeration | CurrentFormMode | Form Mode Types
Public enumeration | FieldType | Field Types


CascadePickupListMetaData Class

[image]

A Sandcastle Documented Class Library
CascadePickupListMetaData Class
Members See Also Send Feedback
Cascade Pickup List Meta Data Properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CascadePickupListMetaData : PickupListMetaData
Visual Basic
<SerializableAttribute>
Public Class CascadePickupListMetaData
    Inherits PickupListMetaData
Visual C++
[SerializableAttribute]
public ref class CascadePickupListMetaData : public PickupListMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ViewManagement..::..DataViewFieldMetaData
CelloSaaS.Model.ViewManagement..::..PickupListMetaData
CelloSaaS.Model.ViewManagement..::..CascadePickupListMetaData

See Also

CascadePickupListMetaData Members
CelloSaaS.Model.ViewManagement Namespace


CascadePickupListMetaData Members

[image] [image]

A Sandcastle Documented Class Library
CascadePickupListMetaData Members
CascadePickupListMetaData Class Constructors Methods Properties See Also Send Feedback

The CascadePickupListMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | CascadePickupListMetaData | Initializes a new instance of the CascadePickupListMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ControlFieldId | Gets or sets the Parent Field Identifier
Public property | CreatedBy | Gets or sets the name/identifier of user who created this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | CreatedOn | Gets or sets the date time when this Data view field meta data created. (Inherited from DataViewFieldMetaData.)
Public property | Description | Gets or sets the description of field (Inherited from DataViewFieldMetaData.)
Public property | DisplayName | Gets or sets the display name of field (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldIdentifier | Gets or sets the entity field identifier (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldMetaData | Gets or sets the Entity field meta data properties (Inherited from DataViewFieldMetaData.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldID | Gets or sets the field identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldType | Gets or sets the field type (Inherited from DataViewFieldMetaData.)
Public property | GlobalField_FieldID | Gets or sets the field identifier of global field (Inherited from DataViewFieldMetaData.)
Public property | GlobalFieldID | Gets or sets the global field identifier (Inherited from DataViewFieldMetaData.)
Public property | ID | Gets or sets the data view field meta data identifier (Inherited from DataViewFieldMetaData.)
Public property | IsEditable | Gets or sets the editability of field (Inherited from DataViewFieldMetaData.)
Public property | IsExtendedField | Gets or sets whether field is extened field or not. (Inherited from DataViewFieldMetaData.)
Public property | IsFixed | Gets or sets whether field is fixed or not. (Inherited from DataViewFieldMetaData.)
Public property | IsMandatory | Gets or sets the mandatory of field (Inherited from DataViewFieldMetaData.)
Public property | IsMultiLine | Gets or sets the current pickup list has multi select option or not (Inherited from PickupListMetaData.)
Public property | IsVisible | Gets or sets the visibility of field (Inherited from DataViewFieldMetaData.)
Public property | MaxLength | Gets or sets the maximum length of field (Inherited from DataViewFieldMetaData.)
Public property | Ordinal | Gets or sets the ordinal of field in form (Inherited from DataViewFieldMetaData.)
Public property | PickupListId | Gets or sets the pickup list identifeir (Inherited from DataViewFieldMetaData.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from DataViewFieldMetaData.)
Public property | RegularExpression | Gets or sets the regular expression of field (Inherited from DataViewFieldMetaData.)
Public property | RegularExpressionErrorMessage | Gets or sets the reqular expression error message (Inherited from DataViewFieldMetaData.)
Public property | RequiredFieldErrorMessage | Gets or sets the required field error message (Inherited from DataViewFieldMetaData.)
Public property | TenantID | Gets or sets the tenant identifier (Inherited from DataViewFieldMetaData.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | UpdatedOn | Gets or sets the date time when this Data view field meta data recently updated. (Inherited from DataViewFieldMetaData.)
Public property | ViewDataName | Gets or sets the name of the view data. (Inherited from DataViewFieldMetaData.)

See Also

CascadePickupListMetaData Class
CelloSaaS.Model.ViewManagement Namespace


CascadePickupListMetaData Constructor

[image]

A Sandcastle Documented Class Library
CascadePickupListMetaData Constructor
CascadePickupListMetaData Class See Also Send Feedback
Initializes a new instance of the CascadePickupListMetaData class

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CascadePickupListMetaData()
Visual Basic
Public Sub New
Visual C++
public:
CascadePickupListMetaData()

See Also

CascadePickupListMetaData Class
CascadePickupListMetaData Members
CelloSaaS.Model.ViewManagement Namespace


CascadePickupListMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
CascadePickupListMetaData Methods
CascadePickupListMetaData Class See Also Send Feedback

The CascadePickupListMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CascadePickupListMetaData Class
CelloSaaS.Model.ViewManagement Namespace


CascadePickupListMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
CascadePickupListMetaData Properties
CascadePickupListMetaData Class See Also Send Feedback

The CascadePickupListMetaData type exposes the following members.

Properties

 | Name | Description
Public property | ControlFieldId | Gets or sets the Parent Field Identifier
Public property | CreatedBy | Gets or sets the name/identifier of user who created this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | CreatedOn | Gets or sets the date time when this Data view field meta data created. (Inherited from DataViewFieldMetaData.)
Public property | Description | Gets or sets the description of field (Inherited from DataViewFieldMetaData.)
Public property | DisplayName | Gets or sets the display name of field (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldIdentifier | Gets or sets the entity field identifier (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldMetaData | Gets or sets the Entity field meta data properties (Inherited from DataViewFieldMetaData.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldID | Gets or sets the field identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldType | Gets or sets the field type (Inherited from DataViewFieldMetaData.)
Public property | GlobalField_FieldID | Gets or sets the field identifier of global field (Inherited from DataViewFieldMetaData.)
Public property | GlobalFieldID | Gets or sets the global field identifier (Inherited from DataViewFieldMetaData.)
Public property | ID | Gets or sets the data view field meta data identifier (Inherited from DataViewFieldMetaData.)
Public property | IsEditable | Gets or sets the editability of field (Inherited from DataViewFieldMetaData.)
Public property | IsExtendedField | Gets or sets whether field is extened field or not. (Inherited from DataViewFieldMetaData.)
Public property | IsFixed | Gets or sets whether field is fixed or not. (Inherited from DataViewFieldMetaData.)
Public property | IsMandatory | Gets or sets the mandatory of field (Inherited from DataViewFieldMetaData.)
Public property | IsMultiLine | Gets or sets the current pickup list has multi select option or not (Inherited from PickupListMetaData.)
Public property | IsVisible | Gets or sets the visibility of field (Inherited from DataViewFieldMetaData.)
Public property | MaxLength | Gets or sets the maximum length of field (Inherited from DataViewFieldMetaData.)
Public property | Ordinal | Gets or sets the ordinal of field in form (Inherited from DataViewFieldMetaData.)
Public property | PickupListId | Gets or sets the pickup list identifeir (Inherited from DataViewFieldMetaData.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from DataViewFieldMetaData.)
Public property | RegularExpression | Gets or sets the regular expression of field (Inherited from DataViewFieldMetaData.)
Public property | RegularExpressionErrorMessage | Gets or sets the reqular expression error message (Inherited from DataViewFieldMetaData.)
Public property | RequiredFieldErrorMessage | Gets or sets the required field error message (Inherited from DataViewFieldMetaData.)
Public property | TenantID | Gets or sets the tenant identifier (Inherited from DataViewFieldMetaData.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | UpdatedOn | Gets or sets the date time when this Data view field meta data recently updated. (Inherited from DataViewFieldMetaData.)
Public property | ViewDataName | Gets or sets the name of the view data. (Inherited from DataViewFieldMetaData.)

See Also

CascadePickupListMetaData Class
CelloSaaS.Model.ViewManagement Namespace


CascadePickupListMetaData.ControlFieldId Property

[image]

A Sandcastle Documented Class Library
CascadePickupListMetaData..::..ControlFieldId Property
CascadePickupListMetaData Class See Also Send Feedback
Gets or sets the Parent Field Identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ControlFieldId { get; set; }
Visual Basic
Public Property ControlFieldId As String
    Get
    Set
Visual C++
public:
property String^ ControlFieldId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

CascadePickupListMetaData Class
CascadePickupListMetaData Members
CelloSaaS.Model.ViewManagement Namespace


CurrentFormMode Enumeration

[image]

A Sandcastle Documented Class Library
CurrentFormMode Enumeration
See Also Send Feedback
Form Mode Types

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum CurrentFormMode
Visual Basic
Public Enumeration CurrentFormMode
Visual C++
public enum class CurrentFormMode

Members

Member name | Value | Description
View | 0 | View Mode
Edit | 1 | Edit Mode
Insert | 2 | Insert Mode

See Also

CelloSaaS.Model.ViewManagement Namespace


DataView Class

[image]

A Sandcastle Documented Class Library
DataView Class
Members See Also Send Feedback
Data View Propertiees

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataView
Visual Basic
<SerializableAttribute>
Public Class DataView
Visual C++
[SerializableAttribute]
public ref class DataView

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ViewManagement..::..DataView

See Also

DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView Members

[image] [image]

A Sandcastle Documented Class Library
DataView Members
DataView Class Constructors Methods Properties See Also Send Feedback

The DataView type exposes the following members.

Constructors

 | Name | Description
Public method | DataView | Initializes a new instance of the DataView class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataViewID | Gets or sets the Data View Identifier
Public property | Description | Gets or sets the Data View Description
Public property | ID | Gets or sets the Identifier
Public property | MainEntity | Gets or sets the Main Entity of Data View
Public property | Name | Gets or sets the Data View Name
Public property | TenantId | Gets or Sets the tenant id value

See Also

DataView Class
CelloSaaS.Model.ViewManagement Namespace


DataView Constructor

[image]

A Sandcastle Documented Class Library
DataView Constructor
DataView Class See Also Send Feedback
Initializes a new instance of the DataView class

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataView()
Visual Basic
Public Sub New
Visual C++
public:
DataView()

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView Methods

[image] [image]

A Sandcastle Documented Class Library
DataView Methods
DataView Class See Also Send Feedback

The DataView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataView Class
CelloSaaS.Model.ViewManagement Namespace


DataView Properties

[image] [image]

A Sandcastle Documented Class Library
DataView Properties
DataView Class See Also Send Feedback

The DataView type exposes the following members.

Properties

 | Name | Description
Public property | DataViewID | Gets or sets the Data View Identifier
Public property | Description | Gets or sets the Data View Description
Public property | ID | Gets or sets the Identifier
Public property | MainEntity | Gets or sets the Main Entity of Data View
Public property | Name | Gets or sets the Data View Name
Public property | TenantId | Gets or Sets the tenant id value

See Also

DataView Class
CelloSaaS.Model.ViewManagement Namespace


DataView.DataViewID Property

[image]

A Sandcastle Documented Class Library
DataView..::..DataViewID Property
DataView Class See Also Send Feedback
Gets or sets the Data View Identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataViewID { get; set; }
Visual Basic
Public Property DataViewID As String
    Get
    Set
Visual C++
public:
property String^ DataViewID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView.Description Property

[image]

A Sandcastle Documented Class Library
DataView..::..Description Property
DataView Class See Also Send Feedback
Gets or sets the Data View Description

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView.ID Property

[image]

A Sandcastle Documented Class Library
DataView..::..ID Property
DataView Class See Also Send Feedback
Gets or sets the Identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ID { get; set; }
Visual Basic
Public Property ID As Integer
    Get
    Set
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView.MainEntity Property

[image]

A Sandcastle Documented Class Library
DataView..::..MainEntity Property
DataView Class See Also Send Feedback
Gets or sets the Main Entity of Data View

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MainEntity { get; set; }
Visual Basic
Public Property MainEntity As String
    Get
    Set
Visual C++
public:
property String^ MainEntity {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView.Name Property

[image]

A Sandcastle Documented Class Library
DataView..::..Name Property
DataView Class See Also Send Feedback
Gets or sets the Data View Name

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataView.TenantId Property

[image]

A Sandcastle Documented Class Library
DataView..::..TenantId Property
DataView Class See Also Send Feedback
Gets or Sets the tenant id value

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataView Class
DataView Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData Class

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData Class
Members See Also Send Feedback
Data View Field Meta Data Properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataViewFieldMetaData
Visual Basic
<SerializableAttribute>
Public Class DataViewFieldMetaData
Visual C++
[SerializableAttribute]
public ref class DataViewFieldMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ViewManagement..::..DataViewFieldMetaData
CelloSaaS.Model.ViewManagement..::..PickupListMetaData

See Also

DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData Members

[image] [image]

A Sandcastle Documented Class Library
DataViewFieldMetaData Members
DataViewFieldMetaData Class Constructors Methods Properties See Also Send Feedback

The DataViewFieldMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | DataViewFieldMetaData | Initializes a new instance of the DataViewFieldMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/identifier of user who created this Data view field meta data.
Public property | CreatedOn | Gets or sets the date time when this Data view field meta data created.
Public property | Description | Gets or sets the description of field
Public property | DisplayName | Gets or sets the display name of field
Public property | EntityFieldIdentifier | Gets or sets the entity field identifier
Public property | EntityFieldMetaData | Gets or sets the Entity field meta data properties
Public property | EntityIdentifier | Gets or sets the entity identifier
Public property | FieldID | Gets or sets the field identifier
Public property | FieldType | Gets or sets the field type
Public property | GlobalField_FieldID | Gets or sets the field identifier of global field
Public property | GlobalFieldID | Gets or sets the global field identifier
Public property | ID | Gets or sets the data view field meta data identifier
Public property | IsEditable | Gets or sets the editability of field
Public property | IsExtendedField | Gets or sets whether field is extened field or not.
Public property | IsFixed | Gets or sets whether field is fixed or not.
Public property | IsMandatory | Gets or sets the mandatory of field
Public property | IsVisible | Gets or sets the visibility of field
Public property | MaxLength | Gets or sets the maximum length of field
Public property | Ordinal | Gets or sets the ordinal of field in form
Public property | PickupListId | Gets or sets the pickup list identifeir
Public property | PropertyName | Gets or sets the name of the property.
Public property | RegularExpression | Gets or sets the regular expression of field
Public property | RegularExpressionErrorMessage | Gets or sets the reqular expression error message
Public property | RequiredFieldErrorMessage | Gets or sets the required field error message
Public property | TenantID | Gets or sets the tenant identifier
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this Data view field meta data.
Public property | UpdatedOn | Gets or sets the date time when this Data view field meta data recently updated.
Public property | ViewDataName | Gets or sets the name of the view data.

See Also

DataViewFieldMetaData Class
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData Constructor

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData Constructor
DataViewFieldMetaData Class See Also Send Feedback
Initializes a new instance of the DataViewFieldMetaData class

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataViewFieldMetaData()
Visual Basic
Public Sub New
Visual C++
public:
DataViewFieldMetaData()

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
DataViewFieldMetaData Methods
DataViewFieldMetaData Class See Also Send Feedback

The DataViewFieldMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataViewFieldMetaData Class
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
DataViewFieldMetaData Properties
DataViewFieldMetaData Class See Also Send Feedback

The DataViewFieldMetaData type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/identifier of user who created this Data view field meta data.
Public property | CreatedOn | Gets or sets the date time when this Data view field meta data created.
Public property | Description | Gets or sets the description of field
Public property | DisplayName | Gets or sets the display name of field
Public property | EntityFieldIdentifier | Gets or sets the entity field identifier
Public property | EntityFieldMetaData | Gets or sets the Entity field meta data properties
Public property | EntityIdentifier | Gets or sets the entity identifier
Public property | FieldID | Gets or sets the field identifier
Public property | FieldType | Gets or sets the field type
Public property | GlobalField_FieldID | Gets or sets the field identifier of global field
Public property | GlobalFieldID | Gets or sets the global field identifier
Public property | ID | Gets or sets the data view field meta data identifier
Public property | IsEditable | Gets or sets the editability of field
Public property | IsExtendedField | Gets or sets whether field is extened field or not.
Public property | IsFixed | Gets or sets whether field is fixed or not.
Public property | IsMandatory | Gets or sets the mandatory of field
Public property | IsVisible | Gets or sets the visibility of field
Public property | MaxLength | Gets or sets the maximum length of field
Public property | Ordinal | Gets or sets the ordinal of field in form
Public property | PickupListId | Gets or sets the pickup list identifeir
Public property | PropertyName | Gets or sets the name of the property.
Public property | RegularExpression | Gets or sets the regular expression of field
Public property | RegularExpressionErrorMessage | Gets or sets the reqular expression error message
Public property | RequiredFieldErrorMessage | Gets or sets the required field error message
Public property | TenantID | Gets or sets the tenant identifier
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this Data view field meta data.
Public property | UpdatedOn | Gets or sets the date time when this Data view field meta data recently updated.
Public property | ViewDataName | Gets or sets the name of the view data.

See Also

DataViewFieldMetaData Class
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..CreatedBy Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the name/identifier of user who created this Data view field meta data.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..CreatedOn Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the date time when this Data view field meta data created.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.Description Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..Description Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the description of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.DisplayName Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..DisplayName Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the display name of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.EntityFieldIdentifier Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..EntityFieldIdentifier Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the entity field identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityFieldIdentifier { get; set; }
Visual Basic
Public Property EntityFieldIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityFieldIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.EntityFieldMetaData Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..EntityFieldMetaData Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the Entity field meta data properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EntityFieldMetaData EntityFieldMetaData { get; set; }
Visual Basic
Public Property EntityFieldMetaData As EntityFieldMetaData
    Get
    Set
Visual C++
public:
property EntityFieldMetaData^ EntityFieldMetaData {
    EntityFieldMetaData^ get ();
    void set (EntityFieldMetaData^ value);
}

Property Value

Type: EntityFieldMetaData

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..EntityIdentifier Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the entity identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityIdentifier { get; set; }
Visual Basic
Public Property EntityIdentifier As String
    Get
    Set
Visual C++
public:
property String^ EntityIdentifier {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.FieldID Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..FieldID Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the field identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FieldID { get; set; }
Visual Basic
Public Property FieldID As String
    Get
    Set
Visual C++
public:
property String^ FieldID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.FieldType Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..FieldType Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the field type

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldType FieldType { get; set; }
Visual Basic
Public Property FieldType As FieldType
    Get
    Set
Visual C++
public:
property FieldType FieldType {
    FieldType get ();
    void set (FieldType value);
}

Property Value

Type: FieldType

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.GlobalField_FieldID Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..GlobalField_FieldID Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the field identifier of global field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string GlobalField_FieldID { get; set; }
Visual Basic
Public Property GlobalField_FieldID As String
    Get
    Set
Visual C++
public:
property String^ GlobalField_FieldID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.GlobalFieldID Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..GlobalFieldID Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the global field identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int GlobalFieldID { get; set; }
Visual Basic
Public Property GlobalFieldID As Integer
    Get
    Set
Visual C++
public:
property int GlobalFieldID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.ID Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..ID Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the data view field meta data identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ID { get; set; }
Visual Basic
Public Property ID As Integer
    Get
    Set
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.IsEditable Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..IsEditable Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the editability of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic
Public Property IsEditable As Boolean
    Get
    Set
Visual C++
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.IsExtendedField Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..IsExtendedField Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets whether field is extened field or not.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsExtendedField { get; set; }
Visual Basic
Public Property IsExtendedField As Boolean
    Get
    Set
Visual C++
public:
property bool IsExtendedField {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.IsFixed Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..IsFixed Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets whether field is fixed or not.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsFixed { get; set; }
Visual Basic
Public Property IsFixed As Boolean
    Get
    Set
Visual C++
public:
property bool IsFixed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.IsMandatory Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..IsMandatory Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the mandatory of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsMandatory { get; set; }
Visual Basic
Public Property IsMandatory As Boolean
    Get
    Set
Visual C++
public:
property bool IsMandatory {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.IsVisible Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..IsVisible Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the visibility of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.MaxLength Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..MaxLength Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the maximum length of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.Ordinal Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..Ordinal Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the ordinal of field in form

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Ordinal { get; set; }
Visual Basic
Public Property Ordinal As Integer
    Get
    Set
Visual C++
public:
property int Ordinal {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.PickupListId Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..PickupListId Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the pickup list identifeir

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PickupListId { get; set; }
Visual Basic
Public Property PickupListId As String
    Get
    Set
Visual C++
public:
property String^ PickupListId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.PropertyName Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..PropertyName Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the name of the property.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the property.

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.RegularExpression Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..RegularExpression Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the regular expression of field

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RegularExpression { get; set; }
Visual Basic
Public Property RegularExpression As String
    Get
    Set
Visual C++
public:
property String^ RegularExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.RegularExpressionErrorMessage Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..RegularExpressionErrorMessage Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the reqular expression error message

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RegularExpressionErrorMessage { get; set; }
Visual Basic
Public Property RegularExpressionErrorMessage As String
    Get
    Set
Visual C++
public:
property String^ RegularExpressionErrorMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.RequiredFieldErrorMessage Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..RequiredFieldErrorMessage Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the required field error message

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RequiredFieldErrorMessage { get; set; }
Visual Basic
Public Property RequiredFieldErrorMessage As String
    Get
    Set
Visual C++
public:
property String^ RequiredFieldErrorMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.TenantID Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..TenantID Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the tenant identifier

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantID { get; set; }
Visual Basic
Public Property TenantID As String
    Get
    Set
Visual C++
public:
property String^ TenantID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..UpdatedBy Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the name/id of user who recently updated this Data view field meta data.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..UpdatedOn Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the date time when this Data view field meta data recently updated.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewFieldMetaData.ViewDataName Property

[image]

A Sandcastle Documented Class Library
DataViewFieldMetaData..::..ViewDataName Property
DataViewFieldMetaData Class See Also Send Feedback
Gets or sets the name of the view data.

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ViewDataName { get; set; }
Visual Basic
Public Property ViewDataName As String
    Get
    Set
Visual C++
public:
property String^ ViewDataName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the view data.

See Also

DataViewFieldMetaData Class
DataViewFieldMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData Class

[image]

A Sandcastle Documented Class Library
DataViewMetaData Class
Members See Also Send Feedback
Data View Meta Data Properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataViewMetaData
Visual Basic
<SerializableAttribute>
Public Class DataViewMetaData
Visual C++
[SerializableAttribute]
public ref class DataViewMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ViewManagement..::..DataViewMetaData

See Also

DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData Members

[image] [image]

A Sandcastle Documented Class Library
DataViewMetaData Members
DataViewMetaData Class Constructors Methods Properties See Also Send Feedback

The DataViewMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | DataViewMetaData | Initializes a new instance of the DataViewMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AvailableFields | Gets or sets the available fields
Public property | DataView | Gets or sets the Data view properties
Public property | DataViewName | Gets or sets the Data View Name
Public property | Features | Gets or sets the features this dataview belongs
Public property | TenantId | Gets or sets the tenant id

See Also

DataViewMetaData Class
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData Constructor

[image]

A Sandcastle Documented Class Library
DataViewMetaData Constructor
DataViewMetaData Class See Also Send Feedback
Initializes a new instance of the DataViewMetaData class

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataViewMetaData()
Visual Basic
Public Sub New
Visual C++
public:
DataViewMetaData()

See Also

DataViewMetaData Class
DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
DataViewMetaData Methods
DataViewMetaData Class See Also Send Feedback

The DataViewMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataViewMetaData Class
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
DataViewMetaData Properties
DataViewMetaData Class See Also Send Feedback

The DataViewMetaData type exposes the following members.

Properties

 | Name | Description
Public property | AvailableFields | Gets or sets the available fields
Public property | DataView | Gets or sets the Data view properties
Public property | DataViewName | Gets or sets the Data View Name
Public property | Features | Gets or sets the features this dataview belongs
Public property | TenantId | Gets or sets the tenant id

See Also

DataViewMetaData Class
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData.AvailableFields Property

[image]

A Sandcastle Documented Class Library
DataViewMetaData..::..AvailableFields Property
DataViewMetaData Class See Also Send Feedback
Gets or sets the available fields

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, DataViewFieldMetaData> AvailableFields { get; set; }
Visual Basic
Public Property AvailableFields As Dictionary(Of String, DataViewFieldMetaData)
    Get
    Set
Visual C++
public:
property Dictionary<String^, DataViewFieldMetaData^>^ AvailableFields {
    Dictionary<String^, DataViewFieldMetaData^>^ get ();
    void set (Dictionary<String^, DataViewFieldMetaData^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, DataViewFieldMetaData >)>)>

See Also

DataViewMetaData Class
DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData.DataView Property

[image]

A Sandcastle Documented Class Library
DataViewMetaData..::..DataView Property
DataViewMetaData Class See Also Send Feedback
Gets or sets the Data view properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataView DataView { get; set; }
Visual Basic
Public Property DataView As DataView
    Get
    Set
Visual C++
public:
property DataView^ DataView {
    DataView^ get ();
    void set (DataView^ value);
}

Property Value

Type: DataView

See Also

DataViewMetaData Class
DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData.DataViewName Property

[image]

A Sandcastle Documented Class Library
DataViewMetaData..::..DataViewName Property
DataViewMetaData Class See Also Send Feedback
Gets or sets the Data View Name

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataViewName { get; set; }
Visual Basic
Public Property DataViewName As String
    Get
    Set
Visual C++
public:
property String^ DataViewName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewMetaData Class
DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData.Features Property

[image]

A Sandcastle Documented Class Library
DataViewMetaData..::..Features Property
DataViewMetaData Class See Also Send Feedback
Gets or sets the features this dataview belongs

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IList<string> Features { get; set; }
Visual Basic
Public Property Features As IList(Of String)
    Get
    Set
Visual C++
public:
property IList<String^>^ Features {
    IList<String^>^ get ();
    void set (IList<String^>^ value);
}

Property Value

Type: IList<(Of <(<'String>)>)>

See Also

DataViewMetaData Class
DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


DataViewMetaData.TenantId Property

[image]

A Sandcastle Documented Class Library
DataViewMetaData..::..TenantId Property
DataViewMetaData Class See Also Send Feedback
Gets or sets the tenant id

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataViewMetaData Class
DataViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


FieldType Enumeration

[image]

A Sandcastle Documented Class Library
FieldType Enumeration
See Also Send Feedback
Field Types

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum FieldType
Visual Basic
Public Enumeration FieldType
Visual C++
public enum class FieldType

Members

Member name | Value | Description
None | 0 | None
TextBox | 1 | Textbox Type
CheckBox | 2 | Checkbox Type
Calendar | 3 | Calender Type
TextArea | 4 | Test Area Type
Label | 5 | Label Type
DropdownList | 6 | Dropdown list type
RadioButton | 7 | Radio Button Type
CascadeDropDownList | 8 | Cascade Dropdown List Type
MultiSelect | 9 | Multi Select Type

See Also

CelloSaaS.Model.ViewManagement Namespace


PickupListMetaData Class

[image]

A Sandcastle Documented Class Library
PickupListMetaData Class
Members See Also Send Feedback
Pickup List Meta Data Properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListMetaData : DataViewFieldMetaData
Visual Basic
<SerializableAttribute>
Public Class PickupListMetaData
    Inherits DataViewFieldMetaData
Visual C++
[SerializableAttribute]
public ref class PickupListMetaData : public DataViewFieldMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ViewManagement..::..DataViewFieldMetaData
CelloSaaS.Model.ViewManagement..::..PickupListMetaData
CelloSaaS.Model.ViewManagement..::..CascadePickupListMetaData

See Also

PickupListMetaData Members
CelloSaaS.Model.ViewManagement Namespace


PickupListMetaData Members

[image] [image]

A Sandcastle Documented Class Library
PickupListMetaData Members
PickupListMetaData Class Constructors Methods Properties See Also Send Feedback

The PickupListMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListMetaData | Initializes a new instance of the PickupListMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/identifier of user who created this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | CreatedOn | Gets or sets the date time when this Data view field meta data created. (Inherited from DataViewFieldMetaData.)
Public property | Description | Gets or sets the description of field (Inherited from DataViewFieldMetaData.)
Public property | DisplayName | Gets or sets the display name of field (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldIdentifier | Gets or sets the entity field identifier (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldMetaData | Gets or sets the Entity field meta data properties (Inherited from DataViewFieldMetaData.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldID | Gets or sets the field identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldType | Gets or sets the field type (Inherited from DataViewFieldMetaData.)
Public property | GlobalField_FieldID | Gets or sets the field identifier of global field (Inherited from DataViewFieldMetaData.)
Public property | GlobalFieldID | Gets or sets the global field identifier (Inherited from DataViewFieldMetaData.)
Public property | ID | Gets or sets the data view field meta data identifier (Inherited from DataViewFieldMetaData.)
Public property | IsEditable | Gets or sets the editability of field (Inherited from DataViewFieldMetaData.)
Public property | IsExtendedField | Gets or sets whether field is extened field or not. (Inherited from DataViewFieldMetaData.)
Public property | IsFixed | Gets or sets whether field is fixed or not. (Inherited from DataViewFieldMetaData.)
Public property | IsMandatory | Gets or sets the mandatory of field (Inherited from DataViewFieldMetaData.)
Public property | IsMultiLine | Gets or sets the current pickup list has multi select option or not
Public property | IsVisible | Gets or sets the visibility of field (Inherited from DataViewFieldMetaData.)
Public property | MaxLength | Gets or sets the maximum length of field (Inherited from DataViewFieldMetaData.)
Public property | Ordinal | Gets or sets the ordinal of field in form (Inherited from DataViewFieldMetaData.)
Public property | PickupListId | Gets or sets the pickup list identifeir (Inherited from DataViewFieldMetaData.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from DataViewFieldMetaData.)
Public property | RegularExpression | Gets or sets the regular expression of field (Inherited from DataViewFieldMetaData.)
Public property | RegularExpressionErrorMessage | Gets or sets the reqular expression error message (Inherited from DataViewFieldMetaData.)
Public property | RequiredFieldErrorMessage | Gets or sets the required field error message (Inherited from DataViewFieldMetaData.)
Public property | TenantID | Gets or sets the tenant identifier (Inherited from DataViewFieldMetaData.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | UpdatedOn | Gets or sets the date time when this Data view field meta data recently updated. (Inherited from DataViewFieldMetaData.)
Public property | ViewDataName | Gets or sets the name of the view data. (Inherited from DataViewFieldMetaData.)

See Also

PickupListMetaData Class
CelloSaaS.Model.ViewManagement Namespace


PickupListMetaData Constructor

[image]

A Sandcastle Documented Class Library
PickupListMetaData Constructor
PickupListMetaData Class See Also Send Feedback
Initializes a new instance of the PickupListMetaData class

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListMetaData()
Visual Basic
Public Sub New
Visual C++
public:
PickupListMetaData()

See Also

PickupListMetaData Class
PickupListMetaData Members
CelloSaaS.Model.ViewManagement Namespace


PickupListMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListMetaData Methods
PickupListMetaData Class See Also Send Feedback

The PickupListMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PickupListMetaData Class
CelloSaaS.Model.ViewManagement Namespace


PickupListMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListMetaData Properties
PickupListMetaData Class See Also Send Feedback

The PickupListMetaData type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the name/identifier of user who created this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | CreatedOn | Gets or sets the date time when this Data view field meta data created. (Inherited from DataViewFieldMetaData.)
Public property | Description | Gets or sets the description of field (Inherited from DataViewFieldMetaData.)
Public property | DisplayName | Gets or sets the display name of field (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldIdentifier | Gets or sets the entity field identifier (Inherited from DataViewFieldMetaData.)
Public property | EntityFieldMetaData | Gets or sets the Entity field meta data properties (Inherited from DataViewFieldMetaData.)
Public property | EntityIdentifier | Gets or sets the entity identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldID | Gets or sets the field identifier (Inherited from DataViewFieldMetaData.)
Public property | FieldType | Gets or sets the field type (Inherited from DataViewFieldMetaData.)
Public property | GlobalField_FieldID | Gets or sets the field identifier of global field (Inherited from DataViewFieldMetaData.)
Public property | GlobalFieldID | Gets or sets the global field identifier (Inherited from DataViewFieldMetaData.)
Public property | ID | Gets or sets the data view field meta data identifier (Inherited from DataViewFieldMetaData.)
Public property | IsEditable | Gets or sets the editability of field (Inherited from DataViewFieldMetaData.)
Public property | IsExtendedField | Gets or sets whether field is extened field or not. (Inherited from DataViewFieldMetaData.)
Public property | IsFixed | Gets or sets whether field is fixed or not. (Inherited from DataViewFieldMetaData.)
Public property | IsMandatory | Gets or sets the mandatory of field (Inherited from DataViewFieldMetaData.)
Public property | IsMultiLine | Gets or sets the current pickup list has multi select option or not
Public property | IsVisible | Gets or sets the visibility of field (Inherited from DataViewFieldMetaData.)
Public property | MaxLength | Gets or sets the maximum length of field (Inherited from DataViewFieldMetaData.)
Public property | Ordinal | Gets or sets the ordinal of field in form (Inherited from DataViewFieldMetaData.)
Public property | PickupListId | Gets or sets the pickup list identifeir (Inherited from DataViewFieldMetaData.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from DataViewFieldMetaData.)
Public property | RegularExpression | Gets or sets the regular expression of field (Inherited from DataViewFieldMetaData.)
Public property | RegularExpressionErrorMessage | Gets or sets the reqular expression error message (Inherited from DataViewFieldMetaData.)
Public property | RequiredFieldErrorMessage | Gets or sets the required field error message (Inherited from DataViewFieldMetaData.)
Public property | TenantID | Gets or sets the tenant identifier (Inherited from DataViewFieldMetaData.)
Public property | UpdatedBy | Gets or sets the name/id of user who recently updated this Data view field meta data. (Inherited from DataViewFieldMetaData.)
Public property | UpdatedOn | Gets or sets the date time when this Data view field meta data recently updated. (Inherited from DataViewFieldMetaData.)
Public property | ViewDataName | Gets or sets the name of the view data. (Inherited from DataViewFieldMetaData.)

See Also

PickupListMetaData Class
CelloSaaS.Model.ViewManagement Namespace


PickupListMetaData.IsMultiLine Property

[image]

A Sandcastle Documented Class Library
PickupListMetaData..::..IsMultiLine Property
PickupListMetaData Class See Also Send Feedback
Gets or sets the current pickup list has multi select option or not

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsMultiLine { get; set; }
Visual Basic
Public Property IsMultiLine As Boolean
    Get
    Set
Visual C++
public:
property bool IsMultiLine {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PickupListMetaData Class
PickupListMetaData Members
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData Class

[image]

A Sandcastle Documented Class Library
ViewMetaData Class
Members See Also Send Feedback
View Meta Data Properties

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ViewMetaData
Visual Basic
<SerializableAttribute>
Public Class ViewMetaData
Visual C++
[SerializableAttribute]
public ref class ViewMetaData

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.ViewManagement..::..ViewMetaData

See Also

ViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData Members

[image] [image]

A Sandcastle Documented Class Library
ViewMetaData Members
ViewMetaData Class Constructors Methods Properties See Also Send Feedback

The ViewMetaData type exposes the following members.

Constructors

 | Name | Description
Public method | ViewMetaData | Initializes a new instance of the ViewMetaData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Logo | Gets or sets the Logo of Tenant
Public property | TenantId | Gets or sets the Tenant Identifier of View Meta Data
Public property | Theme | Gets or sets the Theme of the Tenant

See Also

ViewMetaData Class
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData Constructor

[image]

A Sandcastle Documented Class Library
ViewMetaData Constructor
ViewMetaData Class See Also Send Feedback
Initializes a new instance of the ViewMetaData class

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ViewMetaData()
Visual Basic
Public Sub New
Visual C++
public:
ViewMetaData()

See Also

ViewMetaData Class
ViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData Methods

[image] [image]

A Sandcastle Documented Class Library
ViewMetaData Methods
ViewMetaData Class See Also Send Feedback

The ViewMetaData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewMetaData Class
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData Properties

[image] [image]

A Sandcastle Documented Class Library
ViewMetaData Properties
ViewMetaData Class See Also Send Feedback

The ViewMetaData type exposes the following members.

Properties

 | Name | Description
Public property | Logo | Gets or sets the Logo of Tenant
Public property | TenantId | Gets or sets the Tenant Identifier of View Meta Data
Public property | Theme | Gets or sets the Theme of the Tenant

See Also

ViewMetaData Class
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData.Logo Property

[image]

A Sandcastle Documented Class Library
ViewMetaData..::..Logo Property
ViewMetaData Class See Also Send Feedback
Gets or sets the Logo of Tenant

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Logo { get; set; }
Visual Basic
Public Property Logo As String
    Get
    Set
Visual C++
public:
property String^ Logo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ViewMetaData Class
ViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData.TenantId Property

[image]

A Sandcastle Documented Class Library
ViewMetaData..::..TenantId Property
ViewMetaData Class See Also Send Feedback
Gets or sets the Tenant Identifier of View Meta Data

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ViewMetaData Class
ViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


ViewMetaData.Theme Property

[image]

A Sandcastle Documented Class Library
ViewMetaData..::..Theme Property
ViewMetaData Class See Also Send Feedback
Gets or sets the Theme of the Tenant

Namespace: CelloSaaS.Model.ViewManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Theme { get; set; }
Visual Basic
Public Property Theme As String
    Get
    Set
Visual C++
public:
property String^ Theme {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ViewMetaData Class
ViewMetaData Members
CelloSaaS.Model.ViewManagement Namespace


CelloSaaS.Model.VirtualEntityManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Model.VirtualEntityManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | VirtualEntity | The virtual entity class that inherits Base entity class
Public class | VirtualEntitySearchCondition | The VirtualEntitySearchCondition class that inherits search condition which contains properties for searching virtual entity
Public class | VirtualEntitySearchResult | The VirtualEntitySearchResult class that contains properties for searching virtual entity


VirtualEntity Class

[image]

A Sandcastle Documented Class Library
VirtualEntity Class
Members See Also Send Feedback
The virtual entity class that inherits Base entity class

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class VirtualEntity : BaseEntity
Visual Basic
<SerializableAttribute>
Public Class VirtualEntity
    Inherits BaseEntity
Visual C++
[SerializableAttribute]
public ref class VirtualEntity : public BaseEntity

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..BaseEntity
CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntity

See Also

VirtualEntity Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntity Members

[image] [image]

A Sandcastle Documented Class Library
VirtualEntity Members
VirtualEntity Class Constructors Methods Properties See Also Send Feedback

The VirtualEntity type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualEntity | Initializes a new instance of the VirtualEntity class.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Overrides BaseEntity..::..EntityIdentifier.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

VirtualEntity Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntity Constructor

[image]

A Sandcastle Documented Class Library
VirtualEntity Constructor
VirtualEntity Class See Also Send Feedback
Initializes a new instance of the VirtualEntity class.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public VirtualEntity(
    string entityIdentifier
)
Visual Basic
Public Sub New (
    entityIdentifier As String
)
Visual C++
public:
VirtualEntity(
    String^ entityIdentifier
)

Parameters

entityIdentifier
Type: System..::..String
The entity identifier.

See Also

VirtualEntity Class
VirtualEntity Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntity Methods

[image] [image]

A Sandcastle Documented Class Library
VirtualEntity Methods
VirtualEntity Class See Also Send Feedback

The VirtualEntity type exposes the following members.

Methods

 | Name | Description
Public method | ApplyChanges | This method is used to apply changes in the entity (Inherited from BaseEntity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | This mehod is used to get changes done in entity (Inherited from BaseEntity.)
Public method | GetDeletedChanges | This method is used to get delete values in the entity (Inherited from BaseEntity.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrackChanges | This is used to track changes in the entity (Inherited from BaseEntity.)

See Also

VirtualEntity Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntity Properties

[image] [image]

A Sandcastle Documented Class Library
VirtualEntity Properties
VirtualEntity Class See Also Send Feedback

The VirtualEntity type exposes the following members.

Properties

 | Name | Description
Public property | EntityIdentifier | Gets the entity Identifier (Overrides BaseEntity..::..EntityIdentifier.)
Public property | ExtendedRow | Gets or sets the extended entity row properties (Inherited from BaseEntity.)
Public property | Identifier | Gets or sets the Entity Identifier (Inherited from BaseEntity.)
Public property | IsTrackingOn | Gets or sets whether entity has trackability or not. (Inherited from BaseEntity.)
Public property | TenantId | Gets or sets the tenant id.
Public property | TrackingAdapter | Gets or sets tracking adapter property (Inherited from BaseEntity.)

See Also

VirtualEntity Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntity.EntityIdentifier Property

[image]

A Sandcastle Documented Class Library
VirtualEntity..::..EntityIdentifier Property
VirtualEntity Class See Also Send Feedback
Gets the entity Identifier

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string EntityIdentifier { get; protected set; }
Visual Basic
Public Overrides Property EntityIdentifier As String
    Get
    Protected Set
Visual C++
public:
virtual property String^ EntityIdentifier {
    String^ get () override;
    protected: void set (String^ value) override;
}

Property Value

Type: String
The entity identifier.

See Also

VirtualEntity Class
VirtualEntity Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntity.TenantId Property

[image]

A Sandcastle Documented Class Library
VirtualEntity..::..TenantId Property
VirtualEntity Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

VirtualEntity Class
VirtualEntity Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition Class

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition Class
Members See Also Send Feedback
The VirtualEntitySearchCondition class that inherits search condition which contains properties for searching virtual entity

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class VirtualEntitySearchCondition : SearchCondition
Visual Basic
<SerializableAttribute>
Public Class VirtualEntitySearchCondition
    Inherits SearchCondition
Visual C++
[SerializableAttribute]
public ref class VirtualEntitySearchCondition : public SearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model..::..SearchCondition
CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntitySearchCondition

See Also

VirtualEntitySearchCondition Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition Members
VirtualEntitySearchCondition Class Constructors Methods Properties See Also Send Feedback

The VirtualEntitySearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualEntitySearchCondition | Initializes a new instance of the VirtualEntitySearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | EntityId | Gets or sets the entity id.
Public property | ExtendedFieldsSearchCondition | Gets or sets the extended fields search condition.
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | ReferenceId | Gets or sets the reference id.
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | TenantId | Gets or sets the tenant id.

See Also

VirtualEntitySearchCondition Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition Constructor

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition Constructor
VirtualEntitySearchCondition Class See Also Send Feedback
Initializes a new instance of the VirtualEntitySearchCondition class

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public VirtualEntitySearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
VirtualEntitySearchCondition()

See Also

VirtualEntitySearchCondition Class
VirtualEntitySearchCondition Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition Methods
VirtualEntitySearchCondition Class See Also Send Feedback

The VirtualEntitySearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VirtualEntitySearchCondition Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition Properties
VirtualEntitySearchCondition Class See Also Send Feedback

The VirtualEntitySearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Condition (Inherited from SearchCondition.)
Public property | EntityId | Gets or sets the entity id.
Public property | ExtendedFieldsSearchCondition | Gets or sets the extended fields search condition.
Public property | RecordEnd | Ending record number (Inherited from SearchCondition.)
Public property | RecordStart | Starting record number (Inherited from SearchCondition.)
Public property | ReferenceId | Gets or sets the reference id.
Public property | SearchStringList | Search string list (Inherited from SearchCondition.)
Public property | SetTotalCount | Set total count - Whether need to set total count or not. (Inherited from SearchCondition.)
Public property | SortExpression | Sorting order (Inherited from SearchCondition.)
Public property | SortString | Sort string (Inherited from SearchCondition.)
Public property | TenantId | Gets or sets the tenant id.

See Also

VirtualEntitySearchCondition Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition.EntityId Property

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition..::..EntityId Property
VirtualEntitySearchCondition Class See Also Send Feedback
Gets or sets the entity id.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string EntityId { get; set; }
Visual Basic
Public Property EntityId As String
    Get
    Set
Visual C++
public:
property String^ EntityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The entity id.

See Also

VirtualEntitySearchCondition Class
VirtualEntitySearchCondition Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition.ExtendedFieldsSearchCondition Property

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition..::..ExtendedFieldsSearchCondition Property
VirtualEntitySearchCondition Class See Also Send Feedback
Gets or sets the extended fields search condition.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExtendedFieldsSearchCondition ExtendedFieldsSearchCondition { get; set; }
Visual Basic
Public Property ExtendedFieldsSearchCondition As ExtendedFieldsSearchCondition
    Get
    Set
Visual C++
public:
property ExtendedFieldsSearchCondition^ ExtendedFieldsSearchCondition {
    ExtendedFieldsSearchCondition^ get ();
    void set (ExtendedFieldsSearchCondition^ value);
}

Property Value

Type: ExtendedFieldsSearchCondition
The extended fields search condition.

See Also

VirtualEntitySearchCondition Class
VirtualEntitySearchCondition Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition.ReferenceId Property

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition..::..ReferenceId Property
VirtualEntitySearchCondition Class See Also Send Feedback
Gets or sets the reference id.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] ReferenceId { get; set; }
Visual Basic
Public Property ReferenceId As String()
    Get
    Set
Visual C++
public:
property array<String^>^ ReferenceId {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The reference id.

See Also

VirtualEntitySearchCondition Class
VirtualEntitySearchCondition Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchCondition..::..TenantId Property
VirtualEntitySearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

VirtualEntitySearchCondition Class
VirtualEntitySearchCondition Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult Class

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult Class
Members See Also Send Feedback
The VirtualEntitySearchResult class that contains properties for searching virtual entity

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class VirtualEntitySearchResult
Visual Basic
<SerializableAttribute>
Public Class VirtualEntitySearchResult
Visual C++
[SerializableAttribute]
public ref class VirtualEntitySearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntitySearchResult

See Also

VirtualEntitySearchResult Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult Members

[image] [image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult Members
VirtualEntitySearchResult Class Constructors Methods Properties See Also Send Feedback

The VirtualEntitySearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualEntitySearchResult | Initializes a new instance of the VirtualEntitySearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Items | Gets or sets the items.
Public property | TotalCount | Gets or sets the total count.

See Also

VirtualEntitySearchResult Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult Constructor

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult Constructor
VirtualEntitySearchResult Class See Also Send Feedback
Initializes a new instance of the VirtualEntitySearchResult class

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public VirtualEntitySearchResult()
Visual Basic
Public Sub New
Visual C++
public:
VirtualEntitySearchResult()

See Also

VirtualEntitySearchResult Class
VirtualEntitySearchResult Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult Methods
VirtualEntitySearchResult Class See Also Send Feedback

The VirtualEntitySearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VirtualEntitySearchResult Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult Properties
VirtualEntitySearchResult Class See Also Send Feedback

The VirtualEntitySearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Items | Gets or sets the items.
Public property | TotalCount | Gets or sets the total count.

See Also

VirtualEntitySearchResult Class
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult.Items Property

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult..::..Items Property
VirtualEntitySearchResult Class See Also Send Feedback
Gets or sets the items.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, VirtualEntity> Items { get; set; }
Visual Basic
Public Property Items As Dictionary(Of String, VirtualEntity)
    Get
    Set
Visual C++
public:
property Dictionary<String^, VirtualEntity^>^ Items {
    Dictionary<String^, VirtualEntity^>^ get ();
    void set (Dictionary<String^, VirtualEntity^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, VirtualEntity >)>)>
The items.

See Also

VirtualEntitySearchResult Class
VirtualEntitySearchResult Members
CelloSaaS.Model.VirtualEntityManagement Namespace


VirtualEntitySearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
VirtualEntitySearchResult..::..TotalCount Property
VirtualEntitySearchResult Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.Model.VirtualEntityManagement
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The total count.

See Also

VirtualEntitySearchResult Class
VirtualEntitySearchResult Members
CelloSaaS.Model.VirtualEntityManagement Namespace


CelloSaaS.Notification.BatchService Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.BatchService Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchManagerException | Represents errors that occur during notification manager execution.
Public class | BatchNotificationConstants | This class contain Batch Notification Constants


BatchManagerException Class

[image]

A Sandcastle Documented Class Library
BatchManagerException Class
Members See Also Send Feedback
Represents errors that occur during notification manager execution.

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BatchManagerException : Exception
Visual Basic
<SerializableAttribute>
Public Class BatchManagerException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class BatchManagerException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.Notification.BatchService..::..BatchManagerException

See Also

BatchManagerException Members
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Members

[image] [image]

A Sandcastle Documented Class Library
BatchManagerException Members
BatchManagerException Class Constructors Methods Properties Events See Also Send Feedback

The BatchManagerException type exposes the following members.

Constructors

 | Name | Description
Public method | BatchManagerException()()()() | Initializes a new instance of the BatchManagerException class.
Public method | BatchManagerException(String) | Initializes a new instance of the BatchManagerException class with a specified error message.
Protected method | BatchManagerException(SerializationInfo, StreamingContext) | Initializes a new instance of the BatchManagerException class
Public method | BatchManagerException(String, Exception) | Initializes a new instance of the BatchManagerException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BatchManagerException Class
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Constructor

[image] [image]

A Sandcastle Documented Class Library
BatchManagerException Constructor
BatchManagerException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BatchManagerException()()()() | Initializes a new instance of the BatchManagerException class.
Public method | BatchManagerException(String) | Initializes a new instance of the BatchManagerException class with a specified error message.
Protected method | BatchManagerException(SerializationInfo, StreamingContext) | Initializes a new instance of the BatchManagerException class
Public method | BatchManagerException(String, Exception) | Initializes a new instance of the BatchManagerException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

BatchManagerException Class
BatchManagerException Members
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Constructor

[image]

A Sandcastle Documented Class Library
BatchManagerException Constructor
BatchManagerException Class See Also Send Feedback
Initializes a new instance of the BatchManagerException class.

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchManagerException()
Visual Basic
Public Sub New
Visual C++
public:
BatchManagerException()

See Also

BatchManagerException Class
BatchManagerException Members
BatchManagerException Overload
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Constructor (String)

[image]

A Sandcastle Documented Class Library
BatchManagerException Constructor (String)
BatchManagerException Class See Also Send Feedback
Initializes a new instance of the BatchManagerException class with a specified error message.

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchManagerException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
BatchManagerException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

BatchManagerException Class
BatchManagerException Members
BatchManagerException Overload
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
BatchManagerException Constructor (SerializationInfo, StreamingContext)
BatchManagerException Class See Also Send Feedback
Initializes a new instance of the BatchManagerException class

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected BatchManagerException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
BatchManagerException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

BatchManagerException Class
BatchManagerException Members
BatchManagerException Overload
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
BatchManagerException Constructor (String, Exception)
BatchManagerException Class See Also Send Feedback
Initializes a new instance of the BatchManagerException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchManagerException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
BatchManagerException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message that describes the error.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

BatchManagerException Class
BatchManagerException Members
BatchManagerException Overload
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Methods

[image] [image]

A Sandcastle Documented Class Library
BatchManagerException Methods
BatchManagerException Class See Also Send Feedback

The BatchManagerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BatchManagerException Class
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Properties

[image] [image]

A Sandcastle Documented Class Library
BatchManagerException Properties
BatchManagerException Class See Also Send Feedback

The BatchManagerException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BatchManagerException Class
CelloSaaS.Notification.BatchService Namespace


BatchManagerException Events

[image] [image]

A Sandcastle Documented Class Library
BatchManagerException Events
BatchManagerException Class See Also Send Feedback

The BatchManagerException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BatchManagerException Class
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants Class

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants Class
Members See Also Send Feedback
This class contain Batch Notification Constants

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class BatchNotificationConstants
Visual Basic
Public NotInheritable Class BatchNotificationConstants
Visual C++
public ref class BatchNotificationConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.BatchService..::..BatchNotificationConstants

See Also

BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants Members

[image] [image]

A Sandcastle Documented Class Library
BatchNotificationConstants Members
BatchNotificationConstants Class Fields See Also Send Feedback

The BatchNotificationConstants type exposes the following members.

Fields

Name | Description
BatchSize | Batch Size
DefaultBatchSize | Default Batch Size
DefaultFillQueueTime | Default Fill Queue Time
DefaultParallelThreadSize | Default Parallel Thread Size
DelayTimeAfterDispatch | Delay Time After Dispatch
FillQueueTime | Fill Queue Time
LogDispatchDetails | Log Batch Notification Performance
ParallelThreadSize | Parallel Thread Size

See Also

BatchNotificationConstants Class
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants Fields

[image] [image]

A Sandcastle Documented Class Library
BatchNotificationConstants Fields
BatchNotificationConstants Class See Also Send Feedback

The BatchNotificationConstants type exposes the following members.

Fields

Name | Description
BatchSize | Batch Size
DefaultBatchSize | Default Batch Size
DefaultFillQueueTime | Default Fill Queue Time
DefaultParallelThreadSize | Default Parallel Thread Size
DelayTimeAfterDispatch | Delay Time After Dispatch
FillQueueTime | Fill Queue Time
LogDispatchDetails | Log Batch Notification Performance
ParallelThreadSize | Parallel Thread Size

See Also

BatchNotificationConstants Class
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.BatchSize Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..BatchSize Field
BatchNotificationConstants Class See Also Send Feedback
Batch Size

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BatchSize
Visual Basic
Public Const BatchSize As String
Visual C++
public:
literal String^ BatchSize

Field Value

Type: String

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.DefaultBatchSize Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..DefaultBatchSize Field
BatchNotificationConstants Class See Also Send Feedback
Default Batch Size

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultBatchSize
Visual Basic
Public Const DefaultBatchSize As Integer
Visual C++
public:
literal int DefaultBatchSize

Field Value

Type: Int32

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.DefaultFillQueueTime Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..DefaultFillQueueTime Field
BatchNotificationConstants Class See Also Send Feedback
Default Fill Queue Time

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultFillQueueTime
Visual Basic
Public Const DefaultFillQueueTime As Integer
Visual C++
public:
literal int DefaultFillQueueTime

Field Value

Type: Int32

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.DefaultParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..DefaultParallelThreadSize Field
BatchNotificationConstants Class See Also Send Feedback
Default Parallel Thread Size

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultParallelThreadSize
Visual Basic
Public Const DefaultParallelThreadSize As Integer
Visual C++
public:
literal int DefaultParallelThreadSize

Field Value

Type: Int32

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.DelayTimeAfterDispatch Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..DelayTimeAfterDispatch Field
BatchNotificationConstants Class See Also Send Feedback
Delay Time After Dispatch

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DelayTimeAfterDispatch
Visual Basic
Public Const DelayTimeAfterDispatch As Integer
Visual C++
public:
literal int DelayTimeAfterDispatch

Field Value

Type: Int32

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.FillQueueTime Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..FillQueueTime Field
BatchNotificationConstants Class See Also Send Feedback
Fill Queue Time

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string FillQueueTime
Visual Basic
Public Const FillQueueTime As String
Visual C++
public:
literal String^ FillQueueTime

Field Value

Type: String

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.LogDispatchDetails Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..LogDispatchDetails Field
BatchNotificationConstants Class See Also Send Feedback
Log Batch Notification Performance

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LogDispatchDetails
Visual Basic
Public Const LogDispatchDetails As String
Visual C++
public:
literal String^ LogDispatchDetails

Field Value

Type: String

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


BatchNotificationConstants.ParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
BatchNotificationConstants..::..ParallelThreadSize Field
BatchNotificationConstants Class See Also Send Feedback
Parallel Thread Size

Namespace: CelloSaaS.Notification.BatchService
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ParallelThreadSize
Visual Basic
Public Const ParallelThreadSize As String
Visual C++
public:
literal String^ ParallelThreadSize

Field Value

Type: String

See Also

BatchNotificationConstants Class
BatchNotificationConstants Members
CelloSaaS.Notification.BatchService Namespace


CelloSaaS.Notification.Configuration Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Configuration Namespace
Send Feedback

Classes

 | Class | Description
Public class | NotificationConfigurationManager | This class is used to configure the notification details


NotificationConfigurationManager Class

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager Class
Members See Also Send Feedback
This class is used to configure the notification details

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationConfigurationManager
Visual Basic
Public NotInheritable Class NotificationConfigurationManager
Visual C++
public ref class NotificationConfigurationManager abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Configuration..::..NotificationConfigurationManager

See Also

NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager Members

[image] [image]

A Sandcastle Documented Class Library
NotificationConfigurationManager Members
NotificationConfigurationManager Class Methods See Also Send Feedback

The NotificationConfigurationManager type exposes the following members.

Methods

Name | Description
ConfigureEmailDetails | This method is used to Configure the Email Notification Details.
ConfigureFtpDetails | This method is used to Configure the File Notification Details.
ConfigureLocaleTemplate(LocaleTemplate) | This method is used to configure Locale Template Details using Locale Template Id.
ConfigureLocaleTemplate(String, LocaleTemplate) | This method is used to configure Locale Template using Notification Master Id.
ConfigureNotificationMaster | This method is used to Configures the notification master.
ConfigureSystemNotificationDetails | This method is used to Configure the System Notification Details.
EditLocaleTemplate | This method is used to edit the locale template.
GetEmailDispatchDetails | This method is used to gets the email dispatch details.
GetEmailDispatchDetailsById | This method is used to gets the email dispatch details by using the email dipatch details id.
GetLocaleTemplateByLocaleId | This method is used to get the locale Template for the locale id.
GetLocaleTemplates | This method is used to gets all the locale templates for the template id.
GetNotificationMasterDetails | Obsolete. This method is used to gets the notification master details.
GetNotificationMasterDetailsById | This method is used to Get the notification master details by using the notification master id.
GetNotificationMasterDetailsByTenantId | This method is used to gets the notification master details.
GetNotificationTemplateId | This method is used to gets the notification template id.
RemoveConfiguration | This method is used to remove the Configuration Details related to the Notification Master Id
RemoveLocaleTemplate | This method is used to removes the locale template.
UpdateEmailDetails | This method is used to updates the email details.
UpdateEmailDispatchDetails | This method is used to update the email dispatch details.
UpdateFtpDetails | This method is used to updates the FTP details.
UpdateNotificationMasterDetails | This method is used to updates the notification master details.

See Also

NotificationConfigurationManager Class
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationConfigurationManager Methods
NotificationConfigurationManager Class See Also Send Feedback

The NotificationConfigurationManager type exposes the following members.

Methods

Name | Description
ConfigureEmailDetails | This method is used to Configure the Email Notification Details.
ConfigureFtpDetails | This method is used to Configure the File Notification Details.
ConfigureLocaleTemplate(LocaleTemplate) | This method is used to configure Locale Template Details using Locale Template Id.
ConfigureLocaleTemplate(String, LocaleTemplate) | This method is used to configure Locale Template using Notification Master Id.
ConfigureNotificationMaster | This method is used to Configures the notification master.
ConfigureSystemNotificationDetails | This method is used to Configure the System Notification Details.
EditLocaleTemplate | This method is used to edit the locale template.
GetEmailDispatchDetails | This method is used to gets the email dispatch details.
GetEmailDispatchDetailsById | This method is used to gets the email dispatch details by using the email dipatch details id.
GetLocaleTemplateByLocaleId | This method is used to get the locale Template for the locale id.
GetLocaleTemplates | This method is used to gets all the locale templates for the template id.
GetNotificationMasterDetails | Obsolete. This method is used to gets the notification master details.
GetNotificationMasterDetailsById | This method is used to Get the notification master details by using the notification master id.
GetNotificationMasterDetailsByTenantId | This method is used to gets the notification master details.
GetNotificationTemplateId | This method is used to gets the notification template id.
RemoveConfiguration | This method is used to remove the Configuration Details related to the Notification Master Id
RemoveLocaleTemplate | This method is used to removes the locale template.
UpdateEmailDetails | This method is used to updates the email details.
UpdateEmailDispatchDetails | This method is used to update the email dispatch details.
UpdateFtpDetails | This method is used to updates the FTP details.
UpdateNotificationMasterDetails | This method is used to updates the notification master details.

See Also

NotificationConfigurationManager Class
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureEmailDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureEmailDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to Configure the Email Notification Details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ConfigureEmailDetails(
    NotificationDetails notificationDetails,
    EmailDetails emailDetails
)
Visual Basic
Public Shared Sub ConfigureEmailDetails (
    notificationDetails As NotificationDetails,
    emailDetails As EmailDetails
)
Visual C++
public:
static void ConfigureEmailDetails(
    NotificationDetails^ notificationDetails,
    EmailDetails^ emailDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
Notification Details
emailDetails
Type: CelloSaaS.Notification.Model.Email..::..EmailDetails
Email Details

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details or email details is null
System..::..ArgumentNullException | If Notification details ntification id or email details sender or email details smtp address or smtp user name or smtp password value is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureFtpDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureFtpDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to Configure the File Notification Details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ConfigureFtpDetails(
    NotificationDetails notificationDetails,
    FtpDetails ftpDetails
)
Visual Basic
Public Shared Sub ConfigureFtpDetails (
    notificationDetails As NotificationDetails,
    ftpDetails As FtpDetails
)
Visual C++
public:
static void ConfigureFtpDetails(
    NotificationDetails^ notificationDetails,
    FtpDetails^ ftpDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
Notification Details
ftpDetails
Type: CelloSaaS.Notification.Model.Ftp..::..FtpDetails
Ftp Details

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details or ftp details is null
System..::..ArgumentNullException | If Notification details ntification id or ftp details ftpaddress or ftp details ftp user name or ftp password value is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureLocaleTemplate Method

[image] [image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureLocaleTemplate Method
NotificationConfigurationManager Class See Also Send Feedback

Overload List

Name | Description
ConfigureLocaleTemplate(LocaleTemplate) | This method is used to configure Locale Template Details using Locale Template Id.
ConfigureLocaleTemplate(String, LocaleTemplate) | This method is used to configure Locale Template using Notification Master Id.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureLocaleTemplate Method (LocaleTemplate)

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureLocaleTemplate Method (LocaleTemplate)
NotificationConfigurationManager Class See Also Send Feedback
This method is used to configure Locale Template Details using Locale Template Id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ConfigureLocaleTemplate(
    LocaleTemplate localeTemplate
)
Visual Basic
Public Shared Sub ConfigureLocaleTemplate (
    localeTemplate As LocaleTemplate
)
Visual C++
public:
static void ConfigureLocaleTemplate(
    LocaleTemplate^ localeTemplate
)

Parameters

localeTemplate
Type: CelloSaaS.Notification.Model..::..LocaleTemplate
Locale Template

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If locale template template id is null or empty.
System..::..ArgumentException | If locale template template id or locale template locale id or locale template content text value is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
ConfigureLocaleTemplate Overload
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureLocaleTemplate Method (String, LocaleTemplate)

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureLocaleTemplate Method (String, LocaleTemplate)
NotificationConfigurationManager Class See Also Send Feedback
This method is used to configure Locale Template using Notification Master Id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ConfigureLocaleTemplate(
    string notificationMasterId,
    LocaleTemplate localeTemplate
)
Visual Basic
Public Shared Sub ConfigureLocaleTemplate (
    notificationMasterId As String,
    localeTemplate As LocaleTemplate
)
Visual C++
public:
static void ConfigureLocaleTemplate(
    String^ notificationMasterId,
    LocaleTemplate^ localeTemplate
)

Parameters

notificationMasterId
Type: System..::..String
Notification Master Id
localeTemplate
Type: CelloSaaS.Notification.Model..::..LocaleTemplate
LocaleTemplate

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If notification master id is null or empty.
System..::..ArgumentException | If locale template or locale template template id or locale template locale id or locale template content text value is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
ConfigureLocaleTemplate Overload
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureNotificationMaster Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureNotificationMaster Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to Configures the notification master.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ConfigureNotificationMaster(
    NotificationDetails notificationDetails
)
Visual Basic
Public Shared Function ConfigureNotificationMaster (
    notificationDetails As NotificationDetails
) As String
Visual C++
public:
static String^ ConfigureNotificationMaster(
    NotificationDetails^ notificationDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
The notification details.

Return Value

Type: String

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..DuplicateNotificationNameException | If the notification name is duplicate.
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details is null
System..::..ArgumentNullException | If Notification details ntification name is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.ConfigureSystemNotificationDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..ConfigureSystemNotificationDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to Configure the System Notification Details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ConfigureSystemNotificationDetails(
    NotificationDetails notificationDetails,
    SystemNotificationDestination systemNotificationDestination,
    SystemNotificationContent systemNotificationContent
)
Visual Basic
Public Shared Sub ConfigureSystemNotificationDetails (
    notificationDetails As NotificationDetails,
    systemNotificationDestination As SystemNotificationDestination,
    systemNotificationContent As SystemNotificationContent
)
Visual C++
public:
static void ConfigureSystemNotificationDetails(
    NotificationDetails^ notificationDetails,
    SystemNotificationDestination^ systemNotificationDestination,
    SystemNotificationContent^ systemNotificationContent
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
Notification Details
systemNotificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..SystemNotificationDestination
The system notification destination.
systemNotificationContent
Type: CelloSaaS.Notification.Model.Content..::..SystemNotificationContent
Content of the system notification.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details or system notification destination or system notification content is null
System..::..ArgumentNullException | If Notification details ntification id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.EditLocaleTemplate Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..EditLocaleTemplate Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to edit the locale template.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditLocaleTemplate(
    LocaleTemplate localeTemplate
)
Visual Basic
Public Shared Function EditLocaleTemplate (
    localeTemplate As LocaleTemplate
) As String
Visual C++
public:
static String^ EditLocaleTemplate(
    LocaleTemplate^ localeTemplate
)

Parameters

localeTemplate
Type: CelloSaaS.Notification.Model..::..LocaleTemplate
The locale template.

Return Value

Type: String
locale template id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If locale template is null.
System..::..ArgumentNullException | If locale template template id or locale id or content text value is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetEmailDispatchDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetEmailDispatchDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to gets the email dispatch details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static List<EmailDestination> GetEmailDispatchDetails(
    string tenantId
)
Visual Basic
Public Shared Function GetEmailDispatchDetails (
    tenantId As String
) As List(Of EmailDestination)
Visual C++
public:
static List<EmailDestination^>^ GetEmailDispatchDetails(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: List<(Of <(<' EmailDestination >)>)>
List of email destination

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetEmailDispatchDetailsById Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetEmailDispatchDetailsById Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to gets the email dispatch details by using the email dipatch details id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static EmailDestination GetEmailDispatchDetailsById(
    string emailDispatchDetailsId
)
Visual Basic
Public Shared Function GetEmailDispatchDetailsById (
    emailDispatchDetailsId As String
) As EmailDestination
Visual C++
public:
static EmailDestination^ GetEmailDispatchDetailsById(
    String^ emailDispatchDetailsId
)

Parameters

emailDispatchDetailsId
Type: System..::..String
The email dispatch details id.

Return Value

Type: EmailDestination
Email destination

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If email dispatch details id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetLocaleTemplateByLocaleId Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetLocaleTemplateByLocaleId Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to get the locale Template for the locale id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static LocaleTemplate GetLocaleTemplateByLocaleId(
    string templateId,
    string localeId
)
Visual Basic
Public Shared Function GetLocaleTemplateByLocaleId (
    templateId As String,
    localeId As String
) As LocaleTemplate
Visual C++
public:
static LocaleTemplate^ GetLocaleTemplateByLocaleId(
    String^ templateId,
    String^ localeId
)

Parameters

templateId
Type: System..::..String
Template Id
localeId
Type: System..::..String
Locale Id

Return Value

Type: LocaleTemplate
Locale Template

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If template id or locale id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetLocaleTemplates Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetLocaleTemplates Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to gets all the locale templates for the template id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static List<LocaleTemplate> GetLocaleTemplates(
    string templateId
)
Visual Basic
Public Shared Function GetLocaleTemplates (
    templateId As String
) As List(Of LocaleTemplate)
Visual C++
public:
static List<LocaleTemplate^>^ GetLocaleTemplates(
    String^ templateId
)

Parameters

templateId
Type: System..::..String
The template id.

Return Value

Type: List<(Of <(<' LocaleTemplate >)>)>
Lost of locale templates

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If template id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetNotificationMasterDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetNotificationMasterDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to gets the notification master details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Please use GetNotificationMasterDetailsByTenantId")]
public static List<NotificationDetails> GetNotificationMasterDetails()
Visual Basic
<ObsoleteAttribute("Please use GetNotificationMasterDetailsByTenantId")>
Public Shared Function GetNotificationMasterDetails As List(Of NotificationDetails)
Visual C++
public:
[ObsoleteAttribute(L"Please use GetNotificationMasterDetailsByTenantId")]
static List<NotificationDetails^>^ GetNotificationMasterDetails()

Return Value

Type: List<(Of <(<' NotificationDetails >)>)>
List of notification details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetNotificationMasterDetailsById Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetNotificationMasterDetailsById Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to Get the notification master details by using the notification master id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static NotificationDetails GetNotificationMasterDetailsById(
    string notificationMasterId
)
Visual Basic
Public Shared Function GetNotificationMasterDetailsById (
    notificationMasterId As String
) As NotificationDetails
Visual C++
public:
static NotificationDetails^ GetNotificationMasterDetailsById(
    String^ notificationMasterId
)

Parameters

notificationMasterId
Type: System..::..String
The notification master id.

Return Value

Type: NotificationDetails
Notification details

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If notification master id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetNotificationMasterDetailsByTenantId Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetNotificationMasterDetailsByTenantId Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to gets the notification master details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static List<NotificationDetails> GetNotificationMasterDetailsByTenantId(
    string tenantId
)
Visual Basic
Public Shared Function GetNotificationMasterDetailsByTenantId (
    tenantId As String
) As List(Of NotificationDetails)
Visual C++
public:
static List<NotificationDetails^>^ GetNotificationMasterDetailsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String

Return Value

Type: List<(Of <(<' NotificationDetails >)>)>
List of notification details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.GetNotificationTemplateId Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..GetNotificationTemplateId Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to gets the notification template id.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string GetNotificationTemplateId(
    string notificationMasterId
)
Visual Basic
Public Shared Function GetNotificationTemplateId (
    notificationMasterId As String
) As String
Visual C++
public:
static String^ GetNotificationTemplateId(
    String^ notificationMasterId
)

Parameters

notificationMasterId
Type: System..::..String
The notification master id.

Return Value

Type: String
template Id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If notification master id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.RemoveConfiguration Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..RemoveConfiguration Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to remove the Configuration Details related to the Notification Master Id

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void RemoveConfiguration(
    string notificationDetailsNotificationId
)
Visual Basic
Public Shared Sub RemoveConfiguration (
    notificationDetailsNotificationId As String
)
Visual C++
public:
static void RemoveConfiguration(
    String^ notificationDetailsNotificationId
)

Parameters

notificationDetailsNotificationId
Type: System..::..String
Notification Details Notification Id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If Notification details ntification id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.RemoveLocaleTemplate Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..RemoveLocaleTemplate Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to removes the locale template.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string RemoveLocaleTemplate(
    string localeId,
    string templateId
)
Visual Basic
Public Shared Function RemoveLocaleTemplate (
    localeId As String,
    templateId As String
) As String
Visual C++
public:
static String^ RemoveLocaleTemplate(
    String^ localeId,
    String^ templateId
)

Parameters

localeId
Type: System..::..String
The locale id.
templateId
Type: System..::..String
The template id.

Return Value

Type: String
locale template id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If locale id or template id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.UpdateEmailDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..UpdateEmailDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to updates the email details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateEmailDetails(
    EmailDestination emailDestination,
    TextMessageContent notificationContent,
    string emailContent
)
Visual Basic
Public Shared Function UpdateEmailDetails (
    emailDestination As EmailDestination,
    notificationContent As TextMessageContent,
    emailContent As String
) As String
Visual C++
public:
static String^ UpdateEmailDetails(
    EmailDestination^ emailDestination,
    TextMessageContent^ notificationContent,
    String^ emailContent
)

Parameters

emailDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..EmailDestination
The email destination.
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..TextMessageContent
Content of the notification.
emailContent
Type: System..::..String
Content of the email.

Return Value

Type: String
Email dispatch details id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If email destination or text message content is null.
System..::..ArgumentNullException | If email destination id or sender address or smtp address or smtp username or smtppassword or notification content id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.UpdateEmailDispatchDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..UpdateEmailDispatchDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to update the email dispatch details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateEmailDispatchDetails(
    EmailDestination emailDestination
)
Visual Basic
Public Shared Function UpdateEmailDispatchDetails (
    emailDestination As EmailDestination
) As String
Visual C++
public:
static String^ UpdateEmailDispatchDetails(
    EmailDestination^ emailDestination
)

Parameters

emailDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..EmailDestination
The email destination.

Return Value

Type: String
email dispatch details id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If email destination is null.
System..::..ArgumentNullException | If email destination id or sender address or recipient address or smtp user name or password is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.UpdateFtpDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..UpdateFtpDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to updates the FTP details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateFtpDetails(
    FtpDestination ftpDestination,
    FileContent fileContent
)
Visual Basic
Public Shared Function UpdateFtpDetails (
    ftpDestination As FtpDestination,
    fileContent As FileContent
) As String
Visual C++
public:
static String^ UpdateFtpDetails(
    FtpDestination^ ftpDestination,
    FileContent^ fileContent
)

Parameters

ftpDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..FtpDestination
The FTP destination.
fileContent
Type: CelloSaaS.Notification.Model.Content..::..FileContent
Content of the file.

Return Value

Type: String
ftp destination details id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exception occurs, while connecting of modifying the DB
System..::..ArgumentException | If ftp destination or file content is null.
System..::..ArgumentNullException | If ftp destination id or ftp address or username or password or notification content id is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


NotificationConfigurationManager.UpdateNotificationMasterDetails Method

[image]

A Sandcastle Documented Class Library
NotificationConfigurationManager..::..UpdateNotificationMasterDetails Method
NotificationConfigurationManager Class See Also Send Feedback
This method is used to updates the notification master details.

Namespace: CelloSaaS.Notification.Configuration
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateNotificationMasterDetails(
    NotificationDetails notificationDetails
)
Visual Basic
Public Shared Function UpdateNotificationMasterDetails (
    notificationDetails As NotificationDetails
) As String
Visual C++
public:
static String^ UpdateNotificationMasterDetails(
    NotificationDetails^ notificationDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
The notification details.

Return Value

Type: String
notification id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..DuplicateNotificationNameException | If the notification name is duplicate.
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details is null.
System..::..ArgumentNullException | If notification master id or notification name is null or empty.

See Also

NotificationConfigurationManager Class
NotificationConfigurationManager Members
CelloSaaS.Notification.Configuration Namespace


CelloSaaS.Notification.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | LocaleTemplate | This class contains Locale Template Details
Public class | NotificationAudit | Represents Notification Audit Properties
Public class | NotificationAuditSearchCondition | This classs contains audit search condition
Public class | NotificationAuditSearchResult |
Public class | NotificationBatch | This Model Contain Notification Batch Details.
Public class | NotificationDetails | This class contain Notification Details
Public class | NotificationPrivilegeConstants |

Enumerations

 | Enumeration | Description
Public enumeration | DispatchStatus | Notification Dispatch Status
Public enumeration | NotificationContentType | Notification Content Type
Public enumeration | NotificationDestinationType | Notification Destination Type
Public enumeration | NotificationStatus | Notification Status Details
Public enumeration | Priority | The priority of the email.


DispatchStatus Enumeration

[image]

A Sandcastle Documented Class Library
DispatchStatus Enumeration
See Also Send Feedback
Notification Dispatch Status

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum DispatchStatus
Visual Basic
Public Enumeration DispatchStatus
Visual C++
public enum class DispatchStatus

Members

Member name | Value | Description
Open | 0 | Open Status
InProgress | 1 | In progress status
Completed | 2 | Dispatch Completed
Failure | 3 | Dispatch Failure

See Also

CelloSaaS.Notification.Model Namespace


LocaleTemplate Class

[image]

A Sandcastle Documented Class Library
LocaleTemplate Class
Members See Also Send Feedback
This class contains Locale Template Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LocaleTemplate
Visual Basic
<SerializableAttribute>
Public Class LocaleTemplate
Visual C++
[SerializableAttribute]
public ref class LocaleTemplate

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..LocaleTemplate

See Also

LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate Members

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplate Members
LocaleTemplate Class Constructors Methods Properties See Also Send Feedback

The LocaleTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | LocaleTemplate | Initializes a new instance of the LocaleTemplate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContentText | Gets or sets the Locale template Content
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the Locale Template identifier
Public property | LocaleId | Gets or sets the locale id.
Public property | LocaleName | Gets or sets the locale name's identifier.
Public property | Status | Gets or sets a value indicating whether this LocaleTemplate is status.
Public property | TemplateId | Gets or sets the notification Template identifier
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

LocaleTemplate Class
CelloSaaS.Notification.Model Namespace


LocaleTemplate Constructor

[image]

A Sandcastle Documented Class Library
LocaleTemplate Constructor
LocaleTemplate Class See Also Send Feedback
Initializes a new instance of the LocaleTemplate class

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LocaleTemplate()
Visual Basic
Public Sub New
Visual C++
public:
LocaleTemplate()

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplate Methods
LocaleTemplate Class See Also Send Feedback

The LocaleTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LocaleTemplate Class
CelloSaaS.Notification.Model Namespace


LocaleTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplate Properties
LocaleTemplate Class See Also Send Feedback

The LocaleTemplate type exposes the following members.

Properties

 | Name | Description
Public property | ContentText | Gets or sets the Locale template Content
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the Locale Template identifier
Public property | LocaleId | Gets or sets the locale id.
Public property | LocaleName | Gets or sets the locale name's identifier.
Public property | Status | Gets or sets a value indicating whether this LocaleTemplate is status.
Public property | TemplateId | Gets or sets the notification Template identifier
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

LocaleTemplate Class
CelloSaaS.Notification.Model Namespace


LocaleTemplate.ContentText Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..ContentText Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the Locale template Content

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder ContentText { get; set; }
Visual Basic
Public Property ContentText As StringBuilder
    Get
    Set
Visual C++
public:
property StringBuilder^ ContentText {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..CreatedBy Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..CreatedOn Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.Description Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..Description Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the description.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.Id Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..Id Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the Locale Template identifier

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.LocaleId Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..LocaleId Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
property String^ LocaleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The locale id.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.LocaleName Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..LocaleName Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the locale name's identifier.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleName { get; set; }
Visual Basic
Public Property LocaleName As String
    Get
    Set
Visual C++
public:
property String^ LocaleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The locale name id.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.Status Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..Status Property
LocaleTemplate Class See Also Send Feedback
Gets or sets a value indicating whether this LocaleTemplate is status.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..TemplateId Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the notification Template identifier

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..UpdatedBy Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


LocaleTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..UpdatedOn Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Notification.Model Namespace


NotificationAudit Class

[image]

A Sandcastle Documented Class Library
NotificationAudit Class
Members See Also Send Feedback
Represents Notification Audit Properties

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class NotificationAudit
Visual Basic
Public Class NotificationAudit
Visual C++
public ref class NotificationAudit

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..NotificationAudit

See Also

NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit Members

[image] [image]

A Sandcastle Documented Class Library
NotificationAudit Members
NotificationAudit Class Constructors Methods Properties See Also Send Feedback

The NotificationAudit type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationAudit | Initializes a new instance of the NotificationAudit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BatchCount | Gets or sets the batch count
Public property | BatchDetails | Gets or sets the notification batch details
Public property | CreatedBy | Gets or sets the user identifier
Public property | CreatedOn | Gets or sets the logged date
Public property | Id | Gets or sets the notification audit identifier
Public property | NotificationContent | Gets or sets the content of the notification.
Public property | NotificationContentType | Gets or sets Notification Content Details
Public property | NotificationDestination | Gets or sets the notification destination.
Public property | NotificationDestinationType | Gets or sets Notification Destination Details
Public property | NotificationDetails | Gets or sets the notification details.
Public property | NotificationId | Gets or sets the notification identifier
Public property | NotificationStatus | Gets or sets the notification status
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

NotificationAudit Class
CelloSaaS.Notification.Model Namespace


NotificationAudit Constructor

[image]

A Sandcastle Documented Class Library
NotificationAudit Constructor
NotificationAudit Class See Also Send Feedback
Initializes a new instance of the NotificationAudit class

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationAudit()
Visual Basic
Public Sub New
Visual C++
public:
NotificationAudit()

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationAudit Methods
NotificationAudit Class See Also Send Feedback

The NotificationAudit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationAudit Class
CelloSaaS.Notification.Model Namespace


NotificationAudit Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationAudit Properties
NotificationAudit Class See Also Send Feedback

The NotificationAudit type exposes the following members.

Properties

 | Name | Description
Public property | BatchCount | Gets or sets the batch count
Public property | BatchDetails | Gets or sets the notification batch details
Public property | CreatedBy | Gets or sets the user identifier
Public property | CreatedOn | Gets or sets the logged date
Public property | Id | Gets or sets the notification audit identifier
Public property | NotificationContent | Gets or sets the content of the notification.
Public property | NotificationContentType | Gets or sets Notification Content Details
Public property | NotificationDestination | Gets or sets the notification destination.
Public property | NotificationDestinationType | Gets or sets Notification Destination Details
Public property | NotificationDetails | Gets or sets the notification details.
Public property | NotificationId | Gets or sets the notification identifier
Public property | NotificationStatus | Gets or sets the notification status
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

NotificationAudit Class
CelloSaaS.Notification.Model Namespace


NotificationAudit.BatchCount Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..BatchCount Property
NotificationAudit Class See Also Send Feedback
Gets or sets the batch count

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int BatchCount { get; set; }
Visual Basic
Public Property BatchCount As Integer
    Get
    Set
Visual C++
public:
property int BatchCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.BatchDetails Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..BatchDetails Property
NotificationAudit Class See Also Send Feedback
Gets or sets the notification batch details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch BatchDetails { get; set; }
Visual Basic
Public Property BatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ BatchDetails {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.CreatedBy Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..CreatedBy Property
NotificationAudit Class See Also Send Feedback
Gets or sets the user identifier

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.CreatedOn Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..CreatedOn Property
NotificationAudit Class See Also Send Feedback
Gets or sets the logged date

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.Id Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..Id Property
NotificationAudit Class See Also Send Feedback
Gets or sets the notification audit identifier

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationContent Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationContent Property
NotificationAudit Class See Also Send Feedback
Gets or sets the content of the notification.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationContent NotificationContent { get; set; }
Visual Basic
Public Property NotificationContent As INotificationContent
    Get
    Set
Visual C++
public:
property INotificationContent^ NotificationContent {
    INotificationContent^ get ();
    void set (INotificationContent^ value);
}

Property Value

Type: INotificationContent
The content of the notification.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationContentType Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationContentType Property
NotificationAudit Class See Also Send Feedback
Gets or sets Notification Content Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType NotificationContentType { get; set; }
Visual Basic
Public Property NotificationContentType As NotificationContentType
    Get
    Set
Visual C++
public:
property NotificationContentType NotificationContentType {
    NotificationContentType get ();
    void set (NotificationContentType value);
}

Property Value

Type: NotificationContentType

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationDestination Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationDestination Property
NotificationAudit Class See Also Send Feedback
Gets or sets the notification destination.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationDestination NotificationDestination { get; set; }
Visual Basic
Public Property NotificationDestination As INotificationDestination
    Get
    Set
Visual C++
public:
property INotificationDestination^ NotificationDestination {
    INotificationDestination^ get ();
    void set (INotificationDestination^ value);
}

Property Value

Type: INotificationDestination
The notification destination.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationDestinationType Property
NotificationAudit Class See Also Send Feedback
Gets or sets Notification Destination Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; set; }
Visual Basic
Public Property NotificationDestinationType As NotificationDestinationType
    Get
    Set
Visual C++
public:
property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get ();
    void set (NotificationDestinationType value);
}

Property Value

Type: NotificationDestinationType

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationDetails Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationDetails Property
NotificationAudit Class See Also Send Feedback
Gets or sets the notification details.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDetails NotificationDetails { get; set; }
Visual Basic
Public Property NotificationDetails As NotificationDetails
    Get
    Set
Visual C++
public:
property NotificationDetails^ NotificationDetails {
    NotificationDetails^ get ();
    void set (NotificationDetails^ value);
}

Property Value

Type: NotificationDetails
The notification details.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationId Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationId Property
NotificationAudit Class See Also Send Feedback
Gets or sets the notification identifier

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationId { get; set; }
Visual Basic
Public Property NotificationId As String
    Get
    Set
Visual C++
public:
property String^ NotificationId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.NotificationStatus Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..NotificationStatus Property
NotificationAudit Class See Also Send Feedback
Gets or sets the notification status

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationStatus NotificationStatus { get; set; }
Visual Basic
Public Property NotificationStatus As NotificationStatus
    Get
    Set
Visual C++
public:
property NotificationStatus NotificationStatus {
    NotificationStatus get ();
    void set (NotificationStatus value);
}

Property Value

Type: NotificationStatus

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.Status Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..Status Property
NotificationAudit Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.TenantId Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..TenantId Property
NotificationAudit Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..UpdatedBy Property
NotificationAudit Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAudit.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
NotificationAudit..::..UpdatedOn Property
NotificationAudit Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

NotificationAudit Class
NotificationAudit Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition Class

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition Class
Members See Also Send Feedback
This classs contains audit search condition

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class NotificationAuditSearchCondition
Visual Basic
Public Class NotificationAuditSearchCondition
Visual C++
public ref class NotificationAuditSearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..NotificationAuditSearchCondition

See Also

NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition Members
NotificationAuditSearchCondition Class Constructors Methods Properties See Also Send Feedback

The NotificationAuditSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationAuditSearchCondition | Initializes a new instance of the NotificationAuditSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContentType | Gets or sets the type of the content.
Public property | ContentTypes | Gets or sets the content types.
Public property | DestinationType | Gets or sets the type of the destination.
Public property | DestinationTypes | Gets or sets the destination types.
Public property | EndDate | Gets or sets the end date.
Public property | NotificationDispatchId | Gets or sets the notification dispatch id.
Public property | NotificationFailureId | Gets or sets the notification failure id.
Public property | NotificationId | Gets or sets the Notification Id of the notification.
Public property | NotificationName | Gets or sets the name of the notification.
Public property | NotificationStatus | Gets or sets the notification status.
Public property | PageNumber | Gets or sets the record start.
Public property | PageSize | Gets or sets the record end.
Public property | RecordEnd | Obsolete. Gets or sets the record end.
Public property | RecordStart | Obsolete. Gets or sets the record start.
Public property | SetTotalCount | Gets or sets a value indicating whether [set total count].
Public property | SortExpression | Gets or sets the sort expression.
Public property | SortString | Gets or sets the sort string.
Public property | StartDate | Gets or sets the start date.
Public property | TenantId | Gets or sets the tenant id.
Public property | TenantIds | Gets or sets the tenant ids.
Public property | TotalCount | Obsolete. Gets or sets the total count
Public property | TrackId | Gets or sets the track id.
Public property | UserId | Gets or sets the user id.

See Also

NotificationAuditSearchCondition Class
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition Constructor
NotificationAuditSearchCondition Class See Also Send Feedback
Initializes a new instance of the NotificationAuditSearchCondition class

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationAuditSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
NotificationAuditSearchCondition()

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition Methods
NotificationAuditSearchCondition Class See Also Send Feedback

The NotificationAuditSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationAuditSearchCondition Class
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition Properties
NotificationAuditSearchCondition Class See Also Send Feedback

The NotificationAuditSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | ContentType | Gets or sets the type of the content.
Public property | ContentTypes | Gets or sets the content types.
Public property | DestinationType | Gets or sets the type of the destination.
Public property | DestinationTypes | Gets or sets the destination types.
Public property | EndDate | Gets or sets the end date.
Public property | NotificationDispatchId | Gets or sets the notification dispatch id.
Public property | NotificationFailureId | Gets or sets the notification failure id.
Public property | NotificationId | Gets or sets the Notification Id of the notification.
Public property | NotificationName | Gets or sets the name of the notification.
Public property | NotificationStatus | Gets or sets the notification status.
Public property | PageNumber | Gets or sets the record start.
Public property | PageSize | Gets or sets the record end.
Public property | RecordEnd | Obsolete. Gets or sets the record end.
Public property | RecordStart | Obsolete. Gets or sets the record start.
Public property | SetTotalCount | Gets or sets a value indicating whether [set total count].
Public property | SortExpression | Gets or sets the sort expression.
Public property | SortString | Gets or sets the sort string.
Public property | StartDate | Gets or sets the start date.
Public property | TenantId | Gets or sets the tenant id.
Public property | TenantIds | Gets or sets the tenant ids.
Public property | TotalCount | Obsolete. Gets or sets the total count
Public property | TrackId | Gets or sets the track id.
Public property | UserId | Gets or sets the user id.

See Also

NotificationAuditSearchCondition Class
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.ContentType Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..ContentType Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the type of the content.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<NotificationContentType> ContentType { get; set; }
Visual Basic
Public Property ContentType As Nullable(Of NotificationContentType)
    Get
    Set
Visual C++
public:
property Nullable<NotificationContentType> ContentType {
    Nullable<NotificationContentType> get ();
    void set (Nullable<NotificationContentType> value);
}

Property Value

Type: Nullable<(Of <(<' NotificationContentType >)>)>
The type of the content.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.ContentTypes Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..ContentTypes Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the content types.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<NotificationContentType> ContentTypes { get; set; }
Visual Basic
Public Property ContentTypes As List(Of NotificationContentType)
    Get
    Set
Visual C++
public:
property List<NotificationContentType>^ ContentTypes {
    List<NotificationContentType>^ get ();
    void set (List<NotificationContentType>^ value);
}

Property Value

Type: List<(Of <(<' NotificationContentType >)>)>
The content types.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.DestinationType Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..DestinationType Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the type of the destination.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<NotificationDestinationType> DestinationType { get; set; }
Visual Basic
Public Property DestinationType As Nullable(Of NotificationDestinationType)
    Get
    Set
Visual C++
public:
property Nullable<NotificationDestinationType> DestinationType {
    Nullable<NotificationDestinationType> get ();
    void set (Nullable<NotificationDestinationType> value);
}

Property Value

Type: Nullable<(Of <(<' NotificationDestinationType >)>)>
The type of the destination.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.DestinationTypes Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..DestinationTypes Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the destination types.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<NotificationDestinationType> DestinationTypes { get; set; }
Visual Basic
Public Property DestinationTypes As List(Of NotificationDestinationType)
    Get
    Set
Visual C++
public:
property List<NotificationDestinationType>^ DestinationTypes {
    List<NotificationDestinationType>^ get ();
    void set (List<NotificationDestinationType>^ value);
}

Property Value

Type: List<(Of <(<' NotificationDestinationType >)>)>
The destination types.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.EndDate Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..EndDate Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the end date.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> EndDate { get; set; }
Visual Basic
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> EndDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The end date.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.NotificationDispatchId Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..NotificationDispatchId Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the notification dispatch id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDispatchId { get; set; }
Visual Basic
Public Property NotificationDispatchId As String
    Get
    Set
Visual C++
public:
property String^ NotificationDispatchId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The notification dispatch id.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.NotificationFailureId Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..NotificationFailureId Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the notification failure id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationFailureId { get; set; }
Visual Basic
Public Property NotificationFailureId As String
    Get
    Set
Visual C++
public:
property String^ NotificationFailureId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The notification failure id.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.NotificationId Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..NotificationId Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the Notification Id of the notification.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationId { get; set; }
Visual Basic
Public Property NotificationId As String
    Get
    Set
Visual C++
public:
property String^ NotificationId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Notification Id of the notification.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.NotificationName Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..NotificationName Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the name of the notification.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationName { get; set; }
Visual Basic
Public Property NotificationName As String
    Get
    Set
Visual C++
public:
property String^ NotificationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the notification.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.NotificationStatus Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..NotificationStatus Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the notification status.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<NotificationStatus> NotificationStatus { get; set; }
Visual Basic
Public Property NotificationStatus As Nullable(Of NotificationStatus)
    Get
    Set
Visual C++
public:
property Nullable<NotificationStatus> NotificationStatus {
    Nullable<NotificationStatus> get ();
    void set (Nullable<NotificationStatus> value);
}

Property Value

Type: Nullable<(Of <(<' NotificationStatus >)>)>
The notification status.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.PageNumber Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..PageNumber Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the record start.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Set
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The record start.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.PageSize Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..PageSize Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the record end.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The record end.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.RecordEnd Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..RecordEnd Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the record end.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
public int RecordEnd { get; set; }
Visual Basic
<ObsoleteAttribute>
Public Property RecordEnd As Integer
    Get
    Set
Visual C++
public:
[ObsoleteAttribute]
property int RecordEnd {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The record end.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.RecordStart Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..RecordStart Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the record start.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
public int RecordStart { get; set; }
Visual Basic
<ObsoleteAttribute>
Public Property RecordStart As Integer
    Get
    Set
Visual C++
public:
[ObsoleteAttribute]
property int RecordStart {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The record start.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..SetTotalCount Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets a value indicating whether [set total count].

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Boolean
    Get
    Set
Visual C++
public:
property bool SetTotalCount {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [set total count]; otherwise, false.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.SortExpression Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..SortExpression Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the sort expression.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortExpression { get; set; }
Visual Basic
Public Property SortExpression As String
    Get
    Set
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort expression.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.SortString Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..SortString Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the sort string.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort string.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.StartDate Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..StartDate Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the start date.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> StartDate { get; set; }
Visual Basic
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The start date.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.TenantId Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..TenantId Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.TenantIds Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..TenantIds Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the tenant ids.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] TenantIds { get; set; }
Visual Basic
Public Property TenantIds As String()
    Get
    Set
Visual C++
public:
property array<String^>^ TenantIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The tenant ids.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.TotalCount Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..TotalCount Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the total count

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
public int TotalCount { get; set; }
Visual Basic
<ObsoleteAttribute>
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
[ObsoleteAttribute]
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.TrackId Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..TrackId Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the track id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
property String^ TrackId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The track id.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchCondition.UserId Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchCondition..::..UserId Property
NotificationAuditSearchCondition Class See Also Send Feedback
Gets or sets the user id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user id.

See Also

NotificationAuditSearchCondition Class
NotificationAuditSearchCondition Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult Class

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult Class
Members See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class NotificationAuditSearchResult
Visual Basic
Public Class NotificationAuditSearchResult
Visual C++
public ref class NotificationAuditSearchResult

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..NotificationAuditSearchResult

See Also

NotificationAuditSearchResult Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult Members

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult Members
NotificationAuditSearchResult Class Constructors Methods Properties See Also Send Feedback

The NotificationAuditSearchResult type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationAuditSearchResult | Initializes a new instance of the NotificationAuditSearchResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Result |
Public property | TotalCount |

See Also

NotificationAuditSearchResult Class
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult Constructor

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult Constructor
NotificationAuditSearchResult Class See Also Send Feedback
Initializes a new instance of the NotificationAuditSearchResult class

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationAuditSearchResult()
Visual Basic
Public Sub New
Visual C++
public:
NotificationAuditSearchResult()

See Also

NotificationAuditSearchResult Class
NotificationAuditSearchResult Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult Methods
NotificationAuditSearchResult Class See Also Send Feedback

The NotificationAuditSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationAuditSearchResult Class
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult Properties
NotificationAuditSearchResult Class See Also Send Feedback

The NotificationAuditSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Result |
Public property | TotalCount |

See Also

NotificationAuditSearchResult Class
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult.Result Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult..::..Result Property
NotificationAuditSearchResult Class See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<NotificationAudit> Result { get; set; }
Visual Basic
Public Property Result As List(Of NotificationAudit)
    Get
    Set
Visual C++
public:
property List<NotificationAudit^>^ Result {
    List<NotificationAudit^>^ get ();
    void set (List<NotificationAudit^>^ value);
}

Property Value

Type: List<(Of <(<' NotificationAudit >)>)>

See Also

NotificationAuditSearchResult Class
NotificationAuditSearchResult Members
CelloSaaS.Notification.Model Namespace


NotificationAuditSearchResult.TotalCount Property

[image]

A Sandcastle Documented Class Library
NotificationAuditSearchResult..::..TotalCount Property
NotificationAuditSearchResult Class See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Integer
    Get
    Set
Visual C++
public:
property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

NotificationAuditSearchResult Class
NotificationAuditSearchResult Members
CelloSaaS.Notification.Model Namespace


NotificationBatch Class

[image]

A Sandcastle Documented Class Library
NotificationBatch Class
Members See Also Send Feedback
This Model Contain Notification Batch Details.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class NotificationBatch
Visual Basic
Public Class NotificationBatch
Visual C++
public ref class NotificationBatch

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..NotificationBatch

See Also

NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch Members

[image] [image]

A Sandcastle Documented Class Library
NotificationBatch Members
NotificationBatch Class Constructors Methods Properties See Also Send Feedback

The NotificationBatch type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationBatch | Initializes a new instance of the NotificationBatch class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BatchId | Gets or sets the batch id.
Public property | Combine | Gets or sets a value indicating whether this NotificationBatch is combine.
Public property | Comments | Gets or sets the comments.
Public property | ContentType | Gets or sets the type of the content.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DestinationType | Gets or sets the type of the destination.
Public property | DispatchStatus | Gets or sets the dispatched status.
Public property | Priority | Gets or sets the priority.
Public property | Status | Gets or sets the status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

NotificationBatch Class
CelloSaaS.Notification.Model Namespace


NotificationBatch Constructor

[image]

A Sandcastle Documented Class Library
NotificationBatch Constructor
NotificationBatch Class See Also Send Feedback
Initializes a new instance of the NotificationBatch class

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch()
Visual Basic
Public Sub New
Visual C++
public:
NotificationBatch()

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationBatch Methods
NotificationBatch Class See Also Send Feedback

The NotificationBatch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationBatch Class
CelloSaaS.Notification.Model Namespace


NotificationBatch Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationBatch Properties
NotificationBatch Class See Also Send Feedback

The NotificationBatch type exposes the following members.

Properties

 | Name | Description
Public property | BatchId | Gets or sets the batch id.
Public property | Combine | Gets or sets a value indicating whether this NotificationBatch is combine.
Public property | Comments | Gets or sets the comments.
Public property | ContentType | Gets or sets the type of the content.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DestinationType | Gets or sets the type of the destination.
Public property | DispatchStatus | Gets or sets the dispatched status.
Public property | Priority | Gets or sets the priority.
Public property | Status | Gets or sets the status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

NotificationBatch Class
CelloSaaS.Notification.Model Namespace


NotificationBatch.BatchId Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..BatchId Property
NotificationBatch Class See Also Send Feedback
Gets or sets the batch id.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BatchId { get; set; }
Visual Basic
Public Property BatchId As String
    Get
    Set
Visual C++
public:
property String^ BatchId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The batch id.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.Combine Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..Combine Property
NotificationBatch Class See Also Send Feedback
Gets or sets a value indicating whether this NotificationBatch is combine.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Combine { get; set; }
Visual Basic
Public Property Combine As Boolean
    Get
    Set
Visual C++
public:
property bool Combine {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if combine; otherwise, false.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.Comments Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..Comments Property
NotificationBatch Class See Also Send Feedback
Gets or sets the comments.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The comments.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.ContentType Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..ContentType Property
NotificationBatch Class See Also Send Feedback
Gets or sets the type of the content.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Set
Visual C++
public:
property NotificationContentType ContentType {
    NotificationContentType get ();
    void set (NotificationContentType value);
}

Property Value

Type: NotificationContentType
The type of the content.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.CreatedBy Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..CreatedBy Property
NotificationBatch Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.CreatedOn Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..CreatedOn Property
NotificationBatch Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.DestinationType Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..DestinationType Property
NotificationBatch Class See Also Send Feedback
Gets or sets the type of the destination.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType DestinationType { get; set; }
Visual Basic
Public Property DestinationType As NotificationDestinationType
    Get
    Set
Visual C++
public:
property NotificationDestinationType DestinationType {
    NotificationDestinationType get ();
    void set (NotificationDestinationType value);
}

Property Value

Type: NotificationDestinationType
The type of the destination.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.DispatchStatus Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..DispatchStatus Property
NotificationBatch Class See Also Send Feedback
Gets or sets the dispatched status.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DispatchStatus DispatchStatus { get; set; }
Visual Basic
Public Property DispatchStatus As DispatchStatus
    Get
    Set
Visual C++
public:
property DispatchStatus DispatchStatus {
    DispatchStatus get ();
    void set (DispatchStatus value);
}

Property Value

Type: DispatchStatus
The dispatched status.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.Priority Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..Priority Property
NotificationBatch Class See Also Send Feedback
Gets or sets the priority.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Priority Priority { get; set; }
Visual Basic
Public Property Priority As Priority
    Get
    Set
Visual C++
public:
property Priority Priority {
    Priority get ();
    void set (Priority value);
}

Property Value

Type: Priority
The priority.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.Status Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..Status Property
NotificationBatch Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..UpdatedBy Property
NotificationBatch Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationBatch.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
NotificationBatch..::..UpdatedOn Property
NotificationBatch Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

NotificationBatch Class
NotificationBatch Members
CelloSaaS.Notification.Model Namespace


NotificationContentType Enumeration

[image]

A Sandcastle Documented Class Library
NotificationContentType Enumeration
See Also Send Feedback
Notification Content Type

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum NotificationContentType
Visual Basic
Public Enumeration NotificationContentType
Visual C++
public enum class NotificationContentType

Members

Member name | Value | Description
Text | 0 | Text Content Type
BatchText | 1 | Batch Text Content Type
File | 2 | File Content Type
BatchFile | 3 | Batch File Content Type
Report | 4 | Report Content Type
SystemNotification | 5 | System Notification Content Type
BatchSystemNotification | 6 | Batch System Notification Content Type

See Also

CelloSaaS.Notification.Model Namespace


NotificationDestinationType Enumeration

[image]

A Sandcastle Documented Class Library
NotificationDestinationType Enumeration
See Also Send Feedback
Notification Destination Type

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum NotificationDestinationType
Visual Basic
Public Enumeration NotificationDestinationType
Visual C++
public enum class NotificationDestinationType

Members

Member name | Value | Description
Email | 0 | Email Destination Type
BatchEmail | 1 | Batch Email Type
Ftp | 2 | Ftp Destination Type
BatchFtp | 3 | Batch Ftp Type
Sftp | 4 | SFtp Destination Type
BatchSftp | 5 | Batch SFtp Destination Type
Fax | 6 | Fax Destination Type
SystemNotification | 7 | System Notification Destination Type
BatchSystemNotification | 8 | Batch System Notification Destination Type

See Also

CelloSaaS.Notification.Model Namespace


NotificationDetails Class

[image]

A Sandcastle Documented Class Library
NotificationDetails Class
Members See Also Send Feedback
This class contain Notification Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class NotificationDetails
Visual Basic
<SerializableAttribute>
Public Class NotificationDetails
Visual C++
[SerializableAttribute]
public ref class NotificationDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..NotificationDetails

See Also

NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails Members

[image] [image]

A Sandcastle Documented Class Library
NotificationDetails Members
NotificationDetails Class Constructors Methods Properties See Also Send Feedback

The NotificationDetails type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationDetails | Initializes a new instance of the NotificationDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets Notification Category
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Notification Description
Public property | Id | Gets or sets Id
Public property | NotificationContent | Gets or sets Notification Content Details
Public property | NotificationDestination | Gets or sets Notification Destination Details
Public property | NotificationId | Gets or sets Notification Id
Public property | NotificationName | Gets or sets Notification Name
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant identifier
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

NotificationDetails Class
CelloSaaS.Notification.Model Namespace


NotificationDetails Constructor

[image]

A Sandcastle Documented Class Library
NotificationDetails Constructor
NotificationDetails Class See Also Send Feedback
Initializes a new instance of the NotificationDetails class

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDetails()
Visual Basic
Public Sub New
Visual C++
public:
NotificationDetails()

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationDetails Methods
NotificationDetails Class See Also Send Feedback

The NotificationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationDetails Class
CelloSaaS.Notification.Model Namespace


NotificationDetails Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationDetails Properties
NotificationDetails Class See Also Send Feedback

The NotificationDetails type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets Notification Category
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Notification Description
Public property | Id | Gets or sets Id
Public property | NotificationContent | Gets or sets Notification Content Details
Public property | NotificationDestination | Gets or sets Notification Destination Details
Public property | NotificationId | Gets or sets Notification Id
Public property | NotificationName | Gets or sets Notification Name
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant identifier
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

NotificationDetails Class
CelloSaaS.Notification.Model Namespace


NotificationDetails.Category Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..Category Property
NotificationDetails Class See Also Send Feedback
Gets or sets Notification Category

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..CreatedBy Property
NotificationDetails Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..CreatedOn Property
NotificationDetails Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.Description Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..Description Property
NotificationDetails Class See Also Send Feedback
Gets or sets Notification Description

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.Id Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..Id Property
NotificationDetails Class See Also Send Feedback
Gets or sets Id

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.NotificationContent Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..NotificationContent Property
NotificationDetails Class See Also Send Feedback
Gets or sets Notification Content Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationContent NotificationContent { get; set; }
Visual Basic
Public Property NotificationContent As INotificationContent
    Get
    Set
Visual C++
public:
property INotificationContent^ NotificationContent {
    INotificationContent^ get ();
    void set (INotificationContent^ value);
}

Property Value

Type: INotificationContent

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.NotificationDestination Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..NotificationDestination Property
NotificationDetails Class See Also Send Feedback
Gets or sets Notification Destination Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationDestination NotificationDestination { get; set; }
Visual Basic
Public Property NotificationDestination As INotificationDestination
    Get
    Set
Visual C++
public:
property INotificationDestination^ NotificationDestination {
    INotificationDestination^ get ();
    void set (INotificationDestination^ value);
}

Property Value

Type: INotificationDestination

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.NotificationId Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..NotificationId Property
NotificationDetails Class See Also Send Feedback
Gets or sets Notification Id

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationId { get; set; }
Visual Basic
Public Property NotificationId As String
    Get
    Set
Visual C++
public:
property String^ NotificationId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.NotificationName Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..NotificationName Property
NotificationDetails Class See Also Send Feedback
Gets or sets Notification Name

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationName { get; set; }
Visual Basic
Public Property NotificationName As String
    Get
    Set
Visual C++
public:
property String^ NotificationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.Status Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..Status Property
NotificationDetails Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.TenantId Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..TenantId Property
NotificationDetails Class See Also Send Feedback
Gets or sets the tenant identifier

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..UpdatedBy Property
NotificationDetails Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
NotificationDetails..::..UpdatedOn Property
NotificationDetails Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

NotificationDetails Class
NotificationDetails Members
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationPrivilegeConstants
Visual Basic
Public NotInheritable Class NotificationPrivilegeConstants
Visual C++
public ref class NotificationPrivilegeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model..::..NotificationPrivilegeConstants

See Also

NotificationPrivilegeConstants Members
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants Members
NotificationPrivilegeConstants Class Fields See Also Send Feedback

The NotificationPrivilegeConstants type exposes the following members.

Fields

Name | Description
AddNotification |
DeleteNotification |
EditNotification |
ViewNotification |

See Also

NotificationPrivilegeConstants Class
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants Fields
NotificationPrivilegeConstants Class See Also Send Feedback

The NotificationPrivilegeConstants type exposes the following members.

Fields

Name | Description
AddNotification |
DeleteNotification |
EditNotification |
ViewNotification |

See Also

NotificationPrivilegeConstants Class
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants.AddNotification Field

[image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants..::..AddNotification Field
NotificationPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddNotification
Visual Basic
Public Const AddNotification As String
Visual C++
public:
literal String^ AddNotification

Field Value

Type: String

See Also

NotificationPrivilegeConstants Class
NotificationPrivilegeConstants Members
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants.DeleteNotification Field

[image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants..::..DeleteNotification Field
NotificationPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeleteNotification
Visual Basic
Public Const DeleteNotification As String
Visual C++
public:
literal String^ DeleteNotification

Field Value

Type: String

See Also

NotificationPrivilegeConstants Class
NotificationPrivilegeConstants Members
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants.EditNotification Field

[image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants..::..EditNotification Field
NotificationPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditNotification
Visual Basic
Public Const EditNotification As String
Visual C++
public:
literal String^ EditNotification

Field Value

Type: String

See Also

NotificationPrivilegeConstants Class
NotificationPrivilegeConstants Members
CelloSaaS.Notification.Model Namespace


NotificationPrivilegeConstants.ViewNotification Field

[image]

A Sandcastle Documented Class Library
NotificationPrivilegeConstants..::..ViewNotification Field
NotificationPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewNotification
Visual Basic
Public Const ViewNotification As String
Visual C++
public:
literal String^ ViewNotification

Field Value

Type: String

See Also

NotificationPrivilegeConstants Class
NotificationPrivilegeConstants Members
CelloSaaS.Notification.Model Namespace


NotificationStatus Enumeration

[image]

A Sandcastle Documented Class Library
NotificationStatus Enumeration
See Also Send Feedback
Notification Status Details

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum NotificationStatus
Visual Basic
Public Enumeration NotificationStatus
Visual C++
public enum class NotificationStatus

Members

Member name | Value | Description
Open | 0 | Open Status
InProgress | 1 | In progress Status
Success | 2 | Success Status
Failure | 3 | Failure Status

See Also

CelloSaaS.Notification.Model Namespace


Priority Enumeration

[image]

A Sandcastle Documented Class Library
Priority Enumeration
See Also Send Feedback
The priority of the email.

Namespace: CelloSaaS.Notification.Model
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum Priority
Visual Basic
Public Enumeration Priority
Visual C++
public enum class Priority

Members

Member name | Value | Description
High | 0 | Gets or sets the status as High.
Immediate | 1 | Gets or sets the status as Immediate.
Medium | 2 | Gets or sets the status as medium.
Low | 3 | Gets or sets the status as low.

See Also

CelloSaaS.Notification.Model Namespace


CelloSaaS.Notification.Model.Content Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Model.Content Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchFileContent | Represents the batch file content
Public class | BatchSystemNotificationContent | This class contain batch system notification content details
Public class | BatchTextMessageContent | This class contain batch text message content details
Public class | FileContent | This class contain file content details
Public class | FileNotificationTemplate | This class is used to gets or sets file notification template details
Public class | NotificationPlaceholder | This class conation notification place holder details
Public class | SystemNotificationContent | This class contain System Notification content Details
Public class | TextMessageContent | This class contain Text message content Details
Public class | TextMessageNotificationTemplate | This class is used to gets or sets Text message notification template details

Interfaces

 | Interface | Description
Public interface | IBatchNotificationContent | This interface is used to get list of notification content details
Public interface | INotificationContent | This interface is used to get notification content details
Public interface | INotificationTemplate | This interface is used to get notification template details


BatchFileContent Class

[image]

A Sandcastle Documented Class Library
BatchFileContent Class
Members See Also Send Feedback
Represents the batch file content

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BatchFileContent : IBatchNotificationContent,
    INotificationContent
Visual Basic
<SerializableAttribute>
Public Class BatchFileContent
    Implements IBatchNotificationContent, INotificationContent
Visual C++
[SerializableAttribute]
public ref class BatchFileContent : IBatchNotificationContent,
    INotificationContent

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..BatchFileContent

See Also

BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent Members

[image] [image]

A Sandcastle Documented Class Library
BatchFileContent Members
BatchFileContent Class Constructors Methods Properties See Also Send Feedback

The BatchFileContent type exposes the following members.

Constructors

 | Name | Description
Public method | BatchFileContent | Initializes a new instance of the BatchFileContent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchFileContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent Constructor

[image]

A Sandcastle Documented Class Library
BatchFileContent Constructor
BatchFileContent Class See Also Send Feedback
Initializes a new instance of the BatchFileContent class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchFileContent()
Visual Basic
Public Sub New
Visual C++
public:
BatchFileContent()

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent Methods

[image] [image]

A Sandcastle Documented Class Library
BatchFileContent Methods
BatchFileContent Class See Also Send Feedback

The BatchFileContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFileContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent Properties

[image] [image]

A Sandcastle Documented Class Library
BatchFileContent Properties
BatchFileContent Class See Also Send Feedback

The BatchFileContent type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchFileContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.CommonNotificationContent Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..CommonNotificationContent Property
BatchFileContent Class See Also Send Feedback
Gets or sets the content of the common notification.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationContent CommonNotificationContent { get; set; }
Visual Basic
Public Property CommonNotificationContent As INotificationContent
    Get
    Set
Visual C++
public:
virtual property INotificationContent^ CommonNotificationContent {
    INotificationContent^ get () sealed;
    void set (INotificationContent^ value) sealed;
}

Property Value

Type: INotificationContent
The content of the common notification.

Implements

IBatchNotificationContent..::..CommonNotificationContent

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.ContentType Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..ContentType Property
BatchFileContent Class See Also Send Feedback
Gets the Notification Content Type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; private set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Private Set
Visual C++
public:
virtual property NotificationContentType ContentType {
    NotificationContentType get () sealed;
    private: void set (NotificationContentType value) sealed;
}

Property Value

Type: NotificationContentType

Implements

INotificationContent..::..ContentType

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..CreatedBy Property
BatchFileContent Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationContent..::..CreatedBy

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..CreatedOn Property
BatchFileContent Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationContent..::..CreatedOn

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..LocaleId Property
BatchFileContent Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
virtual property String^ LocaleId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The locale id.

Implements

INotificationContent..::..LocaleId

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..NotificationAuditId Property
BatchFileContent Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationAuditId

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.NotificationContent Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..NotificationContent Property
BatchFileContent Class See Also Send Feedback
Gets or sets notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<INotificationContent> NotificationContent { get; set; }
Visual Basic
Public Property NotificationContent As List(Of INotificationContent)
    Get
    Set
Visual C++
public:
virtual property List<INotificationContent^>^ NotificationContent {
    List<INotificationContent^>^ get () sealed;
    void set (List<INotificationContent^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' INotificationContent >)>)>

Implements

IBatchNotificationContent..::..NotificationContent

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..NotificationContentId Property
BatchFileContent Class See Also Send Feedback
Gets or sets the notification content identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationContentId { get; set; }
Visual Basic
Public Property NotificationContentId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationContentId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationContentId

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..Placeholder Property
BatchFileContent Class See Also Send Feedback
Gets or sets the notification place holder details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Public Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
public:
virtual property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get () sealed;
    void set (NotificationPlaceholder^ value) sealed;
}

Property Value

Type: NotificationPlaceholder

Implements

INotificationContent..::..Placeholder

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..RuleSetCode Property
BatchFileContent Class See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
virtual property String^ RuleSetCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The rule set code.

Implements

INotificationContent..::..RuleSetCode

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.Status Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..Status Property
BatchFileContent Class See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

Implements

INotificationContent..::..Status

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.Template Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..Template Property
BatchFileContent Class See Also Send Feedback
Gets or sets Template Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationTemplate Template { get; set; }
Visual Basic
Public Property Template As INotificationTemplate
    Get
    Set
Visual C++
public:
virtual property INotificationTemplate^ Template {
    INotificationTemplate^ get () sealed;
    void set (INotificationTemplate^ value) sealed;
}

Property Value

Type: INotificationTemplate

Implements

INotificationContent..::..Template

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..TemplateId Property
BatchFileContent Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The template id.

Implements

INotificationContent..::..TemplateId

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..UpdatedBy Property
BatchFileContent Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationContent..::..UpdatedBy

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchFileContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchFileContent..::..UpdatedOn Property
BatchFileContent Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationContent..::..UpdatedOn

See Also

BatchFileContent Class
BatchFileContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent Class

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent Class
Members See Also Send Feedback
This class contain batch system notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BatchSystemNotificationContent : IBatchNotificationContent,
    INotificationContent
Visual Basic
<SerializableAttribute>
Public Class BatchSystemNotificationContent
    Implements IBatchNotificationContent, INotificationContent
Visual C++
[SerializableAttribute]
public ref class BatchSystemNotificationContent : IBatchNotificationContent,
    INotificationContent

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..BatchSystemNotificationContent

See Also

BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent Members

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent Members
BatchSystemNotificationContent Class Constructors Methods Properties See Also Send Feedback

The BatchSystemNotificationContent type exposes the following members.

Constructors

 | Name | Description
Public method | BatchSystemNotificationContent | Initializes a new instance of the BatchSystemNotificationContent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Combine | Gets or sets a value indicating whether this IBatchNotificationContent is combine.
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification content type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets template details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchSystemNotificationContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent Constructor

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent Constructor
BatchSystemNotificationContent Class See Also Send Feedback
Initializes a new instance of the BatchSystemNotificationContent class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchSystemNotificationContent()
Visual Basic
Public Sub New
Visual C++
public:
BatchSystemNotificationContent()

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent Methods

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent Methods
BatchSystemNotificationContent Class See Also Send Feedback

The BatchSystemNotificationContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchSystemNotificationContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent Properties

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent Properties
BatchSystemNotificationContent Class See Also Send Feedback

The BatchSystemNotificationContent type exposes the following members.

Properties

 | Name | Description
Public property | Combine | Gets or sets a value indicating whether this IBatchNotificationContent is combine.
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification content type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets template details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchSystemNotificationContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.Combine Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..Combine Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets a value indicating whether this IBatchNotificationContent is combine.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Combine { get; set; }
Visual Basic
Public Property Combine As Boolean
    Get
    Set
Visual C++
public:
property bool Combine {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if combine; otherwise, false.

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.CommonNotificationContent Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..CommonNotificationContent Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the content of the common notification.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationContent CommonNotificationContent { get; set; }
Visual Basic
Public Property CommonNotificationContent As INotificationContent
    Get
    Set
Visual C++
public:
virtual property INotificationContent^ CommonNotificationContent {
    INotificationContent^ get () sealed;
    void set (INotificationContent^ value) sealed;
}

Property Value

Type: INotificationContent
The content of the common notification.

Implements

IBatchNotificationContent..::..CommonNotificationContent

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.Content Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..Content Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets Notification Content Text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder Content { get; set; }
Visual Basic
Public Property Content As StringBuilder
    Get
    Set
Visual C++
public:
property StringBuilder^ Content {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.ContentType Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..ContentType Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets the Notification content type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; private set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Private Set
Visual C++
public:
virtual property NotificationContentType ContentType {
    NotificationContentType get () sealed;
    private: void set (NotificationContentType value) sealed;
}

Property Value

Type: NotificationContentType

Implements

INotificationContent..::..ContentType

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..CreatedBy Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationContent..::..CreatedBy

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..CreatedOn Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationContent..::..CreatedOn

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..LocaleId Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
virtual property String^ LocaleId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The locale id.

Implements

INotificationContent..::..LocaleId

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..NotificationAuditId Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the notification audit identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationAuditId

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.NotificationContent Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..NotificationContent Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<INotificationContent> NotificationContent { get; set; }
Visual Basic
Public Property NotificationContent As List(Of INotificationContent)
    Get
    Set
Visual C++
public:
virtual property List<INotificationContent^>^ NotificationContent {
    List<INotificationContent^>^ get () sealed;
    void set (List<INotificationContent^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' INotificationContent >)>)>

Implements

IBatchNotificationContent..::..NotificationContent

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..NotificationContentId Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the notification content identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationContentId { get; set; }
Visual Basic
Public Property NotificationContentId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationContentId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationContentId

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..Placeholder Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the notification place holder

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Public Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
public:
virtual property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get () sealed;
    void set (NotificationPlaceholder^ value) sealed;
}

Property Value

Type: NotificationPlaceholder

Implements

INotificationContent..::..Placeholder

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.ProcessedContent Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..ProcessedContent Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the processed content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ProcessedContent { get; set; }
Visual Basic
Public Property ProcessedContent As String
    Get
    Set
Visual C++
public:
property String^ ProcessedContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..RuleSetCode Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
virtual property String^ RuleSetCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The rule set code.

Implements

INotificationContent..::..RuleSetCode

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.Status Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..Status Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

Implements

INotificationContent..::..Status

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.Template Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..Template Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets template details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationTemplate Template { get; set; }
Visual Basic
Public Property Template As INotificationTemplate
    Get
    Set
Visual C++
public:
virtual property INotificationTemplate^ Template {
    INotificationTemplate^ get () sealed;
    void set (INotificationTemplate^ value) sealed;
}

Property Value

Type: INotificationTemplate

Implements

INotificationContent..::..Template

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..TemplateId Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The template id.

Implements

INotificationContent..::..TemplateId

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..UpdatedBy Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationContent..::..UpdatedBy

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchSystemNotificationContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContent..::..UpdatedOn Property
BatchSystemNotificationContent Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationContent..::..UpdatedOn

See Also

BatchSystemNotificationContent Class
BatchSystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent Class

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent Class
Members See Also Send Feedback
This class contain batch text message content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BatchTextMessageContent : IBatchNotificationContent,
    INotificationContent
Visual Basic
<SerializableAttribute>
Public Class BatchTextMessageContent
    Implements IBatchNotificationContent, INotificationContent
Visual C++
[SerializableAttribute]
public ref class BatchTextMessageContent : IBatchNotificationContent,
    INotificationContent

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..BatchTextMessageContent

See Also

BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent Members

[image] [image]

A Sandcastle Documented Class Library
BatchTextMessageContent Members
BatchTextMessageContent Class Constructors Methods Properties See Also Send Feedback

The BatchTextMessageContent type exposes the following members.

Constructors

 | Name | Description
Public method | BatchTextMessageContent | Initializes a new instance of the BatchTextMessageContent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Combine | Gets or sets a value indicating whether this IBatchNotificationContent is combine.
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification content type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Subject | Gets or sets the subject.
Public property | Template | Gets or sets template details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchTextMessageContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent Constructor

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent Constructor
BatchTextMessageContent Class See Also Send Feedback
Initializes a new instance of the BatchTextMessageContent class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchTextMessageContent()
Visual Basic
Public Sub New
Visual C++
public:
BatchTextMessageContent()

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent Methods

[image] [image]

A Sandcastle Documented Class Library
BatchTextMessageContent Methods
BatchTextMessageContent Class See Also Send Feedback

The BatchTextMessageContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchTextMessageContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent Properties

[image] [image]

A Sandcastle Documented Class Library
BatchTextMessageContent Properties
BatchTextMessageContent Class See Also Send Feedback

The BatchTextMessageContent type exposes the following members.

Properties

 | Name | Description
Public property | Combine | Gets or sets a value indicating whether this IBatchNotificationContent is combine.
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification content type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Subject | Gets or sets the subject.
Public property | Template | Gets or sets template details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchTextMessageContent Class
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.Combine Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..Combine Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets a value indicating whether this IBatchNotificationContent is combine.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Combine { get; set; }
Visual Basic
Public Property Combine As Boolean
    Get
    Set
Visual C++
public:
property bool Combine {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if combine; otherwise, false.

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.CommonNotificationContent Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..CommonNotificationContent Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the content of the common notification.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationContent CommonNotificationContent { get; set; }
Visual Basic
Public Property CommonNotificationContent As INotificationContent
    Get
    Set
Visual C++
public:
virtual property INotificationContent^ CommonNotificationContent {
    INotificationContent^ get () sealed;
    void set (INotificationContent^ value) sealed;
}

Property Value

Type: INotificationContent
The content of the common notification.

Implements

IBatchNotificationContent..::..CommonNotificationContent

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.Content Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..Content Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets Notification Content Text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder Content { get; set; }
Visual Basic
Public Property Content As StringBuilder
    Get
    Set
Visual C++
public:
property StringBuilder^ Content {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.ContentType Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..ContentType Property
BatchTextMessageContent Class See Also Send Feedback
Gets the Notification content type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; private set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Private Set
Visual C++
public:
virtual property NotificationContentType ContentType {
    NotificationContentType get () sealed;
    private: void set (NotificationContentType value) sealed;
}

Property Value

Type: NotificationContentType

Implements

INotificationContent..::..ContentType

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..CreatedBy Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationContent..::..CreatedBy

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..CreatedOn Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationContent..::..CreatedOn

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..LocaleId Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
virtual property String^ LocaleId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The locale id.

Implements

INotificationContent..::..LocaleId

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..NotificationAuditId Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the notification audit identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationAuditId

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.NotificationContent Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..NotificationContent Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<INotificationContent> NotificationContent { get; set; }
Visual Basic
Public Property NotificationContent As List(Of INotificationContent)
    Get
    Set
Visual C++
public:
virtual property List<INotificationContent^>^ NotificationContent {
    List<INotificationContent^>^ get () sealed;
    void set (List<INotificationContent^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' INotificationContent >)>)>

Implements

IBatchNotificationContent..::..NotificationContent

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..NotificationContentId Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the notification content identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationContentId { get; set; }
Visual Basic
Public Property NotificationContentId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationContentId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationContentId

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..Placeholder Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the notification place holder

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Public Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
public:
virtual property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get () sealed;
    void set (NotificationPlaceholder^ value) sealed;
}

Property Value

Type: NotificationPlaceholder

Implements

INotificationContent..::..Placeholder

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.ProcessedContent Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..ProcessedContent Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the processed content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ProcessedContent { get; set; }
Visual Basic
Public Property ProcessedContent As String
    Get
    Set
Visual C++
public:
property String^ ProcessedContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..RuleSetCode Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
virtual property String^ RuleSetCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The rule set code.

Implements

INotificationContent..::..RuleSetCode

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.Status Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..Status Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

Implements

INotificationContent..::..Status

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.Subject Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..Subject Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the subject.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The subject.

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.Template Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..Template Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets template details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationTemplate Template { get; set; }
Visual Basic
Public Property Template As INotificationTemplate
    Get
    Set
Visual C++
public:
virtual property INotificationTemplate^ Template {
    INotificationTemplate^ get () sealed;
    void set (INotificationTemplate^ value) sealed;
}

Property Value

Type: INotificationTemplate

Implements

INotificationContent..::..Template

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..TemplateId Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The template id.

Implements

INotificationContent..::..TemplateId

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..UpdatedBy Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationContent..::..UpdatedBy

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


BatchTextMessageContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchTextMessageContent..::..UpdatedOn Property
BatchTextMessageContent Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationContent..::..UpdatedOn

See Also

BatchTextMessageContent Class
BatchTextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent Class

[image]

A Sandcastle Documented Class Library
FileContent Class
Members See Also Send Feedback
This class contain file content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FileContent : INotificationContent
Visual Basic
<SerializableAttribute>
Public Class FileContent
    Implements INotificationContent
Visual C++
[SerializableAttribute]
public ref class FileContent : INotificationContent

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..FileContent

See Also

FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent Members

[image] [image]

A Sandcastle Documented Class Library
FileContent Members
FileContent Class Constructors Methods Properties See Also Send Feedback

The FileContent type exposes the following members.

Constructors

 | Name | Description
Public method | FileContent | Initializes a new instance of the FileContent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContentType | Gets the file content type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | FileName | Gets or sets the name of the file.
Public property | FilePath | Gets or sets file path
Public property | FileType | Gets or sets File Type
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

FileContent Class
CelloSaaS.Notification.Model.Content Namespace


FileContent Constructor

[image]

A Sandcastle Documented Class Library
FileContent Constructor
FileContent Class See Also Send Feedback
Initializes a new instance of the FileContent class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FileContent()
Visual Basic
Public Sub New
Visual C++
public:
FileContent()

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent Methods

[image] [image]

A Sandcastle Documented Class Library
FileContent Methods
FileContent Class See Also Send Feedback

The FileContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileContent Class
CelloSaaS.Notification.Model.Content Namespace


FileContent Properties

[image] [image]

A Sandcastle Documented Class Library
FileContent Properties
FileContent Class See Also Send Feedback

The FileContent type exposes the following members.

Properties

 | Name | Description
Public property | ContentType | Gets the file content type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | FileName | Gets or sets the name of the file.
Public property | FilePath | Gets or sets file path
Public property | FileType | Gets or sets File Type
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets the notification place holder details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

FileContent Class
CelloSaaS.Notification.Model.Content Namespace


FileContent.ContentType Property

[image]

A Sandcastle Documented Class Library
FileContent..::..ContentType Property
FileContent Class See Also Send Feedback
Gets the file content type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; private set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Private Set
Visual C++
public:
virtual property NotificationContentType ContentType {
    NotificationContentType get () sealed;
    private: void set (NotificationContentType value) sealed;
}

Property Value

Type: NotificationContentType

Implements

INotificationContent..::..ContentType

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
FileContent..::..CreatedBy Property
FileContent Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationContent..::..CreatedBy

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
FileContent..::..CreatedOn Property
FileContent Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationContent..::..CreatedOn

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.FileName Property

[image]

A Sandcastle Documented Class Library
FileContent..::..FileName Property
FileContent Class See Also Send Feedback
Gets or sets the name of the file.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the file.

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.FilePath Property

[image]

A Sandcastle Documented Class Library
FileContent..::..FilePath Property
FileContent Class See Also Send Feedback
Gets or sets file path

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.FileType Property

[image]

A Sandcastle Documented Class Library
FileContent..::..FileType Property
FileContent Class See Also Send Feedback
Gets or sets File Type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FileType { get; set; }
Visual Basic
Public Property FileType As String
    Get
    Set
Visual C++
public:
property String^ FileType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
FileContent..::..LocaleId Property
FileContent Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
virtual property String^ LocaleId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The locale id.

Implements

INotificationContent..::..LocaleId

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
FileContent..::..NotificationAuditId Property
FileContent Class See Also Send Feedback
Gets or sets the notification audit identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationAuditId

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
FileContent..::..NotificationContentId Property
FileContent Class See Also Send Feedback
Gets or sets the notification content identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationContentId { get; set; }
Visual Basic
Public Property NotificationContentId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationContentId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationContentId

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
FileContent..::..Placeholder Property
FileContent Class See Also Send Feedback
Gets or sets the notification place holder details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Public Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
public:
virtual property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get () sealed;
    void set (NotificationPlaceholder^ value) sealed;
}

Property Value

Type: NotificationPlaceholder

Implements

INotificationContent..::..Placeholder

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
FileContent..::..RuleSetCode Property
FileContent Class See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
virtual property String^ RuleSetCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The rule set code.

Implements

INotificationContent..::..RuleSetCode

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.Status Property

[image]

A Sandcastle Documented Class Library
FileContent..::..Status Property
FileContent Class See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

Implements

INotificationContent..::..Status

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.Template Property

[image]

A Sandcastle Documented Class Library
FileContent..::..Template Property
FileContent Class See Also Send Feedback
Gets or sets Template Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationTemplate Template { get; set; }
Visual Basic
Public Property Template As INotificationTemplate
    Get
    Set
Visual C++
public:
virtual property INotificationTemplate^ Template {
    INotificationTemplate^ get () sealed;
    void set (INotificationTemplate^ value) sealed;
}

Property Value

Type: INotificationTemplate

Implements

INotificationContent..::..Template

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
FileContent..::..TemplateId Property
FileContent Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The template id.

Implements

INotificationContent..::..TemplateId

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
FileContent..::..UpdatedBy Property
FileContent Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationContent..::..UpdatedBy

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
FileContent..::..UpdatedOn Property
FileContent Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationContent..::..UpdatedOn

See Also

FileContent Class
FileContent Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate Class

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate Class
Members See Also Send Feedback
This class is used to gets or sets file notification template details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FileNotificationTemplate : INotificationTemplate
Visual Basic
<SerializableAttribute>
Public Class FileNotificationTemplate
    Implements INotificationTemplate
Visual C++
[SerializableAttribute]
public ref class FileNotificationTemplate : INotificationTemplate

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..FileNotificationTemplate

See Also

FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate Members

[image] [image]

A Sandcastle Documented Class Library
FileNotificationTemplate Members
FileNotificationTemplate Class Constructors Methods Properties See Also Send Feedback

The FileNotificationTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | FileNotificationTemplate | Initializes a new instance of the FileNotificationTemplate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

FileNotificationTemplate Class
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate Constructor

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate Constructor
FileNotificationTemplate Class See Also Send Feedback
Initializes a new instance of the FileNotificationTemplate class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FileNotificationTemplate()
Visual Basic
Public Sub New
Visual C++
public:
FileNotificationTemplate()

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
FileNotificationTemplate Methods
FileNotificationTemplate Class See Also Send Feedback

The FileNotificationTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileNotificationTemplate Class
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
FileNotificationTemplate Properties
FileNotificationTemplate Class See Also Send Feedback

The FileNotificationTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

FileNotificationTemplate Class
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.Category Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..Category Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets the category.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set
Visual C++
public:
virtual property String^ Category {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The category.

Implements

INotificationTemplate..::..Category

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..CreatedBy Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationTemplate..::..CreatedBy

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..CreatedOn Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationTemplate..::..CreatedOn

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.Description Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..Description Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets Template Description

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationTemplate..::..Description

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.Status Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..Status Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationTemplate..::..Status

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.TemplateContentText Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..TemplateContentText Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets template content text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder TemplateContentText { get; set; }
Visual Basic
Public Property TemplateContentText As StringBuilder
    Get
    Set
Visual C++
public:
virtual property StringBuilder^ TemplateContentText {
    StringBuilder^ get () sealed;
    void set (StringBuilder^ value) sealed;
}

Property Value

Type: StringBuilder

Implements

INotificationTemplate..::..TemplateContentText

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..TemplateId Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets Template Identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationTemplate..::..TemplateId

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.TemplateName Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..TemplateName Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets Template Name

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateName { get; set; }
Visual Basic
Public Property TemplateName As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationTemplate..::..TemplateName

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..UpdatedBy Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationTemplate..::..UpdatedBy

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


FileNotificationTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
FileNotificationTemplate..::..UpdatedOn Property
FileNotificationTemplate Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationTemplate..::..UpdatedOn

See Also

FileNotificationTemplate Class
FileNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


IBatchNotificationContent Interface

[image]

A Sandcastle Documented Class Library
IBatchNotificationContent Interface
Members See Also Send Feedback
This interface is used to get list of notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBatchNotificationContent : INotificationContent
Visual Basic
Public Interface IBatchNotificationContent
    Inherits INotificationContent
Visual C++
public interface class IBatchNotificationContent : INotificationContent

See Also

IBatchNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


IBatchNotificationContent Members

[image] [image]

A Sandcastle Documented Class Library
IBatchNotificationContent Members
IBatchNotificationContent Interface Properties See Also Send Feedback

The IBatchNotificationContent type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | ContentType | Gets the Notification Content Type (Inherited from INotificationContent.)
Public property | CreatedBy | Gets or sets the created by. (Inherited from INotificationContent.)
Public property | CreatedOn | Gets or sets the created on. (Inherited from INotificationContent.)
Public property | LocaleId | Gets or sets the locale id. (Inherited from INotificationContent.)
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier (Inherited from INotificationContent.)
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets Notification Content Identifier (Inherited from INotificationContent.)
Public property | Placeholder | Gets or sets the notification place holder details (Inherited from INotificationContent.)
Public property | RuleSetCode | Gets or sets the rule set code. (Inherited from INotificationContent.)
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status. (Inherited from INotificationContent.)
Public property | Template | Gets or sets Template Details (Inherited from INotificationContent.)
Public property | TemplateId | Gets or sets the template id. (Inherited from INotificationContent.)
Public property | UpdatedBy | Gets or sets the updated by. (Inherited from INotificationContent.)
Public property | UpdatedOn | Gets or sets the updated on. (Inherited from INotificationContent.)

See Also

IBatchNotificationContent Interface
CelloSaaS.Notification.Model.Content Namespace


IBatchNotificationContent Properties

[image] [image]

A Sandcastle Documented Class Library
IBatchNotificationContent Properties
IBatchNotificationContent Interface See Also Send Feedback

The IBatchNotificationContent type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationContent | Gets or sets the content of the common notification.
Public property | ContentType | Gets the Notification Content Type (Inherited from INotificationContent.)
Public property | CreatedBy | Gets or sets the created by. (Inherited from INotificationContent.)
Public property | CreatedOn | Gets or sets the created on. (Inherited from INotificationContent.)
Public property | LocaleId | Gets or sets the locale id. (Inherited from INotificationContent.)
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier (Inherited from INotificationContent.)
Public property | NotificationContent | Gets or sets notification content details
Public property | NotificationContentId | Gets or sets Notification Content Identifier (Inherited from INotificationContent.)
Public property | Placeholder | Gets or sets the notification place holder details (Inherited from INotificationContent.)
Public property | RuleSetCode | Gets or sets the rule set code. (Inherited from INotificationContent.)
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status. (Inherited from INotificationContent.)
Public property | Template | Gets or sets Template Details (Inherited from INotificationContent.)
Public property | TemplateId | Gets or sets the template id. (Inherited from INotificationContent.)
Public property | UpdatedBy | Gets or sets the updated by. (Inherited from INotificationContent.)
Public property | UpdatedOn | Gets or sets the updated on. (Inherited from INotificationContent.)

See Also

IBatchNotificationContent Interface
CelloSaaS.Notification.Model.Content Namespace


IBatchNotificationContent.CommonNotificationContent Property

[image]

A Sandcastle Documented Class Library
IBatchNotificationContent..::..CommonNotificationContent Property
IBatchNotificationContent Interface See Also Send Feedback
Gets or sets the content of the common notification.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
INotificationContent CommonNotificationContent { get; set; }
Visual Basic
Property CommonNotificationContent As INotificationContent
    Get
    Set
Visual C++
property INotificationContent^ CommonNotificationContent {
    INotificationContent^ get ();
    void set (INotificationContent^ value);
}

Property Value

Type: INotificationContent
The content of the common notification.

See Also

IBatchNotificationContent Interface
IBatchNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


IBatchNotificationContent.NotificationContent Property

[image]

A Sandcastle Documented Class Library
IBatchNotificationContent..::..NotificationContent Property
IBatchNotificationContent Interface See Also Send Feedback
Gets or sets notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<INotificationContent> NotificationContent { get; set; }
Visual Basic
Property NotificationContent As List(Of INotificationContent)
    Get
    Set
Visual C++
property List<INotificationContent^>^ NotificationContent {
    List<INotificationContent^>^ get ();
    void set (List<INotificationContent^>^ value);
}

Property Value

Type: List<(Of <(<' INotificationContent >)>)>

See Also

IBatchNotificationContent Interface
IBatchNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent Interface

[image]

A Sandcastle Documented Class Library
INotificationContent Interface
Members See Also Send Feedback
This interface is used to get notification content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationContent
Visual Basic
Public Interface INotificationContent
Visual C++
public interface class INotificationContent

See Also

INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent Members

[image] [image]

A Sandcastle Documented Class Library
INotificationContent Members
INotificationContent Interface Properties See Also Send Feedback

The INotificationContent type exposes the following members.

Properties

 | Name | Description
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationContentId | Gets or sets Notification Content Identifier
Public property | Placeholder | Gets or sets the notification place holder details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

INotificationContent Interface
CelloSaaS.Notification.Model.Content Namespace


INotificationContent Properties

[image] [image]

A Sandcastle Documented Class Library
INotificationContent Properties
INotificationContent Interface See Also Send Feedback

The INotificationContent type exposes the following members.

Properties

 | Name | Description
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationContentId | Gets or sets Notification Content Identifier
Public property | Placeholder | Gets or sets the notification place holder details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

INotificationContent Interface
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.ContentType Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..ContentType Property
INotificationContent Interface See Also Send Feedback
Gets the Notification Content Type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationContentType ContentType { get; }
Visual Basic
ReadOnly Property ContentType As NotificationContentType
    Get
Visual C++
property NotificationContentType ContentType {
    NotificationContentType get ();
}

Property Value

Type: NotificationContentType

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..CreatedBy Property
INotificationContent Interface See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreatedBy { get; set; }
Visual Basic
Property CreatedBy As String
    Get
    Set
Visual C++
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..CreatedOn Property
INotificationContent Interface See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DateTime CreatedOn { get; set; }
Visual Basic
Property CreatedOn As DateTime
    Get
    Set
Visual C++
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..LocaleId Property
INotificationContent Interface See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string LocaleId { get; set; }
Visual Basic
Property LocaleId As String
    Get
    Set
Visual C++
property String^ LocaleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The locale id.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..NotificationAuditId Property
INotificationContent Interface See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string NotificationAuditId { get; set; }
Visual Basic
Property NotificationAuditId As String
    Get
    Set
Visual C++
property String^ NotificationAuditId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..NotificationContentId Property
INotificationContent Interface See Also Send Feedback
Gets or sets Notification Content Identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string NotificationContentId { get; set; }
Visual Basic
Property NotificationContentId As String
    Get
    Set
Visual C++
property String^ NotificationContentId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..Placeholder Property
INotificationContent Interface See Also Send Feedback
Gets or sets the notification place holder details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get ();
    void set (NotificationPlaceholder^ value);
}

Property Value

Type: NotificationPlaceholder

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..RuleSetCode Property
INotificationContent Interface See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string RuleSetCode { get; set; }
Visual Basic
Property RuleSetCode As String
    Get
    Set
Visual C++
property String^ RuleSetCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The rule set code.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.Status Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..Status Property
INotificationContent Interface See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Nullable<bool> Status { get; set; }
Visual Basic
Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.Template Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..Template Property
INotificationContent Interface See Also Send Feedback
Gets or sets Template Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
INotificationTemplate Template { get; set; }
Visual Basic
Property Template As INotificationTemplate
    Get
    Set
Visual C++
property INotificationTemplate^ Template {
    INotificationTemplate^ get ();
    void set (INotificationTemplate^ value);
}

Property Value

Type: INotificationTemplate

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..TemplateId Property
INotificationContent Interface See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string TemplateId { get; set; }
Visual Basic
Property TemplateId As String
    Get
    Set
Visual C++
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The template id.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..UpdatedBy Property
INotificationContent Interface See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdatedBy { get; set; }
Visual Basic
Property UpdatedBy As String
    Get
    Set
Visual C++
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
INotificationContent..::..UpdatedOn Property
INotificationContent Interface See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

INotificationContent Interface
INotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate Interface

[image]

A Sandcastle Documented Class Library
INotificationTemplate Interface
Members See Also Send Feedback
This interface is used to get notification template details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationTemplate
Visual Basic
Public Interface INotificationTemplate
Visual C++
public interface class INotificationTemplate

See Also

INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate Members

[image] [image]

A Sandcastle Documented Class Library
INotificationTemplate Members
INotificationTemplate Interface Properties See Also Send Feedback

The INotificationTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

INotificationTemplate Interface
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
INotificationTemplate Properties
INotificationTemplate Interface See Also Send Feedback

The INotificationTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

INotificationTemplate Interface
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.Category Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..Category Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets the category.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string Category { get; set; }
Visual Basic
Property Category As String
    Get
    Set
Visual C++
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The category.

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..CreatedBy Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreatedBy { get; set; }
Visual Basic
Property CreatedBy As String
    Get
    Set
Visual C++
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..CreatedOn Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DateTime CreatedOn { get; set; }
Visual Basic
Property CreatedOn As DateTime
    Get
    Set
Visual C++
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.Description Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..Description Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets Template Description

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string Description { get; set; }
Visual Basic
Property Description As String
    Get
    Set
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.Status Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..Status Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Nullable<bool> Status { get; set; }
Visual Basic
Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.TemplateContentText Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..TemplateContentText Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets template content text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
StringBuilder TemplateContentText { get; set; }
Visual Basic
Property TemplateContentText As StringBuilder
    Get
    Set
Visual C++
property StringBuilder^ TemplateContentText {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..TemplateId Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets Template Identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string TemplateId { get; set; }
Visual Basic
Property TemplateId As String
    Get
    Set
Visual C++
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.TemplateName Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..TemplateName Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets Template Name

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string TemplateName { get; set; }
Visual Basic
Property TemplateName As String
    Get
    Set
Visual C++
property String^ TemplateName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..UpdatedBy Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdatedBy { get; set; }
Visual Basic
Property UpdatedBy As String
    Get
    Set
Visual C++
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


INotificationTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
INotificationTemplate..::..UpdatedOn Property
INotificationTemplate Interface See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

INotificationTemplate Interface
INotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder Class

[image]

A Sandcastle Documented Class Library
NotificationPlaceholder Class
Members See Also Send Feedback
This class conation notification place holder details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class NotificationPlaceholder
Visual Basic
<SerializableAttribute>
Public Class NotificationPlaceholder
Visual C++
[SerializableAttribute]
public ref class NotificationPlaceholder

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..NotificationPlaceholder

See Also

NotificationPlaceholder Members
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder Members

[image] [image]

A Sandcastle Documented Class Library
NotificationPlaceholder Members
NotificationPlaceholder Class Constructors Methods Properties See Also Send Feedback

The NotificationPlaceholder type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationPlaceholder | Initializes a new instance of the NotificationPlaceholder class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Keys | Gets or sets the key values
Public property | ObjectPlaceholders | Gets or sets object place holders
Public property | ObjectValues | Gets or sets the object details

See Also

NotificationPlaceholder Class
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder Constructor

[image]

A Sandcastle Documented Class Library
NotificationPlaceholder Constructor
NotificationPlaceholder Class See Also Send Feedback
Initializes a new instance of the NotificationPlaceholder class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder()
Visual Basic
Public Sub New
Visual C++
public:
NotificationPlaceholder()

See Also

NotificationPlaceholder Class
NotificationPlaceholder Members
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationPlaceholder Methods
NotificationPlaceholder Class See Also Send Feedback

The NotificationPlaceholder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationPlaceholder Class
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationPlaceholder Properties
NotificationPlaceholder Class See Also Send Feedback

The NotificationPlaceholder type exposes the following members.

Properties

 | Name | Description
Public property | Keys | Gets or sets the key values
Public property | ObjectPlaceholders | Gets or sets object place holders
Public property | ObjectValues | Gets or sets the object details

See Also

NotificationPlaceholder Class
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder.Keys Property

[image]

A Sandcastle Documented Class Library
NotificationPlaceholder..::..Keys Property
NotificationPlaceholder Class See Also Send Feedback
Gets or sets the key values

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, string> Keys { get; set; }
Visual Basic
Public Property Keys As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Keys {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, String>)>)>

See Also

NotificationPlaceholder Class
NotificationPlaceholder Members
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder.ObjectPlaceholders Property

[image]

A Sandcastle Documented Class Library
NotificationPlaceholder..::..ObjectPlaceholders Property
NotificationPlaceholder Class See Also Send Feedback
Gets or sets object place holders

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Object[] ObjectPlaceholders { get; set; }
Visual Basic
Public Property ObjectPlaceholders As Object()
    Get
    Set
Visual C++
public:
property array<Object^>^ ObjectPlaceholders {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Property Value

Type: array<Object>[]()[][]

See Also

NotificationPlaceholder Class
NotificationPlaceholder Members
CelloSaaS.Notification.Model.Content Namespace


NotificationPlaceholder.ObjectValues Property

[image]

A Sandcastle Documented Class Library
NotificationPlaceholder..::..ObjectValues Property
NotificationPlaceholder Class See Also Send Feedback
Gets or sets the object details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Object> ObjectValues { get; set; }
Visual Basic
Public Property ObjectValues As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ ObjectValues {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Object>)>)>

See Also

NotificationPlaceholder Class
NotificationPlaceholder Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent Class

[image]

A Sandcastle Documented Class Library
SystemNotificationContent Class
Members See Also Send Feedback
This class contain System Notification content Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SystemNotificationContent : INotificationContent
Visual Basic
<SerializableAttribute>
Public Class SystemNotificationContent
    Implements INotificationContent
Visual C++
[SerializableAttribute]
public ref class SystemNotificationContent : INotificationContent

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..SystemNotificationContent

See Also

SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent Members

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationContent Members
SystemNotificationContent Class Constructors Methods Properties See Also Send Feedback

The SystemNotificationContent type exposes the following members.

Constructors

 | Name | Description
Public method | SystemNotificationContent | Initializes a new instance of the SystemNotificationContent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets Notification Place Holder details
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Notification Content Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationContent Class
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent Constructor

[image]

A Sandcastle Documented Class Library
SystemNotificationContent Constructor
SystemNotificationContent Class See Also Send Feedback
Initializes a new instance of the SystemNotificationContent class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationContent()
Visual Basic
Public Sub New
Visual C++
public:
SystemNotificationContent()

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent Methods

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationContent Methods
SystemNotificationContent Class See Also Send Feedback

The SystemNotificationContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationContent Class
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent Properties

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationContent Properties
SystemNotificationContent Class See Also Send Feedback

The SystemNotificationContent type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets Notification Place Holder details
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Template | Gets or sets Notification Content Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationContent Class
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.Content Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..Content Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets Notification Content Text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder Content { get; set; }
Visual Basic
Public Property Content As StringBuilder
    Get
    Set
Visual C++
public:
property StringBuilder^ Content {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.ContentType Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..ContentType Property
SystemNotificationContent Class See Also Send Feedback
Gets the Notification Content Type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; private set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Private Set
Visual C++
public:
virtual property NotificationContentType ContentType {
    NotificationContentType get () sealed;
    private: void set (NotificationContentType value) sealed;
}

Property Value

Type: NotificationContentType

Implements

INotificationContent..::..ContentType

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..CreatedBy Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationContent..::..CreatedBy

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..CreatedOn Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationContent..::..CreatedOn

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..LocaleId Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
virtual property String^ LocaleId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The locale id.

Implements

INotificationContent..::..LocaleId

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..NotificationAuditId Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the notification audit identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationAuditId

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..NotificationContentId Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the notification content identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationContentId { get; set; }
Visual Basic
Public Property NotificationContentId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationContentId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationContentId

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..Placeholder Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets Notification Place Holder details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Public Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
public:
virtual property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get () sealed;
    void set (NotificationPlaceholder^ value) sealed;
}

Property Value

Type: NotificationPlaceholder

Implements

INotificationContent..::..Placeholder

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.ProcessedContent Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..ProcessedContent Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the processed content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ProcessedContent { get; set; }
Visual Basic
Public Property ProcessedContent As String
    Get
    Set
Visual C++
public:
property String^ ProcessedContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..RuleSetCode Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
virtual property String^ RuleSetCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The rule set code.

Implements

INotificationContent..::..RuleSetCode

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.Status Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..Status Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

Implements

INotificationContent..::..Status

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.Template Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..Template Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets Notification Content Template Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationTemplate Template { get; set; }
Visual Basic
Public Property Template As INotificationTemplate
    Get
    Set
Visual C++
public:
virtual property INotificationTemplate^ Template {
    INotificationTemplate^ get () sealed;
    void set (INotificationTemplate^ value) sealed;
}

Property Value

Type: INotificationTemplate

Implements

INotificationContent..::..Template

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..TemplateId Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The template id.

Implements

INotificationContent..::..TemplateId

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..UpdatedBy Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationContent..::..UpdatedBy

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


SystemNotificationContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationContent..::..UpdatedOn Property
SystemNotificationContent Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationContent..::..UpdatedOn

See Also

SystemNotificationContent Class
SystemNotificationContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent Class

[image]

A Sandcastle Documented Class Library
TextMessageContent Class
Members See Also Send Feedback
This class contain Text message content Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TextMessageContent : INotificationContent
Visual Basic
<SerializableAttribute>
Public Class TextMessageContent
    Implements INotificationContent
Visual C++
[SerializableAttribute]
public ref class TextMessageContent : INotificationContent

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..TextMessageContent

See Also

TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent Members

[image] [image]

A Sandcastle Documented Class Library
TextMessageContent Members
TextMessageContent Class Constructors Methods Properties See Also Send Feedback

The TextMessageContent type exposes the following members.

Constructors

 | Name | Description
Public method | TextMessageContent | Initializes a new instance of the TextMessageContent class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttachmentFileFolderPath | Gets or sets the attachment file folder path
Public property | AttachmentFiles | Gets or sets the attachment file names
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets Notification Place Holder details
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Subject | Gets or sets the subject.
Public property | Template | Gets or sets Notification Content Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TextMessageContent Class
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent Constructor

[image]

A Sandcastle Documented Class Library
TextMessageContent Constructor
TextMessageContent Class See Also Send Feedback
Initializes a new instance of the TextMessageContent class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TextMessageContent()
Visual Basic
Public Sub New
Visual C++
public:
TextMessageContent()

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent Methods

[image] [image]

A Sandcastle Documented Class Library
TextMessageContent Methods
TextMessageContent Class See Also Send Feedback

The TextMessageContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextMessageContent Class
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent Properties

[image] [image]

A Sandcastle Documented Class Library
TextMessageContent Properties
TextMessageContent Class See Also Send Feedback

The TextMessageContent type exposes the following members.

Properties

 | Name | Description
Public property | AttachmentFileFolderPath | Gets or sets the attachment file folder path
Public property | AttachmentFiles | Gets or sets the attachment file names
Public property | Content | Gets or sets Notification Content Text
Public property | ContentType | Gets the Notification Content Type
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | LocaleId | Gets or sets the locale id.
Public property | NotificationAuditId | Gets or sets the notification audit identifier
Public property | NotificationContentId | Gets or sets the notification content identifier
Public property | Placeholder | Gets or sets Notification Place Holder details
Public property | ProcessedContent | Gets or sets the processed content details
Public property | RuleSetCode | Gets or sets the rule set code.
Public property | Status | Gets or sets a value indicating whether this INotificationContent is status.
Public property | Subject | Gets or sets the subject.
Public property | Template | Gets or sets Notification Content Template Details
Public property | TemplateId | Gets or sets the template id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TextMessageContent Class
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.AttachmentFileFolderPath Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..AttachmentFileFolderPath Property
TextMessageContent Class See Also Send Feedback
Gets or sets the attachment file folder path

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttachmentFileFolderPath { get; set; }
Visual Basic
Public Property AttachmentFileFolderPath As String
    Get
    Set
Visual C++
public:
property String^ AttachmentFileFolderPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.AttachmentFiles Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..AttachmentFiles Property
TextMessageContent Class See Also Send Feedback
Gets or sets the attachment file names

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] AttachmentFiles { get; set; }
Visual Basic
Public Property AttachmentFiles As String()
    Get
    Set
Visual C++
public:
property array<String^>^ AttachmentFiles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.Content Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..Content Property
TextMessageContent Class See Also Send Feedback
Gets or sets Notification Content Text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder Content { get; set; }
Visual Basic
Public Property Content As StringBuilder
    Get
    Set
Visual C++
public:
property StringBuilder^ Content {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.ContentType Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..ContentType Property
TextMessageContent Class See Also Send Feedback
Gets the Notification Content Type

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationContentType ContentType { get; private set; }
Visual Basic
Public Property ContentType As NotificationContentType
    Get
    Private Set
Visual C++
public:
virtual property NotificationContentType ContentType {
    NotificationContentType get () sealed;
    private: void set (NotificationContentType value) sealed;
}

Property Value

Type: NotificationContentType

Implements

INotificationContent..::..ContentType

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..CreatedBy Property
TextMessageContent Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationContent..::..CreatedBy

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..CreatedOn Property
TextMessageContent Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationContent..::..CreatedOn

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.LocaleId Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..LocaleId Property
TextMessageContent Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
virtual property String^ LocaleId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The locale id.

Implements

INotificationContent..::..LocaleId

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..NotificationAuditId Property
TextMessageContent Class See Also Send Feedback
Gets or sets the notification audit identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationAuditId

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.NotificationContentId Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..NotificationContentId Property
TextMessageContent Class See Also Send Feedback
Gets or sets the notification content identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationContentId { get; set; }
Visual Basic
Public Property NotificationContentId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationContentId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationContent..::..NotificationContentId

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.Placeholder Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..Placeholder Property
TextMessageContent Class See Also Send Feedback
Gets or sets Notification Place Holder details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationPlaceholder Placeholder { get; set; }
Visual Basic
Public Property Placeholder As NotificationPlaceholder
    Get
    Set
Visual C++
public:
virtual property NotificationPlaceholder^ Placeholder {
    NotificationPlaceholder^ get () sealed;
    void set (NotificationPlaceholder^ value) sealed;
}

Property Value

Type: NotificationPlaceholder

Implements

INotificationContent..::..Placeholder

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.ProcessedContent Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..ProcessedContent Property
TextMessageContent Class See Also Send Feedback
Gets or sets the processed content details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ProcessedContent { get; set; }
Visual Basic
Public Property ProcessedContent As String
    Get
    Set
Visual C++
public:
property String^ ProcessedContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..RuleSetCode Property
TextMessageContent Class See Also Send Feedback
Gets or sets the rule set code.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
virtual property String^ RuleSetCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The rule set code.

Implements

INotificationContent..::..RuleSetCode

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.Status Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..Status Property
TextMessageContent Class See Also Send Feedback
Gets or sets a value indicating whether this INotificationContent is status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
true if status; otherwise, false.

Implements

INotificationContent..::..Status

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.Subject Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..Subject Property
TextMessageContent Class See Also Send Feedback
Gets or sets the subject.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The subject.

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.Template Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..Template Property
TextMessageContent Class See Also Send Feedback
Gets or sets Notification Content Template Details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationTemplate Template { get; set; }
Visual Basic
Public Property Template As INotificationTemplate
    Get
    Set
Visual C++
public:
virtual property INotificationTemplate^ Template {
    INotificationTemplate^ get () sealed;
    void set (INotificationTemplate^ value) sealed;
}

Property Value

Type: INotificationTemplate

Implements

INotificationContent..::..Template

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.TemplateId Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..TemplateId Property
TextMessageContent Class See Also Send Feedback
Gets or sets the template id.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The template id.

Implements

INotificationContent..::..TemplateId

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..UpdatedBy Property
TextMessageContent Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationContent..::..UpdatedBy

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageContent.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TextMessageContent..::..UpdatedOn Property
TextMessageContent Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationContent..::..UpdatedOn

See Also

TextMessageContent Class
TextMessageContent Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate Class

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate Class
Members See Also Send Feedback
This class is used to gets or sets Text message notification template details

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TextMessageNotificationTemplate : INotificationTemplate
Visual Basic
<SerializableAttribute>
Public Class TextMessageNotificationTemplate
    Implements INotificationTemplate
Visual C++
[SerializableAttribute]
public ref class TextMessageNotificationTemplate : INotificationTemplate

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Content..::..TextMessageNotificationTemplate

See Also

TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate Members

[image] [image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate Members
TextMessageNotificationTemplate Class Constructors Methods Properties See Also Send Feedback

The TextMessageNotificationTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | TextMessageNotificationTemplate | Initializes a new instance of the TextMessageNotificationTemplate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TextMessageNotificationTemplate Class
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate Constructor

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate Constructor
TextMessageNotificationTemplate Class See Also Send Feedback
Initializes a new instance of the TextMessageNotificationTemplate class

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TextMessageNotificationTemplate()
Visual Basic
Public Sub New
Visual C++
public:
TextMessageNotificationTemplate()

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate Methods
TextMessageNotificationTemplate Class See Also Send Feedback

The TextMessageNotificationTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextMessageNotificationTemplate Class
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate Properties
TextMessageNotificationTemplate Class See Also Send Feedback

The TextMessageNotificationTemplate type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TextMessageNotificationTemplate Class
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.Category Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..Category Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets the category.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set
Visual C++
public:
virtual property String^ Category {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The category.

Implements

INotificationTemplate..::..Category

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..CreatedBy Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationTemplate..::..CreatedBy

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..CreatedOn Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationTemplate..::..CreatedOn

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.Description Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..Description Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets Template Description

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationTemplate..::..Description

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.Status Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..Status Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationTemplate..::..Status

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.TemplateContentText Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..TemplateContentText Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets template content text

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder TemplateContentText { get; set; }
Visual Basic
Public Property TemplateContentText As StringBuilder
    Get
    Set
Visual C++
public:
virtual property StringBuilder^ TemplateContentText {
    StringBuilder^ get () sealed;
    void set (StringBuilder^ value) sealed;
}

Property Value

Type: StringBuilder

Implements

INotificationTemplate..::..TemplateContentText

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..TemplateId Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets Template Identifier

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationTemplate..::..TemplateId

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.TemplateName Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..TemplateName Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets Template Name

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateName { get; set; }
Visual Basic
Public Property TemplateName As String
    Get
    Set
Visual C++
public:
virtual property String^ TemplateName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationTemplate..::..TemplateName

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..UpdatedBy Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationTemplate..::..UpdatedBy

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


TextMessageNotificationTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TextMessageNotificationTemplate..::..UpdatedOn Property
TextMessageNotificationTemplate Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationTemplate..::..UpdatedOn

See Also

TextMessageNotificationTemplate Class
TextMessageNotificationTemplate Members
CelloSaaS.Notification.Model.Content Namespace


CelloSaaS.Notification.Model.Dispatch Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Model.Dispatch Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchEmailDestination | This class contain batch email destination details
Public class | BatchFtpDestination | This class contain Batch FTP Destination Details
Public class | BatchSystemNotificationDestination | This class contain Batch System Notification Destination details
Public class | EmailDestination | This class contain Email Destination details
Public class | FtpDestination | This class contain ftp destination details
Public class | SystemNotificationDestination | This class contain System Notification Destination details

Interfaces

 | Interface | Description
Public interface | IBatchNotificationDestination | This interface contain the batch notification destination details
Public interface | INotificationDestination | This interface contain notification destination details


BatchEmailDestination Class

[image]

A Sandcastle Documented Class Library
BatchEmailDestination Class
Members See Also Send Feedback
This class contain batch email destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BatchEmailDestination : IBatchNotificationDestination,
    INotificationDestination
Visual Basic
<SerializableAttribute>
Public Class BatchEmailDestination
    Implements IBatchNotificationDestination, INotificationDestination
Visual C++
[SerializableAttribute]
public ref class BatchEmailDestination : IBatchNotificationDestination,
    INotificationDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Dispatch..::..BatchEmailDestination

See Also

BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination Members

[image] [image]

A Sandcastle Documented Class Library
BatchEmailDestination Members
BatchEmailDestination Class Constructors Methods Properties See Also Send Feedback

The BatchEmailDestination type exposes the following members.

Constructors

 | Name | Description
Public method | BatchEmailDestination | Initializes a new instance of the BatchEmailDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationBatchDetails | Gets or sets Notification Batch Details
Public property | NotificationDestinationId | Gets or sets the notification destination identifier
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the notification destination type
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchEmailDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination Constructor

[image]

A Sandcastle Documented Class Library
BatchEmailDestination Constructor
BatchEmailDestination Class See Also Send Feedback
Initializes a new instance of the BatchEmailDestination class

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchEmailDestination()
Visual Basic
Public Sub New
Visual C++
public:
BatchEmailDestination()

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination Methods

[image] [image]

A Sandcastle Documented Class Library
BatchEmailDestination Methods
BatchEmailDestination Class See Also Send Feedback

The BatchEmailDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchEmailDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination Properties

[image] [image]

A Sandcastle Documented Class Library
BatchEmailDestination Properties
BatchEmailDestination Class See Also Send Feedback

The BatchEmailDestination type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationBatchDetails | Gets or sets Notification Batch Details
Public property | NotificationDestinationId | Gets or sets the notification destination identifier
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the notification destination type
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchEmailDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.CommonNotificationDestination Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..CommonNotificationDestination Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the common notification destination.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationDestination CommonNotificationDestination { get; set; }
Visual Basic
Public Property CommonNotificationDestination As INotificationDestination
    Get
    Set
Visual C++
public:
virtual property INotificationDestination^ CommonNotificationDestination {
    INotificationDestination^ get () sealed;
    void set (INotificationDestination^ value) sealed;
}

Property Value

Type: INotificationDestination
The common notification destination.

Implements

IBatchNotificationDestination..::..CommonNotificationDestination

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..CreatedBy Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the added by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The added by.

Implements

INotificationDestination..::..CreatedBy

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..CreatedOn Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the added on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The added on.

Implements

INotificationDestination..::..CreatedOn

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..NotificationAuditId Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationAuditId

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.NotificationBatchDetails Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..NotificationBatchDetails Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets Notification Batch Details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch NotificationBatchDetails { get; set; }
Visual Basic
Public Property NotificationBatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
virtual property NotificationBatch^ NotificationBatchDetails {
    NotificationBatch^ get () sealed;
    void set (NotificationBatch^ value) sealed;
}

Property Value

Type: NotificationBatch

Implements

IBatchNotificationDestination..::..NotificationBatchDetails

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..NotificationDestinationId Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the notification destination identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDestinationId { get; set; }
Visual Basic
Public Property NotificationDestinationId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationDestinationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationDestinationId

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.NotificationDestinations Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..NotificationDestinations Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the notification destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<INotificationDestination> NotificationDestinations { get; set; }
Visual Basic
Public Property NotificationDestinations As List(Of INotificationDestination)
    Get
    Set
Visual C++
public:
virtual property List<INotificationDestination^>^ NotificationDestinations {
    List<INotificationDestination^>^ get () sealed;
    void set (List<INotificationDestination^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' INotificationDestination >)>)>

Implements

IBatchNotificationDestination..::..NotificationDestinations

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..NotificationDestinationType Property
BatchEmailDestination Class See Also Send Feedback
Gets the notification destination type

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; private set; }
Visual Basic
Public Property NotificationDestinationType As NotificationDestinationType
    Get
    Private Set
Visual C++
public:
virtual property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get () sealed;
    private: void set (NotificationDestinationType value) sealed;
}

Property Value

Type: NotificationDestinationType

Implements

INotificationDestination..::..NotificationDestinationType

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.Status Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..Status Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationDestination..::..Status

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..TrackId Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
virtual property String^ TrackId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The notification track id.

Implements

INotificationDestination..::..TrackId

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..UpdatedBy Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationDestination..::..UpdatedBy

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchEmailDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchEmailDestination..::..UpdatedOn Property
BatchEmailDestination Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationDestination..::..UpdatedOn

See Also

BatchEmailDestination Class
BatchEmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination Class

[image]

A Sandcastle Documented Class Library
BatchFtpDestination Class
Members See Also Send Feedback
This class contain Batch FTP Destination Details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchFtpDestination : IBatchNotificationDestination,
    INotificationDestination
Visual Basic
Public Class BatchFtpDestination
    Implements IBatchNotificationDestination, INotificationDestination
Visual C++
public ref class BatchFtpDestination : IBatchNotificationDestination,
    INotificationDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Dispatch..::..BatchFtpDestination

See Also

BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination Members

[image] [image]

A Sandcastle Documented Class Library
BatchFtpDestination Members
BatchFtpDestination Class Constructors Methods Properties See Also Send Feedback

The BatchFtpDestination type exposes the following members.

Constructors

 | Name | Description
Public method | BatchFtpDestination | Initializes a new instance of the BatchFtpDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | FtpAddress | Gets or sets the ftp address
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationBatchDetails | Gets or sets notification batch details
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the Notification Dispatch Type as FTP
Public property | Password | Gets or sets password
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | UserName | Gets or sets user name

See Also

BatchFtpDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination Constructor

[image]

A Sandcastle Documented Class Library
BatchFtpDestination Constructor
BatchFtpDestination Class See Also Send Feedback
Initializes a new instance of the BatchFtpDestination class

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchFtpDestination()
Visual Basic
Public Sub New
Visual C++
public:
BatchFtpDestination()

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination Methods

[image] [image]

A Sandcastle Documented Class Library
BatchFtpDestination Methods
BatchFtpDestination Class See Also Send Feedback

The BatchFtpDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFtpDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination Properties

[image] [image]

A Sandcastle Documented Class Library
BatchFtpDestination Properties
BatchFtpDestination Class See Also Send Feedback

The BatchFtpDestination type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | FtpAddress | Gets or sets the ftp address
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationBatchDetails | Gets or sets notification batch details
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the Notification Dispatch Type as FTP
Public property | Password | Gets or sets password
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | UserName | Gets or sets user name

See Also

BatchFtpDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.CommonNotificationDestination Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..CommonNotificationDestination Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the common notification destination.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationDestination CommonNotificationDestination { get; set; }
Visual Basic
Public Property CommonNotificationDestination As INotificationDestination
    Get
    Set
Visual C++
public:
virtual property INotificationDestination^ CommonNotificationDestination {
    INotificationDestination^ get () sealed;
    void set (INotificationDestination^ value) sealed;
}

Property Value

Type: INotificationDestination
The common notification destination.

Implements

IBatchNotificationDestination..::..CommonNotificationDestination

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..CreatedBy Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the added by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The added by.

Implements

INotificationDestination..::..CreatedBy

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..CreatedOn Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the added on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The added on.

Implements

INotificationDestination..::..CreatedOn

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.FtpAddress Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..FtpAddress Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the ftp address

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpAddress { get; set; }
Visual Basic
Public Property FtpAddress As String
    Get
    Set
Visual C++
public:
property String^ FtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.IsSecured Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..IsSecured Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets a value indicating whether this instance is secured.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsSecured { get; set; }
Visual Basic
Public Property IsSecured As Boolean
    Get
    Set
Visual C++
public:
property bool IsSecured {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is secured; otherwise, false.

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..NotificationAuditId Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationAuditId

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.NotificationBatchDetails Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..NotificationBatchDetails Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets notification batch details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch NotificationBatchDetails { get; set; }
Visual Basic
Public Property NotificationBatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
virtual property NotificationBatch^ NotificationBatchDetails {
    NotificationBatch^ get () sealed;
    void set (NotificationBatch^ value) sealed;
}

Property Value

Type: NotificationBatch

Implements

IBatchNotificationDestination..::..NotificationBatchDetails

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..NotificationDestinationId Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets Notification Destination Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDestinationId { get; set; }
Visual Basic
Public Property NotificationDestinationId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationDestinationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationDestinationId

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.NotificationDestinations Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..NotificationDestinations Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the notification destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<INotificationDestination> NotificationDestinations { get; set; }
Visual Basic
Public Property NotificationDestinations As List(Of INotificationDestination)
    Get
    Set
Visual C++
public:
virtual property List<INotificationDestination^>^ NotificationDestinations {
    List<INotificationDestination^>^ get () sealed;
    void set (List<INotificationDestination^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' INotificationDestination >)>)>

Implements

IBatchNotificationDestination..::..NotificationDestinations

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..NotificationDestinationType Property
BatchFtpDestination Class See Also Send Feedback
Gets the Notification Dispatch Type as FTP

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; }
Visual Basic
Public ReadOnly Property NotificationDestinationType As NotificationDestinationType
    Get
Visual C++
public:
virtual property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get () sealed;
}

Property Value

Type: NotificationDestinationType

Implements

INotificationDestination..::..NotificationDestinationType

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.Password Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..Password Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets password

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.Status Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..Status Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationDestination..::..Status

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..TrackId Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
virtual property String^ TrackId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The notification track id.

Implements

INotificationDestination..::..TrackId

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..UpdatedBy Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationDestination..::..UpdatedBy

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..UpdatedOn Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationDestination..::..UpdatedOn

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchFtpDestination.UserName Property

[image]

A Sandcastle Documented Class Library
BatchFtpDestination..::..UserName Property
BatchFtpDestination Class See Also Send Feedback
Gets or sets user name

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BatchFtpDestination Class
BatchFtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination Class

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination Class
Members See Also Send Feedback
This class contain Batch System Notification Destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BatchSystemNotificationDestination : IBatchNotificationDestination,
    INotificationDestination
Visual Basic
<SerializableAttribute>
Public Class BatchSystemNotificationDestination
    Implements IBatchNotificationDestination, INotificationDestination
Visual C++
[SerializableAttribute]
public ref class BatchSystemNotificationDestination : IBatchNotificationDestination,
    INotificationDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Dispatch..::..BatchSystemNotificationDestination

See Also

BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination Members

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination Members
BatchSystemNotificationDestination Class Constructors Methods Properties See Also Send Feedback

The BatchSystemNotificationDestination type exposes the following members.

Constructors

 | Name | Description
Public method | BatchSystemNotificationDestination | Initializes a new instance of the BatchSystemNotificationDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationBatchDetails | Gets or sets notification batch details
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the notification destination type as System Notification
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchSystemNotificationDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination Constructor

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination Constructor
BatchSystemNotificationDestination Class See Also Send Feedback
Initializes a new instance of the BatchSystemNotificationDestination class

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchSystemNotificationDestination()
Visual Basic
Public Sub New
Visual C++
public:
BatchSystemNotificationDestination()

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination Methods

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination Methods
BatchSystemNotificationDestination Class See Also Send Feedback

The BatchSystemNotificationDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchSystemNotificationDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination Properties

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination Properties
BatchSystemNotificationDestination Class See Also Send Feedback

The BatchSystemNotificationDestination type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationBatchDetails | Gets or sets notification batch details
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the notification destination type as System Notification
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchSystemNotificationDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.CommonNotificationDestination Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..CommonNotificationDestination Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the common notification destination.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public INotificationDestination CommonNotificationDestination { get; set; }
Visual Basic
Public Property CommonNotificationDestination As INotificationDestination
    Get
    Set
Visual C++
public:
virtual property INotificationDestination^ CommonNotificationDestination {
    INotificationDestination^ get () sealed;
    void set (INotificationDestination^ value) sealed;
}

Property Value

Type: INotificationDestination
The common notification destination.

Implements

IBatchNotificationDestination..::..CommonNotificationDestination

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..CreatedBy Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the added by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The added by.

Implements

INotificationDestination..::..CreatedBy

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..CreatedOn Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the added on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The added on.

Implements

INotificationDestination..::..CreatedOn

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..NotificationAuditId Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationAuditId

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.NotificationBatchDetails Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..NotificationBatchDetails Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets notification batch details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch NotificationBatchDetails { get; set; }
Visual Basic
Public Property NotificationBatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
virtual property NotificationBatch^ NotificationBatchDetails {
    NotificationBatch^ get () sealed;
    void set (NotificationBatch^ value) sealed;
}

Property Value

Type: NotificationBatch

Implements

IBatchNotificationDestination..::..NotificationBatchDetails

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..NotificationDestinationId Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets Notification Destination Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDestinationId { get; set; }
Visual Basic
Public Property NotificationDestinationId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationDestinationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationDestinationId

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.NotificationDestinations Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..NotificationDestinations Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the notification destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<INotificationDestination> NotificationDestinations { get; set; }
Visual Basic
Public Property NotificationDestinations As List(Of INotificationDestination)
    Get
    Set
Visual C++
public:
virtual property List<INotificationDestination^>^ NotificationDestinations {
    List<INotificationDestination^>^ get () sealed;
    void set (List<INotificationDestination^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' INotificationDestination >)>)>

Implements

IBatchNotificationDestination..::..NotificationDestinations

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..NotificationDestinationType Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets the notification destination type as System Notification

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; private set; }
Visual Basic
Public Property NotificationDestinationType As NotificationDestinationType
    Get
    Private Set
Visual C++
public:
virtual property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get () sealed;
    private: void set (NotificationDestinationType value) sealed;
}

Property Value

Type: NotificationDestinationType

Implements

INotificationDestination..::..NotificationDestinationType

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.Status Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..Status Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationDestination..::..Status

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..TrackId Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
virtual property String^ TrackId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The notification track id.

Implements

INotificationDestination..::..TrackId

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..UpdatedBy Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationDestination..::..UpdatedBy

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


BatchSystemNotificationDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDestination..::..UpdatedOn Property
BatchSystemNotificationDestination Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationDestination..::..UpdatedOn

See Also

BatchSystemNotificationDestination Class
BatchSystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination Class

[image]

A Sandcastle Documented Class Library
EmailDestination Class
Members See Also Send Feedback
This class contain Email Destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EmailDestination : INotificationDestination
Visual Basic
<SerializableAttribute>
Public Class EmailDestination
    Implements INotificationDestination
Visual C++
[SerializableAttribute]
public ref class EmailDestination : INotificationDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Dispatch..::..EmailDestination

See Also

EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination Members

[image] [image]

A Sandcastle Documented Class Library
EmailDestination Members
EmailDestination Class Constructors Methods Properties See Also Send Feedback

The EmailDestination type exposes the following members.

Constructors

 | Name | Description
Public method | EmailDestination | Initializes a new instance of the EmailDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bcc | Gets or sets the BCC.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EnableSSL | Gets or sets a value indicating whether [enable SSL].
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the notification destination type as Email
Public property | PortNumber | Gets or sets the port number.
Public property | RecipientAddress | Provide the email addressess for the recipient separated by a semi-colon [;].
Public property | SecondaryRecipientAddress | Gets or sets the secondary recipient email address
Public property | SenderAddress | Gets or sets the sender address.
Public property | SmtpAddress | Gets or sets the smtp address
Public property | SmtpPassword | Gets or sets the smtp password
Public property | SmtpUserName | Gets or sets the smtp user name
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

EmailDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination Constructor

[image]

A Sandcastle Documented Class Library
EmailDestination Constructor
EmailDestination Class See Also Send Feedback
Initializes a new instance of the EmailDestination class

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EmailDestination()
Visual Basic
Public Sub New
Visual C++
public:
EmailDestination()

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination Methods

[image] [image]

A Sandcastle Documented Class Library
EmailDestination Methods
EmailDestination Class See Also Send Feedback

The EmailDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination Properties

[image] [image]

A Sandcastle Documented Class Library
EmailDestination Properties
EmailDestination Class See Also Send Feedback

The EmailDestination type exposes the following members.

Properties

 | Name | Description
Public property | Bcc | Gets or sets the BCC.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EnableSSL | Gets or sets a value indicating whether [enable SSL].
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the notification destination type as Email
Public property | PortNumber | Gets or sets the port number.
Public property | RecipientAddress | Provide the email addressess for the recipient separated by a semi-colon [;].
Public property | SecondaryRecipientAddress | Gets or sets the secondary recipient email address
Public property | SenderAddress | Gets or sets the sender address.
Public property | SmtpAddress | Gets or sets the smtp address
Public property | SmtpPassword | Gets or sets the smtp password
Public property | SmtpUserName | Gets or sets the smtp user name
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

EmailDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.Bcc Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..Bcc Property
EmailDestination Class See Also Send Feedback
Gets or sets the BCC.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] Bcc { get; set; }
Visual Basic
Public Property Bcc As String()
    Get
    Set
Visual C++
public:
property array<String^>^ Bcc {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The BCC.

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..CreatedBy Property
EmailDestination Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The created by.

Implements

INotificationDestination..::..CreatedBy

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..CreatedOn Property
EmailDestination Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The created on.

Implements

INotificationDestination..::..CreatedOn

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.EnableSSL Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..EnableSSL Property
EmailDestination Class See Also Send Feedback
Gets or sets a value indicating whether [enable SSL].

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool EnableSSL { get; set; }
Visual Basic
Public Property EnableSSL As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSSL {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [enable SSL]; otherwise, false.

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..NotificationAuditId Property
EmailDestination Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationAuditId

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..NotificationDestinationId Property
EmailDestination Class See Also Send Feedback
Gets or sets Notification Destination Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDestinationId { get; set; }
Visual Basic
Public Property NotificationDestinationId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationDestinationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationDestinationId

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..NotificationDestinationType Property
EmailDestination Class See Also Send Feedback
Gets the notification destination type as Email

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; private set; }
Visual Basic
Public Property NotificationDestinationType As NotificationDestinationType
    Get
    Private Set
Visual C++
public:
virtual property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get () sealed;
    private: void set (NotificationDestinationType value) sealed;
}

Property Value

Type: NotificationDestinationType

Implements

INotificationDestination..::..NotificationDestinationType

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.PortNumber Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..PortNumber Property
EmailDestination Class See Also Send Feedback
Gets or sets the port number.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PortNumber { get; set; }
Visual Basic
Public Property PortNumber As Integer
    Get
    Set
Visual C++
public:
property int PortNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The port number.

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.RecipientAddress Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..RecipientAddress Property
EmailDestination Class See Also Send Feedback
Provide the email addressess for the recipient separated by a semi-colon [;].

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RecipientAddress { get; set; }
Visual Basic
Public Property RecipientAddress As String
    Get
    Set
Visual C++
public:
property String^ RecipientAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.SecondaryRecipientAddress Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..SecondaryRecipientAddress Property
EmailDestination Class See Also Send Feedback
Gets or sets the secondary recipient email address

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] SecondaryRecipientAddress { get; set; }
Visual Basic
Public Property SecondaryRecipientAddress As String()
    Get
    Set
Visual C++
public:
property array<String^>^ SecondaryRecipientAddress {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.SenderAddress Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..SenderAddress Property
EmailDestination Class See Also Send Feedback
Gets or sets the sender address.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SenderAddress { get; set; }
Visual Basic
Public Property SenderAddress As String
    Get
    Set
Visual C++
public:
property String^ SenderAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sender address.

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.SmtpAddress Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..SmtpAddress Property
EmailDestination Class See Also Send Feedback
Gets or sets the smtp address

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpAddress { get; set; }
Visual Basic
Public Property SmtpAddress As String
    Get
    Set
Visual C++
public:
property String^ SmtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.SmtpPassword Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..SmtpPassword Property
EmailDestination Class See Also Send Feedback
Gets or sets the smtp password

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpPassword { get; set; }
Visual Basic
Public Property SmtpPassword As String
    Get
    Set
Visual C++
public:
property String^ SmtpPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.SmtpUserName Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..SmtpUserName Property
EmailDestination Class See Also Send Feedback
Gets or sets the smtp user name

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpUserName { get; set; }
Visual Basic
Public Property SmtpUserName As String
    Get
    Set
Visual C++
public:
property String^ SmtpUserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.Status Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..Status Property
EmailDestination Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationDestination..::..Status

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..TrackId Property
EmailDestination Class See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
virtual property String^ TrackId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The notification track id.

Implements

INotificationDestination..::..TrackId

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..UpdatedBy Property
EmailDestination Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationDestination..::..UpdatedBy

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


EmailDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EmailDestination..::..UpdatedOn Property
EmailDestination Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationDestination..::..UpdatedOn

See Also

EmailDestination Class
EmailDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination Class

[image]

A Sandcastle Documented Class Library
FtpDestination Class
Members See Also Send Feedback
This class contain ftp destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FtpDestination : INotificationDestination
Visual Basic
<SerializableAttribute>
Public Class FtpDestination
    Implements INotificationDestination
Visual C++
[SerializableAttribute]
public ref class FtpDestination : INotificationDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Dispatch..::..FtpDestination

See Also

FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination Members

[image] [image]

A Sandcastle Documented Class Library
FtpDestination Members
FtpDestination Class Constructors Methods Properties See Also Send Feedback

The FtpDestination type exposes the following members.

Constructors

 | Name | Description
Public method | FtpDestination | Initializes a new instance of the FtpDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | FtpAddress | Gets or sets the ftp address
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the Notification Dispatch Type as FTP
Public property | Password | Gets or sets password
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | UserName | Gets or sets user name

See Also

FtpDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination Constructor

[image]

A Sandcastle Documented Class Library
FtpDestination Constructor
FtpDestination Class See Also Send Feedback
Initializes a new instance of the FtpDestination class

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FtpDestination()
Visual Basic
Public Sub New
Visual C++
public:
FtpDestination()

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination Methods

[image] [image]

A Sandcastle Documented Class Library
FtpDestination Methods
FtpDestination Class See Also Send Feedback

The FtpDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FtpDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination Properties

[image] [image]

A Sandcastle Documented Class Library
FtpDestination Properties
FtpDestination Class See Also Send Feedback

The FtpDestination type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | FtpAddress | Gets or sets the ftp address
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the Notification Dispatch Type as FTP
Public property | Password | Gets or sets password
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | UserName | Gets or sets user name

See Also

FtpDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..CreatedBy Property
FtpDestination Class See Also Send Feedback
Gets or sets the added by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The added by.

Implements

INotificationDestination..::..CreatedBy

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..CreatedOn Property
FtpDestination Class See Also Send Feedback
Gets or sets the added on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The added on.

Implements

INotificationDestination..::..CreatedOn

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.FtpAddress Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..FtpAddress Property
FtpDestination Class See Also Send Feedback
Gets or sets the ftp address

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpAddress { get; set; }
Visual Basic
Public Property FtpAddress As String
    Get
    Set
Visual C++
public:
property String^ FtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.IsSecured Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..IsSecured Property
FtpDestination Class See Also Send Feedback
Gets or sets a value indicating whether this instance is secured.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsSecured { get; set; }
Visual Basic
Public Property IsSecured As Boolean
    Get
    Set
Visual C++
public:
property bool IsSecured {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is secured; otherwise, false.

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..NotificationAuditId Property
FtpDestination Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationAuditId

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..NotificationDestinationId Property
FtpDestination Class See Also Send Feedback
Gets or sets Notification Destination Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDestinationId { get; set; }
Visual Basic
Public Property NotificationDestinationId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationDestinationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationDestinationId

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..NotificationDestinationType Property
FtpDestination Class See Also Send Feedback
Gets the Notification Dispatch Type as FTP

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; private set; }
Visual Basic
Public Property NotificationDestinationType As NotificationDestinationType
    Get
    Private Set
Visual C++
public:
virtual property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get () sealed;
    private: void set (NotificationDestinationType value) sealed;
}

Property Value

Type: NotificationDestinationType

Implements

INotificationDestination..::..NotificationDestinationType

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.Password Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..Password Property
FtpDestination Class See Also Send Feedback
Gets or sets password

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.Status Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..Status Property
FtpDestination Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationDestination..::..Status

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..TrackId Property
FtpDestination Class See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
virtual property String^ TrackId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The notification track id.

Implements

INotificationDestination..::..TrackId

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..UpdatedBy Property
FtpDestination Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationDestination..::..UpdatedBy

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..UpdatedOn Property
FtpDestination Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationDestination..::..UpdatedOn

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


FtpDestination.UserName Property

[image]

A Sandcastle Documented Class Library
FtpDestination..::..UserName Property
FtpDestination Class See Also Send Feedback
Gets or sets user name

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

FtpDestination Class
FtpDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


IBatchNotificationDestination Interface

[image]

A Sandcastle Documented Class Library
IBatchNotificationDestination Interface
Members See Also Send Feedback
This interface contain the batch notification destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IBatchNotificationDestination : INotificationDestination
Visual Basic
Public Interface IBatchNotificationDestination
    Inherits INotificationDestination
Visual C++
public interface class IBatchNotificationDestination : INotificationDestination

See Also

IBatchNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


IBatchNotificationDestination Members

[image] [image]

A Sandcastle Documented Class Library
IBatchNotificationDestination Members
IBatchNotificationDestination Interface Properties See Also Send Feedback

The IBatchNotificationDestination type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by. (Inherited from INotificationDestination.)
Public property | CreatedOn | Gets or sets the added on. (Inherited from INotificationDestination.)
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier (Inherited from INotificationDestination.)
Public property | NotificationBatchDetails | Gets or sets notification batch details
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier (Inherited from INotificationDestination.)
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the Notification Dispatch Type (Inherited from INotificationDestination.)
Public property | Status | Gets or sets the status. (Inherited from INotificationDestination.)
Public property | TrackId | Gets or sets the notification track id. (Inherited from INotificationDestination.)
Public property | UpdatedBy | Gets or sets the updated by. (Inherited from INotificationDestination.)
Public property | UpdatedOn | Gets or sets the updated on. (Inherited from INotificationDestination.)

See Also

IBatchNotificationDestination Interface
CelloSaaS.Notification.Model.Dispatch Namespace


IBatchNotificationDestination Properties

[image] [image]

A Sandcastle Documented Class Library
IBatchNotificationDestination Properties
IBatchNotificationDestination Interface See Also Send Feedback

The IBatchNotificationDestination type exposes the following members.

Properties

 | Name | Description
Public property | CommonNotificationDestination | Gets or sets the common notification destination.
Public property | CreatedBy | Gets or sets the added by. (Inherited from INotificationDestination.)
Public property | CreatedOn | Gets or sets the added on. (Inherited from INotificationDestination.)
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier (Inherited from INotificationDestination.)
Public property | NotificationBatchDetails | Gets or sets notification batch details
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier (Inherited from INotificationDestination.)
Public property | NotificationDestinations | Gets or sets the notification destination details
Public property | NotificationDestinationType | Gets the Notification Dispatch Type (Inherited from INotificationDestination.)
Public property | Status | Gets or sets the status. (Inherited from INotificationDestination.)
Public property | TrackId | Gets or sets the notification track id. (Inherited from INotificationDestination.)
Public property | UpdatedBy | Gets or sets the updated by. (Inherited from INotificationDestination.)
Public property | UpdatedOn | Gets or sets the updated on. (Inherited from INotificationDestination.)

See Also

IBatchNotificationDestination Interface
CelloSaaS.Notification.Model.Dispatch Namespace


IBatchNotificationDestination.CommonNotificationDestination Property

[image]

A Sandcastle Documented Class Library
IBatchNotificationDestination..::..CommonNotificationDestination Property
IBatchNotificationDestination Interface See Also Send Feedback
Gets or sets the common notification destination.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
INotificationDestination CommonNotificationDestination { get; set; }
Visual Basic
Property CommonNotificationDestination As INotificationDestination
    Get
    Set
Visual C++
property INotificationDestination^ CommonNotificationDestination {
    INotificationDestination^ get ();
    void set (INotificationDestination^ value);
}

Property Value

Type: INotificationDestination
The common notification destination.

See Also

IBatchNotificationDestination Interface
IBatchNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


IBatchNotificationDestination.NotificationBatchDetails Property

[image]

A Sandcastle Documented Class Library
IBatchNotificationDestination..::..NotificationBatchDetails Property
IBatchNotificationDestination Interface See Also Send Feedback
Gets or sets notification batch details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationBatch NotificationBatchDetails { get; set; }
Visual Basic
Property NotificationBatchDetails As NotificationBatch
    Get
    Set
Visual C++
property NotificationBatch^ NotificationBatchDetails {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch

See Also

IBatchNotificationDestination Interface
IBatchNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


IBatchNotificationDestination.NotificationDestinations Property

[image]

A Sandcastle Documented Class Library
IBatchNotificationDestination..::..NotificationDestinations Property
IBatchNotificationDestination Interface See Also Send Feedback
Gets or sets the notification destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<INotificationDestination> NotificationDestinations { get; set; }
Visual Basic
Property NotificationDestinations As List(Of INotificationDestination)
    Get
    Set
Visual C++
property List<INotificationDestination^>^ NotificationDestinations {
    List<INotificationDestination^>^ get ();
    void set (List<INotificationDestination^>^ value);
}

Property Value

Type: List<(Of <(<' INotificationDestination >)>)>

See Also

IBatchNotificationDestination Interface
IBatchNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination Interface

[image]

A Sandcastle Documented Class Library
INotificationDestination Interface
Members See Also Send Feedback
This interface contain notification destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationDestination
Visual Basic
Public Interface INotificationDestination
Visual C++
public interface class INotificationDestination

See Also

INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination Members

[image] [image]

A Sandcastle Documented Class Library
INotificationDestination Members
INotificationDestination Interface Properties See Also Send Feedback

The INotificationDestination type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the Notification Dispatch Type
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

INotificationDestination Interface
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination Properties

[image] [image]

A Sandcastle Documented Class Library
INotificationDestination Properties
INotificationDestination Interface See Also Send Feedback

The INotificationDestination type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the Notification Dispatch Type
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

INotificationDestination Interface
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..CreatedBy Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the added by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreatedBy { get; set; }
Visual Basic
Property CreatedBy As String
    Get
    Set
Visual C++
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The added by.

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..CreatedOn Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the added on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DateTime CreatedOn { get; set; }
Visual Basic
Property CreatedOn As DateTime
    Get
    Set
Visual C++
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The added on.

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..NotificationAuditId Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string NotificationAuditId { get; set; }
Visual Basic
Property NotificationAuditId As String
    Get
    Set
Visual C++
property String^ NotificationAuditId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..NotificationDestinationId Property
INotificationDestination Interface See Also Send Feedback
Gets or sets Notification Destination Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string NotificationDestinationId { get; set; }
Visual Basic
Property NotificationDestinationId As String
    Get
    Set
Visual C++
property String^ NotificationDestinationId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..NotificationDestinationType Property
INotificationDestination Interface See Also Send Feedback
Gets the Notification Dispatch Type

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDestinationType NotificationDestinationType { get; }
Visual Basic
ReadOnly Property NotificationDestinationType As NotificationDestinationType
    Get
Visual C++
property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get ();
}

Property Value

Type: NotificationDestinationType

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.Status Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..Status Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Nullable<bool> Status { get; set; }
Visual Basic
Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..TrackId Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string TrackId { get; set; }
Visual Basic
Property TrackId As String
    Get
    Set
Visual C++
property String^ TrackId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The notification track id.

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..UpdatedBy Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdatedBy { get; set; }
Visual Basic
Property UpdatedBy As String
    Get
    Set
Visual C++
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


INotificationDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
INotificationDestination..::..UpdatedOn Property
INotificationDestination Interface See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

INotificationDestination Interface
INotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination Class

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination Class
Members See Also Send Feedback
This class contain System Notification Destination details

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SystemNotificationDestination : INotificationDestination
Visual Basic
<SerializableAttribute>
Public Class SystemNotificationDestination
    Implements INotificationDestination
Visual C++
[SerializableAttribute]
public ref class SystemNotificationDestination : INotificationDestination

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Dispatch..::..SystemNotificationDestination

See Also

SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination Members

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDestination Members
SystemNotificationDestination Class Constructors Methods Properties See Also Send Feedback

The SystemNotificationDestination type exposes the following members.

Constructors

 | Name | Description
Public method | SystemNotificationDestination | Initializes a new instance of the SystemNotificationDestination class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | MapId | Gets or sets the map id.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the notification destination type as System Notification
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination Constructor

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination Constructor
SystemNotificationDestination Class See Also Send Feedback
Initializes a new instance of the SystemNotificationDestination class

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationDestination()
Visual Basic
Public Sub New
Visual C++
public:
SystemNotificationDestination()

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination Methods

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDestination Methods
SystemNotificationDestination Class See Also Send Feedback

The SystemNotificationDestination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination Properties

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDestination Properties
SystemNotificationDestination Class See Also Send Feedback

The SystemNotificationDestination type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the added by.
Public property | CreatedOn | Gets or sets the added on.
Public property | MapId | Gets or sets the map id.
Public property | NotificationAuditId | Gets or sets the Notification Audit Identifier
Public property | NotificationDestinationId | Gets or sets Notification Destination Identifier
Public property | NotificationDestinationType | Gets the notification destination type as System Notification
Public property | Status | Gets or sets the status.
Public property | TrackId | Gets or sets the notification track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationDestination Class
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.CreatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..CreatedBy Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the added by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The added by.

Implements

INotificationDestination..::..CreatedBy

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.CreatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..CreatedOn Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the added on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime CreatedOn {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime
The added on.

Implements

INotificationDestination..::..CreatedOn

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.MapId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..MapId Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.NotificationAuditId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..NotificationAuditId Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the Notification Audit Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationAuditId { get; set; }
Visual Basic
Public Property NotificationAuditId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationAuditId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationAuditId

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.NotificationDestinationId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..NotificationDestinationId Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets Notification Destination Identifier

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string NotificationDestinationId { get; set; }
Visual Basic
Public Property NotificationDestinationId As String
    Get
    Set
Visual C++
public:
virtual property String^ NotificationDestinationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INotificationDestination..::..NotificationDestinationId

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.NotificationDestinationType Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..NotificationDestinationType Property
SystemNotificationDestination Class See Also Send Feedback
Gets the notification destination type as System Notification

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDestinationType NotificationDestinationType { get; private set; }
Visual Basic
Public Property NotificationDestinationType As NotificationDestinationType
    Get
    Private Set
Visual C++
public:
virtual property NotificationDestinationType NotificationDestinationType {
    NotificationDestinationType get () sealed;
    private: void set (NotificationDestinationType value) sealed;
}

Property Value

Type: NotificationDestinationType

Implements

INotificationDestination..::..NotificationDestinationType

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.Status Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..Status Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> Status {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

Implements

INotificationDestination..::..Status

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.TrackId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..TrackId Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the notification track id.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
virtual property String^ TrackId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The notification track id.

Implements

INotificationDestination..::..TrackId

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..UpdatedBy Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
virtual property String^ UpdatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The updated by.

Implements

INotificationDestination..::..UpdatedBy

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


SystemNotificationDestination.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDestination..::..UpdatedOn Property
SystemNotificationDestination Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

Implements

INotificationDestination..::..UpdatedOn

See Also

SystemNotificationDestination Class
SystemNotificationDestination Members
CelloSaaS.Notification.Model.Dispatch Namespace


CelloSaaS.Notification.Model.Email Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Model.Email Namespace
Send Feedback

Classes

 | Class | Description
Public class | EmailBatch | This class represents the batch of emails to be processed
Public class | EmailDetails | The class represents the Email object containing all the relevant fields.

Enumerations

 | Enumeration | Description
Public enumeration | EmailStatus | Enum to Denote the status of the Email.


EmailBatch Class

[image]

A Sandcastle Documented Class Library
EmailBatch Class
Members See Also Send Feedback
This class represents the batch of emails to be processed

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class EmailBatch
Visual Basic
Public Class EmailBatch
Visual C++
public ref class EmailBatch

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Email..::..EmailBatch

See Also

EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch Members

[image] [image]

A Sandcastle Documented Class Library
EmailBatch Members
EmailBatch Class Constructors Methods Properties See Also Send Feedback

The EmailBatch type exposes the following members.

Constructors

 | Name | Description
Public method | EmailBatch | Initializes a new instance of the EmailBatch class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuditId | Gets or sets the audit id.
Public property | Category | Gets or sets Category of notification
Public property | Comments | Gets or sets Comments
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Emails | Gets or sets The array of emails to be processed.
Public property | EnableSSL | true : Enables SSL ; False : Disables SSL
Public property | NotificationBatch | Gets or setsNotification batch of the Email Batch.
Public property | PortNumber | Gets or sets the port number.
Public property | Sender | Gets or sets Sender email address common for everyone
Public property | SmtpAddress | Gets or sets Smtp Address
Public property | SmtpPassword | Gets or sets Smtp password
Public property | SmtpUserName | Gets or sets Smtp username
Public property | Status | Gets or sets a value indicating whether this EmailBatch is status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

EmailBatch Class
CelloSaaS.Notification.Model.Email Namespace


EmailBatch Constructor

[image]

A Sandcastle Documented Class Library
EmailBatch Constructor
EmailBatch Class See Also Send Feedback
Initializes a new instance of the EmailBatch class

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EmailBatch()
Visual Basic
Public Sub New
Visual C++
public:
EmailBatch()

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch Methods

[image] [image]

A Sandcastle Documented Class Library
EmailBatch Methods
EmailBatch Class See Also Send Feedback

The EmailBatch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailBatch Class
CelloSaaS.Notification.Model.Email Namespace


EmailBatch Properties

[image] [image]

A Sandcastle Documented Class Library
EmailBatch Properties
EmailBatch Class See Also Send Feedback

The EmailBatch type exposes the following members.

Properties

 | Name | Description
Public property | AuditId | Gets or sets the audit id.
Public property | Category | Gets or sets Category of notification
Public property | Comments | Gets or sets Comments
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Emails | Gets or sets The array of emails to be processed.
Public property | EnableSSL | true : Enables SSL ; False : Disables SSL
Public property | NotificationBatch | Gets or setsNotification batch of the Email Batch.
Public property | PortNumber | Gets or sets the port number.
Public property | Sender | Gets or sets Sender email address common for everyone
Public property | SmtpAddress | Gets or sets Smtp Address
Public property | SmtpPassword | Gets or sets Smtp password
Public property | SmtpUserName | Gets or sets Smtp username
Public property | Status | Gets or sets a value indicating whether this EmailBatch is status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

EmailBatch Class
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.AuditId Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..AuditId Property
EmailBatch Class See Also Send Feedback
Gets or sets the audit id.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AuditId { get; set; }
Visual Basic
Public Property AuditId As String
    Get
    Set
Visual C++
public:
property String^ AuditId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The audit id.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.Category Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..Category Property
EmailBatch Class See Also Send Feedback
Gets or sets Category of notification

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The category.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.Comments Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..Comments Property
EmailBatch Class See Also Send Feedback
Gets or sets Comments

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The comments.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..CreatedBy Property
EmailBatch Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..CreatedOn Property
EmailBatch Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.Emails Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..Emails Property
EmailBatch Class See Also Send Feedback
Gets or sets The array of emails to be processed.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EmailDetails[] Emails { get; set; }
Visual Basic
Public Property Emails As EmailDetails()
    Get
    Set
Visual C++
public:
property array<EmailDetails^>^ Emails {
    array<EmailDetails^>^ get ();
    void set (array<EmailDetails^>^ value);
}

Property Value

Type: array< EmailDetails >[]()[][]
The emails.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.EnableSSL Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..EnableSSL Property
EmailBatch Class See Also Send Feedback
true : Enables SSL ; False : Disables SSL

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool EnableSSL { get; set; }
Visual Basic
Public Property EnableSSL As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSSL {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [enable SSL]; otherwise, false.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.NotificationBatch Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..NotificationBatch Property
EmailBatch Class See Also Send Feedback
Gets or setsNotification batch of the Email Batch.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch NotificationBatch { get; set; }
Visual Basic
Public Property NotificationBatch As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ NotificationBatch {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch
The notification batch.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.PortNumber Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..PortNumber Property
EmailBatch Class See Also Send Feedback
Gets or sets the port number.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PortNumber { get; set; }
Visual Basic
Public Property PortNumber As Integer
    Get
    Set
Visual C++
public:
property int PortNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The port number.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.Sender Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..Sender Property
EmailBatch Class See Also Send Feedback
Gets or sets Sender email address common for everyone

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Sender { get; set; }
Visual Basic
Public Property Sender As String
    Get
    Set
Visual C++
public:
property String^ Sender {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sender.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.SmtpAddress Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..SmtpAddress Property
EmailBatch Class See Also Send Feedback
Gets or sets Smtp Address

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpAddress { get; set; }
Visual Basic
Public Property SmtpAddress As String
    Get
    Set
Visual C++
public:
property String^ SmtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The SMTP address.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.SmtpPassword Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..SmtpPassword Property
EmailBatch Class See Also Send Feedback
Gets or sets Smtp password

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpPassword { get; set; }
Visual Basic
Public Property SmtpPassword As String
    Get
    Set
Visual C++
public:
property String^ SmtpPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The SMTP password.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.SmtpUserName Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..SmtpUserName Property
EmailBatch Class See Also Send Feedback
Gets or sets Smtp username

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpUserName { get; set; }
Visual Basic
Public Property SmtpUserName As String
    Get
    Set
Visual C++
public:
property String^ SmtpUserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the SMTP user.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.Status Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..Status Property
EmailBatch Class See Also Send Feedback
Gets or sets a value indicating whether this EmailBatch is status.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..UpdatedBy Property
EmailBatch Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailBatch.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EmailBatch..::..UpdatedOn Property
EmailBatch Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

EmailBatch Class
EmailBatch Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails Class

[image]

A Sandcastle Documented Class Library
EmailDetails Class
Members See Also Send Feedback
The class represents the Email object containing all the relevant fields.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class EmailDetails
Visual Basic
<SerializableAttribute>
Public Class EmailDetails
Visual C++
[SerializableAttribute]
public ref class EmailDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Email..::..EmailDetails

See Also

EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails Members

[image] [image]

A Sandcastle Documented Class Library
EmailDetails Members
EmailDetails Class Constructors Methods Properties See Also Send Feedback

The EmailDetails type exposes the following members.

Constructors

 | Name | Description
Public method | EmailDetails | Initializes a new instance of the EmailDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttachmentFileFolderPath | Gets or sets the attachment file folder Path
Public property | AttachmentFiles | Gets or sets the attachment file Path
Public property | BatchDetails | Gets or sets the batch details.
Public property | BatchId | Gets or sets Batch Identifier
Public property | Bcc | Gets or sets the BCC.
Public property | Content | Gets or sets the content of the email.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EmailStatus | Gets or sets current Status of the email.
Public property | EnableSSL | Gets or sets a value indicating whether [enable SSL].
Public property | Id | Gets or sets Unique email id to be used for referencing the email.
Public property | PortNumber | Gets or sets the port number.
Public property | Recipient | Provide the email addressess for the recipient separated by a semi-colon [;].
Public property | RuleSetCode | Gets or sets Rule Set Code
Public property | SecondaryRecipient | Gets or sets the CC field value of the email.
Public property | Sender | Gets or sets senders email address.
Public property | SmtpAddress | Gets or sets SMTP server address.
Public property | SmtpPassword | Gets or sets the SMTP password for the server used for sending mail.
Public property | SmtpUserName | Gets or sets the SMTP user name of the server used for sending mail.
Public property | StatusMessage | Gets or sets status message.
Public property | Subject | Gets or sets subject of the email.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

EmailDetails Class
CelloSaaS.Notification.Model.Email Namespace


EmailDetails Constructor

[image]

A Sandcastle Documented Class Library
EmailDetails Constructor
EmailDetails Class See Also Send Feedback
Initializes a new instance of the EmailDetails class

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EmailDetails()
Visual Basic
Public Sub New
Visual C++
public:
EmailDetails()

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails Methods

[image] [image]

A Sandcastle Documented Class Library
EmailDetails Methods
EmailDetails Class See Also Send Feedback

The EmailDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailDetails Class
CelloSaaS.Notification.Model.Email Namespace


EmailDetails Properties

[image] [image]

A Sandcastle Documented Class Library
EmailDetails Properties
EmailDetails Class See Also Send Feedback

The EmailDetails type exposes the following members.

Properties

 | Name | Description
Public property | AttachmentFileFolderPath | Gets or sets the attachment file folder Path
Public property | AttachmentFiles | Gets or sets the attachment file Path
Public property | BatchDetails | Gets or sets the batch details.
Public property | BatchId | Gets or sets Batch Identifier
Public property | Bcc | Gets or sets the BCC.
Public property | Content | Gets or sets the content of the email.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | EmailStatus | Gets or sets current Status of the email.
Public property | EnableSSL | Gets or sets a value indicating whether [enable SSL].
Public property | Id | Gets or sets Unique email id to be used for referencing the email.
Public property | PortNumber | Gets or sets the port number.
Public property | Recipient | Provide the email addressess for the recipient separated by a semi-colon [;].
Public property | RuleSetCode | Gets or sets Rule Set Code
Public property | SecondaryRecipient | Gets or sets the CC field value of the email.
Public property | Sender | Gets or sets senders email address.
Public property | SmtpAddress | Gets or sets SMTP server address.
Public property | SmtpPassword | Gets or sets the SMTP password for the server used for sending mail.
Public property | SmtpUserName | Gets or sets the SMTP user name of the server used for sending mail.
Public property | StatusMessage | Gets or sets status message.
Public property | Subject | Gets or sets subject of the email.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

EmailDetails Class
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.AttachmentFileFolderPath Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..AttachmentFileFolderPath Property
EmailDetails Class See Also Send Feedback
Gets or sets the attachment file folder Path

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AttachmentFileFolderPath { get; set; }
Visual Basic
Public Property AttachmentFileFolderPath As String
    Get
    Set
Visual C++
public:
property String^ AttachmentFileFolderPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.AttachmentFiles Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..AttachmentFiles Property
EmailDetails Class See Also Send Feedback
Gets or sets the attachment file Path

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] AttachmentFiles { get; set; }
Visual Basic
Public Property AttachmentFiles As String()
    Get
    Set
Visual C++
public:
property array<String^>^ AttachmentFiles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.BatchDetails Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..BatchDetails Property
EmailDetails Class See Also Send Feedback
Gets or sets the batch details.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch BatchDetails { get; set; }
Visual Basic
Public Property BatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ BatchDetails {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch
The batch details.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.BatchId Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..BatchId Property
EmailDetails Class See Also Send Feedback
Gets or sets Batch Identifier

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BatchId { get; set; }
Visual Basic
Public Property BatchId As String
    Get
    Set
Visual C++
public:
property String^ BatchId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.Bcc Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..Bcc Property
EmailDetails Class See Also Send Feedback
Gets or sets the BCC.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] Bcc { get; set; }
Visual Basic
Public Property Bcc As String()
    Get
    Set
Visual C++
public:
property array<String^>^ Bcc {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The BCC.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.Content Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..Content Property
EmailDetails Class See Also Send Feedback
Gets or sets the content of the email.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Content { get; set; }
Visual Basic
Public Property Content As String
    Get
    Set
Visual C++
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..CreatedBy Property
EmailDetails Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..CreatedOn Property
EmailDetails Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.EmailStatus Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..EmailStatus Property
EmailDetails Class See Also Send Feedback
Gets or sets current Status of the email.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EmailStatus EmailStatus { get; set; }
Visual Basic
Public Property EmailStatus As EmailStatus
    Get
    Set
Visual C++
public:
property EmailStatus EmailStatus {
    EmailStatus get ();
    void set (EmailStatus value);
}

Property Value

Type: EmailStatus

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.EnableSSL Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..EnableSSL Property
EmailDetails Class See Also Send Feedback
Gets or sets a value indicating whether [enable SSL].

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool EnableSSL { get; set; }
Visual Basic
Public Property EnableSSL As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSSL {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if [enable SSL]; otherwise, false.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.Id Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..Id Property
EmailDetails Class See Also Send Feedback
Gets or sets Unique email id to be used for referencing the email.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.PortNumber Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..PortNumber Property
EmailDetails Class See Also Send Feedback
Gets or sets the port number.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int PortNumber { get; set; }
Visual Basic
Public Property PortNumber As Integer
    Get
    Set
Visual C++
public:
property int PortNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The port number.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.Recipient Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..Recipient Property
EmailDetails Class See Also Send Feedback
Provide the email addressess for the recipient separated by a semi-colon [;].

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Recipient { get; set; }
Visual Basic
Public Property Recipient As String
    Get
    Set
Visual C++
public:
property String^ Recipient {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.RuleSetCode Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..RuleSetCode Property
EmailDetails Class See Also Send Feedback
Gets or sets Rule Set Code

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RuleSetCode { get; set; }
Visual Basic
Public Property RuleSetCode As String
    Get
    Set
Visual C++
public:
property String^ RuleSetCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.SecondaryRecipient Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..SecondaryRecipient Property
EmailDetails Class See Also Send Feedback
Gets or sets the CC field value of the email.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] SecondaryRecipient { get; set; }
Visual Basic
Public Property SecondaryRecipient As String()
    Get
    Set
Visual C++
public:
property array<String^>^ SecondaryRecipient {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.Sender Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..Sender Property
EmailDetails Class See Also Send Feedback
Gets or sets senders email address.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Sender { get; set; }
Visual Basic
Public Property Sender As String
    Get
    Set
Visual C++
public:
property String^ Sender {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.SmtpAddress Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..SmtpAddress Property
EmailDetails Class See Also Send Feedback
Gets or sets SMTP server address.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpAddress { get; set; }
Visual Basic
Public Property SmtpAddress As String
    Get
    Set
Visual C++
public:
property String^ SmtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.SmtpPassword Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..SmtpPassword Property
EmailDetails Class See Also Send Feedback
Gets or sets the SMTP password for the server used for sending mail.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpPassword { get; set; }
Visual Basic
Public Property SmtpPassword As String
    Get
    Set
Visual C++
public:
property String^ SmtpPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.SmtpUserName Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..SmtpUserName Property
EmailDetails Class See Also Send Feedback
Gets or sets the SMTP user name of the server used for sending mail.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SmtpUserName { get; set; }
Visual Basic
Public Property SmtpUserName As String
    Get
    Set
Visual C++
public:
property String^ SmtpUserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.StatusMessage Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..StatusMessage Property
EmailDetails Class See Also Send Feedback
Gets or sets status message.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string StatusMessage { get; set; }
Visual Basic
Public Property StatusMessage As String
    Get
    Set
Visual C++
public:
property String^ StatusMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.Subject Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..Subject Property
EmailDetails Class See Also Send Feedback
Gets or sets subject of the email.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.TrackId Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..TrackId Property
EmailDetails Class See Also Send Feedback
Gets or sets the track id.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
property String^ TrackId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The track id.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..UpdatedBy Property
EmailDetails Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
EmailDetails..::..UpdatedOn Property
EmailDetails Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

EmailDetails Class
EmailDetails Members
CelloSaaS.Notification.Model.Email Namespace


EmailStatus Enumeration

[image]

A Sandcastle Documented Class Library
EmailStatus Enumeration
See Also Send Feedback
Enum to Denote the status of the Email.

Namespace: CelloSaaS.Notification.Model.Email
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum EmailStatus
Visual Basic
Public Enumeration EmailStatus
Visual C++
public enum class EmailStatus

Members

Member name | Value | Description
Open | 0 | Open denote newly entered emails not yet processed.
Queued | 1 | Queued denote mail which is added to some queue and waiting to be processed.
InProgress | 2 | InProgress denotes mail which is send to the dispatcher.
Success | 3 | Success denotes mail which is send successfully.
Failure | 4 | Failure denotes failure to send.

See Also

CelloSaaS.Notification.Model.Email Namespace


CelloSaaS.Notification.Model.Ftp Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Model.Ftp Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchFtp | Represents the batch ftp properties
Public class | FtpDetails | This class contain FTP Details properties

Enumerations

 | Enumeration | Description
Public enumeration | FtpStatus | Ftp Status


BatchFtp Class

[image]

A Sandcastle Documented Class Library
BatchFtp Class
Members See Also Send Feedback
Represents the batch ftp properties

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchFtp
Visual Basic
Public Class BatchFtp
Visual C++
public ref class BatchFtp

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Ftp..::..BatchFtp

See Also

BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp Members

[image] [image]

A Sandcastle Documented Class Library
BatchFtp Members
BatchFtp Class Constructors Methods Properties See Also Send Feedback

The BatchFtp type exposes the following members.

Constructors

 | Name | Description
Public method | BatchFtp | Initializes a new instance of the BatchFtp class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuditId | Gets or sets the audit id.
Public property | Comments | Gets or sets Comments
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | FileName | Gets or sets the name of the file.
Public property | FilePath | Gets or sets the file path.
Public property | FtpAddress | Gets or sets the FTP address.
Public property | FtpDetails | Gets or sets the FTP details.
Public property | FtpPassword | Gets or sets the FTP password.
Public property | FtpUserName | Gets or sets the name of the FTP user.
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | NotificationBatch | Gets or setsNotification batch of the Email Batch.
Public property | Status | Gets or sets a value indicating whether this BatchFtp is status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchFtp Class
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp Constructor

[image]

A Sandcastle Documented Class Library
BatchFtp Constructor
BatchFtp Class See Also Send Feedback
Initializes a new instance of the BatchFtp class

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchFtp()
Visual Basic
Public Sub New
Visual C++
public:
BatchFtp()

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp Methods

[image] [image]

A Sandcastle Documented Class Library
BatchFtp Methods
BatchFtp Class See Also Send Feedback

The BatchFtp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFtp Class
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp Properties

[image] [image]

A Sandcastle Documented Class Library
BatchFtp Properties
BatchFtp Class See Also Send Feedback

The BatchFtp type exposes the following members.

Properties

 | Name | Description
Public property | AuditId | Gets or sets the audit id.
Public property | Comments | Gets or sets Comments
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | FileName | Gets or sets the name of the file.
Public property | FilePath | Gets or sets the file path.
Public property | FtpAddress | Gets or sets the FTP address.
Public property | FtpDetails | Gets or sets the FTP details.
Public property | FtpPassword | Gets or sets the FTP password.
Public property | FtpUserName | Gets or sets the name of the FTP user.
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | NotificationBatch | Gets or setsNotification batch of the Email Batch.
Public property | Status | Gets or sets a value indicating whether this BatchFtp is status.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

BatchFtp Class
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.AuditId Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..AuditId Property
BatchFtp Class See Also Send Feedback
Gets or sets the audit id.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AuditId { get; set; }
Visual Basic
Public Property AuditId As String
    Get
    Set
Visual C++
public:
property String^ AuditId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The audit id.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.Comments Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..Comments Property
BatchFtp Class See Also Send Feedback
Gets or sets Comments

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The comments.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.CreatedBy Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..CreatedBy Property
BatchFtp Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.CreatedOn Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..CreatedOn Property
BatchFtp Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.FileName Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..FileName Property
BatchFtp Class See Also Send Feedback
Gets or sets the name of the file.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the file.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.FilePath Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..FilePath Property
BatchFtp Class See Also Send Feedback
Gets or sets the file path.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The file path.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.FtpAddress Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..FtpAddress Property
BatchFtp Class See Also Send Feedback
Gets or sets the FTP address.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpAddress { get; set; }
Visual Basic
Public Property FtpAddress As String
    Get
    Set
Visual C++
public:
property String^ FtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The FTP address.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.FtpDetails Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..FtpDetails Property
BatchFtp Class See Also Send Feedback
Gets or sets the FTP details.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FtpDetails[] FtpDetails { get; set; }
Visual Basic
Public Property FtpDetails As FtpDetails()
    Get
    Set
Visual C++
public:
property array<FtpDetails^>^ FtpDetails {
    array<FtpDetails^>^ get ();
    void set (array<FtpDetails^>^ value);
}

Property Value

Type: array< FtpDetails >[]()[][]
The FTP details.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.FtpPassword Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..FtpPassword Property
BatchFtp Class See Also Send Feedback
Gets or sets the FTP password.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpPassword { get; set; }
Visual Basic
Public Property FtpPassword As String
    Get
    Set
Visual C++
public:
property String^ FtpPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The FTP password.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.FtpUserName Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..FtpUserName Property
BatchFtp Class See Also Send Feedback
Gets or sets the name of the FTP user.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpUserName { get; set; }
Visual Basic
Public Property FtpUserName As String
    Get
    Set
Visual C++
public:
property String^ FtpUserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the FTP user.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.IsSecured Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..IsSecured Property
BatchFtp Class See Also Send Feedback
Gets or sets a value indicating whether this instance is secured.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsSecured { get; set; }
Visual Basic
Public Property IsSecured As Boolean
    Get
    Set
Visual C++
public:
property bool IsSecured {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is secured; otherwise, false.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.NotificationBatch Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..NotificationBatch Property
BatchFtp Class See Also Send Feedback
Gets or setsNotification batch of the Email Batch.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch NotificationBatch { get; set; }
Visual Basic
Public Property NotificationBatch As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ NotificationBatch {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch
The notification batch.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.Status Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..Status Property
BatchFtp Class See Also Send Feedback
Gets or sets a value indicating whether this BatchFtp is status.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..UpdatedBy Property
BatchFtp Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


BatchFtp.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
BatchFtp..::..UpdatedOn Property
BatchFtp Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

BatchFtp Class
BatchFtp Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails Class

[image]

A Sandcastle Documented Class Library
FtpDetails Class
Members See Also Send Feedback
This class contain FTP Details properties

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FtpDetails
Visual Basic
<SerializableAttribute>
Public Class FtpDetails
Visual C++
[SerializableAttribute]
public ref class FtpDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.Ftp..::..FtpDetails

See Also

FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails Members

[image] [image]

A Sandcastle Documented Class Library
FtpDetails Members
FtpDetails Class Constructors Methods Properties See Also Send Feedback

The FtpDetails type exposes the following members.

Constructors

 | Name | Description
Public method | FtpDetails | Initializes a new instance of the FtpDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BatchDetails | Gets or sets the batch details.
Public property | BatchId | Gets or sets the batch identifier.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | FileName | Gets or sets the name of the file.
Public property | FilePath | Gets or sets the file path.
Public property | FtpAddress | Gets or sets the FTP address.
Public property | FtpPassword | Gets or sets the FTP password.
Public property | FtpStatus | Gets or sets the FTP status.
Public property | FtpUserName | Gets or sets the name of the FTP user.
Public property | Id | Gets or sets the identifier.
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | StatusMessage | Gets or sets the status message.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

FtpDetails Class
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails Constructor

[image]

A Sandcastle Documented Class Library
FtpDetails Constructor
FtpDetails Class See Also Send Feedback
Initializes a new instance of the FtpDetails class

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FtpDetails()
Visual Basic
Public Sub New
Visual C++
public:
FtpDetails()

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails Methods

[image] [image]

A Sandcastle Documented Class Library
FtpDetails Methods
FtpDetails Class See Also Send Feedback

The FtpDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FtpDetails Class
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails Properties

[image] [image]

A Sandcastle Documented Class Library
FtpDetails Properties
FtpDetails Class See Also Send Feedback

The FtpDetails type exposes the following members.

Properties

 | Name | Description
Public property | BatchDetails | Gets or sets the batch details.
Public property | BatchId | Gets or sets the batch identifier.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | FileName | Gets or sets the name of the file.
Public property | FilePath | Gets or sets the file path.
Public property | FtpAddress | Gets or sets the FTP address.
Public property | FtpPassword | Gets or sets the FTP password.
Public property | FtpStatus | Gets or sets the FTP status.
Public property | FtpUserName | Gets or sets the name of the FTP user.
Public property | Id | Gets or sets the identifier.
Public property | IsSecured | Gets or sets a value indicating whether this instance is secured.
Public property | StatusMessage | Gets or sets the status message.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

FtpDetails Class
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.BatchDetails Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..BatchDetails Property
FtpDetails Class See Also Send Feedback
Gets or sets the batch details.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch BatchDetails { get; set; }
Visual Basic
Public Property BatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ BatchDetails {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch
The batch details.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.BatchId Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..BatchId Property
FtpDetails Class See Also Send Feedback
Gets or sets the batch identifier.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BatchId { get; set; }
Visual Basic
Public Property BatchId As String
    Get
    Set
Visual C++
public:
property String^ BatchId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The batch identifier.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..CreatedBy Property
FtpDetails Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..CreatedOn Property
FtpDetails Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.FileName Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..FileName Property
FtpDetails Class See Also Send Feedback
Gets or sets the name of the file.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the file.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.FilePath Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..FilePath Property
FtpDetails Class See Also Send Feedback
Gets or sets the file path.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The file path.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.FtpAddress Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..FtpAddress Property
FtpDetails Class See Also Send Feedback
Gets or sets the FTP address.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpAddress { get; set; }
Visual Basic
Public Property FtpAddress As String
    Get
    Set
Visual C++
public:
property String^ FtpAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The FTP address.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.FtpPassword Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..FtpPassword Property
FtpDetails Class See Also Send Feedback
Gets or sets the FTP password.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpPassword { get; set; }
Visual Basic
Public Property FtpPassword As String
    Get
    Set
Visual C++
public:
property String^ FtpPassword {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The FTP password.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.FtpStatus Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..FtpStatus Property
FtpDetails Class See Also Send Feedback
Gets or sets the FTP status.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FtpStatus FtpStatus { get; set; }
Visual Basic
Public Property FtpStatus As FtpStatus
    Get
    Set
Visual C++
public:
property FtpStatus FtpStatus {
    FtpStatus get ();
    void set (FtpStatus value);
}

Property Value

Type: FtpStatus
The FTP status.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.FtpUserName Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..FtpUserName Property
FtpDetails Class See Also Send Feedback
Gets or sets the name of the FTP user.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FtpUserName { get; set; }
Visual Basic
Public Property FtpUserName As String
    Get
    Set
Visual C++
public:
property String^ FtpUserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the FTP user.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.Id Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..Id Property
FtpDetails Class See Also Send Feedback
Gets or sets the identifier.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The identifier.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.IsSecured Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..IsSecured Property
FtpDetails Class See Also Send Feedback
Gets or sets a value indicating whether this instance is secured.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsSecured { get; set; }
Visual Basic
Public Property IsSecured As Boolean
    Get
    Set
Visual C++
public:
property bool IsSecured {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is secured; otherwise, false.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.StatusMessage Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..StatusMessage Property
FtpDetails Class See Also Send Feedback
Gets or sets the status message.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string StatusMessage { get; set; }
Visual Basic
Public Property StatusMessage As String
    Get
    Set
Visual C++
public:
property String^ StatusMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The status message.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.TrackId Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..TrackId Property
FtpDetails Class See Also Send Feedback
Gets or sets the track id.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
property String^ TrackId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The track id.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..UpdatedBy Property
FtpDetails Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
FtpDetails..::..UpdatedOn Property
FtpDetails Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

FtpDetails Class
FtpDetails Members
CelloSaaS.Notification.Model.Ftp Namespace


FtpStatus Enumeration

[image]

A Sandcastle Documented Class Library
FtpStatus Enumeration
See Also Send Feedback
Ftp Status

Namespace: CelloSaaS.Notification.Model.Ftp
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum FtpStatus
Visual Basic
Public Enumeration FtpStatus
Visual C++
public enum class FtpStatus

Members

Member name | Value | Description
Open | 0 | Open denote newly entered files not yet processed.
Queued | 1 | Queued denote file which is added to some queue and waiting to be processed.
InProgress | 2 | InProgress denotes file which is uploaded to the dispatcher.
Success | 3 | Success denotes file which is uploaded successfully.
Failure | 4 | Failure denotes failure to send.

See Also

CelloSaaS.Notification.Model.Ftp Namespace


CelloSaaS.Notification.Model.SystemNotification Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.Model.SystemNotification Namespace
Send Feedback

Classes

 | Class | Description
Public class | SystemNotificationBatch | This class contains the system notification batch details.
Public class | SystemNotificationDetails | This class contains system notification details.

Enumerations

 | Enumeration | Description
Public enumeration | SystemNotificationStatus | Enum to Denote the status of the SystemNotification.


SystemNotificationBatch Class

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch Class
Members See Also Send Feedback
This class contains the system notification batch details.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SystemNotificationBatch
Visual Basic
<SerializableAttribute>
Public Class SystemNotificationBatch
Visual C++
[SerializableAttribute]
public ref class SystemNotificationBatch

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.SystemNotification..::..SystemNotificationBatch

See Also

SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch Members

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationBatch Members
SystemNotificationBatch Class Constructors Methods Properties See Also Send Feedback

The SystemNotificationBatch type exposes the following members.

Constructors

 | Name | Description
Public method | SystemNotificationBatch | Initializes a new instance of the SystemNotificationBatch class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AuditId | Gets or sets Unique system notification id to be used for referencing the system notification.
Public property | BatchId | Gets or sets the batch id.
Public property | Content | Gets or sets the content.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | MapId | Gets or sets the map id.
Public property | NotificationBatch | Gets or setsNotification batch of the Email Batch.
Public property | SystemNotifications | Gets or sets The array of emails to be processed.
Public property | SystemNotificationStatus | Gets or sets current Status of the system notification.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationBatch Class
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch Constructor

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch Constructor
SystemNotificationBatch Class See Also Send Feedback
Initializes a new instance of the SystemNotificationBatch class

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationBatch()
Visual Basic
Public Sub New
Visual C++
public:
SystemNotificationBatch()

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch Methods

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationBatch Methods
SystemNotificationBatch Class See Also Send Feedback

The SystemNotificationBatch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationBatch Class
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch Properties

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationBatch Properties
SystemNotificationBatch Class See Also Send Feedback

The SystemNotificationBatch type exposes the following members.

Properties

 | Name | Description
Public property | AuditId | Gets or sets Unique system notification id to be used for referencing the system notification.
Public property | BatchId | Gets or sets the batch id.
Public property | Content | Gets or sets the content.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | MapId | Gets or sets the map id.
Public property | NotificationBatch | Gets or setsNotification batch of the Email Batch.
Public property | SystemNotifications | Gets or sets The array of emails to be processed.
Public property | SystemNotificationStatus | Gets or sets current Status of the system notification.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationBatch Class
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.AuditId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..AuditId Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets Unique system notification id to be used for referencing the system notification.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AuditId { get; set; }
Visual Basic
Public Property AuditId As String
    Get
    Set
Visual C++
public:
property String^ AuditId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.BatchId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..BatchId Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the batch id.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BatchId { get; set; }
Visual Basic
Public Property BatchId As String
    Get
    Set
Visual C++
public:
property String^ BatchId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The batch id.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.Content Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..Content Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the content.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Content { get; set; }
Visual Basic
Public Property Content As String
    Get
    Set
Visual C++
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The content.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.CreatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..CreatedBy Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.CreatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..CreatedOn Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.MapId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..MapId Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.NotificationBatch Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..NotificationBatch Property
SystemNotificationBatch Class See Also Send Feedback
Gets or setsNotification batch of the Email Batch.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch NotificationBatch { get; set; }
Visual Basic
Public Property NotificationBatch As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ NotificationBatch {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch
The notification batch.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.SystemNotifications Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..SystemNotifications Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets The array of emails to be processed.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationDetails[] SystemNotifications { get; set; }
Visual Basic
Public Property SystemNotifications As SystemNotificationDetails()
    Get
    Set
Visual C++
public:
property array<SystemNotificationDetails^>^ SystemNotifications {
    array<SystemNotificationDetails^>^ get ();
    void set (array<SystemNotificationDetails^>^ value);
}

Property Value

Type: array< SystemNotificationDetails >[]()[][]
The system notifications.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.SystemNotificationStatus Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..SystemNotificationStatus Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets current Status of the system notification.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationStatus SystemNotificationStatus { get; set; }
Visual Basic
Public Property SystemNotificationStatus As SystemNotificationStatus
    Get
    Set
Visual C++
public:
property SystemNotificationStatus SystemNotificationStatus {
    SystemNotificationStatus get ();
    void set (SystemNotificationStatus value);
}

Property Value

Type: SystemNotificationStatus

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.TrackId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..TrackId Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the track id.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
property String^ TrackId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The track id.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..UpdatedBy Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationBatch.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationBatch..::..UpdatedOn Property
SystemNotificationBatch Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

SystemNotificationBatch Class
SystemNotificationBatch Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails Class

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails Class
Members See Also Send Feedback
This class contains system notification details.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SystemNotificationDetails
Visual Basic
<SerializableAttribute>
Public Class SystemNotificationDetails
Visual C++
[SerializableAttribute]
public ref class SystemNotificationDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.Model.SystemNotification..::..SystemNotificationDetails

See Also

SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails Members

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDetails Members
SystemNotificationDetails Class Constructors Methods Properties See Also Send Feedback

The SystemNotificationDetails type exposes the following members.

Constructors

 | Name | Description
Public method | SystemNotificationDetails | Initializes a new instance of the SystemNotificationDetails class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BatchDetails | Gets or sets the batch details.
Public property | BatchId | Gets or sets Batch Identifier
Public property | Content | Gets or sets the content.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Id | Gets or sets Unique system notification id to be used for referencing the system notification.
Public property | MapId | Gets or sets the map id.
Public property | StatusMessage | Gets or sets the status message.
Public property | SystemNotificationStatus | Gets or sets current Status of the email.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationDetails Class
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails Constructor

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails Constructor
SystemNotificationDetails Class See Also Send Feedback
Initializes a new instance of the SystemNotificationDetails class

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationDetails()
Visual Basic
Public Sub New
Visual C++
public:
SystemNotificationDetails()

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails Methods

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDetails Methods
SystemNotificationDetails Class See Also Send Feedback

The SystemNotificationDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationDetails Class
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails Properties

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDetails Properties
SystemNotificationDetails Class See Also Send Feedback

The SystemNotificationDetails type exposes the following members.

Properties

 | Name | Description
Public property | BatchDetails | Gets or sets the batch details.
Public property | BatchId | Gets or sets Batch Identifier
Public property | Content | Gets or sets the content.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Id | Gets or sets Unique system notification id to be used for referencing the system notification.
Public property | MapId | Gets or sets the map id.
Public property | StatusMessage | Gets or sets the status message.
Public property | SystemNotificationStatus | Gets or sets current Status of the email.
Public property | TrackId | Gets or sets the track id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

SystemNotificationDetails Class
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.BatchDetails Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..BatchDetails Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the batch details.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationBatch BatchDetails { get; set; }
Visual Basic
Public Property BatchDetails As NotificationBatch
    Get
    Set
Visual C++
public:
property NotificationBatch^ BatchDetails {
    NotificationBatch^ get ();
    void set (NotificationBatch^ value);
}

Property Value

Type: NotificationBatch
The batch details.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.BatchId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..BatchId Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets Batch Identifier

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string BatchId { get; set; }
Visual Basic
Public Property BatchId As String
    Get
    Set
Visual C++
public:
property String^ BatchId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.Content Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..Content Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the content.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Content { get; set; }
Visual Basic
Public Property Content As String
    Get
    Set
Visual C++
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The content.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..CreatedBy Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..CreatedOn Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.Id Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..Id Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets Unique system notification id to be used for referencing the system notification.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.MapId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..MapId Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.StatusMessage Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..StatusMessage Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the status message.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string StatusMessage { get; set; }
Visual Basic
Public Property StatusMessage As String
    Get
    Set
Visual C++
public:
property String^ StatusMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The status message.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.SystemNotificationStatus Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..SystemNotificationStatus Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets current Status of the email.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationStatus SystemNotificationStatus { get; set; }
Visual Basic
Public Property SystemNotificationStatus As SystemNotificationStatus
    Get
    Set
Visual C++
public:
property SystemNotificationStatus SystemNotificationStatus {
    SystemNotificationStatus get ();
    void set (SystemNotificationStatus value);
}

Property Value

Type: SystemNotificationStatus

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.TrackId Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..TrackId Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the track id.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TrackId { get; set; }
Visual Basic
Public Property TrackId As String
    Get
    Set
Visual C++
public:
property String^ TrackId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The track id.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..UpdatedBy Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
SystemNotificationDetails..::..UpdatedOn Property
SystemNotificationDetails Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

SystemNotificationDetails Class
SystemNotificationDetails Members
CelloSaaS.Notification.Model.SystemNotification Namespace


SystemNotificationStatus Enumeration

[image]

A Sandcastle Documented Class Library
SystemNotificationStatus Enumeration
See Also Send Feedback
Enum to Denote the status of the SystemNotification.

Namespace: CelloSaaS.Notification.Model.SystemNotification
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum SystemNotificationStatus
Visual Basic
Public Enumeration SystemNotificationStatus
Visual C++
public enum class SystemNotificationStatus

Members

Member name | Value | Description
Open | 0 | Open denote newly entered systemNotification not yet processed.
Queued | 1 | Queued denote systemNotification which is added to some queue and waiting to be processed.
InProgress | 2 | InProgress denotes systemNotification which is send to the dispatcher.
Success | 3 | Success denotes systemNotification which is send successfully.
Failure | 4 | Failure denotes failure to send.

See Also

CelloSaaS.Notification.Model.SystemNotification Namespace


CelloSaaS.Notification.NotificationManager Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.NotificationManager Namespace
Send Feedback

Classes

 | Class | Description
Public class | DefaultNotificationDetailsManager | This class is used to get notification details
Public class | DuplicateNotificationNameException |
Public class | NotificationAuditManager | Represents the notification audit manager
Public class | NotificationException | Represents errors that occur during notification manager execution.
Public class | NotificationManagerDetails | This class is used to manage notification details

Interfaces

 | Interface | Description
Public interface | INotificationDetailsManager | This interface is used to get notification details


DefaultNotificationDetailsManager Class

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager Class
Members See Also Send Feedback
This class is used to get notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DefaultNotificationDetailsManager : INotificationDetailsManager
Visual Basic
Public Class DefaultNotificationDetailsManager
    Implements INotificationDetailsManager
Visual C++
public ref class DefaultNotificationDetailsManager : INotificationDetailsManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager..::..DefaultNotificationDetailsManager

See Also

DefaultNotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager Members

[image] [image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager Members
DefaultNotificationDetailsManager Class Constructors Methods See Also Send Feedback

The DefaultNotificationDetailsManager type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultNotificationDetailsManager | Initializes a new instance of the DefaultNotificationDetailsManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotificationDetails(String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String, String) | This method is used to get notification details for that particular locale
Public method | GetNotificationIdByNotificationName(String) | Gets the notification id from notification master by using the notfication name.
Public method | GetNotificationIdByNotificationName(String, String) | Gets the notification id from notification master by using the notification name.
Public method | GetNotificationIdFromNotificationMaster(String) | Gets the notification id from notification master.
Public method | GetNotificationIdFromNotificationMaster(String, String) | Gets the notification id from notification master.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultNotificationDetailsManager Class
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager Constructor

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager Constructor
DefaultNotificationDetailsManager Class See Also Send Feedback
Initializes a new instance of the DefaultNotificationDetailsManager class

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DefaultNotificationDetailsManager()
Visual Basic
Public Sub New
Visual C++
public:
DefaultNotificationDetailsManager()

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager Methods

[image] [image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager Methods
DefaultNotificationDetailsManager Class See Also Send Feedback

The DefaultNotificationDetailsManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNotificationDetails(String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String, String) | This method is used to get notification details for that particular locale
Public method | GetNotificationIdByNotificationName(String) | Gets the notification id from notification master by using the notfication name.
Public method | GetNotificationIdByNotificationName(String, String) | Gets the notification id from notification master by using the notification name.
Public method | GetNotificationIdFromNotificationMaster(String) | Gets the notification id from notification master.
Public method | GetNotificationIdFromNotificationMaster(String, String) | Gets the notification id from notification master.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultNotificationDetailsManager Class
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationDetails Method

[image] [image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationDetails Method
DefaultNotificationDetailsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationDetails(String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String, String) | This method is used to get notification details for that particular locale

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationDetails Method (String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationDetails Method (String)
DefaultNotificationDetailsManager Class See Also Send Feedback
This method is used to get notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDetails GetNotificationDetails(
    string notificationId
)
Visual Basic
Public Function GetNotificationDetails (
    notificationId As String
) As NotificationDetails
Visual C++
public:
virtual NotificationDetails^ GetNotificationDetails(
    String^ notificationId
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier

Return Value

Type: NotificationDetails
Notification Details

Implements

INotificationDetailsManager..::..GetNotificationDetails(String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationDetails Method (String, String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationDetails Method (String, String)
DefaultNotificationDetailsManager Class See Also Send Feedback
This method is used to get notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId
)
Visual Basic
Public Function GetNotificationDetails (
    notificationId As String,
    tenantId As String
) As NotificationDetails
Visual C++
public:
virtual NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: NotificationDetails
Notification Details

Implements

INotificationDetailsManager..::..GetNotificationDetails(String, String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationDetails Method (String, String, String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationDetails Method (String, String, String)
DefaultNotificationDetailsManager Class See Also Send Feedback
This method is used to get notification details for that particular locale

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId,
    string localeId
)
Visual Basic
Public Function GetNotificationDetails (
    notificationId As String,
    tenantId As String,
    localeId As String
) As NotificationDetails
Visual C++
public:
virtual NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId,
    String^ localeId
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
Tenant Identifier
localeId
Type: System..::..String

Return Value

Type: NotificationDetails
Notification Details

Implements

INotificationDetailsManager..::..GetNotificationDetails(String, String, String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationIdByNotificationName Method

[image] [image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationIdByNotificationName Method
DefaultNotificationDetailsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationIdByNotificationName(String) | Gets the notification id from notification master by using the notfication name.
Public method | GetNotificationIdByNotificationName(String, String) | Gets the notification id from notification master by using the notification name.

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationIdByNotificationName Method (String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationIdByNotificationName Method (String)
DefaultNotificationDetailsManager Class See Also Send Feedback
Gets the notification id from notification master by using the notfication name.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string GetNotificationIdByNotificationName(
    string notificationName
)
Visual Basic
Public Function GetNotificationIdByNotificationName (
    notificationName As String
) As String
Visual C++
public:
virtual String^ GetNotificationIdByNotificationName(
    String^ notificationName
) sealed

Parameters

notificationName
Type: System..::..String
The notification name

Return Value

Type: String
Notification Id

Implements

INotificationDetailsManager..::..GetNotificationIdByNotificationName(String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationIdByNotificationName Overload
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationIdByNotificationName Method (String, String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationIdByNotificationName Method (String, String)
DefaultNotificationDetailsManager Class See Also Send Feedback
Gets the notification id from notification master by using the notification name.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string GetNotificationIdByNotificationName(
    string notificationName,
    string tenantId
)
Visual Basic
Public Function GetNotificationIdByNotificationName (
    notificationName As String,
    tenantId As String
) As String
Visual C++
public:
virtual String^ GetNotificationIdByNotificationName(
    String^ notificationName,
    String^ tenantId
) sealed

Parameters

notificationName
Type: System..::..String
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
Get Notification Id

Implements

INotificationDetailsManager..::..GetNotificationIdByNotificationName(String, String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationIdByNotificationName Overload
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationIdFromNotificationMaster Method

[image] [image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationIdFromNotificationMaster Method
DefaultNotificationDetailsManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationIdFromNotificationMaster(String) | Gets the notification id from notification master.
Public method | GetNotificationIdFromNotificationMaster(String, String) | Gets the notification id from notification master.

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationIdFromNotificationMaster Method (String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationIdFromNotificationMaster Method (String)
DefaultNotificationDetailsManager Class See Also Send Feedback
Gets the notification id from notification master.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string GetNotificationIdFromNotificationMaster(
    string notificationId
)
Visual Basic
Public Function GetNotificationIdFromNotificationMaster (
    notificationId As String
) As String
Visual C++
public:
virtual String^ GetNotificationIdFromNotificationMaster(
    String^ notificationId
) sealed

Parameters

notificationId
Type: System..::..String
The notification id.

Return Value

Type: String
Notification Id

Implements

INotificationDetailsManager..::..GetNotificationIdFromNotificationMaster(String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationIdFromNotificationMaster Overload
CelloSaaS.Notification.NotificationManager Namespace


DefaultNotificationDetailsManager.GetNotificationIdFromNotificationMaster Method (String, String)

[image]

A Sandcastle Documented Class Library
DefaultNotificationDetailsManager..::..GetNotificationIdFromNotificationMaster Method (String, String)
DefaultNotificationDetailsManager Class See Also Send Feedback
Gets the notification id from notification master.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string GetNotificationIdFromNotificationMaster(
    string notificationId,
    string tenantId
)
Visual Basic
Public Function GetNotificationIdFromNotificationMaster (
    notificationId As String,
    tenantId As String
) As String
Visual C++
public:
virtual String^ GetNotificationIdFromNotificationMaster(
    String^ notificationId,
    String^ tenantId
) sealed

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
Get Notification Id

Implements

INotificationDetailsManager..::..GetNotificationIdFromNotificationMaster(String, String)

See Also

DefaultNotificationDetailsManager Class
DefaultNotificationDetailsManager Members
GetNotificationIdFromNotificationMaster Overload
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Class
Members See Also Send Feedback

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateNotificationNameException : Exception
Visual Basic
<SerializableAttribute>
Public Class DuplicateNotificationNameException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class DuplicateNotificationNameException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.Notification.NotificationManager..::..DuplicateNotificationNameException

See Also

DuplicateNotificationNameException Members
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Members
DuplicateNotificationNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateNotificationNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateNotificationNameException()()()() | Initializes a new instance of the DuplicateNotificationNameException class.
Public method | DuplicateNotificationNameException(String) | Initializes a new instance of the DuplicateNotificationNameException class.
Protected method | DuplicateNotificationNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNotificationNameException class.
Public method | DuplicateNotificationNameException(String, Exception) | Initializes a new instance of the DuplicateNotificationNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateNotificationNameException Class
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Constructor
DuplicateNotificationNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateNotificationNameException()()()() | Initializes a new instance of the DuplicateNotificationNameException class.
Public method | DuplicateNotificationNameException(String) | Initializes a new instance of the DuplicateNotificationNameException class.
Protected method | DuplicateNotificationNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateNotificationNameException class.
Public method | DuplicateNotificationNameException(String, Exception) | Initializes a new instance of the DuplicateNotificationNameException class.

See Also

DuplicateNotificationNameException Class
DuplicateNotificationNameException Members
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Constructor
DuplicateNotificationNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateNotificationNameException class.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateNotificationNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateNotificationNameException()

See Also

DuplicateNotificationNameException Class
DuplicateNotificationNameException Members
DuplicateNotificationNameException Overload
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Constructor (String)
DuplicateNotificationNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateNotificationNameException class.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateNotificationNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateNotificationNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateNotificationNameException Class
DuplicateNotificationNameException Members
DuplicateNotificationNameException Overload
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Constructor (SerializationInfo, StreamingContext)
DuplicateNotificationNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateNotificationNameException class.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateNotificationNameException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
DuplicateNotificationNameException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The info parameter is null.
System.Runtime.Serialization..::..SerializationException | The class name is null or HResult is zero (0).

See Also

DuplicateNotificationNameException Class
DuplicateNotificationNameException Members
DuplicateNotificationNameException Overload
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Constructor (String, Exception)
DuplicateNotificationNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateNotificationNameException class.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateNotificationNameException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateNotificationNameException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateNotificationNameException Class
DuplicateNotificationNameException Members
DuplicateNotificationNameException Overload
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Methods
DuplicateNotificationNameException Class See Also Send Feedback

The DuplicateNotificationNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateNotificationNameException Class
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Properties
DuplicateNotificationNameException Class See Also Send Feedback

The DuplicateNotificationNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateNotificationNameException Class
CelloSaaS.Notification.NotificationManager Namespace


DuplicateNotificationNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateNotificationNameException Events
DuplicateNotificationNameException Class See Also Send Feedback

The DuplicateNotificationNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateNotificationNameException Class
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager Interface

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager Interface
Members See Also Send Feedback
This interface is used to get notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationDetailsManager
Visual Basic
Public Interface INotificationDetailsManager
Visual C++
public interface class INotificationDetailsManager

See Also

INotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager Members

[image] [image]

A Sandcastle Documented Class Library
INotificationDetailsManager Members
INotificationDetailsManager Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | GetNotificationDetails(String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String, String) | This method is used to get notification details for the particular locale
Public method | GetNotificationIdByNotificationName(String) | Gets the notification id from notification master by using the notfication name.
Public method | GetNotificationIdByNotificationName(String, String) | Gets the notification id from notification master by using the notification name.
Public method | GetNotificationIdFromNotificationMaster(String) | Gets the notification id from notification master.
Public method | GetNotificationIdFromNotificationMaster(String, String) | Gets the notification id from notification master.

See Also

INotificationDetailsManager Interface
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager Methods

[image] [image]

A Sandcastle Documented Class Library
INotificationDetailsManager Methods
INotificationDetailsManager Interface See Also Send Feedback

Methods

 | Name | Description
Public method | GetNotificationDetails(String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String, String) | This method is used to get notification details for the particular locale
Public method | GetNotificationIdByNotificationName(String) | Gets the notification id from notification master by using the notfication name.
Public method | GetNotificationIdByNotificationName(String, String) | Gets the notification id from notification master by using the notification name.
Public method | GetNotificationIdFromNotificationMaster(String) | Gets the notification id from notification master.
Public method | GetNotificationIdFromNotificationMaster(String, String) | Gets the notification id from notification master.

See Also

INotificationDetailsManager Interface
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationDetails Method

[image] [image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationDetails Method
INotificationDetailsManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationDetails(String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String) | This method is used to get notification details
Public method | GetNotificationDetails(String, String, String) | This method is used to get notification details for the particular locale

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationDetails Method (String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationDetails Method (String)
INotificationDetailsManager Interface See Also Send Feedback
This method is used to get notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetails(
    string notificationId
)
Visual Basic
Function GetNotificationDetails (
    notificationId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetails(
    String^ notificationId
)

Parameters

notificationId
Type: System..::..String
Notification Identifier

Return Value

Type: NotificationDetails
Notification Details

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationDetails Method (String, String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationDetails Method (String, String)
INotificationDetailsManager Interface See Also Send Feedback
This method is used to get notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId
)
Visual Basic
Function GetNotificationDetails (
    notificationId As String,
    tenantId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId
)

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: NotificationDetails
Notification Details

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationDetails Method (String, String, String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationDetails Method (String, String, String)
INotificationDetailsManager Interface See Also Send Feedback
This method is used to get notification details for the particular locale

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId,
    string localeId
)
Visual Basic
Function GetNotificationDetails (
    notificationId As String,
    tenantId As String,
    localeId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId,
    String^ localeId
)

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
Tenant IdentifierLocale Identifier
localeId
Type: System..::..String

Return Value

Type: NotificationDetails
Notification Details

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationIdByNotificationName Method

[image] [image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationIdByNotificationName Method
INotificationDetailsManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationIdByNotificationName(String) | Gets the notification id from notification master by using the notfication name.
Public method | GetNotificationIdByNotificationName(String, String) | Gets the notification id from notification master by using the notification name.

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationIdByNotificationName Method (String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationIdByNotificationName Method (String)
INotificationDetailsManager Interface See Also Send Feedback
Gets the notification id from notification master by using the notfication name.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetNotificationIdByNotificationName(
    string notificationName
)
Visual Basic
Function GetNotificationIdByNotificationName (
    notificationName As String
) As String
Visual C++
String^ GetNotificationIdByNotificationName(
    String^ notificationName
)

Parameters

notificationName
Type: System..::..String
The notification name

Return Value

Type: String
Notification Id

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationIdByNotificationName Overload
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationIdByNotificationName Method (String, String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationIdByNotificationName Method (String, String)
INotificationDetailsManager Interface See Also Send Feedback
Gets the notification id from notification master by using the notification name.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetNotificationIdByNotificationName(
    string notificationName,
    string tenantId
)
Visual Basic
Function GetNotificationIdByNotificationName (
    notificationName As String,
    tenantId As String
) As String
Visual C++
String^ GetNotificationIdByNotificationName(
    String^ notificationName,
    String^ tenantId
)

Parameters

notificationName
Type: System..::..String
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
Get Notification Id

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationIdByNotificationName Overload
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationIdFromNotificationMaster Method

[image] [image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationIdFromNotificationMaster Method
INotificationDetailsManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationIdFromNotificationMaster(String) | Gets the notification id from notification master.
Public method | GetNotificationIdFromNotificationMaster(String, String) | Gets the notification id from notification master.

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationIdFromNotificationMaster Method (String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationIdFromNotificationMaster Method (String)
INotificationDetailsManager Interface See Also Send Feedback
Gets the notification id from notification master.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetNotificationIdFromNotificationMaster(
    string notificationId
)
Visual Basic
Function GetNotificationIdFromNotificationMaster (
    notificationId As String
) As String
Visual C++
String^ GetNotificationIdFromNotificationMaster(
    String^ notificationId
)

Parameters

notificationId
Type: System..::..String
The notification id.

Return Value

Type: String
Notification Id

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationIdFromNotificationMaster Overload
CelloSaaS.Notification.NotificationManager Namespace


INotificationDetailsManager.GetNotificationIdFromNotificationMaster Method (String, String)

[image]

A Sandcastle Documented Class Library
INotificationDetailsManager..::..GetNotificationIdFromNotificationMaster Method (String, String)
INotificationDetailsManager Interface See Also Send Feedback
Gets the notification id from notification master.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetNotificationIdFromNotificationMaster(
    string notificationId,
    string tenantId
)
Visual Basic
Function GetNotificationIdFromNotificationMaster (
    notificationId As String,
    tenantId As String
) As String
Visual C++
String^ GetNotificationIdFromNotificationMaster(
    String^ notificationId,
    String^ tenantId
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
Notification Id

See Also

INotificationDetailsManager Interface
INotificationDetailsManager Members
GetNotificationIdFromNotificationMaster Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager Class

[image]

A Sandcastle Documented Class Library
NotificationAuditManager Class
Members See Also Send Feedback
Represents the notification audit manager

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationAuditManager
Visual Basic
Public NotInheritable Class NotificationAuditManager
Visual C++
public ref class NotificationAuditManager abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager..::..NotificationAuditManager

See Also

NotificationAuditManager Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager Members

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditManager Members
NotificationAuditManager Class Methods See Also Send Feedback

The NotificationAuditManager type exposes the following members.

Methods

Name | Description
GetNotificationAuditDetails | Obsolete. Gets the notification audit details.
LogPostNotification | This method is used to log notification details after dispatch
LogPreNotification | This method is used to add notification pre log details(Notification Audit)
SearchNotificationAuditDetails | Gets the notification audit details.

See Also

NotificationAuditManager Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationAuditManager Methods
NotificationAuditManager Class See Also Send Feedback

The NotificationAuditManager type exposes the following members.

Methods

Name | Description
GetNotificationAuditDetails | Obsolete. Gets the notification audit details.
LogPostNotification | This method is used to log notification details after dispatch
LogPreNotification | This method is used to add notification pre log details(Notification Audit)
SearchNotificationAuditDetails | Gets the notification audit details.

See Also

NotificationAuditManager Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager.GetNotificationAuditDetails Method

[image]

A Sandcastle Documented Class Library
NotificationAuditManager..::..GetNotificationAuditDetails Method
NotificationAuditManager Class See Also Send Feedback
Gets the notification audit details.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
public static List<NotificationAudit> GetNotificationAuditDetails(
    NotificationAuditSearchCondition notificationAuditSearchCondition
)
Visual Basic
<ObsoleteAttribute>
Public Shared Function GetNotificationAuditDetails (
    notificationAuditSearchCondition As NotificationAuditSearchCondition
) As List(Of NotificationAudit)
Visual C++
public:
[ObsoleteAttribute]
static List<NotificationAudit^>^ GetNotificationAuditDetails(
    NotificationAuditSearchCondition^ notificationAuditSearchCondition
)

Parameters

notificationAuditSearchCondition
Type: CelloSaaS.Notification.Model..::..NotificationAuditSearchCondition
The notification audit search condition.

Return Value

Type: List<(Of <(<' NotificationAudit >)>)>

See Also

NotificationAuditManager Class
NotificationAuditManager Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager.LogPostNotification Method

[image]

A Sandcastle Documented Class Library
NotificationAuditManager..::..LogPostNotification Method
NotificationAuditManager Class See Also Send Feedback
This method is used to log notification details after dispatch

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void LogPostNotification(
    string notificationAuditId,
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    NotificationStatus notificationStatus
)
Visual Basic
Public Shared Sub LogPostNotification (
    notificationAuditId As String,
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    notificationStatus As NotificationStatus
)
Visual C++
public:
static void LogPostNotification(
    String^ notificationAuditId,
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    NotificationStatus notificationStatus
)

Parameters

notificationAuditId
Type: System..::..String
Notification Audit Identifier
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
notificationStatus
Type: CelloSaaS.Notification.Model..::..NotificationStatus
Notification Status

See Also

NotificationAuditManager Class
NotificationAuditManager Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager.LogPreNotification Method

[image]

A Sandcastle Documented Class Library
NotificationAuditManager..::..LogPreNotification Method
NotificationAuditManager Class See Also Send Feedback
This method is used to add notification pre log details(Notification Audit)

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string LogPreNotification(
    NotificationAudit notificationAudit
)
Visual Basic
Public Shared Function LogPreNotification (
    notificationAudit As NotificationAudit
) As String
Visual C++
public:
static String^ LogPreNotification(
    NotificationAudit^ notificationAudit
)

Parameters

notificationAudit
Type: CelloSaaS.Notification.Model..::..NotificationAudit
Notification Audit Details

Return Value

Type: String
Notification Audit Identifier

See Also

NotificationAuditManager Class
NotificationAuditManager Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationAuditManager.SearchNotificationAuditDetails Method

[image]

A Sandcastle Documented Class Library
NotificationAuditManager..::..SearchNotificationAuditDetails Method
NotificationAuditManager Class See Also Send Feedback
Gets the notification audit details.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static NotificationAuditSearchResult SearchNotificationAuditDetails(
    NotificationAuditSearchCondition notificationAuditSearchCondition
)
Visual Basic
Public Shared Function SearchNotificationAuditDetails (
    notificationAuditSearchCondition As NotificationAuditSearchCondition
) As NotificationAuditSearchResult
Visual C++
public:
static NotificationAuditSearchResult^ SearchNotificationAuditDetails(
    NotificationAuditSearchCondition^ notificationAuditSearchCondition
)

Parameters

notificationAuditSearchCondition
Type: CelloSaaS.Notification.Model..::..NotificationAuditSearchCondition
The notification audit search condition.

Return Value

Type: NotificationAuditSearchResult

See Also

NotificationAuditManager Class
NotificationAuditManager Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Class

[image]

A Sandcastle Documented Class Library
NotificationException Class
Members See Also Send Feedback
Represents errors that occur during notification manager execution.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class NotificationException : Exception
Visual Basic
<SerializableAttribute>
Public Class NotificationException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class NotificationException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.Notification.NotificationManager..::..NotificationException

See Also

NotificationException Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Members

[image] [image]

A Sandcastle Documented Class Library
NotificationException Members
NotificationException Class Constructors Methods Properties Events See Also Send Feedback

The NotificationException type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationException()()()() | Initializes a new instance of the NotificationException class.
Public method | NotificationException(String) | Initializes a new instance of the NotificationException class with a specified error message.
Protected method | NotificationException(SerializationInfo, StreamingContext) | Initializes a new instance of the NotificationException class
Public method | NotificationException(String, Exception) | Initializes a new instance of the NotificationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NotificationException Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Constructor

[image] [image]

A Sandcastle Documented Class Library
NotificationException Constructor
NotificationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NotificationException()()()() | Initializes a new instance of the NotificationException class.
Public method | NotificationException(String) | Initializes a new instance of the NotificationException class with a specified error message.
Protected method | NotificationException(SerializationInfo, StreamingContext) | Initializes a new instance of the NotificationException class
Public method | NotificationException(String, Exception) | Initializes a new instance of the NotificationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

NotificationException Class
NotificationException Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Constructor

[image]

A Sandcastle Documented Class Library
NotificationException Constructor
NotificationException Class See Also Send Feedback
Initializes a new instance of the NotificationException class.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationException()
Visual Basic
Public Sub New
Visual C++
public:
NotificationException()

See Also

NotificationException Class
NotificationException Members
NotificationException Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Constructor (String)

[image]

A Sandcastle Documented Class Library
NotificationException Constructor (String)
NotificationException Class See Also Send Feedback
Initializes a new instance of the NotificationException class with a specified error message.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
NotificationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

NotificationException Class
NotificationException Members
NotificationException Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
NotificationException Constructor (SerializationInfo, StreamingContext)
NotificationException Class See Also Send Feedback
Initializes a new instance of the NotificationException class

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected NotificationException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
NotificationException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

NotificationException Class
NotificationException Members
NotificationException Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
NotificationException Constructor (String, Exception)
NotificationException Class See Also Send Feedback
Initializes a new instance of the NotificationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
NotificationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message that describes the error.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

NotificationException Class
NotificationException Members
NotificationException Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationException Methods
NotificationException Class See Also Send Feedback

The NotificationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NotificationException Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationException Properties
NotificationException Class See Also Send Feedback

The NotificationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NotificationException Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationException Events

[image] [image]

A Sandcastle Documented Class Library
NotificationException Events
NotificationException Class See Also Send Feedback

The NotificationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

NotificationException Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails Class

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails Class
Members See Also Send Feedback
This class is used to manage notification details

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationManagerDetails
Visual Basic
Public NotInheritable Class NotificationManagerDetails
Visual C++
public ref class NotificationManagerDetails abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager..::..NotificationManagerDetails

See Also

NotificationManagerDetails Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails Members

[image] [image]

A Sandcastle Documented Class Library
NotificationManagerDetails Members
NotificationManagerDetails Class Methods See Also Send Feedback

The NotificationManagerDetails type exposes the following members.

Methods

Name | Description
GetNotificationDetails(String, String) | This method is used to gets the the notification details by using the notification id and the tenant id.
GetNotificationDetails(String, String, String) | This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.
GetNotificationDetailsByName(String, String) | This method is used to gets the notification details by using the notification name and the tenant id.
GetNotificationDetailsByName(String, String, String) | This method is used to gets the notification details by using the notification name with the given locale id.
ProcessAndSendBatchNotification(String, String, IBatchNotificationContent, IBatchNotificationDestination) | This method is used to processes the batch content and send the batch notification.
ProcessAndSendBatchNotification(String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content
ProcessAndSendBatchNotification(String, String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This method is used to Processes and send batch notification with locale id
ProcessAndSendNotification(String, String, INotificationContent, INotificationDestination) | This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.
ProcessAndSendNotification(String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content
ProcessAndSendNotification(String, String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content
SendNotification | This method is used to send a email or upload a file.

See Also

NotificationManagerDetails Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationManagerDetails Methods
NotificationManagerDetails Class See Also Send Feedback

The NotificationManagerDetails type exposes the following members.

Methods

Name | Description
GetNotificationDetails(String, String) | This method is used to gets the the notification details by using the notification id and the tenant id.
GetNotificationDetails(String, String, String) | This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.
GetNotificationDetailsByName(String, String) | This method is used to gets the notification details by using the notification name and the tenant id.
GetNotificationDetailsByName(String, String, String) | This method is used to gets the notification details by using the notification name with the given locale id.
ProcessAndSendBatchNotification(String, String, IBatchNotificationContent, IBatchNotificationDestination) | This method is used to processes the batch content and send the batch notification.
ProcessAndSendBatchNotification(String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content
ProcessAndSendBatchNotification(String, String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This method is used to Processes and send batch notification with locale id
ProcessAndSendNotification(String, String, INotificationContent, INotificationDestination) | This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.
ProcessAndSendNotification(String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content
ProcessAndSendNotification(String, String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content
SendNotification | This method is used to send a email or upload a file.

See Also

NotificationManagerDetails Class
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.GetNotificationDetails Method

[image] [image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..GetNotificationDetails Method
NotificationManagerDetails Class See Also Send Feedback

Overload List

Name | Description
GetNotificationDetails(String, String) | This method is used to gets the the notification details by using the notification id and the tenant id.
GetNotificationDetails(String, String, String) | This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.GetNotificationDetails Method (String, String)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..GetNotificationDetails Method (String, String)
NotificationManagerDetails Class See Also Send Feedback
This method is used to gets the the notification details by using the notification id and the tenant id.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId
)
Visual Basic
Public Shared Function GetNotificationDetails (
    notificationId As String,
    tenantId As String
) As NotificationDetails
Visual C++
public:
static NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If Notification Identifier Not available

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.GetNotificationDetails Method (String, String, String)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..GetNotificationDetails Method (String, String, String)
NotificationManagerDetails Class See Also Send Feedback
This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId,
    string localeId
)
Visual Basic
Public Shared Function GetNotificationDetails (
    notificationId As String,
    tenantId As String,
    localeId As String
) As NotificationDetails
Visual C++
public:
static NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId,
    String^ localeId
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If the notification id is not available

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
GetNotificationDetails Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.GetNotificationDetailsByName Method

[image] [image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..GetNotificationDetailsByName Method
NotificationManagerDetails Class See Also Send Feedback

Overload List

Name | Description
GetNotificationDetailsByName(String, String) | This method is used to gets the notification details by using the notification name and the tenant id.
GetNotificationDetailsByName(String, String, String) | This method is used to gets the notification details by using the notification name with the given locale id.

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.GetNotificationDetailsByName Method (String, String)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..GetNotificationDetailsByName Method (String, String)
NotificationManagerDetails Class See Also Send Feedback
This method is used to gets the notification details by using the notification name and the tenant id.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static NotificationDetails GetNotificationDetailsByName(
    string notificationName,
    string tenantId
)
Visual Basic
Public Shared Function GetNotificationDetailsByName (
    notificationName As String,
    tenantId As String
) As NotificationDetails
Visual C++
public:
static NotificationDetails^ GetNotificationDetailsByName(
    String^ notificationName,
    String^ tenantId
)

Parameters

notificationName
Type: System..::..String
Name of the notification.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If the notification id is not available

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
GetNotificationDetailsByName Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.GetNotificationDetailsByName Method (String, String, String)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..GetNotificationDetailsByName Method (String, String, String)
NotificationManagerDetails Class See Also Send Feedback
This method is used to gets the notification details by using the notification name with the given locale id.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static NotificationDetails GetNotificationDetailsByName(
    string notificationName,
    string tenantId,
    string localeId
)
Visual Basic
Public Shared Function GetNotificationDetailsByName (
    notificationName As String,
    tenantId As String,
    localeId As String
) As NotificationDetails
Visual C++
public:
static NotificationDetails^ GetNotificationDetailsByName(
    String^ notificationName,
    String^ tenantId,
    String^ localeId
)

Parameters

notificationName
Type: System..::..String
Name of the notification.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If the notification id is not available

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
GetNotificationDetailsByName Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendBatchNotification Method

[image] [image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendBatchNotification Method
NotificationManagerDetails Class See Also Send Feedback

Overload List

Name | Description
ProcessAndSendBatchNotification(String, String, IBatchNotificationContent, IBatchNotificationDestination) | This method is used to processes the batch content and send the batch notification.
ProcessAndSendBatchNotification(String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content
ProcessAndSendBatchNotification(String, String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This method is used to Processes and send batch notification with locale id

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendBatchNotification Method (String, String, IBatchNotificationContent, IBatchNotificationDestination)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendBatchNotification Method (String, String, IBatchNotificationContent, IBatchNotificationDestination)
NotificationManagerDetails Class See Also Send Feedback
This method is used to processes the batch content and send the batch notification.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessAndSendBatchNotification(
    string notificationId,
    string tenantId,
    IBatchNotificationContent content,
    IBatchNotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub ProcessAndSendBatchNotification (
    notificationId As String,
    tenantId As String,
    content As IBatchNotificationContent,
    notificationDestination As IBatchNotificationDestination
)
Visual C++
public:
static void ProcessAndSendBatchNotification(
    String^ notificationId,
    String^ tenantId,
    IBatchNotificationContent^ content,
    IBatchNotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
content
Type: CelloSaaS.Notification.Model.Content..::..IBatchNotificationContent
The notification content details.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..IBatchNotificationDestination
The notification destination details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content or destination values are null
System..::..ArgumentException | If notification content inner property value content is null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
ProcessAndSendBatchNotification Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendBatchNotification Method (String, String, List(NotificationPlaceholder), IBatchNotificationDestination)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendBatchNotification Method (String, String, List<(Of <(<'NotificationPlaceholder>)>)>, IBatchNotificationDestination)
NotificationManagerDetails Class See Also Send Feedback
This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessAndSendBatchNotification(
    string notificationId,
    string tenantId,
    List<NotificationPlaceholder> placeholders,
    IBatchNotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub ProcessAndSendBatchNotification (
    notificationId As String,
    tenantId As String,
    placeholders As List(Of NotificationPlaceholder),
    notificationDestination As IBatchNotificationDestination
)
Visual C++
public:
static void ProcessAndSendBatchNotification(
    String^ notificationId,
    String^ tenantId,
    List<NotificationPlaceholder^>^ placeholders,
    IBatchNotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
placeholders
Type: System.Collections.Generic..::..List<(Of <(<' NotificationPlaceholder >)>)>
The place holders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..IBatchNotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null
System..::..ArgumentException | If destination inner property values are null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
ProcessAndSendBatchNotification Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendBatchNotification Method (String, String, String, List(NotificationPlaceholder), IBatchNotificationDestination)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendBatchNotification Method (String, String, String, List<(Of <(<'NotificationPlaceholder>)>)>, IBatchNotificationDestination)
NotificationManagerDetails Class See Also Send Feedback
This method is used to Processes and send batch notification with locale id

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessAndSendBatchNotification(
    string notificationId,
    string tenantId,
    string localeId,
    List<NotificationPlaceholder> placeholders,
    IBatchNotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub ProcessAndSendBatchNotification (
    notificationId As String,
    tenantId As String,
    localeId As String,
    placeholders As List(Of NotificationPlaceholder),
    notificationDestination As IBatchNotificationDestination
)
Visual C++
public:
static void ProcessAndSendBatchNotification(
    String^ notificationId,
    String^ tenantId,
    String^ localeId,
    List<NotificationPlaceholder^>^ placeholders,
    IBatchNotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.
placeholders
Type: System.Collections.Generic..::..List<(Of <(<' NotificationPlaceholder >)>)>
The placeholders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..IBatchNotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or destination values are null
System..::..ArgumentException | If destination inner property values are null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
ProcessAndSendBatchNotification Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendNotification Method

[image] [image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendNotification Method
NotificationManagerDetails Class See Also Send Feedback

Overload List

Name | Description
ProcessAndSendNotification(String, String, INotificationContent, INotificationDestination) | This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.
ProcessAndSendNotification(String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content
ProcessAndSendNotification(String, String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendNotification Method (String, String, INotificationContent, INotificationDestination)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendNotification Method (String, String, INotificationContent, INotificationDestination)
NotificationManagerDetails Class See Also Send Feedback
This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessAndSendNotification(
    string notificationId,
    string tenantId,
    INotificationContent notificationContent,
    INotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub ProcessAndSendNotification (
    notificationId As String,
    tenantId As String,
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination
)
Visual C++
public:
static void ProcessAndSendNotification(
    String^ notificationId,
    String^ tenantId,
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Content of the notification.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
ProcessAndSendNotification Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendNotification Method (String, String, NotificationPlaceholder, INotificationDestination)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendNotification Method (String, String, NotificationPlaceholder, INotificationDestination)
NotificationManagerDetails Class See Also Send Feedback
This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessAndSendNotification(
    string notificationId,
    string tenantId,
    NotificationPlaceholder placeholders,
    INotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub ProcessAndSendNotification (
    notificationId As String,
    tenantId As String,
    placeholders As NotificationPlaceholder,
    notificationDestination As INotificationDestination
)
Visual C++
public:
static void ProcessAndSendNotification(
    String^ notificationId,
    String^ tenantId,
    NotificationPlaceholder^ placeholders,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
placeholders
Type: CelloSaaS.Notification.Model.Content..::..NotificationPlaceholder
The place holders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
ProcessAndSendNotification Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.ProcessAndSendNotification Method (String, String, String, NotificationPlaceholder, INotificationDestination)

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..ProcessAndSendNotification Method (String, String, String, NotificationPlaceholder, INotificationDestination)
NotificationManagerDetails Class See Also Send Feedback
This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessAndSendNotification(
    string notificationId,
    string tenantId,
    string localeId,
    NotificationPlaceholder placeholders,
    INotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub ProcessAndSendNotification (
    notificationId As String,
    tenantId As String,
    localeId As String,
    placeholders As NotificationPlaceholder,
    notificationDestination As INotificationDestination
)
Visual C++
public:
static void ProcessAndSendNotification(
    String^ notificationId,
    String^ tenantId,
    String^ localeId,
    NotificationPlaceholder^ placeholders,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.
placeholders
Type: CelloSaaS.Notification.Model.Content..::..NotificationPlaceholder
The placeholders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
ProcessAndSendNotification Overload
CelloSaaS.Notification.NotificationManager Namespace


NotificationManagerDetails.SendNotification Method

[image]

A Sandcastle Documented Class Library
NotificationManagerDetails..::..SendNotification Method
NotificationManagerDetails Class See Also Send Feedback
This method is used to send a email or upload a file.

Namespace: CelloSaaS.Notification.NotificationManager
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void SendNotification(
    string notificationId,
    string tenantId,
    INotificationContent notificationContent,
    INotificationDestination notificationDestination
)
Visual Basic
Public Shared Sub SendNotification (
    notificationId As String,
    tenantId As String,
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination
)
Visual C++
public:
static void SendNotification(
    String^ notificationId,
    String^ tenantId,
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
The notification Content Details.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

NotificationManagerDetails Class
NotificationManagerDetails Members
CelloSaaS.Notification.NotificationManager Namespace


CelloSaaS.Notification.NotificationManager.Content Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.NotificationManager.Content Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchFileContentManager | Represents the batch file content manager
Public class | BatchSystemNotificationContentManager | This class contain batch system notification content manager details
Public class | BatchTextContentManager | This class contain batch text content manager details
Public class | FileContentManager | This class contain file content manager details
Public class | NotificationContentManager | This class contain notification content manager details
Public class | NotificationContentManagerFactory | This factory class contain notification content manager details
Public class | NotificationTemplateManager | This class is used to manage notification template
Public class | SystemNotificationContentManager | This class contain system notification content manager details
Public class | TextMessageContentManager | This class contain text message content manager details

Interfaces

 | Interface | Description
Public interface | INotificationContentManager | This interface contain Notification content manager details


BatchFileContentManager Class

[image]

A Sandcastle Documented Class Library
BatchFileContentManager Class
Members See Also Send Feedback
Represents the batch file content manager

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchFileContentManager : INotificationContentManager
Visual Basic
Public Class BatchFileContentManager
    Implements INotificationContentManager
Visual C++
public ref class BatchFileContentManager : INotificationContentManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..BatchFileContentManager

See Also

BatchFileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchFileContentManager Members

[image] [image]

A Sandcastle Documented Class Library
BatchFileContentManager Members
BatchFileContentManager Class Constructors Methods See Also Send Feedback

The BatchFileContentManager type exposes the following members.

Constructors

 | Name | Description
Public method | BatchFileContentManager | Initializes a new instance of the BatchFileContentManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFileContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchFileContentManager Constructor

[image]

A Sandcastle Documented Class Library
BatchFileContentManager Constructor
BatchFileContentManager Class See Also Send Feedback
Initializes a new instance of the BatchFileContentManager class

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchFileContentManager()
Visual Basic
Public Sub New
Visual C++
public:
BatchFileContentManager()

See Also

BatchFileContentManager Class
BatchFileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchFileContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
BatchFileContentManager Methods
BatchFileContentManager Class See Also Send Feedback

The BatchFileContentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFileContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchFileContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
BatchFileContentManager..::..InitializeContentFromTemplate Method
BatchFileContentManager Class See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Public Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
public:
virtual void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

Implements

INotificationContentManager..::..InitializeContentFromTemplate(String, String, INotificationTemplate, INotificationContent)

See Also

BatchFileContentManager Class
BatchFileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchFileContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
BatchFileContentManager..::..ProcessContent Method
BatchFileContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
virtual void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
) sealed

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

Implements

INotificationContentManager..::..ProcessContent(INotificationContent, String)

See Also

BatchFileContentManager Class
BatchFileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchSystemNotificationContentManager Class

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContentManager Class
Members See Also Send Feedback
This class contain batch system notification content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchSystemNotificationContentManager : INotificationContentManager
Visual Basic
Public Class BatchSystemNotificationContentManager
    Implements INotificationContentManager
Visual C++
public ref class BatchSystemNotificationContentManager : INotificationContentManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..BatchSystemNotificationContentManager

See Also

BatchSystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchSystemNotificationContentManager Members

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationContentManager Members
BatchSystemNotificationContentManager Class Constructors Methods See Also Send Feedback

The BatchSystemNotificationContentManager type exposes the following members.

Constructors

 | Name | Description
Public method | BatchSystemNotificationContentManager | Initializes a new instance of the BatchSystemNotificationContentManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchSystemNotificationContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchSystemNotificationContentManager Constructor

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContentManager Constructor
BatchSystemNotificationContentManager Class See Also Send Feedback
Initializes a new instance of the BatchSystemNotificationContentManager class

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchSystemNotificationContentManager()
Visual Basic
Public Sub New
Visual C++
public:
BatchSystemNotificationContentManager()

See Also

BatchSystemNotificationContentManager Class
BatchSystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchSystemNotificationContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationContentManager Methods
BatchSystemNotificationContentManager Class See Also Send Feedback

The BatchSystemNotificationContentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchSystemNotificationContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchSystemNotificationContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContentManager..::..InitializeContentFromTemplate Method
BatchSystemNotificationContentManager Class See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Public Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
public:
virtual void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

Implements

INotificationContentManager..::..InitializeContentFromTemplate(String, String, INotificationTemplate, INotificationContent)

See Also

BatchSystemNotificationContentManager Class
BatchSystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchSystemNotificationContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationContentManager..::..ProcessContent Method
BatchSystemNotificationContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
virtual void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
) sealed

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

Implements

INotificationContentManager..::..ProcessContent(INotificationContent, String)

See Also

BatchSystemNotificationContentManager Class
BatchSystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchTextContentManager Class

[image]

A Sandcastle Documented Class Library
BatchTextContentManager Class
Members See Also Send Feedback
This class contain batch text content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchTextContentManager : INotificationContentManager
Visual Basic
Public Class BatchTextContentManager
    Implements INotificationContentManager
Visual C++
public ref class BatchTextContentManager : INotificationContentManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..BatchTextContentManager

See Also

BatchTextContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchTextContentManager Members

[image] [image]

A Sandcastle Documented Class Library
BatchTextContentManager Members
BatchTextContentManager Class Constructors Methods See Also Send Feedback

The BatchTextContentManager type exposes the following members.

Constructors

 | Name | Description
Public method | BatchTextContentManager | Initializes a new instance of the BatchTextContentManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchTextContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchTextContentManager Constructor

[image]

A Sandcastle Documented Class Library
BatchTextContentManager Constructor
BatchTextContentManager Class See Also Send Feedback
Initializes a new instance of the BatchTextContentManager class

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchTextContentManager()
Visual Basic
Public Sub New
Visual C++
public:
BatchTextContentManager()

See Also

BatchTextContentManager Class
BatchTextContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchTextContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
BatchTextContentManager Methods
BatchTextContentManager Class See Also Send Feedback

The BatchTextContentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchTextContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchTextContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
BatchTextContentManager..::..InitializeContentFromTemplate Method
BatchTextContentManager Class See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Public Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
public:
virtual void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

Implements

INotificationContentManager..::..InitializeContentFromTemplate(String, String, INotificationTemplate, INotificationContent)

See Also

BatchTextContentManager Class
BatchTextContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


BatchTextContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
BatchTextContentManager..::..ProcessContent Method
BatchTextContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
virtual void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
) sealed

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

Implements

INotificationContentManager..::..ProcessContent(INotificationContent, String)

See Also

BatchTextContentManager Class
BatchTextContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


FileContentManager Class

[image]

A Sandcastle Documented Class Library
FileContentManager Class
Members See Also Send Feedback
This class contain file content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class FileContentManager : INotificationContentManager
Visual Basic
Public Class FileContentManager
    Implements INotificationContentManager
Visual C++
public ref class FileContentManager : INotificationContentManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..FileContentManager

See Also

FileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


FileContentManager Members

[image] [image]

A Sandcastle Documented Class Library
FileContentManager Members
FileContentManager Class Constructors Methods See Also Send Feedback

The FileContentManager type exposes the following members.

Constructors

 | Name | Description
Public method | FileContentManager | Initializes a new instance of the FileContentManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


FileContentManager Constructor

[image]

A Sandcastle Documented Class Library
FileContentManager Constructor
FileContentManager Class See Also Send Feedback
Initializes a new instance of the FileContentManager class

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FileContentManager()
Visual Basic
Public Sub New
Visual C++
public:
FileContentManager()

See Also

FileContentManager Class
FileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


FileContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
FileContentManager Methods
FileContentManager Class See Also Send Feedback

The FileContentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


FileContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
FileContentManager..::..InitializeContentFromTemplate Method
FileContentManager Class See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Public Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
public:
virtual void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

Implements

INotificationContentManager..::..InitializeContentFromTemplate(String, String, INotificationTemplate, INotificationContent)

See Also

FileContentManager Class
FileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


FileContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
FileContentManager..::..ProcessContent Method
FileContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
virtual void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
) sealed

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

Implements

INotificationContentManager..::..ProcessContent(INotificationContent, String)

See Also

FileContentManager Class
FileContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


INotificationContentManager Interface

[image]

A Sandcastle Documented Class Library
INotificationContentManager Interface
Members See Also Send Feedback
This interface contain Notification content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationContentManager
Visual Basic
Public Interface INotificationContentManager
Visual C++
public interface class INotificationContentManager

See Also

INotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


INotificationContentManager Members

[image] [image]

A Sandcastle Documented Class Library
INotificationContentManager Members
INotificationContentManager Interface Methods See Also Send Feedback

The INotificationContentManager type exposes the following members.

Methods

 | Name | Description
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Public method | ProcessContent | This method is used to process content details

See Also

INotificationContentManager Interface
CelloSaaS.Notification.NotificationManager.Content Namespace


INotificationContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
INotificationContentManager Methods
INotificationContentManager Interface See Also Send Feedback

The INotificationContentManager type exposes the following members.

Methods

 | Name | Description
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Public method | ProcessContent | This method is used to process content details

See Also

INotificationContentManager Interface
CelloSaaS.Notification.NotificationManager.Content Namespace


INotificationContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
INotificationContentManager..::..InitializeContentFromTemplate Method
INotificationContentManager Interface See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
)

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

See Also

INotificationContentManager Interface
INotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


INotificationContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
INotificationContentManager..::..ProcessContent Method
INotificationContentManager Interface See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
)

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

See Also

INotificationContentManager Interface
INotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManager Class

[image]

A Sandcastle Documented Class Library
NotificationContentManager Class
Members See Also Send Feedback
This class contain notification content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationContentManager
Visual Basic
Public NotInheritable Class NotificationContentManager
Visual C++
public ref class NotificationContentManager abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..NotificationContentManager

See Also

NotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManager Members

[image] [image]

A Sandcastle Documented Class Library
NotificationContentManager Members
NotificationContentManager Class Methods See Also Send Feedback

The NotificationContentManager type exposes the following members.

Methods

Name | Description
PrepareContentFromTemplate | This method is used to prepare notification content from template
ProcessContent | This method is used to process content details

See Also

NotificationContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationContentManager Methods
NotificationContentManager Class See Also Send Feedback

The NotificationContentManager type exposes the following members.

Methods

Name | Description
PrepareContentFromTemplate | This method is used to prepare notification content from template
ProcessContent | This method is used to process content details

See Also

NotificationContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManager.PrepareContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
NotificationContentManager..::..PrepareContentFromTemplate Method
NotificationContentManager Class See Also Send Feedback
This method is used to prepare notification content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void PrepareContentFromTemplate(
    string notificationId,
    string templateId,
    string tenantId,
    INotificationContent content
)
Visual Basic
Public Shared Sub PrepareContentFromTemplate (
    notificationId As String,
    templateId As String,
    tenantId As String,
    content As INotificationContent
)
Visual C++
public:
static void PrepareContentFromTemplate(
    String^ notificationId,
    String^ templateId,
    String^ tenantId,
    INotificationContent^ content
)

Parameters

notificationId
Type: System..::..String
Notification Identifier
templateId
Type: System..::..String
Template Identifier
tenantId
Type: System..::..String
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

See Also

NotificationContentManager Class
NotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
NotificationContentManager..::..ProcessContent Method
NotificationContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Shared Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
static void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
)

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

See Also

NotificationContentManager Class
NotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManagerFactory Class

[image]

A Sandcastle Documented Class Library
NotificationContentManagerFactory Class
Members See Also Send Feedback
This factory class contain notification content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationContentManagerFactory
Visual Basic
Public NotInheritable Class NotificationContentManagerFactory
Visual C++
public ref class NotificationContentManagerFactory abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..NotificationContentManagerFactory

See Also

NotificationContentManagerFactory Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManagerFactory Members

[image] [image]

A Sandcastle Documented Class Library
NotificationContentManagerFactory Members
NotificationContentManagerFactory Class Methods See Also Send Feedback

The NotificationContentManagerFactory type exposes the following members.

Methods

Name | Description
GetContentManager | This method is used to get notification content manager details

See Also

NotificationContentManagerFactory Class
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManagerFactory Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationContentManagerFactory Methods
NotificationContentManagerFactory Class See Also Send Feedback

The NotificationContentManagerFactory type exposes the following members.

Methods

Name | Description
GetContentManager | This method is used to get notification content manager details

See Also

NotificationContentManagerFactory Class
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationContentManagerFactory.GetContentManager Method

[image]

A Sandcastle Documented Class Library
NotificationContentManagerFactory..::..GetContentManager Method
NotificationContentManagerFactory Class See Also Send Feedback
This method is used to get notification content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static INotificationContentManager GetContentManager(
    NotificationContentType contentType
)
Visual Basic
Public Shared Function GetContentManager (
    contentType As NotificationContentType
) As INotificationContentManager
Visual C++
public:
static INotificationContentManager^ GetContentManager(
    NotificationContentType contentType
)

Parameters

contentType
Type: CelloSaaS.Notification.Model..::..NotificationContentType
Notification Content Type

Return Value

Type: INotificationContentManager
Notification Content Manager Details

See Also

NotificationContentManagerFactory Class
NotificationContentManagerFactory Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager Class

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager Class
Members See Also Send Feedback
This class is used to manage notification template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationTemplateManager
Visual Basic
Public NotInheritable Class NotificationTemplateManager
Visual C++
public ref class NotificationTemplateManager abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..NotificationTemplateManager

See Also

NotificationTemplateManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager Members

[image] [image]

A Sandcastle Documented Class Library
NotificationTemplateManager Members
NotificationTemplateManager Class Methods See Also Send Feedback

The NotificationTemplateManager type exposes the following members.

Methods

Name | Description
GetTemplate(String, NotificationContentType) | Gets the template.
GetTemplate(String, String, NotificationContentType) | Gets the template.
GetTemplateByTemplateName | Gets the name of the template by template.
ReplacePlaceholders(String, Dictionary<(Of <<'(String, String>)>>), array<Object>[]()[][]) | This replaces the placeholders with the values form objects passed the object placeholders should be of expression --namespacename.objectname.propertyname-- the key place holders should be of expression {{key name}}
ReplacePlaceholders(String, Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, Object>)>>), array<Object>[]()[][]) | This replaces the placeholders with the values form objects passed
ReplacePlaceholders(String, String, Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, Object>)>>), array<Object>[]()[][]) | Replaces the placeholders.

See Also

NotificationTemplateManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationTemplateManager Methods
NotificationTemplateManager Class See Also Send Feedback

The NotificationTemplateManager type exposes the following members.

Methods

Name | Description
GetTemplate(String, NotificationContentType) | Gets the template.
GetTemplate(String, String, NotificationContentType) | Gets the template.
GetTemplateByTemplateName | Gets the name of the template by template.
ReplacePlaceholders(String, Dictionary<(Of <<'(String, String>)>>), array<Object>[]()[][]) | This replaces the placeholders with the values form objects passed the object placeholders should be of expression --namespacename.objectname.propertyname-- the key place holders should be of expression {{key name}}
ReplacePlaceholders(String, Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, Object>)>>), array<Object>[]()[][]) | This replaces the placeholders with the values form objects passed
ReplacePlaceholders(String, String, Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, Object>)>>), array<Object>[]()[][]) | Replaces the placeholders.

See Also

NotificationTemplateManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.GetTemplate Method

[image] [image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..GetTemplate Method
NotificationTemplateManager Class See Also Send Feedback

Overload List

Name | Description
GetTemplate(String, NotificationContentType) | Gets the template.
GetTemplate(String, String, NotificationContentType) | Gets the template.

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.GetTemplate Method (String, NotificationContentType)

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..GetTemplate Method (String, NotificationContentType)
NotificationTemplateManager Class See Also Send Feedback
Gets the template.

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static INotificationTemplate GetTemplate(
    string templateId,
    NotificationContentType contentType
)
Visual Basic
Public Shared Function GetTemplate (
    templateId As String,
    contentType As NotificationContentType
) As INotificationTemplate
Visual C++
public:
static INotificationTemplate^ GetTemplate(
    String^ templateId,
    NotificationContentType contentType
)

Parameters

templateId
Type: System..::..String
The template id.
contentType
Type: CelloSaaS.Notification.Model..::..NotificationContentType
Type of the content.

Return Value

Type: INotificationTemplate
Notification template details

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
GetTemplate Overload
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.GetTemplate Method (String, String, NotificationContentType)

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..GetTemplate Method (String, String, NotificationContentType)
NotificationTemplateManager Class See Also Send Feedback
Gets the template.

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static INotificationTemplate GetTemplate(
    string templateId,
    string localeId,
    NotificationContentType contentType
)
Visual Basic
Public Shared Function GetTemplate (
    templateId As String,
    localeId As String,
    contentType As NotificationContentType
) As INotificationTemplate
Visual C++
public:
static INotificationTemplate^ GetTemplate(
    String^ templateId,
    String^ localeId,
    NotificationContentType contentType
)

Parameters

templateId
Type: System..::..String
The template id.
localeId
Type: System..::..String
The locale id.
contentType
Type: CelloSaaS.Notification.Model..::..NotificationContentType
Type of the content.

Return Value

Type: INotificationTemplate

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
GetTemplate Overload
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.GetTemplateByTemplateName Method

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..GetTemplateByTemplateName Method
NotificationTemplateManager Class See Also Send Feedback
Gets the name of the template by template.

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static INotificationTemplate GetTemplateByTemplateName(
    string templateName,
    string localeId,
    string tenantId,
    NotificationContentType contentType
)
Visual Basic
Public Shared Function GetTemplateByTemplateName (
    templateName As String,
    localeId As String,
    tenantId As String,
    contentType As NotificationContentType
) As INotificationTemplate
Visual C++
public:
static INotificationTemplate^ GetTemplateByTemplateName(
    String^ templateName,
    String^ localeId,
    String^ tenantId,
    NotificationContentType contentType
)

Parameters

templateName
Type: System..::..String
Name of the template.
localeId
Type: System..::..String
The locale id.
tenantId
Type: System..::..String
contentType
Type: CelloSaaS.Notification.Model..::..NotificationContentType
Type of the content.

Return Value

Type: INotificationTemplate

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.ReplacePlaceholders Method

[image] [image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..ReplacePlaceholders Method
NotificationTemplateManager Class See Also Send Feedback

Overload List

Name | Description
ReplacePlaceholders(String, Dictionary<(Of <<'(String, String>)>>), array<Object>[]()[][]) | This replaces the placeholders with the values form objects passed the object placeholders should be of expression --namespacename.objectname.propertyname-- the key place holders should be of expression {{key name}}
ReplacePlaceholders(String, Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, Object>)>>), array<Object>[]()[][]) | This replaces the placeholders with the values form objects passed
ReplacePlaceholders(String, String, Dictionary<(Of <<'(String, String>)>>), Dictionary<(Of <<'(String, Object>)>>), array<Object>[]()[][]) | Replaces the placeholders.

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.ReplacePlaceholders Method (String, Dictionary(String, String), Object[])

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..ReplacePlaceholders Method (String, Dictionary<(Of <(<'String, String>)>)>, array<Object>[]()[][])
NotificationTemplateManager Class See Also Send Feedback
This replaces the placeholders with the values form objects passed the object placeholders should be of expression --namespacename.objectname.propertyname-- the key place holders should be of expression {{key name}}

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ReplacePlaceholders(
    string notificationMessage,
    Dictionary<string, string> keys,
    Object[] args
)
Visual Basic
Public Shared Function ReplacePlaceholders (
    notificationMessage As String,
    keys As Dictionary(Of String, String),
    args As Object()
) As String
Visual C++
public:
static String^ ReplacePlaceholders(
    String^ notificationMessage,
    Dictionary<String^, String^>^ keys,
    array<Object^>^ args
)

Parameters

notificationMessage
Type: System..::..String
Notification Message
keys
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
Replacement Values
args
Type: array<System..::..Object>[]()[][]
Object Values

Return Value

Type: String
Content Message

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
ReplacePlaceholders Overload
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.ReplacePlaceholders Method (String, Dictionary(String, String), Dictionary(String, Object), Object[])

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..ReplacePlaceholders Method (String, Dictionary<(Of <(<'String, String>)>)>, Dictionary<(Of <(<'String, Object>)>)>, array<Object>[]()[][])
NotificationTemplateManager Class See Also Send Feedback
This replaces the placeholders with the values form objects passed

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ReplacePlaceholders(
    string notificationMessage,
    Dictionary<string, string> keys,
    Dictionary<string, Object> objects,
    Object[] args
)
Visual Basic
Public Shared Function ReplacePlaceholders (
    notificationMessage As String,
    keys As Dictionary(Of String, String),
    objects As Dictionary(Of String, Object),
    args As Object()
) As String
Visual C++
public:
static String^ ReplacePlaceholders(
    String^ notificationMessage,
    Dictionary<String^, String^>^ keys,
    Dictionary<String^, Object^>^ objects,
    array<Object^>^ args
)

Parameters

notificationMessage
Type: System..::..String
Notification Message
keys
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
Replacement Values
objects
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, Object>)>)>
Object Details
args
Type: array<System..::..Object>[]()[][]
Object Values

Return Value

Type: String
Content Message

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
ReplacePlaceholders Overload
CelloSaaS.Notification.NotificationManager.Content Namespace


NotificationTemplateManager.ReplacePlaceholders Method (String, String, Dictionary(String, String), Dictionary(String, Object), Object[])

[image]

A Sandcastle Documented Class Library
NotificationTemplateManager..::..ReplacePlaceholders Method (String, String, Dictionary<(Of <(<'String, String>)>)>, Dictionary<(Of <(<'String, Object>)>)>, array<Object>[]()[][])
NotificationTemplateManager Class See Also Send Feedback
Replaces the placeholders.

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ReplacePlaceholders(
    string notificationMessage,
    string tenantId,
    Dictionary<string, string> keys,
    Dictionary<string, Object> objects,
    Object[] args
)
Visual Basic
Public Shared Function ReplacePlaceholders (
    notificationMessage As String,
    tenantId As String,
    keys As Dictionary(Of String, String),
    objects As Dictionary(Of String, Object),
    args As Object()
) As String
Visual C++
public:
static String^ ReplacePlaceholders(
    String^ notificationMessage,
    String^ tenantId,
    Dictionary<String^, String^>^ keys,
    Dictionary<String^, Object^>^ objects,
    array<Object^>^ args
)

Parameters

notificationMessage
Type: System..::..String
The notification message.
tenantId
Type: System..::..String
The tenant id.
keys
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
The keys.
objects
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, Object>)>)>
The objects.
args
Type: array<System..::..Object>[]()[][]
The args.

Return Value

Type: String

See Also

NotificationTemplateManager Class
NotificationTemplateManager Members
ReplacePlaceholders Overload
CelloSaaS.Notification.NotificationManager.Content Namespace


SystemNotificationContentManager Class

[image]

A Sandcastle Documented Class Library
SystemNotificationContentManager Class
Members See Also Send Feedback
This class contain system notification content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class SystemNotificationContentManager : INotificationContentManager
Visual Basic
Public Class SystemNotificationContentManager
    Implements INotificationContentManager
Visual C++
public ref class SystemNotificationContentManager : INotificationContentManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..SystemNotificationContentManager

See Also

SystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


SystemNotificationContentManager Members

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationContentManager Members
SystemNotificationContentManager Class Constructors Methods See Also Send Feedback

The SystemNotificationContentManager type exposes the following members.

Constructors

 | Name | Description
Public method | SystemNotificationContentManager | Initializes a new instance of the SystemNotificationContentManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


SystemNotificationContentManager Constructor

[image]

A Sandcastle Documented Class Library
SystemNotificationContentManager Constructor
SystemNotificationContentManager Class See Also Send Feedback
Initializes a new instance of the SystemNotificationContentManager class

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationContentManager()
Visual Basic
Public Sub New
Visual C++
public:
SystemNotificationContentManager()

See Also

SystemNotificationContentManager Class
SystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


SystemNotificationContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationContentManager Methods
SystemNotificationContentManager Class See Also Send Feedback

The SystemNotificationContentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


SystemNotificationContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
SystemNotificationContentManager..::..InitializeContentFromTemplate Method
SystemNotificationContentManager Class See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Public Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
public:
virtual void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

Implements

INotificationContentManager..::..InitializeContentFromTemplate(String, String, INotificationTemplate, INotificationContent)

See Also

SystemNotificationContentManager Class
SystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


SystemNotificationContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
SystemNotificationContentManager..::..ProcessContent Method
SystemNotificationContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
virtual void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
) sealed

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

Implements

INotificationContentManager..::..ProcessContent(INotificationContent, String)

See Also

SystemNotificationContentManager Class
SystemNotificationContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


TextMessageContentManager Class

[image]

A Sandcastle Documented Class Library
TextMessageContentManager Class
Members See Also Send Feedback
This class contain text message content manager details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class TextMessageContentManager : INotificationContentManager
Visual Basic
Public Class TextMessageContentManager
    Implements INotificationContentManager
Visual C++
public ref class TextMessageContentManager : INotificationContentManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Content..::..TextMessageContentManager

See Also

TextMessageContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


TextMessageContentManager Members

[image] [image]

A Sandcastle Documented Class Library
TextMessageContentManager Members
TextMessageContentManager Class Constructors Methods See Also Send Feedback

The TextMessageContentManager type exposes the following members.

Constructors

 | Name | Description
Public method | TextMessageContentManager | Initializes a new instance of the TextMessageContentManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextMessageContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


TextMessageContentManager Constructor

[image]

A Sandcastle Documented Class Library
TextMessageContentManager Constructor
TextMessageContentManager Class See Also Send Feedback
Initializes a new instance of the TextMessageContentManager class

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TextMessageContentManager()
Visual Basic
Public Sub New
Visual C++
public:
TextMessageContentManager()

See Also

TextMessageContentManager Class
TextMessageContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


TextMessageContentManager Methods

[image] [image]

A Sandcastle Documented Class Library
TextMessageContentManager Methods
TextMessageContentManager Class See Also Send Feedback

The TextMessageContentManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeContentFromTemplate | This method is used to prepare content from template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessContent | This method is used to process content details
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextMessageContentManager Class
CelloSaaS.Notification.NotificationManager.Content Namespace


TextMessageContentManager.InitializeContentFromTemplate Method

[image]

A Sandcastle Documented Class Library
TextMessageContentManager..::..InitializeContentFromTemplate Method
TextMessageContentManager Class See Also Send Feedback
This method is used to prepare content from template

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void InitializeContentFromTemplate(
    string notificationId,
    string tenantId,
    INotificationTemplate notificationTemplate,
    INotificationContent content
)
Visual Basic
Public Sub InitializeContentFromTemplate (
    notificationId As String,
    tenantId As String,
    notificationTemplate As INotificationTemplate,
    content As INotificationContent
)
Visual C++
public:
virtual void InitializeContentFromTemplate(
    String^ notificationId,
    String^ tenantId,
    INotificationTemplate^ notificationTemplate,
    INotificationContent^ content
) sealed

Parameters

notificationId
Type: System..::..String
Notification Identifier
tenantId
Type: System..::..String
notificationTemplate
Type: CelloSaaS.Notification.Model.Content..::..INotificationTemplate
Notification Template Details
content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details

Implements

INotificationContentManager..::..InitializeContentFromTemplate(String, String, INotificationTemplate, INotificationContent)

See Also

TextMessageContentManager Class
TextMessageContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


TextMessageContentManager.ProcessContent Method

[image]

A Sandcastle Documented Class Library
TextMessageContentManager..::..ProcessContent Method
TextMessageContentManager Class See Also Send Feedback
This method is used to process content details

Namespace: CelloSaaS.Notification.NotificationManager.Content
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void ProcessContent(
    INotificationContent content,
    string tenantId
)
Visual Basic
Public Sub ProcessContent (
    content As INotificationContent,
    tenantId As String
)
Visual C++
public:
virtual void ProcessContent(
    INotificationContent^ content,
    String^ tenantId
) sealed

Parameters

content
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
tenantId
Type: System..::..String

Implements

INotificationContentManager..::..ProcessContent(INotificationContent, String)

See Also

TextMessageContentManager Class
TextMessageContentManager Members
CelloSaaS.Notification.NotificationManager.Content Namespace


CelloSaaS.Notification.NotificationManager.Dispatch Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.NotificationManager.Dispatch Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchEmailDispatchManager | This class contain Batch Email Dispatch Manager Details
Public class | BatchFtpDispatchManager | This class contain Batch Ftp Dispatch Manager Details
Public class | BatchSystemNotificationDispatchManager | This class contain Batch System Notification Dispatch manager details
Public class | EmailDispatchManager | This class contain Email Dispatch manager details
Public class | FileDispatchManager | This class is used to dispatch file details
Public class | NotificationDispatchFactory | This factory class is used to get notification dispatch manager details
Public class | NotificationDispatchManager | This class is used to dispatch the content details
Public class | SystemNotificationDispatchManager | This class contain System Notification Dispatch manager details

Interfaces

 | Interface | Description
Public interface | INotificationDispatchManager | This interface contain Notification Dispatch Manager Details


BatchEmailDispatchManager Class

[image]

A Sandcastle Documented Class Library
BatchEmailDispatchManager Class
Members See Also Send Feedback
This class contain Batch Email Dispatch Manager Details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchEmailDispatchManager : INotificationDispatchManager
Visual Basic
Public Class BatchEmailDispatchManager
    Implements INotificationDispatchManager
Visual C++
public ref class BatchEmailDispatchManager : INotificationDispatchManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..BatchEmailDispatchManager

See Also

BatchEmailDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchEmailDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
BatchEmailDispatchManager Members
BatchEmailDispatchManager Class Constructors Methods See Also Send Feedback

The BatchEmailDispatchManager type exposes the following members.

Constructors

 | Name | Description
Public method | BatchEmailDispatchManager | Initializes a new instance of the BatchEmailDispatchManager class

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchEmailDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchEmailDispatchManager Constructor

[image]

A Sandcastle Documented Class Library
BatchEmailDispatchManager Constructor
BatchEmailDispatchManager Class See Also Send Feedback
Initializes a new instance of the BatchEmailDispatchManager class

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchEmailDispatchManager()
Visual Basic
Public Sub New
Visual C++
public:
BatchEmailDispatchManager()

See Also

BatchEmailDispatchManager Class
BatchEmailDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchEmailDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
BatchEmailDispatchManager Methods
BatchEmailDispatchManager Class See Also Send Feedback

The BatchEmailDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchEmailDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchEmailDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
BatchEmailDispatchManager..::..DispatchNotification Method
BatchEmailDispatchManager Class See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
virtual bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
) sealed

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
Audit Identifier

Return Value

Type: Boolean
Success or Failure

Implements

INotificationDispatchManager..::..DispatchNotification(INotificationContent, INotificationDestination, String)

See Also

BatchEmailDispatchManager Class
BatchEmailDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchFtpDispatchManager Class

[image]

A Sandcastle Documented Class Library
BatchFtpDispatchManager Class
Members See Also Send Feedback
This class contain Batch Ftp Dispatch Manager Details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchFtpDispatchManager : INotificationDispatchManager
Visual Basic
Public Class BatchFtpDispatchManager
    Implements INotificationDispatchManager
Visual C++
public ref class BatchFtpDispatchManager : INotificationDispatchManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..BatchFtpDispatchManager

See Also

BatchFtpDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchFtpDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
BatchFtpDispatchManager Members
BatchFtpDispatchManager Class Constructors Methods See Also Send Feedback

The BatchFtpDispatchManager type exposes the following members.

Constructors

 | Name | Description
Public method | BatchFtpDispatchManager | Initializes a new instance of the BatchFtpDispatchManager class

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFtpDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchFtpDispatchManager Constructor

[image]

A Sandcastle Documented Class Library
BatchFtpDispatchManager Constructor
BatchFtpDispatchManager Class See Also Send Feedback
Initializes a new instance of the BatchFtpDispatchManager class

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchFtpDispatchManager()
Visual Basic
Public Sub New
Visual C++
public:
BatchFtpDispatchManager()

See Also

BatchFtpDispatchManager Class
BatchFtpDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchFtpDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
BatchFtpDispatchManager Methods
BatchFtpDispatchManager Class See Also Send Feedback

The BatchFtpDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchFtpDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchFtpDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
BatchFtpDispatchManager..::..DispatchNotification Method
BatchFtpDispatchManager Class See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
virtual bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
) sealed

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Content of the notification.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.
auditId
Type: System..::..String
The audit id.

Return Value

Type: Boolean
Success or Failure

Implements

INotificationDispatchManager..::..DispatchNotification(INotificationContent, INotificationDestination, String)

See Also

BatchFtpDispatchManager Class
BatchFtpDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchSystemNotificationDispatchManager Class

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDispatchManager Class
Members See Also Send Feedback
This class contain Batch System Notification Dispatch manager details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class BatchSystemNotificationDispatchManager : INotificationDispatchManager
Visual Basic
Public Class BatchSystemNotificationDispatchManager
    Implements INotificationDispatchManager
Visual C++
public ref class BatchSystemNotificationDispatchManager : INotificationDispatchManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..BatchSystemNotificationDispatchManager

See Also

BatchSystemNotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchSystemNotificationDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationDispatchManager Members
BatchSystemNotificationDispatchManager Class Constructors Methods See Also Send Feedback

The BatchSystemNotificationDispatchManager type exposes the following members.

Constructors

 | Name | Description
Public method | BatchSystemNotificationDispatchManager | Initializes a new instance of the BatchSystemNotificationDispatchManager class

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchSystemNotificationDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchSystemNotificationDispatchManager Constructor

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDispatchManager Constructor
BatchSystemNotificationDispatchManager Class See Also Send Feedback
Initializes a new instance of the BatchSystemNotificationDispatchManager class

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BatchSystemNotificationDispatchManager()
Visual Basic
Public Sub New
Visual C++
public:
BatchSystemNotificationDispatchManager()

See Also

BatchSystemNotificationDispatchManager Class
BatchSystemNotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchSystemNotificationDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
BatchSystemNotificationDispatchManager Methods
BatchSystemNotificationDispatchManager Class See Also Send Feedback

The BatchSystemNotificationDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BatchSystemNotificationDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


BatchSystemNotificationDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
BatchSystemNotificationDispatchManager..::..DispatchNotification Method
BatchSystemNotificationDispatchManager Class See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
virtual bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
) sealed

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
Audit Identifier

Return Value

Type: Boolean
Success or Failure

Implements

INotificationDispatchManager..::..DispatchNotification(INotificationContent, INotificationDestination, String)

See Also

BatchSystemNotificationDispatchManager Class
BatchSystemNotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


EmailDispatchManager Class

[image]

A Sandcastle Documented Class Library
EmailDispatchManager Class
Members See Also Send Feedback
This class contain Email Dispatch manager details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class EmailDispatchManager : INotificationDispatchManager
Visual Basic
Public Class EmailDispatchManager
    Implements INotificationDispatchManager
Visual C++
public ref class EmailDispatchManager : INotificationDispatchManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..EmailDispatchManager

See Also

EmailDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


EmailDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
EmailDispatchManager Members
EmailDispatchManager Class Constructors Methods See Also Send Feedback

The EmailDispatchManager type exposes the following members.

Constructors

 | Name | Description
Public method | EmailDispatchManager | Initializes a new instance of the EmailDispatchManager class

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


EmailDispatchManager Constructor

[image]

A Sandcastle Documented Class Library
EmailDispatchManager Constructor
EmailDispatchManager Class See Also Send Feedback
Initializes a new instance of the EmailDispatchManager class

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public EmailDispatchManager()
Visual Basic
Public Sub New
Visual C++
public:
EmailDispatchManager()

See Also

EmailDispatchManager Class
EmailDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


EmailDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
EmailDispatchManager Methods
EmailDispatchManager Class See Also Send Feedback

The EmailDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EmailDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


EmailDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
EmailDispatchManager..::..DispatchNotification Method
EmailDispatchManager Class See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
virtual bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
) sealed

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
Audit Identifier

Return Value

Type: Boolean
Success or Failure

Implements

INotificationDispatchManager..::..DispatchNotification(INotificationContent, INotificationDestination, String)

See Also

EmailDispatchManager Class
EmailDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


FileDispatchManager Class

[image]

A Sandcastle Documented Class Library
FileDispatchManager Class
Members See Also Send Feedback
This class is used to dispatch file details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class FileDispatchManager : INotificationDispatchManager
Visual Basic
Public Class FileDispatchManager
    Implements INotificationDispatchManager
Visual C++
public ref class FileDispatchManager : INotificationDispatchManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..FileDispatchManager

See Also

FileDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


FileDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
FileDispatchManager Members
FileDispatchManager Class Constructors Methods See Also Send Feedback

The FileDispatchManager type exposes the following members.

Constructors

 | Name | Description
Public method | FileDispatchManager | Initializes a new instance of the FileDispatchManager class

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


FileDispatchManager Constructor

[image]

A Sandcastle Documented Class Library
FileDispatchManager Constructor
FileDispatchManager Class See Also Send Feedback
Initializes a new instance of the FileDispatchManager class

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FileDispatchManager()
Visual Basic
Public Sub New
Visual C++
public:
FileDispatchManager()

See Also

FileDispatchManager Class
FileDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


FileDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
FileDispatchManager Methods
FileDispatchManager Class See Also Send Feedback

The FileDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FileDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


FileDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
FileDispatchManager..::..DispatchNotification Method
FileDispatchManager Class See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
virtual bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
) sealed

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
Audit Identifier

Return Value

Type: Boolean
Success or Failure

Implements

INotificationDispatchManager..::..DispatchNotification(INotificationContent, INotificationDestination, String)

See Also

FileDispatchManager Class
FileDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


INotificationDispatchManager Interface

[image]

A Sandcastle Documented Class Library
INotificationDispatchManager Interface
Members See Also Send Feedback
This interface contain Notification Dispatch Manager Details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationDispatchManager
Visual Basic
Public Interface INotificationDispatchManager
Visual C++
public interface class INotificationDispatchManager

See Also

INotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


INotificationDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
INotificationDispatchManager Members
INotificationDispatchManager Interface Methods See Also Send Feedback

The INotificationDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details

See Also

INotificationDispatchManager Interface
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


INotificationDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
INotificationDispatchManager Methods
INotificationDispatchManager Interface See Also Send Feedback

The INotificationDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details

See Also

INotificationDispatchManager Interface
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


INotificationDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
INotificationDispatchManager..::..DispatchNotification Method
INotificationDispatchManager Interface See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
)

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
The audit id.

Return Value

Type: Boolean
Success or Failure

See Also

INotificationDispatchManager Interface
INotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchFactory Class

[image]

A Sandcastle Documented Class Library
NotificationDispatchFactory Class
Members See Also Send Feedback
This factory class is used to get notification dispatch manager details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationDispatchFactory
Visual Basic
Public NotInheritable Class NotificationDispatchFactory
Visual C++
public ref class NotificationDispatchFactory abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..NotificationDispatchFactory

See Also

NotificationDispatchFactory Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchFactory Members

[image] [image]

A Sandcastle Documented Class Library
NotificationDispatchFactory Members
NotificationDispatchFactory Class Methods See Also Send Feedback

The NotificationDispatchFactory type exposes the following members.

Methods

Name | Description
GetDispatchManager | This method is used to get notification dispatch manager details

See Also

NotificationDispatchFactory Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchFactory Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationDispatchFactory Methods
NotificationDispatchFactory Class See Also Send Feedback

The NotificationDispatchFactory type exposes the following members.

Methods

Name | Description
GetDispatchManager | This method is used to get notification dispatch manager details

See Also

NotificationDispatchFactory Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchFactory.GetDispatchManager Method

[image]

A Sandcastle Documented Class Library
NotificationDispatchFactory..::..GetDispatchManager Method
NotificationDispatchFactory Class See Also Send Feedback
This method is used to get notification dispatch manager details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static INotificationDispatchManager GetDispatchManager(
    NotificationContentType notificationContentType,
    NotificationDestinationType notificationDestinationType
)
Visual Basic
Public Shared Function GetDispatchManager (
    notificationContentType As NotificationContentType,
    notificationDestinationType As NotificationDestinationType
) As INotificationDispatchManager
Visual C++
public:
static INotificationDispatchManager^ GetDispatchManager(
    NotificationContentType notificationContentType,
    NotificationDestinationType notificationDestinationType
)

Parameters

notificationContentType
Type: CelloSaaS.Notification.Model..::..NotificationContentType
Notification Content Type
notificationDestinationType
Type: CelloSaaS.Notification.Model..::..NotificationDestinationType
Notification Dispatch Type

Return Value

Type: INotificationDispatchManager
Notification Dispatch Manager Details

See Also

NotificationDispatchFactory Class
NotificationDispatchFactory Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchManager Class

[image]

A Sandcastle Documented Class Library
NotificationDispatchManager Class
Members See Also Send Feedback
This class is used to dispatch the content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationDispatchManager
Visual Basic
Public NotInheritable Class NotificationDispatchManager
Visual C++
public ref class NotificationDispatchManager abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..NotificationDispatchManager

See Also

NotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
NotificationDispatchManager Members
NotificationDispatchManager Class Methods See Also Send Feedback

The NotificationDispatchManager type exposes the following members.

Methods

Name | Description
DispatchNotification | This method is used to dispatch notification content details

See Also

NotificationDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationDispatchManager Methods
NotificationDispatchManager Class See Also Send Feedback

The NotificationDispatchManager type exposes the following members.

Methods

Name | Description
DispatchNotification | This method is used to dispatch notification content details

See Also

NotificationDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


NotificationDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
NotificationDispatchManager..::..DispatchNotification Method
NotificationDispatchManager Class See Also Send Feedback
This method is used to dispatch notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Shared Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
static bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
)

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
The audit id.

Return Value

Type: Boolean
Success or Failure

See Also

NotificationDispatchManager Class
NotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


SystemNotificationDispatchManager Class

[image]

A Sandcastle Documented Class Library
SystemNotificationDispatchManager Class
Members See Also Send Feedback
This class contain System Notification Dispatch manager details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class SystemNotificationDispatchManager : INotificationDispatchManager
Visual Basic
Public Class SystemNotificationDispatchManager
    Implements INotificationDispatchManager
Visual C++
public ref class SystemNotificationDispatchManager : INotificationDispatchManager

Inheritance Hierarchy

System..::..Object
CelloSaaS.Notification.NotificationManager.Dispatch..::..SystemNotificationDispatchManager

See Also

SystemNotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


SystemNotificationDispatchManager Members

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDispatchManager Members
SystemNotificationDispatchManager Class Constructors Methods See Also Send Feedback

The SystemNotificationDispatchManager type exposes the following members.

Constructors

 | Name | Description
Public method | SystemNotificationDispatchManager | Initializes a new instance of the SystemNotificationDispatchManager class

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


SystemNotificationDispatchManager Constructor

[image]

A Sandcastle Documented Class Library
SystemNotificationDispatchManager Constructor
SystemNotificationDispatchManager Class See Also Send Feedback
Initializes a new instance of the SystemNotificationDispatchManager class

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SystemNotificationDispatchManager()
Visual Basic
Public Sub New
Visual C++
public:
SystemNotificationDispatchManager()

See Also

SystemNotificationDispatchManager Class
SystemNotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


SystemNotificationDispatchManager Methods

[image] [image]

A Sandcastle Documented Class Library
SystemNotificationDispatchManager Methods
SystemNotificationDispatchManager Class See Also Send Feedback

The SystemNotificationDispatchManager type exposes the following members.

Methods

 | Name | Description
Public method | DispatchNotification | This method is used to dispatch the notification content details
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SystemNotificationDispatchManager Class
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


SystemNotificationDispatchManager.DispatchNotification Method

[image]

A Sandcastle Documented Class Library
SystemNotificationDispatchManager..::..DispatchNotification Method
SystemNotificationDispatchManager Class See Also Send Feedback
This method is used to dispatch the notification content details

Namespace: CelloSaaS.Notification.NotificationManager.Dispatch
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool DispatchNotification(
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    string auditId
)
Visual Basic
Public Function DispatchNotification (
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    auditId As String
) As Boolean
Visual C++
public:
virtual bool DispatchNotification(
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    String^ auditId
) sealed

Parameters

notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
auditId
Type: System..::..String
Audit Identifier

Return Value

Type: Boolean
Success or Failure

Implements

INotificationDispatchManager..::..DispatchNotification(INotificationContent, INotificationDestination, String)

See Also

SystemNotificationDispatchManager Class
SystemNotificationDispatchManager Members
CelloSaaS.Notification.NotificationManager.Dispatch Namespace


CelloSaaS.Notification.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Notification.ServiceContracts Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | INotificationAuditService | This Interface is used to expose the notification audit services as wcf service.
Public interface | INotificationConfigurationService | This Interface is used to expose the notification configuration services as wcf service.
Public interface | INotificationService | This Interface is used to expose the notification services as wcf service.


INotificationAuditService Interface

[image]

A Sandcastle Documented Class Library
INotificationAuditService Interface
Members See Also Send Feedback
This Interface is used to expose the notification audit services as wcf service.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationAuditService
Visual Basic
Public Interface INotificationAuditService
Visual C++
public interface class INotificationAuditService

See Also

INotificationAuditService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationAuditService Members

[image] [image]

A Sandcastle Documented Class Library
INotificationAuditService Members
INotificationAuditService Interface Methods See Also Send Feedback

The INotificationAuditService type exposes the following members.

Methods

 | Name | Description
Public method | LogPostNotification | This method is used to log notification details after dispatch
Public method | LogPreNotification | This method is used to add notification pre log details(Notification Audit)
Public method | SearchNotificationAuditDetails | Gets the notification audit details.

See Also

INotificationAuditService Interface
CelloSaaS.Notification.ServiceContracts Namespace


INotificationAuditService Methods

[image] [image]

A Sandcastle Documented Class Library
INotificationAuditService Methods
INotificationAuditService Interface See Also Send Feedback

The INotificationAuditService type exposes the following members.

Methods

 | Name | Description
Public method | LogPostNotification | This method is used to log notification details after dispatch
Public method | LogPreNotification | This method is used to add notification pre log details(Notification Audit)
Public method | SearchNotificationAuditDetails | Gets the notification audit details.

See Also

INotificationAuditService Interface
CelloSaaS.Notification.ServiceContracts Namespace


INotificationAuditService.LogPostNotification Method

[image]

A Sandcastle Documented Class Library
INotificationAuditService..::..LogPostNotification Method
INotificationAuditService Interface See Also Send Feedback
This method is used to log notification details after dispatch

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void LogPostNotification(
    string notificationAuditId,
    INotificationContent notificationContent,
    INotificationDestination notificationDestination,
    NotificationStatus notificationStatus
)
Visual Basic
Sub LogPostNotification (
    notificationAuditId As String,
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination,
    notificationStatus As NotificationStatus
)
Visual C++
void LogPostNotification(
    String^ notificationAuditId,
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination,
    NotificationStatus notificationStatus
)

Parameters

notificationAuditId
Type: System..::..String
Notification Audit Identifier
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Notification Content Details
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
Notification Destination Details
notificationStatus
Type: CelloSaaS.Notification.Model..::..NotificationStatus
Notification Status

See Also

INotificationAuditService Interface
INotificationAuditService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationAuditService.LogPreNotification Method

[image]

A Sandcastle Documented Class Library
INotificationAuditService..::..LogPreNotification Method
INotificationAuditService Interface See Also Send Feedback
This method is used to add notification pre log details(Notification Audit)

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string LogPreNotification(
    NotificationAudit notificationAudit
)
Visual Basic
Function LogPreNotification (
    notificationAudit As NotificationAudit
) As String
Visual C++
String^ LogPreNotification(
    NotificationAudit^ notificationAudit
)

Parameters

notificationAudit
Type: CelloSaaS.Notification.Model..::..NotificationAudit
Notification Audit Details

Return Value

Type: String
Notification Audit Identifier

See Also

INotificationAuditService Interface
INotificationAuditService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationAuditService.SearchNotificationAuditDetails Method

[image]

A Sandcastle Documented Class Library
INotificationAuditService..::..SearchNotificationAuditDetails Method
INotificationAuditService Interface See Also Send Feedback
Gets the notification audit details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationAuditSearchResult SearchNotificationAuditDetails(
    NotificationAuditSearchCondition notificationAuditSearchCondition
)
Visual Basic
Function SearchNotificationAuditDetails (
    notificationAuditSearchCondition As NotificationAuditSearchCondition
) As NotificationAuditSearchResult
Visual C++
NotificationAuditSearchResult^ SearchNotificationAuditDetails(
    NotificationAuditSearchCondition^ notificationAuditSearchCondition
)

Parameters

notificationAuditSearchCondition
Type: CelloSaaS.Notification.Model..::..NotificationAuditSearchCondition
The notification audit search condition.

Return Value

Type: NotificationAuditSearchResult

See Also

INotificationAuditService Interface
INotificationAuditService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService Interface

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService Interface
Members See Also Send Feedback
This Interface is used to expose the notification configuration services as wcf service.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationConfigurationService
Visual Basic
Public Interface INotificationConfigurationService
Visual C++
public interface class INotificationConfigurationService

See Also

INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService Members

[image] [image]

A Sandcastle Documented Class Library
INotificationConfigurationService Members
INotificationConfigurationService Interface Methods See Also Send Feedback

The INotificationConfigurationService type exposes the following members.

Methods

 | Name | Description
Public method | ConfigureEmailDetails | This method is used to Configure the Email Notification Details.
Public method | ConfigureFtpDetails | This method is used to Configure the File Notification Details.
Public method | ConfigureNotificationMaster | This method is used to Configures the notification master.
Public method | ConfigureSystemNotificationDetails | This method is used to Configure the System Notification Details.
Public method | GetNotificationMasterDetailsById | This method is used to Get the notification master details by using the notification master id.
Public method | GetNotificationMasterDetailsByTenantId | This method is used to gets the notification master details for the particular tenant.
Public method | RemoveConfiguration | This method is used to remove the Configuration Details related to the Notification Master Id
Public method | UpdateEmailDetails | This method is used to updates the email details.
Public method | UpdateEmailDispatchDetails | This method is used to update the email dispatch details.
Public method | UpdateFtpDetails | This method is used to updates the FTP details.
Public method | UpdateNotificationMasterDetails | This method is used to updates the notification master details.

See Also

INotificationConfigurationService Interface
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService Methods

[image] [image]

A Sandcastle Documented Class Library
INotificationConfigurationService Methods
INotificationConfigurationService Interface See Also Send Feedback

The INotificationConfigurationService type exposes the following members.

Methods

 | Name | Description
Public method | ConfigureEmailDetails | This method is used to Configure the Email Notification Details.
Public method | ConfigureFtpDetails | This method is used to Configure the File Notification Details.
Public method | ConfigureNotificationMaster | This method is used to Configures the notification master.
Public method | ConfigureSystemNotificationDetails | This method is used to Configure the System Notification Details.
Public method | GetNotificationMasterDetailsById | This method is used to Get the notification master details by using the notification master id.
Public method | GetNotificationMasterDetailsByTenantId | This method is used to gets the notification master details for the particular tenant.
Public method | RemoveConfiguration | This method is used to remove the Configuration Details related to the Notification Master Id
Public method | UpdateEmailDetails | This method is used to updates the email details.
Public method | UpdateEmailDispatchDetails | This method is used to update the email dispatch details.
Public method | UpdateFtpDetails | This method is used to updates the FTP details.
Public method | UpdateNotificationMasterDetails | This method is used to updates the notification master details.

See Also

INotificationConfigurationService Interface
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.ConfigureEmailDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..ConfigureEmailDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to Configure the Email Notification Details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ConfigureEmailDetails(
    NotificationDetails notificationDetails,
    EmailDetails emailDetails
)
Visual Basic
Sub ConfigureEmailDetails (
    notificationDetails As NotificationDetails,
    emailDetails As EmailDetails
)
Visual C++
void ConfigureEmailDetails(
    NotificationDetails^ notificationDetails,
    EmailDetails^ emailDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
Notification Details
emailDetails
Type: CelloSaaS.Notification.Model.Email..::..EmailDetails
Email Details

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details or email details is null
System..::..ArgumentNullException | If Notification details notification id or email details sender or email details smtp address or smtp user name or smtp password value is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.ConfigureFtpDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..ConfigureFtpDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to Configure the File Notification Details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ConfigureFtpDetails(
    NotificationDetails notificationDetails,
    FtpDetails ftpDetails
)
Visual Basic
Sub ConfigureFtpDetails (
    notificationDetails As NotificationDetails,
    ftpDetails As FtpDetails
)
Visual C++
void ConfigureFtpDetails(
    NotificationDetails^ notificationDetails,
    FtpDetails^ ftpDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
Notification Details
ftpDetails
Type: CelloSaaS.Notification.Model.Ftp..::..FtpDetails
Ftp Details

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details or ftp details is null
System..::..ArgumentNullException | If Notification details notification id or ftp details ftpaddress or ftp details ftp user name or ftp password value is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.ConfigureNotificationMaster Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..ConfigureNotificationMaster Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to Configures the notification master.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ConfigureNotificationMaster(
    NotificationDetails notificationDetails
)
Visual Basic
Function ConfigureNotificationMaster (
    notificationDetails As NotificationDetails
) As String
Visual C++
String^ ConfigureNotificationMaster(
    NotificationDetails^ notificationDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
The notification details.

Return Value

Type: String

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..DuplicateNotificationNameException | If the notification name is duplicate.
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details is null
System..::..ArgumentNullException | If Notification details notification name is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.ConfigureSystemNotificationDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..ConfigureSystemNotificationDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to Configure the System Notification Details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ConfigureSystemNotificationDetails(
    NotificationDetails notificationDetails,
    SystemNotificationDestination systemNotificationDestination,
    SystemNotificationContent systemNotificationContent
)
Visual Basic
Sub ConfigureSystemNotificationDetails (
    notificationDetails As NotificationDetails,
    systemNotificationDestination As SystemNotificationDestination,
    systemNotificationContent As SystemNotificationContent
)
Visual C++
void ConfigureSystemNotificationDetails(
    NotificationDetails^ notificationDetails,
    SystemNotificationDestination^ systemNotificationDestination,
    SystemNotificationContent^ systemNotificationContent
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
Notification Details
systemNotificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..SystemNotificationDestination
The system notification destination.
systemNotificationContent
Type: CelloSaaS.Notification.Model.Content..::..SystemNotificationContent
Content of the system notification.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details or system notification destination or system notification content is null
System..::..ArgumentNullException | If Notification details notification id is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.GetNotificationMasterDetailsById Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..GetNotificationMasterDetailsById Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to Get the notification master details by using the notification master id.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationMasterDetailsById(
    string notificationMasterId
)
Visual Basic
Function GetNotificationMasterDetailsById (
    notificationMasterId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationMasterDetailsById(
    String^ notificationMasterId
)

Parameters

notificationMasterId
Type: System..::..String
The notification master id.

Return Value

Type: NotificationDetails
Notification details

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If notification master id is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.GetNotificationMasterDetailsByTenantId Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..GetNotificationMasterDetailsByTenantId Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to gets the notification master details for the particular tenant.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<NotificationDetails> GetNotificationMasterDetailsByTenantId(
    string tenantId
)
Visual Basic
Function GetNotificationMasterDetailsByTenantId (
    tenantId As String
) As List(Of NotificationDetails)
Visual C++
List<NotificationDetails^>^ GetNotificationMasterDetailsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String

Return Value

Type: List<(Of <(<' NotificationDetails >)>)>
List of notification details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.RemoveConfiguration Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..RemoveConfiguration Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to remove the Configuration Details related to the Notification Master Id

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void RemoveConfiguration(
    string NotificationDetailsNotificationId
)
Visual Basic
Sub RemoveConfiguration (
    NotificationDetailsNotificationId As String
)
Visual C++
void RemoveConfiguration(
    String^ NotificationDetailsNotificationId
)

Parameters

NotificationDetailsNotificationId
Type: System..::..String

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentNullException | If Notification details ntification id is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.UpdateEmailDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..UpdateEmailDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to updates the email details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateEmailDetails(
    EmailDestination emailDestination,
    TextMessageContent notificationContent,
    string emailContent
)
Visual Basic
Function UpdateEmailDetails (
    emailDestination As EmailDestination,
    notificationContent As TextMessageContent,
    emailContent As String
) As String
Visual C++
String^ UpdateEmailDetails(
    EmailDestination^ emailDestination,
    TextMessageContent^ notificationContent,
    String^ emailContent
)

Parameters

emailDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..EmailDestination
The email destination.
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..TextMessageContent
Content of the notification.
emailContent
Type: System..::..String
Content of the email.

Return Value

Type: String
Email dispatch details id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If email destination or text message content is null.
System..::..ArgumentNullException | If email destination id or sender address or smtp address or smtp username or smtppassword or notification content id is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.UpdateEmailDispatchDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..UpdateEmailDispatchDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to update the email dispatch details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateEmailDispatchDetails(
    EmailDestination emailDestination
)
Visual Basic
Function UpdateEmailDispatchDetails (
    emailDestination As EmailDestination
) As String
Visual C++
String^ UpdateEmailDispatchDetails(
    EmailDestination^ emailDestination
)

Parameters

emailDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..EmailDestination
The email destination.

Return Value

Type: String
email dispatch details id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If email destination is null.
System..::..ArgumentNullException | If email destination id or sender address or recipient address or smtp user name or password is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.UpdateFtpDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..UpdateFtpDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to updates the FTP details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateFtpDetails(
    FtpDestination ftpDestination,
    FileContent fileContent
)
Visual Basic
Function UpdateFtpDetails (
    ftpDestination As FtpDestination,
    fileContent As FileContent
) As String
Visual C++
String^ UpdateFtpDetails(
    FtpDestination^ ftpDestination,
    FileContent^ fileContent
)

Parameters

ftpDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..FtpDestination
The FTP destination.
fileContent
Type: CelloSaaS.Notification.Model.Content..::..FileContent
Content of the file.

Return Value

Type: String
ftp destination details id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exception occurs, while connecting of modifying the DB
System..::..ArgumentException | If ftp destination or file content is null.
System..::..ArgumentNullException | If ftp destination id or ftp address or username or password or notification content id is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationConfigurationService.UpdateNotificationMasterDetails Method

[image]

A Sandcastle Documented Class Library
INotificationConfigurationService..::..UpdateNotificationMasterDetails Method
INotificationConfigurationService Interface See Also Send Feedback
This method is used to updates the notification master details.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateNotificationMasterDetails(
    NotificationDetails notificationDetails
)
Visual Basic
Function UpdateNotificationMasterDetails (
    notificationDetails As NotificationDetails
) As String
Visual C++
String^ UpdateNotificationMasterDetails(
    NotificationDetails^ notificationDetails
)

Parameters

notificationDetails
Type: CelloSaaS.Notification.Model..::..NotificationDetails
The notification details.

Return Value

Type: String
notification id

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..DuplicateNotificationNameException | If the notification name is duplicate.
CelloSaaS.Notification.NotificationManager..::..NotificationException | If any exceptions occures, while connecting or modifying the DB
System..::..ArgumentException | If notification details is null.
System..::..ArgumentNullException | If notification master id or notification name is null or empty.

See Also

INotificationConfigurationService Interface
INotificationConfigurationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService Interface

[image]

A Sandcastle Documented Class Library
INotificationService Interface
Members See Also Send Feedback
This Interface is used to expose the notification services as wcf service.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface INotificationService
Visual Basic
Public Interface INotificationService
Visual C++
public interface class INotificationService

See Also

INotificationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService Members

[image] [image]

A Sandcastle Documented Class Library
INotificationService Members
INotificationService Interface Methods See Also Send Feedback

The INotificationService type exposes the following members.

Methods

 | Name | Description
Public method | GetNotificationDetails(String, String) | This method is used to gets the the notification details by using the notification id and the tenant id.
Public method | GetNotificationDetails(String, String, String) | This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.
Public method | GetNotificationDetailsByName(String, String) | This method is used to gets the notification details by using the notification name and the tenant id.
Public method | GetNotificationDetailsByName(String, String, String) | This method is used to gets the notification details by using the notification name with the given locale id.
Public method | ProcessAndSendBatchNotification(String, String, IBatchNotificationContent, IBatchNotificationDestination) | This method is used to processes the batch content and send the batch notification.
Public method | ProcessAndSendBatchNotification(String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content
Public method | ProcessAndSendBatchNotification(String, String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This method is used to Processes and send batch notification with locale id
Public method | ProcessAndSendNotification(String, String, INotificationContent, INotificationDestination) | This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.
Public method | ProcessAndSendNotification(String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content
Public method | ProcessAndSendNotification(String, String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content
Public method | SendNotification | This method is used to send a email or upload a file.

See Also

INotificationService Interface
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService Methods

[image] [image]

A Sandcastle Documented Class Library
INotificationService Methods
INotificationService Interface See Also Send Feedback

The INotificationService type exposes the following members.

Methods

 | Name | Description
Public method | GetNotificationDetails(String, String) | This method is used to gets the the notification details by using the notification id and the tenant id.
Public method | GetNotificationDetails(String, String, String) | This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.
Public method | GetNotificationDetailsByName(String, String) | This method is used to gets the notification details by using the notification name and the tenant id.
Public method | GetNotificationDetailsByName(String, String, String) | This method is used to gets the notification details by using the notification name with the given locale id.
Public method | ProcessAndSendBatchNotification(String, String, IBatchNotificationContent, IBatchNotificationDestination) | This method is used to processes the batch content and send the batch notification.
Public method | ProcessAndSendBatchNotification(String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content
Public method | ProcessAndSendBatchNotification(String, String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This method is used to Processes and send batch notification with locale id
Public method | ProcessAndSendNotification(String, String, INotificationContent, INotificationDestination) | This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.
Public method | ProcessAndSendNotification(String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content
Public method | ProcessAndSendNotification(String, String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content
Public method | SendNotification | This method is used to send a email or upload a file.

See Also

INotificationService Interface
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.GetNotificationDetails Method

[image] [image]

A Sandcastle Documented Class Library
INotificationService..::..GetNotificationDetails Method
INotificationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationDetails(String, String) | This method is used to gets the the notification details by using the notification id and the tenant id.
Public method | GetNotificationDetails(String, String, String) | This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.

See Also

INotificationService Interface
INotificationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.GetNotificationDetails Method (String, String)

[image]

A Sandcastle Documented Class Library
INotificationService..::..GetNotificationDetails Method (String, String)
INotificationService Interface See Also Send Feedback
This method is used to gets the the notification details by using the notification id and the tenant id.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId
)
Visual Basic
Function GetNotificationDetails (
    notificationId As String,
    tenantId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
[!:NotificationException] | If Notification Identifier Not available

See Also

INotificationService Interface
INotificationService Members
GetNotificationDetails Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.GetNotificationDetails Method (String, String, String)

[image]

A Sandcastle Documented Class Library
INotificationService..::..GetNotificationDetails Method (String, String, String)
INotificationService Interface See Also Send Feedback
This method is used to gets the the notification details by using the notification id and the tenant id based on the locale id.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetails(
    string notificationId,
    string tenantId,
    string localeId
)
Visual Basic
Function GetNotificationDetails (
    notificationId As String,
    tenantId As String,
    localeId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetails(
    String^ notificationId,
    String^ tenantId,
    String^ localeId
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If the notification id is not available

See Also

INotificationService Interface
INotificationService Members
GetNotificationDetails Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.GetNotificationDetailsByName Method

[image] [image]

A Sandcastle Documented Class Library
INotificationService..::..GetNotificationDetailsByName Method
INotificationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNotificationDetailsByName(String, String) | This method is used to gets the notification details by using the notification name and the tenant id.
Public method | GetNotificationDetailsByName(String, String, String) | This method is used to gets the notification details by using the notification name with the given locale id.

See Also

INotificationService Interface
INotificationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.GetNotificationDetailsByName Method (String, String)

[image]

A Sandcastle Documented Class Library
INotificationService..::..GetNotificationDetailsByName Method (String, String)
INotificationService Interface See Also Send Feedback
This method is used to gets the notification details by using the notification name and the tenant id.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetailsByName(
    string notificationName,
    string tenantId
)
Visual Basic
Function GetNotificationDetailsByName (
    notificationName As String,
    tenantId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetailsByName(
    String^ notificationName,
    String^ tenantId
)

Parameters

notificationName
Type: System..::..String
Name of the notification.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If the notification id is not available

See Also

INotificationService Interface
INotificationService Members
GetNotificationDetailsByName Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.GetNotificationDetailsByName Method (String, String, String)

[image]

A Sandcastle Documented Class Library
INotificationService..::..GetNotificationDetailsByName Method (String, String, String)
INotificationService Interface See Also Send Feedback
This method is used to gets the notification details by using the notification name with the given locale id.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
NotificationDetails GetNotificationDetailsByName(
    string notificationName,
    string tenantId,
    string localeId
)
Visual Basic
Function GetNotificationDetailsByName (
    notificationName As String,
    tenantId As String,
    localeId As String
) As NotificationDetails
Visual C++
NotificationDetails^ GetNotificationDetailsByName(
    String^ notificationName,
    String^ tenantId,
    String^ localeId
)

Parameters

notificationName
Type: System..::..String
Name of the notification.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.

Return Value

Type: NotificationDetails

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If the notification id is not available

See Also

INotificationService Interface
INotificationService Members
GetNotificationDetailsByName Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendBatchNotification Method

[image] [image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendBatchNotification Method
INotificationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ProcessAndSendBatchNotification(String, String, IBatchNotificationContent, IBatchNotificationDestination) | This method is used to processes the batch content and send the batch notification.
Public method | ProcessAndSendBatchNotification(String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content
Public method | ProcessAndSendBatchNotification(String, String, String, List<(Of <<'(NotificationPlaceholder>)>>), IBatchNotificationDestination) | This method is used to Processes and send batch notification with locale id

See Also

INotificationService Interface
INotificationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendBatchNotification Method (String, String, IBatchNotificationContent, IBatchNotificationDestination)

[image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendBatchNotification Method (String, String, IBatchNotificationContent, IBatchNotificationDestination)
INotificationService Interface See Also Send Feedback
This method is used to processes the batch content and send the batch notification.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessAndSendBatchNotification(
    string notificationId,
    string tenantId,
    IBatchNotificationContent content,
    IBatchNotificationDestination notificationDestination
)
Visual Basic
Sub ProcessAndSendBatchNotification (
    notificationId As String,
    tenantId As String,
    content As IBatchNotificationContent,
    notificationDestination As IBatchNotificationDestination
)
Visual C++
void ProcessAndSendBatchNotification(
    String^ notificationId,
    String^ tenantId,
    IBatchNotificationContent^ content,
    IBatchNotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
content
Type: CelloSaaS.Notification.Model.Content..::..IBatchNotificationContent
The notification content details.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..IBatchNotificationDestination
The notification destination details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content or destination values are null
System..::..ArgumentException | If notification content inner property value content is null

See Also

INotificationService Interface
INotificationService Members
ProcessAndSendBatchNotification Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendBatchNotification Method (String, String, List(NotificationPlaceholder), IBatchNotificationDestination)

[image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendBatchNotification Method (String, String, List<(Of <(<'NotificationPlaceholder>)>)>, IBatchNotificationDestination)
INotificationService Interface See Also Send Feedback
This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be batch text content

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessAndSendBatchNotification(
    string notificationId,
    string tenantId,
    List<NotificationPlaceholder> placeholders,
    IBatchNotificationDestination notificationDestination
)
Visual Basic
Sub ProcessAndSendBatchNotification (
    notificationId As String,
    tenantId As String,
    placeholders As List(Of NotificationPlaceholder),
    notificationDestination As IBatchNotificationDestination
)
Visual C++
void ProcessAndSendBatchNotification(
    String^ notificationId,
    String^ tenantId,
    List<NotificationPlaceholder^>^ placeholders,
    IBatchNotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
placeholders
Type: System.Collections.Generic..::..List<(Of <(<' NotificationPlaceholder >)>)>
The place holders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..IBatchNotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null
System..::..ArgumentException | If destination inner property values are null

See Also

INotificationService Interface
INotificationService Members
ProcessAndSendBatchNotification Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendBatchNotification Method (String, String, String, List(NotificationPlaceholder), IBatchNotificationDestination)

[image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendBatchNotification Method (String, String, String, List<(Of <(<'NotificationPlaceholder>)>)>, IBatchNotificationDestination)
INotificationService Interface See Also Send Feedback
This method is used to Processes and send batch notification with locale id

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessAndSendBatchNotification(
    string notificationId,
    string tenantId,
    string localeId,
    List<NotificationPlaceholder> placeholders,
    IBatchNotificationDestination notificationDestination
)
Visual Basic
Sub ProcessAndSendBatchNotification (
    notificationId As String,
    tenantId As String,
    localeId As String,
    placeholders As List(Of NotificationPlaceholder),
    notificationDestination As IBatchNotificationDestination
)
Visual C++
void ProcessAndSendBatchNotification(
    String^ notificationId,
    String^ tenantId,
    String^ localeId,
    List<NotificationPlaceholder^>^ placeholders,
    IBatchNotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.
placeholders
Type: System.Collections.Generic..::..List<(Of <(<' NotificationPlaceholder >)>)>
The placeholders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..IBatchNotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or destination values are null
System..::..ArgumentException | If destination inner property values are null

See Also

INotificationService Interface
INotificationService Members
ProcessAndSendBatchNotification Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendNotification Method

[image] [image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendNotification Method
INotificationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ProcessAndSendNotification(String, String, INotificationContent, INotificationDestination) | This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.
Public method | ProcessAndSendNotification(String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content
Public method | ProcessAndSendNotification(String, String, String, NotificationPlaceholder, INotificationDestination) | This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content

See Also

INotificationService Interface
INotificationService Members
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendNotification Method (String, String, INotificationContent, INotificationDestination)

[image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendNotification Method (String, String, INotificationContent, INotificationDestination)
INotificationService Interface See Also Send Feedback
This method is used to Processes and send the notification. That is process the content and it is sent by using the notification dispatch manager.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessAndSendNotification(
    string notificationId,
    string tenantId,
    INotificationContent notificationContent,
    INotificationDestination notificationDestination
)
Visual Basic
Sub ProcessAndSendNotification (
    notificationId As String,
    tenantId As String,
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination
)
Visual C++
void ProcessAndSendNotification(
    String^ notificationId,
    String^ tenantId,
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
Content of the notification.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

INotificationService Interface
INotificationService Members
ProcessAndSendNotification Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendNotification Method (String, String, NotificationPlaceholder, INotificationDestination)

[image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendNotification Method (String, String, NotificationPlaceholder, INotificationDestination)
INotificationService Interface See Also Send Feedback
This reads the content from the configuration using the notificationId, replaces the placeholders and delivers the notification via notification dispatch manager The kind of content here can only be text content

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessAndSendNotification(
    string notificationId,
    string tenantId,
    NotificationPlaceholder placeholders,
    INotificationDestination notificationDestination
)
Visual Basic
Sub ProcessAndSendNotification (
    notificationId As String,
    tenantId As String,
    placeholders As NotificationPlaceholder,
    notificationDestination As INotificationDestination
)
Visual C++
void ProcessAndSendNotification(
    String^ notificationId,
    String^ tenantId,
    NotificationPlaceholder^ placeholders,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
placeholders
Type: CelloSaaS.Notification.Model.Content..::..NotificationPlaceholder
The place holders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

INotificationService Interface
INotificationService Members
ProcessAndSendNotification Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.ProcessAndSendNotification Method (String, String, String, NotificationPlaceholder, INotificationDestination)

[image]

A Sandcastle Documented Class Library
INotificationService..::..ProcessAndSendNotification Method (String, String, String, NotificationPlaceholder, INotificationDestination)
INotificationService Interface See Also Send Feedback
This reads the content from the configuration using the notificationId, replaces the placeholders based on the locale id and delivers the notification via notification dispatch manager The kind of content here can only be text content

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ProcessAndSendNotification(
    string notificationId,
    string tenantId,
    string localeId,
    NotificationPlaceholder placeholders,
    INotificationDestination notificationDestination
)
Visual Basic
Sub ProcessAndSendNotification (
    notificationId As String,
    tenantId As String,
    localeId As String,
    placeholders As NotificationPlaceholder,
    notificationDestination As INotificationDestination
)
Visual C++
void ProcessAndSendNotification(
    String^ notificationId,
    String^ tenantId,
    String^ localeId,
    NotificationPlaceholder^ placeholders,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification id.
tenantId
Type: System..::..String
The tenant id.
localeId
Type: System..::..String
The locale id.
placeholders
Type: CelloSaaS.Notification.Model.Content..::..NotificationPlaceholder
The placeholders.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

INotificationService Interface
INotificationService Members
ProcessAndSendNotification Overload
CelloSaaS.Notification.ServiceContracts Namespace


INotificationService.SendNotification Method

[image]

A Sandcastle Documented Class Library
INotificationService..::..SendNotification Method
INotificationService Interface See Also Send Feedback
This method is used to send a email or upload a file.

Namespace: CelloSaaS.Notification.ServiceContracts
Assembly: CelloSaaS.Notification (in CelloSaaS.Notification.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SendNotification(
    string notificationId,
    string tenantId,
    INotificationContent notificationContent,
    INotificationDestination notificationDestination
)
Visual Basic
Sub SendNotification (
    notificationId As String,
    tenantId As String,
    notificationContent As INotificationContent,
    notificationDestination As INotificationDestination
)
Visual C++
void SendNotification(
    String^ notificationId,
    String^ tenantId,
    INotificationContent^ notificationContent,
    INotificationDestination^ notificationDestination
)

Parameters

notificationId
Type: System..::..String
The notification master id.
tenantId
Type: System..::..String
The tenant id.
notificationContent
Type: CelloSaaS.Notification.Model.Content..::..INotificationContent
The notification Content Details.
notificationDestination
Type: CelloSaaS.Notification.Model.Dispatch..::..INotificationDestination
The notification destination details.

Exceptions

Exception | Condition
CelloSaaS.Notification.NotificationManager..::..NotificationException | If notification id is not avaialble
System..::..ArgumentNullException | If notification id or content destination values are null

See Also

INotificationService Interface
INotificationService Members
CelloSaaS.Notification.ServiceContracts Namespace


CelloSaaS.PartitionManagement.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.PartitionManagement.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | DataModule |
Public class | DataPartition |
Public class | DataPartitionMapping |
Public class | DataServer |
Public class | DuplicateDataModuleCodeException |
Public class | DuplicateDataModuleNameException |
Public class | DuplicateDataPartitionNameException |
Public class | DuplicateDataServerNameException |
Public class | DuplicateMappingException |
Public class | InvalidConnectionStringException |
Public class | IsDataModuleReferredException |
Public class | IsDataServerReferredException |
Public class | IsSetAsDefaultException |
Public class | PartitionManagementConstant |
Public class | PartitionManagementException |


DataModule Class

[image]

A Sandcastle Documented Class Library
DataModule Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataModule
Visual Basic
<SerializableAttribute>
Public Class DataModule
Visual C++
[SerializableAttribute]
public ref class DataModule

Inheritance Hierarchy

System..::..Object
CelloSaaS.PartitionManagement.Model..::..DataModule

See Also

DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule Members

[image] [image]

A Sandcastle Documented Class Library
DataModule Members
DataModule Class Constructors Methods Properties See Also Send Feedback

The DataModule type exposes the following members.

Constructors

 | Name | Description
Public method | DataModule | Initializes a new instance of the DataModule class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy |
Public property | CreatedOn |
Public property | CreateScript |
Public property | DataModuleCode |
Public property | DataModuleName |
Public property | Description |
Public property | Id |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |
Public property | UpdateScript |

See Also

DataModule Class
CelloSaaS.PartitionManagement.Model Namespace


DataModule Constructor

[image]

A Sandcastle Documented Class Library
DataModule Constructor
DataModule Class See Also Send Feedback
Initializes a new instance of the DataModule class

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataModule()
Visual Basic
Public Sub New
Visual C++
public:
DataModule()

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule Methods

[image] [image]

A Sandcastle Documented Class Library
DataModule Methods
DataModule Class See Also Send Feedback

The DataModule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataModule Class
CelloSaaS.PartitionManagement.Model Namespace


DataModule Properties

[image] [image]

A Sandcastle Documented Class Library
DataModule Properties
DataModule Class See Also Send Feedback

The DataModule type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy |
Public property | CreatedOn |
Public property | CreateScript |
Public property | DataModuleCode |
Public property | DataModuleName |
Public property | Description |
Public property | Id |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |
Public property | UpdateScript |

See Also

DataModule Class
CelloSaaS.PartitionManagement.Model Namespace


DataModule.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DataModule..::..CreatedBy Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DataModule..::..CreatedOn Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> CreatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.CreateScript Property

[image]

A Sandcastle Documented Class Library
DataModule..::..CreateScript Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreateScript { get; set; }
Visual Basic
Public Property CreateScript As String
    Get
    Set
Visual C++
public:
property String^ CreateScript {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.DataModuleCode Property

[image]

A Sandcastle Documented Class Library
DataModule..::..DataModuleCode Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataModuleCode { get; set; }
Visual Basic
Public Property DataModuleCode As String
    Get
    Set
Visual C++
public:
property String^ DataModuleCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.DataModuleName Property

[image]

A Sandcastle Documented Class Library
DataModule..::..DataModuleName Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataModuleName { get; set; }
Visual Basic
Public Property DataModuleName As String
    Get
    Set
Visual C++
public:
property String^ DataModuleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.Description Property

[image]

A Sandcastle Documented Class Library
DataModule..::..Description Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.Id Property

[image]

A Sandcastle Documented Class Library
DataModule..::..Id Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.Status Property

[image]

A Sandcastle Documented Class Library
DataModule..::..Status Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DataModule..::..UpdatedBy Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DataModule..::..UpdatedOn Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataModule.UpdateScript Property

[image]

A Sandcastle Documented Class Library
DataModule..::..UpdateScript Property
DataModule Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdateScript { get; set; }
Visual Basic
Public Property UpdateScript As String
    Get
    Set
Visual C++
public:
property String^ UpdateScript {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataModule Class
DataModule Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition Class

[image]

A Sandcastle Documented Class Library
DataPartition Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataPartition
Visual Basic
<SerializableAttribute>
Public Class DataPartition
Visual C++
[SerializableAttribute]
public ref class DataPartition

Inheritance Hierarchy

System..::..Object
CelloSaaS.PartitionManagement.Model..::..DataPartition

See Also

DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition Members

[image] [image]

A Sandcastle Documented Class Library
DataPartition Members
DataPartition Class Constructors Methods Properties See Also Send Feedback

The DataPartition type exposes the following members.

Constructors

 | Name | Description
Public method | DataPartition | Initializes a new instance of the DataPartition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy |
Public property | CreatedOn |
Public property | DataPartitionMappings |
Public property | DataPartitionName |
Public property | Description |
Public property | Id |
Public property | IsDefault |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |

See Also

DataPartition Class
CelloSaaS.PartitionManagement.Model Namespace


DataPartition Constructor

[image]

A Sandcastle Documented Class Library
DataPartition Constructor
DataPartition Class See Also Send Feedback
Initializes a new instance of the DataPartition class

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataPartition()
Visual Basic
Public Sub New
Visual C++
public:
DataPartition()

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition Methods

[image] [image]

A Sandcastle Documented Class Library
DataPartition Methods
DataPartition Class See Also Send Feedback

The DataPartition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataPartition Class
CelloSaaS.PartitionManagement.Model Namespace


DataPartition Properties

[image] [image]

A Sandcastle Documented Class Library
DataPartition Properties
DataPartition Class See Also Send Feedback

The DataPartition type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy |
Public property | CreatedOn |
Public property | DataPartitionMappings |
Public property | DataPartitionName |
Public property | Description |
Public property | Id |
Public property | IsDefault |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |

See Also

DataPartition Class
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..CreatedBy Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..CreatedOn Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> CreatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.DataPartitionMappings Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..DataPartitionMappings Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ICollection<DataPartitionMapping> DataPartitionMappings { get; set; }
Visual Basic
Public Property DataPartitionMappings As ICollection(Of DataPartitionMapping)
    Get
    Set
Visual C++
public:
property ICollection<DataPartitionMapping^>^ DataPartitionMappings {
    ICollection<DataPartitionMapping^>^ get ();
    void set (ICollection<DataPartitionMapping^>^ value);
}

Property Value

Type: ICollection<(Of <(<' DataPartitionMapping >)>)>

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.DataPartitionName Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..DataPartitionName Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataPartitionName { get; set; }
Visual Basic
Public Property DataPartitionName As String
    Get
    Set
Visual C++
public:
property String^ DataPartitionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.Description Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..Description Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.Id Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..Id Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.IsDefault Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..IsDefault Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.Status Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..Status Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..UpdatedBy Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartition.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DataPartition..::..UpdatedOn Property
DataPartition Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataPartition Class
DataPartition Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping Class

[image]

A Sandcastle Documented Class Library
DataPartitionMapping Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataPartitionMapping
Visual Basic
<SerializableAttribute>
Public Class DataPartitionMapping
Visual C++
[SerializableAttribute]
public ref class DataPartitionMapping

Inheritance Hierarchy

System..::..Object
CelloSaaS.PartitionManagement.Model..::..DataPartitionMapping

See Also

DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping Members

[image] [image]

A Sandcastle Documented Class Library
DataPartitionMapping Members
DataPartitionMapping Class Constructors Methods Properties See Also Send Feedback

The DataPartitionMapping type exposes the following members.

Constructors

 | Name | Description
Public method | DataPartitionMapping | Initializes a new instance of the DataPartitionMapping class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy |
Public property | CreatedOn |
Public property | DataModule |
Public property | DataModuleId |
Public property | DataPartitionId |
Public property | DataServer |
Public property | DataServerId |
Public property | Id |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |

See Also

DataPartitionMapping Class
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping Constructor

[image]

A Sandcastle Documented Class Library
DataPartitionMapping Constructor
DataPartitionMapping Class See Also Send Feedback
Initializes a new instance of the DataPartitionMapping class

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataPartitionMapping()
Visual Basic
Public Sub New
Visual C++
public:
DataPartitionMapping()

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping Methods

[image] [image]

A Sandcastle Documented Class Library
DataPartitionMapping Methods
DataPartitionMapping Class See Also Send Feedback

The DataPartitionMapping type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataPartitionMapping Class
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping Properties

[image] [image]

A Sandcastle Documented Class Library
DataPartitionMapping Properties
DataPartitionMapping Class See Also Send Feedback

The DataPartitionMapping type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy |
Public property | CreatedOn |
Public property | DataModule |
Public property | DataModuleId |
Public property | DataPartitionId |
Public property | DataServer |
Public property | DataServerId |
Public property | Id |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |

See Also

DataPartitionMapping Class
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..CreatedBy Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..CreatedOn Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> CreatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.DataModule Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..DataModule Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataModule DataModule { get; set; }
Visual Basic
Public Property DataModule As DataModule
    Get
    Set
Visual C++
public:
property DataModule^ DataModule {
    DataModule^ get ();
    void set (DataModule^ value);
}

Property Value

Type: DataModule

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.DataModuleId Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..DataModuleId Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid DataModuleId { get; set; }
Visual Basic
Public Property DataModuleId As Guid
    Get
    Set
Visual C++
public:
property Guid DataModuleId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.DataPartitionId Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..DataPartitionId Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid DataPartitionId { get; set; }
Visual Basic
Public Property DataPartitionId As Guid
    Get
    Set
Visual C++
public:
property Guid DataPartitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.DataServer Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..DataServer Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataServer DataServer { get; set; }
Visual Basic
Public Property DataServer As DataServer
    Get
    Set
Visual C++
public:
property DataServer^ DataServer {
    DataServer^ get ();
    void set (DataServer^ value);
}

Property Value

Type: DataServer

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.DataServerId Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..DataServerId Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid DataServerId { get; set; }
Visual Basic
Public Property DataServerId As Guid
    Get
    Set
Visual C++
public:
property Guid DataServerId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.Id Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..Id Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.Status Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..Status Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..UpdatedBy Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataPartitionMapping.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DataPartitionMapping..::..UpdatedOn Property
DataPartitionMapping Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataPartitionMapping Class
DataPartitionMapping Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer Class

[image]

A Sandcastle Documented Class Library
DataServer Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataServer
Visual Basic
<SerializableAttribute>
Public Class DataServer
Visual C++
[SerializableAttribute]
public ref class DataServer

Inheritance Hierarchy

System..::..Object
CelloSaaS.PartitionManagement.Model..::..DataServer

See Also

DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer Members

[image] [image]

A Sandcastle Documented Class Library
DataServer Members
DataServer Class Constructors Methods Properties See Also Send Feedback

The DataServer type exposes the following members.

Constructors

 | Name | Description
Public method | DataServer | Initializes a new instance of the DataServer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString |
Public property | CreatedBy |
Public property | CreatedOn |
Public property | DataBaseName |
Public property | Id |
Public property | Name |
Public property | ServerAddress |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |

See Also

DataServer Class
CelloSaaS.PartitionManagement.Model Namespace


DataServer Constructor

[image]

A Sandcastle Documented Class Library
DataServer Constructor
DataServer Class See Also Send Feedback
Initializes a new instance of the DataServer class

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataServer()
Visual Basic
Public Sub New
Visual C++
public:
DataServer()

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer Methods

[image] [image]

A Sandcastle Documented Class Library
DataServer Methods
DataServer Class See Also Send Feedback

The DataServer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataServer Class
CelloSaaS.PartitionManagement.Model Namespace


DataServer Properties

[image] [image]

A Sandcastle Documented Class Library
DataServer Properties
DataServer Class See Also Send Feedback

The DataServer type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionString |
Public property | CreatedBy |
Public property | CreatedOn |
Public property | DataBaseName |
Public property | Id |
Public property | Name |
Public property | ServerAddress |
Public property | Status |
Public property | UpdatedBy |
Public property | UpdatedOn |

See Also

DataServer Class
CelloSaaS.PartitionManagement.Model Namespace


DataServer.ConnectionString Property

[image]

A Sandcastle Documented Class Library
DataServer..::..ConnectionString Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic
Public Property ConnectionString As String
    Get
    Set
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.CreatedBy Property

[image]

A Sandcastle Documented Class Library
DataServer..::..CreatedBy Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.CreatedOn Property

[image]

A Sandcastle Documented Class Library
DataServer..::..CreatedOn Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> CreatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.DataBaseName Property

[image]

A Sandcastle Documented Class Library
DataServer..::..DataBaseName Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataBaseName { get; set; }
Visual Basic
Public Property DataBaseName As String
    Get
    Set
Visual C++
public:
property String^ DataBaseName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.Id Property

[image]

A Sandcastle Documented Class Library
DataServer..::..Id Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.Name Property

[image]

A Sandcastle Documented Class Library
DataServer..::..Name Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.ServerAddress Property

[image]

A Sandcastle Documented Class Library
DataServer..::..ServerAddress Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ServerAddress { get; set; }
Visual Basic
Public Property ServerAddress As String
    Get
    Set
Visual C++
public:
property String^ ServerAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.Status Property

[image]

A Sandcastle Documented Class Library
DataServer..::..Status Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
DataServer..::..UpdatedBy Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DataServer.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
DataServer..::..UpdatedOn Property
DataServer Class See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

DataServer Class
DataServer Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Class

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateDataModuleCodeException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateDataModuleCodeException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateDataModuleCodeException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..DuplicateDataModuleCodeException

See Also

DuplicateDataModuleCodeException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Members
DuplicateDataModuleCodeException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateDataModuleCodeException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateDataModuleCodeException()()()() | Duplicate DataGroupName exception
Public method | DuplicateDataModuleCodeException(String) | Duplicate DataGroupName exception
Public method | DuplicateDataModuleCodeException(String, Exception) | Duplicate DataGroupName exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataModuleCodeException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Constructor
DuplicateDataModuleCodeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateDataModuleCodeException()()()() | Duplicate DataGroupName exception
Public method | DuplicateDataModuleCodeException(String) | Duplicate DataGroupName exception
Public method | DuplicateDataModuleCodeException(String, Exception) | Duplicate DataGroupName exception

See Also

DuplicateDataModuleCodeException Class
DuplicateDataModuleCodeException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Constructor
DuplicateDataModuleCodeException Class See Also Send Feedback
Duplicate DataGroupName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataModuleCodeException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateDataModuleCodeException()

See Also

DuplicateDataModuleCodeException Class
DuplicateDataModuleCodeException Members
DuplicateDataModuleCodeException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Constructor (String)
DuplicateDataModuleCodeException Class See Also Send Feedback
Duplicate DataGroupName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataModuleCodeException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateDataModuleCodeException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

DuplicateDataModuleCodeException Class
DuplicateDataModuleCodeException Members
DuplicateDataModuleCodeException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Constructor (String, Exception)
DuplicateDataModuleCodeException Class See Also Send Feedback
Duplicate DataGroupName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataModuleCodeException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
DuplicateDataModuleCodeException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

DuplicateDataModuleCodeException Class
DuplicateDataModuleCodeException Members
DuplicateDataModuleCodeException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Methods
DuplicateDataModuleCodeException Class See Also Send Feedback

The DuplicateDataModuleCodeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateDataModuleCodeException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Properties
DuplicateDataModuleCodeException Class See Also Send Feedback

The DuplicateDataModuleCodeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateDataModuleCodeException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleCodeException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleCodeException Events
DuplicateDataModuleCodeException Class See Also Send Feedback

The DuplicateDataModuleCodeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataModuleCodeException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateDataModuleNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateDataModuleNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateDataModuleNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..DuplicateDataModuleNameException

See Also

DuplicateDataModuleNameException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Members
DuplicateDataModuleNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateDataModuleNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateDataModuleNameException()()()() | Duplicate DataGroupName exception
Public method | DuplicateDataModuleNameException(String) | Duplicate DataGroupName exception
Public method | DuplicateDataModuleNameException(String, Exception) | Duplicate DataGroupName exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataModuleNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Constructor
DuplicateDataModuleNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateDataModuleNameException()()()() | Duplicate DataGroupName exception
Public method | DuplicateDataModuleNameException(String) | Duplicate DataGroupName exception
Public method | DuplicateDataModuleNameException(String, Exception) | Duplicate DataGroupName exception

See Also

DuplicateDataModuleNameException Class
DuplicateDataModuleNameException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Constructor
DuplicateDataModuleNameException Class See Also Send Feedback
Duplicate DataGroupName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataModuleNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateDataModuleNameException()

See Also

DuplicateDataModuleNameException Class
DuplicateDataModuleNameException Members
DuplicateDataModuleNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Constructor (String)
DuplicateDataModuleNameException Class See Also Send Feedback
Duplicate DataGroupName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataModuleNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateDataModuleNameException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

DuplicateDataModuleNameException Class
DuplicateDataModuleNameException Members
DuplicateDataModuleNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Constructor (String, Exception)
DuplicateDataModuleNameException Class See Also Send Feedback
Duplicate DataGroupName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataModuleNameException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
DuplicateDataModuleNameException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

DuplicateDataModuleNameException Class
DuplicateDataModuleNameException Members
DuplicateDataModuleNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Methods
DuplicateDataModuleNameException Class See Also Send Feedback

The DuplicateDataModuleNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateDataModuleNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Properties
DuplicateDataModuleNameException Class See Also Send Feedback

The DuplicateDataModuleNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateDataModuleNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataModuleNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataModuleNameException Events
DuplicateDataModuleNameException Class See Also Send Feedback

The DuplicateDataModuleNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataModuleNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateDataPartitionNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateDataPartitionNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateDataPartitionNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..DuplicateDataPartitionNameException

See Also

DuplicateDataPartitionNameException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Members
DuplicateDataPartitionNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateDataPartitionNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateDataPartitionNameException()()()() | Duplicate DataPartitionName exception
Public method | DuplicateDataPartitionNameException(String) | Duplicate DataPartitionName exception
Public method | DuplicateDataPartitionNameException(String, Exception) | Duplicate DataPartitionName exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataPartitionNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Constructor
DuplicateDataPartitionNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateDataPartitionNameException()()()() | Duplicate DataPartitionName exception
Public method | DuplicateDataPartitionNameException(String) | Duplicate DataPartitionName exception
Public method | DuplicateDataPartitionNameException(String, Exception) | Duplicate DataPartitionName exception

See Also

DuplicateDataPartitionNameException Class
DuplicateDataPartitionNameException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Constructor
DuplicateDataPartitionNameException Class See Also Send Feedback
Duplicate DataPartitionName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataPartitionNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateDataPartitionNameException()

See Also

DuplicateDataPartitionNameException Class
DuplicateDataPartitionNameException Members
DuplicateDataPartitionNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Constructor (String)
DuplicateDataPartitionNameException Class See Also Send Feedback
Duplicate DataPartitionName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataPartitionNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateDataPartitionNameException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

DuplicateDataPartitionNameException Class
DuplicateDataPartitionNameException Members
DuplicateDataPartitionNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Constructor (String, Exception)
DuplicateDataPartitionNameException Class See Also Send Feedback
Duplicate DataPartitionName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataPartitionNameException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
DuplicateDataPartitionNameException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

DuplicateDataPartitionNameException Class
DuplicateDataPartitionNameException Members
DuplicateDataPartitionNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Methods
DuplicateDataPartitionNameException Class See Also Send Feedback

The DuplicateDataPartitionNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateDataPartitionNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Properties
DuplicateDataPartitionNameException Class See Also Send Feedback

The DuplicateDataPartitionNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateDataPartitionNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataPartitionNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataPartitionNameException Events
DuplicateDataPartitionNameException Class See Also Send Feedback

The DuplicateDataPartitionNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataPartitionNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateDataServerNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateDataServerNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateDataServerNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..DuplicateDataServerNameException

See Also

DuplicateDataServerNameException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Members
DuplicateDataServerNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateDataServerNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateDataServerNameException()()()() | Duplicate PartitionSetName exception
Public method | DuplicateDataServerNameException(String) | Duplicate PartitionSetName exception
Public method | DuplicateDataServerNameException(String, Exception) | Duplicate PartitionSetName exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataServerNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Constructor
DuplicateDataServerNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateDataServerNameException()()()() | Duplicate PartitionSetName exception
Public method | DuplicateDataServerNameException(String) | Duplicate PartitionSetName exception
Public method | DuplicateDataServerNameException(String, Exception) | Duplicate PartitionSetName exception

See Also

DuplicateDataServerNameException Class
DuplicateDataServerNameException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Constructor
DuplicateDataServerNameException Class See Also Send Feedback
Duplicate PartitionSetName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataServerNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateDataServerNameException()

See Also

DuplicateDataServerNameException Class
DuplicateDataServerNameException Members
DuplicateDataServerNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Constructor (String)
DuplicateDataServerNameException Class See Also Send Feedback
Duplicate PartitionSetName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataServerNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateDataServerNameException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

DuplicateDataServerNameException Class
DuplicateDataServerNameException Members
DuplicateDataServerNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Constructor (String, Exception)
DuplicateDataServerNameException Class See Also Send Feedback
Duplicate PartitionSetName exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateDataServerNameException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
DuplicateDataServerNameException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

DuplicateDataServerNameException Class
DuplicateDataServerNameException Members
DuplicateDataServerNameException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Methods
DuplicateDataServerNameException Class See Also Send Feedback

The DuplicateDataServerNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateDataServerNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Properties
DuplicateDataServerNameException Class See Also Send Feedback

The DuplicateDataServerNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateDataServerNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateDataServerNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateDataServerNameException Events
DuplicateDataServerNameException Class See Also Send Feedback

The DuplicateDataServerNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateDataServerNameException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Class

[image]

A Sandcastle Documented Class Library
DuplicateMappingException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateMappingException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateMappingException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateMappingException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..DuplicateMappingException

See Also

DuplicateMappingException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateMappingException Members
DuplicateMappingException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateMappingException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateMappingException()()()() | Duplicate Mapping exception
Public method | DuplicateMappingException(String) | Duplicate Mapping exception
Public method | DuplicateMappingException(String, Exception) | Duplicate Mapping exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateMappingException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateMappingException Constructor
DuplicateMappingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateMappingException()()()() | Duplicate Mapping exception
Public method | DuplicateMappingException(String) | Duplicate Mapping exception
Public method | DuplicateMappingException(String, Exception) | Duplicate Mapping exception

See Also

DuplicateMappingException Class
DuplicateMappingException Members
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateMappingException Constructor
DuplicateMappingException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateMappingException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateMappingException()

See Also

DuplicateMappingException Class
DuplicateMappingException Members
DuplicateMappingException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateMappingException Constructor (String)
DuplicateMappingException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateMappingException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateMappingException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

DuplicateMappingException Class
DuplicateMappingException Members
DuplicateMappingException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateMappingException Constructor (String, Exception)
DuplicateMappingException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateMappingException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
DuplicateMappingException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

DuplicateMappingException Class
DuplicateMappingException Members
DuplicateMappingException Overload
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateMappingException Methods
DuplicateMappingException Class See Also Send Feedback

The DuplicateMappingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateMappingException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateMappingException Properties
DuplicateMappingException Class See Also Send Feedback

The DuplicateMappingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateMappingException Class
CelloSaaS.PartitionManagement.Model Namespace


DuplicateMappingException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateMappingException Events
DuplicateMappingException Class See Also Send Feedback

The DuplicateMappingException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateMappingException Class
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Class

[image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidConnectionStringException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidConnectionStringException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidConnectionStringException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..InvalidConnectionStringException

See Also

InvalidConnectionStringException Members
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Members
InvalidConnectionStringException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidConnectionStringException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidConnectionStringException()()()() | Duplicate Mapping exception
Public method | InvalidConnectionStringException(String) | Duplicate Mapping exception
Public method | InvalidConnectionStringException(String, Exception) | Duplicate Mapping exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidConnectionStringException Class
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Constructor
InvalidConnectionStringException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidConnectionStringException()()()() | Duplicate Mapping exception
Public method | InvalidConnectionStringException(String) | Duplicate Mapping exception
Public method | InvalidConnectionStringException(String, Exception) | Duplicate Mapping exception

See Also

InvalidConnectionStringException Class
InvalidConnectionStringException Members
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Constructor

[image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Constructor
InvalidConnectionStringException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidConnectionStringException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidConnectionStringException()

See Also

InvalidConnectionStringException Class
InvalidConnectionStringException Members
InvalidConnectionStringException Overload
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Constructor (String)
InvalidConnectionStringException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidConnectionStringException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidConnectionStringException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

InvalidConnectionStringException Class
InvalidConnectionStringException Members
InvalidConnectionStringException Overload
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Constructor (String, Exception)
InvalidConnectionStringException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidConnectionStringException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
InvalidConnectionStringException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

InvalidConnectionStringException Class
InvalidConnectionStringException Members
InvalidConnectionStringException Overload
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Methods
InvalidConnectionStringException Class See Also Send Feedback

The InvalidConnectionStringException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidConnectionStringException Class
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Properties
InvalidConnectionStringException Class See Also Send Feedback

The InvalidConnectionStringException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidConnectionStringException Class
CelloSaaS.PartitionManagement.Model Namespace


InvalidConnectionStringException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidConnectionStringException Events
InvalidConnectionStringException Class See Also Send Feedback

The InvalidConnectionStringException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidConnectionStringException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Class

[image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class IsDataModuleReferredException : BaseException
Visual Basic
<SerializableAttribute>
Public Class IsDataModuleReferredException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class IsDataModuleReferredException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..IsDataModuleReferredException

See Also

IsDataModuleReferredException Members
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Members

[image] [image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Members
IsDataModuleReferredException Class Constructors Methods Properties Events See Also Send Feedback

The IsDataModuleReferredException type exposes the following members.

Constructors

 | Name | Description
Public method | IsDataModuleReferredException()()()() | Duplicate Mapping exception
Public method | IsDataModuleReferredException(String) | Duplicate Mapping exception
Public method | IsDataModuleReferredException(String, Exception) | Duplicate Mapping exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IsDataModuleReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Constructor

[image] [image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Constructor
IsDataModuleReferredException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsDataModuleReferredException()()()() | Duplicate Mapping exception
Public method | IsDataModuleReferredException(String) | Duplicate Mapping exception
Public method | IsDataModuleReferredException(String, Exception) | Duplicate Mapping exception

See Also

IsDataModuleReferredException Class
IsDataModuleReferredException Members
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Constructor

[image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Constructor
IsDataModuleReferredException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsDataModuleReferredException()
Visual Basic
Public Sub New
Visual C++
public:
IsDataModuleReferredException()

See Also

IsDataModuleReferredException Class
IsDataModuleReferredException Members
IsDataModuleReferredException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Constructor (String)

[image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Constructor (String)
IsDataModuleReferredException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsDataModuleReferredException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
IsDataModuleReferredException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

IsDataModuleReferredException Class
IsDataModuleReferredException Members
IsDataModuleReferredException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Constructor (String, Exception)
IsDataModuleReferredException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsDataModuleReferredException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
IsDataModuleReferredException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

IsDataModuleReferredException Class
IsDataModuleReferredException Members
IsDataModuleReferredException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Methods

[image] [image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Methods
IsDataModuleReferredException Class See Also Send Feedback

The IsDataModuleReferredException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IsDataModuleReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Properties

[image] [image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Properties
IsDataModuleReferredException Class See Also Send Feedback

The IsDataModuleReferredException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IsDataModuleReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataModuleReferredException Events

[image] [image]

A Sandcastle Documented Class Library
IsDataModuleReferredException Events
IsDataModuleReferredException Class See Also Send Feedback

The IsDataModuleReferredException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IsDataModuleReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Class

[image]

A Sandcastle Documented Class Library
IsDataServerReferredException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class IsDataServerReferredException : BaseException
Visual Basic
<SerializableAttribute>
Public Class IsDataServerReferredException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class IsDataServerReferredException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..IsDataServerReferredException

See Also

IsDataServerReferredException Members
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Members

[image] [image]

A Sandcastle Documented Class Library
IsDataServerReferredException Members
IsDataServerReferredException Class Constructors Methods Properties Events See Also Send Feedback

The IsDataServerReferredException type exposes the following members.

Constructors

 | Name | Description
Public method | IsDataServerReferredException()()()() | Duplicate Mapping exception
Public method | IsDataServerReferredException(String) | Duplicate Mapping exception
Public method | IsDataServerReferredException(String, Exception) | Duplicate Mapping exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IsDataServerReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Constructor

[image] [image]

A Sandcastle Documented Class Library
IsDataServerReferredException Constructor
IsDataServerReferredException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsDataServerReferredException()()()() | Duplicate Mapping exception
Public method | IsDataServerReferredException(String) | Duplicate Mapping exception
Public method | IsDataServerReferredException(String, Exception) | Duplicate Mapping exception

See Also

IsDataServerReferredException Class
IsDataServerReferredException Members
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Constructor

[image]

A Sandcastle Documented Class Library
IsDataServerReferredException Constructor
IsDataServerReferredException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsDataServerReferredException()
Visual Basic
Public Sub New
Visual C++
public:
IsDataServerReferredException()

See Also

IsDataServerReferredException Class
IsDataServerReferredException Members
IsDataServerReferredException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Constructor (String)

[image]

A Sandcastle Documented Class Library
IsDataServerReferredException Constructor (String)
IsDataServerReferredException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsDataServerReferredException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
IsDataServerReferredException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

IsDataServerReferredException Class
IsDataServerReferredException Members
IsDataServerReferredException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
IsDataServerReferredException Constructor (String, Exception)
IsDataServerReferredException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsDataServerReferredException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
IsDataServerReferredException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

IsDataServerReferredException Class
IsDataServerReferredException Members
IsDataServerReferredException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Methods

[image] [image]

A Sandcastle Documented Class Library
IsDataServerReferredException Methods
IsDataServerReferredException Class See Also Send Feedback

The IsDataServerReferredException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IsDataServerReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Properties

[image] [image]

A Sandcastle Documented Class Library
IsDataServerReferredException Properties
IsDataServerReferredException Class See Also Send Feedback

The IsDataServerReferredException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IsDataServerReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsDataServerReferredException Events

[image] [image]

A Sandcastle Documented Class Library
IsDataServerReferredException Events
IsDataServerReferredException Class See Also Send Feedback

The IsDataServerReferredException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IsDataServerReferredException Class
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Class

[image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class IsSetAsDefaultException : BaseException
Visual Basic
<SerializableAttribute>
Public Class IsSetAsDefaultException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class IsSetAsDefaultException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..IsSetAsDefaultException

See Also

IsSetAsDefaultException Members
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Members

[image] [image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Members
IsSetAsDefaultException Class Constructors Methods Properties Events See Also Send Feedback

The IsSetAsDefaultException type exposes the following members.

Constructors

 | Name | Description
Public method | IsSetAsDefaultException()()()() | Duplicate Mapping exception
Public method | IsSetAsDefaultException(String) | Duplicate Mapping exception
Public method | IsSetAsDefaultException(String, Exception) | Duplicate Mapping exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IsSetAsDefaultException Class
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Constructor

[image] [image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Constructor
IsSetAsDefaultException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsSetAsDefaultException()()()() | Duplicate Mapping exception
Public method | IsSetAsDefaultException(String) | Duplicate Mapping exception
Public method | IsSetAsDefaultException(String, Exception) | Duplicate Mapping exception

See Also

IsSetAsDefaultException Class
IsSetAsDefaultException Members
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Constructor

[image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Constructor
IsSetAsDefaultException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsSetAsDefaultException()
Visual Basic
Public Sub New
Visual C++
public:
IsSetAsDefaultException()

See Also

IsSetAsDefaultException Class
IsSetAsDefaultException Members
IsSetAsDefaultException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Constructor (String)

[image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Constructor (String)
IsSetAsDefaultException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsSetAsDefaultException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
IsSetAsDefaultException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

IsSetAsDefaultException Class
IsSetAsDefaultException Members
IsSetAsDefaultException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Constructor (String, Exception)
IsSetAsDefaultException Class See Also Send Feedback
Duplicate Mapping exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IsSetAsDefaultException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
IsSetAsDefaultException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

IsSetAsDefaultException Class
IsSetAsDefaultException Members
IsSetAsDefaultException Overload
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Methods

[image] [image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Methods
IsSetAsDefaultException Class See Also Send Feedback

The IsSetAsDefaultException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IsSetAsDefaultException Class
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Properties

[image] [image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Properties
IsSetAsDefaultException Class See Also Send Feedback

The IsSetAsDefaultException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IsSetAsDefaultException Class
CelloSaaS.PartitionManagement.Model Namespace


IsSetAsDefaultException Events

[image] [image]

A Sandcastle Documented Class Library
IsSetAsDefaultException Events
IsSetAsDefaultException Class See Also Send Feedback

The IsSetAsDefaultException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

IsSetAsDefaultException Class
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementConstant Class

[image]

A Sandcastle Documented Class Library
PartitionManagementConstant Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class PartitionManagementConstant
Visual Basic
Public Class PartitionManagementConstant
Visual C++
public ref class PartitionManagementConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.PartitionManagement.Model..::..PartitionManagementConstant

See Also

PartitionManagementConstant Members
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementConstant Members

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementConstant Members
PartitionManagementConstant Class Constructors Methods See Also Send Feedback

The PartitionManagementConstant type exposes the following members.

Constructors

 | Name | Description
Public method | PartitionManagementConstant | Initializes a new instance of the PartitionManagementConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PartitionManagementConstant Class
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementConstant Constructor

[image]

A Sandcastle Documented Class Library
PartitionManagementConstant Constructor
PartitionManagementConstant Class See Also Send Feedback
Initializes a new instance of the PartitionManagementConstant class

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PartitionManagementConstant()
Visual Basic
Public Sub New
Visual C++
public:
PartitionManagementConstant()

See Also

PartitionManagementConstant Class
PartitionManagementConstant Members
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementConstant Methods

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementConstant Methods
PartitionManagementConstant Class See Also Send Feedback

The PartitionManagementConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PartitionManagementConstant Class
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Class

[image]

A Sandcastle Documented Class Library
PartitionManagementException Class
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PartitionManagementException : BaseException
Visual Basic
<SerializableAttribute>
Public Class PartitionManagementException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PartitionManagementException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.PartitionManagement.Model..::..PartitionManagementException

See Also

PartitionManagementException Members
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Members

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementException Members
PartitionManagementException Class Constructors Methods Properties Events See Also Send Feedback

The PartitionManagementException type exposes the following members.

Constructors

 | Name | Description
Public method | PartitionManagementException()()()() | DataPartition exception
Public method | PartitionManagementException(String) | DataPartition exception
Public method | PartitionManagementException(String, Exception) | DataPartition exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PartitionManagementException Class
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Constructor

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementException Constructor
PartitionManagementException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PartitionManagementException()()()() | DataPartition exception
Public method | PartitionManagementException(String) | DataPartition exception
Public method | PartitionManagementException(String, Exception) | DataPartition exception

See Also

PartitionManagementException Class
PartitionManagementException Members
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Constructor

[image]

A Sandcastle Documented Class Library
PartitionManagementException Constructor
PartitionManagementException Class See Also Send Feedback
DataPartition exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PartitionManagementException()
Visual Basic
Public Sub New
Visual C++
public:
PartitionManagementException()

See Also

PartitionManagementException Class
PartitionManagementException Members
PartitionManagementException Overload
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Constructor (String)

[image]

A Sandcastle Documented Class Library
PartitionManagementException Constructor (String)
PartitionManagementException Class See Also Send Feedback
DataPartition exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PartitionManagementException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
PartitionManagementException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

PartitionManagementException Class
PartitionManagementException Members
PartitionManagementException Overload
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
PartitionManagementException Constructor (String, Exception)
PartitionManagementException Class See Also Send Feedback
DataPartition exception

Namespace: CelloSaaS.PartitionManagement.Model
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PartitionManagementException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
PartitionManagementException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
message
ex
Type: System..::..Exception
ex

See Also

PartitionManagementException Class
PartitionManagementException Members
PartitionManagementException Overload
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Methods

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementException Methods
PartitionManagementException Class See Also Send Feedback

The PartitionManagementException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PartitionManagementException Class
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Properties

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementException Properties
PartitionManagementException Class See Also Send Feedback

The PartitionManagementException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PartitionManagementException Class
CelloSaaS.PartitionManagement.Model Namespace


PartitionManagementException Events

[image] [image]

A Sandcastle Documented Class Library
PartitionManagementException Events
PartitionManagementException Class See Also Send Feedback

The PartitionManagementException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PartitionManagementException Class
CelloSaaS.PartitionManagement.Model Namespace


CelloSaaS.PartitionManagement.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.PartitionManagement.ServiceContracts Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | IDataModuleService |
Public interface | IDataPartitionService |
Public interface | IDataServerService | DataServer service interface


IDataModuleService Interface

[image]

A Sandcastle Documented Class Library
IDataModuleService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IDataModuleService
Visual Basic
Public Interface IDataModuleService
Visual C++
public interface class IDataModuleService

See Also

IDataModuleService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService Members

[image] [image]

A Sandcastle Documented Class Library
IDataModuleService Members
IDataModuleService Interface Methods See Also Send Feedback

The IDataModuleService type exposes the following members.

Methods

 | Name | Description
Public method | AddDataModule | Add data module records.
Public method | DeleteDataModule | Delete data module records.
Public method | GetAllDataModule | Get all data module from server
Public method | GetDataModuleById | Get data module by Identifier.
Public method | UpdateDataModule | Update data module records.

See Also

IDataModuleService Interface
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService Methods

[image] [image]

A Sandcastle Documented Class Library
IDataModuleService Methods
IDataModuleService Interface See Also Send Feedback

The IDataModuleService type exposes the following members.

Methods

 | Name | Description
Public method | AddDataModule | Add data module records.
Public method | DeleteDataModule | Delete data module records.
Public method | GetAllDataModule | Get all data module from server
Public method | GetDataModuleById | Get data module by Identifier.
Public method | UpdateDataModule | Update data module records.

See Also

IDataModuleService Interface
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService.AddDataModule Method

[image]

A Sandcastle Documented Class Library
IDataModuleService..::..AddDataModule Method
IDataModuleService Interface See Also Send Feedback
Add data module records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddDataModule(
    DataModule dataModule
)
Visual Basic
Function AddDataModule (
    dataModule As DataModule
) As Guid
Visual C++
Guid AddDataModule(
    DataModule^ dataModule
)

Parameters

dataModule
Type: CelloSaaS.PartitionManagement.Model..::..DataModule
A DataModule object that contains details of data module record

Return Value

Type: Guid

See Also

IDataModuleService Interface
IDataModuleService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService.DeleteDataModule Method

[image]

A Sandcastle Documented Class Library
IDataModuleService..::..DeleteDataModule Method
IDataModuleService Interface See Also Send Feedback
Delete data module records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteDataModule(
    Guid dataModuleId
)
Visual Basic
Sub DeleteDataModule (
    dataModuleId As Guid
)
Visual C++
void DeleteDataModule(
    Guid dataModuleId
)

Parameters

dataModuleId
Type: System..::..Guid

See Also

IDataModuleService Interface
IDataModuleService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService.GetAllDataModule Method

[image]

A Sandcastle Documented Class Library
IDataModuleService..::..GetAllDataModule Method
IDataModuleService Interface See Also Send Feedback
Get all data module from server

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, DataModule> GetAllDataModule()
Visual Basic
Function GetAllDataModule As Dictionary(Of Guid, DataModule)
Visual C++
Dictionary<Guid, DataModule^>^ GetAllDataModule()

Return Value

Type: Dictionary<(Of <(<'Guid, DataModule >)>)>
Returns collection of data module with corresponding id

See Also

IDataModuleService Interface
IDataModuleService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService.GetDataModuleById Method

[image]

A Sandcastle Documented Class Library
IDataModuleService..::..GetDataModuleById Method
IDataModuleService Interface See Also Send Feedback
Get data module by Identifier.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataModule GetDataModuleById(
    Guid dataModuleId
)
Visual Basic
Function GetDataModuleById (
    dataModuleId As Guid
) As DataModule
Visual C++
DataModule^ GetDataModuleById(
    Guid dataModuleId
)

Parameters

dataModuleId
Type: System..::..Guid

Return Value

Type: DataModule
Returns data module record.

See Also

IDataModuleService Interface
IDataModuleService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataModuleService.UpdateDataModule Method

[image]

A Sandcastle Documented Class Library
IDataModuleService..::..UpdateDataModule Method
IDataModuleService Interface See Also Send Feedback
Update data module records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDataModule(
    DataModule dataModule
)
Visual Basic
Sub UpdateDataModule (
    dataModule As DataModule
)
Visual C++
void UpdateDataModule(
    DataModule^ dataModule
)

Parameters

dataModule
Type: CelloSaaS.PartitionManagement.Model..::..DataModule
A DataModule Object that contains details of data module record

See Also

IDataModuleService Interface
IDataModuleService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService Interface

[image]

A Sandcastle Documented Class Library
IDataPartitionService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IDataPartitionService
Visual Basic
Public Interface IDataPartitionService
Visual C++
public interface class IDataPartitionService

See Also

IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService Members

[image] [image]

A Sandcastle Documented Class Library
IDataPartitionService Members
IDataPartitionService Interface Methods See Also Send Feedback

The IDataPartitionService type exposes the following members.

Methods

 | Name | Description
Public method | AddDataPartition | Add data partition.
Public method | AddDataPartitionMapping | Add data partition mapping records.
Public method | DeleteDataPartitionMapping | delete data partition mapping records.
Public method | GetAllDataPartition | Get all data partition records.
Public method | GetConnectionString | Get connection string by modulename and datapartitionId
Public method | GetDataPartitionById | Get data partition by Id.
Public method | GetDataPartitionMappingById | Get data partition mapping records by Id
Public method | GetDataPartitionStatistics | Get the collection of data partition Id with corresponding tenant code.
Public method | GetDataPartitionStatisticsByDataPartitionId | Get the collection of tenantcode by data partition Id.
Public method | GetDefaultPartitionId | Returns default data partition Id
Public method | SetDataPartitionDefault | this method is used for set the particular data partition as default data partition.
Public method | UpdateDataPartition | Update data partition records.
Public method | UpdateDataPartitionMapping | Update data partition mapping records.

See Also

IDataPartitionService Interface
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService Methods

[image] [image]

A Sandcastle Documented Class Library
IDataPartitionService Methods
IDataPartitionService Interface See Also Send Feedback

The IDataPartitionService type exposes the following members.

Methods

 | Name | Description
Public method | AddDataPartition | Add data partition.
Public method | AddDataPartitionMapping | Add data partition mapping records.
Public method | DeleteDataPartitionMapping | delete data partition mapping records.
Public method | GetAllDataPartition | Get all data partition records.
Public method | GetConnectionString | Get connection string by modulename and datapartitionId
Public method | GetDataPartitionById | Get data partition by Id.
Public method | GetDataPartitionMappingById | Get data partition mapping records by Id
Public method | GetDataPartitionStatistics | Get the collection of data partition Id with corresponding tenant code.
Public method | GetDataPartitionStatisticsByDataPartitionId | Get the collection of tenantcode by data partition Id.
Public method | GetDefaultPartitionId | Returns default data partition Id
Public method | SetDataPartitionDefault | this method is used for set the particular data partition as default data partition.
Public method | UpdateDataPartition | Update data partition records.
Public method | UpdateDataPartitionMapping | Update data partition mapping records.

See Also

IDataPartitionService Interface
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.AddDataPartition Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..AddDataPartition Method
IDataPartitionService Interface See Also Send Feedback
Add data partition.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddDataPartition(
    DataPartition dataPartition
)
Visual Basic
Function AddDataPartition (
    dataPartition As DataPartition
) As Guid
Visual C++
Guid AddDataPartition(
    DataPartition^ dataPartition
)

Parameters

dataPartition
Type: CelloSaaS.PartitionManagement.Model..::..DataPartition
A DataPartition object that contains details of data partition records.

Return Value

Type: Guid
Returns newly created records primary key

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.AddDataPartitionMapping Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..AddDataPartitionMapping Method
IDataPartitionService Interface See Also Send Feedback
Add data partition mapping records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddDataPartitionMapping(
    DataPartitionMapping dataPartitionMap
)
Visual Basic
Function AddDataPartitionMapping (
    dataPartitionMap As DataPartitionMapping
) As Guid
Visual C++
Guid AddDataPartitionMapping(
    DataPartitionMapping^ dataPartitionMap
)

Parameters

dataPartitionMap
Type: CelloSaaS.PartitionManagement.Model..::..DataPartitionMapping
A DataPartitionMapping object that contains mapping details of data partition

Return Value

Type: Guid
Returns newly created records primary key

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.DeleteDataPartitionMapping Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..DeleteDataPartitionMapping Method
IDataPartitionService Interface See Also Send Feedback
delete data partition mapping records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteDataPartitionMapping(
    Guid dataPartitionMappingId
)
Visual Basic
Sub DeleteDataPartitionMapping (
    dataPartitionMappingId As Guid
)
Visual C++
void DeleteDataPartitionMapping(
    Guid dataPartitionMappingId
)

Parameters

dataPartitionMappingId
Type: System..::..Guid
a Guid that contains Id of mapping records.

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetAllDataPartition Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetAllDataPartition Method
IDataPartitionService Interface See Also Send Feedback
Get all data partition records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, DataPartition> GetAllDataPartition()
Visual Basic
Function GetAllDataPartition As Dictionary(Of Guid, DataPartition)
Visual C++
Dictionary<Guid, DataPartition^>^ GetAllDataPartition()

Return Value

Type: Dictionary<(Of <(<'Guid, DataPartition >)>)>
Returns collection data partition with corresponding identifier.

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetConnectionString Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetConnectionString Method
IDataPartitionService Interface See Also Send Feedback
Get connection string by modulename and datapartitionId

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetConnectionString(
    Guid dataPartitionId,
    string dataModuleCode
)
Visual Basic
Function GetConnectionString (
    dataPartitionId As Guid,
    dataModuleCode As String
) As String
Visual C++
String^ GetConnectionString(
    Guid dataPartitionId,
    String^ dataModuleCode
)

Parameters

dataPartitionId
Type: System..::..Guid
A Guid that contains Id of data partition records
dataModuleCode
Type: System..::..String
A string that contains connection string name of data module

Return Value

Type: String

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetDataPartitionById Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetDataPartitionById Method
IDataPartitionService Interface See Also Send Feedback
Get data partition by Id.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataPartition GetDataPartitionById(
    Guid dataPartitionId
)
Visual Basic
Function GetDataPartitionById (
    dataPartitionId As Guid
) As DataPartition
Visual C++
DataPartition^ GetDataPartitionById(
    Guid dataPartitionId
)

Parameters

dataPartitionId
Type: System..::..Guid
A GUID that contains unique Id of particular data partition records

Return Value

Type: DataPartition
DataPartition

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetDataPartitionMappingById Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetDataPartitionMappingById Method
IDataPartitionService Interface See Also Send Feedback
Get data partition mapping records by Id

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataPartitionMapping GetDataPartitionMappingById(
    Guid dataPartitionMappingId
)
Visual Basic
Function GetDataPartitionMappingById (
    dataPartitionMappingId As Guid
) As DataPartitionMapping
Visual C++
DataPartitionMapping^ GetDataPartitionMappingById(
    Guid dataPartitionMappingId
)

Parameters

dataPartitionMappingId
Type: System..::..Guid
A Guid that contains id of data partition mapping records.

Return Value

Type: DataPartitionMapping
DataPartitionMapping records.

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetDataPartitionStatistics Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetDataPartitionStatistics Method
IDataPartitionService Interface See Also Send Feedback
Get the collection of data partition Id with corresponding tenant code.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, List<Guid>> GetDataPartitionStatistics()
Visual Basic
Function GetDataPartitionStatistics As Dictionary(Of Guid, List(Of Guid))
Visual C++
Dictionary<Guid, List<Guid>^>^ GetDataPartitionStatistics()

Return Value

Type: Dictionary<(Of <(<'Guid, List<(Of <(<'Guid>)>)>>)>)>
collection of data partition Id with corresponding tenant code

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetDataPartitionStatisticsByDataPartitionId Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetDataPartitionStatisticsByDataPartitionId Method
IDataPartitionService Interface See Also Send Feedback
Get the collection of tenantcode by data partition Id.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Guid> GetDataPartitionStatisticsByDataPartitionId(
    Guid dataPartitionId
)
Visual Basic
Function GetDataPartitionStatisticsByDataPartitionId (
    dataPartitionId As Guid
) As List(Of Guid)
Visual C++
List<Guid>^ GetDataPartitionStatisticsByDataPartitionId(
    Guid dataPartitionId
)

Parameters

dataPartitionId
Type: System..::..Guid
A Guid that contains id of particular data partition

Return Value

Type: List<(Of <(<'Guid>)>)>
collection of tenantcode by data partition Id.

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.GetDefaultPartitionId Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..GetDefaultPartitionId Method
IDataPartitionService Interface See Also Send Feedback
Returns default data partition Id

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid GetDefaultPartitionId()
Visual Basic
Function GetDefaultPartitionId As Guid
Visual C++
Guid GetDefaultPartitionId()

Return Value

Type: Guid
Identifier

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.SetDataPartitionDefault Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..SetDataPartitionDefault Method
IDataPartitionService Interface See Also Send Feedback
this method is used for set the particular data partition as default data partition.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SetDataPartitionDefault(
    Guid dataPartitionId
)
Visual Basic
Sub SetDataPartitionDefault (
    dataPartitionId As Guid
)
Visual C++
void SetDataPartitionDefault(
    Guid dataPartitionId
)

Parameters

dataPartitionId
Type: System..::..Guid
A GUID that contains unique Id of particular data partition records

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.UpdateDataPartition Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..UpdateDataPartition Method
IDataPartitionService Interface See Also Send Feedback
Update data partition records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDataPartition(
    DataPartition dataPartition
)
Visual Basic
Sub UpdateDataPartition (
    dataPartition As DataPartition
)
Visual C++
void UpdateDataPartition(
    DataPartition^ dataPartition
)

Parameters

dataPartition
Type: CelloSaaS.PartitionManagement.Model..::..DataPartition
A DataPartition object that contains details of data partition record

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataPartitionService.UpdateDataPartitionMapping Method

[image]

A Sandcastle Documented Class Library
IDataPartitionService..::..UpdateDataPartitionMapping Method
IDataPartitionService Interface See Also Send Feedback
Update data partition mapping records.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDataPartitionMapping(
    DataPartitionMapping dataPartitionMap
)
Visual Basic
Sub UpdateDataPartitionMapping (
    dataPartitionMap As DataPartitionMapping
)
Visual C++
void UpdateDataPartitionMapping(
    DataPartitionMapping^ dataPartitionMap
)

Parameters

dataPartitionMap
Type: CelloSaaS.PartitionManagement.Model..::..DataPartitionMapping
A DataPartitionMapping object that contains mapping details of data partition

See Also

IDataPartitionService Interface
IDataPartitionService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService Interface

[image]

A Sandcastle Documented Class Library
IDataServerService Interface
Members See Also Send Feedback
DataServer service interface

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IDataServerService
Visual Basic
Public Interface IDataServerService
Visual C++
public interface class IDataServerService

See Also

IDataServerService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService Members

[image] [image]

A Sandcastle Documented Class Library
IDataServerService Members
IDataServerService Interface Methods See Also Send Feedback

The IDataServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddDataServer | Add data server details.
Public method | DeleteDataServer | Delete data server details.
Public method | GetAllDataServer | Returns the all data server record from database
Public method | GetDataServerById | Returns the data server record by identifier
Public method | UpdateDataServer | Update data server details.

See Also

IDataServerService Interface
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService Methods

[image] [image]

A Sandcastle Documented Class Library
IDataServerService Methods
IDataServerService Interface See Also Send Feedback

The IDataServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddDataServer | Add data server details.
Public method | DeleteDataServer | Delete data server details.
Public method | GetAllDataServer | Returns the all data server record from database
Public method | GetDataServerById | Returns the data server record by identifier
Public method | UpdateDataServer | Update data server details.

See Also

IDataServerService Interface
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService.AddDataServer Method

[image]

A Sandcastle Documented Class Library
IDataServerService..::..AddDataServer Method
IDataServerService Interface See Also Send Feedback
Add data server details.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid AddDataServer(
    DataServer dataServer
)
Visual Basic
Function AddDataServer (
    dataServer As DataServer
) As Guid
Visual C++
Guid AddDataServer(
    DataServer^ dataServer
)

Parameters

dataServer
Type: CelloSaaS.PartitionManagement.Model..::..DataServer
A DataServer Object that contains details of data server record

Return Value

Type: Guid
dataServerID

See Also

IDataServerService Interface
IDataServerService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService.DeleteDataServer Method

[image]

A Sandcastle Documented Class Library
IDataServerService..::..DeleteDataServer Method
IDataServerService Interface See Also Send Feedback
Delete data server details.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteDataServer(
    Guid dataServerId
)
Visual Basic
Sub DeleteDataServer (
    dataServerId As Guid
)
Visual C++
void DeleteDataServer(
    Guid dataServerId
)

Parameters

dataServerId
Type: System..::..Guid
A GUID that contains unique ID of particular ata server record.

See Also

IDataServerService Interface
IDataServerService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService.GetAllDataServer Method

[image]

A Sandcastle Documented Class Library
IDataServerService..::..GetAllDataServer Method
IDataServerService Interface See Also Send Feedback
Returns the all data server record from database

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, DataServer> GetAllDataServer()
Visual Basic
Function GetAllDataServer As Dictionary(Of Guid, DataServer)
Visual C++
Dictionary<Guid, DataServer^>^ GetAllDataServer()

Return Value

Type: Dictionary<(Of <(<'Guid, DataServer >)>)>
Returns collection of dataserver with corresponding identifier

See Also

IDataServerService Interface
IDataServerService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService.GetDataServerById Method

[image]

A Sandcastle Documented Class Library
IDataServerService..::..GetDataServerById Method
IDataServerService Interface See Also Send Feedback
Returns the data server record by identifier

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataServer GetDataServerById(
    Guid dataServerId
)
Visual Basic
Function GetDataServerById (
    dataServerId As Guid
) As DataServer
Visual C++
DataServer^ GetDataServerById(
    Guid dataServerId
)

Parameters

dataServerId
Type: System..::..Guid
A GUID that contains unique Id of particular data server object

Return Value

Type: DataServer
Returns data server records.

See Also

IDataServerService Interface
IDataServerService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


IDataServerService.UpdateDataServer Method

[image]

A Sandcastle Documented Class Library
IDataServerService..::..UpdateDataServer Method
IDataServerService Interface See Also Send Feedback
Update data server details.

Namespace: CelloSaaS.PartitionManagement.ServiceContracts
Assembly: CelloSaaS.PartitionManagement (in CelloSaaS.PartitionManagement.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDataServer(
    DataServer dataServer
)
Visual Basic
Sub UpdateDataServer (
    dataServer As DataServer
)
Visual C++
void UpdateDataServer(
    DataServer^ dataServer
)

Parameters

dataServer
Type: CelloSaaS.PartitionManagement.Model..::..DataServer
A DataServer Object that contains details of data server record

See Also

IDataServerService Interface
IDataServerService Members
CelloSaaS.PartitionManagement.ServiceContracts Namespace


CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | QueryBuilderException | Query builder exception class
Public class | QueryBuilderPrivilegeConstants | QueryBuilder Privilege Constants
Public class | QueryConfigurationException | Query configuration exception


QueryBuilderException Class

[image]

A Sandcastle Documented Class Library
QueryBuilderException Class
Members See Also Send Feedback
Query builder exception class

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class QueryBuilderException : BaseException
Visual Basic
<SerializableAttribute>
Public Class QueryBuilderException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class QueryBuilderException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.QueryBuilderLibrary.ServiceContracts..::..QueryBuilderException

See Also

QueryBuilderException Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Members

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderException Members
QueryBuilderException Class Constructors Methods Properties Events See Also Send Feedback

The QueryBuilderException type exposes the following members.

Constructors

 | Name | Description
Public method | QueryBuilderException()()()() | Initializes a new instance of the QueryBuilderException class.
Public method | QueryBuilderException(String) | Initializes a new instance of the QueryBuilderException class.
Protected method | QueryBuilderException(SerializationInfo, StreamingContext) | Initializes a new instance of the QueryBuilderException class.
Public method | QueryBuilderException(String, Exception) | Initializes a new instance of the QueryBuilderException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

QueryBuilderException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Constructor

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderException Constructor
QueryBuilderException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryBuilderException()()()() | Initializes a new instance of the QueryBuilderException class.
Public method | QueryBuilderException(String) | Initializes a new instance of the QueryBuilderException class.
Protected method | QueryBuilderException(SerializationInfo, StreamingContext) | Initializes a new instance of the QueryBuilderException class.
Public method | QueryBuilderException(String, Exception) | Initializes a new instance of the QueryBuilderException class.

See Also

QueryBuilderException Class
QueryBuilderException Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Constructor

[image]

A Sandcastle Documented Class Library
QueryBuilderException Constructor
QueryBuilderException Class See Also Send Feedback
Initializes a new instance of the QueryBuilderException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public QueryBuilderException()
Visual Basic
Public Sub New
Visual C++
public:
QueryBuilderException()

See Also

QueryBuilderException Class
QueryBuilderException Members
QueryBuilderException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Constructor (String)

[image]

A Sandcastle Documented Class Library
QueryBuilderException Constructor (String)
QueryBuilderException Class See Also Send Feedback
Initializes a new instance of the QueryBuilderException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public QueryBuilderException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
QueryBuilderException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

QueryBuilderException Class
QueryBuilderException Members
QueryBuilderException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
QueryBuilderException Constructor (SerializationInfo, StreamingContext)
QueryBuilderException Class See Also Send Feedback
Initializes a new instance of the QueryBuilderException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected QueryBuilderException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
QueryBuilderException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

QueryBuilderException Class
QueryBuilderException Members
QueryBuilderException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
QueryBuilderException Constructor (String, Exception)
QueryBuilderException Class See Also Send Feedback
Initializes a new instance of the QueryBuilderException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public QueryBuilderException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
QueryBuilderException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

QueryBuilderException Class
QueryBuilderException Members
QueryBuilderException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Methods

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderException Methods
QueryBuilderException Class See Also Send Feedback

The QueryBuilderException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

QueryBuilderException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Properties

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderException Properties
QueryBuilderException Class See Also Send Feedback

The QueryBuilderException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

QueryBuilderException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderException Events

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderException Events
QueryBuilderException Class See Also Send Feedback

The QueryBuilderException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

QueryBuilderException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants Class
Members See Also Send Feedback
QueryBuilder Privilege Constants

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class QueryBuilderPrivilegeConstants
Visual Basic
Public NotInheritable Class QueryBuilderPrivilegeConstants
Visual C++
public ref class QueryBuilderPrivilegeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.QueryBuilderLibrary.ServiceContracts..::..QueryBuilderPrivilegeConstants

See Also

QueryBuilderPrivilegeConstants Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants Members
QueryBuilderPrivilegeConstants Class Properties See Also Send Feedback

The QueryBuilderPrivilegeConstants type exposes the following members.

Properties

Name | Description
AddQuery | Add Query Privilege Name
DeleteQuery | Delete Query Privilege Name
EditQuery | Edit Query Privilege Name
ExecuteQuery | Execute Query Privilege Name
ViewQuery | View Query Privilege Name

See Also

QueryBuilderPrivilegeConstants Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants Properties

[image] [image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants Properties
QueryBuilderPrivilegeConstants Class See Also Send Feedback

The QueryBuilderPrivilegeConstants type exposes the following members.

Properties

Name | Description
AddQuery | Add Query Privilege Name
DeleteQuery | Delete Query Privilege Name
EditQuery | Edit Query Privilege Name
ExecuteQuery | Execute Query Privilege Name
ViewQuery | View Query Privilege Name

See Also

QueryBuilderPrivilegeConstants Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants.AddQuery Property

[image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants..::..AddQuery Property
QueryBuilderPrivilegeConstants Class See Also Send Feedback
Add Query Privilege Name

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddQuery { get; }
Visual Basic
Public Shared ReadOnly Property AddQuery As String
    Get
Visual C++
public:
static property String^ AddQuery {
    String^ get ();
}

Property Value

Type: String

See Also

QueryBuilderPrivilegeConstants Class
QueryBuilderPrivilegeConstants Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants.DeleteQuery Property

[image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants..::..DeleteQuery Property
QueryBuilderPrivilegeConstants Class See Also Send Feedback
Delete Query Privilege Name

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteQuery { get; }
Visual Basic
Public Shared ReadOnly Property DeleteQuery As String
    Get
Visual C++
public:
static property String^ DeleteQuery {
    String^ get ();
}

Property Value

Type: String

See Also

QueryBuilderPrivilegeConstants Class
QueryBuilderPrivilegeConstants Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants.EditQuery Property

[image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants..::..EditQuery Property
QueryBuilderPrivilegeConstants Class See Also Send Feedback
Edit Query Privilege Name

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditQuery { get; }
Visual Basic
Public Shared ReadOnly Property EditQuery As String
    Get
Visual C++
public:
static property String^ EditQuery {
    String^ get ();
}

Property Value

Type: String

See Also

QueryBuilderPrivilegeConstants Class
QueryBuilderPrivilegeConstants Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants.ExecuteQuery Property

[image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants..::..ExecuteQuery Property
QueryBuilderPrivilegeConstants Class See Also Send Feedback
Execute Query Privilege Name

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ExecuteQuery { get; }
Visual Basic
Public Shared ReadOnly Property ExecuteQuery As String
    Get
Visual C++
public:
static property String^ ExecuteQuery {
    String^ get ();
}

Property Value

Type: String

See Also

QueryBuilderPrivilegeConstants Class
QueryBuilderPrivilegeConstants Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryBuilderPrivilegeConstants.ViewQuery Property

[image]

A Sandcastle Documented Class Library
QueryBuilderPrivilegeConstants..::..ViewQuery Property
QueryBuilderPrivilegeConstants Class See Also Send Feedback
View Query Privilege Name

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewQuery { get; }
Visual Basic
Public Shared ReadOnly Property ViewQuery As String
    Get
Visual C++
public:
static property String^ ViewQuery {
    String^ get ();
}

Property Value

Type: String

See Also

QueryBuilderPrivilegeConstants Class
QueryBuilderPrivilegeConstants Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Class

[image]

A Sandcastle Documented Class Library
QueryConfigurationException Class
Members See Also Send Feedback
Query configuration exception

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class QueryConfigurationException : BaseException
Visual Basic
<SerializableAttribute>
Public Class QueryConfigurationException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class QueryConfigurationException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.QueryBuilderLibrary.ServiceContracts..::..QueryConfigurationException

See Also

QueryConfigurationException Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Members

[image] [image]

A Sandcastle Documented Class Library
QueryConfigurationException Members
QueryConfigurationException Class Constructors Methods Properties Events See Also Send Feedback

The QueryConfigurationException type exposes the following members.

Constructors

 | Name | Description
Public method | QueryConfigurationException()()()() | Initializes a new instance of the QueryConfigurationException class.
Public method | QueryConfigurationException(String) | Initializes a new instance of the QueryConfigurationException class.
Protected method | QueryConfigurationException(SerializationInfo, StreamingContext) | Initializes a new instance of the QueryConfigurationException class.
Public method | QueryConfigurationException(String, Exception) | Initializes a new instance of the QueryBuilderException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

QueryConfigurationException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Constructor

[image] [image]

A Sandcastle Documented Class Library
QueryConfigurationException Constructor
QueryConfigurationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | QueryConfigurationException()()()() | Initializes a new instance of the QueryConfigurationException class.
Public method | QueryConfigurationException(String) | Initializes a new instance of the QueryConfigurationException class.
Protected method | QueryConfigurationException(SerializationInfo, StreamingContext) | Initializes a new instance of the QueryConfigurationException class.
Public method | QueryConfigurationException(String, Exception) | Initializes a new instance of the QueryBuilderException class.

See Also

QueryConfigurationException Class
QueryConfigurationException Members
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Constructor

[image]

A Sandcastle Documented Class Library
QueryConfigurationException Constructor
QueryConfigurationException Class See Also Send Feedback
Initializes a new instance of the QueryConfigurationException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public QueryConfigurationException()
Visual Basic
Public Sub New
Visual C++
public:
QueryConfigurationException()

See Also

QueryConfigurationException Class
QueryConfigurationException Members
QueryConfigurationException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Constructor (String)

[image]

A Sandcastle Documented Class Library
QueryConfigurationException Constructor (String)
QueryConfigurationException Class See Also Send Feedback
Initializes a new instance of the QueryConfigurationException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public QueryConfigurationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
QueryConfigurationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

QueryConfigurationException Class
QueryConfigurationException Members
QueryConfigurationException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
QueryConfigurationException Constructor (SerializationInfo, StreamingContext)
QueryConfigurationException Class See Also Send Feedback
Initializes a new instance of the QueryConfigurationException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected QueryConfigurationException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
QueryConfigurationException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

QueryConfigurationException Class
QueryConfigurationException Members
QueryConfigurationException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
QueryConfigurationException Constructor (String, Exception)
QueryConfigurationException Class See Also Send Feedback
Initializes a new instance of the QueryBuilderException class.

Namespace: CelloSaaS.QueryBuilderLibrary.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public QueryConfigurationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
QueryConfigurationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

QueryConfigurationException Class
QueryConfigurationException Members
QueryConfigurationException Overload
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Methods

[image] [image]

A Sandcastle Documented Class Library
QueryConfigurationException Methods
QueryConfigurationException Class See Also Send Feedback

The QueryConfigurationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

QueryConfigurationException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Properties

[image] [image]

A Sandcastle Documented Class Library
QueryConfigurationException Properties
QueryConfigurationException Class See Also Send Feedback

The QueryConfigurationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

QueryConfigurationException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


QueryConfigurationException Events

[image] [image]

A Sandcastle Documented Class Library
QueryConfigurationException Events
QueryConfigurationException Class See Also Send Feedback

The QueryConfigurationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

QueryConfigurationException Class
CelloSaaS.QueryBuilderLibrary.ServiceContracts Namespace


CelloSaaS.ReportBuilder.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ReportBuilder.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | ReportBuilderPrivilegeConstants | ReportBuilder Privilege Constants


ReportBuilderPrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants Class
Members See Also Send Feedback
ReportBuilder Privilege Constants

Namespace: CelloSaaS.ReportBuilder.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class ReportBuilderPrivilegeConstants
Visual Basic
Public NotInheritable Class ReportBuilderPrivilegeConstants
Visual C++
public ref class ReportBuilderPrivilegeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.ReportBuilder.ServiceContracts..::..ReportBuilderPrivilegeConstants

See Also

ReportBuilderPrivilegeConstants Members
CelloSaaS.ReportBuilder.ServiceContracts Namespace


ReportBuilderPrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants Members
ReportBuilderPrivilegeConstants Class Properties See Also Send Feedback

The ReportBuilderPrivilegeConstants type exposes the following members.

Properties

Name | Description
AddReport | Add Report Privilege
DeleteReport | Delete Report Privilege
EditReport | Edit Report Privilege
ViewReport | View Report Privilege

See Also

ReportBuilderPrivilegeConstants Class
CelloSaaS.ReportBuilder.ServiceContracts Namespace


ReportBuilderPrivilegeConstants Properties

[image] [image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants Properties
ReportBuilderPrivilegeConstants Class See Also Send Feedback

The ReportBuilderPrivilegeConstants type exposes the following members.

Properties

Name | Description
AddReport | Add Report Privilege
DeleteReport | Delete Report Privilege
EditReport | Edit Report Privilege
ViewReport | View Report Privilege

See Also

ReportBuilderPrivilegeConstants Class
CelloSaaS.ReportBuilder.ServiceContracts Namespace


ReportBuilderPrivilegeConstants.AddReport Property

[image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants..::..AddReport Property
ReportBuilderPrivilegeConstants Class See Also Send Feedback
Add Report Privilege

Namespace: CelloSaaS.ReportBuilder.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddReport { get; }
Visual Basic
Public Shared ReadOnly Property AddReport As String
    Get
Visual C++
public:
static property String^ AddReport {
    String^ get ();
}

Property Value

Type: String

See Also

ReportBuilderPrivilegeConstants Class
ReportBuilderPrivilegeConstants Members
CelloSaaS.ReportBuilder.ServiceContracts Namespace


ReportBuilderPrivilegeConstants.DeleteReport Property

[image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants..::..DeleteReport Property
ReportBuilderPrivilegeConstants Class See Also Send Feedback
Delete Report Privilege

Namespace: CelloSaaS.ReportBuilder.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteReport { get; }
Visual Basic
Public Shared ReadOnly Property DeleteReport As String
    Get
Visual C++
public:
static property String^ DeleteReport {
    String^ get ();
}

Property Value

Type: String

See Also

ReportBuilderPrivilegeConstants Class
ReportBuilderPrivilegeConstants Members
CelloSaaS.ReportBuilder.ServiceContracts Namespace


ReportBuilderPrivilegeConstants.EditReport Property

[image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants..::..EditReport Property
ReportBuilderPrivilegeConstants Class See Also Send Feedback
Edit Report Privilege

Namespace: CelloSaaS.ReportBuilder.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditReport { get; }
Visual Basic
Public Shared ReadOnly Property EditReport As String
    Get
Visual C++
public:
static property String^ EditReport {
    String^ get ();
}

Property Value

Type: String

See Also

ReportBuilderPrivilegeConstants Class
ReportBuilderPrivilegeConstants Members
CelloSaaS.ReportBuilder.ServiceContracts Namespace


ReportBuilderPrivilegeConstants.ViewReport Property

[image]

A Sandcastle Documented Class Library
ReportBuilderPrivilegeConstants..::..ViewReport Property
ReportBuilderPrivilegeConstants Class See Also Send Feedback
View Report Privilege

Namespace: CelloSaaS.ReportBuilder.ServiceContracts
Assembly: CelloSaaS.Model (in CelloSaaS.Model.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewReport { get; }
Visual Basic
Public Shared ReadOnly Property ViewReport As String
    Get
Visual C++
public:
static property String^ ViewReport {
    String^ get ();
}

Property Value

Type: String

See Also

ReportBuilderPrivilegeConstants Class
ReportBuilderPrivilegeConstants Members
CelloSaaS.ReportBuilder.ServiceContracts Namespace


CelloSaaS.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | CacheKeyConstants | This class contain Cache key Constants


CacheKeyConstants Class

[image]

A Sandcastle Documented Class Library
CacheKeyConstants Class
Members See Also Send Feedback
This class contain Cache key Constants

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class CacheKeyConstants
Visual Basic
Public NotInheritable Class CacheKeyConstants
Visual C++
public ref class CacheKeyConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts..::..CacheKeyConstants

See Also

CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants Members

[image] [image]

A Sandcastle Documented Class Library
CacheKeyConstants Members
CacheKeyConstants Class Fields See Also Send Feedback

The CacheKeyConstants type exposes the following members.

Fields

Name | Description
AllChildTenantsCacheKey | Tenant relationship cache key constant
AllImmediateChildTenantsCacheKey | Tenant relationship cache key constant
AllModuleConfigCacheKey | Module configuration cache key
AllParentTenantCacheKey | Tenant relationship cache key constant
AllSkipLevelChildTenantsCacheKey | Tenant relationship cache key constant
BaseFieldsCacheKey | Cache key for BaseFields
ChildTenantHierarchyCacheKey | Tenant relationship cache key constant
CountryCacheKey | Country Cache Key
DataScopeCacheKey | Cache key for DataScope
DataViewCacheKey | Cache key for DataView
DataViewFieldDefaultValuesCacheKey | Cache key for DataViewFieldDefaultValues
DataViewMetaDataCacheKey | Cache key for DataViewMetaData
DefaultRolesCacheKey | Default Roles Cache Key
EntityBasedDataScopeCacheKey | Cache key for EntityBasedDataScope
EntityMetaDataCacheKey | Cache key for EntityMetaData
EntityViewPrivilegesCacheKey | Cache Key for the Entity View Privileges
ExtendedFieldsCacheKey | Cache key for ExtendedFields
GlobalDefaultValuesCacheKey | Cache key for GlobalDefaultValues
GlobalFieldsCacheKey | Cache key for GlobalFields
GlobalRolesCacheKey | The Global Roles Cache Key
ImmediateChildTenantsCacheKey | Tenant relationship cache key constant
LanguageCacheKey | Language cache Key
ModuleConfigCacheKey | Modle configuration setting value cache key
PackageCacheKey | Cache key for Package
ParentTenantCacheKey | Tenant relationship cache key constant
ParentTenantHierarchyCacheKey | Tenant relationship cache key constant
PrivilegeCacheKey | Cache key for Privilege
RelationTypesCacheKey | Tenant relationship cache key constant
RoleCacheKey | Single Role's Partial Cache Key
TenantCacheKey | Cache key for Tenant
TenantIdCacheKey | Tenant Id Cache Key form tenantCodeString
TenantLicenseCacheKey | Cache key for TenantLicense
TenantMappingCacheKey | Tenant relationship cache key constant
TenantRelationCacheKey | Cache key for Tenant Relation
TenantRoleCacheKey | Tenant role cache key
TenantSettingsCacheKey | Cache key for TenantSettings without attribute set id
TenantSettingsCacheKeyWithAttributeId | Cache key for TenantSettings with attribute set id
TenantURLCacheKey | Tenant URL Cache Key
UserDetailsCacheKey | UserDetailsCacheKey
UserRoleCacheKey | User role cache key
WorkflowDefinitionCacheKey | Cache key for workflow definition caching
WorkflowDefinitionUICacheKey | Cache key for workflow UI caching
WorkflowModelCacheKey | Cache key for workflow model caching

See Also

CacheKeyConstants Class
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants Fields

[image] [image]

A Sandcastle Documented Class Library
CacheKeyConstants Fields
CacheKeyConstants Class See Also Send Feedback

The CacheKeyConstants type exposes the following members.

Fields

Name | Description
AllChildTenantsCacheKey | Tenant relationship cache key constant
AllImmediateChildTenantsCacheKey | Tenant relationship cache key constant
AllModuleConfigCacheKey | Module configuration cache key
AllParentTenantCacheKey | Tenant relationship cache key constant
AllSkipLevelChildTenantsCacheKey | Tenant relationship cache key constant
BaseFieldsCacheKey | Cache key for BaseFields
ChildTenantHierarchyCacheKey | Tenant relationship cache key constant
CountryCacheKey | Country Cache Key
DataScopeCacheKey | Cache key for DataScope
DataViewCacheKey | Cache key for DataView
DataViewFieldDefaultValuesCacheKey | Cache key for DataViewFieldDefaultValues
DataViewMetaDataCacheKey | Cache key for DataViewMetaData
DefaultRolesCacheKey | Default Roles Cache Key
EntityBasedDataScopeCacheKey | Cache key for EntityBasedDataScope
EntityMetaDataCacheKey | Cache key for EntityMetaData
EntityViewPrivilegesCacheKey | Cache Key for the Entity View Privileges
ExtendedFieldsCacheKey | Cache key for ExtendedFields
GlobalDefaultValuesCacheKey | Cache key for GlobalDefaultValues
GlobalFieldsCacheKey | Cache key for GlobalFields
GlobalRolesCacheKey | The Global Roles Cache Key
ImmediateChildTenantsCacheKey | Tenant relationship cache key constant
LanguageCacheKey | Language cache Key
ModuleConfigCacheKey | Modle configuration setting value cache key
PackageCacheKey | Cache key for Package
ParentTenantCacheKey | Tenant relationship cache key constant
ParentTenantHierarchyCacheKey | Tenant relationship cache key constant
PrivilegeCacheKey | Cache key for Privilege
RelationTypesCacheKey | Tenant relationship cache key constant
RoleCacheKey | Single Role's Partial Cache Key
TenantCacheKey | Cache key for Tenant
TenantIdCacheKey | Tenant Id Cache Key form tenantCodeString
TenantLicenseCacheKey | Cache key for TenantLicense
TenantMappingCacheKey | Tenant relationship cache key constant
TenantRelationCacheKey | Cache key for Tenant Relation
TenantRoleCacheKey | Tenant role cache key
TenantSettingsCacheKey | Cache key for TenantSettings without attribute set id
TenantSettingsCacheKeyWithAttributeId | Cache key for TenantSettings with attribute set id
TenantURLCacheKey | Tenant URL Cache Key
UserDetailsCacheKey | UserDetailsCacheKey
UserRoleCacheKey | User role cache key
WorkflowDefinitionCacheKey | Cache key for workflow definition caching
WorkflowDefinitionUICacheKey | Cache key for workflow UI caching
WorkflowModelCacheKey | Cache key for workflow model caching

See Also

CacheKeyConstants Class
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.AllChildTenantsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..AllChildTenantsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AllChildTenantsCacheKey
Visual Basic
Public Const AllChildTenantsCacheKey As String
Visual C++
public:
literal String^ AllChildTenantsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.AllImmediateChildTenantsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..AllImmediateChildTenantsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AllImmediateChildTenantsCacheKey
Visual Basic
Public Const AllImmediateChildTenantsCacheKey As String
Visual C++
public:
literal String^ AllImmediateChildTenantsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.AllModuleConfigCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..AllModuleConfigCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Module configuration cache key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AllModuleConfigCacheKey
Visual Basic
Public Const AllModuleConfigCacheKey As String
Visual C++
public:
literal String^ AllModuleConfigCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.AllParentTenantCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..AllParentTenantCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AllParentTenantCacheKey
Visual Basic
Public Const AllParentTenantCacheKey As String
Visual C++
public:
literal String^ AllParentTenantCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.AllSkipLevelChildTenantsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..AllSkipLevelChildTenantsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AllSkipLevelChildTenantsCacheKey
Visual Basic
Public Const AllSkipLevelChildTenantsCacheKey As String
Visual C++
public:
literal String^ AllSkipLevelChildTenantsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.BaseFieldsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..BaseFieldsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for BaseFields

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BaseFieldsCacheKey
Visual Basic
Public Const BaseFieldsCacheKey As String
Visual C++
public:
literal String^ BaseFieldsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.ChildTenantHierarchyCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..ChildTenantHierarchyCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ChildTenantHierarchyCacheKey
Visual Basic
Public Const ChildTenantHierarchyCacheKey As String
Visual C++
public:
literal String^ ChildTenantHierarchyCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.CountryCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..CountryCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Country Cache Key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CountryCacheKey
Visual Basic
Public Const CountryCacheKey As String
Visual C++
public:
literal String^ CountryCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.DataScopeCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..DataScopeCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for DataScope

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DataScopeCacheKey
Visual Basic
Public Const DataScopeCacheKey As String
Visual C++
public:
literal String^ DataScopeCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.DataViewCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..DataViewCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for DataView

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DataViewCacheKey
Visual Basic
Public Const DataViewCacheKey As String
Visual C++
public:
literal String^ DataViewCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.DataViewFieldDefaultValuesCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..DataViewFieldDefaultValuesCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for DataViewFieldDefaultValues

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DataViewFieldDefaultValuesCacheKey
Visual Basic
Public Const DataViewFieldDefaultValuesCacheKey As String
Visual C++
public:
literal String^ DataViewFieldDefaultValuesCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.DataViewMetaDataCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..DataViewMetaDataCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for DataViewMetaData

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DataViewMetaDataCacheKey
Visual Basic
Public Const DataViewMetaDataCacheKey As String
Visual C++
public:
literal String^ DataViewMetaDataCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.DefaultRolesCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..DefaultRolesCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Default Roles Cache Key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DefaultRolesCacheKey
Visual Basic
Public Const DefaultRolesCacheKey As String
Visual C++
public:
literal String^ DefaultRolesCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.EntityBasedDataScopeCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..EntityBasedDataScopeCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for EntityBasedDataScope

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EntityBasedDataScopeCacheKey
Visual Basic
Public Const EntityBasedDataScopeCacheKey As String
Visual C++
public:
literal String^ EntityBasedDataScopeCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.EntityMetaDataCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..EntityMetaDataCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for EntityMetaData

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EntityMetaDataCacheKey
Visual Basic
Public Const EntityMetaDataCacheKey As String
Visual C++
public:
literal String^ EntityMetaDataCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.EntityViewPrivilegesCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..EntityViewPrivilegesCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache Key for the Entity View Privileges

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EntityViewPrivilegesCacheKey
Visual Basic
Public Const EntityViewPrivilegesCacheKey As String
Visual C++
public:
literal String^ EntityViewPrivilegesCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.ExtendedFieldsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..ExtendedFieldsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for ExtendedFields

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ExtendedFieldsCacheKey
Visual Basic
Public Const ExtendedFieldsCacheKey As String
Visual C++
public:
literal String^ ExtendedFieldsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.GlobalDefaultValuesCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..GlobalDefaultValuesCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for GlobalDefaultValues

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string GlobalDefaultValuesCacheKey
Visual Basic
Public Const GlobalDefaultValuesCacheKey As String
Visual C++
public:
literal String^ GlobalDefaultValuesCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.GlobalFieldsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..GlobalFieldsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for GlobalFields

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string GlobalFieldsCacheKey
Visual Basic
Public Const GlobalFieldsCacheKey As String
Visual C++
public:
literal String^ GlobalFieldsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.GlobalRolesCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..GlobalRolesCacheKey Field
CacheKeyConstants Class See Also Send Feedback
The Global Roles Cache Key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string GlobalRolesCacheKey
Visual Basic
Public Const GlobalRolesCacheKey As String
Visual C++
public:
literal String^ GlobalRolesCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.ImmediateChildTenantsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..ImmediateChildTenantsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ImmediateChildTenantsCacheKey
Visual Basic
Public Const ImmediateChildTenantsCacheKey As String
Visual C++
public:
literal String^ ImmediateChildTenantsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.LanguageCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..LanguageCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Language cache Key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string LanguageCacheKey
Visual Basic
Public Const LanguageCacheKey As String
Visual C++
public:
literal String^ LanguageCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.ModuleConfigCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..ModuleConfigCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Modle configuration setting value cache key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ModuleConfigCacheKey
Visual Basic
Public Const ModuleConfigCacheKey As String
Visual C++
public:
literal String^ ModuleConfigCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.PackageCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..PackageCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for Package

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PackageCacheKey
Visual Basic
Public Const PackageCacheKey As String
Visual C++
public:
literal String^ PackageCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.ParentTenantCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..ParentTenantCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ParentTenantCacheKey
Visual Basic
Public Const ParentTenantCacheKey As String
Visual C++
public:
literal String^ ParentTenantCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.ParentTenantHierarchyCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..ParentTenantHierarchyCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ParentTenantHierarchyCacheKey
Visual Basic
Public Const ParentTenantHierarchyCacheKey As String
Visual C++
public:
literal String^ ParentTenantHierarchyCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.PrivilegeCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..PrivilegeCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for Privilege

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PrivilegeCacheKey
Visual Basic
Public Const PrivilegeCacheKey As String
Visual C++
public:
literal String^ PrivilegeCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.RelationTypesCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..RelationTypesCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string RelationTypesCacheKey
Visual Basic
Public Const RelationTypesCacheKey As String
Visual C++
public:
literal String^ RelationTypesCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.RoleCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..RoleCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Single Role's Partial Cache Key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string RoleCacheKey
Visual Basic
Public Const RoleCacheKey As String
Visual C++
public:
literal String^ RoleCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for Tenant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantCacheKey
Visual Basic
Public Const TenantCacheKey As String
Visual C++
public:
literal String^ TenantCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantIdCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantIdCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant Id Cache Key form tenantCodeString

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantIdCacheKey
Visual Basic
Public Const TenantIdCacheKey As String
Visual C++
public:
literal String^ TenantIdCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantLicenseCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantLicenseCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for TenantLicense

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantLicenseCacheKey
Visual Basic
Public Const TenantLicenseCacheKey As String
Visual C++
public:
literal String^ TenantLicenseCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantMappingCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantMappingCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant relationship cache key constant

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantMappingCacheKey
Visual Basic
Public Const TenantMappingCacheKey As String
Visual C++
public:
literal String^ TenantMappingCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantRelationCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantRelationCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for Tenant Relation

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantRelationCacheKey
Visual Basic
Public Const TenantRelationCacheKey As String
Visual C++
public:
literal String^ TenantRelationCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantRoleCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantRoleCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant role cache key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantRoleCacheKey
Visual Basic
Public Const TenantRoleCacheKey As String
Visual C++
public:
literal String^ TenantRoleCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantSettingsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantSettingsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for TenantSettings without attribute set id

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantSettingsCacheKey
Visual Basic
Public Const TenantSettingsCacheKey As String
Visual C++
public:
literal String^ TenantSettingsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantSettingsCacheKeyWithAttributeId Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantSettingsCacheKeyWithAttributeId Field
CacheKeyConstants Class See Also Send Feedback
Cache key for TenantSettings with attribute set id

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantSettingsCacheKeyWithAttributeId
Visual Basic
Public Const TenantSettingsCacheKeyWithAttributeId As String
Visual C++
public:
literal String^ TenantSettingsCacheKeyWithAttributeId

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.TenantURLCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..TenantURLCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Tenant URL Cache Key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantURLCacheKey
Visual Basic
Public Const TenantURLCacheKey As String
Visual C++
public:
literal String^ TenantURLCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.UserDetailsCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..UserDetailsCacheKey Field
CacheKeyConstants Class See Also Send Feedback
UserDetailsCacheKey

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserDetailsCacheKey
Visual Basic
Public Const UserDetailsCacheKey As String
Visual C++
public:
literal String^ UserDetailsCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.UserRoleCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..UserRoleCacheKey Field
CacheKeyConstants Class See Also Send Feedback
User role cache key

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserRoleCacheKey
Visual Basic
Public Const UserRoleCacheKey As String
Visual C++
public:
literal String^ UserRoleCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.WorkflowDefinitionCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..WorkflowDefinitionCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for workflow definition caching

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WorkflowDefinitionCacheKey
Visual Basic
Public Const WorkflowDefinitionCacheKey As String
Visual C++
public:
literal String^ WorkflowDefinitionCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.WorkflowDefinitionUICacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..WorkflowDefinitionUICacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for workflow UI caching

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WorkflowDefinitionUICacheKey
Visual Basic
Public Const WorkflowDefinitionUICacheKey As String
Visual C++
public:
literal String^ WorkflowDefinitionUICacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CacheKeyConstants.WorkflowModelCacheKey Field

[image]

A Sandcastle Documented Class Library
CacheKeyConstants..::..WorkflowModelCacheKey Field
CacheKeyConstants Class See Also Send Feedback
Cache key for workflow model caching

Namespace: CelloSaaS.ServiceContracts
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WorkflowModelCacheKey
Visual Basic
Public Const WorkflowModelCacheKey As String
Visual C++
public:
literal String^ WorkflowModelCacheKey

Field Value

Type: String

See Also

CacheKeyConstants Class
CacheKeyConstants Members
CelloSaaS.ServiceContracts Namespace


CelloSaaS.ServiceContracts.AccessControlManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.AccessControlManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccessControlException | Access Control Exception
Public class | DataAccessException | Data Access Exception
Public class | FeatureException | Feature Exception
Public class | PrivilegeConstants | Privilege Constants
Public class | PrivilegeException | Privilege Exception
Public class | ProductAdminConstants | ProductAdmin Constants
Public class | RoleConstants | Role Constants
Public class | RoleException | Role Exception
Public class | UserEntityPermissionException | UserEntityPermission Exception

Interfaces

 | Interface | Description
Public interface | IAccessControlService | Access Control Service Interface contains the basic permission checking, startified permission checking and entity based permission checking services
Public interface | IDataAccessService | Data Access Service Interface
Public interface | IEntityPrivilegeService | Privilege Service Interface
Public interface | IFeatureService | Feature Service Interface
Public interface | IPrivilegeService | Privilege Service Interface
Public interface | IRoleService | Role Metadata service Interface
Public interface | ITenantAccessService | Tenant access service interface
Public interface | IUserEntityPermissionService | UserEntityPermission Service Interface


AccessControlException Class

[image]

A Sandcastle Documented Class Library
AccessControlException Class
Members See Also Send Feedback
Access Control Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AccessControlException : BaseException
Visual Basic
<SerializableAttribute>
Public Class AccessControlException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class AccessControlException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.AccessControlManagement..::..AccessControlException

See Also

AccessControlException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Members

[image] [image]

A Sandcastle Documented Class Library
AccessControlException Members
AccessControlException Class Constructors Methods Properties Events See Also Send Feedback

The AccessControlException type exposes the following members.

Constructors

 | Name | Description
Public method | AccessControlException(String) | Initializes a new instance of the AccessControlException class.
Public method | AccessControlException(String, Exception) | Initializes a new instance of the AccessControlException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AccessControlException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Constructor

[image] [image]

A Sandcastle Documented Class Library
AccessControlException Constructor
AccessControlException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AccessControlException(String) | Initializes a new instance of the AccessControlException class.
Public method | AccessControlException(String, Exception) | Initializes a new instance of the AccessControlException class.

See Also

AccessControlException Class
AccessControlException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Constructor (String)

[image]

A Sandcastle Documented Class Library
AccessControlException Constructor (String)
AccessControlException Class See Also Send Feedback
Initializes a new instance of the AccessControlException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AccessControlException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
AccessControlException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

AccessControlException Class
AccessControlException Members
AccessControlException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
AccessControlException Constructor (String, Exception)
AccessControlException Class See Also Send Feedback
Initializes a new instance of the AccessControlException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AccessControlException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
AccessControlException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

AccessControlException Class
AccessControlException Members
AccessControlException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Methods

[image] [image]

A Sandcastle Documented Class Library
AccessControlException Methods
AccessControlException Class See Also Send Feedback

The AccessControlException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AccessControlException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Properties

[image] [image]

A Sandcastle Documented Class Library
AccessControlException Properties
AccessControlException Class See Also Send Feedback

The AccessControlException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AccessControlException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


AccessControlException Events

[image] [image]

A Sandcastle Documented Class Library
AccessControlException Events
AccessControlException Class See Also Send Feedback

The AccessControlException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AccessControlException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


DataAccessException Class

[image]

A Sandcastle Documented Class Library
DataAccessException Class
Members See Also Send Feedback
Data Access Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataAccessException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DataAccessException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DataAccessException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.AccessControlManagement..::..DataAccessException

See Also

DataAccessException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


DataAccessException Members

[image] [image]

A Sandcastle Documented Class Library
DataAccessException Members
DataAccessException Class Constructors Methods Properties Events See Also Send Feedback

The DataAccessException type exposes the following members.

Constructors

 | Name | Description
Public method | DataAccessException | Initializes a new instance of the DataAccessException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DataAccessException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


DataAccessException Constructor

[image]

A Sandcastle Documented Class Library
DataAccessException Constructor
DataAccessException Class See Also Send Feedback
Initializes a new instance of the DataAccessException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataAccessException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DataAccessException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DataAccessException Class
DataAccessException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


DataAccessException Methods

[image] [image]

A Sandcastle Documented Class Library
DataAccessException Methods
DataAccessException Class See Also Send Feedback

The DataAccessException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataAccessException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


DataAccessException Properties

[image] [image]

A Sandcastle Documented Class Library
DataAccessException Properties
DataAccessException Class See Also Send Feedback

The DataAccessException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataAccessException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


DataAccessException Events

[image] [image]

A Sandcastle Documented Class Library
DataAccessException Events
DataAccessException Class See Also Send Feedback

The DataAccessException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DataAccessException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


FeatureException Class

[image]

A Sandcastle Documented Class Library
FeatureException Class
Members See Also Send Feedback
Feature Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FeatureException : BaseException
Visual Basic
<SerializableAttribute>
Public Class FeatureException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class FeatureException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException

See Also

FeatureException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


FeatureException Members

[image] [image]

A Sandcastle Documented Class Library
FeatureException Members
FeatureException Class Constructors Methods Properties Events See Also Send Feedback

The FeatureException type exposes the following members.

Constructors

 | Name | Description
Public method | FeatureException | Initializes a new instance of the FeatureException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FeatureException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


FeatureException Constructor

[image]

A Sandcastle Documented Class Library
FeatureException Constructor
FeatureException Class See Also Send Feedback
Initializes a new instance of the FeatureException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FeatureException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
FeatureException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

FeatureException Class
FeatureException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


FeatureException Methods

[image] [image]

A Sandcastle Documented Class Library
FeatureException Methods
FeatureException Class See Also Send Feedback

The FeatureException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FeatureException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


FeatureException Properties

[image] [image]

A Sandcastle Documented Class Library
FeatureException Properties
FeatureException Class See Also Send Feedback

The FeatureException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FeatureException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


FeatureException Events

[image] [image]

A Sandcastle Documented Class Library
FeatureException Events
FeatureException Class See Also Send Feedback

The FeatureException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FeatureException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService Interface

[image]

A Sandcastle Documented Class Library
IAccessControlService Interface
Members See Also Send Feedback
Access Control Service Interface contains the basic permission checking, startified permission checking and entity based permission checking services

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IAccessControlService
Visual Basic
Public Interface IAccessControlService
Visual C++
public interface class IAccessControlService

See Also

IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService Members

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService Members
IAccessControlService Interface Methods See Also Send Feedback

The IAccessControlService type exposes the following members.

Methods

 | Name | Description
Public method | CheckAllPrivileges | Check if the logged in user has all the given privileges
Public method | CheckPrivilege | Check if the logged in user has the given privilege
Public method | CheckPrivilegeForEntity(BaseEntity, EntityAction) | Check if the logged in user has the privileges to access the entity for the given action
Public method | CheckPrivilegeForEntity(BaseEntity, String) | Check if the logged in user has the privilege for the given entity
Public method | CheckPrivilegeForEntity(BaseEntity, array<String>[]()[][]) | Check if the logged in user has the privileges to access the entity
Public method | CheckPrivilegeForEntity(String, String, array<String>[]()[][]) | Check if the logged in user has the privileges to access the entity record (referenceId)
Public method | CheckPrivilegeForEntityList(Dictionary<(Of <<'(String, BaseEntity>)>>), String, String) | Check if the logged in user has the privilege for the given entities
Public method | CheckPrivilegeForEntityList(String, Dictionary<(Of <<'(String, BaseEntity>)>>), EntityAction) | Check if the logged in user has privileges to perform the following action on the entities
Public method | CheckPrivilegeForFields(String, array<String>[]()[][]) | Check the privilege for entity fields.
Public method | CheckPrivilegeForFields(String, String, array<String>[]()[][]) | Check if the logged in user has the privileges on the entity record (referenceId)
Public method | CheckPrivilegeForFields(String, array<String>[]()[][], array<String>[]()[][]) | Check if the logged in user has the privileges on the entity records (referenceIds)
Public method | CheckPrivileges | Check if the logged in user has the given privileges and returns the result array in the same order
Public method | CheckTenantAccessPrivilege | Check if the logged in user has the given privilege for the given tenantId.
Public method | CheckTenantAccessWithTenantScope | Check if the logged in user has the given privilege for specified entity,tenantid and Fetch Type
Public method | GetTenantAccessPrivileges(array<String>[]()[][]) | Gets the tenant access privileges for the logged in user
Public method | GetTenantAccessPrivileges(String, array<String>[]()[][]) | Gets the tenant access privileges for the given user
Public method | SetDataScopes(String, String, DataScope%, EntityBasedDataScope%) | Sets data scope and entityBaseDataScope in out parameter
Public method | SetDataScopes(String, array<String>[]()[][], Dictionary<(Of <<'(String, DataScope>)>>)%, Dictionary<(Of <<'(String, EntityBasedDataScope>)>>)%) | Sets data scope and entityBaseDataScope in out parameter

See Also

IAccessControlService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService Methods

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService Methods
IAccessControlService Interface See Also Send Feedback

The IAccessControlService type exposes the following members.

Methods

 | Name | Description
Public method | CheckAllPrivileges | Check if the logged in user has all the given privileges
Public method | CheckPrivilege | Check if the logged in user has the given privilege
Public method | CheckPrivilegeForEntity(BaseEntity, EntityAction) | Check if the logged in user has the privileges to access the entity for the given action
Public method | CheckPrivilegeForEntity(BaseEntity, String) | Check if the logged in user has the privilege for the given entity
Public method | CheckPrivilegeForEntity(BaseEntity, array<String>[]()[][]) | Check if the logged in user has the privileges to access the entity
Public method | CheckPrivilegeForEntity(String, String, array<String>[]()[][]) | Check if the logged in user has the privileges to access the entity record (referenceId)
Public method | CheckPrivilegeForEntityList(Dictionary<(Of <<'(String, BaseEntity>)>>), String, String) | Check if the logged in user has the privilege for the given entities
Public method | CheckPrivilegeForEntityList(String, Dictionary<(Of <<'(String, BaseEntity>)>>), EntityAction) | Check if the logged in user has privileges to perform the following action on the entities
Public method | CheckPrivilegeForFields(String, array<String>[]()[][]) | Check the privilege for entity fields.
Public method | CheckPrivilegeForFields(String, String, array<String>[]()[][]) | Check if the logged in user has the privileges on the entity record (referenceId)
Public method | CheckPrivilegeForFields(String, array<String>[]()[][], array<String>[]()[][]) | Check if the logged in user has the privileges on the entity records (referenceIds)
Public method | CheckPrivileges | Check if the logged in user has the given privileges and returns the result array in the same order
Public method | CheckTenantAccessPrivilege | Check if the logged in user has the given privilege for the given tenantId.
Public method | CheckTenantAccessWithTenantScope | Check if the logged in user has the given privilege for specified entity,tenantid and Fetch Type
Public method | GetTenantAccessPrivileges(array<String>[]()[][]) | Gets the tenant access privileges for the logged in user
Public method | GetTenantAccessPrivileges(String, array<String>[]()[][]) | Gets the tenant access privileges for the given user
Public method | SetDataScopes(String, String, DataScope%, EntityBasedDataScope%) | Sets data scope and entityBaseDataScope in out parameter
Public method | SetDataScopes(String, array<String>[]()[][], Dictionary<(Of <<'(String, DataScope>)>>)%, Dictionary<(Of <<'(String, EntityBasedDataScope>)>>)%) | Sets data scope and entityBaseDataScope in out parameter

See Also

IAccessControlService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckAllPrivileges Method

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckAllPrivileges Method
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has all the given privileges

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckAllPrivileges(
    string[] privileges
)
Visual Basic
Function CheckAllPrivileges (
    privileges As String()
) As Boolean
Visual C++
bool CheckAllPrivileges(
    array<String^>^ privileges
)

Parameters

privileges
Type: array<System..::..String>[]()[][]
array of Privileges

Return Value

Type: Boolean
returns True/False

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilege Method

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilege Method
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the given privilege

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckPrivilege(
    string privilege
)
Visual Basic
Function CheckPrivilege (
    privilege As String
) As Boolean
Visual C++
bool CheckPrivilege(
    String^ privilege
)

Parameters

privilege
Type: System..::..String
Privilege Name

Return Value

Type: Boolean
returns True/False

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntity Method

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntity Method
IAccessControlService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckPrivilegeForEntity(BaseEntity, EntityAction) | Check if the logged in user has the privileges to access the entity for the given action
Public method | CheckPrivilegeForEntity(BaseEntity, String) | Check if the logged in user has the privilege for the given entity
Public method | CheckPrivilegeForEntity(BaseEntity, array<String>[]()[][]) | Check if the logged in user has the privileges to access the entity
Public method | CheckPrivilegeForEntity(String, String, array<String>[]()[][]) | Check if the logged in user has the privileges to access the entity record (referenceId)

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntity Method (BaseEntity, EntityAction)

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntity Method (BaseEntity, EntityAction)
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privileges to access the entity for the given action

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckPrivilegeForEntity(
    BaseEntity entity,
    EntityAction action
)
Visual Basic
Function CheckPrivilegeForEntity (
    entity As BaseEntity,
    action As EntityAction
) As Boolean
Visual C++
bool CheckPrivilegeForEntity(
    BaseEntity^ entity,
    EntityAction^ action
)

Parameters

entity
Type: CelloSaaS.Model..::..BaseEntity
Base Entity
action
Type: CelloSaaS.Model..::..EntityAction
Entity Action

Return Value

Type: Boolean
returns True/False

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForEntity Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntity Method (BaseEntity, String)

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntity Method (BaseEntity, String)
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privilege for the given entity

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckPrivilegeForEntity(
    BaseEntity entity,
    string privilegeName
)
Visual Basic
Function CheckPrivilegeForEntity (
    entity As BaseEntity,
    privilegeName As String
) As Boolean
Visual C++
bool CheckPrivilegeForEntity(
    BaseEntity^ entity,
    String^ privilegeName
)

Parameters

entity
Type: CelloSaaS.Model..::..BaseEntity
Base Entity
privilegeName
Type: System..::..String
Privilege Name

Return Value

Type: Boolean
returns True/False

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForEntity Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntity Method (BaseEntity, String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntity Method (BaseEntity, array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privileges to access the entity

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckPrivilegeForEntity(
    BaseEntity entity,
    string[] permissionlist
)
Visual Basic
Function CheckPrivilegeForEntity (
    entity As BaseEntity,
    permissionlist As String()
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckPrivilegeForEntity(
    BaseEntity^ entity,
    array<String^>^ permissionlist
)

Parameters

entity
Type: CelloSaaS.Model..::..BaseEntity
Base Entity
permissionlist
Type: array<System..::..String>[]()[][]
Permission List

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>
Dictionary of Privilege Name and Status

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForEntity Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntity Method (String, String, String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntity Method (String, String, array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privileges to access the entity record (referenceId)

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckPrivilegeForEntity(
    string entityIdentifier,
    string referenceId,
    string[] permissionlist
)
Visual Basic
Function CheckPrivilegeForEntity (
    entityIdentifier As String,
    referenceId As String,
    permissionlist As String()
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckPrivilegeForEntity(
    String^ entityIdentifier,
    String^ referenceId,
    array<String^>^ permissionlist
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
referenceId
Type: System..::..String
Reference Identifier
permissionlist
Type: array<System..::..String>[]()[][]
Permission List

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>
Dictionary of Privilege Name and Status

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForEntity Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntityList Method

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntityList Method
IAccessControlService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckPrivilegeForEntityList(Dictionary<(Of <<'(String, BaseEntity>)>>), String, String) | Check if the logged in user has the privilege for the given entities
Public method | CheckPrivilegeForEntityList(String, Dictionary<(Of <<'(String, BaseEntity>)>>), EntityAction) | Check if the logged in user has privileges to perform the following action on the entities

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntityList Method (Dictionary(String, BaseEntity), String, String)

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntityList Method (Dictionary<(Of <(<'String, BaseEntity>)>)>, String, String)
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privilege for the given entities

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckPrivilegeForEntityList(
    Dictionary<string, BaseEntity> entities,
    string entityIdentifier,
    string privilegeName
)
Visual Basic
Function CheckPrivilegeForEntityList (
    entities As Dictionary(Of String, BaseEntity),
    entityIdentifier As String,
    privilegeName As String
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckPrivilegeForEntityList(
    Dictionary<String^, BaseEntity^>^ entities,
    String^ entityIdentifier,
    String^ privilegeName
)

Parameters

entities
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, BaseEntity >)>)>
Base Entities
entityIdentifier
Type: System..::..String
Entity Identifier
privilegeName
Type: System..::..String
Privilege Name

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>
Dictionary of Privilege Name and Status

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForEntityList Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForEntityList Method (String, Dictionary(String, BaseEntity), EntityAction)

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForEntityList Method (String, Dictionary<(Of <(<'String, BaseEntity>)>)>, EntityAction)
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has privileges to perform the following action on the entities

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckPrivilegeForEntityList(
    string entityIdentifier,
    Dictionary<string, BaseEntity> entities,
    EntityAction action
)
Visual Basic
Function CheckPrivilegeForEntityList (
    entityIdentifier As String,
    entities As Dictionary(Of String, BaseEntity),
    action As EntityAction
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckPrivilegeForEntityList(
    String^ entityIdentifier,
    Dictionary<String^, BaseEntity^>^ entities,
    EntityAction^ action
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
entities
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, BaseEntity >)>)>
Base Entities
action
Type: CelloSaaS.Model..::..EntityAction
Entity Action

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>
Privilege Permission for Entities

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForEntityList Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForFields Method

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForFields Method
IAccessControlService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckPrivilegeForFields(String, array<String>[]()[][]) | Check the privilege for entity fields.
Public method | CheckPrivilegeForFields(String, String, array<String>[]()[][]) | Check if the logged in user has the privileges on the entity record (referenceId)
Public method | CheckPrivilegeForFields(String, array<String>[]()[][], array<String>[]()[][]) | Check if the logged in user has the privileges on the entity records (referenceIds)

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForFields Method (String, String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForFields Method (String, array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Check the privilege for entity fields.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckPrivilegeForFields(
    string entityIdentifier,
    string[] permissionlist
)
Visual Basic
Function CheckPrivilegeForFields (
    entityIdentifier As String,
    permissionlist As String()
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckPrivilegeForFields(
    String^ entityIdentifier,
    array<String^>^ permissionlist
)

Parameters

entityIdentifier
Type: System..::..String
The entity identifier.
permissionlist
Type: array<System..::..String>[]()[][]
The permission list.

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>
Dictionary of Privilege Name and Status

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForFields Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForFields Method (String, String, String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForFields Method (String, String, array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privileges on the entity record (referenceId)

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckPrivilegeForFields(
    string entityIdentifier,
    string referenceId,
    string[] permissionlist
)
Visual Basic
Function CheckPrivilegeForFields (
    entityIdentifier As String,
    referenceId As String,
    permissionlist As String()
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckPrivilegeForFields(
    String^ entityIdentifier,
    String^ referenceId,
    array<String^>^ permissionlist
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
referenceId
Type: System..::..String
Reference Identifier
permissionlist
Type: array<System..::..String>[]()[][]
Permission List

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>
Dictionary of privilege Name and status

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForFields Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivilegeForFields Method (String, String[], String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivilegeForFields Method (String, array<String>[]()[][], array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the privileges on the entity records (referenceIds)

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, bool>> CheckPrivilegeForFields(
    string entityIdentifier,
    string[] referenceIds,
    string[] permissionlist
)
Visual Basic
Function CheckPrivilegeForFields (
    entityIdentifier As String,
    referenceIds As String(),
    permissionlist As String()
) As Dictionary(Of String, Dictionary(Of String, Boolean))
Visual C++
Dictionary<String^, Dictionary<String^, bool>^>^ CheckPrivilegeForFields(
    String^ entityIdentifier,
    array<String^>^ referenceIds,
    array<String^>^ permissionlist
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
referenceIds
Type: array<System..::..String>[]()[][]
Reference Identifier List
permissionlist
Type: array<System..::..String>[]()[][]
Permission List

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Boolean>)>)>>)>)>
Dictionary of privilege Name and status

See Also

IAccessControlService Interface
IAccessControlService Members
CheckPrivilegeForFields Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckPrivileges Method

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckPrivileges Method
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the given privileges and returns the result array in the same order

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool[] CheckPrivileges(
    string[] privileges
)
Visual Basic
Function CheckPrivileges (
    privileges As String()
) As Boolean()
Visual C++
array<bool>^ CheckPrivileges(
    array<String^>^ privileges
)

Parameters

privileges
Type: array<System..::..String>[]()[][]
array of Privileges

Return Value

Type: array<Boolean>[]()[][]
returns True/False List

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckTenantAccessPrivilege Method

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckTenantAccessPrivilege Method
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the given privilege for the given tenantId.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckTenantAccessPrivilege(
    string userId,
    string privilege,
    string tenantId
)
Visual Basic
Function CheckTenantAccessPrivilege (
    userId As String,
    privilege As String,
    tenantId As String
) As Boolean
Visual C++
bool CheckTenantAccessPrivilege(
    String^ userId,
    String^ privilege,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
privilege
Type: System..::..String
The privilege.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean
trueif the user has the access privilege, falseotherwise

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.CheckTenantAccessWithTenantScope Method

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..CheckTenantAccessWithTenantScope Method
IAccessControlService Interface See Also Send Feedback
Check if the logged in user has the given privilege for specified entity,tenantid and Fetch Type

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckTenantAccessWithTenantScope(
    string userId,
    string privilege,
    string tenantId,
    string entityId,
    FetchType fetchType,
    string operationalTenantId
)
Visual Basic
Function CheckTenantAccessWithTenantScope (
    userId As String,
    privilege As String,
    tenantId As String,
    entityId As String,
    fetchType As FetchType,
    operationalTenantId As String
) As Boolean
Visual C++
bool CheckTenantAccessWithTenantScope(
    String^ userId,
    String^ privilege,
    String^ tenantId,
    String^ entityId,
    FetchType fetchType,
    String^ operationalTenantId
)

Parameters

userId
Type: System..::..String
The user id.
privilege
Type: System..::..String
The privilege.
tenantId
Type: System..::..String
The tenant id.
entityId
Type: System..::..String
The entity id.
fetchType
Type: CelloSaaS.Model..::..FetchType
Type of the fetch.
operationalTenantId
Type: System..::..String
The Operational tenant Id

Return Value

Type: Boolean
trueif the user has the access privilege, falseotherwise

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.GetTenantAccessPrivileges Method

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService..::..GetTenantAccessPrivileges Method
IAccessControlService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantAccessPrivileges(array<String>[]()[][]) | Gets the tenant access privileges for the logged in user
Public method | GetTenantAccessPrivileges(String, array<String>[]()[][]) | Gets the tenant access privileges for the given user

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.GetTenantAccessPrivileges Method (String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..GetTenantAccessPrivileges Method (array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Gets the tenant access privileges for the logged in user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, TenantDetails>> GetTenantAccessPrivileges(
    string[] privileges
)
Visual Basic
Function GetTenantAccessPrivileges (
    privileges As String()
) As Dictionary(Of String, Dictionary(Of String, TenantDetails))
Visual C++
Dictionary<String^, Dictionary<String^, TenantDetails^>^>^ GetTenantAccessPrivileges(
    array<String^>^ privileges
)

Parameters

privileges
Type: array<System..::..String>[]()[][]
The privileges.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, TenantDetails >)>)>>)>)>
Privileges, Dictionary of TenantDetails

See Also

IAccessControlService Interface
IAccessControlService Members
GetTenantAccessPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.GetTenantAccessPrivileges Method (String, String[])

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..GetTenantAccessPrivileges Method (String, array<String>[]()[][])
IAccessControlService Interface See Also Send Feedback
Gets the tenant access privileges for the given user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, TenantDetails>> GetTenantAccessPrivileges(
    string userId,
    string[] privileges
)
Visual Basic
Function GetTenantAccessPrivileges (
    userId As String,
    privileges As String()
) As Dictionary(Of String, Dictionary(Of String, TenantDetails))
Visual C++
Dictionary<String^, Dictionary<String^, TenantDetails^>^>^ GetTenantAccessPrivileges(
    String^ userId,
    array<String^>^ privileges
)

Parameters

userId
Type: System..::..String
The user id.
privileges
Type: array<System..::..String>[]()[][]
The privileges.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, TenantDetails >)>)>>)>)>
PrivilegeId, Dictionary of TenantDetails

See Also

IAccessControlService Interface
IAccessControlService Members
GetTenantAccessPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.SetDataScopes Method

[image] [image]

A Sandcastle Documented Class Library
IAccessControlService..::..SetDataScopes Method
IAccessControlService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDataScopes(String, String, DataScope%, EntityBasedDataScope%) | Sets data scope and entityBaseDataScope in out parameter
Public method | SetDataScopes(String, array<String>[]()[][], Dictionary<(Of <<'(String, DataScope>)>>)%, Dictionary<(Of <<'(String, EntityBasedDataScope>)>>)%) | Sets data scope and entityBaseDataScope in out parameter

See Also

IAccessControlService Interface
IAccessControlService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.SetDataScopes Method (String, String, DataScope, EntityBasedDataScope)

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..SetDataScopes Method (String, String, DataScope%, EntityBasedDataScope%)
IAccessControlService Interface See Also Send Feedback
Sets data scope and entityBaseDataScope in out parameter

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SetDataScopes(
    string entityIdentifier,
    string permissionName,
    out DataScope dataScope,
    out EntityBasedDataScope entityDataScope
)
Visual Basic
Sub SetDataScopes (
    entityIdentifier As String,
    permissionName As String,
    <OutAttribute> ByRef dataScope As DataScope,
    <OutAttribute> ByRef entityDataScope As EntityBasedDataScope
)
Visual C++
void SetDataScopes(
    String^ entityIdentifier,
    String^ permissionName,
    [OutAttribute] DataScope^% dataScope,
    [OutAttribute] EntityBasedDataScope^% entityDataScope
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
permissionName
Type: System..::..String
Permission List
dataScope
Type: CelloSaaS.Model.AccessControlManagement..::..DataScope %
Data Scope Details
entityDataScope
Type: CelloSaaS.Model.AccessControlManagement..::..EntityBasedDataScope %
Entity Based Data Scope Details

See Also

IAccessControlService Interface
IAccessControlService Members
SetDataScopes Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IAccessControlService.SetDataScopes Method (String, String[], Dictionary(String, DataScope), Dictionary(String, EntityBasedDataScope))

[image]

A Sandcastle Documented Class Library
IAccessControlService..::..SetDataScopes Method (String, array<String>[]()[][], Dictionary<(Of <(<'String, DataScope>)>)>%, Dictionary<(Of <(<'String, EntityBasedDataScope>)>)>%)
IAccessControlService Interface See Also Send Feedback
Sets data scope and entityBaseDataScope in out parameter

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SetDataScopes(
    string entityIdentifier,
    string[] permissionlist,
    out Dictionary<string, DataScope> dicDataScope,
    out Dictionary<string, EntityBasedDataScope> dicEntityDataScope
)
Visual Basic
Sub SetDataScopes (
    entityIdentifier As String,
    permissionlist As String(),
    <OutAttribute> ByRef dicDataScope As Dictionary(Of String, DataScope),
    <OutAttribute> ByRef dicEntityDataScope As Dictionary(Of String, EntityBasedDataScope)
)
Visual C++
void SetDataScopes(
    String^ entityIdentifier,
    array<String^>^ permissionlist,
    [OutAttribute] Dictionary<String^, DataScope^>^% dicDataScope,
    [OutAttribute] Dictionary<String^, EntityBasedDataScope^>^% dicEntityDataScope
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
permissionlist
Type: array<System..::..String>[]()[][]
Permission List
dicDataScope
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, DataScope >)>)>%
Data Scope Details
dicEntityDataScope
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, EntityBasedDataScope >)>)>%
Entity Based Data Scope Details

See Also

IAccessControlService Interface
IAccessControlService Members
SetDataScopes Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService Interface

[image]

A Sandcastle Documented Class Library
IDataAccessService Interface
Members See Also Send Feedback
Data Access Service Interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IDataAccessService
Visual Basic
Public Interface IDataAccessService
Visual C++
public interface class IDataAccessService

See Also

IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService Members

[image] [image]

A Sandcastle Documented Class Library
IDataAccessService Members
IDataAccessService Interface Methods See Also Send Feedback

The IDataAccessService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllDataScope | This method is used to get all data scope details
Public method | GetAllDataScopeBasedonEntity | This method is used to get all data scope details based on the entity id's
Public method | GetDataScope(Dictionary<(Of <<'(String, RolePrivilege>)>>)) | Which all data of the entity identified by the identifier can the user access for the following action
Public method | GetDataScope(String) | This method is used to get DataScope details based on the data scope name.
Public method | GetDataScopeFilterData | Get the datascope filter data based on entityId and permissionName
Public method | GetDynamicVariable | Gets the dynamic variable.
Public method | GetDynamicVariables(String) | Gets the dynamic variables.
Public method | GetDynamicVariables(array<String>[]()[][]) | Gets the dynamic variables.
Public method | GetEntityBasedDataScope | This method is used to get Entity based Data Scope details based on the Entity Identifier and DataScope Name
Public method | GetViewPrivilegesForAllEntities | Gets the view privileges for entity.
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, BaseEntity) |
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, String, String) |
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, String, array<String>[]()[][]) |

See Also

IDataAccessService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService Methods

[image] [image]

A Sandcastle Documented Class Library
IDataAccessService Methods
IDataAccessService Interface See Also Send Feedback

The IDataAccessService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllDataScope | This method is used to get all data scope details
Public method | GetAllDataScopeBasedonEntity | This method is used to get all data scope details based on the entity id's
Public method | GetDataScope(Dictionary<(Of <<'(String, RolePrivilege>)>>)) | Which all data of the entity identified by the identifier can the user access for the following action
Public method | GetDataScope(String) | This method is used to get DataScope details based on the data scope name.
Public method | GetDataScopeFilterData | Get the datascope filter data based on entityId and permissionName
Public method | GetDynamicVariable | Gets the dynamic variable.
Public method | GetDynamicVariables(String) | Gets the dynamic variables.
Public method | GetDynamicVariables(array<String>[]()[][]) | Gets the dynamic variables.
Public method | GetEntityBasedDataScope | This method is used to get Entity based Data Scope details based on the Entity Identifier and DataScope Name
Public method | GetViewPrivilegesForAllEntities | Gets the view privileges for entity.
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, BaseEntity) |
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, String, String) |
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, String, array<String>[]()[][]) |

See Also

IDataAccessService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetAllDataScope Method

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetAllDataScope Method
IDataAccessService Interface See Also Send Feedback
This method is used to get all data scope details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<DataScope> GetAllDataScope()
Visual Basic
Function GetAllDataScope As List(Of DataScope)
Visual C++
List<DataScope^>^ GetAllDataScope()

Return Value

Type: List<(Of <(<' DataScope >)>)>
Data scope details

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetAllDataScopeBasedonEntity Method

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetAllDataScopeBasedonEntity Method
IDataAccessService Interface See Also Send Feedback
This method is used to get all data scope details based on the entity id's

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, DataScope>> GetAllDataScopeBasedonEntity(
    string[] entityIds
)
Visual Basic
Function GetAllDataScopeBasedonEntity (
    entityIds As String()
) As Dictionary(Of String, Dictionary(Of String, DataScope))
Visual C++
Dictionary<String^, Dictionary<String^, DataScope^>^>^ GetAllDataScopeBasedonEntity(
    array<String^>^ entityIds
)

Parameters

entityIds
Type: array<System..::..String>[]()[][]

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, DataScope >)>)>>)>)>
Data scope details for the enityid's

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDataScope Method

[image] [image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDataScope Method
IDataAccessService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataScope(Dictionary<(Of <<'(String, RolePrivilege>)>>)) | Which all data of the entity identified by the identifier can the user access for the following action
Public method | GetDataScope(String) | This method is used to get DataScope details based on the data scope name.

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDataScope Method (Dictionary(String, RolePrivilege))

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDataScope Method (Dictionary<(Of <(<'String, RolePrivilege>)>)>)
IDataAccessService Interface See Also Send Feedback
Which all data of the entity identified by the identifier can the user access for the following action

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataScope GetDataScope(
    Dictionary<string, RolePrivilege> rolePrivileges
)
Visual Basic
Function GetDataScope (
    rolePrivileges As Dictionary(Of String, RolePrivilege)
) As DataScope
Visual C++
DataScope^ GetDataScope(
    Dictionary<String^, RolePrivilege^>^ rolePrivileges
)

Parameters

rolePrivileges
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, RolePrivilege >)>)>

Return Value

Type: DataScope

See Also

IDataAccessService Interface
IDataAccessService Members
GetDataScope Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDataScope Method (String)

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDataScope Method (String)
IDataAccessService Interface See Also Send Feedback
This method is used to get DataScope details based on the data scope name.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataScope GetDataScope(
    string dataScopeName
)
Visual Basic
Function GetDataScope (
    dataScopeName As String
) As DataScope
Visual C++
DataScope^ GetDataScope(
    String^ dataScopeName
)

Parameters

dataScopeName
Type: System..::..String
Data Scope Name

Return Value

Type: DataScope
DataScope Details

See Also

IDataAccessService Interface
IDataAccessService Members
GetDataScope Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDataScopeFilterData Method

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDataScopeFilterData Method
IDataAccessService Interface See Also Send Feedback
Get the datascope filter data based on entityId and permissionName

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetDataScopeFilterData(
    string entityId,
    string permissionName
)
Visual Basic
Function GetDataScopeFilterData (
    entityId As String,
    permissionName As String
) As List(Of String)
Visual C++
List<String^>^ GetDataScopeFilterData(
    String^ entityId,
    String^ permissionName
)

Parameters

entityId
Type: System..::..String
entityId
permissionName
Type: System..::..String
permissionName

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDynamicVariable Method

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDynamicVariable Method
IDataAccessService Interface See Also Send Feedback
Gets the dynamic variable.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DynamicVariable GetDynamicVariable(
    string dynamicVariableId
)
Visual Basic
Function GetDynamicVariable (
    dynamicVariableId As String
) As DynamicVariable
Visual C++
DynamicVariable^ GetDynamicVariable(
    String^ dynamicVariableId
)

Parameters

dynamicVariableId
Type: System..::..String
The dynamic variable id.

Return Value

Type: DynamicVariable

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDynamicVariables Method

[image] [image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDynamicVariables Method
IDataAccessService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDynamicVariables(String) | Gets the dynamic variables.
Public method | GetDynamicVariables(array<String>[]()[][]) | Gets the dynamic variables.

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDynamicVariables Method (String)

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDynamicVariables Method (String)
IDataAccessService Interface See Also Send Feedback
Gets the dynamic variables.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, DynamicVariable> GetDynamicVariables(
    string dataScopeId
)
Visual Basic
Function GetDynamicVariables (
    dataScopeId As String
) As Dictionary(Of String, DynamicVariable)
Visual C++
Dictionary<String^, DynamicVariable^>^ GetDynamicVariables(
    String^ dataScopeId
)

Parameters

dataScopeId
Type: System..::..String
The data scope id.

Return Value

Type: Dictionary<(Of <(<'String, DynamicVariable >)>)>

See Also

IDataAccessService Interface
IDataAccessService Members
GetDynamicVariables Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetDynamicVariables Method (String[])

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetDynamicVariables Method (array<String>[]()[][])
IDataAccessService Interface See Also Send Feedback
Gets the dynamic variables.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, DynamicVariable>> GetDynamicVariables(
    string[] dataScopeIds
)
Visual Basic
Function GetDynamicVariables (
    dataScopeIds As String()
) As Dictionary(Of String, Dictionary(Of String, DynamicVariable))
Visual C++
Dictionary<String^, Dictionary<String^, DynamicVariable^>^>^ GetDynamicVariables(
    array<String^>^ dataScopeIds
)

Parameters

dataScopeIds
Type: array<System..::..String>[]()[][]
The data scope ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, DynamicVariable >)>)>>)>)>

See Also

IDataAccessService Interface
IDataAccessService Members
GetDynamicVariables Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetEntityBasedDataScope Method

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetEntityBasedDataScope Method
IDataAccessService Interface See Also Send Feedback
This method is used to get Entity based Data Scope details based on the Entity Identifier and DataScope Name

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityBasedDataScope GetEntityBasedDataScope(
    string entityIdentifier,
    string dataScopeName
)
Visual Basic
Function GetEntityBasedDataScope (
    entityIdentifier As String,
    dataScopeName As String
) As EntityBasedDataScope
Visual C++
EntityBasedDataScope^ GetEntityBasedDataScope(
    String^ entityIdentifier,
    String^ dataScopeName
)

Parameters

entityIdentifier
Type: System..::..String
Entity ID
dataScopeName
Type: System..::..String
Data Scope Name

Return Value

Type: EntityBasedDataScope
Entity based Data Scope details

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.GetViewPrivilegesForAllEntities Method

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..GetViewPrivilegesForAllEntities Method
IDataAccessService Interface See Also Send Feedback
Gets the view privileges for entity.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
IDictionary<string, string> GetViewPrivilegesForAllEntities()
Visual Basic
Function GetViewPrivilegesForAllEntities As IDictionary(Of String, String)
Visual C++
IDictionary<String^, String^>^ GetViewPrivilegesForAllEntities()

Return Value

Type: IDictionary<(Of <(<'String, String>)>)>

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.ValidateDataScope Method

[image] [image]

A Sandcastle Documented Class Library
IDataAccessService..::..ValidateDataScope Method
IDataAccessService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, BaseEntity) |
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, String, String) |
Public method | ValidateDataScope(DataScope, EntityBasedDataScope, String, array<String>[]()[][]) |

See Also

IDataAccessService Interface
IDataAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.ValidateDataScope Method (DataScope, EntityBasedDataScope, BaseEntity)

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..ValidateDataScope Method (DataScope, EntityBasedDataScope, BaseEntity)
IDataAccessService Interface See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateDataScope(
    DataScope dataScope,
    EntityBasedDataScope entityBasedDataScope,
    BaseEntity entity
)
Visual Basic
Function ValidateDataScope (
    dataScope As DataScope,
    entityBasedDataScope As EntityBasedDataScope,
    entity As BaseEntity
) As Boolean
Visual C++
bool ValidateDataScope(
    DataScope^ dataScope,
    EntityBasedDataScope^ entityBasedDataScope,
    BaseEntity^ entity
)

Parameters

dataScope
Type: CelloSaaS.Model.AccessControlManagement..::..DataScope
entityBasedDataScope
Type: CelloSaaS.Model.AccessControlManagement..::..EntityBasedDataScope
entity
Type: CelloSaaS.Model..::..BaseEntity

Return Value

Type: Boolean

See Also

IDataAccessService Interface
IDataAccessService Members
ValidateDataScope Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.ValidateDataScope Method (DataScope, EntityBasedDataScope, String, String)

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..ValidateDataScope Method (DataScope, EntityBasedDataScope, String, String)
IDataAccessService Interface See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateDataScope(
    DataScope dataScope,
    EntityBasedDataScope entityBasedDataScope,
    string entityIdentifier,
    string referenceId
)
Visual Basic
Function ValidateDataScope (
    dataScope As DataScope,
    entityBasedDataScope As EntityBasedDataScope,
    entityIdentifier As String,
    referenceId As String
) As Boolean
Visual C++
bool ValidateDataScope(
    DataScope^ dataScope,
    EntityBasedDataScope^ entityBasedDataScope,
    String^ entityIdentifier,
    String^ referenceId
)

Parameters

dataScope
Type: CelloSaaS.Model.AccessControlManagement..::..DataScope
entityBasedDataScope
Type: CelloSaaS.Model.AccessControlManagement..::..EntityBasedDataScope
entityIdentifier
Type: System..::..String
referenceId
Type: System..::..String

Return Value

Type: Boolean

See Also

IDataAccessService Interface
IDataAccessService Members
ValidateDataScope Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IDataAccessService.ValidateDataScope Method (DataScope, EntityBasedDataScope, String, String[])

[image]

A Sandcastle Documented Class Library
IDataAccessService..::..ValidateDataScope Method (DataScope, EntityBasedDataScope, String, array<String>[]()[][])
IDataAccessService Interface See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> ValidateDataScope(
    DataScope dataScope,
    EntityBasedDataScope entityBasedDataScope,
    string entityIdentifier,
    string[] referenceIds
)
Visual Basic
Function ValidateDataScope (
    dataScope As DataScope,
    entityBasedDataScope As EntityBasedDataScope,
    entityIdentifier As String,
    referenceIds As String()
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ ValidateDataScope(
    DataScope^ dataScope,
    EntityBasedDataScope^ entityBasedDataScope,
    String^ entityIdentifier,
    array<String^>^ referenceIds
)

Parameters

dataScope
Type: CelloSaaS.Model.AccessControlManagement..::..DataScope
entityBasedDataScope
Type: CelloSaaS.Model.AccessControlManagement..::..EntityBasedDataScope
entityIdentifier
Type: System..::..String
referenceIds
Type: array<System..::..String>[]()[][]

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>

See Also

IDataAccessService Interface
IDataAccessService Members
ValidateDataScope Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IEntityPrivilegeService Interface

[image]

A Sandcastle Documented Class Library
IEntityPrivilegeService Interface
Members See Also Send Feedback
Privilege Service Interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IEntityPrivilegeService
Visual Basic
Public Interface IEntityPrivilegeService
Visual C++
public interface class IEntityPrivilegeService

See Also

IEntityPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IEntityPrivilegeService Members

[image] [image]

A Sandcastle Documented Class Library
IEntityPrivilegeService Members
IEntityPrivilegeService Interface Methods See Also Send Feedback

The IEntityPrivilegeService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllEntityPrivileges | This method is used to get entity privileges for entity ids
Public method | GetEntityPrivileges | This method is used to get entity privilege for entity id

See Also

IEntityPrivilegeService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IEntityPrivilegeService Methods

[image] [image]

A Sandcastle Documented Class Library
IEntityPrivilegeService Methods
IEntityPrivilegeService Interface See Also Send Feedback

The IEntityPrivilegeService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllEntityPrivileges | This method is used to get entity privileges for entity ids
Public method | GetEntityPrivileges | This method is used to get entity privilege for entity id

See Also

IEntityPrivilegeService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IEntityPrivilegeService.GetAllEntityPrivileges Method

[image]

A Sandcastle Documented Class Library
IEntityPrivilegeService..::..GetAllEntityPrivileges Method
IEntityPrivilegeService Interface Example See Also Send Feedback
This method is used to get entity privileges for entity ids

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, EntityPrivilege>> GetAllEntityPrivileges(
    string[] entityIds
)
Visual Basic
Function GetAllEntityPrivileges (
    entityIds As String()
) As Dictionary(Of String, Dictionary(Of String, EntityPrivilege))
Visual C++
Dictionary<String^, Dictionary<String^, EntityPrivilege^>^>^ GetAllEntityPrivileges(
    array<String^>^ entityIds
)

Parameters

entityIds
Type: array<System..::..String>[]()[][]
Entity Identifierss

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, EntityPrivilege >)>)>>)>)>
Entity Privilege Details

Examples

Copy image Copy
public void GetAllEntityPrivileges()
{
    string[] entityIds = new string[] {"User", "UserRole"};
    IEntityPrivilegeService entityPrivilegeServive =(IEntityPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IEntityPrivilegeService));
    Dictionary<string, Dictionary<string, EntityPrivilege>> entityPrivileges = entityPrivilegeServive.GetAllEntityPrivileges(entityIds);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | This exception is thrown while fetching role entity privilege details
System..::..ArgumentNullException | This exception is thrown when entity ids are null or empty

See Also

IEntityPrivilegeService Interface
IEntityPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IEntityPrivilegeService.GetEntityPrivileges Method

[image]

A Sandcastle Documented Class Library
IEntityPrivilegeService..::..GetEntityPrivileges Method
IEntityPrivilegeService Interface Example See Also Send Feedback
This method is used to get entity privilege for entity id

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityPrivilege> GetEntityPrivileges(
    string entityId
)
Visual Basic
Function GetEntityPrivileges (
    entityId As String
) As Dictionary(Of String, EntityPrivilege)
Visual C++
Dictionary<String^, EntityPrivilege^>^ GetEntityPrivileges(
    String^ entityId
)

Parameters

entityId
Type: System..::..String
Entity Identifier

Return Value

Type: Dictionary<(Of <(<'String, EntityPrivilege >)>)>
Entity Privilege Details

Examples

Copy image Copy
public void GetEntityPrivileges()
{
    string entityId = "User";
    IEntityPrivilegeService entityPrivilegeServive =(IEntityPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IEntityPrivilegeService));
    Dictionary<string, EntityPrivilege> entityPrivileges = entityPrivilegeServive.GetEntityPrivileges(entityId);
}

See Also

IEntityPrivilegeService Interface
IEntityPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService Interface

[image]

A Sandcastle Documented Class Library
IFeatureService Interface
Members See Also Send Feedback
Feature Service Interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IFeatureService
Visual Basic
Public Interface IFeatureService
Visual C++
public interface class IFeatureService

See Also

IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService Members

[image] [image]

A Sandcastle Documented Class Library
IFeatureService Members
IFeatureService Interface Methods See Also Send Feedback

The IFeatureService type exposes the following members.

Methods

 | Name | Description
Public method | AddFeatureToRole | This method is used to add feature to role
Public method | DeleteFeaturesForRole | This method is used to delete features for role
Public method | GetFeaturesForRole | This method is used to get role features for role Identifier.
Public method | SaveFeaturesToRole | This method is used to add/update role features details for the given role id,tenant id,feature codes
Public method | UpdateFeaturesToRole | This method is used to updae Role features for the given role id,tenant id,features
Public method | UpdateRoleFeature | This method is used to update role feature details

See Also

IFeatureService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService Methods

[image] [image]

A Sandcastle Documented Class Library
IFeatureService Methods
IFeatureService Interface See Also Send Feedback

The IFeatureService type exposes the following members.

Methods

 | Name | Description
Public method | AddFeatureToRole | This method is used to add feature to role
Public method | DeleteFeaturesForRole | This method is used to delete features for role
Public method | GetFeaturesForRole | This method is used to get role features for role Identifier.
Public method | SaveFeaturesToRole | This method is used to add/update role features details for the given role id,tenant id,feature codes
Public method | UpdateFeaturesToRole | This method is used to updae Role features for the given role id,tenant id,features
Public method | UpdateRoleFeature | This method is used to update role feature details

See Also

IFeatureService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService.AddFeatureToRole Method

[image]

A Sandcastle Documented Class Library
IFeatureService..::..AddFeatureToRole Method
IFeatureService Interface Example See Also Send Feedback
This method is used to add feature to role

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddFeatureToRole(
    string tenantCode,
    RoleFeature roleFeature
)
Visual Basic
Function AddFeatureToRole (
    tenantCode As String,
    roleFeature As RoleFeature
) As String
Visual C++
String^ AddFeatureToRole(
    String^ tenantCode,
    RoleFeature^ roleFeature
)

Parameters

tenantCode
Type: System..::..String
Tenant Code(Mandatory)
roleFeature
Type: CelloSaaS.Model.AccessControlManagement..::..RoleFeature
Role Feature Details(Mandatory - Role Identifier, Feature Identifier)

Return Value

Type: String
Role Feature Identifier

Examples

Copy image Copy
public void AddFeatureToRole()
{
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    RoleFeature roleFeature = new RoleFeature();
    roleFeature.FeatureId = "ManageUser";
    roleFeature.RoleId = "GR$Tenant_Admin";
    IFeatureService featureServive = (IFeatureService)ServiceLocator.GetServiceImplementation(typeof(IFeatureService));
    featureServive.AddFeatureToRole(roleFeature);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when role feature or role feature id or role feature role id or tenant code is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when it does not have permission to add role feature details
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException | This exception is thrown while addding role feature details or not inserted successfully

See Also

IFeatureService Interface
IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService.DeleteFeaturesForRole Method

[image]

A Sandcastle Documented Class Library
IFeatureService..::..DeleteFeaturesForRole Method
IFeatureService Interface Example See Also Send Feedback
This method is used to delete features for role

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteFeaturesForRole(
    string roleId,
    string tenantId,
    string[] featureCodes
)
Visual Basic
Sub DeleteFeaturesForRole (
    roleId As String,
    tenantId As String,
    featureCodes As String()
)
Visual C++
void DeleteFeaturesForRole(
    String^ roleId,
    String^ tenantId,
    array<String^>^ featureCodes
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
featureCodes
Type: array<System..::..String>[]()[][]
Feature Codes(Mandatory)

Examples

Copy image Copy
public void DeleteFeaturesForRole()
{
    string roleId = "GR$Tenant_Admin";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string[] featureCodes = new string[] {"ManageUser", "ManageUserRoles"};
    IFeatureService featureServive = (IFeatureService)ServiceLocator.GetServiceImplementation(typeof(IFeatureService));
    featureServive.DeleteFeaturesForRole(roleId, tenantId, featureCodes);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when role id or featureCodes or tenant id is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when it does not have permission to delete role feature details
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException | This exception is thrown while deleting role feature details

See Also

IFeatureService Interface
IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService.GetFeaturesForRole Method

[image]

A Sandcastle Documented Class Library
IFeatureService..::..GetFeaturesForRole Method
IFeatureService Interface Example See Also Send Feedback
This method is used to get role features for role Identifier.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, RoleFeature> GetFeaturesForRole(
    string roleId,
    string tenantId
)
Visual Basic
Function GetFeaturesForRole (
    roleId As String,
    tenantId As String
) As Dictionary(Of String, RoleFeature)
Visual C++
Dictionary<String^, RoleFeature^>^ GetFeaturesForRole(
    String^ roleId,
    String^ tenantId
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, RoleFeature >)>)>
Role Features with their Identifiers

Examples

Copy image Copy
public void SaveFeaturesToRole()
{
    string roleId = "GR$Tenant_Admin";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IFeatureService featureServive = (IFeatureService)ServiceLocator.GetServiceImplementation(typeof(IFeatureService));
    Dictionary<string, RoleFeature> roleFeatures = featureServive.GetFeaturesForRole(roleId, tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when role id or tenant id is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when it does not have permission to view role feature details
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException | This exception is thrown while fetching role feature details

See Also

IFeatureService Interface
IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService.SaveFeaturesToRole Method

[image]

A Sandcastle Documented Class Library
IFeatureService..::..SaveFeaturesToRole Method
IFeatureService Interface Example See Also Send Feedback
This method is used to add/update role features details for the given role id,tenant id,feature codes

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveFeaturesToRole(
    string roleId,
    string tenantId,
    string[] featureCodes
)
Visual Basic
Sub SaveFeaturesToRole (
    roleId As String,
    tenantId As String,
    featureCodes As String()
)
Visual C++
void SaveFeaturesToRole(
    String^ roleId,
    String^ tenantId,
    array<String^>^ featureCodes
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
featureCodes
Type: array<System..::..String>[]()[][]
Feature Codes(Mandatory)

Examples

Copy image Copy
public void SaveFeaturesToRole()
{
    string roleId = "GR$Tenant_Admin";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string[] featureCodes = new string[] {"ManageUser", "ManageUserRoles"};
    IFeatureService featureServive = (IFeatureService)ServiceLocator.GetServiceImplementation(typeof(IFeatureService));
    featureServive.SaveFeaturesToRole(roleId, tenantId, featureCodes);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when role id or feature codes or tenant id is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when it does not have permission to save role feature details
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException | This exception is thrown while saving role feature details

See Also

IFeatureService Interface
IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService.UpdateFeaturesToRole Method

[image]

A Sandcastle Documented Class Library
IFeatureService..::..UpdateFeaturesToRole Method
IFeatureService Interface Example See Also Send Feedback
This method is used to updae Role features for the given role id,tenant id,features

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateFeaturesToRole(
    string roleId,
    string tenantId,
    string[] features
)
Visual Basic
Sub UpdateFeaturesToRole (
    roleId As String,
    tenantId As String,
    features As String()
)
Visual C++
void UpdateFeaturesToRole(
    String^ roleId,
    String^ tenantId,
    array<String^>^ features
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
features
Type: array<System..::..String>[]()[][]
Feature codes

Examples

Copy image Copy
public void UpdateFeaturesToRole()
{
    string roleId = "GR$Tenant_Admin";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string[] features = new string[] {"ManageUser", "ManageUserRoles"};
    IFeatureService featureServive = (IFeatureService)ServiceLocator.GetServiceImplementation(typeof(IFeatureService));
    featureServive.UpdateFeaturesToRole(roleId, tenantId, features);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when role id or tenant id is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when it does not have permission to save role feature details
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException | This exception is thrown while updating role feature details

See Also

IFeatureService Interface
IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IFeatureService.UpdateRoleFeature Method

[image]

A Sandcastle Documented Class Library
IFeatureService..::..UpdateRoleFeature Method
IFeatureService Interface Example See Also Send Feedback
This method is used to update role feature details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRoleFeature(
    RoleFeature roleFeature
)
Visual Basic
Sub UpdateRoleFeature (
    roleFeature As RoleFeature
)
Visual C++
void UpdateRoleFeature(
    RoleFeature^ roleFeature
)

Parameters

roleFeature
Type: CelloSaaS.Model.AccessControlManagement..::..RoleFeature
Role Feature DetailsMandatory - Role Identifier, Feature Identifier, Tenant Code)

Examples

Copy image Copy
public void UpdateRoleFeature()
{
    RoleFeature roleFeature = new RoleFeature();
    roleFeature.FeatureId = "ManageUser";
    roleFeature.RoleId = "GR$Tenant_Admin";
    roleFeature.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    roleFeature.DataScopeId = "8FB38A1C-FCBD-4F99-9DED-6EA4CC0B97A4";
    IFeatureService featureServive = (IFeatureService)ServiceLocator.GetServiceImplementation(typeof(IFeatureService));
    featureServive.UpdateRoleFeature(roleFeature);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when role feature or role feature id or role feature role id or tenant code is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when it does not have permission to update role feature details
CelloSaaS.ServiceContracts.AccessControlManagement..::..FeatureException | This exception is thrown while addding role feature details

See Also

IFeatureService Interface
IFeatureService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService Interface

[image]

A Sandcastle Documented Class Library
IPrivilegeService Interface
Members See Also Send Feedback
Privilege Service Interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IPrivilegeService
Visual Basic
Public Interface IPrivilegeService
Visual C++
public interface class IPrivilegeService

See Also

IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService Members

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService Members
IPrivilegeService Interface Methods See Also Send Feedback

The IPrivilegeService type exposes the following members.

Methods

 | Name | Description
Public method | AddDynamicDatascopeValue | This method is used to adds the dynamic datascope value.
Public method | AddPrivileges | Add privilege details to the system.
Public method | AddPrivilegesToRole | Add role privilege details
Public method | AddPrivilegeToRole | Add privilege details to role.
Public method | CheckTenantAccessPrivilege | Obsolete. Checks the tenant access privilege.
Public method | DeletePrivilegesForRole | Delete privileges for role
Public method | DeleteRolePrivilege | Delete role privilege details
Public method | GetAllPrivileges | Get all privilege defined in the system.
Public method | GetCurrentUsersAssignablePrivilegesForRole | Gets offeredPrivilege for given role.
Public method | GetDefaultAssignablePrivilegesForRole | Get assignable privileges for given role.
Public method | GetDynamicDatascopeValues(String) | Gets the dynamic datascope values.
Public method | GetDynamicDatascopeValues(array<String>[]()[][]) | This method is used to gets the dynamic datascope values.
Public method | GetDynamicDatascopeValues(String, String) | This method is used to gets the dynamic datascope values.
Public method | GetPrivilege | Get privilege details for a particular privilege identifier.
Public method | GetPrivilegeNames | Gets the privilege identifiers for the given roles
Public method | GetPrivilegeNamesOfCurrentUser | Get list of privilege identifiers for a current user
Public method | GetPrivileges(array<String>[]()[][]) | Get privilege details for array of privilege ids
Public method | GetPrivileges(String, String) | Get all privilege details based on the privilege search name and tenant code
Public method | GetPrivilegesbyFeatureIds(array<String>[]()[][]) | Gets the privileges by feature ids.
Public method | GetPrivilegesbyFeatureIds(array<String>[]()[][], String) | Gets the privileges by feature ids.
Public method | GetPrivilegesbyModuleIds | Gets the privileges by module ids.
Public method | GetPrivilegesByServiceIds | Gets privilege by serviceIds
Public method | GetPrivilegesForRoles(String, array<String>[]()[][]) | Get Role Privilege details
Public method | GetPrivilegesForRoles(String, array<String>[]()[][], String) | Get Privilege details for roles
Public method | GetRolePrivilegeCount(String, array<String>[]()[][]) | Gets the role privilege count.
Public method | GetRolePrivilegeCount(array<String>[]()[][], array<String>[]()[][]) | Gets the role privilege count.
Public method | GetRolePrivilegesForPrivileges(String, array<String>[]()[][]) | Gets the role privileges for privileges.
Public method | GetRolePrivilegesForPrivileges(array<String>[]()[][], array<String>[]()[][]) | Gets the role privileges for privileges for tenants.
Public method | GetTenantAccessPrivileges(array<String>[]()[][]) | Obsolete. Gets the tenant access privileges.
Public method | GetTenantAccessPrivileges(String, array<String>[]()[][]) | Obsolete. Gets the tenant access privileges.
Public method | SavePrivilegesToRole | Add/update privileges to role
Public method | UpdateDynamicDatascopeValue | This method is used to updates the dynamic datascope value.
Public method | UpdateRolePrivilege | Update role privilege details

See Also

IPrivilegeService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService Methods

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService Methods
IPrivilegeService Interface See Also Send Feedback

The IPrivilegeService type exposes the following members.

Methods

 | Name | Description
Public method | AddDynamicDatascopeValue | This method is used to adds the dynamic datascope value.
Public method | AddPrivileges | Add privilege details to the system.
Public method | AddPrivilegesToRole | Add role privilege details
Public method | AddPrivilegeToRole | Add privilege details to role.
Public method | CheckTenantAccessPrivilege | Obsolete. Checks the tenant access privilege.
Public method | DeletePrivilegesForRole | Delete privileges for role
Public method | DeleteRolePrivilege | Delete role privilege details
Public method | GetAllPrivileges | Get all privilege defined in the system.
Public method | GetCurrentUsersAssignablePrivilegesForRole | Gets offeredPrivilege for given role.
Public method | GetDefaultAssignablePrivilegesForRole | Get assignable privileges for given role.
Public method | GetDynamicDatascopeValues(String) | Gets the dynamic datascope values.
Public method | GetDynamicDatascopeValues(array<String>[]()[][]) | This method is used to gets the dynamic datascope values.
Public method | GetDynamicDatascopeValues(String, String) | This method is used to gets the dynamic datascope values.
Public method | GetPrivilege | Get privilege details for a particular privilege identifier.
Public method | GetPrivilegeNames | Gets the privilege identifiers for the given roles
Public method | GetPrivilegeNamesOfCurrentUser | Get list of privilege identifiers for a current user
Public method | GetPrivileges(array<String>[]()[][]) | Get privilege details for array of privilege ids
Public method | GetPrivileges(String, String) | Get all privilege details based on the privilege search name and tenant code
Public method | GetPrivilegesbyFeatureIds(array<String>[]()[][]) | Gets the privileges by feature ids.
Public method | GetPrivilegesbyFeatureIds(array<String>[]()[][], String) | Gets the privileges by feature ids.
Public method | GetPrivilegesbyModuleIds | Gets the privileges by module ids.
Public method | GetPrivilegesByServiceIds | Gets privilege by serviceIds
Public method | GetPrivilegesForRoles(String, array<String>[]()[][]) | Get Role Privilege details
Public method | GetPrivilegesForRoles(String, array<String>[]()[][], String) | Get Privilege details for roles
Public method | GetRolePrivilegeCount(String, array<String>[]()[][]) | Gets the role privilege count.
Public method | GetRolePrivilegeCount(array<String>[]()[][], array<String>[]()[][]) | Gets the role privilege count.
Public method | GetRolePrivilegesForPrivileges(String, array<String>[]()[][]) | Gets the role privileges for privileges.
Public method | GetRolePrivilegesForPrivileges(array<String>[]()[][], array<String>[]()[][]) | Gets the role privileges for privileges for tenants.
Public method | GetTenantAccessPrivileges(array<String>[]()[][]) | Obsolete. Gets the tenant access privileges.
Public method | GetTenantAccessPrivileges(String, array<String>[]()[][]) | Obsolete. Gets the tenant access privileges.
Public method | SavePrivilegesToRole | Add/update privileges to role
Public method | UpdateDynamicDatascopeValue | This method is used to updates the dynamic datascope value.
Public method | UpdateRolePrivilege | Update role privilege details

See Also

IPrivilegeService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.AddDynamicDatascopeValue Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..AddDynamicDatascopeValue Method
IPrivilegeService Interface See Also Send Feedback
This method is used to adds the dynamic datascope value.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddDynamicDatascopeValue(
    DynamicDatascopeValue dynamicDatascopeValue
)
Visual Basic
Function AddDynamicDatascopeValue (
    dynamicDatascopeValue As DynamicDatascopeValue
) As String
Visual C++
String^ AddDynamicDatascopeValue(
    DynamicDatascopeValue^ dynamicDatascopeValue
)

Parameters

dynamicDatascopeValue
Type: CelloSaaS.Model.AccessControlManagement..::..DynamicDatascopeValue
The dynamic datascope value.

Return Value

Type: String

Exceptions

Exception | Condition
System..::..ArgumentException | If dynamic data scope value is null
CelloSaaS.ServiceContracts.AccessControlManagement..::..DataAccessException | If db exceptions occur

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.AddPrivileges Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..AddPrivileges Method
IPrivilegeService Interface Example See Also Send Feedback
Add privilege details to the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddPrivileges(
    List<Privilege> privileges
)
Visual Basic
Sub AddPrivileges (
    privileges As List(Of Privilege)
)
Visual C++
void AddPrivileges(
    List<Privilege^>^ privileges
)

Parameters

privileges
Type: System.Collections.Generic..::..List<(Of <(<' Privilege >)>)>
Privilege Details(Mandatory)

Examples

Copy image Copy
public void AddPrivileges()
{
    List<Privilege> privileges = new List<Privilege>();
    Privilege privilege = new Privilege();
    privilege.Id = "Add_User";
    privilege.Name = "Add User";
    privilege.Description = "Add User";
    privileges.Add(privilege);
    privilege = new Privilege();
    privilege.Id = "Edit_User";
    privilege.Name = "Edit User";
    privilege.Description = "Edit User";
    privileges.Add(privilege);
    privilege = new Privilege();
    privilege.Id = "Delete_User";
    privilege.Name = "Delete User";
    privilege.Description = "Delete User";
    privileges.Add(privilege);
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    privilegeServive.AddPrivileges(privileges);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If privileges is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.AddPrivilegesToRole Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..AddPrivilegesToRole Method
IPrivilegeService Interface Example See Also Send Feedback
Add role privilege details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddPrivilegesToRole(
    string tenantIdentifier,
    List<RolePrivilege> rolePrivileges
)
Visual Basic
Sub AddPrivilegesToRole (
    tenantIdentifier As String,
    rolePrivileges As List(Of RolePrivilege)
)
Visual C++
void AddPrivilegesToRole(
    String^ tenantIdentifier,
    List<RolePrivilege^>^ rolePrivileges
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier(Mandatory)
rolePrivileges
Type: System.Collections.Generic..::..List<(Of <(<' RolePrivilege >)>)>
Role PRivilege Details(Mandatory)

Examples

Copy image Copy
public void AddPrivilegesToRole()
{
    string tenantIdentifier = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    List<RolePrivilege> rolePrivileges = new List<RolePrivilege>();
    RolePrivilege rolePrivilege1 = new RolePrivilege();
    rolePrivilege1.RoleId = "GR$Tenant_Admin";
    rolePrivilege1.DataScopeId = "8FB38A1C-FCBD-4F99-9DED-6EA4CC0B97A4";
    rolePrivilege1.PrivilegeId = "Add_Role";
    rolePrivileges.Add(rolePrivilege1);
    rolePrivilege1 = new RolePrivilege();
    rolePrivilege1.RoleId = "GR$Tenant_Admin";
    rolePrivilege1.PrivilegeId = "Edit_Role";
    rolePrivileges.Add(rolePrivilege1);
    rolePrivilege1 = new RolePrivilege();
    rolePrivilege1.RoleId = "GR$Tenant_Admin";
    rolePrivilege1.DataScopeId = "8FB38A1C-FCBD-4F99-9DED-6EA4CC0B97A4";
    rolePrivilege1.PrivilegeId = "View_Role";
    rolePrivileges.Add(rolePrivilege1);
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    privilegeServive.AddPrivilegesToRole(tenantIdentifier, rolePrivileges);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If privileges is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.AddPrivilegeToRole Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..AddPrivilegeToRole Method
IPrivilegeService Interface Example See Also Send Feedback
Add privilege details to role.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddPrivilegeToRole(
    string tenantIdentifier,
    RolePrivilege rolePrivilege
)
Visual Basic
Function AddPrivilegeToRole (
    tenantIdentifier As String,
    rolePrivilege As RolePrivilege
) As String
Visual C++
String^ AddPrivilegeToRole(
    String^ tenantIdentifier,
    RolePrivilege^ rolePrivilege
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier(Mandatory)
rolePrivilege
Type: CelloSaaS.Model.AccessControlManagement..::..RolePrivilege
Role Privilege details(Mandatory)

Return Value

Type: String
Role privilege Identifier

Examples

Copy image Copy
public void AddPrivilegeToRole()
{
    string tenantIdentifier = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    RolePrivilege rolePrivilege = new RolePrivilege();
    rolePrivilege.PrivilegeId = "Add_User";
    rolePrivilege.RoleId = "GR$Tenant_Admin";
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    string rolePrivilegeId = privilegeServive.AddPrivilegeToRole(tenantIdentifier, rolePrivilege);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
System.Data..::..DataException | If it is duplicate privilege id
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If role privilege is null
System..::..ArgumentException | If privilege id or role id is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.CheckTenantAccessPrivilege Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..CheckTenantAccessPrivilege Method
IPrivilegeService Interface See Also Send Feedback
Checks the tenant access privilege.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
bool CheckTenantAccessPrivilege(
    string userId,
    string privilege,
    string tenantId
)
Visual Basic
<ObsoleteAttribute>
Function CheckTenantAccessPrivilege (
    userId As String,
    privilege As String,
    tenantId As String
) As Boolean
Visual C++
[ObsoleteAttribute]
bool CheckTenantAccessPrivilege(
    String^ userId,
    String^ privilege,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
privilege
Type: System..::..String
The privilege.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.DeletePrivilegesForRole Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..DeletePrivilegesForRole Method
IPrivilegeService Interface Example See Also Send Feedback
Delete privileges for role

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeletePrivilegesForRole(
    string tenantId,
    string roleId,
    string[] privilegeIds
)
Visual Basic
Sub DeletePrivilegesForRole (
    tenantId As String,
    roleId As String,
    privilegeIds As String()
)
Visual C++
void DeletePrivilegesForRole(
    String^ tenantId,
    String^ roleId,
    array<String^>^ privilegeIds
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
roleId
Type: System..::..String
Role Identifier(Mandatory)
privilegeIds
Type: array<System..::..String>[]()[][]
Privilege Identifiers(Mandatory)

Examples

Copy image Copy
public void DeletePrivilegesForRole()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string roleId = "GR$Tenant_Admin";
    string[] privilegeIds = new string[] {"Add_User", "Edit_User", "Delete_User"};
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    privilegeServive.DeletePrivilegesForRole(tenantId, roleId, privilegeIds);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege.
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs.
System..::..ArgumentNullException | If role id or privilege ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.DeleteRolePrivilege Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..DeleteRolePrivilege Method
IPrivilegeService Interface Example See Also Send Feedback
Delete role privilege details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteRolePrivilege(
    string rolePrivilegeId
)
Visual Basic
Sub DeleteRolePrivilege (
    rolePrivilegeId As String
)
Visual C++
void DeleteRolePrivilege(
    String^ rolePrivilegeId
)

Parameters

rolePrivilegeId
Type: System..::..String
Role Privilege Identifier(Mandatory)

Examples

Copy image Copy
public void DeleteRolePrivilege()
{
    string rolePrivilegeId = "FE574591-F293-DF11-8DEB-001EC9DAB123";
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    privilegeServive.DeleteRolePrivilege(rolePrivilegeId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If role privilege id is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetAllPrivileges Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetAllPrivileges Method
IPrivilegeService Interface Example See Also Send Feedback
Get all privilege defined in the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Privilege> GetAllPrivileges()
Visual Basic
Function GetAllPrivileges As List(Of Privilege)
Visual C++
List<Privilege^>^ GetAllPrivileges()

Return Value

Type: List<(Of <(<' Privilege >)>)>
Privilege Details

Examples

Copy image Copy
public void GetAllPrivileges()
{
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    List<Privilege> privileges = privilegeServive.GetAllPrivileges();
}

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetCurrentUsersAssignablePrivilegesForRole Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetCurrentUsersAssignablePrivilegesForRole Method
IPrivilegeService Interface See Also Send Feedback
Gets offeredPrivilege for given role.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetCurrentUsersAssignablePrivilegesForRole(
    string roleId
)
Visual Basic
Function GetCurrentUsersAssignablePrivilegesForRole (
    roleId As String
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetCurrentUsersAssignablePrivilegesForRole(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
the role id

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>
dictionary of privilege.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetDefaultAssignablePrivilegesForRole Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetDefaultAssignablePrivilegesForRole Method
IPrivilegeService Interface See Also Send Feedback
Get assignable privileges for given role.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetDefaultAssignablePrivilegesForRole(
    string roleId
)
Visual Basic
Function GetDefaultAssignablePrivilegesForRole (
    roleId As String
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetDefaultAssignablePrivilegesForRole(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
The role id.

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>
dictionary of privileges

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetDynamicDatascopeValues Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetDynamicDatascopeValues Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDynamicDatascopeValues(String) | Gets the dynamic datascope values.
Public method | GetDynamicDatascopeValues(array<String>[]()[][]) | This method is used to gets the dynamic datascope values.
Public method | GetDynamicDatascopeValues(String, String) | This method is used to gets the dynamic datascope values.

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetDynamicDatascopeValues Method (String)

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetDynamicDatascopeValues Method (String)
IPrivilegeService Interface See Also Send Feedback
Gets the dynamic datascope values.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, DynamicDatascopeValue> GetDynamicDatascopeValues(
    string rolePrivilegeId
)
Visual Basic
Function GetDynamicDatascopeValues (
    rolePrivilegeId As String
) As Dictionary(Of String, DynamicDatascopeValue)
Visual C++
Dictionary<String^, DynamicDatascopeValue^>^ GetDynamicDatascopeValues(
    String^ rolePrivilegeId
)

Parameters

rolePrivilegeId
Type: System..::..String
The role privilege id.

Return Value

Type: Dictionary<(Of <(<'String, DynamicDatascopeValue >)>)>
Dictionary of DynamicDatascopeValue.

Exceptions

Exception | Condition
System..::..ArgumentNullException | If role privilege id is null or empty.
CelloSaaS.ServiceContracts.AccessControlManagement..::..DataAccessException | If db exception occurs.

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetDynamicDatascopeValues Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetDynamicDatascopeValues Method (String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetDynamicDatascopeValues Method (array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
This method is used to gets the dynamic datascope values.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, DynamicDatascopeValue>> GetDynamicDatascopeValues(
    string[] rolePrivilegeIds
)
Visual Basic
Function GetDynamicDatascopeValues (
    rolePrivilegeIds As String()
) As Dictionary(Of String, Dictionary(Of String, DynamicDatascopeValue))
Visual C++
Dictionary<String^, Dictionary<String^, DynamicDatascopeValue^>^>^ GetDynamicDatascopeValues(
    array<String^>^ rolePrivilegeIds
)

Parameters

rolePrivilegeIds
Type: array<System..::..String>[]()[][]
The role privilege ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, DynamicDatascopeValue >)>)>>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..DataAccessException | If db exception occurs

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetDynamicDatascopeValues Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetDynamicDatascopeValues Method (String, String)

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetDynamicDatascopeValues Method (String, String)
IPrivilegeService Interface See Also Send Feedback
This method is used to gets the dynamic datascope values.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, DynamicDatascopeValue> GetDynamicDatascopeValues(
    string rolePrivilegeId,
    string dataScopeId
)
Visual Basic
Function GetDynamicDatascopeValues (
    rolePrivilegeId As String,
    dataScopeId As String
) As Dictionary(Of String, DynamicDatascopeValue)
Visual C++
Dictionary<String^, DynamicDatascopeValue^>^ GetDynamicDatascopeValues(
    String^ rolePrivilegeId,
    String^ dataScopeId
)

Parameters

rolePrivilegeId
Type: System..::..String
The role privilege id.
dataScopeId
Type: System..::..String
The dataScope id.

Return Value

Type: Dictionary<(Of <(<'String, DynamicDatascopeValue >)>)>
Dictionary of DynamicDatascopeValue.

Exceptions

Exception | Condition
System..::..ArgumentNullException | If role privilege id or dataScopeId is null or empty.
CelloSaaS.ServiceContracts.AccessControlManagement..::..DataAccessException | If db exception occurs

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetDynamicDatascopeValues Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilege Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilege Method
IPrivilegeService Interface Example See Also Send Feedback
Get privilege details for a particular privilege identifier.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Privilege GetPrivilege(
    string privilegeIdentifier
)
Visual Basic
Function GetPrivilege (
    privilegeIdentifier As String
) As Privilege
Visual C++
Privilege^ GetPrivilege(
    String^ privilegeIdentifier
)

Parameters

privilegeIdentifier
Type: System..::..String
Privilege Identifier(Mandatory)

Return Value

Type: Privilege
Privilege Details

Examples

Copy image Copy
public void GetPrivilege()
{
    string privilegeIdentifier = "Add_User";
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    Privilege privilege = privilegeServive.GetPrivilege(privilegeIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If privilege id is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegeNames Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegeNames Method
IPrivilegeService Interface See Also Send Feedback
Gets the privilege identifiers for the given roles

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetPrivilegeNames(
    string tenantId,
    string[] roles
)
Visual Basic
Function GetPrivilegeNames (
    tenantId As String,
    roles As String()
) As List(Of String)
Visual C++
List<String^>^ GetPrivilegeNames(
    String^ tenantId,
    array<String^>^ roles
)

Parameters

tenantId
Type: System..::..String
The tenant id.
roles
Type: array<System..::..String>[]()[][]
The roles.

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegeNamesOfCurrentUser Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegeNamesOfCurrentUser Method
IPrivilegeService Interface Example See Also Send Feedback
Get list of privilege identifiers for a current user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetPrivilegeNamesOfCurrentUser()
Visual Basic
Function GetPrivilegeNamesOfCurrentUser As List(Of String)
Visual C++
List<String^>^ GetPrivilegeNamesOfCurrentUser()

Return Value

Type: List<(Of <(<'String>)>)>
Privilege Identifiers

Examples

Copy image Copy
public void GetPrivilegeNamesOfCurrentUser()
{
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    List<string> privileges = privilegeServive.GetPrivilegeNamesOfCurrentUser();
}

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivileges Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivileges Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPrivileges(array<String>[]()[][]) | Get privilege details for array of privilege ids
Public method | GetPrivileges(String, String) | Get all privilege details based on the privilege search name and tenant code

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivileges Method (String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivileges Method (array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Get privilege details for array of privilege ids

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetPrivileges(
    string[] privilegeIds
)
Visual Basic
Function GetPrivileges (
    privilegeIds As String()
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetPrivileges(
    array<String^>^ privilegeIds
)

Parameters

privilegeIds
Type: array<System..::..String>[]()[][]
Privilege IDs

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>
Dicts of Privilege Details

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivileges Method (String, String)

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivileges Method (String, String)
IPrivilegeService Interface Example See Also Send Feedback
Get all privilege details based on the privilege search name and tenant code

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Privilege> GetPrivileges(
    string searchPrivilege,
    string tenantCode
)
Visual Basic
Function GetPrivileges (
    searchPrivilege As String,
    tenantCode As String
) As List(Of Privilege)
Visual C++
List<Privilege^>^ GetPrivileges(
    String^ searchPrivilege,
    String^ tenantCode
)

Parameters

searchPrivilege
Type: System..::..String
Privilege Name
tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: List<(Of <(<' Privilege >)>)>
Privilege Details

Examples

Copy image Copy
public void GetPrivileges()
{
    string searchPrivilege = "a";
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123":
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    List<Privilege> privileges = privilegeServive.GetPrivileges(searchPrivilege, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If tenant code is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesbyFeatureIds Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesbyFeatureIds Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPrivilegesbyFeatureIds(array<String>[]()[][]) | Gets the privileges by feature ids.
Public method | GetPrivilegesbyFeatureIds(array<String>[]()[][], String) | Gets the privileges by feature ids.

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesbyFeatureIds Method (String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesbyFeatureIds Method (array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the privileges by feature ids.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetPrivilegesbyFeatureIds(
    string[] featureIds
)
Visual Basic
Function GetPrivilegesbyFeatureIds (
    featureIds As String()
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetPrivilegesbyFeatureIds(
    array<String^>^ featureIds
)

Parameters

featureIds
Type: array<System..::..String>[]()[][]
The feature ids.

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetPrivilegesbyFeatureIds Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesbyFeatureIds Method (String[], String)

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesbyFeatureIds Method (array<String>[]()[][], String)
IPrivilegeService Interface See Also Send Feedback
Gets the privileges by feature ids.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetPrivilegesbyFeatureIds(
    string[] featureIds,
    string tenantId
)
Visual Basic
Function GetPrivilegesbyFeatureIds (
    featureIds As String(),
    tenantId As String
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetPrivilegesbyFeatureIds(
    array<String^>^ featureIds,
    String^ tenantId
)

Parameters

featureIds
Type: array<System..::..String>[]()[][]
The feature ids.
tenantId
Type: System..::..String
tenant id

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetPrivilegesbyFeatureIds Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesbyModuleIds Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesbyModuleIds Method
IPrivilegeService Interface See Also Send Feedback
Gets the privileges by module ids.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetPrivilegesbyModuleIds(
    string[] moduleIds
)
Visual Basic
Function GetPrivilegesbyModuleIds (
    moduleIds As String()
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetPrivilegesbyModuleIds(
    array<String^>^ moduleIds
)

Parameters

moduleIds
Type: array<System..::..String>[]()[][]
The module ids.

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs.
System..::..ArgumentNullException | If module ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesByServiceIds Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesByServiceIds Method
IPrivilegeService Interface See Also Send Feedback
Gets privilege by serviceIds

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Privilege> GetPrivilegesByServiceIds(
    string[] serviceIds
)
Visual Basic
Function GetPrivilegesByServiceIds (
    serviceIds As String()
) As Dictionary(Of String, Privilege)
Visual C++
Dictionary<String^, Privilege^>^ GetPrivilegesByServiceIds(
    array<String^>^ serviceIds
)

Parameters

serviceIds
Type: array<System..::..String>[]()[][]
service ids (Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, Privilege >)>)>
dictionary of privileges.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If service ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesForRoles Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesForRoles Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPrivilegesForRoles(String, array<String>[]()[][]) | Get Role Privilege details
Public method | GetPrivilegesForRoles(String, array<String>[]()[][], String) | Get Privilege details for roles

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesForRoles Method (String, String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesForRoles Method (String, array<String>[]()[][])
IPrivilegeService Interface Example See Also Send Feedback
Get Role Privilege details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, RolePrivilege> GetPrivilegesForRoles(
    string tenantIdentifier,
    string[] roleIdentifiers
)
Visual Basic
Function GetPrivilegesForRoles (
    tenantIdentifier As String,
    roleIdentifiers As String()
) As Dictionary(Of String, RolePrivilege)
Visual C++
Dictionary<String^, RolePrivilege^>^ GetPrivilegesForRoles(
    String^ tenantIdentifier,
    array<String^>^ roleIdentifiers
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier(Mandatory)
roleIdentifiers
Type: array<System..::..String>[]()[][]
Role Identifiers(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, RolePrivilege >)>)>
Role Privilege details

Examples

Copy image Copy
public void GetPrivilegesForRoles()
{
    string tenantIdentifier = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string[] roleIdentifiers = new string[] {"GR$Tenant_Admin", "GR$Product_Admin"};
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    Dictionary<string, RolePrivilege>  rolePrivileges = privilegeServive.GetPrivilegesForRoles(tenantIdentifier, roleIdentifiers);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception or license exception occurs
System..::..ArgumentNullException | If role ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetPrivilegesForRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetPrivilegesForRoles Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetPrivilegesForRoles Method (String, array<String>[]()[][], String)
IPrivilegeService Interface Example See Also Send Feedback
Get Privilege details for roles

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, RolePrivilege> GetPrivilegesForRoles(
    string tenantIdentifier,
    string[] roleIdentifiers,
    string privilegeIdentifier
)
Visual Basic
Function GetPrivilegesForRoles (
    tenantIdentifier As String,
    roleIdentifiers As String(),
    privilegeIdentifier As String
) As Dictionary(Of String, RolePrivilege)
Visual C++
Dictionary<String^, RolePrivilege^>^ GetPrivilegesForRoles(
    String^ tenantIdentifier,
    array<String^>^ roleIdentifiers,
    String^ privilegeIdentifier
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier(Mandatory)
roleIdentifiers
Type: array<System..::..String>[]()[][]
Role Idntifiers(Mandatory)
privilegeIdentifier
Type: System..::..String
Privilege Identifier(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, RolePrivilege >)>)>
Role Privilege details

Examples

Copy image Copy
public void GetPrivilegesForRoles()
{
    string tenantIdentifier = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string[] roleIdentifiers = new string[] {"GR$Tenant_Admin", "GR$Product_Admin"};
    string privilegeIdentifier = "Add_User";
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    Dictionary<string, RolePrivilege>  rolePrivileges = privilegeServive.GetPrivilegesForRoles(tenantIdentifier, roleIdentifiers, privilegeIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If tenant id or role id is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetPrivilegesForRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetRolePrivilegeCount Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetRolePrivilegeCount Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRolePrivilegeCount(String, array<String>[]()[][]) | Gets the role privilege count.
Public method | GetRolePrivilegeCount(array<String>[]()[][], array<String>[]()[][]) | Gets the role privilege count.

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetRolePrivilegeCount Method (String, String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetRolePrivilegeCount Method (String, array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the role privilege count.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, int> GetRolePrivilegeCount(
    string tenantId,
    string[] roleIds
)
Visual Basic
Function GetRolePrivilegeCount (
    tenantId As String,
    roleIds As String()
) As Dictionary(Of String, Integer)
Visual C++
Dictionary<String^, int>^ GetRolePrivilegeCount(
    String^ tenantId,
    array<String^>^ roleIds
)

Parameters

tenantId
Type: System..::..String
The tenant id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.

Return Value

Type: Dictionary<(Of <(<'String, Int32>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If role ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetRolePrivilegeCount Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetRolePrivilegeCount Method (String[], String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetRolePrivilegeCount Method (array<String>[]()[][], array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the role privilege count.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, int>> GetRolePrivilegeCount(
    string[] tenantIds,
    string[] roleIds
)
Visual Basic
Function GetRolePrivilegeCount (
    tenantIds As String(),
    roleIds As String()
) As Dictionary(Of String, Dictionary(Of String, Integer))
Visual C++
Dictionary<String^, Dictionary<String^, int>^>^ GetRolePrivilegeCount(
    array<String^>^ tenantIds,
    array<String^>^ roleIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Int32>)>)>>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If role ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetRolePrivilegeCount Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetRolePrivilegesForPrivileges Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetRolePrivilegesForPrivileges Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRolePrivilegesForPrivileges(String, array<String>[]()[][]) | Gets the role privileges for privileges.
Public method | GetRolePrivilegesForPrivileges(array<String>[]()[][], array<String>[]()[][]) | Gets the role privileges for privileges for tenants.

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetRolePrivilegesForPrivileges Method (String, String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetRolePrivilegesForPrivileges Method (String, array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the role privileges for privileges.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, RolePrivilege>> GetRolePrivilegesForPrivileges(
    string tenantId,
    string[] privilegeIds
)
Visual Basic
Function GetRolePrivilegesForPrivileges (
    tenantId As String,
    privilegeIds As String()
) As Dictionary(Of String, Dictionary(Of String, RolePrivilege))
Visual C++
Dictionary<String^, Dictionary<String^, RolePrivilege^>^>^ GetRolePrivilegesForPrivileges(
    String^ tenantId,
    array<String^>^ privilegeIds
)

Parameters

tenantId
Type: System..::..String
The tenant id.
privilegeIds
Type: array<System..::..String>[]()[][]
The privilege ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, RolePrivilege >)>)>>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If tenant id or privilege ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetRolePrivilegesForPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetRolePrivilegesForPrivileges Method (String[], String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetRolePrivilegesForPrivileges Method (array<String>[]()[][], array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the role privileges for privileges for tenants.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, RolePrivilege>> GetRolePrivilegesForPrivileges(
    string[] tenantIds,
    string[] privilegeIds
)
Visual Basic
Function GetRolePrivilegesForPrivileges (
    tenantIds As String(),
    privilegeIds As String()
) As Dictionary(Of String, Dictionary(Of String, RolePrivilege))
Visual C++
Dictionary<String^, Dictionary<String^, RolePrivilege^>^>^ GetRolePrivilegesForPrivileges(
    array<String^>^ tenantIds,
    array<String^>^ privilegeIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.
privilegeIds
Type: array<System..::..String>[]()[][]
The privilege ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, RolePrivilege >)>)>>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If tenant ids or privilege ids is null or empty

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetRolePrivilegesForPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetTenantAccessPrivileges Method

[image] [image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetTenantAccessPrivileges Method
IPrivilegeService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantAccessPrivileges(array<String>[]()[][]) | Obsolete. Gets the tenant access privileges.
Public method | GetTenantAccessPrivileges(String, array<String>[]()[][]) | Obsolete. Gets the tenant access privileges.

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetTenantAccessPrivileges Method (String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetTenantAccessPrivileges Method (array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the tenant access privileges.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
Dictionary<string, Dictionary<string, TenantDetails>> GetTenantAccessPrivileges(
    string[] privileges
)
Visual Basic
<ObsoleteAttribute>
Function GetTenantAccessPrivileges (
    privileges As String()
) As Dictionary(Of String, Dictionary(Of String, TenantDetails))
Visual C++
[ObsoleteAttribute]
Dictionary<String^, Dictionary<String^, TenantDetails^>^>^ GetTenantAccessPrivileges(
    array<String^>^ privileges
)

Parameters

privileges
Type: array<System..::..String>[]()[][]
The privileges.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, TenantDetails >)>)>>)>)>

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetTenantAccessPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.GetTenantAccessPrivileges Method (String, String[])

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..GetTenantAccessPrivileges Method (String, array<String>[]()[][])
IPrivilegeService Interface See Also Send Feedback
Gets the tenant access privileges.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
Dictionary<string, Dictionary<string, TenantDetails>> GetTenantAccessPrivileges(
    string userId,
    string[] privileges
)
Visual Basic
<ObsoleteAttribute>
Function GetTenantAccessPrivileges (
    userId As String,
    privileges As String()
) As Dictionary(Of String, Dictionary(Of String, TenantDetails))
Visual C++
[ObsoleteAttribute]
Dictionary<String^, Dictionary<String^, TenantDetails^>^>^ GetTenantAccessPrivileges(
    String^ userId,
    array<String^>^ privileges
)

Parameters

userId
Type: System..::..String
The user id.
privileges
Type: array<System..::..String>[]()[][]
The privileges.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, TenantDetails >)>)>>)>)>

See Also

IPrivilegeService Interface
IPrivilegeService Members
GetTenantAccessPrivileges Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.SavePrivilegesToRole Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..SavePrivilegesToRole Method
IPrivilegeService Interface Example See Also Send Feedback
Add/update privileges to role

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SavePrivilegesToRole(
    string tenantIdentifier,
    List<RolePrivilege> rolePrivileges
)
Visual Basic
Sub SavePrivilegesToRole (
    tenantIdentifier As String,
    rolePrivileges As List(Of RolePrivilege)
)
Visual C++
void SavePrivilegesToRole(
    String^ tenantIdentifier,
    List<RolePrivilege^>^ rolePrivileges
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Code(Mandatory)
rolePrivileges
Type: System.Collections.Generic..::..List<(Of <(<' RolePrivilege >)>)>
List of role privilege details(Mandatory)

Examples

Copy image Copy
public void SavePrivilegesToRole()
{
    string tenantIdentifier = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    List<RolePrivilege> rolePrivileges = new List<RolePrivilege>();
    RolePrivilege rolePrivilege1 = new RolePrivilege();
    rolePrivilege1.RoleId = "GR$Tenant_Admin";
    rolePrivilege1.DataScopeId = "8FB38A1C-FCBD-4F99-9DED-6EA4CC0B97A4";
    rolePrivilege1.PrivilegeId = "Add_Role";
    rolePrivileges.Add(rolePrivilege1);
    rolePrivilege1 = new RolePrivilege();
    rolePrivilege1.RoleId = "GR$Tenant_Admin";
    rolePrivilege1.PrivilegeId = "Edit_Role";
    rolePrivileges.Add(rolePrivilege1);
    rolePrivilege1 = new RolePrivilege();
    rolePrivilege1.RoleId = "GR$Tenant_Admin";
    rolePrivilege1.DataScopeId = "8FB38A1C-FCBD-4F99-9DED-6EA4CC0B97A4";
    rolePrivilege1.PrivilegeId = "View_Role";
    rolePrivileges.Add(rolePrivilege1);
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    privilegeServive.SavePrivilegesToRole(tenantIdentifier, rolePrivileges);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..ArgumentNullException | If tenant id or role privileges is null or empty
System..::..UnauthorizedAccessException | If the user has not the privilege

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.UpdateDynamicDatascopeValue Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..UpdateDynamicDatascopeValue Method
IPrivilegeService Interface See Also Send Feedback
This method is used to updates the dynamic datascope value.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDynamicDatascopeValue(
    DynamicDatascopeValue dynamicDatascopeValue
)
Visual Basic
Sub UpdateDynamicDatascopeValue (
    dynamicDatascopeValue As DynamicDatascopeValue
)
Visual C++
void UpdateDynamicDatascopeValue(
    DynamicDatascopeValue^ dynamicDatascopeValue
)

Parameters

dynamicDatascopeValue
Type: CelloSaaS.Model.AccessControlManagement..::..DynamicDatascopeValue
The dynamic datascope value.

Exceptions

Exception | Condition
System..::..ArgumentNullException | if dynamic data scope value is null
CelloSaaS.ServiceContracts.AccessControlManagement..::..DataAccessException | If db exception occurs

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IPrivilegeService.UpdateRolePrivilege Method

[image]

A Sandcastle Documented Class Library
IPrivilegeService..::..UpdateRolePrivilege Method
IPrivilegeService Interface Example See Also Send Feedback
Update role privilege details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateRolePrivilege(
    RolePrivilege rolePrivilege
)
Visual Basic
Function UpdateRolePrivilege (
    rolePrivilege As RolePrivilege
) As String
Visual C++
String^ UpdateRolePrivilege(
    RolePrivilege^ rolePrivilege
)

Parameters

rolePrivilege
Type: CelloSaaS.Model.AccessControlManagement..::..RolePrivilege
Role Privilege Details(Mandatory)

Return Value

Type: String
Role Privilege Identifier

Examples

Copy image Copy
public void UpdateRolePrivilege()
{
    RolePrivilege rolePrivilege = new RolePrivilege();
    rolePrivilege.Id = "FE574591-F293-DF11-8DEB-001EC9DAB123";
    rolePrivilege.DataScopeId = "8FB38A1C-FCBD-4F99-9DED-6EA4CC0B97A4";
    IPrivilegeService privilegeServive = (IPrivilegeService)ServiceLocator.GetServiceImplementation(typeof(IPrivilegeService));
    string rolePrivilegeId = privilegeServive.UpdateRolePrivilege(rolePrivilege);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
System..::..ArgumentException | if role privilege id is null or empty.
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | if db exception occurs.
System..::..ArgumentNullException | If role privilege is null

See Also

IPrivilegeService Interface
IPrivilegeService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService Interface

[image]

A Sandcastle Documented Class Library
IRoleService Interface
Members See Also Send Feedback
Role Metadata service Interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IRoleService
Visual Basic
Public Interface IRoleService
Visual C++
public interface class IRoleService

See Also

IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService Members

[image] [image]

A Sandcastle Documented Class Library
IRoleService Members
IRoleService Interface Methods See Also Send Feedback

The IRoleService type exposes the following members.

Methods

Name Description
Public method AddRole(Role)
Adds a new role to the system.
Public method AddRole(Role, String)
Adds a new role to the system.
Public method AddRole(String, String, String)
Adds a new role to the system.
Public method AddRole(String, String, String, String)
Adds a new role to the system.
Public method AddRole(String, String, String, array<String>[]()[][])
Adds a new role to the system.
Public method AddRoles
Adds the given list of roles to the system
Public method AddUsersToRole(array<String>[]()[][], String)
Assign role to many users.
Public method AddUsersToRole(array<String>[]()[][], String, String)
Assign role to many users.
Public method AddUserToRoles(String, array<String>[]()[][])
Assign many roles to the given user
Public method AddUserToRoles(String, array<String>[]()[][], String)
Assign many roles to the given user
Public method AddUserToRoles(String, array<String>[]()[][], String, String)
Assignes the user to the given roles.
Public method CopyAllRolesAndPrivilegesFromParent
Copies roles and privileges from Parent tenant
Public method DeleteRole
Deactivates the specified role in the system.
Public method DeleteUserRoleAssignedByTenant
Deletes the user role tenant mapping that has been assigned by the role assigning tenant for the userid and the roles
Public method GetAllDefaultRoles
Get all default global roles defined in the system.
Public method GetAllGlobalRoleDetails
Get all global role details
Public method GetAllTenantRoleDetails
Get all roles created by the given tenant
Public method GetGlobalRoleDetails
Get active global role details
Public method GetGlobalRolesByTenant
Gets the global roles created by tenant.
Public method GetRoleDetailsByRoleId
Fetchs the role details for role Identifier
Public method GetRolesAssignedToUserByTenant
This method is used to gets the roles assigned to user by tenant.
Public method GetRolesByServiceAdminUser
Gets the roles by service admin user.
Public method GetRolesByServiceId
Get all roles for the given serviceId
Public method GetRolesByServiceIds
Get all roles for the given serviceIds
Public method GetStratifiedTenantAndRolesForUser
Gets the stratified tenant and roles for user. This API call gets the tenants by stratification that this user can manage and then lists all the roles that are assigned for this userid by which tenant and which role
Public method GetTenantRoleDetails
Get active roles created by the given tenant
Public method GetUserRoles(String)
Get roles assigned to the given user.
Public method GetUserRoles(String, String)
Get roles assigned to the given user.
Public method GetUserRolesForStratifiedTenant
Gets the shared user roles.

Remarks

This API lists all the roles that this user has with respect to this tenant obtained via sharing and / or stratification

Public method GetUserRolesForStratifiedTenants
This method is used to gets the user roles for stratified tenant for this user.
Public method GetUserRolesForTenant(String, String)
Gets the tenant roles for the given user
Public method GetUserRolesForTenant(String, String, String)
Gets the tenant roles for the given user
Public method GetUsersCountByRoleIds
Get user counts in the given roles
Public method GetUsersInRole(String)
Get users for the given role.
Public method GetUsersInRole(String, String)
Gets the users in the given role.
Public method GetUsersInRoleByTenantStratification(String, String)
Gets the users in role by tenant stratification.
Public method GetUsersInRoleByTenantStratification(array<String>[]()[][], String)
Gets the users in role by tenant stratification.
Public method GetUsersInRoleByTenantStratification(String, String, String)
Gets the user's who can manage the tasks for the tenant's mapped by the assigned tenant and assigned role
Public method GetUsersInRoleByTenantStratification(array<String>[]()[][], String, String)
Gets the userids of the user's to the role assigned by the given role assigned tenant for the stratified tenant with the given roles
Public method GetUsersInRoles
Get user in the given roles.
Public method GetUsersInRoleTenantByStratification
Gets the Stratified Tenant Id, User Role pair that can be managed by the given user id based on the roles assigned by the given role assigning tenant identifier
Public method PermanentDeleteRole
Deletes specified role from the system.
Public method PermanentDeleteUserRole(String, array<String>[]()[][])
Removes the given roles from the user
Public method PermanentDeleteUserRole(String, array<String>[]()[][], String)
Removes the given roles from the user
Public method SearchAllRolesInCurrentTenant
Search all role details in current tenant
Public method SearchAllRolesInOtherTenants
Searches all role details in other tenants
Public method SearchRoleDetails
Searches the role details based on the Search Condition parameters
Public method SearchRolesInCurrentTenant
Search active role details in current tenant
Public method SearchRolesInOtherTenants
Searches active role details in other tenants
Public method UpdateRole(Role, String)
Updates the given role details
Public method UpdateRole(String, String, String)
Updates the given role details
Public method UpdateRole(String, String, array<String>[]()[][])
Updated the given role with service ids
Public method UpdateUserRoles(String, array<String>[]()[][])
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method UpdateUserRoles(String, array<String>[]()[][], String)
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method UpdateUserRoles(String, array<String>[]()[][], array<String>[]()[][])
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method UpdateUserRoles(String, array<String>[]()[][], array<String>[]()[][], String)
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

See Also

IRoleService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService Methods

[image] [image]

A Sandcastle Documented Class Library
IRoleService Methods
IRoleService Interface See Also Send Feedback

The IRoleService type exposes the following members.

Methods

Name Description
Public method AddRole(Role)
Adds a new role to the system.
Public method AddRole(Role, String)
Adds a new role to the system.
Public method AddRole(String, String, String)
Adds a new role to the system.
Public method AddRole(String, String, String, String)
Adds a new role to the system.
Public method AddRole(String, String, String, array<String>[]()[][])
Adds a new role to the system.
Public method AddRoles
Adds the given list of roles to the system
Public method AddUsersToRole(array<String>[]()[][], String)
Assign role to many users.
Public method AddUsersToRole(array<String>[]()[][], String, String)
Assign role to many users.
Public method AddUserToRoles(String, array<String>[]()[][])
Assign many roles to the given user
Public method AddUserToRoles(String, array<String>[]()[][], String)
Assign many roles to the given user
Public method AddUserToRoles(String, array<String>[]()[][], String, String)
Assignes the user to the given roles.
Public method CopyAllRolesAndPrivilegesFromParent
Copies roles and privileges from Parent tenant
Public method DeleteRole
Deactivates the specified role in the system.
Public method DeleteUserRoleAssignedByTenant
Deletes the user role tenant mapping that has been assigned by the role assigning tenant for the userid and the roles
Public method GetAllDefaultRoles
Get all default global roles defined in the system.
Public method GetAllGlobalRoleDetails
Get all global role details
Public method GetAllTenantRoleDetails
Get all roles created by the given tenant
Public method GetGlobalRoleDetails
Get active global role details
Public method GetGlobalRolesByTenant
Gets the global roles created by tenant.
Public method GetRoleDetailsByRoleId
Fetchs the role details for role Identifier
Public method GetRolesAssignedToUserByTenant
This method is used to gets the roles assigned to user by tenant.
Public method GetRolesByServiceAdminUser
Gets the roles by service admin user.
Public method GetRolesByServiceId
Get all roles for the given serviceId
Public method GetRolesByServiceIds
Get all roles for the given serviceIds
Public method GetStratifiedTenantAndRolesForUser
Gets the stratified tenant and roles for user. This API call gets the tenants by stratification that this user can manage and then lists all the roles that are assigned for this userid by which tenant and which role
Public method GetTenantRoleDetails
Get active roles created by the given tenant
Public method GetUserRoles(String)
Get roles assigned to the given user.
Public method GetUserRoles(String, String)
Get roles assigned to the given user.
Public method GetUserRolesForStratifiedTenant
Gets the shared user roles.

Remarks

This API lists all the roles that this user has with respect to this tenant obtained via sharing and / or stratification

Public method GetUserRolesForStratifiedTenants
This method is used to gets the user roles for stratified tenant for this user.
Public method GetUserRolesForTenant(String, String)
Gets the tenant roles for the given user
Public method GetUserRolesForTenant(String, String, String)
Gets the tenant roles for the given user
Public method GetUsersCountByRoleIds
Get user counts in the given roles
Public method GetUsersInRole(String)
Get users for the given role.
Public method GetUsersInRole(String, String)
Gets the users in the given role.
Public method GetUsersInRoleByTenantStratification(String, String)
Gets the users in role by tenant stratification.
Public method GetUsersInRoleByTenantStratification(array<String>[]()[][], String)
Gets the users in role by tenant stratification.
Public method GetUsersInRoleByTenantStratification(String, String, String)
Gets the user's who can manage the tasks for the tenant's mapped by the assigned tenant and assigned role
Public method GetUsersInRoleByTenantStratification(array<String>[]()[][], String, String)
Gets the userids of the user's to the role assigned by the given role assigned tenant for the stratified tenant with the given roles
Public method GetUsersInRoles
Get user in the given roles.
Public method GetUsersInRoleTenantByStratification
Gets the Stratified Tenant Id, User Role pair that can be managed by the given user id based on the roles assigned by the given role assigning tenant identifier
Public method PermanentDeleteRole
Deletes specified role from the system.
Public method PermanentDeleteUserRole(String, array<String>[]()[][])
Removes the given roles from the user
Public method PermanentDeleteUserRole(String, array<String>[]()[][], String)
Removes the given roles from the user
Public method SearchAllRolesInCurrentTenant
Search all role details in current tenant
Public method SearchAllRolesInOtherTenants
Searches all role details in other tenants
Public method SearchRoleDetails
Searches the role details based on the Search Condition parameters
Public method SearchRolesInCurrentTenant
Search active role details in current tenant
Public method SearchRolesInOtherTenants
Searches active role details in other tenants
Public method UpdateRole(Role, String)
Updates the given role details
Public method UpdateRole(String, String, String)
Updates the given role details
Public method UpdateRole(String, String, array<String>[]()[][])
Updated the given role with service ids
Public method UpdateUserRoles(String, array<String>[]()[][])
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method UpdateUserRoles(String, array<String>[]()[][], String)
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method UpdateUserRoles(String, array<String>[]()[][], array<String>[]()[][])
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method UpdateUserRoles(String, array<String>[]()[][], array<String>[]()[][], String)
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

See Also

IRoleService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRole Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..AddRole Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRole(Role) | Adds a new role to the system.
Public method | AddRole(Role, String) | Adds a new role to the system.
Public method | AddRole(String, String, String) | Adds a new role to the system.
Public method | AddRole(String, String, String, String) | Adds a new role to the system.
Public method | AddRole(String, String, String, array<String>[]()[][]) | Adds a new role to the system.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRole Method (Role)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddRole Method (Role)
IRoleService Interface Example See Also Send Feedback
Adds a new role to the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRole(
    Role roleDetails
)
Visual Basic
Function AddRole (
    roleDetails As Role
) As String
Visual C++
String^ AddRole(
    Role^ roleDetails
)

Parameters

roleDetails
Type: CelloSaaS.Model.AccessControlManagement..::..Role
Role Details(Mandatory - Role Name)

Return Value

Type: String
Inserted Role Id

Examples

Copy image Copy
public void AddRole()
{
   Role roleDetails = new Role();
   roleDetails.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
   roleDetails.RoleName = "Tenant_Admin";
   roleDetails.Description = "Tenant Admin Role";
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   string roleId = roleService.AddRole(roleDetails);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If the role name is duplicate
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor was not inserted.
System..::..ArgumentNullException | If role name or description is null or empty.
System..::..ArgumentException | If role details is null

See Also

IRoleService Interface
IRoleService Members
AddRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRole Method (Role, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddRole Method (Role, String)
IRoleService Interface Example See Also Send Feedback
Adds a new role to the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRole(
    Role roleDetails,
    string roleQualifierQuery
)
Visual Basic
Function AddRole (
    roleDetails As Role,
    roleQualifierQuery As String
) As String
Visual C++
String^ AddRole(
    Role^ roleDetails,
    String^ roleQualifierQuery
)

Parameters

roleDetails
Type: CelloSaaS.Model.AccessControlManagement..::..Role
Role Details(Mandatory - Role Name, Role Description)
roleQualifierQuery
Type: System..::..String
Qualifier Query (Obsolete)

Return Value

Type: String
Inserted Role Identifier

Examples

Copy image Copy
public void AddRole()
{
   Role roleDetails = new Role();
   roleDetails.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
   roleDetails.RoleName = "Tenant_Admin";
   roleDetails.Description = "Tenant Admin Role";
   string roleQualifierQuery = string.Empty;
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   string roleId = roleService.AddRole(roleDetails, roleQualifierQuery);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If the role name is duplicate
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor was not inserted.
System..::..ArgumentNullException | If role name or description is null or empty.
System..::..ArgumentException | If role details is null

See Also

IRoleService Interface
IRoleService Members
AddRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRole Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddRole Method (String, String, String)
IRoleService Interface Example See Also Send Feedback
Adds a new role to the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRole(
    string tenantCode,
    string roleName,
    string description
)
Visual Basic
Function AddRole (
    tenantCode As String,
    roleName As String,
    description As String
) As String
Visual C++
String^ AddRole(
    String^ tenantCode,
    String^ roleName,
    String^ description
)

Parameters

tenantCode
Type: System..::..String
Tenant Code
roleName
Type: System..::..String
Role Name(Mandatory)
description
Type: System..::..String
Role Description

Return Value

Type: String
Inserted Role Id

Examples

Copy image Copy
public void AddRole()
{
string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
string roleName = "Tenant_Admin";
string description = "Tenant Admin Role";
IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
string roleId = roleService.AddRole(tenantCode, roleName, description);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If the role name is duplicate
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor was not inserted.
System..::..ArgumentNullException | If role name or description is null or empty.
System..::..ArgumentException | If role details is null

See Also

IRoleService Interface
IRoleService Members
AddRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRole Method (String, String, String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddRole Method (String, String, String, String)
IRoleService Interface Example See Also Send Feedback
Adds a new role to the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRole(
    string tenantCode,
    string roleName,
    string description,
    string roleQualifierQuery
)
Visual Basic
Function AddRole (
    tenantCode As String,
    roleName As String,
    description As String,
    roleQualifierQuery As String
) As String
Visual C++
String^ AddRole(
    String^ tenantCode,
    String^ roleName,
    String^ description,
    String^ roleQualifierQuery
)

Parameters

tenantCode
Type: System..::..String
Tenant Code
roleName
Type: System..::..String
Role Name(Mandatory)
description
Type: System..::..String
Role Description
roleQualifierQuery
Type: System..::..String
Qualifier Query (Obsolete)

Return Value

Type: String
Inserted Role Id

Examples

Copy image Copy
public void AddRole()
{
   string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
   string roleName = "Tenant_Admin";
   string description = "Tenant Admin Role";
   string roleQualifierQuery = string.Empty;
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   string roleId = roleService.AddRole(tenantCode, roleName, description, roleQualifierQuery);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If the role name is duplicate
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor was not inserted.
System..::..ArgumentNullException | If role name or description is null or empty.
System..::..ArgumentException | If role details is null

See Also

IRoleService Interface
IRoleService Members
AddRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRole Method (String, String, String, String[])

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddRole Method (String, String, String, array<String>[]()[][])
IRoleService Interface See Also Send Feedback
Adds a new role to the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRole(
    string tenantCode,
    string roleName,
    string description,
    string[] serviceIds
)
Visual Basic
Function AddRole (
    tenantCode As String,
    roleName As String,
    description As String,
    serviceIds As String()
) As String
Visual C++
String^ AddRole(
    String^ tenantCode,
    String^ roleName,
    String^ description,
    array<String^>^ serviceIds
)

Parameters

tenantCode
Type: System..::..String
Tenant Code
roleName
Type: System..::..String
Role Name(Mandatory)
description
Type: System..::..String
Role Description
serviceIds
Type: array<System..::..String>[]()[][]
The service ids.

Return Value

Type: String
Inserted Role Id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while adding the role.

See Also

IRoleService Interface
IRoleService Members
AddRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddRoles Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddRoles Method
IRoleService Interface See Also Send Feedback
Adds the given list of roles to the system

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddRoles(
    List<Role> roles
)
Visual Basic
Sub AddRoles (
    roles As List(Of Role)
)
Visual C++
void AddRoles(
    List<Role^>^ roles
)

Parameters

roles
Type: System.Collections.Generic..::..List<(Of <(<' Role >)>)>
The roles.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while adding the roles
System..::..ArgumentNullException | If roles value is null.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUsersToRole Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..AddUsersToRole Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddUsersToRole(array<String>[]()[][], String) | Assign role to many users.
Public method | AddUsersToRole(array<String>[]()[][], String, String) | Assign role to many users.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUsersToRole Method (String[], String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddUsersToRole Method (array<String>[]()[][], String)
IRoleService Interface Example See Also Send Feedback
Assign role to many users.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddUsersToRole(
    string[] userIdentifiers,
    string roleIdentifier
)
Visual Basic
Sub AddUsersToRole (
    userIdentifiers As String(),
    roleIdentifier As String
)
Visual C++
void AddUsersToRole(
    array<String^>^ userIdentifiers,
    String^ roleIdentifier
)

Parameters

userIdentifiers
Type: array<System..::..String>[]()[][]
User Identifiers(Mandatory)
roleIdentifier
Type: System..::..String
Role Identifier(Mandatory)

Examples

Copy image Copy
public void AddUsersToRole()
{
    string[] userIdentifiers = new string[] {"C051E882-E393-DF11-8DEB-001EC9DAB123", "C151E882-E393-DF11-8DEB-001EC9DAB123"};
    string roleIdentifier = "GR$Tenant_Admin";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    roleService.AddUsersToRole(userIdentifiers, roleIdentifier);
}

Exceptions

Exception | Condition
System..::..ArgumentException |
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the role id or user ids is null or empty.
System..::..UnauthorizedAccessException | If the user has not the privilege.

See Also

IRoleService Interface
IRoleService Members
AddUsersToRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUsersToRole Method (String[], String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddUsersToRole Method (array<String>[]()[][], String, String)
IRoleService Interface See Also Send Feedback
Assign role to many users.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddUsersToRole(
    string[] userIdentifiers,
    string roleIdentifier,
    string tenantId
)
Visual Basic
Sub AddUsersToRole (
    userIdentifiers As String(),
    roleIdentifier As String,
    tenantId As String
)
Visual C++
void AddUsersToRole(
    array<String^>^ userIdentifiers,
    String^ roleIdentifier,
    String^ tenantId
)

Parameters

userIdentifiers
Type: array<System..::..String>[]()[][]
The user identifiers.
roleIdentifier
Type: System..::..String
The role identifier.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentException | If user id or role id is null or empty
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the role id or tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
AddUsersToRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUserToRoles Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..AddUserToRoles Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddUserToRoles(String, array<String>[]()[][]) | Assign many roles to the given user
Public method | AddUserToRoles(String, array<String>[]()[][], String) | Assign many roles to the given user
Public method | AddUserToRoles(String, array<String>[]()[][], String, String) | Assignes the user to the given roles.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUserToRoles Method (String, String[])

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddUserToRoles Method (String, array<String>[]()[][])
IRoleService Interface See Also Send Feedback
Assign many roles to the given user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddUserToRoles(
    string userIdentifier,
    string[] roleIdentifiers
)
Visual Basic
Sub AddUserToRoles (
    userIdentifier As String,
    roleIdentifiers As String()
)
Visual C++
void AddUserToRoles(
    String^ userIdentifier,
    array<String^>^ roleIdentifiers
)

Parameters

userIdentifier
Type: System..::..String
The user identifier.
roleIdentifiers
Type: array<System..::..String>[]()[][]
The role identifiers.

Exceptions

Exception | Condition
System..::..ArgumentException |
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the role ids or user id is null or empty.
System..::..UnauthorizedAccessException | If the use rhas not the privilege.

See Also

IRoleService Interface
IRoleService Members
AddUserToRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUserToRoles Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddUserToRoles Method (String, array<String>[]()[][], String)
IRoleService Interface Example See Also Send Feedback
Assign many roles to the given user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddUserToRoles(
    string userIdentifier,
    string[] roleIdentifiers,
    string tenantId
)
Visual Basic
Sub AddUserToRoles (
    userIdentifier As String,
    roleIdentifiers As String(),
    tenantId As String
)
Visual C++
void AddUserToRoles(
    String^ userIdentifier,
    array<String^>^ roleIdentifiers,
    String^ tenantId
)

Parameters

userIdentifier
Type: System..::..String
The user identifier.
roleIdentifiers
Type: array<System..::..String>[]()[][]
The role identifiers.
tenantId
Type: System..::..String
The tenant id.

Examples

Copy image Copy
public void AddUserToRoles()
{
string userIdentifier = "3398F837-B988-4708-999D-D3DFE11875B3";
string[] roleIdentifiers = new string[] {"GR$Tenant_Admin", "GR$Product_Admin"};
IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
roleService.AddUserToRoles(userIdentifier, roleIdentifiers,UserIdentity.TenantID);
}

Exceptions

Exception | Condition
System..::..ArgumentException |
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..UnauthorizedAccessException | Incase of privilege to add user roles
System..::..ArgumentNullException | If used id or tenant id or role ids is null or empty

See Also

IRoleService Interface
IRoleService Members
AddUserToRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.AddUserToRoles Method (String, String[], String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..AddUserToRoles Method (String, array<String>[]()[][], String, String)
IRoleService Interface See Also Send Feedback
Assignes the user to the given roles.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddUserToRoles(
    string userIdentifier,
    string[] roleIdentifiers,
    string roleAssigningtenantId,
    string stratifiedTenantId
)
Visual Basic
Sub AddUserToRoles (
    userIdentifier As String,
    roleIdentifiers As String(),
    roleAssigningtenantId As String,
    stratifiedTenantId As String
)
Visual C++
void AddUserToRoles(
    String^ userIdentifier,
    array<String^>^ roleIdentifiers,
    String^ roleAssigningtenantId,
    String^ stratifiedTenantId
)

Parameters

userIdentifier
Type: System..::..String
The user identifier.
roleIdentifiers
Type: array<System..::..String>[]()[][]
The role identifiers.
roleAssigningtenantId
Type: System..::..String
The role assigningtenant id.
stratifiedTenantId
Type: System..::..String
The stratified tenant id.

Exceptions

Exception | Condition
System..::..ArgumentException | Duplicate user role
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..UnauthorizedAccessException | Incase of privilege to add user roles
System..::..ArgumentNullException | If role ids or user id or role assigned tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
AddUserToRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.CopyAllRolesAndPrivilegesFromParent Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..CopyAllRolesAndPrivilegesFromParent Method
IRoleService Interface See Also Send Feedback
Copies roles and privileges from Parent tenant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int CopyAllRolesAndPrivilegesFromParent(
    string tenantId
)
Visual Basic
Function CopyAllRolesAndPrivilegesFromParent (
    tenantId As String
) As Integer
Visual C++
int CopyAllRolesAndPrivilegesFromParent(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Int32
number of role privileges

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.DeleteRole Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..DeleteRole Method
IRoleService Interface Example See Also Send Feedback
Deactivates the specified role in the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteRole(
    string tenantCode,
    string roleIdentifier
)
Visual Basic
Sub DeleteRole (
    tenantCode As String,
    roleIdentifier As String
)
Visual C++
void DeleteRole(
    String^ tenantCode,
    String^ roleIdentifier
)

Parameters

tenantCode
Type: System..::..String
Tenant Code
roleIdentifier
Type: System..::..String
Role Identifier(Mandatory)

Examples

Copy image Copy
public void DeactivateRole()
{
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string roleIdentifier = "GR$Tenant_Admin";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    roleService.DeleteRole(tenantCode, roleIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while deleting the role.
System..::..ArgumentNullException | If role id is null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.DeleteUserRoleAssignedByTenant Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..DeleteUserRoleAssignedByTenant Method
IRoleService Interface See Also Send Feedback
Deletes the user role tenant mapping that has been assigned by the role assigning tenant for the userid and the roles

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleAssignedByTenant(
    string userId,
    string[] roleIds,
    string roleAssignedTenantId
)
Visual Basic
Sub DeleteUserRoleAssignedByTenant (
    userId As String,
    roleIds As String(),
    roleAssignedTenantId As String
)
Visual C++
void DeleteUserRoleAssignedByTenant(
    String^ userId,
    array<String^>^ roleIds,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.
roleAssignedTenantId
Type: System..::..String
The role assigning tenant id.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If user id or role ids or role assigned tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetAllDefaultRoles Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetAllDefaultRoles Method
IRoleService Interface Example See Also Send Feedback
Get all default global roles defined in the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetAllDefaultRoles()
Visual Basic
Function GetAllDefaultRoles As String()
Visual C++
array<String^>^ GetAllDefaultRoles()

Return Value

Type: array<String>[]()[][]
Default Role Identifiers

Examples

Copy image Copy
public void GetAllDefaultRoles()
{
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   string[] roles = roleService.GetAllDefaultRoles();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while getting default roles.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetAllGlobalRoleDetails Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetAllGlobalRoleDetails Method
IRoleService Interface Example See Also Send Feedback
Get all global role details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> GetAllGlobalRoleDetails()
Visual Basic
Function GetAllGlobalRoleDetails As List(Of Role)
Visual C++
List<Role^>^ GetAllGlobalRoleDetails()

Return Value

Type: List<(Of <(<' Role >)>)>
Active and Inactive Global Role details

Examples

Copy image Copy
public void GetAllGlobalRoleDetails()
{
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   List<Role> roles = roleService.GetAllGlobalRoleDetails();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while fetching hte global role details.
System..::..UnauthorizedAccessException | If the user has not the privilege.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetAllTenantRoleDetails Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetAllTenantRoleDetails Method
IRoleService Interface Example See Also Send Feedback
Get all roles created by the given tenant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> GetAllTenantRoleDetails(
    string tenantCode
)
Visual Basic
Function GetAllTenantRoleDetails (
    tenantCode As String
) As List(Of Role)
Visual C++
List<Role^>^ GetAllTenantRoleDetails(
    String^ tenantCode
)

Parameters

tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: List<(Of <(<' Role >)>)>
Active and Inactive Tenant Role details

Examples

Copy image Copy
public void GetAllTenantRoleDetails()
{
   string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   List<Role> roles = roleService.GetAllTenantRoleDetails(tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while fetching the role details.
System..::..UnauthorizedAccessException | If the user has not the privilege.
System..::..ArgumentNullException | If tenant code is null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetGlobalRoleDetails Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetGlobalRoleDetails Method
IRoleService Interface Example See Also Send Feedback
Get active global role details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> GetGlobalRoleDetails()
Visual Basic
Function GetGlobalRoleDetails As List(Of Role)
Visual C++
List<Role^>^ GetGlobalRoleDetails()

Return Value

Type: List<(Of <(<' Role >)>)>
Active Global Role details

Examples

Copy image Copy
public void GetGlobalRoleDetails()
{
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    List<Role> roles = roleService.GetGlobalRoleDetails();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while getting global role details
System..::..UnauthorizedAccessException | If the user has not the privilege.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetGlobalRolesByTenant Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetGlobalRolesByTenant Method
IRoleService Interface See Also Send Feedback
Gets the global roles created by tenant.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> GetGlobalRolesByTenant(
    string tenantId
)
Visual Basic
Function GetGlobalRolesByTenant (
    tenantId As String
) As List(Of Role)
Visual C++
List<Role^>^ GetGlobalRolesByTenant(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: List<(Of <(<' Role >)>)>
List of roles

Exceptions

Exception | Condition
System..::..ArgumentNullException | If tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetRoleDetailsByRoleId Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetRoleDetailsByRoleId Method
IRoleService Interface Example See Also Send Feedback
Fetchs the role details for role Identifier

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Role GetRoleDetailsByRoleId(
    string roleId
)
Visual Basic
Function GetRoleDetailsByRoleId (
    roleId As String
) As Role
Visual C++
Role^ GetRoleDetailsByRoleId(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)

Return Value

Type: Role
Role Details

Examples

Copy image Copy
public void GetRoleDetailsByRoleId()
{
    string roleId = "GR$Tenant_Admin";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    Role roles = roleService.GetRoleDetailsByRoleId(roleId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while getting role details.
System..::..ArgumentNullException | If role id is null or empty.
System..::..UnauthorizedAccessException | If the user has not the privilege.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetRolesAssignedToUserByTenant Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetRolesAssignedToUserByTenant Method
IRoleService Interface See Also Send Feedback
This method is used to gets the roles assigned to user by tenant.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetRolesAssignedToUserByTenant(
    string userId,
    string roleAssignedTenantId
)
Visual Basic
Function GetRolesAssignedToUserByTenant (
    userId As String,
    roleAssignedTenantId As String
) As String()
Visual C++
array<String^>^ GetRolesAssignedToUserByTenant(
    String^ userId,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Return Value

Type: array<String>[]()[][]

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If the user id or role assigned tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetRolesByServiceAdminUser Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetRolesByServiceAdminUser Method
IRoleService Interface See Also Send Feedback
Gets the roles by service admin user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Role> GetRolesByServiceAdminUser(
    string serviceAdminUserId
)
Visual Basic
Function GetRolesByServiceAdminUser (
    serviceAdminUserId As String
) As Dictionary(Of String, Role)
Visual C++
Dictionary<String^, Role^>^ GetRolesByServiceAdminUser(
    String^ serviceAdminUserId
)

Parameters

serviceAdminUserId
Type: System..::..String
The service admin user id.

Return Value

Type: Dictionary<(Of <(<'String, Role >)>)>
Dictionary of roles

Exceptions

Exception | Condition
System..::..ArgumentNullException | If service admin user id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetRolesByServiceId Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetRolesByServiceId Method
IRoleService Interface See Also Send Feedback
Get all roles for the given serviceId

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Role> GetRolesByServiceId(
    string serviceId
)
Visual Basic
Function GetRolesByServiceId (
    serviceId As String
) As Dictionary(Of String, Role)
Visual C++
Dictionary<String^, Role^>^ GetRolesByServiceId(
    String^ serviceId
)

Parameters

serviceId
Type: System..::..String
Service Id

Return Value

Type: Dictionary<(Of <(<'String, Role >)>)>
List of role details

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If service id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetRolesByServiceIds Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetRolesByServiceIds Method
IRoleService Interface See Also Send Feedback
Get all roles for the given serviceIds

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Role> GetRolesByServiceIds(
    string[] serviceIds
)
Visual Basic
Function GetRolesByServiceIds (
    serviceIds As String()
) As Dictionary(Of String, Role)
Visual C++
Dictionary<String^, Role^>^ GetRolesByServiceIds(
    array<String^>^ serviceIds
)

Parameters

serviceIds
Type: array<System..::..String>[]()[][]
Service Ids

Return Value

Type: Dictionary<(Of <(<'String, Role >)>)>
List of role details

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetStratifiedTenantAndRolesForUser Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetStratifiedTenantAndRolesForUser Method
IRoleService Interface See Also Send Feedback
Gets the stratified tenant and roles for user. This API call gets the tenants by stratification that this user can manage and then lists all the roles that are assigned for this userid by which tenant and which role

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, List<string>>> GetStratifiedTenantAndRolesForUser(
    string userId
)
Visual Basic
Function GetStratifiedTenantAndRolesForUser (
    userId As String
) As Dictionary(Of String, Dictionary(Of String, List(Of String)))
Visual C++
Dictionary<String^, Dictionary<String^, List<String^>^>^>^ GetStratifiedTenantAndRolesForUser(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>>)>)>
Dictionary of stratified tenant id and dictionary of role assigned tenant id and list of roels

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If user id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetTenantRoleDetails Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetTenantRoleDetails Method
IRoleService Interface Example See Also Send Feedback
Get active roles created by the given tenant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> GetTenantRoleDetails(
    string tenantCode
)
Visual Basic
Function GetTenantRoleDetails (
    tenantCode As String
) As List(Of Role)
Visual C++
List<Role^>^ GetTenantRoleDetails(
    String^ tenantCode
)

Parameters

tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: List<(Of <(<' Role >)>)>
Active Tenant Role details

Examples

Copy image Copy
public void GetTenantRoleDetails()
{
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    List<Role> roles = roleService.GetTenantRoleDetails(tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exceptions occur
System..::..UnauthorizedAccessException | If the user has not the privilege.
System..::..ArgumentNullException | If tenant code is null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRoles Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRoles Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUserRoles(String) | Get roles assigned to the given user.
Public method | GetUserRoles(String, String) | Get roles assigned to the given user.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRoles Method (String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRoles Method (String)
IRoleService Interface See Also Send Feedback
Get roles assigned to the given user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUserRoles(
    string userIdentifier
)
Visual Basic
Function GetUserRoles (
    userIdentifier As String
) As String()
Visual C++
array<String^>^ GetUserRoles(
    String^ userIdentifier
)

Parameters

userIdentifier
Type: System..::..String
User Identifier(Mandatory)

Return Value

Type: array<String>[]()[][]
Role Ids

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the user id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUserRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRoles Method (String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRoles Method (String, String)
IRoleService Interface See Also Send Feedback
Get roles assigned to the given user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUserRoles(
    string userIdentifier,
    string tenantId
)
Visual Basic
Function GetUserRoles (
    userIdentifier As String,
    tenantId As String
) As String()
Visual C++
array<String^>^ GetUserRoles(
    String^ userIdentifier,
    String^ tenantId
)

Parameters

userIdentifier
Type: System..::..String
User Identifier(Mandatory)
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: array<String>[]()[][]
Role Ids

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If the user id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUserRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRolesForStratifiedTenant Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRolesForStratifiedTenant Method
IRoleService Interface See Also Send Feedback
Gets the shared user roles.

Remarks

This API lists all the roles that this user has with respect to this tenant obtained via sharing and / or stratification

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<string>> GetUserRolesForStratifiedTenant(
    string userId,
    string stratifiedTenantId,
    string roleAssigningTenantId
)
Visual Basic
Function GetUserRolesForStratifiedTenant (
    userId As String,
    stratifiedTenantId As String,
    roleAssigningTenantId As String
) As Dictionary(Of String, List(Of String))
Visual C++
Dictionary<String^, List<String^>^>^ GetUserRolesForStratifiedTenant(
    String^ userId,
    String^ stratifiedTenantId,
    String^ roleAssigningTenantId
)

Parameters

userId
Type: System..::..String
The user id.
stratifiedTenantId
Type: System..::..String
The stratified tenant id.
roleAssigningTenantId
Type: System..::..String

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
dictionary of role assigned tenant id and the list of the roles

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If user id or stratified tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRolesForStratifiedTenants Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRolesForStratifiedTenants Method
IRoleService Interface See Also Send Feedback
This method is used to gets the user roles for stratified tenant for this user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, List<string>>> GetUserRolesForStratifiedTenants(
    string userId,
    string[] stratifiedTenantIds
)
Visual Basic
Function GetUserRolesForStratifiedTenants (
    userId As String,
    stratifiedTenantIds As String()
) As Dictionary(Of String, Dictionary(Of String, List(Of String)))
Visual C++
Dictionary<String^, Dictionary<String^, List<String^>^>^>^ GetUserRolesForStratifiedTenants(
    String^ userId,
    array<String^>^ stratifiedTenantIds
)

Parameters

userId
Type: System..::..String
The user id.
stratifiedTenantIds
Type: array<System..::..String>[]()[][]
The stratified tenant ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>>)>)>
dictionary of stratified tenant and dictionary of role assigned tenant id and the list of the roles

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRolesForTenant Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRolesForTenant Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUserRolesForTenant(String, String) | Gets the tenant roles for the given user
Public method | GetUserRolesForTenant(String, String, String) | Gets the tenant roles for the given user

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRolesForTenant Method (String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRolesForTenant Method (String, String)
IRoleService Interface See Also Send Feedback
Gets the tenant roles for the given user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUserRolesForTenant(
    string userId,
    string tenantId
)
Visual Basic
Function GetUserRolesForTenant (
    userId As String,
    tenantId As String
) As String()
Visual C++
array<String^>^ GetUserRolesForTenant(
    String^ userId,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
tenantId
Type: System..::..String
The session tenant id.

Return Value

Type: array<String>[]()[][]
List of Roles

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the user id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUserRolesForTenant Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUserRolesForTenant Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUserRolesForTenant Method (String, String, String)
IRoleService Interface See Also Send Feedback
Gets the tenant roles for the given user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUserRolesForTenant(
    string userId,
    string stratifiedTenantId,
    string roleAssigningTenantId
)
Visual Basic
Function GetUserRolesForTenant (
    userId As String,
    stratifiedTenantId As String,
    roleAssigningTenantId As String
) As String()
Visual C++
array<String^>^ GetUserRolesForTenant(
    String^ userId,
    String^ stratifiedTenantId,
    String^ roleAssigningTenantId
)

Parameters

userId
Type: System..::..String
The user id.
stratifiedTenantId
Type: System..::..String
The stratified tenant id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: array<String>[]()[][]

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur

See Also

IRoleService Interface
IRoleService Members
GetUserRolesForTenant Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersCountByRoleIds Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersCountByRoleIds Method
IRoleService Interface Example See Also Send Feedback
Get user counts in the given roles

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<int, int>> GetUsersCountByRoleIds(
    string[] roleIds,
    string tenantCode
)
Visual Basic
Function GetUsersCountByRoleIds (
    roleIds As String(),
    tenantCode As String
) As Dictionary(Of String, Dictionary(Of Integer, Integer))
Visual C++
Dictionary<String^, Dictionary<int, int>^>^ GetUsersCountByRoleIds(
    array<String^>^ roleIds,
    String^ tenantCode
)

Parameters

roleIds
Type: array<System..::..String>[]()[][]
Role Ids(Mandatory)
tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'Int32, Int32>)>)>>)>)>
Number of Active and Inactive users in the given roles

Examples

Copy image Copy
public void GetUsersCountByRoleIds()
{
    string[] roleIds = new string[] {"GR$Tenant_Admin", "GR$Product_Admin"};
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    Dictionary<string, Dictionary<int, int>> userCounts = roleService.GetUsersCountByRoleIds(roleIds, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If tenant code or role ids are null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRole Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRole Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUsersInRole(String) | Get users for the given role.
Public method | GetUsersInRole(String, String) | Gets the users in the given role.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRole Method (String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRole Method (String)
IRoleService Interface Example See Also Send Feedback
Get users for the given role.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUsersInRole(
    string roleIdentifier
)
Visual Basic
Function GetUsersInRole (
    roleIdentifier As String
) As String()
Visual C++
array<String^>^ GetUsersInRole(
    String^ roleIdentifier
)

Parameters

roleIdentifier
Type: System..::..String
Role Identifier(Mandatory)

Return Value

Type: array<String>[]()[][]
User Identifiers

Examples

Copy image Copy
public void GetUsersInRole()
{
    string roleIdentifier = "GR$Tenant_Admin";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    string[] roles = roleService.GetUsersInRole(roleIdentifier);
}

Exceptions

Exception | Condition
System..::..NotSupportedException | If it is user connection string provider
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while getting the role details.
System..::..ArgumentNullException | If the role id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUsersInRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRole Method (String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRole Method (String, String)
IRoleService Interface See Also Send Feedback
Gets the users in the given role.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUsersInRole(
    string roleIdentifier,
    string tenantId
)
Visual Basic
Function GetUsersInRole (
    roleIdentifier As String,
    tenantId As String
) As String()
Visual C++
array<String^>^ GetUsersInRole(
    String^ roleIdentifier,
    String^ tenantId
)

Parameters

roleIdentifier
Type: System..::..String
The role identifier.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: array<String>[]()[][]

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the role id or tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUsersInRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoleByTenantStratification Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoleByTenantStratification Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUsersInRoleByTenantStratification(String, String) | Gets the users in role by tenant stratification.
Public method | GetUsersInRoleByTenantStratification(array<String>[]()[][], String) | Gets the users in role by tenant stratification.
Public method | GetUsersInRoleByTenantStratification(String, String, String) | Gets the user's who can manage the tasks for the tenant's mapped by the assigned tenant and assigned role
Public method | GetUsersInRoleByTenantStratification(array<String>[]()[][], String, String) | Gets the userids of the user's to the role assigned by the given role assigned tenant for the stratified tenant with the given roles

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoleByTenantStratification Method (String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoleByTenantStratification Method (String, String)
IRoleService Interface See Also Send Feedback
Gets the users in role by tenant stratification.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUsersInRoleByTenantStratification(
    string roleIdentifier,
    string tenantId
)
Visual Basic
Function GetUsersInRoleByTenantStratification (
    roleIdentifier As String,
    tenantId As String
) As String()
Visual C++
array<String^>^ GetUsersInRoleByTenantStratification(
    String^ roleIdentifier,
    String^ tenantId
)

Parameters

roleIdentifier
Type: System..::..String
The role identifier.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: array<String>[]()[][]

Exceptions

Exception | Condition
System..::..NotSupportedException |
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If the role id or tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUsersInRoleByTenantStratification Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoleByTenantStratification Method (String[], String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoleByTenantStratification Method (array<String>[]()[][], String)
IRoleService Interface See Also Send Feedback
Gets the users in role by tenant stratification.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<string>> GetUsersInRoleByTenantStratification(
    string[] roleIdentifiers,
    string tenantId
)
Visual Basic
Function GetUsersInRoleByTenantStratification (
    roleIdentifiers As String(),
    tenantId As String
) As Dictionary(Of String, List(Of String))
Visual C++
Dictionary<String^, List<String^>^>^ GetUsersInRoleByTenantStratification(
    array<String^>^ roleIdentifiers,
    String^ tenantId
)

Parameters

roleIdentifiers
Type: array<System..::..String>[]()[][]
The role identifiers.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>

Exceptions

Exception | Condition
System..::..NotSupportedException |
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If the role ids or tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
GetUsersInRoleByTenantStratification Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoleByTenantStratification Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoleByTenantStratification Method (String, String, String)
IRoleService Interface See Also Send Feedback
Gets the user's who can manage the tasks for the tenant's mapped by the assigned tenant and assigned role

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUsersInRoleByTenantStratification(
    string roleId,
    string stratifiedTenantId,
    string roleAssigningTenantId
)
Visual Basic
Function GetUsersInRoleByTenantStratification (
    roleId As String,
    stratifiedTenantId As String,
    roleAssigningTenantId As String
) As String()
Visual C++
array<String^>^ GetUsersInRoleByTenantStratification(
    String^ roleId,
    String^ stratifiedTenantId,
    String^ roleAssigningTenantId
)

Parameters

roleId
Type: System..::..String
The role id.
stratifiedTenantId
Type: System..::..String
The stratified tenant id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant.

Return Value

Type: array<String>[]()[][]
Array of user identifiers

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If role id or stratified tenant id or role assigned tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
GetUsersInRoleByTenantStratification Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoleByTenantStratification Method (String[], String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoleByTenantStratification Method (array<String>[]()[][], String, String)
IRoleService Interface See Also Send Feedback
Gets the userids of the user's to the role assigned by the given role assigned tenant for the stratified tenant with the given roles

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<string>> GetUsersInRoleByTenantStratification(
    string[] roleIdentifiers,
    string stratifiedTenantId,
    string roleAssigningTenantId
)
Visual Basic
Function GetUsersInRoleByTenantStratification (
    roleIdentifiers As String(),
    stratifiedTenantId As String,
    roleAssigningTenantId As String
) As Dictionary(Of String, List(Of String))
Visual C++
Dictionary<String^, List<String^>^>^ GetUsersInRoleByTenantStratification(
    array<String^>^ roleIdentifiers,
    String^ stratifiedTenantId,
    String^ roleAssigningTenantId
)

Parameters

roleIdentifiers
Type: array<System..::..String>[]()[][]
The role identifiers.
stratifiedTenantId
Type: System..::..String
The stratified tenant id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
Dictionary of Roles and their User identifiers

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If role ids or stratified tenant id or role assigned tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
GetUsersInRoleByTenantStratification Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoles Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoles Method
IRoleService Interface Example See Also Send Feedback
Get user in the given roles.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetUsersInRoles(
    string[] roleIdentifier,
    string tenantId
)
Visual Basic
Function GetUsersInRoles (
    roleIdentifier As String(),
    tenantId As String
) As String()
Visual C++
array<String^>^ GetUsersInRoles(
    array<String^>^ roleIdentifier,
    String^ tenantId
)

Parameters

roleIdentifier
Type: array<System..::..String>[]()[][]
User Identifier(Mandatory)
tenantId
Type: System..::..String
tenant's id

Return Value

Type: array<String>[]()[][]
Role Identifiers

Examples

Copy image Copy
public void GetUserRoles()
{
    string userIdentifier = "3398F837-B988-4708-999D-D3DFE11875B3";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    string[] roles = roleService.GetUserRoles(userIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If the user id is null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.GetUsersInRoleTenantByStratification Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..GetUsersInRoleTenantByStratification Method
IRoleService Interface See Also Send Feedback
Gets the Stratified Tenant Id, User Role pair that can be managed by the given user id based on the roles assigned by the given role assigning tenant identifier

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<string>> GetUsersInRoleTenantByStratification(
    string userId,
    string roleAssigningTenantId
)
Visual Basic
Function GetUsersInRoleTenantByStratification (
    userId As String,
    roleAssigningTenantId As String
) As Dictionary(Of String, List(Of String))
Visual C++
Dictionary<String^, List<String^>^>^ GetUsersInRoleTenantByStratification(
    String^ userId,
    String^ roleAssigningTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
Dictionary of Stratified TenantId with the list of roles for this tenant id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If user id or role assigned tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.PermanentDeleteRole Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..PermanentDeleteRole Method
IRoleService Interface Example See Also Send Feedback
Deletes specified role from the system.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteRole(
    string tenantCode,
    string roleIdentifier
)
Visual Basic
Sub PermanentDeleteRole (
    tenantCode As String,
    roleIdentifier As String
)
Visual C++
void PermanentDeleteRole(
    String^ tenantCode,
    String^ roleIdentifier
)

Parameters

tenantCode
Type: System..::..String
Tenant Code
roleIdentifier
Type: System..::..String
Role Identifier(Mandatory)

Examples

Copy image Copy
public void DeleteRole()
{
   string tenantCode = UserIdentity.TenantID;
   string roleIdentifier = "GR$SampleRole";
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   roleService.PermanentDeleteRole(tenantCode, roleIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor permanent delete was not happened.
System..::..ArgumentNullException | If role id is null or empty.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.PermanentDeleteUserRole Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..PermanentDeleteUserRole Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | PermanentDeleteUserRole(String, array<String>[]()[][]) | Removes the given roles from the user
Public method | PermanentDeleteUserRole(String, array<String>[]()[][], String) | Removes the given roles from the user

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.PermanentDeleteUserRole Method (String, String[])

[image]

A Sandcastle Documented Class Library
IRoleService..::..PermanentDeleteUserRole Method (String, array<String>[]()[][])
IRoleService Interface Example See Also Send Feedback
Removes the given roles from the user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteUserRole(
    string userId,
    string[] roleIds
)
Visual Basic
Sub PermanentDeleteUserRole (
    userId As String,
    roleIds As String()
)
Visual C++
void PermanentDeleteUserRole(
    String^ userId,
    array<String^>^ roleIds
)

Parameters

userId
Type: System..::..String
User Identifier(Mandatory)
roleIds
Type: array<System..::..String>[]()[][]
Role Identifiers(Mandatory)

Examples

Copy image Copy
public void PermanentDeleteUserRole()
{
    string userId = "3398F837-B988-4708-999D-D3DFE11875B3";
    string[] roleIds = new string[] {"GR$Tenant_Admin", "GR$Product_Admin"};
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    roleService.PermanentDeleteUserRole(userId, roleIds);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..UnauthorizedAccessException | If user has not the privilege to delete the user role
System..::..ArgumentNullException | If role ids or user id is null or empty.

See Also

IRoleService Interface
IRoleService Members
PermanentDeleteUserRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.PermanentDeleteUserRole Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..PermanentDeleteUserRole Method (String, array<String>[]()[][], String)
IRoleService Interface See Also Send Feedback
Removes the given roles from the user

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteUserRole(
    string userId,
    string[] roleIds,
    string tenantId
)
Visual Basic
Sub PermanentDeleteUserRole (
    userId As String,
    roleIds As String(),
    tenantId As String
)
Visual C++
void PermanentDeleteUserRole(
    String^ userId,
    array<String^>^ roleIds,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | If role ids or user id or tenant id is null or empty.
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..UnauthorizedAccessException | If user has not the privilege to delete the user role

See Also

IRoleService Interface
IRoleService Members
PermanentDeleteUserRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.SearchAllRolesInCurrentTenant Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..SearchAllRolesInCurrentTenant Method
IRoleService Interface Example See Also Send Feedback
Search all role details in current tenant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> SearchAllRolesInCurrentTenant(
    string searchValue,
    string tenantCode
)
Visual Basic
Function SearchAllRolesInCurrentTenant (
    searchValue As String,
    tenantCode As String
) As List(Of Role)
Visual C++
List<Role^>^ SearchAllRolesInCurrentTenant(
    String^ searchValue,
    String^ tenantCode
)

Parameters

searchValue
Type: System..::..String
Search Role Name String
tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: List<(Of <(<' Role >)>)>
Active and Inactive Role details in current tenant

Examples

Copy image Copy
public void SearchAllRolesInCurrentTenant()
{
    string searchValue = "a";
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    List<Role> roles = roleService.SearchAllRolesInCurrentTenant(searchValue, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.SearchAllRolesInOtherTenants Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..SearchAllRolesInOtherTenants Method
IRoleService Interface Example See Also Send Feedback
Searches all role details in other tenants

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> SearchAllRolesInOtherTenants(
    string searchValue,
    string[] tenantCodes
)
Visual Basic
Function SearchAllRolesInOtherTenants (
    searchValue As String,
    tenantCodes As String()
) As List(Of Role)
Visual C++
List<Role^>^ SearchAllRolesInOtherTenants(
    String^ searchValue,
    array<String^>^ tenantCodes
)

Parameters

searchValue
Type: System..::..String
Search Role Name String
tenantCodes
Type: array<System..::..String>[]()[][]
Tenant Codes(Empty or null will return all roles)

Return Value

Type: List<(Of <(<' Role >)>)>
Active and Inactive Role details in other tenant

Examples

Copy image Copy
public void SearchAllRolesInOtherTenants()
{
    string searchValue = "a";
    string[] tenantCodes = new string[] {"F1446542-0294-DF11-8DEB-001EC9DAB123", "E1446542-0294-DF11-8DEB-001EC9DAB123"};
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    List<Role> roles = roleService.SearchAllRolesInOtherTenants(searchValue, tenantCodes);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..UnauthorizedAccessException | If the user has not the privilege

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.SearchRoleDetails Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..SearchRoleDetails Method
IRoleService Interface See Also Send Feedback
Searches the role details based on the Search Condition parameters

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Role> SearchRoleDetails(
    RoleDetailsSearchCondition roleDetailsSearchCondition
)
Visual Basic
Function SearchRoleDetails (
    roleDetailsSearchCondition As RoleDetailsSearchCondition
) As Dictionary(Of String, Role)
Visual C++
Dictionary<String^, Role^>^ SearchRoleDetails(
    RoleDetailsSearchCondition^ roleDetailsSearchCondition
)

Parameters

roleDetailsSearchCondition
Type: CelloSaaS.Model.AccessControlManagement..::..RoleDetailsSearchCondition
The role details search condition.

Return Value

Type: Dictionary<(Of <(<'String, Role >)>)>
Dictionary of Roles with Key as Role Identifier

.NET Framework Security

Permission | Description
 | View_Role Privilege is mandatory

Exceptions

Exception | Condition
System..::..ArgumentException | Incase of a null search condition
System.Data.Common..::..DbException | Incase of any exception occured when fetching the role details from the database
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | Incase of any malformed search condition

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.SearchRolesInCurrentTenant Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..SearchRolesInCurrentTenant Method
IRoleService Interface Example See Also Send Feedback
Search active role details in current tenant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> SearchRolesInCurrentTenant(
    string searchValue,
    string tenantCode
)
Visual Basic
Function SearchRolesInCurrentTenant (
    searchValue As String,
    tenantCode As String
) As List(Of Role)
Visual C++
List<Role^>^ SearchRolesInCurrentTenant(
    String^ searchValue,
    String^ tenantCode
)

Parameters

searchValue
Type: System..::..String
Search Role Name String
tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: List<(Of <(<' Role >)>)>
Active Role details in current tenant

Examples

Copy image Copy
public void SearchRolesInCurrentTenant()
{
    string searchValue = "a";
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    List<Role> roles = roleService.SearchRolesInCurrentTenant(searchValue, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If tenant id is null or empty

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.SearchRolesInOtherTenants Method

[image]

A Sandcastle Documented Class Library
IRoleService..::..SearchRolesInOtherTenants Method
IRoleService Interface Example See Also Send Feedback
Searches active role details in other tenants

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Role> SearchRolesInOtherTenants(
    string searchValue,
    string[] tenantCodes
)
Visual Basic
Function SearchRolesInOtherTenants (
    searchValue As String,
    tenantCodes As String()
) As List(Of Role)
Visual C++
List<Role^>^ SearchRolesInOtherTenants(
    String^ searchValue,
    array<String^>^ tenantCodes
)

Parameters

searchValue
Type: System..::..String
Search Role Name String
tenantCodes
Type: array<System..::..String>[]()[][]
Tenant Codes(Empty will return all roles)

Return Value

Type: List<(Of <(<' Role >)>)>
Active Role details in other tenant

Examples

Copy image Copy
public void SearchRolesInOtherTenants()
{
    string searchValue = "a";
    string[] tenantCodes = new string[] {"F1446542-0294-DF11-8DEB-001EC9DAB123", "E1446542-0294-DF11-8DEB-001EC9DAB123"};
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    List<Role> roles = roleService.SearchRolesInOtherTenants(searchValue, tenantCodes);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateRole Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateRole Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateRole(Role, String) | Updates the given role details
Public method | UpdateRole(String, String, String) | Updates the given role details
Public method | UpdateRole(String, String, array<String>[]()[][]) | Updated the given role with service ids

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateRole Method (Role, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateRole Method (Role, String)
IRoleService Interface Example See Also Send Feedback
Updates the given role details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateRole(
    Role roleDetails,
    string qualifierQuery
)
Visual Basic
Function UpdateRole (
    roleDetails As Role,
    qualifierQuery As String
) As String
Visual C++
String^ UpdateRole(
    Role^ roleDetails,
    String^ qualifierQuery
)

Parameters

roleDetails
Type: CelloSaaS.Model.AccessControlManagement..::..Role
Role Details(Mandatory - Role Identifier, Description)
qualifierQuery
Type: System..::..String
Qualifier query (Obsolete)

Return Value

Type: String
Updated Role Identifier

Examples

Copy image Copy
public void UpdateRole()
{
   Role roleDetails = new Role();
   roleDetails.RoleId = "GR$Tenant_Admin";
   roleDetails.Description = "Tenant Admin Role";
   string qualifierQuery = string.Empty;
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   string roleId = roleService.UpdateRole(roleDetails, qualifierQuery);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If rule name is duplicate.
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor was not updated.
System..::..ArgumentNullException | If role id or role name or description is null.
System..::..ArgumentException | If role details is null.

See Also

IRoleService Interface
IRoleService Members
UpdateRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateRole Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateRole Method (String, String, String)
IRoleService Interface Example See Also Send Feedback
Updates the given role details

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateRole(
    string roleIdentifier,
    string roleDescription,
    string qualifierQuery
)
Visual Basic
Function UpdateRole (
    roleIdentifier As String,
    roleDescription As String,
    qualifierQuery As String
) As String
Visual C++
String^ UpdateRole(
    String^ roleIdentifier,
    String^ roleDescription,
    String^ qualifierQuery
)

Parameters

roleIdentifier
Type: System..::..String
Role Identifier(Mandatory)
roleDescription
Type: System..::..String
Role Description(Mandatory)
qualifierQuery
Type: System..::..String
Qualifier query (Obsolete)

Return Value

Type: String
Updated Role Identifier

Examples

Copy image Copy
public void UpdateRole()
{
   string roleIdentifier = "GR$Tenant_Admin";
   string description = "Tenant Admin Role";
   string qualifierQuery = string.Empty;
   IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
   string roleId = roleService.UpdateRole(roleIdentifier, description, qualifierQuery);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If rule name is duplicate.
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If pre or post processor was not updated.
System..::..ArgumentNullException | If role id or role name or description is null.
System..::..ArgumentException | If role details is null.

See Also

IRoleService Interface
IRoleService Members
UpdateRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateRole Method (String, String, String[])

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateRole Method (String, String, array<String>[]()[][])
IRoleService Interface See Also Send Feedback
Updated the given role with service ids

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateRole(
    string roleIdentifier,
    string roleDescription,
    string[] serviceIds
)
Visual Basic
Function UpdateRole (
    roleIdentifier As String,
    roleDescription As String,
    serviceIds As String()
) As String
Visual C++
String^ UpdateRole(
    String^ roleIdentifier,
    String^ roleDescription,
    array<String^>^ serviceIds
)

Parameters

roleIdentifier
Type: System..::..String
Role ID(Mandatory)
roleDescription
Type: System..::..String
The role description.
serviceIds
Type: array<System..::..String>[]()[][]
The service ids.

Return Value

Type: String
Updated Role ID

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs while updating the role.

See Also

IRoleService Interface
IRoleService Members
UpdateRole Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateUserRoles Method

[image] [image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateUserRoles Method
IRoleService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateUserRoles(String, array<String>[]()[][]) | This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method | UpdateUserRoles(String, array<String>[]()[][], String) | This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method | UpdateUserRoles(String, array<String>[]()[][], array<String>[]()[][]) | This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.
Public method | UpdateUserRoles(String, array<String>[]()[][], array<String>[]()[][], String) | This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

See Also

IRoleService Interface
IRoleService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateUserRoles Method (String, String[])

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateUserRoles Method (String, array<String>[]()[][])
IRoleService Interface Example See Also Send Feedback
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserRoles(
    string userIdentifier,
    string[] roleIdentifiers
)
Visual Basic
Sub UpdateUserRoles (
    userIdentifier As String,
    roleIdentifiers As String()
)
Visual C++
void UpdateUserRoles(
    String^ userIdentifier,
    array<String^>^ roleIdentifiers
)

Parameters

userIdentifier
Type: System..::..String
User Identifier(Mandatory)
roleIdentifiers
Type: array<System..::..String>[]()[][]
Role Identifiers(Mandatory)

Examples

Copy image Copy
public void UpdateUserRoles()
{
    string userIdentifier = "3398F837-B988-4708-999D-D3DFE11875B3";
    string[] roleIdentifiers = new string[] {"GR$Tenant_Admin", "GR$Product_Admin"};
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    roleService.UpdateUserRoles(userIdentifier, roleIdentifiers);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception ocurs
System..::..UnauthorizedAccessException | Incase of no permission to update the user roles
System..::..ArgumentNullException | If role id or user id is null

See Also

IRoleService Interface
IRoleService Members
UpdateUserRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateUserRoles Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateUserRoles Method (String, array<String>[]()[][], String)
IRoleService Interface See Also Send Feedback
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserRoles(
    string userIdentifier,
    string[] roleIdentifiers,
    string tenantId
)
Visual Basic
Sub UpdateUserRoles (
    userIdentifier As String,
    roleIdentifiers As String(),
    tenantId As String
)
Visual C++
void UpdateUserRoles(
    String^ userIdentifier,
    array<String^>^ roleIdentifiers,
    String^ tenantId
)

Parameters

userIdentifier
Type: System..::..String
The user identifier.
roleIdentifiers
Type: array<System..::..String>[]()[][]
The role identifiers.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If role ids or user id or tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
UpdateUserRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateUserRoles Method (String, String[], String[])

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateUserRoles Method (String, array<String>[]()[][], array<String>[]()[][])
IRoleService Interface Example See Also Send Feedback
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserRoles(
    string userIdentifier,
    string[] updateRoleIdentifiers,
    string[] deleteRoleIdentifiers
)
Visual Basic
Sub UpdateUserRoles (
    userIdentifier As String,
    updateRoleIdentifiers As String(),
    deleteRoleIdentifiers As String()
)
Visual C++
void UpdateUserRoles(
    String^ userIdentifier,
    array<String^>^ updateRoleIdentifiers,
    array<String^>^ deleteRoleIdentifiers
)

Parameters

userIdentifier
Type: System..::..String
User Identifier(Mandatory)
updateRoleIdentifiers
Type: array<System..::..String>[]()[][]
Update Role Identifiers(Mandatory)
deleteRoleIdentifiers
Type: array<System..::..String>[]()[][]
Delete Role Identifiers(Mandatory)

Examples

Copy image Copy
public void UpdateUserRoles()
{
    string userIdentifier = "3398F837-B988-4708-999D-D3DFE11875B3";
    string[] updateRoleIdentifiers = new string[] {"GR$Tenant_Admin"};
    string[] deleteRoleIdentifiers = new string[] {"GR$Product_Admin"};
    IRoleService roleService = ServiceLocator.Resolve>IRoleService<();
    roleService.UpdateUserRoles(userIdentifier, updateRoleIdentifiers,deleteRoleIdentifiers);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the use has not the privilege
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occur
System..::..ArgumentNullException | If user id is null or empty

See Also

IRoleService Interface
IRoleService Members
UpdateUserRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IRoleService.UpdateUserRoles Method (String, String[], String[], String)

[image]

A Sandcastle Documented Class Library
IRoleService..::..UpdateUserRoles Method (String, array<String>[]()[][], array<String>[]()[][], String)
IRoleService Interface See Also Send Feedback
This method is used to update user roles. New role Identifier for user then insert role to user. Previous user role is not available in the current list then remove role from user.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserRoles(
    string userIdentifier,
    string[] updateRoleIdentifiers,
    string[] deleteRoleIdentifiers,
    string tenantId
)
Visual Basic
Sub UpdateUserRoles (
    userIdentifier As String,
    updateRoleIdentifiers As String(),
    deleteRoleIdentifiers As String(),
    tenantId As String
)
Visual C++
void UpdateUserRoles(
    String^ userIdentifier,
    array<String^>^ updateRoleIdentifiers,
    array<String^>^ deleteRoleIdentifiers,
    String^ tenantId
)

Parameters

userIdentifier
Type: System..::..String
The user identifier.
updateRoleIdentifiers
Type: array<System..::..String>[]()[][]
The update role identifiers.
deleteRoleIdentifiers
Type: array<System..::..String>[]()[][]
The delete role identifiers.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException | If db exception occurs
System..::..ArgumentNullException | If user id or tenant id is null or empty.

See Also

IRoleService Interface
IRoleService Members
UpdateUserRoles Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService Interface

[image]

A Sandcastle Documented Class Library
ITenantAccessService Interface
Members See Also Send Feedback
Tenant access service interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantAccessService
Visual Basic
Public Interface ITenantAccessService
Visual C++
public interface class ITenantAccessService

See Also

ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantAccessService Members
ITenantAccessService Interface Methods See Also Send Feedback

The ITenantAccessService type exposes the following members.

Methods

 | Name | Description
Public method | CheckTenantAccess(String, String, FetchType, String) | Checks the tenant access.
Public method | CheckTenantAccess(String, array<String>[]()[][], FetchType, String) | Checks the tenant access.
Public method | CheckTenantAccess(array<String>[]()[][], String, FetchType, String) | Checks the tenant access.
Public method | GetAccessedTenants(String, FetchType) | Get the List of tenant ids for the entity tenant scope
Public method | GetAccessedTenants(String, FetchType, String) | Get the List of tenant ids for the entity tenant scope
Public method | GetAllEntityBasedTenantScope | Gets all entity based tenant scope.
Public method | GetAllEntityTenantScope | Gets all entity tenant scope.
Public method | GetAllTenantScope | Gets all tenant scope.
Public method | GetDefaultEntityTenantScope | Gets the default entity tenant scope.
Public method | GetEntityTenantScopeByEntity | Gets the entity tenant scope by entity.
Public method | GetParentTenantForConfigurationSettings | Gets the parent tenant for configuration settings.
Public method | GetParentTenantId | Gets the parent tenant id.
Public method | GetTenantHierarchy | Gets the tenant hierarchy for view.
Public method | GetTenantScope | Gets the tenant scope.
Public method | UpdateEntityTenantScope | Updates the entity tenant scope.

See Also

ITenantAccessService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantAccessService Methods
ITenantAccessService Interface See Also Send Feedback

The ITenantAccessService type exposes the following members.

Methods

 | Name | Description
Public method | CheckTenantAccess(String, String, FetchType, String) | Checks the tenant access.
Public method | CheckTenantAccess(String, array<String>[]()[][], FetchType, String) | Checks the tenant access.
Public method | CheckTenantAccess(array<String>[]()[][], String, FetchType, String) | Checks the tenant access.
Public method | GetAccessedTenants(String, FetchType) | Get the List of tenant ids for the entity tenant scope
Public method | GetAccessedTenants(String, FetchType, String) | Get the List of tenant ids for the entity tenant scope
Public method | GetAllEntityBasedTenantScope | Gets all entity based tenant scope.
Public method | GetAllEntityTenantScope | Gets all entity tenant scope.
Public method | GetAllTenantScope | Gets all tenant scope.
Public method | GetDefaultEntityTenantScope | Gets the default entity tenant scope.
Public method | GetEntityTenantScopeByEntity | Gets the entity tenant scope by entity.
Public method | GetParentTenantForConfigurationSettings | Gets the parent tenant for configuration settings.
Public method | GetParentTenantId | Gets the parent tenant id.
Public method | GetTenantHierarchy | Gets the tenant hierarchy for view.
Public method | GetTenantScope | Gets the tenant scope.
Public method | UpdateEntityTenantScope | Updates the entity tenant scope.

See Also

ITenantAccessService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.CheckTenantAccess Method

[image] [image]

A Sandcastle Documented Class Library
ITenantAccessService..::..CheckTenantAccess Method
ITenantAccessService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckTenantAccess(String, String, FetchType, String) | Checks the tenant access.
Public method | CheckTenantAccess(String, array<String>[]()[][], FetchType, String) | Checks the tenant access.
Public method | CheckTenantAccess(array<String>[]()[][], String, FetchType, String) | Checks the tenant access.

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.CheckTenantAccess Method (String, String, FetchType, String)

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..CheckTenantAccess Method (String, String, FetchType, String)
ITenantAccessService Interface See Also Send Feedback
Checks the tenant access.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckTenantAccess(
    string entityId,
    string accessTenantId,
    FetchType fetchType,
    string operationalTenantId
)
Visual Basic
Function CheckTenantAccess (
    entityId As String,
    accessTenantId As String,
    fetchType As FetchType,
    operationalTenantId As String
) As Boolean
Visual C++
bool CheckTenantAccess(
    String^ entityId,
    String^ accessTenantId,
    FetchType fetchType,
    String^ operationalTenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
accessTenantId
Type: System..::..String
The access tenant id.
fetchType
Type: CelloSaaS.Model..::..FetchType
Type of the fetch.
operationalTenantId
Type: System..::..String
The operational tenant id.

Return Value

Type: Boolean

See Also

ITenantAccessService Interface
ITenantAccessService Members
CheckTenantAccess Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.CheckTenantAccess Method (String, String[], FetchType, String)

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..CheckTenantAccess Method (String, array<String>[]()[][], FetchType, String)
ITenantAccessService Interface See Also Send Feedback
Checks the tenant access.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckTenantAccess(
    string entityId,
    string[] accessTenantIds,
    FetchType fetchType,
    string operationalTenantId
)
Visual Basic
Function CheckTenantAccess (
    entityId As String,
    accessTenantIds As String(),
    fetchType As FetchType,
    operationalTenantId As String
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckTenantAccess(
    String^ entityId,
    array<String^>^ accessTenantIds,
    FetchType fetchType,
    String^ operationalTenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
accessTenantIds
Type: array<System..::..String>[]()[][]
The access tenant ids.
fetchType
Type: CelloSaaS.Model..::..FetchType
Type of the fetch.
operationalTenantId
Type: System..::..String
The operational tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
CheckTenantAccess Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.CheckTenantAccess Method (String[], String, FetchType, String)

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..CheckTenantAccess Method (array<String>[]()[][], String, FetchType, String)
ITenantAccessService Interface See Also Send Feedback
Checks the tenant access.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckTenantAccess(
    string[] entityIds,
    string accessTenantId,
    FetchType fetchType,
    string operationalTenantId
)
Visual Basic
Function CheckTenantAccess (
    entityIds As String(),
    accessTenantId As String,
    fetchType As FetchType,
    operationalTenantId As String
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckTenantAccess(
    array<String^>^ entityIds,
    String^ accessTenantId,
    FetchType fetchType,
    String^ operationalTenantId
)

Parameters

entityIds
Type: array<System..::..String>[]()[][]
The entity ids.
accessTenantId
Type: System..::..String
The access tenant id.
fetchType
Type: CelloSaaS.Model..::..FetchType
Type of the fetch.
operationalTenantId
Type: System..::..String
The operational tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
CheckTenantAccess Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetAccessedTenants Method

[image] [image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetAccessedTenants Method
ITenantAccessService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAccessedTenants(String, FetchType) | Get the List of tenant ids for the entity tenant scope
Public method | GetAccessedTenants(String, FetchType, String) | Get the List of tenant ids for the entity tenant scope

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetAccessedTenants Method (String, FetchType)

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetAccessedTenants Method (String, FetchType)
ITenantAccessService Interface See Also Send Feedback
Get the List of tenant ids for the entity tenant scope

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetAccessedTenants(
    string entityId,
    FetchType fetchType
)
Visual Basic
Function GetAccessedTenants (
    entityId As String,
    fetchType As FetchType
) As List(Of String)
Visual C++
List<String^>^ GetAccessedTenants(
    String^ entityId,
    FetchType fetchType
)

Parameters

entityId
Type: System..::..String
entityId
fetchType
Type: CelloSaaS.Model..::..FetchType
fetchType

Return Value

Type: List<(Of <(<'String>)>)>
List of TenantIds

See Also

ITenantAccessService Interface
ITenantAccessService Members
GetAccessedTenants Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetAccessedTenants Method (String, FetchType, String)

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetAccessedTenants Method (String, FetchType, String)
ITenantAccessService Interface See Also Send Feedback
Get the List of tenant ids for the entity tenant scope

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetAccessedTenants(
    string entityId,
    FetchType fetchType,
    string operationalTenantId
)
Visual Basic
Function GetAccessedTenants (
    entityId As String,
    fetchType As FetchType,
    operationalTenantId As String
) As List(Of String)
Visual C++
List<String^>^ GetAccessedTenants(
    String^ entityId,
    FetchType fetchType,
    String^ operationalTenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
fetchType
Type: CelloSaaS.Model..::..FetchType
Type of the fetch.
operationalTenantId
Type: System..::..String
The operational tenant id.

Return Value

Type: List<(Of <(<'String>)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
GetAccessedTenants Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetAllEntityBasedTenantScope Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetAllEntityBasedTenantScope Method
ITenantAccessService Interface See Also Send Feedback
Gets all entity based tenant scope.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityBasedTenantScope> GetAllEntityBasedTenantScope()
Visual Basic
Function GetAllEntityBasedTenantScope As Dictionary(Of String, EntityBasedTenantScope)
Visual C++
Dictionary<String^, EntityBasedTenantScope^>^ GetAllEntityBasedTenantScope()

Return Value

Type: Dictionary<(Of <(<'String, EntityBasedTenantScope >)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetAllEntityTenantScope Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetAllEntityTenantScope Method
ITenantAccessService Interface See Also Send Feedback
Gets all entity tenant scope.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityTenantScope> GetAllEntityTenantScope(
    string tenantId
)
Visual Basic
Function GetAllEntityTenantScope (
    tenantId As String
) As Dictionary(Of String, EntityTenantScope)
Visual C++
Dictionary<String^, EntityTenantScope^>^ GetAllEntityTenantScope(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, EntityTenantScope >)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetAllTenantScope Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetAllTenantScope Method
ITenantAccessService Interface See Also Send Feedback
Gets all tenant scope.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantScope> GetAllTenantScope()
Visual Basic
Function GetAllTenantScope As Dictionary(Of String, TenantScope)
Visual C++
Dictionary<String^, TenantScope^>^ GetAllTenantScope()

Return Value

Type: Dictionary<(Of <(<'String, TenantScope >)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetDefaultEntityTenantScope Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetDefaultEntityTenantScope Method
ITenantAccessService Interface See Also Send Feedback
Gets the default entity tenant scope.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityTenantScope GetDefaultEntityTenantScope(
    string entityId
)
Visual Basic
Function GetDefaultEntityTenantScope (
    entityId As String
) As EntityTenantScope
Visual C++
EntityTenantScope^ GetDefaultEntityTenantScope(
    String^ entityId
)

Parameters

entityId
Type: System..::..String
The entity id.

Return Value

Type: EntityTenantScope

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetEntityTenantScopeByEntity Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetEntityTenantScopeByEntity Method
ITenantAccessService Interface See Also Send Feedback
Gets the entity tenant scope by entity.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityTenantScope GetEntityTenantScopeByEntity(
    string entityId,
    string tenantId
)
Visual Basic
Function GetEntityTenantScopeByEntity (
    entityId As String,
    tenantId As String
) As EntityTenantScope
Visual C++
EntityTenantScope^ GetEntityTenantScopeByEntity(
    String^ entityId,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: EntityTenantScope

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetParentTenantForConfigurationSettings Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetParentTenantForConfigurationSettings Method
ITenantAccessService Interface See Also Send Feedback
Gets the parent tenant for configuration settings.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetParentTenantForConfigurationSettings(
    string tenantId,
    string configurationId
)
Visual Basic
Function GetParentTenantForConfigurationSettings (
    tenantId As String,
    configurationId As String
) As String
Visual C++
String^ GetParentTenantForConfigurationSettings(
    String^ tenantId,
    String^ configurationId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationId
Type: System..::..String
The configuration id.

Return Value

Type: String

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetParentTenantId Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetParentTenantId Method
ITenantAccessService Interface See Also Send Feedback
Gets the parent tenant id.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetParentTenantId(
    string tenantId,
    string configurationId
)
Visual Basic
Function GetParentTenantId (
    tenantId As String,
    configurationId As String
) As String
Visual C++
String^ GetParentTenantId(
    String^ tenantId,
    String^ configurationId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationId
Type: System..::..String
The configuration id.

Return Value

Type: String

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetTenantHierarchy Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetTenantHierarchy Method
ITenantAccessService Interface See Also Send Feedback
Gets the tenant hierarchy for view.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantHierarchy(
    string entityId,
    FetchType fetchType,
    string operationalTenantId
)
Visual Basic
Function GetTenantHierarchy (
    entityId As String,
    fetchType As FetchType,
    operationalTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantHierarchy(
    String^ entityId,
    FetchType fetchType,
    String^ operationalTenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
fetchType
Type: CelloSaaS.Model..::..FetchType
Type of the fetch.
operationalTenantId
Type: System..::..String
The operational tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.GetTenantScope Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..GetTenantScope Method
ITenantAccessService Interface See Also Send Feedback
Gets the tenant scope.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantScope GetTenantScope(
    string tenantScopeId
)
Visual Basic
Function GetTenantScope (
    tenantScopeId As String
) As TenantScope
Visual C++
TenantScope^ GetTenantScope(
    String^ tenantScopeId
)

Parameters

tenantScopeId
Type: System..::..String
The tenant scope id.

Return Value

Type: TenantScope

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ITenantAccessService.UpdateEntityTenantScope Method

[image]

A Sandcastle Documented Class Library
ITenantAccessService..::..UpdateEntityTenantScope Method
ITenantAccessService Interface See Also Send Feedback
Updates the entity tenant scope.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateEntityTenantScope(
    string tenantId,
    Dictionary<string, EntityTenantScope> entityTenantScopeList
)
Visual Basic
Sub UpdateEntityTenantScope (
    tenantId As String,
    entityTenantScopeList As Dictionary(Of String, EntityTenantScope)
)
Visual C++
void UpdateEntityTenantScope(
    String^ tenantId,
    Dictionary<String^, EntityTenantScope^>^ entityTenantScopeList
)

Parameters

tenantId
Type: System..::..String
The tenant id.
entityTenantScopeList
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, EntityTenantScope >)>)>
The entity tenant scope list.

See Also

ITenantAccessService Interface
ITenantAccessService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService Interface

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService Interface
Members See Also Send Feedback
UserEntityPermission Service Interface

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IUserEntityPermissionService
Visual Basic
Public Interface IUserEntityPermissionService
Visual C++
public interface class IUserEntityPermissionService

See Also

IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService Members

[image] [image]

A Sandcastle Documented Class Library
IUserEntityPermissionService Members
IUserEntityPermissionService Interface Methods See Also Send Feedback

The IUserEntityPermissionService type exposes the following members.

Methods

 | Name | Description
Public method | AddUserEntityPermission | Adds the user entity permission.
Public method | CheckUserEntityPermissionByEntityOperation | Checks the user entity permission by entity operation.
Public method | CheckUserEntityPermissionByEntityOperations | Checks the user entity permission by entity operations.
Public method | CheckUserEntityPermissionByOtherPrivilege | Checks the user entity permission by other privilege.
Public method | CheckUserEntityPermissionByOtherPrivileges | Checks the user entity permission by other privileges.
Public method | DeleteUserEntityPermission | delete the UserEntityPermission details by id
Public method | GetReferenceIdByEntities | Gets the reference id by entities.
Public method | GetReferenceIdByEntity | Gets the reference id by entity.
Public method | GetReferenceIdByField | Gets the reference id by field.
Public method | GetReferenceIdByFields | Gets the reference id by fields.
Public method | GetReferenceIdByOperations | Gets the reference id by operations.
Public method | GetReferenceIdByPrivilege | Gets the reference id by privilege.
Public method | GetReferenceIdByPrivileges | Gets the reference id by privileges.
Public method | GetUserEntityPermissionsByTenantId | Gets the user entity permissions by tenant id.
Public method | SaveUserEntityOtherPrivileges | Saves the user entity other privileges.
Public method | SearchUserEntityPermissionDetails | Searches the user entity permission details.
Public method | SearchUserEntityPermissionDetailsCount | Searches the user entity permission details count.
Public method | UpdateUserEntityPermission | Updates the user entity permission.

See Also

IUserEntityPermissionService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService Methods

[image] [image]

A Sandcastle Documented Class Library
IUserEntityPermissionService Methods
IUserEntityPermissionService Interface See Also Send Feedback

The IUserEntityPermissionService type exposes the following members.

Methods

 | Name | Description
Public method | AddUserEntityPermission | Adds the user entity permission.
Public method | CheckUserEntityPermissionByEntityOperation | Checks the user entity permission by entity operation.
Public method | CheckUserEntityPermissionByEntityOperations | Checks the user entity permission by entity operations.
Public method | CheckUserEntityPermissionByOtherPrivilege | Checks the user entity permission by other privilege.
Public method | CheckUserEntityPermissionByOtherPrivileges | Checks the user entity permission by other privileges.
Public method | DeleteUserEntityPermission | delete the UserEntityPermission details by id
Public method | GetReferenceIdByEntities | Gets the reference id by entities.
Public method | GetReferenceIdByEntity | Gets the reference id by entity.
Public method | GetReferenceIdByField | Gets the reference id by field.
Public method | GetReferenceIdByFields | Gets the reference id by fields.
Public method | GetReferenceIdByOperations | Gets the reference id by operations.
Public method | GetReferenceIdByPrivilege | Gets the reference id by privilege.
Public method | GetReferenceIdByPrivileges | Gets the reference id by privileges.
Public method | GetUserEntityPermissionsByTenantId | Gets the user entity permissions by tenant id.
Public method | SaveUserEntityOtherPrivileges | Saves the user entity other privileges.
Public method | SearchUserEntityPermissionDetails | Searches the user entity permission details.
Public method | SearchUserEntityPermissionDetailsCount | Searches the user entity permission details count.
Public method | UpdateUserEntityPermission | Updates the user entity permission.

See Also

IUserEntityPermissionService Interface
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.AddUserEntityPermission Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..AddUserEntityPermission Method
IUserEntityPermissionService Interface See Also Send Feedback
Adds the user entity permission.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddUserEntityPermission(
    UserEntityPermission userEntityPermission
)
Visual Basic
Function AddUserEntityPermission (
    userEntityPermission As UserEntityPermission
) As String
Visual C++
String^ AddUserEntityPermission(
    UserEntityPermission^ userEntityPermission
)

Parameters

userEntityPermission
Type: CelloSaaS.Model.AccessControlManagement..::..UserEntityPermission
The user entity permission.

Return Value

Type: String
Id

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.CheckUserEntityPermissionByEntityOperation Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..CheckUserEntityPermissionByEntityOperation Method
IUserEntityPermissionService Interface See Also Send Feedback
Checks the user entity permission by entity operation.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckUserEntityPermissionByEntityOperation(
    string entityId,
    string userId,
    string referenceId,
    EntityOperation entityOperation,
    string tenantId
)
Visual Basic
Function CheckUserEntityPermissionByEntityOperation (
    entityId As String,
    userId As String,
    referenceId As String,
    entityOperation As EntityOperation,
    tenantId As String
) As Boolean
Visual C++
bool CheckUserEntityPermissionByEntityOperation(
    String^ entityId,
    String^ userId,
    String^ referenceId,
    EntityOperation entityOperation,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
userId
Type: System..::..String
The user id.
referenceId
Type: System..::..String
The reference id.
entityOperation
Type: CelloSaaS.Model..::..EntityOperation
The entity operation.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.CheckUserEntityPermissionByEntityOperations Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..CheckUserEntityPermissionByEntityOperations Method
IUserEntityPermissionService Interface See Also Send Feedback
Checks the user entity permission by entity operations.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckUserEntityPermissionByEntityOperations(
    string entityId,
    string userId,
    string referenceId,
    EntityOperation[] entityOperations,
    string tenantId
)
Visual Basic
Function CheckUserEntityPermissionByEntityOperations (
    entityId As String,
    userId As String,
    referenceId As String,
    entityOperations As EntityOperation(),
    tenantId As String
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckUserEntityPermissionByEntityOperations(
    String^ entityId,
    String^ userId,
    String^ referenceId,
    array<EntityOperation>^ entityOperations,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
userId
Type: System..::..String
The user id.
referenceId
Type: System..::..String
The reference id.
entityOperations
Type: array< CelloSaaS.Model..::..EntityOperation >[]()[][]
The entity operations.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.CheckUserEntityPermissionByOtherPrivilege Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..CheckUserEntityPermissionByOtherPrivilege Method
IUserEntityPermissionService Interface See Also Send Feedback
Checks the user entity permission by other privilege.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckUserEntityPermissionByOtherPrivilege(
    string entityId,
    string userId,
    string referenceId,
    string privilege,
    string tenantId
)
Visual Basic
Function CheckUserEntityPermissionByOtherPrivilege (
    entityId As String,
    userId As String,
    referenceId As String,
    privilege As String,
    tenantId As String
) As Boolean
Visual C++
bool CheckUserEntityPermissionByOtherPrivilege(
    String^ entityId,
    String^ userId,
    String^ referenceId,
    String^ privilege,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
userId
Type: System..::..String
The user id.
referenceId
Type: System..::..String
The reference id.
privilege
Type: System..::..String
The privilege.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.CheckUserEntityPermissionByOtherPrivileges Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..CheckUserEntityPermissionByOtherPrivileges Method
IUserEntityPermissionService Interface See Also Send Feedback
Checks the user entity permission by other privileges.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, bool> CheckUserEntityPermissionByOtherPrivileges(
    string entityId,
    string userId,
    string referenceId,
    string[] privileges,
    string tenantId
)
Visual Basic
Function CheckUserEntityPermissionByOtherPrivileges (
    entityId As String,
    userId As String,
    referenceId As String,
    privileges As String(),
    tenantId As String
) As Dictionary(Of String, Boolean)
Visual C++
Dictionary<String^, bool>^ CheckUserEntityPermissionByOtherPrivileges(
    String^ entityId,
    String^ userId,
    String^ referenceId,
    array<String^>^ privileges,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
userId
Type: System..::..String
The user id.
referenceId
Type: System..::..String
The reference id.
privileges
Type: array<System..::..String>[]()[][]
The privileges.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Boolean>)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.DeleteUserEntityPermission Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..DeleteUserEntityPermission Method
IUserEntityPermissionService Interface See Also Send Feedback
delete the UserEntityPermission details by id

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserEntityPermission(
    string id
)
Visual Basic
Sub DeleteUserEntityPermission (
    id As String
)
Visual C++
void DeleteUserEntityPermission(
    String^ id
)

Parameters

id
Type: System..::..String
The id.

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByEntities Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByEntities Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by entities.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string[]> GetReferenceIdByEntities(
    string userId,
    string[] entityIds,
    EntityOperation operation
)
Visual Basic
Function GetReferenceIdByEntities (
    userId As String,
    entityIds As String(),
    operation As EntityOperation
) As Dictionary(Of String, String())
Visual C++
Dictionary<String^, array<String^>^>^ GetReferenceIdByEntities(
    String^ userId,
    array<String^>^ entityIds,
    EntityOperation operation
)

Parameters

userId
Type: System..::..String
The user id.
entityIds
Type: array<System..::..String>[]()[][]
The entity ids.
operation
Type: CelloSaaS.Model..::..EntityOperation
The operation.

Return Value

Type: Dictionary<(Of <(<'String, array<String>[]()[][]>)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByEntity Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByEntity Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by entity.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetReferenceIdByEntity(
    string userId,
    string entityId,
    EntityOperation operation
)
Visual Basic
Function GetReferenceIdByEntity (
    userId As String,
    entityId As String,
    operation As EntityOperation
) As String()
Visual C++
array<String^>^ GetReferenceIdByEntity(
    String^ userId,
    String^ entityId,
    EntityOperation operation
)

Parameters

userId
Type: System..::..String
The user id.
entityId
Type: System..::..String
The entity id.
operation
Type: CelloSaaS.Model..::..EntityOperation
The operation.

Return Value

Type: array<String>[]()[][]

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByField Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByField Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by field.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetReferenceIdByField(
    string userId,
    string fieldId,
    EntityOperation operation
)
Visual Basic
Function GetReferenceIdByField (
    userId As String,
    fieldId As String,
    operation As EntityOperation
) As String()
Visual C++
array<String^>^ GetReferenceIdByField(
    String^ userId,
    String^ fieldId,
    EntityOperation operation
)

Parameters

userId
Type: System..::..String
The user id.
fieldId
Type: System..::..String
The field id.
operation
Type: CelloSaaS.Model..::..EntityOperation
The operation.

Return Value

Type: array<String>[]()[][]

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByFields Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByFields Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by fields.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string[]> GetReferenceIdByFields(
    string userId,
    string[] fieldIds,
    EntityOperation operation
)
Visual Basic
Function GetReferenceIdByFields (
    userId As String,
    fieldIds As String(),
    operation As EntityOperation
) As Dictionary(Of String, String())
Visual C++
Dictionary<String^, array<String^>^>^ GetReferenceIdByFields(
    String^ userId,
    array<String^>^ fieldIds,
    EntityOperation operation
)

Parameters

userId
Type: System..::..String
The user id.
fieldIds
Type: array<System..::..String>[]()[][]
The fields ids.
operation
Type: CelloSaaS.Model..::..EntityOperation
The operation.

Return Value

Type: Dictionary<(Of <(<'String, array<String>[]()[][]>)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByOperations Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByOperations Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by operations.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string[]> GetReferenceIdByOperations(
    string userId,
    string entityId,
    EntityOperation[] operation
)
Visual Basic
Function GetReferenceIdByOperations (
    userId As String,
    entityId As String,
    operation As EntityOperation()
) As Dictionary(Of String, String())
Visual C++
Dictionary<String^, array<String^>^>^ GetReferenceIdByOperations(
    String^ userId,
    String^ entityId,
    array<EntityOperation>^ operation
)

Parameters

userId
Type: System..::..String
The user id.
entityId
Type: System..::..String
The entity id.
operation
Type: array< CelloSaaS.Model..::..EntityOperation >[]()[][]
The operation.

Return Value

Type: Dictionary<(Of <(<'String, array<String>[]()[][]>)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByPrivilege Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByPrivilege Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by privilege.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetReferenceIdByPrivilege(
    string userId,
    string entityId,
    string privilege
)
Visual Basic
Function GetReferenceIdByPrivilege (
    userId As String,
    entityId As String,
    privilege As String
) As String()
Visual C++
array<String^>^ GetReferenceIdByPrivilege(
    String^ userId,
    String^ entityId,
    String^ privilege
)

Parameters

userId
Type: System..::..String
The user id.
entityId
Type: System..::..String
The entity id.
privilege
Type: System..::..String
The privilege.

Return Value

Type: array<String>[]()[][]

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetReferenceIdByPrivileges Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetReferenceIdByPrivileges Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the reference id by privileges.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string[]> GetReferenceIdByPrivileges(
    string userId,
    string entityId,
    string[] privileges
)
Visual Basic
Function GetReferenceIdByPrivileges (
    userId As String,
    entityId As String,
    privileges As String()
) As Dictionary(Of String, String())
Visual C++
Dictionary<String^, array<String^>^>^ GetReferenceIdByPrivileges(
    String^ userId,
    String^ entityId,
    array<String^>^ privileges
)

Parameters

userId
Type: System..::..String
The user id.
entityId
Type: System..::..String
The entity id.
privileges
Type: array<System..::..String>[]()[][]
The privileges.

Return Value

Type: Dictionary<(Of <(<'String, array<String>[]()[][]>)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.GetUserEntityPermissionsByTenantId Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..GetUserEntityPermissionsByTenantId Method
IUserEntityPermissionService Interface See Also Send Feedback
Gets the user entity permissions by tenant id.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserEntityPermission> GetUserEntityPermissionsByTenantId(
    string tenantId
)
Visual Basic
Function GetUserEntityPermissionsByTenantId (
    tenantId As String
) As Dictionary(Of String, UserEntityPermission)
Visual C++
Dictionary<String^, UserEntityPermission^>^ GetUserEntityPermissionsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, UserEntityPermission >)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.SaveUserEntityOtherPrivileges Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..SaveUserEntityOtherPrivileges Method
IUserEntityPermissionService Interface See Also Send Feedback
Saves the user entity other privileges.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveUserEntityOtherPrivileges(
    UserEntityPermission userEntityPermission
)
Visual Basic
Sub SaveUserEntityOtherPrivileges (
    userEntityPermission As UserEntityPermission
)
Visual C++
void SaveUserEntityOtherPrivileges(
    UserEntityPermission^ userEntityPermission
)

Parameters

userEntityPermission
Type: CelloSaaS.Model.AccessControlManagement..::..UserEntityPermission
The user entity permission.

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.SearchUserEntityPermissionDetails Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..SearchUserEntityPermissionDetails Method
IUserEntityPermissionService Interface See Also Send Feedback
Searches the user entity permission details.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserEntityPermission> SearchUserEntityPermissionDetails(
    UserEntityPermissionSearchCondition userEntityPermissionSearchCondition
)
Visual Basic
Function SearchUserEntityPermissionDetails (
    userEntityPermissionSearchCondition As UserEntityPermissionSearchCondition
) As Dictionary(Of String, UserEntityPermission)
Visual C++
Dictionary<String^, UserEntityPermission^>^ SearchUserEntityPermissionDetails(
    UserEntityPermissionSearchCondition^ userEntityPermissionSearchCondition
)

Parameters

userEntityPermissionSearchCondition
Type: CelloSaaS.Model.AccessControlManagement..::..UserEntityPermissionSearchCondition
The user entity permission search condition.

Return Value

Type: Dictionary<(Of <(<'String, UserEntityPermission >)>)>

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.SearchUserEntityPermissionDetailsCount Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..SearchUserEntityPermissionDetailsCount Method
IUserEntityPermissionService Interface See Also Send Feedback
Searches the user entity permission details count.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int SearchUserEntityPermissionDetailsCount(
    UserEntityPermissionSearchCondition userEntityPermissionSearchCondition
)
Visual Basic
Function SearchUserEntityPermissionDetailsCount (
    userEntityPermissionSearchCondition As UserEntityPermissionSearchCondition
) As Integer
Visual C++
int SearchUserEntityPermissionDetailsCount(
    UserEntityPermissionSearchCondition^ userEntityPermissionSearchCondition
)

Parameters

userEntityPermissionSearchCondition
Type: CelloSaaS.Model.AccessControlManagement..::..UserEntityPermissionSearchCondition
The user entity permission search condition.

Return Value

Type: Int32

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


IUserEntityPermissionService.UpdateUserEntityPermission Method

[image]

A Sandcastle Documented Class Library
IUserEntityPermissionService..::..UpdateUserEntityPermission Method
IUserEntityPermissionService Interface See Also Send Feedback
Updates the user entity permission.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserEntityPermission(
    UserEntityPermission userEntityPermission
)
Visual Basic
Sub UpdateUserEntityPermission (
    userEntityPermission As UserEntityPermission
)
Visual C++
void UpdateUserEntityPermission(
    UserEntityPermission^ userEntityPermission
)

Parameters

userEntityPermission
Type: CelloSaaS.Model.AccessControlManagement..::..UserEntityPermission
The user entity permission.

See Also

IUserEntityPermissionService Interface
IUserEntityPermissionService Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
PrivilegeConstants Class
Members See Also Send Feedback
Privilege Constants

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class PrivilegeConstants
Visual Basic
Public NotInheritable Class PrivilegeConstants
Visual C++
public ref class PrivilegeConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeConstants

See Also

PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
PrivilegeConstants Members
PrivilegeConstants Class Fields Properties See Also Send Feedback

The PrivilegeConstants type exposes the following members.

Fields

Name | Description
AddEndpoint |
AddPricePlan |
AddUserEntityPermission |
AddVirtualEntity |
CreateDatabackup |
DeleteEndpoint |
DeletePricePlan |
DeleteUserEntityPermission |
DeleteVirtualEntity |
EditEndpoint |
EditInvoice |
EditPricePlan |
EditUserEntityPermission |
ManageDataView |
ManageEntity |
ManageModuleConfiguration |
SaveRule |
SelfUpgradePackage |
ViewAudit |
ViewChildInvoice |
ViewDatabackup |
ViewEndpoint |
ViewEventAudit |
ViewInvoice |
ViewInvoiceDashboard |
ViewJobAudit |
ViewNotificationAudit |
ViewPricePlan |
ViewProductAnalyticsAudit |
ViewRule |
ViewUsageAudit |
ViewUserEntityPermission |

Properties

Name | Description
AddMasterData |
AddPackage |
AddPackageSettings |
AddPickupList |
AddPickupListValue |
AddRole |
AddRoleFeature |
AddRolePrivilege |
AddRoleSettings |
AddTenant |
AddTenantSettings |
AddUser |
AddUserRole |
AddUserSettings |
DeleteMasterData |
DeletePackage |
DeletePackageSettings |
DeletePickupList |
DeletePickupListValue |
DeleteRole |
DeleteRoleFeature |
DeleteRolePrivilege |
DeleteRoleSettings |
DeleteTenant |
DeleteTenantSettings |
DeleteUser |
DeleteUserRole |
DeleteUserSettings |
EditSelfUser |
ForcePasswordExpiry |
InsertTenantLicense |
LockUser |
ResetPINUser |
SearchOtherTenantRoles |
SearchOtherTenantUsers |
SearchRole |
SearchTenant |
SearchUser |
UnLockUser |
UpdateMasterData |
UpdatePackage |
UpdatePackageSettings |
UpdatePickupList |
UpdatePickupListValue |
UpdateRole |
UpdateRoleFeature |
UpdateRolePrivilege |
UpdateRoleSettings |
UpdateTenant |
UpdateTenantLicense |
UpdateTenantSettings |
UpdateUser |
UpdateUserSettings |
ViewChildRelationData |
ViewMasterData |
ViewPackage |
ViewPackageSettings |
ViewPickupList |
ViewPickupListValue |
ViewRole |
ViewRoleFeature |
ViewRolePrivilege |
ViewRoleSettings |
ViewSelfUser |
ViewTenant |
ViewTenantLicense |
ViewTenantSettings |
ViewUser |
ViewUserSettings |

See Also

PrivilegeConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
PrivilegeConstants Fields
PrivilegeConstants Class See Also Send Feedback

The PrivilegeConstants type exposes the following members.

Fields

Name | Description
AddEndpoint |
AddPricePlan |
AddUserEntityPermission |
AddVirtualEntity |
CreateDatabackup |
DeleteEndpoint |
DeletePricePlan |
DeleteUserEntityPermission |
DeleteVirtualEntity |
EditEndpoint |
EditInvoice |
EditPricePlan |
EditUserEntityPermission |
ManageDataView |
ManageEntity |
ManageModuleConfiguration |
SaveRule |
SelfUpgradePackage |
ViewAudit |
ViewChildInvoice |
ViewDatabackup |
ViewEndpoint |
ViewEventAudit |
ViewInvoice |
ViewInvoiceDashboard |
ViewJobAudit |
ViewNotificationAudit |
ViewPricePlan |
ViewProductAnalyticsAudit |
ViewRule |
ViewUsageAudit |
ViewUserEntityPermission |

See Also

PrivilegeConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddEndpoint Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddEndpoint Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddEndpoint
Visual Basic
Public Const AddEndpoint As String
Visual C++
public:
literal String^ AddEndpoint

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddPricePlan Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddPricePlan Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddPricePlan
Visual Basic
Public Const AddPricePlan As String
Visual C++
public:
literal String^ AddPricePlan

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddUserEntityPermission Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddUserEntityPermission
Visual Basic
Public Const AddUserEntityPermission As String
Visual C++
public:
literal String^ AddUserEntityPermission

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddVirtualEntity Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddVirtualEntity Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddVirtualEntity
Visual Basic
Public Const AddVirtualEntity As String
Visual C++
public:
literal String^ AddVirtualEntity

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.CreateDatabackup Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..CreateDatabackup Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CreateDatabackup
Visual Basic
Public Const CreateDatabackup As String
Visual C++
public:
literal String^ CreateDatabackup

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteEndpoint Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteEndpoint Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeleteEndpoint
Visual Basic
Public Const DeleteEndpoint As String
Visual C++
public:
literal String^ DeleteEndpoint

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeletePricePlan Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeletePricePlan Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeletePricePlan
Visual Basic
Public Const DeletePricePlan As String
Visual C++
public:
literal String^ DeletePricePlan

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteUserEntityPermission Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeleteUserEntityPermission
Visual Basic
Public Const DeleteUserEntityPermission As String
Visual C++
public:
literal String^ DeleteUserEntityPermission

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteVirtualEntity Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteVirtualEntity Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeleteVirtualEntity
Visual Basic
Public Const DeleteVirtualEntity As String
Visual C++
public:
literal String^ DeleteVirtualEntity

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.EditEndpoint Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..EditEndpoint Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditEndpoint
Visual Basic
Public Const EditEndpoint As String
Visual C++
public:
literal String^ EditEndpoint

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.EditInvoice Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..EditInvoice Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditInvoice
Visual Basic
Public Const EditInvoice As String
Visual C++
public:
literal String^ EditInvoice

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.EditPricePlan Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..EditPricePlan Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditPricePlan
Visual Basic
Public Const EditPricePlan As String
Visual C++
public:
literal String^ EditPricePlan

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.EditUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..EditUserEntityPermission Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditUserEntityPermission
Visual Basic
Public Const EditUserEntityPermission As String
Visual C++
public:
literal String^ EditUserEntityPermission

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ManageDataView Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ManageDataView Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ManageDataView
Visual Basic
Public Const ManageDataView As String
Visual C++
public:
literal String^ ManageDataView

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ManageEntity Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ManageEntity Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ManageEntity
Visual Basic
Public Const ManageEntity As String
Visual C++
public:
literal String^ ManageEntity

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ManageModuleConfiguration Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ManageModuleConfiguration Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ManageModuleConfiguration
Visual Basic
Public Const ManageModuleConfiguration As String
Visual C++
public:
literal String^ ManageModuleConfiguration

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SaveRule Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SaveRule Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SaveRule
Visual Basic
Public Const SaveRule As String
Visual C++
public:
literal String^ SaveRule

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SelfUpgradePackage Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SelfUpgradePackage Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SelfUpgradePackage
Visual Basic
Public Const SelfUpgradePackage As String
Visual C++
public:
literal String^ SelfUpgradePackage

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewAudit Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewAudit Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewAudit
Visual Basic
Public Const ViewAudit As String
Visual C++
public:
literal String^ ViewAudit

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewChildInvoice Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewChildInvoice Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewChildInvoice
Visual Basic
Public Const ViewChildInvoice As String
Visual C++
public:
literal String^ ViewChildInvoice

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewDatabackup Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewDatabackup Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewDatabackup
Visual Basic
Public Const ViewDatabackup As String
Visual C++
public:
literal String^ ViewDatabackup

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewEndpoint Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewEndpoint Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewEndpoint
Visual Basic
Public Const ViewEndpoint As String
Visual C++
public:
literal String^ ViewEndpoint

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewEventAudit Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewEventAudit Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewEventAudit
Visual Basic
Public Const ViewEventAudit As String
Visual C++
public:
literal String^ ViewEventAudit

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewInvoice Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewInvoice Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewInvoice
Visual Basic
Public Const ViewInvoice As String
Visual C++
public:
literal String^ ViewInvoice

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewInvoiceDashboard Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewInvoiceDashboard Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewInvoiceDashboard
Visual Basic
Public Const ViewInvoiceDashboard As String
Visual C++
public:
literal String^ ViewInvoiceDashboard

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewJobAudit Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewJobAudit Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewJobAudit
Visual Basic
Public Const ViewJobAudit As String
Visual C++
public:
literal String^ ViewJobAudit

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewNotificationAudit Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewNotificationAudit Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewNotificationAudit
Visual Basic
Public Const ViewNotificationAudit As String
Visual C++
public:
literal String^ ViewNotificationAudit

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewPricePlan Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewPricePlan Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewPricePlan
Visual Basic
Public Const ViewPricePlan As String
Visual C++
public:
literal String^ ViewPricePlan

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewProductAnalyticsAudit Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewProductAnalyticsAudit Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewProductAnalyticsAudit
Visual Basic
Public Const ViewProductAnalyticsAudit As String
Visual C++
public:
literal String^ ViewProductAnalyticsAudit

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewRule Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewRule Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewRule
Visual Basic
Public Const ViewRule As String
Visual C++
public:
literal String^ ViewRule

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewUsageAudit Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewUsageAudit Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewUsageAudit
Visual Basic
Public Const ViewUsageAudit As String
Visual C++
public:
literal String^ ViewUsageAudit

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewUserEntityPermission Field

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewUserEntityPermission Field
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewUserEntityPermission
Visual Basic
Public Const ViewUserEntityPermission As String
Visual C++
public:
literal String^ ViewUserEntityPermission

Field Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants Properties

[image] [image]

A Sandcastle Documented Class Library
PrivilegeConstants Properties
PrivilegeConstants Class See Also Send Feedback

The PrivilegeConstants type exposes the following members.

Properties

Name | Description
AddMasterData |
AddPackage |
AddPackageSettings |
AddPickupList |
AddPickupListValue |
AddRole |
AddRoleFeature |
AddRolePrivilege |
AddRoleSettings |
AddTenant |
AddTenantSettings |
AddUser |
AddUserRole |
AddUserSettings |
DeleteMasterData |
DeletePackage |
DeletePackageSettings |
DeletePickupList |
DeletePickupListValue |
DeleteRole |
DeleteRoleFeature |
DeleteRolePrivilege |
DeleteRoleSettings |
DeleteTenant |
DeleteTenantSettings |
DeleteUser |
DeleteUserRole |
DeleteUserSettings |
EditSelfUser |
ForcePasswordExpiry |
InsertTenantLicense |
LockUser |
ResetPINUser |
SearchOtherTenantRoles |
SearchOtherTenantUsers |
SearchRole |
SearchTenant |
SearchUser |
UnLockUser |
UpdateMasterData |
UpdatePackage |
UpdatePackageSettings |
UpdatePickupList |
UpdatePickupListValue |
UpdateRole |
UpdateRoleFeature |
UpdateRolePrivilege |
UpdateRoleSettings |
UpdateTenant |
UpdateTenantLicense |
UpdateTenantSettings |
UpdateUser |
UpdateUserSettings |
ViewChildRelationData |
ViewMasterData |
ViewPackage |
ViewPackageSettings |
ViewPickupList |
ViewPickupListValue |
ViewRole |
ViewRoleFeature |
ViewRolePrivilege |
ViewRoleSettings |
ViewSelfUser |
ViewTenant |
ViewTenantLicense |
ViewTenantSettings |
ViewUser |
ViewUserSettings |

See Also

PrivilegeConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddMasterData Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddMasterData Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddMasterData { get; }
Visual Basic
Public Shared ReadOnly Property AddMasterData As String
    Get
Visual C++
public:
static property String^ AddMasterData {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddPackage Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddPackage Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddPackage { get; }
Visual Basic
Public Shared ReadOnly Property AddPackage As String
    Get
Visual C++
public:
static property String^ AddPackage {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddPackageSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddPackageSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddPackageSettings { get; }
Visual Basic
Public Shared ReadOnly Property AddPackageSettings As String
    Get
Visual C++
public:
static property String^ AddPackageSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddPickupList Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddPickupList Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddPickupList { get; }
Visual Basic
Public Shared ReadOnly Property AddPickupList As String
    Get
Visual C++
public:
static property String^ AddPickupList {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddPickupListValue Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddPickupListValue Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddPickupListValue { get; }
Visual Basic
Public Shared ReadOnly Property AddPickupListValue As String
    Get
Visual C++
public:
static property String^ AddPickupListValue {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddRole { get; }
Visual Basic
Public Shared ReadOnly Property AddRole As String
    Get
Visual C++
public:
static property String^ AddRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddRoleFeature Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddRoleFeature Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddRoleFeature { get; }
Visual Basic
Public Shared ReadOnly Property AddRoleFeature As String
    Get
Visual C++
public:
static property String^ AddRoleFeature {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddRolePrivilege Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddRolePrivilege Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddRolePrivilege { get; }
Visual Basic
Public Shared ReadOnly Property AddRolePrivilege As String
    Get
Visual C++
public:
static property String^ AddRolePrivilege {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddRoleSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddRoleSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddRoleSettings { get; }
Visual Basic
Public Shared ReadOnly Property AddRoleSettings As String
    Get
Visual C++
public:
static property String^ AddRoleSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddTenant Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddTenant Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddTenant { get; }
Visual Basic
Public Shared ReadOnly Property AddTenant As String
    Get
Visual C++
public:
static property String^ AddTenant {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddTenantSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddTenantSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddTenantSettings { get; }
Visual Basic
Public Shared ReadOnly Property AddTenantSettings As String
    Get
Visual C++
public:
static property String^ AddTenantSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddUser { get; }
Visual Basic
Public Shared ReadOnly Property AddUser As String
    Get
Visual C++
public:
static property String^ AddUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddUserRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddUserRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddUserRole { get; }
Visual Basic
Public Shared ReadOnly Property AddUserRole As String
    Get
Visual C++
public:
static property String^ AddUserRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.AddUserSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..AddUserSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string AddUserSettings { get; }
Visual Basic
Public Shared ReadOnly Property AddUserSettings As String
    Get
Visual C++
public:
static property String^ AddUserSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteMasterData Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteMasterData Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteMasterData { get; }
Visual Basic
Public Shared ReadOnly Property DeleteMasterData As String
    Get
Visual C++
public:
static property String^ DeleteMasterData {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeletePackage Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeletePackage Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeletePackage { get; }
Visual Basic
Public Shared ReadOnly Property DeletePackage As String
    Get
Visual C++
public:
static property String^ DeletePackage {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeletePackageSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeletePackageSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeletePackageSettings { get; }
Visual Basic
Public Shared ReadOnly Property DeletePackageSettings As String
    Get
Visual C++
public:
static property String^ DeletePackageSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeletePickupList Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeletePickupList Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeletePickupList { get; }
Visual Basic
Public Shared ReadOnly Property DeletePickupList As String
    Get
Visual C++
public:
static property String^ DeletePickupList {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeletePickupListValue Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeletePickupListValue Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeletePickupListValue { get; }
Visual Basic
Public Shared ReadOnly Property DeletePickupListValue As String
    Get
Visual C++
public:
static property String^ DeletePickupListValue {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteRole { get; }
Visual Basic
Public Shared ReadOnly Property DeleteRole As String
    Get
Visual C++
public:
static property String^ DeleteRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteRoleFeature Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteRoleFeature Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteRoleFeature { get; }
Visual Basic
Public Shared ReadOnly Property DeleteRoleFeature As String
    Get
Visual C++
public:
static property String^ DeleteRoleFeature {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteRolePrivilege Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteRolePrivilege Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteRolePrivilege { get; }
Visual Basic
Public Shared ReadOnly Property DeleteRolePrivilege As String
    Get
Visual C++
public:
static property String^ DeleteRolePrivilege {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteRoleSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteRoleSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteRoleSettings { get; }
Visual Basic
Public Shared ReadOnly Property DeleteRoleSettings As String
    Get
Visual C++
public:
static property String^ DeleteRoleSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteTenant Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteTenant Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteTenant { get; }
Visual Basic
Public Shared ReadOnly Property DeleteTenant As String
    Get
Visual C++
public:
static property String^ DeleteTenant {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteTenantSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteTenantSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteTenantSettings { get; }
Visual Basic
Public Shared ReadOnly Property DeleteTenantSettings As String
    Get
Visual C++
public:
static property String^ DeleteTenantSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteUser { get; }
Visual Basic
Public Shared ReadOnly Property DeleteUser As String
    Get
Visual C++
public:
static property String^ DeleteUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteUserRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteUserRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteUserRole { get; }
Visual Basic
Public Shared ReadOnly Property DeleteUserRole As String
    Get
Visual C++
public:
static property String^ DeleteUserRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.DeleteUserSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..DeleteUserSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string DeleteUserSettings { get; }
Visual Basic
Public Shared ReadOnly Property DeleteUserSettings As String
    Get
Visual C++
public:
static property String^ DeleteUserSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.EditSelfUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..EditSelfUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string EditSelfUser { get; }
Visual Basic
Public Shared ReadOnly Property EditSelfUser As String
    Get
Visual C++
public:
static property String^ EditSelfUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ForcePasswordExpiry Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ForcePasswordExpiry Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ForcePasswordExpiry { get; }
Visual Basic
Public Shared ReadOnly Property ForcePasswordExpiry As String
    Get
Visual C++
public:
static property String^ ForcePasswordExpiry {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.InsertTenantLicense Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..InsertTenantLicense Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string InsertTenantLicense { get; }
Visual Basic
Public Shared ReadOnly Property InsertTenantLicense As String
    Get
Visual C++
public:
static property String^ InsertTenantLicense {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.LockUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..LockUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string LockUser { get; }
Visual Basic
Public Shared ReadOnly Property LockUser As String
    Get
Visual C++
public:
static property String^ LockUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ResetPINUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ResetPINUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ResetPINUser { get; }
Visual Basic
Public Shared ReadOnly Property ResetPINUser As String
    Get
Visual C++
public:
static property String^ ResetPINUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SearchOtherTenantRoles Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SearchOtherTenantRoles Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string SearchOtherTenantRoles { get; }
Visual Basic
Public Shared ReadOnly Property SearchOtherTenantRoles As String
    Get
Visual C++
public:
static property String^ SearchOtherTenantRoles {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SearchOtherTenantUsers Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SearchOtherTenantUsers Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string SearchOtherTenantUsers { get; }
Visual Basic
Public Shared ReadOnly Property SearchOtherTenantUsers As String
    Get
Visual C++
public:
static property String^ SearchOtherTenantUsers {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SearchRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SearchRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string SearchRole { get; }
Visual Basic
Public Shared ReadOnly Property SearchRole As String
    Get
Visual C++
public:
static property String^ SearchRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SearchTenant Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SearchTenant Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string SearchTenant { get; }
Visual Basic
Public Shared ReadOnly Property SearchTenant As String
    Get
Visual C++
public:
static property String^ SearchTenant {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.SearchUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..SearchUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string SearchUser { get; }
Visual Basic
Public Shared ReadOnly Property SearchUser As String
    Get
Visual C++
public:
static property String^ SearchUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UnLockUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UnLockUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UnLockUser { get; }
Visual Basic
Public Shared ReadOnly Property UnLockUser As String
    Get
Visual C++
public:
static property String^ UnLockUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateMasterData Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateMasterData Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateMasterData { get; }
Visual Basic
Public Shared ReadOnly Property UpdateMasterData As String
    Get
Visual C++
public:
static property String^ UpdateMasterData {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdatePackage Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdatePackage Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdatePackage { get; }
Visual Basic
Public Shared ReadOnly Property UpdatePackage As String
    Get
Visual C++
public:
static property String^ UpdatePackage {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdatePackageSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdatePackageSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdatePackageSettings { get; }
Visual Basic
Public Shared ReadOnly Property UpdatePackageSettings As String
    Get
Visual C++
public:
static property String^ UpdatePackageSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdatePickupList Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdatePickupList Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdatePickupList { get; }
Visual Basic
Public Shared ReadOnly Property UpdatePickupList As String
    Get
Visual C++
public:
static property String^ UpdatePickupList {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdatePickupListValue Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdatePickupListValue Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdatePickupListValue { get; }
Visual Basic
Public Shared ReadOnly Property UpdatePickupListValue As String
    Get
Visual C++
public:
static property String^ UpdatePickupListValue {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateRole { get; }
Visual Basic
Public Shared ReadOnly Property UpdateRole As String
    Get
Visual C++
public:
static property String^ UpdateRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateRoleFeature Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateRoleFeature Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateRoleFeature { get; }
Visual Basic
Public Shared ReadOnly Property UpdateRoleFeature As String
    Get
Visual C++
public:
static property String^ UpdateRoleFeature {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateRolePrivilege Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateRolePrivilege Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateRolePrivilege { get; }
Visual Basic
Public Shared ReadOnly Property UpdateRolePrivilege As String
    Get
Visual C++
public:
static property String^ UpdateRolePrivilege {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateRoleSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateRoleSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateRoleSettings { get; }
Visual Basic
Public Shared ReadOnly Property UpdateRoleSettings As String
    Get
Visual C++
public:
static property String^ UpdateRoleSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateTenant Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateTenant Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateTenant { get; }
Visual Basic
Public Shared ReadOnly Property UpdateTenant As String
    Get
Visual C++
public:
static property String^ UpdateTenant {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateTenantLicense Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateTenantLicense Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateTenantLicense { get; }
Visual Basic
Public Shared ReadOnly Property UpdateTenantLicense As String
    Get
Visual C++
public:
static property String^ UpdateTenantLicense {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateTenantSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateTenantSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateTenantSettings { get; }
Visual Basic
Public Shared ReadOnly Property UpdateTenantSettings As String
    Get
Visual C++
public:
static property String^ UpdateTenantSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateUser { get; }
Visual Basic
Public Shared ReadOnly Property UpdateUser As String
    Get
Visual C++
public:
static property String^ UpdateUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.UpdateUserSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..UpdateUserSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string UpdateUserSettings { get; }
Visual Basic
Public Shared ReadOnly Property UpdateUserSettings As String
    Get
Visual C++
public:
static property String^ UpdateUserSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewChildRelationData Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewChildRelationData Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewChildRelationData { get; }
Visual Basic
Public Shared ReadOnly Property ViewChildRelationData As String
    Get
Visual C++
public:
static property String^ ViewChildRelationData {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewMasterData Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewMasterData Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewMasterData { get; }
Visual Basic
Public Shared ReadOnly Property ViewMasterData As String
    Get
Visual C++
public:
static property String^ ViewMasterData {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewPackage Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewPackage Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewPackage { get; }
Visual Basic
Public Shared ReadOnly Property ViewPackage As String
    Get
Visual C++
public:
static property String^ ViewPackage {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewPackageSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewPackageSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewPackageSettings { get; }
Visual Basic
Public Shared ReadOnly Property ViewPackageSettings As String
    Get
Visual C++
public:
static property String^ ViewPackageSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewPickupList Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewPickupList Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewPickupList { get; }
Visual Basic
Public Shared ReadOnly Property ViewPickupList As String
    Get
Visual C++
public:
static property String^ ViewPickupList {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewPickupListValue Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewPickupListValue Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewPickupListValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewPickupListValue As String
    Get
Visual C++
public:
static property String^ ViewPickupListValue {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewRole Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewRole Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewRole { get; }
Visual Basic
Public Shared ReadOnly Property ViewRole As String
    Get
Visual C++
public:
static property String^ ViewRole {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewRoleFeature Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewRoleFeature Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewRoleFeature { get; }
Visual Basic
Public Shared ReadOnly Property ViewRoleFeature As String
    Get
Visual C++
public:
static property String^ ViewRoleFeature {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewRolePrivilege Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewRolePrivilege Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewRolePrivilege { get; }
Visual Basic
Public Shared ReadOnly Property ViewRolePrivilege As String
    Get
Visual C++
public:
static property String^ ViewRolePrivilege {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewRoleSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewRoleSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewRoleSettings { get; }
Visual Basic
Public Shared ReadOnly Property ViewRoleSettings As String
    Get
Visual C++
public:
static property String^ ViewRoleSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewSelfUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewSelfUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewSelfUser { get; }
Visual Basic
Public Shared ReadOnly Property ViewSelfUser As String
    Get
Visual C++
public:
static property String^ ViewSelfUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewTenant Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewTenant Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewTenant { get; }
Visual Basic
Public Shared ReadOnly Property ViewTenant As String
    Get
Visual C++
public:
static property String^ ViewTenant {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewTenantLicense Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewTenantLicense Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewTenantLicense { get; }
Visual Basic
Public Shared ReadOnly Property ViewTenantLicense As String
    Get
Visual C++
public:
static property String^ ViewTenantLicense {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewTenantSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewTenantSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewTenantSettings { get; }
Visual Basic
Public Shared ReadOnly Property ViewTenantSettings As String
    Get
Visual C++
public:
static property String^ ViewTenantSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewUser Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewUser Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewUser { get; }
Visual Basic
Public Shared ReadOnly Property ViewUser As String
    Get
Visual C++
public:
static property String^ ViewUser {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeConstants.ViewUserSettings Property

[image]

A Sandcastle Documented Class Library
PrivilegeConstants..::..ViewUserSettings Property
PrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ViewUserSettings { get; }
Visual Basic
Public Shared ReadOnly Property ViewUserSettings As String
    Get
Visual C++
public:
static property String^ ViewUserSettings {
    String^ get ();
}

Property Value

Type: String

See Also

PrivilegeConstants Class
PrivilegeConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeException Class

[image]

A Sandcastle Documented Class Library
PrivilegeException Class
Members See Also Send Feedback
Privilege Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PrivilegeException : BaseException
Visual Basic
<SerializableAttribute>
Public Class PrivilegeException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PrivilegeException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException

See Also

PrivilegeException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeException Members

[image] [image]

A Sandcastle Documented Class Library
PrivilegeException Members
PrivilegeException Class Constructors Methods Properties Events See Also Send Feedback

The PrivilegeException type exposes the following members.

Constructors

 | Name | Description
Public method | PrivilegeException | Initializes a new instance of the PrivilegeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PrivilegeException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeException Constructor

[image]

A Sandcastle Documented Class Library
PrivilegeException Constructor
PrivilegeException Class See Also Send Feedback
Initializes a new instance of the PrivilegeException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PrivilegeException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
PrivilegeException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

PrivilegeException Class
PrivilegeException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeException Methods

[image] [image]

A Sandcastle Documented Class Library
PrivilegeException Methods
PrivilegeException Class See Also Send Feedback

The PrivilegeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PrivilegeException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeException Properties

[image] [image]

A Sandcastle Documented Class Library
PrivilegeException Properties
PrivilegeException Class See Also Send Feedback

The PrivilegeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PrivilegeException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


PrivilegeException Events

[image] [image]

A Sandcastle Documented Class Library
PrivilegeException Events
PrivilegeException Class See Also Send Feedback

The PrivilegeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PrivilegeException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants Class

[image]

A Sandcastle Documented Class Library
ProductAdminConstants Class
Members See Also Send Feedback
ProductAdmin Constants

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class ProductAdminConstants
Visual Basic
Public NotInheritable Class ProductAdminConstants
Visual C++
public ref class ProductAdminConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.AccessControlManagement..::..ProductAdminConstants

See Also

ProductAdminConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants Members

[image] [image]

A Sandcastle Documented Class Library
ProductAdminConstants Members
ProductAdminConstants Class Fields Properties See Also Send Feedback

The ProductAdminConstants type exposes the following members.

Fields

Name | Description
ProductAdminTenantId | Product Admin TenantId
ProductAdminUserId | Product Admin UserId
ProductAdminUserName | Product Admin UserName
ProductAdminWCFApiKey | Product Admin WCF API Key

Properties

Name | Description
IsProductAdminTenant | Gets a value indicating whether this instance is product admin tenant.

See Also

ProductAdminConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants Fields

[image] [image]

A Sandcastle Documented Class Library
ProductAdminConstants Fields
ProductAdminConstants Class See Also Send Feedback

The ProductAdminConstants type exposes the following members.

Fields

Name | Description
ProductAdminTenantId | Product Admin TenantId
ProductAdminUserId | Product Admin UserId
ProductAdminUserName | Product Admin UserName
ProductAdminWCFApiKey | Product Admin WCF API Key

See Also

ProductAdminConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants.ProductAdminTenantId Field

[image]

A Sandcastle Documented Class Library
ProductAdminConstants..::..ProductAdminTenantId Field
ProductAdminConstants Class See Also Send Feedback
Product Admin TenantId

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ProductAdminTenantId
Visual Basic
Public Shared ProductAdminTenantId As String
Visual C++
public:
static String^ ProductAdminTenantId

Field Value

Type: String

See Also

ProductAdminConstants Class
ProductAdminConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants.ProductAdminUserId Field

[image]

A Sandcastle Documented Class Library
ProductAdminConstants..::..ProductAdminUserId Field
ProductAdminConstants Class See Also Send Feedback
Product Admin UserId

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ProductAdminUserId
Visual Basic
Public Shared ProductAdminUserId As String
Visual C++
public:
static String^ ProductAdminUserId

Field Value

Type: String

See Also

ProductAdminConstants Class
ProductAdminConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants.ProductAdminUserName Field

[image]

A Sandcastle Documented Class Library
ProductAdminConstants..::..ProductAdminUserName Field
ProductAdminConstants Class See Also Send Feedback
Product Admin UserName

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ProductAdminUserName
Visual Basic
Public Shared ProductAdminUserName As String
Visual C++
public:
static String^ ProductAdminUserName

Field Value

Type: String

See Also

ProductAdminConstants Class
ProductAdminConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants.ProductAdminWCFApiKey Field

[image]

A Sandcastle Documented Class Library
ProductAdminConstants..::..ProductAdminWCFApiKey Field
ProductAdminConstants Class See Also Send Feedback
Product Admin WCF API Key

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static string ProductAdminWCFApiKey
Visual Basic
Public Shared ProductAdminWCFApiKey As String
Visual C++
public:
static String^ ProductAdminWCFApiKey

Field Value

Type: String

See Also

ProductAdminConstants Class
ProductAdminConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants Properties

[image] [image]

A Sandcastle Documented Class Library
ProductAdminConstants Properties
ProductAdminConstants Class See Also Send Feedback

The ProductAdminConstants type exposes the following members.

Properties

Name | Description
IsProductAdminTenant | Gets a value indicating whether this instance is product admin tenant.

See Also

ProductAdminConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


ProductAdminConstants.IsProductAdminTenant Property

[image]

A Sandcastle Documented Class Library
ProductAdminConstants..::..IsProductAdminTenant Property
ProductAdminConstants Class See Also Send Feedback
Gets a value indicating whether this instance is product admin tenant.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static bool IsProductAdminTenant { get; }
Visual Basic
Public Shared ReadOnly Property IsProductAdminTenant As Boolean
    Get
Visual C++
public:
static property bool IsProductAdminTenant {
    bool get ();
}

Property Value

Type: Boolean
true if this instance is product admin tenant; otherwise, false.

See Also

ProductAdminConstants Class
ProductAdminConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants Class

[image]

A Sandcastle Documented Class Library
RoleConstants Class
Members See Also Send Feedback
Role Constants

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class RoleConstants
Visual Basic
Public Class RoleConstants
Visual C++
public ref class RoleConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleConstants

See Also

RoleConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants Members

[image] [image]

A Sandcastle Documented Class Library
RoleConstants Members
RoleConstants Class Constructors Methods Fields See Also Send Feedback

The RoleConstants type exposes the following members.

Constructors

 | Name | Description
Public method | RoleConstants | Initializes a new instance of the RoleConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Member | User Member role constant
ProductAdmin | Product admin role constant
ServiceAdmin | Service admin role constant
TenantAdmin | Tenant admin role constant

See Also

RoleConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants Constructor

[image]

A Sandcastle Documented Class Library
RoleConstants Constructor
RoleConstants Class See Also Send Feedback
Initializes a new instance of the RoleConstants class

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleConstants()
Visual Basic
Public Sub New
Visual C++
public:
RoleConstants()

See Also

RoleConstants Class
RoleConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants Fields

[image] [image]

A Sandcastle Documented Class Library
RoleConstants Fields
RoleConstants Class See Also Send Feedback

The RoleConstants type exposes the following members.

Fields

Name | Description
Member | User Member role constant
ProductAdmin | Product admin role constant
ServiceAdmin | Service admin role constant
TenantAdmin | Tenant admin role constant

See Also

RoleConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants.Member Field

[image]

A Sandcastle Documented Class Library
RoleConstants..::..Member Field
RoleConstants Class See Also Send Feedback
User Member role constant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Member
Visual Basic
Public Const Member As String
Visual C++
public:
literal String^ Member

Field Value

Type: String

See Also

RoleConstants Class
RoleConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants.ProductAdmin Field

[image]

A Sandcastle Documented Class Library
RoleConstants..::..ProductAdmin Field
RoleConstants Class See Also Send Feedback
Product admin role constant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ProductAdmin
Visual Basic
Public Const ProductAdmin As String
Visual C++
public:
literal String^ ProductAdmin

Field Value

Type: String

See Also

RoleConstants Class
RoleConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants.ServiceAdmin Field

[image]

A Sandcastle Documented Class Library
RoleConstants..::..ServiceAdmin Field
RoleConstants Class See Also Send Feedback
Service admin role constant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ServiceAdmin
Visual Basic
Public Const ServiceAdmin As String
Visual C++
public:
literal String^ ServiceAdmin

Field Value

Type: String

See Also

RoleConstants Class
RoleConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants.TenantAdmin Field

[image]

A Sandcastle Documented Class Library
RoleConstants..::..TenantAdmin Field
RoleConstants Class See Also Send Feedback
Tenant admin role constant

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantAdmin
Visual Basic
Public Const TenantAdmin As String
Visual C++
public:
literal String^ TenantAdmin

Field Value

Type: String

See Also

RoleConstants Class
RoleConstants Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleConstants Methods

[image] [image]

A Sandcastle Documented Class Library
RoleConstants Methods
RoleConstants Class See Also Send Feedback

The RoleConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoleConstants Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Class

[image]

A Sandcastle Documented Class Library
RoleException Class
Members See Also Send Feedback
Role Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoleException : BaseException
Visual Basic
<SerializableAttribute>
Public Class RoleException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class RoleException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.AccessControlManagement..::..RoleException

See Also

RoleException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Members

[image] [image]

A Sandcastle Documented Class Library
RoleException Members
RoleException Class Constructors Methods Properties Events See Also Send Feedback

The RoleException type exposes the following members.

Constructors

 | Name | Description
Public method | RoleException(String) | Initializes a new instance of the RoleException class.
Public method | RoleException(String, Exception) | Initializes a new instance of the RoleException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RoleException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Constructor

[image] [image]

A Sandcastle Documented Class Library
RoleException Constructor
RoleException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RoleException(String) | Initializes a new instance of the RoleException class.
Public method | RoleException(String, Exception) | Initializes a new instance of the RoleException class.

See Also

RoleException Class
RoleException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Constructor (String)

[image]

A Sandcastle Documented Class Library
RoleException Constructor (String)
RoleException Class See Also Send Feedback
Initializes a new instance of the RoleException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
RoleException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

RoleException Class
RoleException Members
RoleException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
RoleException Constructor (String, Exception)
RoleException Class See Also Send Feedback
Initializes a new instance of the RoleException class.

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
RoleException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

RoleException Class
RoleException Members
RoleException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Methods

[image] [image]

A Sandcastle Documented Class Library
RoleException Methods
RoleException Class See Also Send Feedback

The RoleException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RoleException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Properties

[image] [image]

A Sandcastle Documented Class Library
RoleException Properties
RoleException Class See Also Send Feedback

The RoleException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RoleException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


RoleException Events

[image] [image]

A Sandcastle Documented Class Library
RoleException Events
RoleException Class See Also Send Feedback

The RoleException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RoleException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Class

[image]

A Sandcastle Documented Class Library
UserEntityPermissionException Class
Members See Also Send Feedback
UserEntityPermission Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class UserEntityPermissionException : BaseException
Visual Basic
Public Class UserEntityPermissionException
    Inherits BaseException
Visual C++
public ref class UserEntityPermissionException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.AccessControlManagement..::..UserEntityPermissionException

See Also

UserEntityPermissionException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Members

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionException Members
UserEntityPermissionException Class Constructors Methods Properties Events See Also Send Feedback

The UserEntityPermissionException type exposes the following members.

Constructors

 | Name | Description
Public method | UserEntityPermissionException()()()() | UserEntityPermission Exception
Public method | UserEntityPermissionException(String) | UserEntityPermission Exception
Public method | UserEntityPermissionException(String, Exception) | UserEntityPermission Exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserEntityPermissionException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionException Constructor
UserEntityPermissionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserEntityPermissionException()()()() | UserEntityPermission Exception
Public method | UserEntityPermissionException(String) | UserEntityPermission Exception
Public method | UserEntityPermissionException(String, Exception) | UserEntityPermission Exception

See Also

UserEntityPermissionException Class
UserEntityPermissionException Members
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Constructor

[image]

A Sandcastle Documented Class Library
UserEntityPermissionException Constructor
UserEntityPermissionException Class See Also Send Feedback
UserEntityPermission Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserEntityPermissionException()
Visual Basic
Public Sub New
Visual C++
public:
UserEntityPermissionException()

See Also

UserEntityPermissionException Class
UserEntityPermissionException Members
UserEntityPermissionException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserEntityPermissionException Constructor (String)
UserEntityPermissionException Class See Also Send Feedback
UserEntityPermission Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserEntityPermissionException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserEntityPermissionException(
    String^ message
)

Parameters

message
Type: System..::..String
message

See Also

UserEntityPermissionException Class
UserEntityPermissionException Members
UserEntityPermissionException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
UserEntityPermissionException Constructor (String, Exception)
UserEntityPermissionException Class See Also Send Feedback
UserEntityPermission Exception

Namespace: CelloSaaS.ServiceContracts.AccessControlManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserEntityPermissionException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
UserEntityPermissionException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
message
innerException
Type: System..::..Exception
innerException

See Also

UserEntityPermissionException Class
UserEntityPermissionException Members
UserEntityPermissionException Overload
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Methods

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionException Methods
UserEntityPermissionException Class See Also Send Feedback

The UserEntityPermissionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserEntityPermissionException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Properties

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionException Properties
UserEntityPermissionException Class See Also Send Feedback

The UserEntityPermissionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserEntityPermissionException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


UserEntityPermissionException Events

[image] [image]

A Sandcastle Documented Class Library
UserEntityPermissionException Events
UserEntityPermissionException Class See Also Send Feedback

The UserEntityPermissionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserEntityPermissionException Class
CelloSaaS.ServiceContracts.AccessControlManagement Namespace


CelloSaaS.ServiceContracts.Configuration Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.Configuration Namespace
Send Feedback

Classes

 | Class | Description
Public class | DuplicateRelationshipMetaDataException | This exception is used to catch Duplicate Name of Relationship Meta Data
Public class | ModuleConfigurationSettingException | Thrown in case of any exception occurred while getting the module configuration settings
Public class | PickupListException | This exception is used to catch pickup list exception
Public class | PickupListValueDuplicateNameException | This exception is used to catch Duplicate Name of pickup list value
Public class | PickupListValueDuplicateValueException | This exception is used to catch Duplicate value of pickup list value

Interfaces

 | Interface | Description
Public interface | IModuleConfigurationSettingService | This interface defines methods for configuration settings
Public interface | IPickupListService | This interface defines methods for Pickup List and Pickup List Value details.


DuplicateRelationshipMetaDataException Class

[image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Class
Members See Also Send Feedback
This exception is used to catch Duplicate Name of Relationship Meta Data

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateRelationshipMetaDataException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateRelationshipMetaDataException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateRelationshipMetaDataException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Configuration..::..DuplicateRelationshipMetaDataException

See Also

DuplicateRelationshipMetaDataException Members
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Members
DuplicateRelationshipMetaDataException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateRelationshipMetaDataException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateRelationshipMetaDataException()()()() | Initializes a new instance of the DuplicateRelationshipMetaDataException class.
Public method | DuplicateRelationshipMetaDataException(String) | Initializes a new instance of the DuplicateRelationshipMetaDataException class.
Public method | DuplicateRelationshipMetaDataException(String, Exception) | Initializes a new instance of the DuplicateRelationshipMetaDataException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateRelationshipMetaDataException Class
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Constructor
DuplicateRelationshipMetaDataException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateRelationshipMetaDataException()()()() | Initializes a new instance of the DuplicateRelationshipMetaDataException class.
Public method | DuplicateRelationshipMetaDataException(String) | Initializes a new instance of the DuplicateRelationshipMetaDataException class.
Public method | DuplicateRelationshipMetaDataException(String, Exception) | Initializes a new instance of the DuplicateRelationshipMetaDataException class.

See Also

DuplicateRelationshipMetaDataException Class
DuplicateRelationshipMetaDataException Members
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Constructor
DuplicateRelationshipMetaDataException Class See Also Send Feedback
Initializes a new instance of the DuplicateRelationshipMetaDataException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateRelationshipMetaDataException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateRelationshipMetaDataException()

See Also

DuplicateRelationshipMetaDataException Class
DuplicateRelationshipMetaDataException Members
DuplicateRelationshipMetaDataException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Constructor (String)
DuplicateRelationshipMetaDataException Class See Also Send Feedback
Initializes a new instance of the DuplicateRelationshipMetaDataException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateRelationshipMetaDataException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateRelationshipMetaDataException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateRelationshipMetaDataException Class
DuplicateRelationshipMetaDataException Members
DuplicateRelationshipMetaDataException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Constructor (String, Exception)
DuplicateRelationshipMetaDataException Class See Also Send Feedback
Initializes a new instance of the DuplicateRelationshipMetaDataException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateRelationshipMetaDataException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateRelationshipMetaDataException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

DuplicateRelationshipMetaDataException Class
DuplicateRelationshipMetaDataException Members
DuplicateRelationshipMetaDataException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Methods
DuplicateRelationshipMetaDataException Class See Also Send Feedback

The DuplicateRelationshipMetaDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateRelationshipMetaDataException Class
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Properties
DuplicateRelationshipMetaDataException Class See Also Send Feedback

The DuplicateRelationshipMetaDataException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateRelationshipMetaDataException Class
CelloSaaS.ServiceContracts.Configuration Namespace


DuplicateRelationshipMetaDataException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateRelationshipMetaDataException Events
DuplicateRelationshipMetaDataException Class See Also Send Feedback

The DuplicateRelationshipMetaDataException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateRelationshipMetaDataException Class
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService Interface

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService Interface
Members See Also Send Feedback
This interface defines methods for configuration settings

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IModuleConfigurationSettingService
Visual Basic
Public Interface IModuleConfigurationSettingService
Visual C++
public interface class IModuleConfigurationSettingService

See Also

IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService Members

[image] [image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService Members
IModuleConfigurationSettingService Interface Methods See Also Send Feedback

The IModuleConfigurationSettingService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteModuleConfigurationSetting(String) | This method is used to remove the module configuration setting for particular tenant
Public method | DeleteModuleConfigurationSetting(String, String) | This method is used to remove the module configuration setting for particular tenant and configuration
Public method | GetAllModuleConfiguration | This method is used to get all module configuration settings.
Public method | GetModuleConfigurationSettingIdValuePair | This method is used to get the module configuration setting in key value pair format
Public method | GetModuleConfigurationSettingValue(String) | This method is used to get the module configuration setting value based on particular tenant
Public method | GetModuleConfigurationSettingValue(String, String) | This method is used to get the module configuration setting value based on particular tenant and configuration
Public method | GetTenantByModuleConfigurationSettingValue | This method is used to get the tenant by module configuration setting value.
Public method | UpdateModuleConfigurationSetting(String, Dictionary<(Of <<'(String, String>)>>)) | This method is used to update the module configuration setting with configuration id and value in key value pair format as input
Public method | UpdateModuleConfigurationSetting(String, String, String) | This method is used to update the module configuration setting with configuration id and value as input

See Also

IModuleConfigurationSettingService Interface
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService Methods

[image] [image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService Methods
IModuleConfigurationSettingService Interface See Also Send Feedback

The IModuleConfigurationSettingService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteModuleConfigurationSetting(String) | This method is used to remove the module configuration setting for particular tenant
Public method | DeleteModuleConfigurationSetting(String, String) | This method is used to remove the module configuration setting for particular tenant and configuration
Public method | GetAllModuleConfiguration | This method is used to get all module configuration settings.
Public method | GetModuleConfigurationSettingIdValuePair | This method is used to get the module configuration setting in key value pair format
Public method | GetModuleConfigurationSettingValue(String) | This method is used to get the module configuration setting value based on particular tenant
Public method | GetModuleConfigurationSettingValue(String, String) | This method is used to get the module configuration setting value based on particular tenant and configuration
Public method | GetTenantByModuleConfigurationSettingValue | This method is used to get the tenant by module configuration setting value.
Public method | UpdateModuleConfigurationSetting(String, Dictionary<(Of <<'(String, String>)>>)) | This method is used to update the module configuration setting with configuration id and value in key value pair format as input
Public method | UpdateModuleConfigurationSetting(String, String, String) | This method is used to update the module configuration setting with configuration id and value as input

See Also

IModuleConfigurationSettingService Interface
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.DeleteModuleConfigurationSetting Method

[image] [image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..DeleteModuleConfigurationSetting Method
IModuleConfigurationSettingService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteModuleConfigurationSetting(String) | This method is used to remove the module configuration setting for particular tenant
Public method | DeleteModuleConfigurationSetting(String, String) | This method is used to remove the module configuration setting for particular tenant and configuration

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.DeleteModuleConfigurationSetting Method (String)

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..DeleteModuleConfigurationSetting Method (String)
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to remove the module configuration setting for particular tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteModuleConfigurationSetting(
    string tenantId
)
Visual Basic
Sub DeleteModuleConfigurationSetting (
    tenantId As String
)
Visual C++
void DeleteModuleConfigurationSetting(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while deleting module configuration settings
System..::..ArgumentNullException | This exception is thrown when tenantId is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
DeleteModuleConfigurationSetting Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.DeleteModuleConfigurationSetting Method (String, String)

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..DeleteModuleConfigurationSetting Method (String, String)
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to remove the module configuration setting for particular tenant and configuration

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteModuleConfigurationSetting(
    string tenantId,
    string configurationId
)
Visual Basic
Sub DeleteModuleConfigurationSetting (
    tenantId As String,
    configurationId As String
)
Visual C++
void DeleteModuleConfigurationSetting(
    String^ tenantId,
    String^ configurationId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationId
Type: System..::..String
The configuration id.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown deleting fetching module configuration settings
System..::..ArgumentNullException | This exception is thrown when tenantId or configurationId or value is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
DeleteModuleConfigurationSetting Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.GetAllModuleConfiguration Method

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..GetAllModuleConfiguration Method
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to get all module configuration settings.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, ModuleConfiguration> GetAllModuleConfiguration()
Visual Basic
Function GetAllModuleConfiguration As Dictionary(Of String, ModuleConfiguration)
Visual C++
Dictionary<String^, ModuleConfiguration^>^ GetAllModuleConfiguration()

Return Value

Type: Dictionary<(Of <(<'String, ModuleConfiguration >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while fetching module configuration settings

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.GetModuleConfigurationSettingIdValuePair Method

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..GetModuleConfigurationSettingIdValuePair Method
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to get the module configuration setting in key value pair format

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string> GetModuleConfigurationSettingIdValuePair(
    string tenantId,
    string[] configurationIds
)
Visual Basic
Function GetModuleConfigurationSettingIdValuePair (
    tenantId As String,
    configurationIds As String()
) As Dictionary(Of String, String)
Visual C++
Dictionary<String^, String^>^ GetModuleConfigurationSettingIdValuePair(
    String^ tenantId,
    array<String^>^ configurationIds
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationIds
Type: array<System..::..String>[]()[][]
The configuration ids.

Return Value

Type: Dictionary<(Of <(<'String, String>)>)>

Exceptions

Exception | Condition
System..::..NotImplementedException | This exception is thrown when this method is not implemented

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.GetModuleConfigurationSettingValue Method

[image] [image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..GetModuleConfigurationSettingValue Method
IModuleConfigurationSettingService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetModuleConfigurationSettingValue(String) | This method is used to get the module configuration setting value based on particular tenant
Public method | GetModuleConfigurationSettingValue(String, String) | This method is used to get the module configuration setting value based on particular tenant and configuration

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.GetModuleConfigurationSettingValue Method (String)

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..GetModuleConfigurationSettingValue Method (String)
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to get the module configuration setting value based on particular tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string> GetModuleConfigurationSettingValue(
    string tenantId
)
Visual Basic
Function GetModuleConfigurationSettingValue (
    tenantId As String
) As Dictionary(Of String, String)
Visual C++
Dictionary<String^, String^>^ GetModuleConfigurationSettingValue(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, String>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while fetching module configuration settings
System..::..ArgumentNullException | This exception is thrown when tenantId is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
GetModuleConfigurationSettingValue Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.GetModuleConfigurationSettingValue Method (String, String)

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..GetModuleConfigurationSettingValue Method (String, String)
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to get the module configuration setting value based on particular tenant and configuration

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetModuleConfigurationSettingValue(
    string tenantId,
    string configurationId
)
Visual Basic
Function GetModuleConfigurationSettingValue (
    tenantId As String,
    configurationId As String
) As String
Visual C++
String^ GetModuleConfigurationSettingValue(
    String^ tenantId,
    String^ configurationId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationId
Type: System..::..String
The configuration id.

Return Value

Type: String

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while fetching module configuration settings
System..::..ArgumentNullException | This exception is thrown when tenantId or configurationId or value is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
GetModuleConfigurationSettingValue Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.GetTenantByModuleConfigurationSettingValue Method

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..GetTenantByModuleConfigurationSettingValue Method
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to get the tenant by module configuration setting value.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string[] GetTenantByModuleConfigurationSettingValue(
    string configurationId,
    string settingValue
)
Visual Basic
Function GetTenantByModuleConfigurationSettingValue (
    configurationId As String,
    settingValue As String
) As String()
Visual C++
array<String^>^ GetTenantByModuleConfigurationSettingValue(
    String^ configurationId,
    String^ settingValue
)

Parameters

configurationId
Type: System..::..String
The configuration id.
settingValue
Type: System..::..String
The value.

Return Value

Type: array<String>[]()[][]

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while fetching module configuration settings
System..::..ArgumentNullException | This exception is thrown when configurationId or setting value is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.UpdateModuleConfigurationSetting Method

[image] [image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..UpdateModuleConfigurationSetting Method
IModuleConfigurationSettingService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateModuleConfigurationSetting(String, Dictionary<(Of <<'(String, String>)>>)) | This method is used to update the module configuration setting with configuration id and value in key value pair format as input
Public method | UpdateModuleConfigurationSetting(String, String, String) | This method is used to update the module configuration setting with configuration id and value as input

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.UpdateModuleConfigurationSetting Method (String, Dictionary(String, String))

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..UpdateModuleConfigurationSetting Method (String, Dictionary<(Of <(<'String, String>)>)>)
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to update the module configuration setting with configuration id and value in key value pair format as input

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateModuleConfigurationSetting(
    string tenantId,
    Dictionary<string, string> configurationIdValuePair
)
Visual Basic
Sub UpdateModuleConfigurationSetting (
    tenantId As String,
    configurationIdValuePair As Dictionary(Of String, String)
)
Visual C++
void UpdateModuleConfigurationSetting(
    String^ tenantId,
    Dictionary<String^, String^>^ configurationIdValuePair
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationIdValuePair
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
The configuration id value pair.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while updating module configuration settings
System..::..ArgumentNullException | This exception is thrown when tenantId or configurationIdValuePair is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
UpdateModuleConfigurationSetting Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IModuleConfigurationSettingService.UpdateModuleConfigurationSetting Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IModuleConfigurationSettingService..::..UpdateModuleConfigurationSetting Method (String, String, String)
IModuleConfigurationSettingService Interface See Also Send Feedback
This method is used to update the module configuration setting with configuration id and value as input

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateModuleConfigurationSetting(
    string tenantId,
    string configurationId,
    string value
)
Visual Basic
Sub UpdateModuleConfigurationSetting (
    tenantId As String,
    configurationId As String,
    value As String
)
Visual C++
void UpdateModuleConfigurationSetting(
    String^ tenantId,
    String^ configurationId,
    String^ value
)

Parameters

tenantId
Type: System..::..String
The tenant id.
configurationId
Type: System..::..String
The configuration id.
value
Type: System..::..String
The value.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException | This exception is thrown while updating module configuration settings
System..::..ArgumentNullException | This exception is thrown when tenantId or configurationId or value is null or empty

See Also

IModuleConfigurationSettingService Interface
IModuleConfigurationSettingService Members
UpdateModuleConfigurationSetting Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService Interface

[image]

A Sandcastle Documented Class Library
IPickupListService Interface
Members See Also Send Feedback
This interface defines methods for Pickup List and Pickup List Value details.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IPickupListService
Visual Basic
Public Interface IPickupListService
Visual C++
public interface class IPickupListService

See Also

IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService Members

[image] [image]

A Sandcastle Documented Class Library
IPickupListService Members
IPickupListService Interface Methods See Also Send Feedback

The IPickupListService type exposes the following members.

Methods

 | Name | Description
Public method | ActivatePickupList | This method is used to activate the given pickup list
Public method | ActivatePickupListValue | This method is used to activate the given pickup list value for particular tenant and pickuplist
Public method | AddPickupList | This method is used to insert Pickup list
Public method | AddPickupListValue(PickupListValue) | This method is used to insert list of Pickup list values
Public method | AddPickupListValue(List<(Of <<'(PickupListValue>)>>)) | This method is used to insert list of Pickup list values
Public method | AddPickupListValueMapping | This method is used to add pickup list value mapping details
Public method | AddRelationshipMetaData | This method is used to add relationship meta data details
Public method | CopyAllPickupListsFromParent | This method copies all pickup list and its values form parent tenant if he has
Public method | CopyPickupList | This method copies the given pickup list id from the parent tenant
Public method | DeactivatePickupList | This method is used to delete Pickup list details
Public method | DeactivatePickupListValue | This method is used to delete Pickup list value details
Public method | DeactivatePickupListValues | This method is used to de-activates all the pickup list values for the give pickuplist id
Public method | FilterChildPickupList | This method is used to get child pickup list details with particular parent
Public method | FilterParentPickupList | This method is used to get parent pickup list details with particular child
Public method | GetAllPickupLists | This method is used to get all active/deactive pickup lists for particular tenant
Public method | GetAllPickupListValues(String, String) | This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist
Public method | GetAllPickupListValues(array<String>[]()[][], String) | This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist
Public method | GetChildPickupListValueDetails | This method is used to get PickupList Value by Child Identifier
Public method | GetOwnRelationshipMetaData | This method is used to get the own relationship meta data for tenant
Public method | GetParentPickupListValueDetails | This method is used to get PickupList Value by Child Identifier
Public method | GetPickupListDetails(String) | This method is used to get the pickup list details for pickup list identifier.
Public method | GetPickupListDetails(array<String>[]()[][]) | This method is used to get the pickup list details for pickup list identifier.
Public method | GetPickupListDetailsByName | This method is used to search for the pickup list with the given pickuplist name and tenant
Public method | GetPickupLists | This method is used to get the pickup list based on the tenant
Public method | GetPickupListValue(String, String) | This method is used to get the Pickup list value details
Public method | GetPickupListValue(String, String, String) | This method is used to get the Pickup list value details
Public method | GetPickupListValues | This method is used to get Pickup list value details for tenant
Public method | GetRelationshipMetaData(String) | This method is used to get Relationship details for tenant
Public method | GetRelationshipMetaData(String, String, Relation, String) | This method is used to get Relationship details for target Identifier
Public method | GetRelationshipMetaDataDetails(String) | This method is used to get Relationship details for oarticular relationship meta data
Public method | GetRelationshipMetaDataDetails(String, String) | This method is used to get the relationship meta data details for the given tenantIdentifier and the sourceid.
Public method | SavePickupListValueMapping | This method is used to save(Insert/Update) Pickup List Value Mapping details
Public method | SoftDeleteRelationshipMetaData | This mthod is used to deactivate relationship details
Public method | UpdatePickupList | This method is used to edit Pickup list
Public method | UpdatePickupListValue | This method is used to edit Pickup list values
Public method | UpdatePickupListValueMapping | This method is used to update pickup list value mapping details
Public method | UpdateRelationshipMetaData | This method is used to update relationship meta data details

See Also

IPickupListService Interface
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService Methods

[image] [image]

A Sandcastle Documented Class Library
IPickupListService Methods
IPickupListService Interface See Also Send Feedback

The IPickupListService type exposes the following members.

Methods

 | Name | Description
Public method | ActivatePickupList | This method is used to activate the given pickup list
Public method | ActivatePickupListValue | This method is used to activate the given pickup list value for particular tenant and pickuplist
Public method | AddPickupList | This method is used to insert Pickup list
Public method | AddPickupListValue(PickupListValue) | This method is used to insert list of Pickup list values
Public method | AddPickupListValue(List<(Of <<'(PickupListValue>)>>)) | This method is used to insert list of Pickup list values
Public method | AddPickupListValueMapping | This method is used to add pickup list value mapping details
Public method | AddRelationshipMetaData | This method is used to add relationship meta data details
Public method | CopyAllPickupListsFromParent | This method copies all pickup list and its values form parent tenant if he has
Public method | CopyPickupList | This method copies the given pickup list id from the parent tenant
Public method | DeactivatePickupList | This method is used to delete Pickup list details
Public method | DeactivatePickupListValue | This method is used to delete Pickup list value details
Public method | DeactivatePickupListValues | This method is used to de-activates all the pickup list values for the give pickuplist id
Public method | FilterChildPickupList | This method is used to get child pickup list details with particular parent
Public method | FilterParentPickupList | This method is used to get parent pickup list details with particular child
Public method | GetAllPickupLists | This method is used to get all active/deactive pickup lists for particular tenant
Public method | GetAllPickupListValues(String, String) | This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist
Public method | GetAllPickupListValues(array<String>[]()[][], String) | This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist
Public method | GetChildPickupListValueDetails | This method is used to get PickupList Value by Child Identifier
Public method | GetOwnRelationshipMetaData | This method is used to get the own relationship meta data for tenant
Public method | GetParentPickupListValueDetails | This method is used to get PickupList Value by Child Identifier
Public method | GetPickupListDetails(String) | This method is used to get the pickup list details for pickup list identifier.
Public method | GetPickupListDetails(array<String>[]()[][]) | This method is used to get the pickup list details for pickup list identifier.
Public method | GetPickupListDetailsByName | This method is used to search for the pickup list with the given pickuplist name and tenant
Public method | GetPickupLists | This method is used to get the pickup list based on the tenant
Public method | GetPickupListValue(String, String) | This method is used to get the Pickup list value details
Public method | GetPickupListValue(String, String, String) | This method is used to get the Pickup list value details
Public method | GetPickupListValues | This method is used to get Pickup list value details for tenant
Public method | GetRelationshipMetaData(String) | This method is used to get Relationship details for tenant
Public method | GetRelationshipMetaData(String, String, Relation, String) | This method is used to get Relationship details for target Identifier
Public method | GetRelationshipMetaDataDetails(String) | This method is used to get Relationship details for oarticular relationship meta data
Public method | GetRelationshipMetaDataDetails(String, String) | This method is used to get the relationship meta data details for the given tenantIdentifier and the sourceid.
Public method | SavePickupListValueMapping | This method is used to save(Insert/Update) Pickup List Value Mapping details
Public method | SoftDeleteRelationshipMetaData | This mthod is used to deactivate relationship details
Public method | UpdatePickupList | This method is used to edit Pickup list
Public method | UpdatePickupListValue | This method is used to edit Pickup list values
Public method | UpdatePickupListValueMapping | This method is used to update pickup list value mapping details
Public method | UpdateRelationshipMetaData | This method is used to update relationship meta data details

See Also

IPickupListService Interface
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.ActivatePickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..ActivatePickupList Method
IPickupListService Interface See Also Send Feedback
This method is used to activate the given pickup list

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ActivatePickupList(
    string pickupListId
)
Visual Basic
Sub ActivatePickupList (
    pickupListId As String
)
Visual C++
void ActivatePickupList(
    String^ pickupListId
)

Parameters

pickupListId
Type: System..::..String
pickup list id to activate

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while activating pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown while pickuplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.ActivatePickupListValue Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..ActivatePickupListValue Method
IPickupListService Interface See Also Send Feedback
This method is used to activate the given pickup list value for particular tenant and pickuplist

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ActivatePickupListValue(
    string pickupListValueId,
    string pickupListId,
    string tenantId
)
Visual Basic
Sub ActivatePickupListValue (
    pickupListValueId As String,
    pickupListId As String,
    tenantId As String
)
Visual C++
void ActivatePickupListValue(
    String^ pickupListValueId,
    String^ pickupListId,
    String^ tenantId
)

Parameters

pickupListValueId
Type: System..::..String
pickupListId
Type: System..::..String
tenantId
Type: System..::..String

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while activating pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pick uplist id,value id ,tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.AddPickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..AddPickupList Method
IPickupListService Interface Example See Also Send Feedback
This method is used to insert Pickup list

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddPickupList(
    PickupList pickupList
)
Visual Basic
Function AddPickupList (
    pickupList As PickupList
) As String
Visual C++
String^ AddPickupList(
    PickupList^ pickupList
)

Parameters

pickupList
Type: CelloSaaS.Model.Configuration..::..PickupList
Pickup list details(Madatory - Pickup List Name)

Return Value

Type: String
Pickup list identifier

Examples

Copy image Copy
public void AddPickupList()
{
    PickupList pickupList = new PickupList();
    pickupList.Name = "City";
    pickupList.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    string insertedPickupListId = pickupListService.AddPickupList(pickupList);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while inserting pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentException | This exception is thrown when pick up list name is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.AddPickupListValue Method

[image] [image]

A Sandcastle Documented Class Library
IPickupListService..::..AddPickupListValue Method
IPickupListService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPickupListValue(PickupListValue) | This method is used to insert list of Pickup list values
Public method | AddPickupListValue(List<(Of <<'(PickupListValue>)>>)) | This method is used to insert list of Pickup list values

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.AddPickupListValue Method (PickupListValue)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..AddPickupListValue Method (PickupListValue)
IPickupListService Interface Example See Also Send Feedback
This method is used to insert list of Pickup list values

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddPickupListValue(
    PickupListValue pickupListValue
)
Visual Basic
Function AddPickupListValue (
    pickupListValue As PickupListValue
) As String
Visual C++
String^ AddPickupListValue(
    PickupListValue^ pickupListValue
)

Parameters

pickupListValue
Type: CelloSaaS.Model.Configuration..::..PickupListValue
Pickup list value details(Mandatory)

Return Value

Type: String
Pickup list value Identifier

Examples

Copy image Copy
public void AddPickupListValue()
{
    PickupListValue pickupListValue = new PickupListValue();
    pickupListValue.PickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    pickupListValue.TenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    pickupListValue.ItemId = "1";
    pickupListValue.ItemName = "US";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    string insertedPickupListValueId = pickupListService.AddPickupListValue(pickupListValue);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when pickuplistvalue item name or pickuplistvalue pickuplistid or pickuplistvalue item id is null or empty
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details

See Also

IPickupListService Interface
IPickupListService Members
AddPickupListValue Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.AddPickupListValue Method (List(PickupListValue))

[image]

A Sandcastle Documented Class Library
IPickupListService..::..AddPickupListValue Method (List<(Of <(<'PickupListValue>)>)>)
IPickupListService Interface Example See Also Send Feedback
This method is used to insert list of Pickup list values

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool AddPickupListValue(
    List<PickupListValue> lstPickupListValues
)
Visual Basic
Function AddPickupListValue (
    lstPickupListValues As List(Of PickupListValue)
) As Boolean
Visual C++
bool AddPickupListValue(
    List<PickupListValue^>^ lstPickupListValues
)

Parameters

lstPickupListValues
Type: System.Collections.Generic..::..List<(Of <(<' PickupListValue >)>)>
List of Pickup list values(Mandatory)

Return Value

Type: Boolean
Sucess (True)/Failure (False)

Examples

Copy image Copy
public void AddPickupListValue()
{
    List<PickupListValue> lstPickupListValues = new List<PickupListValue>();
    PickupListValue pickupListValue = new PickupListValue();
    pickupListValue.PickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    pickupListValue.TenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    pickupListValue.ItemId = "1";
    pickupListValue.ItemName = "US";
    lstPickupListValues.Add(pickupListValue);
    pickupListValue = new PickupListValue();
    pickupListValue.PickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    pickupListValue.TenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    pickupListValue.ItemId = "2";
    pickupListValue.ItemName = "UK";
    lstPickupListValues.Add(pickupListValue);
    pickupListValue = new PickupListValue();
    pickupListValue.PickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    pickupListValue.TenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    pickupListValue.ItemId = "3";
    pickupListValue.ItemName = "Aus";
    lstPickupListValues.Add(pickupListValue);
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    bool insertedPickupListValues = pickupListService.AddPickupListValue(lstPickupListValues);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while inserting pickup list details
System..::..ArgumentException | This exception is thrown while pickup list is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access

See Also

IPickupListService Interface
IPickupListService Members
AddPickupListValue Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.AddPickupListValueMapping Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..AddPickupListValueMapping Method
IPickupListService Interface Example See Also Send Feedback
This method is used to add pickup list value mapping details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddPickupListValueMapping(
    PickupListValueMapping pickupListValueMapping
)
Visual Basic
Function AddPickupListValueMapping (
    pickupListValueMapping As PickupListValueMapping
) As String
Visual C++
String^ AddPickupListValueMapping(
    PickupListValueMapping^ pickupListValueMapping
)

Parameters

pickupListValueMapping
Type: CelloSaaS.Model.Configuration..::..PickupListValueMapping
Pickup List Value Mapping Details(Mandatory)

Return Value

Type: String
Inserted Identifier

Examples

Copy image Copy
public void AddPickupListValueMapping()
{
    PickupListValueMapping pickupListValueMapping = new PickupListValueMapping();
    pickupListValueMapping.SourceValueId = "6a96db6f-8d94-df11-8deb-001ec9dab123";
    pickupListValueMapping.TargetValueId = "aea18441-8794-df11-8deb-001ec9dab123";
    pickupListValueMapping.RelationshipMetaDataId = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    pickupListValueMapping.TenantId = "b590cd25-3093-df11-8deb-001ec9dab123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListValueMapping.Id = pickupListService.AddPickupListValueMapping(pickupListValueMapping);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when pickupListValueMapping is null or empty,pickupListValueMapping source id is null or empty,target id is null or empty,relationship meta data is null or empty or tenant id is null or empty
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while inserting Pickup list value mapping details

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.AddRelationshipMetaData Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..AddRelationshipMetaData Method
IPickupListService Interface Example See Also Send Feedback
This method is used to add relationship meta data details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRelationshipMetaData(
    RelationshipMetaData relationshipMetaData
)
Visual Basic
Function AddRelationshipMetaData (
    relationshipMetaData As RelationshipMetaData
) As String
Visual C++
String^ AddRelationshipMetaData(
    RelationshipMetaData^ relationshipMetaData
)

Parameters

relationshipMetaData
Type: CelloSaaS.Model.Configuration..::..RelationshipMetaData
Relationship Meta data(Madatory)

Return Value

Type: String
Relationship Meta Data Identifier

Examples

Copy image Copy
public void AddRelationshipMetaData()
{
    RelationshipMetaData relationshipMetaData = new RelationshipMetaData();
    relationshipMetaData.SourceId = "782119f7-8494-df11-8deb-001ec9dab123";
    relationshipMetaData.TargetId = "772119f7-8494-df11-8deb-001ec9dab123";
    relationshipMetaData.TargetType = Convert.ToInt32(Relation.Child).ToString();
    relationshipMetaData.RelationType = "PickupList";
    relationshipMetaData.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    relationshipMetaData.Id = pickupListService.AddRelationshipMetaData(relationshipMetaData);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while adding relationship meta data details
CelloSaaS.ServiceContracts.Configuration..::..DuplicateRelationshipMetaDataException | This exception is thrown when Relationship mete data details already available
System..::..ArgumentException | This exception is thrown while relationshipmetadata's Tenant id or Source id or target id or target type or relation type is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.CopyAllPickupListsFromParent Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..CopyAllPickupListsFromParent Method
IPickupListService Interface See Also Send Feedback
This method copies all pickup list and its values form parent tenant if he has

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int CopyAllPickupListsFromParent(
    string tenantId
)
Visual Basic
Function CopyAllPickupListsFromParent (
    tenantId As String
) As Integer
Visual C++
int CopyAllPickupListsFromParent(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
tenant identifier

Return Value

Type: Int32
total number of pickuplist copied

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown if the extended field setting is PARENT_SETTING
System..::..ArgumentNullException | This exception is thrown when tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.CopyPickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..CopyPickupList Method
IPickupListService Interface See Also Send Feedback
This method copies the given pickup list id from the parent tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int CopyPickupList(
    string pickupListId,
    string tenantId
)
Visual Basic
Function CopyPickupList (
    pickupListId As String,
    tenantId As String
) As Integer
Visual C++
int CopyPickupList(
    String^ pickupListId,
    String^ tenantId
)

Parameters

pickupListId
Type: System..::..String
pickup list id to copy
tenantId
Type: System..::..String
tenant id

Return Value

Type: Int32
Number of values copied

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown if the extended field setting is PARENT_SETTING
System..::..ArgumentNullException | This exception is thrown while tenant id or pickuplist id is id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.DeactivatePickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..DeactivatePickupList Method
IPickupListService Interface Example See Also Send Feedback
This method is used to delete Pickup list details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeactivatePickupList(
    string pickupListId
)
Visual Basic
Sub DeactivatePickupList (
    pickupListId As String
)
Visual C++
void DeactivatePickupList(
    String^ pickupListId
)

Parameters

pickupListId
Type: System..::..String
Pickup list identifier(Mandatory)

Examples

Copy image Copy
public void DeactivatePickupList()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListService.DeactivatePickupList(pickupListId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while deleting or deleting pickup list details
System..::..ArgumentException | This exception is thrown when pick uplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.DeactivatePickupListValue Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..DeactivatePickupListValue Method
IPickupListService Interface Example See Also Send Feedback
This method is used to delete Pickup list value details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeactivatePickupListValue(
    string pickupListValueId,
    string pickupListId,
    string tenantCode
)
Visual Basic
Sub DeactivatePickupListValue (
    pickupListValueId As String,
    pickupListId As String,
    tenantCode As String
)
Visual C++
void DeactivatePickupListValue(
    String^ pickupListValueId,
    String^ pickupListId,
    String^ tenantCode
)

Parameters

pickupListValueId
Type: System..::..String
Pickup list value Identifier(Mandatory)
pickupListId
Type: System..::..String
Pickup list Identifier(Mandatory)
tenantCode
Type: System..::..String
Tenant Code

Examples

Copy image Copy
public void DeactivatePickupListValue()
{
    string pickupListValueId = "97E81471-0494-DF11-8DEB-001EC9DAB123";
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListService.DeactivatePickupListValue(pickupListValueId, pickupListId, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while deleting pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pickupListValueId or pickupListId is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.DeactivatePickupListValues Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..DeactivatePickupListValues Method
IPickupListService Interface See Also Send Feedback
This method is used to de-activates all the pickup list values for the give pickuplist id

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeactivatePickupListValues(
    string pickupListId,
    string tenantId
)
Visual Basic
Sub DeactivatePickupListValues (
    pickupListId As String,
    tenantId As String
)
Visual C++
void DeactivatePickupListValues(
    String^ pickupListId,
    String^ tenantId
)

Parameters

pickupListId
Type: System..::..String
pickup list id
tenantId
Type: System..::..String
tenant id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while deleting pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pickupListId or tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.FilterChildPickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..FilterChildPickupList Method
IPickupListService Interface Example See Also Send Feedback
This method is used to get child pickup list details with particular parent

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupListValue FilterChildPickupList(
    string parentPickupListId,
    string tenantId,
    PickupListFilter filter
)
Visual Basic
Function FilterChildPickupList (
    parentPickupListId As String,
    tenantId As String,
    filter As PickupListFilter
) As PickupListValue
Visual C++
PickupListValue^ FilterChildPickupList(
    String^ parentPickupListId,
    String^ tenantId,
    PickupListFilter^ filter
)

Parameters

parentPickupListId
Type: System..::..String
Parent Pickup List Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier
filter
Type: CelloSaaS.Model.Configuration..::..PickupListFilter
Pickup List Filter Details(Mandatory)

Return Value

Type: PickupListValue
PickupListValue

Examples

Copy image Copy
public void FilterParentPickupList()
{
    string parentPickupListId = "8251fca5-0594-df11-8deb-001ec9dab123";
    string tenantId = "CAADE3DC-0594-DF11-8DEB-001EC9DAB123";
    PickupListFilter filter = new PickupListFilter();
    filter.PickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    filter.PickupListValueId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupListValue pickupListValue = pickupListService.FilterParentPickupList(parentPickupListId, tenantId, filter);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching child Pickup list value details
System..::..ArgumentException | This exception is thrown when filter's pickuplist id or pickuplistvalue id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.FilterParentPickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..FilterParentPickupList Method
IPickupListService Interface Example See Also Send Feedback
This method is used to get parent pickup list details with particular child

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupListValue FilterParentPickupList(
    string childPickupListId,
    string tenantId,
    PickupListFilter filter
)
Visual Basic
Function FilterParentPickupList (
    childPickupListId As String,
    tenantId As String,
    filter As PickupListFilter
) As PickupListValue
Visual C++
PickupListValue^ FilterParentPickupList(
    String^ childPickupListId,
    String^ tenantId,
    PickupListFilter^ filter
)

Parameters

childPickupListId
Type: System..::..String
Child Pickup List Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier
filter
Type: CelloSaaS.Model.Configuration..::..PickupListFilter
Pickup List Filter Details(Mandatory)

Return Value

Type: PickupListValue
returns PickupListValue

Examples

Copy image Copy
public void FilterParentPickupList()
{
    string childPickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    PickupListFilter filter = new PickupListFilter();
    filter.PickupListId = "8251fca5-0594-df11-8deb-001ec9dab123";
    filter.PickupListValueId = "CAADE3DC-0594-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupListValue pickupListValue = pickupListService.FilterParentPickupList(childPickupListId, tenantId, filter);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching Parent Pickup list value details
System..::..ArgumentException | This exception is thrown when filter's pickuplist id or pickuplistvalue id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetAllPickupLists Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetAllPickupLists Method
IPickupListService Interface See Also Send Feedback
This method is used to get all active/deactive pickup lists for particular tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<PickupList> GetAllPickupLists(
    string tenantId
)
Visual Basic
Function GetAllPickupLists (
    tenantId As String
) As List(Of PickupList)
Visual C++
List<PickupList^>^ GetAllPickupLists(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
tenant id

Return Value

Type: List<(Of <(<' PickupList >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..ArgumentNullException | This exception is thrown whwn tenant id is null or empty
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetAllPickupListValues Method

[image] [image]

A Sandcastle Documented Class Library
IPickupListService..::..GetAllPickupListValues Method
IPickupListService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAllPickupListValues(String, String) | This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist
Public method | GetAllPickupListValues(array<String>[]()[][], String) | This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetAllPickupListValues Method (String, String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetAllPickupListValues Method (String, String)
IPickupListService Interface See Also Send Feedback
This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<PickupListValue> GetAllPickupListValues(
    string pickupListId,
    string tenantId
)
Visual Basic
Function GetAllPickupListValues (
    pickupListId As String,
    tenantId As String
) As List(Of PickupListValue)
Visual C++
List<PickupListValue^>^ GetAllPickupListValues(
    String^ pickupListId,
    String^ tenantId
)

Parameters

pickupListId
Type: System..::..String
pickup list id
tenantId
Type: System..::..String
tennat id

Return Value

Type: List<(Of <(<' PickupListValue >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching all pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pick uplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetAllPickupListValues Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetAllPickupListValues Method (String[], String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetAllPickupListValues Method (array<String>[]()[][], String)
IPickupListService Interface See Also Send Feedback
This method is used to get all active/deactive pickuplist values for particular tenant and pickuplist

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<PickupListValue>> GetAllPickupListValues(
    string[] pickupListIds,
    string tenantId
)
Visual Basic
Function GetAllPickupListValues (
    pickupListIds As String(),
    tenantId As String
) As Dictionary(Of String, List(Of PickupListValue))
Visual C++
Dictionary<String^, List<PickupListValue^>^>^ GetAllPickupListValues(
    array<String^>^ pickupListIds,
    String^ tenantId
)

Parameters

pickupListIds
Type: array<System..::..String>[]()[][]
pickup list identifier array
tenantId
Type: System..::..String
tennat id

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<' PickupListValue >)>)>>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching all pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pick uplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetAllPickupListValues Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetChildPickupListValueDetails Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetChildPickupListValueDetails Method
IPickupListService Interface Example See Also Send Feedback
This method is used to get PickupList Value by Child Identifier

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupListValue GetChildPickupListValueDetails(
    string pickupListId,
    string pickupListValueId,
    string tenantId
)
Visual Basic
Function GetChildPickupListValueDetails (
    pickupListId As String,
    pickupListValueId As String,
    tenantId As String
) As PickupListValue
Visual C++
PickupListValue^ GetChildPickupListValueDetails(
    String^ pickupListId,
    String^ pickupListValueId,
    String^ tenantId
)

Parameters

pickupListId
Type: System..::..String
Child Pickup List Identifier(Mandatory)
pickupListValueId
Type: System..::..String
Child Pickup List Value Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: PickupListValue
PickupListValue (Child)

Examples

Copy image Copy
public void GetChildPickupListValueDetails()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    string pickupListValueId = "97E81471-0494-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupListValue pickupListValue = pickupListService.GetChildPickupListValueDetails(pickupListId, pickupListValueId, tenantId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching parent pickup list details
System..::..ArgumentNullException | This exception is thrown when pickuplist id or pickuplistvalue id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetOwnRelationshipMetaData Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetOwnRelationshipMetaData Method
IPickupListService Interface See Also Send Feedback
This method is used to get the own relationship meta data for tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<RelationshipMetaData> GetOwnRelationshipMetaData(
    string tenantId
)
Visual Basic
Function GetOwnRelationshipMetaData (
    tenantId As String
) As List(Of RelationshipMetaData)
Visual C++
List<RelationshipMetaData^>^ GetOwnRelationshipMetaData(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: List<(Of <(<' RelationshipMetaData >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching own pickup list relationship details
System..::..ArgumentNullException | This exception is thrown when tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetParentPickupListValueDetails Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetParentPickupListValueDetails Method
IPickupListService Interface Example See Also Send Feedback
This method is used to get PickupList Value by Child Identifier

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupListValue GetParentPickupListValueDetails(
    string pickupListId,
    string pickupListValueId,
    string tenantId
)
Visual Basic
Function GetParentPickupListValueDetails (
    pickupListId As String,
    pickupListValueId As String,
    tenantId As String
) As PickupListValue
Visual C++
PickupListValue^ GetParentPickupListValueDetails(
    String^ pickupListId,
    String^ pickupListValueId,
    String^ tenantId
)

Parameters

pickupListId
Type: System..::..String
Parent Pickup List Identifier(Mandatory)
pickupListValueId
Type: System..::..String
Parent Pickup List Value Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: PickupListValue
PickupListValue( Parent)

Examples

Copy image Copy
public void GetParentPickupListValueDetails()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    string pickupListValueId = "97E81471-0494-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupListValue pickupListValue = pickupListService.GetParentPickupListValueDetails(pickupListId, pickupListValueId, tenantId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching parent pickup list details
System..::..ArgumentNullException | This exception is thrown when pickuplist id or pickuplistvalue id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListDetails Method

[image] [image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListDetails Method
IPickupListService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPickupListDetails(String) | This method is used to get the pickup list details for pickup list identifier.
Public method | GetPickupListDetails(array<String>[]()[][]) | This method is used to get the pickup list details for pickup list identifier.

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListDetails Method (String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListDetails Method (String)
IPickupListService Interface Example See Also Send Feedback
This method is used to get the pickup list details for pickup list identifier.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupList GetPickupListDetails(
    string pickupListId
)
Visual Basic
Function GetPickupListDetails (
    pickupListId As String
) As PickupList
Visual C++
PickupList^ GetPickupListDetails(
    String^ pickupListId
)

Parameters

pickupListId
Type: System..::..String
Pickup list identifier(Mandatory)

Return Value

Type: PickupList
Pickup list details

Examples

Copy image Copy
public void GetPickupListDetails()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupList pickupList = pickupListService.GetPickupListDetails(pickupListId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown while pickuplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetPickupListDetails Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListDetails Method (String[])

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListDetails Method (array<String>[]()[][])
IPickupListService Interface Example See Also Send Feedback
This method is used to get the pickup list details for pickup list identifier.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, PickupList> GetPickupListDetails(
    string[] pickupListIds
)
Visual Basic
Function GetPickupListDetails (
    pickupListIds As String()
) As Dictionary(Of String, PickupList)
Visual C++
Dictionary<String^, PickupList^>^ GetPickupListDetails(
    array<String^>^ pickupListIds
)

Parameters

pickupListIds
Type: array<System..::..String>[]()[][]
Pickup list identifier(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, PickupList >)>)>
Dictionary of pickuplist id and Pickuplist details

Examples

Copy image Copy
public void GetPickupListDetails()
{
string pickupListIds = new string[]{"A60F4864-0494-DF11-8DEB-001EC9DAB123"};
IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
PickupList pickupList = pickupListService.GetPickupListDetails(pickupListIds);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown while pickuplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetPickupListDetails Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListDetailsByName Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListDetailsByName Method
IPickupListService Interface See Also Send Feedback
This method is used to search for the pickup list with the given pickuplist name and tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupList GetPickupListDetailsByName(
    string pickupListName,
    string tenantId
)
Visual Basic
Function GetPickupListDetailsByName (
    pickupListName As String,
    tenantId As String
) As PickupList
Visual C++
PickupList^ GetPickupListDetailsByName(
    String^ pickupListName,
    String^ tenantId
)

Parameters

pickupListName
Type: System..::..String
pickup list name
tenantId
Type: System..::..String
tenant identifier

Return Value

Type: PickupList
Pickuplist details if found or null

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown while tenant code or pickuplist name is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupLists Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupLists Method
IPickupListService Interface Example See Also Send Feedback
This method is used to get the pickup list based on the tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<PickupList> GetPickupLists(
    string tenantCode
)
Visual Basic
Function GetPickupLists (
    tenantCode As String
) As List(Of PickupList)
Visual C++
List<PickupList^>^ GetPickupLists(
    String^ tenantCode
)

Parameters

tenantCode
Type: System..::..String
Tenant Code

Return Value

Type: List<(Of <(<' PickupList >)>)>
Pickup list values

Examples

Copy image Copy
public void GetPickupLists()
{
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    List<PickupList> pickupLists = pickupListService.GetPickupLists(tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown while tenant code is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListValue Method

[image] [image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListValue Method
IPickupListService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPickupListValue(String, String) | This method is used to get the Pickup list value details
Public method | GetPickupListValue(String, String, String) | This method is used to get the Pickup list value details

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListValue Method (String, String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListValue Method (String, String)
IPickupListService Interface Example See Also Send Feedback
This method is used to get the Pickup list value details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupListValue GetPickupListValue(
    string pickupListValueId,
    string pickupListId
)
Visual Basic
Function GetPickupListValue (
    pickupListValueId As String,
    pickupListId As String
) As PickupListValue
Visual C++
PickupListValue^ GetPickupListValue(
    String^ pickupListValueId,
    String^ pickupListId
)

Parameters

pickupListValueId
Type: System..::..String
Pickup List Value Identifier(Mandatory)
pickupListId
Type: System..::..String
Pickup List Identifier(Mandatory)

Return Value

Type: PickupListValue
Pickup list value details

Examples

Copy image Copy
public void GetPickupListValue()
{
    string pickupListValueId = "97E81471-0494-DF11-8DEB-001EC9DAB123";
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupListValue pickupListValue = pickupListService.GetPickupListValue(pickupListValueId, pickupListId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pick uplist id or value id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetPickupListValue Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListValue Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListValue Method (String, String, String)
IPickupListService Interface Example See Also Send Feedback
This method is used to get the Pickup list value details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PickupListValue GetPickupListValue(
    string pickupListValueItemId,
    string pickupListId,
    string tenantCode
)
Visual Basic
Function GetPickupListValue (
    pickupListValueItemId As String,
    pickupListId As String,
    tenantCode As String
) As PickupListValue
Visual C++
PickupListValue^ GetPickupListValue(
    String^ pickupListValueItemId,
    String^ pickupListId,
    String^ tenantCode
)

Parameters

pickupListValueItemId
Type: System..::..String
Pickup list value Item Identifier(Mandatory)
pickupListId
Type: System..::..String
Pickup List Identifier(Mandatory)
tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: PickupListValue
Pickup list value details

Examples

Copy image Copy
public void GetPickupListValue()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    string pickupListValueItemId = "1";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    PickupListValue pickupListValue = pickupListService.GetPickupListValue(pickupListValueItemId, pickupListId, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pick uplist id or item id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetPickupListValue Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetPickupListValues Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetPickupListValues Method
IPickupListService Interface Example See Also Send Feedback
This method is used to get Pickup list value details for tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<PickupListValue> GetPickupListValues(
    string pickupListId,
    string tenantCode
)
Visual Basic
Function GetPickupListValues (
    pickupListId As String,
    tenantCode As String
) As List(Of PickupListValue)
Visual C++
List<PickupListValue^>^ GetPickupListValues(
    String^ pickupListId,
    String^ tenantCode
)

Parameters

pickupListId
Type: System..::..String
Pickup list Identifier(Mandatory)
tenantCode
Type: System..::..String
Tenant Code

Return Value

Type: List<(Of <(<' PickupListValue >)>)>
List of Pickup list value details

Examples

Copy image Copy
public void GetPickupListValues()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    List<PickupListValue> pickupListValueDetails = pickupListService.GetPickupListValues(pickupListId, tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentNullException | This exception is thrown when pick uplist id or tenant code is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetRelationshipMetaData Method

[image] [image]

A Sandcastle Documented Class Library
IPickupListService..::..GetRelationshipMetaData Method
IPickupListService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRelationshipMetaData(String) | This method is used to get Relationship details for tenant
Public method | GetRelationshipMetaData(String, String, Relation, String) | This method is used to get Relationship details for target Identifier

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetRelationshipMetaData Method (String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetRelationshipMetaData Method (String)
IPickupListService Interface Example See Also Send Feedback
This method is used to get Relationship details for tenant

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<RelationshipMetaData> GetRelationshipMetaData(
    string tenantId
)
Visual Basic
Function GetRelationshipMetaData (
    tenantId As String
) As List(Of RelationshipMetaData)
Visual C++
List<RelationshipMetaData^>^ GetRelationshipMetaData(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: List<(Of <(<' RelationshipMetaData >)>)>
List [RelationshipMetaData]

Examples

Copy image Copy
public void GetRelationshipMetaData()
{
    string tenantId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    List<RelationshipMetaData> relationshipDetails = pickupListService.GetRelationshipMetaData(tenantId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list relationship details
System..::..ArgumentNullException | This exception is thrown when tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetRelationshipMetaData Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetRelationshipMetaData Method (String, String, Relation, String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetRelationshipMetaData Method (String, String, Relation, String)
IPickupListService Interface Example See Also Send Feedback
This method is used to get Relationship details for target Identifier

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<RelationshipMetaData> GetRelationshipMetaData(
    string filterPickupListId,
    string tenantId,
    Relation relation,
    string pickupListId
)
Visual Basic
Function GetRelationshipMetaData (
    filterPickupListId As String,
    tenantId As String,
    relation As Relation,
    pickupListId As String
) As List(Of RelationshipMetaData)
Visual C++
List<RelationshipMetaData^>^ GetRelationshipMetaData(
    String^ filterPickupListId,
    String^ tenantId,
    Relation relation,
    String^ pickupListId
)

Parameters

filterPickupListId
Type: System..::..String
Parent Pickup list Identifier(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
relation
Type: CelloSaaS.Model.Configuration..::..Relation
Relation [Parent/Child]
pickupListId
Type: System..::..String
Child Pickup List Identifier

Return Value

Type: List<(Of <(<' RelationshipMetaData >)>)>
List [RelationshipMetaData]

Examples

Copy image Copy
public void GetRelationshipMetaData()
{
    string filterPickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    string tenantId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    Relation relation = Relation.Child;
    string pickupListId = "8251fca5-0594-df11-8deb-001ec9dab123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    List<RelationshipMetaData> relationshipDetails = pickupListService.GetRelationshipMetaData(filterPickupListId, tenantId, relation, pickupListId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching pickup list relationship details
System..::..ArgumentNullException | This exception is thrown when filterPickupListId or tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetRelationshipMetaData Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetRelationshipMetaDataDetails Method

[image] [image]

A Sandcastle Documented Class Library
IPickupListService..::..GetRelationshipMetaDataDetails Method
IPickupListService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRelationshipMetaDataDetails(String) | This method is used to get Relationship details for oarticular relationship meta data
Public method | GetRelationshipMetaDataDetails(String, String) | This method is used to get the relationship meta data details for the given tenantIdentifier and the sourceid.

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetRelationshipMetaDataDetails Method (String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetRelationshipMetaDataDetails Method (String)
IPickupListService Interface Example See Also Send Feedback
This method is used to get Relationship details for oarticular relationship meta data

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
RelationshipMetaData GetRelationshipMetaDataDetails(
    string relationshipMetaDataId
)
Visual Basic
Function GetRelationshipMetaDataDetails (
    relationshipMetaDataId As String
) As RelationshipMetaData
Visual C++
RelationshipMetaData^ GetRelationshipMetaDataDetails(
    String^ relationshipMetaDataId
)

Parameters

relationshipMetaDataId
Type: System..::..String
Relationship MetaData Identifier(Mandatory)

Return Value

Type: RelationshipMetaData
RelationshipMetaData

Examples

Copy image Copy
public void GetRelationshipMetaDataDetails()
{
    string relationshipMetaDataId = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    RelationshipMetaData relationshipMetaData = pickupListService.GetRelationshipMetaDataDetails(relationshipMetaDataId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while relationship meta data details

See Also

IPickupListService Interface
IPickupListService Members
GetRelationshipMetaDataDetails Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.GetRelationshipMetaDataDetails Method (String, String)

[image]

A Sandcastle Documented Class Library
IPickupListService..::..GetRelationshipMetaDataDetails Method (String, String)
IPickupListService Interface See Also Send Feedback
This method is used to get the relationship meta data details for the given tenantIdentifier and the sourceid.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
RelationshipMetaData GetRelationshipMetaDataDetails(
    string tenantId,
    string sourceId
)
Visual Basic
Function GetRelationshipMetaDataDetails (
    tenantId As String,
    sourceId As String
) As RelationshipMetaData
Visual C++
RelationshipMetaData^ GetRelationshipMetaDataDetails(
    String^ tenantId,
    String^ sourceId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
sourceId
Type: System..::..String
The source id.

Return Value

Type: RelationshipMetaData

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while fetching own pickup list relationship details
System..::..ArgumentNullException | This exception is thrown when source id or tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
GetRelationshipMetaDataDetails Overload
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.SavePickupListValueMapping Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..SavePickupListValueMapping Method
IPickupListService Interface Example See Also Send Feedback
This method is used to save(Insert/Update) Pickup List Value Mapping details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SavePickupListValueMapping(
    List<PickupListValueMapping> pickupListValueMappingList
)
Visual Basic
Sub SavePickupListValueMapping (
    pickupListValueMappingList As List(Of PickupListValueMapping)
)
Visual C++
void SavePickupListValueMapping(
    List<PickupListValueMapping^>^ pickupListValueMappingList
)

Parameters

pickupListValueMappingList
Type: System.Collections.Generic..::..List<(Of <(<' PickupListValueMapping >)>)>
Pickup List Value Mapping Details List(Mandatory)

Examples

Copy image Copy
public void SavePickupListValueMapping()
{
    List<PickupListValueMapping> pickupListValueMappingList = new List<PickupListValueMapping>();
    PickupListValueMapping pickupListValueMapping = new pickupListValueMapping();
    pickupListValueMapping.SourceValueId = "6a96db6f-8d94-df11-8deb-001ec9dab123";
    pickupListValueMapping.TargetValueId = "aea18441-8794-df11-8deb-001ec9dab123";
    pickupListValueMapping.RelationshipMetaDataId = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    pickupListValueMapping.TenantId = "b590cd25-3093-df11-8deb-001ec9dab123";
    pickupListValueMappingList.Add(pickupListValueMapping);
    pickupListValueMapping = new pickupListValueMapping();
    pickupListValueMapping.SourceValueId = "9e46f077-8d94-df11-8deb-001ec9dab123";
    pickupListValueMapping.TargetValueId = "aea18441-8794-df11-8deb-001ec9dab123";
    pickupListValueMapping.RelationshipMetaDataId = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    pickupListValueMapping.TenantId = "b590cd25-3093-df11-8deb-001ec9dab123";
    pickupListValueMappingList.Add(pickupListValueMapping);
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListService.SavePickupListValueMapping(pickupListValueMappingList);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while saving Pickup list value mapping details
System..::..ArgumentException | This exception is thrown when pickupListValueMapping is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.SoftDeleteRelationshipMetaData Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..SoftDeleteRelationshipMetaData Method
IPickupListService Interface Example See Also Send Feedback
This mthod is used to deactivate relationship details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SoftDeleteRelationshipMetaData(
    string relationshipMetaDataId
)
Visual Basic
Sub SoftDeleteRelationshipMetaData (
    relationshipMetaDataId As String
)
Visual C++
void SoftDeleteRelationshipMetaData(
    String^ relationshipMetaDataId
)

Parameters

relationshipMetaDataId
Type: System..::..String
Relationship Identifier(Mandatory)

Examples

Copy image Copy
public void SoftDeleteRelationshipMetaData()
{
    string relationshipMetaDataId = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListService.SoftDeleteRelationshipMetaData(relationshipMetaDataId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while deactivating relationship meta data details
System..::..ArgumentNullException | This exception is thrown while relationshipmetadata's id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.UpdatePickupList Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..UpdatePickupList Method
IPickupListService Interface Example See Also Send Feedback
This method is used to edit Pickup list

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdatePickupList(
    PickupList pickupList
)
Visual Basic
Function UpdatePickupList (
    pickupList As PickupList
) As String
Visual C++
String^ UpdatePickupList(
    PickupList^ pickupList
)

Parameters

pickupList
Type: CelloSaaS.Model.Configuration..::..PickupList
Pickup list details(Madatory - Pickup List Identifier,Pickup List Name)

Return Value

Type: String
Pickup list Identifier

Examples

Copy image Copy
public void UpdatePickupList()
{
    PickupList pickupList = new PickupList();
    pickupList.Id = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    pickupList.Name = "City";
    pickupList.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    string updatedPickupListId = pickupListService.UpdatePickupList(pickupList);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while updating pickup list details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentException | This exception is thrown when pick uplist's id, name is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.UpdatePickupListValue Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..UpdatePickupListValue Method
IPickupListService Interface Example See Also Send Feedback
This method is used to edit Pickup list values

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdatePickupListValue(
    PickupListValue pickupListValue
)
Visual Basic
Function UpdatePickupListValue (
    pickupListValue As PickupListValue
) As String
Visual C++
String^ UpdatePickupListValue(
    PickupListValue^ pickupListValue
)

Parameters

pickupListValue
Type: CelloSaaS.Model.Configuration..::..PickupListValue
Pickup list value details(Mandatory)

Return Value

Type: String
Pickup list value Identifier

Examples

Copy image Copy
public void UpdatePickupListValue()
{
    PickupListValue pickupListValue = new PickupListValue();
    pickupListValue.Id = "97E81471-0494-DF11-8DEB-001EC9DAB123";
    pickupListValue.PickupListId = "A60F4864-0494-DF11-8DEB-001EC9DAB123";
    pickupListValue.TenantCode = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    pickupListValue.ItemId = "1";
    pickupListValue.ItemName = "US";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    string updatedPickupListValueId = pickupListService.UpdatePickupListValue(pickupListValue);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown when pickup list value or name or Pickup list value details not updated successfully or exception occur while updating Pickup list value details
System..::..UnauthorizedAccessException | This exception is thrown when does not permission to access
System..::..ArgumentException | This exception is thrown while pickup list value,item id,item name,pickuplist id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.UpdatePickupListValueMapping Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..UpdatePickupListValueMapping Method
IPickupListService Interface Example See Also Send Feedback
This method is used to update pickup list value mapping details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdatePickupListValueMapping(
    PickupListValueMapping pickupListValueMapping
)
Visual Basic
Sub UpdatePickupListValueMapping (
    pickupListValueMapping As PickupListValueMapping
)
Visual C++
void UpdatePickupListValueMapping(
    PickupListValueMapping^ pickupListValueMapping
)

Parameters

pickupListValueMapping
Type: CelloSaaS.Model.Configuration..::..PickupListValueMapping
Pickup List Value Mapping Details(Mandatory)

Examples

Copy image Copy
public void UpdatePickupListValueMapping()
{
    PickupListValueMapping pickupListValueMapping = new PickupListValueMapping();
    pickupListValueMapping.SourceValueId = "6a96db6f-8d94-df11-8deb-001ec9dab123";
    pickupListValueMapping.TargetValueId = "aea18441-8794-df11-8deb-001ec9dab123";
    pickupListValueMapping.RelationshipMetaDataId = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    pickupListValueMapping.TenantId = "b590cd25-3093-df11-8deb-001ec9dab123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListService.UpdatePickupListValueMapping(pickupListValueMapping);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while updating Pickup list value mapping details
System..::..ArgumentException | This exception is thrown when pickupListValueMapping is null or empty,pickupListValueMapping source id is null or empty,target id is null or empty,relationship meta data is null or empty or tenant id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


IPickupListService.UpdateRelationshipMetaData Method

[image]

A Sandcastle Documented Class Library
IPickupListService..::..UpdateRelationshipMetaData Method
IPickupListService Interface Example See Also Send Feedback
This method is used to update relationship meta data details

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRelationshipMetaData(
    RelationshipMetaData relationshipMetaData
)
Visual Basic
Sub UpdateRelationshipMetaData (
    relationshipMetaData As RelationshipMetaData
)
Visual C++
void UpdateRelationshipMetaData(
    RelationshipMetaData^ relationshipMetaData
)

Parameters

relationshipMetaData
Type: CelloSaaS.Model.Configuration..::..RelationshipMetaData
Relationship Meta data(Madatory - Relationship Id)

Examples

Copy image Copy
public void UpdateRelationshipMetaData()
{
    RelationshipMetaData relationshipMetaData = new RelationshipMetaData();
    relationshipMetaData.Id = "E96052A9-8D94-DF11-8DEB-001EC9DAB123";
    relationshipMetaData.SourceId = "782119f7-8494-df11-8deb-001ec9dab123";
    relationshipMetaData.TargetId = "772119f7-8494-df11-8deb-001ec9dab123";
    relationshipMetaData.TargetType = Convert.ToInt32(Relation.Child).ToString();
    relationshipMetaData.RelationType = "PickupList";
    relationshipMetaData.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IPickupListService pickupListService = (IPickupListService)ServiceLocator.GetServiceImplementation(typeof(IPickupListService));
    pickupListService.UpdateRelationshipMetaData(relationshipMetaData);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Configuration..::..PickupListException | This exception is thrown while updating relationship meta data details
System..::..ArgumentException | This exception is thrown while relationshipmetadata's id is null or empty

See Also

IPickupListService Interface
IPickupListService Members
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Class

[image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Class
Members See Also Send Feedback
Thrown in case of any exception occurred while getting the module configuration settings

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ModuleConfigurationSettingException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ModuleConfigurationSettingException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ModuleConfigurationSettingException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Configuration..::..ModuleConfigurationSettingException

See Also

ModuleConfigurationSettingException Members
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Members

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Members
ModuleConfigurationSettingException Class Constructors Methods Properties Events See Also Send Feedback

The ModuleConfigurationSettingException type exposes the following members.

Constructors

 | Name | Description
Public method | ModuleConfigurationSettingException()()()() | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.
Public method | ModuleConfigurationSettingException(String) | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.
Public method | ModuleConfigurationSettingException(SerializationInfo, StreamingContext) | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.
Public method | ModuleConfigurationSettingException(String, Exception) | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ModuleConfigurationSettingException Class
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Constructor

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Constructor
ModuleConfigurationSettingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ModuleConfigurationSettingException()()()() | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.
Public method | ModuleConfigurationSettingException(String) | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.
Public method | ModuleConfigurationSettingException(SerializationInfo, StreamingContext) | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.
Public method | ModuleConfigurationSettingException(String, Exception) | This method is used to initialize a new instance of the ModuleConfigurationSettingException class.

See Also

ModuleConfigurationSettingException Class
ModuleConfigurationSettingException Members
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Constructor

[image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Constructor
ModuleConfigurationSettingException Class See Also Send Feedback
This method is used to initialize a new instance of the ModuleConfigurationSettingException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleConfigurationSettingException()
Visual Basic
Public Sub New
Visual C++
public:
ModuleConfigurationSettingException()

See Also

ModuleConfigurationSettingException Class
ModuleConfigurationSettingException Members
ModuleConfigurationSettingException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Constructor (String)

[image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Constructor (String)
ModuleConfigurationSettingException Class See Also Send Feedback
This method is used to initialize a new instance of the ModuleConfigurationSettingException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleConfigurationSettingException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ModuleConfigurationSettingException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ModuleConfigurationSettingException Class
ModuleConfigurationSettingException Members
ModuleConfigurationSettingException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Constructor (SerializationInfo, StreamingContext)
ModuleConfigurationSettingException Class See Also Send Feedback
This method is used to initialize a new instance of the ModuleConfigurationSettingException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleConfigurationSettingException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Public Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
public:
ModuleConfigurationSettingException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

ModuleConfigurationSettingException Class
ModuleConfigurationSettingException Members
ModuleConfigurationSettingException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Constructor (String, Exception)
ModuleConfigurationSettingException Class See Also Send Feedback
This method is used to initialize a new instance of the ModuleConfigurationSettingException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ModuleConfigurationSettingException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ModuleConfigurationSettingException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

ModuleConfigurationSettingException Class
ModuleConfigurationSettingException Members
ModuleConfigurationSettingException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Methods

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Methods
ModuleConfigurationSettingException Class See Also Send Feedback

The ModuleConfigurationSettingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ModuleConfigurationSettingException Class
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Properties

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Properties
ModuleConfigurationSettingException Class See Also Send Feedback

The ModuleConfigurationSettingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModuleConfigurationSettingException Class
CelloSaaS.ServiceContracts.Configuration Namespace


ModuleConfigurationSettingException Events

[image] [image]

A Sandcastle Documented Class Library
ModuleConfigurationSettingException Events
ModuleConfigurationSettingException Class See Also Send Feedback

The ModuleConfigurationSettingException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ModuleConfigurationSettingException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Class

[image]

A Sandcastle Documented Class Library
PickupListException Class
Members See Also Send Feedback
This exception is used to catch pickup list exception

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListException : BaseException
Visual Basic
<SerializableAttribute>
Public Class PickupListException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PickupListException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Configuration..::..PickupListException

See Also

PickupListException Members
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Members

[image] [image]

A Sandcastle Documented Class Library
PickupListException Members
PickupListException Class Constructors Methods Properties Events See Also Send Feedback

The PickupListException type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListException()()()() | Initializes a new instance of the PickupListException class.
Public method | PickupListException(String) | Initializes a new instance of the PickupListException class.
Public method | PickupListException(String, Exception) | Initializes a new instance of the PickupListException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PickupListException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Constructor

[image] [image]

A Sandcastle Documented Class Library
PickupListException Constructor
PickupListException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PickupListException()()()() | Initializes a new instance of the PickupListException class.
Public method | PickupListException(String) | Initializes a new instance of the PickupListException class.
Public method | PickupListException(String, Exception) | Initializes a new instance of the PickupListException class.

See Also

PickupListException Class
PickupListException Members
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Constructor

[image]

A Sandcastle Documented Class Library
PickupListException Constructor
PickupListException Class See Also Send Feedback
Initializes a new instance of the PickupListException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListException()
Visual Basic
Public Sub New
Visual C++
public:
PickupListException()

See Also

PickupListException Class
PickupListException Members
PickupListException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Constructor (String)

[image]

A Sandcastle Documented Class Library
PickupListException Constructor (String)
PickupListException Class See Also Send Feedback
Initializes a new instance of the PickupListException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
PickupListException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

PickupListException Class
PickupListException Members
PickupListException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
PickupListException Constructor (String, Exception)
PickupListException Class See Also Send Feedback
Initializes a new instance of the PickupListException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
PickupListException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

PickupListException Class
PickupListException Members
PickupListException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListException Methods
PickupListException Class See Also Send Feedback

The PickupListException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PickupListException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListException Properties
PickupListException Class See Also Send Feedback

The PickupListException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PickupListException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListException Events

[image] [image]

A Sandcastle Documented Class Library
PickupListException Events
PickupListException Class See Also Send Feedback

The PickupListException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PickupListException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Class

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Class
Members See Also Send Feedback
This exception is used to catch Duplicate Name of pickup list value

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListValueDuplicateNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class PickupListValueDuplicateNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PickupListValueDuplicateNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Configuration..::..PickupListValueDuplicateNameException

See Also

PickupListValueDuplicateNameException Members
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Members

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Members
PickupListValueDuplicateNameException Class Constructors Methods Properties Events See Also Send Feedback

The PickupListValueDuplicateNameException type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListValueDuplicateNameException()()()() | Initializes a new instance of the PickupListValueDuplicateNameException class.
Public method | PickupListValueDuplicateNameException(String) | Initializes a new instance of the PickupListValueDuplicateNameException class.
Public method | PickupListValueDuplicateNameException(String, Exception) | Initializes a new instance of the PickupListValueDuplicateNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateNameException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Constructor
PickupListValueDuplicateNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PickupListValueDuplicateNameException()()()() | Initializes a new instance of the PickupListValueDuplicateNameException class.
Public method | PickupListValueDuplicateNameException(String) | Initializes a new instance of the PickupListValueDuplicateNameException class.
Public method | PickupListValueDuplicateNameException(String, Exception) | Initializes a new instance of the PickupListValueDuplicateNameException class.

See Also

PickupListValueDuplicateNameException Class
PickupListValueDuplicateNameException Members
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Constructor

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Constructor
PickupListValueDuplicateNameException Class See Also Send Feedback
Initializes a new instance of the PickupListValueDuplicateNameException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueDuplicateNameException()
Visual Basic
Public Sub New
Visual C++
public:
PickupListValueDuplicateNameException()

See Also

PickupListValueDuplicateNameException Class
PickupListValueDuplicateNameException Members
PickupListValueDuplicateNameException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Constructor (String)
PickupListValueDuplicateNameException Class See Also Send Feedback
Initializes a new instance of the PickupListValueDuplicateNameException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueDuplicateNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
PickupListValueDuplicateNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

PickupListValueDuplicateNameException Class
PickupListValueDuplicateNameException Members
PickupListValueDuplicateNameException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Constructor (String, Exception)
PickupListValueDuplicateNameException Class See Also Send Feedback
Initializes a new instance of the PickupListValueDuplicateNameException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueDuplicateNameException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
PickupListValueDuplicateNameException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

PickupListValueDuplicateNameException Class
PickupListValueDuplicateNameException Members
PickupListValueDuplicateNameException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Methods
PickupListValueDuplicateNameException Class See Also Send Feedback

The PickupListValueDuplicateNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateNameException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Properties
PickupListValueDuplicateNameException Class See Also Send Feedback

The PickupListValueDuplicateNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateNameException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateNameException Events

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateNameException Events
PickupListValueDuplicateNameException Class See Also Send Feedback

The PickupListValueDuplicateNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateNameException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Class

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Class
Members See Also Send Feedback
This exception is used to catch Duplicate value of pickup list value

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PickupListValueDuplicateValueException : BaseException
Visual Basic
<SerializableAttribute>
Public Class PickupListValueDuplicateValueException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PickupListValueDuplicateValueException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Configuration..::..PickupListValueDuplicateValueException

See Also

PickupListValueDuplicateValueException Members
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Members

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Members
PickupListValueDuplicateValueException Class Constructors Methods Properties Events See Also Send Feedback

The PickupListValueDuplicateValueException type exposes the following members.

Constructors

 | Name | Description
Public method | PickupListValueDuplicateValueException()()()() | Initializes a new instance of the PickupListValueDuplicateValueException class.
Public method | PickupListValueDuplicateValueException(String) | Initializes a new instance of the PickupListValueDuplicateValueException class.
Public method | PickupListValueDuplicateValueException(String, Exception) | Initializes a new instance of the PickupListValueDuplicateValueException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateValueException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Constructor

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Constructor
PickupListValueDuplicateValueException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PickupListValueDuplicateValueException()()()() | Initializes a new instance of the PickupListValueDuplicateValueException class.
Public method | PickupListValueDuplicateValueException(String) | Initializes a new instance of the PickupListValueDuplicateValueException class.
Public method | PickupListValueDuplicateValueException(String, Exception) | Initializes a new instance of the PickupListValueDuplicateValueException class.

See Also

PickupListValueDuplicateValueException Class
PickupListValueDuplicateValueException Members
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Constructor

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Constructor
PickupListValueDuplicateValueException Class See Also Send Feedback
Initializes a new instance of the PickupListValueDuplicateValueException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueDuplicateValueException()
Visual Basic
Public Sub New
Visual C++
public:
PickupListValueDuplicateValueException()

See Also

PickupListValueDuplicateValueException Class
PickupListValueDuplicateValueException Members
PickupListValueDuplicateValueException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Constructor (String)

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Constructor (String)
PickupListValueDuplicateValueException Class See Also Send Feedback
Initializes a new instance of the PickupListValueDuplicateValueException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueDuplicateValueException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
PickupListValueDuplicateValueException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

PickupListValueDuplicateValueException Class
PickupListValueDuplicateValueException Members
PickupListValueDuplicateValueException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Constructor (String, Exception)
PickupListValueDuplicateValueException Class See Also Send Feedback
Initializes a new instance of the PickupListValueDuplicateValueException class.

Namespace: CelloSaaS.ServiceContracts.Configuration
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PickupListValueDuplicateValueException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
PickupListValueDuplicateValueException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

PickupListValueDuplicateValueException Class
PickupListValueDuplicateValueException Members
PickupListValueDuplicateValueException Overload
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Methods

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Methods
PickupListValueDuplicateValueException Class See Also Send Feedback

The PickupListValueDuplicateValueException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateValueException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Properties

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Properties
PickupListValueDuplicateValueException Class See Also Send Feedback

The PickupListValueDuplicateValueException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateValueException Class
CelloSaaS.ServiceContracts.Configuration Namespace


PickupListValueDuplicateValueException Events

[image] [image]

A Sandcastle Documented Class Library
PickupListValueDuplicateValueException Events
PickupListValueDuplicateValueException Class See Also Send Feedback

The PickupListValueDuplicateValueException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PickupListValueDuplicateValueException Class
CelloSaaS.ServiceContracts.Configuration Namespace


CelloSaaS.ServiceContracts.DataManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.DataManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | AlreadyAssignedException | Already Assigned Exception
Public class | DataManagementException | Data Management Exception
Public class | FieldMetaException | Filed Meta Data delete Exception
Public class | FieldNameUniquenessException | Field Name Uniqueness Exception
Public class | ForeignKeyException | Foreign Key Exception
Public class | InvalidDataTypeConversionException | Invalid Data Type Conversion Exception
Public class | InvalidFieldTypeException | Invalid Field Type Exception
Public class | MaximumLimitException | Maximum Limit Exception

Interfaces

 | Interface | Description
Public interface | IDataManagementService | This interface will be used to manage entity and entityfield metadata.


AlreadyAssignedException Class

[image]

A Sandcastle Documented Class Library
AlreadyAssignedException Class
Members See Also Send Feedback
Already Assigned Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AlreadyAssignedException : BaseException
Visual Basic
<SerializableAttribute>
Public Class AlreadyAssignedException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class AlreadyAssignedException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..AlreadyAssignedException

See Also

AlreadyAssignedException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Members

[image] [image]

A Sandcastle Documented Class Library
AlreadyAssignedException Members
AlreadyAssignedException Class Constructors Methods Properties Events See Also Send Feedback

The AlreadyAssignedException type exposes the following members.

Constructors

 | Name | Description
Public method | AlreadyAssignedException()()()() | Initializes a new instance of the AlreadyAssignedException class.
Public method | AlreadyAssignedException(String) | Initializes a new instance of the AlreadyAssignedException class.
Public method | AlreadyAssignedException(String, Exception) | Initializes a new instance of the AlreadyAssignedException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AlreadyAssignedException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Constructor

[image] [image]

A Sandcastle Documented Class Library
AlreadyAssignedException Constructor
AlreadyAssignedException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlreadyAssignedException()()()() | Initializes a new instance of the AlreadyAssignedException class.
Public method | AlreadyAssignedException(String) | Initializes a new instance of the AlreadyAssignedException class.
Public method | AlreadyAssignedException(String, Exception) | Initializes a new instance of the AlreadyAssignedException class.

See Also

AlreadyAssignedException Class
AlreadyAssignedException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Constructor

[image]

A Sandcastle Documented Class Library
AlreadyAssignedException Constructor
AlreadyAssignedException Class See Also Send Feedback
Initializes a new instance of the AlreadyAssignedException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AlreadyAssignedException()
Visual Basic
Public Sub New
Visual C++
public:
AlreadyAssignedException()

See Also

AlreadyAssignedException Class
AlreadyAssignedException Members
AlreadyAssignedException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Constructor (String)

[image]

A Sandcastle Documented Class Library
AlreadyAssignedException Constructor (String)
AlreadyAssignedException Class See Also Send Feedback
Initializes a new instance of the AlreadyAssignedException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AlreadyAssignedException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
AlreadyAssignedException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

AlreadyAssignedException Class
AlreadyAssignedException Members
AlreadyAssignedException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
AlreadyAssignedException Constructor (String, Exception)
AlreadyAssignedException Class See Also Send Feedback
Initializes a new instance of the AlreadyAssignedException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AlreadyAssignedException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
AlreadyAssignedException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

AlreadyAssignedException Class
AlreadyAssignedException Members
AlreadyAssignedException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Methods

[image] [image]

A Sandcastle Documented Class Library
AlreadyAssignedException Methods
AlreadyAssignedException Class See Also Send Feedback

The AlreadyAssignedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AlreadyAssignedException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Properties

[image] [image]

A Sandcastle Documented Class Library
AlreadyAssignedException Properties
AlreadyAssignedException Class See Also Send Feedback

The AlreadyAssignedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AlreadyAssignedException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


AlreadyAssignedException Events

[image] [image]

A Sandcastle Documented Class Library
AlreadyAssignedException Events
AlreadyAssignedException Class See Also Send Feedback

The AlreadyAssignedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AlreadyAssignedException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Class

[image]

A Sandcastle Documented Class Library
DataManagementException Class
Members See Also Send Feedback
Data Management Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DataManagementException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DataManagementException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DataManagementException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException

See Also

DataManagementException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Members

[image] [image]

A Sandcastle Documented Class Library
DataManagementException Members
DataManagementException Class Constructors Methods Properties Events See Also Send Feedback

The DataManagementException type exposes the following members.

Constructors

 | Name | Description
Public method | DataManagementException()()()() | Initializes a new instance of the DataManagementException class.
Public method | DataManagementException(String) | Initializes a new instance of the DataManagementException class
Public method | DataManagementException(String, Exception) | Initializes a new instance of the DataManagementException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DataManagementException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Constructor

[image] [image]

A Sandcastle Documented Class Library
DataManagementException Constructor
DataManagementException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataManagementException()()()() | Initializes a new instance of the DataManagementException class.
Public method | DataManagementException(String) | Initializes a new instance of the DataManagementException class
Public method | DataManagementException(String, Exception) | Initializes a new instance of the DataManagementException class.

See Also

DataManagementException Class
DataManagementException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Constructor

[image]

A Sandcastle Documented Class Library
DataManagementException Constructor
DataManagementException Class See Also Send Feedback
Initializes a new instance of the DataManagementException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataManagementException()
Visual Basic
Public Sub New
Visual C++
public:
DataManagementException()

See Also

DataManagementException Class
DataManagementException Members
DataManagementException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Constructor (String)

[image]

A Sandcastle Documented Class Library
DataManagementException Constructor (String)
DataManagementException Class See Also Send Feedback
Initializes a new instance of the DataManagementException class

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataManagementException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DataManagementException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

DataManagementException Class
DataManagementException Members
DataManagementException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DataManagementException Constructor (String, Exception)
DataManagementException Class See Also Send Feedback
Initializes a new instance of the DataManagementException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DataManagementException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DataManagementException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DataManagementException Class
DataManagementException Members
DataManagementException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Methods

[image] [image]

A Sandcastle Documented Class Library
DataManagementException Methods
DataManagementException Class See Also Send Feedback

The DataManagementException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataManagementException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Properties

[image] [image]

A Sandcastle Documented Class Library
DataManagementException Properties
DataManagementException Class See Also Send Feedback

The DataManagementException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DataManagementException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


DataManagementException Events

[image] [image]

A Sandcastle Documented Class Library
DataManagementException Events
DataManagementException Class See Also Send Feedback

The DataManagementException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DataManagementException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Class

[image]

A Sandcastle Documented Class Library
FieldMetaException Class
Members See Also Send Feedback
Filed Meta Data delete Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FieldMetaException : BaseException
Visual Basic
<SerializableAttribute>
Public Class FieldMetaException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class FieldMetaException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..FieldMetaException

See Also

FieldMetaException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Members

[image] [image]

A Sandcastle Documented Class Library
FieldMetaException Members
FieldMetaException Class Constructors Methods Properties Events See Also Send Feedback

The FieldMetaException type exposes the following members.

Constructors

 | Name | Description
Public method | FieldMetaException()()()() | Initializes a new instance of the FieldMetaException class.
Public method | FieldMetaException(String) | Initializes a new instance of the FieldMetaException class.
Public method | FieldMetaException(String, Exception) | Initializes a new instance of the FieldMetaException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FieldMetaException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Constructor

[image] [image]

A Sandcastle Documented Class Library
FieldMetaException Constructor
FieldMetaException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldMetaException()()()() | Initializes a new instance of the FieldMetaException class.
Public method | FieldMetaException(String) | Initializes a new instance of the FieldMetaException class.
Public method | FieldMetaException(String, Exception) | Initializes a new instance of the FieldMetaException class.

See Also

FieldMetaException Class
FieldMetaException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Constructor

[image]

A Sandcastle Documented Class Library
FieldMetaException Constructor
FieldMetaException Class See Also Send Feedback
Initializes a new instance of the FieldMetaException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldMetaException()
Visual Basic
Public Sub New
Visual C++
public:
FieldMetaException()

See Also

FieldMetaException Class
FieldMetaException Members
FieldMetaException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Constructor (String)

[image]

A Sandcastle Documented Class Library
FieldMetaException Constructor (String)
FieldMetaException Class See Also Send Feedback
Initializes a new instance of the FieldMetaException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldMetaException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
FieldMetaException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

FieldMetaException Class
FieldMetaException Members
FieldMetaException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
FieldMetaException Constructor (String, Exception)
FieldMetaException Class See Also Send Feedback
Initializes a new instance of the FieldMetaException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldMetaException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
FieldMetaException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

FieldMetaException Class
FieldMetaException Members
FieldMetaException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Methods

[image] [image]

A Sandcastle Documented Class Library
FieldMetaException Methods
FieldMetaException Class See Also Send Feedback

The FieldMetaException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FieldMetaException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Properties

[image] [image]

A Sandcastle Documented Class Library
FieldMetaException Properties
FieldMetaException Class See Also Send Feedback

The FieldMetaException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FieldMetaException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldMetaException Events

[image] [image]

A Sandcastle Documented Class Library
FieldMetaException Events
FieldMetaException Class See Also Send Feedback

The FieldMetaException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FieldMetaException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Class

[image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Class
Members See Also Send Feedback
Field Name Uniqueness Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class FieldNameUniquenessException : BaseException
Visual Basic
<SerializableAttribute>
Public Class FieldNameUniquenessException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class FieldNameUniquenessException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..FieldNameUniquenessException

See Also

FieldNameUniquenessException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Members

[image] [image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Members
FieldNameUniquenessException Class Constructors Methods Properties Events See Also Send Feedback

The FieldNameUniquenessException type exposes the following members.

Constructors

 | Name | Description
Public method | FieldNameUniquenessException()()()() | Initializes a new instance of the FieldNameUniquenessException class.
Public method | FieldNameUniquenessException(String) | Initializes a new instance of the FieldNameUniquenessException class.
Public method | FieldNameUniquenessException(String, Exception) | Initializes a new instance of the FieldNameUniquenessException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FieldNameUniquenessException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Constructor

[image] [image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Constructor
FieldNameUniquenessException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldNameUniquenessException()()()() | Initializes a new instance of the FieldNameUniquenessException class.
Public method | FieldNameUniquenessException(String) | Initializes a new instance of the FieldNameUniquenessException class.
Public method | FieldNameUniquenessException(String, Exception) | Initializes a new instance of the FieldNameUniquenessException class.

See Also

FieldNameUniquenessException Class
FieldNameUniquenessException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Constructor

[image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Constructor
FieldNameUniquenessException Class See Also Send Feedback
Initializes a new instance of the FieldNameUniquenessException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldNameUniquenessException()
Visual Basic
Public Sub New
Visual C++
public:
FieldNameUniquenessException()

See Also

FieldNameUniquenessException Class
FieldNameUniquenessException Members
FieldNameUniquenessException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Constructor (String)

[image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Constructor (String)
FieldNameUniquenessException Class See Also Send Feedback
Initializes a new instance of the FieldNameUniquenessException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldNameUniquenessException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
FieldNameUniquenessException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

FieldNameUniquenessException Class
FieldNameUniquenessException Members
FieldNameUniquenessException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Constructor (String, Exception)
FieldNameUniquenessException Class See Also Send Feedback
Initializes a new instance of the FieldNameUniquenessException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public FieldNameUniquenessException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
FieldNameUniquenessException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

FieldNameUniquenessException Class
FieldNameUniquenessException Members
FieldNameUniquenessException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Methods

[image] [image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Methods
FieldNameUniquenessException Class See Also Send Feedback

The FieldNameUniquenessException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FieldNameUniquenessException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Properties

[image] [image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Properties
FieldNameUniquenessException Class See Also Send Feedback

The FieldNameUniquenessException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FieldNameUniquenessException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


FieldNameUniquenessException Events

[image] [image]

A Sandcastle Documented Class Library
FieldNameUniquenessException Events
FieldNameUniquenessException Class See Also Send Feedback

The FieldNameUniquenessException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FieldNameUniquenessException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Class

[image]

A Sandcastle Documented Class Library
ForeignKeyException Class
Members See Also Send Feedback
Foreign Key Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ForeignKeyException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ForeignKeyException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ForeignKeyException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..ForeignKeyException

See Also

ForeignKeyException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Members

[image] [image]

A Sandcastle Documented Class Library
ForeignKeyException Members
ForeignKeyException Class Constructors Methods Properties Events See Also Send Feedback

The ForeignKeyException type exposes the following members.

Constructors

 | Name | Description
Public method | ForeignKeyException()()()() | Initializes a new instance of the ForeignKeyException class.
Public method | ForeignKeyException(String, Exception) | Initializes a new instance of the ForeignKeyException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ForeignKeyException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Constructor

[image] [image]

A Sandcastle Documented Class Library
ForeignKeyException Constructor
ForeignKeyException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForeignKeyException()()()() | Initializes a new instance of the ForeignKeyException class.
Public method | ForeignKeyException(String, Exception) | Initializes a new instance of the ForeignKeyException class.

See Also

ForeignKeyException Class
ForeignKeyException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Constructor

[image]

A Sandcastle Documented Class Library
ForeignKeyException Constructor
ForeignKeyException Class See Also Send Feedback
Initializes a new instance of the ForeignKeyException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ForeignKeyException()
Visual Basic
Public Sub New
Visual C++
public:
ForeignKeyException()

See Also

ForeignKeyException Class
ForeignKeyException Members
ForeignKeyException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ForeignKeyException Constructor (String, Exception)
ForeignKeyException Class See Also Send Feedback
Initializes a new instance of the ForeignKeyException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ForeignKeyException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ForeignKeyException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

ForeignKeyException Class
ForeignKeyException Members
ForeignKeyException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Methods

[image] [image]

A Sandcastle Documented Class Library
ForeignKeyException Methods
ForeignKeyException Class See Also Send Feedback

The ForeignKeyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ForeignKeyException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Properties

[image] [image]

A Sandcastle Documented Class Library
ForeignKeyException Properties
ForeignKeyException Class See Also Send Feedback

The ForeignKeyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForeignKeyException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


ForeignKeyException Events

[image] [image]

A Sandcastle Documented Class Library
ForeignKeyException Events
ForeignKeyException Class See Also Send Feedback

The ForeignKeyException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ForeignKeyException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService Interface

[image]

A Sandcastle Documented Class Library
IDataManagementService Interface
Members See Also Send Feedback
This interface will be used to manage entity and entityfield metadata.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IDataManagementService
Visual Basic
Public Interface IDataManagementService
Visual C++
public interface class IDataManagementService

See Also

IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService Members

[image] [image]

A Sandcastle Documented Class Library
IDataManagementService Members
IDataManagementService Interface Methods See Also Send Feedback

The IDataManagementService type exposes the following members.

Methods

 | Name | Description
Public method | CheckExtendedFieldsByTenantIdAndEntity | This method is used to check whether extended field exists for given tenant and entity
Public method | CheckPickupListDependency | This method is used to check the pickup list dependency.
Public method | CopyAllParentExtendedFields | This method is used to copy all extended fields from all self entities from parent tenant
Public method | CopyParentExtendedFields | This method is used to copy all extended fields from parent tenant
Public method | DeleteExtendedEntityRow | This method is used to Delete the extended entity row.
Public method | DeleteFieldMetaData | This method is used to delete field metadata for the given entity,tenant and fieldIdentifier
Public method | GetAllEntityFieldType | This method is used to gets the data type of all entity field.
Public method | GetAllEntityMetaData(String) | This method is used to get all entity meta data.
Public method | GetAllEntityMetaData(array<String>[]()[][]) | This method is used to get Entity metadata based on the features which is IsExtendable
Public method | GetAllEntityMetaDataByTenantId | Gets all entity meta data by tenant id.
Public method | GetAllEntityMetaDataIsExtendable | This method is used to get Entity metadata based on the features which is IsExtendable
Public method | GetBaseFields | This method is used to get the base fields.
Public method | GetEntityFieldMetaData | This method is used to get the entity field meta data.
Public method | GetEntityKeyValuePair | This method is used to get the entity key value pair.
Public method | GetEntityMetaData(String, String) | This method is used to get the metaData information for the entity for the tenant and entity
Public method | GetEntityMetaData(array<String>[]()[][], String) | This method is used to get the entity meta data for the given collection of entity identifiers
Public method | GetEntityMetaDataForSchemaTable | This method is used to get the entity meta data for schema table.
Public method | GetExtendedEntityRow | This method is used to get the extended entity row.
Public method | GetExtendedEntityRows | This method is used to get the extended entity rows.
Public method | GetExtendedFields | This method is used to get the extended fields.
Public method | GetExtendedFieldsByTenantId | This method is used to get entity extended fields meta data for given tenant
Public method | GetFields | This method is used to get both extended and base field metadata for given entity and tenant
Public method | GetFieldsForSchemaTable | This method is used to get the entity meta data for schema table.
Public method | GetOwnEntityFieldMetaData | This method is used to get the entity field meta data from own settings
Public method | GetOwnEntityMetaData | This method is used to get the entity meta data from own settings
Public method | GetOwnExtendedFields | This method is used to get all extended field metadata for given entity and tenant from own settings Does not lookup parent tenant
Public method | IsFieldIdentifierUnique | Obsolete. This method is used to determine whether [is field identifier unique] [the specified field id].
Public method | QueryForExtendedFieldsReferenceIds | this method returns the required query as string for getting reference ids of the extension table that are matched with the given expression or search value
Public method | SaveEntityMetaData | This method is used to save the entity meta data.
Public method | SaveExtendedEntityRow | This method is used to save the extended entity row.
Public method | SaveFieldMetaData | This method is used to save the field meta data.
Public method | SearchExtendedFields | This method is used to search the extended entity meta data values for schema table with tenant id , entity name and search condition
Public method | SearchExtendedFieldsReferenceIds | this method returns the list of reference ids of the extension table that are matched with the given expression or search value
Public method | UpdateDisplayColumName | Updates the display name of the column.

See Also

IDataManagementService Interface
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService Methods

[image] [image]

A Sandcastle Documented Class Library
IDataManagementService Methods
IDataManagementService Interface See Also Send Feedback

The IDataManagementService type exposes the following members.

Methods

 | Name | Description
Public method | CheckExtendedFieldsByTenantIdAndEntity | This method is used to check whether extended field exists for given tenant and entity
Public method | CheckPickupListDependency | This method is used to check the pickup list dependency.
Public method | CopyAllParentExtendedFields | This method is used to copy all extended fields from all self entities from parent tenant
Public method | CopyParentExtendedFields | This method is used to copy all extended fields from parent tenant
Public method | DeleteExtendedEntityRow | This method is used to Delete the extended entity row.
Public method | DeleteFieldMetaData | This method is used to delete field metadata for the given entity,tenant and fieldIdentifier
Public method | GetAllEntityFieldType | This method is used to gets the data type of all entity field.
Public method | GetAllEntityMetaData(String) | This method is used to get all entity meta data.
Public method | GetAllEntityMetaData(array<String>[]()[][]) | This method is used to get Entity metadata based on the features which is IsExtendable
Public method | GetAllEntityMetaDataByTenantId | Gets all entity meta data by tenant id.
Public method | GetAllEntityMetaDataIsExtendable | This method is used to get Entity metadata based on the features which is IsExtendable
Public method | GetBaseFields | This method is used to get the base fields.
Public method | GetEntityFieldMetaData | This method is used to get the entity field meta data.
Public method | GetEntityKeyValuePair | This method is used to get the entity key value pair.
Public method | GetEntityMetaData(String, String) | This method is used to get the metaData information for the entity for the tenant and entity
Public method | GetEntityMetaData(array<String>[]()[][], String) | This method is used to get the entity meta data for the given collection of entity identifiers
Public method | GetEntityMetaDataForSchemaTable | This method is used to get the entity meta data for schema table.
Public method | GetExtendedEntityRow | This method is used to get the extended entity row.
Public method | GetExtendedEntityRows | This method is used to get the extended entity rows.
Public method | GetExtendedFields | This method is used to get the extended fields.
Public method | GetExtendedFieldsByTenantId | This method is used to get entity extended fields meta data for given tenant
Public method | GetFields | This method is used to get both extended and base field metadata for given entity and tenant
Public method | GetFieldsForSchemaTable | This method is used to get the entity meta data for schema table.
Public method | GetOwnEntityFieldMetaData | This method is used to get the entity field meta data from own settings
Public method | GetOwnEntityMetaData | This method is used to get the entity meta data from own settings
Public method | GetOwnExtendedFields | This method is used to get all extended field metadata for given entity and tenant from own settings Does not lookup parent tenant
Public method | IsFieldIdentifierUnique | Obsolete. This method is used to determine whether [is field identifier unique] [the specified field id].
Public method | QueryForExtendedFieldsReferenceIds | this method returns the required query as string for getting reference ids of the extension table that are matched with the given expression or search value
Public method | SaveEntityMetaData | This method is used to save the entity meta data.
Public method | SaveExtendedEntityRow | This method is used to save the extended entity row.
Public method | SaveFieldMetaData | This method is used to save the field meta data.
Public method | SearchExtendedFields | This method is used to search the extended entity meta data values for schema table with tenant id , entity name and search condition
Public method | SearchExtendedFieldsReferenceIds | this method returns the list of reference ids of the extension table that are matched with the given expression or search value
Public method | UpdateDisplayColumName | Updates the display name of the column.

See Also

IDataManagementService Interface
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.CheckExtendedFieldsByTenantIdAndEntity Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..CheckExtendedFieldsByTenantIdAndEntity Method
IDataManagementService Interface See Also Send Feedback
This method is used to check whether extended field exists for given tenant and entity

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckExtendedFieldsByTenantIdAndEntity(
    string tenantId,
    string entityName
)
Visual Basic
Function CheckExtendedFieldsByTenantIdAndEntity (
    tenantId As String,
    entityName As String
) As Boolean
Visual C++
bool CheckExtendedFieldsByTenantIdAndEntity(
    String^ tenantId,
    String^ entityName
)

Parameters

tenantId
Type: System..::..String
Tenant Id
entityName
Type: System..::..String
Entity Name

Return Value

Type: Boolean
it returns true when tenantid and entityname is present otherwise it will return false

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching extended field column details
System..::..ArgumentNullException | This exception is thrown when tenant id or entity name is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.CheckPickupListDependency Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..CheckPickupListDependency Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to check the pickup list dependency.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckPickupListDependency(
    string pickupListId
)
Visual Basic
Function CheckPickupListDependency (
    pickupListId As String
) As Boolean
Visual C++
bool CheckPickupListDependency(
    String^ pickupListId
)

Parameters

pickupListId
Type: System..::..String
The pickup list id.

Return Value

Type: Boolean
true if it is referd in dataview otherwise, false.

Examples

Copy image Copy
public void CheckPickupListDependency()
{
    string pickupListId = "A60F4864-0494-DF11-8DEB-001EC9
    DAB123";
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    bool pickupListDependency = dataManagementService.CheckPickupListDependency(pickupListId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown pickup list id is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.CopyAllParentExtendedFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..CopyAllParentExtendedFields Method
IDataManagementService Interface See Also Send Feedback
This method is used to copy all extended fields from all self entities from parent tenant

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int CopyAllParentExtendedFields(
    string tenantId
)
Visual Basic
Function CopyAllParentExtendedFields (
    tenantId As String
) As Integer
Visual C++
int CopyAllParentExtendedFields(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
logged in tenant identifier

Return Value

Type: Int32
Total number of extended fields copied.

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when tenant id is null or empty
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while copying extended fields from parent

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.CopyParentExtendedFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..CopyParentExtendedFields Method
IDataManagementService Interface See Also Send Feedback
This method is used to copy all extended fields from parent tenant

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int CopyParentExtendedFields(
    string entityId,
    string tenantId
)
Visual Basic
Function CopyParentExtendedFields (
    entityId As String,
    tenantId As String
) As Integer
Visual C++
int CopyParentExtendedFields(
    String^ entityId,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
entity identifer
tenantId
Type: System..::..String
logged in tenant identifier

Return Value

Type: Int32
Total number of extended fields copied.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown when extended field setting is PARENT_SETTING or No extended fields for product admin
CelloSaaS.ServiceContracts.DataManagement..::..AlreadyAssignedException | This exception is thrown when extended fields are already created
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while copying extended fields from parent

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.DeleteExtendedEntityRow Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..DeleteExtendedEntityRow Method
IDataManagementService Interface See Also Send Feedback
This method is used to Delete the extended entity row.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool DeleteExtendedEntityRow(
    string entityName,
    string tenantId,
    string referenceId
)
Visual Basic
Function DeleteExtendedEntityRow (
    entityName As String,
    tenantId As String,
    referenceId As String
) As Boolean
Visual C++
bool DeleteExtendedEntityRow(
    String^ entityName,
    String^ tenantId,
    String^ referenceId
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
referenceId
Type: System..::..String
The reference id.

Return Value

Type: Boolean

Exceptions

Exception | Condition
System..::..NotImplementedException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.DeleteFieldMetaData Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..DeleteFieldMetaData Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to delete field metadata for the given entity,tenant and fieldIdentifier

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool DeleteFieldMetaData(
    string entityName,
    string tenantId,
    string fieldIdentifier
)
Visual Basic
Function DeleteFieldMetaData (
    entityName As String,
    tenantId As String,
    fieldIdentifier As String
) As Boolean
Visual C++
bool DeleteFieldMetaData(
    String^ entityName,
    String^ tenantId,
    String^ fieldIdentifier
)

Parameters

entityName
Type: System..::..String
Entity Name
tenantId
Type: System..::..String
Tenant Identifier
fieldIdentifier
Type: System..::..String
Field Identifier

Return Value

Type: Boolean
returns True if it is deleted otherwise False

Examples

Copy image Copy
public void DeleteFieldMetaData()
{
    string entityName = "User";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string fieldIdentifier = "User_FirstName";
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    bool fieldMetaDataDeleted = dataManagementService.DeleteFieldMetaData(entityName, tenantId, fieldIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while deleting entity field metadata
System..::..ArgumentNullException | This exception is thrown when entity name or tenant id or entityfield meta data or fieldIdentifier's is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetAllEntityFieldType Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetAllEntityFieldType Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to gets the data type of all entity field.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, FieldDataType> GetAllEntityFieldType()
Visual Basic
Function GetAllEntityFieldType As Dictionary(Of String, FieldDataType)
Visual C++
Dictionary<String^, FieldDataType^>^ GetAllEntityFieldType()

Return Value

Type: Dictionary<(Of <(<'String, FieldDataType >)>)>
Dictionary of data type of all entity field

Examples

Copy image Copy
public void GetAllEntityFieldType()
{
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    Dictionary<string, FieldDataType> fieldDataTypeDetails = dataManagementService.GetAllEntityFieldType();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching all entity fieldTypeId

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetAllEntityMetaData Method

[image] [image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetAllEntityMetaData Method
IDataManagementService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAllEntityMetaData(String) | This method is used to get all entity meta data.
Public method | GetAllEntityMetaData(array<String>[]()[][]) | This method is used to get Entity metadata based on the features which is IsExtendable

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetAllEntityMetaData Method (String)

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetAllEntityMetaData Method (String)
IDataManagementService Interface Example See Also Send Feedback
This method is used to get all entity meta data.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityMetaData> GetAllEntityMetaData(
    string tenantId = null
)
Visual Basic
Function GetAllEntityMetaData (
    Optional tenantId As String = Nothing
) As Dictionary(Of String, EntityMetaData)
Visual C++
Dictionary<String^, EntityMetaData^>^ GetAllEntityMetaData(
    String^ tenantId = nullptr
)

Parameters

tenantId (Optional)
Type: System..::..String

Return Value

Type: Dictionary<(Of <(<'String, EntityMetaData >)>)>
Dictioary of all entity meta data

Examples

Copy image Copy
public void GetAllEntityMetaData()
{
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    Dictionary<string, EntityMetaData> entityMetaDataDetails = dataManagementService.GetAllEntityMetaData();
}

See Also

IDataManagementService Interface
IDataManagementService Members
GetAllEntityMetaData Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetAllEntityMetaData Method (String[])

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetAllEntityMetaData Method (array<String>[]()[][])
IDataManagementService Interface Example See Also Send Feedback
This method is used to get Entity metadata based on the features which is IsExtendable

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityMetaData> GetAllEntityMetaData(
    string[] featureIds
)
Visual Basic
Function GetAllEntityMetaData (
    featureIds As String()
) As Dictionary(Of String, EntityMetaData)
Visual C++
Dictionary<String^, EntityMetaData^>^ GetAllEntityMetaData(
    array<String^>^ featureIds
)

Parameters

featureIds
Type: array<System..::..String>[]()[][]
Feature Details

Return Value

Type: Dictionary<(Of <(<'String, EntityMetaData >)>)>
Entity metadata based on the features

Examples

Copy image Copy
public void GetAllEntityMetaData()
{
    string[] featureIds = new string[] {"ManageRole","ManagePickupList","ManageUser","ManageUserRoles" };
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    Dictionary<string, EntityMetaData> entityMetaDataDetails = dataManagementService.GetAllEntityMetaData(featureIds);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is null or empty when featureIds is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
GetAllEntityMetaData Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetAllEntityMetaDataByTenantId Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetAllEntityMetaDataByTenantId Method
IDataManagementService Interface See Also Send Feedback
Gets all entity meta data by tenant id.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityMetaData> GetAllEntityMetaDataByTenantId(
    string[] featureIds,
    string tenantId
)
Visual Basic
Function GetAllEntityMetaDataByTenantId (
    featureIds As String(),
    tenantId As String
) As Dictionary(Of String, EntityMetaData)
Visual C++
Dictionary<String^, EntityMetaData^>^ GetAllEntityMetaDataByTenantId(
    array<String^>^ featureIds,
    String^ tenantId
)

Parameters

featureIds
Type: array<System..::..String>[]()[][]
The feature ids.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, EntityMetaData >)>)>

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetAllEntityMetaDataIsExtendable Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetAllEntityMetaDataIsExtendable Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to get Entity metadata based on the features which is IsExtendable

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityMetaData> GetAllEntityMetaDataIsExtendable(
    string[] featureIds
)
Visual Basic
Function GetAllEntityMetaDataIsExtendable (
    featureIds As String()
) As Dictionary(Of String, EntityMetaData)
Visual C++
Dictionary<String^, EntityMetaData^>^ GetAllEntityMetaDataIsExtendable(
    array<String^>^ featureIds
)

Parameters

featureIds
Type: array<System..::..String>[]()[][]
Feature Details

Return Value

Type: Dictionary<(Of <(<'String, EntityMetaData >)>)>
Entity metadata based on the features

Examples

Copy image Copy
public void GetAllEntityMetaDataIsExtendable()
{
    string[] featureIds = new string[] {"ManageRole","ManagePickupList","ManageUser","ManageUserRoles" };
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    Dictionary<string, EntityMetaData> entityMetaDataDetails = dataManagementService.GetAllEntityMetaDataIsExtendable(featureIds);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is null or empty when featureIds is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetBaseFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetBaseFields Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to get the base fields.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityFieldMetaData> GetBaseFields(
    string entityName
)
Visual Basic
Function GetBaseFields (
    entityName As String
) As Dictionary(Of String, EntityFieldMetaData)
Visual C++
Dictionary<String^, EntityFieldMetaData^>^ GetBaseFields(
    String^ entityName
)

Parameters

entityName
Type: System..::..String
Name of the entity.

Return Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>
Dictionary of base fields meta data

Examples

Copy image Copy
public void GetAllEntityMetaData()
{
string entityName = "User";
IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
Dictionary<string, EntityFieldMetaData> entityFieldMetaDataDetails = dataManagementService.GetBaseFields(entityName);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when entity name is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetEntityFieldMetaData Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetEntityFieldMetaData Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to get the entity field meta data.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityFieldMetaData GetEntityFieldMetaData(
    string entityName,
    string tenantId,
    string fieldIdentifier
)
Visual Basic
Function GetEntityFieldMetaData (
    entityName As String,
    tenantId As String,
    fieldIdentifier As String
) As EntityFieldMetaData
Visual C++
EntityFieldMetaData^ GetEntityFieldMetaData(
    String^ entityName,
    String^ tenantId,
    String^ fieldIdentifier
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
fieldIdentifier
Type: System..::..String
The field identifier.

Return Value

Type: EntityFieldMetaData
Entity field meta data details

Examples

Copy image Copy
public void GetEntityFieldMetaData()
{
    string entityName = "User";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string fieldIdentifier = "User_FirstName";
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    EntityFieldMetaData entityFieldMetaData = dataManagementService.GetEntityFieldMetaData(entityName, tenantId, fieldIdentifier);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when entity name or tenant id or field identifier is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetEntityKeyValuePair Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetEntityKeyValuePair Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the entity key value pair.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string> GetEntityKeyValuePair(
    string entityIdentifier,
    string tenantIdentifier
)
Visual Basic
Function GetEntityKeyValuePair (
    entityIdentifier As String,
    tenantIdentifier As String
) As Dictionary(Of String, String)
Visual C++
Dictionary<String^, String^>^ GetEntityKeyValuePair(
    String^ entityIdentifier,
    String^ tenantIdentifier
)

Parameters

entityIdentifier
Type: System..::..String
The entity identifier.
tenantIdentifier
Type: System..::..String
The tenant identifier.

Return Value

Type: Dictionary<(Of <(<'String, String>)>)>
Dictionary of key value pair

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetEntityMetaData Method

[image] [image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetEntityMetaData Method
IDataManagementService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEntityMetaData(String, String) | This method is used to get the metaData information for the entity for the tenant and entity
Public method | GetEntityMetaData(array<String>[]()[][], String) | This method is used to get the entity meta data for the given collection of entity identifiers

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetEntityMetaData Method (String, String)

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetEntityMetaData Method (String, String)
IDataManagementService Interface Example See Also Send Feedback
This method is used to get the metaData information for the entity for the tenant and entity

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityMetaData GetEntityMetaData(
    string entityIdentifier,
    string tenantIdentifier
)
Visual Basic
Function GetEntityMetaData (
    entityIdentifier As String,
    tenantIdentifier As String
) As EntityMetaData
Visual C++
EntityMetaData^ GetEntityMetaData(
    String^ entityIdentifier,
    String^ tenantIdentifier
)

Parameters

entityIdentifier
Type: System..::..String
Entity Identifier
tenantIdentifier
Type: System..::..String
Tenant Identifier

Return Value

Type: EntityMetaData
Entity Meta Data Details

Examples

Copy image Copy
public void GetEntityMetaData()
{
    string entityIdentifier = "User";
    string tenantIdentifier = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    EntityMetaData entityMetaData = dataManagementService.GetEntityMetaData(entityIdentifier, tenantIdentifier);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching entity metadata
System..::..ArgumentNullException | This exception is thrown when tenant id or entity is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
GetEntityMetaData Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetEntityMetaData Method (String[], String)

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetEntityMetaData Method (array<String>[]()[][], String)
IDataManagementService Interface See Also Send Feedback
This method is used to get the entity meta data for the given collection of entity identifiers

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityMetaData> GetEntityMetaData(
    string[] entityIdentifiers,
    string tenantIdentifier
)
Visual Basic
Function GetEntityMetaData (
    entityIdentifiers As String(),
    tenantIdentifier As String
) As Dictionary(Of String, EntityMetaData)
Visual C++
Dictionary<String^, EntityMetaData^>^ GetEntityMetaData(
    array<String^>^ entityIdentifiers,
    String^ tenantIdentifier
)

Parameters

entityIdentifiers
Type: array<System..::..String>[]()[][]
The entity identifiers.
tenantIdentifier
Type: System..::..String
The tenant identifier.

Return Value

Type: Dictionary<(Of <(<'String, EntityMetaData >)>)>
Entity field meta data details

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when tenant id or entity identitfier is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
GetEntityMetaData Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetEntityMetaDataForSchemaTable Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetEntityMetaDataForSchemaTable Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the entity meta data for schema table.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityMetaData GetEntityMetaDataForSchemaTable(
    string schemaTableName,
    string tenantIdentifier
)
Visual Basic
Function GetEntityMetaDataForSchemaTable (
    schemaTableName As String,
    tenantIdentifier As String
) As EntityMetaData
Visual C++
EntityMetaData^ GetEntityMetaDataForSchemaTable(
    String^ schemaTableName,
    String^ tenantIdentifier
)

Parameters

schemaTableName
Type: System..::..String
Name of the schema table.
tenantIdentifier
Type: System..::..String
The tenant identifier.

Return Value

Type: EntityMetaData
Entity Field Meta Data Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when tenant id or schema table is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetExtendedEntityRow Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetExtendedEntityRow Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the extended entity row.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ExtendedEntityRow GetExtendedEntityRow(
    string entityName,
    string tenantId,
    string referenceId
)
Visual Basic
Function GetExtendedEntityRow (
    entityName As String,
    tenantId As String,
    referenceId As String
) As ExtendedEntityRow
Visual C++
ExtendedEntityRow^ GetExtendedEntityRow(
    String^ entityName,
    String^ tenantId,
    String^ referenceId
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
referenceId
Type: System..::..String
The reference id.

Return Value

Type: ExtendedEntityRow

Exceptions

Exception | Condition
System..::..NotImplementedException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetExtendedEntityRows Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetExtendedEntityRows Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the extended entity rows.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, ExtendedEntityRow> GetExtendedEntityRows(
    string entityName,
    string tenantId,
    string[] referenceIds
)
Visual Basic
Function GetExtendedEntityRows (
    entityName As String,
    tenantId As String,
    referenceIds As String()
) As Dictionary(Of String, ExtendedEntityRow)
Visual C++
Dictionary<String^, ExtendedEntityRow^>^ GetExtendedEntityRows(
    String^ entityName,
    String^ tenantId,
    array<String^>^ referenceIds
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
referenceIds
Type: array<System..::..String>[]()[][]
The reference ids.

Return Value

Type: Dictionary<(Of <(<'String, ExtendedEntityRow >)>)>

Exceptions

Exception | Condition
System..::..NotImplementedException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetExtendedFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetExtendedFields Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to get the extended fields.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityFieldMetaData> GetExtendedFields(
    string entityName,
    string tenantId
)
Visual Basic
Function GetExtendedFields (
    entityName As String,
    tenantId As String
) As Dictionary(Of String, EntityFieldMetaData)
Visual C++
Dictionary<String^, EntityFieldMetaData^>^ GetExtendedFields(
    String^ entityName,
    String^ tenantId
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>
Dictionary of extended field meata data details

Return Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>
it returns dictionary of extended fields

Examples

Copy image Copy
public void GetExtendedFields()
{
string entityName = "User";
string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
Dictionary<string, EntityFieldMetaData> entityFieldMetaDataDetails = dataManagementService.GetExtendedFields(entityName, tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception occurs when entity identifier or tenant identifier or extended fields search condition is null or empty
System..::..ArgumentException | This exception occurs when condition format is null or empty
CelloSaaS.Model..::..InvalidSearchConditionException | This exception occurs when condition format is invalid
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception occurs while searching extended fields value

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetExtendedFieldsByTenantId Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetExtendedFieldsByTenantId Method
IDataManagementService Interface See Also Send Feedback
This method is used to get entity extended fields meta data for given tenant

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, int> GetExtendedFieldsByTenantId(
    string tenantId
)
Visual Basic
Function GetExtendedFieldsByTenantId (
    tenantId As String
) As Dictionary(Of String, Integer)
Visual C++
Dictionary<String^, int>^ GetExtendedFieldsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: Dictionary<(Of <(<'String, Int32>)>)>
Entity Field Meta Data Details

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching extended field column details
System..::..ArgumentNullException | This exception is thrown when tenant id is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetFields Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to get both extended and base field metadata for given entity and tenant

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityFieldMetaData> GetFields(
    string entityName,
    string tenantId
)
Visual Basic
Function GetFields (
    entityName As String,
    tenantId As String
) As Dictionary(Of String, EntityFieldMetaData)
Visual C++
Dictionary<String^, EntityFieldMetaData^>^ GetFields(
    String^ entityName,
    String^ tenantId
)

Parameters

entityName
Type: System..::..String
The entity identifier.
tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>
Dictionary of Entity Field Meta Data Details

Examples

Copy image Copy
public void GetFields()
{
string entityName = "User";
string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
Dictionary<string, EntityFieldMetaData> entityFieldMetaDataDetails = dataManagementService.GetFields(entityName, tenantId);
}

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetFieldsForSchemaTable Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetFieldsForSchemaTable Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the entity meta data for schema table.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityFieldMetaData> GetFieldsForSchemaTable(
    string schemaTableName,
    string tenantId
)
Visual Basic
Function GetFieldsForSchemaTable (
    schemaTableName As String,
    tenantId As String
) As Dictionary(Of String, EntityFieldMetaData)
Visual C++
Dictionary<String^, EntityFieldMetaData^>^ GetFieldsForSchemaTable(
    String^ schemaTableName,
    String^ tenantId
)

Parameters

schemaTableName
Type: System..::..String
Name of the schema table.
tenantId
Type: System..::..String
The tenant identifier.

Return Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>
Dictionary of Entity Field Meta Data Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when schema table name or tenant id is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetOwnEntityFieldMetaData Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetOwnEntityFieldMetaData Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the entity field meta data from own settings

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityFieldMetaData GetOwnEntityFieldMetaData(
    string entityName,
    string tenantId,
    string fieldIdentifier
)
Visual Basic
Function GetOwnEntityFieldMetaData (
    entityName As String,
    tenantId As String,
    fieldIdentifier As String
) As EntityFieldMetaData
Visual C++
EntityFieldMetaData^ GetOwnEntityFieldMetaData(
    String^ entityName,
    String^ tenantId,
    String^ fieldIdentifier
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
fieldIdentifier
Type: System..::..String
The field identifier.

Return Value

Type: EntityFieldMetaData
Entity field meta data details from own settings

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when entity name or tenant id or field identifier is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetOwnEntityMetaData Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetOwnEntityMetaData Method
IDataManagementService Interface See Also Send Feedback
This method is used to get the entity meta data from own settings

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
EntityMetaData GetOwnEntityMetaData(
    string entityIdentifier,
    string tenantIdentifier
)
Visual Basic
Function GetOwnEntityMetaData (
    entityIdentifier As String,
    tenantIdentifier As String
) As EntityMetaData
Visual C++
EntityMetaData^ GetOwnEntityMetaData(
    String^ entityIdentifier,
    String^ tenantIdentifier
)

Parameters

entityIdentifier
Type: System..::..String
The entity identifier.
tenantIdentifier
Type: System..::..String
The tenant identifier.

Return Value

Type: EntityMetaData
Entity meta data details from own settings

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching entity metadata
System..::..ArgumentNullException | This exception is thrown when tenant id or entity is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.GetOwnExtendedFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..GetOwnExtendedFields Method
IDataManagementService Interface See Also Send Feedback
This method is used to get all extended field metadata for given entity and tenant from own settings Does not lookup parent tenant

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, EntityFieldMetaData> GetOwnExtendedFields(
    string entityId,
    string tenantId
)
Visual Basic
Function GetOwnExtendedFields (
    entityId As String,
    tenantId As String
) As Dictionary(Of String, EntityFieldMetaData)
Visual C++
Dictionary<String^, EntityFieldMetaData^>^ GetOwnExtendedFields(
    String^ entityId,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
Entity id
tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: Dictionary<(Of <(<'String, EntityFieldMetaData >)>)>
Entity Field Meta Data Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when entity id or tenant id is null or empty
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching field metadata

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.IsFieldIdentifierUnique Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..IsFieldIdentifierUnique Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to determine whether [is field identifier unique] [the specified field id].

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("This service will be removed from the next version")]
bool IsFieldIdentifierUnique(
    string fieldId
)
Visual Basic
<ObsoleteAttribute("This service will be removed from the next version")>
Function IsFieldIdentifierUnique (
    fieldId As String
) As Boolean
Visual C++
[ObsoleteAttribute(L"This service will be removed from the next version")]
bool IsFieldIdentifierUnique(
    String^ fieldId
)

Parameters

fieldId
Type: System..::..String
The field id.

Return Value

Type: Boolean
true if [is field identifier unique] [the specified field id]; otherwise, false.

Examples

Copy image Copy
public void IsFieldIdentifierUnique()
{
    string fieldId = "User_FirstName";
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    bool uniqueFieldIdentifier = dataManagementService.IsFieldIdentifierUnique(fieldId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while fetching field metadata
System..::..ArgumentNullException | This exception is thrown while field id is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.QueryForExtendedFieldsReferenceIds Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..QueryForExtendedFieldsReferenceIds Method
IDataManagementService Interface See Also Send Feedback
this method returns the required query as string for getting reference ids of the extension table that are matched with the given expression or search value

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string QueryForExtendedFieldsReferenceIds(
    ExtendedFieldsSearchCondition extendedFieldsSearchCondition
)
Visual Basic
Function QueryForExtendedFieldsReferenceIds (
    extendedFieldsSearchCondition As ExtendedFieldsSearchCondition
) As String
Visual C++
String^ QueryForExtendedFieldsReferenceIds(
    ExtendedFieldsSearchCondition^ extendedFieldsSearchCondition
)

Parameters

extendedFieldsSearchCondition
Type: CelloSaaS.Model.DataManagement..::..ExtendedFieldsSearchCondition
The extended fields search condition.

Return Value

Type: String

Exceptions

Exception | Condition
CelloSaaS.Model..::..InvalidSearchConditionException |
System..::..ArgumentException |
System..::..ArgumentNullException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.SaveEntityMetaData Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..SaveEntityMetaData Method
IDataManagementService Interface See Also Send Feedback
This method is used to save the entity meta data.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool SaveEntityMetaData(
    string entityName,
    EntityMetaData entityMetaData
)
Visual Basic
Function SaveEntityMetaData (
    entityName As String,
    entityMetaData As EntityMetaData
) As Boolean
Visual C++
bool SaveEntityMetaData(
    String^ entityName,
    EntityMetaData^ entityMetaData
)

Parameters

entityName
Type: System..::..String
Name of the entity.
entityMetaData
Type: CelloSaaS.Model.DataManagement..::..EntityMetaData
The entity meta data.

Return Value

Type: Boolean

Exceptions

Exception | Condition
System..::..NotImplementedException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.SaveExtendedEntityRow Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..SaveExtendedEntityRow Method
IDataManagementService Interface See Also Send Feedback
This method is used to save the extended entity row.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool SaveExtendedEntityRow(
    string entityName,
    string tenantId,
    ExtendedEntityRow extendedEntityRow,
    string referenceId
)
Visual Basic
Function SaveExtendedEntityRow (
    entityName As String,
    tenantId As String,
    extendedEntityRow As ExtendedEntityRow,
    referenceId As String
) As Boolean
Visual C++
bool SaveExtendedEntityRow(
    String^ entityName,
    String^ tenantId,
    ExtendedEntityRow^ extendedEntityRow,
    String^ referenceId
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
extendedEntityRow
Type: CelloSaaS.Model.DataManagement..::..ExtendedEntityRow
The extended entity row.
referenceId
Type: System..::..String
The reference id.

Return Value

Type: Boolean

Exceptions

Exception | Condition
System..::..NotImplementedException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.SaveFieldMetaData Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..SaveFieldMetaData Method
IDataManagementService Interface Example See Also Send Feedback
This method is used to save the field meta data.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool SaveFieldMetaData(
    string entityName,
    string tenantId,
    EntityFieldMetaData entityFieldMetaData
)
Visual Basic
Function SaveFieldMetaData (
    entityName As String,
    tenantId As String,
    entityFieldMetaData As EntityFieldMetaData
) As Boolean
Visual C++
bool SaveFieldMetaData(
    String^ entityName,
    String^ tenantId,
    EntityFieldMetaData^ entityFieldMetaData
)

Parameters

entityName
Type: System..::..String
Name of the entity.
tenantId
Type: System..::..String
The tenant id.
entityFieldMetaData
Type: CelloSaaS.Model.DataManagement..::..EntityFieldMetaData
The entity field meta data.

Return Value

Type: Boolean
true if it is saved otherwise, false.

Examples

Copy image Copy
public void SaveFieldMetaData()
{
    string entityName = "User";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    EntityFieldMetaData entityFieldMetaData = new EntityFieldMetaData();
    entityFieldMetaData.EntityFieldIdentifier = "MiddleName";
    entityFieldMetaData.Name = "MiddleName";
    entityFieldMetaData.TypeID = "0419E788-0182-4F85-A91C-5B13FC71DE85";
    IDataManagementService dataManagementService = (IDataManagementService)ServiceLocator.GetServiceImplementation(typeof(IDataManagementService));
    bool fieldMetaDataSaved = dataManagementService.SaveFieldMetaData(entityName, tenantId, entityFieldMetaData);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..FieldNameUniquenessException | This exception is thrown while
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException | This exception is thrown while Extended Field with FieldIdentifier is not found or while saving field meta data
CelloSaaS.ServiceContracts.DataManagement..::..InvalidFieldTypeException | This exception is thrown when Field Type is invalid
CelloSaaS.ServiceContracts.DataManagement..::..MaximumLimitException | This exception is thrown when maximum limit for columns of this datatype is exceeded
CelloSaaS.ServiceContracts.DataManagement..::..InvalidDataTypeConversionException | This exception is thrown when Invalid data type conversion
System..::..ArgumentNullException | This exception is thrown when entity name or tenant id or entityfield meta data or entity meta data's field name is null or empty

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.SearchExtendedFields Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..SearchExtendedFields Method
IDataManagementService Interface See Also Send Feedback
This method is used to search the extended entity meta data values for schema table with tenant id , entity name and search condition

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, ExtendedEntityRow> SearchExtendedFields(
    ExtendedFieldsSearchCondition extendedFieldsSearchCondition
)
Visual Basic
Function SearchExtendedFields (
    extendedFieldsSearchCondition As ExtendedFieldsSearchCondition
) As Dictionary(Of String, ExtendedEntityRow)
Visual C++
Dictionary<String^, ExtendedEntityRow^>^ SearchExtendedFields(
    ExtendedFieldsSearchCondition^ extendedFieldsSearchCondition
)

Parameters

extendedFieldsSearchCondition
Type: CelloSaaS.Model.DataManagement..::..ExtendedFieldsSearchCondition

Return Value

Type: Dictionary<(Of <(<'String, ExtendedEntityRow >)>)>
it returns dictionary of extended fields

Exceptions

Exception | Condition
CelloSaaS.Model..::..InvalidSearchConditionException |
System..::..ArgumentException |
System..::..ArgumentNullException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.SearchExtendedFieldsReferenceIds Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..SearchExtendedFieldsReferenceIds Method
IDataManagementService Interface See Also Send Feedback
this method returns the list of reference ids of the extension table that are matched with the given expression or search value

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> SearchExtendedFieldsReferenceIds(
    ExtendedFieldsSearchCondition extendedFieldsSearchCondition
)
Visual Basic
Function SearchExtendedFieldsReferenceIds (
    extendedFieldsSearchCondition As ExtendedFieldsSearchCondition
) As List(Of String)
Visual C++
List<String^>^ SearchExtendedFieldsReferenceIds(
    ExtendedFieldsSearchCondition^ extendedFieldsSearchCondition
)

Parameters

extendedFieldsSearchCondition
Type: CelloSaaS.Model.DataManagement..::..ExtendedFieldsSearchCondition
The extended fields search condition.

Return Value

Type: List<(Of <(<'String>)>)>

Exceptions

Exception | Condition
CelloSaaS.Model..::..InvalidSearchConditionException |
System..::..ArgumentException |
System..::..ArgumentNullException |

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


IDataManagementService.UpdateDisplayColumName Method

[image]

A Sandcastle Documented Class Library
IDataManagementService..::..UpdateDisplayColumName Method
IDataManagementService Interface See Also Send Feedback
Updates the display name of the column.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdateDisplayColumName(
    string entityName,
    string fieldIdentifier,
    string tenantId
)
Visual Basic
Function UpdateDisplayColumName (
    entityName As String,
    fieldIdentifier As String,
    tenantId As String
) As Boolean
Visual C++
bool UpdateDisplayColumName(
    String^ entityName,
    String^ fieldIdentifier,
    String^ tenantId
)

Parameters

entityName
Type: System..::..String
Name of the entity.
fieldIdentifier
Type: System..::..String
The field identifier.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean

See Also

IDataManagementService Interface
IDataManagementService Members
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Class

[image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Class
Members See Also Send Feedback
Invalid Data Type Conversion Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidDataTypeConversionException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidDataTypeConversionException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidDataTypeConversionException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..InvalidDataTypeConversionException

See Also

InvalidDataTypeConversionException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Members
InvalidDataTypeConversionException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidDataTypeConversionException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidDataTypeConversionException()()()() | Initializes a new instance of the InvalidDataTypeConversionException class.
Public method | InvalidDataTypeConversionException(String) | Initializes a new instance of the InvalidDataTypeConversionException class.
Public method | InvalidDataTypeConversionException(String, Exception) | Initializes a new instance of the InvalidDataTypeConversionException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidDataTypeConversionException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Constructor
InvalidDataTypeConversionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidDataTypeConversionException()()()() | Initializes a new instance of the InvalidDataTypeConversionException class.
Public method | InvalidDataTypeConversionException(String) | Initializes a new instance of the InvalidDataTypeConversionException class.
Public method | InvalidDataTypeConversionException(String, Exception) | Initializes a new instance of the InvalidDataTypeConversionException class.

See Also

InvalidDataTypeConversionException Class
InvalidDataTypeConversionException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Constructor

[image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Constructor
InvalidDataTypeConversionException Class See Also Send Feedback
Initializes a new instance of the InvalidDataTypeConversionException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidDataTypeConversionException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidDataTypeConversionException()

See Also

InvalidDataTypeConversionException Class
InvalidDataTypeConversionException Members
InvalidDataTypeConversionException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Constructor (String)
InvalidDataTypeConversionException Class See Also Send Feedback
Initializes a new instance of the InvalidDataTypeConversionException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidDataTypeConversionException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidDataTypeConversionException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidDataTypeConversionException Class
InvalidDataTypeConversionException Members
InvalidDataTypeConversionException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Constructor (String, Exception)
InvalidDataTypeConversionException Class See Also Send Feedback
Initializes a new instance of the InvalidDataTypeConversionException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidDataTypeConversionException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidDataTypeConversionException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidDataTypeConversionException Class
InvalidDataTypeConversionException Members
InvalidDataTypeConversionException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Methods
InvalidDataTypeConversionException Class See Also Send Feedback

The InvalidDataTypeConversionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidDataTypeConversionException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Properties
InvalidDataTypeConversionException Class See Also Send Feedback

The InvalidDataTypeConversionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDataTypeConversionException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidDataTypeConversionException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidDataTypeConversionException Events
InvalidDataTypeConversionException Class See Also Send Feedback

The InvalidDataTypeConversionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidDataTypeConversionException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Class

[image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Class
Members See Also Send Feedback
Invalid Field Type Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidFieldTypeException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidFieldTypeException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidFieldTypeException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..InvalidFieldTypeException

See Also

InvalidFieldTypeException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Members
InvalidFieldTypeException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidFieldTypeException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidFieldTypeException()()()() | Initializes a new instance of the InvalidFieldTypeException class.
Public method | InvalidFieldTypeException(String) | Initializes a new instance of the InvalidFieldTypeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidFieldTypeException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Constructor
InvalidFieldTypeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidFieldTypeException()()()() | Initializes a new instance of the InvalidFieldTypeException class.
Public method | InvalidFieldTypeException(String) | Initializes a new instance of the InvalidFieldTypeException class.

See Also

InvalidFieldTypeException Class
InvalidFieldTypeException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Constructor

[image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Constructor
InvalidFieldTypeException Class See Also Send Feedback
Initializes a new instance of the InvalidFieldTypeException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidFieldTypeException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidFieldTypeException()

See Also

InvalidFieldTypeException Class
InvalidFieldTypeException Members
InvalidFieldTypeException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Constructor (String)
InvalidFieldTypeException Class See Also Send Feedback
Initializes a new instance of the InvalidFieldTypeException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidFieldTypeException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidFieldTypeException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidFieldTypeException Class
InvalidFieldTypeException Members
InvalidFieldTypeException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Methods
InvalidFieldTypeException Class See Also Send Feedback

The InvalidFieldTypeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidFieldTypeException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Properties
InvalidFieldTypeException Class See Also Send Feedback

The InvalidFieldTypeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidFieldTypeException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


InvalidFieldTypeException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidFieldTypeException Events
InvalidFieldTypeException Class See Also Send Feedback

The InvalidFieldTypeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidFieldTypeException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Class

[image]

A Sandcastle Documented Class Library
MaximumLimitException Class
Members See Also Send Feedback
Maximum Limit Exception

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MaximumLimitException : BaseException
Visual Basic
<SerializableAttribute>
Public Class MaximumLimitException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MaximumLimitException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.DataManagement..::..MaximumLimitException

See Also

MaximumLimitException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Members

[image] [image]

A Sandcastle Documented Class Library
MaximumLimitException Members
MaximumLimitException Class Constructors Methods Properties Events See Also Send Feedback

The MaximumLimitException type exposes the following members.

Constructors

 | Name | Description
Public method | MaximumLimitException()()()() | Initializes a new instance of the MaximumLimitException class.
Public method | MaximumLimitException(String) | Initializes a new instance of the MaximumLimitException class.
Public method | MaximumLimitException(String, Exception) | Initializes a new instance of the MaximumLimitException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MaximumLimitException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Constructor

[image] [image]

A Sandcastle Documented Class Library
MaximumLimitException Constructor
MaximumLimitException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MaximumLimitException()()()() | Initializes a new instance of the MaximumLimitException class.
Public method | MaximumLimitException(String) | Initializes a new instance of the MaximumLimitException class.
Public method | MaximumLimitException(String, Exception) | Initializes a new instance of the MaximumLimitException class.

See Also

MaximumLimitException Class
MaximumLimitException Members
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Constructor

[image]

A Sandcastle Documented Class Library
MaximumLimitException Constructor
MaximumLimitException Class See Also Send Feedback
Initializes a new instance of the MaximumLimitException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MaximumLimitException()
Visual Basic
Public Sub New
Visual C++
public:
MaximumLimitException()

See Also

MaximumLimitException Class
MaximumLimitException Members
MaximumLimitException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Constructor (String)

[image]

A Sandcastle Documented Class Library
MaximumLimitException Constructor (String)
MaximumLimitException Class See Also Send Feedback
Initializes a new instance of the MaximumLimitException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MaximumLimitException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
MaximumLimitException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

MaximumLimitException Class
MaximumLimitException Members
MaximumLimitException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
MaximumLimitException Constructor (String, Exception)
MaximumLimitException Class See Also Send Feedback
Initializes a new instance of the MaximumLimitException class.

Namespace: CelloSaaS.ServiceContracts.DataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MaximumLimitException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
MaximumLimitException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

MaximumLimitException Class
MaximumLimitException Members
MaximumLimitException Overload
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Methods

[image] [image]

A Sandcastle Documented Class Library
MaximumLimitException Methods
MaximumLimitException Class See Also Send Feedback

The MaximumLimitException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MaximumLimitException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Properties

[image] [image]

A Sandcastle Documented Class Library
MaximumLimitException Properties
MaximumLimitException Class See Also Send Feedback

The MaximumLimitException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MaximumLimitException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


MaximumLimitException Events

[image] [image]

A Sandcastle Documented Class Library
MaximumLimitException Events
MaximumLimitException Class See Also Send Feedback

The MaximumLimitException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MaximumLimitException Class
CelloSaaS.ServiceContracts.DataManagement Namespace


CelloSaaS.ServiceContracts.Encryption Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.Encryption Namespace
Send Feedback

Classes

 | Class | Description
Public class | TenantKeyStoreFactory | Tenant Key Store Factory

Interfaces

 | Interface | Description
Public interface | ITenantEncryption | Tenant Encryption Interface
Public interface | ITenantKeyStore | Tenant Key Store Interface


ITenantEncryption Interface

[image]

A Sandcastle Documented Class Library
ITenantEncryption Interface
Members See Also Send Feedback
Tenant Encryption Interface

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantEncryption
Visual Basic
Public Interface ITenantEncryption
Visual C++
public interface class ITenantEncryption

See Also

ITenantEncryption Members
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantEncryption Members

[image] [image]

A Sandcastle Documented Class Library
ITenantEncryption Members
ITenantEncryption Interface Methods See Also Send Feedback

The ITenantEncryption type exposes the following members.

Methods

 | Name | Description
Public method | DecryptData | Decrypts the data.
Public method | EncryptData | Encrypts the data.

See Also

ITenantEncryption Interface
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantEncryption Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantEncryption Methods
ITenantEncryption Interface See Also Send Feedback

The ITenantEncryption type exposes the following members.

Methods

 | Name | Description
Public method | DecryptData | Decrypts the data.
Public method | EncryptData | Encrypts the data.

See Also

ITenantEncryption Interface
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantEncryption.DecryptData Method

[image]

A Sandcastle Documented Class Library
ITenantEncryption..::..DecryptData Method
ITenantEncryption Interface See Also Send Feedback
Decrypts the data.

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string DecryptData(
    string tenantId,
    string encryptedData
)
Visual Basic
Function DecryptData (
    tenantId As String,
    encryptedData As String
) As String
Visual C++
String^ DecryptData(
    String^ tenantId,
    String^ encryptedData
)

Parameters

tenantId
Type: System..::..String
The tenant id.
encryptedData
Type: System..::..String
The encrypted data.

Return Value

Type: String

See Also

ITenantEncryption Interface
ITenantEncryption Members
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantEncryption.EncryptData Method

[image]

A Sandcastle Documented Class Library
ITenantEncryption..::..EncryptData Method
ITenantEncryption Interface See Also Send Feedback
Encrypts the data.

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool EncryptData(
    string tenantId,
    string data
)
Visual Basic
Function EncryptData (
    tenantId As String,
    data As String
) As Boolean
Visual C++
bool EncryptData(
    String^ tenantId,
    String^ data
)

Parameters

tenantId
Type: System..::..String
The tenant id.
data
Type: System..::..String
The data.

Return Value

Type: Boolean

See Also

ITenantEncryption Interface
ITenantEncryption Members
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantKeyStore Interface

[image]

A Sandcastle Documented Class Library
ITenantKeyStore Interface
Members See Also Send Feedback
Tenant Key Store Interface

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantKeyStore
Visual Basic
Public Interface ITenantKeyStore
Visual C++
public interface class ITenantKeyStore

See Also

ITenantKeyStore Members
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantKeyStore Members

[image] [image]

A Sandcastle Documented Class Library
ITenantKeyStore Members
ITenantKeyStore Interface Methods See Also Send Feedback

The ITenantKeyStore type exposes the following members.

Methods

 | Name | Description
Public method | GetTenantKey | Gets the tenant key.
Public method | StoreTenantKey | Stores the tenant key.

See Also

ITenantKeyStore Interface
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantKeyStore Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantKeyStore Methods
ITenantKeyStore Interface See Also Send Feedback

The ITenantKeyStore type exposes the following members.

Methods

 | Name | Description
Public method | GetTenantKey | Gets the tenant key.
Public method | StoreTenantKey | Stores the tenant key.

See Also

ITenantKeyStore Interface
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantKeyStore.GetTenantKey Method

[image]

A Sandcastle Documented Class Library
ITenantKeyStore..::..GetTenantKey Method
ITenantKeyStore Interface See Also Send Feedback
Gets the tenant key.

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantKey GetTenantKey(
    string tenantID
)
Visual Basic
Function GetTenantKey (
    tenantID As String
) As TenantKey
Visual C++
TenantKey^ GetTenantKey(
    String^ tenantID
)

Parameters

tenantID
Type: System..::..String
The tenant ID.

Return Value

Type: TenantKey

See Also

ITenantKeyStore Interface
ITenantKeyStore Members
CelloSaaS.ServiceContracts.Encryption Namespace


ITenantKeyStore.StoreTenantKey Method

[image]

A Sandcastle Documented Class Library
ITenantKeyStore..::..StoreTenantKey Method
ITenantKeyStore Interface See Also Send Feedback
Stores the tenant key.

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool StoreTenantKey(
    string tenantID,
    TenantKey tenantKey
)
Visual Basic
Function StoreTenantKey (
    tenantID As String,
    tenantKey As TenantKey
) As Boolean
Visual C++
bool StoreTenantKey(
    String^ tenantID,
    TenantKey^ tenantKey
)

Parameters

tenantID
Type: System..::..String
The tenant ID.
tenantKey
Type: CelloSaaS.Model.Encryption..::..TenantKey
The tenant key.

Return Value

Type: Boolean

See Also

ITenantKeyStore Interface
ITenantKeyStore Members
CelloSaaS.ServiceContracts.Encryption Namespace


TenantKeyStoreFactory Class

[image]

A Sandcastle Documented Class Library
TenantKeyStoreFactory Class
Members See Also Send Feedback
Tenant Key Store Factory

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TenantKeyStoreFactory
Visual Basic
Public NotInheritable Class TenantKeyStoreFactory
Visual C++
public ref class TenantKeyStoreFactory abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.Encryption..::..TenantKeyStoreFactory

See Also

TenantKeyStoreFactory Members
CelloSaaS.ServiceContracts.Encryption Namespace


TenantKeyStoreFactory Members

[image] [image]

A Sandcastle Documented Class Library
TenantKeyStoreFactory Members
TenantKeyStoreFactory Class Methods See Also Send Feedback

The TenantKeyStoreFactory type exposes the following members.

Methods

Name | Description
GetKeyStore | Gets the key store.

See Also

TenantKeyStoreFactory Class
CelloSaaS.ServiceContracts.Encryption Namespace


TenantKeyStoreFactory Methods

[image] [image]

A Sandcastle Documented Class Library
TenantKeyStoreFactory Methods
TenantKeyStoreFactory Class See Also Send Feedback

The TenantKeyStoreFactory type exposes the following members.

Methods

Name | Description
GetKeyStore | Gets the key store.

See Also

TenantKeyStoreFactory Class
CelloSaaS.ServiceContracts.Encryption Namespace


TenantKeyStoreFactory.GetKeyStore Method

[image]

A Sandcastle Documented Class Library
TenantKeyStoreFactory..::..GetKeyStore Method
TenantKeyStoreFactory Class See Also Send Feedback
Gets the key store.

Namespace: CelloSaaS.ServiceContracts.Encryption
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static ITenantKeyStore GetKeyStore()
Visual Basic
Public Shared Function GetKeyStore As ITenantKeyStore
Visual C++
public:
static ITenantKeyStore^ GetKeyStore()

Return Value

Type: ITenantKeyStore

See Also

TenantKeyStoreFactory Class
TenantKeyStoreFactory Members
CelloSaaS.ServiceContracts.Encryption Namespace


CelloSaaS.ServiceContracts.EntityFrameWork Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.EntityFrameWork Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | IEntityFrameWorkService | Entity framework helper service interface


IEntityFrameWorkService Interface

[image]

A Sandcastle Documented Class Library
IEntityFrameWorkService Interface
Members See Also Send Feedback
Entity framework helper service interface

Namespace: CelloSaaS.ServiceContracts.EntityFrameWork
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IEntityFrameWorkService
Visual Basic
Public Interface IEntityFrameWorkService
Visual C++
public interface class IEntityFrameWorkService

See Also

IEntityFrameWorkService Members
CelloSaaS.ServiceContracts.EntityFrameWork Namespace


IEntityFrameWorkService Members

[image] [image]

A Sandcastle Documented Class Library
IEntityFrameWorkService Members
IEntityFrameWorkService Interface Methods See Also Send Feedback

The IEntityFrameWorkService type exposes the following members.

Methods

 | Name | Description
Public method | GetEntityFrameWorkConnectionString | Get the entity frame work connectionstring based on connection string name

See Also

IEntityFrameWorkService Interface
CelloSaaS.ServiceContracts.EntityFrameWork Namespace


IEntityFrameWorkService Methods

[image] [image]

A Sandcastle Documented Class Library
IEntityFrameWorkService Methods
IEntityFrameWorkService Interface See Also Send Feedback

The IEntityFrameWorkService type exposes the following members.

Methods

 | Name | Description
Public method | GetEntityFrameWorkConnectionString | Get the entity frame work connectionstring based on connection string name

See Also

IEntityFrameWorkService Interface
CelloSaaS.ServiceContracts.EntityFrameWork Namespace


IEntityFrameWorkService.GetEntityFrameWorkConnectionString Method

[image]

A Sandcastle Documented Class Library
IEntityFrameWorkService..::..GetEntityFrameWorkConnectionString Method
IEntityFrameWorkService Interface See Also Send Feedback
Get the entity frame work connectionstring based on connection string name

Namespace: CelloSaaS.ServiceContracts.EntityFrameWork
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetEntityFrameWorkConnectionString(
    string connectionStringName,
    string metadata
)
Visual Basic
Function GetEntityFrameWorkConnectionString (
    connectionStringName As String,
    metadata As String
) As String
Visual C++
String^ GetEntityFrameWorkConnectionString(
    String^ connectionStringName,
    String^ metadata
)

Parameters

connectionStringName
Type: System..::..String
connectionStringName
metadata
Type: System..::..String
edmx metadata string (optional)

Return Value

Type: String
ConnectionString

See Also

IEntityFrameWorkService Interface
IEntityFrameWorkService Members
CelloSaaS.ServiceContracts.EntityFrameWork Namespace


CelloSaaS.ServiceContracts.LicenseManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.LicenseManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | InvalidNumberOfUsers | Invalid Number Of Users
Public class | InvalidUsageTypeException | Invalid usage type exception
Public class | LicenseConstant | Usaget limit Constants
Public class | LicenseException | License Exception
Public class | PackageConstant | Package Constant
Public class | ServiceMappingException | Service Mapping Exception
Public class | UsageTypeConstants | Usage type constants

Interfaces

 | Interface | Description
Public interface | ILicenseService | Contains services to manage the subscription packages and tenant license
Public interface | IMeteringService | Contains services to increment/decrement and validate the metering components


ILicenseService Interface

[image]

A Sandcastle Documented Class Library
ILicenseService Interface
Members See Also Send Feedback
Contains services to manage the subscription packages and tenant license

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ILicenseService
Visual Basic
Public Interface ILicenseService
Visual C++
public interface class ILicenseService

See Also

ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService Members

[image] [image]

A Sandcastle Documented Class Library
ILicenseService Members
ILicenseService Interface Methods See Also Send Feedback

The ILicenseService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateTenantLicense | Activates the given tenant's subscription by creating new subscription license form last subscription.
Public method | CreateLicenseForLicensePackage | This method is used to assign package to tenant.
Public method | DeactivateTenantLicense | Deactivates the given tenant's subscription by modifying the Validity End Date to now
Public method | DeleteLicensePackage | This method is used to deactivate the license package details for the package Identifier.
Public method | DeleteRoleServices | This method is used to delete role services.
Public method | DeleteTenantService | This method is used to delete tenant service for given tenantServiceMappingId.
Public method | DeleteTenantServices | This method is used to delete the tenant services.
Public method | DeleteUserServices | This method is used to delete user services.
Public method | GetActiveAndFutureTenantServicesByTenantId | This method is used to get the active and future tenant services by tenant id.
Public method | GetAllLicensePackage()()()() | This method is used to get all the license package details.
Public method | GetAllLicensePackage(String) | This method is used to get all license package.
Public method | GetAllModules | This method is used to get all the module details
Public method | GetAllPackageDetails()()()() | Returns all the subscription packages created by the authenticated tenant
Public method | GetAllPackageDetails(String) | Returns all the subscription packages created by the given tenantId
Public method | GetAllServices | This method is used to get all the services
Public method | GetAssignableLicensePackages | This method is used to get all assignable license packages excluding evaluation packages.
Public method | GetAssignablePackageDetailsByPackageId | This method is used to get the assignable package details by package id.
Public method | GetFeatureByModuleIds | This method is used to get all the feature details for given module ids
Public method | GetFeatureByServiceIds | This method is used to get all the feature details for each services
Public method | GetInActiveTenantLicense | This method is used to get last active tenant license
Public method | GetLicenseUsageDetailsByUsageType | This method is used to get the usage details based on the usage type and tenant id
Public method | GetModuleByServiceIds | This method is used to get module details by serviceIds
Public method | GetPackageDetails()()()() | This method is used to get active subscription package details.
Public method | GetPackageDetails(String) | This method is used to get active subscription packages created by the given tenantId.
Public method | GetPackageDetailsByPackageId | This method is used to get the package details by package identifier.
Public method | GetService | This method is used to get the service detail by serviceId
Public method | GetServicesByRoleId | This method is used to get the service details for given roleId.
Public method | GetServicesByRoleIds | This method is used to get the service details for given roleIds.
Public method | GetServicesByUserId | This method is used to get the service details for given userId.
Public method | GetServicesByUserIds | This method is used to get the service details for given userIds.
Public method | GetTenantLicense | This method is used to get the active tenant subscription license details. Returns TenantLicense object if the tenant has valid license else null if the subscription expires
Public method | GetTenantLicenseHistory | This method is used to get tenant license history details.
Public method | GetTenantServiceByMappingId | This method is used to get the tenant service by mapping id.
Public method | GetTenantServicesByTenantId | This method is used to get the service details for given tenantId.
Public method | GetUnRestrictedPackage | This method is used to get the details of product admin package.
Public method | GetUsageByModuleIds | This method is used to get usage details for modules
Public method | GetUsageStatus | Gets the usage status for the given usage name and amount to be incremented. Checks whether the given amount can be incremented without crossing the max capacity limit set in the subscription package.
Public method | InsertPackage | This method is used to insert package details.
Public method | InsertTenantLicense | This method is to insert the license for tenant.
Public method | InsertTenantService | This method is used to insert tenant service
Public method | PermanentDeleteLicensePackage | This method is used to delete the license package details for the input package Identifier.
Public method | ResetBillingPeriodBlockedUsageAmount | This method is used to reset the meter usage amount to 0 for Billing period blocked usage type.
Public method | SearchTenantLicenses | Searches the tenant licenses Key is tenantId, value is TenantLicense
Public method | UpdateLicenseForLicensePackage | This method is to update the tenant license.
Public method | UpdatePackage | This method is used to update the package details.
Public method | UpdateRoleServices | This method is used to update role service.
Public method | UpdateTenantLicense | Updates the given tenant's subscription license
Public method | UpdateTenantService | This method is used to update tenant service.
Public method | UpdateUserServices | This method is used to update user service.
Public method | ValidateModuleLicense | Validates the tenant subscription package whether it contains the given module name.
Public method | ValidateTenantLicense | Validates the tenant subscription package. Returns "true" If the validatity end date is greater than now (current datetime) else "false"
Public method | ValidateUsageLicense | This method is used to validate license for usage limit of tenant.

See Also

ILicenseService Interface
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService Methods

[image] [image]

A Sandcastle Documented Class Library
ILicenseService Methods
ILicenseService Interface See Also Send Feedback

The ILicenseService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateTenantLicense | Activates the given tenant's subscription by creating new subscription license form last subscription.
Public method | CreateLicenseForLicensePackage | This method is used to assign package to tenant.
Public method | DeactivateTenantLicense | Deactivates the given tenant's subscription by modifying the Validity End Date to now
Public method | DeleteLicensePackage | This method is used to deactivate the license package details for the package Identifier.
Public method | DeleteRoleServices | This method is used to delete role services.
Public method | DeleteTenantService | This method is used to delete tenant service for given tenantServiceMappingId.
Public method | DeleteTenantServices | This method is used to delete the tenant services.
Public method | DeleteUserServices | This method is used to delete user services.
Public method | GetActiveAndFutureTenantServicesByTenantId | This method is used to get the active and future tenant services by tenant id.
Public method | GetAllLicensePackage()()()() | This method is used to get all the license package details.
Public method | GetAllLicensePackage(String) | This method is used to get all license package.
Public method | GetAllModules | This method is used to get all the module details
Public method | GetAllPackageDetails()()()() | Returns all the subscription packages created by the authenticated tenant
Public method | GetAllPackageDetails(String) | Returns all the subscription packages created by the given tenantId
Public method | GetAllServices | This method is used to get all the services
Public method | GetAssignableLicensePackages | This method is used to get all assignable license packages excluding evaluation packages.
Public method | GetAssignablePackageDetailsByPackageId | This method is used to get the assignable package details by package id.
Public method | GetFeatureByModuleIds | This method is used to get all the feature details for given module ids
Public method | GetFeatureByServiceIds | This method is used to get all the feature details for each services
Public method | GetInActiveTenantLicense | This method is used to get last active tenant license
Public method | GetLicenseUsageDetailsByUsageType | This method is used to get the usage details based on the usage type and tenant id
Public method | GetModuleByServiceIds | This method is used to get module details by serviceIds
Public method | GetPackageDetails()()()() | This method is used to get active subscription package details.
Public method | GetPackageDetails(String) | This method is used to get active subscription packages created by the given tenantId.
Public method | GetPackageDetailsByPackageId | This method is used to get the package details by package identifier.
Public method | GetService | This method is used to get the service detail by serviceId
Public method | GetServicesByRoleId | This method is used to get the service details for given roleId.
Public method | GetServicesByRoleIds | This method is used to get the service details for given roleIds.
Public method | GetServicesByUserId | This method is used to get the service details for given userId.
Public method | GetServicesByUserIds | This method is used to get the service details for given userIds.
Public method | GetTenantLicense | This method is used to get the active tenant subscription license details. Returns TenantLicense object if the tenant has valid license else null if the subscription expires
Public method | GetTenantLicenseHistory | This method is used to get tenant license history details.
Public method | GetTenantServiceByMappingId | This method is used to get the tenant service by mapping id.
Public method | GetTenantServicesByTenantId | This method is used to get the service details for given tenantId.
Public method | GetUnRestrictedPackage | This method is used to get the details of product admin package.
Public method | GetUsageByModuleIds | This method is used to get usage details for modules
Public method | GetUsageStatus | Gets the usage status for the given usage name and amount to be incremented. Checks whether the given amount can be incremented without crossing the max capacity limit set in the subscription package.
Public method | InsertPackage | This method is used to insert package details.
Public method | InsertTenantLicense | This method is to insert the license for tenant.
Public method | InsertTenantService | This method is used to insert tenant service
Public method | PermanentDeleteLicensePackage | This method is used to delete the license package details for the input package Identifier.
Public method | ResetBillingPeriodBlockedUsageAmount | This method is used to reset the meter usage amount to 0 for Billing period blocked usage type.
Public method | SearchTenantLicenses | Searches the tenant licenses Key is tenantId, value is TenantLicense
Public method | UpdateLicenseForLicensePackage | This method is to update the tenant license.
Public method | UpdatePackage | This method is used to update the package details.
Public method | UpdateRoleServices | This method is used to update role service.
Public method | UpdateTenantLicense | Updates the given tenant's subscription license
Public method | UpdateTenantService | This method is used to update tenant service.
Public method | UpdateUserServices | This method is used to update user service.
Public method | ValidateModuleLicense | Validates the tenant subscription package whether it contains the given module name.
Public method | ValidateTenantLicense | Validates the tenant subscription package. Returns "true" If the validatity end date is greater than now (current datetime) else "false"
Public method | ValidateUsageLicense | This method is used to validate license for usage limit of tenant.

See Also

ILicenseService Interface
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.ActivateTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..ActivateTenantLicense Method
ILicenseService Interface See Also Send Feedback
Activates the given tenant's subscription by creating new subscription license form last subscription.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ActivateTenantLicense(
    string tenantId
)
Visual Basic
Sub ActivateTenantLicense (
    tenantId As String
)
Visual C++
void ActivateTenantLicense(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant identifier

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.CreateLicenseForLicensePackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..CreateLicenseForLicensePackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to assign package to tenant.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CreateLicenseForLicensePackage(
    TenantLicense tenantLicense
)
Visual Basic
Sub CreateLicenseForLicensePackage (
    tenantLicense As TenantLicense
)
Visual C++
void CreateLicenseForLicensePackage(
    TenantLicense^ tenantLicense
)

Parameters

tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License Details(Mandatory - Tenant Identifier, Package Identifier)

Examples

Copy image Copy
public void CreateLicenseForLicensePackage()
{
    TenantLicense tenantLicense = new TenantLicense();
    tenantLicense.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    tenantLicense.PackageId = "A011B120-DD93-DF11-8DEB-001EC9DAB123";
    tenantLicense.NumberOfUsers = "150";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    licenseService.CreateLicenseForLicensePackage(tenantLicense);
}

Exceptions

Exception | Condition
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate
CelloSaaS.ServiceContracts.LicenseManagement..::..InvalidNumberOfUsers | Throws InvalidNumberOfUsers if users count is not valid.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.DeactivateTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..DeactivateTenantLicense Method
ILicenseService Interface See Also Send Feedback
Deactivates the given tenant's subscription by modifying the Validity End Date to now

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeactivateTenantLicense(
    string tenantId
)
Visual Basic
Sub DeactivateTenantLicense (
    tenantId As String
)
Visual C++
void DeactivateTenantLicense(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant identifier

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.DeleteLicensePackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..DeleteLicensePackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to deactivate the license package details for the package Identifier.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteLicensePackage(
    string packageId
)
Visual Basic
Sub DeleteLicensePackage (
    packageId As String
)
Visual C++
void DeleteLicensePackage(
    String^ packageId
)

Parameters

packageId
Type: System..::..String
Package Identifier(Mandatory)

Examples

Copy image Copy
public void DeactivateLicensePackage()
{
    string packageId = "A011B120-DD93-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    licenseService.DeleteLicensePackage(packageId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.DeleteRoleServices Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..DeleteRoleServices Method
ILicenseService Interface See Also Send Feedback
This method is used to delete role services.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteRoleServices(
    string roleId,
    string[] serviceIds
)
Visual Basic
Sub DeleteRoleServices (
    roleId As String,
    serviceIds As String()
)
Visual C++
void DeleteRoleServices(
    String^ roleId,
    array<String^>^ serviceIds
)

Parameters

roleId
Type: System..::..String
Role Id
serviceIds
Type: array<System..::..String>[]()[][]
Service Ids

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.DeleteTenantService Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..DeleteTenantService Method
ILicenseService Interface See Also Send Feedback
This method is used to delete tenant service for given tenantServiceMappingId.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantService(
    string tenantServiceMappingId
)
Visual Basic
Sub DeleteTenantService (
    tenantServiceMappingId As String
)
Visual C++
void DeleteTenantService(
    String^ tenantServiceMappingId
)

Parameters

tenantServiceMappingId
Type: System..::..String
Tenant Service Mapping Id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.DeleteTenantServices Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..DeleteTenantServices Method
ILicenseService Interface See Also Send Feedback
This method is used to delete the tenant services.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantServices(
    string[] tenantServiceMappingIds
)
Visual Basic
Sub DeleteTenantServices (
    tenantServiceMappingIds As String()
)
Visual C++
void DeleteTenantServices(
    array<String^>^ tenantServiceMappingIds
)

Parameters

tenantServiceMappingIds
Type: array<System..::..String>[]()[][]
The tenant service mapping ids.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.DeleteUserServices Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..DeleteUserServices Method
ILicenseService Interface See Also Send Feedback
This method is used to delete user services.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserServices(
    string userId,
    string[] serviceIds
)
Visual Basic
Sub DeleteUserServices (
    userId As String,
    serviceIds As String()
)
Visual C++
void DeleteUserServices(
    String^ userId,
    array<String^>^ serviceIds
)

Parameters

userId
Type: System..::..String
User Id
serviceIds
Type: array<System..::..String>[]()[][]
Service Ids

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetActiveAndFutureTenantServicesByTenantId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetActiveAndFutureTenantServicesByTenantId Method
ILicenseService Interface See Also Send Feedback
This method is used to get the active and future tenant services by tenant id.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantServiceMapping> GetActiveAndFutureTenantServicesByTenantId(
    string tenantId
)
Visual Basic
Function GetActiveAndFutureTenantServicesByTenantId (
    tenantId As String
) As Dictionary(Of String, TenantServiceMapping)
Visual C++
Dictionary<String^, TenantServiceMapping^>^ GetActiveAndFutureTenantServicesByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantServiceMapping >)>)>
Dictionary of Tenant Service Mapping

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllLicensePackage Method

[image] [image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllLicensePackage Method
ILicenseService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAllLicensePackage()()()() | This method is used to get all the license package details.
Public method | GetAllLicensePackage(String) | This method is used to get all license package.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllLicensePackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllLicensePackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get all the license package details.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<LicensePackage> GetAllLicensePackage()
Visual Basic
Function GetAllLicensePackage As List(Of LicensePackage)
Visual C++
List<LicensePackage^>^ GetAllLicensePackage()

Return Value

Type: List<(Of <(<' LicensePackage >)>)>
List of License Package

Examples

Copy image Copy
public void GetAllLicensePackage()
{
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    List<LicensePackage> packageDetails = licenseService.GetAllLicensePackage();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
GetAllLicensePackage Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllLicensePackage Method (String)

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllLicensePackage Method (String)
ILicenseService Interface See Also Send Feedback
This method is used to get all license package.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<LicensePackage> GetAllLicensePackage(
    string tenantId
)
Visual Basic
Function GetAllLicensePackage (
    tenantId As String
) As List(Of LicensePackage)
Visual C++
List<LicensePackage^>^ GetAllLicensePackage(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: List<(Of <(<' LicensePackage >)>)>
List of License Package

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
GetAllLicensePackage Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllModules Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllModules Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get all the module details

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Module> GetAllModules()
Visual Basic
Function GetAllModules As Dictionary(Of String, Module)
Visual C++
Dictionary<String^, Module^>^ GetAllModules()

Return Value

Type: Dictionary<(Of <(<'String, Module >)>)>
Module details

Examples

Copy image Copy
public void GetAllModules()
{
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    Dictionary<string, Module> moduleDetails = licenseService.GetAllModules();
}

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllPackageDetails Method

[image] [image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllPackageDetails Method
ILicenseService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAllPackageDetails()()()() | Returns all the subscription packages created by the authenticated tenant
Public method | GetAllPackageDetails(String) | Returns all the subscription packages created by the given tenantId

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllPackageDetails Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllPackageDetails Method
ILicenseService Interface Example See Also Send Feedback
Returns all the subscription packages created by the authenticated tenant

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, PackageDetails> GetAllPackageDetails()
Visual Basic
Function GetAllPackageDetails As Dictionary(Of String, PackageDetails)
Visual C++
Dictionary<String^, PackageDetails^>^ GetAllPackageDetails()

Return Value

Type: Dictionary<(Of <(<'String, PackageDetails >)>)>
Package Details

Examples

Copy image Copy
public void GetAllPackageDetails()
{
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    Dictionary<string, PackageDetails> packageDetails = licenseService.GetAllPackageDetails();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
GetAllPackageDetails Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllPackageDetails Method (String)

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllPackageDetails Method (String)
ILicenseService Interface See Also Send Feedback
Returns all the subscription packages created by the given tenantId

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, PackageDetails> GetAllPackageDetails(
    string tenantId
)
Visual Basic
Function GetAllPackageDetails (
    tenantId As String
) As Dictionary(Of String, PackageDetails)
Visual C++
Dictionary<String^, PackageDetails^>^ GetAllPackageDetails(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, PackageDetails >)>)>
The Package Details

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
GetAllPackageDetails Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAllServices Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAllServices Method
ILicenseService Interface See Also Send Feedback
This method is used to get all the services

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Service> GetAllServices()
Visual Basic
Function GetAllServices As Dictionary(Of String, Service)
Visual C++
Dictionary<String^, Service^>^ GetAllServices()

Return Value

Type: Dictionary<(Of <(<'String, Service >)>)>
Dictionary of Service

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAssignableLicensePackages Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAssignableLicensePackages Method
ILicenseService Interface See Also Send Feedback
This method is used to get all assignable license packages excluding evaluation packages.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<LicensePackage> GetAssignableLicensePackages(
    string tenantId
)
Visual Basic
Function GetAssignableLicensePackages (
    tenantId As String
) As List(Of LicensePackage)
Visual C++
List<LicensePackage^>^ GetAssignableLicensePackages(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: List<(Of <(<' LicensePackage >)>)>
List of License Package

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetAssignablePackageDetailsByPackageId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetAssignablePackageDetailsByPackageId Method
ILicenseService Interface See Also Send Feedback
This method is used to get the assignable package details by package id.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PackageDetails GetAssignablePackageDetailsByPackageId(
    string packageId
)
Visual Basic
Function GetAssignablePackageDetailsByPackageId (
    packageId As String
) As PackageDetails
Visual C++
PackageDetails^ GetAssignablePackageDetailsByPackageId(
    String^ packageId
)

Parameters

packageId
Type: System..::..String
The package id.

Return Value

Type: PackageDetails
The Package Details

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetFeatureByModuleIds Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetFeatureByModuleIds Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get all the feature details for given module ids

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, Feature>> GetFeatureByModuleIds(
    string[] moduleIds
)
Visual Basic
Function GetFeatureByModuleIds (
    moduleIds As String()
) As Dictionary(Of String, Dictionary(Of String, Feature))
Visual C++
Dictionary<String^, Dictionary<String^, Feature^>^>^ GetFeatureByModuleIds(
    array<String^>^ moduleIds
)

Parameters

moduleIds
Type: array<System..::..String>[]()[][]
Module Identifiers

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Feature >)>)>>)>)>
Feature details for each modules

Examples

Copy image Copy
public void GetFeatureByModuleIds()
{
    string[] moduleIds = new string { "User", "AccessControl" }
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    Dictionary<string, Dictionary<string, Feature>> featureDetails = licenseService.GetFeatureByModuleIds(moduleIds);
}

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetFeatureByServiceIds Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetFeatureByServiceIds Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get all the feature details for each services

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, Feature>> GetFeatureByServiceIds(
    string[] serviceIds
)
Visual Basic
Function GetFeatureByServiceIds (
    serviceIds As String()
) As Dictionary(Of String, Dictionary(Of String, Feature))
Visual C++
Dictionary<String^, Dictionary<String^, Feature^>^>^ GetFeatureByServiceIds(
    array<String^>^ serviceIds
)

Parameters

serviceIds
Type: array<System..::..String>[]()[][]
Service Identifiers

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Feature >)>)>>)>)>
Feature details for each modules

Examples

Copy image Copy
public void GetFeatureByModuleIds()
{
    string[] moduleIds = new string { "User", "AccessControl" }
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    Dictionary<string, Dictionary<string, Feature>> featureDetails = licenseService.GetFeatureByModuleIds(moduleIds);
}

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetInActiveTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetInActiveTenantLicense Method
ILicenseService Interface See Also Send Feedback
This method is used to get last active tenant license

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantLicense GetInActiveTenantLicense(
    string tenantId
)
Visual Basic
Function GetInActiveTenantLicense (
    tenantId As String
) As TenantLicense
Visual C++
TenantLicense^ GetInActiveTenantLicense(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: TenantLicense
Tenant License Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetLicenseUsageDetailsByUsageType Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetLicenseUsageDetailsByUsageType Method
ILicenseService Interface See Also Send Feedback
This method is used to get the usage details based on the usage type and tenant id

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Usage> GetLicenseUsageDetailsByUsageType(
    string usageType,
    string tenantId
)
Visual Basic
Function GetLicenseUsageDetailsByUsageType (
    usageType As String,
    tenantId As String
) As List(Of Usage)
Visual C++
List<Usage^>^ GetLicenseUsageDetailsByUsageType(
    String^ usageType,
    String^ tenantId
)

Parameters

usageType
Type: System..::..String
Usage Type
tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: List<(Of <(<' Usage >)>)>
Usage List

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetModuleByServiceIds Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetModuleByServiceIds Method
ILicenseService Interface See Also Send Feedback
This method is used to get module details by serviceIds

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, Module>> GetModuleByServiceIds(
    string[] serviceIds
)
Visual Basic
Function GetModuleByServiceIds (
    serviceIds As String()
) As Dictionary(Of String, Dictionary(Of String, Module))
Visual C++
Dictionary<String^, Dictionary<String^, Module^>^>^ GetModuleByServiceIds(
    array<String^>^ serviceIds
)

Parameters

serviceIds
Type: array<System..::..String>[]()[][]
array of service ids

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Module >)>)>>)>)>
Dictionary of Dictionary of Module

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception, If any mandatory argument is null or empty

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetPackageDetails Method

[image] [image]

A Sandcastle Documented Class Library
ILicenseService..::..GetPackageDetails Method
ILicenseService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPackageDetails()()()() | This method is used to get active subscription package details.
Public method | GetPackageDetails(String) | This method is used to get active subscription packages created by the given tenantId.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetPackageDetails Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetPackageDetails Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get active subscription package details.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, PackageDetails> GetPackageDetails()
Visual Basic
Function GetPackageDetails As Dictionary(Of String, PackageDetails)
Visual C++
Dictionary<String^, PackageDetails^>^ GetPackageDetails()

Return Value

Type: Dictionary<(Of <(<'String, PackageDetails >)>)>
Active Package Details

Examples

Copy image Copy
public void GetPackageDetails()
{
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    Dictionary<string, PackageDetails> packageDetails = licenseService.GetPackageDetails();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
GetPackageDetails Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetPackageDetails Method (String)

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetPackageDetails Method (String)
ILicenseService Interface See Also Send Feedback
This method is used to get active subscription packages created by the given tenantId.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, PackageDetails> GetPackageDetails(
    string tenantId
)
Visual Basic
Function GetPackageDetails (
    tenantId As String
) As Dictionary(Of String, PackageDetails)
Visual C++
Dictionary<String^, PackageDetails^>^ GetPackageDetails(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, PackageDetails >)>)>
The Package Details

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
GetPackageDetails Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetPackageDetailsByPackageId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetPackageDetailsByPackageId Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get the package details by package identifier.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PackageDetails GetPackageDetailsByPackageId(
    string packageId
)
Visual Basic
Function GetPackageDetailsByPackageId (
    packageId As String
) As PackageDetails
Visual C++
PackageDetails^ GetPackageDetailsByPackageId(
    String^ packageId
)

Parameters

packageId
Type: System..::..String
Package Identifier(Mandatory)

Return Value

Type: PackageDetails
The Package Details

Examples

Copy image Copy
public void GetPackageDetailsByPackageId()
{
    string packageId = "A011B120-DD93-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    PackageDetails packageDetails = licenseService.GetPackageDetailsByPackageId();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetService Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetService Method
ILicenseService Interface See Also Send Feedback
This method is used to get the service detail by serviceId

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Service GetService(
    string serviceId
)
Visual Basic
Function GetService (
    serviceId As String
) As Service
Visual C++
Service^ GetService(
    String^ serviceId
)

Parameters

serviceId
Type: System..::..String
ServiceId

Return Value

Type: Service
Service detail

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception, If any mandatory argument is null or empty

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetServicesByRoleId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetServicesByRoleId Method
ILicenseService Interface See Also Send Feedback
This method is used to get the service details for given roleId.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Service> GetServicesByRoleId(
    string roleId
)
Visual Basic
Function GetServicesByRoleId (
    roleId As String
) As Dictionary(Of String, Service)
Visual C++
Dictionary<String^, Service^>^ GetServicesByRoleId(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
Role Id

Return Value

Type: Dictionary<(Of <(<'String, Service >)>)>
Dictionary of Service

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetServicesByRoleIds Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetServicesByRoleIds Method
ILicenseService Interface See Also Send Feedback
This method is used to get the service details for given roleIds.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Service> GetServicesByRoleIds(
    string[] roleIds
)
Visual Basic
Function GetServicesByRoleIds (
    roleIds As String()
) As Dictionary(Of String, Service)
Visual C++
Dictionary<String^, Service^>^ GetServicesByRoleIds(
    array<String^>^ roleIds
)

Parameters

roleIds
Type: array<System..::..String>[]()[][]
Role Ids

Return Value

Type: Dictionary<(Of <(<'String, Service >)>)>
Dictionary of Service

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetServicesByUserId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetServicesByUserId Method
ILicenseService Interface See Also Send Feedback
This method is used to get the service details for given userId.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Service> GetServicesByUserId(
    string userId
)
Visual Basic
Function GetServicesByUserId (
    userId As String
) As Dictionary(Of String, Service)
Visual C++
Dictionary<String^, Service^>^ GetServicesByUserId(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user Identifier

Return Value

Type: Dictionary<(Of <(<'String, Service >)>)>
Dictionary of Service

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetServicesByUserIds Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetServicesByUserIds Method
ILicenseService Interface See Also Send Feedback
This method is used to get the service details for given userIds.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Service> GetServicesByUserIds(
    string[] userIds
)
Visual Basic
Function GetServicesByUserIds (
    userIds As String()
) As Dictionary(Of String, Service)
Visual C++
Dictionary<String^, Service^>^ GetServicesByUserIds(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
array of user identifier.

Return Value

Type: Dictionary<(Of <(<'String, Service >)>)>
Dictionary of Service

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetTenantLicense Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get the active tenant subscription license details. Returns TenantLicense object if the tenant has valid license else null if the subscription expires

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantLicense GetTenantLicense(
    string tenantId
)
Visual Basic
Function GetTenantLicense (
    tenantId As String
) As TenantLicense
Visual C++
TenantLicense^ GetTenantLicense(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: TenantLicense
Tenant License Details

Examples

Copy image Copy
public void GetAllLicensePackage()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    TenantLicense packageDetails = licenseService.GetTenantLicense(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetTenantLicenseHistory Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetTenantLicenseHistory Method
ILicenseService Interface See Also Send Feedback
This method is used to get tenant license history details.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantLicense> GetTenantLicenseHistory(
    string tenantId
)
Visual Basic
Function GetTenantLicenseHistory (
    tenantId As String
) As List(Of TenantLicense)
Visual C++
List<TenantLicense^>^ GetTenantLicenseHistory(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: List<(Of <(<' TenantLicense >)>)>
Tenant License Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetTenantServiceByMappingId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetTenantServiceByMappingId Method
ILicenseService Interface See Also Send Feedback
This method is used to get the tenant service by mapping id.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantServiceMapping GetTenantServiceByMappingId(
    string tenantServiceMappingId
)
Visual Basic
Function GetTenantServiceByMappingId (
    tenantServiceMappingId As String
) As TenantServiceMapping
Visual C++
TenantServiceMapping^ GetTenantServiceByMappingId(
    String^ tenantServiceMappingId
)

Parameters

tenantServiceMappingId
Type: System..::..String
The tenant service mapping id.

Return Value

Type: TenantServiceMapping
The Tenant Service Mapping

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetTenantServicesByTenantId Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetTenantServicesByTenantId Method
ILicenseService Interface See Also Send Feedback
This method is used to get the service details for given tenantId.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantServiceMapping> GetTenantServicesByTenantId(
    string tenantId
)
Visual Basic
Function GetTenantServicesByTenantId (
    tenantId As String
) As Dictionary(Of String, TenantServiceMapping)
Visual C++
Dictionary<String^, TenantServiceMapping^>^ GetTenantServicesByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
the tenant identifier

Return Value

Type: Dictionary<(Of <(<'String, TenantServiceMapping >)>)>
Dictionary of Tenant Service Mapping

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetUnRestrictedPackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetUnRestrictedPackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get the details of product admin package.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PackageDetails GetUnRestrictedPackage()
Visual Basic
Function GetUnRestrictedPackage As PackageDetails
Visual C++
PackageDetails^ GetUnRestrictedPackage()

Return Value

Type: PackageDetails
Package Details

Examples

Copy image Copy
public void GetUnRestrictedPackage()
{
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    PackageDetails packageDetails = licenseService.GetUnRestrictedPackage();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetUsageByModuleIds Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetUsageByModuleIds Method
ILicenseService Interface Example See Also Send Feedback
This method is used to get usage details for modules

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, Usage>> GetUsageByModuleIds(
    string[] moduleIds
)
Visual Basic
Function GetUsageByModuleIds (
    moduleIds As String()
) As Dictionary(Of String, Dictionary(Of String, Usage))
Visual C++
Dictionary<String^, Dictionary<String^, Usage^>^>^ GetUsageByModuleIds(
    array<String^>^ moduleIds
)

Parameters

moduleIds
Type: array<System..::..String>[]()[][]
Module Identifiers

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Usage >)>)>>)>)>
Usage Details with Module

Examples

Copy image Copy
public void GetUsageByModuleIds()
{
    string[] moduleIds = new string { "User", "AccessControl" }
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    Dictionary<string, Dictionary<string, Usage>> featureDetails = licenseService.GetUsageByModuleIds(moduleIds);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.GetUsageStatus Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..GetUsageStatus Method
ILicenseService Interface See Also Send Feedback
Gets the usage status for the given usage name and amount to be incremented. Checks whether the given amount can be incremented without crossing the max capacity limit set in the subscription package.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UsageStatus GetUsageStatus(
    string usageCode,
    string tenantId
)
Visual Basic
Function GetUsageStatus (
    usageCode As String,
    tenantId As String
) As UsageStatus
Visual C++
UsageStatus GetUsageStatus(
    String^ usageCode,
    String^ tenantId
)

Parameters

usageCode
Type: System..::..String
usage code.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: UsageStatus

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.InsertPackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..InsertPackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to insert package details.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InsertPackage(
    PackageDetails licensePackageDetails
)
Visual Basic
Function InsertPackage (
    licensePackageDetails As PackageDetails
) As String
Visual C++
String^ InsertPackage(
    PackageDetails^ licensePackageDetails
)

Parameters

licensePackageDetails
Type: CelloSaaS.Model.LicenseManagement..::..PackageDetails
Package Details(Mandatory - Name)

Return Value

Type: String
Inserted Package Identifier

Examples

Copy image Copy
public void InsertPackage()
{
    PackageDetails licensePackageDetails = new PackageDetails();
    licensePackageDetails.PackageName = "Standard";

    Dictionary<string, PackageModule> moduleDetails = new Dictionary<string, PackageModule>();

    PackageModule module = new PackageModule();
    module.ModuleCode = "User";
    moduleDetails.Add("User", module);

    module = new PackageModule();
    module.ModuleCode = "Setting";
    moduleDetails.Add("Setting", module);

    module = new PackageModule();
    module.ModuleCode = "Configuration";
    moduleDetails.Add("Configuration", module);

    module = new PackageModule();
    module.ModuleCode = "AccessControl";
    moduleDetails.Add("AccessControl", module);

    licensePackageDetails.PacakageModuleDetails = moduleDetails;

    Dictionary<string, PackageFeature> featureDetails = new Dictionary<string, PackageFeature>();
    PackageFeature feature = new PackageFeature();
    feature.FeatureId = "ManageRole";
    featureDetails.Add("ManageRole", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManageUserRoles";
    featureDetails.Add("ManageUserRoles", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManagePickupList";
    featureDetails.Add("ManagePickupList", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManageTenantSettings";
    featureDetails.Add("ManageTenantSettings", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManageUser";
    featureDetails.Add("ManageUser", feature);

    licensePackageDetails.PacakgeFeatureDetails = featureDetails;

    Dictionary<string, PackageUsage> usageDetails = new Dictionary<string, PackageUsage>();

    PackageUsage usage = new PackageUsage();
    usage.UsageCode = "CompanyUsage";
    usageDetails.Add("CompanyUsage", usage);

    licensePackageDetails.PackageUsageDetails = usageDetails;
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    string insertedPackageId =  licenseService.InsertPackage(licensePackageDetails);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.InsertTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..InsertTenantLicense Method
ILicenseService Interface Example See Also Send Feedback
This method is to insert the license for tenant.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InsertTenantLicense(
    TenantLicense tenantLicense
)
Visual Basic
Function InsertTenantLicense (
    tenantLicense As TenantLicense
) As String
Visual C++
String^ InsertTenantLicense(
    TenantLicense^ tenantLicense
)

Parameters

tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License Details(Mandatory - Tenant Identifier, Package Identifier)

Return Value

Type: String
The Tenant LicenseId

Examples

Copy image Copy
public void InsertTenantLicense()
{
    TenantLicense tenantLicense = new TenantLicense();
    tenantLicense.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    tenantLicense.PackageId = "A8174FD7-808F-4CB1-A3E4-F3013684DEEE";
    tenantLicense.NumberOfUsers = 100;
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    string tenantLicenseId = licenseService.InsertTenantLicense(tenantLicense);
}

Exceptions

Exception | Condition
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have insert tenant license permission
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.InsertTenantService Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..InsertTenantService Method
ILicenseService Interface See Also Send Feedback
This method is used to insert tenant service

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InsertTenantService(
    TenantServiceMapping tenantServiceMapping
)
Visual Basic
Function InsertTenantService (
    tenantServiceMapping As TenantServiceMapping
) As String
Visual C++
String^ InsertTenantService(
    TenantServiceMapping^ tenantServiceMapping
)

Parameters

tenantServiceMapping
Type: CelloSaaS.Model.LicenseManagement..::..TenantServiceMapping
Tenant Service Mapping

Return Value

Type: String
The Tenant Service Mapping Id

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.PermanentDeleteLicensePackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..PermanentDeleteLicensePackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to delete the license package details for the input package Identifier.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteLicensePackage(
    string packageId
)
Visual Basic
Sub PermanentDeleteLicensePackage (
    packageId As String
)
Visual C++
void PermanentDeleteLicensePackage(
    String^ packageId
)

Parameters

packageId
Type: System..::..String
Package Identifier(Mandatory)

Examples

Copy image Copy
public void DeleteLicensePackage()
{
    string packageId = "A011B120-DD93-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    licenseService.PermanentDeleteLicensePackage(packageId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.ResetBillingPeriodBlockedUsageAmount Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..ResetBillingPeriodBlockedUsageAmount Method
ILicenseService Interface See Also Send Feedback
This method is used to reset the meter usage amount to 0 for Billing period blocked usage type.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ResetBillingPeriodBlockedUsageAmount(
    string tenantId
)
Visual Basic
Sub ResetBillingPeriodBlockedUsageAmount (
    tenantId As String
)
Visual C++
void ResetBillingPeriodBlockedUsageAmount(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.SearchTenantLicenses Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..SearchTenantLicenses Method
ILicenseService Interface See Also Send Feedback
Searches the tenant licenses Key is tenantId, value is TenantLicense

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, TenantLicense> SearchTenantLicenses(
    TenantLicenseSearchCondition condition
)
Visual Basic
Function SearchTenantLicenses (
    condition As TenantLicenseSearchCondition
) As Dictionary(Of Guid, TenantLicense)
Visual C++
Dictionary<Guid, TenantLicense^>^ SearchTenantLicenses(
    TenantLicenseSearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicenseSearchCondition
search condition

Return Value

Type: Dictionary<(Of <(<'Guid, TenantLicense >)>)>
Returns the TenantLicense object

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.UpdateLicenseForLicensePackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..UpdateLicenseForLicensePackage Method
ILicenseService Interface Example See Also Send Feedback
This method is to update the tenant license.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateLicenseForLicensePackage(
    TenantLicense tenantLicense
)
Visual Basic
Sub UpdateLicenseForLicensePackage (
    tenantLicense As TenantLicense
)
Visual C++
void UpdateLicenseForLicensePackage(
    TenantLicense^ tenantLicense
)

Parameters

tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License Details(Mandatory - Tenant License Identifier,Tenant Identifier, Package Identifier)

Examples

Copy image Copy
public void UpdateLicenseForLicensePackage()
{
    TenantLicense tenantLicense = new TenantLicense();
    tenantLicense.TenantLicenseCode = "F2446542-0294-DF11-8DEB-001EC9DAB123";
    tenantLicense.TenantId = "F1446542-0294-DF11-8DEB-001EC9DAB123";
    tenantLicense.PackageId = "A011B120-DD93-DF11-8DEB-001EC9DAB123";
    tenantLicense.NumberOfUsers = "150";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    licenseService.UpdateLicenseForLicensePackage(tenantLicense);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..ArgumentException | Throws ArgumentException if any argument is getting error value
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have update license for license package
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.UpdatePackage Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..UpdatePackage Method
ILicenseService Interface Example See Also Send Feedback
This method is used to update the package details.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdatePackage(
    PackageDetails licensePackageDetails
)
Visual Basic
Function UpdatePackage (
    licensePackageDetails As PackageDetails
) As String
Visual C++
String^ UpdatePackage(
    PackageDetails^ licensePackageDetails
)

Parameters

licensePackageDetails
Type: CelloSaaS.Model.LicenseManagement..::..PackageDetails
Package Details(Mandatory - Identifier, Name)

Return Value

Type: String
Updated Package Identifier

Examples

Copy image Copy
public void UpdatePackage()
{
    PackageDetails licensePackageDetails = new PackageDetails();
    licensePackageDetails.PackageId = "A011B120-DD93-DF11-8DEB-001EC9DAB123";
    licensePackageDetails.PackageName = "Standard";

    Dictionary<string, PackageModule> moduleDetails = new Dictionary<string, PackageModule>();

    PackageModule module = new PackageModule();
    module.ModuleCode = "User";
    moduleDetails.Add("User", module);

    module = new PackageModule();
    module.ModuleCode = "Setting";
    moduleDetails.Add("Setting", module);

    module = new PackageModule();
    module.ModuleCode = "Configuration";
    moduleDetails.Add("Configuration", module);

    module = new PackageModule();
    module.ModuleCode = "AccessControl";
    moduleDetails.Add("AccessControl", module);

    licensePackageDetails.PacakageModuleDetails = moduleDetails;

    Dictionary<string, PackageFeature> featureDetails = new Dictionary<string, PackageFeature>();
    PackageFeature feature = new PackageFeature();
    feature.FeatureId = "ManageRole";
    featureDetails.Add("ManageRole", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManageUserRoles";
    featureDetails.Add("ManageUserRoles", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManagePickupList";
    featureDetails.Add("ManagePickupList", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManageTenantSettings";
    featureDetails.Add("ManageTenantSettings", feature);

    feature = new PackageFeature();
    feature.FeatureId = "ManageUser";
    featureDetails.Add("ManageUser", feature);

    licensePackageDetails.PacakgeFeatureDetails = featureDetails;

    Dictionary<string, PackageUsage> usageDetails = new Dictionary<string, PackageUsage>();

    PackageUsage usage = new PackageUsage();
    usage.UsageCode = "CompanyUsage";
    usageDetails.Add("CompanyUsage", usage);

    licensePackageDetails.PackageUsageDetails = usageDetails;
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    string updatedPackageId =  licenseService.UpdatePackage(licensePackageDetails);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have permission for this method
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.UpdateRoleServices Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..UpdateRoleServices Method
ILicenseService Interface See Also Send Feedback
This method is used to update role service.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRoleServices(
    string roleId,
    string[] serviceIds
)
Visual Basic
Sub UpdateRoleServices (
    roleId As String,
    serviceIds As String()
)
Visual C++
void UpdateRoleServices(
    String^ roleId,
    array<String^>^ serviceIds
)

Parameters

roleId
Type: System..::..String
Role Id
serviceIds
Type: array<System..::..String>[]()[][]
Service Ids

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.UpdateTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..UpdateTenantLicense Method
ILicenseService Interface Example See Also Send Feedback
Updates the given tenant's subscription license

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateTenantLicense(
    TenantLicense tenantLicense
)
Visual Basic
Function UpdateTenantLicense (
    tenantLicense As TenantLicense
) As String
Visual C++
String^ UpdateTenantLicense(
    TenantLicense^ tenantLicense
)

Parameters

tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License Details(Mandatory - Tenant Identifier, Package Identifier)

Return Value

Type: String
The Tenant License Id

Examples

Copy image Copy
public void UpdateTenantLicense()
{
    TenantLicense tenantLicense = new TenantLicense();
    tenantLicense.TenantLicenseCode = "196078AF-7844-4391-AB59-38FEA2E5AB0E";
    tenantLicense.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    tenantLicense.PackageId = "A8174FD7-808F-4CB1-A3E4-F3013684DEEE";
    tenantLicense.NumberOfUsers = 150;
    tenantLicense.ValidityStart = DateTime.Now;
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    string tenantLicenseId = licenseService.InsertTenantLicense(tenantLicense);
}

Exceptions

Exception | Condition
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if user don't have update tenant license permission
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.UpdateTenantService Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..UpdateTenantService Method
ILicenseService Interface See Also Send Feedback
This method is used to update tenant service.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateTenantService(
    TenantServiceMapping tenantServiceMapping
)
Visual Basic
Sub UpdateTenantService (
    tenantServiceMapping As TenantServiceMapping
)
Visual C++
void UpdateTenantService(
    TenantServiceMapping^ tenantServiceMapping
)

Parameters

tenantServiceMapping
Type: CelloSaaS.Model.LicenseManagement..::..TenantServiceMapping
Tenant Service Mapping

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.UpdateUserServices Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..UpdateUserServices Method
ILicenseService Interface See Also Send Feedback
This method is used to update user service.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserServices(
    string userId,
    string[] serviceIds
)
Visual Basic
Sub UpdateUserServices (
    userId As String,
    serviceIds As String()
)
Visual C++
void UpdateUserServices(
    String^ userId,
    array<String^>^ serviceIds
)

Parameters

userId
Type: System..::..String
User Id
serviceIds
Type: array<System..::..String>[]()[][]
Service Ids

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException | Throws ServiceMappingException.

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.ValidateModuleLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..ValidateModuleLicense Method
ILicenseService Interface Example See Also Send Feedback
Validates the tenant subscription package whether it contains the given module name.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateModuleLicense(
    string moduleNameAccessed,
    string tenantId
)
Visual Basic
Function ValidateModuleLicense (
    moduleNameAccessed As String,
    tenantId As String
) As Boolean
Visual C++
bool ValidateModuleLicense(
    String^ moduleNameAccessed,
    String^ tenantId
)

Parameters

moduleNameAccessed
Type: System..::..String
Module Name(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: Boolean
The True/False value

Examples

Copy image Copy
public void ValidateModuleLicense()
{
    string moduleName = "User";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    bool validModule = licenseService.ValidateModuleLicense(moduleName, tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.ValidateTenantLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..ValidateTenantLicense Method
ILicenseService Interface Example See Also Send Feedback
Validates the tenant subscription package. Returns "true" If the validatity end date is greater than now (current datetime) else "false"

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateTenantLicense(
    string tenantId
)
Visual Basic
Function ValidateTenantLicense (
    tenantId As String
) As Boolean
Visual C++
bool ValidateTenantLicense(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: Boolean
The True/False value

Examples

Copy image Copy
public void ValidateTenantLicense()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    bool isValid = licenseService.ValidateTenantLicense(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ILicenseService.ValidateUsageLicense Method

[image]

A Sandcastle Documented Class Library
ILicenseService..::..ValidateUsageLicense Method
ILicenseService Interface Example See Also Send Feedback
This method is used to validate license for usage limit of tenant.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ValidateUsageLicense(
    string usageType,
    string usageCode,
    double amount,
    string tenantId
)
Visual Basic
Function ValidateUsageLicense (
    usageType As String,
    usageCode As String,
    amount As Double,
    tenantId As String
) As String
Visual C++
String^ ValidateUsageLicense(
    String^ usageType,
    String^ usageCode,
    double amount,
    String^ tenantId
)

Parameters

usageType
Type: System..::..String
Usage Type(Mandatory)
usageCode
Type: System..::..String
Usage Name((Mandatory)
amount
Type: System..::..Double
Usage Amount(Mandatory - Not less than or equal to zero)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: String
The Usage Status

Examples

Copy image Copy
public void ValidateUsageLicense()
{
    string usageType = "BlockUsage";
    string usageCode = "CompanyUsage";
    double amount = 2;
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ILicenseService licenseService = ServiceLocator.Resolve<ILicenseService>();
    bool validUsage = licenseService.ValidateUsageLicense(usageType, usageName, amount, tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any errors occurs in module license validate

See Also

ILicenseService Interface
ILicenseService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService Interface

[image]

A Sandcastle Documented Class Library
IMeteringService Interface
Members See Also Send Feedback
Contains services to increment/decrement and validate the metering components

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IMeteringService
Visual Basic
Public Interface IMeteringService
Visual C++
public interface class IMeteringService

See Also

IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService Members

[image] [image]

A Sandcastle Documented Class Library
IMeteringService Members
IMeteringService Interface Methods See Also Send Feedback

The IMeteringService type exposes the following members.

Methods

 | Name | Description
Public method | DecrementMeterUsage | Increments the usage by the given amount.
Public method | GetChildTenantsUsageAmount | Gets the usage amount from the given period for the child tenants.
Public method | GetMeteringLogDetails | Returns the metering log details for the given date period.
Public method | GetMeterUsage | Returns the used amount for the given usage.
Public method | GetUsageAmount | Gets the usage amount from the given period.
Public method | IncrementMeterUsage | Increments the usage by the given amount.
Public method | InsertLogMeteringDetails | Inserts metering log record in the database for the given values. Used internally. App developer must not use. Instead use IncrementMeterUsage(String, String, Double)
Public method | ResetMeterUsage | Resets the meter usage amount to 0.
Public method | SearchMeteringLog | Search metering log details
Public method | SearchUsageDetails | Searches the usage details.

See Also

IMeteringService Interface
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService Methods

[image] [image]

A Sandcastle Documented Class Library
IMeteringService Methods
IMeteringService Interface See Also Send Feedback

The IMeteringService type exposes the following members.

Methods

 | Name | Description
Public method | DecrementMeterUsage | Increments the usage by the given amount.
Public method | GetChildTenantsUsageAmount | Gets the usage amount from the given period for the child tenants.
Public method | GetMeteringLogDetails | Returns the metering log details for the given date period.
Public method | GetMeterUsage | Returns the used amount for the given usage.
Public method | GetUsageAmount | Gets the usage amount from the given period.
Public method | IncrementMeterUsage | Increments the usage by the given amount.
Public method | InsertLogMeteringDetails | Inserts metering log record in the database for the given values. Used internally. App developer must not use. Instead use IncrementMeterUsage(String, String, Double)
Public method | ResetMeterUsage | Resets the meter usage amount to 0.
Public method | SearchMeteringLog | Search metering log details
Public method | SearchUsageDetails | Searches the usage details.

See Also

IMeteringService Interface
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.DecrementMeterUsage Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..DecrementMeterUsage Method
IMeteringService Interface Example See Also Send Feedback
Increments the usage by the given amount.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool DecrementMeterUsage(
    string tenantId,
    string usageCode,
    double amount
)
Visual Basic
Function DecrementMeterUsage (
    tenantId As String,
    usageCode As String,
    amount As Double
) As Boolean
Visual C++
bool DecrementMeterUsage(
    String^ tenantId,
    String^ usageCode,
    double amount
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
usageCode
Type: System..::..String
Usage Code(Mandatory)
amount
Type: System..::..Double
Usage Amount

Return Value

Type: Boolean
returns True/False

Examples

Copy image Copy
public void DecrementMeterUsage()
{
    string tenantId = UserIdentity.TenantID;
    string usageCode = "CompanyUsage";
    double amount = 1;
    IMeteringService meteringService = ServiceLocator.Resolve<IMeteringService>();
    bool decrementedUsage = meteringService.DecrementMeterUsage(tenantId, usageCode, amount);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | If any mandatory argument is null or empty
System..::..ArgumentException | If any argument is producing error
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | If any error occurs in this method

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.GetChildTenantsUsageAmount Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..GetChildTenantsUsageAmount Method
IMeteringService Interface See Also Send Feedback
Gets the usage amount from the given period for the child tenants.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, double>> GetChildTenantsUsageAmount(
    string[] usageCodes,
    DateTime fromDate,
    DateTime toDate,
    string parentTenantId
)
Visual Basic
Function GetChildTenantsUsageAmount (
    usageCodes As String(),
    fromDate As DateTime,
    toDate As DateTime,
    parentTenantId As String
) As Dictionary(Of String, Dictionary(Of String, Double))
Visual C++
Dictionary<String^, Dictionary<String^, double>^>^ GetChildTenantsUsageAmount(
    array<String^>^ usageCodes,
    DateTime fromDate,
    DateTime toDate,
    String^ parentTenantId
)

Parameters

usageCodes
Type: array<System..::..String>[]()[][]
usage code arrary (optional)
fromDate
Type: System..::..DateTime
from date
toDate
Type: System..::..DateTime
to date
parentTenantId
Type: System..::..String
tenant id

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, Double>)>)>>)>)>

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.GetMeteringLogDetails Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..GetMeteringLogDetails Method
IMeteringService Interface Example See Also Send Feedback
Returns the metering log details for the given date period.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<MeteringLog>> GetMeteringLogDetails(
    string tenantId,
    Nullable<DateTime> startDate,
    Nullable<DateTime> endDate
)
Visual Basic
Function GetMeteringLogDetails (
    tenantId As String,
    startDate As Nullable(Of DateTime),
    endDate As Nullable(Of DateTime)
) As Dictionary(Of String, List(Of MeteringLog))
Visual C++
Dictionary<String^, List<MeteringLog^>^>^ GetMeteringLogDetails(
    String^ tenantId,
    Nullable<DateTime> startDate,
    Nullable<DateTime> endDate
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
startDate
Type: System..::..Nullable<(Of <(<'DateTime>)>)>
Start Date of the log
endDate
Type: System..::..Nullable<(Of <(<'DateTime>)>)>
End Date of the log

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<' MeteringLog >)>)>>)>)>
Metering Log Details

Examples

Copy image Copy
public void GetMeteringLogDetails()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    DateTime? startDate =  Convert.ToDateTime("4/1/2010");
    DateTime? endDate = Convert.ToDateTime("4/15/2010");
    IMeteringService meteringService = ServiceLocator.Resolve<IMeteringService>();
    Dictionary<string, List<MeteringLog>> meteringLogDetails = meteringService.GetMeteringLogDetails(tenantId, startDate, endDate);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any error occurs in this method

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.GetMeterUsage Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..GetMeterUsage Method
IMeteringService Interface Example See Also Send Feedback
Returns the used amount for the given usage.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
double GetMeterUsage(
    string tenantId,
    string usageCode
)
Visual Basic
Function GetMeterUsage (
    tenantId As String,
    usageCode As String
) As Double
Visual C++
double GetMeterUsage(
    String^ tenantId,
    String^ usageCode
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
usageCode
Type: System..::..String
Usage Code(Mandatory)

Return Value

Type: Double
returns UsageAmount

Examples

Copy image Copy
public void GetMeterUsage()
{
    string tenantId = UserIdentity.TenantID;
    string usageCode = "CompanyUsage";
    IMeteringService meteringService = ServiceLocator.Resolve<IMeteringService>();
    double usageAmount = meteringService.GetMeterUsage(tenantId, usageCode);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any error occurs in this method

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.GetUsageAmount Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..GetUsageAmount Method
IMeteringService Interface See Also Send Feedback
Gets the usage amount from the given period.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, double> GetUsageAmount(
    string[] usageCodes,
    DateTime fromDate,
    DateTime toDate,
    string tenantId
)
Visual Basic
Function GetUsageAmount (
    usageCodes As String(),
    fromDate As DateTime,
    toDate As DateTime,
    tenantId As String
) As Dictionary(Of String, Double)
Visual C++
Dictionary<String^, double>^ GetUsageAmount(
    array<String^>^ usageCodes,
    DateTime fromDate,
    DateTime toDate,
    String^ tenantId
)

Parameters

usageCodes
Type: array<System..::..String>[]()[][]
usage code arrary (optional)
fromDate
Type: System..::..DateTime
from date
toDate
Type: System..::..DateTime
to date
tenantId
Type: System..::..String
tenant id

Return Value

Type: Dictionary<(Of <(<'String, Double>)>)>

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.IncrementMeterUsage Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..IncrementMeterUsage Method
IMeteringService Interface Example See Also Send Feedback
Increments the usage by the given amount.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool IncrementMeterUsage(
    string tenantId,
    string usageCode,
    double amount
)
Visual Basic
Function IncrementMeterUsage (
    tenantId As String,
    usageCode As String,
    amount As Double
) As Boolean
Visual C++
bool IncrementMeterUsage(
    String^ tenantId,
    String^ usageCode,
    double amount
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
usageCode
Type: System..::..String
Usage Code(Mandatory)
amount
Type: System..::..Double
Usage Amount

Return Value

Type: Boolean
The True/False value

Examples

Copy image Copy
public void IncrementMeterUsage()
{
    string tenantId = UserIdentity.TenantID;
    string usageCode = "SampleUsage";
    double amount = 1.0;
    IMeteringService meteringService = ServiceLocator.Resolve<IMeteringService>();
    bool incrementedUsage = meteringService.IncrementMeterUsage(tenantId, usageCode, amount);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | If any mandatory argument is null or empty
System..::..ArgumentException | If any argument is producing error
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | If any error occurs in this method
CelloSaaS.ServiceContracts.UserManagement..::..LicenseLimitException | If the usage limit exceeds

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.InsertLogMeteringDetails Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..InsertLogMeteringDetails Method
IMeteringService Interface See Also Send Feedback
Inserts metering log record in the database for the given values. Used internally. App developer must not use. Instead use IncrementMeterUsage(String, String, Double)

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InsertLogMeteringDetails(
    string tenantId,
    string usageCode,
    double amount
)
Visual Basic
Function InsertLogMeteringDetails (
    tenantId As String,
    usageCode As String,
    amount As Double
) As String
Visual C++
String^ InsertLogMeteringDetails(
    String^ tenantId,
    String^ usageCode,
    double amount
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
usageCode
Type: System..::..String
Usage Code(Mandatory)
amount
Type: System..::..Double
Amount(Not equal to Zero)

Return Value

Type: String
Returns LogId(Success)/Empty(Fails)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..ArgumentException | Throws ArgumentException if any argument is producing error
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any error occurs in this method

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.ResetMeterUsage Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..ResetMeterUsage Method
IMeteringService Interface See Also Send Feedback
Resets the meter usage amount to 0.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ResetMeterUsage(
    string tenantId,
    string[] usageCodes
)
Visual Basic
Function ResetMeterUsage (
    tenantId As String,
    usageCodes As String()
) As Boolean
Visual C++
bool ResetMeterUsage(
    String^ tenantId,
    array<String^>^ usageCodes
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier
usageCodes
Type: array<System..::..String>[]()[][]
Usage Codes

Return Value

Type: Boolean

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException | Throws LicenseException if any error occurs in this method

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.SearchMeteringLog Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..SearchMeteringLog Method
IMeteringService Interface See Also Send Feedback
Search metering log details

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
MeteringSearchResult SearchMeteringLog(
    MeteringSearchCondition meteringSearchCondition
)
Visual Basic
Function SearchMeteringLog (
    meteringSearchCondition As MeteringSearchCondition
) As MeteringSearchResult
Visual C++
MeteringSearchResult^ SearchMeteringLog(
    MeteringSearchCondition^ meteringSearchCondition
)

Parameters

meteringSearchCondition
Type: CelloSaaS.Model.LicenseManagement..::..MeteringSearchCondition
metering search condition

Return Value

Type: MeteringSearchResult

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


IMeteringService.SearchUsageDetails Method

[image]

A Sandcastle Documented Class Library
IMeteringService..::..SearchUsageDetails Method
IMeteringService Interface See Also Send Feedback
Searches the usage details.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UsageSearchResult SearchUsageDetails(
    UsageSearchCondition searchCondition
)
Visual Basic
Function SearchUsageDetails (
    searchCondition As UsageSearchCondition
) As UsageSearchResult
Visual C++
UsageSearchResult^ SearchUsageDetails(
    UsageSearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.Model.LicenseManagement..::..UsageSearchCondition
The search condition.

Return Value

Type: UsageSearchResult

See Also

IMeteringService Interface
IMeteringService Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidNumberOfUsers Class

[image]

A Sandcastle Documented Class Library
InvalidNumberOfUsers Class
Members See Also Send Feedback
Invalid Number Of Users

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidNumberOfUsers : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidNumberOfUsers
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidNumberOfUsers : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.LicenseManagement..::..InvalidNumberOfUsers

See Also

InvalidNumberOfUsers Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidNumberOfUsers Members

[image] [image]

A Sandcastle Documented Class Library
InvalidNumberOfUsers Members
InvalidNumberOfUsers Class Constructors Methods Properties Events See Also Send Feedback

The InvalidNumberOfUsers type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidNumberOfUsers | Initializes a new instance of the InvalidNumberOfUsers class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidNumberOfUsers Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidNumberOfUsers Constructor

[image]

A Sandcastle Documented Class Library
InvalidNumberOfUsers Constructor
InvalidNumberOfUsers Class See Also Send Feedback
Initializes a new instance of the InvalidNumberOfUsers class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidNumberOfUsers(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidNumberOfUsers(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidNumberOfUsers Class
InvalidNumberOfUsers Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidNumberOfUsers Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidNumberOfUsers Methods
InvalidNumberOfUsers Class See Also Send Feedback

The InvalidNumberOfUsers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidNumberOfUsers Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidNumberOfUsers Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidNumberOfUsers Properties
InvalidNumberOfUsers Class See Also Send Feedback

The InvalidNumberOfUsers type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidNumberOfUsers Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidNumberOfUsers Events

[image] [image]

A Sandcastle Documented Class Library
InvalidNumberOfUsers Events
InvalidNumberOfUsers Class See Also Send Feedback

The InvalidNumberOfUsers type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidNumberOfUsers Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Class

[image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Class
Members See Also Send Feedback
Invalid usage type exception

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidUsageTypeException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidUsageTypeException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidUsageTypeException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.LicenseManagement..::..InvalidUsageTypeException

See Also

InvalidUsageTypeException Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Members
InvalidUsageTypeException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidUsageTypeException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidUsageTypeException(String) | Initializes a new instance of the InvalidUsageTypeException class.
Public method | InvalidUsageTypeException(String, Exception) | Initializes a new instance of the InvalidUsageTypeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidUsageTypeException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Constructor
InvalidUsageTypeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidUsageTypeException(String) | Initializes a new instance of the InvalidUsageTypeException class.
Public method | InvalidUsageTypeException(String, Exception) | Initializes a new instance of the InvalidUsageTypeException class.

See Also

InvalidUsageTypeException Class
InvalidUsageTypeException Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Constructor (String)
InvalidUsageTypeException Class See Also Send Feedback
Initializes a new instance of the InvalidUsageTypeException class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidUsageTypeException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidUsageTypeException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidUsageTypeException Class
InvalidUsageTypeException Members
InvalidUsageTypeException Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Constructor (String, Exception)
InvalidUsageTypeException Class See Also Send Feedback
Initializes a new instance of the InvalidUsageTypeException class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidUsageTypeException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidUsageTypeException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidUsageTypeException Class
InvalidUsageTypeException Members
InvalidUsageTypeException Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Methods
InvalidUsageTypeException Class See Also Send Feedback

The InvalidUsageTypeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidUsageTypeException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Properties
InvalidUsageTypeException Class See Also Send Feedback

The InvalidUsageTypeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidUsageTypeException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


InvalidUsageTypeException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidUsageTypeException Events
InvalidUsageTypeException Class See Also Send Feedback

The InvalidUsageTypeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidUsageTypeException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant Class

[image]

A Sandcastle Documented Class Library
LicenseConstant Class
Members See Also Send Feedback
Usaget limit Constants

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class LicenseConstant
Visual Basic
Public Class LicenseConstant
Visual C++
public ref class LicenseConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseConstant

See Also

LicenseConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant Members

[image] [image]

A Sandcastle Documented Class Library
LicenseConstant Members
LicenseConstant Class Constructors Methods Fields See Also Send Feedback

The LicenseConstant type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseConstant | Initializes a new instance of the LicenseConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
CrossedLimit | CrossedLimit
OverUsageAllowed | OverUsageAllowed
WithinLimit | WithinLimit

See Also

LicenseConstant Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant Constructor

[image]

A Sandcastle Documented Class Library
LicenseConstant Constructor
LicenseConstant Class See Also Send Feedback
Initializes a new instance of the LicenseConstant class

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseConstant()
Visual Basic
Public Sub New
Visual C++
public:
LicenseConstant()

See Also

LicenseConstant Class
LicenseConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant Fields

[image] [image]

A Sandcastle Documented Class Library
LicenseConstant Fields
LicenseConstant Class See Also Send Feedback

The LicenseConstant type exposes the following members.

Fields

Name | Description
CrossedLimit | CrossedLimit
OverUsageAllowed | OverUsageAllowed
WithinLimit | WithinLimit

See Also

LicenseConstant Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant.CrossedLimit Field

[image]

A Sandcastle Documented Class Library
LicenseConstant..::..CrossedLimit Field
LicenseConstant Class See Also Send Feedback
CrossedLimit

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CrossedLimit
Visual Basic
Public Const CrossedLimit As String
Visual C++
public:
literal String^ CrossedLimit

Field Value

Type: String

See Also

LicenseConstant Class
LicenseConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant.OverUsageAllowed Field

[image]

A Sandcastle Documented Class Library
LicenseConstant..::..OverUsageAllowed Field
LicenseConstant Class See Also Send Feedback
OverUsageAllowed

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string OverUsageAllowed
Visual Basic
Public Const OverUsageAllowed As String
Visual C++
public:
literal String^ OverUsageAllowed

Field Value

Type: String

See Also

LicenseConstant Class
LicenseConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant.WithinLimit Field

[image]

A Sandcastle Documented Class Library
LicenseConstant..::..WithinLimit Field
LicenseConstant Class See Also Send Feedback
WithinLimit

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WithinLimit
Visual Basic
Public Const WithinLimit As String
Visual C++
public:
literal String^ WithinLimit

Field Value

Type: String

See Also

LicenseConstant Class
LicenseConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseConstant Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseConstant Methods
LicenseConstant Class See Also Send Feedback

The LicenseConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LicenseConstant Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Class

[image]

A Sandcastle Documented Class Library
LicenseException Class
Members See Also Send Feedback
License Exception

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicenseException : BaseException
Visual Basic
<SerializableAttribute>
Public Class LicenseException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class LicenseException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.LicenseManagement..::..LicenseException

See Also

LicenseException Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Members

[image] [image]

A Sandcastle Documented Class Library
LicenseException Members
LicenseException Class Constructors Methods Properties Events See Also Send Feedback

The LicenseException type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseException(String) | Initializes a new instance of the LicenseException class.
Public method | LicenseException(String, Exception) | Initializes a new instance of the LicenseException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LicenseException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Constructor

[image] [image]

A Sandcastle Documented Class Library
LicenseException Constructor
LicenseException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LicenseException(String) | Initializes a new instance of the LicenseException class.
Public method | LicenseException(String, Exception) | Initializes a new instance of the LicenseException class.

See Also

LicenseException Class
LicenseException Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Constructor (String)

[image]

A Sandcastle Documented Class Library
LicenseException Constructor (String)
LicenseException Class See Also Send Feedback
Initializes a new instance of the LicenseException class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
LicenseException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

LicenseException Class
LicenseException Members
LicenseException Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
LicenseException Constructor (String, Exception)
LicenseException Class See Also Send Feedback
Initializes a new instance of the LicenseException class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
LicenseException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

LicenseException Class
LicenseException Members
LicenseException Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseException Methods
LicenseException Class See Also Send Feedback

The LicenseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Properties

[image] [image]

A Sandcastle Documented Class Library
LicenseException Properties
LicenseException Class See Also Send Feedback

The LicenseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


LicenseException Events

[image] [image]

A Sandcastle Documented Class Library
LicenseException Events
LicenseException Class See Also Send Feedback

The LicenseException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LicenseException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


PackageConstant Class

[image]

A Sandcastle Documented Class Library
PackageConstant Class
Members See Also Send Feedback
Package Constant

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class PackageConstant
Visual Basic
Public Class PackageConstant
Visual C++
public ref class PackageConstant

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.LicenseManagement..::..PackageConstant

See Also

PackageConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


PackageConstant Members

[image] [image]

A Sandcastle Documented Class Library
PackageConstant Members
PackageConstant Class Constructors Methods Fields See Also Send Feedback

The PackageConstant type exposes the following members.

Constructors

 | Name | Description
Public method | PackageConstant | Initializes a new instance of the PackageConstant class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
UnRestrictedPackage | UnRestrictedPackage

See Also

PackageConstant Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


PackageConstant Constructor

[image]

A Sandcastle Documented Class Library
PackageConstant Constructor
PackageConstant Class See Also Send Feedback
Initializes a new instance of the PackageConstant class

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageConstant()
Visual Basic
Public Sub New
Visual C++
public:
PackageConstant()

See Also

PackageConstant Class
PackageConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


PackageConstant Fields

[image] [image]

A Sandcastle Documented Class Library
PackageConstant Fields
PackageConstant Class See Also Send Feedback

The PackageConstant type exposes the following members.

Fields

Name | Description
UnRestrictedPackage | UnRestrictedPackage

See Also

PackageConstant Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


PackageConstant.UnRestrictedPackage Field

[image]

A Sandcastle Documented Class Library
PackageConstant..::..UnRestrictedPackage Field
PackageConstant Class See Also Send Feedback
UnRestrictedPackage

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UnRestrictedPackage
Visual Basic
Public Const UnRestrictedPackage As String
Visual C++
public:
literal String^ UnRestrictedPackage

Field Value

Type: String

See Also

PackageConstant Class
PackageConstant Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


PackageConstant Methods

[image] [image]

A Sandcastle Documented Class Library
PackageConstant Methods
PackageConstant Class See Also Send Feedback

The PackageConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PackageConstant Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Class

[image]

A Sandcastle Documented Class Library
ServiceMappingException Class
Members See Also Send Feedback
Service Mapping Exception

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ServiceMappingException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ServiceMappingException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ServiceMappingException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.LicenseManagement..::..ServiceMappingException

See Also

ServiceMappingException Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Members

[image] [image]

A Sandcastle Documented Class Library
ServiceMappingException Members
ServiceMappingException Class Constructors Methods Properties Events See Also Send Feedback

The ServiceMappingException type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceMappingException(String) | Initializes a new instance of the ServiceMappingException class.
Public method | ServiceMappingException(String, Exception) | Initializes a new instance of the ServiceMappingException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ServiceMappingException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Constructor

[image] [image]

A Sandcastle Documented Class Library
ServiceMappingException Constructor
ServiceMappingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ServiceMappingException(String) | Initializes a new instance of the ServiceMappingException class.
Public method | ServiceMappingException(String, Exception) | Initializes a new instance of the ServiceMappingException class.

See Also

ServiceMappingException Class
ServiceMappingException Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Constructor (String)

[image]

A Sandcastle Documented Class Library
ServiceMappingException Constructor (String)
ServiceMappingException Class See Also Send Feedback
Initializes a new instance of the ServiceMappingException class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ServiceMappingException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ServiceMappingException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ServiceMappingException Class
ServiceMappingException Members
ServiceMappingException Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ServiceMappingException Constructor (String, Exception)
ServiceMappingException Class See Also Send Feedback
Initializes a new instance of the ServiceMappingException class.

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ServiceMappingException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ServiceMappingException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

ServiceMappingException Class
ServiceMappingException Members
ServiceMappingException Overload
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Methods

[image] [image]

A Sandcastle Documented Class Library
ServiceMappingException Methods
ServiceMappingException Class See Also Send Feedback

The ServiceMappingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ServiceMappingException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Properties

[image] [image]

A Sandcastle Documented Class Library
ServiceMappingException Properties
ServiceMappingException Class See Also Send Feedback

The ServiceMappingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServiceMappingException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


ServiceMappingException Events

[image] [image]

A Sandcastle Documented Class Library
ServiceMappingException Events
ServiceMappingException Class See Also Send Feedback

The ServiceMappingException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ServiceMappingException Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants Class

[image]

A Sandcastle Documented Class Library
UsageTypeConstants Class
Members See Also Send Feedback
Usage type constants

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class UsageTypeConstants
Visual Basic
Public Class UsageTypeConstants
Visual C++
public ref class UsageTypeConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.LicenseManagement..::..UsageTypeConstants

See Also

UsageTypeConstants Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants Members

[image] [image]

A Sandcastle Documented Class Library
UsageTypeConstants Members
UsageTypeConstants Class Constructors Methods Fields See Also Send Feedback

The UsageTypeConstants type exposes the following members.

Constructors

 | Name | Description
Public method | UsageTypeConstants | Initializes a new instance of the UsageTypeConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
BillingPeriodBlocked | Billing Period Blocked
BlockUsage | Block Usage
Cumulative | Cummulative usage (summed up from the start point)

See Also

UsageTypeConstants Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants Constructor

[image]

A Sandcastle Documented Class Library
UsageTypeConstants Constructor
UsageTypeConstants Class See Also Send Feedback
Initializes a new instance of the UsageTypeConstants class

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UsageTypeConstants()
Visual Basic
Public Sub New
Visual C++
public:
UsageTypeConstants()

See Also

UsageTypeConstants Class
UsageTypeConstants Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
UsageTypeConstants Fields
UsageTypeConstants Class See Also Send Feedback

The UsageTypeConstants type exposes the following members.

Fields

Name | Description
BillingPeriodBlocked | Billing Period Blocked
BlockUsage | Block Usage
Cumulative | Cummulative usage (summed up from the start point)

See Also

UsageTypeConstants Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants.BillingPeriodBlocked Field

[image]

A Sandcastle Documented Class Library
UsageTypeConstants..::..BillingPeriodBlocked Field
UsageTypeConstants Class See Also Send Feedback
Billing Period Blocked

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BillingPeriodBlocked
Visual Basic
Public Const BillingPeriodBlocked As String
Visual C++
public:
literal String^ BillingPeriodBlocked

Field Value

Type: String

See Also

UsageTypeConstants Class
UsageTypeConstants Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants.BlockUsage Field

[image]

A Sandcastle Documented Class Library
UsageTypeConstants..::..BlockUsage Field
UsageTypeConstants Class See Also Send Feedback
Block Usage

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BlockUsage
Visual Basic
Public Const BlockUsage As String
Visual C++
public:
literal String^ BlockUsage

Field Value

Type: String

See Also

UsageTypeConstants Class
UsageTypeConstants Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants.Cumulative Field

[image]

A Sandcastle Documented Class Library
UsageTypeConstants..::..Cumulative Field
UsageTypeConstants Class See Also Send Feedback
Cummulative usage (summed up from the start point)

Namespace: CelloSaaS.ServiceContracts.LicenseManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Cumulative
Visual Basic
Public Const Cumulative As String
Visual C++
public:
literal String^ Cumulative

Field Value

Type: String

See Also

UsageTypeConstants Class
UsageTypeConstants Members
CelloSaaS.ServiceContracts.LicenseManagement Namespace


UsageTypeConstants Methods

[image] [image]

A Sandcastle Documented Class Library
UsageTypeConstants Methods
UsageTypeConstants Class See Also Send Feedback

The UsageTypeConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UsageTypeConstants Class
CelloSaaS.ServiceContracts.LicenseManagement Namespace


CelloSaaS.ServiceContracts.Logger Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.Logger Namespace
Send Feedback

Classes

 | Class | Description
Public class | LoggerException | The ProductAnalyticsException class

Interfaces

 | Interface | Description
Public interface | ILoggerService | CelloSaaS datbase exception log access utility interface


ILoggerService Interface

[image]

A Sandcastle Documented Class Library
ILoggerService Interface
Members See Also Send Feedback
CelloSaaS datbase exception log access utility interface

Namespace: CelloSaaS.ServiceContracts.Logger
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ILoggerService
Visual Basic
Public Interface ILoggerService
Visual C++
public interface class ILoggerService

See Also

ILoggerService Members
CelloSaaS.ServiceContracts.Logger Namespace


ILoggerService Members

[image] [image]

A Sandcastle Documented Class Library
ILoggerService Members
ILoggerService Interface Methods See Also Send Feedback

The ILoggerService type exposes the following members.

Methods

 | Name | Description
Public method | SearchLog | Searches the exception log from the database

See Also

ILoggerService Interface
CelloSaaS.ServiceContracts.Logger Namespace


ILoggerService Methods

[image] [image]

A Sandcastle Documented Class Library
ILoggerService Methods
ILoggerService Interface See Also Send Feedback

The ILoggerService type exposes the following members.

Methods

 | Name | Description
Public method | SearchLog | Searches the exception log from the database

See Also

ILoggerService Interface
CelloSaaS.ServiceContracts.Logger Namespace


ILoggerService.SearchLog Method

[image]

A Sandcastle Documented Class Library
ILoggerService..::..SearchLog Method
ILoggerService Interface See Also Send Feedback
Searches the exception log from the database

Namespace: CelloSaaS.ServiceContracts.Logger
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
CelloLogEntrySearchResult SearchLog(
    CelloLogEntrySearchCondition searchCondition
)
Visual Basic
Function SearchLog (
    searchCondition As CelloLogEntrySearchCondition
) As CelloLogEntrySearchResult
Visual C++
CelloLogEntrySearchResult^ SearchLog(
    CelloLogEntrySearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.Model.Logger..::..CelloLogEntrySearchCondition
The search condition.

Return Value

Type: CelloLogEntrySearchResult

See Also

ILoggerService Interface
ILoggerService Members
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Class

[image]

A Sandcastle Documented Class Library
LoggerException Class
Members See Also Send Feedback
The ProductAnalyticsException class

Namespace: CelloSaaS.ServiceContracts.Logger
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LoggerException : BaseException
Visual Basic
<SerializableAttribute>
Public Class LoggerException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class LoggerException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Logger..::..LoggerException

See Also

LoggerException Members
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Members

[image] [image]

A Sandcastle Documented Class Library
LoggerException Members
LoggerException Class Constructors Methods Properties Events See Also Send Feedback

The LoggerException type exposes the following members.

Constructors

 | Name | Description
Public method | LoggerException(String) | Initializes a new instance of the LoggerException class.
Public method | LoggerException(String, Exception) | Initializes a new instance of the LoggerException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LoggerException Class
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Constructor

[image] [image]

A Sandcastle Documented Class Library
LoggerException Constructor
LoggerException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoggerException(String) | Initializes a new instance of the LoggerException class.
Public method | LoggerException(String, Exception) | Initializes a new instance of the LoggerException class.

See Also

LoggerException Class
LoggerException Members
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Constructor (String)

[image]

A Sandcastle Documented Class Library
LoggerException Constructor (String)
LoggerException Class See Also Send Feedback
Initializes a new instance of the LoggerException class.

Namespace: CelloSaaS.ServiceContracts.Logger
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LoggerException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
LoggerException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

LoggerException Class
LoggerException Members
LoggerException Overload
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
LoggerException Constructor (String, Exception)
LoggerException Class See Also Send Feedback
Initializes a new instance of the LoggerException class.

Namespace: CelloSaaS.ServiceContracts.Logger
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LoggerException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
LoggerException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
The message.
ex
Type: System..::..Exception
The ex.

See Also

LoggerException Class
LoggerException Members
LoggerException Overload
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Methods

[image] [image]

A Sandcastle Documented Class Library
LoggerException Methods
LoggerException Class See Also Send Feedback

The LoggerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LoggerException Class
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Properties

[image] [image]

A Sandcastle Documented Class Library
LoggerException Properties
LoggerException Class See Also Send Feedback

The LoggerException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LoggerException Class
CelloSaaS.ServiceContracts.Logger Namespace


LoggerException Events

[image] [image]

A Sandcastle Documented Class Library
LoggerException Events
LoggerException Class See Also Send Feedback

The LoggerException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LoggerException Class
CelloSaaS.ServiceContracts.Logger Namespace


CelloSaaS.ServiceContracts.MasterData Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.MasterData Namespace
Send Feedback

Classes

 | Class | Description
Public class | MasterDataException | MasterData Exception

Interfaces

 | Interface | Description
Public interface | IAddressService | This interface defines the methods for the address details.
Public interface | ICountryService | This interface defines the methods for the country details.
Public interface | ILanguageService | This interface defines the method for language details.


IAddressService Interface

[image]

A Sandcastle Documented Class Library
IAddressService Interface
Members See Also Send Feedback
This interface defines the methods for the address details.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IAddressService
Visual Basic
Public Interface IAddressService
Visual C++
public interface class IAddressService

See Also

IAddressService Members
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService Members

[image] [image]

A Sandcastle Documented Class Library
IAddressService Members
IAddressService Interface Methods See Also Send Feedback

The IAddressService type exposes the following members.

Methods

 | Name | Description
Public method | AddRegAddress | This method is to insert address details.
Public method | DeleteAddressDetails | This method is used to deactivate address details
Public method | GetAddressDetails | This method is used to get the address details for given address Identifiers
Public method | PermanentDeleteAddressDetails | This method is used to delete address details
Public method | UpdateAddressDetails | This method is used to update address details

See Also

IAddressService Interface
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService Methods

[image] [image]

A Sandcastle Documented Class Library
IAddressService Methods
IAddressService Interface See Also Send Feedback

The IAddressService type exposes the following members.

Methods

 | Name | Description
Public method | AddRegAddress | This method is to insert address details.
Public method | DeleteAddressDetails | This method is used to deactivate address details
Public method | GetAddressDetails | This method is used to get the address details for given address Identifiers
Public method | PermanentDeleteAddressDetails | This method is used to delete address details
Public method | UpdateAddressDetails | This method is used to update address details

See Also

IAddressService Interface
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService.AddRegAddress Method

[image]

A Sandcastle Documented Class Library
IAddressService..::..AddRegAddress Method
IAddressService Interface Example See Also Send Feedback
This method is to insert address details.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRegAddress(
    Address address
)
Visual Basic
Function AddRegAddress (
    address As Address
) As String
Visual C++
String^ AddRegAddress(
    Address^ address
)

Parameters

address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address details(Mandatory - City,State,CountryIdentifier)

Return Value

Type: String
Address Identifier

Examples

Copy image Copy
public void AddAddressDetails()
{
    Address address = new Address();
    address.Address1 = "Address";
    address.City = "City";
    address.State = "State";
    address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    address.PostalCode = "600025";
    IAddressService addressService = (IAddressService)ServiceLocator.GetServiceImplementation(typeof(IAddressService));
    address.AddressId = addressService.AddRegAddress(address);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when address,city,state,countryid is null
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while inserting address details

See Also

IAddressService Interface
IAddressService Members
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService.DeleteAddressDetails Method

[image]

A Sandcastle Documented Class Library
IAddressService..::..DeleteAddressDetails Method
IAddressService Interface Example See Also Send Feedback
This method is used to deactivate address details

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteAddressDetails(
    string addressId
)
Visual Basic
Sub DeleteAddressDetails (
    addressId As String
)
Visual C++
void DeleteAddressDetails(
    String^ addressId
)

Parameters

addressId
Type: System..::..String
Address Identifier(Mandatory)

Examples

Copy image Copy
public void DeactivateAddressDetails()
{
    string addressId = "6B9B9948-BF93-DF11-8DEB-001EC9DAB123";
    IAddressService addressService = (IAddressService)ServiceLocator.GetServiceImplementation(typeof(IAddressService));
    addressService.DeleteAddressDetails(addressId);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when addressid is null
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while deactivating address details

See Also

IAddressService Interface
IAddressService Members
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService.GetAddressDetails Method

[image]

A Sandcastle Documented Class Library
IAddressService..::..GetAddressDetails Method
IAddressService Interface Example See Also Send Feedback
This method is used to get the address details for given address Identifiers

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Address> GetAddressDetails(
    string[] addressIds
)
Visual Basic
Function GetAddressDetails (
    addressIds As String()
) As Dictionary(Of String, Address)
Visual C++
Dictionary<String^, Address^>^ GetAddressDetails(
    array<String^>^ addressIds
)

Parameters

addressIds
Type: array<System..::..String>[]()[][]
Address Identifiers(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, Address >)>)>
Address Details

Examples

Copy image Copy
public void GetAddressDetails()
{
    string[] addressIds = {"6B9B9948-BF93-DF11-8DEB-001EC9DAB123","6C9B9948-BF93-DF11-8DEB-001EC9DAB123"};
    IAddressService addressService = (IAddressService)ServiceLocator.GetServiceImplementation(typeof(IAddressService));
    Dictionary<string, Address> addressDetails = addressService.GetAddressDetails(addressIds);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when addressids are null
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while deleting address details

See Also

IAddressService Interface
IAddressService Members
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService.PermanentDeleteAddressDetails Method

[image]

A Sandcastle Documented Class Library
IAddressService..::..PermanentDeleteAddressDetails Method
IAddressService Interface Example See Also Send Feedback
This method is used to delete address details

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteAddressDetails(
    string addressId
)
Visual Basic
Sub PermanentDeleteAddressDetails (
    addressId As String
)
Visual C++
void PermanentDeleteAddressDetails(
    String^ addressId
)

Parameters

addressId
Type: System..::..String
Address Identifier(Mandatory)

Examples

Copy image Copy
public void DeleteAddressDetails()
{
    string addressId = "6B9B9948-BF93-DF11-8DEB-001EC9DAB123";
    IAddressService addressService = (IAddressService)ServiceLocator.GetServiceImplementation(typeof(IAddressService));
    addressService.PermanentDeleteAddressDetails(addressId);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when addressid is null
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while deleting address details

See Also

IAddressService Interface
IAddressService Members
CelloSaaS.ServiceContracts.MasterData Namespace


IAddressService.UpdateAddressDetails Method

[image]

A Sandcastle Documented Class Library
IAddressService..::..UpdateAddressDetails Method
IAddressService Interface Example See Also Send Feedback
This method is used to update address details

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateAddressDetails(
    Address address
)
Visual Basic
Function UpdateAddressDetails (
    address As Address
) As String
Visual C++
String^ UpdateAddressDetails(
    Address^ address
)

Parameters

address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address Details(Mandatory -AddressIdentifier,City,State,CountryIdentifier)

Return Value

Type: String
Address Identifier

Examples

Copy image Copy
public void UpdateAddressDetails()
{
    Address address = new Address();
    address.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    address.Address1 = "Address";
    address.City = "City";
    address.State = "State";
    address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    address.PostalCode = "600025";
    IAddressService addressService = (IAddressService)ServiceLocator.GetServiceImplementation(typeof(IAddressService));
    string updatedAddressId = addressService.UpdateAddressDetails(address);
}

Exceptions

Exception | Condition
System..::..ArgumentException | This exception is thrown when address,city,state,countryid, is null
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while updating address details

See Also

IAddressService Interface
IAddressService Members
CelloSaaS.ServiceContracts.MasterData Namespace


ICountryService Interface

[image]

A Sandcastle Documented Class Library
ICountryService Interface
Members See Also Send Feedback
This interface defines the methods for the country details.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ICountryService
Visual Basic
Public Interface ICountryService
Visual C++
public interface class ICountryService

See Also

ICountryService Members
CelloSaaS.ServiceContracts.MasterData Namespace


ICountryService Members

[image] [image]

A Sandcastle Documented Class Library
ICountryService Members
ICountryService Interface Methods See Also Send Feedback

The ICountryService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllCountry | This method is used to Get All country details

See Also

ICountryService Interface
CelloSaaS.ServiceContracts.MasterData Namespace


ICountryService Methods

[image] [image]

A Sandcastle Documented Class Library
ICountryService Methods
ICountryService Interface See Also Send Feedback

The ICountryService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllCountry | This method is used to Get All country details

See Also

ICountryService Interface
CelloSaaS.ServiceContracts.MasterData Namespace


ICountryService.GetAllCountry Method

[image]

A Sandcastle Documented Class Library
ICountryService..::..GetAllCountry Method
ICountryService Interface Example See Also Send Feedback
This method is used to Get All country details

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Country> GetAllCountry()
Visual Basic
Function GetAllCountry As List(Of Country)
Visual C++
List<Country^>^ GetAllCountry()

Return Value

Type: List<(Of <(<' Country >)>)>
List of Country Details

Examples

Copy image Copy
public void GetAllCountry()
{
    ICountryService countryService = (ICountryService)ServiceLocator.GetServiceImplementation(typeof(ICountryService));
    List<Country> countryDetails = countryService.GetAllCountry();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while getting country details

See Also

ICountryService Interface
ICountryService Members
CelloSaaS.ServiceContracts.MasterData Namespace


ILanguageService Interface

[image]

A Sandcastle Documented Class Library
ILanguageService Interface
Members See Also Send Feedback
This interface defines the method for language details.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ILanguageService
Visual Basic
Public Interface ILanguageService
Visual C++
public interface class ILanguageService

See Also

ILanguageService Members
CelloSaaS.ServiceContracts.MasterData Namespace


ILanguageService Members

[image] [image]

A Sandcastle Documented Class Library
ILanguageService Members
ILanguageService Interface Methods See Also Send Feedback

The ILanguageService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllLanguages | This method is used to get all language details

See Also

ILanguageService Interface
CelloSaaS.ServiceContracts.MasterData Namespace


ILanguageService Methods

[image] [image]

A Sandcastle Documented Class Library
ILanguageService Methods
ILanguageService Interface See Also Send Feedback

The ILanguageService type exposes the following members.

Methods

 | Name | Description
Public method | GetAllLanguages | This method is used to get all language details

See Also

ILanguageService Interface
CelloSaaS.ServiceContracts.MasterData Namespace


ILanguageService.GetAllLanguages Method

[image]

A Sandcastle Documented Class Library
ILanguageService..::..GetAllLanguages Method
ILanguageService Interface See Also Send Feedback
This method is used to get all language details

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Language> GetAllLanguages()
Visual Basic
Function GetAllLanguages As List(Of Language)
Visual C++
List<Language^>^ GetAllLanguages()

Return Value

Type: List<(Of <(<' Language >)>)>
Language Details

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException | This exception is thrown while getting language details

See Also

ILanguageService Interface
ILanguageService Members
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Class

[image]

A Sandcastle Documented Class Library
MasterDataException Class
Members See Also Send Feedback
MasterData Exception

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MasterDataException : BaseException
Visual Basic
<SerializableAttribute>
Public Class MasterDataException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MasterDataException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.MasterData..::..MasterDataException

See Also

MasterDataException Members
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Members

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Members
MasterDataException Class Constructors Methods Properties Events See Also Send Feedback

The MasterDataException type exposes the following members.

Constructors

 | Name | Description
Public method | MasterDataException()()()() | Initializes a new instance of the MasterDataException class.
Public method | MasterDataException(String) | Initializes a new instance of the MasterDataException class.
Public method | MasterDataException(String, Exception) | Initializes a new instance of the MasterDataException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Constructor

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Constructor
MasterDataException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MasterDataException()()()() | Initializes a new instance of the MasterDataException class.
Public method | MasterDataException(String) | Initializes a new instance of the MasterDataException class.
Public method | MasterDataException(String, Exception) | Initializes a new instance of the MasterDataException class.

See Also

MasterDataException Class
MasterDataException Members
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Constructor

[image]

A Sandcastle Documented Class Library
MasterDataException Constructor
MasterDataException Class See Also Send Feedback
Initializes a new instance of the MasterDataException class.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataException()
Visual Basic
Public Sub New
Visual C++
public:
MasterDataException()

See Also

MasterDataException Class
MasterDataException Members
MasterDataException Overload
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Constructor (String)

[image]

A Sandcastle Documented Class Library
MasterDataException Constructor (String)
MasterDataException Class See Also Send Feedback
Initializes a new instance of the MasterDataException class.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
MasterDataException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

MasterDataException Class
MasterDataException Members
MasterDataException Overload
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
MasterDataException Constructor (String, Exception)
MasterDataException Class See Also Send Feedback
Initializes a new instance of the MasterDataException class.

Namespace: CelloSaaS.ServiceContracts.MasterData
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
MasterDataException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

MasterDataException Class
MasterDataException Members
MasterDataException Overload
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Methods

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Methods
MasterDataException Class See Also Send Feedback

The MasterDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Properties

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Properties
MasterDataException Class See Also Send Feedback

The MasterDataException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterData Namespace


MasterDataException Events

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Events
MasterDataException Class See Also Send Feedback

The MasterDataException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterData Namespace


CelloSaaS.ServiceContracts.MasterDataManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.MasterDataManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | MasterDataException | This class inherits base exception and implements masterDataException
Public class | MasterDataReferenceException | This class inherits base exception and implements masterDataReferenceException

Interfaces

 | Interface | Description
Public interface | IMasterDataService<(Of <(<'T>)>)> | This interface has declaration of masterdata services.


IMasterDataService(T) Interface

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)> Interface
Members See Also Send Feedback
This interface has declaration of masterdata services.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IMasterDataService<T>
Visual Basic
Public Interface IMasterDataService(Of T)
Visual C++
generic<typename T>
public interface class IMasterDataService

Type Parameters

T

See Also

IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T) Members

[image] [image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)> Members
IMasterDataService<(Of <(<'T>)>)> Interface Methods See Also Send Feedback

The IMasterDataService<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CreateMasterDataDetails | Inserts the given masterData details and returns the Identifier.
Public method | DeleteMasterDataDetails | Deletes masterDataDetails for given masterDataEntity. Before do the delete operation,checks this record is being refered with softdelete property by using child relation configuration.
Public method | FetchMasterDataDetails | Fetchs master data details for given referenceId and masterdataname
Public method | FetchMasterDataList | Fetches list of masterData details for given masterDataName and tenantId. It returns dictionary collection with Identifier as key and masterdata details as value. If logged in user is Product admin, it returns common masterData details(which has null tenantId) and his tenant based masterdata details.
Public method | GetChildRelationData | Gets child relationdata for given masterDataname and tenantId. It takes child data relation info from config file. It returns both pickup list data and child data. Since it uses pickuplist service,you need "ViewPickupListValue" privilege to access this method.
Public method | UpdateMasterDataDetails | Updates masterData details for given entity. It updates properties and tenantId

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T) Methods

[image] [image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)> Methods
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback

The IMasterDataService<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | CreateMasterDataDetails | Inserts the given masterData details and returns the Identifier.
Public method | DeleteMasterDataDetails | Deletes masterDataDetails for given masterDataEntity. Before do the delete operation,checks this record is being refered with softdelete property by using child relation configuration.
Public method | FetchMasterDataDetails | Fetchs master data details for given referenceId and masterdataname
Public method | FetchMasterDataList | Fetches list of masterData details for given masterDataName and tenantId. It returns dictionary collection with Identifier as key and masterdata details as value. If logged in user is Product admin, it returns common masterData details(which has null tenantId) and his tenant based masterdata details.
Public method | GetChildRelationData | Gets child relationdata for given masterDataname and tenantId. It takes child data relation info from config file. It returns both pickup list data and child data. Since it uses pickuplist service,you need "ViewPickupListValue" privilege to access this method.
Public method | UpdateMasterDataDetails | Updates masterData details for given entity. It updates properties and tenantId

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T).CreateMasterDataDetails Method

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)>..::..CreateMasterDataDetails Method
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback
Inserts the given masterData details and returns the Identifier.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreateMasterDataDetails(
    T masterDataEntity
)
Visual Basic
Function CreateMasterDataDetails (
    masterDataEntity As T
) As String
Visual C++
String^ CreateMasterDataDetails(
    T masterDataEntity
)

Parameters

masterDataEntity
Type: T
MasterDataEntiy

Return Value

Type: String
Identifier

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T).DeleteMasterDataDetails Method

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)>..::..DeleteMasterDataDetails Method
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback
Deletes masterDataDetails for given masterDataEntity. Before do the delete operation,checks this record is being refered with softdelete property by using child relation configuration.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteMasterDataDetails(
    T masterDataEntity
)
Visual Basic
Sub DeleteMasterDataDetails (
    masterDataEntity As T
)
Visual C++
void DeleteMasterDataDetails(
    T masterDataEntity
)

Parameters

masterDataEntity
Type: T
MasterDataEntity

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T).FetchMasterDataDetails Method

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)>..::..FetchMasterDataDetails Method
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback
Fetchs master data details for given referenceId and masterdataname

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
T FetchMasterDataDetails(
    string masterDataName,
    string referenceId,
    T masterDataEntity
)
Visual Basic
Function FetchMasterDataDetails (
    masterDataName As String,
    referenceId As String,
    masterDataEntity As T
) As T
Visual C++
T FetchMasterDataDetails(
    String^ masterDataName,
    String^ referenceId,
    T masterDataEntity
)

Parameters

masterDataName
Type: System..::..String
MasterDataName
referenceId
Type: System..::..String
ReferenceId
masterDataEntity
Type: T
masterDataEntity

Return Value

Type: T
MasterDataEntity

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T).FetchMasterDataList Method

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)>..::..FetchMasterDataList Method
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback
Fetches list of masterData details for given masterDataName and tenantId. It returns dictionary collection with Identifier as key and masterdata details as value. If logged in user is Product admin, it returns common masterData details(which has null tenantId) and his tenant based masterdata details.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, T> FetchMasterDataList(
    string masterDataName,
    string tenantId,
    T masterDataEntity
)
Visual Basic
Function FetchMasterDataList (
    masterDataName As String,
    tenantId As String,
    masterDataEntity As T
) As Dictionary(Of String, T)
Visual C++
Dictionary<String^, T>^ FetchMasterDataList(
    String^ masterDataName,
    String^ tenantId,
    T masterDataEntity
)

Parameters

masterDataName
Type: System..::..String
MasterDataName
tenantId
Type: System..::..String
TenantId
masterDataEntity
Type: T
masterDataEntity

Return Value

Type: Dictionary<(Of <(<'String, T >)>)>
Dictionary of MasterDataEntity

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T).GetChildRelationData Method

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)>..::..GetChildRelationData Method
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback
Gets child relationdata for given masterDataname and tenantId. It takes child data relation info from config file. It returns both pickup list data and child data. Since it uses pickuplist service,you need "ViewPickupListValue" privilege to access this method.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ChildRelationData GetChildRelationData(
    string masterDataName,
    string tenantId
)
Visual Basic
Function GetChildRelationData (
    masterDataName As String,
    tenantId As String
) As ChildRelationData
Visual C++
ChildRelationData^ GetChildRelationData(
    String^ masterDataName,
    String^ tenantId
)

Parameters

masterDataName
Type: System..::..String
MasterDataName
tenantId
Type: System..::..String
TenantId

Return Value

Type: ChildRelationData
ChildRelationData

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


IMasterDataService(T).UpdateMasterDataDetails Method

[image]

A Sandcastle Documented Class Library
IMasterDataService<(Of <(<'T>)>)>..::..UpdateMasterDataDetails Method
IMasterDataService<(Of <(<'T>)>)> Interface See Also Send Feedback
Updates masterData details for given entity. It updates properties and tenantId

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateMasterDataDetails(
    T masterDataEntity
)
Visual Basic
Sub UpdateMasterDataDetails (
    masterDataEntity As T
)
Visual C++
void UpdateMasterDataDetails(
    T masterDataEntity
)

Parameters

masterDataEntity
Type: T
MasterDataEntity

See Also

IMasterDataService<(Of <(<'T>)>)> Interface
IMasterDataService<(Of <(<'T>)>)> Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Class

[image]

A Sandcastle Documented Class Library
MasterDataException Class
Members See Also Send Feedback
This class inherits base exception and implements masterDataException

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MasterDataException : BaseException
Visual Basic
<SerializableAttribute>
Public Class MasterDataException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MasterDataException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.MasterDataManagement..::..MasterDataException

See Also

MasterDataException Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Members

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Members
MasterDataException Class Constructors Methods Properties Events See Also Send Feedback

The MasterDataException type exposes the following members.

Constructors

 | Name | Description
Public method | MasterDataException()()()() | Initializes a new instance of the MasterDataException class.
Public method | MasterDataException(String, Exception) | Initializes a new instance of the MasterDataException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Constructor

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Constructor
MasterDataException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MasterDataException()()()() | Initializes a new instance of the MasterDataException class.
Public method | MasterDataException(String, Exception) | Initializes a new instance of the MasterDataException class.

See Also

MasterDataException Class
MasterDataException Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Constructor

[image]

A Sandcastle Documented Class Library
MasterDataException Constructor
MasterDataException Class See Also Send Feedback
Initializes a new instance of the MasterDataException class.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataException()
Visual Basic
Public Sub New
Visual C++
public:
MasterDataException()

See Also

MasterDataException Class
MasterDataException Members
MasterDataException Overload
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
MasterDataException Constructor (String, Exception)
MasterDataException Class See Also Send Feedback
Initializes a new instance of the MasterDataException class.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
MasterDataException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

MasterDataException Class
MasterDataException Members
MasterDataException Overload
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Methods

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Methods
MasterDataException Class See Also Send Feedback

The MasterDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Properties

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Properties
MasterDataException Class See Also Send Feedback

The MasterDataException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataException Events

[image] [image]

A Sandcastle Documented Class Library
MasterDataException Events
MasterDataException Class See Also Send Feedback

The MasterDataException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MasterDataException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Class

[image]

A Sandcastle Documented Class Library
MasterDataReferenceException Class
Members See Also Send Feedback
This class inherits base exception and implements masterDataReferenceException

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class MasterDataReferenceException : BaseException
Visual Basic
<SerializableAttribute>
Public Class MasterDataReferenceException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class MasterDataReferenceException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.MasterDataManagement..::..MasterDataReferenceException

See Also

MasterDataReferenceException Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Members

[image] [image]

A Sandcastle Documented Class Library
MasterDataReferenceException Members
MasterDataReferenceException Class Constructors Methods Properties Events See Also Send Feedback

The MasterDataReferenceException type exposes the following members.

Constructors

 | Name | Description
Public method | MasterDataReferenceException()()()() | Initializes a new instance of the MasterDataReferenceException class.
Public method | MasterDataReferenceException(String, Exception) | Initializes a new instance of the MasterDataReferenceException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MasterDataReferenceException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Constructor

[image] [image]

A Sandcastle Documented Class Library
MasterDataReferenceException Constructor
MasterDataReferenceException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MasterDataReferenceException()()()() | Initializes a new instance of the MasterDataReferenceException class.
Public method | MasterDataReferenceException(String, Exception) | Initializes a new instance of the MasterDataReferenceException class.

See Also

MasterDataReferenceException Class
MasterDataReferenceException Members
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Constructor

[image]

A Sandcastle Documented Class Library
MasterDataReferenceException Constructor
MasterDataReferenceException Class See Also Send Feedback
Initializes a new instance of the MasterDataReferenceException class.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataReferenceException()
Visual Basic
Public Sub New
Visual C++
public:
MasterDataReferenceException()

See Also

MasterDataReferenceException Class
MasterDataReferenceException Members
MasterDataReferenceException Overload
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
MasterDataReferenceException Constructor (String, Exception)
MasterDataReferenceException Class See Also Send Feedback
Initializes a new instance of the MasterDataReferenceException class.

Namespace: CelloSaaS.ServiceContracts.MasterDataManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MasterDataReferenceException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
MasterDataReferenceException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

MasterDataReferenceException Class
MasterDataReferenceException Members
MasterDataReferenceException Overload
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Methods

[image] [image]

A Sandcastle Documented Class Library
MasterDataReferenceException Methods
MasterDataReferenceException Class See Also Send Feedback

The MasterDataReferenceException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MasterDataReferenceException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Properties

[image] [image]

A Sandcastle Documented Class Library
MasterDataReferenceException Properties
MasterDataReferenceException Class See Also Send Feedback

The MasterDataReferenceException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MasterDataReferenceException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


MasterDataReferenceException Events

[image] [image]

A Sandcastle Documented Class Library
MasterDataReferenceException Events
MasterDataReferenceException Class See Also Send Feedback

The MasterDataReferenceException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

MasterDataReferenceException Class
CelloSaaS.ServiceContracts.MasterDataManagement Namespace


CelloSaaS.ServiceContracts.ProductAnalytics Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.ProductAnalytics Namespace
Send Feedback

Classes

 | Class | Description
Public class | ProductAnalyticsException | The ProductAnalyticsException class

Interfaces

 | Interface | Description
Public interface | IProductAnalyticsService | Product analytics service interface


IProductAnalyticsService Interface

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService Interface
Members See Also Send Feedback
Product analytics service interface

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IProductAnalyticsService
Visual Basic
Public Interface IProductAnalyticsService
Visual C++
public interface class IProductAnalyticsService

See Also

IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService Members

[image] [image]

A Sandcastle Documented Class Library
IProductAnalyticsService Members
IProductAnalyticsService Interface Methods See Also Send Feedback

The IProductAnalyticsService type exposes the following members.

Methods

 | Name | Description
Public method | AddProductAnalytics | Updates the product analytics.
Public method | Delete | Deletes the logs
Public method | GetCustomerNeedAttention | CustomerNeedAttention
Public method | GetHotTrials | GetHotTrials
Public method | GetProductAnalyticsLog | Gets the product analytics log.
Public method | GetTrialsNeedAttention | GetTrialNeedingAttention

See Also

IProductAnalyticsService Interface
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService Methods

[image] [image]

A Sandcastle Documented Class Library
IProductAnalyticsService Methods
IProductAnalyticsService Interface See Also Send Feedback

The IProductAnalyticsService type exposes the following members.

Methods

 | Name | Description
Public method | AddProductAnalytics | Updates the product analytics.
Public method | Delete | Deletes the logs
Public method | GetCustomerNeedAttention | CustomerNeedAttention
Public method | GetHotTrials | GetHotTrials
Public method | GetProductAnalyticsLog | Gets the product analytics log.
Public method | GetTrialsNeedAttention | GetTrialNeedingAttention

See Also

IProductAnalyticsService Interface
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService.AddProductAnalytics Method

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService..::..AddProductAnalytics Method
IProductAnalyticsService Interface See Also Send Feedback
Updates the product analytics.

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddProductAnalytics(
    ProductAnalytics productAnalytics
)
Visual Basic
Sub AddProductAnalytics (
    productAnalytics As ProductAnalytics
)
Visual C++
void AddProductAnalytics(
    ProductAnalytics^ productAnalytics
)

Parameters

productAnalytics
Type: CelloSaaS.Model.ProductAnalytics..::..ProductAnalytics
The product analytics.

See Also

IProductAnalyticsService Interface
IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService.Delete Method

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService..::..Delete Method
IProductAnalyticsService Interface See Also Send Feedback
Deletes the logs

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int Delete(
    string tenantId,
    string userId = null,
    Nullable<DateTime> FromDate = null,
    Nullable<DateTime> ToDate = null
)
Visual Basic
Function Delete (
    tenantId As String,
    Optional userId As String = Nothing,
    Optional FromDate As Nullable(Of DateTime) = Nothing,
    Optional ToDate As Nullable(Of DateTime) = Nothing
) As Integer
Visual C++
int Delete(
    String^ tenantId,
    String^ userId = nullptr,
    Nullable<DateTime> FromDate = nullptr,
    Nullable<DateTime> ToDate = nullptr
)

Parameters

tenantId
Type: System..::..String
The tenant id.
userId (Optional)
Type: System..::..String
The user id.
FromDate (Optional)
Type: System..::..Nullable<(Of <(<'DateTime>)>)>
From date.
ToDate (Optional)
Type: System..::..Nullable<(Of <(<'DateTime>)>)>
To date.

Return Value

Type: Int32

See Also

IProductAnalyticsService Interface
IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService.GetCustomerNeedAttention Method

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService..::..GetCustomerNeedAttention Method
IProductAnalyticsService Interface See Also Send Feedback
CustomerNeedAttention

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
HotTrialSearchResult GetCustomerNeedAttention(
    ProductAnalyticsTrialSearchCondition searchCondition
)
Visual Basic
Function GetCustomerNeedAttention (
    searchCondition As ProductAnalyticsTrialSearchCondition
) As HotTrialSearchResult
Visual C++
HotTrialSearchResult^ GetCustomerNeedAttention(
    ProductAnalyticsTrialSearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsTrialSearchCondition
The search condition.

Return Value

Type: HotTrialSearchResult

See Also

IProductAnalyticsService Interface
IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService.GetHotTrials Method

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService..::..GetHotTrials Method
IProductAnalyticsService Interface See Also Send Feedback
GetHotTrials

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
HotTrialSearchResult GetHotTrials(
    ProductAnalyticsTrialSearchCondition searchCondition
)
Visual Basic
Function GetHotTrials (
    searchCondition As ProductAnalyticsTrialSearchCondition
) As HotTrialSearchResult
Visual C++
HotTrialSearchResult^ GetHotTrials(
    ProductAnalyticsTrialSearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsTrialSearchCondition
The search condition.

Return Value

Type: HotTrialSearchResult

See Also

IProductAnalyticsService Interface
IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService.GetProductAnalyticsLog Method

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService..::..GetProductAnalyticsLog Method
IProductAnalyticsService Interface See Also Send Feedback
Gets the product analytics log.

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, ProductAnalytics> GetProductAnalyticsLog(
    ProductAnalyticsSearchCondition searchConditon
)
Visual Basic
Function GetProductAnalyticsLog (
    searchConditon As ProductAnalyticsSearchCondition
) As Dictionary(Of String, ProductAnalytics)
Visual C++
Dictionary<String^, ProductAnalytics^>^ GetProductAnalyticsLog(
    ProductAnalyticsSearchCondition^ searchConditon
)

Parameters

searchConditon
Type: CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsSearchCondition
The search conditon.

Return Value

Type: Dictionary<(Of <(<'String, ProductAnalytics >)>)>

See Also

IProductAnalyticsService Interface
IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


IProductAnalyticsService.GetTrialsNeedAttention Method

[image]

A Sandcastle Documented Class Library
IProductAnalyticsService..::..GetTrialsNeedAttention Method
IProductAnalyticsService Interface See Also Send Feedback
GetTrialNeedingAttention

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
HotTrialSearchResult GetTrialsNeedAttention(
    ProductAnalyticsTrialSearchCondition searchCondition
)
Visual Basic
Function GetTrialsNeedAttention (
    searchCondition As ProductAnalyticsTrialSearchCondition
) As HotTrialSearchResult
Visual C++
HotTrialSearchResult^ GetTrialsNeedAttention(
    ProductAnalyticsTrialSearchCondition^ searchCondition
)

Parameters

searchCondition
Type: CelloSaaS.Model.ProductAnalytics..::..ProductAnalyticsTrialSearchCondition
The search condition.

Return Value

Type: HotTrialSearchResult

See Also

IProductAnalyticsService Interface
IProductAnalyticsService Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Class

[image]

A Sandcastle Documented Class Library
ProductAnalyticsException Class
Members See Also Send Feedback
The ProductAnalyticsException class

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ProductAnalyticsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ProductAnalyticsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ProductAnalyticsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.ProductAnalytics..::..ProductAnalyticsException

See Also

ProductAnalyticsException Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Members

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsException Members
ProductAnalyticsException Class Constructors Methods Properties Events See Also Send Feedback

The ProductAnalyticsException type exposes the following members.

Constructors

 | Name | Description
Public method | ProductAnalyticsException(String) | Initializes a new instance of the ProductAnalyticsException class.
Public method | ProductAnalyticsException(String, Exception) | Initializes a new instance of the ProductAnalyticsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ProductAnalyticsException Class
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Constructor

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsException Constructor
ProductAnalyticsException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProductAnalyticsException(String) | Initializes a new instance of the ProductAnalyticsException class.
Public method | ProductAnalyticsException(String, Exception) | Initializes a new instance of the ProductAnalyticsException class.

See Also

ProductAnalyticsException Class
ProductAnalyticsException Members
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Constructor (String)

[image]

A Sandcastle Documented Class Library
ProductAnalyticsException Constructor (String)
ProductAnalyticsException Class See Also Send Feedback
Initializes a new instance of the ProductAnalyticsException class.

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ProductAnalyticsException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ProductAnalyticsException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

ProductAnalyticsException Class
ProductAnalyticsException Members
ProductAnalyticsException Overload
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ProductAnalyticsException Constructor (String, Exception)
ProductAnalyticsException Class See Also Send Feedback
Initializes a new instance of the ProductAnalyticsException class.

Namespace: CelloSaaS.ServiceContracts.ProductAnalytics
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ProductAnalyticsException(
    string message,
    Exception ex
)
Visual Basic
Public Sub New (
    message As String,
    ex As Exception
)
Visual C++
public:
ProductAnalyticsException(
    String^ message,
    Exception^ ex
)

Parameters

message
Type: System..::..String
The message.
ex
Type: System..::..Exception
The ex.

See Also

ProductAnalyticsException Class
ProductAnalyticsException Members
ProductAnalyticsException Overload
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Methods

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsException Methods
ProductAnalyticsException Class See Also Send Feedback

The ProductAnalyticsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProductAnalyticsException Class
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Properties

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsException Properties
ProductAnalyticsException Class See Also Send Feedback

The ProductAnalyticsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProductAnalyticsException Class
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


ProductAnalyticsException Events

[image] [image]

A Sandcastle Documented Class Library
ProductAnalyticsException Events
ProductAnalyticsException Class See Also Send Feedback

The ProductAnalyticsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ProductAnalyticsException Class
CelloSaaS.ServiceContracts.ProductAnalytics Namespace


CelloSaaS.ServiceContracts.Providers Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.Providers Namespace
Send Feedback

Classes

 | Class | Description
Public class | UserConnectionStringException | To handle the Invalid User Connectionstrings Obtained for tenant based user connection string.


UserConnectionStringException Class

[image]

A Sandcastle Documented Class Library
UserConnectionStringException Class
Members See Also Send Feedback
To handle the Invalid User Connectionstrings Obtained for tenant based user connection string.

Namespace: CelloSaaS.ServiceContracts.Providers
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class UserConnectionStringException : BaseException
Visual Basic
Public Class UserConnectionStringException
    Inherits BaseException
Visual C++
public ref class UserConnectionStringException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Providers..::..UserConnectionStringException

See Also

UserConnectionStringException Members
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Members

[image] [image]

A Sandcastle Documented Class Library
UserConnectionStringException Members
UserConnectionStringException Class Constructors Methods Properties Events See Also Send Feedback

The UserConnectionStringException type exposes the following members.

Constructors

 | Name | Description
Public method | UserConnectionStringException(String) | User ConnectionString Exception Constructor
Public method | UserConnectionStringException(String, Exception) | User ConnectionString Exception Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserConnectionStringException Class
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserConnectionStringException Constructor
UserConnectionStringException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserConnectionStringException(String) | User ConnectionString Exception Constructor
Public method | UserConnectionStringException(String, Exception) | User ConnectionString Exception Constructor

See Also

UserConnectionStringException Class
UserConnectionStringException Members
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserConnectionStringException Constructor (String)
UserConnectionStringException Class See Also Send Feedback
User ConnectionString Exception Constructor

Namespace: CelloSaaS.ServiceContracts.Providers
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserConnectionStringException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserConnectionStringException(
    String^ message
)

Parameters

message
Type: System..::..String
Detailed explanation of the exception message

See Also

UserConnectionStringException Class
UserConnectionStringException Members
UserConnectionStringException Overload
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
UserConnectionStringException Constructor (String, Exception)
UserConnectionStringException Class See Also Send Feedback
User ConnectionString Exception Constructor

Namespace: CelloSaaS.ServiceContracts.Providers
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserConnectionStringException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
UserConnectionStringException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
Detailed explanation of the exception message
innerException
Type: System..::..Exception
The innerexception for this exception

See Also

UserConnectionStringException Class
UserConnectionStringException Members
UserConnectionStringException Overload
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Methods

[image] [image]

A Sandcastle Documented Class Library
UserConnectionStringException Methods
UserConnectionStringException Class See Also Send Feedback

The UserConnectionStringException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserConnectionStringException Class
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Properties

[image] [image]

A Sandcastle Documented Class Library
UserConnectionStringException Properties
UserConnectionStringException Class See Also Send Feedback

The UserConnectionStringException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserConnectionStringException Class
CelloSaaS.ServiceContracts.Providers Namespace


UserConnectionStringException Events

[image] [image]

A Sandcastle Documented Class Library
UserConnectionStringException Events
UserConnectionStringException Class See Also Send Feedback

The UserConnectionStringException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserConnectionStringException Class
CelloSaaS.ServiceContracts.Providers Namespace


CelloSaaS.ServiceContracts.SettingsManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.SettingsManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | AttributeConstants | This class Represents the attribute constants.
Public class | AttributeSetConstants | This class Represents attribute set constants strings
Public class | DuplicateAttributeTemplateException | Duplicate attribute template exception
Public class | DuplicateTemplateName | Duplicate template Name exception
Public class | PackageSettingsException | Package Settings Exception
Public class | RoleSettingsException | Role Settings Exception
Public class | SettingsMetaDataException | Setting sMetaData Exception
Public class | SettingsTemplateException | Settings template exception class
Public class | TenantPasswordExpirySettingException | Tenant Password Expiry Setting Exception
Public class | TenantSettingsException | Tenant Settings Exception
Public class | UserSettingsException | UserSettings Exception

Interfaces

 | Interface | Description
Public interface | IPackageSettingsService | Package Settings Service Interface
Public interface | IRoleSettingsService | Role Settings Service Interface
Public interface | ISettingsMetaDataService | Settings Meata Data Service Interface
Public interface | ISettingsTemplateService | The Settings Template Service Interface
Public interface | ITenantClientValidatorSettingService | Tenant Client Validator Setting Service Interface
Public interface | ITenantPasswordExpirySettingService | TenantPassword Expiry Setting Service Interface
Public interface | ITenantSettingsService | Tenant Settings Service Interface
Public interface | ITenantUserDetailsConnectionStringService | Tenant UserDetails ConnectionString Service Interface
Public interface | IUserSettingsService | User Settings Service interface.


AttributeConstants Class

[image]

A Sandcastle Documented Class Library
AttributeConstants Class
Members See Also Send Feedback
This class Represents the attribute constants.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class AttributeConstants
Visual Basic
Public Class AttributeConstants
Visual C++
public ref class AttributeConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.SettingsManagement..::..AttributeConstants

See Also

AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants Members

[image] [image]

A Sandcastle Documented Class Library
AttributeConstants Members
AttributeConstants Class Constructors Methods Fields See Also Send Feedback

The AttributeConstants type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeConstants | Initializes a new instance of the AttributeConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ApplicationConnectionString | Tenant Application Connection String
AutoApprovalTenantCreation | Auto Approval Tenant Creation
CurrencyCulture | Tenant billing currency culture ietf tag name e.g: en, ja, in, eu
DateFormat | DateFormat constant
DisableProductAnalytics | Product Analytics Enable/Disable Constant
HomeRealm | Tenant Home Realm Uri used for federated sign on
JQueryDateFormat | Jquery dateformat constant
Language | Tenant UI culture ietf tag name e.g: en, ja, in, eu
Logo | Logo constant
MasterPage | Master page constant
MaxPasswordAnswerFailureCount | Max password failure count constant
MaxPasswordFailureCount | Max password answer failure count constant
ShareUsers | Linked By Other Tenant Users Constant
TenantAuthenticateSetting | Tenant authenticat setting constant
Theme | Theme constant
UserDetailsConnectionString | For setting the tenant specific user details connection string.
UserPasswordExpiration | To set the tenant specific user password expiry days.
WCFSharedKey | The WCF Secret Shared Key.

See Also

AttributeConstants Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants Constructor

[image]

A Sandcastle Documented Class Library
AttributeConstants Constructor
AttributeConstants Class See Also Send Feedback
Initializes a new instance of the AttributeConstants class

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AttributeConstants()
Visual Basic
Public Sub New
Visual C++
public:
AttributeConstants()

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
AttributeConstants Fields
AttributeConstants Class See Also Send Feedback

The AttributeConstants type exposes the following members.

Fields

Name | Description
ApplicationConnectionString | Tenant Application Connection String
AutoApprovalTenantCreation | Auto Approval Tenant Creation
CurrencyCulture | Tenant billing currency culture ietf tag name e.g: en, ja, in, eu
DateFormat | DateFormat constant
DisableProductAnalytics | Product Analytics Enable/Disable Constant
HomeRealm | Tenant Home Realm Uri used for federated sign on
JQueryDateFormat | Jquery dateformat constant
Language | Tenant UI culture ietf tag name e.g: en, ja, in, eu
Logo | Logo constant
MasterPage | Master page constant
MaxPasswordAnswerFailureCount | Max password failure count constant
MaxPasswordFailureCount | Max password answer failure count constant
ShareUsers | Linked By Other Tenant Users Constant
TenantAuthenticateSetting | Tenant authenticat setting constant
Theme | Theme constant
UserDetailsConnectionString | For setting the tenant specific user details connection string.
UserPasswordExpiration | To set the tenant specific user password expiry days.
WCFSharedKey | The WCF Secret Shared Key.

See Also

AttributeConstants Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.ApplicationConnectionString Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..ApplicationConnectionString Field
AttributeConstants Class See Also Send Feedback
Tenant Application Connection String

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ApplicationConnectionString
Visual Basic
Public Const ApplicationConnectionString As String
Visual C++
public:
literal String^ ApplicationConnectionString

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.AutoApprovalTenantCreation Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..AutoApprovalTenantCreation Field
AttributeConstants Class See Also Send Feedback
Auto Approval Tenant Creation

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AutoApprovalTenantCreation
Visual Basic
Public Const AutoApprovalTenantCreation As String
Visual C++
public:
literal String^ AutoApprovalTenantCreation

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.CurrencyCulture Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..CurrencyCulture Field
AttributeConstants Class See Also Send Feedback
Tenant billing currency culture ietf tag name e.g: en, ja, in, eu

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CurrencyCulture
Visual Basic
Public Const CurrencyCulture As String
Visual C++
public:
literal String^ CurrencyCulture

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.DateFormat Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..DateFormat Field
AttributeConstants Class See Also Send Feedback
DateFormat constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DateFormat
Visual Basic
Public Const DateFormat As String
Visual C++
public:
literal String^ DateFormat

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.DisableProductAnalytics Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..DisableProductAnalytics Field
AttributeConstants Class See Also Send Feedback
Product Analytics Enable/Disable Constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DisableProductAnalytics
Visual Basic
Public Const DisableProductAnalytics As String
Visual C++
public:
literal String^ DisableProductAnalytics

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.HomeRealm Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..HomeRealm Field
AttributeConstants Class See Also Send Feedback
Tenant Home Realm Uri used for federated sign on

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string HomeRealm
Visual Basic
Public Const HomeRealm As String
Visual C++
public:
literal String^ HomeRealm

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.JQueryDateFormat Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..JQueryDateFormat Field
AttributeConstants Class See Also Send Feedback
Jquery dateformat constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string JQueryDateFormat
Visual Basic
Public Const JQueryDateFormat As String
Visual C++
public:
literal String^ JQueryDateFormat

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.Language Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..Language Field
AttributeConstants Class See Also Send Feedback
Tenant UI culture ietf tag name e.g: en, ja, in, eu

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Language
Visual Basic
Public Const Language As String
Visual C++
public:
literal String^ Language

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.Logo Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..Logo Field
AttributeConstants Class See Also Send Feedback
Logo constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Logo
Visual Basic
Public Const Logo As String
Visual C++
public:
literal String^ Logo

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.MasterPage Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..MasterPage Field
AttributeConstants Class See Also Send Feedback
Master page constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string MasterPage
Visual Basic
Public Const MasterPage As String
Visual C++
public:
literal String^ MasterPage

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.MaxPasswordAnswerFailureCount Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..MaxPasswordAnswerFailureCount Field
AttributeConstants Class See Also Send Feedback
Max password failure count constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string MaxPasswordAnswerFailureCount
Visual Basic
Public Const MaxPasswordAnswerFailureCount As String
Visual C++
public:
literal String^ MaxPasswordAnswerFailureCount

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.MaxPasswordFailureCount Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..MaxPasswordFailureCount Field
AttributeConstants Class See Also Send Feedback
Max password answer failure count constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string MaxPasswordFailureCount
Visual Basic
Public Const MaxPasswordFailureCount As String
Visual C++
public:
literal String^ MaxPasswordFailureCount

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.ShareUsers Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..ShareUsers Field
AttributeConstants Class See Also Send Feedback
Linked By Other Tenant Users Constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ShareUsers
Visual Basic
Public Const ShareUsers As String
Visual C++
public:
literal String^ ShareUsers

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.TenantAuthenticateSetting Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..TenantAuthenticateSetting Field
AttributeConstants Class See Also Send Feedback
Tenant authenticat setting constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TenantAuthenticateSetting
Visual Basic
Public Const TenantAuthenticateSetting As String
Visual C++
public:
literal String^ TenantAuthenticateSetting

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.Theme Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..Theme Field
AttributeConstants Class See Also Send Feedback
Theme constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Theme
Visual Basic
Public Const Theme As String
Visual C++
public:
literal String^ Theme

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.UserDetailsConnectionString Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..UserDetailsConnectionString Field
AttributeConstants Class See Also Send Feedback
For setting the tenant specific user details connection string.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserDetailsConnectionString
Visual Basic
Public Const UserDetailsConnectionString As String
Visual C++
public:
literal String^ UserDetailsConnectionString

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.UserPasswordExpiration Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..UserPasswordExpiration Field
AttributeConstants Class See Also Send Feedback
To set the tenant specific user password expiry days.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string UserPasswordExpiration
Visual Basic
Public Const UserPasswordExpiration As String
Visual C++
public:
literal String^ UserPasswordExpiration

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants.WCFSharedKey Field

[image]

A Sandcastle Documented Class Library
AttributeConstants..::..WCFSharedKey Field
AttributeConstants Class See Also Send Feedback
The WCF Secret Shared Key.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WCFSharedKey
Visual Basic
Public Const WCFSharedKey As String
Visual C++
public:
literal String^ WCFSharedKey

Field Value

Type: String

See Also

AttributeConstants Class
AttributeConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeConstants Methods

[image] [image]

A Sandcastle Documented Class Library
AttributeConstants Methods
AttributeConstants Class See Also Send Feedback

The AttributeConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AttributeConstants Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants Class

[image]

A Sandcastle Documented Class Library
AttributeSetConstants Class
Members See Also Send Feedback
This class Represents attribute set constants strings

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class AttributeSetConstants
Visual Basic
Public Class AttributeSetConstants
Visual C++
public ref class AttributeSetConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.SettingsManagement..::..AttributeSetConstants

See Also

AttributeSetConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants Members

[image] [image]

A Sandcastle Documented Class Library
AttributeSetConstants Members
AttributeSetConstants Class Constructors Methods Fields See Also Send Feedback

The AttributeSetConstants type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeSetConstants | Initializes a new instance of the AttributeSetConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AuthenticateSetting | Authenticate setting attribute constant
ConnectionString | Connection string attribute constant
Locale | Locale attribute constant

See Also

AttributeSetConstants Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants Constructor

[image]

A Sandcastle Documented Class Library
AttributeSetConstants Constructor
AttributeSetConstants Class See Also Send Feedback
Initializes a new instance of the AttributeSetConstants class

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AttributeSetConstants()
Visual Basic
Public Sub New
Visual C++
public:
AttributeSetConstants()

See Also

AttributeSetConstants Class
AttributeSetConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants Fields

[image] [image]

A Sandcastle Documented Class Library
AttributeSetConstants Fields
AttributeSetConstants Class See Also Send Feedback

The AttributeSetConstants type exposes the following members.

Fields

Name | Description
AuthenticateSetting | Authenticate setting attribute constant
ConnectionString | Connection string attribute constant
Locale | Locale attribute constant

See Also

AttributeSetConstants Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants.AuthenticateSetting Field

[image]

A Sandcastle Documented Class Library
AttributeSetConstants..::..AuthenticateSetting Field
AttributeSetConstants Class See Also Send Feedback
Authenticate setting attribute constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AuthenticateSetting
Visual Basic
Public Const AuthenticateSetting As String
Visual C++
public:
literal String^ AuthenticateSetting

Field Value

Type: String

See Also

AttributeSetConstants Class
AttributeSetConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants.ConnectionString Field

[image]

A Sandcastle Documented Class Library
AttributeSetConstants..::..ConnectionString Field
AttributeSetConstants Class See Also Send Feedback
Connection string attribute constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ConnectionString
Visual Basic
Public Const ConnectionString As String
Visual C++
public:
literal String^ ConnectionString

Field Value

Type: String

See Also

AttributeSetConstants Class
AttributeSetConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants.Locale Field

[image]

A Sandcastle Documented Class Library
AttributeSetConstants..::..Locale Field
AttributeSetConstants Class See Also Send Feedback
Locale attribute constant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Locale
Visual Basic
Public Const Locale As String
Visual C++
public:
literal String^ Locale

Field Value

Type: String

See Also

AttributeSetConstants Class
AttributeSetConstants Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


AttributeSetConstants Methods

[image] [image]

A Sandcastle Documented Class Library
AttributeSetConstants Methods
AttributeSetConstants Class See Also Send Feedback

The AttributeSetConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AttributeSetConstants Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Class

[image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Class
Members See Also Send Feedback
Duplicate attribute template exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DuplicateAttributeTemplateException : BaseException
Visual Basic
Public Class DuplicateAttributeTemplateException
    Inherits BaseException
Visual C++
public ref class DuplicateAttributeTemplateException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..DuplicateAttributeTemplateException

See Also

DuplicateAttributeTemplateException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Members
DuplicateAttributeTemplateException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateAttributeTemplateException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateAttributeTemplateException(String) | Initializes a new instance of the SettingsTemplateException class.
Public method | DuplicateAttributeTemplateException(String, Exception) | Initializes a new instance of the SettingsTemplateException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateAttributeTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Constructor
DuplicateAttributeTemplateException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateAttributeTemplateException(String) | Initializes a new instance of the SettingsTemplateException class.
Public method | DuplicateAttributeTemplateException(String, Exception) | Initializes a new instance of the SettingsTemplateException class.

See Also

DuplicateAttributeTemplateException Class
DuplicateAttributeTemplateException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Constructor (String)
DuplicateAttributeTemplateException Class See Also Send Feedback
Initializes a new instance of the SettingsTemplateException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateAttributeTemplateException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateAttributeTemplateException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateAttributeTemplateException Class
DuplicateAttributeTemplateException Members
DuplicateAttributeTemplateException Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Constructor (String, Exception)
DuplicateAttributeTemplateException Class See Also Send Feedback
Initializes a new instance of the SettingsTemplateException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateAttributeTemplateException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateAttributeTemplateException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateAttributeTemplateException Class
DuplicateAttributeTemplateException Members
DuplicateAttributeTemplateException Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Methods
DuplicateAttributeTemplateException Class See Also Send Feedback

The DuplicateAttributeTemplateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateAttributeTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Properties
DuplicateAttributeTemplateException Class See Also Send Feedback

The DuplicateAttributeTemplateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateAttributeTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateAttributeTemplateException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateAttributeTemplateException Events
DuplicateAttributeTemplateException Class See Also Send Feedback

The DuplicateAttributeTemplateException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateAttributeTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Class

[image]

A Sandcastle Documented Class Library
DuplicateTemplateName Class
Members See Also Send Feedback
Duplicate template Name exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DuplicateTemplateName : BaseException
Visual Basic
Public Class DuplicateTemplateName
    Inherits BaseException
Visual C++
public ref class DuplicateTemplateName : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..DuplicateTemplateName

See Also

DuplicateTemplateName Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateName Members
DuplicateTemplateName Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateTemplateName type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateTemplateName(String) | Initializes a new instance of the SettingsTemplateException class.
Public method | DuplicateTemplateName(String, Exception) | Initializes a new instance of the SettingsTemplateException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTemplateName Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateName Constructor
DuplicateTemplateName Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateTemplateName(String) | Initializes a new instance of the SettingsTemplateException class.
Public method | DuplicateTemplateName(String, Exception) | Initializes a new instance of the SettingsTemplateException class.

See Also

DuplicateTemplateName Class
DuplicateTemplateName Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateTemplateName Constructor (String)
DuplicateTemplateName Class See Also Send Feedback
Initializes a new instance of the SettingsTemplateException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTemplateName(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateTemplateName(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateTemplateName Class
DuplicateTemplateName Members
DuplicateTemplateName Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateTemplateName Constructor (String, Exception)
DuplicateTemplateName Class See Also Send Feedback
Initializes a new instance of the SettingsTemplateException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTemplateName(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateTemplateName(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateTemplateName Class
DuplicateTemplateName Members
DuplicateTemplateName Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateName Methods
DuplicateTemplateName Class See Also Send Feedback

The DuplicateTemplateName type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateTemplateName Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateName Properties
DuplicateTemplateName Class See Also Send Feedback

The DuplicateTemplateName type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateTemplateName Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


DuplicateTemplateName Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateName Events
DuplicateTemplateName Class See Also Send Feedback

The DuplicateTemplateName type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTemplateName Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IPackageSettingsService Interface

[image]

A Sandcastle Documented Class Library
IPackageSettingsService Interface
Members See Also Send Feedback
Package Settings Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IPackageSettingsService
Visual Basic
Public Interface IPackageSettingsService
Visual C++
public interface class IPackageSettingsService

See Also

IPackageSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IPackageSettingsService Members

[image] [image]

A Sandcastle Documented Class Library
IPackageSettingsService Members
IPackageSettingsService Interface Methods See Also Send Feedback

The IPackageSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | GetPackageSettings | This method is used to get package setting details
Public method | PermanentDeletePackageSettings | This method is used to delete all package settings for given package.
Public method | UpdatePackageSettings | This method is used to Update package setting details. Check if package settings exist for a given package identifier and attribute set identifier. If so update else insert package setting details.

See Also

IPackageSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IPackageSettingsService Methods

[image] [image]

A Sandcastle Documented Class Library
IPackageSettingsService Methods
IPackageSettingsService Interface See Also Send Feedback

The IPackageSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | GetPackageSettings | This method is used to get package setting details
Public method | PermanentDeletePackageSettings | This method is used to delete all package settings for given package.
Public method | UpdatePackageSettings | This method is used to Update package setting details. Check if package settings exist for a given package identifier and attribute set identifier. If so update else insert package setting details.

See Also

IPackageSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IPackageSettingsService.GetPackageSettings Method

[image]

A Sandcastle Documented Class Library
IPackageSettingsService..::..GetPackageSettings Method
IPackageSettingsService Interface Example See Also Send Feedback
This method is used to get package setting details

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PackageSetting GetPackageSettings(
    string packageId
)
Visual Basic
Function GetPackageSettings (
    packageId As String
) As PackageSetting
Visual C++
PackageSetting^ GetPackageSettings(
    String^ packageId
)

Parameters

packageId
Type: System..::..String
Package Identifier(Mandatory)

Return Value

Type: PackageSetting
Package Setting details

Examples

Copy image Copy
public void GetPackageSettings()
{
string packageId = "711A41B2-EB93-DF11-8DEB-001EC9DAB123";
IPackageSettingsService packageSettingsService = (IPackageSettingsService)ServiceLocator.GetServiceImplementation(typeof(IPackageSettingsService));
PackageSetting packageSettings = packageSettingsService.GetPackageSettings(packageId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | The Permission to access View Package Settings is denied.
System..::..ArgumentNullException | Package ID is null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..PackageSettingsException | This will throw PackageSettingsException if any error occurs in get package settings

See Also

IPackageSettingsService Interface
IPackageSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IPackageSettingsService.PermanentDeletePackageSettings Method

[image]

A Sandcastle Documented Class Library
IPackageSettingsService..::..PermanentDeletePackageSettings Method
IPackageSettingsService Interface Example See Also Send Feedback
This method is used to delete all package settings for given package.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeletePackageSettings(
    string packageId
)
Visual Basic
Sub PermanentDeletePackageSettings (
    packageId As String
)
Visual C++
void PermanentDeletePackageSettings(
    String^ packageId
)

Parameters

packageId
Type: System..::..String
Package Identifier(Mandatory)

Examples

Copy image Copy
public void DeletePackageSettings()
{
    string packageId = "711A41B2-EB93-DF11-8DEB-001EC9DAB123";
    IPackageSettingsService packageSettingsService = (IPackageSettingsService)ServiceLocator.GetServiceImplementation(typeof(IPackageSettingsService));
    packageSettingsService.PermanentDeletePackageSettings(packageId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | The Permission to access Delete Package Settings is denied.
System..::..ArgumentException | Throws ArgumentException if any mandatory arguments null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..PackageSettingsException | This will throw PackageSettingsException if any error occurs in delete package settings permanently

See Also

IPackageSettingsService Interface
IPackageSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IPackageSettingsService.UpdatePackageSettings Method

[image]

A Sandcastle Documented Class Library
IPackageSettingsService..::..UpdatePackageSettings Method
IPackageSettingsService Interface Example See Also Send Feedback
This method is used to Update package setting details. Check if package settings exist for a given package identifier and attribute set identifier. If so update else insert package setting details.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdatePackageSettings(
    PackageSetting packageSetting
)
Visual Basic
Sub UpdatePackageSettings (
    packageSetting As PackageSetting
)
Visual C++
void UpdatePackageSettings(
    PackageSetting^ packageSetting
)

Parameters

packageSetting
Type: CelloSaaS.Model.SettingsManagement..::..PackageSetting
Package setting details(Mandatory - Attributes and Package Identifier)

Examples

Copy image Copy
 public void UpdatePackageSettings()
 {
    PackageSetting packageSetting = new PackageSetting();
    packageSetting.PackageId = "711A41B2-EB93-DF11-8DEB-001EC9DAB123";
    packageSetting.Setting = new Settings();
    packageSetting.Setting.Attributes = new Dictionary<string, string>();
    packageSetting.Setting.Attributes.Add(AttributeConstants.Theme, "CelloSkin");
    packageSetting.Setting.Attributes.Add(AttributeConstants.MasterPage, "sample.master");
    IPackageSettingsService packageSettingsService = (IPackageSettingsService)ServiceLocator.GetServiceImplementation(typeof(IPackageSettingsService));
    packageSettingsService.UpdatePackageSettings(packageSetting);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | The Permission to access Update Package Settings is denied.
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument property is null or empty.
System..::..ArgumentException | Throws ArgumentException if any mandatory arguments null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..PackageSettingsException | This will throw PackageSettingsException if any error occurs in update package settings

See Also

IPackageSettingsService Interface
IPackageSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IRoleSettingsService Interface

[image]

A Sandcastle Documented Class Library
IRoleSettingsService Interface
Members See Also Send Feedback
Role Settings Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IRoleSettingsService
Visual Basic
Public Interface IRoleSettingsService
Visual C++
public interface class IRoleSettingsService

See Also

IRoleSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IRoleSettingsService Members

[image] [image]

A Sandcastle Documented Class Library
IRoleSettingsService Members
IRoleSettingsService Interface Methods See Also Send Feedback

The IRoleSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | GetRoleSettings | This method is used to get role settings details for Role Identifier
Public method | PermanentDeleteRoleSettings | This method is used to delete all role settings for given role.
Public method | UpdateRoleSettings | This method is used to Update role setting details Check if role settings exist for a given role identifier and attribute set identifier. If so update else insert role setting details.

See Also

IRoleSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IRoleSettingsService Methods

[image] [image]

A Sandcastle Documented Class Library
IRoleSettingsService Methods
IRoleSettingsService Interface See Also Send Feedback

The IRoleSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | GetRoleSettings | This method is used to get role settings details for Role Identifier
Public method | PermanentDeleteRoleSettings | This method is used to delete all role settings for given role.
Public method | UpdateRoleSettings | This method is used to Update role setting details Check if role settings exist for a given role identifier and attribute set identifier. If so update else insert role setting details.

See Also

IRoleSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IRoleSettingsService.GetRoleSettings Method

[image]

A Sandcastle Documented Class Library
IRoleSettingsService..::..GetRoleSettings Method
IRoleSettingsService Interface Example See Also Send Feedback
This method is used to get role settings details for Role Identifier

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
RoleSetting GetRoleSettings(
    string roleId
)
Visual Basic
Function GetRoleSettings (
    roleId As String
) As RoleSetting
Visual C++
RoleSetting^ GetRoleSettings(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)

Return Value

Type: RoleSetting
Role Setting details

Examples

Copy image Copy
public void GetRoleSettings()
{
    string roleId = "GR$Tenant_Admin";
    IRoleSettingsService roleSettingsService = (IRoleSettingsService)ServiceLocator.GetServiceImplementation(typeof(IRoleSettingsService));
    RoleSetting roleSetting = roleSettingsService.GetRoleSettings(roleId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception if no access for get role settings
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument property is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..RoleSettingsException | Throws RoleSettingsException if any error occurs in Get role settings

See Also

IRoleSettingsService Interface
IRoleSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IRoleSettingsService.PermanentDeleteRoleSettings Method

[image]

A Sandcastle Documented Class Library
IRoleSettingsService..::..PermanentDeleteRoleSettings Method
IRoleSettingsService Interface Example See Also Send Feedback
This method is used to delete all role settings for given role.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteRoleSettings(
    string roleId
)
Visual Basic
Sub PermanentDeleteRoleSettings (
    roleId As String
)
Visual C++
void PermanentDeleteRoleSettings(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
Role Identifier(Mandatory)

Examples

Copy image Copy
public void PermanentDeleteRoleSettings()
{
    string roleId = "GR$Tenant_Admin";
    IRoleSettingsService roleSettingsService = (IRoleSettingsService)ServiceLocator.GetServiceImplementation(typeof(IRoleSettingsService));
    roleSettingsService.PermanentDeleteRoleSettings(roleId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception if no access for get role settings
System..::..ArgumentNullException | Throws ArgumentNullException if any required argument is null
CelloSaaS.ServiceContracts.SettingsManagement..::..RoleSettingsException | Throws RoleSettingsException if any error occurs while permanent delete role settings

See Also

IRoleSettingsService Interface
IRoleSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IRoleSettingsService.UpdateRoleSettings Method

[image]

A Sandcastle Documented Class Library
IRoleSettingsService..::..UpdateRoleSettings Method
IRoleSettingsService Interface Example See Also Send Feedback
This method is used to Update role setting details Check if role settings exist for a given role identifier and attribute set identifier. If so update else insert role setting details.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRoleSettings(
    RoleSetting roleSetting
)
Visual Basic
Sub UpdateRoleSettings (
    roleSetting As RoleSetting
)
Visual C++
void UpdateRoleSettings(
    RoleSetting^ roleSetting
)

Parameters

roleSetting
Type: CelloSaaS.Model.SettingsManagement..::..RoleSetting
Role setting details(Mandatory - Attributes and Role Identifier)

Examples

Copy image Copy
public void UpdateRoleSettings()
{
    RoleSetting roleSetting = new RoleSetting();
    roleSetting.RoleId = "GR$Tenant_Admin";
    roleSetting.Setting = new Settings();
    roleSetting.Setting.Attributes = new Dictionary<string, string>();
    roleSetting.Setting.Attributes.Add(AttributeConstants.Theme, "CelloSkin");
    roleSetting.Setting.Attributes.Add(AttributeConstants.MasterPage, "sample.master");
    IRoleSettingsService roleSettingsService = (IRoleSettingsService)ServiceLocator.GetServiceImplementation(typeof(IRoleSettingsService));
    roleSettingsService.UpdateRoleSettings(roleSetting);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception if no access for get role settings
System..::..ArgumentNullException | Throws ArgumentNullException if any required argument is null
System..::..ArgumentException | Throws ArgumentException if any required argument is null
CelloSaaS.ServiceContracts.SettingsManagement..::..RoleSettingsException | Throws RoleSettingsException if any error occurs while permanent delete role settings

See Also

IRoleSettingsService Interface
IRoleSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsMetaDataService Interface

[image]

A Sandcastle Documented Class Library
ISettingsMetaDataService Interface
Members See Also Send Feedback
Settings Meata Data Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ISettingsMetaDataService
Visual Basic
Public Interface ISettingsMetaDataService
Visual C++
public interface class ISettingsMetaDataService

See Also

ISettingsMetaDataService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsMetaDataService Members

[image] [image]

A Sandcastle Documented Class Library
ISettingsMetaDataService Members
ISettingsMetaDataService Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | GetSettingsMetaData()()()() | This method is used to get settings meta data details
Public method | GetSettingsMetaData(String) | This method is used to get settings meta data details for tenant code

See Also

ISettingsMetaDataService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsMetaDataService Methods

[image] [image]

A Sandcastle Documented Class Library
ISettingsMetaDataService Methods
ISettingsMetaDataService Interface See Also Send Feedback

Methods

 | Name | Description
Public method | GetSettingsMetaData()()()() | This method is used to get settings meta data details
Public method | GetSettingsMetaData(String) | This method is used to get settings meta data details for tenant code

See Also

ISettingsMetaDataService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsMetaDataService.GetSettingsMetaData Method

[image] [image]

A Sandcastle Documented Class Library
ISettingsMetaDataService..::..GetSettingsMetaData Method
ISettingsMetaDataService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSettingsMetaData()()()() | This method is used to get settings meta data details
Public method | GetSettingsMetaData(String) | This method is used to get settings meta data details for tenant code

See Also

ISettingsMetaDataService Interface
ISettingsMetaDataService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsMetaDataService.GetSettingsMetaData Method

[image]

A Sandcastle Documented Class Library
ISettingsMetaDataService..::..GetSettingsMetaData Method
ISettingsMetaDataService Interface Example See Also Send Feedback
This method is used to get settings meta data details

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
SettingsMetaData GetSettingsMetaData()
Visual Basic
Function GetSettingsMetaData As SettingsMetaData
Visual C++
SettingsMetaData^ GetSettingsMetaData()

Return Value

Type: SettingsMetaData
Settings meta data details

Examples

Copy image Copy
public void GetSettingsMetaData()
{
    ISettingsMetaDataService settingsMetaDataService = (ISettingsMetaDataService)ServiceLocator.GetServiceImplementation(typeof(ISettingsMetaDataService));
    SettingsMetaData settingsMetaData = settingsMetaDataService.GetSettingsMetaData();
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsMetaDataException | Throws exception while get settings meta data

See Also

ISettingsMetaDataService Interface
ISettingsMetaDataService Members
GetSettingsMetaData Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsMetaDataService.GetSettingsMetaData Method (String)

[image]

A Sandcastle Documented Class Library
ISettingsMetaDataService..::..GetSettingsMetaData Method (String)
ISettingsMetaDataService Interface Example See Also Send Feedback
This method is used to get settings meta data details for tenant code

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
SettingsMetaData GetSettingsMetaData(
    string tenantCode
)
Visual Basic
Function GetSettingsMetaData (
    tenantCode As String
) As SettingsMetaData
Visual C++
SettingsMetaData^ GetSettingsMetaData(
    String^ tenantCode
)

Parameters

tenantCode
Type: System..::..String
Tenant Code(Mandatory)

Return Value

Type: SettingsMetaData
Settings meta data details

Examples

Copy image Copy
public void GetSettingsMetaData()
{
    string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ISettingsMetaDataService settingsMetaDataService = (ISettingsMetaDataService)ServiceLocator.GetServiceImplementation(typeof(ISettingsMetaDataService));
    SettingsMetaData settingsMetaData = settingsMetaDataService.GetSettingsMetaData(tenantCode);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if tenant code is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsMetaDataException | Throws SettingsMetaDataException if any error occurs while get settings metadata

See Also

ISettingsMetaDataService Interface
ISettingsMetaDataService Members
GetSettingsMetaData Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService Interface

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService Interface
Members See Also Send Feedback
The Settings Template Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ISettingsTemplateService
Visual Basic
Public Interface ISettingsTemplateService
Visual C++
public interface class ISettingsTemplateService

See Also

ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService Members

[image] [image]

A Sandcastle Documented Class Library
ISettingsTemplateService Members
ISettingsTemplateService Interface Methods See Also Send Feedback

The ISettingsTemplateService type exposes the following members.

Methods

 | Name | Description
Public method | AddSettingsTemplate | This method is used to Add the settings template.
Public method | AddTenantSettingsTemplate | This method is used to Add the tenant settings template.
Public method | DeleteTenantSettingsTemplate | This method is used to Delete the tenant's settings template.
Public method | GetAssignableTemplateForTenant | This method is used to get the assignable template for tenant.
Public method | GetAssignableTemplateForTenantByOtherTenant | This method is used to get the assignable template for tenant by other tenant.
Public method | GetGlobalSettingsTemplates | This method is used to get the global settings templates.
Public method | GetSettingsTemplateDetails | This method is used to get the settings template details.
Public method | GetSettingsTemplateForTenants | This method is used to get all settings template for tenants.
Public method | GetSettingsTemplatesForTenant | This method is used to get all the settings templates for the tenant.
Public method | GetTenantSettingsTemplates | This method is used to get the tenant settings templates.
Public method | GetTenantTemplateDetails | This method is used to get the tenant template details.
Public method | GetTenantTemplatesDetailsByAttributeId | Gets the tenant templates details by attribute id.
Public method | UpdateSettingsTemplate | This method is used to Update the settings template.
Public method | UpdateTenantSettingsTemplate | This method is used to Update the tenant's settings template.

See Also

ISettingsTemplateService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService Methods

[image] [image]

A Sandcastle Documented Class Library
ISettingsTemplateService Methods
ISettingsTemplateService Interface See Also Send Feedback

The ISettingsTemplateService type exposes the following members.

Methods

 | Name | Description
Public method | AddSettingsTemplate | This method is used to Add the settings template.
Public method | AddTenantSettingsTemplate | This method is used to Add the tenant settings template.
Public method | DeleteTenantSettingsTemplate | This method is used to Delete the tenant's settings template.
Public method | GetAssignableTemplateForTenant | This method is used to get the assignable template for tenant.
Public method | GetAssignableTemplateForTenantByOtherTenant | This method is used to get the assignable template for tenant by other tenant.
Public method | GetGlobalSettingsTemplates | This method is used to get the global settings templates.
Public method | GetSettingsTemplateDetails | This method is used to get the settings template details.
Public method | GetSettingsTemplateForTenants | This method is used to get all settings template for tenants.
Public method | GetSettingsTemplatesForTenant | This method is used to get all the settings templates for the tenant.
Public method | GetTenantSettingsTemplates | This method is used to get the tenant settings templates.
Public method | GetTenantTemplateDetails | This method is used to get the tenant template details.
Public method | GetTenantTemplatesDetailsByAttributeId | Gets the tenant templates details by attribute id.
Public method | UpdateSettingsTemplate | This method is used to Update the settings template.
Public method | UpdateTenantSettingsTemplate | This method is used to Update the tenant's settings template.

See Also

ISettingsTemplateService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.AddSettingsTemplate Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..AddSettingsTemplate Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to Add the settings template.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddSettingsTemplate(
    SettingsTemplate settingsTemplate
)
Visual Basic
Function AddSettingsTemplate (
    settingsTemplate As SettingsTemplate
) As String
Visual C++
String^ AddSettingsTemplate(
    SettingsTemplate^ settingsTemplate
)

Parameters

settingsTemplate
Type: CelloSaaS.Model.SettingsManagement..::..SettingsTemplate
The settings template.(Mandatory)

Return Value

Type: String
Template Id

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..DuplicateTemplateName | Throws Exception as Template Name should be unique
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Throws Settings Template Exception

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.AddTenantSettingsTemplate Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..AddTenantSettingsTemplate Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to Add the tenant settings template.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddTenantSettingsTemplate(
    TenantSettingsTemplate tenantSettingsTemplate
)
Visual Basic
Function AddTenantSettingsTemplate (
    tenantSettingsTemplate As TenantSettingsTemplate
) As String
Visual C++
String^ AddTenantSettingsTemplate(
    TenantSettingsTemplate^ tenantSettingsTemplate
)

Parameters

tenantSettingsTemplate
Type: CelloSaaS.Model.SettingsManagement..::..TenantSettingsTemplate
The tenant settings template (Mandatory).

Return Value

Type: String
Tenant Template Id

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Throws Settings Template Exception while mapping tenant with template

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.DeleteTenantSettingsTemplate Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..DeleteTenantSettingsTemplate Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to Delete the tenant's settings template.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantSettingsTemplate(
    string tenantId,
    string templateId
)
Visual Basic
Sub DeleteTenantSettingsTemplate (
    tenantId As String,
    templateId As String
)
Visual C++
void DeleteTenantSettingsTemplate(
    String^ tenantId,
    String^ templateId
)

Parameters

tenantId
Type: System..::..String
The tenant id (Mandatory).
templateId
Type: System..::..String
The template id (Mandatory).

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Throws Settings Template Exception while delete tenant settings template

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetAssignableTemplateForTenant Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetAssignableTemplateForTenant Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get the assignable template for tenant.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, SettingsTemplate> GetAssignableTemplateForTenant(
    string tenantId
)
Visual Basic
Function GetAssignableTemplateForTenant (
    tenantId As String
) As Dictionary(Of String, SettingsTemplate)
Visual C++
Dictionary<String^, SettingsTemplate^>^ GetAssignableTemplateForTenant(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id (Mandatory).

Return Value

Type: Dictionary<(Of <(<'String, SettingsTemplate >)>)>
Dictionary of SettingsTemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while fetching assignable templates for tenant

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetAssignableTemplateForTenantByOtherTenant Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetAssignableTemplateForTenantByOtherTenant Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get the assignable template for tenant by other tenant.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, SettingsTemplate> GetAssignableTemplateForTenantByOtherTenant(
    string tenantId,
    string assigningTenantId
)
Visual Basic
Function GetAssignableTemplateForTenantByOtherTenant (
    tenantId As String,
    assigningTenantId As String
) As Dictionary(Of String, SettingsTemplate)
Visual C++
Dictionary<String^, SettingsTemplate^>^ GetAssignableTemplateForTenantByOtherTenant(
    String^ tenantId,
    String^ assigningTenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
assigningTenantId
Type: System..::..String
The assigning tenant id.

Return Value

Type: Dictionary<(Of <(<'String, SettingsTemplate >)>)>
Dictionary of SettingsTemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while fetching assignable templates for tenant

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetGlobalSettingsTemplates Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetGlobalSettingsTemplates Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get the global settings templates.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, SettingsTemplate> GetGlobalSettingsTemplates()
Visual Basic
Function GetGlobalSettingsTemplates As Dictionary(Of String, SettingsTemplate)
Visual C++
Dictionary<String^, SettingsTemplate^>^ GetGlobalSettingsTemplates()

Return Value

Type: Dictionary<(Of <(<'String, SettingsTemplate >)>)>
Dictionary of SettingsTemplate

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while get all settings template.

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetSettingsTemplateDetails Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetSettingsTemplateDetails Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get the settings template details.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
SettingsTemplate GetSettingsTemplateDetails(
    string templateId
)
Visual Basic
Function GetSettingsTemplateDetails (
    templateId As String
) As SettingsTemplate
Visual C++
SettingsTemplate^ GetSettingsTemplateDetails(
    String^ templateId
)

Parameters

templateId
Type: System..::..String
The template id (Mandatory).

Return Value

Type: SettingsTemplate
SettingsTemplate settingsTemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception if template Id is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Throws Settings Template Exception while get settings template details

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetSettingsTemplateForTenants Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetSettingsTemplateForTenants Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get all settings template for tenants.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, SettingsTemplate> GetSettingsTemplateForTenants(
    string[] tenantIds
)
Visual Basic
Function GetSettingsTemplateForTenants (
    tenantIds As String()
) As Dictionary(Of String, SettingsTemplate)
Visual C++
Dictionary<String^, SettingsTemplate^>^ GetSettingsTemplateForTenants(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Return Value

Type: Dictionary<(Of <(<'String, SettingsTemplate >)>)>
Dictionary of SettingsTemplate

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while get all settings template.

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetSettingsTemplatesForTenant Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetSettingsTemplatesForTenant Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get all the settings templates for the tenant.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, SettingsTemplate> GetSettingsTemplatesForTenant(
    string tenantId
)
Visual Basic
Function GetSettingsTemplatesForTenant (
    tenantId As String
) As Dictionary(Of String, SettingsTemplate)
Visual C++
Dictionary<String^, SettingsTemplate^>^ GetSettingsTemplatesForTenant(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, SettingsTemplate >)>)>
Dictionary of SettingsTemplate

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while get all settings template.

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetTenantSettingsTemplates Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetTenantSettingsTemplates Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get the tenant settings templates.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantSettingsTemplate> GetTenantSettingsTemplates(
    string tenantId
)
Visual Basic
Function GetTenantSettingsTemplates (
    tenantId As String
) As Dictionary(Of String, TenantSettingsTemplate)
Visual C++
Dictionary<String^, TenantSettingsTemplate^>^ GetTenantSettingsTemplates(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id (Mandatory).

Return Value

Type: Dictionary<(Of <(<'String, TenantSettingsTemplate >)>)>
Dictionary of TenantSettingsTemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while get tenant settings templates.

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetTenantTemplateDetails Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetTenantTemplateDetails Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to get the tenant template details.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantSettingsTemplate GetTenantTemplateDetails(
    string tenantId,
    string templateId
)
Visual Basic
Function GetTenantTemplateDetails (
    tenantId As String,
    templateId As String
) As TenantSettingsTemplate
Visual C++
TenantSettingsTemplate^ GetTenantTemplateDetails(
    String^ tenantId,
    String^ templateId
)

Parameters

tenantId
Type: System..::..String
The tenant id (Mandatory).
templateId
Type: System..::..String
The template id (Mandatory).

Return Value

Type: TenantSettingsTemplate
TenantSettingsTemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception if any argument is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Exception while getting tenant's template details

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.GetTenantTemplatesDetailsByAttributeId Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..GetTenantTemplatesDetailsByAttributeId Method
ISettingsTemplateService Interface See Also Send Feedback
Gets the tenant templates details by attribute id.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantSettingsTemplate> GetTenantTemplatesDetailsByAttributeId(
    string attributeId
)
Visual Basic
Function GetTenantTemplatesDetailsByAttributeId (
    attributeId As String
) As Dictionary(Of String, TenantSettingsTemplate)
Visual C++
Dictionary<String^, TenantSettingsTemplate^>^ GetTenantTemplatesDetailsByAttributeId(
    String^ attributeId
)

Parameters

attributeId
Type: System..::..String
The attribute id.

Return Value

Type: Dictionary<(Of <(<'String, TenantSettingsTemplate >)>)>
Dictionary of string and tenantsettingstemplate

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty attribute Id
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Incase of any exception while getting the templates by the attribute Id

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.UpdateSettingsTemplate Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..UpdateSettingsTemplate Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to Update the settings template.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateSettingsTemplate(
    SettingsTemplate settingsTemplate
)
Visual Basic
Sub UpdateSettingsTemplate (
    settingsTemplate As SettingsTemplate
)
Visual C++
void UpdateSettingsTemplate(
    SettingsTemplate^ settingsTemplate
)

Parameters

settingsTemplate
Type: CelloSaaS.Model.SettingsManagement..::..SettingsTemplate
The settings template (Mandatory).

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..DuplicateTemplateName | Template Name should be unique
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Throws Settings Template Exception while update settings template

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ISettingsTemplateService.UpdateTenantSettingsTemplate Method

[image]

A Sandcastle Documented Class Library
ISettingsTemplateService..::..UpdateTenantSettingsTemplate Method
ISettingsTemplateService Interface See Also Send Feedback
This method is used to Update the tenant's settings template.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateTenantSettingsTemplate(
    TenantSettingsTemplate tenantSettingsTemplate
)
Visual Basic
Sub UpdateTenantSettingsTemplate (
    tenantSettingsTemplate As TenantSettingsTemplate
)
Visual C++
void UpdateTenantSettingsTemplate(
    TenantSettingsTemplate^ tenantSettingsTemplate
)

Parameters

tenantSettingsTemplate
Type: CelloSaaS.Model.SettingsManagement..::..TenantSettingsTemplate
The tenant settings template (Mandatory).

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException | Throws Settings Template Exception while update tenant settings template

See Also

ISettingsTemplateService Interface
ISettingsTemplateService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantClientValidatorSettingService Interface

[image]

A Sandcastle Documented Class Library
ITenantClientValidatorSettingService Interface
Members See Also Send Feedback
Tenant Client Validator Setting Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantClientValidatorSettingService
Visual Basic
Public Interface ITenantClientValidatorSettingService
Visual C++
public interface class ITenantClientValidatorSettingService

See Also

ITenantClientValidatorSettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantClientValidatorSettingService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantClientValidatorSettingService Members
ITenantClientValidatorSettingService Interface Methods See Also Send Feedback

The ITenantClientValidatorSettingService type exposes the following members.

Methods

 | Name | Description
Public method | GetClientValidatorSecretKey | This method is used to get the client validator secret key.
Public method | GetDecrpytClientValidatorSecretKey | This method is used to get the decrpyt client validator secret key.
Public method | SaveClientValidatorSetting | This method id used to save the client validator setting.

See Also

ITenantClientValidatorSettingService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantClientValidatorSettingService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantClientValidatorSettingService Methods
ITenantClientValidatorSettingService Interface See Also Send Feedback

The ITenantClientValidatorSettingService type exposes the following members.

Methods

 | Name | Description
Public method | GetClientValidatorSecretKey | This method is used to get the client validator secret key.
Public method | GetDecrpytClientValidatorSecretKey | This method is used to get the decrpyt client validator secret key.
Public method | SaveClientValidatorSetting | This method id used to save the client validator setting.

See Also

ITenantClientValidatorSettingService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantClientValidatorSettingService.GetClientValidatorSecretKey Method

[image]

A Sandcastle Documented Class Library
ITenantClientValidatorSettingService..::..GetClientValidatorSecretKey Method
ITenantClientValidatorSettingService Interface See Also Send Feedback
This method is used to get the client validator secret key.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetClientValidatorSecretKey(
    string tenantId
)
Visual Basic
Function GetClientValidatorSecretKey (
    tenantId As String
) As String
Visual C++
String^ GetClientValidatorSecretKey(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
Returns the WCF Shared Key

See Also

ITenantClientValidatorSettingService Interface
ITenantClientValidatorSettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantClientValidatorSettingService.GetDecrpytClientValidatorSecretKey Method

[image]

A Sandcastle Documented Class Library
ITenantClientValidatorSettingService..::..GetDecrpytClientValidatorSecretKey Method
ITenantClientValidatorSettingService Interface See Also Send Feedback
This method is used to get the decrpyt client validator secret key.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetDecrpytClientValidatorSecretKey(
    string tenantId
)
Visual Basic
Function GetDecrpytClientValidatorSecretKey (
    tenantId As String
) As String
Visual C++
String^ GetDecrpytClientValidatorSecretKey(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
Returns the decrypted WCF Shared Key

See Also

ITenantClientValidatorSettingService Interface
ITenantClientValidatorSettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantClientValidatorSettingService.SaveClientValidatorSetting Method

[image]

A Sandcastle Documented Class Library
ITenantClientValidatorSettingService..::..SaveClientValidatorSetting Method
ITenantClientValidatorSettingService Interface See Also Send Feedback
This method id used to save the client validator setting.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveClientValidatorSetting(
    string secretKey,
    string tenantId
)
Visual Basic
Sub SaveClientValidatorSetting (
    secretKey As String,
    tenantId As String
)
Visual C++
void SaveClientValidatorSetting(
    String^ secretKey,
    String^ tenantId
)

Parameters

secretKey
Type: System..::..String
The secret key.
tenantId
Type: System..::..String
The tenant id.

See Also

ITenantClientValidatorSettingService Interface
ITenantClientValidatorSettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantPasswordExpirySettingService Interface

[image]

A Sandcastle Documented Class Library
ITenantPasswordExpirySettingService Interface
Members See Also Send Feedback
TenantPassword Expiry Setting Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantPasswordExpirySettingService
Visual Basic
Public Interface ITenantPasswordExpirySettingService
Visual C++
public interface class ITenantPasswordExpirySettingService

See Also

ITenantPasswordExpirySettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantPasswordExpirySettingService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantPasswordExpirySettingService Members
ITenantPasswordExpirySettingService Interface Methods See Also Send Feedback

The ITenantPasswordExpirySettingService type exposes the following members.

Methods

 | Name | Description
Public method | GetPasswordExpirationDays | This method is used to get the expiry days for the given tenantID.
Public method | SetupPasswordExpiry | This method is used to update the expiration days for a given tenant id along with the synchronization of the expiration date with the user password expiration date

See Also

ITenantPasswordExpirySettingService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantPasswordExpirySettingService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantPasswordExpirySettingService Methods
ITenantPasswordExpirySettingService Interface See Also Send Feedback

The ITenantPasswordExpirySettingService type exposes the following members.

Methods

 | Name | Description
Public method | GetPasswordExpirationDays | This method is used to get the expiry days for the given tenantID.
Public method | SetupPasswordExpiry | This method is used to update the expiration days for a given tenant id along with the synchronization of the expiration date with the user password expiration date

See Also

ITenantPasswordExpirySettingService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantPasswordExpirySettingService.GetPasswordExpirationDays Method

[image]

A Sandcastle Documented Class Library
ITenantPasswordExpirySettingService..::..GetPasswordExpirationDays Method
ITenantPasswordExpirySettingService Interface See Also Send Feedback
This method is used to get the expiry days for the given tenantID.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int GetPasswordExpirationDays(
    string tenantId
)
Visual Basic
Function GetPasswordExpirationDays (
    tenantId As String
) As Integer
Visual C++
int GetPasswordExpirationDays(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String

Return Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant ID is null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantPasswordExpirySettingException | Throws error while setup password expiry

See Also

ITenantPasswordExpirySettingService Interface
ITenantPasswordExpirySettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantPasswordExpirySettingService.SetupPasswordExpiry Method

[image]

A Sandcastle Documented Class Library
ITenantPasswordExpirySettingService..::..SetupPasswordExpiry Method
ITenantPasswordExpirySettingService Interface See Also Send Feedback
This method is used to update the expiration days for a given tenant id along with the synchronization of the expiration date with the user password expiration date

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool SetupPasswordExpiry(
    int expirationDays,
    string tenantId
)
Visual Basic
Function SetupPasswordExpiry (
    expirationDays As Integer,
    tenantId As String
) As Boolean
Visual C++
bool SetupPasswordExpiry(
    int expirationDays,
    String^ tenantId
)

Parameters

expirationDays
Type: System..::..Int32
New Expiration days in which the passwords will expire
tenantId
Type: System..::..String
Tenant ID

Return Value

Type: Boolean
true : if this operation succeeds false : if this operation fails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any argument is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantPasswordExpirySettingException | Error while setup password expiry

See Also

ITenantPasswordExpirySettingService Interface
ITenantPasswordExpirySettingService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService Interface

[image]

A Sandcastle Documented Class Library
ITenantSettingsService Interface
Members See Also Send Feedback
Tenant Settings Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantSettingsService
Visual Basic
Public Interface ITenantSettingsService
Visual C++
public interface class ITenantSettingsService

See Also

ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantSettingsService Members
ITenantSettingsService Interface Methods See Also Send Feedback

The ITenantSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteTenantSettingsByAttribute(String, String) | This method is used to delete tenant settings for given tenantId and attributeId.
Public method | DeleteTenantSettingsByAttribute(String, array<String>[]()[][]) | This method is used to delete tenant settings for given tenantId and attributeIds.
Public method | DeleteTenantSettingsByAttributeSet | This method is used to delete tenantSettings for given tenantId and attributeSetId.
Public method | GetAllTenantSettingByAttributeId | This method is used to get the dictionary of all tenant settings for all tenants based on the attribute Id.
Public method | GetAllTenantSettingsByAttributeIdAndValue | This method is used to get all tenant setting by attribute id.
Public method | GetTenantSettings(String) | This method is used to get settings of a tenant
Public method | GetTenantSettings(String, String) | This method is used to get TenantSettings for a given tenantId by a specific attribute set Id.
Public method | PermanentDeleteTenantSettings | This method is used to delete all tenant settings for given tenant Identifier
Public method | UpdateTenantSettings | This method is used to update the tenant settings for a tenant. Check if tenant settings exist for a given tenant identifier and attribute set identifier. If so update else insert tenant setting details.
Public method | ValidateConnectionString | This method is used to check the validity of the connection string via AJAX for the UserConnectionString

See Also

ITenantSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantSettingsService Methods
ITenantSettingsService Interface See Also Send Feedback

The ITenantSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteTenantSettingsByAttribute(String, String) | This method is used to delete tenant settings for given tenantId and attributeId.
Public method | DeleteTenantSettingsByAttribute(String, array<String>[]()[][]) | This method is used to delete tenant settings for given tenantId and attributeIds.
Public method | DeleteTenantSettingsByAttributeSet | This method is used to delete tenantSettings for given tenantId and attributeSetId.
Public method | GetAllTenantSettingByAttributeId | This method is used to get the dictionary of all tenant settings for all tenants based on the attribute Id.
Public method | GetAllTenantSettingsByAttributeIdAndValue | This method is used to get all tenant setting by attribute id.
Public method | GetTenantSettings(String) | This method is used to get settings of a tenant
Public method | GetTenantSettings(String, String) | This method is used to get TenantSettings for a given tenantId by a specific attribute set Id.
Public method | PermanentDeleteTenantSettings | This method is used to delete all tenant settings for given tenant Identifier
Public method | UpdateTenantSettings | This method is used to update the tenant settings for a tenant. Check if tenant settings exist for a given tenant identifier and attribute set identifier. If so update else insert tenant setting details.
Public method | ValidateConnectionString | This method is used to check the validity of the connection string via AJAX for the UserConnectionString

See Also

ITenantSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.DeleteTenantSettingsByAttribute Method

[image] [image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..DeleteTenantSettingsByAttribute Method
ITenantSettingsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteTenantSettingsByAttribute(String, String) | This method is used to delete tenant settings for given tenantId and attributeId.
Public method | DeleteTenantSettingsByAttribute(String, array<String>[]()[][]) | This method is used to delete tenant settings for given tenantId and attributeIds.

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.DeleteTenantSettingsByAttribute Method (String, String)

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..DeleteTenantSettingsByAttribute Method (String, String)
ITenantSettingsService Interface See Also Send Feedback
This method is used to delete tenant settings for given tenantId and attributeId.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantSettingsByAttribute(
    string tenantId,
    string attributeId
)
Visual Basic
Sub DeleteTenantSettingsByAttribute (
    tenantId As String,
    attributeId As String
)
Visual C++
void DeleteTenantSettingsByAttribute(
    String^ tenantId,
    String^ attributeId
)

Parameters

tenantId
Type: System..::..String
The Tenant identifier (Mandatory).
attributeId
Type: System..::..String
The attribute set identifier (Mandatory).

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant Id is null or empty.
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if don't have access to delete tenant settings
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs while Delete Tenant Settings by Attribute.

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
DeleteTenantSettingsByAttribute Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.DeleteTenantSettingsByAttribute Method (String, String[])

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..DeleteTenantSettingsByAttribute Method (String, array<String>[]()[][])
ITenantSettingsService Interface See Also Send Feedback
This method is used to delete tenant settings for given tenantId and attributeIds.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantSettingsByAttribute(
    string tenantId,
    string[] attributeIds
)
Visual Basic
Sub DeleteTenantSettingsByAttribute (
    tenantId As String,
    attributeIds As String()
)
Visual C++
void DeleteTenantSettingsByAttribute(
    String^ tenantId,
    array<String^>^ attributeIds
)

Parameters

tenantId
Type: System..::..String
The Tenant identifier.
attributeIds
Type: array<System..::..String>[]()[][]
Array of attribute set identifiers.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant Id is null or empty.
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if don't have access to delete tenant settings by attribute
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs in delete tenant settings by attribute

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
DeleteTenantSettingsByAttribute Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.DeleteTenantSettingsByAttributeSet Method

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..DeleteTenantSettingsByAttributeSet Method
ITenantSettingsService Interface See Also Send Feedback
This method is used to delete tenantSettings for given tenantId and attributeSetId.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantSettingsByAttributeSet(
    string tenantId,
    string attributeSetId
)
Visual Basic
Sub DeleteTenantSettingsByAttributeSet (
    tenantId As String,
    attributeSetId As String
)
Visual C++
void DeleteTenantSettingsByAttributeSet(
    String^ tenantId,
    String^ attributeSetId
)

Parameters

tenantId
Type: System..::..String
The Tenant identifier.
attributeSetId
Type: System..::..String
The attribute set identifier.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant Id is null or empty.
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if don't have access to delete tenant settings
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs while Delete Tenant Settings by AttributeSet.

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.GetAllTenantSettingByAttributeId Method

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..GetAllTenantSettingByAttributeId Method
ITenantSettingsService Interface See Also Send Feedback
This method is used to get the dictionary of all tenant settings for all tenants based on the attribute Id.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantSetting> GetAllTenantSettingByAttributeId(
    string attributeId
)
Visual Basic
Function GetAllTenantSettingByAttributeId (
    attributeId As String
) As Dictionary(Of String, TenantSetting)
Visual C++
Dictionary<String^, TenantSetting^>^ GetAllTenantSettingByAttributeId(
    String^ attributeId
)

Parameters

attributeId
Type: System..::..String
attribute Id

Return Value

Type: Dictionary<(Of <(<'String, TenantSetting >)>)>
Dictionary of tenantId and Tenant Setting

Exceptions

Exception | Condition
System..::..ArgumentNullException | Attribute Id cannot be null or empty
CelloSaaS.ServiceContracts.Providers..::..UserConnectionStringException | The Connection String is Invalid

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.GetAllTenantSettingsByAttributeIdAndValue Method

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..GetAllTenantSettingsByAttributeIdAndValue Method
ITenantSettingsService Interface See Also Send Feedback
This method is used to get all tenant setting by attribute id.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantSetting> GetAllTenantSettingsByAttributeIdAndValue(
    string attributeId,
    string attributeValue
)
Visual Basic
Function GetAllTenantSettingsByAttributeIdAndValue (
    attributeId As String,
    attributeValue As String
) As Dictionary(Of String, TenantSetting)
Visual C++
Dictionary<String^, TenantSetting^>^ GetAllTenantSettingsByAttributeIdAndValue(
    String^ attributeId,
    String^ attributeValue
)

Parameters

attributeId
Type: System..::..String
The attribute id.
attributeValue
Type: System..::..String
The attribute value.

Return Value

Type: Dictionary<(Of <(<'String, TenantSetting >)>)>
Dictionary of Tenant Setting for the matched tenant Setting Attribute Id and value

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs in this method

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.GetTenantSettings Method

[image] [image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..GetTenantSettings Method
ITenantSettingsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantSettings(String) | This method is used to get settings of a tenant
Public method | GetTenantSettings(String, String) | This method is used to get TenantSettings for a given tenantId by a specific attribute set Id.

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.GetTenantSettings Method (String)

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..GetTenantSettings Method (String)
ITenantSettingsService Interface Example See Also Send Feedback
This method is used to get settings of a tenant

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantSetting GetTenantSettings(
    string tenantId
)
Visual Basic
Function GetTenantSettings (
    tenantId As String
) As TenantSetting
Visual C++
TenantSetting^ GetTenantSettings(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: TenantSetting
Tenant Setting details

Examples

Copy image Copy
public void GetTenantSettings()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ITenantSettingsService tenantSettingsService = (ITenantSettingsService)ServiceLocator.GetServiceImplementation(typeof(ITenantSettingsService));
    TenantSetting tenantSettings = tenantSettingsService.GetTenantSettings(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant ID is null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException while get tenant settings

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
GetTenantSettings Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.GetTenantSettings Method (String, String)

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..GetTenantSettings Method (String, String)
ITenantSettingsService Interface Example See Also Send Feedback
This method is used to get TenantSettings for a given tenantId by a specific attribute set Id.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantSetting GetTenantSettings(
    string tenantId,
    string attributeSetId
)
Visual Basic
Function GetTenantSettings (
    tenantId As String,
    attributeSetId As String
) As TenantSetting
Visual C++
TenantSetting^ GetTenantSettings(
    String^ tenantId,
    String^ attributeSetId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)
attributeSetId
Type: System..::..String
Attribute set identifier

Return Value

Type: TenantSetting
Tenant Settings Details

Examples

Copy image Copy
public void GetTenantSettings()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string attributeSetId = "C971B848-2164-4CB7-93C3-3B37DD15535E";
    ITenantSettingsService tenantSettingsService = (ITenantSettingsService)ServiceLocator.GetServiceImplementation(typeof(ITenantSettingsService));
    TenantSetting tenantSettings = tenantSettingsService.GetTenantSettings(tenantId, attributeSetId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..UserSettingsException | Throws UserSettingsException if any error occurs while Get Tenant settings

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
GetTenantSettings Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.PermanentDeleteTenantSettings Method

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..PermanentDeleteTenantSettings Method
ITenantSettingsService Interface Example See Also Send Feedback
This method is used to delete all tenant settings for given tenant Identifier

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteTenantSettings(
    string tenantId
)
Visual Basic
Sub PermanentDeleteTenantSettings (
    tenantId As String
)
Visual C++
void PermanentDeleteTenantSettings(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Examples

Copy image Copy
public void PermanentDeleteTenantSettings()
{
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    ITenantSettingsService tenantSettingsService = (ITenantSettingsService)ServiceLocator.GetServiceImplementation(typeof(ITenantSettingsService));
    tenantSettingsService.PermanentDeleteTenantSettings(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant Id is null or empty.
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if don't have access to Permanent Delete Tenant Settings
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs while Permanent Delete Tenant Settings

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.UpdateTenantSettings Method

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..UpdateTenantSettings Method
ITenantSettingsService Interface Example See Also Send Feedback
This method is used to update the tenant settings for a tenant. Check if tenant settings exist for a given tenant identifier and attribute set identifier. If so update else insert tenant setting details.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateTenantSettings(
    TenantSetting tenantSetting
)
Visual Basic
Sub UpdateTenantSettings (
    tenantSetting As TenantSetting
)
Visual C++
void UpdateTenantSettings(
    TenantSetting^ tenantSetting
)

Parameters

tenantSetting
Type: CelloSaaS.Model.SettingsManagement..::..TenantSetting
Tenant Settings (Mandatory - Attributes , Tenant Identifier)

Examples

Copy image Copy
public void UpdateTenantSettings()
{
    TenantSetting tenantSetting = new TenantSetting();
    tenantSetting.TenantID = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    tenantSetting.Setting = new Settings();
    tenantSetting.Setting.Attributes = new Dictionary<string, string>();
    tenantSetting.Setting.Attributes.Add(AttributeConstants.Theme, "CelloSkin");
    tenantSetting.Setting.Attributes.Add(AttributeConstants.MasterPage, "sample.master");
    tenantSetting.Setting.Attributes.Add(AttributeConstants.Logo, "Company_Logo.jpg");
    ITenantSettingsService tenantSettingsService = (ITenantSettingsService)ServiceLocator.GetServiceImplementation(typeof(ITenantSettingsService));
    tenantSettingsService.UpdateTenantSettings(tenantSetting);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any required argument is null or empty
System..::..ArgumentException | Throws ArgumentException if any required argument is null or empty
System..::..UnauthorizedAccessException | Throws UnauthorizedAccessException if don't have access to update tenant settings
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs while update tenant settings

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantSettingsService.ValidateConnectionString Method

[image]

A Sandcastle Documented Class Library
ITenantSettingsService..::..ValidateConnectionString Method
ITenantSettingsService Interface See Also Send Feedback
This method is used to check the validity of the connection string via AJAX for the UserConnectionString

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateConnectionString(
    string connectionString,
    string provider
)
Visual Basic
Function ValidateConnectionString (
    connectionString As String,
    provider As String
) As Boolean
Visual C++
bool ValidateConnectionString(
    String^ connectionString,
    String^ provider
)

Parameters

connectionString
Type: System..::..String
UserConnectionString
provider
Type: System..::..String
DataProvider

Return Value

Type: Boolean
true : if the connection string is valid false : if the connection string is invalid

Exceptions

Exception | Condition
System..::..ArgumentNullException | The UserConnectionString / provider cannot be null or Empty.
CelloSaaS.ServiceContracts.Providers..::..UserConnectionStringException | The Connection String is Invalid

See Also

ITenantSettingsService Interface
ITenantSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantUserDetailsConnectionStringService Interface

[image]

A Sandcastle Documented Class Library
ITenantUserDetailsConnectionStringService Interface
Members See Also Send Feedback
Tenant UserDetails ConnectionString Service Interface

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantUserDetailsConnectionStringService
Visual Basic
Public Interface ITenantUserDetailsConnectionStringService
Visual C++
public interface class ITenantUserDetailsConnectionStringService

See Also

ITenantUserDetailsConnectionStringService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantUserDetailsConnectionStringService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantUserDetailsConnectionStringService Members
ITenantUserDetailsConnectionStringService Interface Methods See Also Send Feedback

The ITenantUserDetailsConnectionStringService type exposes the following members.

Methods

 | Name | Description
Public method | GetUserDetailsConnectionString | This method is used to get the user details connection string for the given tenantID
Public method | IsUserDetailsConnectionStringSet | This method is used to check whether the given tenant Id has the user details connection strings

See Also

ITenantUserDetailsConnectionStringService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantUserDetailsConnectionStringService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantUserDetailsConnectionStringService Methods
ITenantUserDetailsConnectionStringService Interface See Also Send Feedback

The ITenantUserDetailsConnectionStringService type exposes the following members.

Methods

 | Name | Description
Public method | GetUserDetailsConnectionString | This method is used to get the user details connection string for the given tenantID
Public method | IsUserDetailsConnectionStringSet | This method is used to check whether the given tenant Id has the user details connection strings

See Also

ITenantUserDetailsConnectionStringService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantUserDetailsConnectionStringService.GetUserDetailsConnectionString Method

[image]

A Sandcastle Documented Class Library
ITenantUserDetailsConnectionStringService..::..GetUserDetailsConnectionString Method
ITenantUserDetailsConnectionStringService Interface See Also Send Feedback
This method is used to get the user details connection string for the given tenantID

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetUserDetailsConnectionString(
    string tenantId
)
Visual Basic
Function GetUserDetailsConnectionString (
    tenantId As String
) As String
Visual C++
String^ GetUserDetailsConnectionString(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant Id to get the expiry days

Return Value

Type: String
The user details connection string

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant ID is null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs in Get user details connection string

See Also

ITenantUserDetailsConnectionStringService Interface
ITenantUserDetailsConnectionStringService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


ITenantUserDetailsConnectionStringService.IsUserDetailsConnectionStringSet Method

[image]

A Sandcastle Documented Class Library
ITenantUserDetailsConnectionStringService..::..IsUserDetailsConnectionStringSet Method
ITenantUserDetailsConnectionStringService Interface See Also Send Feedback
This method is used to check whether the given tenant Id has the user details connection strings

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool IsUserDetailsConnectionStringSet(
    string tenantId
)
Visual Basic
Function IsUserDetailsConnectionStringSet (
    tenantId As String
) As Boolean
Visual C++
bool IsUserDetailsConnectionStringSet(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant id (Mandatory)

Return Value

Type: Boolean
true : if the tenant has a user details connection string false : if the tenant does not have a user details connection string

Exceptions

Exception | Condition
System..::..ArgumentNullException | Tenant ID is null or empty.
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs in Get user details connection string

See Also

ITenantUserDetailsConnectionStringService Interface
ITenantUserDetailsConnectionStringService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService Interface

[image]

A Sandcastle Documented Class Library
IUserSettingsService Interface
Members See Also Send Feedback
User Settings Service interface.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IUserSettingsService
Visual Basic
Public Interface IUserSettingsService
Visual C++
public interface class IUserSettingsService

See Also

IUserSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService Members

[image] [image]

A Sandcastle Documented Class Library
IUserSettingsService Members
IUserSettingsService Interface Methods See Also Send Feedback

The IUserSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | GetUserSettings(String) | This method is used to get all UserSettings for a given user Identifier.
Public method | GetUserSettings(String, String) | This method is used to get UserSettings for a given userId by a specific attribute set Id.
Public method | PermananentDeleteUserSetting | This method is used to delete all user settings for a given userId.
Public method | UpdateUserSettings | This method is used to insert/update UserSettings for a given User. Check if user settings exist for a given user and attribute set id. If so update else insert.

See Also

IUserSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService Methods

[image] [image]

A Sandcastle Documented Class Library
IUserSettingsService Methods
IUserSettingsService Interface See Also Send Feedback

The IUserSettingsService type exposes the following members.

Methods

 | Name | Description
Public method | GetUserSettings(String) | This method is used to get all UserSettings for a given user Identifier.
Public method | GetUserSettings(String, String) | This method is used to get UserSettings for a given userId by a specific attribute set Id.
Public method | PermananentDeleteUserSetting | This method is used to delete all user settings for a given userId.
Public method | UpdateUserSettings | This method is used to insert/update UserSettings for a given User. Check if user settings exist for a given user and attribute set id. If so update else insert.

See Also

IUserSettingsService Interface
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService.GetUserSettings Method

[image] [image]

A Sandcastle Documented Class Library
IUserSettingsService..::..GetUserSettings Method
IUserSettingsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUserSettings(String) | This method is used to get all UserSettings for a given user Identifier.
Public method | GetUserSettings(String, String) | This method is used to get UserSettings for a given userId by a specific attribute set Id.

See Also

IUserSettingsService Interface
IUserSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService.GetUserSettings Method (String)

[image]

A Sandcastle Documented Class Library
IUserSettingsService..::..GetUserSettings Method (String)
IUserSettingsService Interface See Also Send Feedback
This method is used to get all UserSettings for a given user Identifier.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserSettings GetUserSettings(
    string userId
)
Visual Basic
Function GetUserSettings (
    userId As String
) As UserSettings
Visual C++
UserSettings^ GetUserSettings(
    String^ userId
)

Parameters

userId
Type: System..::..String
User Identifier(Mandatory)

Return Value

Type: UserSettings
The User Settings details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if userId is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..UserSettingsException | Throws UserSettingsException if any error occurs while get user settings

See Also

IUserSettingsService Interface
IUserSettingsService Members
GetUserSettings Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService.GetUserSettings Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserSettingsService..::..GetUserSettings Method (String, String)
IUserSettingsService Interface See Also Send Feedback
This method is used to get UserSettings for a given userId by a specific attribute set Id.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserSettings GetUserSettings(
    string userId,
    string attributeSetId
)
Visual Basic
Function GetUserSettings (
    userId As String,
    attributeSetId As String
) As UserSettings
Visual C++
UserSettings^ GetUserSettings(
    String^ userId,
    String^ attributeSetId
)

Parameters

userId
Type: System..::..String
User Identifier (Mandatory)
attributeSetId
Type: System..::..String
Attribute Set Identifier

Return Value

Type: UserSettings
The User Settings

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if userId is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..UserSettingsException | Throws UserSettingsException if any error occurs while get user settings

See Also

IUserSettingsService Interface
IUserSettingsService Members
GetUserSettings Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService.PermananentDeleteUserSetting Method

[image]

A Sandcastle Documented Class Library
IUserSettingsService..::..PermananentDeleteUserSetting Method
IUserSettingsService Interface See Also Send Feedback
This method is used to delete all user settings for a given userId.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermananentDeleteUserSetting(
    string userId
)
Visual Basic
Sub PermananentDeleteUserSetting (
    userId As String
)
Visual C++
void PermananentDeleteUserSetting(
    String^ userId
)

Parameters

userId
Type: System..::..String
The User Identifier (Mandatory)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if userId is null or empty
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException | Throws TenantSettingsException if any error occurs while permanent delete user settings

See Also

IUserSettingsService Interface
IUserSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


IUserSettingsService.UpdateUserSettings Method

[image]

A Sandcastle Documented Class Library
IUserSettingsService..::..UpdateUserSettings Method
IUserSettingsService Interface See Also Send Feedback
This method is used to insert/update UserSettings for a given User. Check if user settings exist for a given user and attribute set id. If so update else insert.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserSettings(
    UserSettings userSettings
)
Visual Basic
Sub UpdateUserSettings (
    userSettings As UserSettings
)
Visual C++
void UpdateUserSettings(
    UserSettings^ userSettings
)

Parameters

userSettings
Type: CelloSaaS.Model.SettingsManagement..::..UserSettings
The User Settings

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if userSettings is null
System..::..ArgumentException | Throws ArgumentException
CelloSaaS.ServiceContracts.SettingsManagement..::..UserSettingsException | Throws UserSettingsException if any error occurs while update user settings

See Also

IUserSettingsService Interface
IUserSettingsService Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


PackageSettingsException Class

[image]

A Sandcastle Documented Class Library
PackageSettingsException Class
Members See Also Send Feedback
Package Settings Exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PackageSettingsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class PackageSettingsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class PackageSettingsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..PackageSettingsException

See Also

PackageSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


PackageSettingsException Members

[image] [image]

A Sandcastle Documented Class Library
PackageSettingsException Members
PackageSettingsException Class Constructors Methods Properties Events See Also Send Feedback

The PackageSettingsException type exposes the following members.

Constructors

 | Name | Description
Public method | PackageSettingsException | Initializes a new instance of the PackageSettingsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PackageSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


PackageSettingsException Constructor

[image]

A Sandcastle Documented Class Library
PackageSettingsException Constructor
PackageSettingsException Class See Also Send Feedback
Initializes a new instance of the PackageSettingsException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PackageSettingsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
PackageSettingsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

PackageSettingsException Class
PackageSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


PackageSettingsException Methods

[image] [image]

A Sandcastle Documented Class Library
PackageSettingsException Methods
PackageSettingsException Class See Also Send Feedback

The PackageSettingsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PackageSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


PackageSettingsException Properties

[image] [image]

A Sandcastle Documented Class Library
PackageSettingsException Properties
PackageSettingsException Class See Also Send Feedback

The PackageSettingsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PackageSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


PackageSettingsException Events

[image] [image]

A Sandcastle Documented Class Library
PackageSettingsException Events
PackageSettingsException Class See Also Send Feedback

The PackageSettingsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

PackageSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


RoleSettingsException Class

[image]

A Sandcastle Documented Class Library
RoleSettingsException Class
Members See Also Send Feedback
Role Settings Exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoleSettingsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class RoleSettingsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class RoleSettingsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..RoleSettingsException

See Also

RoleSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


RoleSettingsException Members

[image] [image]

A Sandcastle Documented Class Library
RoleSettingsException Members
RoleSettingsException Class Constructors Methods Properties Events See Also Send Feedback

The RoleSettingsException type exposes the following members.

Constructors

 | Name | Description
Public method | RoleSettingsException | Initializes a new instance of the RoleSettingsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RoleSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


RoleSettingsException Constructor

[image]

A Sandcastle Documented Class Library
RoleSettingsException Constructor
RoleSettingsException Class See Also Send Feedback
Initializes a new instance of the RoleSettingsException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleSettingsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
RoleSettingsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

RoleSettingsException Class
RoleSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


RoleSettingsException Methods

[image] [image]

A Sandcastle Documented Class Library
RoleSettingsException Methods
RoleSettingsException Class See Also Send Feedback

The RoleSettingsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RoleSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


RoleSettingsException Properties

[image] [image]

A Sandcastle Documented Class Library
RoleSettingsException Properties
RoleSettingsException Class See Also Send Feedback

The RoleSettingsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RoleSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


RoleSettingsException Events

[image] [image]

A Sandcastle Documented Class Library
RoleSettingsException Events
RoleSettingsException Class See Also Send Feedback

The RoleSettingsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

RoleSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsMetaDataException Class

[image]

A Sandcastle Documented Class Library
SettingsMetaDataException Class
Members See Also Send Feedback
Setting sMetaData Exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SettingsMetaDataException : BaseException
Visual Basic
<SerializableAttribute>
Public Class SettingsMetaDataException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class SettingsMetaDataException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsMetaDataException

See Also

SettingsMetaDataException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsMetaDataException Members

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaDataException Members
SettingsMetaDataException Class Constructors Methods Properties Events See Also Send Feedback

The SettingsMetaDataException type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsMetaDataException | Initializes a new instance of the SettingsMetaDataException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SettingsMetaDataException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsMetaDataException Constructor

[image]

A Sandcastle Documented Class Library
SettingsMetaDataException Constructor
SettingsMetaDataException Class See Also Send Feedback
Initializes a new instance of the SettingsMetaDataException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsMetaDataException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
SettingsMetaDataException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

SettingsMetaDataException Class
SettingsMetaDataException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsMetaDataException Methods

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaDataException Methods
SettingsMetaDataException Class See Also Send Feedback

The SettingsMetaDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SettingsMetaDataException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsMetaDataException Properties

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaDataException Properties
SettingsMetaDataException Class See Also Send Feedback

The SettingsMetaDataException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SettingsMetaDataException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsMetaDataException Events

[image] [image]

A Sandcastle Documented Class Library
SettingsMetaDataException Events
SettingsMetaDataException Class See Also Send Feedback

The SettingsMetaDataException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SettingsMetaDataException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Class

[image]

A Sandcastle Documented Class Library
SettingsTemplateException Class
Members See Also Send Feedback
Settings template exception class

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class SettingsTemplateException : BaseException
Visual Basic
Public Class SettingsTemplateException
    Inherits BaseException
Visual C++
public ref class SettingsTemplateException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..SettingsTemplateException

See Also

SettingsTemplateException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Members

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateException Members
SettingsTemplateException Class Constructors Methods Properties Events See Also Send Feedback

The SettingsTemplateException type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsTemplateException(String) | Initializes a new instance of the SettingsTemplateException class.
Public method | SettingsTemplateException(String, Exception) | Initializes a new instance of the SettingsTemplateException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SettingsTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Constructor

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateException Constructor
SettingsTemplateException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SettingsTemplateException(String) | Initializes a new instance of the SettingsTemplateException class.
Public method | SettingsTemplateException(String, Exception) | Initializes a new instance of the SettingsTemplateException class.

See Also

SettingsTemplateException Class
SettingsTemplateException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Constructor (String)

[image]

A Sandcastle Documented Class Library
SettingsTemplateException Constructor (String)
SettingsTemplateException Class See Also Send Feedback
Initializes a new instance of the SettingsTemplateException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsTemplateException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
SettingsTemplateException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

SettingsTemplateException Class
SettingsTemplateException Members
SettingsTemplateException Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
SettingsTemplateException Constructor (String, Exception)
SettingsTemplateException Class See Also Send Feedback
Initializes a new instance of the SettingsTemplateException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SettingsTemplateException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
SettingsTemplateException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

SettingsTemplateException Class
SettingsTemplateException Members
SettingsTemplateException Overload
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Methods

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateException Methods
SettingsTemplateException Class See Also Send Feedback

The SettingsTemplateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SettingsTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Properties

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateException Properties
SettingsTemplateException Class See Also Send Feedback

The SettingsTemplateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SettingsTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


SettingsTemplateException Events

[image] [image]

A Sandcastle Documented Class Library
SettingsTemplateException Events
SettingsTemplateException Class See Also Send Feedback

The SettingsTemplateException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SettingsTemplateException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantPasswordExpirySettingException Class

[image]

A Sandcastle Documented Class Library
TenantPasswordExpirySettingException Class
Members See Also Send Feedback
Tenant Password Expiry Setting Exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantPasswordExpirySettingException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantPasswordExpirySettingException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantPasswordExpirySettingException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantPasswordExpirySettingException

See Also

TenantPasswordExpirySettingException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantPasswordExpirySettingException Members

[image] [image]

A Sandcastle Documented Class Library
TenantPasswordExpirySettingException Members
TenantPasswordExpirySettingException Class Constructors Methods Properties Events See Also Send Feedback

The TenantPasswordExpirySettingException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantPasswordExpirySettingException | Initializes a new instance of the TenantPasswordExpirySettingException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantPasswordExpirySettingException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantPasswordExpirySettingException Constructor

[image]

A Sandcastle Documented Class Library
TenantPasswordExpirySettingException Constructor
TenantPasswordExpirySettingException Class See Also Send Feedback
Initializes a new instance of the TenantPasswordExpirySettingException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantPasswordExpirySettingException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantPasswordExpirySettingException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantPasswordExpirySettingException Class
TenantPasswordExpirySettingException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantPasswordExpirySettingException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantPasswordExpirySettingException Methods
TenantPasswordExpirySettingException Class See Also Send Feedback

The TenantPasswordExpirySettingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantPasswordExpirySettingException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantPasswordExpirySettingException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantPasswordExpirySettingException Properties
TenantPasswordExpirySettingException Class See Also Send Feedback

The TenantPasswordExpirySettingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantPasswordExpirySettingException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantPasswordExpirySettingException Events

[image] [image]

A Sandcastle Documented Class Library
TenantPasswordExpirySettingException Events
TenantPasswordExpirySettingException Class See Also Send Feedback

The TenantPasswordExpirySettingException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantPasswordExpirySettingException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantSettingsException Class

[image]

A Sandcastle Documented Class Library
TenantSettingsException Class
Members See Also Send Feedback
Tenant Settings Exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantSettingsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantSettingsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantSettingsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..TenantSettingsException

See Also

TenantSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantSettingsException Members

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsException Members
TenantSettingsException Class Constructors Methods Properties Events See Also Send Feedback

The TenantSettingsException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantSettingsException | Initializes a new instance of the TenantSettingsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantSettingsException Constructor

[image]

A Sandcastle Documented Class Library
TenantSettingsException Constructor
TenantSettingsException Class See Also Send Feedback
Initializes a new instance of the TenantSettingsException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantSettingsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantSettingsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantSettingsException Class
TenantSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantSettingsException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsException Methods
TenantSettingsException Class See Also Send Feedback

The TenantSettingsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantSettingsException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsException Properties
TenantSettingsException Class See Also Send Feedback

The TenantSettingsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


TenantSettingsException Events

[image] [image]

A Sandcastle Documented Class Library
TenantSettingsException Events
TenantSettingsException Class See Also Send Feedback

The TenantSettingsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


UserSettingsException Class

[image]

A Sandcastle Documented Class Library
UserSettingsException Class
Members See Also Send Feedback
UserSettings Exception

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserSettingsException : BaseException
Visual Basic
<SerializableAttribute>
Public Class UserSettingsException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class UserSettingsException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.SettingsManagement..::..UserSettingsException

See Also

UserSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


UserSettingsException Members

[image] [image]

A Sandcastle Documented Class Library
UserSettingsException Members
UserSettingsException Class Constructors Methods Properties Events See Also Send Feedback

The UserSettingsException type exposes the following members.

Constructors

 | Name | Description
Public method | UserSettingsException | Initializes a new instance of the UserSettingsException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


UserSettingsException Constructor

[image]

A Sandcastle Documented Class Library
UserSettingsException Constructor
UserSettingsException Class See Also Send Feedback
Initializes a new instance of the UserSettingsException class.

Namespace: CelloSaaS.ServiceContracts.SettingsManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserSettingsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
UserSettingsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

UserSettingsException Class
UserSettingsException Members
CelloSaaS.ServiceContracts.SettingsManagement Namespace


UserSettingsException Methods

[image] [image]

A Sandcastle Documented Class Library
UserSettingsException Methods
UserSettingsException Class See Also Send Feedback

The UserSettingsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


UserSettingsException Properties

[image] [image]

A Sandcastle Documented Class Library
UserSettingsException Properties
UserSettingsException Class See Also Send Feedback

The UserSettingsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


UserSettingsException Events

[image] [image]

A Sandcastle Documented Class Library
UserSettingsException Events
UserSettingsException Class See Also Send Feedback

The UserSettingsException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserSettingsException Class
CelloSaaS.ServiceContracts.SettingsManagement Namespace


CelloSaaS.ServiceContracts.TenantManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.TenantManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | DuplicateTenantCodeException | Duplicate TenantCode Exception
Public class | DuplicateTenantNameException | Duplicate TenantName Exception
Public class | DuplicateTenantRelationException | Duplicate TenantRelation Exception
Public class | DuplicateURLException | Duplicate URL Exception
Public class | DuplicateWebsiteException | Duplicate Website Exception
Public class | InvalidActivationKeyException | Invalid ActivationKey Exception class
Public class | InvalidEmailException | Invalid Email Exception
Public class | InvalidTenantCodeException | Invalid TenantCode Exception
Public class | InvalidURLException | Invalid URL Exception
Public class | InvalidWebsiteException | Invalid Website Exception
Public class | TenantActivationException | Tenant Activation Exception class
Public class | TenantActivationKeyExpiredException | Tenant ActivationKey Expired Exception class
Public class | TenantException | Tenant Exception class
Public class | TenantRelationException | Tenant Relation Exception class
Public class | TenantTypesException | Tenant Types Exception class

Interfaces

 | Interface | Description
Public interface | ITenantRelationService | Tenant Relation Service Interface
Public interface | ITenantService | Tenant Service Interface
Public interface | ITenantTypesService | Interface for tenant types service


DuplicateTenantCodeException Class

[image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Class
Members See Also Send Feedback
Duplicate TenantCode Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateTenantCodeException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateTenantCodeException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateTenantCodeException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException

See Also

DuplicateTenantCodeException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Members
DuplicateTenantCodeException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateTenantCodeException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateTenantCodeException()()()() | Initializes a new instance of the DuplicateTenantCodeException class.
Public method | DuplicateTenantCodeException(String) | Initializes a new instance of the DuplicateTenantCodeException class.
Protected method | DuplicateTenantCodeException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTenantCodeException class.
Public method | DuplicateTenantCodeException(String, Exception) | Initializes a new instance of the DuplicateTenantCodeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Constructor
DuplicateTenantCodeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateTenantCodeException()()()() | Initializes a new instance of the DuplicateTenantCodeException class.
Public method | DuplicateTenantCodeException(String) | Initializes a new instance of the DuplicateTenantCodeException class.
Protected method | DuplicateTenantCodeException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTenantCodeException class.
Public method | DuplicateTenantCodeException(String, Exception) | Initializes a new instance of the DuplicateTenantCodeException class.

See Also

DuplicateTenantCodeException Class
DuplicateTenantCodeException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Constructor
DuplicateTenantCodeException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantCodeException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateTenantCodeException()

See Also

DuplicateTenantCodeException Class
DuplicateTenantCodeException Members
DuplicateTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Constructor (String)
DuplicateTenantCodeException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantCodeException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateTenantCodeException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateTenantCodeException Class
DuplicateTenantCodeException Members
DuplicateTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Constructor (SerializationInfo, StreamingContext)
DuplicateTenantCodeException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateTenantCodeException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
DuplicateTenantCodeException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

DuplicateTenantCodeException Class
DuplicateTenantCodeException Members
DuplicateTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Constructor (String, Exception)
DuplicateTenantCodeException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantCodeException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateTenantCodeException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateTenantCodeException Class
DuplicateTenantCodeException Members
DuplicateTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Methods
DuplicateTenantCodeException Class See Also Send Feedback

The DuplicateTenantCodeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Properties
DuplicateTenantCodeException Class See Also Send Feedback

The DuplicateTenantCodeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantCodeException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantCodeException Events
DuplicateTenantCodeException Class See Also Send Feedback

The DuplicateTenantCodeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Class
Members See Also Send Feedback
Duplicate TenantName Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateTenantNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateTenantNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateTenantNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException

See Also

DuplicateTenantNameException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Members
DuplicateTenantNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateTenantNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateTenantNameException()()()() | Initializes a new instance of the DuplicateTenantNameException class.
Public method | DuplicateTenantNameException(String) | Initializes a new instance of the DuplicateTenantNameException class.
Protected method | DuplicateTenantNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTenantNameException class.
Public method | DuplicateTenantNameException(String, Exception) | Initializes a new instance of the DuplicateTenantNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTenantNameException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Constructor
DuplicateTenantNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateTenantNameException()()()() | Initializes a new instance of the DuplicateTenantNameException class.
Public method | DuplicateTenantNameException(String) | Initializes a new instance of the DuplicateTenantNameException class.
Protected method | DuplicateTenantNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTenantNameException class.
Public method | DuplicateTenantNameException(String, Exception) | Initializes a new instance of the DuplicateTenantNameException class.

See Also

DuplicateTenantNameException Class
DuplicateTenantNameException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Constructor
DuplicateTenantNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantNameException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateTenantNameException()

See Also

DuplicateTenantNameException Class
DuplicateTenantNameException Members
DuplicateTenantNameException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Constructor (String)
DuplicateTenantNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantNameException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateTenantNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateTenantNameException Class
DuplicateTenantNameException Members
DuplicateTenantNameException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Constructor (SerializationInfo, StreamingContext)
DuplicateTenantNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantNameException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateTenantNameException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
DuplicateTenantNameException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

DuplicateTenantNameException Class
DuplicateTenantNameException Members
DuplicateTenantNameException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Constructor (String, Exception)
DuplicateTenantNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantNameException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantNameException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateTenantNameException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateTenantNameException Class
DuplicateTenantNameException Members
DuplicateTenantNameException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Methods
DuplicateTenantNameException Class See Also Send Feedback

The DuplicateTenantNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateTenantNameException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Properties
DuplicateTenantNameException Class See Also Send Feedback

The DuplicateTenantNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateTenantNameException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantNameException Events
DuplicateTenantNameException Class See Also Send Feedback

The DuplicateTenantNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTenantNameException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Class

[image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Class
Members See Also Send Feedback
Duplicate TenantRelation Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateTenantRelationException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateTenantRelationException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateTenantRelationException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantRelationException

See Also

DuplicateTenantRelationException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Members
DuplicateTenantRelationException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateTenantRelationException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateTenantRelationException()()()() | Initializes a new instance of the DuplicateTenantRelationException class.
Public method | DuplicateTenantRelationException(String) | Initializes a new instance of the DuplicateTenantRelationException class.
Protected method | DuplicateTenantRelationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTenantRelationException class.
Public method | DuplicateTenantRelationException(String, Exception) | Initializes a new instance of the DuplicateTenantRelationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Constructor
DuplicateTenantRelationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateTenantRelationException()()()() | Initializes a new instance of the DuplicateTenantRelationException class.
Public method | DuplicateTenantRelationException(String) | Initializes a new instance of the DuplicateTenantRelationException class.
Protected method | DuplicateTenantRelationException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTenantRelationException class.
Public method | DuplicateTenantRelationException(String, Exception) | Initializes a new instance of the DuplicateTenantRelationException class.

See Also

DuplicateTenantRelationException Class
DuplicateTenantRelationException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Constructor
DuplicateTenantRelationException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantRelationException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateTenantRelationException()

See Also

DuplicateTenantRelationException Class
DuplicateTenantRelationException Members
DuplicateTenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Constructor (String)
DuplicateTenantRelationException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantRelationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateTenantRelationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateTenantRelationException Class
DuplicateTenantRelationException Members
DuplicateTenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Constructor (SerializationInfo, StreamingContext)
DuplicateTenantRelationException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateTenantRelationException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
DuplicateTenantRelationException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

DuplicateTenantRelationException Class
DuplicateTenantRelationException Members
DuplicateTenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Constructor (String, Exception)
DuplicateTenantRelationException Class See Also Send Feedback
Initializes a new instance of the DuplicateTenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTenantRelationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateTenantRelationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateTenantRelationException Class
DuplicateTenantRelationException Members
DuplicateTenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Methods
DuplicateTenantRelationException Class See Also Send Feedback

The DuplicateTenantRelationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateTenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Properties
DuplicateTenantRelationException Class See Also Send Feedback

The DuplicateTenantRelationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateTenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateTenantRelationException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateTenantRelationException Events
DuplicateTenantRelationException Class See Also Send Feedback

The DuplicateTenantRelationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Class

[image]

A Sandcastle Documented Class Library
DuplicateURLException Class
Members See Also Send Feedback
Duplicate URL Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateURLException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateURLException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateURLException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException

See Also

DuplicateURLException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateURLException Members
DuplicateURLException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateURLException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateURLException()()()() | Initializes a new instance of the DuplicateURLException class.
Public method | DuplicateURLException(String) | Initializes a new instance of the DuplicateURLException class.
Protected method | DuplicateURLException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateURLException class.
Public method | DuplicateURLException(String, Exception) | Initializes a new instance of the DuplicateURLException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateURLException Constructor
DuplicateURLException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateURLException()()()() | Initializes a new instance of the DuplicateURLException class.
Public method | DuplicateURLException(String) | Initializes a new instance of the DuplicateURLException class.
Protected method | DuplicateURLException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateURLException class.
Public method | DuplicateURLException(String, Exception) | Initializes a new instance of the DuplicateURLException class.

See Also

DuplicateURLException Class
DuplicateURLException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateURLException Constructor
DuplicateURLException Class See Also Send Feedback
Initializes a new instance of the DuplicateURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateURLException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateURLException()

See Also

DuplicateURLException Class
DuplicateURLException Members
DuplicateURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateURLException Constructor (String)
DuplicateURLException Class See Also Send Feedback
Initializes a new instance of the DuplicateURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateURLException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateURLException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateURLException Class
DuplicateURLException Members
DuplicateURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateURLException Constructor (SerializationInfo, StreamingContext)
DuplicateURLException Class See Also Send Feedback
Initializes a new instance of the DuplicateURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateURLException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
DuplicateURLException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

DuplicateURLException Class
DuplicateURLException Members
DuplicateURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateURLException Constructor (String, Exception)
DuplicateURLException Class See Also Send Feedback
Initializes a new instance of the DuplicateURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateURLException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateURLException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateURLException Class
DuplicateURLException Members
DuplicateURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateURLException Methods
DuplicateURLException Class See Also Send Feedback

The DuplicateURLException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateURLException Properties
DuplicateURLException Class See Also Send Feedback

The DuplicateURLException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateURLException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateURLException Events
DuplicateURLException Class See Also Send Feedback

The DuplicateURLException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Class

[image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Class
Members See Also Send Feedback
Duplicate Website Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateWebsiteException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateWebsiteException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateWebsiteException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException

See Also

DuplicateWebsiteException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Members
DuplicateWebsiteException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateWebsiteException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateWebsiteException()()()() | Initializes a new instance of the DuplicateWebsiteException class.
Public method | DuplicateWebsiteException(String) | Initializes a new instance of the DuplicateWebsiteException class.
Protected method | DuplicateWebsiteException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateWebsiteException class.
Public method | DuplicateWebsiteException(String, Exception) | Initializes a new instance of the DuplicateWebsiteException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Constructor
DuplicateWebsiteException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateWebsiteException()()()() | Initializes a new instance of the DuplicateWebsiteException class.
Public method | DuplicateWebsiteException(String) | Initializes a new instance of the DuplicateWebsiteException class.
Protected method | DuplicateWebsiteException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateWebsiteException class.
Public method | DuplicateWebsiteException(String, Exception) | Initializes a new instance of the DuplicateWebsiteException class.

See Also

DuplicateWebsiteException Class
DuplicateWebsiteException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Constructor
DuplicateWebsiteException Class See Also Send Feedback
Initializes a new instance of the DuplicateWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateWebsiteException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateWebsiteException()

See Also

DuplicateWebsiteException Class
DuplicateWebsiteException Members
DuplicateWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Constructor (String)
DuplicateWebsiteException Class See Also Send Feedback
Initializes a new instance of the DuplicateWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateWebsiteException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateWebsiteException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateWebsiteException Class
DuplicateWebsiteException Members
DuplicateWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Constructor (SerializationInfo, StreamingContext)
DuplicateWebsiteException Class See Also Send Feedback
Initializes a new instance of the DuplicateWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateWebsiteException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
DuplicateWebsiteException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

DuplicateWebsiteException Class
DuplicateWebsiteException Members
DuplicateWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Constructor (String, Exception)
DuplicateWebsiteException Class See Also Send Feedback
Initializes a new instance of the DuplicateWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateWebsiteException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateWebsiteException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateWebsiteException Class
DuplicateWebsiteException Members
DuplicateWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Methods
DuplicateWebsiteException Class See Also Send Feedback

The DuplicateWebsiteException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Properties
DuplicateWebsiteException Class See Also Send Feedback

The DuplicateWebsiteException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


DuplicateWebsiteException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateWebsiteException Events
DuplicateWebsiteException Class See Also Send Feedback

The DuplicateWebsiteException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Class

[image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Class
Members See Also Send Feedback
Invalid ActivationKey Exception class

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidActivationKeyException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidActivationKeyException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidActivationKeyException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidActivationKeyException

See Also

InvalidActivationKeyException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Members
InvalidActivationKeyException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidActivationKeyException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidActivationKeyException()()()() | Initializes a new instance of the InvalidActivationKeyException class.
Public method | InvalidActivationKeyException(String) | Initializes a new instance of the InvalidActivationKeyException class.
Protected method | InvalidActivationKeyException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidActivationKeyException class.
Public method | InvalidActivationKeyException(String, Exception) | Initializes a new instance of the InvalidActivationKeyException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidActivationKeyException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Constructor
InvalidActivationKeyException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidActivationKeyException()()()() | Initializes a new instance of the InvalidActivationKeyException class.
Public method | InvalidActivationKeyException(String) | Initializes a new instance of the InvalidActivationKeyException class.
Protected method | InvalidActivationKeyException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidActivationKeyException class.
Public method | InvalidActivationKeyException(String, Exception) | Initializes a new instance of the InvalidActivationKeyException class.

See Also

InvalidActivationKeyException Class
InvalidActivationKeyException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Constructor

[image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Constructor
InvalidActivationKeyException Class See Also Send Feedback
Initializes a new instance of the InvalidActivationKeyException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidActivationKeyException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidActivationKeyException()

See Also

InvalidActivationKeyException Class
InvalidActivationKeyException Members
InvalidActivationKeyException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Constructor (String)
InvalidActivationKeyException Class See Also Send Feedback
Initializes a new instance of the InvalidActivationKeyException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidActivationKeyException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidActivationKeyException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidActivationKeyException Class
InvalidActivationKeyException Members
InvalidActivationKeyException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Constructor (SerializationInfo, StreamingContext)
InvalidActivationKeyException Class See Also Send Feedback
Initializes a new instance of the InvalidActivationKeyException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected InvalidActivationKeyException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
InvalidActivationKeyException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

InvalidActivationKeyException Class
InvalidActivationKeyException Members
InvalidActivationKeyException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Constructor (String, Exception)
InvalidActivationKeyException Class See Also Send Feedback
Initializes a new instance of the InvalidActivationKeyException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidActivationKeyException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidActivationKeyException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidActivationKeyException Class
InvalidActivationKeyException Members
InvalidActivationKeyException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Methods
InvalidActivationKeyException Class See Also Send Feedback

The InvalidActivationKeyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidActivationKeyException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Properties
InvalidActivationKeyException Class See Also Send Feedback

The InvalidActivationKeyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidActivationKeyException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidActivationKeyException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidActivationKeyException Events
InvalidActivationKeyException Class See Also Send Feedback

The InvalidActivationKeyException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidActivationKeyException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Class

[image]

A Sandcastle Documented Class Library
InvalidEmailException Class
Members See Also Send Feedback
Invalid Email Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidEmailException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidEmailException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidEmailException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException

See Also

InvalidEmailException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailException Members
InvalidEmailException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidEmailException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidEmailException()()()() | Initializes a new instance of the InvalidEmailException class.
Public method | InvalidEmailException(String) | Initializes a new instance of the InvalidEmailException class.
Protected method | InvalidEmailException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidEmailException class.
Public method | InvalidEmailException(String, Exception) | Initializes a new instance of the InvalidEmailException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidEmailException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailException Constructor
InvalidEmailException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidEmailException()()()() | Initializes a new instance of the InvalidEmailException class.
Public method | InvalidEmailException(String) | Initializes a new instance of the InvalidEmailException class.
Protected method | InvalidEmailException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidEmailException class.
Public method | InvalidEmailException(String, Exception) | Initializes a new instance of the InvalidEmailException class.

See Also

InvalidEmailException Class
InvalidEmailException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Constructor

[image]

A Sandcastle Documented Class Library
InvalidEmailException Constructor
InvalidEmailException Class See Also Send Feedback
Initializes a new instance of the InvalidEmailException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidEmailException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidEmailException()

See Also

InvalidEmailException Class
InvalidEmailException Members
InvalidEmailException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidEmailException Constructor (String)
InvalidEmailException Class See Also Send Feedback
Initializes a new instance of the InvalidEmailException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidEmailException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidEmailException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidEmailException Class
InvalidEmailException Members
InvalidEmailException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
InvalidEmailException Constructor (SerializationInfo, StreamingContext)
InvalidEmailException Class See Also Send Feedback
Initializes a new instance of the InvalidEmailException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected InvalidEmailException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
InvalidEmailException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

InvalidEmailException Class
InvalidEmailException Members
InvalidEmailException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidEmailException Constructor (String, Exception)
InvalidEmailException Class See Also Send Feedback
Initializes a new instance of the InvalidEmailException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidEmailException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidEmailException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidEmailException Class
InvalidEmailException Members
InvalidEmailException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailException Methods
InvalidEmailException Class See Also Send Feedback

The InvalidEmailException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidEmailException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailException Properties
InvalidEmailException Class See Also Send Feedback

The InvalidEmailException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidEmailException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidEmailException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailException Events
InvalidEmailException Class See Also Send Feedback

The InvalidEmailException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidEmailException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Class

[image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Class
Members See Also Send Feedback
Invalid TenantCode Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidTenantCodeException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidTenantCodeException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidTenantCodeException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException

See Also

InvalidTenantCodeException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Members
InvalidTenantCodeException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidTenantCodeException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidTenantCodeException()()()() | Initializes a new instance of the InvalidTenantCodeException class.
Public method | InvalidTenantCodeException(String) | Initializes a new instance of the InvalidTenantCodeException class.
Protected method | InvalidTenantCodeException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidTenantCodeException class.
Public method | InvalidTenantCodeException(String, Exception) | Initializes a new instance of the InvalidTenantCodeException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Constructor
InvalidTenantCodeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidTenantCodeException()()()() | Initializes a new instance of the InvalidTenantCodeException class.
Public method | InvalidTenantCodeException(String) | Initializes a new instance of the InvalidTenantCodeException class.
Protected method | InvalidTenantCodeException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidTenantCodeException class.
Public method | InvalidTenantCodeException(String, Exception) | Initializes a new instance of the InvalidTenantCodeException class.

See Also

InvalidTenantCodeException Class
InvalidTenantCodeException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Constructor

[image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Constructor
InvalidTenantCodeException Class See Also Send Feedback
Initializes a new instance of the InvalidTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidTenantCodeException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidTenantCodeException()

See Also

InvalidTenantCodeException Class
InvalidTenantCodeException Members
InvalidTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Constructor (String)
InvalidTenantCodeException Class See Also Send Feedback
Initializes a new instance of the InvalidTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidTenantCodeException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidTenantCodeException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidTenantCodeException Class
InvalidTenantCodeException Members
InvalidTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Constructor (SerializationInfo, StreamingContext)
InvalidTenantCodeException Class See Also Send Feedback
Initializes a new instance of the InvalidTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected InvalidTenantCodeException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
InvalidTenantCodeException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

InvalidTenantCodeException Class
InvalidTenantCodeException Members
InvalidTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Constructor (String, Exception)
InvalidTenantCodeException Class See Also Send Feedback
Initializes a new instance of the InvalidTenantCodeException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidTenantCodeException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidTenantCodeException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidTenantCodeException Class
InvalidTenantCodeException Members
InvalidTenantCodeException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Methods
InvalidTenantCodeException Class See Also Send Feedback

The InvalidTenantCodeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Properties
InvalidTenantCodeException Class See Also Send Feedback

The InvalidTenantCodeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidTenantCodeException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidTenantCodeException Events
InvalidTenantCodeException Class See Also Send Feedback

The InvalidTenantCodeException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidTenantCodeException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Class

[image]

A Sandcastle Documented Class Library
InvalidURLException Class
Members See Also Send Feedback
Invalid URL Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidURLException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidURLException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidURLException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException

See Also

InvalidURLException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidURLException Members
InvalidURLException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidURLException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidURLException()()()() | Initializes a new instance of the InvalidURLException class.
Public method | InvalidURLException(String) | Initializes a new instance of the InvalidURLException class.
Protected method | InvalidURLException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidURLException class.
Public method | InvalidURLException(String, Exception) | Initializes a new instance of the InvalidURLException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidURLException Constructor
InvalidURLException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidURLException()()()() | Initializes a new instance of the InvalidURLException class.
Public method | InvalidURLException(String) | Initializes a new instance of the InvalidURLException class.
Protected method | InvalidURLException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidURLException class.
Public method | InvalidURLException(String, Exception) | Initializes a new instance of the InvalidURLException class.

See Also

InvalidURLException Class
InvalidURLException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Constructor

[image]

A Sandcastle Documented Class Library
InvalidURLException Constructor
InvalidURLException Class See Also Send Feedback
Initializes a new instance of the InvalidURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidURLException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidURLException()

See Also

InvalidURLException Class
InvalidURLException Members
InvalidURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidURLException Constructor (String)
InvalidURLException Class See Also Send Feedback
Initializes a new instance of the InvalidURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidURLException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidURLException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidURLException Class
InvalidURLException Members
InvalidURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
InvalidURLException Constructor (SerializationInfo, StreamingContext)
InvalidURLException Class See Also Send Feedback
Initializes a new instance of the InvalidURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected InvalidURLException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
InvalidURLException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

InvalidURLException Class
InvalidURLException Members
InvalidURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidURLException Constructor (String, Exception)
InvalidURLException Class See Also Send Feedback
Initializes a new instance of the InvalidURLException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidURLException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidURLException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidURLException Class
InvalidURLException Members
InvalidURLException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidURLException Methods
InvalidURLException Class See Also Send Feedback

The InvalidURLException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidURLException Properties
InvalidURLException Class See Also Send Feedback

The InvalidURLException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidURLException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidURLException Events
InvalidURLException Class See Also Send Feedback

The InvalidURLException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidURLException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Class

[image]

A Sandcastle Documented Class Library
InvalidWebsiteException Class
Members See Also Send Feedback
Invalid Website Exception

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidWebsiteException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidWebsiteException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidWebsiteException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException

See Also

InvalidWebsiteException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidWebsiteException Members
InvalidWebsiteException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidWebsiteException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidWebsiteException()()()() | Initializes a new instance of the InvalidWebsiteException class.
Public method | InvalidWebsiteException(String) | Initializes a new instance of the InvalidWebsiteException class.
Protected method | InvalidWebsiteException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidWebsiteException class.
Public method | InvalidWebsiteException(String, Exception) | Initializes a new instance of the InvalidWebsiteException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Constructor

[image] [image]

A Sandcastle Documented Class Library
InvalidWebsiteException Constructor
InvalidWebsiteException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvalidWebsiteException()()()() | Initializes a new instance of the InvalidWebsiteException class.
Public method | InvalidWebsiteException(String) | Initializes a new instance of the InvalidWebsiteException class.
Protected method | InvalidWebsiteException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidWebsiteException class.
Public method | InvalidWebsiteException(String, Exception) | Initializes a new instance of the InvalidWebsiteException class.

See Also

InvalidWebsiteException Class
InvalidWebsiteException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Constructor

[image]

A Sandcastle Documented Class Library
InvalidWebsiteException Constructor
InvalidWebsiteException Class See Also Send Feedback
Initializes a new instance of the InvalidWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidWebsiteException()
Visual Basic
Public Sub New
Visual C++
public:
InvalidWebsiteException()

See Also

InvalidWebsiteException Class
InvalidWebsiteException Members
InvalidWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Constructor (String)

[image]

A Sandcastle Documented Class Library
InvalidWebsiteException Constructor (String)
InvalidWebsiteException Class See Also Send Feedback
Initializes a new instance of the InvalidWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidWebsiteException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidWebsiteException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidWebsiteException Class
InvalidWebsiteException Members
InvalidWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
InvalidWebsiteException Constructor (SerializationInfo, StreamingContext)
InvalidWebsiteException Class See Also Send Feedback
Initializes a new instance of the InvalidWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected InvalidWebsiteException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
InvalidWebsiteException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

InvalidWebsiteException Class
InvalidWebsiteException Members
InvalidWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
InvalidWebsiteException Constructor (String, Exception)
InvalidWebsiteException Class See Also Send Feedback
Initializes a new instance of the InvalidWebsiteException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidWebsiteException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
InvalidWebsiteException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

InvalidWebsiteException Class
InvalidWebsiteException Members
InvalidWebsiteException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidWebsiteException Methods
InvalidWebsiteException Class See Also Send Feedback

The InvalidWebsiteException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidWebsiteException Properties
InvalidWebsiteException Class See Also Send Feedback

The InvalidWebsiteException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


InvalidWebsiteException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidWebsiteException Events
InvalidWebsiteException Class See Also Send Feedback

The InvalidWebsiteException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidWebsiteException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService Interface

[image]

A Sandcastle Documented Class Library
ITenantRelationService Interface
Members See Also Send Feedback
Tenant Relation Service Interface

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantRelationService
Visual Basic
Public Interface ITenantRelationService
Visual C++
public interface class ITenantRelationService

See Also

ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantRelationService Members
ITenantRelationService Interface Methods See Also Send Feedback

The ITenantRelationService type exposes the following members.

Methods

 | Name | Description
Public method | AddTenantRelation | This method is used to add a given relation between the given parent and child tenant
Public method | DeleteTenantRelation | This method is used to delete the tenant relation based on the given relation identifier that may exist between tenants
Public method | DisassociateTenantRelationShip(String) | This method is used to disassociate the tenant relation ship based on the mapping identifier
Public method | DisassociateTenantRelationShip(String, String) | This method is used to disassociate the tenant relation ship between the given parent and child tenants
Public method | GetAllActiveImmediateChildTenants | This method is used to get the list of all the active immediate child tenants for the given parent tenant identifier.
Public method | GetAllChildTenants | This method is used to get all the child tenants for the given parent tenant identifier.
Public method | GetAllChildTenantsCount | Returns the all child tenants count for the given tenant ids
Public method | GetAllImmediateChildTenants | This method is used to get all immediate child tenants for the given parent tenant identifier
Public method | GetAllParentTenants | This method is used to get all the parent tenant for the given child tenant identifier
Public method | GetAllSkipLevelChildTenants | This method is used to get all skip level child tenants for the given parent tenant identifier
Public method | GetAllTenantRelationTypes | This method is used to get all the tenant relation types available
Public method | GetChildTenantHierarchy | This method is used to get the child tenant hierarchy for the given parent tenant identifier
Public method | GetParentTenant | This method is used to get the parent tenant details for the given child tenant identifier
Public method | GetParentTenantInHierarchy | This method is used to get the parent tenant in the hierarchy of the given child tenant identifier
Public method | GetRelatedTenants | This method is used to get all the relation for the given tenant code
Public method | GetTenantMappingDetails | This method is used to fetch the relation mapping for the given relation mapping identifier
Public method | UpdateTenantRelation | This method is used to update tenant relation between the given parent and child tenant with the given relationship id

See Also

ITenantRelationService Interface
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantRelationService Methods
ITenantRelationService Interface See Also Send Feedback

The ITenantRelationService type exposes the following members.

Methods

 | Name | Description
Public method | AddTenantRelation | This method is used to add a given relation between the given parent and child tenant
Public method | DeleteTenantRelation | This method is used to delete the tenant relation based on the given relation identifier that may exist between tenants
Public method | DisassociateTenantRelationShip(String) | This method is used to disassociate the tenant relation ship based on the mapping identifier
Public method | DisassociateTenantRelationShip(String, String) | This method is used to disassociate the tenant relation ship between the given parent and child tenants
Public method | GetAllActiveImmediateChildTenants | This method is used to get the list of all the active immediate child tenants for the given parent tenant identifier.
Public method | GetAllChildTenants | This method is used to get all the child tenants for the given parent tenant identifier.
Public method | GetAllChildTenantsCount | Returns the all child tenants count for the given tenant ids
Public method | GetAllImmediateChildTenants | This method is used to get all immediate child tenants for the given parent tenant identifier
Public method | GetAllParentTenants | This method is used to get all the parent tenant for the given child tenant identifier
Public method | GetAllSkipLevelChildTenants | This method is used to get all skip level child tenants for the given parent tenant identifier
Public method | GetAllTenantRelationTypes | This method is used to get all the tenant relation types available
Public method | GetChildTenantHierarchy | This method is used to get the child tenant hierarchy for the given parent tenant identifier
Public method | GetParentTenant | This method is used to get the parent tenant details for the given child tenant identifier
Public method | GetParentTenantInHierarchy | This method is used to get the parent tenant in the hierarchy of the given child tenant identifier
Public method | GetRelatedTenants | This method is used to get all the relation for the given tenant code
Public method | GetTenantMappingDetails | This method is used to fetch the relation mapping for the given relation mapping identifier
Public method | UpdateTenantRelation | This method is used to update tenant relation between the given parent and child tenant with the given relationship id

See Also

ITenantRelationService Interface
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.AddTenantRelation Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..AddTenantRelation Method
ITenantRelationService Interface See Also Send Feedback
This method is used to add a given relation between the given parent and child tenant

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddTenantRelation(
    string parentTenantCode,
    string childTenantCode,
    string tenantRelationTypeId
)
Visual Basic
Sub AddTenantRelation (
    parentTenantCode As String,
    childTenantCode As String,
    tenantRelationTypeId As String
)
Visual C++
void AddTenantRelation(
    String^ parentTenantCode,
    String^ childTenantCode,
    String^ tenantRelationTypeId
)

Parameters

parentTenantCode
Type: System..::..String
parent tenant id
childTenantCode
Type: System..::..String
child tenant id
tenantRelationTypeId
Type: System..::..String
tenant relation id

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
System..::..ArgumentException | Throws Argument Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.DeleteTenantRelation Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..DeleteTenantRelation Method
ITenantRelationService Interface See Also Send Feedback
This method is used to delete the tenant relation based on the given relation identifier that may exist between tenants

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantRelation(
    string relationId
)
Visual Basic
Sub DeleteTenantRelation (
    relationId As String
)
Visual C++
void DeleteTenantRelation(
    String^ relationId
)

Parameters

relationId
Type: System..::..String
tenant relation id

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.DisassociateTenantRelationShip Method

[image] [image]

A Sandcastle Documented Class Library
ITenantRelationService..::..DisassociateTenantRelationShip Method
ITenantRelationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DisassociateTenantRelationShip(String) | This method is used to disassociate the tenant relation ship based on the mapping identifier
Public method | DisassociateTenantRelationShip(String, String) | This method is used to disassociate the tenant relation ship between the given parent and child tenants

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.DisassociateTenantRelationShip Method (String)

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..DisassociateTenantRelationShip Method (String)
ITenantRelationService Interface See Also Send Feedback
This method is used to disassociate the tenant relation ship based on the mapping identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DisassociateTenantRelationShip(
    string mappingId
)
Visual Basic
Sub DisassociateTenantRelationShip (
    mappingId As String
)
Visual C++
void DisassociateTenantRelationShip(
    String^ mappingId
)

Parameters

mappingId
Type: System..::..String
The mapping id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
DisassociateTenantRelationShip Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.DisassociateTenantRelationShip Method (String, String)

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..DisassociateTenantRelationShip Method (String, String)
ITenantRelationService Interface See Also Send Feedback
This method is used to disassociate the tenant relation ship between the given parent and child tenants

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DisassociateTenantRelationShip(
    string parentTenantId,
    string childTenantId
)
Visual Basic
Sub DisassociateTenantRelationShip (
    parentTenantId As String,
    childTenantId As String
)
Visual C++
void DisassociateTenantRelationShip(
    String^ parentTenantId,
    String^ childTenantId
)

Parameters

parentTenantId
Type: System..::..String
The parent tenant id.
childTenantId
Type: System..::..String
The child tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
DisassociateTenantRelationShip Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllActiveImmediateChildTenants Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllActiveImmediateChildTenants Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get the list of all the active immediate child tenants for the given parent tenant identifier.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllActiveImmediateChildTenants(
    string parentTenantId
)
Visual Basic
Function GetAllActiveImmediateChildTenants (
    parentTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllActiveImmediateChildTenants(
    String^ parentTenantId
)

Parameters

parentTenantId
Type: System..::..String
The parent tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllChildTenants Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllChildTenants Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get all the child tenants for the given parent tenant identifier.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllChildTenants(
    string parentTenantId
)
Visual Basic
Function GetAllChildTenants (
    parentTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllChildTenants(
    String^ parentTenantId
)

Parameters

parentTenantId
Type: System..::..String
The parent tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of Tenant Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllChildTenantsCount Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllChildTenantsCount Method
ITenantRelationService Interface See Also Send Feedback
Returns the all child tenants count for the given tenant ids

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<Guid, int> GetAllChildTenantsCount(
    Guid[] tenantIds
)
Visual Basic
Function GetAllChildTenantsCount (
    tenantIds As Guid()
) As Dictionary(Of Guid, Integer)
Visual C++
Dictionary<Guid, int>^ GetAllChildTenantsCount(
    array<Guid>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..Guid>[]()[][]

Return Value

Type: Dictionary<(Of <(<'Guid, Int32>)>)>

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllImmediateChildTenants Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllImmediateChildTenants Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get all immediate child tenants for the given parent tenant identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllImmediateChildTenants(
    string parentTenantId
)
Visual Basic
Function GetAllImmediateChildTenants (
    parentTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllImmediateChildTenants(
    String^ parentTenantId
)

Parameters

parentTenantId
Type: System..::..String
The parent tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllParentTenants Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllParentTenants Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get all the parent tenant for the given child tenant identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllParentTenants(
    string childTenantId
)
Visual Basic
Function GetAllParentTenants (
    childTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllParentTenants(
    String^ childTenantId
)

Parameters

childTenantId
Type: System..::..String
The child tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of Tenant Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllSkipLevelChildTenants Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllSkipLevelChildTenants Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get all skip level child tenants for the given parent tenant identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllSkipLevelChildTenants(
    string parentTenantId
)
Visual Basic
Function GetAllSkipLevelChildTenants (
    parentTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllSkipLevelChildTenants(
    String^ parentTenantId
)

Parameters

parentTenantId
Type: System..::..String
The parent tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of Tenant Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetAllTenantRelationTypes Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetAllTenantRelationTypes Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get all the tenant relation types available

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantRelationType> GetAllTenantRelationTypes()
Visual Basic
Function GetAllTenantRelationTypes As List(Of TenantRelationType)
Visual C++
List<TenantRelationType^>^ GetAllTenantRelationTypes()

Return Value

Type: List<(Of <(<' TenantRelationType >)>)>
list of tenant relation type details

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetChildTenantHierarchy Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetChildTenantHierarchy Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get the child tenant hierarchy for the given parent tenant identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetChildTenantHierarchy(
    string parentTenantId
)
Visual Basic
Function GetChildTenantHierarchy (
    parentTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetChildTenantHierarchy(
    String^ parentTenantId
)

Parameters

parentTenantId
Type: System..::..String
The parent tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of Tenant Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetParentTenant Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetParentTenant Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get the parent tenant details for the given child tenant identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantDetails GetParentTenant(
    string childTenantId
)
Visual Basic
Function GetParentTenant (
    childTenantId As String
) As TenantDetails
Visual C++
TenantDetails^ GetParentTenant(
    String^ childTenantId
)

Parameters

childTenantId
Type: System..::..String
The child tenant id.

Return Value

Type: TenantDetails
Tenant Details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetParentTenantInHierarchy Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetParentTenantInHierarchy Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get the parent tenant in the hierarchy of the given child tenant identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantDetails GetParentTenantInHierarchy(
    string childTenantId
)
Visual Basic
Function GetParentTenantInHierarchy (
    childTenantId As String
) As TenantDetails
Visual C++
TenantDetails^ GetParentTenantInHierarchy(
    String^ childTenantId
)

Parameters

childTenantId
Type: System..::..String
The child tenant id.

Return Value

Type: TenantDetails
The TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetRelatedTenants Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetRelatedTenants Method
ITenantRelationService Interface See Also Send Feedback
This method is used to get all the relation for the given tenant code

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantRelation> GetRelatedTenants(
    string parentTenantCode
)
Visual Basic
Function GetRelatedTenants (
    parentTenantCode As String
) As List(Of TenantRelation)
Visual C++
List<TenantRelation^>^ GetRelatedTenants(
    String^ parentTenantCode
)

Parameters

parentTenantCode
Type: System..::..String
parent tenant id

Return Value

Type: List<(Of <(<' TenantRelation >)>)>
dictionary of tenant relation and tenant

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.GetTenantMappingDetails Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..GetTenantMappingDetails Method
ITenantRelationService Interface See Also Send Feedback
This method is used to fetch the relation mapping for the given relation mapping identifier

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantRelationMapping GetTenantMappingDetails(
    string relationMappingId
)
Visual Basic
Function GetTenantMappingDetails (
    relationMappingId As String
) As TenantRelationMapping
Visual C++
TenantRelationMapping^ GetTenantMappingDetails(
    String^ relationMappingId
)

Parameters

relationMappingId
Type: System..::..String
relation mapping id

Return Value

Type: TenantRelationMapping
relation mapping details TenantRelationMapping

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantRelationService.UpdateTenantRelation Method

[image]

A Sandcastle Documented Class Library
ITenantRelationService..::..UpdateTenantRelation Method
ITenantRelationService Interface See Also Send Feedback
This method is used to update tenant relation between the given parent and child tenant with the given relationship id

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateTenantRelation(
    string mappingId,
    string parentTenantCode,
    string childTenantCode,
    string tenantRelationTypeId
)
Visual Basic
Sub UpdateTenantRelation (
    mappingId As String,
    parentTenantCode As String,
    childTenantCode As String,
    tenantRelationTypeId As String
)
Visual C++
void UpdateTenantRelation(
    String^ mappingId,
    String^ parentTenantCode,
    String^ childTenantCode,
    String^ tenantRelationTypeId
)

Parameters

mappingId
Type: System..::..String
mapping table unique id
parentTenantCode
Type: System..::..String
parent tenant id
childTenantCode
Type: System..::..String
child tenant id
tenantRelationTypeId
Type: System..::..String
tenant relation type id

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException | Throws Tenant Relation Exception

See Also

ITenantRelationService Interface
ITenantRelationService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService Interface

[image]

A Sandcastle Documented Class Library
ITenantService Interface
Members See Also Send Feedback
Tenant Service Interface

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantService
Visual Basic
Public Interface ITenantService
Visual C++
public interface class ITenantService

See Also

ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantService Members
ITenantService Interface Methods See Also Send Feedback

The ITenantService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateTenant | This method is used to activate the tenant using activation key
Public method | DeleteRoleTenants | This method is used to delete role-tenants
Public method | DeleteTenant | Deactivate the tenant.
Public method | DeleteUserRoleAndTenantMapping | This method is used to delete the user role and tenant mapping. Calling this API will invoke a delete of the selected role to the primary tenant of this user and also to the child tenants or stratified tenants to this user
Public method | DeleteUserRoleTenants(String, String, String) | This method is used to delete the user role tenant mappings assigned by the role assigned tenant for the given user and role.
Public method | DeleteUserRoleTenants(String, String, array<String>[]()[][]) | This method is used to delete userRole-Tenants.
Public method | DeleteUserRoleTenants(String, array<String>[]()[][], String) | This method is used to delete the user role tenants based on the UserId, list of Roles for the given single tenant.
Public method | DeleteUserRoleTenants(String, String, array<String>[]()[][], String) | This method is used to delete the user role tenants.
Public method | DeleteUserRoleTenants(String, array<String>[]()[][], String, String) | This method is used to delete the user role tenants.
Public method | GetAllActiveTenantDetails | Get all active tenant details.
Public method | GetAllTenantDetails | Get all (Active and Inactive) tenant details.
Public method | GetAllTenantInfoDetails | Get All(Active and Inactive) tenant details
Public method | GetManageableTenantsForUserAssignedByTenant | This method is used to get the manageable tenants for user assigned by tenant.
Public method | GetNumberOfTenants | This method is used to get the number of tenant with status for the input package identifiers.
Public method | GetOtherTenantUserRolesByTenantAndUserId(String, String) | Get the user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(array<String>[]()[][], String) | This method is used to get the user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(String, String, String) | This method is used to get the other tenant user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(array<String>[]()[][], String, String) | This method is used to get the other tenant user roles by tenant and user id.
Public method | GetRoleWiseTenantsByUserRoles(String, array<String>[]()[][]) | This method is used to get list of tenant details for given userId and roleIds.
Public method | GetRoleWiseTenantsByUserRoles(String, array<String>[]()[][], String) | This method is used to get the role wise tenants by user roles for the given role assigning tenant id.
Public method | GetStratifiedTenantsByUser | This method is used to get the tenants by user, based on the current tenant who has assigned the roles to this tenant
Public method | GetTenantDetails()()()() | Get only active tenant details.
Public method | GetTenantDetails(array<String>[]()[][]) | Get the tenant details for the given array of tenant identifiers
Public method | GetTenantDetailsByTenantCodeString | This method is used to get the tenant details for given tenant code string.
Public method | GetTenantDetailsByTenantId(String) | Get tenant details by given tenant identifier.
Public method | GetTenantDetailsByTenantId(String, String) | This method is used to get the tenant details by tenant id.
Public method | GetTenantDetailsByURL | Get the tenant details for the given tenant Url.
Public method | GetTenantDetailsForShareUsers | This method is used to get the required tenant informations for user sharing.
Public method | GetTenantIdFromTenantCode | This method is used to get the tenant id from the give tenant code string
Public method | GetTenantInfoDetails | Get Active Tenant Details
Public method | GetTenantsByRole | This method is used to get list of tenant details for given roleId.
Public method | GetTenantsByRoles | This method is used to get list of tenant details for given roleIds.
Public method | GetTenantsByUser | This method is used to get list of tenant details for given userId.
Public method | GetTenantsByUserRole(String) | This method is used to get list of tenant details for given userRoleId.
Public method | GetTenantsByUserRole(String, String) | This method is used to get list of tenant details for given userId and roleId.
Public method | GetTenantsByUserRole(String, String, String) | This method is used to get the tenants by user role for the given role assigned tenant id who has assigned the role for the user
Public method | GetTenantsByUserRoles(String, array<String>[]()[][]) | This method is used to get list of tenant details for given userId and roleIds.
Public method | GetTenantsByUserRoles(String, array<String>[]()[][], String) | This method is used to get the tenants which can be managed by the given user and roles belonging to this tenant id.
Public method | GetTenantsForCurrentUser | This method is used to get list of tenant details for current logged in user.
Public method | GetTenantsInTrial | Returns all trial tenants for the current logged in tenant. Only immediate child tenants are considered.
Public method | InsertUserRoleTenantMapping(String, String, String) | This method is used to insert the user role tenant mapping.
Public method | InsertUserRoleTenantMapping(String, String, String, String) | This method is used to insert the user role tenant mapping for the assigning tenant id
Public method | PermanentDeleteTenant | This method is used to delete the tenant details.
Public method | ProvisionTenant(Tenant, TenantLicense) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenant(Tenant, TenantLicense, TenantSettingsTemplate) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenant(TenantDetails, Address, ContactDetails, User, MembershipDetails, TenantLicense) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenantWithConnString | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | SearchAllTenantDetails | Get all(active and inactive) tenant details by search string as input.
Public method | SearchTenantDetails | Search tenant details by search condition.
Public method | UpdateApprovalStatus | This method is used to update the approval status for the given tenant.
Public method | UpdateRoleTenants | This method is used to update role-tenants.
Public method | UpdateTenantInfo(Tenant, TenantLicense) | Update the tenant details.
Public method | UpdateTenantInfo(TenantDetails, Address, ContactDetails, TenantLicense) | Update the tenant details.
Public method | UpdateUserRoleTenants(String, String, array<String>[]()[][]) | This method is used to update userRole-Tenants.
Public method | UpdateUserRoleTenants(String, String, array<String>[]()[][], String) | This method is used to update the user role tenants.

See Also

ITenantService Interface
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantService Methods
ITenantService Interface See Also Send Feedback

The ITenantService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateTenant | This method is used to activate the tenant using activation key
Public method | DeleteRoleTenants | This method is used to delete role-tenants
Public method | DeleteTenant | Deactivate the tenant.
Public method | DeleteUserRoleAndTenantMapping | This method is used to delete the user role and tenant mapping. Calling this API will invoke a delete of the selected role to the primary tenant of this user and also to the child tenants or stratified tenants to this user
Public method | DeleteUserRoleTenants(String, String, String) | This method is used to delete the user role tenant mappings assigned by the role assigned tenant for the given user and role.
Public method | DeleteUserRoleTenants(String, String, array<String>[]()[][]) | This method is used to delete userRole-Tenants.
Public method | DeleteUserRoleTenants(String, array<String>[]()[][], String) | This method is used to delete the user role tenants based on the UserId, list of Roles for the given single tenant.
Public method | DeleteUserRoleTenants(String, String, array<String>[]()[][], String) | This method is used to delete the user role tenants.
Public method | DeleteUserRoleTenants(String, array<String>[]()[][], String, String) | This method is used to delete the user role tenants.
Public method | GetAllActiveTenantDetails | Get all active tenant details.
Public method | GetAllTenantDetails | Get all (Active and Inactive) tenant details.
Public method | GetAllTenantInfoDetails | Get All(Active and Inactive) tenant details
Public method | GetManageableTenantsForUserAssignedByTenant | This method is used to get the manageable tenants for user assigned by tenant.
Public method | GetNumberOfTenants | This method is used to get the number of tenant with status for the input package identifiers.
Public method | GetOtherTenantUserRolesByTenantAndUserId(String, String) | Get the user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(array<String>[]()[][], String) | This method is used to get the user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(String, String, String) | This method is used to get the other tenant user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(array<String>[]()[][], String, String) | This method is used to get the other tenant user roles by tenant and user id.
Public method | GetRoleWiseTenantsByUserRoles(String, array<String>[]()[][]) | This method is used to get list of tenant details for given userId and roleIds.
Public method | GetRoleWiseTenantsByUserRoles(String, array<String>[]()[][], String) | This method is used to get the role wise tenants by user roles for the given role assigning tenant id.
Public method | GetStratifiedTenantsByUser | This method is used to get the tenants by user, based on the current tenant who has assigned the roles to this tenant
Public method | GetTenantDetails()()()() | Get only active tenant details.
Public method | GetTenantDetails(array<String>[]()[][]) | Get the tenant details for the given array of tenant identifiers
Public method | GetTenantDetailsByTenantCodeString | This method is used to get the tenant details for given tenant code string.
Public method | GetTenantDetailsByTenantId(String) | Get tenant details by given tenant identifier.
Public method | GetTenantDetailsByTenantId(String, String) | This method is used to get the tenant details by tenant id.
Public method | GetTenantDetailsByURL | Get the tenant details for the given tenant Url.
Public method | GetTenantDetailsForShareUsers | This method is used to get the required tenant informations for user sharing.
Public method | GetTenantIdFromTenantCode | This method is used to get the tenant id from the give tenant code string
Public method | GetTenantInfoDetails | Get Active Tenant Details
Public method | GetTenantsByRole | This method is used to get list of tenant details for given roleId.
Public method | GetTenantsByRoles | This method is used to get list of tenant details for given roleIds.
Public method | GetTenantsByUser | This method is used to get list of tenant details for given userId.
Public method | GetTenantsByUserRole(String) | This method is used to get list of tenant details for given userRoleId.
Public method | GetTenantsByUserRole(String, String) | This method is used to get list of tenant details for given userId and roleId.
Public method | GetTenantsByUserRole(String, String, String) | This method is used to get the tenants by user role for the given role assigned tenant id who has assigned the role for the user
Public method | GetTenantsByUserRoles(String, array<String>[]()[][]) | This method is used to get list of tenant details for given userId and roleIds.
Public method | GetTenantsByUserRoles(String, array<String>[]()[][], String) | This method is used to get the tenants which can be managed by the given user and roles belonging to this tenant id.
Public method | GetTenantsForCurrentUser | This method is used to get list of tenant details for current logged in user.
Public method | GetTenantsInTrial | Returns all trial tenants for the current logged in tenant. Only immediate child tenants are considered.
Public method | InsertUserRoleTenantMapping(String, String, String) | This method is used to insert the user role tenant mapping.
Public method | InsertUserRoleTenantMapping(String, String, String, String) | This method is used to insert the user role tenant mapping for the assigning tenant id
Public method | PermanentDeleteTenant | This method is used to delete the tenant details.
Public method | ProvisionTenant(Tenant, TenantLicense) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenant(Tenant, TenantLicense, TenantSettingsTemplate) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenant(TenantDetails, Address, ContactDetails, User, MembershipDetails, TenantLicense) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenantWithConnString | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | SearchAllTenantDetails | Get all(active and inactive) tenant details by search string as input.
Public method | SearchTenantDetails | Search tenant details by search condition.
Public method | UpdateApprovalStatus | This method is used to update the approval status for the given tenant.
Public method | UpdateRoleTenants | This method is used to update role-tenants.
Public method | UpdateTenantInfo(Tenant, TenantLicense) | Update the tenant details.
Public method | UpdateTenantInfo(TenantDetails, Address, ContactDetails, TenantLicense) | Update the tenant details.
Public method | UpdateUserRoleTenants(String, String, array<String>[]()[][]) | This method is used to update userRole-Tenants.
Public method | UpdateUserRoleTenants(String, String, array<String>[]()[][], String) | This method is used to update the user role tenants.

See Also

ITenantService Interface
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.ActivateTenant Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..ActivateTenant Method
ITenantService Interface See Also Send Feedback
This method is used to activate the tenant using activation key

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ActivateTenant(
    string activationKey
)
Visual Basic
Function ActivateTenant (
    activationKey As String
) As Boolean
Visual C++
bool ActivateTenant(
    String^ activationKey
)

Parameters

activationKey
Type: System..::..String
The activation key.

Return Value

Type: Boolean

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteRoleTenants Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteRoleTenants Method
ITenantService Interface See Also Send Feedback
This method is used to delete role-tenants

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteRoleTenants(
    string roleId,
    string[] tenantIds
)
Visual Basic
Sub DeleteRoleTenants (
    roleId As String,
    tenantIds As String()
)
Visual C++
void DeleteRoleTenants(
    String^ roleId,
    array<String^>^ tenantIds
)

Parameters

roleId
Type: System..::..String
The role id.
tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the role id or the tenant identifiers being null or empty

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteTenant Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteTenant Method
ITenantService Interface Example See Also Send Feedback
Deactivate the tenant.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenant(
    string tenantId
)
Visual Basic
Sub DeleteTenant (
    tenantId As String
)
Visual C++
void DeleteTenant(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Id(Mandatory)

Examples

Copy image Copy
public void DeleteTenant()
{
string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
tenantService.DeleteTenant(tenantId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of absence of the privilege to delete the tenant
System..::..ArgumentNullException | Incase the tenant identifier value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase the any exception while deleting the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleAndTenantMapping Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleAndTenantMapping Method
ITenantService Interface See Also Send Feedback
This method is used to delete the user role and tenant mapping. Calling this API will invoke a delete of the selected role to the primary tenant of this user and also to the child tenants or stratified tenants to this user

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleAndTenantMapping(
    string userId,
    string roleId,
    string tenantIds
)
Visual Basic
Sub DeleteUserRoleAndTenantMapping (
    userId As String,
    roleId As String,
    tenantIds As String
)
Visual C++
void DeleteUserRoleAndTenantMapping(
    String^ userId,
    String^ roleId,
    String^ tenantIds
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
tenantIds
Type: System..::..String
The tenant ids.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the search value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while deleting the user role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleTenants Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleTenants Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteUserRoleTenants(String, String, String) | This method is used to delete the user role tenant mappings assigned by the role assigned tenant for the given user and role.
Public method | DeleteUserRoleTenants(String, String, array<String>[]()[][]) | This method is used to delete userRole-Tenants.
Public method | DeleteUserRoleTenants(String, array<String>[]()[][], String) | This method is used to delete the user role tenants based on the UserId, list of Roles for the given single tenant.
Public method | DeleteUserRoleTenants(String, String, array<String>[]()[][], String) | This method is used to delete the user role tenants.
Public method | DeleteUserRoleTenants(String, array<String>[]()[][], String, String) | This method is used to delete the user role tenants.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleTenants Method (String, String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleTenants Method (String, String, String)
ITenantService Interface See Also Send Feedback
This method is used to delete the user role tenant mappings assigned by the role assigned tenant for the given user and role.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleTenants(
    string userId,
    string roleId,
    string roleAssignedTenantId
)
Visual Basic
Sub DeleteUserRoleTenants (
    userId As String,
    roleId As String,
    roleAssignedTenantId As String
)
Visual C++
void DeleteUserRoleTenants(
    String^ userId,
    String^ roleId,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while deleting the user role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
DeleteUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleTenants Method (String, String, String[])

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleTenants Method (String, String, array<String>[]()[][])
ITenantService Interface See Also Send Feedback
This method is used to delete userRole-Tenants.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleTenants(
    string userId,
    string roleId,
    string[] tenantIds
)
Visual Basic
Sub DeleteUserRoleTenants (
    userId As String,
    roleId As String,
    tenantIds As String()
)
Visual C++
void DeleteUserRoleTenants(
    String^ userId,
    String^ roleId,
    array<String^>^ tenantIds
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the argument values being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while deleting the user role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
DeleteUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleTenants Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleTenants Method (String, array<String>[]()[][], String)
ITenantService Interface See Also Send Feedback
This method is used to delete the user role tenants based on the UserId, list of Roles for the given single tenant.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleTenants(
    string userId,
    string[] roleIds,
    string tenantId
)
Visual Basic
Sub DeleteUserRoleTenants (
    userId As String,
    roleIds As String(),
    tenantId As String
)
Visual C++
void DeleteUserRoleTenants(
    String^ userId,
    array<String^>^ roleIds,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the arguments value being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while deleting the user role tenant mapping

See Also

ITenantService Interface
ITenantService Members
DeleteUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleTenants Method (String, String, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleTenants Method (String, String, array<String>[]()[][], String)
ITenantService Interface See Also Send Feedback
This method is used to delete the user role tenants.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleTenants(
    string userId,
    string roleId,
    string[] tenantIds,
    string roleAssignedTenantId
)
Visual Basic
Sub DeleteUserRoleTenants (
    userId As String,
    roleId As String,
    tenantIds As String(),
    roleAssignedTenantId As String
)
Visual C++
void DeleteUserRoleTenants(
    String^ userId,
    String^ roleId,
    array<String^>^ tenantIds,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while deleting the user role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
DeleteUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.DeleteUserRoleTenants Method (String, String[], String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..DeleteUserRoleTenants Method (String, array<String>[]()[][], String, String)
ITenantService Interface See Also Send Feedback
This method is used to delete the user role tenants.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUserRoleTenants(
    string userId,
    string[] roleIds,
    string tenantId,
    string roleAssignedTenantId
)
Visual Basic
Sub DeleteUserRoleTenants (
    userId As String,
    roleIds As String(),
    tenantId As String,
    roleAssignedTenantId As String
)
Visual C++
void DeleteUserRoleTenants(
    String^ userId,
    array<String^>^ roleIds,
    String^ tenantId,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.
tenantId
Type: System..::..String
The tenant id.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while deleting the user role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
DeleteUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetAllActiveTenantDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetAllActiveTenantDetails Method
ITenantService Interface See Also Send Feedback
Get all active tenant details.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllActiveTenantDetails()
Visual Basic
Function GetAllActiveTenantDetails As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllActiveTenantDetails()

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of tenant id and tenant details

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of no privilege to access the tenant info
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetAllTenantDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetAllTenantDetails Method
ITenantService Interface Example See Also Send Feedback
Get all (Active and Inactive) tenant details.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantDetails> GetAllTenantDetails()
Visual Basic
Function GetAllTenantDetails As List(Of TenantDetails)
Visual C++
List<TenantDetails^>^ GetAllTenantDetails()

Return Value

Type: List<(Of <(<' TenantDetails >)>)>
List[TenantDetails]

Examples

Copy image Copy
public void GetAllTenantDetails()
{
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
List<TenantDetails>  tenantDetails = tenantService.GetAllTenantDetails();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of no privilege to access the tenant info
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetAllTenantInfoDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetAllTenantInfoDetails Method
ITenantService Interface Example See Also Send Feedback
Get All(Active and Inactive) tenant details

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Tenant> GetAllTenantInfoDetails()
Visual Basic
Function GetAllTenantInfoDetails As List(Of Tenant)
Visual C++
List<Tenant^>^ GetAllTenantInfoDetails()

Return Value

Type: List<(Of <(<' Tenant >)>)>
List of Active and Inactive Tenant Details

Examples

Copy image Copy
public void GetAllTenantInfoDetails()
{
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
List<Tenant> tenantDetails = tenantService.GetAllTenantInfoDetails();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of absence of the privilege to view the tenant details
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase the search value is null or empty

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetManageableTenantsForUserAssignedByTenant Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetManageableTenantsForUserAssignedByTenant Method
ITenantService Interface See Also Send Feedback
This method is used to get the manageable tenants for user assigned by tenant.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetManageableTenantsForUserAssignedByTenant(
    string userId,
    string roleAssigningTenantId
)
Visual Basic
Function GetManageableTenantsForUserAssignedByTenant (
    userId As String,
    roleAssigningTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetManageableTenantsForUserAssignedByTenant(
    String^ userId,
    String^ roleAssigningTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the arguments are null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetNumberOfTenants Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetNumberOfTenants Method
ITenantService Interface Example See Also Send Feedback
This method is used to get the number of tenant with status for the input package identifiers.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<int, int>> GetNumberOfTenants(
    string[] packageIds
)
Visual Basic
Function GetNumberOfTenants (
    packageIds As String()
) As Dictionary(Of String, Dictionary(Of Integer, Integer))
Visual C++
Dictionary<String^, Dictionary<int, int>^>^ GetNumberOfTenants(
    array<String^>^ packageIds
)

Parameters

packageIds
Type: array<System..::..String>[]()[][]
Package Identifiers(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'Int32, Int32>)>)>>)>)>
Dictionary[PackageId, Dictionary[TenantStatus, TenantCount]]

Examples

Copy image Copy
public void PermanentDeleteTenant()
{
string[] packageIds = string[] {"5A55010F-DD93-DF11-8DEB-001EC9DAB123", "A011B120-DD93-DF11-8DEB-001EC9DAB123"};
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
Dictionary<string, Dictionary<int, int>> numberofTenants = tenantService.GetNumberOfTenants(packageIds);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of absence of the privilege to get the tenant count
System..::..ArgumentNullException | Incase the package identifiers are null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant count

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetOtherTenantUserRolesByTenantAndUserId Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..GetOtherTenantUserRolesByTenantAndUserId Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetOtherTenantUserRolesByTenantAndUserId(String, String) | Get the user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(array<String>[]()[][], String) | This method is used to get the user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(String, String, String) | This method is used to get the other tenant user roles by tenant and user id.
Public method | GetOtherTenantUserRolesByTenantAndUserId(array<String>[]()[][], String, String) | This method is used to get the other tenant user roles by tenant and user id.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetOtherTenantUserRolesByTenantAndUserId Method (String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetOtherTenantUserRolesByTenantAndUserId Method (String, String)
ITenantService Interface See Also Send Feedback
Get the user roles by tenant and user id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
IEnumerable<string> GetOtherTenantUserRolesByTenantAndUserId(
    string otherTenantId,
    string userId
)
Visual Basic
Function GetOtherTenantUserRolesByTenantAndUserId (
    otherTenantId As String,
    userId As String
) As IEnumerable(Of String)
Visual C++
IEnumerable<String^>^ GetOtherTenantUserRolesByTenantAndUserId(
    String^ otherTenantId,
    String^ userId
)

Parameters

otherTenantId
Type: System..::..String
The other tenant id.
userId
Type: System..::..String
The user id.

Return Value

Type: IEnumerable<(Of <(<'String>)>)>
Enumerable Role Identifiers

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the User id or other tenant ids being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the roles

See Also

ITenantService Interface
ITenantService Members
GetOtherTenantUserRolesByTenantAndUserId Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetOtherTenantUserRolesByTenantAndUserId Method (String[], String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetOtherTenantUserRolesByTenantAndUserId Method (array<String>[]()[][], String)
ITenantService Interface See Also Send Feedback
This method is used to get the user roles by tenant and user id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
IDictionary<string, List<string>> GetOtherTenantUserRolesByTenantAndUserId(
    string[] otherTenantIds,
    string userId
)
Visual Basic
Function GetOtherTenantUserRolesByTenantAndUserId (
    otherTenantIds As String(),
    userId As String
) As IDictionary(Of String, List(Of String))
Visual C++
IDictionary<String^, List<String^>^>^ GetOtherTenantUserRolesByTenantAndUserId(
    array<String^>^ otherTenantIds,
    String^ userId
)

Parameters

otherTenantIds
Type: array<System..::..String>[]()[][]
The other tenant ids.
userId
Type: System..::..String
The user id.

Return Value

Type: IDictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
Dictionary of TenantCode and list of roles for that tenant

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the User id or other tenant ids being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while tenant wise roles

See Also

ITenantService Interface
ITenantService Members
GetOtherTenantUserRolesByTenantAndUserId Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetOtherTenantUserRolesByTenantAndUserId Method (String, String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetOtherTenantUserRolesByTenantAndUserId Method (String, String, String)
ITenantService Interface See Also Send Feedback
This method is used to get the other tenant user roles by tenant and user id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
IEnumerable<string> GetOtherTenantUserRolesByTenantAndUserId(
    string otherTenantId,
    string userId,
    string roleAssigningTenantId
)
Visual Basic
Function GetOtherTenantUserRolesByTenantAndUserId (
    otherTenantId As String,
    userId As String,
    roleAssigningTenantId As String
) As IEnumerable(Of String)
Visual C++
IEnumerable<String^>^ GetOtherTenantUserRolesByTenantAndUserId(
    String^ otherTenantId,
    String^ userId,
    String^ roleAssigningTenantId
)

Parameters

otherTenantId
Type: System..::..String
The other tenant id.
userId
Type: System..::..String
The user id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: IEnumerable<(Of <(<'String>)>)>
Ienumerable string of role identifiers

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the argument values being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the role ids

See Also

ITenantService Interface
ITenantService Members
GetOtherTenantUserRolesByTenantAndUserId Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetOtherTenantUserRolesByTenantAndUserId Method (String[], String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetOtherTenantUserRolesByTenantAndUserId Method (array<String>[]()[][], String, String)
ITenantService Interface See Also Send Feedback
This method is used to get the other tenant user roles by tenant and user id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
IDictionary<string, List<string>> GetOtherTenantUserRolesByTenantAndUserId(
    string[] otherTenantIds,
    string userId,
    string roleAssigningTenantId
)
Visual Basic
Function GetOtherTenantUserRolesByTenantAndUserId (
    otherTenantIds As String(),
    userId As String,
    roleAssigningTenantId As String
) As IDictionary(Of String, List(Of String))
Visual C++
IDictionary<String^, List<String^>^>^ GetOtherTenantUserRolesByTenantAndUserId(
    array<String^>^ otherTenantIds,
    String^ userId,
    String^ roleAssigningTenantId
)

Parameters

otherTenantIds
Type: array<System..::..String>[]()[][]
The other tenant ids.
userId
Type: System..::..String
The user id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: IDictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
Dictionary of tenant and list of roles

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant wise role details

See Also

ITenantService Interface
ITenantService Members
GetOtherTenantUserRolesByTenantAndUserId Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetRoleWiseTenantsByUserRoles Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..GetRoleWiseTenantsByUserRoles Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRoleWiseTenantsByUserRoles(String, array<String>[]()[][]) | This method is used to get list of tenant details for given userId and roleIds.
Public method | GetRoleWiseTenantsByUserRoles(String, array<String>[]()[][], String) | This method is used to get the role wise tenants by user roles for the given role assigning tenant id.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetRoleWiseTenantsByUserRoles Method (String, String[])

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetRoleWiseTenantsByUserRoles Method (String, array<String>[]()[][])
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given userId and roleIds.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, TenantDetails>> GetRoleWiseTenantsByUserRoles(
    string userId,
    string[] roleIds
)
Visual Basic
Function GetRoleWiseTenantsByUserRoles (
    userId As String,
    roleIds As String()
) As Dictionary(Of String, Dictionary(Of String, TenantDetails))
Visual C++
Dictionary<String^, Dictionary<String^, TenantDetails^>^>^ GetRoleWiseTenantsByUserRoles(
    String^ userId,
    array<String^>^ roleIds
)

Parameters

userId
Type: System..::..String
The user Identifier.
roleIds
Type: array<System..::..String>[]()[][]
Array of role identifiers.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, TenantDetails >)>)>>)>)>
Dictionary of Role wise TenantDetails

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
GetRoleWiseTenantsByUserRoles Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetRoleWiseTenantsByUserRoles Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetRoleWiseTenantsByUserRoles Method (String, array<String>[]()[][], String)
ITenantService Interface See Also Send Feedback
This method is used to get the role wise tenants by user roles for the given role assigning tenant id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, TenantDetails>> GetRoleWiseTenantsByUserRoles(
    string userId,
    string[] roleIds,
    string roleAssignedTenantId
)
Visual Basic
Function GetRoleWiseTenantsByUserRoles (
    userId As String,
    roleIds As String(),
    roleAssignedTenantId As String
) As Dictionary(Of String, Dictionary(Of String, TenantDetails))
Visual C++
Dictionary<String^, Dictionary<String^, TenantDetails^>^>^ GetRoleWiseTenantsByUserRoles(
    String^ userId,
    array<String^>^ roleIds,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, TenantDetails >)>)>>)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
GetRoleWiseTenantsByUserRoles Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetStratifiedTenantsByUser Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetStratifiedTenantsByUser Method
ITenantService Interface See Also Send Feedback
This method is used to get the tenants by user, based on the current tenant who has assigned the roles to this tenant

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetStratifiedTenantsByUser(
    string userId,
    string tenantId
)
Visual Basic
Function GetStratifiedTenantsByUser (
    userId As String,
    tenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetStratifiedTenantsByUser(
    String^ userId,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentException | Incase the user id value being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetails Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetails Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantDetails()()()() | Get only active tenant details.
Public method | GetTenantDetails(array<String>[]()[][]) | Get the tenant details for the given array of tenant identifiers

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetails Method
ITenantService Interface Example See Also Send Feedback
Get only active tenant details.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantDetails> GetTenantDetails()
Visual Basic
Function GetTenantDetails As List(Of TenantDetails)
Visual C++
List<TenantDetails^>^ GetTenantDetails()

Return Value

Type: List<(Of <(<' TenantDetails >)>)>
List of Tenant Details

Examples

Copy image Copy
public void GetTenantDetails()
{
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
List<TenantDetails>  tenantDetails = tenantService.GetTenantDetails();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of no privilege to access the tenant info
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
GetTenantDetails Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetails Method (String[])

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetails Method (array<String>[]()[][])
ITenantService Interface See Also Send Feedback
Get the tenant details for the given array of tenant identifiers

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantDetails(
    string[] tenantIds
)
Visual Basic
Function GetTenantDetails (
    tenantIds As String()
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantDetails(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of tenant id and tenant details TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
GetTenantDetails Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetailsByTenantCodeString Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetailsByTenantCodeString Method
ITenantService Interface See Also Send Feedback
This method is used to get the tenant details for given tenant code string.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantDetails GetTenantDetailsByTenantCodeString(
    string tenantCodeString
)
Visual Basic
Function GetTenantDetailsByTenantCodeString (
    tenantCodeString As String
) As TenantDetails
Visual C++
TenantDetails^ GetTenantDetailsByTenantCodeString(
    String^ tenantCodeString
)

Parameters

tenantCodeString
Type: System..::..String
The tenant code string.

Return Value

Type: TenantDetails
Tenant Details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetailsByTenantId Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetailsByTenantId Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantDetailsByTenantId(String) | Get tenant details by given tenant identifier.
Public method | GetTenantDetailsByTenantId(String, String) | This method is used to get the tenant details by tenant id.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetailsByTenantId Method (String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetailsByTenantId Method (String)
ITenantService Interface Example See Also Send Feedback
Get tenant details by given tenant identifier.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Tenant GetTenantDetailsByTenantId(
    string tenantId
)
Visual Basic
Function GetTenantDetailsByTenantId (
    tenantId As String
) As Tenant
Visual C++
Tenant^ GetTenantDetailsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: Tenant
Tenant

Examples

Copy image Copy
public void GetTenantDetailsByTenantId()
{
string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
Tenant tenant = tenantService.GetTenantDetailsByTenantId(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentException | Incase of null or empty argument tenant id
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
GetTenantDetailsByTenantId Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetailsByTenantId Method (String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetailsByTenantId Method (String, String)
ITenantService Interface See Also Send Feedback
This method is used to get the tenant details by tenant id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Tenant GetTenantDetailsByTenantId(
    string tenantId,
    string operationalTenantId
)
Visual Basic
Function GetTenantDetailsByTenantId (
    tenantId As String,
    operationalTenantId As String
) As Tenant
Visual C++
Tenant^ GetTenantDetailsByTenantId(
    String^ tenantId,
    String^ operationalTenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
operationalTenantId
Type: System..::..String
The operational tenant id.

Return Value

Type: Tenant
The Tenant

Exceptions

Exception | Condition
System..::..ArgumentException | Incase of null or empty argument tenant id
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
GetTenantDetailsByTenantId Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetailsByURL Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetailsByURL Method
ITenantService Interface Example See Also Send Feedback
Get the tenant details for the given tenant Url.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantDetails GetTenantDetailsByURL(
    string tenantUrl
)
Visual Basic
Function GetTenantDetailsByURL (
    tenantUrl As String
) As TenantDetails
Visual C++
TenantDetails^ GetTenantDetailsByURL(
    String^ tenantUrl
)

Parameters

tenantUrl
Type: System..::..String
Tenant Url(mandatory)

Return Value

Type: TenantDetails
Tenant Details

Examples

Copy image Copy
public void GetTenantDetailsByURL()
{
string url = "www.company.com";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
TenantDetails tenantDetails = tenantService.GetTenantDetailsByURL(url);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of tenant url being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantDetailsForShareUsers Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantDetailsForShareUsers Method
ITenantService Interface See Also Send Feedback
This method is used to get the required tenant informations for user sharing.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantDetailsForShareUsers(
    string[] tenantIds
)
Visual Basic
Function GetTenantDetailsForShareUsers (
    tenantIds As String()
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantDetailsForShareUsers(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of tenant id and tenant details TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantIdFromTenantCode Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantIdFromTenantCode Method
ITenantService Interface See Also Send Feedback
This method is used to get the tenant id from the give tenant code string

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetTenantIdFromTenantCode(
    string tenantCode
)
Visual Basic
Function GetTenantIdFromTenantCode (
    tenantCode As String
) As String
Visual C++
String^ GetTenantIdFromTenantCode(
    String^ tenantCode
)

Parameters

tenantCode
Type: System..::..String
tenant code string

Return Value

Type: String
tenant id (unique identifier)

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the tenant Code value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantInfoDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantInfoDetails Method
ITenantService Interface Example See Also Send Feedback
Get Active Tenant Details

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Tenant> GetTenantInfoDetails()
Visual Basic
Function GetTenantInfoDetails As List(Of Tenant)
Visual C++
List<Tenant^>^ GetTenantInfoDetails()

Return Value

Type: List<(Of <(<' Tenant >)>)>
Tenant Details

Examples

Copy image Copy
public void GetTenantInfoDetails()
{
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
List<Tenant> tenantDetails = tenantService.GetTenantInfoDetails();
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of absence of the privilege to view tenant details
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByRole Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByRole Method
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given roleId.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByRole(
    string roleId
)
Visual Basic
Function GetTenantsByRole (
    roleId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByRole(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
The role id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
dictionary of tenant id and tenant details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the role identifier value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting tenants by role

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByRoles Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByRoles Method
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given roleIds.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByRoles(
    string[] roleIds
)
Visual Basic
Function GetTenantsByRoles (
    roleIds As String()
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByRoles(
    array<String^>^ roleIds
)

Parameters

roleIds
Type: array<System..::..String>[]()[][]
The role ids.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of tenant id and tenant details

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting tenant details by roles
System..::..ArgumentException | Incase the role identifiers array value is null or empty

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUser Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUser Method
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given userId.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByUser(
    string userId
)
Visual Basic
Function GetTenantsByUser (
    userId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByUser(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user Identifier.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentException | Incase the user identifier value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRole Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRole Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantsByUserRole(String) | This method is used to get list of tenant details for given userRoleId.
Public method | GetTenantsByUserRole(String, String) | This method is used to get list of tenant details for given userId and roleId.
Public method | GetTenantsByUserRole(String, String, String) | This method is used to get the tenants by user role for the given role assigned tenant id who has assigned the role for the user

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRole Method (String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRole Method (String)
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given userRoleId.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByUserRole(
    string userRoleId
)
Visual Basic
Function GetTenantsByUserRole (
    userRoleId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByUserRole(
    String^ userRoleId
)

Parameters

userRoleId
Type: System..::..String
The user Role Identifier.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the userRoleId value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting tenants for the given user role

See Also

ITenantService Interface
ITenantService Members
GetTenantsByUserRole Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRole Method (String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRole Method (String, String)
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given userId and roleId.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByUserRole(
    string userId,
    string roleId
)
Visual Basic
Function GetTenantsByUserRole (
    userId As String,
    roleId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByUserRole(
    String^ userId,
    String^ roleId
)

Parameters

userId
Type: System..::..String
The user Identifier.
roleId
Type: System..::..String
The role Identifier.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the userId or role id value is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while getting tenant details by user and role

See Also

ITenantService Interface
ITenantService Members
GetTenantsByUserRole Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRole Method (String, String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRole Method (String, String, String)
ITenantService Interface See Also Send Feedback
This method is used to get the tenants by user role for the given role assigned tenant id who has assigned the role for the user

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByUserRole(
    string userId,
    string roleId,
    string roleAssignedTenantId
)
Visual Basic
Function GetTenantsByUserRole (
    userId As String,
    roleId As String,
    roleAssignedTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByUserRole(
    String^ userId,
    String^ roleId,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of tenant id and tenant details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
GetTenantsByUserRole Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRoles Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRoles Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantsByUserRoles(String, array<String>[]()[][]) | This method is used to get list of tenant details for given userId and roleIds.
Public method | GetTenantsByUserRoles(String, array<String>[]()[][], String) | This method is used to get the tenants which can be managed by the given user and roles belonging to this tenant id.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRoles Method (String, String[])

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRoles Method (String, array<String>[]()[][])
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for given userId and roleIds.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByUserRoles(
    string userId,
    string[] roleIds
)
Visual Basic
Function GetTenantsByUserRoles (
    userId As String,
    roleIds As String()
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByUserRoles(
    String^ userId,
    array<String^>^ roleIds
)

Parameters

userId
Type: System..::..String
The user Identifier.
roleIds
Type: array<System..::..String>[]()[][]
Array of role identifiers.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the user id value being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching tenants by user id and roles

See Also

ITenantService Interface
ITenantService Members
GetTenantsByUserRoles Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsByUserRoles Method (String, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsByUserRoles Method (String, array<String>[]()[][], String)
ITenantService Interface See Also Send Feedback
This method is used to get the tenants which can be managed by the given user and roles belonging to this tenant id.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsByUserRoles(
    string userId,
    string[] roleIds,
    string roleAssignedTenantId
)
Visual Basic
Function GetTenantsByUserRoles (
    userId As String,
    roleIds As String(),
    roleAssignedTenantId As String
) As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsByUserRoles(
    String^ userId,
    array<String^>^ roleIds,
    String^ roleAssignedTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleIds
Type: array<System..::..String>[]()[][]
The role ids.
roleAssignedTenantId
Type: System..::..String
The role assigned tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
dictionary of tenant id and tenant details

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
GetTenantsByUserRoles Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsForCurrentUser Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsForCurrentUser Method
ITenantService Interface See Also Send Feedback
This method is used to get list of tenant details for current logged in user.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsForCurrentUser()
Visual Basic
Function GetTenantsForCurrentUser As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsForCurrentUser()

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the Tenant Details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.GetTenantsInTrial Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..GetTenantsInTrial Method
ITenantService Interface See Also Send Feedback
Returns all trial tenants for the current logged in tenant. Only immediate child tenants are considered.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetTenantsInTrial()
Visual Basic
Function GetTenantsInTrial As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetTenantsInTrial()

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.InsertUserRoleTenantMapping Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..InsertUserRoleTenantMapping Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertUserRoleTenantMapping(String, String, String) | This method is used to insert the user role tenant mapping.
Public method | InsertUserRoleTenantMapping(String, String, String, String) | This method is used to insert the user role tenant mapping for the assigning tenant id

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.InsertUserRoleTenantMapping Method (String, String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..InsertUserRoleTenantMapping Method (String, String, String)
ITenantService Interface See Also Send Feedback
This method is used to insert the user role tenant mapping.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InsertUserRoleTenantMapping(
    string userId,
    string roleId,
    string tenantId
)
Visual Basic
Function InsertUserRoleTenantMapping (
    userId As String,
    roleId As String,
    tenantId As String
) As String
Visual C++
String^ InsertUserRoleTenantMapping(
    String^ userId,
    String^ roleId,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
User Role Tenant Identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the argument values being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while inserting the user role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
InsertUserRoleTenantMapping Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.InsertUserRoleTenantMapping Method (String, String, String, String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..InsertUserRoleTenantMapping Method (String, String, String, String)
ITenantService Interface See Also Send Feedback
This method is used to insert the user role tenant mapping for the assigning tenant id

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string InsertUserRoleTenantMapping(
    string userId,
    string roleId,
    string stratifiedTenantId,
    string roleAssigningTenantId
)
Visual Basic
Function InsertUserRoleTenantMapping (
    userId As String,
    roleId As String,
    stratifiedTenantId As String,
    roleAssigningTenantId As String
) As String
Visual C++
String^ InsertUserRoleTenantMapping(
    String^ userId,
    String^ roleId,
    String^ stratifiedTenantId,
    String^ roleAssigningTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
stratifiedTenantId
Type: System..::..String
The stratified tenant id.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Return Value

Type: String
UserRoleTenant Identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty argument
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while inserting the user role and tenant mapping details

See Also

ITenantService Interface
ITenantService Members
InsertUserRoleTenantMapping Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.PermanentDeleteTenant Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..PermanentDeleteTenant Method
ITenantService Interface Example See Also Send Feedback
This method is used to delete the tenant details.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteTenant(
    string tenantId
)
Visual Basic
Sub PermanentDeleteTenant (
    tenantId As String
)
Visual C++
void PermanentDeleteTenant(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Id(Mandatory)

Examples

Copy image Copy
public void PermanentDeleteTenant()
{
string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
tenantService.PermanentDeleteTenant(tenantId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase the any other exception while deleting the tenant details
System..::..ArgumentNullException | Incase the tenant id value is null or empty
System..::..UnauthorizedAccessException | Incase of absence of the privilege

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.ProvisionTenant Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..ProvisionTenant Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ProvisionTenant(Tenant, TenantLicense) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenant(Tenant, TenantLicense, TenantSettingsTemplate) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.
Public method | ProvisionTenant(TenantDetails, Address, ContactDetails, User, MembershipDetails, TenantLicense) | This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.ProvisionTenant Method (Tenant, TenantLicense)

[image]

A Sandcastle Documented Class Library
ITenantService..::..ProvisionTenant Method (Tenant, TenantLicense)
ITenantService Interface Example See Also Send Feedback
This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ProvisionTenant(
    Tenant tenant,
    TenantLicense tenantLicense
)
Visual Basic
Function ProvisionTenant (
    tenant As Tenant,
    tenantLicense As TenantLicense
) As String
Visual C++
String^ ProvisionTenant(
    Tenant^ tenant,
    TenantLicense^ tenantLicense
)

Parameters

tenant
Type: CelloSaaS.Model.TenantManagement..::..Tenant
Tenant Details
tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License details(Mandatory)

Return Value

Type: String
Tenant Code

Examples

Copy image Copy
public void ProvisionTenant()
{
Tenant tenant = new Tenant();
TenantDetails tenantDetails = new TenantDetails();
TenantLicense tenantlicense = new TenantLicense();
tenantDetails.TenantCodeString = "Company";
tenantDetails.Description = "Company";
tenantDetails.TenantName = "Company";
tenantDetails.Website = "www.company.com";
tenantDetails.URL = "www.company.com";
Address address = new Address();
address.Address1 = "Address1";
address.City = "City";
address.State = "State";
address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3";
address.PostalCode = "620003";
ContactDetails contactDetails = new ContactDetails();
contactDetails.Email = "admin@company.com";
contactDetails.Fax = "044272281";
contactDetails.FirstName = "Admin";
contactDetails.LastName = "Company";
contactDetails.Phone = "044272281";
User user = new User();
user.FirstName = "Company";
user.LastName = "Admin";
MembershipDetails membershipDetails = new MembershipDetails();
membershipDetails.UserName = "admin@company.com";
tenantlicense.NumberOfUsers = 150;
tenantlicense.PackageId = "5A55010F-DD93-DF11-8DEB-001EC9DAB123";
tenant.TenantDetails = tenantDetails;
tenant.Address = address;
tenant.ContactDetails = contactDetails
tenant.TenantAdminUserdetail = user;
tenant.TenantAdminMembershipdetail = membershipDetails;
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
string tenantCode = tenantService.ProvisionTenant(tenant, tenantlicense);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException | Throws Invalid TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException | Throws Invalid URL Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException | Throws Invalid Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException | Throws Invalid Email Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Throws Tenant Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException | Throws Duplicate TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException | Throws Duplicate TenantName Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException | Throws Duplicate Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException | Throws Duplicate URL Exception

See Also

ITenantService Interface
ITenantService Members
ProvisionTenant Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.ProvisionTenant Method (Tenant, TenantLicense, TenantSettingsTemplate)

[image]

A Sandcastle Documented Class Library
ITenantService..::..ProvisionTenant Method (Tenant, TenantLicense, TenantSettingsTemplate)
ITenantService Interface See Also Send Feedback
This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ProvisionTenant(
    Tenant tenant,
    TenantLicense tenantLicense,
    TenantSettingsTemplate tenantSettingsTemplate
)
Visual Basic
Function ProvisionTenant (
    tenant As Tenant,
    tenantLicense As TenantLicense,
    tenantSettingsTemplate As TenantSettingsTemplate
) As String
Visual C++
String^ ProvisionTenant(
    Tenant^ tenant,
    TenantLicense^ tenantLicense,
    TenantSettingsTemplate^ tenantSettingsTemplate
)

Parameters

tenant
Type: CelloSaaS.Model.TenantManagement..::..Tenant
The tenant.
tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
The tenant license.
tenantSettingsTemplate
Type: CelloSaaS.Model.SettingsManagement..::..TenantSettingsTemplate
The tenant settings template.

Return Value

Type: String
Created tenant identifier [Tenant_Code]

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException | Throws Invalid TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException | Throws Invalid URL Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException | Throws Invalid Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException | Throws Invalid Email Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Throws Tenant Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException | Throws Duplicate TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException | Throws Duplicate TenantName Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException | Throws Duplicate Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException | Throws Duplicate URL Exception

See Also

ITenantService Interface
ITenantService Members
ProvisionTenant Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.ProvisionTenant Method (TenantDetails, Address, ContactDetails, User, MembershipDetails, TenantLicense)

[image]

A Sandcastle Documented Class Library
ITenantService..::..ProvisionTenant Method (TenantDetails, Address, ContactDetails, User, MembershipDetails, TenantLicense)
ITenantService Interface Example See Also Send Feedback
This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ProvisionTenant(
    TenantDetails tenantDetails,
    Address address,
    ContactDetails contactDetails,
    User tenantAdminUserDetail,
    MembershipDetails tenantAdminMembershipDetail,
    TenantLicense tenantLicense
)
Visual Basic
Function ProvisionTenant (
    tenantDetails As TenantDetails,
    address As Address,
    contactDetails As ContactDetails,
    tenantAdminUserDetail As User,
    tenantAdminMembershipDetail As MembershipDetails,
    tenantLicense As TenantLicense
) As String
Visual C++
String^ ProvisionTenant(
    TenantDetails^ tenantDetails,
    Address^ address,
    ContactDetails^ contactDetails,
    User^ tenantAdminUserDetail,
    MembershipDetails^ tenantAdminMembershipDetail,
    TenantLicense^ tenantLicense
)

Parameters

tenantDetails
Type: CelloSaaS.Model.TenantManagement..::..TenantDetails
Tenant Details(Mandatory)
address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address Details
contactDetails
Type: CelloSaaS.Model.TenantManagement..::..ContactDetails
Contact details
tenantAdminUserDetail
Type: CelloSaaS.Model.UserManagement..::..User
User details(Mandatory)
tenantAdminMembershipDetail
Type: CelloSaaS.Model.UserManagement..::..MembershipDetails
Membership details(Mandatory)
tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License details(Mandatory)

Return Value

Type: String
Tenant Code

Examples

Copy image Copy
public void ProvisionTenant()
{
TenantDetails tenantDetails = new TenantDetails();
TenantLicense tenantlicense = new TenantLicense();
tenantDetails.TenantCodeString = "Company";
tenantDetails.Description = "Company";
tenantDetails.TenantName = "Company";
tenantDetails.Website = "www.company.com";
tenantDetails.URL = "www.company.com";
Address address = new Address();
address.Address1 = "Address1";
address.City = "City";
address.State = "State";
address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3";
address.PostalCode = "620003";
ContactDetails contactDetails = new ContactDetails();
contactDetails.Email = "admin@company.com";
contactDetails.Fax = "044272281";
contactDetails.FirstName = "Admin";
contactDetails.LastName = "Company";
contactDetails.Phone = "044272281";
User user = new User();
user.FirstName = "Company";
user.LastName = "Admin";
MembershipDetails membershipDetails = new MembershipDetails();
membershipDetails.UserName = "admin@company.com";
tenantlicense.NumberOfUsers = 150;
tenantlicense.PackageId = "5A55010F-DD93-DF11-8DEB-001EC9DAB123";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
string tenantCode = tenantService.ProvisionTenant(tenantDetails, address, contactDetails, user, membershipDetails, tenantlicense);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException | Throws Invalid TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException | Throws Invalid URL Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException | Throws Invalid Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException | Throws Invalid Email Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Throws Tenant Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException | Throws Duplicate TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException | Throws Duplicate TenantName Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException | Throws Duplicate Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException | Throws Duplicate URL Exception

See Also

ITenantService Interface
ITenantService Members
ProvisionTenant Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.ProvisionTenantWithConnString Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..ProvisionTenantWithConnString Method
ITenantService Interface See Also Send Feedback
This method is used to add tenant details. After tenant added successfully, the followin email will be sent 1. Tenant Activation Mail - If self registered containing the activation link 2. Tenant Welcome Mail - If admin added tenant and if the self reg. tenant activates the account by clicking the link.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ProvisionTenantWithConnString(
    Tenant tenant,
    TenantLicense tenantLicense,
    string userConnectionString = null
)
Visual Basic
Function ProvisionTenantWithConnString (
    tenant As Tenant,
    tenantLicense As TenantLicense,
    Optional userConnectionString As String = Nothing
) As String
Visual C++
String^ ProvisionTenantWithConnString(
    Tenant^ tenant,
    TenantLicense^ tenantLicense,
    String^ userConnectionString = nullptr
)

Parameters

tenant
Type: CelloSaaS.Model.TenantManagement..::..Tenant
Tenant Details
tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License details(Mandatory)
userConnectionString (Optional)
Type: System..::..String
User Connection string for the given tenant

Return Value

Type: String
Tenant Code

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException | Throws Invalid TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException | Throws Invalid URL Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException | Throws Invalid Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException | Throws Invalid Email Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Throws Tenant Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException | Throws Duplicate TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException | Throws Duplicate TenantName Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException | Throws Duplicate Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException | Throws Duplicate URL Exception

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.SearchAllTenantDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..SearchAllTenantDetails Method
ITenantService Interface Example See Also Send Feedback
Get all(active and inactive) tenant details by search string as input.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Tenant> SearchAllTenantDetails(
    string searchValue
)
Visual Basic
Function SearchAllTenantDetails (
    searchValue As String
) As List(Of Tenant)
Visual C++
List<Tenant^>^ SearchAllTenantDetails(
    String^ searchValue
)

Parameters

searchValue
Type: System..::..String
Search Value

Return Value

Type: List<(Of <(<' Tenant >)>)>
Active and Inactive Tenant Details

Examples

Copy image Copy
public void SearchAllTenantDetails()
{
string searchValue = "a";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
List<Tenant> tenantDetails = tenantService.SearchAllTenantDetails(searchValue);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of absence of the privilege to view tenant details
System..::..ArgumentException | Incase the search value is null or empty

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.SearchTenantDetails Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..SearchTenantDetails Method
ITenantService Interface Example See Also Send Feedback
Search tenant details by search condition.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TenantDetailsSearchResult SearchTenantDetails(
    TenantDetailsSearchCondition condition
)
Visual Basic
Function SearchTenantDetails (
    condition As TenantDetailsSearchCondition
) As TenantDetailsSearchResult
Visual C++
TenantDetailsSearchResult^ SearchTenantDetails(
    TenantDetailsSearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.Model.TenantManagement..::..TenantDetailsSearchCondition
Search condition

Return Value

Type: TenantDetailsSearchResult
search Tenant Details

Examples

Copy image Copy
public void SearchTenantDetails()
{
string searchValue = "a";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
List<Tenant> tenantDetails = tenantService.SearchTenantDetails(searchValue);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | Incase of no privilege to access the tenant details
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while fetching the tenant details

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateApprovalStatus Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateApprovalStatus Method
ITenantService Interface See Also Send Feedback
This method is used to update the approval status for the given tenant.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateApprovalStatus(
    string tenantId,
    string approvalStatus
)
Visual Basic
Sub UpdateApprovalStatus (
    tenantId As String,
    approvalStatus As String
)
Visual C++
void UpdateApprovalStatus(
    String^ tenantId,
    String^ approvalStatus
)

Parameters

tenantId
Type: System..::..String
The tenant id.
approvalStatus
Type: System..::..String
The approval status.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception. If any mandatory argument is null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while updating tenant approval status

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateRoleTenants Method

[image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateRoleTenants Method
ITenantService Interface See Also Send Feedback
This method is used to update role-tenants.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRoleTenants(
    string roleId,
    string[] tenantIds
)
Visual Basic
Sub UpdateRoleTenants (
    roleId As String,
    tenantIds As String()
)
Visual C++
void UpdateRoleTenants(
    String^ roleId,
    array<String^>^ tenantIds
)

Parameters

roleId
Type: System..::..String
The role id.
tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the role id or tenant identifiers being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while updating role tenants

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateTenantInfo Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateTenantInfo Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateTenantInfo(Tenant, TenantLicense) | Update the tenant details.
Public method | UpdateTenantInfo(TenantDetails, Address, ContactDetails, TenantLicense) | Update the tenant details.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateTenantInfo Method (Tenant, TenantLicense)

[image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateTenantInfo Method (Tenant, TenantLicense)
ITenantService Interface Example See Also Send Feedback
Update the tenant details.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateTenantInfo(
    Tenant tenant,
    TenantLicense tenantLicense
)
Visual Basic
Function UpdateTenantInfo (
    tenant As Tenant,
    tenantLicense As TenantLicense
) As String
Visual C++
String^ UpdateTenantInfo(
    Tenant^ tenant,
    TenantLicense^ tenantLicense
)

Parameters

tenant
Type: CelloSaaS.Model.TenantManagement..::..Tenant
Tenant Details(Mandatory)
tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License Details(Mandatory)

Return Value

Type: String
Tenant Code

Examples

Copy image Copy
public void UpdateTenantInfo()
{
Tenant tenant = new Tenant();
TenantDetails tenantDetails = new TenantDetails();
TenantLicense tenantlicense = new TenantLicense();
tenantDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
tenantDetails.Description = "Company";
tenantDetails.TenantName = "Company";
tenantDetails.Website = "www.company.com";
tenantDetails.URL = "www.company.com";
Address address = new Address();
address.Address1 = "Address1";
address.City = "City";
address.State = "State";
address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3";
address.PostalCode = "620003";
ContactDetails contactDetails = new ContactDetails();
contactDetails.Email = "admin@company.com";
contactDetails.Fax = "044272281";
contactDetails.FirstName = "Admin";
contactDetails.LastName = "Company";
contactDetails.Phone = "044272281";
User user = new User();
user.FirstName = "Company";
user.LastName = "Admin";
MembershipDetails membershipDetails = new MembershipDetails();
membershipDetails.UserName = "admin@company.com";
tenantlicense.NumberOfUsers = 150;
tenantlicense.PackageId = "5A55010F-DD93-DF11-8DEB-001EC9DAB123";
tenant.TenantDetails = tenantDetails;
tenant.Address = address;
tenant.ContactDetails = contactDetails
tenant.TenantAdminUserdetail = user;
tenant.TenantAdminMembershipdetail = membershipDetails;
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
string tenantCode = tenantService.UpdateTenantInfo(tenant, tenantlicense);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException | Throws Invalid TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException | Throws Invalid URL Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException | Throws Invalid Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException | Throws Invalid Email Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Throws Tenant Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException | Throws Duplicate TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException | Throws Duplicate TenantName Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException | Throws Duplicate Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException | Throws Duplicate URL Exception

See Also

ITenantService Interface
ITenantService Members
UpdateTenantInfo Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateTenantInfo Method (TenantDetails, Address, ContactDetails, TenantLicense)

[image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateTenantInfo Method (TenantDetails, Address, ContactDetails, TenantLicense)
ITenantService Interface Example See Also Send Feedback
Update the tenant details.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateTenantInfo(
    TenantDetails tenantDetails,
    Address address,
    ContactDetails contactDetails,
    TenantLicense tenantLicense
)
Visual Basic
Function UpdateTenantInfo (
    tenantDetails As TenantDetails,
    address As Address,
    contactDetails As ContactDetails,
    tenantLicense As TenantLicense
) As String
Visual C++
String^ UpdateTenantInfo(
    TenantDetails^ tenantDetails,
    Address^ address,
    ContactDetails^ contactDetails,
    TenantLicense^ tenantLicense
)

Parameters

tenantDetails
Type: CelloSaaS.Model.TenantManagement..::..TenantDetails
Tenant Details(Mandatory)
address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address Details
contactDetails
Type: CelloSaaS.Model.TenantManagement..::..ContactDetails
Contact Details
tenantLicense
Type: CelloSaaS.Model.LicenseManagement..::..TenantLicense
Tenant License Details(Mandatory)

Return Value

Type: String
Tenant Code

Examples

Copy image Copy
public void UpdateTenantInfo()
{
TenantDetails tenantDetails = new TenantDetails();
TenantLicense tenantlicense = new TenantLicense();
tenantDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
tenantDetails.Description = "Company";
tenantDetails.TenantName = "Company";
tenantDetails.Website = "www.company.com";
tenantDetails.URL = "www.company.com";
Address address = new Address();
address.Address1 = "Address1";
address.City = "City";
address.State = "State";
address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3";
address.PostalCode = "620003";
ContactDetails contactDetails = new ContactDetails();
contactDetails.Email = "admin@company.com";
contactDetails.Fax = "044272281";
contactDetails.FirstName = "Admin";
contactDetails.LastName = "Company";
contactDetails.Phone = "044272281";
User user = new User();
user.FirstName = "Company";
user.LastName = "Admin";
MembershipDetails membershipDetails = new MembershipDetails();
membershipDetails.UserName = "admin@company.com";
tenantlicense.NumberOfUsers = 150;
tenantlicense.PackageId = "5A55010F-DD93-DF11-8DEB-001EC9DAB123";
ITenantService tenantService = (ITenantService)ServiceLocator.GetServiceImplementation(typeof(ITenantService));
string tenantCode = tenantService.UpdateTenantInfo(tenantDetails, address, contactDetails, user, membershipDetails, tenantlicense);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws Argument Null Exception
System..::..ArgumentException | Throws Argument Exception
System..::..UnauthorizedAccessException | Throws Unauthorized Access Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidTenantCodeException | Throws Invalid TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidURLException | Throws Invalid URL Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidWebsiteException | Throws Invalid Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..InvalidEmailException | Throws Invalid Email Exception
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Throws Tenant Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantCodeException | Throws Duplicate TenantCode Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateTenantNameException | Throws Duplicate TenantName Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateWebsiteException | Throws Duplicate Website Exception
CelloSaaS.ServiceContracts.TenantManagement..::..DuplicateURLException | Throws Duplicate URL Exception

See Also

ITenantService Interface
ITenantService Members
UpdateTenantInfo Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateUserRoleTenants Method

[image] [image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateUserRoleTenants Method
ITenantService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateUserRoleTenants(String, String, array<String>[]()[][]) | This method is used to update userRole-Tenants.
Public method | UpdateUserRoleTenants(String, String, array<String>[]()[][], String) | This method is used to update the user role tenants.

See Also

ITenantService Interface
ITenantService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateUserRoleTenants Method (String, String, String[])

[image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateUserRoleTenants Method (String, String, array<String>[]()[][])
ITenantService Interface See Also Send Feedback
This method is used to update userRole-Tenants.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserRoleTenants(
    string userId,
    string roleId,
    string[] tenantIds
)
Visual Basic
Sub UpdateUserRoleTenants (
    userId As String,
    roleId As String,
    tenantIds As String()
)
Visual C++
void UpdateUserRoleTenants(
    String^ userId,
    String^ roleId,
    array<String^>^ tenantIds
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
tenantIds
Type: array<System..::..String>[]()[][]
The tenant ids.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase the argument values being null or empty
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while updating the user, role and tenant mapping

See Also

ITenantService Interface
ITenantService Members
UpdateUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantService.UpdateUserRoleTenants Method (String, String, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantService..::..UpdateUserRoleTenants Method (String, String, array<String>[]()[][], String)
ITenantService Interface See Also Send Feedback
This method is used to update the user role tenants.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateUserRoleTenants(
    string userId,
    string roleId,
    string[] stratifiedTenantIds,
    string roleAssigningTenantId
)
Visual Basic
Sub UpdateUserRoleTenants (
    userId As String,
    roleId As String,
    stratifiedTenantIds As String(),
    roleAssigningTenantId As String
)
Visual C++
void UpdateUserRoleTenants(
    String^ userId,
    String^ roleId,
    array<String^>^ stratifiedTenantIds,
    String^ roleAssigningTenantId
)

Parameters

userId
Type: System..::..String
The user id.
roleId
Type: System..::..String
The role id.
stratifiedTenantIds
Type: array<System..::..String>[]()[][]
The stratified tenant ids.
roleAssigningTenantId
Type: System..::..String
The role assigning tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Incase of null or empty arguments
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException | Incase of any exception while mapping the user role and tenant

See Also

ITenantService Interface
ITenantService Members
UpdateUserRoleTenants Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService Interface

[image]

A Sandcastle Documented Class Library
ITenantTypesService Interface
Members See Also Send Feedback
Interface for tenant types service

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantTypesService
Visual Basic
Public Interface ITenantTypesService
Visual C++
public interface class ITenantTypesService

See Also

ITenantTypesService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantTypesService Members
ITenantTypesService Interface Methods See Also Send Feedback

The ITenantTypesService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteTenantTypesFromTenant | This method is used to delete the tenant types from tenant.
Public method | GetTenantTypes()()()() | This method is used to retrieve all the tenant types from the database
Public method | GetTenantTypes(String) | This method is used to retrieve tenant types for the given tenant id
Public method | MapTenantTypesToTenant | This method used to map the tenant types to the tenant

See Also

ITenantTypesService Interface
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantTypesService Methods
ITenantTypesService Interface See Also Send Feedback

The ITenantTypesService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteTenantTypesFromTenant | This method is used to delete the tenant types from tenant.
Public method | GetTenantTypes()()()() | This method is used to retrieve all the tenant types from the database
Public method | GetTenantTypes(String) | This method is used to retrieve tenant types for the given tenant id
Public method | MapTenantTypesToTenant | This method used to map the tenant types to the tenant

See Also

ITenantTypesService Interface
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService.DeleteTenantTypesFromTenant Method

[image]

A Sandcastle Documented Class Library
ITenantTypesService..::..DeleteTenantTypesFromTenant Method
ITenantTypesService Interface See Also Send Feedback
This method is used to delete the tenant types from tenant.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTenantTypesFromTenant(
    string tenantCode
)
Visual Basic
Sub DeleteTenantTypesFromTenant (
    tenantCode As String
)
Visual C++
void DeleteTenantTypesFromTenant(
    String^ tenantCode
)

Parameters

tenantCode
Type: System..::..String
The tenant code.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantTypesException | Throws Tenant Types Exception

See Also

ITenantTypesService Interface
ITenantTypesService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService.GetTenantTypes Method

[image] [image]

A Sandcastle Documented Class Library
ITenantTypesService..::..GetTenantTypes Method
ITenantTypesService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTenantTypes()()()() | This method is used to retrieve all the tenant types from the database
Public method | GetTenantTypes(String) | This method is used to retrieve tenant types for the given tenant id

See Also

ITenantTypesService Interface
ITenantTypesService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService.GetTenantTypes Method

[image]

A Sandcastle Documented Class Library
ITenantTypesService..::..GetTenantTypes Method
ITenantTypesService Interface See Also Send Feedback
This method is used to retrieve all the tenant types from the database

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantType> GetTenantTypes()
Visual Basic
Function GetTenantTypes As List(Of TenantType)
Visual C++
List<TenantType^>^ GetTenantTypes()

Return Value

Type: List<(Of <(<' TenantType >)>)>
List of Tenant Type

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantTypesException | Throws Tenant Types Exception. Probably DbException

See Also

ITenantTypesService Interface
ITenantTypesService Members
GetTenantTypes Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService.GetTenantTypes Method (String)

[image]

A Sandcastle Documented Class Library
ITenantTypesService..::..GetTenantTypes Method (String)
ITenantTypesService Interface See Also Send Feedback
This method is used to retrieve tenant types for the given tenant id

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<TenantType> GetTenantTypes(
    string tenantId
)
Visual Basic
Function GetTenantTypes (
    tenantId As String
) As List(Of TenantType)
Visual C++
List<TenantType^>^ GetTenantTypes(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
tenant id to look for

Return Value

Type: List<(Of <(<' TenantType >)>)>
list of tenant types belonging to tenant id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantTypesException | Throws Tenant Types Exception

See Also

ITenantTypesService Interface
ITenantTypesService Members
GetTenantTypes Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


ITenantTypesService.MapTenantTypesToTenant Method

[image]

A Sandcastle Documented Class Library
ITenantTypesService..::..MapTenantTypesToTenant Method
ITenantTypesService Interface See Also Send Feedback
This method used to map the tenant types to the tenant

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void MapTenantTypesToTenant(
    string tenantCode,
    string[] tenantTypes
)
Visual Basic
Sub MapTenantTypesToTenant (
    tenantCode As String,
    tenantTypes As String()
)
Visual C++
void MapTenantTypesToTenant(
    String^ tenantCode,
    array<String^>^ tenantTypes
)

Parameters

tenantCode
Type: System..::..String
tenant identifier
tenantTypes
Type: array<System..::..String>[]()[][]
array of tenant types id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.TenantManagement..::..TenantTypesException | Throws Tenant Types Exception

See Also

ITenantTypesService Interface
ITenantTypesService Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Class

[image]

A Sandcastle Documented Class Library
TenantActivationException Class
Members See Also Send Feedback
Tenant Activation Exception class

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantActivationException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantActivationException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantActivationException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..TenantActivationException

See Also

TenantActivationException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Members

[image] [image]

A Sandcastle Documented Class Library
TenantActivationException Members
TenantActivationException Class Constructors Methods Properties Events See Also Send Feedback

The TenantActivationException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantActivationException()()()() | Initializes a new instance of the TenantActivationException class.
Public method | TenantActivationException(String) | Initializes a new instance of the TenantActivationException class.
Protected method | TenantActivationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantActivationException class.
Public method | TenantActivationException(String, Exception) | Initializes a new instance of the TenantActivationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantActivationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Constructor

[image] [image]

A Sandcastle Documented Class Library
TenantActivationException Constructor
TenantActivationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TenantActivationException()()()() | Initializes a new instance of the TenantActivationException class.
Public method | TenantActivationException(String) | Initializes a new instance of the TenantActivationException class.
Protected method | TenantActivationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantActivationException class.
Public method | TenantActivationException(String, Exception) | Initializes a new instance of the TenantActivationException class.

See Also

TenantActivationException Class
TenantActivationException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Constructor

[image]

A Sandcastle Documented Class Library
TenantActivationException Constructor
TenantActivationException Class See Also Send Feedback
Initializes a new instance of the TenantActivationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationException()
Visual Basic
Public Sub New
Visual C++
public:
TenantActivationException()

See Also

TenantActivationException Class
TenantActivationException Members
TenantActivationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Constructor (String)

[image]

A Sandcastle Documented Class Library
TenantActivationException Constructor (String)
TenantActivationException Class See Also Send Feedback
Initializes a new instance of the TenantActivationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TenantActivationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TenantActivationException Class
TenantActivationException Members
TenantActivationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TenantActivationException Constructor (SerializationInfo, StreamingContext)
TenantActivationException Class See Also Send Feedback
Initializes a new instance of the TenantActivationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TenantActivationException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
TenantActivationException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

TenantActivationException Class
TenantActivationException Members
TenantActivationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TenantActivationException Constructor (String, Exception)
TenantActivationException Class See Also Send Feedback
Initializes a new instance of the TenantActivationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantActivationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantActivationException Class
TenantActivationException Members
TenantActivationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantActivationException Methods
TenantActivationException Class See Also Send Feedback

The TenantActivationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantActivationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantActivationException Properties
TenantActivationException Class See Also Send Feedback

The TenantActivationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantActivationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationException Events

[image] [image]

A Sandcastle Documented Class Library
TenantActivationException Events
TenantActivationException Class See Also Send Feedback

The TenantActivationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantActivationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Class

[image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Class
Members See Also Send Feedback
Tenant ActivationKey Expired Exception class

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantActivationKeyExpiredException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantActivationKeyExpiredException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantActivationKeyExpiredException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..TenantActivationKeyExpiredException

See Also

TenantActivationKeyExpiredException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Members

[image] [image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Members
TenantActivationKeyExpiredException Class Constructors Methods Properties Events See Also Send Feedback

The TenantActivationKeyExpiredException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantActivationKeyExpiredException()()()() | Initializes a new instance of the TenantActivationKeyExpiredException class.
Public method | TenantActivationKeyExpiredException(String) | Initializes a new instance of the TenantActivationKeyExpiredException class.
Protected method | TenantActivationKeyExpiredException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantActivationKeyExpiredException class.
Public method | TenantActivationKeyExpiredException(String, Exception) | Initializes a new instance of the TenantActivationKeyExpiredException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantActivationKeyExpiredException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Constructor

[image] [image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Constructor
TenantActivationKeyExpiredException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TenantActivationKeyExpiredException()()()() | Initializes a new instance of the TenantActivationKeyExpiredException class.
Public method | TenantActivationKeyExpiredException(String) | Initializes a new instance of the TenantActivationKeyExpiredException class.
Protected method | TenantActivationKeyExpiredException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantActivationKeyExpiredException class.
Public method | TenantActivationKeyExpiredException(String, Exception) | Initializes a new instance of the TenantActivationKeyExpiredException class.

See Also

TenantActivationKeyExpiredException Class
TenantActivationKeyExpiredException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Constructor

[image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Constructor
TenantActivationKeyExpiredException Class See Also Send Feedback
Initializes a new instance of the TenantActivationKeyExpiredException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationKeyExpiredException()
Visual Basic
Public Sub New
Visual C++
public:
TenantActivationKeyExpiredException()

See Also

TenantActivationKeyExpiredException Class
TenantActivationKeyExpiredException Members
TenantActivationKeyExpiredException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Constructor (String)

[image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Constructor (String)
TenantActivationKeyExpiredException Class See Also Send Feedback
Initializes a new instance of the TenantActivationKeyExpiredException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationKeyExpiredException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TenantActivationKeyExpiredException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TenantActivationKeyExpiredException Class
TenantActivationKeyExpiredException Members
TenantActivationKeyExpiredException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Constructor (SerializationInfo, StreamingContext)
TenantActivationKeyExpiredException Class See Also Send Feedback
Initializes a new instance of the TenantActivationKeyExpiredException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TenantActivationKeyExpiredException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
TenantActivationKeyExpiredException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

TenantActivationKeyExpiredException Class
TenantActivationKeyExpiredException Members
TenantActivationKeyExpiredException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Constructor (String, Exception)
TenantActivationKeyExpiredException Class See Also Send Feedback
Initializes a new instance of the TenantActivationKeyExpiredException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantActivationKeyExpiredException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantActivationKeyExpiredException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantActivationKeyExpiredException Class
TenantActivationKeyExpiredException Members
TenantActivationKeyExpiredException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Methods
TenantActivationKeyExpiredException Class See Also Send Feedback

The TenantActivationKeyExpiredException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantActivationKeyExpiredException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Properties
TenantActivationKeyExpiredException Class See Also Send Feedback

The TenantActivationKeyExpiredException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantActivationKeyExpiredException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantActivationKeyExpiredException Events

[image] [image]

A Sandcastle Documented Class Library
TenantActivationKeyExpiredException Events
TenantActivationKeyExpiredException Class See Also Send Feedback

The TenantActivationKeyExpiredException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantActivationKeyExpiredException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Class

[image]

A Sandcastle Documented Class Library
TenantException Class
Members See Also Send Feedback
Tenant Exception class

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..TenantException

See Also

TenantException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Members

[image] [image]

A Sandcastle Documented Class Library
TenantException Members
TenantException Class Constructors Methods Properties Events See Also Send Feedback

The TenantException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantException()()()() | Initializes a new instance of the TenantException class.
Public method | TenantException(String) | Initializes a new instance of the TenantException class.
Protected method | TenantException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantException class.
Public method | TenantException(String, Exception) | Initializes a new instance of the TenantException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Constructor

[image] [image]

A Sandcastle Documented Class Library
TenantException Constructor
TenantException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TenantException()()()() | Initializes a new instance of the TenantException class.
Public method | TenantException(String) | Initializes a new instance of the TenantException class.
Protected method | TenantException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantException class.
Public method | TenantException(String, Exception) | Initializes a new instance of the TenantException class.

See Also

TenantException Class
TenantException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Constructor

[image]

A Sandcastle Documented Class Library
TenantException Constructor
TenantException Class See Also Send Feedback
Initializes a new instance of the TenantException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantException()
Visual Basic
Public Sub New
Visual C++
public:
TenantException()

See Also

TenantException Class
TenantException Members
TenantException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Constructor (String)

[image]

A Sandcastle Documented Class Library
TenantException Constructor (String)
TenantException Class See Also Send Feedback
Initializes a new instance of the TenantException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TenantException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TenantException Class
TenantException Members
TenantException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TenantException Constructor (SerializationInfo, StreamingContext)
TenantException Class See Also Send Feedback
Initializes a new instance of the TenantException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TenantException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
TenantException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

TenantException Class
TenantException Members
TenantException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TenantException Constructor (String, Exception)
TenantException Class See Also Send Feedback
Initializes a new instance of the TenantException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantException Class
TenantException Members
TenantException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantException Methods
TenantException Class See Also Send Feedback

The TenantException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantException Properties
TenantException Class See Also Send Feedback

The TenantException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantException Events

[image] [image]

A Sandcastle Documented Class Library
TenantException Events
TenantException Class See Also Send Feedback

The TenantException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Class

[image]

A Sandcastle Documented Class Library
TenantRelationException Class
Members See Also Send Feedback
Tenant Relation Exception class

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantRelationException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantRelationException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantRelationException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..TenantRelationException

See Also

TenantRelationException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Members

[image] [image]

A Sandcastle Documented Class Library
TenantRelationException Members
TenantRelationException Class Constructors Methods Properties Events See Also Send Feedback

The TenantRelationException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantRelationException()()()() | Initializes a new instance of the TenantRelationException class.
Public method | TenantRelationException(String) | Initializes a new instance of the TenantRelationException class.
Protected method | TenantRelationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantRelationException class.
Public method | TenantRelationException(String, Exception) | Initializes a new instance of the TenantException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Constructor

[image] [image]

A Sandcastle Documented Class Library
TenantRelationException Constructor
TenantRelationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TenantRelationException()()()() | Initializes a new instance of the TenantRelationException class.
Public method | TenantRelationException(String) | Initializes a new instance of the TenantRelationException class.
Protected method | TenantRelationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantRelationException class.
Public method | TenantRelationException(String, Exception) | Initializes a new instance of the TenantException class.

See Also

TenantRelationException Class
TenantRelationException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Constructor

[image]

A Sandcastle Documented Class Library
TenantRelationException Constructor
TenantRelationException Class See Also Send Feedback
Initializes a new instance of the TenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelationException()
Visual Basic
Public Sub New
Visual C++
public:
TenantRelationException()

See Also

TenantRelationException Class
TenantRelationException Members
TenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Constructor (String)

[image]

A Sandcastle Documented Class Library
TenantRelationException Constructor (String)
TenantRelationException Class See Also Send Feedback
Initializes a new instance of the TenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TenantRelationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TenantRelationException Class
TenantRelationException Members
TenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TenantRelationException Constructor (SerializationInfo, StreamingContext)
TenantRelationException Class See Also Send Feedback
Initializes a new instance of the TenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TenantRelationException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
TenantRelationException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

TenantRelationException Class
TenantRelationException Members
TenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TenantRelationException Constructor (String, Exception)
TenantRelationException Class See Also Send Feedback
Initializes a new instance of the TenantException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantRelationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantRelationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantRelationException Class
TenantRelationException Members
TenantRelationException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantRelationException Methods
TenantRelationException Class See Also Send Feedback

The TenantRelationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantRelationException Properties
TenantRelationException Class See Also Send Feedback

The TenantRelationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantRelationException Events

[image] [image]

A Sandcastle Documented Class Library
TenantRelationException Events
TenantRelationException Class See Also Send Feedback

The TenantRelationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantRelationException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Class

[image]

A Sandcastle Documented Class Library
TenantTypesException Class
Members See Also Send Feedback
Tenant Types Exception class

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantTypesException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantTypesException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantTypesException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.TenantManagement..::..TenantTypesException

See Also

TenantTypesException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Members

[image] [image]

A Sandcastle Documented Class Library
TenantTypesException Members
TenantTypesException Class Constructors Methods Properties Events See Also Send Feedback

The TenantTypesException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantTypesException()()()() | Initializes a new instance of the TenantRelationException class.
Public method | TenantTypesException(String) | Initializes a new instance of the TenantRelationException class.
Protected method | TenantTypesException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantRelationException class.
Public method | TenantTypesException(String, Exception) | Initializes a new instance of the TenantException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantTypesException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Constructor

[image] [image]

A Sandcastle Documented Class Library
TenantTypesException Constructor
TenantTypesException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TenantTypesException()()()() | Initializes a new instance of the TenantRelationException class.
Public method | TenantTypesException(String) | Initializes a new instance of the TenantRelationException class.
Protected method | TenantTypesException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantRelationException class.
Public method | TenantTypesException(String, Exception) | Initializes a new instance of the TenantException class.

See Also

TenantTypesException Class
TenantTypesException Members
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Constructor

[image]

A Sandcastle Documented Class Library
TenantTypesException Constructor
TenantTypesException Class See Also Send Feedback
Initializes a new instance of the TenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantTypesException()
Visual Basic
Public Sub New
Visual C++
public:
TenantTypesException()

See Also

TenantTypesException Class
TenantTypesException Members
TenantTypesException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Constructor (String)

[image]

A Sandcastle Documented Class Library
TenantTypesException Constructor (String)
TenantTypesException Class See Also Send Feedback
Initializes a new instance of the TenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantTypesException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TenantTypesException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TenantTypesException Class
TenantTypesException Members
TenantTypesException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TenantTypesException Constructor (SerializationInfo, StreamingContext)
TenantTypesException Class See Also Send Feedback
Initializes a new instance of the TenantRelationException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TenantTypesException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Protected Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
protected:
TenantTypesException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

TenantTypesException Class
TenantTypesException Members
TenantTypesException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TenantTypesException Constructor (String, Exception)
TenantTypesException Class See Also Send Feedback
Initializes a new instance of the TenantException class.

Namespace: CelloSaaS.ServiceContracts.TenantManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantTypesException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantTypesException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantTypesException Class
TenantTypesException Members
TenantTypesException Overload
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantTypesException Methods
TenantTypesException Class See Also Send Feedback

The TenantTypesException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantTypesException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantTypesException Properties
TenantTypesException Class See Also Send Feedback

The TenantTypesException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantTypesException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


TenantTypesException Events

[image] [image]

A Sandcastle Documented Class Library
TenantTypesException Events
TenantTypesException Class See Also Send Feedback

The TenantTypesException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantTypesException Class
CelloSaaS.ServiceContracts.TenantManagement Namespace


CelloSaaS.ServiceContracts.Tracking Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.Tracking Namespace
Send Feedback

Classes

 | Class | Description
Public class | TrackingException | Tracking Exception class

Interfaces

 | Interface | Description
Public interface | ITrackingService | This interface defines the methods for the tracking.


ITrackingService Interface

[image]

A Sandcastle Documented Class Library
ITrackingService Interface
Members See Also Send Feedback
This interface defines the methods for the tracking.

Namespace: CelloSaaS.ServiceContracts.Tracking
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITrackingService
Visual Basic
Public Interface ITrackingService
Visual C++
public interface class ITrackingService

See Also

ITrackingService Members
CelloSaaS.ServiceContracts.Tracking Namespace


ITrackingService Members

[image] [image]

A Sandcastle Documented Class Library
ITrackingService Members
ITrackingService Interface Methods See Also Send Feedback

The ITrackingService type exposes the following members.

Methods

 | Name | Description
Public method | GetChanges | This method is used to get changes details for entity reference Also get changes details for entity between particular dates.
Public method | SaveChanges | This method is used to save changes details

See Also

ITrackingService Interface
CelloSaaS.ServiceContracts.Tracking Namespace


ITrackingService Methods

[image] [image]

A Sandcastle Documented Class Library
ITrackingService Methods
ITrackingService Interface See Also Send Feedback

The ITrackingService type exposes the following members.

Methods

 | Name | Description
Public method | GetChanges | This method is used to get changes details for entity reference Also get changes details for entity between particular dates.
Public method | SaveChanges | This method is used to save changes details

See Also

ITrackingService Interface
CelloSaaS.ServiceContracts.Tracking Namespace


ITrackingService.GetChanges Method

[image]

A Sandcastle Documented Class Library
ITrackingService..::..GetChanges Method
ITrackingService Interface Example See Also Send Feedback
This method is used to get changes details for entity reference Also get changes details for entity between particular dates.

Namespace: CelloSaaS.ServiceContracts.Tracking
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Changes[] GetChanges(
    string entityName,
    string entityReference,
    DateTime startDate,
    DateTime endDate
)
Visual Basic
Function GetChanges (
    entityName As String,
    entityReference As String,
    startDate As DateTime,
    endDate As DateTime
) As Changes()
Visual C++
array<Changes^>^ GetChanges(
    String^ entityName,
    String^ entityReference,
    DateTime startDate,
    DateTime endDate
)

Parameters

entityName
Type: System..::..String
Entity Name(Mandatory)
entityReference
Type: System..::..String
Entity Reference Identifier(Mandatory)
startDate
Type: System..::..DateTime
Changes From Date
endDate
Type: System..::..DateTime
Changes To Date

Return Value

Type: array<Changes>[]()[][]
Changes Details

Examples

Copy image Copy
public Changes[] GetChanges()
{
    string entityName = "User";
    string entityReference = "711A41B2-EB93-DF11-8DEB-001EC9DAB123";
    ITrackingService trackingService = (ITrackingService)ServiceLocator.GetServiceImplementation(typeof(ITrackingService));
    return trackingService.GetChanges(entityName,entityReference,null,null);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Tracking..::..TrackingException | This exception is thrown while fetching changes details
System..::..ArgumentNullException | This exception is thrown when entity name or entityreference is null or empty

See Also

ITrackingService Interface
ITrackingService Members
CelloSaaS.ServiceContracts.Tracking Namespace


ITrackingService.SaveChanges Method

[image]

A Sandcastle Documented Class Library
ITrackingService..::..SaveChanges Method
ITrackingService Interface Example See Also Send Feedback
This method is used to save changes details

Namespace: CelloSaaS.ServiceContracts.Tracking
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveChanges(
    string entityName,
    string entityReference,
    Changes changes
)
Visual Basic
Sub SaveChanges (
    entityName As String,
    entityReference As String,
    changes As Changes
)
Visual C++
void SaveChanges(
    String^ entityName,
    String^ entityReference,
    Changes^ changes
)

Parameters

entityName
Type: System..::..String
Entity Name(Mandatory)
entityReference
Type: System..::..String
Entity Reference Identifier(Mandatory)
changes
Type: Changes
Change details(Mandatory)

Examples

Copy image Copy
public void SaveChanges()
{
    string entityName = "User";
    string entityReference = "711A41B2-EB93-DF11-8DEB-001EC9DAB123";
    User baseline = null;
    User delta = null;
    User current = null;
    Dictionary<string, ChangeStatus> changeSet = new Dictionary<string, ChangeStatus>();
    Changes changes = new Changes();
    changes.Baseline = baseline;
    changes.Delta = delta;
    changes.Current = current;
    changes.ChangeSet = changeSet;
    ITrackingService trackingService = (ITrackingService)ServiceLocator.GetServiceImplementation(typeof(ITrackingService));
    trackingService.SaveChanges(entityName,entityReference,changes);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.Tracking..::..TrackingException | This exception is thrown while saving changes details
System..::..ArgumentNullException | This exception is thrown when entity name or entityreference is null or empty
System..::..ArgumentException | This exception is thrown when chages is null or empty

See Also

ITrackingService Interface
ITrackingService Members
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Class

[image]

A Sandcastle Documented Class Library
TrackingException Class
Members See Also Send Feedback
Tracking Exception class

Namespace: CelloSaaS.ServiceContracts.Tracking
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TrackingException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TrackingException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TrackingException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.Tracking..::..TrackingException

See Also

TrackingException Members
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Members

[image] [image]

A Sandcastle Documented Class Library
TrackingException Members
TrackingException Class Constructors Methods Properties Events See Also Send Feedback

The TrackingException type exposes the following members.

Constructors

 | Name | Description
Public method | TrackingException()()()() | Initializes a new instance of the TrackingException class.
Public method | TrackingException(String, Exception) | Initializes a new instance of the TrackingException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TrackingException Class
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Constructor

[image] [image]

A Sandcastle Documented Class Library
TrackingException Constructor
TrackingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrackingException()()()() | Initializes a new instance of the TrackingException class.
Public method | TrackingException(String, Exception) | Initializes a new instance of the TrackingException class.

See Also

TrackingException Class
TrackingException Members
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Constructor

[image]

A Sandcastle Documented Class Library
TrackingException Constructor
TrackingException Class See Also Send Feedback
Initializes a new instance of the TrackingException class.

Namespace: CelloSaaS.ServiceContracts.Tracking
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TrackingException()
Visual Basic
Public Sub New
Visual C++
public:
TrackingException()

See Also

TrackingException Class
TrackingException Members
TrackingException Overload
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TrackingException Constructor (String, Exception)
TrackingException Class See Also Send Feedback
Initializes a new instance of the TrackingException class.

Namespace: CelloSaaS.ServiceContracts.Tracking
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TrackingException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TrackingException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TrackingException Class
TrackingException Members
TrackingException Overload
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Methods

[image] [image]

A Sandcastle Documented Class Library
TrackingException Methods
TrackingException Class See Also Send Feedback

The TrackingException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TrackingException Class
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Properties

[image] [image]

A Sandcastle Documented Class Library
TrackingException Properties
TrackingException Class See Also Send Feedback

The TrackingException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TrackingException Class
CelloSaaS.ServiceContracts.Tracking Namespace


TrackingException Events

[image] [image]

A Sandcastle Documented Class Library
TrackingException Events
TrackingException Class See Also Send Feedback

The TrackingException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TrackingException Class
CelloSaaS.ServiceContracts.Tracking Namespace


CelloSaaS.ServiceContracts.UserManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.UserManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | DuplicateEmailIDException | This exception is used to catch duplicate email id
Public class | DuplicateUserNameException | This exception is used to catch duplicate user name
Public class | InvalidEmailIDException | This exception is used to catch invalid email id
Public class | InvalidUserNameException | This exception is used to catch invalid user name
Public class | LicenseLimitException | This exception used to catch user count exceed for tenant
Public class | MembershipConstants | Contains User Membership Constants
Public class | SendMailException | This exception is used to catch failure mail sending
Public class | TenantUserAssociationException | Incase of any exception while fetching the Tenant User Association
Public class | UserActivityException | This exception is thrown in the event of any issues that arise when handling the User Activity
Public class | UserDeactivateException | This exception is used to catch when user exceed password failure attempts
Public class | UserDetailException | UserDetail Exception
Public class | UserLockedOutException | This exception is used to catch when user exceed password failure attempts
Public class | UserPasswordExpirationException | This is to raise the password expiration exception, due to the password expiry after a finite amount of time.
Public class | UserPasswordPenultimateFailureAttempt | This exception is used to inform the controller that on next password failure attempt the user will be locked out

Interfaces

 | Interface | Description
Public interface | IMembershipService | Membership service interface
Public interface | IPasswordValidationService | Password Validation Plugin Interface
Public interface | ITenantUserAssociationService | Tenant user association service
Public interface | IUserActivityService | User Activity Service
Public interface | IUserDetailsService | User Details Service Interface


DuplicateEmailIDException Class

[image]

A Sandcastle Documented Class Library
DuplicateEmailIDException Class
Members See Also Send Feedback
This exception is used to catch duplicate email id

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateEmailIDException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateEmailIDException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateEmailIDException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..DuplicateEmailIDException

See Also

DuplicateEmailIDException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateEmailIDException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateEmailIDException Members
DuplicateEmailIDException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateEmailIDException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateEmailIDException | Initializes a new instance of the DuplicateEmailIDException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateEmailIDException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateEmailIDException Constructor
DuplicateEmailIDException Class See Also Send Feedback
Initializes a new instance of the DuplicateEmailIDException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateEmailIDException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateEmailIDException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateEmailIDException Class
DuplicateEmailIDException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateEmailIDException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateEmailIDException Methods
DuplicateEmailIDException Class See Also Send Feedback

The DuplicateEmailIDException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateEmailIDException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateEmailIDException Properties
DuplicateEmailIDException Class See Also Send Feedback

The DuplicateEmailIDException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateEmailIDException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateEmailIDException Events
DuplicateEmailIDException Class See Also Send Feedback

The DuplicateEmailIDException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateUserNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateUserNameException Class
Members See Also Send Feedback
This exception is used to catch duplicate user name

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateUserNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class DuplicateUserNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class DuplicateUserNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..DuplicateUserNameException

See Also

DuplicateUserNameException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateUserNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateUserNameException Members
DuplicateUserNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateUserNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateUserNameException | Initializes a new instance of the DuplicateUserNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateUserNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateUserNameException Constructor
DuplicateUserNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateUserNameException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateUserNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateUserNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateUserNameException Class
DuplicateUserNameException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateUserNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateUserNameException Methods
DuplicateUserNameException Class See Also Send Feedback

The DuplicateUserNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateUserNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateUserNameException Properties
DuplicateUserNameException Class See Also Send Feedback

The DuplicateUserNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


DuplicateUserNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateUserNameException Events
DuplicateUserNameException Class See Also Send Feedback

The DuplicateUserNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


IMembershipService Interface

[image]

A Sandcastle Documented Class Library
IMembershipService Interface
Members See Also Send Feedback
Membership service interface

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IMembershipService
Visual Basic
Public Interface IMembershipService
Visual C++
public interface class IMembershipService

See Also

IMembershipService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IMembershipService Members

[image] [image]

A Sandcastle Documented Class Library
IMembershipService Members
IMembershipService Interface Methods See Also Send Feedback

The IMembershipService type exposes the following members.

Methods

 | Name | Description
Public method | GetMembershipDetails | This method is used to gets the membership details.
Public method | GetMembershipDetailsForValidate | This methodd is used to gets the membership details for validate.

See Also

IMembershipService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IMembershipService Methods

[image] [image]

A Sandcastle Documented Class Library
IMembershipService Methods
IMembershipService Interface See Also Send Feedback

The IMembershipService type exposes the following members.

Methods

 | Name | Description
Public method | GetMembershipDetails | This method is used to gets the membership details.
Public method | GetMembershipDetailsForValidate | This methodd is used to gets the membership details for validate.

See Also

IMembershipService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IMembershipService.GetMembershipDetails Method

[image]

A Sandcastle Documented Class Library
IMembershipService..::..GetMembershipDetails Method
IMembershipService Interface See Also Send Feedback
This method is used to gets the membership details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
MembershipDetails GetMembershipDetails(
    string userName,
    string tenantId
)
Visual Basic
Function GetMembershipDetails (
    userName As String,
    tenantId As String
) As MembershipDetails
Visual C++
MembershipDetails^ GetMembershipDetails(
    String^ userName,
    String^ tenantId
)

Parameters

userName
Type: System..::..String
Name of the user.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: MembershipDetails
Membershipdetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | If user name or tenant id is null or empty.

See Also

IMembershipService Interface
IMembershipService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IMembershipService.GetMembershipDetailsForValidate Method

[image]

A Sandcastle Documented Class Library
IMembershipService..::..GetMembershipDetailsForValidate Method
IMembershipService Interface See Also Send Feedback
This methodd is used to gets the membership details for validate.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
MembershipDetails GetMembershipDetailsForValidate(
    string userName,
    string tenantId
)
Visual Basic
Function GetMembershipDetailsForValidate (
    userName As String,
    tenantId As String
) As MembershipDetails
Visual C++
MembershipDetails^ GetMembershipDetailsForValidate(
    String^ userName,
    String^ tenantId
)

Parameters

userName
Type: System..::..String
Name of the user.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: MembershipDetails
Membershipdetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | If user name or tenant id is null or empty.

See Also

IMembershipService Interface
IMembershipService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidEmailIDException Class

[image]

A Sandcastle Documented Class Library
InvalidEmailIDException Class
Members See Also Send Feedback
This exception is used to catch invalid email id

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidEmailIDException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidEmailIDException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidEmailIDException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..InvalidEmailIDException

See Also

InvalidEmailIDException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidEmailIDException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailIDException Members
InvalidEmailIDException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidEmailIDException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidEmailIDException | Initializes a new instance of the InvalidEmailIDException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidEmailIDException Constructor

[image]

A Sandcastle Documented Class Library
InvalidEmailIDException Constructor
InvalidEmailIDException Class See Also Send Feedback
Initializes a new instance of the InvalidEmailIDException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidEmailIDException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidEmailIDException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidEmailIDException Class
InvalidEmailIDException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidEmailIDException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailIDException Methods
InvalidEmailIDException Class See Also Send Feedback

The InvalidEmailIDException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidEmailIDException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailIDException Properties
InvalidEmailIDException Class See Also Send Feedback

The InvalidEmailIDException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidEmailIDException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidEmailIDException Events
InvalidEmailIDException Class See Also Send Feedback

The InvalidEmailIDException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidEmailIDException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidUserNameException Class

[image]

A Sandcastle Documented Class Library
InvalidUserNameException Class
Members See Also Send Feedback
This exception is used to catch invalid user name

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InvalidUserNameException : BaseException
Visual Basic
<SerializableAttribute>
Public Class InvalidUserNameException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class InvalidUserNameException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException

See Also

InvalidUserNameException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidUserNameException Members

[image] [image]

A Sandcastle Documented Class Library
InvalidUserNameException Members
InvalidUserNameException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidUserNameException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidUserNameException | Initializes a new instance of the InvalidUserNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidUserNameException Constructor

[image]

A Sandcastle Documented Class Library
InvalidUserNameException Constructor
InvalidUserNameException Class See Also Send Feedback
Initializes a new instance of the InvalidUserNameException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InvalidUserNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
InvalidUserNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

InvalidUserNameException Class
InvalidUserNameException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidUserNameException Methods

[image] [image]

A Sandcastle Documented Class Library
InvalidUserNameException Methods
InvalidUserNameException Class See Also Send Feedback

The InvalidUserNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidUserNameException Properties

[image] [image]

A Sandcastle Documented Class Library
InvalidUserNameException Properties
InvalidUserNameException Class See Also Send Feedback

The InvalidUserNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


InvalidUserNameException Events

[image] [image]

A Sandcastle Documented Class Library
InvalidUserNameException Events
InvalidUserNameException Class See Also Send Feedback

The InvalidUserNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidUserNameException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


IPasswordValidationService Interface

[image]

A Sandcastle Documented Class Library
IPasswordValidationService Interface
Members See Also Send Feedback
Password Validation Plugin Interface

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IPasswordValidationService
Visual Basic
Public Interface IPasswordValidationService
Visual C++
public interface class IPasswordValidationService

See Also

IPasswordValidationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IPasswordValidationService Members

[image] [image]

A Sandcastle Documented Class Library
IPasswordValidationService Members
IPasswordValidationService Interface Methods See Also Send Feedback

The IPasswordValidationService type exposes the following members.

Methods

 | Name | Description
Public method | ValidatePassword | This method is used to validate the user password according to the criteria
Public method | ValidateUserPassword | This method is used to validate the user password according to the criteria

See Also

IPasswordValidationService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IPasswordValidationService Methods

[image] [image]

A Sandcastle Documented Class Library
IPasswordValidationService Methods
IPasswordValidationService Interface See Also Send Feedback

The IPasswordValidationService type exposes the following members.

Methods

 | Name | Description
Public method | ValidatePassword | This method is used to validate the user password according to the criteria
Public method | ValidateUserPassword | This method is used to validate the user password according to the criteria

See Also

IPasswordValidationService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IPasswordValidationService.ValidatePassword Method

[image]

A Sandcastle Documented Class Library
IPasswordValidationService..::..ValidatePassword Method
IPasswordValidationService Interface See Also Send Feedback
This method is used to validate the user password according to the criteria

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PasswordValidationStatus ValidatePassword(
    string password
)
Visual Basic
Function ValidatePassword (
    password As String
) As PasswordValidationStatus
Visual C++
PasswordValidationStatus^ ValidatePassword(
    String^ password
)

Parameters

password
Type: System..::..String
Password 1

Return Value

Type: PasswordValidationStatus
true : if the passwords are valid false : if the passwords are not valid

Exceptions

Exception | Condition
System..::..ArgumentNullException | If the password is null or empth

See Also

IPasswordValidationService Interface
IPasswordValidationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IPasswordValidationService.ValidateUserPassword Method

[image]

A Sandcastle Documented Class Library
IPasswordValidationService..::..ValidateUserPassword Method
IPasswordValidationService Interface See Also Send Feedback
This method is used to validate the user password according to the criteria

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
PasswordValidationStatus ValidateUserPassword(
    string newPassword,
    string confirmPassword
)
Visual Basic
Function ValidateUserPassword (
    newPassword As String,
    confirmPassword As String
) As PasswordValidationStatus
Visual C++
PasswordValidationStatus^ ValidateUserPassword(
    String^ newPassword,
    String^ confirmPassword
)

Parameters

newPassword
Type: System..::..String
Password 1
confirmPassword
Type: System..::..String
Password 2

Return Value

Type: PasswordValidationStatus
true : if the passwords are valid false : if the passwords are not valid

Exceptions

Exception | Condition
System..::..ArgumentNullException | If the new password or confirm passwod values are null

See Also

IPasswordValidationService Interface
IPasswordValidationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService Interface

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService Interface
Members See Also Send Feedback
Tenant user association service

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITenantUserAssociationService
Visual Basic
Public Interface ITenantUserAssociationService
Visual C++
public interface class ITenantUserAssociationService

See Also

ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService Members

[image] [image]

A Sandcastle Documented Class Library
ITenantUserAssociationService Members
ITenantUserAssociationService Interface Methods See Also Send Feedback

The ITenantUserAssociationService type exposes the following members.

Methods

 | Name | Description
Public method | CanLinkWithOtherTenants | This method is used to determine whether this the specified tenant id can link with other tenant user.
Public method | CheckLinkExists | This method is used to check whether there exists a link between the user and the tenant for the given status.
Public method | GetAllLinkableTenantDetails()()()() | This method is used to gets all the tenant details, which has enabled the property called can linked with other tenant users.
Public method | GetAllLinkableTenantDetails(String) | This method gets all the linked tenant details for the userId.
Public method | GetAllLinkedTenantUsers | This method gets all the linked users details for the tenantId.
Public method | GetLinkedTenantsDetails | This method gets the linked tenant's details for that user id and the request status. we can get approved tenants 's details from this method
Public method | GetLinkedTenantUserDetails | This method is used to get the linked tenant user details.
Public method | GetLinkedTenantUsers | This method gets the linked users details for that tenant id and the request status. we can get approved users details from this method
Public method | GetLinkedTenantUsersByStatus | This method gets the linked users details for that tenant id and the request status. we can get approved users details from this method
Public method | GetLinkedUserCount(String, RequestStatus) | This method is used to get the Total user count for the given tenant
Public method | GetLinkedUserCount(array<String>[]()[][], RequestStatus) | This method is used to get the Total user count for the given tenants
Public method | IsLinkedByOtherTenant | This method is used to determine whether this the specified tenant id can link with other tenant user.
Public method | LinkOtherTenant | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | LinkOtherTenantUser(LinkedTenantUsers, String) | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | LinkOtherTenantUser(LinkedTenantUsers, array<String>[]()[][], String) | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | RemoveLinkedTenantUser | This method is used to removes the linked tenant user details.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers) | This method is used to approve or reject the requests. It can be a tenant approval or the user approval.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, String) | This method is used to approve or reject the requests. It can be a tenant approval or the user approval.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, array<String>[]()[][]) | This method is used to update the linked tenants user.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, array<String>[]()[][], String) | This method is used to update the linked tenants user.
Public method | UpdateLinkedTenantsUserStatus | This method is used change the status of the record. we can deactivate that details.

See Also

ITenantUserAssociationService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService Methods

[image] [image]

A Sandcastle Documented Class Library
ITenantUserAssociationService Methods
ITenantUserAssociationService Interface See Also Send Feedback

The ITenantUserAssociationService type exposes the following members.

Methods

 | Name | Description
Public method | CanLinkWithOtherTenants | This method is used to determine whether this the specified tenant id can link with other tenant user.
Public method | CheckLinkExists | This method is used to check whether there exists a link between the user and the tenant for the given status.
Public method | GetAllLinkableTenantDetails()()()() | This method is used to gets all the tenant details, which has enabled the property called can linked with other tenant users.
Public method | GetAllLinkableTenantDetails(String) | This method gets all the linked tenant details for the userId.
Public method | GetAllLinkedTenantUsers | This method gets all the linked users details for the tenantId.
Public method | GetLinkedTenantsDetails | This method gets the linked tenant's details for that user id and the request status. we can get approved tenants 's details from this method
Public method | GetLinkedTenantUserDetails | This method is used to get the linked tenant user details.
Public method | GetLinkedTenantUsers | This method gets the linked users details for that tenant id and the request status. we can get approved users details from this method
Public method | GetLinkedTenantUsersByStatus | This method gets the linked users details for that tenant id and the request status. we can get approved users details from this method
Public method | GetLinkedUserCount(String, RequestStatus) | This method is used to get the Total user count for the given tenant
Public method | GetLinkedUserCount(array<String>[]()[][], RequestStatus) | This method is used to get the Total user count for the given tenants
Public method | IsLinkedByOtherTenant | This method is used to determine whether this the specified tenant id can link with other tenant user.
Public method | LinkOtherTenant | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | LinkOtherTenantUser(LinkedTenantUsers, String) | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | LinkOtherTenantUser(LinkedTenantUsers, array<String>[]()[][], String) | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | RemoveLinkedTenantUser | This method is used to removes the linked tenant user details.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers) | This method is used to approve or reject the requests. It can be a tenant approval or the user approval.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, String) | This method is used to approve or reject the requests. It can be a tenant approval or the user approval.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, array<String>[]()[][]) | This method is used to update the linked tenants user.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, array<String>[]()[][], String) | This method is used to update the linked tenants user.
Public method | UpdateLinkedTenantsUserStatus | This method is used change the status of the record. we can deactivate that details.

See Also

ITenantUserAssociationService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.CanLinkWithOtherTenants Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..CanLinkWithOtherTenants Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to determine whether this the specified tenant id can link with other tenant user.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CanLinkWithOtherTenants(
    string tenantId
)
Visual Basic
Function CanLinkWithOtherTenants (
    tenantId As String
) As Boolean
Visual C++
bool CanLinkWithOtherTenants(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean
true if this instance [can link with other tenants] the specified tenant id; otherwise, false.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Throws TenantUserAssociationException

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.CheckLinkExists Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..CheckLinkExists Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to check whether there exists a link between the user and the tenant for the given status.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckLinkExists(
    string userId,
    string tenantId,
    RequestStatus requestStatus
)
Visual Basic
Function CheckLinkExists (
    userId As String,
    tenantId As String,
    requestStatus As RequestStatus
) As Boolean
Visual C++
bool CheckLinkExists(
    String^ userId,
    String^ tenantId,
    RequestStatus requestStatus
)

Parameters

userId
Type: System..::..String
The user id.
tenantId
Type: System..::..String
The tenant id.
requestStatus
Type: CelloSaaS.Model.UserManagement..::..RequestStatus
The request status.

Return Value

Type: Boolean
True if a link with the given status already exists otherwise

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while fetching the link status for user and tenant with status

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetAllLinkableTenantDetails Method

[image] [image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetAllLinkableTenantDetails Method
ITenantUserAssociationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAllLinkableTenantDetails()()()() | This method is used to gets all the tenant details, which has enabled the property called can linked with other tenant users.
Public method | GetAllLinkableTenantDetails(String) | This method gets all the linked tenant details for the userId.

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetAllLinkableTenantDetails Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetAllLinkableTenantDetails Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to gets all the tenant details, which has enabled the property called can linked with other tenant users.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TenantDetails> GetAllLinkableTenantDetails()
Visual Basic
Function GetAllLinkableTenantDetails As Dictionary(Of String, TenantDetails)
Visual C++
Dictionary<String^, TenantDetails^>^ GetAllLinkableTenantDetails()

Return Value

Type: Dictionary<(Of <(<'String, TenantDetails >)>)>
Dictionary of TenantDetails

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while fetching all the linkable tenant details

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
GetAllLinkableTenantDetails Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetAllLinkableTenantDetails Method (String)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetAllLinkableTenantDetails Method (String)
ITenantUserAssociationService Interface See Also Send Feedback
This method gets all the linked tenant details for the userId.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, LinkedTenantUsers> GetAllLinkableTenantDetails(
    string userId
)
Visual Basic
Function GetAllLinkableTenantDetails (
    userId As String
) As Dictionary(Of String, LinkedTenantUsers)
Visual C++
Dictionary<String^, LinkedTenantUsers^>^ GetAllLinkableTenantDetails(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Dictionary<(Of <(<'String, LinkedTenantUsers >)>)>
Dictionary of LinkedTenantUsers LinkedTenantUsers

Exceptions

Exception | Condition
System..::..ArgumentNullException | If user id is null or empty then ArgumentNullException will be thrown.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while getting all the linkable tenants

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
GetAllLinkableTenantDetails Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetAllLinkedTenantUsers Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetAllLinkedTenantUsers Method
ITenantUserAssociationService Interface See Also Send Feedback
This method gets all the linked users details for the tenantId.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, LinkedTenantUsers> GetAllLinkedTenantUsers(
    string tenantId
)
Visual Basic
Function GetAllLinkedTenantUsers (
    tenantId As String
) As Dictionary(Of String, LinkedTenantUsers)
Visual C++
Dictionary<String^, LinkedTenantUsers^>^ GetAllLinkedTenantUsers(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, LinkedTenantUsers >)>)>
Dictionary of LinkedTenantUsers LinkedTenantUsers

Exceptions

Exception | Condition
System..::..ArgumentNullException | If tenant id is null or empty then ArgumentNullException will be thrown
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | If exception occurs TenantUserAssociationException will be thrown.

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedTenantsDetails Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedTenantsDetails Method
ITenantUserAssociationService Interface See Also Send Feedback
This method gets the linked tenant's details for that user id and the request status. we can get approved tenants 's details from this method

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, LinkedTenantUsers> GetLinkedTenantsDetails(
    string userId,
    RequestStatus requestStatus
)
Visual Basic
Function GetLinkedTenantsDetails (
    userId As String,
    requestStatus As RequestStatus
) As Dictionary(Of String, LinkedTenantUsers)
Visual C++
Dictionary<String^, LinkedTenantUsers^>^ GetLinkedTenantsDetails(
    String^ userId,
    RequestStatus requestStatus
)

Parameters

userId
Type: System..::..String
The user id.
requestStatus
Type: CelloSaaS.Model.UserManagement..::..RequestStatus
The request status.

Return Value

Type: Dictionary<(Of <(<'String, LinkedTenantUsers >)>)>
Dictionary of LinkedTenantUsers LinkedTenantUsers

Exceptions

Exception | Condition
System..::..ArgumentNullException | If userId is null or empty then ArgumentNullException will be thrown.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while fetching the linked tenant details

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedTenantUserDetails Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedTenantUserDetails Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to get the linked tenant user details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
LinkedTenantUsers GetLinkedTenantUserDetails(
    string linkedTenantUserId
)
Visual Basic
Function GetLinkedTenantUserDetails (
    linkedTenantUserId As String
) As LinkedTenantUsers
Visual C++
LinkedTenantUsers^ GetLinkedTenantUserDetails(
    String^ linkedTenantUserId
)

Parameters

linkedTenantUserId
Type: System..::..String
The linked tenant user id.

Return Value

Type: LinkedTenantUsers
LinkedTenantUsers LinkedTenantUsers

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If linkedTenantUserId is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while fetching the tenant user association

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedTenantUsers Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedTenantUsers Method
ITenantUserAssociationService Interface See Also Send Feedback
This method gets the linked users details for that tenant id and the request status. we can get approved users details from this method

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, LinkedTenantUsers> GetLinkedTenantUsers(
    string tenantId,
    RequestStatus requestStatus
)
Visual Basic
Function GetLinkedTenantUsers (
    tenantId As String,
    requestStatus As RequestStatus
) As Dictionary(Of String, LinkedTenantUsers)
Visual C++
Dictionary<String^, LinkedTenantUsers^>^ GetLinkedTenantUsers(
    String^ tenantId,
    RequestStatus requestStatus
)

Parameters

tenantId
Type: System..::..String
The tenant id.
requestStatus
Type: CelloSaaS.Model.UserManagement..::..RequestStatus
The request status.

Return Value

Type: Dictionary<(Of <(<'String, LinkedTenantUsers >)>)>
Dictionary of LinkedTenantUsers LinkedTenantUsers

Exceptions

Exception | Condition
System..::..ArgumentNullException | If tenantId is null or empty then ArgumentNullException will be thrown.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while getting all the linkable tenants

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedTenantUsersByStatus Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedTenantUsersByStatus Method
ITenantUserAssociationService Interface See Also Send Feedback
This method gets the linked users details for that tenant id and the request status. we can get approved users details from this method

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, LinkedTenantUsers>> GetLinkedTenantUsersByStatus(
    string tenantId,
    RequestStatus[] requestStatuses
)
Visual Basic
Function GetLinkedTenantUsersByStatus (
    tenantId As String,
    requestStatuses As RequestStatus()
) As Dictionary(Of String, Dictionary(Of String, LinkedTenantUsers))
Visual C++
Dictionary<String^, Dictionary<String^, LinkedTenantUsers^>^>^ GetLinkedTenantUsersByStatus(
    String^ tenantId,
    array<RequestStatus>^ requestStatuses
)

Parameters

tenantId
Type: System..::..String
The tenant id.
requestStatuses
Type: array< CelloSaaS.Model.UserManagement..::..RequestStatus >[]()[][]

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, LinkedTenantUsers >)>)>>)>)>
Dictionary of LinkedTenantUsers LinkedTenantUsers

Exceptions

Exception | Condition
System..::..ArgumentNullException | If tenantId is null or empty then ArgumentNullException will be thrown.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while getting all the linkable tenants

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedUserCount Method

[image] [image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedUserCount Method
ITenantUserAssociationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLinkedUserCount(String, RequestStatus) | This method is used to get the Total user count for the given tenant
Public method | GetLinkedUserCount(array<String>[]()[][], RequestStatus) | This method is used to get the Total user count for the given tenants

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedUserCount Method (String, RequestStatus)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedUserCount Method (String, RequestStatus)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to get the Total user count for the given tenant

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int GetLinkedUserCount(
    string tenantId,
    RequestStatus requestStatus
)
Visual Basic
Function GetLinkedUserCount (
    tenantId As String,
    requestStatus As RequestStatus
) As Integer
Visual C++
int GetLinkedUserCount(
    String^ tenantId,
    RequestStatus requestStatus
)

Parameters

tenantId
Type: System..::..String
The tenant id.
requestStatus
Type: CelloSaaS.Model.UserManagement..::..RequestStatus
The request status.

Return Value

Type: Int32
Total User Count [Inclusive of the self requests and obtained requests] for the given tenant and request status

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If tenantId is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while fetching the tenant user count

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
GetLinkedUserCount Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.GetLinkedUserCount Method (String[], RequestStatus)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..GetLinkedUserCount Method (array<String>[]()[][], RequestStatus)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to get the Total user count for the given tenants

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, int> GetLinkedUserCount(
    string[] tenantIds,
    RequestStatus requestStatus
)
Visual Basic
Function GetLinkedUserCount (
    tenantIds As String(),
    requestStatus As RequestStatus
) As Dictionary(Of String, Integer)
Visual C++
Dictionary<String^, int>^ GetLinkedUserCount(
    array<String^>^ tenantIds,
    RequestStatus requestStatus
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
Array of tenant identifiers
requestStatus
Type: CelloSaaS.Model.UserManagement..::..RequestStatus
The request status.

Return Value

Type: Dictionary<(Of <(<'String, Int32>)>)>
Total User Count [Inclusive of the self requests and obtained requests] in a dictionary of tenant id and user count

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while fetching the tenant user counts

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
GetLinkedUserCount Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.IsLinkedByOtherTenant Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..IsLinkedByOtherTenant Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to determine whether this the specified tenant id can link with other tenant user.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool IsLinkedByOtherTenant(
    string tenantId
)
Visual Basic
Function IsLinkedByOtherTenant (
    tenantId As String
) As Boolean
Visual C++
bool IsLinkedByOtherTenant(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Boolean
true if [is linked by other tenant] [the specified tenant id]; otherwise, false.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while checking whether the tenant is already linked

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.LinkOtherTenant Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..LinkOtherTenant Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to link a tenant with an user. It can be an user request or the tenant request.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string LinkOtherTenant(
    LinkedTenantUsers linkedTenantUsers
)
Visual Basic
Function LinkOtherTenant (
    linkedTenantUsers As LinkedTenantUsers
) As String
Visual C++
String^ LinkOtherTenant(
    LinkedTenantUsers^ linkedTenantUsers
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.

Return Value

Type: String
LinkedTenantUser Identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | If userId is null or empty then ArgumentNullException will be thrown.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Throws Tenant User Association Exception

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.LinkOtherTenantUser Method

[image] [image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..LinkOtherTenantUser Method
ITenantUserAssociationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | LinkOtherTenantUser(LinkedTenantUsers, String) | This method is used to link a tenant with an user. It can be an user request or the tenant request.
Public method | LinkOtherTenantUser(LinkedTenantUsers, array<String>[]()[][], String) | This method is used to link a tenant with an user. It can be an user request or the tenant request.

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.LinkOtherTenantUser Method (LinkedTenantUsers, String)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..LinkOtherTenantUser Method (LinkedTenantUsers, String)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to link a tenant with an user. It can be an user request or the tenant request.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string LinkOtherTenantUser(
    LinkedTenantUsers linkedTenantUsers,
    string tenantId
)
Visual Basic
Function LinkOtherTenantUser (
    linkedTenantUsers As LinkedTenantUsers,
    tenantId As String
) As String
Visual C++
String^ LinkOtherTenantUser(
    LinkedTenantUsers^ linkedTenantUsers,
    String^ tenantId
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
LinkedTenantUser Identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | If userId is null or empty then ArgumentNullException will be thrown.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Throws Tenant User Association Exception

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
LinkOtherTenantUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.LinkOtherTenantUser Method (LinkedTenantUsers, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..LinkOtherTenantUser Method (LinkedTenantUsers, array<String>[]()[][], String)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to link a tenant with an user. It can be an user request or the tenant request.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string LinkOtherTenantUser(
    LinkedTenantUsers linkedTenantUsers,
    string[] assignedRoles,
    string tenantId
)
Visual Basic
Function LinkOtherTenantUser (
    linkedTenantUsers As LinkedTenantUsers,
    assignedRoles As String(),
    tenantId As String
) As String
Visual C++
String^ LinkOtherTenantUser(
    LinkedTenantUsers^ linkedTenantUsers,
    array<String^>^ assignedRoles,
    String^ tenantId
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.
assignedRoles
Type: array<System..::..String>[]()[][]
The assigned roles.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
LinkedTenantUser Identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while updating the User Association

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
LinkOtherTenantUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.RemoveLinkedTenantUser Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..RemoveLinkedTenantUser Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to removes the linked tenant user details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void RemoveLinkedTenantUser(
    string linkedTenantUsersId
)
Visual Basic
Sub RemoveLinkedTenantUser (
    linkedTenantUsersId As String
)
Visual C++
void RemoveLinkedTenantUser(
    String^ linkedTenantUsersId
)

Parameters

linkedTenantUsersId
Type: System..::..String
The linked tenant users id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while removing the linked user association

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.UpdateLinkedTenantsUser Method

[image] [image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..UpdateLinkedTenantsUser Method
ITenantUserAssociationService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers) | This method is used to approve or reject the requests. It can be a tenant approval or the user approval.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, String) | This method is used to approve or reject the requests. It can be a tenant approval or the user approval.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, array<String>[]()[][]) | This method is used to update the linked tenants user.
Public method | UpdateLinkedTenantsUser(LinkedTenantUsers, array<String>[]()[][], String) | This method is used to update the linked tenants user.

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.UpdateLinkedTenantsUser Method (LinkedTenantUsers)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..UpdateLinkedTenantsUser Method (LinkedTenantUsers)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to approve or reject the requests. It can be a tenant approval or the user approval.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateLinkedTenantsUser(
    LinkedTenantUsers linkedTenantUsers
)
Visual Basic
Sub UpdateLinkedTenantsUser (
    linkedTenantUsers As LinkedTenantUsers
)
Visual C++
void UpdateLinkedTenantsUser(
    LinkedTenantUsers^ linkedTenantUsers
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while getting all the linkable tenants

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
UpdateLinkedTenantsUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.UpdateLinkedTenantsUser Method (LinkedTenantUsers, String)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..UpdateLinkedTenantsUser Method (LinkedTenantUsers, String)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to approve or reject the requests. It can be a tenant approval or the user approval.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateLinkedTenantsUser(
    LinkedTenantUsers linkedTenantUsers,
    string tenantId
)
Visual Basic
Sub UpdateLinkedTenantsUser (
    linkedTenantUsers As LinkedTenantUsers,
    tenantId As String
)
Visual C++
void UpdateLinkedTenantsUser(
    LinkedTenantUsers^ linkedTenantUsers,
    String^ tenantId
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | ExException occurred while updating the User Association

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
UpdateLinkedTenantsUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.UpdateLinkedTenantsUser Method (LinkedTenantUsers, String[])

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..UpdateLinkedTenantsUser Method (LinkedTenantUsers, array<String>[]()[][])
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to update the linked tenants user.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateLinkedTenantsUser(
    LinkedTenantUsers linkedTenantUsers,
    string[] assignedRoles
)
Visual Basic
Sub UpdateLinkedTenantsUser (
    linkedTenantUsers As LinkedTenantUsers,
    assignedRoles As String()
)
Visual C++
void UpdateLinkedTenantsUser(
    LinkedTenantUsers^ linkedTenantUsers,
    array<String^>^ assignedRoles
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.
assignedRoles
Type: array<System..::..String>[]()[][]
The assigned roles.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Throws TenantUserAssociationException

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
UpdateLinkedTenantsUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.UpdateLinkedTenantsUser Method (LinkedTenantUsers, String[], String)

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..UpdateLinkedTenantsUser Method (LinkedTenantUsers, array<String>[]()[][], String)
ITenantUserAssociationService Interface See Also Send Feedback
This method is used to update the linked tenants user.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateLinkedTenantsUser(
    LinkedTenantUsers linkedTenantUsers,
    string[] assignedRoles,
    string tenantId
)
Visual Basic
Sub UpdateLinkedTenantsUser (
    linkedTenantUsers As LinkedTenantUsers,
    assignedRoles As String(),
    tenantId As String
)
Visual C++
void UpdateLinkedTenantsUser(
    LinkedTenantUsers^ linkedTenantUsers,
    array<String^>^ assignedRoles,
    String^ tenantId
)

Parameters

linkedTenantUsers
Type: CelloSaaS.Model.UserManagement..::..LinkedTenantUsers
The linked tenant users.
assignedRoles
Type: array<System..::..String>[]()[][]
The assigned roles.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while updating the User Association

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
UpdateLinkedTenantsUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


ITenantUserAssociationService.UpdateLinkedTenantsUserStatus Method

[image]

A Sandcastle Documented Class Library
ITenantUserAssociationService..::..UpdateLinkedTenantsUserStatus Method
ITenantUserAssociationService Interface See Also Send Feedback
This method is used change the status of the record. we can deactivate that details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateLinkedTenantsUserStatus(
    string identifier,
    bool status
)
Visual Basic
Sub UpdateLinkedTenantsUserStatus (
    identifier As String,
    status As Boolean
)
Visual C++
void UpdateLinkedTenantsUserStatus(
    String^ identifier,
    bool status
)

Parameters

identifier
Type: System..::..String
The identifier. The linked tenant users id . ie primary key of the table
status
Type: System..::..Boolean
if set to true [status].

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException. If any mandatory argument is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | Exception occurred while updating the tenant user association status

See Also

ITenantUserAssociationService Interface
ITenantUserAssociationService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService Interface

[image]

A Sandcastle Documented Class Library
IUserActivityService Interface
Members See Also Send Feedback
User Activity Service

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IUserActivityService
Visual Basic
Public Interface IUserActivityService
Visual C++
public interface class IUserActivityService

See Also

IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService Members

[image] [image]

A Sandcastle Documented Class Library
IUserActivityService Members
IUserActivityService Interface Methods See Also Send Feedback

The IUserActivityService type exposes the following members.

Methods

 | Name | Description
Public method | AddUserActivity | This Method is used to adds the user activity.
Public method | DeleteUserActivity | This methosd is used to deletes the user activity.
Public method | GetActivitySpan | This method is used to gets the activity span.
Public method | GetUserActivity | This method is used to gets the user activity.
Public method | IsSessionActive | This method determines whether this session is active for the specified user id.
Public method | UpdateUserActivity | This methosd is used to updates the user activity.

See Also

IUserActivityService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService Methods

[image] [image]

A Sandcastle Documented Class Library
IUserActivityService Methods
IUserActivityService Interface See Also Send Feedback

The IUserActivityService type exposes the following members.

Methods

 | Name | Description
Public method | AddUserActivity | This Method is used to adds the user activity.
Public method | DeleteUserActivity | This methosd is used to deletes the user activity.
Public method | GetActivitySpan | This method is used to gets the activity span.
Public method | GetUserActivity | This method is used to gets the user activity.
Public method | IsSessionActive | This method determines whether this session is active for the specified user id.
Public method | UpdateUserActivity | This methosd is used to updates the user activity.

See Also

IUserActivityService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService.AddUserActivity Method

[image]

A Sandcastle Documented Class Library
IUserActivityService..::..AddUserActivity Method
IUserActivityService Interface See Also Send Feedback
This Method is used to adds the user activity.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DateTime AddUserActivity(
    string userId
)
Visual Basic
Function AddUserActivity (
    userId As String
) As DateTime
Visual C++
DateTime AddUserActivity(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: DateTime
activity timestamp

Remarks

esp. at the time of login

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserActivityException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user id is null or empty.

See Also

IUserActivityService Interface
IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService.DeleteUserActivity Method

[image]

A Sandcastle Documented Class Library
IUserActivityService..::..DeleteUserActivity Method
IUserActivityService Interface See Also Send Feedback
This methosd is used to deletes the user activity.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int DeleteUserActivity(
    string userId
)
Visual Basic
Function DeleteUserActivity (
    userId As String
) As Integer
Visual C++
int DeleteUserActivity(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Int32
Number of rows affected

Remarks

Removes the User Activity trace for this user id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserActivityException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user id is null or empty.

See Also

IUserActivityService Interface
IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService.GetActivitySpan Method

[image]

A Sandcastle Documented Class Library
IUserActivityService..::..GetActivitySpan Method
IUserActivityService Interface See Also Send Feedback
This method is used to gets the activity span.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
long GetActivitySpan(
    string userId
)
Visual Basic
Function GetActivitySpan (
    userId As String
) As Long
Visual C++
long long GetActivitySpan(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Int64
Milliseconds

Remarks

This function returns the number of milliseconds between the last user activity and now

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserActivityException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user id is null or empty.

See Also

IUserActivityService Interface
IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService.GetUserActivity Method

[image]

A Sandcastle Documented Class Library
IUserActivityService..::..GetUserActivity Method
IUserActivityService Interface See Also Send Feedback
This method is used to gets the user activity.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserActivity GetUserActivity(
    string userId
)
Visual Basic
Function GetUserActivity (
    userId As String
) As UserActivity
Visual C++
UserActivity^ GetUserActivity(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: UserActivity
User Activity

Remarks

Gets the UserActivity Object for the given user id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserActivityException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user id is null or empty.

See Also

IUserActivityService Interface
IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService.IsSessionActive Method

[image]

A Sandcastle Documented Class Library
IUserActivityService..::..IsSessionActive Method
IUserActivityService Interface See Also Send Feedback
This method determines whether this session is active for the specified user id.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool IsSessionActive(
    string userId
)
Visual Basic
Function IsSessionActive (
    userId As String
) As Boolean
Visual C++
bool IsSessionActive(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Boolean
true if [is session active] [the specified user id]; otherwise, false.

See Also

IUserActivityService Interface
IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserActivityService.UpdateUserActivity Method

[image]

A Sandcastle Documented Class Library
IUserActivityService..::..UpdateUserActivity Method
IUserActivityService Interface See Also Send Feedback
This methosd is used to updates the user activity.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int UpdateUserActivity(
    string userId
)
Visual Basic
Function UpdateUserActivity (
    userId As String
) As Integer
Visual C++
int UpdateUserActivity(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Return Value

Type: Int32
Number of rows affected

Remarks

Updates the timestamp for this userid for the current time

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserActivityException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user id is null or empty.

See Also

IUserActivityService Interface
IUserActivityService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService Interface

[image]

A Sandcastle Documented Class Library
IUserDetailsService Interface
Members See Also Send Feedback
User Details Service Interface

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IUserDetailsService
Visual Basic
Public Interface IUserDetailsService
Visual C++
public interface class IUserDetailsService

See Also

IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService Members

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService Members
IUserDetailsService Interface Methods See Also Send Feedback

The IUserDetailsService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateUser | Activates the user so that the user can login to system again.
Public method | AddUser(UserDetails) | This method is used to create user details. After successful creation of user, mail(Conformation/Password) will be send to user based on the configuration.
Public method | AddUser(MembershipDetails, Address, User, String) | This method is used to create user details. After successful creation of user, mail(Conformation/Password) will be send to user based on the configuration.
Public method | ChangePassword(String, String, String) | Obsolete. This method is used to change the password
Public method | ChangePassword(String, String, String, String) | This method is used to change the password
Public method | CheckPasswordsExpired | Return true or false based on whether the membership id's password has expired or not.
Public method | DeleteUser | Deactivates the user. User cannot login if deactivated.
Public method | ForceUserPasswordReset | To force the password resetting for the users under a given tenant.
Public method | ForgotPassword(String) | Obsolete. This method is used to send mail to user with his/her password. Password may be old password or resetted password
Public method | ForgotPassword(String, String) | This method is used to send mail to user with his/her password. Password may be old password or reseted password
Public method | GetAllUserDetailsByTenantId | Get all(both active and inactive) user details for the given tenant Identifier.
Public method | GetOnlineUsers | Retuns the currently online users for the given tenant id. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)
Public method | GetOnlineUsersCount | Retuns the currently online users count for the given tenant id. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)
Public method | GetOnlineUsersCountForTenants | Retuns the currently online users count for the given tenant ids. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)
Public method | GetPasswordExpiredUser | Get the list of membershipIds which have been expired for a given tenantID.
Public method | GetUserCountByTenantId | Gets the user count by tenant id.
Public method | GetUserCountByTenantIds | Get user counts for tenant Identifiers.
Public method | GetUserDetails(array<String>[]()[][]) | Gets the user details.
Public method | GetUserDetails(String, String) | Get user details by user name and company code.
Public method | GetUserDetailsByEmailId | Gets the user details by email id.
Public method | GetUserDetailsByName(String) | Obsolete. Get user details by user name.
Public method | GetUserDetailsByName(String, String) | Get user details by user name and tenant Id.
Public method | GetUserDetailsByTenantId | Get active user details for the given tenant id
Public method | GetUserDetailsByUserId(String) | Get user details for the given userId
Public method | GetUserDetailsByUserId(String, String) | Gets the user details for the given user id and the tenant Id.
Public method | GetUserDetailsForShareUsers | This method is used to gets the user details for share users.
Public method | GetUserIdByEmailId | Gets the user id by email id. EmailId is unique throughout the system (accross all tenants)
Public method | GetUserInPrivileges | Gets the user in privileges.
Public method | GetUserNameForAudit | Get the username for the given userIds for audit display purposes
Public method | GetUsersInRole | Gets the users in role.
Public method | GetUsersInRoles | Gets the users in roles.
Public method | IsUserPasswordForcedForChange | To check whether this membershipid is forced for password reset or not
Public method | LockAllUserAccounts | Locks all user accounts.
Public method | LockUserAccounts | Locks the user accounts.
Public method | PermanentDeleteUser | Delete the user details from the system
Public method | ResetPassword(String) | Obsolete. Resets the password for a user
Public method | ResetPassword(String, String) | Resets the password for a user
Public method | ResetPassword(String, String, String) | Obsolete. Resets the password for a user
Public method | ResetPassword(array<String>[]()[][], String, String) | Resets the user password password.
Public method | ResetPassword(String, String, String, String) | Resets the password for a user
Public method | SearchAllUserDetailsInCurrentTenant | Get all user details based on the search value in current tenant
Public method | SearchAllUserDetailsInOtherTenants | Get all user details based on the search value in other tenants
Public method | SearchUserDetails(SearchParameters) | Get user details based on the search parameters
Public method | SearchUserDetails(SearchParameters, String) | Get user details based on the search parameters
Public method | SearchUserDetailsInCurrentTenant | Get active user details by search value in current tenant
Public method | SearchUserDetailsInOtherTenants | Get active user details based on the search value in other tenants
Public method | UnLockAllUserAccounts | Uns the lock all user accounts.
Public method | UnLockUserAccounts | This method will set the lock field of the membership table to false and resets the failure attempts column value to zero.
Public method | UpdateFirstTimeLogOn(String, String, String, String, Boolean) | Obsolete. Updates the first time log on.
Public method | UpdateFirstTimeLogOn(String, String, String, String, Boolean, String) | Update the password and security question/answer
Public method | UpdatePasswordExpirationDate | Update the user password expiry date for the given membershipid
Public method | UpdatePasswordExpirationStatus | Updates the password expiry status daily and sets the expiry status for each user in the userpasswordexpiration table.
Public method | UpdateUser(UserDetails) | Update the given user details.
Public method | UpdateUser(MembershipDetails, User, Address) | Update the given user details.
Public method | UserDetailsBulkInsert | This method is used to insert bulk user details
Public method | UserDetailsBulkUpdate | This method is used to update bulk user details
Public method | ValidateSecurityAnswer | This method checks the security answer for the given user and updates the failure attempts. If exceeds the maximum allowed number, then it locks the user account.
Public method | ValidateUser(String, String) | Obsolete. Validates the user login credentials. True if the valid credentials passed else False
Public method | ValidateUser(String, String, String) | Validates the user login credentials. True if the valid credentials passed else False Primarly used in Forms validation
Public method | ValidateWCFUser | Validates the tenant API key. Used to authenticate WCF service calls.

See Also

IUserDetailsService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService Methods

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService Methods
IUserDetailsService Interface See Also Send Feedback

The IUserDetailsService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateUser | Activates the user so that the user can login to system again.
Public method | AddUser(UserDetails) | This method is used to create user details. After successful creation of user, mail(Conformation/Password) will be send to user based on the configuration.
Public method | AddUser(MembershipDetails, Address, User, String) | This method is used to create user details. After successful creation of user, mail(Conformation/Password) will be send to user based on the configuration.
Public method | ChangePassword(String, String, String) | Obsolete. This method is used to change the password
Public method | ChangePassword(String, String, String, String) | This method is used to change the password
Public method | CheckPasswordsExpired | Return true or false based on whether the membership id's password has expired or not.
Public method | DeleteUser | Deactivates the user. User cannot login if deactivated.
Public method | ForceUserPasswordReset | To force the password resetting for the users under a given tenant.
Public method | ForgotPassword(String) | Obsolete. This method is used to send mail to user with his/her password. Password may be old password or resetted password
Public method | ForgotPassword(String, String) | This method is used to send mail to user with his/her password. Password may be old password or reseted password
Public method | GetAllUserDetailsByTenantId | Get all(both active and inactive) user details for the given tenant Identifier.
Public method | GetOnlineUsers | Retuns the currently online users for the given tenant id. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)
Public method | GetOnlineUsersCount | Retuns the currently online users count for the given tenant id. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)
Public method | GetOnlineUsersCountForTenants | Retuns the currently online users count for the given tenant ids. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)
Public method | GetPasswordExpiredUser | Get the list of membershipIds which have been expired for a given tenantID.
Public method | GetUserCountByTenantId | Gets the user count by tenant id.
Public method | GetUserCountByTenantIds | Get user counts for tenant Identifiers.
Public method | GetUserDetails(array<String>[]()[][]) | Gets the user details.
Public method | GetUserDetails(String, String) | Get user details by user name and company code.
Public method | GetUserDetailsByEmailId | Gets the user details by email id.
Public method | GetUserDetailsByName(String) | Obsolete. Get user details by user name.
Public method | GetUserDetailsByName(String, String) | Get user details by user name and tenant Id.
Public method | GetUserDetailsByTenantId | Get active user details for the given tenant id
Public method | GetUserDetailsByUserId(String) | Get user details for the given userId
Public method | GetUserDetailsByUserId(String, String) | Gets the user details for the given user id and the tenant Id.
Public method | GetUserDetailsForShareUsers | This method is used to gets the user details for share users.
Public method | GetUserIdByEmailId | Gets the user id by email id. EmailId is unique throughout the system (accross all tenants)
Public method | GetUserInPrivileges | Gets the user in privileges.
Public method | GetUserNameForAudit | Get the username for the given userIds for audit display purposes
Public method | GetUsersInRole | Gets the users in role.
Public method | GetUsersInRoles | Gets the users in roles.
Public method | IsUserPasswordForcedForChange | To check whether this membershipid is forced for password reset or not
Public method | LockAllUserAccounts | Locks all user accounts.
Public method | LockUserAccounts | Locks the user accounts.
Public method | PermanentDeleteUser | Delete the user details from the system
Public method | ResetPassword(String) | Obsolete. Resets the password for a user
Public method | ResetPassword(String, String) | Resets the password for a user
Public method | ResetPassword(String, String, String) | Obsolete. Resets the password for a user
Public method | ResetPassword(array<String>[]()[][], String, String) | Resets the user password password.
Public method | ResetPassword(String, String, String, String) | Resets the password for a user
Public method | SearchAllUserDetailsInCurrentTenant | Get all user details based on the search value in current tenant
Public method | SearchAllUserDetailsInOtherTenants | Get all user details based on the search value in other tenants
Public method | SearchUserDetails(SearchParameters) | Get user details based on the search parameters
Public method | SearchUserDetails(SearchParameters, String) | Get user details based on the search parameters
Public method | SearchUserDetailsInCurrentTenant | Get active user details by search value in current tenant
Public method | SearchUserDetailsInOtherTenants | Get active user details based on the search value in other tenants
Public method | UnLockAllUserAccounts | Uns the lock all user accounts.
Public method | UnLockUserAccounts | This method will set the lock field of the membership table to false and resets the failure attempts column value to zero.
Public method | UpdateFirstTimeLogOn(String, String, String, String, Boolean) | Obsolete. Updates the first time log on.
Public method | UpdateFirstTimeLogOn(String, String, String, String, Boolean, String) | Update the password and security question/answer
Public method | UpdatePasswordExpirationDate | Update the user password expiry date for the given membershipid
Public method | UpdatePasswordExpirationStatus | Updates the password expiry status daily and sets the expiry status for each user in the userpasswordexpiration table.
Public method | UpdateUser(UserDetails) | Update the given user details.
Public method | UpdateUser(MembershipDetails, User, Address) | Update the given user details.
Public method | UserDetailsBulkInsert | This method is used to insert bulk user details
Public method | UserDetailsBulkUpdate | This method is used to update bulk user details
Public method | ValidateSecurityAnswer | This method checks the security answer for the given user and updates the failure attempts. If exceeds the maximum allowed number, then it locks the user account.
Public method | ValidateUser(String, String) | Obsolete. Validates the user login credentials. True if the valid credentials passed else False
Public method | ValidateUser(String, String, String) | Validates the user login credentials. True if the valid credentials passed else False Primarly used in Forms validation
Public method | ValidateWCFUser | Validates the tenant API key. Used to authenticate WCF service calls.

See Also

IUserDetailsService Interface
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ActivateUser Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ActivateUser Method
IUserDetailsService Interface See Also Send Feedback
Activates the user so that the user can login to system again.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ActivateUser(
    string userId
)
Visual Basic
Sub ActivateUser (
    userId As String
)
Visual C++
void ActivateUser(
    String^ userId
)

Parameters

userId
Type: System..::..String
The user id.

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the delete user privilege.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If userId is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.AddUser Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..AddUser Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddUser(UserDetails) | This method is used to create user details. After successful creation of user, mail(Conformation/Password) will be send to user based on the configuration.
Public method | AddUser(MembershipDetails, Address, User, String) | This method is used to create user details. After successful creation of user, mail(Conformation/Password) will be send to user based on the configuration.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.AddUser Method (UserDetails)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..AddUser Method (UserDetails)
IUserDetailsService Interface Example See Also Send Feedback
This method is used to create user details. After successful creation of user,
mail(Conformation/Password) will be send to user based on the configuration.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddUser(
    UserDetails userDetails
)
Visual Basic
Function AddUser (
    userDetails As UserDetails
) As String
Visual C++
String^ AddUser(
    UserDetails^ userDetails
)

Parameters

userDetails
Type: CelloSaaS.Model.UserManagement..::..UserDetails
User Details(Mandatory)

Return Value

Type: String
User Identifier

Examples

Copy image Copy
Public string AddUserDetails()
{
    // Create instance for UserDetails
    UserDetails userDetails = new UserDetails();

    //Fill membership details
    userDetails.MembershipDetails.EmailId = "admin@company.com";
    userDetails.MembershipDetails.UserName = "admin@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";

    //Fill Address Details
    userDetails.Address.Address1 = "Address";
    userDetails.Address.City = "City";
    userDetails.Address.State = "State";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";

    //Fill User Details
    userDetails.User.FirstName = "Company Admin";
    userDetails.User.LastName = "Test";

    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    string userId = userDetailsService.AddUser(userDetails);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
CelloSaaS.ServiceContracts.UserManagement..::..SendMailException | If any exception occurred while sending emails

See Also

IUserDetailsService Interface
IUserDetailsService Members
AddUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.AddUser Method (MembershipDetails, Address, User, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..AddUser Method (MembershipDetails, Address, User, String)
IUserDetailsService Interface Example See Also Send Feedback
This method is used to create user details. After successful creation of user,
mail(Conformation/Password) will be send to user based on the configuration.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddUser(
    MembershipDetails membershipDetails,
    Address address,
    User user,
    string tenantId
)
Visual Basic
Function AddUser (
    membershipDetails As MembershipDetails,
    address As Address,
    user As User,
    tenantId As String
) As String
Visual C++
String^ AddUser(
    MembershipDetails^ membershipDetails,
    Address^ address,
    User^ user,
    String^ tenantId
)

Parameters

membershipDetails
Type: CelloSaaS.Model.UserManagement..::..MembershipDetails
Membership Details(Mandatory)
address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address details
user
Type: CelloSaaS.Model.UserManagement..::..User
User Details(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: String
User Identifier

Examples

Copy image Copy
Public string AddUserDetails()
{
    // Create instance for UserDetails
    UserDetails userDetails = new UserDetails();

    //Fill membership details
    userDetails.MembershipDetails.EmailId = "admin@company.com";
    userDetails.MembershipDetails.UserName = "admin@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";

    //Fill Address Details
    userDetails.Address.Address1 = "Address";
    userDetails.Address.City = "City";
    userDetails.Address.State = "State";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";

    //Fill User Details
    userDetails.User.FirstName = "Company Admin";
    userDetails.User.LastName = "Test";

    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    string userId = userDetailsService.AddUser(userDetails.MembershipDetails, userDetails.Address, userDetails.User);
}

See Also

IUserDetailsService Interface
IUserDetailsService Members
AddUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ChangePassword Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ChangePassword Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangePassword(String, String, String) | Obsolete. This method is used to change the password
Public method | ChangePassword(String, String, String, String) | This method is used to change the password

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ChangePassword Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ChangePassword Method (String, String, String)
IUserDetailsService Interface Example See Also Send Feedback
This method is used to change the password

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use the overload with tenantId parameter.")]
bool ChangePassword(
    string userName,
    string oldPassword,
    string newPassword
)
Visual Basic
<ObsoleteAttribute("Use the overload with tenantId parameter.")>
Function ChangePassword (
    userName As String,
    oldPassword As String,
    newPassword As String
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use the overload with tenantId parameter.")]
bool ChangePassword(
    String^ userName,
    String^ oldPassword,
    String^ newPassword
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
oldPassword
Type: System..::..String
Old Password(Mandatory)
newPassword
Type: System..::..String
New Password(Mandatory)

Return Value

Type: Boolean
True - Password Changed Successfully/False

Examples

Copy image Copy
Publuic void ChangePassword()
{
    string userName = "admin@company.com";
    string oldPassword = "company";
    string newPassword = "company1";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ChangePassword(userName, oldPassword, newPassword);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If the user name is incorrect.
System..::..ArgumentNullException | If the user name or old password or new password or tenant id is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ChangePassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ChangePassword Method (String, String, String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ChangePassword Method (String, String, String, String)
IUserDetailsService Interface Example See Also Send Feedback
This method is used to change the password

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ChangePassword(
    string userName,
    string tenantId,
    string oldPassword,
    string newPassword
)
Visual Basic
Function ChangePassword (
    userName As String,
    tenantId As String,
    oldPassword As String,
    newPassword As String
) As Boolean
Visual C++
bool ChangePassword(
    String^ userName,
    String^ tenantId,
    String^ oldPassword,
    String^ newPassword
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier
oldPassword
Type: System..::..String
Old Password(Mandatory)
newPassword
Type: System..::..String
New Password(Mandatory)

Return Value

Type: Boolean
True - Password Changed Successfully/False

Examples

Copy image Copy
Public void ChangePassword()
{
    string userName = "admin@company.com";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string oldPassword = "company";
    string newPassword = "company1";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ChangePassword(userName, tenantId, oldPassword, newPassword);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If the user name is incorrect.
System..::..ArgumentNullException | If the user name or old password or new password or tenant id is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ChangePassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.CheckPasswordsExpired Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..CheckPasswordsExpired Method
IUserDetailsService Interface See Also Send Feedback
Return true or false based on whether the membership id's password has expired or not.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CheckPasswordsExpired(
    string membershipId
)
Visual Basic
Function CheckPasswordsExpired (
    membershipId As String
) As Boolean
Visual C++
bool CheckPasswordsExpired(
    String^ membershipId
)

Parameters

membershipId
Type: System..::..String
The membership id.

Return Value

Type: Boolean

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If membership id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.DeleteUser Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..DeleteUser Method
IUserDetailsService Interface Example See Also Send Feedback
Deactivates the user. User cannot login if deactivated.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteUser(
    string userId
)
Visual Basic
Sub DeleteUser (
    userId As String
)
Visual C++
void DeleteUser(
    String^ userId
)

Parameters

userId
Type: System..::..String
User Identifier(Mandatory)

Examples

Copy image Copy
Public void DeactivateUser()
{
string userId = "428C0E1A-C993-DF11-8DEB-001EC9DAB123";
IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
userDetailsService.DeleteUser(userId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not privilege to deactivate user.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If userId is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ForceUserPasswordReset Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ForceUserPasswordReset Method
IUserDetailsService Interface See Also Send Feedback
To force the password resetting for the users under a given tenant.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ForceUserPasswordReset(
    string[] userIds
)
Visual Basic
Function ForceUserPasswordReset (
    userIds As String()
) As Boolean
Visual C++
bool ForceUserPasswordReset(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
Array of UserIds to reset the password.

Return Value

Type: Boolean
true if forced password reset is successful. false if forced password reset is NOT successful.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ForgotPassword Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ForgotPassword Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ForgotPassword(String) | Obsolete. This method is used to send mail to user with his/her password. Password may be old password or resetted password
Public method | ForgotPassword(String, String) | This method is used to send mail to user with his/her password. Password may be old password or reseted password

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ForgotPassword Method (String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ForgotPassword Method (String)
IUserDetailsService Interface Example See Also Send Feedback
This method is used to send mail to user with his/her password. Password may be old password or resetted password

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use the overload with tenantId parameter.")]
void ForgotPassword(
    string userName
)
Visual Basic
<ObsoleteAttribute("Use the overload with tenantId parameter.")>
Sub ForgotPassword (
    userName As String
)
Visual C++
[ObsoleteAttribute(L"Use the overload with tenantId parameter.")]
void ForgotPassword(
    String^ userName
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)

Examples

Copy image Copy
Publuic void ForgotPassword()
{
    string userName = "admin@company.com";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ForgotPassword(userName);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If user details was not available for the user name.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user name is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ForgotPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ForgotPassword Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ForgotPassword Method (String, String)
IUserDetailsService Interface Example See Also Send Feedback
This method is used to send mail to user with his/her password. Password may be old password or reseted password

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ForgotPassword(
    string userName,
    string tenantId
)
Visual Basic
Sub ForgotPassword (
    userName As String,
    tenantId As String
)
Visual C++
void ForgotPassword(
    String^ userName,
    String^ tenantId
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier

Examples

Copy image Copy
Publuic void ForgotPassword()
{
    string userName = "admin@company.com";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ForgotPassword(userName, tenantId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If user details was not available for the user name.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user name is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ForgotPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetAllUserDetailsByTenantId Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetAllUserDetailsByTenantId Method
IUserDetailsService Interface Example See Also Send Feedback
Get all(both active and inactive) user details for the given tenant Identifier.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetAllUserDetailsByTenantId(
    string tenantId
)
Visual Basic
Function GetAllUserDetailsByTenantId (
    tenantId As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetAllUserDetailsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
Active and Inactive User details

Examples

Copy image Copy
public void GetAllUserDetailsByTenantId()
{
    Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.GetAllUserDetailsByTenantId(tenantId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException |
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | If any error occur, while sharing the user details.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the tenant id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetOnlineUsers Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetOnlineUsers Method
IUserDetailsService Interface See Also Send Feedback
Retuns the currently online users for the given tenant id. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetOnlineUsers(
    string tenantId
)
Visual Basic
Function GetOnlineUsers (
    tenantId As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetOnlineUsers(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetOnlineUsersCount Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetOnlineUsersCount Method
IUserDetailsService Interface See Also Send Feedback
Retuns the currently online users count for the given tenant id. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int GetOnlineUsersCount(
    string tenantId
)
Visual Basic
Function GetOnlineUsersCount (
    tenantId As String
) As Integer
Visual C++
int GetOnlineUsersCount(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String

Return Value

Type: Int32

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetOnlineUsersCountForTenants Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetOnlineUsersCountForTenants Method
IUserDetailsService Interface See Also Send Feedback
Retuns the currently online users count for the given tenant ids. Online users are identifier if their last activity time is less than 10 minutes (configurable in appsettings)

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, int> GetOnlineUsersCountForTenants(
    string[] tenantIds
)
Visual Basic
Function GetOnlineUsersCountForTenants (
    tenantIds As String()
) As Dictionary(Of String, Integer)
Visual C++
Dictionary<String^, int>^ GetOnlineUsersCountForTenants(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]

Return Value

Type: Dictionary<(Of <(<'String, Int32>)>)>

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetPasswordExpiredUser Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetPasswordExpiredUser Method
IUserDetailsService Interface See Also Send Feedback
Get the list of membershipIds which have been expired for a given tenantID.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetPasswordExpiredUser(
    string tenantId
)
Visual Basic
Function GetPasswordExpiredUser (
    tenantId As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetPasswordExpiredUser(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
TenantId to find the list of expired memberships

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
List of expired membership Ids.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the tenant id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserCountByTenantId Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserCountByTenantId Method
IUserDetailsService Interface See Also Send Feedback
Gets the user count by tenant id.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<bool, int> GetUserCountByTenantId(
    string tenantId
)
Visual Basic
Function GetUserCountByTenantId (
    tenantId As String
) As Dictionary(Of Boolean, Integer)
Visual C++
Dictionary<bool, int>^ GetUserCountByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'Boolean, Int32>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the tenant id is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserCountByTenantIds Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserCountByTenantIds Method
IUserDetailsService Interface Example See Also Send Feedback
Get user counts for tenant Identifiers.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<int, int>> GetUserCountByTenantIds(
    string[] tenantIds
)
Visual Basic
Function GetUserCountByTenantIds (
    tenantIds As String()
) As Dictionary(Of String, Dictionary(Of Integer, Integer))
Visual C++
Dictionary<String^, Dictionary<int, int>^>^ GetUserCountByTenantIds(
    array<String^>^ tenantIds
)

Parameters

tenantIds
Type: array<System..::..String>[]()[][]
Tenant Identifiers(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'Int32, Int32>)>)>>)>)>
User details count and tenant Identifier

Examples

Copy image Copy
public void GetUserCountByTenantIds()
{
    Dictionary<string, Dictionary<int, int>> userDetailsCount = new Dictionary<string, Dictionary<int, int>>();
    string[] tenantIds = new string {"B590CD25-3093-DF11-8DEB-001EC9DAB123", "C590CD25-3093-DF11-8DEB-001EC9DAB123" };
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.GetUserCountByTenantIds(tenantIds);
}

Exceptions

Exception | Condition
System..::..NotSupportedException | If the service is for User Connection String DAL Provider
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the tenant ids is null or tenant ids count is zero

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetails Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetails Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUserDetails(array<String>[]()[][]) | Gets the user details.
Public method | GetUserDetails(String, String) | Get user details by user name and company code.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetails Method (String[])

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetails Method (array<String>[]()[][])
IUserDetailsService Interface See Also Send Feedback
Gets the user details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetUserDetails(
    string[] userIds
)
Visual Basic
Function GetUserDetails (
    userIds As String()
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetUserDetails(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
The user ids.

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user ids is null or user ids count is zero

See Also

IUserDetailsService Interface
IUserDetailsService Members
GetUserDetails Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetails Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetails Method (String, String)
IUserDetailsService Interface See Also Send Feedback
Get user details by user name and company code.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserDetails GetUserDetails(
    string companyCode,
    string userName
)
Visual Basic
Function GetUserDetails (
    companyCode As String,
    userName As String
) As UserDetails
Visual C++
UserDetails^ GetUserDetails(
    String^ companyCode,
    String^ userName
)

Parameters

companyCode
Type: System..::..String
company code(Mandatory)
userName
Type: System..::..String
User Name(Mandatory)

Return Value

Type: UserDetails
User information

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If company code or user name is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
GetUserDetails Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByEmailId Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByEmailId Method
IUserDetailsService Interface See Also Send Feedback
Gets the user details by email id.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserDetails GetUserDetailsByEmailId(
    string emailId
)
Visual Basic
Function GetUserDetailsByEmailId (
    emailId As String
) As UserDetails
Visual C++
UserDetails^ GetUserDetailsByEmailId(
    String^ emailId
)

Parameters

emailId
Type: System..::..String
The email id.

Return Value

Type: UserDetails

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByName Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByName Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUserDetailsByName(String) | Obsolete. Get user details by user name.
Public method | GetUserDetailsByName(String, String) | Get user details by user name and tenant Id.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByName Method (String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByName Method (String)
IUserDetailsService Interface Example See Also Send Feedback
Get user details by user name.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use the overload by passing tenantId")]
UserDetails GetUserDetailsByName(
    string userName
)
Visual Basic
<ObsoleteAttribute("Use the overload by passing tenantId")>
Function GetUserDetailsByName (
    userName As String
) As UserDetails
Visual C++
[ObsoleteAttribute(L"Use the overload by passing tenantId")]
UserDetails^ GetUserDetailsByName(
    String^ userName
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)

Return Value

Type: UserDetails
User information

Examples

Copy image Copy
Public void GetUserDetailsByName()
{
    UserDetails userDetails = new UserDetails();
    string userName = "admin@company.com";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.GetUserDetailsByName(userName);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user name is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
GetUserDetailsByName Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByName Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByName Method (String, String)
IUserDetailsService Interface Example See Also Send Feedback
Get user details by user name and tenant Id.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserDetails GetUserDetailsByName(
    string userName,
    string tenantId
)
Visual Basic
Function GetUserDetailsByName (
    userName As String,
    tenantId As String
) As UserDetails
Visual C++
UserDetails^ GetUserDetailsByName(
    String^ userName,
    String^ tenantId
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
tenantId
Type: System..::..String
Tenant Code

Return Value

Type: UserDetails
User information

Examples

Copy image Copy
Public void GetUserDetailsByName()
{
UserDetails userDetails = new UserDetails();
string userName = "admin@company.com":
string tenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
userDetails = userDetailsService.GetUserDetailsByName(userName,tenantCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user name is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
GetUserDetailsByName Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByTenantId Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByTenantId Method
IUserDetailsService Interface See Also Send Feedback
Get active user details for the given tenant id

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetUserDetailsByTenantId(
    string tenantId
)
Visual Basic
Function GetUserDetailsByTenantId (
    tenantId As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetUserDetailsByTenantId(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
Tenant Id(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
User details

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the view user privilege.
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException | If Any exception occurred, while sharing the user details.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the tenant id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByUserId Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByUserId Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUserDetailsByUserId(String) | Get user details for the given userId
Public method | GetUserDetailsByUserId(String, String) | Gets the user details for the given user id and the tenant Id.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByUserId Method (String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByUserId Method (String)
IUserDetailsService Interface Example See Also Send Feedback
Get user details for the given userId

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserDetails GetUserDetailsByUserId(
    string userId
)
Visual Basic
Function GetUserDetailsByUserId (
    userId As String
) As UserDetails
Visual C++
UserDetails^ GetUserDetailsByUserId(
    String^ userId
)

Parameters

userId
Type: System..::..String
User Identifier(Mandatory)

Return Value

Type: UserDetails
User Details

Examples

Copy image Copy
public void GetUserDetailsByUserId()
{
    UserDetails userDetails = new UserDetails();
    string userId = "3398F837-B988-4708-999D-D3DFE11875B3";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.GetUserDetailsByUserId(userId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..UnauthorizedAccessException | If the user has not the view user privilege
System..::..ArgumentNullException | If the user id is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
GetUserDetailsByUserId Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsByUserId Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsByUserId Method (String, String)
IUserDetailsService Interface See Also Send Feedback
Gets the user details for the given user id and the tenant Id.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
UserDetails GetUserDetailsByUserId(
    string userId,
    string tenantId
)
Visual Basic
Function GetUserDetailsByUserId (
    userId As String,
    tenantId As String
) As UserDetails
Visual C++
UserDetails^ GetUserDetailsByUserId(
    String^ userId,
    String^ tenantId
)

Parameters

userId
Type: System..::..String
The user id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: UserDetails
UserDetails

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..UnauthorizedAccessException | If the user has not the view user privilege
System..::..ArgumentNullException | If the user id is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
GetUserDetailsByUserId Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserDetailsForShareUsers Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserDetailsForShareUsers Method
IUserDetailsService Interface See Also Send Feedback
This method is used to gets the user details for share users.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetUserDetailsForShareUsers(
    string[] userIds
)
Visual Basic
Function GetUserDetailsForShareUsers (
    userIds As String()
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetUserDetailsForShareUsers(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
The user ids.

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user ids is null or user ids count is zero

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserIdByEmailId Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserIdByEmailId Method
IUserDetailsService Interface See Also Send Feedback
Gets the user id by email id. EmailId is unique throughout the system (accross all tenants)

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetUserIdByEmailId(
    string emailId
)
Visual Basic
Function GetUserIdByEmailId (
    emailId As String
) As String
Visual C++
String^ GetUserIdByEmailId(
    String^ emailId
)

Parameters

emailId
Type: System..::..String
The email id.

Return Value

Type: String
User Id

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If email id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserInPrivileges Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserInPrivileges Method
IUserDetailsService Interface See Also Send Feedback
Gets the user in privileges.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, UserDetails>> GetUserInPrivileges(
    string[] privilegeIds
)
Visual Basic
Function GetUserInPrivileges (
    privilegeIds As String()
) As Dictionary(Of String, Dictionary(Of String, UserDetails))
Visual C++
Dictionary<String^, Dictionary<String^, UserDetails^>^>^ GetUserInPrivileges(
    array<String^>^ privilegeIds
)

Parameters

privilegeIds
Type: array<System..::..String>[]()[][]
The privilege ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, UserDetails >)>)>>)>)>

Exceptions

Exception | Condition
System..::..ArgumentNullException | If the privilege ids is null or privilege ids count is zero

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUserNameForAudit Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUserNameForAudit Method
IUserDetailsService Interface See Also Send Feedback
Get the username for the given userIds for audit display purposes

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string> GetUserNameForAudit(
    string[] userIds
)
Visual Basic
Function GetUserNameForAudit (
    userIds As String()
) As Dictionary(Of String, String)
Visual C++
Dictionary<String^, String^>^ GetUserNameForAudit(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
a array of userIds

Return Value

Type: Dictionary<(Of <(<'String, String>)>)>

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUsersInRole Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUsersInRole Method
IUserDetailsService Interface See Also Send Feedback
Gets the users in role.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> GetUsersInRole(
    string roleId
)
Visual Basic
Function GetUsersInRole (
    roleId As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ GetUsersInRole(
    String^ roleId
)

Parameters

roleId
Type: System..::..String
The role id.

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>

Exceptions

Exception | Condition
System..::..NotSupportedException | If the service is for UserConnectionString DAL Provider
System..::..ArgumentNullException | If the role id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.GetUsersInRoles Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..GetUsersInRoles Method
IUserDetailsService Interface See Also Send Feedback
Gets the users in roles.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, Dictionary<string, UserDetails>> GetUsersInRoles(
    string[] roleIds
)
Visual Basic
Function GetUsersInRoles (
    roleIds As String()
) As Dictionary(Of String, Dictionary(Of String, UserDetails))
Visual C++
Dictionary<String^, Dictionary<String^, UserDetails^>^>^ GetUsersInRoles(
    array<String^>^ roleIds
)

Parameters

roleIds
Type: array<System..::..String>[]()[][]
The role ids.

Return Value

Type: Dictionary<(Of <(<'String, Dictionary<(Of <(<'String, UserDetails >)>)>>)>)>

Exceptions

Exception | Condition
System..::..NotSupportedException | If the service is for UserConnectionString DAL Provider
System..::..ArgumentNullException | If the role ids is null or role ids count is zero

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.IsUserPasswordForcedForChange Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..IsUserPasswordForcedForChange Method
IUserDetailsService Interface See Also Send Feedback
To check whether this membershipid is forced for password reset or not

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool IsUserPasswordForcedForChange(
    string membershipId,
    string tenantId
)
Visual Basic
Function IsUserPasswordForcedForChange (
    membershipId As String,
    tenantId As String
) As Boolean
Visual C++
bool IsUserPasswordForcedForChange(
    String^ membershipId,
    String^ tenantId
)

Parameters

membershipId
Type: System..::..String
The membership id.
tenantId
Type: System..::..String
tenant id

Return Value

Type: Boolean
true : if the user has been forced for password change false : if the user has NOT been forced for password change

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If membership id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.LockAllUserAccounts Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..LockAllUserAccounts Method
IUserDetailsService Interface See Also Send Feedback
Locks all user accounts.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int LockAllUserAccounts(
    string tenantId
)
Visual Basic
Function LockAllUserAccounts (
    tenantId As String
) As Integer
Visual C++
int LockAllUserAccounts(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Int32
No of users accounts locked.

Exceptions

Exception | Condition
System..::..ArgumentException |
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If tenant id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.LockUserAccounts Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..LockUserAccounts Method
IUserDetailsService Interface See Also Send Feedback
Locks the user accounts.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int LockUserAccounts(
    string[] userIds
)
Visual Basic
Function LockUserAccounts (
    userIds As String()
) As Integer
Visual C++
int LockUserAccounts(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
Array of user identifiers

Return Value

Type: Int32
No of users accounts locked.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user ids is null or user ids count is zero.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.PermanentDeleteUser Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..PermanentDeleteUser Method
IUserDetailsService Interface Example See Also Send Feedback
Delete the user details from the system

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PermanentDeleteUser(
    string userIdentifier
)
Visual Basic
Sub PermanentDeleteUser (
    userIdentifier As String
)
Visual C++
void PermanentDeleteUser(
    String^ userIdentifier
)

Parameters

userIdentifier
Type: System..::..String
User Identifier(Mandatory)

Examples

Copy image Copy
Public void DeleteUser()
{
    string userId = "428C0E1A-C993-DF11-8DEB-001EC9DAB123";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.PermanentDeleteUser(userId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege to delete user
System..::..ArgumentNullException | If userId is null or empty.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ResetPassword Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ResetPassword Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ResetPassword(String) | Obsolete. Resets the password for a user
Public method | ResetPassword(String, String) | Resets the password for a user
Public method | ResetPassword(String, String, String) | Obsolete. Resets the password for a user
Public method | ResetPassword(array<String>[]()[][], String, String) | Resets the user password password.
Public method | ResetPassword(String, String, String, String) | Resets the password for a user

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ResetPassword Method (String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ResetPassword Method (String)
IUserDetailsService Interface Example See Also Send Feedback
Resets the password for a user

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use the overload with tenantId parameter.")]
void ResetPassword(
    string userName
)
Visual Basic
<ObsoleteAttribute("Use the overload with tenantId parameter.")>
Sub ResetPassword (
    userName As String
)
Visual C++
[ObsoleteAttribute(L"Use the overload with tenantId parameter.")]
void ResetPassword(
    String^ userName
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)

Examples

Copy image Copy
public void ResetPassword()
{
    string userName = "admin@company.com";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ResetPassword(userName);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If the user name is not valid.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user name is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ResetPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ResetPassword Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ResetPassword Method (String, String)
IUserDetailsService Interface Example See Also Send Feedback
Resets the password for a user

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ResetPassword(
    string userName,
    string tenantId
)
Visual Basic
Sub ResetPassword (
    userName As String,
    tenantId As String
)
Visual C++
void ResetPassword(
    String^ userName,
    String^ tenantId
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier

Examples

Copy image Copy
Publuic void ResetPassword()
{
    string userName = "admin@company.com";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ResetPassword(userName, tenantId);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If the user name is not valid.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user name is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ResetPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ResetPassword Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ResetPassword Method (String, String, String)
IUserDetailsService Interface Example See Also Send Feedback
Resets the password for a user

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use the overload with tenantId parameter.")]
void ResetPassword(
    string userName,
    string passwordQuestion,
    string passwordAnswer
)
Visual Basic
<ObsoleteAttribute("Use the overload with tenantId parameter.")>
Sub ResetPassword (
    userName As String,
    passwordQuestion As String,
    passwordAnswer As String
)
Visual C++
[ObsoleteAttribute(L"Use the overload with tenantId parameter.")]
void ResetPassword(
    String^ userName,
    String^ passwordQuestion,
    String^ passwordAnswer
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
passwordQuestion
Type: System..::..String
Password Question(Mandatory)
passwordAnswer
Type: System..::..String
Password Answer(Mandatory)

Examples

Copy image Copy
public void ResetPassword()
{
    string userName = "admin@company.com";
    string passwordQuestion = "What is your pet name?";
    string passwordAnswer = "admin";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ResetPassword(userName, passwordQuestion, passwordAnswer);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If the security answer is incorrect.
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If the user name is incorrect.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user name or password question password answer is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ResetPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ResetPassword Method (String[], String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ResetPassword Method (array<String>[]()[][], String, String)
IUserDetailsService Interface See Also Send Feedback
Resets the user password password.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int ResetPassword(
    string[] userIds,
    string password,
    string tenantId
)
Visual Basic
Function ResetPassword (
    userIds As String(),
    password As String,
    tenantId As String
) As Integer
Visual C++
int ResetPassword(
    array<String^>^ userIds,
    String^ password,
    String^ tenantId
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
The user ids.
password
Type: System..::..String
The password.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Int32

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user ids or password or tenant id is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ResetPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ResetPassword Method (String, String, String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ResetPassword Method (String, String, String, String)
IUserDetailsService Interface Example See Also Send Feedback
Resets the password for a user

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ResetPassword(
    string userName,
    string tenantId,
    string passwordQuestion,
    string passwordAnswer
)
Visual Basic
Sub ResetPassword (
    userName As String,
    tenantId As String,
    passwordQuestion As String,
    passwordAnswer As String
)
Visual C++
void ResetPassword(
    String^ userName,
    String^ tenantId,
    String^ passwordQuestion,
    String^ passwordAnswer
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
tenantId
Type: System..::..String
Tenant Identifier
passwordQuestion
Type: System..::..String
Password Question(Mandatory)
passwordAnswer
Type: System..::..String
Password Answer(Mandatory)

Examples

Copy image Copy
public void ResetPassword()
{
    string userName = "admin@company.com";
    string tenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    string passwordQuestion = "What is your pet name?";
    string passwordAnswer = "admin";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetailsService.ResetPassword(userName, tenantId, passwordQuestion, passwordAnswer);
}

Exceptions

Exception | Condition
System.Data..::..DataException | If the security answer is incorrect.
CelloSaaS.ServiceContracts.UserManagement..::..InvalidUserNameException | If the user name is incorrect.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user name or password question password answer is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
ResetPassword Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchAllUserDetailsInCurrentTenant Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchAllUserDetailsInCurrentTenant Method
IUserDetailsService Interface Example See Also Send Feedback
Get all user details based on the search value in current tenant

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> SearchAllUserDetailsInCurrentTenant(
    string tenantCode,
    string searchValue
)
Visual Basic
Function SearchAllUserDetailsInCurrentTenant (
    tenantCode As String,
    searchValue As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ SearchAllUserDetailsInCurrentTenant(
    String^ tenantCode,
    String^ searchValue
)

Parameters

tenantCode
Type: System..::..String
Tenant Code(Mandatory)
searchValue
Type: System..::..String
Search Value

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
Active and Inactive user Details

Examples

Copy image Copy
public void SearchAllUserDetailsInCurrentTenant()
{
    Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
    string tenantCode = "Compay";
    string searchValue= "a";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.SearchAllUserDetailsInCurrentTenant(tenantCode, searchValue);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the search user privilege.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If tenant code is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchAllUserDetailsInOtherTenants Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchAllUserDetailsInOtherTenants Method
IUserDetailsService Interface Example See Also Send Feedback
Get all user details based on the search value in other tenants

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> SearchAllUserDetailsInOtherTenants(
    string[] tenantCodes,
    string searchValue
)
Visual Basic
Function SearchAllUserDetailsInOtherTenants (
    tenantCodes As String(),
    searchValue As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ SearchAllUserDetailsInOtherTenants(
    array<String^>^ tenantCodes,
    String^ searchValue
)

Parameters

tenantCodes
Type: array<System..::..String>[]()[][]
Tenant Codes
searchValue
Type: System..::..String
Search Value

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
Active and Inactive user Details

Examples

Copy image Copy
public void SearchAllUserDetailsInOtherTenants()
{
    Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
    string[] tenantCodes = new string {"C590CD25-3093-DF11-8DEB-001EC9DAB123","D590CD25-3093-DF11-8DEB-001EC9DAB123"};
    string searchValue= "a";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.SearchAllUserDetailsInOtherTenants(tenantCodes, searchValue);
}

Exceptions

Exception | Condition
System..::..NotSupportedException |
System..::..UnauthorizedAccessException | If the user has not the search other tenant user privilege.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchUserDetails Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchUserDetails Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SearchUserDetails(SearchParameters) | Get user details based on the search parameters
Public method | SearchUserDetails(SearchParameters, String) | Get user details based on the search parameters

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchUserDetails Method (SearchParameters)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchUserDetails Method (SearchParameters)
IUserDetailsService Interface Example See Also Send Feedback
Get user details based on the search parameters

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> SearchUserDetails(
    SearchParameters searchParameters
)
Visual Basic
Function SearchUserDetails (
    searchParameters As SearchParameters
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ SearchUserDetails(
    SearchParameters^ searchParameters
)

Parameters

searchParameters
Type: CelloSaaS.Model..::..SearchParameters
Search parameters details(Mandatory)

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
User details

Examples

Copy image Copy
public void SearchUserDetails()
{
    Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
    SearchParameters searchParameters = new SearchParameters();
    UserDetailsSearchCondition userDetailsSearchCondition = new UserDetailsSearchCondition();
    userDetailsSearchCondition.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    userDetailsSearchCondition.Status = true;
    userDetailsSearchCondition.SortString = "User_FirstName";
    userDetailsSearchCondition.SortExpression = "ASC";
    userDetailsSearchCondition.SetTotalCount = true;
    userDetailsSearchCondition.RecordStart = 1;
    userDetailsSearchCondition.RecordEnd = 50;
    searchParameters.searchCondition = userDetailsSearchCondition;
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.SearchUserDetails(searchParameters);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the view user privilege.
System..::..ArgumentException | If search condition or search parameter is null
System..::..ArgumentNullException | If search condition or search parameter is null
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occur, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
SearchUserDetails Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchUserDetails Method (SearchParameters, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchUserDetails Method (SearchParameters, String)
IUserDetailsService Interface Example See Also Send Feedback
Get user details based on the search parameters

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> SearchUserDetails(
    SearchParameters searchParameters,
    string tenantId
)
Visual Basic
Function SearchUserDetails (
    searchParameters As SearchParameters,
    tenantId As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ SearchUserDetails(
    SearchParameters^ searchParameters,
    String^ tenantId
)

Parameters

searchParameters
Type: CelloSaaS.Model..::..SearchParameters
Search parameters details(Mandatory)
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
User details

Examples

Copy image Copy
public void SearchUserDetails()
{
Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
SearchParameters searchParameters = new SearchParameters();
UserDetailsSearchCondition userDetailsSearchCondition = new UserDetailsSearchCondition();
userDetailsSearchCondition.TenantId = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
userDetailsSearchCondition.Status = true;
userDetailsSearchCondition.SortString = "User_FirstName";
userDetailsSearchCondition.SortExpression = "ASC";
userDetailsSearchCondition.SetTotalCount = true;
userDetailsSearchCondition.RecordStart = 1;
userDetailsSearchCondition.RecordEnd = 50;
searchParameters.searchCondition = userDetailsSearchCondition;
IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
userDetails = userDetailsService.SearchUserDetails(searchParameters, userDetailsSearchCondition.TenantId);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the view user privilege.
System..::..ArgumentException | If search condition or search parameter is null
System..::..ArgumentNullException | If search condition or search parameter is null
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occur, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
SearchUserDetails Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchUserDetailsInCurrentTenant Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchUserDetailsInCurrentTenant Method
IUserDetailsService Interface Example See Also Send Feedback
Get active user details by search value in current tenant

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> SearchUserDetailsInCurrentTenant(
    string tenantCode,
    string searchValue
)
Visual Basic
Function SearchUserDetailsInCurrentTenant (
    tenantCode As String,
    searchValue As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ SearchUserDetailsInCurrentTenant(
    String^ tenantCode,
    String^ searchValue
)

Parameters

tenantCode
Type: System..::..String
Tenant Code(Mandatory)
searchValue
Type: System..::..String
Search Value

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
Active User details

Examples

Copy image Copy
public void SearchUserDetailsInCurrentTenant()
{
    Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
    string tenantCode = "Compay";
    string searchValue= "a";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.SearchUserDetailsInCurrentTenant(tenantCode, searchValue);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the search user privilege.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If tenant code is null or empty

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.SearchUserDetailsInOtherTenants Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..SearchUserDetailsInOtherTenants Method
IUserDetailsService Interface Example See Also Send Feedback
Get active user details based on the search value in other tenants

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, UserDetails> SearchUserDetailsInOtherTenants(
    string[] tenantCodes,
    string searchValue
)
Visual Basic
Function SearchUserDetailsInOtherTenants (
    tenantCodes As String(),
    searchValue As String
) As Dictionary(Of String, UserDetails)
Visual C++
Dictionary<String^, UserDetails^>^ SearchUserDetailsInOtherTenants(
    array<String^>^ tenantCodes,
    String^ searchValue
)

Parameters

tenantCodes
Type: array<System..::..String>[]()[][]
Tenant Codes
searchValue
Type: System..::..String
Search Value

Return Value

Type: Dictionary<(Of <(<'String, UserDetails >)>)>
Active user Details

Examples

Copy image Copy
public void SearchUserDetailsInOtherTenants()
{
    Dictionary<string, UserDetails> userDetails = new Dictionary<string, UserDetails>();
    string[] tenantCodes = new string {"C590CD25-3093-DF11-8DEB-001EC9DAB123","D590CD25-3093-DF11-8DEB-001EC9DAB123"};
    string searchValue= "a";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    userDetails = userDetailsService.SearchUserDetailsInOtherTenants(tenantCodes, searchValue);
}

Exceptions

Exception | Condition
System..::..NotSupportedException | If the service is for user connection sting DAL Provider
System..::..UnauthorizedAccessException | If the user has not the search other tenant user privilege.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UnLockAllUserAccounts Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UnLockAllUserAccounts Method
IUserDetailsService Interface See Also Send Feedback
Uns the lock all user accounts.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int UnLockAllUserAccounts(
    string tenantId
)
Visual Basic
Function UnLockAllUserAccounts (
    tenantId As String
) As Integer
Visual C++
int UnLockAllUserAccounts(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Int32
No of users accounts Un-locked.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If tenant id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UnLockUserAccounts Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UnLockUserAccounts Method
IUserDetailsService Interface See Also Send Feedback
This method will set the lock field of the membership table to false and resets the failure attempts column value to zero.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int UnLockUserAccounts(
    string[] userIds
)
Visual Basic
Function UnLockUserAccounts (
    userIds As String()
) As Integer
Visual C++
int UnLockUserAccounts(
    array<String^>^ userIds
)

Parameters

userIds
Type: array<System..::..String>[]()[][]
Array of user identifiers

Return Value

Type: Int32
No of users accounts locked.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If user ids is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdateFirstTimeLogOn Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdateFirstTimeLogOn Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateFirstTimeLogOn(String, String, String, String, Boolean) | Obsolete. Updates the first time log on.
Public method | UpdateFirstTimeLogOn(String, String, String, String, Boolean, String) | Update the password and security question/answer

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdateFirstTimeLogOn Method (String, String, String, String, Boolean)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdateFirstTimeLogOn Method (String, String, String, String, Boolean)
IUserDetailsService Interface See Also Send Feedback
Updates the first time log on.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute]
void UpdateFirstTimeLogOn(
    string membershipId,
    string password,
    string securityQuestion,
    string securityAnswer,
    bool firstLogOn
)
Visual Basic
<ObsoleteAttribute>
Sub UpdateFirstTimeLogOn (
    membershipId As String,
    password As String,
    securityQuestion As String,
    securityAnswer As String,
    firstLogOn As Boolean
)
Visual C++
[ObsoleteAttribute]
void UpdateFirstTimeLogOn(
    String^ membershipId,
    String^ password,
    String^ securityQuestion,
    String^ securityAnswer,
    bool firstLogOn
)

Parameters

membershipId
Type: System..::..String
The membership id.
password
Type: System..::..String
The password.
securityQuestion
Type: System..::..String
The security question.
securityAnswer
Type: System..::..String
The security answer.
firstLogOn
Type: System..::..Boolean
if set to true [first log on].

Exceptions

Exception | Condition
System..::..ArgumentNullException | If password or securityAnswer or Security Question is null.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
UpdateFirstTimeLogOn Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdateFirstTimeLogOn Method (String, String, String, String, Boolean, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdateFirstTimeLogOn Method (String, String, String, String, Boolean, String)
IUserDetailsService Interface See Also Send Feedback
Update the password and security question/answer

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateFirstTimeLogOn(
    string membershipId,
    string password,
    string securityQuestion,
    string securityAnswer,
    bool firstLogOn,
    string tenantId
)
Visual Basic
Sub UpdateFirstTimeLogOn (
    membershipId As String,
    password As String,
    securityQuestion As String,
    securityAnswer As String,
    firstLogOn As Boolean,
    tenantId As String
)
Visual C++
void UpdateFirstTimeLogOn(
    String^ membershipId,
    String^ password,
    String^ securityQuestion,
    String^ securityAnswer,
    bool firstLogOn,
    String^ tenantId
)

Parameters

membershipId
Type: System..::..String
membership id(Mandatory)
password
Type: System..::..String
new password (Mandatory)
securityQuestion
Type: System..::..String
security question
securityAnswer
Type: System..::..String
security answer
firstLogOn
Type: System..::..Boolean
if set to true [first log on].
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
System..::..ArgumentNullException |
System..::..ArgumentException |
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
UpdateFirstTimeLogOn Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdatePasswordExpirationDate Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdatePasswordExpirationDate Method
IUserDetailsService Interface See Also Send Feedback
Update the user password expiry date for the given membershipid

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdatePasswordExpirationDate(
    string membershipId,
    string tenantId
)
Visual Basic
Function UpdatePasswordExpirationDate (
    membershipId As String,
    tenantId As String
) As Boolean
Visual C++
bool UpdatePasswordExpirationDate(
    String^ membershipId,
    String^ tenantId
)

Parameters

membershipId
Type: System..::..String
user membership id to change the expiry date for
tenantId
Type: System..::..String
the user's tenant id

Return Value

Type: Boolean
true : if the update is successful false : if the update has failed.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the tenant id or membership id is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdatePasswordExpirationStatus Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdatePasswordExpirationStatus Method
IUserDetailsService Interface See Also Send Feedback
Updates the password expiry status daily and sets the expiry status for each user in the userpasswordexpiration table.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, MembershipDetails> UpdatePasswordExpirationStatus()
Visual Basic
Function UpdatePasswordExpirationStatus As Dictionary(Of String, MembershipDetails)
Visual C++
Dictionary<String^, MembershipDetails^>^ UpdatePasswordExpirationStatus()

Return Value

Type: Dictionary<(Of <(<'String, MembershipDetails >)>)>

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdateUser Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdateUser Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateUser(UserDetails) | Update the given user details.
Public method | UpdateUser(MembershipDetails, User, Address) | Update the given user details.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdateUser Method (UserDetails)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdateUser Method (UserDetails)
IUserDetailsService Interface Example See Also Send Feedback
Update the given user details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateUser(
    UserDetails userDetails
)
Visual Basic
Function UpdateUser (
    userDetails As UserDetails
) As String
Visual C++
String^ UpdateUser(
    UserDetails^ userDetails
)

Parameters

userDetails
Type: CelloSaaS.Model.UserManagement..::..UserDetails
User Details

Return Value

Type: String
User Identifier

Examples

Copy image Copy
Public string UpdateUserDetails()
{
    // Create instance for UserDetails
    UserDetails userDetails = new UserDetails();

    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "4AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "admin@company.com";
    userDetails.MembershipDetails.UserName = "admin@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";

    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address";
    userDetails.Address.City = "City";
    userDetails.Address.State = "State";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";

    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "3398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "4AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Company Admin";
    userDetails.User.LastName = "Test";

    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    string userId = userDetailsService.UpdateUser(userDetails);
}

Exceptions

Exception | Condition
System..::..UnauthorizedAccessException | If the user has not the privilege to update the user details
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
UpdateUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UpdateUser Method (MembershipDetails, User, Address)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UpdateUser Method (MembershipDetails, User, Address)
IUserDetailsService Interface Example See Also Send Feedback
Update the given user details.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UpdateUser(
    MembershipDetails membershipDetails,
    User user,
    Address address
)
Visual Basic
Function UpdateUser (
    membershipDetails As MembershipDetails,
    user As User,
    address As Address
) As String
Visual C++
String^ UpdateUser(
    MembershipDetails^ membershipDetails,
    User^ user,
    Address^ address
)

Parameters

membershipDetails
Type: CelloSaaS.Model.UserManagement..::..MembershipDetails
Membership Details(Mandatory)
user
Type: CelloSaaS.Model.UserManagement..::..User
User Details(Mandatory)
address
Type: CelloSaaS.Model.TenantManagement..::..Address
Address details

Return Value

Type: String
User Identifier

Examples

Copy image Copy
Public string UpdateUserDetails()
{
    // Create instance for UserDetails
    UserDetails userDetails = new UserDetails();

    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "4AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "admin@company.com";
    userDetails.MembershipDetails.UserName = "admin@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";

    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address";
    userDetails.Address.City = "City";
    userDetails.Address.State = "State";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";

    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "3398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "4AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Company Admin";
    userDetails.User.LastName = "Test";

    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    string userId = userDetailsService.UpdateUser(userDetails.MembershipDetails, userDetails.Address, userDetails.User);
}

See Also

IUserDetailsService Interface
IUserDetailsService Members
UpdateUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UserDetailsBulkInsert Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UserDetailsBulkInsert Method
IUserDetailsService Interface Example See Also Send Feedback
This method is used to insert bulk user details

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<UserBulkInsertError> UserDetailsBulkInsert(
    List<UserDetails> userDetails
)
Visual Basic
Function UserDetailsBulkInsert (
    userDetails As List(Of UserDetails)
) As List(Of UserBulkInsertError)
Visual C++
List<UserBulkInsertError^>^ UserDetailsBulkInsert(
    List<UserDetails^>^ userDetails
)

Parameters

userDetails
Type: System.Collections.Generic..::..List<(Of <(<' UserDetails >)>)>
User Details List

Return Value

Type: List<(Of <(<' UserBulkInsertError >)>)>
Un inserted User Details

Examples

Copy image Copy
public void UserDetailsBulkInsert()
{
    List<UserDetails> userDetailsList = new  List<UserDetails>();
    for (int count = 0; count < 1000; count++)
    {
        // Create instance for UserDetails
        UserDetails userDetails = new UserDetails();

        //Fill membership details
        userDetails.MembershipDetails.EmailId = "user"+count+"@company.com";
        userDetails.MembershipDetails.UserName = user"+count+"@company.com";
        userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";

        //Fill Address Details
        userDetails.Address.Address1 = "Address"+count;
        userDetails.Address.City = "City"+count;
        userDetails.Address.State = "State"+count;
        userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
        userDetails.Address.PostalCode = "600025";

        //Fill User Details
        userDetails.User.FirstName = "User"+count;
        userDetails.User.LastName = "Test"+count;

        userDetailsList.Add(userDetails);
    }
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    List<UserBulkInsertError> unInsertedUserDetails = userDetailsService.UserDetailsBulkInsert(userDetailsList);
}
IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
List<UserBulkInsertError> unInsertedUserDetails = userDetailsService.UserDetailsBulkInsert(userDetailsList);
}

Exceptions

Exception | Condition
System..::..ArgumentException | If the user details are null
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user details is null

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.UserDetailsBulkUpdate Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..UserDetailsBulkUpdate Method
IUserDetailsService Interface Example See Also Send Feedback
This method is used to update bulk user details

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<UserBulkInsertError> UserDetailsBulkUpdate(
    List<UserDetails> userDetails
)
Visual Basic
Function UserDetailsBulkUpdate (
    userDetails As List(Of UserDetails)
) As List(Of UserBulkInsertError)
Visual C++
List<UserBulkInsertError^>^ UserDetailsBulkUpdate(
    List<UserDetails^>^ userDetails
)

Parameters

userDetails
Type: System.Collections.Generic..::..List<(Of <(<' UserDetails >)>)>
User Details List

Return Value

Type: List<(Of <(<' UserBulkInsertError >)>)>
Un updated User Details

Examples

Copy image Copy
public void UserDetailsBuklkUpdate()
{
    List<UserDetails> userDetailsList = new  List<UserDetails>();

    UserDetails userDetails = new UserDetails();
    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "4AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "user1@company.com";
    userDetails.MembershipDetails.UserName = "user1@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address1";
    userDetails.Address.City = "City1";
    userDetails.Address.State = "State1";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";
    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "3398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "4AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "398C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Uer1";
    userDetails.User.LastName = "Test1";
    userDetailsList.Add(userDetails);

    userDetails = new UserDetails();
    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "5AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "user2@company.com";
    userDetails.MembershipDetails.UserName = "user2@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "498C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address2";
    userDetails.Address.City = "City2";
    userDetails.Address.State = "State2";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";
    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "4398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "5AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "498C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Uer2";
    userDetails.User.LastName = "Test2";
    userDetailsList.Add(userDetails);

    userDetails = new UserDetails();
    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "6AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "user3@company.com";
    userDetails.MembershipDetails.UserName = "user3@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "598C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address3";
    userDetails.Address.City = "City3";
    userDetails.Address.State = "State3";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";
    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "5398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "6AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "598C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Uer3";
    userDetails.User.LastName = "Test3";
    userDetailsList.Add(userDetails);

    userDetails = new UserDetails();
    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "7AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "user4@company.com";
    userDetails.MembershipDetails.UserName = "user4@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "698C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address4";
    userDetails.Address.City = "City4";
    userDetails.Address.State = "State4";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";
    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "6398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "7AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "698C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Uer4";
    userDetails.User.LastName = "Test4";
    userDetailsList.Add(userDetails);

    userDetails = new UserDetails();
    //Fill Membership Details
    userDetails.MembershipDetails.Identifier = userDetails.MembershipDetails.MembershipId = "8AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.MembershipDetails.EmailId = "user5@company.com";
    userDetails.MembershipDetails.UserName = "user5@company.com";
    userDetails.MembershipDetails.TenantCode = "B590CD25-3093-DF11-8DEB-001EC9DAB123";
    //Fill Address Details
    userDetails.Address.Identifier = userDetails.Address.AddressId = "798C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.Address.Address1 = "Address5";
    userDetails.Address.City = "City5";
    userDetails.Address.State = "State5";
    userDetails.Address.CountryId = "3FD432E1-A8A4-4F22-BE65-DF751A1FBFE3"; // US
    userDetails.Address.PostalCode = "600025";
    //Fill User Details
    userDetails.User.Identifier = userDetails.User.UserId = "7398F837-B988-4708-999D-D3DFE11875B3";
    userDetails.User.MembershipId = "8AD211A6-E845-43E9-A668-6F5BDBFB7F3C";
    userDetails.User.AddressId = "798C0E1A-C993-DF11-8DEB-001EC9DAB123";
    userDetails.User.FirstName = "Uer5";
    userDetails.User.LastName = "Test5";
    userDetailsList.Add(userDetails);

    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    List<UserBulkInsertError> unUpdatedUserDetails = userDetailsService.UserDetailsBuklkUpdate(userDetailsList);
}

Exceptions

Exception | Condition
System..::..ArgumentException | If the user details are null.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If the user details are null.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ValidateSecurityAnswer Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ValidateSecurityAnswer Method
IUserDetailsService Interface See Also Send Feedback
This method checks the security answer for the given user and updates the failure attempts. If exceeds the maximum allowed number, then it locks the user account.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateSecurityAnswer(
    string companyCode,
    string userName,
    string answer
)
Visual Basic
Function ValidateSecurityAnswer (
    companyCode As String,
    userName As String,
    answer As String
) As Boolean
Visual C++
bool ValidateSecurityAnswer(
    String^ companyCode,
    String^ userName,
    String^ answer
)

Parameters

companyCode
Type: System..::..String
Company Code of the user
userName
Type: System..::..String
user name
answer
Type: System..::..String
security answer

Return Value

Type: Boolean
Returns True/False

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ValidateUser Method

[image] [image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ValidateUser Method
IUserDetailsService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateUser(String, String) | Obsolete. Validates the user login credentials. True if the valid credentials passed else False
Public method | ValidateUser(String, String, String) | Validates the user login credentials. True if the valid credentials passed else False Primarly used in Forms validation

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ValidateUser Method (String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ValidateUser Method (String, String)
IUserDetailsService Interface Example See Also Send Feedback
Validates the user login credentials. True if the valid credentials passed else False

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[ObsoleteAttribute("Use the other overload provided")]
bool ValidateUser(
    string userName,
    string password
)
Visual Basic
<ObsoleteAttribute("Use the other overload provided")>
Function ValidateUser (
    userName As String,
    password As String
) As Boolean
Visual C++
[ObsoleteAttribute(L"Use the other overload provided")]
bool ValidateUser(
    String^ userName,
    String^ password
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
password
Type: System..::..String
Password (Mandatory)

Return Value

Type: Boolean
returns True/False

Examples

Copy image Copy
public void ValidateUser()
{
    string userName = "admin@company.com";
    string password = "company";
    IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
    bool validUser = userDetailsService.ValidateUser(userName, password);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDeactivateException | If the user is in deactivated status.
CelloSaaS.ServiceContracts.UserManagement..::..UserLockedOutException | If the user is in locked status.
CelloSaaS.ServiceContracts.UserManagement..::..UserPasswordExpirationException | If the user's password is in expiry status.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If any exception occur, while connecting or modifying the database.
System..::..ArgumentNullException | If user name or password is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
ValidateUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ValidateUser Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ValidateUser Method (String, String, String)
IUserDetailsService Interface Example See Also Send Feedback
Validates the user login credentials. True if the valid credentials passed else False Primarly used in Forms validation

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateUser(
    string userName,
    string password,
    string companyCode
)
Visual Basic
Function ValidateUser (
    userName As String,
    password As String,
    companyCode As String
) As Boolean
Visual C++
bool ValidateUser(
    String^ userName,
    String^ password,
    String^ companyCode
)

Parameters

userName
Type: System..::..String
User Name(Mandatory)
password
Type: System..::..String
Password(Mandatory)
companyCode
Type: System..::..String
Company Code(Mandatory)

Return Value

Type: Boolean
returns True/False

Examples

Copy image Copy
public void ValidateUser()
{
string userName = "admin@company.com";
string password = "company";
string companyCode = "company";
IUserDetailsService userDetailsService = (IUserDetailsService)ServiceLocator.GetServiceImplementation(typeof(IUserDetailsService));
bool validUser = userDetailsService.ValidateUser(userName, password, companyCode);
}

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDeactivateException | If the user is in deactivated status.
CelloSaaS.ServiceContracts.UserManagement..::..UserLockedOutException | If the user is in locked status.
CelloSaaS.ServiceContracts.UserManagement..::..UserPasswordExpirationException | If the user's password is in expiry status.
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If any exception occur, while connecting or modifying the database.
System..::..ArgumentNullException | If user name or password or company code is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
ValidateUser Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


IUserDetailsService.ValidateWCFUser Method

[image]

A Sandcastle Documented Class Library
IUserDetailsService..::..ValidateWCFUser Method
IUserDetailsService Interface See Also Send Feedback
Validates the tenant API key. Used to authenticate WCF service calls.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool ValidateWCFUser(
    string userName,
    string wcfSharedKey,
    string tenantId
)
Visual Basic
Function ValidateWCFUser (
    userName As String,
    wcfSharedKey As String,
    tenantId As String
) As Boolean
Visual C++
bool ValidateWCFUser(
    String^ userName,
    String^ wcfSharedKey,
    String^ tenantId
)

Parameters

userName
Type: System..::..String
Name of the user.
wcfSharedKey
Type: System..::..String
The WCF shared key.
tenantId
Type: System..::..String
The tenantId

Return Value

Type: Boolean

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException | If Any exception occurred, while connecting or modifying the database.
System..::..ArgumentNullException | If tenant id or user name or wcf shared key is null or empty.

See Also

IUserDetailsService Interface
IUserDetailsService Members
CelloSaaS.ServiceContracts.UserManagement Namespace


LicenseLimitException Class

[image]

A Sandcastle Documented Class Library
LicenseLimitException Class
Members See Also Send Feedback
This exception used to catch user count exceed for tenant

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LicenseLimitException : BaseException
Visual Basic
<SerializableAttribute>
Public Class LicenseLimitException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class LicenseLimitException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..LicenseLimitException

See Also

LicenseLimitException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


LicenseLimitException Members

[image] [image]

A Sandcastle Documented Class Library
LicenseLimitException Members
LicenseLimitException Class Constructors Methods Properties Events See Also Send Feedback

The LicenseLimitException type exposes the following members.

Constructors

 | Name | Description
Public method | LicenseLimitException | Initializes a new instance of the LicenseLimitException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LicenseLimitException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


LicenseLimitException Constructor

[image]

A Sandcastle Documented Class Library
LicenseLimitException Constructor
LicenseLimitException Class See Also Send Feedback
Initializes a new instance of the LicenseLimitException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LicenseLimitException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
LicenseLimitException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

LicenseLimitException Class
LicenseLimitException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


LicenseLimitException Methods

[image] [image]

A Sandcastle Documented Class Library
LicenseLimitException Methods
LicenseLimitException Class See Also Send Feedback

The LicenseLimitException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseLimitException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


LicenseLimitException Properties

[image] [image]

A Sandcastle Documented Class Library
LicenseLimitException Properties
LicenseLimitException Class See Also Send Feedback

The LicenseLimitException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseLimitException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


LicenseLimitException Events

[image] [image]

A Sandcastle Documented Class Library
LicenseLimitException Events
LicenseLimitException Class See Also Send Feedback

The LicenseLimitException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LicenseLimitException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants Class

[image]

A Sandcastle Documented Class Library
MembershipConstants Class
Members See Also Send Feedback
Contains User Membership Constants

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class MembershipConstants
Visual Basic
Public Class MembershipConstants
Visual C++
public ref class MembershipConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.ServiceContracts.UserManagement..::..MembershipConstants

See Also

MembershipConstants Members
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants Members

[image] [image]

A Sandcastle Documented Class Library
MembershipConstants Members
MembershipConstants Class Constructors Methods Fields See Also Send Feedback

The MembershipConstants type exposes the following members.

Constructors

 | Name | Description
Public method | MembershipConstants | Initializes a new instance of the MembershipConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ForgotPasswordModeKey | This is forgot password mode. Whether need to send resetted passsword or user passwod to user.
ForgotPasswordModeValueReset | Send reset password to user.
ForgotPasswordModeValueSend | Send the user password to user without reset.
SendConfirmationKey | This is used to send comformation mail to user. If you want conformation mail to user then add SendConfirmation key and True/False value in Appsetting.

See Also

MembershipConstants Class
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants Constructor

[image]

A Sandcastle Documented Class Library
MembershipConstants Constructor
MembershipConstants Class See Also Send Feedback
Initializes a new instance of the MembershipConstants class

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MembershipConstants()
Visual Basic
Public Sub New
Visual C++
public:
MembershipConstants()

See Also

MembershipConstants Class
MembershipConstants Members
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants Fields

[image] [image]

A Sandcastle Documented Class Library
MembershipConstants Fields
MembershipConstants Class See Also Send Feedback

The MembershipConstants type exposes the following members.

Fields

Name | Description
ForgotPasswordModeKey | This is forgot password mode. Whether need to send resetted passsword or user passwod to user.
ForgotPasswordModeValueReset | Send reset password to user.
ForgotPasswordModeValueSend | Send the user password to user without reset.
SendConfirmationKey | This is used to send comformation mail to user. If you want conformation mail to user then add SendConfirmation key and True/False value in Appsetting.

See Also

MembershipConstants Class
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants.ForgotPasswordModeKey Field

[image]

A Sandcastle Documented Class Library
MembershipConstants..::..ForgotPasswordModeKey Field
MembershipConstants Class See Also Send Feedback
This is forgot password mode. Whether need to send resetted passsword or user passwod to user.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ForgotPasswordModeKey
Visual Basic
Public Const ForgotPasswordModeKey As String
Visual C++
public:
literal String^ ForgotPasswordModeKey

Field Value

Type: String

See Also

MembershipConstants Class
MembershipConstants Members
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants.ForgotPasswordModeValueReset Field

[image]

A Sandcastle Documented Class Library
MembershipConstants..::..ForgotPasswordModeValueReset Field
MembershipConstants Class See Also Send Feedback
Send reset password to user.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ForgotPasswordModeValueReset
Visual Basic
Public Const ForgotPasswordModeValueReset As String
Visual C++
public:
literal String^ ForgotPasswordModeValueReset

Field Value

Type: String

See Also

MembershipConstants Class
MembershipConstants Members
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants.ForgotPasswordModeValueSend Field

[image]

A Sandcastle Documented Class Library
MembershipConstants..::..ForgotPasswordModeValueSend Field
MembershipConstants Class See Also Send Feedback
Send the user password to user without reset.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ForgotPasswordModeValueSend
Visual Basic
Public Const ForgotPasswordModeValueSend As String
Visual C++
public:
literal String^ ForgotPasswordModeValueSend

Field Value

Type: String

See Also

MembershipConstants Class
MembershipConstants Members
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants.SendConfirmationKey Field

[image]

A Sandcastle Documented Class Library
MembershipConstants..::..SendConfirmationKey Field
MembershipConstants Class See Also Send Feedback
This is used to send comformation mail to user. If you want conformation mail to user then add SendConfirmation key and True/False value in Appsetting.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SendConfirmationKey
Visual Basic
Public Const SendConfirmationKey As String
Visual C++
public:
literal String^ SendConfirmationKey

Field Value

Type: String

See Also

MembershipConstants Class
MembershipConstants Members
CelloSaaS.ServiceContracts.UserManagement Namespace


MembershipConstants Methods

[image] [image]

A Sandcastle Documented Class Library
MembershipConstants Methods
MembershipConstants Class See Also Send Feedback

The MembershipConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MembershipConstants Class
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException Class

[image]

A Sandcastle Documented Class Library
SendMailException Class
Members See Also Send Feedback
This exception is used to catch failure mail sending

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SendMailException : BaseException
Visual Basic
<SerializableAttribute>
Public Class SendMailException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class SendMailException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..SendMailException

See Also

SendMailException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException Members

[image] [image]

A Sandcastle Documented Class Library
SendMailException Members
SendMailException Class Constructors Methods Properties Events See Also Send Feedback

The SendMailException type exposes the following members.

Constructors

 | Name | Description
Public method | SendMailException | Initializes a new instance of the SendMailException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | UserId | Gets or sets the user id.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SendMailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException Constructor

[image]

A Sandcastle Documented Class Library
SendMailException Constructor
SendMailException Class See Also Send Feedback
Initializes a new instance of the SendMailException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SendMailException(
    string userId,
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    userId As String,
    message As String,
    innerException As Exception
)
Visual C++
public:
SendMailException(
    String^ userId,
    String^ message,
    Exception^ innerException
)

Parameters

userId
Type: System..::..String
The user id.
message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

SendMailException Class
SendMailException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException Methods

[image] [image]

A Sandcastle Documented Class Library
SendMailException Methods
SendMailException Class See Also Send Feedback

The SendMailException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SendMailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException Properties

[image] [image]

A Sandcastle Documented Class Library
SendMailException Properties
SendMailException Class See Also Send Feedback

The SendMailException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | UserId | Gets or sets the user id.

See Also

SendMailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException.UserId Property

[image]

A Sandcastle Documented Class Library
SendMailException..::..UserId Property
SendMailException Class See Also Send Feedback
Gets or sets the user id.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user id.

See Also

SendMailException Class
SendMailException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


SendMailException Events

[image] [image]

A Sandcastle Documented Class Library
SendMailException Events
SendMailException Class See Also Send Feedback

The SendMailException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

SendMailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Class

[image]

A Sandcastle Documented Class Library
TenantUserAssociationException Class
Members See Also Send Feedback
Incase of any exception while fetching the Tenant User Association

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TenantUserAssociationException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TenantUserAssociationException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TenantUserAssociationException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..TenantUserAssociationException

See Also

TenantUserAssociationException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Members

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationException Members
TenantUserAssociationException Class Constructors Methods Properties Events See Also Send Feedback

The TenantUserAssociationException type exposes the following members.

Constructors

 | Name | Description
Public method | TenantUserAssociationException()()()() | Initializes a new instance of the TenantUserAssociationException class.
Public method | TenantUserAssociationException(String) | Initializes a new instance of the TenantUserAssociationException class.
Public method | TenantUserAssociationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantUserAssociationException class.
Public method | TenantUserAssociationException(String, Exception) | Initializes a new instance of the TenantUserAssociationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantUserAssociationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Constructor

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationException Constructor
TenantUserAssociationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TenantUserAssociationException()()()() | Initializes a new instance of the TenantUserAssociationException class.
Public method | TenantUserAssociationException(String) | Initializes a new instance of the TenantUserAssociationException class.
Public method | TenantUserAssociationException(SerializationInfo, StreamingContext) | Initializes a new instance of the TenantUserAssociationException class.
Public method | TenantUserAssociationException(String, Exception) | Initializes a new instance of the TenantUserAssociationException class.

See Also

TenantUserAssociationException Class
TenantUserAssociationException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Constructor

[image]

A Sandcastle Documented Class Library
TenantUserAssociationException Constructor
TenantUserAssociationException Class See Also Send Feedback
Initializes a new instance of the TenantUserAssociationException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantUserAssociationException()
Visual Basic
Public Sub New
Visual C++
public:
TenantUserAssociationException()

See Also

TenantUserAssociationException Class
TenantUserAssociationException Members
TenantUserAssociationException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Constructor (String)

[image]

A Sandcastle Documented Class Library
TenantUserAssociationException Constructor (String)
TenantUserAssociationException Class See Also Send Feedback
Initializes a new instance of the TenantUserAssociationException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantUserAssociationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TenantUserAssociationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TenantUserAssociationException Class
TenantUserAssociationException Members
TenantUserAssociationException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TenantUserAssociationException Constructor (SerializationInfo, StreamingContext)
TenantUserAssociationException Class See Also Send Feedback
Initializes a new instance of the TenantUserAssociationException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantUserAssociationException(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic
Public Sub New (
    serializationInfo As SerializationInfo,
    streamingContext As StreamingContext
)
Visual C++
public:
TenantUserAssociationException(
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::..SerializationInfo
The serialization info.
streamingContext
Type: System.Runtime.Serialization..::..StreamingContext
The streaming context.

See Also

TenantUserAssociationException Class
TenantUserAssociationException Members
TenantUserAssociationException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TenantUserAssociationException Constructor (String, Exception)
TenantUserAssociationException Class See Also Send Feedback
Initializes a new instance of the TenantUserAssociationException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TenantUserAssociationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TenantUserAssociationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TenantUserAssociationException Class
TenantUserAssociationException Members
TenantUserAssociationException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Methods

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationException Methods
TenantUserAssociationException Class See Also Send Feedback

The TenantUserAssociationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TenantUserAssociationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Properties

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationException Properties
TenantUserAssociationException Class See Also Send Feedback

The TenantUserAssociationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TenantUserAssociationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


TenantUserAssociationException Events

[image] [image]

A Sandcastle Documented Class Library
TenantUserAssociationException Events
TenantUserAssociationException Class See Also Send Feedback

The TenantUserAssociationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TenantUserAssociationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Class

[image]

A Sandcastle Documented Class Library
UserActivityException Class
Members See Also Send Feedback
This exception is thrown in the event of any issues that arise when handling the User Activity

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserActivityException : BaseException
Visual Basic
<SerializableAttribute>
Public Class UserActivityException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class UserActivityException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..UserActivityException

See Also

UserActivityException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Members

[image] [image]

A Sandcastle Documented Class Library
UserActivityException Members
UserActivityException Class Constructors Methods Properties Events See Also Send Feedback

The UserActivityException type exposes the following members.

Constructors

 | Name | Description
Public method | UserActivityException(String) | Initializes a new instance of the UserDetailException class.
Public method | UserActivityException(String, Exception) | Initializes a new instance of the UserDetailException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserActivityException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserActivityException Constructor
UserActivityException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserActivityException(String) | Initializes a new instance of the UserDetailException class.
Public method | UserActivityException(String, Exception) | Initializes a new instance of the UserDetailException class.

See Also

UserActivityException Class
UserActivityException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserActivityException Constructor (String)
UserActivityException Class See Also Send Feedback
Initializes a new instance of the UserDetailException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserActivityException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserActivityException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UserActivityException Class
UserActivityException Members
UserActivityException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
UserActivityException Constructor (String, Exception)
UserActivityException Class See Also Send Feedback
Initializes a new instance of the UserDetailException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserActivityException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
UserActivityException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

UserActivityException Class
UserActivityException Members
UserActivityException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Methods

[image] [image]

A Sandcastle Documented Class Library
UserActivityException Methods
UserActivityException Class See Also Send Feedback

The UserActivityException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserActivityException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Properties

[image] [image]

A Sandcastle Documented Class Library
UserActivityException Properties
UserActivityException Class See Also Send Feedback

The UserActivityException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserActivityException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserActivityException Events

[image] [image]

A Sandcastle Documented Class Library
UserActivityException Events
UserActivityException Class See Also Send Feedback

The UserActivityException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserActivityException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Class

[image]

A Sandcastle Documented Class Library
UserDeactivateException Class
Members See Also Send Feedback
This exception is used to catch when user exceed password failure attempts

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserDeactivateException : Exception
Visual Basic
<SerializableAttribute>
Public Class UserDeactivateException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class UserDeactivateException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.ServiceContracts.UserManagement..::..UserDeactivateException

See Also

UserDeactivateException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Members

[image] [image]

A Sandcastle Documented Class Library
UserDeactivateException Members
UserDeactivateException Class Constructors Methods Properties Events See Also Send Feedback

The UserDeactivateException type exposes the following members.

Constructors

 | Name | Description
Public method | UserDeactivateException()()()() | Initializes a new instance of the UserDeactivateException class.
Public method | UserDeactivateException(String) | Initializes a new instance of the UserDeactivateException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserDeactivateException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserDeactivateException Constructor
UserDeactivateException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserDeactivateException()()()() | Initializes a new instance of the UserDeactivateException class.
Public method | UserDeactivateException(String) | Initializes a new instance of the UserDeactivateException class.

See Also

UserDeactivateException Class
UserDeactivateException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Constructor

[image]

A Sandcastle Documented Class Library
UserDeactivateException Constructor
UserDeactivateException Class See Also Send Feedback
Initializes a new instance of the UserDeactivateException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDeactivateException()
Visual Basic
Public Sub New
Visual C++
public:
UserDeactivateException()

See Also

UserDeactivateException Class
UserDeactivateException Members
UserDeactivateException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserDeactivateException Constructor (String)
UserDeactivateException Class See Also Send Feedback
Initializes a new instance of the UserDeactivateException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDeactivateException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserDeactivateException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UserDeactivateException Class
UserDeactivateException Members
UserDeactivateException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Methods

[image] [image]

A Sandcastle Documented Class Library
UserDeactivateException Methods
UserDeactivateException Class See Also Send Feedback

The UserDeactivateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserDeactivateException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Properties

[image] [image]

A Sandcastle Documented Class Library
UserDeactivateException Properties
UserDeactivateException Class See Also Send Feedback

The UserDeactivateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserDeactivateException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDeactivateException Events

[image] [image]

A Sandcastle Documented Class Library
UserDeactivateException Events
UserDeactivateException Class See Also Send Feedback

The UserDeactivateException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserDeactivateException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Class

[image]

A Sandcastle Documented Class Library
UserDetailException Class
Members See Also Send Feedback
UserDetail Exception

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserDetailException : BaseException
Visual Basic
<SerializableAttribute>
Public Class UserDetailException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class UserDetailException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..UserDetailException

See Also

UserDetailException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Members

[image] [image]

A Sandcastle Documented Class Library
UserDetailException Members
UserDetailException Class Constructors Methods Properties Events See Also Send Feedback

The UserDetailException type exposes the following members.

Constructors

 | Name | Description
Public method | UserDetailException(String) | Initializes a new instance of the UserDetailException class.
Public method | UserDetailException(String, Exception) | Initializes a new instance of the UserDetailException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserDetailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserDetailException Constructor
UserDetailException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserDetailException(String) | Initializes a new instance of the UserDetailException class.
Public method | UserDetailException(String, Exception) | Initializes a new instance of the UserDetailException class.

See Also

UserDetailException Class
UserDetailException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserDetailException Constructor (String)
UserDetailException Class See Also Send Feedback
Initializes a new instance of the UserDetailException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetailException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserDetailException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UserDetailException Class
UserDetailException Members
UserDetailException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
UserDetailException Constructor (String, Exception)
UserDetailException Class See Also Send Feedback
Initializes a new instance of the UserDetailException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserDetailException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
UserDetailException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

UserDetailException Class
UserDetailException Members
UserDetailException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Methods

[image] [image]

A Sandcastle Documented Class Library
UserDetailException Methods
UserDetailException Class See Also Send Feedback

The UserDetailException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserDetailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Properties

[image] [image]

A Sandcastle Documented Class Library
UserDetailException Properties
UserDetailException Class See Also Send Feedback

The UserDetailException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserDetailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserDetailException Events

[image] [image]

A Sandcastle Documented Class Library
UserDetailException Events
UserDetailException Class See Also Send Feedback

The UserDetailException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserDetailException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Class

[image]

A Sandcastle Documented Class Library
UserLockedOutException Class
Members See Also Send Feedback
This exception is used to catch when user exceed password failure attempts

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserLockedOutException : Exception
Visual Basic
<SerializableAttribute>
Public Class UserLockedOutException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class UserLockedOutException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.ServiceContracts.UserManagement..::..UserLockedOutException

See Also

UserLockedOutException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Members

[image] [image]

A Sandcastle Documented Class Library
UserLockedOutException Members
UserLockedOutException Class Constructors Methods Properties Events See Also Send Feedback

The UserLockedOutException type exposes the following members.

Constructors

 | Name | Description
Public method | UserLockedOutException()()()() | Initializes a new instance of the UserLockedOutException class.
Public method | UserLockedOutException(String) | Initializes a new instance of the UserLockedOutException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserLockedOutException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserLockedOutException Constructor
UserLockedOutException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserLockedOutException()()()() | Initializes a new instance of the UserLockedOutException class.
Public method | UserLockedOutException(String) | Initializes a new instance of the UserLockedOutException class.

See Also

UserLockedOutException Class
UserLockedOutException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Constructor

[image]

A Sandcastle Documented Class Library
UserLockedOutException Constructor
UserLockedOutException Class See Also Send Feedback
Initializes a new instance of the UserLockedOutException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserLockedOutException()
Visual Basic
Public Sub New
Visual C++
public:
UserLockedOutException()

See Also

UserLockedOutException Class
UserLockedOutException Members
UserLockedOutException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserLockedOutException Constructor (String)
UserLockedOutException Class See Also Send Feedback
Initializes a new instance of the UserLockedOutException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserLockedOutException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserLockedOutException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UserLockedOutException Class
UserLockedOutException Members
UserLockedOutException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Methods

[image] [image]

A Sandcastle Documented Class Library
UserLockedOutException Methods
UserLockedOutException Class See Also Send Feedback

The UserLockedOutException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserLockedOutException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Properties

[image] [image]

A Sandcastle Documented Class Library
UserLockedOutException Properties
UserLockedOutException Class See Also Send Feedback

The UserLockedOutException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserLockedOutException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserLockedOutException Events

[image] [image]

A Sandcastle Documented Class Library
UserLockedOutException Events
UserLockedOutException Class See Also Send Feedback

The UserLockedOutException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserLockedOutException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Class

[image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Class
Members See Also Send Feedback
This is to raise the password expiration exception, due to the password expiry after a finite amount of time.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserPasswordExpirationException : BaseException
Visual Basic
<SerializableAttribute>
Public Class UserPasswordExpirationException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class UserPasswordExpirationException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.UserManagement..::..UserPasswordExpirationException

See Also

UserPasswordExpirationException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Members

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Members
UserPasswordExpirationException Class Constructors Methods Properties Events See Also Send Feedback

The UserPasswordExpirationException type exposes the following members.

Constructors

 | Name | Description
Public method | UserPasswordExpirationException(String) | Initializes a new instance of the UserPasswordExpirationException class.
Public method | UserPasswordExpirationException(String, Exception) | Initializes a new instance of the UserPasswordExpirationException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserPasswordExpirationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Constructor

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Constructor
UserPasswordExpirationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserPasswordExpirationException(String) | Initializes a new instance of the UserPasswordExpirationException class.
Public method | UserPasswordExpirationException(String, Exception) | Initializes a new instance of the UserPasswordExpirationException class.

See Also

UserPasswordExpirationException Class
UserPasswordExpirationException Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Constructor (String)

[image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Constructor (String)
UserPasswordExpirationException Class See Also Send Feedback
Initializes a new instance of the UserPasswordExpirationException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserPasswordExpirationException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserPasswordExpirationException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UserPasswordExpirationException Class
UserPasswordExpirationException Members
UserPasswordExpirationException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Constructor (String, Exception)
UserPasswordExpirationException Class See Also Send Feedback
Initializes a new instance of the UserPasswordExpirationException class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserPasswordExpirationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
UserPasswordExpirationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

UserPasswordExpirationException Class
UserPasswordExpirationException Members
UserPasswordExpirationException Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Methods

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Methods
UserPasswordExpirationException Class See Also Send Feedback

The UserPasswordExpirationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserPasswordExpirationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Properties

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Properties
UserPasswordExpirationException Class See Also Send Feedback

The UserPasswordExpirationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserPasswordExpirationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordExpirationException Events

[image] [image]

A Sandcastle Documented Class Library
UserPasswordExpirationException Events
UserPasswordExpirationException Class See Also Send Feedback

The UserPasswordExpirationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserPasswordExpirationException Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Class

[image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Class
Members See Also Send Feedback
This exception is used to inform the controller that on next password failure attempt the user will be locked out

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class UserPasswordPenultimateFailureAttempt : Exception
Visual Basic
<SerializableAttribute>
Public Class UserPasswordPenultimateFailureAttempt
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class UserPasswordPenultimateFailureAttempt : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.ServiceContracts.UserManagement..::..UserPasswordPenultimateFailureAttempt

See Also

UserPasswordPenultimateFailureAttempt Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Members

[image] [image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Members
UserPasswordPenultimateFailureAttempt Class Constructors Methods Properties Events See Also Send Feedback

The UserPasswordPenultimateFailureAttempt type exposes the following members.

Constructors

 | Name | Description
Public method | UserPasswordPenultimateFailureAttempt()()()() | Initializes a new instance of the UserPasswordPenultimateFailureAttempt class.
Public method | UserPasswordPenultimateFailureAttempt(String) | Initializes a new instance of the UserPasswordPenultimateFailureAttempt class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserPasswordPenultimateFailureAttempt Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Constructor

[image] [image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Constructor
UserPasswordPenultimateFailureAttempt Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UserPasswordPenultimateFailureAttempt()()()() | Initializes a new instance of the UserPasswordPenultimateFailureAttempt class.
Public method | UserPasswordPenultimateFailureAttempt(String) | Initializes a new instance of the UserPasswordPenultimateFailureAttempt class.

See Also

UserPasswordPenultimateFailureAttempt Class
UserPasswordPenultimateFailureAttempt Members
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Constructor

[image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Constructor
UserPasswordPenultimateFailureAttempt Class See Also Send Feedback
Initializes a new instance of the UserPasswordPenultimateFailureAttempt class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserPasswordPenultimateFailureAttempt()
Visual Basic
Public Sub New
Visual C++
public:
UserPasswordPenultimateFailureAttempt()

See Also

UserPasswordPenultimateFailureAttempt Class
UserPasswordPenultimateFailureAttempt Members
UserPasswordPenultimateFailureAttempt Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Constructor (String)

[image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Constructor (String)
UserPasswordPenultimateFailureAttempt Class See Also Send Feedback
Initializes a new instance of the UserPasswordPenultimateFailureAttempt class.

Namespace: CelloSaaS.ServiceContracts.UserManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public UserPasswordPenultimateFailureAttempt(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
UserPasswordPenultimateFailureAttempt(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

UserPasswordPenultimateFailureAttempt Class
UserPasswordPenultimateFailureAttempt Members
UserPasswordPenultimateFailureAttempt Overload
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Methods

[image] [image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Methods
UserPasswordPenultimateFailureAttempt Class See Also Send Feedback

The UserPasswordPenultimateFailureAttempt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UserPasswordPenultimateFailureAttempt Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Properties

[image] [image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Properties
UserPasswordPenultimateFailureAttempt Class See Also Send Feedback

The UserPasswordPenultimateFailureAttempt type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UserPasswordPenultimateFailureAttempt Class
CelloSaaS.ServiceContracts.UserManagement Namespace


UserPasswordPenultimateFailureAttempt Events

[image] [image]

A Sandcastle Documented Class Library
UserPasswordPenultimateFailureAttempt Events
UserPasswordPenultimateFailureAttempt Class See Also Send Feedback

The UserPasswordPenultimateFailureAttempt type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

UserPasswordPenultimateFailureAttempt Class
CelloSaaS.ServiceContracts.UserManagement Namespace


CelloSaaS.ServiceContracts.ViewManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.ViewManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | ViewMetaDataException | View metadata exception class

Interfaces

 | Interface | Description
Public interface | IFileStorageService | File Storage Service Interface
Public interface | IViewMetaDataService | View MetaData Service Interface


IFileStorageService Interface

[image]

A Sandcastle Documented Class Library
IFileStorageService Interface
Members See Also Send Feedback
File Storage Service Interface

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IFileStorageService
Visual Basic
Public Interface IFileStorageService
Visual C++
public interface class IFileStorageService

See Also

IFileStorageService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IFileStorageService Members

[image] [image]

A Sandcastle Documented Class Library
IFileStorageService Members
IFileStorageService Interface Methods See Also Send Feedback

The IFileStorageService type exposes the following members.

Methods

 | Name | Description
Public method | GetFile | This method is used to get the file.
Public method | StoreFile | This method is used to store the file.

See Also

IFileStorageService Interface
CelloSaaS.ServiceContracts.ViewManagement Namespace


IFileStorageService Methods

[image] [image]

A Sandcastle Documented Class Library
IFileStorageService Methods
IFileStorageService Interface See Also Send Feedback

The IFileStorageService type exposes the following members.

Methods

 | Name | Description
Public method | GetFile | This method is used to get the file.
Public method | StoreFile | This method is used to store the file.

See Also

IFileStorageService Interface
CelloSaaS.ServiceContracts.ViewManagement Namespace


IFileStorageService.GetFile Method

[image]

A Sandcastle Documented Class Library
IFileStorageService..::..GetFile Method
IFileStorageService Interface See Also Send Feedback
This method is used to get the file.

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetFile(
    string location,
    string fileName
)
Visual Basic
Function GetFile (
    location As String,
    fileName As String
) As String
Visual C++
String^ GetFile(
    String^ location,
    String^ fileName
)

Parameters

location
Type: System..::..String
The file save location or Container Name.
fileName
Type: System..::..String
Name of the file with extension.

Return Value

Type: String
File Uri

See Also

IFileStorageService Interface
IFileStorageService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IFileStorageService.StoreFile Method

[image]

A Sandcastle Documented Class Library
IFileStorageService..::..StoreFile Method
IFileStorageService Interface See Also Send Feedback
This method is used to store the file.

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void StoreFile(
    string location,
    string fileName,
    int index
)
Visual Basic
Sub StoreFile (
    location As String,
    fileName As String,
    index As Integer
)
Visual C++
void StoreFile(
    String^ location,
    String^ fileName,
    int index
)

Parameters

location
Type: System..::..String
The file save location.
fileName
Type: System..::..String
Name of the file.
index
Type: System..::..Int32
The index.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
System..::..ArgumentException | Throws ArgumentException if any argument produce error value
System..::..ArgumentOutOfRangeException | Throws ArgumentOutOfRangeException if index is out of range
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IFileStorageService Interface
IFileStorageService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService Interface

[image]

A Sandcastle Documented Class Library
IViewMetaDataService Interface
Members See Also Send Feedback
View MetaData Service Interface

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IViewMetaDataService
Visual Basic
Public Interface IViewMetaDataService
Visual C++
public interface class IViewMetaDataService

See Also

IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService Members

[image] [image]

A Sandcastle Documented Class Library
IViewMetaDataService Members
IViewMetaDataService Interface Methods See Also Send Feedback

The IViewMetaDataService type exposes the following members.

Methods

 | Name | Description
Public method | AddExtendedField | This method is used to add the extended field to data view field
Public method | CreateDataView | Creates the data view.
Public method | DeleteDataView | Deletes the data view.
Public method | DeleteExtendedField | This method is used to delete the selected data view field
Public method | GetDataView | This method is used to returns DataView info for the passed DataViewID
Public method | GetDataViewByTenantId | This method is used to returns DataView info for the passed DataViewID
Public method | GetDataViewFieldDefaultValues | This Method returns the default values for all the fields
Public method | GetDataViewFieldDetails | This method is used to get the data view field details for the passed fieldID
Public method | GetDataViewMetaData | This method used to get all the data view metadata information for the passed TenantID
Public method | GetDataViews | This method is used to return all data views of the application
Public method | GetGlobalDefaultValues | This Method returns the default values for all the global fields
Public method | GetGlobalFieldProperties | The method returns the global Field properties for the passed fieldID
Public method | GetGlobalFields | This method is used to return all global fields
Public method | GetViewMetaData | This method is used to return metadata of the view
Public method | UpdateDataView | Creates the data view.
Public method | UpdateDataViewField | This method is used to update the data view Field with the values filled in the passed object
Public method | UpdateFieldOrdinal | This method is used to update the data view field Ordinal
Public method | UpdateGlobalField | This method is used to update the global field properties
Public method | UpdateViewMetaData | This method is used to update the tenant settings for a tenant

See Also

IViewMetaDataService Interface
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService Methods

[image] [image]

A Sandcastle Documented Class Library
IViewMetaDataService Methods
IViewMetaDataService Interface See Also Send Feedback

The IViewMetaDataService type exposes the following members.

Methods

 | Name | Description
Public method | AddExtendedField | This method is used to add the extended field to data view field
Public method | CreateDataView | Creates the data view.
Public method | DeleteDataView | Deletes the data view.
Public method | DeleteExtendedField | This method is used to delete the selected data view field
Public method | GetDataView | This method is used to returns DataView info for the passed DataViewID
Public method | GetDataViewByTenantId | This method is used to returns DataView info for the passed DataViewID
Public method | GetDataViewFieldDefaultValues | This Method returns the default values for all the fields
Public method | GetDataViewFieldDetails | This method is used to get the data view field details for the passed fieldID
Public method | GetDataViewMetaData | This method used to get all the data view metadata information for the passed TenantID
Public method | GetDataViews | This method is used to return all data views of the application
Public method | GetGlobalDefaultValues | This Method returns the default values for all the global fields
Public method | GetGlobalFieldProperties | The method returns the global Field properties for the passed fieldID
Public method | GetGlobalFields | This method is used to return all global fields
Public method | GetViewMetaData | This method is used to return metadata of the view
Public method | UpdateDataView | Creates the data view.
Public method | UpdateDataViewField | This method is used to update the data view Field with the values filled in the passed object
Public method | UpdateFieldOrdinal | This method is used to update the data view field Ordinal
Public method | UpdateGlobalField | This method is used to update the global field properties
Public method | UpdateViewMetaData | This method is used to update the tenant settings for a tenant

See Also

IViewMetaDataService Interface
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.AddExtendedField Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..AddExtendedField Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to add the extended field to data view field

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool AddExtendedField(
    DataViewFieldMetaData fieldMetaData,
    string dataViewID
)
Visual Basic
Function AddExtendedField (
    fieldMetaData As DataViewFieldMetaData,
    dataViewID As String
) As Boolean
Visual C++
bool AddExtendedField(
    DataViewFieldMetaData^ fieldMetaData,
    String^ dataViewID
)

Parameters

fieldMetaData
Type: CelloSaaS.Model.ViewManagement..::..DataViewFieldMetaData
Field Meta Data Details
dataViewID
Type: System..::..String
Data View Identifier

Return Value

Type: Boolean
True or False

Examples

Copy image Copy
public bool AddExtendedField()
{
    string dataviewId ="FormUserDetails";
    DataViewFieldMetaData fieldMetaData = new DataViewFieldMetaData();
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.AddExtendedField(fieldMetaData,dataviewId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.CreateDataView Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..CreateDataView Method
IViewMetaDataService Interface See Also Send Feedback
Creates the data view.

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CreateDataView(
    DataViewMetaData metaData
)
Visual Basic
Sub CreateDataView (
    metaData As DataViewMetaData
)
Visual C++
void CreateDataView(
    DataViewMetaData^ metaData
)

Parameters

metaData
Type: CelloSaaS.Model.ViewManagement..::..DataViewMetaData
The meta data.

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.DeleteDataView Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..DeleteDataView Method
IViewMetaDataService Interface See Also Send Feedback
Deletes the data view.

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteDataView(
    string dataViewId,
    string tenantId,
    string mainEntity
)
Visual Basic
Sub DeleteDataView (
    dataViewId As String,
    tenantId As String,
    mainEntity As String
)
Visual C++
void DeleteDataView(
    String^ dataViewId,
    String^ tenantId,
    String^ mainEntity
)

Parameters

dataViewId
Type: System..::..String
The data view id.
tenantId
Type: System..::..String
The tenant id.
mainEntity
Type: System..::..String
The main entity.

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.DeleteExtendedField Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..DeleteExtendedField Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to delete the selected data view field

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool DeleteExtendedField(
    int fieldID,
    string tenantId,
    string dataViewId
)
Visual Basic
Function DeleteExtendedField (
    fieldID As Integer,
    tenantId As String,
    dataViewId As String
) As Boolean
Visual C++
bool DeleteExtendedField(
    int fieldID,
    String^ tenantId,
    String^ dataViewId
)

Parameters

fieldID
Type: System..::..Int32
Field Identifier
tenantId
Type: System..::..String
Tenant Identifier
dataViewId
Type: System..::..String
dataView Identifier

Return Value

Type: Boolean
True or False

Examples

Copy image Copy
public bool DeleteExtendedField()
{
    string fielId ="FirstName";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.DeleteExtendedField(fieldId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetDataView Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetDataView Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to returns DataView info for the passed DataViewID

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataView GetDataView(
    string dataViewID
)
Visual Basic
Function GetDataView (
    dataViewID As String
) As DataView
Visual C++
DataView^ GetDataView(
    String^ dataViewID
)

Parameters

dataViewID
Type: System..::..String
Data View Identifier

Return Value

Type: DataView
Data View Details

Examples

Copy image Copy
public DataView GetDataView()
{
    string dataviewId ="FormUserDetails";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetDataView(dataviewId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetDataViewByTenantId Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetDataViewByTenantId Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to returns DataView info for the passed DataViewID

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataView GetDataViewByTenantId(
    string dataViewID,
    string tenantId
)
Visual Basic
Function GetDataViewByTenantId (
    dataViewID As String,
    tenantId As String
) As DataView
Visual C++
DataView^ GetDataViewByTenantId(
    String^ dataViewID,
    String^ tenantId
)

Parameters

dataViewID
Type: System..::..String
Data View Identifier
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: DataView
Data View Details

Examples

Copy image Copy
public DataView GetDataView()
{
string dataviewId ="FormUserDetails";
IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
return viewMetaDataService.GetDataView(dataviewId);
}

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetDataViewFieldDefaultValues Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetDataViewFieldDefaultValues Method
IViewMetaDataService Interface Example See Also Send Feedback
This Method returns the default values for all the fields

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, DataViewFieldMetaData> GetDataViewFieldDefaultValues(
    string dataViewId
)
Visual Basic
Function GetDataViewFieldDefaultValues (
    dataViewId As String
) As Dictionary(Of String, DataViewFieldMetaData)
Visual C++
Dictionary<String^, DataViewFieldMetaData^>^ GetDataViewFieldDefaultValues(
    String^ dataViewId
)

Parameters

dataViewId
Type: System..::..String
Data View Identifier

Return Value

Type: Dictionary<(Of <(<'String, DataViewFieldMetaData >)>)>
Data View Field Meta Data Details

Examples

Copy image Copy
public Dictionary<string, DataViewFieldMetaData> GetDataViewFieldDefaultValues()
{
    string dataviewId ="FormUserDetails";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetDataViewFieldDefaultValues(dataviewId);
}

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetDataViewFieldDetails Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetDataViewFieldDetails Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to get the data view field details for the passed fieldID

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataViewFieldMetaData GetDataViewFieldDetails(
    string tenantId,
    string fieldIdentifier,
    string dataViewId,
    int globalFieldID
)
Visual Basic
Function GetDataViewFieldDetails (
    tenantId As String,
    fieldIdentifier As String,
    dataViewId As String,
    globalFieldID As Integer
) As DataViewFieldMetaData
Visual C++
DataViewFieldMetaData^ GetDataViewFieldDetails(
    String^ tenantId,
    String^ fieldIdentifier,
    String^ dataViewId,
    int globalFieldID
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier
fieldIdentifier
Type: System..::..String
Field Identifier
dataViewId
Type: System..::..String
Data View Identifier
globalFieldID
Type: System..::..Int32
Global Field Identifier

Return Value

Type: DataViewFieldMetaData
Data View Field Meta Data Details

Examples

Copy image Copy
public DataViewFieldMetaData GetDataViewFieldDetails()
{
    string tenantId = UserIdentity.TenantId;
    string fieldId = "FirstName";
    string dataviewId ="FormUserDetails";
    int globalFieldId = 2;
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetDataViewFieldDetails(tenantId,fieldId,dataviewId,globalFieldId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetDataViewMetaData Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetDataViewMetaData Method
IViewMetaDataService Interface Example See Also Send Feedback
This method used to get all the data view metadata information for the passed TenantID

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataViewMetaData GetDataViewMetaData(
    string tenantIdentifier,
    string dataViewIdentifier,
    string entityIdentifier
)
Visual Basic
Function GetDataViewMetaData (
    tenantIdentifier As String,
    dataViewIdentifier As String,
    entityIdentifier As String
) As DataViewMetaData
Visual C++
DataViewMetaData^ GetDataViewMetaData(
    String^ tenantIdentifier,
    String^ dataViewIdentifier,
    String^ entityIdentifier
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier
dataViewIdentifier
Type: System..::..String
Data View Identifier
entityIdentifier
Type: System..::..String
Entity Identifier

Return Value

Type: DataViewMetaData
Data View Meta Data Details

Examples

Copy image Copy
public DataViewMetaData GetDataViewMetaData()
{
    string tenantId = UserIdentity.TenantId;
    string dataViewId = "FormUserDetails";
    string entityId ="User";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetDataViewMetaData(tenantId,dataviewId,entityId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetDataViews Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetDataViews Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to return all data views of the application

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<DataView> GetDataViews(
    string tenantIdentifier
)
Visual Basic
Function GetDataViews (
    tenantIdentifier As String
) As List(Of DataView)
Visual C++
List<DataView^>^ GetDataViews(
    String^ tenantIdentifier
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier

Return Value

Type: List<(Of <(<' DataView >)>)>
List of Data View Details

Examples

Copy image Copy
public List<CelloSaaS.Model.ViewManagement.DataView> GetDataViews()
{
    string tenantId = UserIdentity.TenantId;
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetDataViews(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetGlobalDefaultValues Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetGlobalDefaultValues Method
IViewMetaDataService Interface Example See Also Send Feedback
This Method returns the default values for all the global fields

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, DataViewFieldMetaData> GetGlobalDefaultValues()
Visual Basic
Function GetGlobalDefaultValues As Dictionary(Of String, DataViewFieldMetaData)
Visual C++
Dictionary<String^, DataViewFieldMetaData^>^ GetGlobalDefaultValues()

Return Value

Type: Dictionary<(Of <(<'String, DataViewFieldMetaData >)>)>
Data View Field Meta Data Details

Examples

Copy image Copy
public Dictionary<string, DataViewFieldMetaData> GetGlobalDefaultValues()
{
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetGlobalDefaultValues();
}

Exceptions

Exception | Condition
System..::..ArgumentException | Throws ArgumentException if any argument produce error
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetGlobalFieldProperties Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetGlobalFieldProperties Method
IViewMetaDataService Interface Example See Also Send Feedback
The method returns the global Field properties for the passed fieldID

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
DataViewFieldMetaData GetGlobalFieldProperties(
    string tenantIdentifier,
    int fieldIdentifier
)
Visual Basic
Function GetGlobalFieldProperties (
    tenantIdentifier As String,
    fieldIdentifier As Integer
) As DataViewFieldMetaData
Visual C++
DataViewFieldMetaData^ GetGlobalFieldProperties(
    String^ tenantIdentifier,
    int fieldIdentifier
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier
fieldIdentifier
Type: System..::..Int32
Field Identifier

Return Value

Type: DataViewFieldMetaData
Data View Field Meta Data Details

Examples

Copy image Copy
public DataViewFieldMetaData GetGlobalFieldProperties()
{
    string tenantId = UserIdentity.TenantId;
    string fieldId = "FirstName";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetGlobalFieldProperties(tenantId,field);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetGlobalFields Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetGlobalFields Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to return all global fields

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<int, DataViewFieldMetaData> GetGlobalFields(
    string tenantIdentifier
)
Visual Basic
Function GetGlobalFields (
    tenantIdentifier As String
) As Dictionary(Of Integer, DataViewFieldMetaData)
Visual C++
Dictionary<int, DataViewFieldMetaData^>^ GetGlobalFields(
    String^ tenantIdentifier
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier

Return Value

Type: Dictionary<(Of <(<'Int32, DataViewFieldMetaData >)>)>
List of Data View Field Meta Data Details

Examples

Copy image Copy
public Dictionary<int, DataViewFieldMetaData> GetGlobalFields()
{
    string tenantId = UserIdentity.TenantId;
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetGlobalFields(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.GetViewMetaData Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..GetViewMetaData Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to return metadata of the view

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ViewMetaData GetViewMetaData(
    string tenantIdentifier
)
Visual Basic
Function GetViewMetaData (
    tenantIdentifier As String
) As ViewMetaData
Visual C++
ViewMetaData^ GetViewMetaData(
    String^ tenantIdentifier
)

Parameters

tenantIdentifier
Type: System..::..String
Tenant Identifier

Return Value

Type: ViewMetaData
View Meta Data Details

Examples

Copy image Copy
public ViewMetaData GetViewMetaData()
{
    string tenantId = "408C0E1A-C993-DF11-8DEB-001EC9DAB123";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.GetViewMetaData(tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.UpdateDataView Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..UpdateDataView Method
IViewMetaDataService Interface See Also Send Feedback
Creates the data view.

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDataView(
    DataViewMetaData metaData
)
Visual Basic
Sub UpdateDataView (
    metaData As DataViewMetaData
)
Visual C++
void UpdateDataView(
    DataViewMetaData^ metaData
)

Parameters

metaData
Type: CelloSaaS.Model.ViewManagement..::..DataViewMetaData
The meta data.

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.UpdateDataViewField Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..UpdateDataViewField Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to update the data view Field with the values filled in the passed object

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdateDataViewField(
    DataViewFieldMetaData fieldMetaData,
    string tenantId,
    string dataViewId
)
Visual Basic
Function UpdateDataViewField (
    fieldMetaData As DataViewFieldMetaData,
    tenantId As String,
    dataViewId As String
) As Boolean
Visual C++
bool UpdateDataViewField(
    DataViewFieldMetaData^ fieldMetaData,
    String^ tenantId,
    String^ dataViewId
)

Parameters

fieldMetaData
Type: CelloSaaS.Model.ViewManagement..::..DataViewFieldMetaData
Field Meta Data Details
tenantId
Type: System..::..String
Tenant Identifier
dataViewId
Type: System..::..String
Data View Identifier

Return Value

Type: Boolean
True or False

Examples

Copy image Copy
public bool UpdateDataViewField()
{
    string tenantId = UserIdentity.TenantId;
    string dataviewId ="FormUserDetails";
    DataViewFieldMetaData fieldMetaData = new DataViewFieldMetaData();
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.UpdateDataViewField(fieldMetaData,tenantId,dataviewId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.UpdateFieldOrdinal Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..UpdateFieldOrdinal Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to update the data view field Ordinal

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdateFieldOrdinal(
    string tenantId,
    string dataViewId,
    string entityId,
    ArrayList ids,
    string userId
)
Visual Basic
Function UpdateFieldOrdinal (
    tenantId As String,
    dataViewId As String,
    entityId As String,
    ids As ArrayList,
    userId As String
) As Boolean
Visual C++
bool UpdateFieldOrdinal(
    String^ tenantId,
    String^ dataViewId,
    String^ entityId,
    ArrayList^ ids,
    String^ userId
)

Parameters

tenantId
Type: System..::..String
Tenant Identifier
dataViewId
Type: System..::..String
Data View Identifier
entityId
Type: System..::..String
Entity Identifier
ids
Type: System.Collections..::..ArrayList
Data View Field Meta Data Identifiers
userId
Type: System..::..String
User Identifier

Return Value

Type: Boolean
True or False

Examples

Copy image Copy
public bool UpdateFieldOrdinal()
{
    string tenantId = UserIdentity.TenantId;
    string dataviewId ="FormUserDetails";
    ArrayList Ids = new ArrayList();
    string userId = "408C0E1A-C993-DF11-8DEB-001EC9DAB123";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.UpdateFieldOrdinal(dataviewId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.UpdateGlobalField Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..UpdateGlobalField Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to update the global field properties

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdateGlobalField(
    DataViewFieldMetaData fieldMetaData,
    string tenantId
)
Visual Basic
Function UpdateGlobalField (
    fieldMetaData As DataViewFieldMetaData,
    tenantId As String
) As Boolean
Visual C++
bool UpdateGlobalField(
    DataViewFieldMetaData^ fieldMetaData,
    String^ tenantId
)

Parameters

fieldMetaData
Type: CelloSaaS.Model.ViewManagement..::..DataViewFieldMetaData
Field Meta Data Details
tenantId
Type: System..::..String
Tenant Identifier

Return Value

Type: Boolean
True or False

Examples

Copy image Copy
public bool UpdateGlobalField()
{
    string tenantId = UserIdentity.TenantId;
    DataViewFieldMetaData fieldMetaData = new DataViewFieldMetaData();
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.UpdateGlobalField(fieldMetaData,tenantId);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


IViewMetaDataService.UpdateViewMetaData Method

[image]

A Sandcastle Documented Class Library
IViewMetaDataService..::..UpdateViewMetaData Method
IViewMetaDataService Interface Example See Also Send Feedback
This method is used to update the tenant settings for a tenant

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdateViewMetaData(
    ViewMetaData viewMetaData
)
Visual Basic
Function UpdateViewMetaData (
    viewMetaData As ViewMetaData
) As Boolean
Visual C++
bool UpdateViewMetaData(
    ViewMetaData^ viewMetaData
)

Parameters

viewMetaData
Type: CelloSaaS.Model.ViewManagement..::..ViewMetaData
View Meta Data Details

Return Value

Type: Boolean
True or False

Examples

Copy image Copy
public bool UpdateViewMetaData()
{
    ViewMetaData viewMetaData = new ViewMetaData();
    viewMetaData.TenantId = UserIdentity.TenantId;
    viewMetaData.Theme = "celloSkin";
    viewMetaData.Logo ="company.gif";
    IViewMetaDataService viewMetaDataService = (IViewMetaDataService)ServiceLocator.GetServiceImplementation(typeof(IViewMetaDataService));
    return viewMetaDataService.UpdateViewMetaData(viewMetaData);
}

Exceptions

Exception | Condition
System..::..ArgumentNullException | Throws ArgumentNullException if any mandatory argument is null or empty
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException | Throws ViewMetaDataException if any error occurs in this method

See Also

IViewMetaDataService Interface
IViewMetaDataService Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Class

[image]

A Sandcastle Documented Class Library
ViewMetaDataException Class
Members See Also Send Feedback
View metadata exception class

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ViewMetaDataException : BaseException
Visual Basic
<SerializableAttribute>
Public Class ViewMetaDataException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class ViewMetaDataException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.ViewManagement..::..ViewMetaDataException

See Also

ViewMetaDataException Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Members

[image] [image]

A Sandcastle Documented Class Library
ViewMetaDataException Members
ViewMetaDataException Class Constructors Methods Properties Events See Also Send Feedback

The ViewMetaDataException type exposes the following members.

Constructors

 | Name | Description
Public method | ViewMetaDataException(String) | ViewMetaDataException
Public method | ViewMetaDataException(String, Exception) | ViewMetaDataException

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ViewMetaDataException Class
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Constructor

[image] [image]

A Sandcastle Documented Class Library
ViewMetaDataException Constructor
ViewMetaDataException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ViewMetaDataException(String) | ViewMetaDataException
Public method | ViewMetaDataException(String, Exception) | ViewMetaDataException

See Also

ViewMetaDataException Class
ViewMetaDataException Members
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Constructor (String)

[image]

A Sandcastle Documented Class Library
ViewMetaDataException Constructor (String)
ViewMetaDataException Class See Also Send Feedback
ViewMetaDataException

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ViewMetaDataException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
ViewMetaDataException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

ViewMetaDataException Class
ViewMetaDataException Members
ViewMetaDataException Overload
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
ViewMetaDataException Constructor (String, Exception)
ViewMetaDataException Class See Also Send Feedback
ViewMetaDataException

Namespace: CelloSaaS.ServiceContracts.ViewManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ViewMetaDataException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
ViewMetaDataException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

ViewMetaDataException Class
ViewMetaDataException Members
ViewMetaDataException Overload
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Methods

[image] [image]

A Sandcastle Documented Class Library
ViewMetaDataException Methods
ViewMetaDataException Class See Also Send Feedback

The ViewMetaDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ViewMetaDataException Class
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Properties

[image] [image]

A Sandcastle Documented Class Library
ViewMetaDataException Properties
ViewMetaDataException Class See Also Send Feedback

The ViewMetaDataException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ViewMetaDataException Class
CelloSaaS.ServiceContracts.ViewManagement Namespace


ViewMetaDataException Events

[image] [image]

A Sandcastle Documented Class Library
ViewMetaDataException Events
ViewMetaDataException Class See Also Send Feedback

The ViewMetaDataException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ViewMetaDataException Class
CelloSaaS.ServiceContracts.ViewManagement Namespace


CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace
Send Feedback

Classes

 | Class | Description
Public class | VirtualEntityException | Virtual entity exception class

Interfaces

 | Interface | Description
Public interface | IVirtualEntityService | Virtual entity service interface


IVirtualEntityService Interface

[image]

A Sandcastle Documented Class Library
IVirtualEntityService Interface
Members See Also Send Feedback
Virtual entity service interface

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IVirtualEntityService
Visual Basic
Public Interface IVirtualEntityService
Visual C++
public interface class IVirtualEntityService

See Also

IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService Members

[image] [image]

A Sandcastle Documented Class Library
IVirtualEntityService Members
IVirtualEntityService Interface Methods See Also Send Feedback

The IVirtualEntityService type exposes the following members.

Methods

 | Name | Description
Public method | CopyVirtualEntity | Copies the virtual entity.
Public method | CreateVirtualEntity | Creates the virtual entity.
Public method | DeleteVirtualEntity | Deletes the virtual entity.
Public method | DeleteVirtualEntityData | Deletes the virtual entity data.
Public method | GetEntityData | Gets the entity data.
Public method | GetVirtualEntityData | Gets the virtual entity data.
Public method | SaveVirtualEntityData | Saves the virtual entity data.
Public method | SearchEntityData | Searches the entity data.
Public method | SearchVirtualEntityData | Saves the virtual entity data.

See Also

IVirtualEntityService Interface
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService Methods

[image] [image]

A Sandcastle Documented Class Library
IVirtualEntityService Methods
IVirtualEntityService Interface See Also Send Feedback

The IVirtualEntityService type exposes the following members.

Methods

 | Name | Description
Public method | CopyVirtualEntity | Copies the virtual entity.
Public method | CreateVirtualEntity | Creates the virtual entity.
Public method | DeleteVirtualEntity | Deletes the virtual entity.
Public method | DeleteVirtualEntityData | Deletes the virtual entity data.
Public method | GetEntityData | Gets the entity data.
Public method | GetVirtualEntityData | Gets the virtual entity data.
Public method | SaveVirtualEntityData | Saves the virtual entity data.
Public method | SearchEntityData | Searches the entity data.
Public method | SearchVirtualEntityData | Saves the virtual entity data.

See Also

IVirtualEntityService Interface
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.CopyVirtualEntity Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..CopyVirtualEntity Method
IVirtualEntityService Interface See Also Send Feedback
Copies the virtual entity.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int CopyVirtualEntity(
    string tenantId
)
Visual Basic
Function CopyVirtualEntity (
    tenantId As String
) As Integer
Visual C++
int CopyVirtualEntity(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Int32

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.DataManagement..::..DataManagementException |
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.CreateVirtualEntity Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..CreateVirtualEntity Method
IVirtualEntityService Interface See Also Send Feedback
Creates the virtual entity.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CreateVirtualEntity(
    EntityMetaData metadata,
    string featureId
)
Visual Basic
Sub CreateVirtualEntity (
    metadata As EntityMetaData,
    featureId As String
)
Visual C++
void CreateVirtualEntity(
    EntityMetaData^ metadata,
    String^ featureId
)

Parameters

metadata
Type: CelloSaaS.Model.DataManagement..::..EntityMetaData
The metadata.
featureId
Type: System..::..String
The feature id.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException | This exception is thrown when virtual entity already exist or tenant can't access the feature
CelloSaaS.ServiceContracts.AccessControlManagement..::..PrivilegeException | If db exception occurs
System..::..UnauthorizedAccessException | If the user has not the privilege
System.Data..::..DataException | If it is duplicate privilege id

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.DeleteVirtualEntity Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..DeleteVirtualEntity Method
IVirtualEntityService Interface See Also Send Feedback
Deletes the virtual entity.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteVirtualEntity(
    string entityId,
    string tenantId
)
Visual Basic
Sub DeleteVirtualEntity (
    entityId As String,
    tenantId As String
)
Visual C++
void DeleteVirtualEntity(
    String^ entityId,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
tenantId
Type: System..::..String
The tenanted.

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when tenant id or entity id is null or empty
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException | This exception is thrown while deleting virtual entity

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.DeleteVirtualEntityData Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..DeleteVirtualEntityData Method
IVirtualEntityService Interface See Also Send Feedback
Deletes the virtual entity data.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteVirtualEntityData(
    string entityId,
    string referenceId,
    string tenantId
)
Visual Basic
Sub DeleteVirtualEntityData (
    entityId As String,
    referenceId As String,
    tenantId As String
)
Visual C++
void DeleteVirtualEntityData(
    String^ entityId,
    String^ referenceId,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
referenceId
Type: System..::..String
The reference id.
tenantId
Type: System..::..String
The tenant id.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.GetEntityData Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..GetEntityData Method
IVirtualEntityService Interface See Also Send Feedback
Gets the entity data.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetEntityData(
    string primaryKey,
    string entityId,
    string tenantId
)
Visual Basic
Function GetEntityData (
    primaryKey As String,
    entityId As String,
    tenantId As String
) As String
Visual C++
String^ GetEntityData(
    String^ primaryKey,
    String^ entityId,
    String^ tenantId
)

Parameters

primaryKey
Type: System..::..String
The primary key.
entityId
Type: System..::..String
The entity id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.GetVirtualEntityData Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..GetVirtualEntityData Method
IVirtualEntityService Interface See Also Send Feedback
Gets the virtual entity data.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
VirtualEntity GetVirtualEntityData(
    string entityId,
    string referenceId,
    string tenantId
)
Visual Basic
Function GetVirtualEntityData (
    entityId As String,
    referenceId As String,
    tenantId As String
) As VirtualEntity
Visual C++
VirtualEntity^ GetVirtualEntityData(
    String^ entityId,
    String^ referenceId,
    String^ tenantId
)

Parameters

entityId
Type: System..::..String
The entity id.
referenceId
Type: System..::..String
The reference id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: VirtualEntity

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.SaveVirtualEntityData Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..SaveVirtualEntityData Method
IVirtualEntityService Interface See Also Send Feedback
Saves the virtual entity data.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveVirtualEntityData(
    VirtualEntity entity
)
Visual Basic
Sub SaveVirtualEntityData (
    entity As VirtualEntity
)
Visual C++
void SaveVirtualEntityData(
    VirtualEntity^ entity
)

Parameters

entity
Type: CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntity
The entity.

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.SearchEntityData Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..SearchEntityData Method
IVirtualEntityService Interface See Also Send Feedback
Searches the entity data.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, string> SearchEntityData(
    string entityId,
    string tenantId,
    string[] ids
)
Visual Basic
Function SearchEntityData (
    entityId As String,
    tenantId As String,
    ids As String()
) As Dictionary(Of String, String)
Visual C++
Dictionary<String^, String^>^ SearchEntityData(
    String^ entityId,
    String^ tenantId,
    array<String^>^ ids
)

Parameters

entityId
Type: System..::..String
The entity id.
tenantId
Type: System..::..String
The tenant id.
ids
Type: array<System..::..String>[]()[][]
primary key ids

Return Value

Type: Dictionary<(Of <(<'String, String>)>)>

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


IVirtualEntityService.SearchVirtualEntityData Method

[image]

A Sandcastle Documented Class Library
IVirtualEntityService..::..SearchVirtualEntityData Method
IVirtualEntityService Interface See Also Send Feedback
Saves the virtual entity data.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
VirtualEntitySearchResult SearchVirtualEntityData(
    VirtualEntitySearchCondition condition
)
Visual Basic
Function SearchVirtualEntityData (
    condition As VirtualEntitySearchCondition
) As VirtualEntitySearchResult
Visual C++
VirtualEntitySearchResult^ SearchVirtualEntityData(
    VirtualEntitySearchCondition^ condition
)

Parameters

condition
Type: CelloSaaS.Model.VirtualEntityManagement..::..VirtualEntitySearchCondition
The search condition.

Return Value

Type: VirtualEntitySearchResult

Exceptions

Exception | Condition
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException |

See Also

IVirtualEntityService Interface
IVirtualEntityService Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Class

[image]

A Sandcastle Documented Class Library
VirtualEntityException Class
Members See Also Send Feedback
Virtual entity exception class

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class VirtualEntityException : BaseException
Visual Basic
<SerializableAttribute>
Public Class VirtualEntityException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class VirtualEntityException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.ServiceContracts.VirtualEntityManagement..::..VirtualEntityException

See Also

VirtualEntityException Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Members

[image] [image]

A Sandcastle Documented Class Library
VirtualEntityException Members
VirtualEntityException Class Constructors Methods Properties Events See Also Send Feedback

The VirtualEntityException type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualEntityException()()()() | Initializes a new instance of the VirtualEntityException class.
Public method | VirtualEntityException(String) | Initializes a new instance of the VirtualEntityException class.
Public method | VirtualEntityException(String, Exception) | Initializes a new instance of the VirtualEntityException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

VirtualEntityException Class
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Constructor

[image] [image]

A Sandcastle Documented Class Library
VirtualEntityException Constructor
VirtualEntityException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VirtualEntityException()()()() | Initializes a new instance of the VirtualEntityException class.
Public method | VirtualEntityException(String) | Initializes a new instance of the VirtualEntityException class.
Public method | VirtualEntityException(String, Exception) | Initializes a new instance of the VirtualEntityException class.

See Also

VirtualEntityException Class
VirtualEntityException Members
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Constructor

[image]

A Sandcastle Documented Class Library
VirtualEntityException Constructor
VirtualEntityException Class See Also Send Feedback
Initializes a new instance of the VirtualEntityException class.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public VirtualEntityException()
Visual Basic
Public Sub New
Visual C++
public:
VirtualEntityException()

See Also

VirtualEntityException Class
VirtualEntityException Members
VirtualEntityException Overload
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Constructor (String)

[image]

A Sandcastle Documented Class Library
VirtualEntityException Constructor (String)
VirtualEntityException Class See Also Send Feedback
Initializes a new instance of the VirtualEntityException class.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public VirtualEntityException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
VirtualEntityException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

VirtualEntityException Class
VirtualEntityException Members
VirtualEntityException Overload
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
VirtualEntityException Constructor (String, Exception)
VirtualEntityException Class See Also Send Feedback
Initializes a new instance of the VirtualEntityException class.

Namespace: CelloSaaS.ServiceContracts.VirtualEntityManagement
Assembly: CelloSaaS.ServiceContracts (in CelloSaaS.ServiceContracts.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public VirtualEntityException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
VirtualEntityException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

VirtualEntityException Class
VirtualEntityException Members
VirtualEntityException Overload
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Methods

[image] [image]

A Sandcastle Documented Class Library
VirtualEntityException Methods
VirtualEntityException Class See Also Send Feedback

The VirtualEntityException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

VirtualEntityException Class
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Properties

[image] [image]

A Sandcastle Documented Class Library
VirtualEntityException Properties
VirtualEntityException Class See Also Send Feedback

The VirtualEntityException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VirtualEntityException Class
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


VirtualEntityException Events

[image] [image]

A Sandcastle Documented Class Library
VirtualEntityException Events
VirtualEntityException Class See Also Send Feedback

The VirtualEntityException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

VirtualEntityException Class
CelloSaaS.ServiceContracts.VirtualEntityManagement Namespace


CelloSaaS.Template.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Template.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | DuplicateTemplateNameException |
Public class | LocaleTemplate | This class contains Locale Template Details
Public class | LocaleTemplateException |
Public class | PlaceholderXml |
Public class | TemplateConstants |
Public class | TemplateDetail | Contains the template details
Public class | TemplateException |


DuplicateTemplateNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Class
Members See Also Send Feedback

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateTemplateNameException : Exception
Visual Basic
<SerializableAttribute>
Public Class DuplicateTemplateNameException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class DuplicateTemplateNameException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.Template.Model..::..DuplicateTemplateNameException

See Also

DuplicateTemplateNameException Members
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Members
DuplicateTemplateNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateTemplateNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateTemplateNameException()()()() | Initializes a new instance of the DuplicateTemplateNameException class.
Public method | DuplicateTemplateNameException(String) | Initializes a new instance of the DuplicateTemplateNameException class.
Protected method | DuplicateTemplateNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTemplateNameException class.
Public method | DuplicateTemplateNameException(String, Exception) | Initializes a new instance of the DuplicateTemplateNameException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTemplateNameException Class
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Constructor

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Constructor
DuplicateTemplateNameException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateTemplateNameException()()()() | Initializes a new instance of the DuplicateTemplateNameException class.
Public method | DuplicateTemplateNameException(String) | Initializes a new instance of the DuplicateTemplateNameException class.
Protected method | DuplicateTemplateNameException(SerializationInfo, StreamingContext) | Initializes a new instance of the DuplicateTemplateNameException class.
Public method | DuplicateTemplateNameException(String, Exception) | Initializes a new instance of the DuplicateTemplateNameException class.

See Also

DuplicateTemplateNameException Class
DuplicateTemplateNameException Members
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Constructor
DuplicateTemplateNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTemplateNameException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTemplateNameException()
Visual Basic
Public Sub New
Visual C++
public:
DuplicateTemplateNameException()

See Also

DuplicateTemplateNameException Class
DuplicateTemplateNameException Members
DuplicateTemplateNameException Overload
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Constructor (String)

[image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Constructor (String)
DuplicateTemplateNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTemplateNameException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTemplateNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateTemplateNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

DuplicateTemplateNameException Class
DuplicateTemplateNameException Members
DuplicateTemplateNameException Overload
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Constructor (SerializationInfo, StreamingContext)
DuplicateTemplateNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTemplateNameException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected DuplicateTemplateNameException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
DuplicateTemplateNameException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.Serialization..::..StreamingContext
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception | Condition
System..::..ArgumentNullException | The info parameter is null.
System.Runtime.Serialization..::..SerializationException | The class name is null or HResult is zero (0).

See Also

DuplicateTemplateNameException Class
DuplicateTemplateNameException Members
DuplicateTemplateNameException Overload
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Constructor (String, Exception)
DuplicateTemplateNameException Class See Also Send Feedback
Initializes a new instance of the DuplicateTemplateNameException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateTemplateNameException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
DuplicateTemplateNameException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

DuplicateTemplateNameException Class
DuplicateTemplateNameException Members
DuplicateTemplateNameException Overload
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Methods
DuplicateTemplateNameException Class See Also Send Feedback

The DuplicateTemplateNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateTemplateNameException Class
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Properties
DuplicateTemplateNameException Class See Also Send Feedback

The DuplicateTemplateNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateTemplateNameException Class
CelloSaaS.Template.Model Namespace


DuplicateTemplateNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateTemplateNameException Events
DuplicateTemplateNameException Class See Also Send Feedback

The DuplicateTemplateNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateTemplateNameException Class
CelloSaaS.Template.Model Namespace


LocaleTemplate Class

[image]

A Sandcastle Documented Class Library
LocaleTemplate Class
Members See Also Send Feedback
This class contains Locale Template Details

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LocaleTemplate
Visual Basic
<SerializableAttribute>
Public Class LocaleTemplate
Visual C++
[SerializableAttribute]
public ref class LocaleTemplate

Inheritance Hierarchy

System..::..Object
CelloSaaS.Template.Model..::..LocaleTemplate

See Also

LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate Members

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplate Members
LocaleTemplate Class Constructors Methods Properties See Also Send Feedback

The LocaleTemplate type exposes the following members.

Constructors

 | Name | Description
Public method | LocaleTemplate | Initializes a new instance of the LocaleTemplate class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContentText | Gets or sets the Locale template Content
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the Locale Template identifier
Public property | LocaleId | Gets or sets the locale id.
Public property | LocaleName | Gets or sets the locale name's identifier.
Public property | Status | Gets or sets a value indicating whether this LocaleTemplate is status.
Public property | TemplateId | Gets or sets the notification Template identifier
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

LocaleTemplate Class
CelloSaaS.Template.Model Namespace


LocaleTemplate Constructor

[image]

A Sandcastle Documented Class Library
LocaleTemplate Constructor
LocaleTemplate Class See Also Send Feedback
Initializes a new instance of the LocaleTemplate class

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LocaleTemplate()
Visual Basic
Public Sub New
Visual C++
public:
LocaleTemplate()

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate Methods

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplate Methods
LocaleTemplate Class See Also Send Feedback

The LocaleTemplate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LocaleTemplate Class
CelloSaaS.Template.Model Namespace


LocaleTemplate Properties

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplate Properties
LocaleTemplate Class See Also Send Feedback

The LocaleTemplate type exposes the following members.

Properties

 | Name | Description
Public property | ContentText | Gets or sets the Locale template Content
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the Locale Template identifier
Public property | LocaleId | Gets or sets the locale id.
Public property | LocaleName | Gets or sets the locale name's identifier.
Public property | Status | Gets or sets a value indicating whether this LocaleTemplate is status.
Public property | TemplateId | Gets or sets the notification Template identifier
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

LocaleTemplate Class
CelloSaaS.Template.Model Namespace


LocaleTemplate.ContentText Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..ContentText Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the Locale template Content

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ContentText { get; set; }
Visual Basic
Public Property ContentText As String
    Get
    Set
Visual C++
public:
property String^ ContentText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.CreatedBy Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..CreatedBy Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.CreatedOn Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..CreatedOn Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.Description Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..Description Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the description.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.Id Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..Id Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the Locale Template identifier

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.LocaleId Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..LocaleId Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the locale id.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleId { get; set; }
Visual Basic
Public Property LocaleId As String
    Get
    Set
Visual C++
public:
property String^ LocaleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The locale id.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.LocaleName Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..LocaleName Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the locale name's identifier.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string LocaleName { get; set; }
Visual Basic
Public Property LocaleName As String
    Get
    Set
Visual C++
public:
property String^ LocaleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The locale name id.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.Status Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..Status Property
LocaleTemplate Class See Also Send Feedback
Gets or sets a value indicating whether this LocaleTemplate is status.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.TemplateId Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..TemplateId Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the notification Template identifier

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..UpdatedBy Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplate.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
LocaleTemplate..::..UpdatedOn Property
LocaleTemplate Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

LocaleTemplate Class
LocaleTemplate Members
CelloSaaS.Template.Model Namespace


LocaleTemplateException Class

[image]

A Sandcastle Documented Class Library
LocaleTemplateException Class
Members See Also Send Feedback

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class LocaleTemplateException : BaseException
Visual Basic
<SerializableAttribute>
Public Class LocaleTemplateException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class LocaleTemplateException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Template.Model..::..LocaleTemplateException

See Also

LocaleTemplateException Members
CelloSaaS.Template.Model Namespace


LocaleTemplateException Members

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplateException Members
LocaleTemplateException Class Constructors Methods Properties Events See Also Send Feedback

The LocaleTemplateException type exposes the following members.

Constructors

 | Name | Description
Public method | LocaleTemplateException()()()() | Initializes a new instance of the LocaleTemplateException class.
Public method | LocaleTemplateException(String) | Initializes a new instance of the LocaleTemplateException class.
Protected method | LocaleTemplateException(SerializationInfo, StreamingContext) | Initializes a new instance of the LocaleTemplateException class.
Public method | LocaleTemplateException(String, Exception) | Initializes a new instance of the LocaleTemplateException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LocaleTemplateException Class
CelloSaaS.Template.Model Namespace


LocaleTemplateException Constructor

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplateException Constructor
LocaleTemplateException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LocaleTemplateException()()()() | Initializes a new instance of the LocaleTemplateException class.
Public method | LocaleTemplateException(String) | Initializes a new instance of the LocaleTemplateException class.
Protected method | LocaleTemplateException(SerializationInfo, StreamingContext) | Initializes a new instance of the LocaleTemplateException class.
Public method | LocaleTemplateException(String, Exception) | Initializes a new instance of the LocaleTemplateException class.

See Also

LocaleTemplateException Class
LocaleTemplateException Members
CelloSaaS.Template.Model Namespace


LocaleTemplateException Constructor

[image]

A Sandcastle Documented Class Library
LocaleTemplateException Constructor
LocaleTemplateException Class See Also Send Feedback
Initializes a new instance of the LocaleTemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LocaleTemplateException()
Visual Basic
Public Sub New
Visual C++
public:
LocaleTemplateException()

See Also

LocaleTemplateException Class
LocaleTemplateException Members
LocaleTemplateException Overload
CelloSaaS.Template.Model Namespace


LocaleTemplateException Constructor (String)

[image]

A Sandcastle Documented Class Library
LocaleTemplateException Constructor (String)
LocaleTemplateException Class See Also Send Feedback
Initializes a new instance of the LocaleTemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LocaleTemplateException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
LocaleTemplateException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

LocaleTemplateException Class
LocaleTemplateException Members
LocaleTemplateException Overload
CelloSaaS.Template.Model Namespace


LocaleTemplateException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
LocaleTemplateException Constructor (SerializationInfo, StreamingContext)
LocaleTemplateException Class See Also Send Feedback
Initializes a new instance of the LocaleTemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected LocaleTemplateException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
LocaleTemplateException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

LocaleTemplateException Class
LocaleTemplateException Members
LocaleTemplateException Overload
CelloSaaS.Template.Model Namespace


LocaleTemplateException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
LocaleTemplateException Constructor (String, Exception)
LocaleTemplateException Class See Also Send Feedback
Initializes a new instance of the LocaleTemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public LocaleTemplateException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
LocaleTemplateException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

LocaleTemplateException Class
LocaleTemplateException Members
LocaleTemplateException Overload
CelloSaaS.Template.Model Namespace


LocaleTemplateException Methods

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplateException Methods
LocaleTemplateException Class See Also Send Feedback

The LocaleTemplateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LocaleTemplateException Class
CelloSaaS.Template.Model Namespace


LocaleTemplateException Properties

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplateException Properties
LocaleTemplateException Class See Also Send Feedback

The LocaleTemplateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LocaleTemplateException Class
CelloSaaS.Template.Model Namespace


LocaleTemplateException Events

[image] [image]

A Sandcastle Documented Class Library
LocaleTemplateException Events
LocaleTemplateException Class See Also Send Feedback

The LocaleTemplateException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

LocaleTemplateException Class
CelloSaaS.Template.Model Namespace


PlaceholderXml Class

[image]

A Sandcastle Documented Class Library
PlaceholderXml Class
Members See Also Send Feedback

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class PlaceholderXml
Visual Basic
<SerializableAttribute>
Public Class PlaceholderXml
Visual C++
[SerializableAttribute]
public ref class PlaceholderXml

Inheritance Hierarchy

System..::..Object
CelloSaaS.Template.Model..::..PlaceholderXml

See Also

PlaceholderXml Members
CelloSaaS.Template.Model Namespace


PlaceholderXml Members

[image] [image]

A Sandcastle Documented Class Library
PlaceholderXml Members
PlaceholderXml Class Constructors Methods Properties See Also Send Feedback

The PlaceholderXml type exposes the following members.

Constructors

 | Name | Description
Public method | PlaceholderXml()()()() | Initializes a new instance of the PlaceholderXml class.
Public method | PlaceholderXml(String) | Initializes a new instance of the PlaceholderXml class.

Methods

 | Name | Description
Public method | Element | Elements the specified x path.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rule | This method is used to execute the rule with the specified rule set code and tenant id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Xml | Gets or sets the XML.

See Also

PlaceholderXml Class
CelloSaaS.Template.Model Namespace


PlaceholderXml Constructor

[image] [image]

A Sandcastle Documented Class Library
PlaceholderXml Constructor
PlaceholderXml Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PlaceholderXml()()()() | Initializes a new instance of the PlaceholderXml class.
Public method | PlaceholderXml(String) | Initializes a new instance of the PlaceholderXml class.

See Also

PlaceholderXml Class
PlaceholderXml Members
CelloSaaS.Template.Model Namespace


PlaceholderXml Constructor

[image]

A Sandcastle Documented Class Library
PlaceholderXml Constructor
PlaceholderXml Class See Also Send Feedback
Initializes a new instance of the PlaceholderXml class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PlaceholderXml()
Visual Basic
Public Sub New
Visual C++
public:
PlaceholderXml()

See Also

PlaceholderXml Class
PlaceholderXml Members
PlaceholderXml Overload
CelloSaaS.Template.Model Namespace


PlaceholderXml Constructor (String)

[image]

A Sandcastle Documented Class Library
PlaceholderXml Constructor (String)
PlaceholderXml Class See Also Send Feedback
Initializes a new instance of the PlaceholderXml class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public PlaceholderXml(
    string xml
)
Visual Basic
Public Sub New (
    xml As String
)
Visual C++
public:
PlaceholderXml(
    String^ xml
)

Parameters

xml
Type: System..::..String
The XML.

See Also

PlaceholderXml Class
PlaceholderXml Members
PlaceholderXml Overload
CelloSaaS.Template.Model Namespace


PlaceholderXml Methods

[image] [image]

A Sandcastle Documented Class Library
PlaceholderXml Methods
PlaceholderXml Class See Also Send Feedback

The PlaceholderXml type exposes the following members.

Methods

 | Name | Description
Public method | Element | Elements the specified x path.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rule | This method is used to execute the rule with the specified rule set code and tenant id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PlaceholderXml Class
CelloSaaS.Template.Model Namespace


PlaceholderXml.Element Method

[image]

A Sandcastle Documented Class Library
PlaceholderXml..::..Element Method
PlaceholderXml Class See Also Send Feedback
Elements the specified x path.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Element(
    string xPath
)
Visual Basic
Public Function Element (
    xPath As String
) As String
Visual C++
public:
String^ Element(
    String^ xPath
)

Parameters

xPath
Type: System..::..String
The x path.

Return Value

Type: String

See Also

PlaceholderXml Class
PlaceholderXml Members
CelloSaaS.Template.Model Namespace


PlaceholderXml.Rule Method

[image]

A Sandcastle Documented Class Library
PlaceholderXml..::..Rule Method
PlaceholderXml Class See Also Send Feedback
This method is used to execute the rule with the specified rule set code and tenant id.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Rule(
    string ruleSetCode,
    string tenantId
)
Visual Basic
Public Function Rule (
    ruleSetCode As String,
    tenantId As String
) As String
Visual C++
public:
String^ Rule(
    String^ ruleSetCode,
    String^ tenantId
)

Parameters

ruleSetCode
Type: System..::..String
The rule set code.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: String
rule result

See Also

PlaceholderXml Class
PlaceholderXml Members
CelloSaaS.Template.Model Namespace


PlaceholderXml Properties

[image] [image]

A Sandcastle Documented Class Library
PlaceholderXml Properties
PlaceholderXml Class See Also Send Feedback

The PlaceholderXml type exposes the following members.

Properties

 | Name | Description
Public property | Xml | Gets or sets the XML.

See Also

PlaceholderXml Class
CelloSaaS.Template.Model Namespace


PlaceholderXml.Xml Property

[image]

A Sandcastle Documented Class Library
PlaceholderXml..::..Xml Property
PlaceholderXml Class See Also Send Feedback
Gets or sets the XML.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Xml { get; set; }
Visual Basic
Public Property Xml As String
    Get
    Set
Visual C++
public:
property String^ Xml {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The XML.

See Also

PlaceholderXml Class
PlaceholderXml Members
CelloSaaS.Template.Model Namespace


TemplateConstants Class

[image]

A Sandcastle Documented Class Library
TemplateConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class TemplateConstants
Visual Basic
Public NotInheritable Class TemplateConstants
Visual C++
public ref class TemplateConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.Template.Model..::..TemplateConstants

See Also

TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants Members

[image] [image]

A Sandcastle Documented Class Library
TemplateConstants Members
TemplateConstants Class Fields See Also Send Feedback

The TemplateConstants type exposes the following members.

Fields

Name | Description
ContextPattern | This is the pattern for Event Context value. The Event's context value is used as the placeholder object.
Element | Element Of
EventParameterPattern | This is the pattern for Event Parameter value. The Event's event parameter value is used as the placeholder object.
KeyEndDelimiter | Key End Delimiter
KeyStartDelimiter | Key Start Delimiter
ObjectEndDelimiter | Object End Delimiter
ObjectStartDelimiter | Object Start Delimiter
Rule | Rule Of
SubjectPattern | This is the pattern for Event subject value. The Event's subject value is used as the placeholder object.
TargetPattern | This is the pattern for Event target value. The Event's target value is used as the placeholder object.

See Also

TemplateConstants Class
CelloSaaS.Template.Model Namespace


TemplateConstants Fields

[image] [image]

A Sandcastle Documented Class Library
TemplateConstants Fields
TemplateConstants Class See Also Send Feedback

The TemplateConstants type exposes the following members.

Fields

Name | Description
ContextPattern | This is the pattern for Event Context value. The Event's context value is used as the placeholder object.
Element | Element Of
EventParameterPattern | This is the pattern for Event Parameter value. The Event's event parameter value is used as the placeholder object.
KeyEndDelimiter | Key End Delimiter
KeyStartDelimiter | Key Start Delimiter
ObjectEndDelimiter | Object End Delimiter
ObjectStartDelimiter | Object Start Delimiter
Rule | Rule Of
SubjectPattern | This is the pattern for Event subject value. The Event's subject value is used as the placeholder object.
TargetPattern | This is the pattern for Event target value. The Event's target value is used as the placeholder object.

See Also

TemplateConstants Class
CelloSaaS.Template.Model Namespace


TemplateConstants.ContextPattern Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..ContextPattern Field
TemplateConstants Class See Also Send Feedback
This is the pattern for Event Context value. The Event's context value is used as the placeholder object.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ContextPattern
Visual Basic
Public Const ContextPattern As String
Visual C++
public:
literal String^ ContextPattern

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.Element Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..Element Field
TemplateConstants Class See Also Send Feedback
Element Of

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Element
Visual Basic
Public Const Element As String
Visual C++
public:
literal String^ Element

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.EventParameterPattern Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..EventParameterPattern Field
TemplateConstants Class See Also Send Feedback
This is the pattern for Event Parameter value. The Event's event parameter value is used as the placeholder object.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EventParameterPattern
Visual Basic
Public Const EventParameterPattern As String
Visual C++
public:
literal String^ EventParameterPattern

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.KeyEndDelimiter Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..KeyEndDelimiter Field
TemplateConstants Class See Also Send Feedback
Key End Delimiter

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string KeyEndDelimiter
Visual Basic
Public Const KeyEndDelimiter As String
Visual C++
public:
literal String^ KeyEndDelimiter

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.KeyStartDelimiter Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..KeyStartDelimiter Field
TemplateConstants Class See Also Send Feedback
Key Start Delimiter

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string KeyStartDelimiter
Visual Basic
Public Const KeyStartDelimiter As String
Visual C++
public:
literal String^ KeyStartDelimiter

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.ObjectEndDelimiter Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..ObjectEndDelimiter Field
TemplateConstants Class See Also Send Feedback
Object End Delimiter

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ObjectEndDelimiter
Visual Basic
Public Const ObjectEndDelimiter As String
Visual C++
public:
literal String^ ObjectEndDelimiter

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.ObjectStartDelimiter Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..ObjectStartDelimiter Field
TemplateConstants Class See Also Send Feedback
Object Start Delimiter

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ObjectStartDelimiter
Visual Basic
Public Const ObjectStartDelimiter As String
Visual C++
public:
literal String^ ObjectStartDelimiter

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.Rule Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..Rule Field
TemplateConstants Class See Also Send Feedback
Rule Of

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Rule
Visual Basic
Public Const Rule As String
Visual C++
public:
literal String^ Rule

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.SubjectPattern Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..SubjectPattern Field
TemplateConstants Class See Also Send Feedback
This is the pattern for Event subject value. The Event's subject value is used as the placeholder object.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string SubjectPattern
Visual Basic
Public Const SubjectPattern As String
Visual C++
public:
literal String^ SubjectPattern

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateConstants.TargetPattern Field

[image]

A Sandcastle Documented Class Library
TemplateConstants..::..TargetPattern Field
TemplateConstants Class See Also Send Feedback
This is the pattern for Event target value. The Event's target value is used as the placeholder object.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string TargetPattern
Visual Basic
Public Const TargetPattern As String
Visual C++
public:
literal String^ TargetPattern

Field Value

Type: String

See Also

TemplateConstants Class
TemplateConstants Members
CelloSaaS.Template.Model Namespace


TemplateDetail Class

[image]

A Sandcastle Documented Class Library
TemplateDetail Class
Members See Also Send Feedback
Contains the template details

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TemplateDetail
Visual Basic
<SerializableAttribute>
Public Class TemplateDetail
Visual C++
[SerializableAttribute]
public ref class TemplateDetail

Inheritance Hierarchy

System..::..Object
CelloSaaS.Template.Model..::..TemplateDetail

See Also

TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail Members

[image] [image]

A Sandcastle Documented Class Library
TemplateDetail Members
TemplateDetail Class Constructors Methods Properties See Also Send Feedback

The TemplateDetail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateDetail | Initializes a new instance of the TemplateDetail class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | LocaleTemplates | Gets or sets the locale templates.
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TemplateDetail Class
CelloSaaS.Template.Model Namespace


TemplateDetail Constructor

[image]

A Sandcastle Documented Class Library
TemplateDetail Constructor
TemplateDetail Class See Also Send Feedback
Initializes a new instance of the TemplateDetail class

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TemplateDetail()
Visual Basic
Public Sub New
Visual C++
public:
TemplateDetail()

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail Methods

[image] [image]

A Sandcastle Documented Class Library
TemplateDetail Methods
TemplateDetail Class See Also Send Feedback

The TemplateDetail type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TemplateDetail Class
CelloSaaS.Template.Model Namespace


TemplateDetail Properties

[image] [image]

A Sandcastle Documented Class Library
TemplateDetail Properties
TemplateDetail Class See Also Send Feedback

The TemplateDetail type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets or sets the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets Template Description
Public property | LocaleTemplates | Gets or sets the locale templates.
Public property | Status | Gets or sets the status.
Public property | TemplateContentText | Gets or sets template content text
Public property | TemplateId | Gets or sets Template Identifier
Public property | TemplateName | Gets or sets Template Name
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.

See Also

TemplateDetail Class
CelloSaaS.Template.Model Namespace


TemplateDetail.Category Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..Category Property
TemplateDetail Class See Also Send Feedback
Gets or sets the category.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The category.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..CreatedBy Property
TemplateDetail Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..CreatedOn Property
TemplateDetail Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.Description Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..Description Property
TemplateDetail Class See Also Send Feedback
Gets or sets Template Description

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.LocaleTemplates Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..LocaleTemplates Property
TemplateDetail Class See Also Send Feedback
Gets or sets the locale templates.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, LocaleTemplate> LocaleTemplates { get; set; }
Visual Basic
Public Property LocaleTemplates As Dictionary(Of String, LocaleTemplate)
    Get
    Set
Visual C++
public:
property Dictionary<String^, LocaleTemplate^>^ LocaleTemplates {
    Dictionary<String^, LocaleTemplate^>^ get ();
    void set (Dictionary<String^, LocaleTemplate^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, LocaleTemplate >)>)>
The locale templates.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.Status Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..Status Property
TemplateDetail Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> Status { get; set; }
Visual Basic
Public Property Status As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> Status {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The status.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.TemplateContentText Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..TemplateContentText Property
TemplateDetail Class See Also Send Feedback
Gets or sets template content text

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StringBuilder TemplateContentText { get; set; }
Visual Basic
Public Property TemplateContentText As StringBuilder
    Get
    Set
Visual C++
public:
property StringBuilder^ TemplateContentText {
    StringBuilder^ get ();
    void set (StringBuilder^ value);
}

Property Value

Type: StringBuilder

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.TemplateId Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..TemplateId Property
TemplateDetail Class See Also Send Feedback
Gets or sets Template Identifier

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateId { get; set; }
Visual Basic
Public Property TemplateId As String
    Get
    Set
Visual C++
public:
property String^ TemplateId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.TemplateName Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..TemplateName Property
TemplateDetail Class See Also Send Feedback
Gets or sets Template Name

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TemplateName { get; set; }
Visual Basic
Public Property TemplateName As String
    Get
    Set
Visual C++
public:
property String^ TemplateName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.TenantId Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..TenantId Property
TemplateDetail Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..UpdatedBy Property
TemplateDetail Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateDetail.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TemplateDetail..::..UpdatedOn Property
TemplateDetail Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> UpdatedOn {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The updated on.

See Also

TemplateDetail Class
TemplateDetail Members
CelloSaaS.Template.Model Namespace


TemplateException Class

[image]

A Sandcastle Documented Class Library
TemplateException Class
Members See Also Send Feedback

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TemplateException : BaseException
Visual Basic
<SerializableAttribute>
Public Class TemplateException
    Inherits BaseException
Visual C++
[SerializableAttribute]
public ref class TemplateException : public BaseException

Inheritance Hierarchy

System..::..Object
System..::..Exception
BaseException
CelloSaaS.Template.Model..::..TemplateException

See Also

TemplateException Members
CelloSaaS.Template.Model Namespace


TemplateException Members

[image] [image]

A Sandcastle Documented Class Library
TemplateException Members
TemplateException Class Constructors Methods Properties Events See Also Send Feedback

The TemplateException type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateException()()()() | Initializes a new instance of the TemplateException class.
Public method | TemplateException(String) | Initializes a new instance of the TemplateException class.
Protected method | TemplateException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateException class.
Public method | TemplateException(String, Exception) | Initializes a new instance of the TemplateException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TemplateException Class
CelloSaaS.Template.Model Namespace


TemplateException Constructor

[image] [image]

A Sandcastle Documented Class Library
TemplateException Constructor
TemplateException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TemplateException()()()() | Initializes a new instance of the TemplateException class.
Public method | TemplateException(String) | Initializes a new instance of the TemplateException class.
Protected method | TemplateException(SerializationInfo, StreamingContext) | Initializes a new instance of the TemplateException class.
Public method | TemplateException(String, Exception) | Initializes a new instance of the TemplateException class.

See Also

TemplateException Class
TemplateException Members
CelloSaaS.Template.Model Namespace


TemplateException Constructor

[image]

A Sandcastle Documented Class Library
TemplateException Constructor
TemplateException Class See Also Send Feedback
Initializes a new instance of the TemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TemplateException()
Visual Basic
Public Sub New
Visual C++
public:
TemplateException()

See Also

TemplateException Class
TemplateException Members
TemplateException Overload
CelloSaaS.Template.Model Namespace


TemplateException Constructor (String)

[image]

A Sandcastle Documented Class Library
TemplateException Constructor (String)
TemplateException Class See Also Send Feedback
Initializes a new instance of the TemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TemplateException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TemplateException(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

TemplateException Class
TemplateException Members
TemplateException Overload
CelloSaaS.Template.Model Namespace


TemplateException Constructor (SerializationInfo, StreamingContext)

[image]

A Sandcastle Documented Class Library
TemplateException Constructor (SerializationInfo, StreamingContext)
TemplateException Class See Also Send Feedback
Initializes a new instance of the TemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
protected TemplateException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
protected:
TemplateException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The info.
context
Type: System.Runtime.Serialization..::..StreamingContext
The context.

See Also

TemplateException Class
TemplateException Members
TemplateException Overload
CelloSaaS.Template.Model Namespace


TemplateException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TemplateException Constructor (String, Exception)
TemplateException Class See Also Send Feedback
Initializes a new instance of the TemplateException class.

Namespace: CelloSaaS.Template.Model
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TemplateException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TemplateException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message.
innerException
Type: System..::..Exception
The inner exception.

See Also

TemplateException Class
TemplateException Members
TemplateException Overload
CelloSaaS.Template.Model Namespace


TemplateException Methods

[image] [image]

A Sandcastle Documented Class Library
TemplateException Methods
TemplateException Class See Also Send Feedback

The TemplateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | (Inherited from BaseException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TemplateException Class
CelloSaaS.Template.Model Namespace


TemplateException Properties

[image] [image]

A Sandcastle Documented Class Library
TemplateException Properties
TemplateException Class See Also Send Feedback

The TemplateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExceptionCode | (Inherited from BaseException.)
Public property | ExceptionDetails | (Inherited from BaseException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TemplateException Class
CelloSaaS.Template.Model Namespace


TemplateException Events

[image] [image]

A Sandcastle Documented Class Library
TemplateException Events
TemplateException Class See Also Send Feedback

The TemplateException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TemplateException Class
CelloSaaS.Template.Model Namespace


CelloSaaS.Template.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.Template.ServiceContracts Namespace
Send Feedback

Interfaces

 | Interface | Description
Public interface | ITemplateService |


ITemplateService Interface

[image]

A Sandcastle Documented Class Library
ITemplateService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITemplateService
Visual Basic
Public Interface ITemplateService
Visual C++
public interface class ITemplateService

See Also

ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService Members

[image] [image]

A Sandcastle Documented Class Library
ITemplateService Members
ITemplateService Interface Methods See Also Send Feedback

The ITemplateService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateTemplate | This method is used to activates the template.
Public method | DeActivateTemplate | This method is used to deactivate the template.
Public method | DeleteLocaleTemplate | Deletes the locale template.
Public method | GetAllTemplateDetails | This method is used to get all the template details for the tenant Id.
Public method | GetAllTemplateDetailsByCategory | This method is used to gets all the template details based on the category.
Public method | GetLocaleTemplateByLocaleId | This method is used to gets the locale template for the locale id.
Public method | GetLocaleTemplateByLocaleName | This method is used to gets the locale template using the locale name.
Public method | GetLocaleTemplates | This method is used to get the locale templates for the template id.
Public method | GetLocaleTemplatesByTemplateIds | This method is used to gets the locale templates for array of template ids.
Public method | GetProcessedContent | This method is used to get the processed content.
Public method | GetProcessedTemplateContent | This method is uses to Processes the template Content and replace the placeholders with their corresponding values in wcf service.
Public method | GetTemplate | This method is used to gets all the template details for the tenant Id.
Public method | GetTemplates | This method is used to gets all the template details for the tenant Id.
Public method | SaveLocaleTemplate | This method is used to Save the locale template.
Public method | SaveTemplate | This method is used to saves the template.

See Also

ITemplateService Interface
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService Methods

[image] [image]

A Sandcastle Documented Class Library
ITemplateService Methods
ITemplateService Interface See Also Send Feedback

The ITemplateService type exposes the following members.

Methods

 | Name | Description
Public method | ActivateTemplate | This method is used to activates the template.
Public method | DeActivateTemplate | This method is used to deactivate the template.
Public method | DeleteLocaleTemplate | Deletes the locale template.
Public method | GetAllTemplateDetails | This method is used to get all the template details for the tenant Id.
Public method | GetAllTemplateDetailsByCategory | This method is used to gets all the template details based on the category.
Public method | GetLocaleTemplateByLocaleId | This method is used to gets the locale template for the locale id.
Public method | GetLocaleTemplateByLocaleName | This method is used to gets the locale template using the locale name.
Public method | GetLocaleTemplates | This method is used to get the locale templates for the template id.
Public method | GetLocaleTemplatesByTemplateIds | This method is used to gets the locale templates for array of template ids.
Public method | GetProcessedContent | This method is used to get the processed content.
Public method | GetProcessedTemplateContent | This method is uses to Processes the template Content and replace the placeholders with their corresponding values in wcf service.
Public method | GetTemplate | This method is used to gets all the template details for the tenant Id.
Public method | GetTemplates | This method is used to gets all the template details for the tenant Id.
Public method | SaveLocaleTemplate | This method is used to Save the locale template.
Public method | SaveTemplate | This method is used to saves the template.

See Also

ITemplateService Interface
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.ActivateTemplate Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..ActivateTemplate Method
ITemplateService Interface See Also Send Feedback
This method is used to activates the template.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ActivateTemplate(
    string templateId,
    string tenantId
)
Visual Basic
Sub ActivateTemplate (
    templateId As String,
    tenantId As String
)
Visual C++
void ActivateTemplate(
    String^ templateId,
    String^ tenantId
)

Parameters

templateId
Type: System..::..String
The template id.
tenantId
Type: System..::..String
The tenant id

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If db exception occurs while connecting or modifying the db.
System..::..ArgumentNullException | If the tenant Id or template id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.DeActivateTemplate Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..DeActivateTemplate Method
ITemplateService Interface See Also Send Feedback
This method is used to deactivate the template.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeActivateTemplate(
    string templateId,
    string tenantId
)
Visual Basic
Sub DeActivateTemplate (
    templateId As String,
    tenantId As String
)
Visual C++
void DeActivateTemplate(
    String^ templateId,
    String^ tenantId
)

Parameters

templateId
Type: System..::..String
The template id.
tenantId
Type: System..::..String
The tenant id

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If db exception occurs while activates the template.
System..::..ArgumentNullException | If the tenant Id or template id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.DeleteLocaleTemplate Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..DeleteLocaleTemplate Method
ITemplateService Interface See Also Send Feedback
Deletes the locale template.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteLocaleTemplate(
    string localeId,
    string templateId
)
Visual Basic
Sub DeleteLocaleTemplate (
    localeId As String,
    templateId As String
)
Visual C++
void DeleteLocaleTemplate(
    String^ localeId,
    String^ templateId
)

Parameters

localeId
Type: System..::..String
The locale id.
templateId
Type: System..::..String
The template id.

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If db exception occurs while connecting the db or deleting the locale template.
System..::..ArgumentNullException | If the template id or locale id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetAllTemplateDetails Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetAllTemplateDetails Method
ITemplateService Interface See Also Send Feedback
This method is used to get all the template details for the tenant Id.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TemplateDetail> GetAllTemplateDetails(
    string tenantId
)
Visual Basic
Function GetAllTemplateDetails (
    tenantId As String
) As Dictionary(Of String, TemplateDetail)
Visual C++
Dictionary<String^, TemplateDetail^>^ GetAllTemplateDetails(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, TemplateDetail >)>)>
Dictionary of template details.

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If any exception occurs while connecting or fetching the db.
System..::..ArgumentNullException | If the tenant Id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetAllTemplateDetailsByCategory Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetAllTemplateDetailsByCategory Method
ITemplateService Interface See Also Send Feedback
This method is used to gets all the template details based on the category.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TemplateDetail> GetAllTemplateDetailsByCategory(
    string tenantId,
    string category
)
Visual Basic
Function GetAllTemplateDetailsByCategory (
    tenantId As String,
    category As String
) As Dictionary(Of String, TemplateDetail)
Visual C++
Dictionary<String^, TemplateDetail^>^ GetAllTemplateDetailsByCategory(
    String^ tenantId,
    String^ category
)

Parameters

tenantId
Type: System..::..String
The tenant id.
category
Type: System..::..String
The category.

Return Value

Type: Dictionary<(Of <(<'String, TemplateDetail >)>)>
Dictionary of template details.

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If any exception occurs while connecting or fetching the db.
System..::..ArgumentNullException | If the tenant Id or category is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetLocaleTemplateByLocaleId Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetLocaleTemplateByLocaleId Method
ITemplateService Interface See Also Send Feedback
This method is used to gets the locale template for the locale id.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
LocaleTemplate GetLocaleTemplateByLocaleId(
    string templateId,
    string localeId
)
Visual Basic
Function GetLocaleTemplateByLocaleId (
    templateId As String,
    localeId As String
) As LocaleTemplate
Visual C++
LocaleTemplate^ GetLocaleTemplateByLocaleId(
    String^ templateId,
    String^ localeId
)

Parameters

templateId
Type: System..::..String
The template id.
localeId
Type: System..::..String
The locale id.

Return Value

Type: LocaleTemplate
locale template

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | if db exception occurs while connecting or fetching the db
System..::..ArgumentNullException | If the template id or locale id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetLocaleTemplateByLocaleName Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetLocaleTemplateByLocaleName Method
ITemplateService Interface See Also Send Feedback
This method is used to gets the locale template using the locale name.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
LocaleTemplate GetLocaleTemplateByLocaleName(
    string templateId,
    string localeName
)
Visual Basic
Function GetLocaleTemplateByLocaleName (
    templateId As String,
    localeName As String
) As LocaleTemplate
Visual C++
LocaleTemplate^ GetLocaleTemplateByLocaleName(
    String^ templateId,
    String^ localeName
)

Parameters

templateId
Type: System..::..String
The template id.
localeName
Type: System..::..String
Name of the locale.

Return Value

Type: LocaleTemplate
locale template

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If db exception occurs while connecting or fetching the db.
System..::..ArgumentNullException | If the template id or locale name is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetLocaleTemplates Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetLocaleTemplates Method
ITemplateService Interface See Also Send Feedback
This method is used to get the locale templates for the template id.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, LocaleTemplate> GetLocaleTemplates(
    string templateId
)
Visual Basic
Function GetLocaleTemplates (
    templateId As String
) As Dictionary(Of String, LocaleTemplate)
Visual C++
Dictionary<String^, LocaleTemplate^>^ GetLocaleTemplates(
    String^ templateId
)

Parameters

templateId
Type: System..::..String
The template id.

Return Value

Type: Dictionary<(Of <(<'String, LocaleTemplate >)>)>
Dictionary of locale templates

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If db exception occurs, while fetching the locale template details.
System..::..ArgumentNullException | If the template id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetLocaleTemplatesByTemplateIds Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetLocaleTemplatesByTemplateIds Method
ITemplateService Interface See Also Send Feedback
This method is used to gets the locale templates for array of template ids.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, LocaleTemplate> GetLocaleTemplatesByTemplateIds(
    string[] templateIds,
    string localeName
)
Visual Basic
Function GetLocaleTemplatesByTemplateIds (
    templateIds As String(),
    localeName As String
) As Dictionary(Of String, LocaleTemplate)
Visual C++
Dictionary<String^, LocaleTemplate^>^ GetLocaleTemplatesByTemplateIds(
    array<String^>^ templateIds,
    String^ localeName
)

Parameters

templateIds
Type: array<System..::..String>[]()[][]
The template ids.
localeName
Type: System..::..String
The locale id.

Return Value

Type: Dictionary<(Of <(<'String, LocaleTemplate >)>)>
Dictionary of locale templates

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If any exception occurs while connecting or fetching the db.
System..::..ArgumentNullException | If the template ids or locale name is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetProcessedContent Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetProcessedContent Method
ITemplateService Interface See Also Send Feedback
This method is used to get the processed content.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetProcessedContent(
    string templateContent,
    string tenantId,
    string inputXml,
    Dictionary<string, string> keys,
    Dictionary<string, Object> objects,
    Object[] args
)
Visual Basic
Function GetProcessedContent (
    templateContent As String,
    tenantId As String,
    inputXml As String,
    keys As Dictionary(Of String, String),
    objects As Dictionary(Of String, Object),
    args As Object()
) As String
Visual C++
String^ GetProcessedContent(
    String^ templateContent,
    String^ tenantId,
    String^ inputXml,
    Dictionary<String^, String^>^ keys,
    Dictionary<String^, Object^>^ objects,
    array<Object^>^ args
)

Parameters

templateContent
Type: System..::..String
tenantId
Type: System..::..String
The tenant id.
inputXml
Type: System..::..String
keys
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
The keys.
objects
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, Object>)>)>
The objects.
args
Type: array<System..::..Object>[]()[][]
The args.

Return Value

Type: String
processed template content.

Exceptions

Exception | Condition
System..::..ArgumentNullException | If the notification message is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetProcessedTemplateContent Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetProcessedTemplateContent Method
ITemplateService Interface See Also Send Feedback
This method is uses to Processes the template Content and replace the placeholders with their corresponding values in wcf service.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string GetProcessedTemplateContent(
    string tenantId,
    string templateContent,
    Dictionary<string, string> keys,
    string[] inputXml
)
Visual Basic
Function GetProcessedTemplateContent (
    tenantId As String,
    templateContent As String,
    keys As Dictionary(Of String, String),
    inputXml As String()
) As String
Visual C++
String^ GetProcessedTemplateContent(
    String^ tenantId,
    String^ templateContent,
    Dictionary<String^, String^>^ keys,
    array<String^>^ inputXml
)

Parameters

tenantId
Type: System..::..String
The tenant id.
templateContent
Type: System..::..String
The notification message.
keys
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
The keys.
inputXml
Type: array<System..::..String>[]()[][]
The input XML.

Return Value

Type: String
processed template content.

Exceptions

Exception | Condition
System..::..ArgumentNullException | If the notification message is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetTemplate Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetTemplate Method
ITemplateService Interface See Also Send Feedback
This method is used to gets all the template details for the tenant Id.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TemplateDetail GetTemplate(
    string tenantId,
    string templateId
)
Visual Basic
Function GetTemplate (
    tenantId As String,
    templateId As String
) As TemplateDetail
Visual C++
TemplateDetail^ GetTemplate(
    String^ tenantId,
    String^ templateId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
templateId
Type: System..::..String
The template id.

Return Value

Type: TemplateDetail
Template Details

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If any exception occurs while connecting or fetching the db.
System..::..ArgumentNullException | If the tenant Id or template id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.GetTemplates Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..GetTemplates Method
ITemplateService Interface See Also Send Feedback
This method is used to gets all the template details for the tenant Id.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TemplateDetail> GetTemplates(
    string tenantId,
    string[] templateIds
)
Visual Basic
Function GetTemplates (
    tenantId As String,
    templateIds As String()
) As Dictionary(Of String, TemplateDetail)
Visual C++
Dictionary<String^, TemplateDetail^>^ GetTemplates(
    String^ tenantId,
    array<String^>^ templateIds
)

Parameters

tenantId
Type: System..::..String
The tenant id.
templateIds
Type: array<System..::..String>[]()[][]
The template id.

Return Value

Type: Dictionary<(Of <(<'String, TemplateDetail >)>)>
Template Details

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If any exception occurs while connecting or fetching the db.
System..::..ArgumentNullException | If the tenant Id or template id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.SaveLocaleTemplate Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..SaveLocaleTemplate Method
ITemplateService Interface See Also Send Feedback
This method is used to Save the locale template.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string SaveLocaleTemplate(
    LocaleTemplate localeTemplate
)
Visual Basic
Function SaveLocaleTemplate (
    localeTemplate As LocaleTemplate
) As String
Visual C++
String^ SaveLocaleTemplate(
    LocaleTemplate^ localeTemplate
)

Parameters

localeTemplate
Type: CelloSaaS.Template.Model..::..LocaleTemplate
The locale template.

Return Value

Type: String
locale template id

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..TemplateException | If db exception occurs while connecting or modifying the db
System..::..ArgumentException | If the locale template is null or empty.
System..::..ArgumentNullException | If the locale template template id or locale template locale id is null or empty.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


ITemplateService.SaveTemplate Method

[image]

A Sandcastle Documented Class Library
ITemplateService..::..SaveTemplate Method
ITemplateService Interface See Also Send Feedback
This method is used to saves the template.

Namespace: CelloSaaS.Template.ServiceContracts
Assembly: CelloSaaS.Template (in CelloSaaS.Template.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string SaveTemplate(
    TemplateDetail template
)
Visual Basic
Function SaveTemplate (
    template As TemplateDetail
) As String
Visual C++
String^ SaveTemplate(
    TemplateDetail^ template
)

Parameters

template
Type: CelloSaaS.Template.Model..::..TemplateDetail
The template.

Return Value

Type: String
TemplateId

Exceptions

Exception | Condition
CelloSaaS.Template.Model..::..DuplicateTemplateNameException | If the template name is duplicate.
CelloSaaS.Template.Model..::..TemplateException | If any error occurs while connecting or modifying the db.
System..::..ArgumentNullException | If the tenant Id or template name is null or empty.
System..::..ArgumentException | If the template is null.

See Also

ITemplateService Interface
ITemplateService Members
CelloSaaS.Template.ServiceContracts Namespace


CelloSaaS.TimeScheduler.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.TimeScheduler.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | JobParameter | Quartz Job paramter class
Public class | TimeSchedule | The time schedule model class
Public class | TimeScheduleSearchCondition | This class defines time schedule search parameters


JobParameter Class

[image]

A Sandcastle Documented Class Library
JobParameter Class
Members See Also Send Feedback
Quartz Job paramter class

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class JobParameter
Visual Basic
<SerializableAttribute>
Public Class JobParameter
Visual C++
[SerializableAttribute]
public ref class JobParameter

Inheritance Hierarchy

System..::..Object
CelloSaaS.TimeScheduler.Model..::..JobParameter

See Also

JobParameter Members
CelloSaaS.TimeScheduler.Model Namespace


JobParameter Members

[image] [image]

A Sandcastle Documented Class Library
JobParameter Members
JobParameter Class Constructors Methods Properties See Also Send Feedback

The JobParameter type exposes the following members.

Constructors

 | Name | Description
Public method | JobParameter | Initializes a new instance of the JobParameter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | This is used to get or set the key.
Public property | Value | This is used to get or set the value.

See Also

JobParameter Class
CelloSaaS.TimeScheduler.Model Namespace


JobParameter Constructor

[image]

A Sandcastle Documented Class Library
JobParameter Constructor
JobParameter Class See Also Send Feedback
Initializes a new instance of the JobParameter class

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public JobParameter()
Visual Basic
Public Sub New
Visual C++
public:
JobParameter()

See Also

JobParameter Class
JobParameter Members
CelloSaaS.TimeScheduler.Model Namespace


JobParameter Methods

[image] [image]

A Sandcastle Documented Class Library
JobParameter Methods
JobParameter Class See Also Send Feedback

The JobParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JobParameter Class
CelloSaaS.TimeScheduler.Model Namespace


JobParameter Properties

[image] [image]

A Sandcastle Documented Class Library
JobParameter Properties
JobParameter Class See Also Send Feedback

The JobParameter type exposes the following members.

Properties

 | Name | Description
Public property | Key | This is used to get or set the key.
Public property | Value | This is used to get or set the value.

See Also

JobParameter Class
CelloSaaS.TimeScheduler.Model Namespace


JobParameter.Key Property

[image]

A Sandcastle Documented Class Library
JobParameter..::..Key Property
JobParameter Class See Also Send Feedback
This is used to get or set the key.

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Key { get; set; }
Visual Basic
Public Property Key As String
    Get
    Set
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The key.

See Also

JobParameter Class
JobParameter Members
CelloSaaS.TimeScheduler.Model Namespace


JobParameter.Value Property

[image]

A Sandcastle Documented Class Library
JobParameter..::..Value Property
JobParameter Class See Also Send Feedback
This is used to get or set the value.

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
The value.

See Also

JobParameter Class
JobParameter Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule Class

[image]

A Sandcastle Documented Class Library
TimeSchedule Class
Members See Also Send Feedback
The time schedule model class

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class TimeSchedule
Visual Basic
Public Class TimeSchedule
Visual C++
public ref class TimeSchedule

Inheritance Hierarchy

System..::..Object
CelloSaaS.TimeScheduler.Model..::..TimeSchedule

See Also

TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule Members

[image] [image]

A Sandcastle Documented Class Library
TimeSchedule Members
TimeSchedule Class Constructors Methods Properties See Also Send Feedback

The TimeSchedule type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSchedule | Initializes a new instance of the TimeSchedule class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | This is used to get or set the created user id
Public property | CreatedOn | This is used to get or set the created date and time
Public property | EndDateTime | This is used to get or set the end date and time
Public property | JobId | This is used to get or set the job id
Public property | JobReferenceName | This is used to get or set the job reference id
Public property | ScheduleId | This is used to get or set the schedule id
Public property | StartDateTime | This is used to get or set the start date and time
Public property | Status | This is used to get or set status
Public property | TimeScheduleId | This is used to get or set the time schedule id
Public property | UpdatedBy | This is used to get or set the updated user id
Public property | UpdatedOn | This is used to get or set the created date and time

See Also

TimeSchedule Class
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule Constructor

[image]

A Sandcastle Documented Class Library
TimeSchedule Constructor
TimeSchedule Class See Also Send Feedback
Initializes a new instance of the TimeSchedule class

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TimeSchedule()
Visual Basic
Public Sub New
Visual C++
public:
TimeSchedule()

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule Methods

[image] [image]

A Sandcastle Documented Class Library
TimeSchedule Methods
TimeSchedule Class See Also Send Feedback

The TimeSchedule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TimeSchedule Class
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule Properties

[image] [image]

A Sandcastle Documented Class Library
TimeSchedule Properties
TimeSchedule Class See Also Send Feedback

The TimeSchedule type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | This is used to get or set the created user id
Public property | CreatedOn | This is used to get or set the created date and time
Public property | EndDateTime | This is used to get or set the end date and time
Public property | JobId | This is used to get or set the job id
Public property | JobReferenceName | This is used to get or set the job reference id
Public property | ScheduleId | This is used to get or set the schedule id
Public property | StartDateTime | This is used to get or set the start date and time
Public property | Status | This is used to get or set status
Public property | TimeScheduleId | This is used to get or set the time schedule id
Public property | UpdatedBy | This is used to get or set the updated user id
Public property | UpdatedOn | This is used to get or set the created date and time

See Also

TimeSchedule Class
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..CreatedBy Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the created user id

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..CreatedOn Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the created date and time

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.EndDateTime Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..EndDateTime Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the end date and time

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> EndDateTime { get; set; }
Visual Basic
Public Property EndDateTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> EndDateTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.JobId Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..JobId Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the job id

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.JobReferenceName Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..JobReferenceName Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the job reference id

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobReferenceName { get; set; }
Visual Basic
Public Property JobReferenceName As String
    Get
    Set
Visual C++
public:
property String^ JobReferenceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.ScheduleId Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..ScheduleId Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the schedule id

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ScheduleId { get; set; }
Visual Basic
Public Property ScheduleId As String
    Get
    Set
Visual C++
public:
property String^ ScheduleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.StartDateTime Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..StartDateTime Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the start date and time

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime StartDateTime { get; set; }
Visual Basic
Public Property StartDateTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDateTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.Status Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..Status Property
TimeSchedule Class See Also Send Feedback
This is used to get or set status

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.TimeScheduleId Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..TimeScheduleId Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the time schedule id

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TimeScheduleId { get; set; }
Visual Basic
Public Property TimeScheduleId As String
    Get
    Set
Visual C++
public:
property String^ TimeScheduleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..UpdatedBy Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the updated user id

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeSchedule.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TimeSchedule..::..UpdatedOn Property
TimeSchedule Class See Also Send Feedback
This is used to get or set the created date and time

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime

See Also

TimeSchedule Class
TimeSchedule Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition Class

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition Class
Members See Also Send Feedback
This class defines time schedule search parameters

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class TimeScheduleSearchCondition : ISearchCondition
Visual Basic
Public Class TimeScheduleSearchCondition
    Implements ISearchCondition
Visual C++
public ref class TimeScheduleSearchCondition : ISearchCondition

Inheritance Hierarchy

System..::..Object
CelloSaaS.TimeScheduler.Model..::..TimeScheduleSearchCondition

See Also

TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition Members

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition Members
TimeScheduleSearchCondition Class Constructors Methods Properties See Also Send Feedback

The TimeScheduleSearchCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TimeScheduleSearchCondition | Initializes a new instance of the TimeScheduleSearchCondition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | This is used to get or set Condition
Public property | EndDateTime | This is used to get or set the end date time
Public property | JobId | This is used to get or set the job id.
Public property | JobReferenceName | This is used to get or set the name of the job reference.
Public property | ScheduleId | This is used to get or set the schedule id.
Public property | StartDateTime | This is used to get or set the start date time
Public property | TimeScheduleId | This is used to get or set the time schedule id.

See Also

TimeScheduleSearchCondition Class
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition Constructor

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition Constructor
TimeScheduleSearchCondition Class See Also Send Feedback
Initializes a new instance of the TimeScheduleSearchCondition class

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TimeScheduleSearchCondition()
Visual Basic
Public Sub New
Visual C++
public:
TimeScheduleSearchCondition()

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition Methods

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition Methods
TimeScheduleSearchCondition Class See Also Send Feedback

The TimeScheduleSearchCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TimeScheduleSearchCondition Class
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition Properties

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition Properties
TimeScheduleSearchCondition Class See Also Send Feedback

The TimeScheduleSearchCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | This is used to get or set Condition
Public property | EndDateTime | This is used to get or set the end date time
Public property | JobId | This is used to get or set the job id.
Public property | JobReferenceName | This is used to get or set the name of the job reference.
Public property | ScheduleId | This is used to get or set the schedule id.
Public property | StartDateTime | This is used to get or set the start date time
Public property | TimeScheduleId | This is used to get or set the time schedule id.

See Also

TimeScheduleSearchCondition Class
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.Condition Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..Condition Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set Condition

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Condition { get; set; }
Visual Basic
Public Property Condition As String
    Get
    Set
Visual C++
public:
virtual property String^ Condition {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISearchCondition..::..Condition

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.EndDateTime Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..EndDateTime Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set the end date time

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> EndDateTime { get; set; }
Visual Basic
Public Property EndDateTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> EndDateTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.JobId Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..JobId Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set the job id.

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobId { get; set; }
Visual Basic
Public Property JobId As String
    Get
    Set
Visual C++
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The job id.

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.JobReferenceName Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..JobReferenceName Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set the name of the job reference.

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string JobReferenceName { get; set; }
Visual Basic
Public Property JobReferenceName As String
    Get
    Set
Visual C++
public:
property String^ JobReferenceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the job reference.

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.ScheduleId Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..ScheduleId Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set the schedule id.

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ScheduleId { get; set; }
Visual Basic
Public Property ScheduleId As String
    Get
    Set
Visual C++
public:
property String^ ScheduleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The schedule id.

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.StartDateTime Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..StartDateTime Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set the start date time

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> StartDateTime { get; set; }
Visual Basic
Public Property StartDateTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> StartDateTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


TimeScheduleSearchCondition.TimeScheduleId Property

[image]

A Sandcastle Documented Class Library
TimeScheduleSearchCondition..::..TimeScheduleId Property
TimeScheduleSearchCondition Class See Also Send Feedback
This is used to get or set the time schedule id.

Namespace: CelloSaaS.TimeScheduler.Model
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TimeScheduleId { get; set; }
Visual Basic
Public Property TimeScheduleId As String
    Get
    Set
Visual C++
public:
property String^ TimeScheduleId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The time schedule id.

See Also

TimeScheduleSearchCondition Class
TimeScheduleSearchCondition Members
CelloSaaS.TimeScheduler.Model Namespace


CelloSaaS.TimeScheduler.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.TimeScheduler.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | TimeScheduleException | The Time schedule exception

Interfaces

 | Interface | Description
Public interface | ITimeSchedulerService | The interface to be implemented for the time scheduler service


ITimeSchedulerService Interface

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService Interface
Members See Also Send Feedback
The interface to be implemented for the time scheduler service

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITimeSchedulerService
Visual Basic
Public Interface ITimeSchedulerService
Visual C++
public interface class ITimeSchedulerService

See Also

ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService Members

[image] [image]

A Sandcastle Documented Class Library
ITimeSchedulerService Members
ITimeSchedulerService Interface Methods See Also Send Feedback

The ITimeSchedulerService type exposes the following members.

Methods

 | Name | Description
Public method | AddTimeScheduleToQuartz(TimeSchedule, IList<(Of <<'(JobParameter>)>>)) | This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database
Public method | AddTimeScheduleToQuartz(TimeSchedule, IList<(Of <<'(JobParameter>)>>), Int32, TimeSpan) | This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database
Public method | CreateTimeSchedule | This service will insert new time schedule record in the database
Public method | DeleteTimeSchedule | This method will delete the time schedule record from the database.
Public method | GetTimeSchedule | This service searches the time schedule records
Public method | GetTimeScheduleByJobId | This service searches the time schedule records by job identifier.
Public method | GetTimeScheduleByJobReferenceName | This service searches the time schedule records by job reference name.
Public method | GetTimeScheduleByScheduleId | This service searches the time schedule records by schedule identifier.
Public method | GetTimeSchedules | This service searches the time schedule records for the given time range.
Public method | UpdateTimeSchedule | This service updates the time schedule details in the database

See Also

ITimeSchedulerService Interface
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService Methods

[image] [image]

A Sandcastle Documented Class Library
ITimeSchedulerService Methods
ITimeSchedulerService Interface See Also Send Feedback

The ITimeSchedulerService type exposes the following members.

Methods

 | Name | Description
Public method | AddTimeScheduleToQuartz(TimeSchedule, IList<(Of <<'(JobParameter>)>>)) | This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database
Public method | AddTimeScheduleToQuartz(TimeSchedule, IList<(Of <<'(JobParameter>)>>), Int32, TimeSpan) | This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database
Public method | CreateTimeSchedule | This service will insert new time schedule record in the database
Public method | DeleteTimeSchedule | This method will delete the time schedule record from the database.
Public method | GetTimeSchedule | This service searches the time schedule records
Public method | GetTimeScheduleByJobId | This service searches the time schedule records by job identifier.
Public method | GetTimeScheduleByJobReferenceName | This service searches the time schedule records by job reference name.
Public method | GetTimeScheduleByScheduleId | This service searches the time schedule records by schedule identifier.
Public method | GetTimeSchedules | This service searches the time schedule records for the given time range.
Public method | UpdateTimeSchedule | This service updates the time schedule details in the database

See Also

ITimeSchedulerService Interface
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.AddTimeScheduleToQuartz Method

[image] [image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..AddTimeScheduleToQuartz Method
ITimeSchedulerService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddTimeScheduleToQuartz(TimeSchedule, IList<(Of <<'(JobParameter>)>>)) | This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database
Public method | AddTimeScheduleToQuartz(TimeSchedule, IList<(Of <<'(JobParameter>)>>), Int32, TimeSpan) | This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.AddTimeScheduleToQuartz Method (TimeSchedule, IList(JobParameter))

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..AddTimeScheduleToQuartz Method (TimeSchedule, IList<(Of <(<'JobParameter>)>)>)
ITimeSchedulerService Interface See Also Send Feedback
This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddTimeScheduleToQuartz(
    TimeSchedule timeSchedule,
    IList<JobParameter> jobParameters
)
Visual Basic
Function AddTimeScheduleToQuartz (
    timeSchedule As TimeSchedule,
    jobParameters As IList(Of JobParameter)
) As String
Visual C++
String^ AddTimeScheduleToQuartz(
    TimeSchedule^ timeSchedule,
    IList<JobParameter^>^ jobParameters
)

Parameters

timeSchedule
Type: CelloSaaS.TimeScheduler.Model..::..TimeSchedule
The time schedule.
jobParameters
Type: System.Collections.Generic..::..IList<(Of <(<' JobParameter >)>)>
The job parameters.

Return Value

Type: String
newly inserted record id

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
AddTimeScheduleToQuartz Overload
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.AddTimeScheduleToQuartz Method (TimeSchedule, IList(JobParameter), Int32, TimeSpan)

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..AddTimeScheduleToQuartz Method (TimeSchedule, IList<(Of <(<'JobParameter>)>)>, Int32, TimeSpan)
ITimeSchedulerService Interface See Also Send Feedback
This method will created time schedule and schedule it to quartz scheduler and then inserts them to the database

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddTimeScheduleToQuartz(
    TimeSchedule timeSchedule,
    IList<JobParameter> jobParameters,
    int triggerType,
    TimeSpan timeSpan
)
Visual Basic
Function AddTimeScheduleToQuartz (
    timeSchedule As TimeSchedule,
    jobParameters As IList(Of JobParameter),
    triggerType As Integer,
    timeSpan As TimeSpan
) As String
Visual C++
String^ AddTimeScheduleToQuartz(
    TimeSchedule^ timeSchedule,
    IList<JobParameter^>^ jobParameters,
    int triggerType,
    TimeSpan timeSpan
)

Parameters

timeSchedule
Type: CelloSaaS.TimeScheduler.Model..::..TimeSchedule
time schedule details
jobParameters
Type: System.Collections.Generic..::..IList<(Of <(<' JobParameter >)>)>
job parameters
triggerType
Type: System..::..Int32
The trigger. Can be either Quartz.SimpleTrigger.RepeatIndefinitely or Quartz.SimpleTrigger.DefaultPriority
timeSpan
Type: System..::..TimeSpan
The time interval.

Return Value

Type: String
returns newly inserted time schedule identifier

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when job is null or empty
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while inserting time schedule details or could not able to create job instance of type

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
AddTimeScheduleToQuartz Overload
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.CreateTimeSchedule Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..CreateTimeSchedule Method
ITimeSchedulerService Interface See Also Send Feedback
This service will insert new time schedule record in the database

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CreateTimeSchedule(
    TimeSchedule timeSchedule
)
Visual Basic
Function CreateTimeSchedule (
    timeSchedule As TimeSchedule
) As String
Visual C++
String^ CreateTimeSchedule(
    TimeSchedule^ timeSchedule
)

Parameters

timeSchedule
Type: CelloSaaS.TimeScheduler.Model..::..TimeSchedule
time schedule details

Return Value

Type: String
returns the newly inserted identifier

Exceptions

Exception | Condition
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while inserting time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.DeleteTimeSchedule Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..DeleteTimeSchedule Method
ITimeSchedulerService Interface See Also Send Feedback
This method will delete the time schedule record from the database.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTimeSchedule(
    string timeScheduleId
)
Visual Basic
Sub DeleteTimeSchedule (
    timeScheduleId As String
)
Visual C++
void DeleteTimeSchedule(
    String^ timeScheduleId
)

Parameters

timeScheduleId
Type: System..::..String
time schedule record id to be deleted

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when time schedule id is null or empty
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while deleting time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.GetTimeSchedule Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..GetTimeSchedule Method
ITimeSchedulerService Interface See Also Send Feedback
This service searches the time schedule records

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TimeSchedule GetTimeSchedule(
    string timeScheduleId
)
Visual Basic
Function GetTimeSchedule (
    timeScheduleId As String
) As TimeSchedule
Visual C++
TimeSchedule^ GetTimeSchedule(
    String^ timeScheduleId
)

Parameters

timeScheduleId
Type: System..::..String
time schedule identifier

Return Value

Type: TimeSchedule
returns time schedule details if found otherwise null is returned

Exceptions

Exception | Condition
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while searching time schedule details
System..::..ArgumentNullException | This exception is thrown when time schedule id is null or empty

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.GetTimeScheduleByJobId Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..GetTimeScheduleByJobId Method
ITimeSchedulerService Interface See Also Send Feedback
This service searches the time schedule records by job identifier.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TimeSchedule> GetTimeScheduleByJobId(
    string jobId
)
Visual Basic
Function GetTimeScheduleByJobId (
    jobId As String
) As Dictionary(Of String, TimeSchedule)
Visual C++
Dictionary<String^, TimeSchedule^>^ GetTimeScheduleByJobId(
    String^ jobId
)

Parameters

jobId
Type: System..::..String
job identifier

Return Value

Type: Dictionary<(Of <(<'String, TimeSchedule >)>)>
returns dictionary of time schedule details found

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when jobId is null or empty
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while searching time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.GetTimeScheduleByJobReferenceName Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..GetTimeScheduleByJobReferenceName Method
ITimeSchedulerService Interface See Also Send Feedback
This service searches the time schedule records by job reference name.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TimeSchedule> GetTimeScheduleByJobReferenceName(
    string jobRefName
)
Visual Basic
Function GetTimeScheduleByJobReferenceName (
    jobRefName As String
) As Dictionary(Of String, TimeSchedule)
Visual C++
Dictionary<String^, TimeSchedule^>^ GetTimeScheduleByJobReferenceName(
    String^ jobRefName
)

Parameters

jobRefName
Type: System..::..String
job reference name

Return Value

Type: Dictionary<(Of <(<'String, TimeSchedule >)>)>
returns dictionary of time schedule details found

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when jobRefName is null or empty
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while deleting time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.GetTimeScheduleByScheduleId Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..GetTimeScheduleByScheduleId Method
ITimeSchedulerService Interface See Also Send Feedback
This service searches the time schedule records by schedule identifier.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TimeSchedule> GetTimeScheduleByScheduleId(
    string scheduleId
)
Visual Basic
Function GetTimeScheduleByScheduleId (
    scheduleId As String
) As Dictionary(Of String, TimeSchedule)
Visual C++
Dictionary<String^, TimeSchedule^>^ GetTimeScheduleByScheduleId(
    String^ scheduleId
)

Parameters

scheduleId
Type: System..::..String
scheduler identifier

Return Value

Type: Dictionary<(Of <(<'String, TimeSchedule >)>)>
returns dictionary of time schedule details found

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when scheduleId is null or empty
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while searching time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.GetTimeSchedules Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..GetTimeSchedules Method
ITimeSchedulerService Interface See Also Send Feedback
This service searches the time schedule records for the given time range.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TimeSchedule> GetTimeSchedules(
    DateTime startDate,
    DateTime endDate
)
Visual Basic
Function GetTimeSchedules (
    startDate As DateTime,
    endDate As DateTime
) As Dictionary(Of String, TimeSchedule)
Visual C++
Dictionary<String^, TimeSchedule^>^ GetTimeSchedules(
    DateTime startDate,
    DateTime endDate
)

Parameters

startDate
Type: System..::..DateTime
job start time
endDate
Type: System..::..DateTime
job end time

Return Value

Type: Dictionary<(Of <(<'String, TimeSchedule >)>)>
returns dictionary of time schedule details found

Exceptions

Exception | Condition
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while searching time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


ITimeSchedulerService.UpdateTimeSchedule Method

[image]

A Sandcastle Documented Class Library
ITimeSchedulerService..::..UpdateTimeSchedule Method
ITimeSchedulerService Interface See Also Send Feedback
This service updates the time schedule details in the database

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateTimeSchedule(
    TimeSchedule timeSchedule
)
Visual Basic
Sub UpdateTimeSchedule (
    timeSchedule As TimeSchedule
)
Visual C++
void UpdateTimeSchedule(
    TimeSchedule^ timeSchedule
)

Parameters

timeSchedule
Type: CelloSaaS.TimeScheduler.Model..::..TimeSchedule
time schedule details to be updated

Exceptions

Exception | Condition
System..::..ArgumentNullException | This exception is thrown when time schedule is null or empty
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException | This exception is thrown while updating time schedule details

See Also

ITimeSchedulerService Interface
ITimeSchedulerService Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Class

[image]

A Sandcastle Documented Class Library
TimeScheduleException Class
Members See Also Send Feedback
The Time schedule exception

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TimeScheduleException : Exception
Visual Basic
<SerializableAttribute>
Public Class TimeScheduleException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class TimeScheduleException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.TimeScheduler.ServiceContracts..::..TimeScheduleException

See Also

TimeScheduleException Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Members

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleException Members
TimeScheduleException Class Constructors Methods Properties Events See Also Send Feedback

The TimeScheduleException type exposes the following members.

Constructors

 | Name | Description
Public method | TimeScheduleException()()()() | Initializes a new instance of the TimeScheduleException class.
Public method | TimeScheduleException(String) | Initializes a new instance of the TimeScheduleException class.
Public method | TimeScheduleException(String, Exception) | Initializes a new instance of the TimeScheduleException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TimeScheduleException Class
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Constructor

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleException Constructor
TimeScheduleException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TimeScheduleException()()()() | Initializes a new instance of the TimeScheduleException class.
Public method | TimeScheduleException(String) | Initializes a new instance of the TimeScheduleException class.
Public method | TimeScheduleException(String, Exception) | Initializes a new instance of the TimeScheduleException class.

See Also

TimeScheduleException Class
TimeScheduleException Members
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Constructor

[image]

A Sandcastle Documented Class Library
TimeScheduleException Constructor
TimeScheduleException Class See Also Send Feedback
Initializes a new instance of the TimeScheduleException class.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TimeScheduleException()
Visual Basic
Public Sub New
Visual C++
public:
TimeScheduleException()

See Also

TimeScheduleException Class
TimeScheduleException Members
TimeScheduleException Overload
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Constructor (String)

[image]

A Sandcastle Documented Class Library
TimeScheduleException Constructor (String)
TimeScheduleException Class See Also Send Feedback
Initializes a new instance of the TimeScheduleException class.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TimeScheduleException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
TimeScheduleException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

TimeScheduleException Class
TimeScheduleException Members
TimeScheduleException Overload
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
TimeScheduleException Constructor (String, Exception)
TimeScheduleException Class See Also Send Feedback
Initializes a new instance of the TimeScheduleException class.

Namespace: CelloSaaS.TimeScheduler.ServiceContracts
Assembly: CelloSaaS.TimeScheduler (in CelloSaaS.TimeScheduler.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TimeScheduleException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
TimeScheduleException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The error message that explains the reason for the exception.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

TimeScheduleException Class
TimeScheduleException Members
TimeScheduleException Overload
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Methods

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleException Methods
TimeScheduleException Class See Also Send Feedback

The TimeScheduleException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

TimeScheduleException Class
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Properties

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleException Properties
TimeScheduleException Class See Also Send Feedback

The TimeScheduleException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

TimeScheduleException Class
CelloSaaS.TimeScheduler.ServiceContracts Namespace


TimeScheduleException Events

[image] [image]

A Sandcastle Documented Class Library
TimeScheduleException Events
TimeScheduleException Class See Also Send Feedback

The TimeScheduleException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

TimeScheduleException Class
CelloSaaS.TimeScheduler.ServiceContracts Namespace


CelloSaaS.WorkFlow.Activities Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.WorkFlow.Activities Namespace
Send Feedback

Classes

 | Class | Description
Public class | ApprovalActivity | This activity is used for Approval process
Public class | ApprovalActivityDefinition | This Activity Definition is used for Approval Activity
Public class | NotificationActivity |
Public class | NotificationActivityConstants | This class contains the Notification Activity Property constants
Public class | NotificationActivityDefinition | This class is used to define the Sending Email Activity
Public class | ServiceCallActivity |
Public class | ServiceCallActivityConstants |
Public class | ServiceCallActivityDefinition | This class is used to define the service call Activity


ApprovalActivity Class

[image]

A Sandcastle Documented Class Library
ApprovalActivity Class
Members See Also Send Feedback
This activity is used for Approval process

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ApprovalActivity : IActivity
Visual Basic
Public Class ApprovalActivity
    Implements IActivity
Visual C++
public ref class ApprovalActivity : IActivity

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Activities..::..ApprovalActivity

See Also

ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity Members

[image] [image]

A Sandcastle Documented Class Library
ApprovalActivity Members
ApprovalActivity Class Constructors Methods Properties See Also Send Feedback

The ApprovalActivity type exposes the following members.

Constructors

 | Name | Description
Public method | ApprovalActivity | Initializes a new instance of the ApprovalActivity class

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExpired | Determines whether this instance has expired.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

ApprovalActivity Class
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity Constructor

[image]

A Sandcastle Documented Class Library
ApprovalActivity Constructor
ApprovalActivity Class See Also Send Feedback
Initializes a new instance of the ApprovalActivity class

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ApprovalActivity()
Visual Basic
Public Sub New
Visual C++
public:
ApprovalActivity()

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity Methods

[image] [image]

A Sandcastle Documented Class Library
ApprovalActivity Methods
ApprovalActivity Class See Also Send Feedback

The ApprovalActivity type exposes the following members.

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExpired | Determines whether this instance has expired.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ApprovalActivity Class
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.CanComplete Method

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..CanComplete Method
ApprovalActivity Class See Also Send Feedback
Determines whether this instance can complete.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool CanComplete()
Visual Basic
Public Function CanComplete As Boolean
Visual C++
public:
virtual bool CanComplete() sealed

Return Value

Type: Boolean
true if this instance can complete; otherwise, false.

Implements

IActivity..::..CanComplete()()()()

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.CanStart Method

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..CanStart Method
ApprovalActivity Class See Also Send Feedback
Determines whether this instance can start.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool CanStart()
Visual Basic
Public Function CanStart As Boolean
Visual C++
public:
virtual bool CanStart() sealed

Return Value

Type: Boolean
true if this instance can start; otherwise, false.

Implements

IActivity..::..CanStart()()()()

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.Complete Method

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..Complete Method
ApprovalActivity Class See Also Send Feedback
Completes this instance.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Complete()
Visual Basic
Public Function Complete As List(Of String)
Visual C++
public:
virtual List<String^>^ Complete() sealed

Return Value

Type: List<(Of <(<'String>)>)>

Implements

IActivity..::..Complete()()()()

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.Execute Method

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..Execute Method
ApprovalActivity Class See Also Send Feedback
Executes this instance.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Execute()
Visual Basic
Public Function Execute As List(Of String)
Visual C++
public:
virtual List<String^>^ Execute() sealed

Return Value

Type: List<(Of <(<'String>)>)>

Implements

IActivity..::..Execute()()()()

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.HasExpired Method

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..HasExpired Method
ApprovalActivity Class See Also Send Feedback
Determines whether this instance has expired.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool HasExpired()
Visual Basic
Public Function HasExpired As Boolean
Visual C++
public:
virtual bool HasExpired() sealed

Return Value

Type: Boolean
true if this instance has expired; otherwise, false.

Implements

IActivity..::..HasExpired()()()()

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity Properties

[image] [image]

A Sandcastle Documented Class Library
ApprovalActivity Properties
ApprovalActivity Class See Also Send Feedback

The ApprovalActivity type exposes the following members.

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

ApprovalActivity Class
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.ActivityDefinition Property

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..ActivityDefinition Property
ApprovalActivity Class See Also Send Feedback
Gets or sets the activity definition.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskActivityDefinition ActivityDefinition { get; set; }
Visual Basic
Public Property ActivityDefinition As ITaskActivityDefinition
    Get
    Set
Visual C++
public:
virtual property ITaskActivityDefinition^ ActivityDefinition {
    ITaskActivityDefinition^ get () sealed;
    void set (ITaskActivityDefinition^ value) sealed;
}

Property Value

Type: ITaskActivityDefinition
The activity definition.

Implements

IActivity..::..ActivityDefinition

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.Inputs Property

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..Inputs Property
ApprovalActivity Class See Also Send Feedback
Gets or sets the inputs.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Object> Inputs { get; set; }
Visual Basic
Public Property Inputs As List(Of Object)
    Get
    Set
Visual C++
public:
virtual property List<Object^>^ Inputs {
    List<Object^>^ get () sealed;
    void set (List<Object^>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Object>)>)>
The inputs.

Implements

IActivity..::..Inputs

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivity.TaskInstanceService Property

[image]

A Sandcastle Documented Class Library
ApprovalActivity..::..TaskInstanceService Property
ApprovalActivity Class See Also Send Feedback
Gets or sets the workflow task instance service object

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTaskInstanceService TaskInstanceService { get; set; }
Visual Basic
Public Property TaskInstanceService As WorkflowTaskInstanceService
    Get
    Set
Visual C++
public:
virtual property WorkflowTaskInstanceService^ TaskInstanceService {
    WorkflowTaskInstanceService^ get () sealed;
    void set (WorkflowTaskInstanceService^ value) sealed;
}

Property Value

Type: WorkflowTaskInstanceService

Implements

IActivity..::..TaskInstanceService

See Also

ApprovalActivity Class
ApprovalActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivityDefinition Class

[image]

A Sandcastle Documented Class Library
ApprovalActivityDefinition Class
Members See Also Send Feedback
This Activity Definition is used for Approval Activity

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ApprovalActivityDefinition : DLLTaskActivityDefinition
Visual Basic
<SerializableAttribute>
Public Class ApprovalActivityDefinition
    Inherits DLLTaskActivityDefinition
Visual C++
[SerializableAttribute]
public ref class ApprovalActivityDefinition : public DLLTaskActivityDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DLLTaskActivityDefinition
CelloSaaS.WorkFlow.Activities..::..ApprovalActivityDefinition

See Also

ApprovalActivityDefinition Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
ApprovalActivityDefinition Members
ApprovalActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The ApprovalActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | ApprovalActivityDefinition | This constructor is used to set the DLL Task Activity Definition details

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

ApprovalActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
ApprovalActivityDefinition Constructor
ApprovalActivityDefinition Class See Also Send Feedback
This constructor is used to set the DLL Task Activity Definition details

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ApprovalActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ApprovalActivityDefinition()

See Also

ApprovalActivityDefinition Class
ApprovalActivityDefinition Members
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
ApprovalActivityDefinition Methods
ApprovalActivityDefinition Class See Also Send Feedback

The ApprovalActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ApprovalActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


ApprovalActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
ApprovalActivityDefinition Properties
ApprovalActivityDefinition Class See Also Send Feedback

The ApprovalActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

ApprovalActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity Class

[image]

A Sandcastle Documented Class Library
NotificationActivity Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class NotificationActivity : IActivity
Visual Basic
Public Class NotificationActivity
    Implements IActivity
Visual C++
public ref class NotificationActivity : IActivity

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Activities..::..NotificationActivity

See Also

NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity Members

[image] [image]

A Sandcastle Documented Class Library
NotificationActivity Members
NotificationActivity Class Constructors Methods Properties See Also Send Feedback

The NotificationActivity type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationActivity | Initializes a new instance of the NotificationActivity class

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExpired | Determines whether this instance has expired.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

NotificationActivity Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity Constructor

[image]

A Sandcastle Documented Class Library
NotificationActivity Constructor
NotificationActivity Class See Also Send Feedback
Initializes a new instance of the NotificationActivity class

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationActivity()
Visual Basic
Public Sub New
Visual C++
public:
NotificationActivity()

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationActivity Methods
NotificationActivity Class See Also Send Feedback

The NotificationActivity type exposes the following members.

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExpired | Determines whether this instance has expired.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationActivity Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.CanComplete Method

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..CanComplete Method
NotificationActivity Class See Also Send Feedback
Determines whether this instance can complete.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool CanComplete()
Visual Basic
Public Function CanComplete As Boolean
Visual C++
public:
virtual bool CanComplete() sealed

Return Value

Type: Boolean
true if this instance can complete; otherwise, false.

Implements

IActivity..::..CanComplete()()()()

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.CanStart Method

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..CanStart Method
NotificationActivity Class See Also Send Feedback
Determines whether this instance can start.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool CanStart()
Visual Basic
Public Function CanStart As Boolean
Visual C++
public:
virtual bool CanStart() sealed

Return Value

Type: Boolean
true if this instance can start; otherwise, false.

Implements

IActivity..::..CanStart()()()()

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.Complete Method

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..Complete Method
NotificationActivity Class See Also Send Feedback
Completes this instance.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Complete()
Visual Basic
Public Function Complete As List(Of String)
Visual C++
public:
virtual List<String^>^ Complete() sealed

Return Value

Type: List<(Of <(<'String>)>)>

Implements

IActivity..::..Complete()()()()

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.Execute Method

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..Execute Method
NotificationActivity Class See Also Send Feedback
Executes this instance.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Execute()
Visual Basic
Public Function Execute As List(Of String)
Visual C++
public:
virtual List<String^>^ Execute() sealed

Return Value

Type: List<(Of <(<'String>)>)>

Implements

IActivity..::..Execute()()()()

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.HasExpired Method

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..HasExpired Method
NotificationActivity Class See Also Send Feedback
Determines whether this instance has expired.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool HasExpired()
Visual Basic
Public Function HasExpired As Boolean
Visual C++
public:
virtual bool HasExpired() sealed

Return Value

Type: Boolean
true if this instance has expired; otherwise, false.

Implements

IActivity..::..HasExpired()()()()

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationActivity Properties
NotificationActivity Class See Also Send Feedback

The NotificationActivity type exposes the following members.

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

NotificationActivity Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.ActivityDefinition Property

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..ActivityDefinition Property
NotificationActivity Class See Also Send Feedback
Gets or sets the activity definition.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskActivityDefinition ActivityDefinition { get; set; }
Visual Basic
Public Property ActivityDefinition As ITaskActivityDefinition
    Get
    Set
Visual C++
public:
virtual property ITaskActivityDefinition^ ActivityDefinition {
    ITaskActivityDefinition^ get () sealed;
    void set (ITaskActivityDefinition^ value) sealed;
}

Property Value

Type: ITaskActivityDefinition
The activity definition.

Implements

IActivity..::..ActivityDefinition

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.Inputs Property

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..Inputs Property
NotificationActivity Class See Also Send Feedback
Gets or sets the inputs.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Object> Inputs { get; set; }
Visual Basic
Public Property Inputs As List(Of Object)
    Get
    Set
Visual C++
public:
virtual property List<Object^>^ Inputs {
    List<Object^>^ get () sealed;
    void set (List<Object^>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Object>)>)>
The inputs.

Implements

IActivity..::..Inputs

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivity.TaskInstanceService Property

[image]

A Sandcastle Documented Class Library
NotificationActivity..::..TaskInstanceService Property
NotificationActivity Class See Also Send Feedback
Gets or sets the workflow task instance service object

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTaskInstanceService TaskInstanceService { get; set; }
Visual Basic
Public Property TaskInstanceService As WorkflowTaskInstanceService
    Get
    Set
Visual C++
public:
virtual property WorkflowTaskInstanceService^ TaskInstanceService {
    WorkflowTaskInstanceService^ get () sealed;
    void set (WorkflowTaskInstanceService^ value) sealed;
}

Property Value

Type: WorkflowTaskInstanceService

Implements

IActivity..::..TaskInstanceService

See Also

NotificationActivity Class
NotificationActivity Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants Class

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants Class
Members See Also Send Feedback
This class contains the Notification Activity Property constants

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class NotificationActivityConstants
Visual Basic
Public NotInheritable Class NotificationActivityConstants
Visual C++
public ref class NotificationActivityConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Activities..::..NotificationActivityConstants

See Also

NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants Members

[image] [image]

A Sandcastle Documented Class Library
NotificationActivityConstants Members
NotificationActivityConstants Class Fields See Also Send Feedback

The NotificationActivityConstants type exposes the following members.

Fields

Name | Description
CcProperty |
CcStatic |
CcXpath |
HandleExceptionInNotificationActivity | The handle exception information notification activity
NotificationName |
Subject |
ToProperty |
ToStatic |
ToXpath |

See Also

NotificationActivityConstants Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants Fields

[image] [image]

A Sandcastle Documented Class Library
NotificationActivityConstants Fields
NotificationActivityConstants Class See Also Send Feedback

The NotificationActivityConstants type exposes the following members.

Fields

Name | Description
CcProperty |
CcStatic |
CcXpath |
HandleExceptionInNotificationActivity | The handle exception information notification activity
NotificationName |
Subject |
ToProperty |
ToStatic |
ToXpath |

See Also

NotificationActivityConstants Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.CcProperty Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..CcProperty Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CcProperty
Visual Basic
Public Const CcProperty As String
Visual C++
public:
literal String^ CcProperty

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.CcStatic Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..CcStatic Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CcStatic
Visual Basic
Public Const CcStatic As String
Visual C++
public:
literal String^ CcStatic

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.CcXpath Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..CcXpath Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string CcXpath
Visual Basic
Public Const CcXpath As String
Visual C++
public:
literal String^ CcXpath

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.HandleExceptionInNotificationActivity Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..HandleExceptionInNotificationActivity Field
NotificationActivityConstants Class See Also Send Feedback
The handle exception information notification activity

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string HandleExceptionInNotificationActivity
Visual Basic
Public Const HandleExceptionInNotificationActivity As String
Visual C++
public:
literal String^ HandleExceptionInNotificationActivity

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.NotificationName Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..NotificationName Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string NotificationName
Visual Basic
Public Const NotificationName As String
Visual C++
public:
literal String^ NotificationName

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.Subject Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..Subject Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Subject
Visual Basic
Public Const Subject As String
Visual C++
public:
literal String^ Subject

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.ToProperty Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..ToProperty Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ToProperty
Visual Basic
Public Const ToProperty As String
Visual C++
public:
literal String^ ToProperty

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.ToStatic Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..ToStatic Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ToStatic
Visual Basic
Public Const ToStatic As String
Visual C++
public:
literal String^ ToStatic

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityConstants.ToXpath Field

[image]

A Sandcastle Documented Class Library
NotificationActivityConstants..::..ToXpath Field
NotificationActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ToXpath
Visual Basic
Public Const ToXpath As String
Visual C++
public:
literal String^ ToXpath

Field Value

Type: String

See Also

NotificationActivityConstants Class
NotificationActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityDefinition Class

[image]

A Sandcastle Documented Class Library
NotificationActivityDefinition Class
Members See Also Send Feedback
This class is used to define the Sending Email Activity

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class NotificationActivityDefinition : DLLTaskActivityDefinition
Visual Basic
<SerializableAttribute>
Public Class NotificationActivityDefinition
    Inherits DLLTaskActivityDefinition
Visual C++
[SerializableAttribute]
public ref class NotificationActivityDefinition : public DLLTaskActivityDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DLLTaskActivityDefinition
CelloSaaS.WorkFlow.Activities..::..NotificationActivityDefinition

See Also

NotificationActivityDefinition Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
NotificationActivityDefinition Members
NotificationActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The NotificationActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationActivityDefinition | This constructor is used to set the DLL Task Activity Definition details

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

NotificationActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
NotificationActivityDefinition Constructor
NotificationActivityDefinition Class See Also Send Feedback
This constructor is used to set the DLL Task Activity Definition details

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public NotificationActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
NotificationActivityDefinition()

See Also

NotificationActivityDefinition Class
NotificationActivityDefinition Members
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
NotificationActivityDefinition Methods
NotificationActivityDefinition Class See Also Send Feedback

The NotificationActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NotificationActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


NotificationActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
NotificationActivityDefinition Properties
NotificationActivityDefinition Class See Also Send Feedback

The NotificationActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

NotificationActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity Class

[image]

A Sandcastle Documented Class Library
ServiceCallActivity Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ServiceCallActivity : IActivity
Visual Basic
Public Class ServiceCallActivity
    Implements IActivity
Visual C++
public ref class ServiceCallActivity : IActivity

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Activities..::..ServiceCallActivity

See Also

ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity Members

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivity Members
ServiceCallActivity Class Constructors Methods Properties See Also Send Feedback

The ServiceCallActivity type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceCallActivity | Initializes a new instance of the ServiceCallActivity class

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExpired | Determines whether this instance has expired.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

ServiceCallActivity Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity Constructor

[image]

A Sandcastle Documented Class Library
ServiceCallActivity Constructor
ServiceCallActivity Class See Also Send Feedback
Initializes a new instance of the ServiceCallActivity class

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ServiceCallActivity()
Visual Basic
Public Sub New
Visual C++
public:
ServiceCallActivity()

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity Methods

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivity Methods
ServiceCallActivity Class See Also Send Feedback

The ServiceCallActivity type exposes the following members.

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasExpired | Determines whether this instance has expired.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceCallActivity Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.CanComplete Method

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..CanComplete Method
ServiceCallActivity Class See Also Send Feedback
Determines whether this instance can complete.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool CanComplete()
Visual Basic
Public Function CanComplete As Boolean
Visual C++
public:
virtual bool CanComplete() sealed

Return Value

Type: Boolean
true if this instance can complete; otherwise, false.

Implements

IActivity..::..CanComplete()()()()

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.CanStart Method

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..CanStart Method
ServiceCallActivity Class See Also Send Feedback
Determines whether this instance can start.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool CanStart()
Visual Basic
Public Function CanStart As Boolean
Visual C++
public:
virtual bool CanStart() sealed

Return Value

Type: Boolean
true if this instance can start; otherwise, false.

Implements

IActivity..::..CanStart()()()()

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.Complete Method

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..Complete Method
ServiceCallActivity Class See Also Send Feedback
Completes this instance.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Complete()
Visual Basic
Public Function Complete As List(Of String)
Visual C++
public:
virtual List<String^>^ Complete() sealed

Return Value

Type: List<(Of <(<'String>)>)>

Implements

IActivity..::..Complete()()()()

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.Execute Method

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..Execute Method
ServiceCallActivity Class See Also Send Feedback
Executes this instance.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Execute()
Visual Basic
Public Function Execute As List(Of String)
Visual C++
public:
virtual List<String^>^ Execute() sealed

Return Value

Type: List<(Of <(<'String>)>)>

Implements

IActivity..::..Execute()()()()

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.HasExpired Method

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..HasExpired Method
ServiceCallActivity Class See Also Send Feedback
Determines whether this instance has expired.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool HasExpired()
Visual Basic
Public Function HasExpired As Boolean
Visual C++
public:
virtual bool HasExpired() sealed

Return Value

Type: Boolean
true if this instance has expired; otherwise, false.

Implements

IActivity..::..HasExpired()()()()

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity Properties

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivity Properties
ServiceCallActivity Class See Also Send Feedback

The ServiceCallActivity type exposes the following members.

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

ServiceCallActivity Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.ActivityDefinition Property

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..ActivityDefinition Property
ServiceCallActivity Class See Also Send Feedback
Gets or sets the activity definition.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskActivityDefinition ActivityDefinition { get; set; }
Visual Basic
Public Property ActivityDefinition As ITaskActivityDefinition
    Get
    Set
Visual C++
public:
virtual property ITaskActivityDefinition^ ActivityDefinition {
    ITaskActivityDefinition^ get () sealed;
    void set (ITaskActivityDefinition^ value) sealed;
}

Property Value

Type: ITaskActivityDefinition
The activity definition.

Implements

IActivity..::..ActivityDefinition

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.Inputs Property

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..Inputs Property
ServiceCallActivity Class See Also Send Feedback
Gets or sets the inputs.

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Object> Inputs { get; set; }
Visual Basic
Public Property Inputs As List(Of Object)
    Get
    Set
Visual C++
public:
virtual property List<Object^>^ Inputs {
    List<Object^>^ get () sealed;
    void set (List<Object^>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Object>)>)>
The inputs.

Implements

IActivity..::..Inputs

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivity.TaskInstanceService Property

[image]

A Sandcastle Documented Class Library
ServiceCallActivity..::..TaskInstanceService Property
ServiceCallActivity Class See Also Send Feedback
Gets or sets the workflow task instance service object

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTaskInstanceService TaskInstanceService { get; set; }
Visual Basic
Public Property TaskInstanceService As WorkflowTaskInstanceService
    Get
    Set
Visual C++
public:
virtual property WorkflowTaskInstanceService^ TaskInstanceService {
    WorkflowTaskInstanceService^ get () sealed;
    void set (WorkflowTaskInstanceService^ value) sealed;
}

Property Value

Type: WorkflowTaskInstanceService

Implements

IActivity..::..TaskInstanceService

See Also

ServiceCallActivity Class
ServiceCallActivity Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityConstants Class

[image]

A Sandcastle Documented Class Library
ServiceCallActivityConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class ServiceCallActivityConstants
Visual Basic
Public NotInheritable Class ServiceCallActivityConstants
Visual C++
public ref class ServiceCallActivityConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Activities..::..ServiceCallActivityConstants

See Also

ServiceCallActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityConstants Members

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivityConstants Members
ServiceCallActivityConstants Class Fields See Also Send Feedback

The ServiceCallActivityConstants type exposes the following members.

Fields

Name | Description
ServiceInputTransform |
ServiceName |
WFInputTransform |

See Also

ServiceCallActivityConstants Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityConstants Fields

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivityConstants Fields
ServiceCallActivityConstants Class See Also Send Feedback

The ServiceCallActivityConstants type exposes the following members.

Fields

Name | Description
ServiceInputTransform |
ServiceName |
WFInputTransform |

See Also

ServiceCallActivityConstants Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityConstants.ServiceInputTransform Field

[image]

A Sandcastle Documented Class Library
ServiceCallActivityConstants..::..ServiceInputTransform Field
ServiceCallActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ServiceInputTransform
Visual Basic
Public Const ServiceInputTransform As String
Visual C++
public:
literal String^ ServiceInputTransform

Field Value

Type: String

See Also

ServiceCallActivityConstants Class
ServiceCallActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityConstants.ServiceName Field

[image]

A Sandcastle Documented Class Library
ServiceCallActivityConstants..::..ServiceName Field
ServiceCallActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ServiceName
Visual Basic
Public Const ServiceName As String
Visual C++
public:
literal String^ ServiceName

Field Value

Type: String

See Also

ServiceCallActivityConstants Class
ServiceCallActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityConstants.WFInputTransform Field

[image]

A Sandcastle Documented Class Library
ServiceCallActivityConstants..::..WFInputTransform Field
ServiceCallActivityConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WFInputTransform
Visual Basic
Public Const WFInputTransform As String
Visual C++
public:
literal String^ WFInputTransform

Field Value

Type: String

See Also

ServiceCallActivityConstants Class
ServiceCallActivityConstants Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityDefinition Class

[image]

A Sandcastle Documented Class Library
ServiceCallActivityDefinition Class
Members See Also Send Feedback
This class is used to define the service call Activity

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ServiceCallActivityDefinition : DLLTaskActivityDefinition
Visual Basic
<SerializableAttribute>
Public Class ServiceCallActivityDefinition
    Inherits DLLTaskActivityDefinition
Visual C++
[SerializableAttribute]
public ref class ServiceCallActivityDefinition : public DLLTaskActivityDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DLLTaskActivityDefinition
CelloSaaS.WorkFlow.Activities..::..ServiceCallActivityDefinition

See Also

ServiceCallActivityDefinition Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivityDefinition Members
ServiceCallActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The ServiceCallActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceCallActivityDefinition | This constructor is used to set the DLL Task Activity Definition details

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

ServiceCallActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
ServiceCallActivityDefinition Constructor
ServiceCallActivityDefinition Class See Also Send Feedback
This constructor is used to set the DLL Task Activity Definition details

Namespace: CelloSaaS.WorkFlow.Activities
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ServiceCallActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ServiceCallActivityDefinition()

See Also

ServiceCallActivityDefinition Class
ServiceCallActivityDefinition Members
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivityDefinition Methods
ServiceCallActivityDefinition Class See Also Send Feedback

The ServiceCallActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServiceCallActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


ServiceCallActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
ServiceCallActivityDefinition Properties
ServiceCallActivityDefinition Class See Also Send Feedback

The ServiceCallActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

ServiceCallActivityDefinition Class
CelloSaaS.WorkFlow.Activities Namespace


CelloSaaS.WorkFlow.Model Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.WorkFlow.Model Namespace
Send Feedback

Classes

 | Class | Description
Public class | ActivityDetails | Contains activity model details
Public class | ActivityProperty | This class used to store
Public class | AutoTaskDefinition | This is task is executed automatically i.e without waiting for an user action to trigger this task
Public class | AutoWorkflowTaskInstance |
Public class | BusinessRuleExpressionCondition |
Public class | CloseTaskActivityDefinition |
Public class | CloseTaskDefinition | This is the end task definition of any workflow
Public class | CodeExpressionCondition |
Public class | DefaultWorkflowAttributeMapper |
Public class | DLLTaskActivityDefinition |
Public class | DynamicTaskActorDefinition | Dynamic actor for manual task. reterived from sp
Public class | ExecutionStatusChange |
Public class | IfElseRoutingContion |
Public class | IfElseWorkflowTaskRouter | This class contains the IF Else workflow router definition.
Public class | InputMapping | InputMapping
Public class | ManualTaskDefinition | This task is trigger by an user action. Does not automatically executed. Only the actors defined can executed this task
Public class | ManualWorkflowTaskInstance |
Public class | MappedObjectKeyValue |
Public class | RoleBasedTaskActorDefinition | Role based manual task actor definition details
Public class | RouterViewModel |
Public class | RoutingConditions |
Public class | RoutingConditionService |
Public class | RoutingConditionService..::..ExecutionStatus |
Public class | RoutingConditionService..::..Outcome |
Public class | RoutingTable |
Public class | SPDefinition |
Public class | SpInputMapping |
Public class | SPTaskActivityDefinition |
Public class | SPTaskCondition |
Public class | StartTaskActivityDefinition |
Public class | StartTaskDefinition | This is the start task of any workflow
Public class | TaskActor |
Public class | TaskActorDefViewModel |
Public class | TaskConditionDefinition |
Public class | TaskConditionsViewModel |
Public class | TaskDefinition | Defines the tasks properties such as task name, task code, conditions, activity definitions
Public class | TaskDefViewModel |
Public class | TaskExpressionCondition |
Public class | TaskRouterDefinition |
Public class | TrueOrFalseTaskExpressConditions |
Public class | TypeInvocationDefinition | TypeInvocationDefinition
Public class | WFRequestModel |
Public class | WfSearchParameter |
Public class | WFState |
Public class | WFTrack |
Public class | WFTrackAudit |
Public class | WFTrackAuditSearchParameter |
Public class | WFUIModel |
Public class | WFUIModelDictionary |
Public class | WFXmlInput |
Public class | Workflow |
Public class | WorkflowAttributeMapper |
Public class | WorkflowDefinition | Workflow definitions
Public class | WorkflowInput |
Public class | WorkflowInputAttributeMapper |
Public class | WorkflowInstance |
Public class | WorkflowInstanceStatus |
Public class | WorkflowModel |
Public class | WorkflowTask |
Public class | WorkflowTaskInstance |
Public class | WorkflowTaskRouter |

Interfaces

 | Interface | Description
Public interface | IActivity |
Public interface | IRoutingCondition |
Public interface | ITaskActivityDefinition |
Public interface | ITaskActor |
Public interface | ITaskActorDefinition | Manual Task actor's definition details
Public interface | ITaskCondition |
Public interface | ITaskConditionDefinition |
Public interface | ITaskExpressionConditions |
Public interface | IWFXMLSerializable |
Public interface | IWorkflowElement |
Public interface | IWorkflowInput |
Public interface | IWorkFlowInputFinder |
Public interface | IWorkflowItemDefinition |

Enumerations

 | Enumeration | Description
Public enumeration | ActivityType |
Public enumeration | ExecuteType |
Public enumeration | RouterType |
Public enumeration | SourceType | Source Type of the Property Value
Public enumeration | WFRecordStatus |
Public enumeration | WFTaskType | Types of workflow task
Public enumeration | WFTrackingStatus |
Public enumeration | WorkflowDefinitionStatus | Status of the workflow defined


ActivityDetails Class

[image]

A Sandcastle Documented Class Library
ActivityDetails Class
Members See Also Send Feedback
Contains activity model details

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ActivityDetails
Visual Basic
<SerializableAttribute>
Public Class ActivityDetails
Visual C++
[SerializableAttribute]
public ref class ActivityDetails

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..ActivityDetails

See Also

ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails Members

[image] [image]

A Sandcastle Documented Class Library
ActivityDetails Members
ActivityDetails Class Constructors Methods Properties See Also Send Feedback

The ActivityDetails type exposes the following members.

Constructors

 | Name | Description
Public method | ActivityDetails | Initializes a new instance of the ActivityDetails class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetKeyValues |
Public method | SetOutcomes | Sets the out comes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityDefinition | Gets the activity definition instances.
Public property | ActivityType | Gets or sets the type.
Public property | AssemblyName | Gets or sets the name of the activity definiton assembly.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the id.
Public property | KeyValues | Gets or sets the key values.
Public property | Name | Gets or sets the name.
Public property | Outcomes | Gets or sets the outcomes.
Public property | Status | Gets or sets a value indicating whether this ActivityDetails is status.
Public property | TenantId | Gets or sets the tenant id.
Public property | TypeName | Gets or sets the name of the activity definiton type.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | WorkflowId | Gets or sets the workflow id. this activity belongs to

See Also

ActivityDetails Class
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails Constructor

[image]

A Sandcastle Documented Class Library
ActivityDetails Constructor
ActivityDetails Class See Also Send Feedback
Initializes a new instance of the ActivityDetails class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ActivityDetails()
Visual Basic
Public Sub New
Visual C++
public:
ActivityDetails()

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails Methods

[image] [image]

A Sandcastle Documented Class Library
ActivityDetails Methods
ActivityDetails Class See Also Send Feedback

The ActivityDetails type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetKeyValues |
Public method | SetOutcomes | Sets the out comes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ActivityDetails Class
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.SetKeyValues Method

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..SetKeyValues Method
ActivityDetails Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void SetKeyValues(
    string[] keyValues
)
Visual Basic
Public Sub SetKeyValues (
    keyValues As String()
)
Visual C++
public:
void SetKeyValues(
    array<String^>^ keyValues
)

Parameters

keyValues
Type: array<System..::..String>[]()[][]

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.SetOutcomes Method

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..SetOutcomes Method
ActivityDetails Class See Also Send Feedback
Sets the out comes.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void SetOutcomes(
    string[] outcomes
)
Visual Basic
Public Sub SetOutcomes (
    outcomes As String()
)
Visual C++
public:
void SetOutcomes(
    array<String^>^ outcomes
)

Parameters

outcomes
Type: array<System..::..String>[]()[][]
The outcomes.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails Properties

[image] [image]

A Sandcastle Documented Class Library
ActivityDetails Properties
ActivityDetails Class See Also Send Feedback

The ActivityDetails type exposes the following members.

Properties

 | Name | Description
Public property | ActivityDefinition | Gets the activity definition instances.
Public property | ActivityType | Gets or sets the type.
Public property | AssemblyName | Gets or sets the name of the activity definiton assembly.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the id.
Public property | KeyValues | Gets or sets the key values.
Public property | Name | Gets or sets the name.
Public property | Outcomes | Gets or sets the outcomes.
Public property | Status | Gets or sets a value indicating whether this ActivityDetails is status.
Public property | TenantId | Gets or sets the tenant id.
Public property | TypeName | Gets or sets the name of the activity definiton type.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | WorkflowId | Gets or sets the workflow id. this activity belongs to

See Also

ActivityDetails Class
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.ActivityDefinition Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..ActivityDefinition Property
ActivityDetails Class See Also Send Feedback
Gets the activity definition instances.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskActivityDefinition ActivityDefinition { get; }
Visual Basic
Public ReadOnly Property ActivityDefinition As ITaskActivityDefinition
    Get
Visual C++
public:
property ITaskActivityDefinition^ ActivityDefinition {
    ITaskActivityDefinition^ get ();
}

Property Value

Type: ITaskActivityDefinition
The activity definition.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.ActivityType Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..ActivityType Property
ActivityDetails Class See Also Send Feedback
Gets or sets the type.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ActivityType ActivityType { get; set; }
Visual Basic
Public Property ActivityType As ActivityType
    Get
    Set
Visual C++
public:
property ActivityType ActivityType {
    ActivityType get ();
    void set (ActivityType value);
}

Property Value

Type: ActivityType
The type.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.AssemblyName Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..AssemblyName Property
ActivityDetails Class See Also Send Feedback
Gets or sets the name of the activity definiton assembly.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the activity definiton assembly.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.CreatedBy Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..CreatedBy Property
ActivityDetails Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.CreatedOn Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..CreatedOn Property
ActivityDetails Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.Description Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..Description Property
ActivityDetails Class See Also Send Feedback
Gets or sets the description.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.Id Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..Id Property
ActivityDetails Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The id.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.KeyValues Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..KeyValues Property
ActivityDetails Class See Also Send Feedback
Gets or sets the key values.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] KeyValues { get; private set; }
Visual Basic
Public Property KeyValues As String()
    Get
    Private Set
Visual C++
public:
property array<String^>^ KeyValues {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The key values.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.Name Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..Name Property
ActivityDetails Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.Outcomes Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..Outcomes Property
ActivityDetails Class See Also Send Feedback
Gets or sets the outcomes.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] Outcomes { get; private set; }
Visual Basic
Public Property Outcomes As String()
    Get
    Private Set
Visual C++
public:
property array<String^>^ Outcomes {
    array<String^>^ get ();
    private: void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]
The outcomes.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.Status Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..Status Property
ActivityDetails Class See Also Send Feedback
Gets or sets a value indicating whether this ActivityDetails is status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if status; otherwise, false.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.TenantId Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..TenantId Property
ActivityDetails Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.TypeName Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..TypeName Property
ActivityDetails Class See Also Send Feedback
Gets or sets the name of the activity definiton type.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the activity definiton type.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..UpdatedBy Property
ActivityDetails Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..UpdatedOn Property
ActivityDetails Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityDetails.WorkflowId Property

[image]

A Sandcastle Documented Class Library
ActivityDetails..::..WorkflowId Property
ActivityDetails Class See Also Send Feedback
Gets or sets the workflow id. this activity belongs to

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WorkflowId { get; set; }
Visual Basic
Public Property WorkflowId As Guid
    Get
    Set
Visual C++
public:
property Guid WorkflowId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The workflow id.

See Also

ActivityDetails Class
ActivityDetails Members
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty Class

[image]

A Sandcastle Documented Class Library
ActivityProperty Class
Members See Also Send Feedback
This class used to store

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ActivityProperty
Visual Basic
<SerializableAttribute>
Public Class ActivityProperty
Visual C++
[SerializableAttribute]
public ref class ActivityProperty

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..ActivityProperty

See Also

ActivityProperty Members
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty Members

[image] [image]

A Sandcastle Documented Class Library
ActivityProperty Members
ActivityProperty Class Constructors Methods Properties See Also Send Feedback

The ActivityProperty type exposes the following members.

Constructors

 | Name | Description
Public method | ActivityProperty | Initializes a new instance of the ActivityProperty class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataType | Gets or sets the type of the data.
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.

See Also

ActivityProperty Class
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty Constructor

[image]

A Sandcastle Documented Class Library
ActivityProperty Constructor
ActivityProperty Class See Also Send Feedback
Initializes a new instance of the ActivityProperty class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ActivityProperty()
Visual Basic
Public Sub New
Visual C++
public:
ActivityProperty()

See Also

ActivityProperty Class
ActivityProperty Members
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty Methods

[image] [image]

A Sandcastle Documented Class Library
ActivityProperty Methods
ActivityProperty Class See Also Send Feedback

The ActivityProperty type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ActivityProperty Class
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty Properties

[image] [image]

A Sandcastle Documented Class Library
ActivityProperty Properties
ActivityProperty Class See Also Send Feedback

The ActivityProperty type exposes the following members.

Properties

 | Name | Description
Public property | DataType | Gets or sets the type of the data.
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.

See Also

ActivityProperty Class
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty.DataType Property

[image]

A Sandcastle Documented Class Library
ActivityProperty..::..DataType Property
ActivityProperty Class See Also Send Feedback
Gets or sets the type of the data.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DataType { get; set; }
Visual Basic
Public Property DataType As String
    Get
    Set
Visual C++
public:
property String^ DataType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The type of the data.

See Also

ActivityProperty Class
ActivityProperty Members
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty.Name Property

[image]

A Sandcastle Documented Class Library
ActivityProperty..::..Name Property
ActivityProperty Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

ActivityProperty Class
ActivityProperty Members
CelloSaaS.WorkFlow.Model Namespace


ActivityProperty.Value Property

[image]

A Sandcastle Documented Class Library
ActivityProperty..::..Value Property
ActivityProperty Class See Also Send Feedback
Gets or sets the value.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The value.

See Also

ActivityProperty Class
ActivityProperty Members
CelloSaaS.WorkFlow.Model Namespace


ActivityType Enumeration

[image]

A Sandcastle Documented Class Library
ActivityType Enumeration
See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum ActivityType
Visual Basic
Public Enumeration ActivityType
Visual C++
public enum class ActivityType

Members

Member name | Value | Description
StoredProcedure | 0 |
Dll | 1 |

See Also

CelloSaaS.WorkFlow.Model Namespace


AutoTaskDefinition Class

[image]

A Sandcastle Documented Class Library
AutoTaskDefinition Class
Members See Also Send Feedback
This is task is executed automatically i.e without waiting for an user action to trigger this task

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AutoTaskDefinition : TaskDefinition
Visual Basic
<SerializableAttribute>
Public Class AutoTaskDefinition
    Inherits TaskDefinition
Visual C++
[SerializableAttribute]
public ref class AutoTaskDefinition : public TaskDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskDefinition
CelloSaaS.WorkFlow.Model..::..AutoTaskDefinition

See Also

AutoTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


AutoTaskDefinition Members

[image] [image]

A Sandcastle Documented Class Library
AutoTaskDefinition Members
AutoTaskDefinition Class Constructors Methods Properties See Also Send Feedback

The AutoTaskDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | AutoTaskDefinition | Initializes a new instance of the AutoTaskDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from TaskDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from TaskDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

AutoTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


AutoTaskDefinition Constructor

[image]

A Sandcastle Documented Class Library
AutoTaskDefinition Constructor
AutoTaskDefinition Class See Also Send Feedback
Initializes a new instance of the AutoTaskDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AutoTaskDefinition()
Visual Basic
Public Sub New
Visual C++
public:
AutoTaskDefinition()

See Also

AutoTaskDefinition Class
AutoTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


AutoTaskDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
AutoTaskDefinition Methods
AutoTaskDefinition Class See Also Send Feedback

The AutoTaskDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from TaskDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from TaskDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AutoTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


AutoTaskDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
AutoTaskDefinition Properties
AutoTaskDefinition Class See Also Send Feedback

The AutoTaskDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

AutoTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


AutoWorkflowTaskInstance Class

[image]

A Sandcastle Documented Class Library
AutoWorkflowTaskInstance Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class AutoWorkflowTaskInstance : WorkflowTaskInstance
Visual Basic
<SerializableAttribute>
Public Class AutoWorkflowTaskInstance
    Inherits WorkflowTaskInstance
Visual C++
[SerializableAttribute]
public ref class AutoWorkflowTaskInstance : public WorkflowTaskInstance

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowTaskInstance
CelloSaaS.WorkFlow.Model..::..AutoWorkflowTaskInstance

See Also

AutoWorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


AutoWorkflowTaskInstance Members

[image] [image]

A Sandcastle Documented Class Library
AutoWorkflowTaskInstance Members
AutoWorkflowTaskInstance Class Constructors Methods Properties See Also Send Feedback

The AutoWorkflowTaskInstance type exposes the following members.

Constructors

 | Name | Description
Public method | AutoWorkflowTaskInstance | Initializes a new instance of the AutoWorkflowTaskInstance class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id. (Inherited from WorkflowTaskInstance.)
Public property | AffectedExecutionStatus | Gets or sets the affected execution status. (Inherited from WorkflowTaskInstance.)
Public property | AffectedOutComes | Gets or sets the affected out comes. (Inherited from WorkflowTaskInstance.)
Public property | CurrentExecutionStatus | Gets or sets the current execution status. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeCompleted | Gets or sets the date time completed. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeExpired | Gets or sets the date time expired. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeUpdated | Gets or sets the date time updated. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionOrder | Gets or sets the execution order. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionStatus | Gets or sets the execution status. (Inherited from WorkflowTaskInstance.)
Public property | Id | Gets or sets the id. (Inherited from WorkflowTaskInstance.)
Public property | InvokedTaskDefinitionRouterId | Gets or sets the invoked task definition router id. (Inherited from WorkflowTaskInstance.)
Public property | MapId | Gets or sets the map id. (Inherited from WorkflowTaskInstance.)
Public property | OutComes | Gets or sets the out comes. (Inherited from WorkflowTaskInstance.)
Public property | PreviousExecutionStatus | Gets or sets the previous execution status. (Inherited from WorkflowTaskInstance.)
Public property | StartTime | Gets or sets the start time. (Inherited from WorkflowTaskInstance.)
Public property | Task | Gets or sets the task. (Inherited from WorkflowTaskInstance.)
Public property | TaskDefinition | Gets the task definition. (Inherited from WorkflowTaskInstance.)
Public property | WFId | Gets or sets the WF id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowInstanceId | Gets or sets the work flow instance id. (Inherited from WorkflowTaskInstance.)

See Also

AutoWorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


AutoWorkflowTaskInstance Constructor

[image]

A Sandcastle Documented Class Library
AutoWorkflowTaskInstance Constructor
AutoWorkflowTaskInstance Class See Also Send Feedback
Initializes a new instance of the AutoWorkflowTaskInstance class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public AutoWorkflowTaskInstance(
    Guid taskInstanceId,
    int executionOrder
)
Visual Basic
Public Sub New (
    taskInstanceId As Guid,
    executionOrder As Integer
)
Visual C++
public:
AutoWorkflowTaskInstance(
    Guid taskInstanceId,
    int executionOrder
)

Parameters

taskInstanceId
Type: System..::..Guid
The task instance id.
executionOrder
Type: System..::..Int32
The execution order.

See Also

AutoWorkflowTaskInstance Class
AutoWorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


AutoWorkflowTaskInstance Methods

[image] [image]

A Sandcastle Documented Class Library
AutoWorkflowTaskInstance Methods
AutoWorkflowTaskInstance Class See Also Send Feedback

The AutoWorkflowTaskInstance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AutoWorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


AutoWorkflowTaskInstance Properties

[image] [image]

A Sandcastle Documented Class Library
AutoWorkflowTaskInstance Properties
AutoWorkflowTaskInstance Class See Also Send Feedback

The AutoWorkflowTaskInstance type exposes the following members.

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id. (Inherited from WorkflowTaskInstance.)
Public property | AffectedExecutionStatus | Gets or sets the affected execution status. (Inherited from WorkflowTaskInstance.)
Public property | AffectedOutComes | Gets or sets the affected out comes. (Inherited from WorkflowTaskInstance.)
Public property | CurrentExecutionStatus | Gets or sets the current execution status. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeCompleted | Gets or sets the date time completed. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeExpired | Gets or sets the date time expired. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeUpdated | Gets or sets the date time updated. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionOrder | Gets or sets the execution order. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionStatus | Gets or sets the execution status. (Inherited from WorkflowTaskInstance.)
Public property | Id | Gets or sets the id. (Inherited from WorkflowTaskInstance.)
Public property | InvokedTaskDefinitionRouterId | Gets or sets the invoked task definition router id. (Inherited from WorkflowTaskInstance.)
Public property | MapId | Gets or sets the map id. (Inherited from WorkflowTaskInstance.)
Public property | OutComes | Gets or sets the out comes. (Inherited from WorkflowTaskInstance.)
Public property | PreviousExecutionStatus | Gets or sets the previous execution status. (Inherited from WorkflowTaskInstance.)
Public property | StartTime | Gets or sets the start time. (Inherited from WorkflowTaskInstance.)
Public property | Task | Gets or sets the task. (Inherited from WorkflowTaskInstance.)
Public property | TaskDefinition | Gets the task definition. (Inherited from WorkflowTaskInstance.)
Public property | WFId | Gets or sets the WF id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowInstanceId | Gets or sets the work flow instance id. (Inherited from WorkflowTaskInstance.)

See Also

AutoWorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Class

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class BusinessRuleExpressionCondition : ITaskCondition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class BusinessRuleExpressionCondition
    Implements ITaskCondition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class BusinessRuleExpressionCondition : ITaskCondition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..BusinessRuleExpressionCondition

See Also

BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Members

[image] [image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Members
BusinessRuleExpressionCondition Class Constructors Methods Properties See Also Send Feedback

The BusinessRuleExpressionCondition type exposes the following members.

Constructors

 | Name | Description
Public method | BusinessRuleExpressionCondition()()()() | Initializes a new instance of the BusinessRuleExpressionCondition class.
Public method | BusinessRuleExpressionCondition(String) | Initializes a new instance of the BusinessRuleExpressionCondition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize Business Rule conditions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes Business Rule conditions
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

BusinessRuleExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Constructor

[image] [image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Constructor
BusinessRuleExpressionCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BusinessRuleExpressionCondition()()()() | Initializes a new instance of the BusinessRuleExpressionCondition class.
Public method | BusinessRuleExpressionCondition(String) | Initializes a new instance of the BusinessRuleExpressionCondition class.

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Constructor

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Constructor
BusinessRuleExpressionCondition Class See Also Send Feedback
Initializes a new instance of the BusinessRuleExpressionCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BusinessRuleExpressionCondition()
Visual Basic
Public Sub New
Visual C++
public:
BusinessRuleExpressionCondition()

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
BusinessRuleExpressionCondition Overload
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Constructor (String)

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Constructor (String)
BusinessRuleExpressionCondition Class See Also Send Feedback
Initializes a new instance of the BusinessRuleExpressionCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public BusinessRuleExpressionCondition(
    string expression
)
Visual Basic
Public Sub New (
    expression As String
)
Visual C++
public:
BusinessRuleExpressionCondition(
    String^ expression
)

Parameters

expression
Type: System..::..String
The expression.

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
BusinessRuleExpressionCondition Overload
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Methods

[image] [image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Methods
BusinessRuleExpressionCondition Class See Also Send Feedback

The BusinessRuleExpressionCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize Business Rule conditions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes Business Rule conditions
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

BusinessRuleExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition..::..DeSerailizeFromXML Method
BusinessRuleExpressionCondition Class See Also Send Feedback
De-serailize Business Rule conditions

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String
The XML.

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition.Evaluate Method

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition..::..Evaluate Method
BusinessRuleExpressionCondition Class See Also Send Feedback
Evaluates the specified work flow instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Evaluate(
    WorkflowInstance workFlowInstance
)
Visual Basic
Public Function Evaluate (
    workFlowInstance As WorkflowInstance
) As Boolean
Visual C++
public:
virtual bool Evaluate(
    WorkflowInstance^ workFlowInstance
) sealed

Parameters

workFlowInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The work flow instance.

Return Value

Type: Boolean

Implements

ITaskCondition..::..Evaluate(WorkflowInstance)

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition..::..SerailizeToXML Method
BusinessRuleExpressionCondition Class See Also Send Feedback
Serailizes Business Rule conditions

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition.ToString Method

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition..::..ToString Method
BusinessRuleExpressionCondition Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents this instance.

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition Properties

[image] [image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition Properties
BusinessRuleExpressionCondition Class See Also Send Feedback

The BusinessRuleExpressionCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

BusinessRuleExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


BusinessRuleExpressionCondition.ConditionExpression Property

[image]

A Sandcastle Documented Class Library
BusinessRuleExpressionCondition..::..ConditionExpression Property
BusinessRuleExpressionCondition Class See Also Send Feedback
Gets or sets the condition expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConditionExpression { get; set; }
Visual Basic
Public Property ConditionExpression As String
    Get
    Set
Visual C++
public:
virtual property String^ ConditionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The condition expression.

Implements

ITaskCondition..::..ConditionExpression

See Also

BusinessRuleExpressionCondition Class
BusinessRuleExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CloseTaskActivityDefinition Class

[image]

A Sandcastle Documented Class Library
CloseTaskActivityDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CloseTaskActivityDefinition : DLLTaskActivityDefinition
Visual Basic
<SerializableAttribute>
Public Class CloseTaskActivityDefinition
    Inherits DLLTaskActivityDefinition
Visual C++
[SerializableAttribute]
public ref class CloseTaskActivityDefinition : public DLLTaskActivityDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DLLTaskActivityDefinition
CelloSaaS.WorkFlow.Model..::..CloseTaskActivityDefinition

See Also

CloseTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


CloseTaskActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
CloseTaskActivityDefinition Members
CloseTaskActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The CloseTaskActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | CloseTaskActivityDefinition | Initializes a new instance of the CloseTaskActivityDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

CloseTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


CloseTaskActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
CloseTaskActivityDefinition Constructor
CloseTaskActivityDefinition Class See Also Send Feedback
Initializes a new instance of the CloseTaskActivityDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CloseTaskActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
CloseTaskActivityDefinition()

See Also

CloseTaskActivityDefinition Class
CloseTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


CloseTaskActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
CloseTaskActivityDefinition Methods
CloseTaskActivityDefinition Class See Also Send Feedback

The CloseTaskActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CloseTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


CloseTaskActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
CloseTaskActivityDefinition Properties
CloseTaskActivityDefinition Class See Also Send Feedback

The CloseTaskActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

CloseTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


CloseTaskDefinition Class

[image]

A Sandcastle Documented Class Library
CloseTaskDefinition Class
Members See Also Send Feedback
This is the end task definition of any workflow

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CloseTaskDefinition : TaskDefinition
Visual Basic
<SerializableAttribute>
Public Class CloseTaskDefinition
    Inherits TaskDefinition
Visual C++
[SerializableAttribute]
public ref class CloseTaskDefinition : public TaskDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskDefinition
CelloSaaS.WorkFlow.Model..::..CloseTaskDefinition

See Also

CloseTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


CloseTaskDefinition Members

[image] [image]

A Sandcastle Documented Class Library
CloseTaskDefinition Members
CloseTaskDefinition Class Constructors Methods Properties See Also Send Feedback

The CloseTaskDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | CloseTaskDefinition | Initializes a new instance of the CloseTaskDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from TaskDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from TaskDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

CloseTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


CloseTaskDefinition Constructor

[image]

A Sandcastle Documented Class Library
CloseTaskDefinition Constructor
CloseTaskDefinition Class See Also Send Feedback
Initializes a new instance of the CloseTaskDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CloseTaskDefinition()
Visual Basic
Public Sub New
Visual C++
public:
CloseTaskDefinition()

See Also

CloseTaskDefinition Class
CloseTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


CloseTaskDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
CloseTaskDefinition Methods
CloseTaskDefinition Class See Also Send Feedback

The CloseTaskDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from TaskDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from TaskDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CloseTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


CloseTaskDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
CloseTaskDefinition Properties
CloseTaskDefinition Class See Also Send Feedback

The CloseTaskDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

CloseTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Class

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class CodeExpressionCondition : ITaskExpressionConditions,
    ITaskCondition, IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class CodeExpressionCondition
    Implements ITaskExpressionConditions, ITaskCondition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class CodeExpressionCondition : ITaskExpressionConditions,
    ITaskCondition, IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..CodeExpressionCondition

See Also

CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Members

[image] [image]

A Sandcastle Documented Class Library
CodeExpressionCondition Members
CodeExpressionCondition Class Constructors Methods Properties See Also Send Feedback

The CodeExpressionCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CodeExpressionCondition()()()() | Initializes a new instance of the CodeExpressionCondition class.
Public method | CodeExpressionCondition(String) | Initializes a new instance of the CodeExpressionCondition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

CodeExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Constructor

[image] [image]

A Sandcastle Documented Class Library
CodeExpressionCondition Constructor
CodeExpressionCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CodeExpressionCondition()()()() | Initializes a new instance of the CodeExpressionCondition class.
Public method | CodeExpressionCondition(String) | Initializes a new instance of the CodeExpressionCondition class.

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Constructor

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition Constructor
CodeExpressionCondition Class See Also Send Feedback
Initializes a new instance of the CodeExpressionCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CodeExpressionCondition()
Visual Basic
Public Sub New
Visual C++
public:
CodeExpressionCondition()

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CodeExpressionCondition Overload
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Constructor (String)

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition Constructor (String)
CodeExpressionCondition Class See Also Send Feedback
Initializes a new instance of the CodeExpressionCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public CodeExpressionCondition(
    string expression
)
Visual Basic
Public Sub New (
    expression As String
)
Visual C++
public:
CodeExpressionCondition(
    String^ expression
)

Parameters

expression
Type: System..::..String
The expression.

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CodeExpressionCondition Overload
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Methods

[image] [image]

A Sandcastle Documented Class Library
CodeExpressionCondition Methods
CodeExpressionCondition Class See Also Send Feedback

The CodeExpressionCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

CodeExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition..::..DeSerailizeFromXML Method
CodeExpressionCondition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition.Evaluate Method

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition..::..Evaluate Method
CodeExpressionCondition Class See Also Send Feedback
Evaluates the specified work flow instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Evaluate(
    WorkflowInstance workFlowInstance
)
Visual Basic
Public Function Evaluate (
    workFlowInstance As WorkflowInstance
) As Boolean
Visual C++
public:
virtual bool Evaluate(
    WorkflowInstance^ workFlowInstance
) sealed

Parameters

workFlowInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The work flow instance.

Return Value

Type: Boolean

Implements

ITaskCondition..::..Evaluate(WorkflowInstance)

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition..::..SerailizeToXML Method
CodeExpressionCondition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition.ToString Method

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition..::..ToString Method
CodeExpressionCondition Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents this instance.

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition Properties

[image] [image]

A Sandcastle Documented Class Library
CodeExpressionCondition Properties
CodeExpressionCondition Class See Also Send Feedback

The CodeExpressionCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

CodeExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


CodeExpressionCondition.ConditionExpression Property

[image]

A Sandcastle Documented Class Library
CodeExpressionCondition..::..ConditionExpression Property
CodeExpressionCondition Class See Also Send Feedback
Gets or sets the condition expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConditionExpression { get; set; }
Visual Basic
Public Property ConditionExpression As String
    Get
    Set
Visual C++
public:
virtual property String^ ConditionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The condition expression.

Implements

ITaskCondition..::..ConditionExpression

See Also

CodeExpressionCondition Class
CodeExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper Class

[image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DefaultWorkflowAttributeMapper : WorkflowAttributeMapper
Visual Basic
Public Class DefaultWorkflowAttributeMapper
    Inherits WorkflowAttributeMapper
Visual C++
public ref class DefaultWorkflowAttributeMapper : public WorkflowAttributeMapper

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowAttributeMapper
CelloSaaS.WorkFlow.Model..::..DefaultWorkflowAttributeMapper

See Also

DefaultWorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper Members

[image] [image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper Members
DefaultWorkflowAttributeMapper Class Constructors Methods See Also Send Feedback

The DefaultWorkflowAttributeMapper type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultWorkflowAttributeMapper | Initializes a new instance of the DefaultWorkflowAttributeMapper class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMapKeys | Gets the map keys. (Overrides WorkflowAttributeMapper..::..GetMapKeys()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String) | Gets the value. (Overrides WorkflowAttributeMapper..::..GetValue(String).)
Public method | GetValue(array<String>[]()[][]) | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultWorkflowAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper Constructor

[image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper Constructor
DefaultWorkflowAttributeMapper Class See Also Send Feedback
Initializes a new instance of the DefaultWorkflowAttributeMapper class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DefaultWorkflowAttributeMapper(
    IWorkflowInput workflowInput
)
Visual Basic
Public Sub New (
    workflowInput As IWorkflowInput
)
Visual C++
public:
DefaultWorkflowAttributeMapper(
    IWorkflowInput^ workflowInput
)

Parameters

workflowInput
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The workflow input.

See Also

DefaultWorkflowAttributeMapper Class
DefaultWorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper Methods

[image] [image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper Methods
DefaultWorkflowAttributeMapper Class See Also Send Feedback

The DefaultWorkflowAttributeMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMapKeys | Gets the map keys. (Overrides WorkflowAttributeMapper..::..GetMapKeys()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String) | Gets the value. (Overrides WorkflowAttributeMapper..::..GetValue(String).)
Public method | GetValue(array<String>[]()[][]) | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultWorkflowAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper.GetMapKeys Method

[image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper..::..GetMapKeys Method
DefaultWorkflowAttributeMapper Class See Also Send Feedback
Gets the map keys.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override List<string> GetMapKeys()
Visual Basic
Public Overrides Function GetMapKeys As List(Of String)
Visual C++
public:
virtual List<String^>^ GetMapKeys() override

Return Value

Type: List<(Of <(<'String>)>)>

See Also

DefaultWorkflowAttributeMapper Class
DefaultWorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper.GetValue Method

[image] [image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper..::..GetValue Method
DefaultWorkflowAttributeMapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(String) | Gets the value. (Overrides WorkflowAttributeMapper..::..GetValue(String).)
Public method | GetValue(array<String>[]()[][]) | Gets the value.

See Also

DefaultWorkflowAttributeMapper Class
DefaultWorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper.GetValue Method (String)

[image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper..::..GetValue Method (String)
DefaultWorkflowAttributeMapper Class See Also Send Feedback
Gets the value.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override List<MappedObjectKeyValue> GetValue(
    string key
)
Visual Basic
Public Overrides Function GetValue (
    key As String
) As List(Of MappedObjectKeyValue)
Visual C++
public:
virtual List<MappedObjectKeyValue^>^ GetValue(
    String^ key
) override

Parameters

key
Type: System..::..String
The key.

Return Value

Type: List<(Of <(<' MappedObjectKeyValue >)>)>

See Also

DefaultWorkflowAttributeMapper Class
DefaultWorkflowAttributeMapper Members
GetValue Overload
CelloSaaS.WorkFlow.Model Namespace


DefaultWorkflowAttributeMapper.GetValue Method (String[])

[image]

A Sandcastle Documented Class Library
DefaultWorkflowAttributeMapper..::..GetValue Method (array<String>[]()[][])
DefaultWorkflowAttributeMapper Class See Also Send Feedback
Gets the value.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<MappedObjectKeyValue> GetValue(
    string[] key
)
Visual Basic
Public Function GetValue (
    key As String()
) As List(Of MappedObjectKeyValue)
Visual C++
public:
List<MappedObjectKeyValue^>^ GetValue(
    array<String^>^ key
)

Parameters

key
Type: array<System..::..String>[]()[][]
The key.

Return Value

Type: List<(Of <(<' MappedObjectKeyValue >)>)>

See Also

DefaultWorkflowAttributeMapper Class
DefaultWorkflowAttributeMapper Members
GetValue Overload
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Class

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DLLTaskActivityDefinition : ITaskActivityDefinition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class DLLTaskActivityDefinition
    Implements ITaskActivityDefinition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class DLLTaskActivityDefinition : ITaskActivityDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DLLTaskActivityDefinition
CelloSaaS.WorkFlow.Activities..::..ApprovalActivityDefinition
CelloSaaS.WorkFlow.Activities..::..NotificationActivityDefinition
CelloSaaS.WorkFlow.Activities..::..ServiceCallActivityDefinition
CelloSaaS.WorkFlow.Model..::..CloseTaskActivityDefinition
CelloSaaS.WorkFlow.Model..::..StartTaskActivityDefinition

See Also

DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Members
DLLTaskActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The DLLTaskActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | DLLTaskActivityDefinition()()()() | Initializes a new instance of the DLLTaskActivityDefinition class
Public method | DLLTaskActivityDefinition(String, String) | Initializes a new instance of the DLLTaskActivityDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly |
Public property | FullyQualifiedType |
Public property | Properties |

See Also

DLLTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Constructor

[image] [image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Constructor
DLLTaskActivityDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DLLTaskActivityDefinition()()()() | Initializes a new instance of the DLLTaskActivityDefinition class
Public method | DLLTaskActivityDefinition(String, String) | Initializes a new instance of the DLLTaskActivityDefinition class

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Constructor
DLLTaskActivityDefinition Class See Also Send Feedback
Initializes a new instance of the DLLTaskActivityDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DLLTaskActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
DLLTaskActivityDefinition()

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
DLLTaskActivityDefinition Overload
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Constructor (String, String)

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Constructor (String, String)
DLLTaskActivityDefinition Class See Also Send Feedback
Initializes a new instance of the DLLTaskActivityDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DLLTaskActivityDefinition(
    string typeName,
    string assemblyName
)
Visual Basic
Public Sub New (
    typeName As String,
    assemblyName As String
)
Visual C++
public:
DLLTaskActivityDefinition(
    String^ typeName,
    String^ assemblyName
)

Parameters

typeName
Type: System..::..String
assemblyName
Type: System..::..String

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
DLLTaskActivityDefinition Overload
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Methods
DLLTaskActivityDefinition Class See Also Send Feedback

The DLLTaskActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DLLTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition..::..DeSerailizeFromXML Method
DLLTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition..::..SerailizeToXML Method
DLLTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition Properties
DLLTaskActivityDefinition Class See Also Send Feedback

The DLLTaskActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly |
Public property | FullyQualifiedType |
Public property | Properties |

See Also

DLLTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition.Assembly Property

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition..::..Assembly Property
DLLTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Assembly { get; set; }
Visual Basic
Public Property Assembly As String
    Get
    Set
Visual C++
public:
virtual property String^ Assembly {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ITaskActivityDefinition..::..Assembly

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition.FullyQualifiedType Property

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition..::..FullyQualifiedType Property
DLLTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FullyQualifiedType { get; set; }
Visual Basic
Public Property FullyQualifiedType As String
    Get
    Set
Visual C++
public:
virtual property String^ FullyQualifiedType {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ITaskActivityDefinition..::..FullyQualifiedType

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DLLTaskActivityDefinition.Properties Property

[image]

A Sandcastle Documented Class Library
DLLTaskActivityDefinition..::..Properties Property
DLLTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, ActivityProperty> Properties { get; set; }
Visual Basic
Public Property Properties As Dictionary(Of String, ActivityProperty)
    Get
    Set
Visual C++
public:
virtual property Dictionary<String^, ActivityProperty^>^ Properties {
    Dictionary<String^, ActivityProperty^>^ get () sealed;
    void set (Dictionary<String^, ActivityProperty^>^ value) sealed;
}

Property Value

Type: Dictionary<(Of <(<'String, ActivityProperty >)>)>

Implements

ITaskActivityDefinition..::..Properties

See Also

DLLTaskActivityDefinition Class
DLLTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition Class

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition Class
Members See Also Send Feedback
Dynamic actor for manual task. reterived from sp

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class DynamicTaskActorDefinition : ITaskActorDefinition,
    IWFXMLSerializable
Visual Basic
Public Class DynamicTaskActorDefinition
    Implements ITaskActorDefinition, IWFXMLSerializable
Visual C++
public ref class DynamicTaskActorDefinition : ITaskActorDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DynamicTaskActorDefinition

See Also

DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition Members

[image] [image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition Members
DynamicTaskActorDefinition Class Constructors Methods Properties See Also Send Feedback

The DynamicTaskActorDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | DynamicTaskActorDefinition | Initializes a new instance of the DynamicTaskActorDefinition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inputs | Gets or sets the inputs.
Public property | IsRuntimeCalculated | Gets or sets a value indicating whether this instance is runtime calculated.
Public property | spDefinition | Gets or sets the sp definition.

See Also

DynamicTaskActorDefinition Class
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition Constructor

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition Constructor
DynamicTaskActorDefinition Class See Also Send Feedback
Initializes a new instance of the DynamicTaskActorDefinition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DynamicTaskActorDefinition()
Visual Basic
Public Sub New
Visual C++
public:
DynamicTaskActorDefinition()

See Also

DynamicTaskActorDefinition Class
DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition Methods
DynamicTaskActorDefinition Class See Also Send Feedback

The DynamicTaskActorDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DynamicTaskActorDefinition Class
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition..::..DeSerailizeFromXML Method
DynamicTaskActorDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

DynamicTaskActorDefinition Class
DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition..::..SerailizeToXML Method
DynamicTaskActorDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

DynamicTaskActorDefinition Class
DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition Properties
DynamicTaskActorDefinition Class See Also Send Feedback

The DynamicTaskActorDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Inputs | Gets or sets the inputs.
Public property | IsRuntimeCalculated | Gets or sets a value indicating whether this instance is runtime calculated.
Public property | spDefinition | Gets or sets the sp definition.

See Also

DynamicTaskActorDefinition Class
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition.Inputs Property

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition..::..Inputs Property
DynamicTaskActorDefinition Class See Also Send Feedback
Gets or sets the inputs.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Object> Inputs { get; set; }
Visual Basic
Public Property Inputs As List(Of Object)
    Get
    Set
Visual C++
public:
property List<Object^>^ Inputs {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}

Property Value

Type: List<(Of <(<'Object>)>)>
The inputs.

See Also

DynamicTaskActorDefinition Class
DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition.IsRuntimeCalculated Property

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition..::..IsRuntimeCalculated Property
DynamicTaskActorDefinition Class See Also Send Feedback
Gets or sets a value indicating whether this instance is runtime calculated.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsRuntimeCalculated { get; set; }
Visual Basic
Public Property IsRuntimeCalculated As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsRuntimeCalculated {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean
true if this instance is runtime calculated; otherwise, false.

Implements

ITaskActorDefinition..::..IsRuntimeCalculated

See Also

DynamicTaskActorDefinition Class
DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


DynamicTaskActorDefinition.spDefinition Property

[image]

A Sandcastle Documented Class Library
DynamicTaskActorDefinition..::..spDefinition Property
DynamicTaskActorDefinition Class See Also Send Feedback
Gets or sets the sp definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPDefinition spDefinition { get; set; }
Visual Basic
Public Property spDefinition As SPDefinition
    Get
    Set
Visual C++
public:
property SPDefinition^ spDefinition {
    SPDefinition^ get ();
    void set (SPDefinition^ value);
}

Property Value

Type: SPDefinition
The sp definition.

See Also

DynamicTaskActorDefinition Class
DynamicTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ExecuteType Enumeration

[image]

A Sandcastle Documented Class Library
ExecuteType Enumeration
See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum ExecuteType
Visual Basic
Public Enumeration ExecuteType
Visual C++
public enum class ExecuteType

Members

Member name | Value | Description
ExecuteScalar | 0 |
ExecuteReader | 1 |
ExecuteNonQuery | 2 |

See Also

CelloSaaS.WorkFlow.Model Namespace


ExecutionStatusChange Class

[image]

A Sandcastle Documented Class Library
ExecutionStatusChange Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ExecutionStatusChange
Visual Basic
Public Class ExecutionStatusChange
Visual C++
public ref class ExecutionStatusChange

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..ExecutionStatusChange

See Also

ExecutionStatusChange Members
CelloSaaS.WorkFlow.Model Namespace


ExecutionStatusChange Members

[image] [image]

A Sandcastle Documented Class Library
ExecutionStatusChange Members
ExecutionStatusChange Class Constructors Methods See Also Send Feedback

The ExecutionStatusChange type exposes the following members.

Constructors

 | Name | Description
Public method | ExecutionStatusChange | Initializes a new instance of the ExecutionStatusChange class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExecutionStatusChange Class
CelloSaaS.WorkFlow.Model Namespace


ExecutionStatusChange Constructor

[image]

A Sandcastle Documented Class Library
ExecutionStatusChange Constructor
ExecutionStatusChange Class See Also Send Feedback
Initializes a new instance of the ExecutionStatusChange class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExecutionStatusChange()
Visual Basic
Public Sub New
Visual C++
public:
ExecutionStatusChange()

See Also

ExecutionStatusChange Class
ExecutionStatusChange Members
CelloSaaS.WorkFlow.Model Namespace


ExecutionStatusChange Methods

[image] [image]

A Sandcastle Documented Class Library
ExecutionStatusChange Methods
ExecutionStatusChange Class See Also Send Feedback

The ExecutionStatusChange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExecutionStatusChange Class
CelloSaaS.WorkFlow.Model Namespace


IActivity Interface

[image]

A Sandcastle Documented Class Library
IActivity Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IActivity
Visual Basic
Public Interface IActivity
Visual C++
public interface class IActivity

See Also

IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity Members

[image] [image]

A Sandcastle Documented Class Library
IActivity Members
IActivity Interface Methods Properties See Also Send Feedback

The IActivity type exposes the following members.

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Execute | Executes this instance.
Public method | HasExpired | Determines whether this instance has expired.

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

IActivity Interface
CelloSaaS.WorkFlow.Model Namespace


IActivity Methods

[image] [image]

A Sandcastle Documented Class Library
IActivity Methods
IActivity Interface See Also Send Feedback

The IActivity type exposes the following members.

Methods

 | Name | Description
Public method | CanComplete | Determines whether this instance can complete.
Public method | CanStart | Determines whether this instance can start.
Public method | Complete | Completes this instance.
Public method | Execute | Executes this instance.
Public method | HasExpired | Determines whether this instance has expired.

See Also

IActivity Interface
CelloSaaS.WorkFlow.Model Namespace


IActivity.CanComplete Method

[image]

A Sandcastle Documented Class Library
IActivity..::..CanComplete Method
IActivity Interface See Also Send Feedback
Determines whether this instance can complete.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CanComplete()
Visual Basic
Function CanComplete As Boolean
Visual C++
bool CanComplete()

Return Value

Type: Boolean
true if this instance can complete; otherwise, false.

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity.CanStart Method

[image]

A Sandcastle Documented Class Library
IActivity..::..CanStart Method
IActivity Interface See Also Send Feedback
Determines whether this instance can start.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CanStart()
Visual Basic
Function CanStart As Boolean
Visual C++
bool CanStart()

Return Value

Type: Boolean
true if this instance can start; otherwise, false.

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity.Complete Method

[image]

A Sandcastle Documented Class Library
IActivity..::..Complete Method
IActivity Interface See Also Send Feedback
Completes this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> Complete()
Visual Basic
Function Complete As List(Of String)
Visual C++
List<String^>^ Complete()

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity.Execute Method

[image]

A Sandcastle Documented Class Library
IActivity..::..Execute Method
IActivity Interface See Also Send Feedback
Executes this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> Execute()
Visual Basic
Function Execute As List(Of String)
Visual C++
List<String^>^ Execute()

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity.HasExpired Method

[image]

A Sandcastle Documented Class Library
IActivity..::..HasExpired Method
IActivity Interface See Also Send Feedback
Determines whether this instance has expired.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool HasExpired()
Visual Basic
Function HasExpired As Boolean
Visual C++
bool HasExpired()

Return Value

Type: Boolean
true if this instance has expired; otherwise, false.

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity Properties

[image] [image]

A Sandcastle Documented Class Library
IActivity Properties
IActivity Interface See Also Send Feedback

The IActivity type exposes the following members.

Properties

 | Name | Description
Public property | ActivityDefinition | Gets or sets the activity definition.
Public property | Inputs | Gets or sets the inputs.
Public property | TaskInstanceService | Gets or sets the workflow task instance service object

See Also

IActivity Interface
CelloSaaS.WorkFlow.Model Namespace


IActivity.ActivityDefinition Property

[image]

A Sandcastle Documented Class Library
IActivity..::..ActivityDefinition Property
IActivity Interface See Also Send Feedback
Gets or sets the activity definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ITaskActivityDefinition ActivityDefinition { get; set; }
Visual Basic
Property ActivityDefinition As ITaskActivityDefinition
    Get
    Set
Visual C++
property ITaskActivityDefinition^ ActivityDefinition {
    ITaskActivityDefinition^ get ();
    void set (ITaskActivityDefinition^ value);
}

Property Value

Type: ITaskActivityDefinition
The activity definition.

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity.Inputs Property

[image]

A Sandcastle Documented Class Library
IActivity..::..Inputs Property
IActivity Interface See Also Send Feedback
Gets or sets the inputs.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Object> Inputs { get; set; }
Visual Basic
Property Inputs As List(Of Object)
    Get
    Set
Visual C++
property List<Object^>^ Inputs {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}

Property Value

Type: List<(Of <(<'Object>)>)>
The inputs.

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IActivity.TaskInstanceService Property

[image]

A Sandcastle Documented Class Library
IActivity..::..TaskInstanceService Property
IActivity Interface See Also Send Feedback
Gets or sets the workflow task instance service object

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowTaskInstanceService TaskInstanceService { get; set; }
Visual Basic
Property TaskInstanceService As WorkflowTaskInstanceService
    Get
    Set
Visual C++
property WorkflowTaskInstanceService^ TaskInstanceService {
    WorkflowTaskInstanceService^ get ();
    void set (WorkflowTaskInstanceService^ value);
}

Property Value

Type: WorkflowTaskInstanceService

See Also

IActivity Interface
IActivity Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion Class

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class IfElseRoutingContion : IRoutingCondition,
    IWFXMLSerializable
Visual Basic
Public Class IfElseRoutingContion
    Implements IRoutingCondition, IWFXMLSerializable
Visual C++
public ref class IfElseRoutingContion : IRoutingCondition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..IfElseRoutingContion

See Also

IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion Members

[image] [image]

A Sandcastle Documented Class Library
IfElseRoutingContion Members
IfElseRoutingContion Class Constructors Methods Properties See Also Send Feedback

The IfElseRoutingContion type exposes the following members.

Constructors

 | Name | Description
Public method | IfElseRoutingContion | Initializes a new instance of the IfElseRoutingContion class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition.
Public property | ElseNodeOutputIds | Gets or sets the else node output ids.
Public property | IfNodeOutputIds | Gets or sets if node output ids.
Public property | InputTaskIds | Gets or sets the input tasks.
Public property | OutputTaskIds | Gets or sets the output tasks.

See Also

IfElseRoutingContion Class
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion Constructor

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion Constructor
IfElseRoutingContion Class See Also Send Feedback
Initializes a new instance of the IfElseRoutingContion class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IfElseRoutingContion()
Visual Basic
Public Sub New
Visual C++
public:
IfElseRoutingContion()

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion Methods

[image] [image]

A Sandcastle Documented Class Library
IfElseRoutingContion Methods
IfElseRoutingContion Class See Also Send Feedback

The IfElseRoutingContion type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IfElseRoutingContion Class
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..DeSerailizeFromXML Method
IfElseRoutingContion Class See Also Send Feedback
De-serailize itself from XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String
The XML.

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..SerailizeToXML Method
IfElseRoutingContion Class See Also Send Feedback
Serailizes to XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion Properties

[image] [image]

A Sandcastle Documented Class Library
IfElseRoutingContion Properties
IfElseRoutingContion Class See Also Send Feedback

The IfElseRoutingContion type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition.
Public property | ElseNodeOutputIds | Gets or sets the else node output ids.
Public property | IfNodeOutputIds | Gets or sets if node output ids.
Public property | InputTaskIds | Gets or sets the input tasks.
Public property | OutputTaskIds | Gets or sets the output tasks.

See Also

IfElseRoutingContion Class
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.Condition Property

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..Condition Property
IfElseRoutingContion Class See Also Send Feedback
Gets or sets the condition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskCondition Condition { get; set; }
Visual Basic
Public Property Condition As ITaskCondition
    Get
    Set
Visual C++
public:
virtual property ITaskCondition^ Condition {
    ITaskCondition^ get () sealed;
    void set (ITaskCondition^ value) sealed;
}

Property Value

Type: ITaskCondition
The condition.

Implements

IRoutingCondition..::..Condition

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.ElseNodeOutputIds Property

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..ElseNodeOutputIds Property
IfElseRoutingContion Class See Also Send Feedback
Gets or sets the else node output ids.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Guid> ElseNodeOutputIds { get; set; }
Visual Basic
Public Property ElseNodeOutputIds As List(Of Guid)
    Get
    Set
Visual C++
public:
property List<Guid>^ ElseNodeOutputIds {
    List<Guid>^ get ();
    void set (List<Guid>^ value);
}

Property Value

Type: List<(Of <(<'Guid>)>)>
The else node output ids.

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.IfNodeOutputIds Property

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..IfNodeOutputIds Property
IfElseRoutingContion Class See Also Send Feedback
Gets or sets if node output ids.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Guid> IfNodeOutputIds { get; set; }
Visual Basic
Public Property IfNodeOutputIds As List(Of Guid)
    Get
    Set
Visual C++
public:
property List<Guid>^ IfNodeOutputIds {
    List<Guid>^ get ();
    void set (List<Guid>^ value);
}

Property Value

Type: List<(Of <(<'Guid>)>)>
If node output ids.

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.InputTaskIds Property

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..InputTaskIds Property
IfElseRoutingContion Class See Also Send Feedback
Gets or sets the input tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Guid> InputTaskIds { get; set; }
Visual Basic
Public Property InputTaskIds As List(Of Guid)
    Get
    Set
Visual C++
public:
virtual property List<Guid>^ InputTaskIds {
    List<Guid>^ get () sealed;
    void set (List<Guid>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Guid>)>)>
The input tasks.

Implements

IRoutingCondition..::..InputTaskIds

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseRoutingContion.OutputTaskIds Property

[image]

A Sandcastle Documented Class Library
IfElseRoutingContion..::..OutputTaskIds Property
IfElseRoutingContion Class See Also Send Feedback
Gets or sets the output tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Guid> OutputTaskIds { get; set; }
Visual Basic
Public Property OutputTaskIds As List(Of Guid)
    Get
    Set
Visual C++
public:
virtual property List<Guid>^ OutputTaskIds {
    List<Guid>^ get () sealed;
    void set (List<Guid>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Guid>)>)>
The output tasks.

Implements

IRoutingCondition..::..OutputTaskIds

See Also

IfElseRoutingContion Class
IfElseRoutingContion Members
CelloSaaS.WorkFlow.Model Namespace


IfElseWorkflowTaskRouter Class

[image]

A Sandcastle Documented Class Library
IfElseWorkflowTaskRouter Class
Members See Also Send Feedback
This class contains the IF Else workflow router definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class IfElseWorkflowTaskRouter : WorkflowTaskRouter
Visual Basic
Public Class IfElseWorkflowTaskRouter
    Inherits WorkflowTaskRouter
Visual C++
public ref class IfElseWorkflowTaskRouter : public WorkflowTaskRouter

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowTaskRouter
CelloSaaS.WorkFlow.Model..::..IfElseWorkflowTaskRouter

See Also

IfElseWorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


IfElseWorkflowTaskRouter Members

[image] [image]

A Sandcastle Documented Class Library
IfElseWorkflowTaskRouter Members
IfElseWorkflowTaskRouter Class Constructors Methods Properties See Also Send Feedback

The IfElseWorkflowTaskRouter type exposes the following members.

Constructors

 | Name | Description
Public method | IfElseWorkflowTaskRouter | Initializes a new instance of the IfElseWorkflowTaskRouter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Overrides WorkflowTaskRouter..::..Evaluate(WorkflowInstance).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Gets or sets the definition. (Inherited from WorkflowTaskRouter.)
Public property | RoutingTable | Gets or sets the routing table. (Inherited from WorkflowTaskRouter.)

See Also

IfElseWorkflowTaskRouter Class
CelloSaaS.WorkFlow.Model Namespace


IfElseWorkflowTaskRouter Constructor

[image]

A Sandcastle Documented Class Library
IfElseWorkflowTaskRouter Constructor
IfElseWorkflowTaskRouter Class See Also Send Feedback
Initializes a new instance of the IfElseWorkflowTaskRouter class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IfElseWorkflowTaskRouter()
Visual Basic
Public Sub New
Visual C++
public:
IfElseWorkflowTaskRouter()

See Also

IfElseWorkflowTaskRouter Class
IfElseWorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


IfElseWorkflowTaskRouter Methods

[image] [image]

A Sandcastle Documented Class Library
IfElseWorkflowTaskRouter Methods
IfElseWorkflowTaskRouter Class See Also Send Feedback

The IfElseWorkflowTaskRouter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | (Overrides WorkflowTaskRouter..::..Evaluate(WorkflowInstance).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IfElseWorkflowTaskRouter Class
CelloSaaS.WorkFlow.Model Namespace


IfElseWorkflowTaskRouter.Evaluate Method

[image]

A Sandcastle Documented Class Library
IfElseWorkflowTaskRouter..::..Evaluate Method
IfElseWorkflowTaskRouter Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override List<Guid> Evaluate(
    WorkflowInstance instance
)
Visual Basic
Public Overrides Function Evaluate (
    instance As WorkflowInstance
) As List(Of Guid)
Visual C++
public:
virtual List<Guid>^ Evaluate(
    WorkflowInstance^ instance
) override

Parameters

instance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance

Return Value

Type: List<(Of <(<'Guid>)>)>

See Also

IfElseWorkflowTaskRouter Class
IfElseWorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


IfElseWorkflowTaskRouter Properties

[image] [image]

A Sandcastle Documented Class Library
IfElseWorkflowTaskRouter Properties
IfElseWorkflowTaskRouter Class See Also Send Feedback

The IfElseWorkflowTaskRouter type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets or sets the definition. (Inherited from WorkflowTaskRouter.)
Public property | RoutingTable | Gets or sets the routing table. (Inherited from WorkflowTaskRouter.)

See Also

IfElseWorkflowTaskRouter Class
CelloSaaS.WorkFlow.Model Namespace


InputMapping Class

[image]

A Sandcastle Documented Class Library
InputMapping Class
Members See Also Send Feedback
InputMapping

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class InputMapping
Visual Basic
<SerializableAttribute>
Public Class InputMapping
Visual C++
[SerializableAttribute]
public ref class InputMapping

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..InputMapping

See Also

InputMapping Members
CelloSaaS.WorkFlow.Model Namespace


InputMapping Members

[image] [image]

A Sandcastle Documented Class Library
InputMapping Members
InputMapping Class Constructors Methods See Also Send Feedback

The InputMapping type exposes the following members.

Constructors

 | Name | Description
Public method | InputMapping | Initializes a new instance of the InputMapping class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InputMapping Class
CelloSaaS.WorkFlow.Model Namespace


InputMapping Constructor

[image]

A Sandcastle Documented Class Library
InputMapping Constructor
InputMapping Class See Also Send Feedback
Initializes a new instance of the InputMapping class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public InputMapping()
Visual Basic
Public Sub New
Visual C++
public:
InputMapping()

See Also

InputMapping Class
InputMapping Members
CelloSaaS.WorkFlow.Model Namespace


InputMapping Methods

[image] [image]

A Sandcastle Documented Class Library
InputMapping Methods
InputMapping Class See Also Send Feedback

The InputMapping type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InputMapping Class
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition Interface

[image]

A Sandcastle Documented Class Library
IRoutingCondition Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IRoutingCondition : IWFXMLSerializable
Visual Basic
Public Interface IRoutingCondition
    Inherits IWFXMLSerializable
Visual C++
public interface class IRoutingCondition : IWFXMLSerializable

See Also

IRoutingCondition Members
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition Members

[image] [image]

A Sandcastle Documented Class Library
IRoutingCondition Members
IRoutingCondition Interface Methods Properties See Also Send Feedback

The IRoutingCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition.
Public property | InputTaskIds | Gets or sets the input tasks.
Public property | OutputTaskIds | Gets or sets the output tasks.

See Also

IRoutingCondition Interface
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition Methods

[image] [image]

A Sandcastle Documented Class Library
IRoutingCondition Methods
IRoutingCondition Interface See Also Send Feedback

The IRoutingCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

IRoutingCondition Interface
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition Properties

[image] [image]

A Sandcastle Documented Class Library
IRoutingCondition Properties
IRoutingCondition Interface See Also Send Feedback

The IRoutingCondition type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition.
Public property | InputTaskIds | Gets or sets the input tasks.
Public property | OutputTaskIds | Gets or sets the output tasks.

See Also

IRoutingCondition Interface
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition.Condition Property

[image]

A Sandcastle Documented Class Library
IRoutingCondition..::..Condition Property
IRoutingCondition Interface See Also Send Feedback
Gets or sets the condition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ITaskCondition Condition { get; set; }
Visual Basic
Property Condition As ITaskCondition
    Get
    Set
Visual C++
property ITaskCondition^ Condition {
    ITaskCondition^ get ();
    void set (ITaskCondition^ value);
}

Property Value

Type: ITaskCondition
The condition.

See Also

IRoutingCondition Interface
IRoutingCondition Members
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition.InputTaskIds Property

[image]

A Sandcastle Documented Class Library
IRoutingCondition..::..InputTaskIds Property
IRoutingCondition Interface See Also Send Feedback
Gets or sets the input tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Guid> InputTaskIds { get; set; }
Visual Basic
Property InputTaskIds As List(Of Guid)
    Get
    Set
Visual C++
property List<Guid>^ InputTaskIds {
    List<Guid>^ get ();
    void set (List<Guid>^ value);
}

Property Value

Type: List<(Of <(<'Guid>)>)>
The input tasks.

See Also

IRoutingCondition Interface
IRoutingCondition Members
CelloSaaS.WorkFlow.Model Namespace


IRoutingCondition.OutputTaskIds Property

[image]

A Sandcastle Documented Class Library
IRoutingCondition..::..OutputTaskIds Property
IRoutingCondition Interface See Also Send Feedback
Gets or sets the output tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<Guid> OutputTaskIds { get; set; }
Visual Basic
Property OutputTaskIds As List(Of Guid)
    Get
    Set
Visual C++
property List<Guid>^ OutputTaskIds {
    List<Guid>^ get ();
    void set (List<Guid>^ value);
}

Property Value

Type: List<(Of <(<'Guid>)>)>
The output tasks.

See Also

IRoutingCondition Interface
IRoutingCondition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition Interface

[image]

A Sandcastle Documented Class Library
ITaskActivityDefinition Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaskActivityDefinition : IWFXMLSerializable
Visual Basic
Public Interface ITaskActivityDefinition
    Inherits IWFXMLSerializable
Visual C++
public interface class ITaskActivityDefinition : IWFXMLSerializable

See Also

ITaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
ITaskActivityDefinition Members
ITaskActivityDefinition Interface Methods Properties See Also Send Feedback

The ITaskActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

Properties

 | Name | Description
Public property | Assembly |
Public property | FullyQualifiedType |
Public property | Properties |

See Also

ITaskActivityDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
ITaskActivityDefinition Methods
ITaskActivityDefinition Interface See Also Send Feedback

The ITaskActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

ITaskActivityDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
ITaskActivityDefinition Properties
ITaskActivityDefinition Interface See Also Send Feedback

The ITaskActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly |
Public property | FullyQualifiedType |
Public property | Properties |

See Also

ITaskActivityDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition.Assembly Property

[image]

A Sandcastle Documented Class Library
ITaskActivityDefinition..::..Assembly Property
ITaskActivityDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string Assembly { get; set; }
Visual Basic
Property Assembly As String
    Get
    Set
Visual C++
property String^ Assembly {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ITaskActivityDefinition Interface
ITaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition.FullyQualifiedType Property

[image]

A Sandcastle Documented Class Library
ITaskActivityDefinition..::..FullyQualifiedType Property
ITaskActivityDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string FullyQualifiedType { get; set; }
Visual Basic
Property FullyQualifiedType As String
    Get
    Set
Visual C++
property String^ FullyQualifiedType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ITaskActivityDefinition Interface
ITaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActivityDefinition.Properties Property

[image]

A Sandcastle Documented Class Library
ITaskActivityDefinition..::..Properties Property
ITaskActivityDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, ActivityProperty> Properties { get; set; }
Visual Basic
Property Properties As Dictionary(Of String, ActivityProperty)
    Get
    Set
Visual C++
property Dictionary<String^, ActivityProperty^>^ Properties {
    Dictionary<String^, ActivityProperty^>^ get ();
    void set (Dictionary<String^, ActivityProperty^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, ActivityProperty >)>)>

See Also

ITaskActivityDefinition Interface
ITaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActor Interface

[image]

A Sandcastle Documented Class Library
ITaskActor Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaskActor
Visual Basic
Public Interface ITaskActor
Visual C++
public interface class ITaskActor

See Also

ITaskActor Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActor Members

[image] [image]

A Sandcastle Documented Class Library
ITaskActor Members
ITaskActor Interface Properties See Also Send Feedback

The ITaskActor type exposes the following members.

Properties

 | Name | Description
Public property | UserId | Gets or sets the user id.

See Also

ITaskActor Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActor Properties

[image] [image]

A Sandcastle Documented Class Library
ITaskActor Properties
ITaskActor Interface See Also Send Feedback

The ITaskActor type exposes the following members.

Properties

 | Name | Description
Public property | UserId | Gets or sets the user id.

See Also

ITaskActor Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActor.UserId Property

[image]

A Sandcastle Documented Class Library
ITaskActor..::..UserId Property
ITaskActor Interface See Also Send Feedback
Gets or sets the user id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string UserId { get; set; }
Visual Basic
Property UserId As String
    Get
    Set
Visual C++
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The user id.

See Also

ITaskActor Interface
ITaskActor Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActorDefinition Interface

[image]

A Sandcastle Documented Class Library
ITaskActorDefinition Interface
Members See Also Send Feedback
Manual Task actor's definition details

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaskActorDefinition : IWFXMLSerializable
Visual Basic
Public Interface ITaskActorDefinition
    Inherits IWFXMLSerializable
Visual C++
public interface class ITaskActorDefinition : IWFXMLSerializable

See Also

ITaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskActorDefinition Members

[image] [image]

A Sandcastle Documented Class Library
ITaskActorDefinition Members
ITaskActorDefinition Interface Methods Properties See Also Send Feedback

The ITaskActorDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

Properties

 | Name | Description
Public property | IsRuntimeCalculated |

See Also

ITaskActorDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActorDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
ITaskActorDefinition Methods
ITaskActorDefinition Interface See Also Send Feedback

The ITaskActorDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

ITaskActorDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActorDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
ITaskActorDefinition Properties
ITaskActorDefinition Interface See Also Send Feedback

The ITaskActorDefinition type exposes the following members.

Properties

 | Name | Description
Public property | IsRuntimeCalculated |

See Also

ITaskActorDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskActorDefinition.IsRuntimeCalculated Property

[image]

A Sandcastle Documented Class Library
ITaskActorDefinition..::..IsRuntimeCalculated Property
ITaskActorDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool IsRuntimeCalculated { get; set; }
Visual Basic
Property IsRuntimeCalculated As Boolean
    Get
    Set
Visual C++
property bool IsRuntimeCalculated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ITaskActorDefinition Interface
ITaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskCondition Interface

[image]

A Sandcastle Documented Class Library
ITaskCondition Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaskCondition : IWFXMLSerializable
Visual Basic
Public Interface ITaskCondition
    Inherits IWFXMLSerializable
Visual C++
public interface class ITaskCondition : IWFXMLSerializable

See Also

ITaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskCondition Members

[image] [image]

A Sandcastle Documented Class Library
ITaskCondition Members
ITaskCondition Interface Methods Properties See Also Send Feedback

The ITaskCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | Evaluate | Evaluates the task condition .
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

ITaskCondition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskCondition Methods

[image] [image]

A Sandcastle Documented Class Library
ITaskCondition Methods
ITaskCondition Interface See Also Send Feedback

The ITaskCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | Evaluate | Evaluates the task condition .
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

ITaskCondition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskCondition.Evaluate Method

[image]

A Sandcastle Documented Class Library
ITaskCondition..::..Evaluate Method
ITaskCondition Interface See Also Send Feedback
Evaluates the task condition .

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool Evaluate(
    WorkflowInstance workFlowInstance
)
Visual Basic
Function Evaluate (
    workFlowInstance As WorkflowInstance
) As Boolean
Visual C++
bool Evaluate(
    WorkflowInstance^ workFlowInstance
)

Parameters

workFlowInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The work flow instance.

Return Value

Type: Boolean

See Also

ITaskCondition Interface
ITaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskCondition Properties

[image] [image]

A Sandcastle Documented Class Library
ITaskCondition Properties
ITaskCondition Interface See Also Send Feedback

The ITaskCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

ITaskCondition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskCondition.ConditionExpression Property

[image]

A Sandcastle Documented Class Library
ITaskCondition..::..ConditionExpression Property
ITaskCondition Interface See Also Send Feedback
Gets or sets the condition expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string ConditionExpression { get; set; }
Visual Basic
Property ConditionExpression As String
    Get
    Set
Visual C++
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The condition expression.

See Also

ITaskCondition Interface
ITaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition Interface

[image]

A Sandcastle Documented Class Library
ITaskConditionDefinition Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaskConditionDefinition : IWFXMLSerializable
Visual Basic
Public Interface ITaskConditionDefinition
    Inherits IWFXMLSerializable
Visual C++
public interface class ITaskConditionDefinition : IWFXMLSerializable

See Also

ITaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition Members

[image] [image]

A Sandcastle Documented Class Library
ITaskConditionDefinition Members
ITaskConditionDefinition Interface Methods Properties See Also Send Feedback

The ITaskConditionDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

Properties

 | Name | Description
Public property | CompleteConditions |
Public property | ExpireConditions |
Public property | OverrideConditions |
Public property | SkipConditions |
Public property | StartConditions |

See Also

ITaskConditionDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
ITaskConditionDefinition Methods
ITaskConditionDefinition Interface See Also Send Feedback

The ITaskConditionDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

ITaskConditionDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
ITaskConditionDefinition Properties
ITaskConditionDefinition Interface See Also Send Feedback

The ITaskConditionDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CompleteConditions |
Public property | ExpireConditions |
Public property | OverrideConditions |
Public property | SkipConditions |
Public property | StartConditions |

See Also

ITaskConditionDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition.CompleteConditions Property

[image]

A Sandcastle Documented Class Library
ITaskConditionDefinition..::..CompleteConditions Property
ITaskConditionDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskCondition> CompleteConditions { get; set; }
Visual Basic
Property CompleteConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
property List<ITaskCondition^>^ CompleteConditions {
    List<ITaskCondition^>^ get ();
    void set (List<ITaskCondition^>^ value);
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

See Also

ITaskConditionDefinition Interface
ITaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition.ExpireConditions Property

[image]

A Sandcastle Documented Class Library
ITaskConditionDefinition..::..ExpireConditions Property
ITaskConditionDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskCondition> ExpireConditions { get; set; }
Visual Basic
Property ExpireConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
property List<ITaskCondition^>^ ExpireConditions {
    List<ITaskCondition^>^ get ();
    void set (List<ITaskCondition^>^ value);
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

See Also

ITaskConditionDefinition Interface
ITaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition.OverrideConditions Property

[image]

A Sandcastle Documented Class Library
ITaskConditionDefinition..::..OverrideConditions Property
ITaskConditionDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskCondition> OverrideConditions { get; set; }
Visual Basic
Property OverrideConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
property List<ITaskCondition^>^ OverrideConditions {
    List<ITaskCondition^>^ get ();
    void set (List<ITaskCondition^>^ value);
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

See Also

ITaskConditionDefinition Interface
ITaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition.SkipConditions Property

[image]

A Sandcastle Documented Class Library
ITaskConditionDefinition..::..SkipConditions Property
ITaskConditionDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskCondition> SkipConditions { get; set; }
Visual Basic
Property SkipConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
property List<ITaskCondition^>^ SkipConditions {
    List<ITaskCondition^>^ get ();
    void set (List<ITaskCondition^>^ value);
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

See Also

ITaskConditionDefinition Interface
ITaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskConditionDefinition.StartConditions Property

[image]

A Sandcastle Documented Class Library
ITaskConditionDefinition..::..StartConditions Property
ITaskConditionDefinition Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskCondition> StartConditions { get; set; }
Visual Basic
Property StartConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
property List<ITaskCondition^>^ StartConditions {
    List<ITaskCondition^>^ get ();
    void set (List<ITaskCondition^>^ value);
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

See Also

ITaskConditionDefinition Interface
ITaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ITaskExpressionConditions Interface

[image]

A Sandcastle Documented Class Library
ITaskExpressionConditions Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface ITaskExpressionConditions : ITaskCondition,
    IWFXMLSerializable
Visual Basic
Public Interface ITaskExpressionConditions
    Inherits ITaskCondition, IWFXMLSerializable
Visual C++
public interface class ITaskExpressionConditions : ITaskCondition,
    IWFXMLSerializable

See Also

ITaskExpressionConditions Members
CelloSaaS.WorkFlow.Model Namespace


ITaskExpressionConditions Members

[image] [image]

A Sandcastle Documented Class Library
ITaskExpressionConditions Members
ITaskExpressionConditions Interface Methods Properties See Also Send Feedback

The ITaskExpressionConditions type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | Evaluate | Evaluates the task condition . (Inherited from ITaskCondition.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression. (Inherited from ITaskCondition.)

See Also

ITaskExpressionConditions Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskExpressionConditions Methods

[image] [image]

A Sandcastle Documented Class Library
ITaskExpressionConditions Methods
ITaskExpressionConditions Interface See Also Send Feedback

The ITaskExpressionConditions type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | Evaluate | Evaluates the task condition . (Inherited from ITaskCondition.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

ITaskExpressionConditions Interface
CelloSaaS.WorkFlow.Model Namespace


ITaskExpressionConditions Properties

[image] [image]

A Sandcastle Documented Class Library
ITaskExpressionConditions Properties
ITaskExpressionConditions Interface See Also Send Feedback

The ITaskExpressionConditions type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression. (Inherited from ITaskCondition.)

See Also

ITaskExpressionConditions Interface
CelloSaaS.WorkFlow.Model Namespace


IWFXMLSerializable Interface

[image]

A Sandcastle Documented Class Library
IWFXMLSerializable Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWFXMLSerializable
Visual Basic
Public Interface IWFXMLSerializable
Visual C++
public interface class IWFXMLSerializable

See Also

IWFXMLSerializable Members
CelloSaaS.WorkFlow.Model Namespace


IWFXMLSerializable Members

[image] [image]

A Sandcastle Documented Class Library
IWFXMLSerializable Members
IWFXMLSerializable Interface Methods See Also Send Feedback

The IWFXMLSerializable type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | SerailizeToXML | Serailizes to XML.

See Also

IWFXMLSerializable Interface
CelloSaaS.WorkFlow.Model Namespace


IWFXMLSerializable Methods

[image] [image]

A Sandcastle Documented Class Library
IWFXMLSerializable Methods
IWFXMLSerializable Interface See Also Send Feedback

The IWFXMLSerializable type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | SerailizeToXML | Serailizes to XML.

See Also

IWFXMLSerializable Interface
CelloSaaS.WorkFlow.Model Namespace


IWFXMLSerializable.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
IWFXMLSerializable..::..DeSerailizeFromXML Method
IWFXMLSerializable Interface See Also Send Feedback
De-serailize itself from XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeSerailizeFromXML(
    string xml
)
Visual Basic
Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
void DeSerailizeFromXML(
    String^ xml
)

Parameters

xml
Type: System..::..String
The XML.

Return Value

Type:

See Also

IWFXMLSerializable Interface
IWFXMLSerializable Members
CelloSaaS.WorkFlow.Model Namespace


IWFXMLSerializable.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
IWFXMLSerializable..::..SerailizeToXML Method
IWFXMLSerializable Interface See Also Send Feedback
Serailizes to XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string SerailizeToXML()
Visual Basic
Function SerailizeToXML As String
Visual C++
String^ SerailizeToXML()

Return Value

Type: String

See Also

IWFXMLSerializable Interface
IWFXMLSerializable Members
CelloSaaS.WorkFlow.Model Namespace


IWorkflowElement Interface

[image]

A Sandcastle Documented Class Library
IWorkflowElement Interface
See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowElement
Visual Basic
Public Interface IWorkflowElement
Visual C++
public interface class IWorkflowElement

See Also

CelloSaaS.WorkFlow.Model Namespace


IWorkflowInput Interface

[image]

A Sandcastle Documented Class Library
IWorkflowInput Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowInput
Visual Basic
Public Interface IWorkflowInput
Visual C++
public interface class IWorkflowInput

See Also

IWorkflowInput Members
CelloSaaS.WorkFlow.Model Namespace


IWorkflowInput Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowInput Members
IWorkflowInput Interface Properties See Also Send Feedback

The IWorkflowInput type exposes the following members.

Properties

 | Name | Description
Public property | FilterId | Gets or sets the filter id.

See Also

IWorkflowInput Interface
CelloSaaS.WorkFlow.Model Namespace


IWorkflowInput Properties

[image] [image]

A Sandcastle Documented Class Library
IWorkflowInput Properties
IWorkflowInput Interface See Also Send Feedback

The IWorkflowInput type exposes the following members.

Properties

 | Name | Description
Public property | FilterId | Gets or sets the filter id.

See Also

IWorkflowInput Interface
CelloSaaS.WorkFlow.Model Namespace


IWorkflowInput.FilterId Property

[image]

A Sandcastle Documented Class Library
IWorkflowInput..::..FilterId Property
IWorkflowInput Interface See Also Send Feedback
Gets or sets the filter id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string FilterId { get; set; }
Visual Basic
Property FilterId As String
    Get
    Set
Visual C++
property String^ FilterId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The filter id.

See Also

IWorkflowInput Interface
IWorkflowInput Members
CelloSaaS.WorkFlow.Model Namespace


IWorkFlowInputFinder Interface

[image]

A Sandcastle Documented Class Library
IWorkFlowInputFinder Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkFlowInputFinder
Visual Basic
Public Interface IWorkFlowInputFinder
Visual C++
public interface class IWorkFlowInputFinder

See Also

IWorkFlowInputFinder Members
CelloSaaS.WorkFlow.Model Namespace


IWorkFlowInputFinder Members

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowInputFinder Members
IWorkFlowInputFinder Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | GetMappingObjects(List<(Of <<'(String>)>>), String) | Gets the mapping objects for given map ids and workflowId
Public method | GetMappingObjects(List<(Of <<'(String>)>>), String, String) | Gets the mapping objects for given map ids, workflowId and tenant id.

See Also

IWorkFlowInputFinder Interface
CelloSaaS.WorkFlow.Model Namespace


IWorkFlowInputFinder Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowInputFinder Methods
IWorkFlowInputFinder Interface See Also Send Feedback

Methods

 | Name | Description
Public method | GetMappingObjects(List<(Of <<'(String>)>>), String) | Gets the mapping objects for given map ids and workflowId
Public method | GetMappingObjects(List<(Of <<'(String>)>>), String, String) | Gets the mapping objects for given map ids, workflowId and tenant id.

See Also

IWorkFlowInputFinder Interface
CelloSaaS.WorkFlow.Model Namespace


IWorkFlowInputFinder.GetMappingObjects Method

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowInputFinder..::..GetMappingObjects Method
IWorkFlowInputFinder Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMappingObjects(List<(Of <<'(String>)>>), String) | Gets the mapping objects for given map ids and workflowId
Public method | GetMappingObjects(List<(Of <<'(String>)>>), String, String) | Gets the mapping objects for given map ids, workflowId and tenant id.

See Also

IWorkFlowInputFinder Interface
IWorkFlowInputFinder Members
CelloSaaS.WorkFlow.Model Namespace


IWorkFlowInputFinder.GetMappingObjects Method (List(String), String)

[image]

A Sandcastle Documented Class Library
IWorkFlowInputFinder..::..GetMappingObjects Method (List<(Of <(<'String>)>)>, String)
IWorkFlowInputFinder Interface See Also Send Feedback
Gets the mapping objects for given map ids and workflowId

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, IWorkflowInput> GetMappingObjects(
    List<string> mapIds,
    string workFlowId
)
Visual Basic
Function GetMappingObjects (
    mapIds As List(Of String),
    workFlowId As String
) As Dictionary(Of String, IWorkflowInput)
Visual C++
Dictionary<String^, IWorkflowInput^>^ GetMappingObjects(
    List<String^>^ mapIds,
    String^ workFlowId
)

Parameters

mapIds
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
The map ids.
workFlowId
Type: System..::..String
The work flow id.

Return Value

Type: Dictionary<(Of <(<'String, IWorkflowInput >)>)>

See Also

IWorkFlowInputFinder Interface
IWorkFlowInputFinder Members
GetMappingObjects Overload
CelloSaaS.WorkFlow.Model Namespace


IWorkFlowInputFinder.GetMappingObjects Method (List(String), String, String)

[image]

A Sandcastle Documented Class Library
IWorkFlowInputFinder..::..GetMappingObjects Method (List<(Of <(<'String>)>)>, String, String)
IWorkFlowInputFinder Interface See Also Send Feedback
Gets the mapping objects for given map ids, workflowId and tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, IWorkflowInput> GetMappingObjects(
    List<string> mapIds,
    string workFlowId,
    string tenantId
)
Visual Basic
Function GetMappingObjects (
    mapIds As List(Of String),
    workFlowId As String,
    tenantId As String
) As Dictionary(Of String, IWorkflowInput)
Visual C++
Dictionary<String^, IWorkflowInput^>^ GetMappingObjects(
    List<String^>^ mapIds,
    String^ workFlowId,
    String^ tenantId
)

Parameters

mapIds
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
The map ids.
workFlowId
Type: System..::..String
The work flow id.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: Dictionary<(Of <(<'String, IWorkflowInput >)>)>

See Also

IWorkFlowInputFinder Interface
IWorkFlowInputFinder Members
GetMappingObjects Overload
CelloSaaS.WorkFlow.Model Namespace


IWorkflowItemDefinition Interface

[image]

A Sandcastle Documented Class Library
IWorkflowItemDefinition Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowItemDefinition : IWFXMLSerializable
Visual Basic
Public Interface IWorkflowItemDefinition
    Inherits IWFXMLSerializable
Visual C++
public interface class IWorkflowItemDefinition : IWFXMLSerializable

See Also

IWorkflowItemDefinition Members
CelloSaaS.WorkFlow.Model Namespace


IWorkflowItemDefinition Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowItemDefinition Members
IWorkflowItemDefinition Interface Methods See Also Send Feedback

The IWorkflowItemDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

IWorkflowItemDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


IWorkflowItemDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowItemDefinition Methods
IWorkflowItemDefinition Interface See Also Send Feedback

The IWorkflowItemDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML. (Inherited from IWFXMLSerializable.)
Public method | SerailizeToXML | Serailizes to XML. (Inherited from IWFXMLSerializable.)

See Also

IWorkflowItemDefinition Interface
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition Class

[image]

A Sandcastle Documented Class Library
ManualTaskDefinition Class
Members See Also Send Feedback
This task is trigger by an user action. Does not automatically executed. Only the actors defined can executed this task

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ManualTaskDefinition : TaskDefinition
Visual Basic
<SerializableAttribute>
Public Class ManualTaskDefinition
    Inherits TaskDefinition
Visual C++
[SerializableAttribute]
public ref class ManualTaskDefinition : public TaskDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskDefinition
CelloSaaS.WorkFlow.Model..::..ManualTaskDefinition

See Also

ManualTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition Members

[image] [image]

A Sandcastle Documented Class Library
ManualTaskDefinition Members
ManualTaskDefinition Class Constructors Methods Properties See Also Send Feedback

The ManualTaskDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | ManualTaskDefinition | Initializes a new instance of the ManualTaskDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Overrides TaskDefinition..::..DeSerailizeFromXML(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Overrides TaskDefinition..::..SerailizeToXML()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | ActorDefinition |
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | Url |
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

ManualTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition Constructor

[image]

A Sandcastle Documented Class Library
ManualTaskDefinition Constructor
ManualTaskDefinition Class See Also Send Feedback
Initializes a new instance of the ManualTaskDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ManualTaskDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ManualTaskDefinition()

See Also

ManualTaskDefinition Class
ManualTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
ManualTaskDefinition Methods
ManualTaskDefinition Class See Also Send Feedback

The ManualTaskDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Overrides TaskDefinition..::..DeSerailizeFromXML(String).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Overrides TaskDefinition..::..SerailizeToXML()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ManualTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
ManualTaskDefinition..::..DeSerailizeFromXML Method
ManualTaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Overrides Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) override

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

ManualTaskDefinition Class
ManualTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
ManualTaskDefinition..::..SerailizeToXML Method
ManualTaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string SerailizeToXML()
Visual Basic
Public Overrides Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() override

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

ManualTaskDefinition Class
ManualTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
ManualTaskDefinition Properties
ManualTaskDefinition Class See Also Send Feedback

The ManualTaskDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | ActorDefinition |
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | Url |
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

ManualTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition.ActorDefinition Property

[image]

A Sandcastle Documented Class Library
ManualTaskDefinition..::..ActorDefinition Property
ManualTaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskActorDefinition ActorDefinition { get; set; }
Visual Basic
Public Property ActorDefinition As ITaskActorDefinition
    Get
    Set
Visual C++
public:
property ITaskActorDefinition^ ActorDefinition {
    ITaskActorDefinition^ get ();
    void set (ITaskActorDefinition^ value);
}

Property Value

Type: ITaskActorDefinition

See Also

ManualTaskDefinition Class
ManualTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ManualTaskDefinition.Url Property

[image]

A Sandcastle Documented Class Library
ManualTaskDefinition..::..Url Property
ManualTaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ManualTaskDefinition Class
ManualTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


ManualWorkflowTaskInstance Class

[image]

A Sandcastle Documented Class Library
ManualWorkflowTaskInstance Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class ManualWorkflowTaskInstance : WorkflowTaskInstance
Visual Basic
<SerializableAttribute>
Public Class ManualWorkflowTaskInstance
    Inherits WorkflowTaskInstance
Visual C++
[SerializableAttribute]
public ref class ManualWorkflowTaskInstance : public WorkflowTaskInstance

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowTaskInstance
CelloSaaS.WorkFlow.Model..::..ManualWorkflowTaskInstance

See Also

ManualWorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


ManualWorkflowTaskInstance Members

[image] [image]

A Sandcastle Documented Class Library
ManualWorkflowTaskInstance Members
ManualWorkflowTaskInstance Class Constructors Methods Properties See Also Send Feedback

The ManualWorkflowTaskInstance type exposes the following members.

Constructors

 | Name | Description
Public method | ManualWorkflowTaskInstance | Initializes a new instance of the ManualWorkflowTaskInstance class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id. (Inherited from WorkflowTaskInstance.)
Public property | Actors | Gets or sets the actors.
Public property | AffectedExecutionStatus | Gets or sets the affected execution status. (Inherited from WorkflowTaskInstance.)
Public property | AffectedOutComes | Gets or sets the affected out comes. (Inherited from WorkflowTaskInstance.)
Public property | CurrentExecutionStatus | Gets or sets the current execution status. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeCompleted | Gets or sets the date time completed. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeExpired | Gets or sets the date time expired. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeUpdated | Gets or sets the date time updated. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionOrder | Gets or sets the execution order. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionStatus | Gets or sets the execution status. (Inherited from WorkflowTaskInstance.)
Public property | Id | Gets or sets the id. (Inherited from WorkflowTaskInstance.)
Public property | InvokedTaskDefinitionRouterId | Gets or sets the invoked task definition router id. (Inherited from WorkflowTaskInstance.)
Public property | MapId | Gets or sets the map id. (Inherited from WorkflowTaskInstance.)
Public property | OutComes | Gets or sets the out comes. (Inherited from WorkflowTaskInstance.)
Public property | PreviousExecutionStatus | Gets or sets the previous execution status. (Inherited from WorkflowTaskInstance.)
Public property | StartTime | Gets or sets the start time. (Inherited from WorkflowTaskInstance.)
Public property | Task | Gets or sets the task. (Inherited from WorkflowTaskInstance.)
Public property | TaskDefinition | Gets the task definition. (Inherited from WorkflowTaskInstance.)
Public property | WFId | Gets or sets the WF id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowInstanceId | Gets or sets the work flow instance id. (Inherited from WorkflowTaskInstance.)

See Also

ManualWorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


ManualWorkflowTaskInstance Constructor

[image]

A Sandcastle Documented Class Library
ManualWorkflowTaskInstance Constructor
ManualWorkflowTaskInstance Class See Also Send Feedback
Initializes a new instance of the ManualWorkflowTaskInstance class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ManualWorkflowTaskInstance(
    Guid taskInstanceId,
    int execOrder
)
Visual Basic
Public Sub New (
    taskInstanceId As Guid,
    execOrder As Integer
)
Visual C++
public:
ManualWorkflowTaskInstance(
    Guid taskInstanceId,
    int execOrder
)

Parameters

taskInstanceId
Type: System..::..Guid
The task instance id.
execOrder
Type: System..::..Int32
The exec order.

See Also

ManualWorkflowTaskInstance Class
ManualWorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


ManualWorkflowTaskInstance Methods

[image] [image]

A Sandcastle Documented Class Library
ManualWorkflowTaskInstance Methods
ManualWorkflowTaskInstance Class See Also Send Feedback

The ManualWorkflowTaskInstance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ManualWorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


ManualWorkflowTaskInstance Properties

[image] [image]

A Sandcastle Documented Class Library
ManualWorkflowTaskInstance Properties
ManualWorkflowTaskInstance Class See Also Send Feedback

The ManualWorkflowTaskInstance type exposes the following members.

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id. (Inherited from WorkflowTaskInstance.)
Public property | Actors | Gets or sets the actors.
Public property | AffectedExecutionStatus | Gets or sets the affected execution status. (Inherited from WorkflowTaskInstance.)
Public property | AffectedOutComes | Gets or sets the affected out comes. (Inherited from WorkflowTaskInstance.)
Public property | CurrentExecutionStatus | Gets or sets the current execution status. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeCompleted | Gets or sets the date time completed. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeExpired | Gets or sets the date time expired. (Inherited from WorkflowTaskInstance.)
Public property | DateTimeUpdated | Gets or sets the date time updated. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionOrder | Gets or sets the execution order. (Inherited from WorkflowTaskInstance.)
Public property | ExecutionStatus | Gets or sets the execution status. (Inherited from WorkflowTaskInstance.)
Public property | Id | Gets or sets the id. (Inherited from WorkflowTaskInstance.)
Public property | InvokedTaskDefinitionRouterId | Gets or sets the invoked task definition router id. (Inherited from WorkflowTaskInstance.)
Public property | MapId | Gets or sets the map id. (Inherited from WorkflowTaskInstance.)
Public property | OutComes | Gets or sets the out comes. (Inherited from WorkflowTaskInstance.)
Public property | PreviousExecutionStatus | Gets or sets the previous execution status. (Inherited from WorkflowTaskInstance.)
Public property | StartTime | Gets or sets the start time. (Inherited from WorkflowTaskInstance.)
Public property | Task | Gets or sets the task. (Inherited from WorkflowTaskInstance.)
Public property | TaskDefinition | Gets the task definition. (Inherited from WorkflowTaskInstance.)
Public property | WFId | Gets or sets the WF id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id. (Inherited from WorkflowTaskInstance.)
Public property | WorkFlowInstanceId | Gets or sets the work flow instance id. (Inherited from WorkflowTaskInstance.)

See Also

ManualWorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


ManualWorkflowTaskInstance.Actors Property

[image]

A Sandcastle Documented Class Library
ManualWorkflowTaskInstance..::..Actors Property
ManualWorkflowTaskInstance Class See Also Send Feedback
Gets or sets the actors.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ITaskActor> Actors { get; set; }
Visual Basic
Public Property Actors As List(Of ITaskActor)
    Get
    Set
Visual C++
public:
property List<ITaskActor^>^ Actors {
    List<ITaskActor^>^ get ();
    void set (List<ITaskActor^>^ value);
}

Property Value

Type: List<(Of <(<' ITaskActor >)>)>
The actors.

See Also

ManualWorkflowTaskInstance Class
ManualWorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


MappedObjectKeyValue Class

[image]

A Sandcastle Documented Class Library
MappedObjectKeyValue Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class MappedObjectKeyValue
Visual Basic
Public Class MappedObjectKeyValue
Visual C++
public ref class MappedObjectKeyValue

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..MappedObjectKeyValue

See Also

MappedObjectKeyValue Members
CelloSaaS.WorkFlow.Model Namespace


MappedObjectKeyValue Members

[image] [image]

A Sandcastle Documented Class Library
MappedObjectKeyValue Members
MappedObjectKeyValue Class Constructors Methods See Also Send Feedback

The MappedObjectKeyValue type exposes the following members.

Constructors

 | Name | Description
Public method | MappedObjectKeyValue | Initializes a new instance of the MappedObjectKeyValue class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MappedObjectKeyValue Class
CelloSaaS.WorkFlow.Model Namespace


MappedObjectKeyValue Constructor

[image]

A Sandcastle Documented Class Library
MappedObjectKeyValue Constructor
MappedObjectKeyValue Class See Also Send Feedback
Initializes a new instance of the MappedObjectKeyValue class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public MappedObjectKeyValue()
Visual Basic
Public Sub New
Visual C++
public:
MappedObjectKeyValue()

See Also

MappedObjectKeyValue Class
MappedObjectKeyValue Members
CelloSaaS.WorkFlow.Model Namespace


MappedObjectKeyValue Methods

[image] [image]

A Sandcastle Documented Class Library
MappedObjectKeyValue Methods
MappedObjectKeyValue Class See Also Send Feedback

The MappedObjectKeyValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MappedObjectKeyValue Class
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition Class

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition Class
Members See Also Send Feedback
Role based manual task actor definition details

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoleBasedTaskActorDefinition : ITaskActorDefinition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class RoleBasedTaskActorDefinition
    Implements ITaskActorDefinition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class RoleBasedTaskActorDefinition : ITaskActorDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RoleBasedTaskActorDefinition

See Also

RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition Members

[image] [image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition Members
RoleBasedTaskActorDefinition Class Constructors Methods Properties See Also Send Feedback

The RoleBasedTaskActorDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | RoleBasedTaskActorDefinition | Initializes a new instance of the RoleBasedTaskActorDefinition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsRuntimeCalculated | Gets or sets a value indicating whether this instance is runtime calculated.
Public property | RoleNames | Gets or sets the List of role names.
Public property | Roles | Gets or sets the roles.
Public property | UserNames | Gets or sets the user names.

See Also

RoleBasedTaskActorDefinition Class
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition Constructor

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition Constructor
RoleBasedTaskActorDefinition Class See Also Send Feedback
Initializes a new instance of the RoleBasedTaskActorDefinition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoleBasedTaskActorDefinition()
Visual Basic
Public Sub New
Visual C++
public:
RoleBasedTaskActorDefinition()

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition Methods
RoleBasedTaskActorDefinition Class See Also Send Feedback

The RoleBasedTaskActorDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoleBasedTaskActorDefinition Class
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition..::..DeSerailizeFromXML Method
RoleBasedTaskActorDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition..::..SerailizeToXML Method
RoleBasedTaskActorDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition Properties
RoleBasedTaskActorDefinition Class See Also Send Feedback

The RoleBasedTaskActorDefinition type exposes the following members.

Properties

 | Name | Description
Public property | IsRuntimeCalculated | Gets or sets a value indicating whether this instance is runtime calculated.
Public property | RoleNames | Gets or sets the List of role names.
Public property | Roles | Gets or sets the roles.
Public property | UserNames | Gets or sets the user names.

See Also

RoleBasedTaskActorDefinition Class
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition.IsRuntimeCalculated Property

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition..::..IsRuntimeCalculated Property
RoleBasedTaskActorDefinition Class See Also Send Feedback
Gets or sets a value indicating whether this instance is runtime calculated.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsRuntimeCalculated { get; set; }
Visual Basic
Public Property IsRuntimeCalculated As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsRuntimeCalculated {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean
true if this instance is runtime calculated; otherwise, false.

Implements

ITaskActorDefinition..::..IsRuntimeCalculated

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition.RoleNames Property

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition..::..RoleNames Property
RoleBasedTaskActorDefinition Class See Also Send Feedback
Gets or sets the List of role names.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> RoleNames { get; set; }
Visual Basic
Public Property RoleNames As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ RoleNames {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The list of role names

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition.Roles Property

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition..::..Roles Property
RoleBasedTaskActorDefinition Class See Also Send Feedback
Gets or sets the roles.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> Roles { get; set; }
Visual Basic
Public Property Roles As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ Roles {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The roles.

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RoleBasedTaskActorDefinition.UserNames Property

[image]

A Sandcastle Documented Class Library
RoleBasedTaskActorDefinition..::..UserNames Property
RoleBasedTaskActorDefinition Class See Also Send Feedback
Gets or sets the user names.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> UserNames { get; set; }
Visual Basic
Public Property UserNames As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ UserNames {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The user names.

See Also

RoleBasedTaskActorDefinition Class
RoleBasedTaskActorDefinition Members
CelloSaaS.WorkFlow.Model Namespace


RouterType Enumeration

[image]

A Sandcastle Documented Class Library
RouterType Enumeration
See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum RouterType
Visual Basic
Public Enumeration RouterType
Visual C++
public enum class RouterType

Members

Member name | Value | Description
Default | 0 |
IfElse | 1 |

See Also

CelloSaaS.WorkFlow.Model Namespace


RouterViewModel Class

[image]

A Sandcastle Documented Class Library
RouterViewModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RouterViewModel
Visual Basic
<SerializableAttribute>
Public Class RouterViewModel
Visual C++
[SerializableAttribute]
public ref class RouterViewModel

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RouterViewModel

See Also

RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel Members

[image] [image]

A Sandcastle Documented Class Library
RouterViewModel Members
RouterViewModel Class Constructors Methods Properties See Also Send Feedback

The RouterViewModel type exposes the following members.

Constructors

 | Name | Description
Public method | RouterViewModel | Initializes a new instance of the RouterViewModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Conditions |
Public property | ElseOutputIds |
Public property | InputTaskIds |
Public property | IsVisible |
Public property | OutputTaskIds |
Public property | RouterId |
Public property | RouterName |
Public property | Type |
Public property | TypeString |
Public property | UIModel |

See Also

RouterViewModel Class
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel Constructor

[image]

A Sandcastle Documented Class Library
RouterViewModel Constructor
RouterViewModel Class See Also Send Feedback
Initializes a new instance of the RouterViewModel class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RouterViewModel()
Visual Basic
Public Sub New
Visual C++
public:
RouterViewModel()

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel Methods

[image] [image]

A Sandcastle Documented Class Library
RouterViewModel Methods
RouterViewModel Class See Also Send Feedback

The RouterViewModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RouterViewModel Class
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel Properties

[image] [image]

A Sandcastle Documented Class Library
RouterViewModel Properties
RouterViewModel Class See Also Send Feedback

The RouterViewModel type exposes the following members.

Properties

 | Name | Description
Public property | Conditions |
Public property | ElseOutputIds |
Public property | InputTaskIds |
Public property | IsVisible |
Public property | OutputTaskIds |
Public property | RouterId |
Public property | RouterName |
Public property | Type |
Public property | TypeString |
Public property | UIModel |

See Also

RouterViewModel Class
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.Conditions Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..Conditions Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] Conditions { get; set; }
Visual Basic
Public Property Conditions As String()
    Get
    Set
Visual C++
public:
property array<String^>^ Conditions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.ElseOutputIds Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..ElseOutputIds Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ElseOutputIds { get; set; }
Visual Basic
Public Property ElseOutputIds As String
    Get
    Set
Visual C++
public:
property String^ ElseOutputIds {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.InputTaskIds Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..InputTaskIds Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string InputTaskIds { get; set; }
Visual Basic
Public Property InputTaskIds As String
    Get
    Set
Visual C++
public:
property String^ InputTaskIds {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.IsVisible Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..IsVisible Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.OutputTaskIds Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..OutputTaskIds Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string OutputTaskIds { get; set; }
Visual Basic
Public Property OutputTaskIds As String
    Get
    Set
Visual C++
public:
property String^ OutputTaskIds {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.RouterId Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..RouterId Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid RouterId { get; set; }
Visual Basic
Public Property RouterId As Guid
    Get
    Set
Visual C++
public:
property Guid RouterId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.RouterName Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..RouterName Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RouterName { get; set; }
Visual Basic
Public Property RouterName As String
    Get
    Set
Visual C++
public:
property String^ RouterName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.Type Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..Type Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RouterType Type { get; set; }
Visual Basic
Public Property Type As RouterType
    Get
    Set
Visual C++
public:
property RouterType Type {
    RouterType get ();
    void set (RouterType value);
}

Property Value

Type: RouterType

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.TypeString Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..TypeString Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeString { get; set; }
Visual Basic
Public Property TypeString As String
    Get
    Set
Visual C++
public:
property String^ TypeString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RouterViewModel.UIModel Property

[image]

A Sandcastle Documented Class Library
RouterViewModel..::..UIModel Property
RouterViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFUIModel UIModel { get; set; }
Visual Basic
Public Property UIModel As WFUIModel
    Get
    Set
Visual C++
public:
property WFUIModel^ UIModel {
    WFUIModel^ get ();
    void set (WFUIModel^ value);
}

Property Value

Type: WFUIModel

See Also

RouterViewModel Class
RouterViewModel Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions Class

[image]

A Sandcastle Documented Class Library
RoutingConditions Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoutingConditions : IRoutingCondition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class RoutingConditions
    Implements IRoutingCondition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class RoutingConditions : IRoutingCondition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RoutingConditions

See Also

RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions Members

[image] [image]

A Sandcastle Documented Class Library
RoutingConditions Members
RoutingConditions Class Constructors Methods Properties See Also Send Feedback

The RoutingConditions type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditions | Initializes a new instance of the RoutingConditions class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition.
Public property | InputTaskIds |
Public property | OutputTaskIds | Gets or sets the output tasks.

See Also

RoutingConditions Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions Constructor

[image]

A Sandcastle Documented Class Library
RoutingConditions Constructor
RoutingConditions Class See Also Send Feedback
Initializes a new instance of the RoutingConditions class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoutingConditions()
Visual Basic
Public Sub New
Visual C++
public:
RoutingConditions()

See Also

RoutingConditions Class
RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions Methods

[image] [image]

A Sandcastle Documented Class Library
RoutingConditions Methods
RoutingConditions Class See Also Send Feedback

The RoutingConditions type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditions Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
RoutingConditions..::..DeSerailizeFromXML Method
RoutingConditions Class See Also Send Feedback
De-serailize itself from XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String
The XML.

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

RoutingConditions Class
RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
RoutingConditions..::..SerailizeToXML Method
RoutingConditions Class See Also Send Feedback
Serailizes to XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

RoutingConditions Class
RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions Properties

[image] [image]

A Sandcastle Documented Class Library
RoutingConditions Properties
RoutingConditions Class See Also Send Feedback

The RoutingConditions type exposes the following members.

Properties

 | Name | Description
Public property | Condition | Gets or sets the condition.
Public property | InputTaskIds |
Public property | OutputTaskIds | Gets or sets the output tasks.

See Also

RoutingConditions Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions.Condition Property

[image]

A Sandcastle Documented Class Library
RoutingConditions..::..Condition Property
RoutingConditions Class See Also Send Feedback
Gets or sets the condition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskCondition Condition { get; set; }
Visual Basic
Public Property Condition As ITaskCondition
    Get
    Set
Visual C++
public:
virtual property ITaskCondition^ Condition {
    ITaskCondition^ get () sealed;
    void set (ITaskCondition^ value) sealed;
}

Property Value

Type: ITaskCondition
The condition.

Implements

IRoutingCondition..::..Condition

See Also

RoutingConditions Class
RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions.InputTaskIds Property

[image]

A Sandcastle Documented Class Library
RoutingConditions..::..InputTaskIds Property
RoutingConditions Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Guid> InputTaskIds { get; set; }
Visual Basic
Public Property InputTaskIds As List(Of Guid)
    Get
    Set
Visual C++
public:
virtual property List<Guid>^ InputTaskIds {
    List<Guid>^ get () sealed;
    void set (List<Guid>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Guid>)>)>

Implements

IRoutingCondition..::..InputTaskIds

See Also

RoutingConditions Class
RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditions.OutputTaskIds Property

[image]

A Sandcastle Documented Class Library
RoutingConditions..::..OutputTaskIds Property
RoutingConditions Class See Also Send Feedback
Gets or sets the output tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<Guid> OutputTaskIds { get; set; }
Visual Basic
Public Property OutputTaskIds As List(Of Guid)
    Get
    Set
Visual C++
public:
virtual property List<Guid>^ OutputTaskIds {
    List<Guid>^ get () sealed;
    void set (List<Guid>^ value) sealed;
}

Property Value

Type: List<(Of <(<'Guid>)>)>
The output tasks.

Implements

IRoutingCondition..::..OutputTaskIds

See Also

RoutingConditions Class
RoutingConditions Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService Class

[image]

A Sandcastle Documented Class Library
RoutingConditionService Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class RoutingConditionService
Visual Basic
Public Class RoutingConditionService
Visual C++
public ref class RoutingConditionService

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RoutingConditionService

See Also

RoutingConditionService Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService Members

[image] [image]

A Sandcastle Documented Class Library
RoutingConditionService Members
RoutingConditionService Class Constructors Methods See Also Send Feedback

The RoutingConditionService type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditionService | Initializes a new instance of the RoutingConditionService class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EvaluateRoutingCondition | Evaluates the routing condition.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditionService Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService Constructor

[image]

A Sandcastle Documented Class Library
RoutingConditionService Constructor
RoutingConditionService Class See Also Send Feedback
Initializes a new instance of the RoutingConditionService class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoutingConditionService()
Visual Basic
Public Sub New
Visual C++
public:
RoutingConditionService()

See Also

RoutingConditionService Class
RoutingConditionService Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService Methods

[image] [image]

A Sandcastle Documented Class Library
RoutingConditionService Methods
RoutingConditionService Class See Also Send Feedback

The RoutingConditionService type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EvaluateRoutingCondition | Evaluates the routing condition.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditionService Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.EvaluateRoutingCondition Method

[image]

A Sandcastle Documented Class Library
RoutingConditionService..::..EvaluateRoutingCondition Method
RoutingConditionService Class See Also Send Feedback
Evaluates the routing condition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static List<Guid> EvaluateRoutingCondition(
    RoutingTable routingTable,
    WorkflowInstance instance
)
Visual Basic
Public Shared Function EvaluateRoutingCondition (
    routingTable As RoutingTable,
    instance As WorkflowInstance
) As List(Of Guid)
Visual C++
public:
static List<Guid>^ EvaluateRoutingCondition(
    RoutingTable^ routingTable,
    WorkflowInstance^ instance
)

Parameters

routingTable
Type: CelloSaaS.WorkFlow.Model..::..RoutingTable
instance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The instance.

Return Value

Type: List<(Of <(<'Guid>)>)>

See Also

RoutingConditionService Class
RoutingConditionService Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.ExecutionStatus Class

[image]

A Sandcastle Documented Class Library
RoutingConditionService..::..ExecutionStatus Class
RoutingConditionService Class Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class ExecutionStatus
Visual Basic
Public Class ExecutionStatus
Visual C++
public ref class ExecutionStatus

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RoutingConditionService..::..ExecutionStatus

See Also

RoutingConditionService..::..ExecutionStatus Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.ExecutionStatus Members

[image] [image]

A Sandcastle Documented Class Library
RoutingConditionService..::..ExecutionStatus Members
RoutingConditionService..::..ExecutionStatus Class Constructors Methods See Also Send Feedback

The RoutingConditionService..::..ExecutionStatus type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditionService..::..ExecutionStatus | Initializes a new instance of the RoutingConditionService..::..ExecutionStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditionService..::..ExecutionStatus Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.ExecutionStatus Constructor

[image]

A Sandcastle Documented Class Library
RoutingConditionService..::..ExecutionStatus Constructor
RoutingConditionService..::..ExecutionStatus Class See Also Send Feedback
Initializes a new instance of the RoutingConditionService..::..ExecutionStatus class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExecutionStatus()
Visual Basic
Public Sub New
Visual C++
public:
ExecutionStatus()

See Also

RoutingConditionService..::..ExecutionStatus Class
RoutingConditionService..::..ExecutionStatus Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.ExecutionStatus Methods

[image] [image]

A Sandcastle Documented Class Library
RoutingConditionService..::..ExecutionStatus Methods
RoutingConditionService..::..ExecutionStatus Class See Also Send Feedback

The RoutingConditionService..::..ExecutionStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditionService..::..ExecutionStatus Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.Outcome Class

[image]

A Sandcastle Documented Class Library
RoutingConditionService..::..Outcome Class
RoutingConditionService Class Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class Outcome
Visual Basic
Public Class Outcome
Visual C++
public ref class Outcome

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RoutingConditionService..::..Outcome

See Also

RoutingConditionService..::..Outcome Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.Outcome Members

[image] [image]

A Sandcastle Documented Class Library
RoutingConditionService..::..Outcome Members
RoutingConditionService..::..Outcome Class Constructors Methods See Also Send Feedback

The RoutingConditionService..::..Outcome type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditionService..::..Outcome | Initializes a new instance of the RoutingConditionService..::..Outcome class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditionService..::..Outcome Class
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.Outcome Constructor

[image]

A Sandcastle Documented Class Library
RoutingConditionService..::..Outcome Constructor
RoutingConditionService..::..Outcome Class See Also Send Feedback
Initializes a new instance of the RoutingConditionService..::..Outcome class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Outcome()
Visual Basic
Public Sub New
Visual C++
public:
Outcome()

See Also

RoutingConditionService..::..Outcome Class
RoutingConditionService..::..Outcome Members
CelloSaaS.WorkFlow.Model Namespace


RoutingConditionService.Outcome Methods

[image] [image]

A Sandcastle Documented Class Library
RoutingConditionService..::..Outcome Methods
RoutingConditionService..::..Outcome Class See Also Send Feedback

The RoutingConditionService..::..Outcome type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingConditionService..::..Outcome Class
CelloSaaS.WorkFlow.Model Namespace


RoutingTable Class

[image]

A Sandcastle Documented Class Library
RoutingTable Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class RoutingTable
Visual Basic
<SerializableAttribute>
Public Class RoutingTable
Visual C++
[SerializableAttribute]
public ref class RoutingTable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..RoutingTable

See Also

RoutingTable Members
CelloSaaS.WorkFlow.Model Namespace


RoutingTable Members

[image] [image]

A Sandcastle Documented Class Library
RoutingTable Members
RoutingTable Class Constructors Methods Properties See Also Send Feedback

The RoutingTable type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingTable | Initializes a new instance of the RoutingTable class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoutingConditions | Gets or sets the routing condition.

See Also

RoutingTable Class
CelloSaaS.WorkFlow.Model Namespace


RoutingTable Constructor

[image]

A Sandcastle Documented Class Library
RoutingTable Constructor
RoutingTable Class See Also Send Feedback
Initializes a new instance of the RoutingTable class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoutingTable()
Visual Basic
Public Sub New
Visual C++
public:
RoutingTable()

See Also

RoutingTable Class
RoutingTable Members
CelloSaaS.WorkFlow.Model Namespace


RoutingTable Methods

[image] [image]

A Sandcastle Documented Class Library
RoutingTable Methods
RoutingTable Class See Also Send Feedback

The RoutingTable type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingTable Class
CelloSaaS.WorkFlow.Model Namespace


RoutingTable Properties

[image] [image]

A Sandcastle Documented Class Library
RoutingTable Properties
RoutingTable Class See Also Send Feedback

The RoutingTable type exposes the following members.

Properties

 | Name | Description
Public property | RoutingConditions | Gets or sets the routing condition.

See Also

RoutingTable Class
CelloSaaS.WorkFlow.Model Namespace


RoutingTable.RoutingConditions Property

[image]

A Sandcastle Documented Class Library
RoutingTable..::..RoutingConditions Property
RoutingTable Class See Also Send Feedback
Gets or sets the routing condition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<IRoutingCondition> RoutingConditions { get; set; }
Visual Basic
Public Property RoutingConditions As List(Of IRoutingCondition)
    Get
    Set
Visual C++
public:
property List<IRoutingCondition^>^ RoutingConditions {
    List<IRoutingCondition^>^ get ();
    void set (List<IRoutingCondition^>^ value);
}

Property Value

Type: List<(Of <(<' IRoutingCondition >)>)>
The routing condition.

See Also

RoutingTable Class
RoutingTable Members
CelloSaaS.WorkFlow.Model Namespace


SourceType Enumeration

[image]

A Sandcastle Documented Class Library
SourceType Enumeration
See Also Send Feedback
Source Type of the Property Value

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum SourceType
Visual Basic
Public Enumeration SourceType
Visual C++
public enum class SourceType

Members

Member name | Value | Description
Static | 0 | The value will be given value.
xPath | 1 | The value will be taken from this xPath
Property | 2 | The value is taken from this Property

See Also

CelloSaaS.WorkFlow.Model Namespace


SPDefinition Class

[image]

A Sandcastle Documented Class Library
SPDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SPDefinition : IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class SPDefinition
    Implements IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class SPDefinition : IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..SPDefinition

See Also

SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition Members

[image] [image]

A Sandcastle Documented Class Library
SPDefinition Members
SPDefinition Class Constructors Methods Properties See Also Send Feedback

The SPDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | SPDefinition | Initializes a new instance of the SPDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString |
Public property | ConnectionStringName |
Public property | ExecutionType |
Public property | InputMappings |
Public property | SPName |

See Also

SPDefinition Class
CelloSaaS.WorkFlow.Model Namespace


SPDefinition Constructor

[image]

A Sandcastle Documented Class Library
SPDefinition Constructor
SPDefinition Class See Also Send Feedback
Initializes a new instance of the SPDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPDefinition()
Visual Basic
Public Sub New
Visual C++
public:
SPDefinition()

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
SPDefinition Methods
SPDefinition Class See Also Send Feedback

The SPDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SPDefinition Class
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
SPDefinition..::..DeSerailizeFromXML Method
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
SPDefinition..::..SerailizeToXML Method
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
SPDefinition Properties
SPDefinition Class See Also Send Feedback

The SPDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionString |
Public property | ConnectionStringName |
Public property | ExecutionType |
Public property | InputMappings |
Public property | SPName |

See Also

SPDefinition Class
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.ConnectionString Property

[image]

A Sandcastle Documented Class Library
SPDefinition..::..ConnectionString Property
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic
Public Property ConnectionString As String
    Get
    Set
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.ConnectionStringName Property

[image]

A Sandcastle Documented Class Library
SPDefinition..::..ConnectionStringName Property
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConnectionStringName { get; set; }
Visual Basic
Public Property ConnectionStringName As String
    Get
    Set
Visual C++
public:
property String^ ConnectionStringName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.ExecutionType Property

[image]

A Sandcastle Documented Class Library
SPDefinition..::..ExecutionType Property
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ExecuteType ExecutionType { get; set; }
Visual Basic
Public Property ExecutionType As ExecuteType
    Get
    Set
Visual C++
public:
property ExecuteType ExecutionType {
    ExecuteType get ();
    void set (ExecuteType value);
}

Property Value

Type: ExecuteType

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.InputMappings Property

[image]

A Sandcastle Documented Class Library
SPDefinition..::..InputMappings Property
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<SpInputMapping> InputMappings { get; set; }
Visual Basic
Public Property InputMappings As List(Of SpInputMapping)
    Get
    Set
Visual C++
public:
property List<SpInputMapping^>^ InputMappings {
    List<SpInputMapping^>^ get ();
    void set (List<SpInputMapping^>^ value);
}

Property Value

Type: List<(Of <(<' SpInputMapping >)>)>

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPDefinition.SPName Property

[image]

A Sandcastle Documented Class Library
SPDefinition..::..SPName Property
SPDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SPName { get; set; }
Visual Basic
Public Property SPName As String
    Get
    Set
Visual C++
public:
property String^ SPName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SPDefinition Class
SPDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Class

[image]

A Sandcastle Documented Class Library
SpInputMapping Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SpInputMapping : IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class SpInputMapping
    Implements IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class SpInputMapping : IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..SpInputMapping

See Also

SpInputMapping Members
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Members

[image] [image]

A Sandcastle Documented Class Library
SpInputMapping Members
SpInputMapping Class Constructors Methods Properties See Also Send Feedback

The SpInputMapping type exposes the following members.

Constructors

 | Name | Description
Public method | SpInputMapping()()()() | Initializes a new instance of the SpInputMapping class
Public method | SpInputMapping(String, ParameterDirection) | Initializes a new instance of the SpInputMapping class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction |
Public property | ParameterName |

See Also

SpInputMapping Class
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Constructor

[image] [image]

A Sandcastle Documented Class Library
SpInputMapping Constructor
SpInputMapping Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpInputMapping()()()() | Initializes a new instance of the SpInputMapping class
Public method | SpInputMapping(String, ParameterDirection) | Initializes a new instance of the SpInputMapping class

See Also

SpInputMapping Class
SpInputMapping Members
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Constructor

[image]

A Sandcastle Documented Class Library
SpInputMapping Constructor
SpInputMapping Class See Also Send Feedback
Initializes a new instance of the SpInputMapping class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SpInputMapping()
Visual Basic
Public Sub New
Visual C++
public:
SpInputMapping()

See Also

SpInputMapping Class
SpInputMapping Members
SpInputMapping Overload
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Constructor (String, ParameterDirection)

[image]

A Sandcastle Documented Class Library
SpInputMapping Constructor (String, ParameterDirection)
SpInputMapping Class See Also Send Feedback
Initializes a new instance of the SpInputMapping class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SpInputMapping(
    string parameterName,
    ParameterDirection direction
)
Visual Basic
Public Sub New (
    parameterName As String,
    direction As ParameterDirection
)
Visual C++
public:
SpInputMapping(
    String^ parameterName,
    ParameterDirection direction
)

Parameters

parameterName
Type: System..::..String
direction
Type: System.Data..::..ParameterDirection

See Also

SpInputMapping Class
SpInputMapping Members
SpInputMapping Overload
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Methods

[image] [image]

A Sandcastle Documented Class Library
SpInputMapping Methods
SpInputMapping Class See Also Send Feedback

The SpInputMapping type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpInputMapping Class
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
SpInputMapping..::..DeSerailizeFromXML Method
SpInputMapping Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

SpInputMapping Class
SpInputMapping Members
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
SpInputMapping..::..SerailizeToXML Method
SpInputMapping Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

SpInputMapping Class
SpInputMapping Members
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping Properties

[image] [image]

A Sandcastle Documented Class Library
SpInputMapping Properties
SpInputMapping Class See Also Send Feedback

The SpInputMapping type exposes the following members.

Properties

 | Name | Description
Public property | Direction |
Public property | ParameterName |

See Also

SpInputMapping Class
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping.Direction Property

[image]

A Sandcastle Documented Class Library
SpInputMapping..::..Direction Property
SpInputMapping Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ParameterDirection Direction { get; set; }
Visual Basic
Public Property Direction As ParameterDirection
    Get
    Set
Visual C++
public:
property ParameterDirection Direction {
    ParameterDirection get ();
    void set (ParameterDirection value);
}

Property Value

Type: ParameterDirection

See Also

SpInputMapping Class
SpInputMapping Members
CelloSaaS.WorkFlow.Model Namespace


SpInputMapping.ParameterName Property

[image]

A Sandcastle Documented Class Library
SpInputMapping..::..ParameterName Property
SpInputMapping Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ParameterName { get; set; }
Visual Basic
Public Property ParameterName As String
    Get
    Set
Visual C++
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

SpInputMapping Class
SpInputMapping Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Class

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SPTaskActivityDefinition : ITaskActivityDefinition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class SPTaskActivityDefinition
    Implements ITaskActivityDefinition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class SPTaskActivityDefinition : ITaskActivityDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..SPTaskActivityDefinition

See Also

SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Members
SPTaskActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The SPTaskActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | SPTaskActivityDefinition()()()() | Initializes a new instance of the SPTaskActivityDefinition class
Public method | SPTaskActivityDefinition(String, String) | Initializes a new instance of the SPTaskActivityDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly |
Public property | FullyQualifiedType |
Public property | Properties |
Public property | SpDefinition |

See Also

SPTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Constructor

[image] [image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Constructor
SPTaskActivityDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SPTaskActivityDefinition()()()() | Initializes a new instance of the SPTaskActivityDefinition class
Public method | SPTaskActivityDefinition(String, String) | Initializes a new instance of the SPTaskActivityDefinition class

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Constructor
SPTaskActivityDefinition Class See Also Send Feedback
Initializes a new instance of the SPTaskActivityDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPTaskActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
SPTaskActivityDefinition()

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
SPTaskActivityDefinition Overload
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Constructor (String, String)

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Constructor (String, String)
SPTaskActivityDefinition Class See Also Send Feedback
Initializes a new instance of the SPTaskActivityDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPTaskActivityDefinition(
    string typeName,
    string assemblyName
)
Visual Basic
Public Sub New (
    typeName As String,
    assemblyName As String
)
Visual C++
public:
SPTaskActivityDefinition(
    String^ typeName,
    String^ assemblyName
)

Parameters

typeName
Type: System..::..String
assemblyName
Type: System..::..String

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
SPTaskActivityDefinition Overload
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Methods
SPTaskActivityDefinition Class See Also Send Feedback

The SPTaskActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SPTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition..::..DeSerailizeFromXML Method
SPTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition..::..SerailizeToXML Method
SPTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition Properties
SPTaskActivityDefinition Class See Also Send Feedback

The SPTaskActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly |
Public property | FullyQualifiedType |
Public property | Properties |
Public property | SpDefinition |

See Also

SPTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition.Assembly Property

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition..::..Assembly Property
SPTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Assembly { get; set; }
Visual Basic
Public Property Assembly As String
    Get
    Set
Visual C++
public:
virtual property String^ Assembly {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ITaskActivityDefinition..::..Assembly

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition.FullyQualifiedType Property

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition..::..FullyQualifiedType Property
SPTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FullyQualifiedType { get; set; }
Visual Basic
Public Property FullyQualifiedType As String
    Get
    Set
Visual C++
public:
virtual property String^ FullyQualifiedType {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ITaskActivityDefinition..::..FullyQualifiedType

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition.Properties Property

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition..::..Properties Property
SPTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, ActivityProperty> Properties { get; set; }
Visual Basic
Public Property Properties As Dictionary(Of String, ActivityProperty)
    Get
    Set
Visual C++
public:
virtual property Dictionary<String^, ActivityProperty^>^ Properties {
    Dictionary<String^, ActivityProperty^>^ get () sealed;
    void set (Dictionary<String^, ActivityProperty^>^ value) sealed;
}

Property Value

Type: Dictionary<(Of <(<'String, ActivityProperty >)>)>

Implements

ITaskActivityDefinition..::..Properties

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskActivityDefinition.SpDefinition Property

[image]

A Sandcastle Documented Class Library
SPTaskActivityDefinition..::..SpDefinition Property
SPTaskActivityDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPDefinition SpDefinition { get; set; }
Visual Basic
Public Property SpDefinition As SPDefinition
    Get
    Set
Visual C++
public:
property SPDefinition^ SpDefinition {
    SPDefinition^ get ();
    void set (SPDefinition^ value);
}

Property Value

Type: SPDefinition

See Also

SPTaskActivityDefinition Class
SPTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Class

[image]

A Sandcastle Documented Class Library
SPTaskCondition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class SPTaskCondition : ITaskCondition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class SPTaskCondition
    Implements ITaskCondition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class SPTaskCondition : ITaskCondition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..SPTaskCondition

See Also

SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Members

[image] [image]

A Sandcastle Documented Class Library
SPTaskCondition Members
SPTaskCondition Class Constructors Methods Properties See Also Send Feedback

The SPTaskCondition type exposes the following members.

Constructors

 | Name | Description
Public method | SPTaskCondition()()()() | Initializes a new instance of the SPTaskCondition class.
Public method | SPTaskCondition(String) | Initializes a new instance of the SPTaskCondition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | SpDefinition | Gets or sets the sp definition.

See Also

SPTaskCondition Class
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Constructor

[image] [image]

A Sandcastle Documented Class Library
SPTaskCondition Constructor
SPTaskCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SPTaskCondition()()()() | Initializes a new instance of the SPTaskCondition class.
Public method | SPTaskCondition(String) | Initializes a new instance of the SPTaskCondition class.

See Also

SPTaskCondition Class
SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Constructor

[image]

A Sandcastle Documented Class Library
SPTaskCondition Constructor
SPTaskCondition Class See Also Send Feedback
Initializes a new instance of the SPTaskCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPTaskCondition()
Visual Basic
Public Sub New
Visual C++
public:
SPTaskCondition()

See Also

SPTaskCondition Class
SPTaskCondition Members
SPTaskCondition Overload
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Constructor (String)

[image]

A Sandcastle Documented Class Library
SPTaskCondition Constructor (String)
SPTaskCondition Class See Also Send Feedback
Initializes a new instance of the SPTaskCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPTaskCondition(
    string spName
)
Visual Basic
Public Sub New (
    spName As String
)
Visual C++
public:
SPTaskCondition(
    String^ spName
)

Parameters

spName
Type: System..::..String
Name of the sp.

See Also

SPTaskCondition Class
SPTaskCondition Members
SPTaskCondition Overload
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Methods

[image] [image]

A Sandcastle Documented Class Library
SPTaskCondition Methods
SPTaskCondition Class See Also Send Feedback

The SPTaskCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SPTaskCondition Class
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
SPTaskCondition..::..DeSerailizeFromXML Method
SPTaskCondition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

SPTaskCondition Class
SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition.Evaluate Method

[image]

A Sandcastle Documented Class Library
SPTaskCondition..::..Evaluate Method
SPTaskCondition Class See Also Send Feedback
Evaluates the specified work flow instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Evaluate(
    WorkflowInstance workFlowInstance
)
Visual Basic
Public Function Evaluate (
    workFlowInstance As WorkflowInstance
) As Boolean
Visual C++
public:
virtual bool Evaluate(
    WorkflowInstance^ workFlowInstance
) sealed

Parameters

workFlowInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The work flow instance.

Return Value

Type: Boolean

Implements

ITaskCondition..::..Evaluate(WorkflowInstance)

See Also

SPTaskCondition Class
SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
SPTaskCondition..::..SerailizeToXML Method
SPTaskCondition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

SPTaskCondition Class
SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition Properties

[image] [image]

A Sandcastle Documented Class Library
SPTaskCondition Properties
SPTaskCondition Class See Also Send Feedback

The SPTaskCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | SpDefinition | Gets or sets the sp definition.

See Also

SPTaskCondition Class
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition.ConditionExpression Property

[image]

A Sandcastle Documented Class Library
SPTaskCondition..::..ConditionExpression Property
SPTaskCondition Class See Also Send Feedback
Gets or sets the condition expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConditionExpression { get; set; }
Visual Basic
Public Property ConditionExpression As String
    Get
    Set
Visual C++
public:
virtual property String^ ConditionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The condition expression.

Implements

ITaskCondition..::..ConditionExpression

See Also

SPTaskCondition Class
SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


SPTaskCondition.SpDefinition Property

[image]

A Sandcastle Documented Class Library
SPTaskCondition..::..SpDefinition Property
SPTaskCondition Class See Also Send Feedback
Gets or sets the sp definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public SPDefinition SpDefinition { get; set; }
Visual Basic
Public Property SpDefinition As SPDefinition
    Get
    Set
Visual C++
public:
property SPDefinition^ SpDefinition {
    SPDefinition^ get ();
    void set (SPDefinition^ value);
}

Property Value

Type: SPDefinition
The sp definition.

See Also

SPTaskCondition Class
SPTaskCondition Members
CelloSaaS.WorkFlow.Model Namespace


StartTaskActivityDefinition Class

[image]

A Sandcastle Documented Class Library
StartTaskActivityDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class StartTaskActivityDefinition : DLLTaskActivityDefinition
Visual Basic
<SerializableAttribute>
Public Class StartTaskActivityDefinition
    Inherits DLLTaskActivityDefinition
Visual C++
[SerializableAttribute]
public ref class StartTaskActivityDefinition : public DLLTaskActivityDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..DLLTaskActivityDefinition
CelloSaaS.WorkFlow.Model..::..StartTaskActivityDefinition

See Also

StartTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


StartTaskActivityDefinition Members

[image] [image]

A Sandcastle Documented Class Library
StartTaskActivityDefinition Members
StartTaskActivityDefinition Class Constructors Methods Properties See Also Send Feedback

The StartTaskActivityDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | StartTaskActivityDefinition | Initializes a new instance of the StartTaskActivityDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

StartTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


StartTaskActivityDefinition Constructor

[image]

A Sandcastle Documented Class Library
StartTaskActivityDefinition Constructor
StartTaskActivityDefinition Class See Also Send Feedback
Initializes a new instance of the StartTaskActivityDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StartTaskActivityDefinition()
Visual Basic
Public Sub New
Visual C++
public:
StartTaskActivityDefinition()

See Also

StartTaskActivityDefinition Class
StartTaskActivityDefinition Members
CelloSaaS.WorkFlow.Model Namespace


StartTaskActivityDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
StartTaskActivityDefinition Methods
StartTaskActivityDefinition Class See Also Send Feedback

The StartTaskActivityDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from DLLTaskActivityDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from DLLTaskActivityDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StartTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


StartTaskActivityDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
StartTaskActivityDefinition Properties
StartTaskActivityDefinition Class See Also Send Feedback

The StartTaskActivityDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Assembly | (Inherited from DLLTaskActivityDefinition.)
Public property | FullyQualifiedType | (Inherited from DLLTaskActivityDefinition.)
Public property | Properties | (Inherited from DLLTaskActivityDefinition.)

See Also

StartTaskActivityDefinition Class
CelloSaaS.WorkFlow.Model Namespace


StartTaskDefinition Class

[image]

A Sandcastle Documented Class Library
StartTaskDefinition Class
Members See Also Send Feedback
This is the start task of any workflow

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class StartTaskDefinition : TaskDefinition
Visual Basic
<SerializableAttribute>
Public Class StartTaskDefinition
    Inherits TaskDefinition
Visual C++
[SerializableAttribute]
public ref class StartTaskDefinition : public TaskDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskDefinition
CelloSaaS.WorkFlow.Model..::..StartTaskDefinition

See Also

StartTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


StartTaskDefinition Members

[image] [image]

A Sandcastle Documented Class Library
StartTaskDefinition Members
StartTaskDefinition Class Constructors Methods Properties See Also Send Feedback

The StartTaskDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | StartTaskDefinition | Initializes a new instance of the StartTaskDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from TaskDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from TaskDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

StartTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


StartTaskDefinition Constructor

[image]

A Sandcastle Documented Class Library
StartTaskDefinition Constructor
StartTaskDefinition Class See Also Send Feedback
Initializes a new instance of the StartTaskDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public StartTaskDefinition()
Visual Basic
Public Sub New
Visual C++
public:
StartTaskDefinition()

See Also

StartTaskDefinition Class
StartTaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


StartTaskDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
StartTaskDefinition Methods
StartTaskDefinition Class See Also Send Feedback

The StartTaskDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | (Inherited from TaskDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | (Inherited from TaskDefinition.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StartTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


StartTaskDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
StartTaskDefinition Properties
StartTaskDefinition Class See Also Send Feedback

The StartTaskDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ActivityProperties | (Inherited from TaskDefinition.)
Public property | AssemblyName | (Inherited from TaskDefinition.)
Public property | CreatedBy | (Inherited from TaskDefinition.)
Public property | CreatedOn | (Inherited from TaskDefinition.)
Public property | Ordinal | (Inherited from TaskDefinition.)
Public property | TaskActivityDefinition | (Inherited from TaskDefinition.)
Public property | TaskCode | (Inherited from TaskDefinition.)
Public property | TaskConditionDefinition | (Inherited from TaskDefinition.)
Public property | TaskId | (Inherited from TaskDefinition.)
Public property | TaskName | (Inherited from TaskDefinition.)
Public property | TypeName | (Inherited from TaskDefinition.)
Public property | UpdatedBy | (Inherited from TaskDefinition.)
Public property | UpdatedOn | (Inherited from TaskDefinition.)
Public property | WorkFlowDefinitionId | (Inherited from TaskDefinition.)

See Also

StartTaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskActor Class

[image]

A Sandcastle Documented Class Library
TaskActor Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskActor : ITaskActor
Visual Basic
<SerializableAttribute>
Public Class TaskActor
    Implements ITaskActor
Visual C++
[SerializableAttribute]
public ref class TaskActor : ITaskActor

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskActor

See Also

TaskActor Members
CelloSaaS.WorkFlow.Model Namespace


TaskActor Members

[image] [image]

A Sandcastle Documented Class Library
TaskActor Members
TaskActor Class Constructors Methods Properties See Also Send Feedback

The TaskActor type exposes the following members.

Constructors

 | Name | Description
Public method | TaskActor | Initializes a new instance of the TaskActor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserId | Gets or sets the user id.

See Also

TaskActor Class
CelloSaaS.WorkFlow.Model Namespace


TaskActor Constructor

[image]

A Sandcastle Documented Class Library
TaskActor Constructor
TaskActor Class See Also Send Feedback
Initializes a new instance of the TaskActor class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskActor()
Visual Basic
Public Sub New
Visual C++
public:
TaskActor()

See Also

TaskActor Class
TaskActor Members
CelloSaaS.WorkFlow.Model Namespace


TaskActor Methods

[image] [image]

A Sandcastle Documented Class Library
TaskActor Methods
TaskActor Class See Also Send Feedback

The TaskActor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskActor Class
CelloSaaS.WorkFlow.Model Namespace


TaskActor.GetObjectData Method

[image]

A Sandcastle Documented Class Library
TaskActor..::..GetObjectData Method
TaskActor Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
Visual C++
public:
void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

TaskActor Class
TaskActor Members
CelloSaaS.WorkFlow.Model Namespace


TaskActor Properties

[image] [image]

A Sandcastle Documented Class Library
TaskActor Properties
TaskActor Class See Also Send Feedback

The TaskActor type exposes the following members.

Properties

 | Name | Description
Public property | UserId | Gets or sets the user id.

See Also

TaskActor Class
CelloSaaS.WorkFlow.Model Namespace


TaskActor.UserId Property

[image]

A Sandcastle Documented Class Library
TaskActor..::..UserId Property
TaskActor Class See Also Send Feedback
Gets or sets the user id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserId { get; set; }
Visual Basic
Public Property UserId As String
    Get
    Set
Visual C++
public:
virtual property String^ UserId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The user id.

Implements

ITaskActor..::..UserId

See Also

TaskActor Class
TaskActor Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel Class

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskActorDefViewModel
Visual Basic
<SerializableAttribute>
Public Class TaskActorDefViewModel
Visual C++
[SerializableAttribute]
public ref class TaskActorDefViewModel

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskActorDefViewModel

See Also

TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel Members

[image] [image]

A Sandcastle Documented Class Library
TaskActorDefViewModel Members
TaskActorDefViewModel Class Constructors Methods Properties See Also Send Feedback

The TaskActorDefViewModel type exposes the following members.

Constructors

 | Name | Description
Public method | TaskActorDefViewModel | Initializes a new instance of the TaskActorDefViewModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsRuntimeCalculated |
Public property | RoleNames |
Public property | Roles |
Public property | Url |
Public property | UserNames |

See Also

TaskActorDefViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel Constructor

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel Constructor
TaskActorDefViewModel Class See Also Send Feedback
Initializes a new instance of the TaskActorDefViewModel class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskActorDefViewModel()
Visual Basic
Public Sub New
Visual C++
public:
TaskActorDefViewModel()

See Also

TaskActorDefViewModel Class
TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel Methods

[image] [image]

A Sandcastle Documented Class Library
TaskActorDefViewModel Methods
TaskActorDefViewModel Class See Also Send Feedback

The TaskActorDefViewModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskActorDefViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel Properties

[image] [image]

A Sandcastle Documented Class Library
TaskActorDefViewModel Properties
TaskActorDefViewModel Class See Also Send Feedback

The TaskActorDefViewModel type exposes the following members.

Properties

 | Name | Description
Public property | IsRuntimeCalculated |
Public property | RoleNames |
Public property | Roles |
Public property | Url |
Public property | UserNames |

See Also

TaskActorDefViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel.IsRuntimeCalculated Property

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel..::..IsRuntimeCalculated Property
TaskActorDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsRuntimeCalculated { get; set; }
Visual Basic
Public Property IsRuntimeCalculated As Boolean
    Get
    Set
Visual C++
public:
property bool IsRuntimeCalculated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TaskActorDefViewModel Class
TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel.RoleNames Property

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel..::..RoleNames Property
TaskActorDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RoleNames { get; set; }
Visual Basic
Public Property RoleNames As String
    Get
    Set
Visual C++
public:
property String^ RoleNames {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskActorDefViewModel Class
TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel.Roles Property

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel..::..Roles Property
TaskActorDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Roles { get; set; }
Visual Basic
Public Property Roles As String
    Get
    Set
Visual C++
public:
property String^ Roles {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskActorDefViewModel Class
TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel.Url Property

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel..::..Url Property
TaskActorDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Url { get; set; }
Visual Basic
Public Property Url As String
    Get
    Set
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskActorDefViewModel Class
TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskActorDefViewModel.UserNames Property

[image]

A Sandcastle Documented Class Library
TaskActorDefViewModel..::..UserNames Property
TaskActorDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UserNames { get; set; }
Visual Basic
Public Property UserNames As String
    Get
    Set
Visual C++
public:
property String^ UserNames {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskActorDefViewModel Class
TaskActorDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition Class

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskConditionDefinition : ITaskConditionDefinition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class TaskConditionDefinition
    Implements ITaskConditionDefinition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class TaskConditionDefinition : ITaskConditionDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskConditionDefinition

See Also

TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition Members

[image] [image]

A Sandcastle Documented Class Library
TaskConditionDefinition Members
TaskConditionDefinition Class Constructors Methods Properties See Also Send Feedback

The TaskConditionDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | TaskConditionDefinition | Initializes a new instance of the TaskConditionDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompleteConditions |
Public property | ExpireConditions |
Public property | OverrideConditions |
Public property | SkipConditions |
Public property | StartConditions |

See Also

TaskConditionDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition Constructor

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition Constructor
TaskConditionDefinition Class See Also Send Feedback
Initializes a new instance of the TaskConditionDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskConditionDefinition()
Visual Basic
Public Sub New
Visual C++
public:
TaskConditionDefinition()

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
TaskConditionDefinition Methods
TaskConditionDefinition Class See Also Send Feedback

The TaskConditionDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskConditionDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..DeSerailizeFromXML Method
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..SerailizeToXML Method
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
TaskConditionDefinition Properties
TaskConditionDefinition Class See Also Send Feedback

The TaskConditionDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CompleteConditions |
Public property | ExpireConditions |
Public property | OverrideConditions |
Public property | SkipConditions |
Public property | StartConditions |

See Also

TaskConditionDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.CompleteConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..CompleteConditions Property
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ITaskCondition> CompleteConditions { get; set; }
Visual Basic
Public Property CompleteConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
public:
virtual property List<ITaskCondition^>^ CompleteConditions {
    List<ITaskCondition^>^ get () sealed;
    void set (List<ITaskCondition^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

Implements

ITaskConditionDefinition..::..CompleteConditions

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.ExpireConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..ExpireConditions Property
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ITaskCondition> ExpireConditions { get; set; }
Visual Basic
Public Property ExpireConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
public:
virtual property List<ITaskCondition^>^ ExpireConditions {
    List<ITaskCondition^>^ get () sealed;
    void set (List<ITaskCondition^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

Implements

ITaskConditionDefinition..::..ExpireConditions

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.OverrideConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..OverrideConditions Property
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ITaskCondition> OverrideConditions { get; set; }
Visual Basic
Public Property OverrideConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
public:
virtual property List<ITaskCondition^>^ OverrideConditions {
    List<ITaskCondition^>^ get () sealed;
    void set (List<ITaskCondition^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

Implements

ITaskConditionDefinition..::..OverrideConditions

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.SkipConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..SkipConditions Property
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ITaskCondition> SkipConditions { get; set; }
Visual Basic
Public Property SkipConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
public:
virtual property List<ITaskCondition^>^ SkipConditions {
    List<ITaskCondition^>^ get () sealed;
    void set (List<ITaskCondition^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

Implements

ITaskConditionDefinition..::..SkipConditions

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionDefinition.StartConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionDefinition..::..StartConditions Property
TaskConditionDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<ITaskCondition> StartConditions { get; set; }
Visual Basic
Public Property StartConditions As List(Of ITaskCondition)
    Get
    Set
Visual C++
public:
virtual property List<ITaskCondition^>^ StartConditions {
    List<ITaskCondition^>^ get () sealed;
    void set (List<ITaskCondition^>^ value) sealed;
}

Property Value

Type: List<(Of <(<' ITaskCondition >)>)>

Implements

ITaskConditionDefinition..::..StartConditions

See Also

TaskConditionDefinition Class
TaskConditionDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel Class

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskConditionsViewModel
Visual Basic
<SerializableAttribute>
Public Class TaskConditionsViewModel
Visual C++
[SerializableAttribute]
public ref class TaskConditionsViewModel

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskConditionsViewModel

See Also

TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel Members

[image] [image]

A Sandcastle Documented Class Library
TaskConditionsViewModel Members
TaskConditionsViewModel Class Constructors Methods Properties See Also Send Feedback

The TaskConditionsViewModel type exposes the following members.

Constructors

 | Name | Description
Public method | TaskConditionsViewModel | Initializes a new instance of the TaskConditionsViewModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompleteConditions |
Public property | ExpireConditions |
Public property | OverrideConditions |
Public property | SkipConditions |
Public property | StartConditions |

See Also

TaskConditionsViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel Constructor

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel Constructor
TaskConditionsViewModel Class See Also Send Feedback
Initializes a new instance of the TaskConditionsViewModel class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskConditionsViewModel()
Visual Basic
Public Sub New
Visual C++
public:
TaskConditionsViewModel()

See Also

TaskConditionsViewModel Class
TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel Methods

[image] [image]

A Sandcastle Documented Class Library
TaskConditionsViewModel Methods
TaskConditionsViewModel Class See Also Send Feedback

The TaskConditionsViewModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskConditionsViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel Properties

[image] [image]

A Sandcastle Documented Class Library
TaskConditionsViewModel Properties
TaskConditionsViewModel Class See Also Send Feedback

The TaskConditionsViewModel type exposes the following members.

Properties

 | Name | Description
Public property | CompleteConditions |
Public property | ExpireConditions |
Public property | OverrideConditions |
Public property | SkipConditions |
Public property | StartConditions |

See Also

TaskConditionsViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel.CompleteConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel..::..CompleteConditions Property
TaskConditionsViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] CompleteConditions { get; set; }
Visual Basic
Public Property CompleteConditions As String()
    Get
    Set
Visual C++
public:
property array<String^>^ CompleteConditions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TaskConditionsViewModel Class
TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel.ExpireConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel..::..ExpireConditions Property
TaskConditionsViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] ExpireConditions { get; set; }
Visual Basic
Public Property ExpireConditions As String()
    Get
    Set
Visual C++
public:
property array<String^>^ ExpireConditions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TaskConditionsViewModel Class
TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel.OverrideConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel..::..OverrideConditions Property
TaskConditionsViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] OverrideConditions { get; set; }
Visual Basic
Public Property OverrideConditions As String()
    Get
    Set
Visual C++
public:
property array<String^>^ OverrideConditions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TaskConditionsViewModel Class
TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel.SkipConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel..::..SkipConditions Property
TaskConditionsViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] SkipConditions { get; set; }
Visual Basic
Public Property SkipConditions As String()
    Get
    Set
Visual C++
public:
property array<String^>^ SkipConditions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TaskConditionsViewModel Class
TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskConditionsViewModel.StartConditions Property

[image]

A Sandcastle Documented Class Library
TaskConditionsViewModel..::..StartConditions Property
TaskConditionsViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string[] StartConditions { get; set; }
Visual Basic
Public Property StartConditions As String()
    Get
    Set
Visual C++
public:
property array<String^>^ StartConditions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: array<String>[]()[][]

See Also

TaskConditionsViewModel Class
TaskConditionsViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition Class

[image]

A Sandcastle Documented Class Library
TaskDefinition Class
Members See Also Send Feedback
Defines the tasks properties such as task name, task code, conditions, activity definitions

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskDefinition : IWorkflowItemDefinition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class TaskDefinition
    Implements IWorkflowItemDefinition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class TaskDefinition : IWorkflowItemDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskDefinition
CelloSaaS.WorkFlow.Model..::..AutoTaskDefinition
CelloSaaS.WorkFlow.Model..::..CloseTaskDefinition
CelloSaaS.WorkFlow.Model..::..ManualTaskDefinition
CelloSaaS.WorkFlow.Model..::..StartTaskDefinition

See Also

TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition Members

[image] [image]

A Sandcastle Documented Class Library
TaskDefinition Members
TaskDefinition Class Constructors Methods Properties See Also Send Feedback

The TaskDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | TaskDefinition | Initializes a new instance of the TaskDefinition class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityProperties |
Public property | AssemblyName |
Public property | CreatedBy |
Public property | CreatedOn |
Public property | Ordinal |
Public property | TaskActivityDefinition |
Public property | TaskCode |
Public property | TaskConditionDefinition |
Public property | TaskId |
Public property | TaskName |
Public property | TypeName |
Public property | UpdatedBy |
Public property | UpdatedOn |
Public property | WorkFlowDefinitionId |

See Also

TaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition Constructor

[image]

A Sandcastle Documented Class Library
TaskDefinition Constructor
TaskDefinition Class See Also Send Feedback
Initializes a new instance of the TaskDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskDefinition()
Visual Basic
Public Sub New
Visual C++
public:
TaskDefinition()

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
TaskDefinition Methods
TaskDefinition Class See Also Send Feedback

The TaskDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..DeSerailizeFromXML Method
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Overridable Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
)

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..SerailizeToXML Method
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual string SerailizeToXML()
Visual Basic
Public Overridable Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML()

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
TaskDefinition Properties
TaskDefinition Class See Also Send Feedback

The TaskDefinition type exposes the following members.

Properties

 | Name | Description
Public property | ActivityProperties |
Public property | AssemblyName |
Public property | CreatedBy |
Public property | CreatedOn |
Public property | Ordinal |
Public property | TaskActivityDefinition |
Public property | TaskCode |
Public property | TaskConditionDefinition |
Public property | TaskId |
Public property | TaskName |
Public property | TypeName |
Public property | UpdatedBy |
Public property | UpdatedOn |
Public property | WorkFlowDefinitionId |

See Also

TaskDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.ActivityProperties Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..ActivityProperties Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, ActivityProperty> ActivityProperties { get; set; }
Visual Basic
Public Property ActivityProperties As Dictionary(Of String, ActivityProperty)
    Get
    Set
Visual C++
public:
property Dictionary<String^, ActivityProperty^>^ ActivityProperties {
    Dictionary<String^, ActivityProperty^>^ get ();
    void set (Dictionary<String^, ActivityProperty^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, ActivityProperty >)>)>

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.AssemblyName Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..AssemblyName Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..CreatedBy Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..CreatedOn Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As String
    Get
    Set
Visual C++
public:
property String^ CreatedOn {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.Ordinal Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..Ordinal Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Ordinal { get; set; }
Visual Basic
Public Property Ordinal As Integer
    Get
    Set
Visual C++
public:
property int Ordinal {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.TaskActivityDefinition Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..TaskActivityDefinition Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskActivityDefinition TaskActivityDefinition { get; set; }
Visual Basic
Public Property TaskActivityDefinition As ITaskActivityDefinition
    Get
    Set
Visual C++
public:
property ITaskActivityDefinition^ TaskActivityDefinition {
    ITaskActivityDefinition^ get ();
    void set (ITaskActivityDefinition^ value);
}

Property Value

Type: ITaskActivityDefinition

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.TaskCode Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..TaskCode Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskCode { get; set; }
Visual Basic
Public Property TaskCode As String
    Get
    Set
Visual C++
public:
property String^ TaskCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.TaskConditionDefinition Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..TaskConditionDefinition Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ITaskConditionDefinition TaskConditionDefinition { get; set; }
Visual Basic
Public Property TaskConditionDefinition As ITaskConditionDefinition
    Get
    Set
Visual C++
public:
property ITaskConditionDefinition^ TaskConditionDefinition {
    ITaskConditionDefinition^ get ();
    void set (ITaskConditionDefinition^ value);
}

Property Value

Type: ITaskConditionDefinition

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.TaskId Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..TaskId Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TaskId { get; set; }
Visual Basic
Public Property TaskId As Guid
    Get
    Set
Visual C++
public:
property Guid TaskId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.TaskName Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..TaskName Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskName { get; set; }
Visual Basic
Public Property TaskName As String
    Get
    Set
Visual C++
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.TypeName Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..TypeName Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..UpdatedBy Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..UpdatedOn Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As String
    Get
    Set
Visual C++
public:
property String^ UpdatedOn {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefinition.WorkFlowDefinitionId Property

[image]

A Sandcastle Documented Class Library
TaskDefinition..::..WorkFlowDefinitionId Property
TaskDefinition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WorkFlowDefinitionId { get; set; }
Visual Basic
Public Property WorkFlowDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid WorkFlowDefinitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

See Also

TaskDefinition Class
TaskDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel Class

[image]

A Sandcastle Documented Class Library
TaskDefViewModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskDefViewModel
Visual Basic
<SerializableAttribute>
Public Class TaskDefViewModel
Visual C++
[SerializableAttribute]
public ref class TaskDefViewModel

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskDefViewModel

See Also

TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel Members

[image] [image]

A Sandcastle Documented Class Library
TaskDefViewModel Members
TaskDefViewModel Class Constructors Methods Properties See Also Send Feedback

The TaskDefViewModel type exposes the following members.

Constructors

 | Name | Description
Public method | TaskDefViewModel | Initializes a new instance of the TaskDefViewModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivityDescription |
Public property | ActivityId |
Public property | ActivityName |
Public property | ActivityProperties |
Public property | ActorDef |
Public property | Conditions |
Public property | Ordinal |
Public property | TaskCode |
Public property | TaskId |
Public property | TaskName |
Public property | TaskType |
Public property | UIModel |

See Also

TaskDefViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel Constructor

[image]

A Sandcastle Documented Class Library
TaskDefViewModel Constructor
TaskDefViewModel Class See Also Send Feedback
Initializes a new instance of the TaskDefViewModel class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskDefViewModel()
Visual Basic
Public Sub New
Visual C++
public:
TaskDefViewModel()

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel Methods

[image] [image]

A Sandcastle Documented Class Library
TaskDefViewModel Methods
TaskDefViewModel Class See Also Send Feedback

The TaskDefViewModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskDefViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel Properties

[image] [image]

A Sandcastle Documented Class Library
TaskDefViewModel Properties
TaskDefViewModel Class See Also Send Feedback

The TaskDefViewModel type exposes the following members.

Properties

 | Name | Description
Public property | ActivityDescription |
Public property | ActivityId |
Public property | ActivityName |
Public property | ActivityProperties |
Public property | ActorDef |
Public property | Conditions |
Public property | Ordinal |
Public property | TaskCode |
Public property | TaskId |
Public property | TaskName |
Public property | TaskType |
Public property | UIModel |

See Also

TaskDefViewModel Class
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.ActivityDescription Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..ActivityDescription Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivityDescription { get; set; }
Visual Basic
Public Property ActivityDescription As String
    Get
    Set
Visual C++
public:
property String^ ActivityDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.ActivityId Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..ActivityId Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivityId { get; set; }
Visual Basic
Public Property ActivityId As String
    Get
    Set
Visual C++
public:
property String^ ActivityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.ActivityName Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..ActivityName Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActivityName { get; set; }
Visual Basic
Public Property ActivityName As String
    Get
    Set
Visual C++
public:
property String^ ActivityName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.ActivityProperties Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..ActivityProperties Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public ActivityProperty[] ActivityProperties { get; set; }
Visual Basic
Public Property ActivityProperties As ActivityProperty()
    Get
    Set
Visual C++
public:
property array<ActivityProperty^>^ ActivityProperties {
    array<ActivityProperty^>^ get ();
    void set (array<ActivityProperty^>^ value);
}

Property Value

Type: array< ActivityProperty >[]()[][]

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.ActorDef Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..ActorDef Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskActorDefViewModel ActorDef { get; set; }
Visual Basic
Public Property ActorDef As TaskActorDefViewModel
    Get
    Set
Visual C++
public:
property TaskActorDefViewModel^ ActorDef {
    TaskActorDefViewModel^ get ();
    void set (TaskActorDefViewModel^ value);
}

Property Value

Type: TaskActorDefViewModel

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.Conditions Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..Conditions Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskConditionsViewModel Conditions { get; set; }
Visual Basic
Public Property Conditions As TaskConditionsViewModel
    Get
    Set
Visual C++
public:
property TaskConditionsViewModel^ Conditions {
    TaskConditionsViewModel^ get ();
    void set (TaskConditionsViewModel^ value);
}

Property Value

Type: TaskConditionsViewModel

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.Ordinal Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..Ordinal Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Ordinal { get; set; }
Visual Basic
Public Property Ordinal As Integer
    Get
    Set
Visual C++
public:
property int Ordinal {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.TaskCode Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..TaskCode Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskCode { get; set; }
Visual Basic
Public Property TaskCode As String
    Get
    Set
Visual C++
public:
property String^ TaskCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.TaskId Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..TaskId Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskId { get; set; }
Visual Basic
Public Property TaskId As String
    Get
    Set
Visual C++
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.TaskName Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..TaskName Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskName { get; set; }
Visual Basic
Public Property TaskName As String
    Get
    Set
Visual C++
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.TaskType Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..TaskType Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskType { get; set; }
Visual Basic
Public Property TaskType As String
    Get
    Set
Visual C++
public:
property String^ TaskType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskDefViewModel.UIModel Property

[image]

A Sandcastle Documented Class Library
TaskDefViewModel..::..UIModel Property
TaskDefViewModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFUIModel UIModel { get; set; }
Visual Basic
Public Property UIModel As WFUIModel
    Get
    Set
Visual C++
public:
property WFUIModel^ UIModel {
    WFUIModel^ get ();
    void set (WFUIModel^ value);
}

Property Value

Type: WFUIModel

See Also

TaskDefViewModel Class
TaskDefViewModel Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Class

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskExpressionCondition : ITaskExpressionConditions,
    ITaskCondition, IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class TaskExpressionCondition
    Implements ITaskExpressionConditions, ITaskCondition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class TaskExpressionCondition : ITaskExpressionConditions,
    ITaskCondition, IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskExpressionCondition

See Also

TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Members

[image] [image]

A Sandcastle Documented Class Library
TaskExpressionCondition Members
TaskExpressionCondition Class Constructors Methods Properties See Also Send Feedback

The TaskExpressionCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TaskExpressionCondition()()()() | Initializes a new instance of the TaskExpressionCondition class.
Public method | TaskExpressionCondition(String) | Initializes a new instance of the TaskExpressionCondition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

TaskExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Constructor

[image] [image]

A Sandcastle Documented Class Library
TaskExpressionCondition Constructor
TaskExpressionCondition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TaskExpressionCondition()()()() | Initializes a new instance of the TaskExpressionCondition class.
Public method | TaskExpressionCondition(String) | Initializes a new instance of the TaskExpressionCondition class.

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Constructor

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition Constructor
TaskExpressionCondition Class See Also Send Feedback
Initializes a new instance of the TaskExpressionCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskExpressionCondition()
Visual Basic
Public Sub New
Visual C++
public:
TaskExpressionCondition()

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
TaskExpressionCondition Overload
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Constructor (String)

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition Constructor (String)
TaskExpressionCondition Class See Also Send Feedback
Initializes a new instance of the TaskExpressionCondition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskExpressionCondition(
    string expression
)
Visual Basic
Public Sub New (
    expression As String
)
Visual C++
public:
TaskExpressionCondition(
    String^ expression
)

Parameters

expression
Type: System..::..String
The expression.

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
TaskExpressionCondition Overload
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Methods

[image] [image]

A Sandcastle Documented Class Library
TaskExpressionCondition Methods
TaskExpressionCondition Class See Also Send Feedback

The TaskExpressionCondition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

TaskExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition..::..DeSerailizeFromXML Method
TaskExpressionCondition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition.Evaluate Method

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition..::..Evaluate Method
TaskExpressionCondition Class See Also Send Feedback
Evaluates the specified work flow instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Evaluate(
    WorkflowInstance workFlowInstance
)
Visual Basic
Public Function Evaluate (
    workFlowInstance As WorkflowInstance
) As Boolean
Visual C++
public:
virtual bool Evaluate(
    WorkflowInstance^ workFlowInstance
) sealed

Parameters

workFlowInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The work flow instance.

Return Value

Type: Boolean

Implements

ITaskCondition..::..Evaluate(WorkflowInstance)

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition..::..SerailizeToXML Method
TaskExpressionCondition Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition.ToString Method

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition..::..ToString Method
TaskExpressionCondition Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents this instance.

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition Properties

[image] [image]

A Sandcastle Documented Class Library
TaskExpressionCondition Properties
TaskExpressionCondition Class See Also Send Feedback

The TaskExpressionCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

TaskExpressionCondition Class
CelloSaaS.WorkFlow.Model Namespace


TaskExpressionCondition.ConditionExpression Property

[image]

A Sandcastle Documented Class Library
TaskExpressionCondition..::..ConditionExpression Property
TaskExpressionCondition Class See Also Send Feedback
Gets or sets the condition expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConditionExpression { get; set; }
Visual Basic
Public Property ConditionExpression As String
    Get
    Set
Visual C++
public:
virtual property String^ ConditionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The condition expression.

Implements

ITaskCondition..::..ConditionExpression

See Also

TaskExpressionCondition Class
TaskExpressionCondition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition Class

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TaskRouterDefinition : IWorkflowItemDefinition,
    IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class TaskRouterDefinition
    Implements IWorkflowItemDefinition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class TaskRouterDefinition : IWorkflowItemDefinition,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TaskRouterDefinition

See Also

TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition Members

[image] [image]

A Sandcastle Documented Class Library
TaskRouterDefinition Members
TaskRouterDefinition Class Constructors Methods Properties See Also Send Feedback

The TaskRouterDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | TaskRouterDefinition | Initializes a new instance of the TaskRouterDefinition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | IsVisible | Gets or sets a value indicating whether this instance is visible on UI.
Public property | RegisteredElseOutputTasks | Gets or sets the registered else output tasks.
Public property | RegisteredInputTasks | Gets or sets the registered input tasks.
Public property | RegisteredOutputTasks | Gets or sets the registered output tasks.
Public property | RouterId | Gets or sets the router id.
Public property | RouterName | Gets or sets the name of the router.
Public property | RouterType | Gets or sets the type of the router.
Public property | RoutingTable | Gets or sets the routing conditions.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id.

See Also

TaskRouterDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition Constructor

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition Constructor
TaskRouterDefinition Class See Also Send Feedback
Initializes a new instance of the TaskRouterDefinition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskRouterDefinition()
Visual Basic
Public Sub New
Visual C++
public:
TaskRouterDefinition()

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
TaskRouterDefinition Methods
TaskRouterDefinition Class See Also Send Feedback

The TaskRouterDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | De-serailize itself from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TaskRouterDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..DeSerailizeFromXML Method
TaskRouterDefinition Class See Also Send Feedback
De-serailize itself from XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String
The XML.

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..SerailizeToXML Method
TaskRouterDefinition Class See Also Send Feedback
Serailizes to XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
TaskRouterDefinition Properties
TaskRouterDefinition Class See Also Send Feedback

The TaskRouterDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | IsVisible | Gets or sets a value indicating whether this instance is visible on UI.
Public property | RegisteredElseOutputTasks | Gets or sets the registered else output tasks.
Public property | RegisteredInputTasks | Gets or sets the registered input tasks.
Public property | RegisteredOutputTasks | Gets or sets the registered output tasks.
Public property | RouterId | Gets or sets the router id.
Public property | RouterName | Gets or sets the name of the router.
Public property | RouterType | Gets or sets the type of the router.
Public property | RoutingTable | Gets or sets the routing conditions.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id.

See Also

TaskRouterDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.CreatedBy Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..CreatedBy Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.CreatedOn Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..CreatedOn Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As String
    Get
    Set
Visual C++
public:
property String^ CreatedOn {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created on.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.IsVisible Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..IsVisible Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets a value indicating whether this instance is visible on UI.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
true if this instance is visible on UI; otherwise, false.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RegisteredElseOutputTasks Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RegisteredElseOutputTasks Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the registered else output tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<TaskDefinition> RegisteredElseOutputTasks { get; set; }
Visual Basic
Public Property RegisteredElseOutputTasks As List(Of TaskDefinition)
    Get
    Set
Visual C++
public:
property List<TaskDefinition^>^ RegisteredElseOutputTasks {
    List<TaskDefinition^>^ get ();
    void set (List<TaskDefinition^>^ value);
}

Property Value

Type: List<(Of <(<' TaskDefinition >)>)>
The registered else output tasks.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RegisteredInputTasks Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RegisteredInputTasks Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the registered input tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<TaskDefinition> RegisteredInputTasks { get; set; }
Visual Basic
Public Property RegisteredInputTasks As List(Of TaskDefinition)
    Get
    Set
Visual C++
public:
property List<TaskDefinition^>^ RegisteredInputTasks {
    List<TaskDefinition^>^ get ();
    void set (List<TaskDefinition^>^ value);
}

Property Value

Type: List<(Of <(<' TaskDefinition >)>)>
The registered input tasks.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RegisteredOutputTasks Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RegisteredOutputTasks Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the registered output tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<TaskDefinition> RegisteredOutputTasks { get; set; }
Visual Basic
Public Property RegisteredOutputTasks As List(Of TaskDefinition)
    Get
    Set
Visual C++
public:
property List<TaskDefinition^>^ RegisteredOutputTasks {
    List<TaskDefinition^>^ get ();
    void set (List<TaskDefinition^>^ value);
}

Property Value

Type: List<(Of <(<' TaskDefinition >)>)>
The registered output tasks.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RouterId Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RouterId Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the router id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid RouterId { get; set; }
Visual Basic
Public Property RouterId As Guid
    Get
    Set
Visual C++
public:
property Guid RouterId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The router id.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RouterName Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RouterName Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the name of the router.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string RouterName { get; set; }
Visual Basic
Public Property RouterName As String
    Get
    Set
Visual C++
public:
property String^ RouterName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the router.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RouterType Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RouterType Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the type of the router.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RouterType RouterType { get; set; }
Visual Basic
Public Property RouterType As RouterType
    Get
    Set
Visual C++
public:
property RouterType RouterType {
    RouterType get ();
    void set (RouterType value);
}

Property Value

Type: RouterType
The type of the router.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.RoutingTable Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..RoutingTable Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the routing conditions.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoutingTable RoutingTable { get; set; }
Visual Basic
Public Property RoutingTable As RoutingTable
    Get
    Set
Visual C++
public:
property RoutingTable^ RoutingTable {
    RoutingTable^ get ();
    void set (RoutingTable^ value);
}

Property Value

Type: RoutingTable
The routing conditions.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..UpdatedBy Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..UpdatedOn Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As String
    Get
    Set
Visual C++
public:
property String^ UpdatedOn {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated on.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TaskRouterDefinition.WorkFlowDefinitionId Property

[image]

A Sandcastle Documented Class Library
TaskRouterDefinition..::..WorkFlowDefinitionId Property
TaskRouterDefinition Class See Also Send Feedback
Gets or sets the work flow definition id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WorkFlowDefinitionId { get; set; }
Visual Basic
Public Property WorkFlowDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid WorkFlowDefinitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The work flow definition id.

See Also

TaskRouterDefinition Class
TaskRouterDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Class

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TrueOrFalseTaskExpressConditions : ITaskExpressionConditions,
    ITaskCondition, IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class TrueOrFalseTaskExpressConditions
    Implements ITaskExpressionConditions, ITaskCondition, IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class TrueOrFalseTaskExpressConditions : ITaskExpressionConditions,
    ITaskCondition, IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TrueOrFalseTaskExpressConditions

See Also

TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Members

[image] [image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Members
TrueOrFalseTaskExpressConditions Class Constructors Methods Properties See Also Send Feedback

The TrueOrFalseTaskExpressConditions type exposes the following members.

Constructors

 | Name | Description
Public method | TrueOrFalseTaskExpressConditions()()()() | Initializes a new instance of the TrueOrFalseTaskExpressConditions class.
Public method | TrueOrFalseTaskExpressConditions(Boolean) | Initializes a new instance of the TrueOrFalseTaskExpressConditions class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

TrueOrFalseTaskExpressConditions Class
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Constructor

[image] [image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Constructor
TrueOrFalseTaskExpressConditions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TrueOrFalseTaskExpressConditions()()()() | Initializes a new instance of the TrueOrFalseTaskExpressConditions class.
Public method | TrueOrFalseTaskExpressConditions(Boolean) | Initializes a new instance of the TrueOrFalseTaskExpressConditions class.

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Constructor

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Constructor
TrueOrFalseTaskExpressConditions Class See Also Send Feedback
Initializes a new instance of the TrueOrFalseTaskExpressConditions class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TrueOrFalseTaskExpressConditions()
Visual Basic
Public Sub New
Visual C++
public:
TrueOrFalseTaskExpressConditions()

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
TrueOrFalseTaskExpressConditions Overload
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Constructor (Boolean)

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Constructor (Boolean)
TrueOrFalseTaskExpressConditions Class See Also Send Feedback
Initializes a new instance of the TrueOrFalseTaskExpressConditions class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TrueOrFalseTaskExpressConditions(
    bool istrueCondition
)
Visual Basic
Public Sub New (
    istrueCondition As Boolean
)
Visual C++
public:
TrueOrFalseTaskExpressConditions(
    bool istrueCondition
)

Parameters

istrueCondition
Type: System..::..Boolean
if set to true [istrue condition].

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
TrueOrFalseTaskExpressConditions Overload
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Methods

[image] [image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Methods
TrueOrFalseTaskExpressConditions Class See Also Send Feedback

The TrueOrFalseTaskExpressConditions type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the specified work flow instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a String that represents this instance. (Overrides Object..::..ToString()()()().)

See Also

TrueOrFalseTaskExpressConditions Class
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions..::..DeSerailizeFromXML Method
TrueOrFalseTaskExpressConditions Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions.Evaluate Method

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions..::..Evaluate Method
TrueOrFalseTaskExpressConditions Class See Also Send Feedback
Evaluates the specified work flow instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Evaluate(
    WorkflowInstance workFlowInstance
)
Visual Basic
Public Function Evaluate (
    workFlowInstance As WorkflowInstance
) As Boolean
Visual C++
public:
virtual bool Evaluate(
    WorkflowInstance^ workFlowInstance
) sealed

Parameters

workFlowInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The work flow instance.

Return Value

Type: Boolean

Implements

ITaskCondition..::..Evaluate(WorkflowInstance)

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions..::..SerailizeToXML Method
TrueOrFalseTaskExpressConditions Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions.ToString Method

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions..::..ToString Method
TrueOrFalseTaskExpressConditions Class See Also Send Feedback
Returns a String that represents this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents this instance.

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions Properties

[image] [image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions Properties
TrueOrFalseTaskExpressConditions Class See Also Send Feedback

The TrueOrFalseTaskExpressConditions type exposes the following members.

Properties

 | Name | Description
Public property | ConditionExpression | Gets or sets the condition expression.

See Also

TrueOrFalseTaskExpressConditions Class
CelloSaaS.WorkFlow.Model Namespace


TrueOrFalseTaskExpressConditions.ConditionExpression Property

[image]

A Sandcastle Documented Class Library
TrueOrFalseTaskExpressConditions..::..ConditionExpression Property
TrueOrFalseTaskExpressConditions Class See Also Send Feedback
Gets or sets the condition expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConditionExpression { get; set; }
Visual Basic
Public Property ConditionExpression As String
    Get
    Set
Visual C++
public:
virtual property String^ ConditionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The condition expression.

Implements

ITaskCondition..::..ConditionExpression

See Also

TrueOrFalseTaskExpressConditions Class
TrueOrFalseTaskExpressConditions Members
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition Class

[image]

A Sandcastle Documented Class Library
TypeInvocationDefinition Class
Members See Also Send Feedback
TypeInvocationDefinition

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class TypeInvocationDefinition
Visual Basic
<SerializableAttribute>
Public Class TypeInvocationDefinition
Visual C++
[SerializableAttribute]
public ref class TypeInvocationDefinition

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..TypeInvocationDefinition

See Also

TypeInvocationDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition Members

[image] [image]

A Sandcastle Documented Class Library
TypeInvocationDefinition Members
TypeInvocationDefinition Class Constructors Methods Properties See Also Send Feedback

The TypeInvocationDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | TypeInvocationDefinition | Initializes a new instance of the TypeInvocationDefinition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InputMapping | Gets or sets the input mapping.
Public property | WebServiceURL | Gets or sets the web service URL.

See Also

TypeInvocationDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition Constructor

[image]

A Sandcastle Documented Class Library
TypeInvocationDefinition Constructor
TypeInvocationDefinition Class See Also Send Feedback
Initializes a new instance of the TypeInvocationDefinition class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TypeInvocationDefinition()
Visual Basic
Public Sub New
Visual C++
public:
TypeInvocationDefinition()

See Also

TypeInvocationDefinition Class
TypeInvocationDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
TypeInvocationDefinition Methods
TypeInvocationDefinition Class See Also Send Feedback

The TypeInvocationDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TypeInvocationDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
TypeInvocationDefinition Properties
TypeInvocationDefinition Class See Also Send Feedback

The TypeInvocationDefinition type exposes the following members.

Properties

 | Name | Description
Public property | InputMapping | Gets or sets the input mapping.
Public property | WebServiceURL | Gets or sets the web service URL.

See Also

TypeInvocationDefinition Class
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition.InputMapping Property

[image]

A Sandcastle Documented Class Library
TypeInvocationDefinition..::..InputMapping Property
TypeInvocationDefinition Class See Also Send Feedback
Gets or sets the input mapping.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<InputMapping> InputMapping { get; set; }
Visual Basic
Public Property InputMapping As List(Of InputMapping)
    Get
    Set
Visual C++
public:
property List<InputMapping^>^ InputMapping {
    List<InputMapping^>^ get ();
    void set (List<InputMapping^>^ value);
}

Property Value

Type: List<(Of <(<' InputMapping >)>)>
The input mapping.

See Also

TypeInvocationDefinition Class
TypeInvocationDefinition Members
CelloSaaS.WorkFlow.Model Namespace


TypeInvocationDefinition.WebServiceURL Property

[image]

A Sandcastle Documented Class Library
TypeInvocationDefinition..::..WebServiceURL Property
TypeInvocationDefinition Class See Also Send Feedback
Gets or sets the web service URL.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Uri WebServiceURL { get; set; }
Visual Basic
Public Property WebServiceURL As Uri
    Get
    Set
Visual C++
public:
property Uri^ WebServiceURL {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
The web service URL.

See Also

TypeInvocationDefinition Class
TypeInvocationDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WFRecordStatus Enumeration

[image]

A Sandcastle Documented Class Library
WFRecordStatus Enumeration
See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum WFRecordStatus
Visual Basic
Public Enumeration WFRecordStatus
Visual C++
public enum class WFRecordStatus

Members

Member name | Value | Description
New | 0 |
Queued | 1 |
Completed | 2 |
Failure | 3 |

See Also

CelloSaaS.WorkFlow.Model Namespace


WFRequestModel Class

[image]

A Sandcastle Documented Class Library
WFRequestModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WFRequestModel
Visual Basic
<SerializableAttribute>
Public Class WFRequestModel
Visual C++
[SerializableAttribute]
public ref class WFRequestModel

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WFRequestModel

See Also

WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel Members

[image] [image]

A Sandcastle Documented Class Library
WFRequestModel Members
WFRequestModel Class Constructors Methods Properties See Also Send Feedback

The WFRequestModel type exposes the following members.

Constructors

 | Name | Description
Public method | WFRequestModel | Initializes a new instance of the WFRequestModel class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Id | Gets or sets the id.
Public property | MapId | Gets or sets the map id.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | WorkflowId | Gets or sets the workflow id.

See Also

WFRequestModel Class
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel Constructor

[image]

A Sandcastle Documented Class Library
WFRequestModel Constructor
WFRequestModel Class See Also Send Feedback
Initializes a new instance of the WFRequestModel class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFRequestModel()
Visual Basic
Public Sub New
Visual C++
public:
WFRequestModel()

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel Methods

[image] [image]

A Sandcastle Documented Class Library
WFRequestModel Methods
WFRequestModel Class See Also Send Feedback

The WFRequestModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFRequestModel Class
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel Properties

[image] [image]

A Sandcastle Documented Class Library
WFRequestModel Properties
WFRequestModel Class See Also Send Feedback

The WFRequestModel type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Id | Gets or sets the id.
Public property | MapId | Gets or sets the map id.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | WorkflowId | Gets or sets the workflow id.

See Also

WFRequestModel Class
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.CreatedBy Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..CreatedBy Property
WFRequestModel Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.CreatedOn Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..CreatedOn Property
WFRequestModel Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.Id Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..Id Property
WFRequestModel Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The id.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.MapId Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..MapId Property
WFRequestModel Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.Status Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..Status Property
WFRequestModel Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFRecordStatus Status { get; set; }
Visual Basic
Public Property Status As WFRecordStatus
    Get
    Set
Visual C++
public:
property WFRecordStatus Status {
    WFRecordStatus get ();
    void set (WFRecordStatus value);
}

Property Value

Type: WFRecordStatus
The status.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.TenantId Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..TenantId Property
WFRequestModel Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WFRequestModel.WorkflowId Property

[image]

A Sandcastle Documented Class Library
WFRequestModel..::..WorkflowId Property
WFRequestModel Class See Also Send Feedback
Gets or sets the workflow id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WorkflowId { get; set; }
Visual Basic
Public Property WorkflowId As String
    Get
    Set
Visual C++
public:
property String^ WorkflowId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The workflow id.

See Also

WFRequestModel Class
WFRequestModel Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter Class

[image]

A Sandcastle Documented Class Library
WfSearchParameter Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WfSearchParameter
Visual Basic
<SerializableAttribute>
Public Class WfSearchParameter
Visual C++
[SerializableAttribute]
public ref class WfSearchParameter

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WfSearchParameter

See Also

WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter Members

[image] [image]

A Sandcastle Documented Class Library
WfSearchParameter Members
WfSearchParameter Class Constructors Methods Properties See Also Send Feedback

The WfSearchParameter type exposes the following members.

Constructors

 | Name | Description
Public method | WfSearchParameter | Initializes a new instance of the WfSearchParameter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id.
Public property | ActorIds | Gets or sets the actor ids.
Public property | MapId | Gets or sets the map id.
Public property | MapIds | Gets or sets the map ids.
Public property | RecordEnd | Gets or sets the record end.
Public property | RecordStart | Gets or sets the rocord start.
Public property | SetTotalCount | Gets or sets the set total count.
Public property | SortExpression | Gets or sets the sort expression.
Public property | SortString | Gets or sets the sort string.
Public property | StartsWithMapId | If set this will search the wf instances whose mapid starts with the given one
Public property | TaskCode | Gets or sets the task code.
Public property | TaskCodes | Gets or sets the task codes.
Public property | TaskCurrentExecutionStatus | Gets or sets the task execution status.
Public property | TaskCurrentExecutionStatusDetails | Gets or sets the task execution status.
Public property | TaskInstanceId | Gets or sets the task instance id.
Public property | TaskInstanceIds | Gets or sets the task instance ids.
Public property | TenantId | Gets or sets the tenant id.
Public property | TotalCount | Gets or sets the total count.
Public property | WFId | Gets or sets the WF id.
Public property | WFInstanceId | Gets or sets the wf instance id.
Public property | WFInstanceIds | Gets or sets the WF instance ids.
Public property | WFInstanceStatus | Gets or sets the WF instance status.
Public property | WFInstanceStatusDetails | Gets or sets the WF instance status details.
Public property | WFName | Gets or sets the name of the WF.

See Also

WfSearchParameter Class
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter Constructor

[image]

A Sandcastle Documented Class Library
WfSearchParameter Constructor
WfSearchParameter Class See Also Send Feedback
Initializes a new instance of the WfSearchParameter class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WfSearchParameter()
Visual Basic
Public Sub New
Visual C++
public:
WfSearchParameter()

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter Methods

[image] [image]

A Sandcastle Documented Class Library
WfSearchParameter Methods
WfSearchParameter Class See Also Send Feedback

The WfSearchParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WfSearchParameter Class
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter Properties

[image] [image]

A Sandcastle Documented Class Library
WfSearchParameter Properties
WfSearchParameter Class See Also Send Feedback

The WfSearchParameter type exposes the following members.

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id.
Public property | ActorIds | Gets or sets the actor ids.
Public property | MapId | Gets or sets the map id.
Public property | MapIds | Gets or sets the map ids.
Public property | RecordEnd | Gets or sets the record end.
Public property | RecordStart | Gets or sets the rocord start.
Public property | SetTotalCount | Gets or sets the set total count.
Public property | SortExpression | Gets or sets the sort expression.
Public property | SortString | Gets or sets the sort string.
Public property | StartsWithMapId | If set this will search the wf instances whose mapid starts with the given one
Public property | TaskCode | Gets or sets the task code.
Public property | TaskCodes | Gets or sets the task codes.
Public property | TaskCurrentExecutionStatus | Gets or sets the task execution status.
Public property | TaskCurrentExecutionStatusDetails | Gets or sets the task execution status.
Public property | TaskInstanceId | Gets or sets the task instance id.
Public property | TaskInstanceIds | Gets or sets the task instance ids.
Public property | TenantId | Gets or sets the tenant id.
Public property | TotalCount | Gets or sets the total count.
Public property | WFId | Gets or sets the WF id.
Public property | WFInstanceId | Gets or sets the wf instance id.
Public property | WFInstanceIds | Gets or sets the WF instance ids.
Public property | WFInstanceStatus | Gets or sets the WF instance status.
Public property | WFInstanceStatusDetails | Gets or sets the WF instance status details.
Public property | WFName | Gets or sets the name of the WF.

See Also

WfSearchParameter Class
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.ActorId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..ActorId Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the actor id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActorId { get; set; }
Visual Basic
Public Property ActorId As String
    Get
    Set
Visual C++
public:
property String^ ActorId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The actor id.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.ActorIds Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..ActorIds Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the actor ids.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> ActorIds { get; set; }
Visual Basic
Public Property ActorIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ ActorIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The actor ids.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.MapId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..MapId Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.MapIds Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..MapIds Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the map ids.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> MapIds { get; set; }
Visual Basic
Public Property MapIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ MapIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The map ids.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.RecordEnd Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..RecordEnd Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the record end.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordEnd { get; set; }
Visual Basic
Public Property RecordEnd As Integer
    Get
    Set
Visual C++
public:
property int RecordEnd {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The record end.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.RecordStart Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..RecordStart Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the rocord start.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordStart { get; set; }
Visual Basic
Public Property RecordStart As Integer
    Get
    Set
Visual C++
public:
property int RecordStart {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The rocord start.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..SetTotalCount Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the set total count.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> SetTotalCount {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The set total count.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.SortExpression Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..SortExpression Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the sort expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortExpression { get; set; }
Visual Basic
Public Property SortExpression As String
    Get
    Set
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort expression.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.SortString Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..SortString Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the sort string.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort string.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.StartsWithMapId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..StartsWithMapId Property
WfSearchParameter Class See Also Send Feedback
If set this will search the wf instances whose mapid starts with the given one

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string StartsWithMapId { get; set; }
Visual Basic
Public Property StartsWithMapId As String
    Get
    Set
Visual C++
public:
property String^ StartsWithMapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TaskCode Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TaskCode Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the task code.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskCode { get; set; }
Visual Basic
Public Property TaskCode As String
    Get
    Set
Visual C++
public:
property String^ TaskCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The task code.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TaskCodes Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TaskCodes Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the task codes.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> TaskCodes { get; set; }
Visual Basic
Public Property TaskCodes As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ TaskCodes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The task codes.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TaskCurrentExecutionStatus Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TaskCurrentExecutionStatus Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the task execution status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskCurrentExecutionStatus { get; set; }
Visual Basic
Public Property TaskCurrentExecutionStatus As String
    Get
    Set
Visual C++
public:
property String^ TaskCurrentExecutionStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The task execution status.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TaskCurrentExecutionStatusDetails Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TaskCurrentExecutionStatusDetails Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the task execution status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> TaskCurrentExecutionStatusDetails { get; set; }
Visual Basic
Public Property TaskCurrentExecutionStatusDetails As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ TaskCurrentExecutionStatusDetails {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The task execution status.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TaskInstanceId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TaskInstanceId Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the task instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TaskInstanceId { get; set; }
Visual Basic
Public Property TaskInstanceId As String
    Get
    Set
Visual C++
public:
property String^ TaskInstanceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The task instance id.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TaskInstanceIds Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TaskInstanceIds Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the task instance ids.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> TaskInstanceIds { get; set; }
Visual Basic
Public Property TaskInstanceIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ TaskInstanceIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The task instance ids.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TenantId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TenantId Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.TotalCount Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..TotalCount Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> TotalCount {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>
The total count.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.WFId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..WFId Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the WF id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFId { get; set; }
Visual Basic
Public Property WFId As String
    Get
    Set
Visual C++
public:
property String^ WFId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The WF id.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.WFInstanceId Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..WFInstanceId Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the wf instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFInstanceId { get; set; }
Visual Basic
Public Property WFInstanceId As String
    Get
    Set
Visual C++
public:
property String^ WFInstanceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The wf instance id.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.WFInstanceIds Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..WFInstanceIds Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the WF instance ids.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> WFInstanceIds { get; set; }
Visual Basic
Public Property WFInstanceIds As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ WFInstanceIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The WF instance ids.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.WFInstanceStatus Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..WFInstanceStatus Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the WF instance status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFInstanceStatus { get; set; }
Visual Basic
Public Property WFInstanceStatus As String
    Get
    Set
Visual C++
public:
property String^ WFInstanceStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The WF instance status.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.WFInstanceStatusDetails Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..WFInstanceStatusDetails Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the WF instance status details.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> WFInstanceStatusDetails { get; set; }
Visual Basic
Public Property WFInstanceStatusDetails As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ WFInstanceStatusDetails {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The WF instance status details.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WfSearchParameter.WFName Property

[image]

A Sandcastle Documented Class Library
WfSearchParameter..::..WFName Property
WfSearchParameter Class See Also Send Feedback
Gets or sets the name of the WF.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFName { get; set; }
Visual Basic
Public Property WFName As String
    Get
    Set
Visual C++
public:
property String^ WFName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the WF.

See Also

WfSearchParameter Class
WfSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFState Class

[image]

A Sandcastle Documented Class Library
WFState Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WFState
Visual Basic
<SerializableAttribute>
Public Class WFState
Visual C++
[SerializableAttribute]
public ref class WFState

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WFState

See Also

WFState Members
CelloSaaS.WorkFlow.Model Namespace


WFState Members

[image] [image]

A Sandcastle Documented Class Library
WFState Members
WFState Class Constructors Methods Properties See Also Send Feedback

The WFState type exposes the following members.

Constructors

 | Name | Description
Public method | WFState | Initializes a new instance of the WFState class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | WFStateDetails | Gets or sets the state of the WF.

See Also

WFState Class
CelloSaaS.WorkFlow.Model Namespace


WFState Constructor

[image]

A Sandcastle Documented Class Library
WFState Constructor
WFState Class See Also Send Feedback
Initializes a new instance of the WFState class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFState()
Visual Basic
Public Sub New
Visual C++
public:
WFState()

See Also

WFState Class
WFState Members
CelloSaaS.WorkFlow.Model Namespace


WFState Methods

[image] [image]

A Sandcastle Documented Class Library
WFState Methods
WFState Class See Also Send Feedback

The WFState type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFState Class
CelloSaaS.WorkFlow.Model Namespace


WFState Properties

[image] [image]

A Sandcastle Documented Class Library
WFState Properties
WFState Class See Also Send Feedback

The WFState type exposes the following members.

Properties

 | Name | Description
Public property | WFStateDetails | Gets or sets the state of the WF.

See Also

WFState Class
CelloSaaS.WorkFlow.Model Namespace


WFState.WFStateDetails Property

[image]

A Sandcastle Documented Class Library
WFState..::..WFStateDetails Property
WFState Class See Also Send Feedback
Gets or sets the state of the WF.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Dictionary<string, Object> WFStateDetails { get; set; }
Visual Basic
Public Property WFStateDetails As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
property Dictionary<String^, Object^>^ WFStateDetails {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}

Property Value

Type: Dictionary<(Of <(<'String, Object>)>)>
The state of the WF.

See Also

WFState Class
WFState Members
CelloSaaS.WorkFlow.Model Namespace


WFTaskType Enumeration

[image]

A Sandcastle Documented Class Library
WFTaskType Enumeration
See Also Send Feedback
Types of workflow task

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum WFTaskType
Visual Basic
Public Enumeration WFTaskType
Visual C++
public enum class WFTaskType

Members

Member name | Value | Description
Start | 0 | Start
Close | 1 | End
Auto | 2 | Auto
Manual | 3 | Manual

See Also

CelloSaaS.WorkFlow.Model Namespace


WFTrack Class

[image]

A Sandcastle Documented Class Library
WFTrack Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WFTrack
Visual Basic
Public Class WFTrack
Visual C++
public ref class WFTrack

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WFTrack

See Also

WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack Members

[image] [image]

A Sandcastle Documented Class Library
WFTrack Members
WFTrack Class Constructors Methods Properties See Also Send Feedback

The WFTrack type exposes the following members.

Constructors

 | Name | Description
Public method | WFTrack | Initializes a new instance of the WFTrack class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MapId | Gets or sets the map id.
Public property | TrackingId | Gets or sets the tracking unique identifier.
Public property | UpdatedTime | Gets or sets the updated time.
Public property | WFId | Gets or sets the WF id.
Public property | WFInstanceId | Gets or sets the WF instance id.
Public property | WFtaskInstanceId | Gets or sets the W ftask instance id.
Public property | WFTrackingPreviousStatus | Gets or sets the WF tracking previous status.
Public property | WFTrackingStatus | Gets or sets the WF tracking status.

See Also

WFTrack Class
CelloSaaS.WorkFlow.Model Namespace


WFTrack Constructor

[image]

A Sandcastle Documented Class Library
WFTrack Constructor
WFTrack Class See Also Send Feedback
Initializes a new instance of the WFTrack class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFTrack()
Visual Basic
Public Sub New
Visual C++
public:
WFTrack()

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack Methods

[image] [image]

A Sandcastle Documented Class Library
WFTrack Methods
WFTrack Class See Also Send Feedback

The WFTrack type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFTrack Class
CelloSaaS.WorkFlow.Model Namespace


WFTrack Properties

[image] [image]

A Sandcastle Documented Class Library
WFTrack Properties
WFTrack Class See Also Send Feedback

The WFTrack type exposes the following members.

Properties

 | Name | Description
Public property | MapId | Gets or sets the map id.
Public property | TrackingId | Gets or sets the tracking unique identifier.
Public property | UpdatedTime | Gets or sets the updated time.
Public property | WFId | Gets or sets the WF id.
Public property | WFInstanceId | Gets or sets the WF instance id.
Public property | WFtaskInstanceId | Gets or sets the W ftask instance id.
Public property | WFTrackingPreviousStatus | Gets or sets the WF tracking previous status.
Public property | WFTrackingStatus | Gets or sets the WF tracking status.

See Also

WFTrack Class
CelloSaaS.WorkFlow.Model Namespace


WFTrack.MapId Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..MapId Property
WFTrack Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.TrackingId Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..TrackingId Property
WFTrack Class See Also Send Feedback
Gets or sets the tracking unique identifier.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> TrackingId { get; set; }
Visual Basic
Public Property TrackingId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> TrackingId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>
The tracking unique identifier.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.UpdatedTime Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..UpdatedTime Property
WFTrack Class See Also Send Feedback
Gets or sets the updated time.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedTime { get; set; }
Visual Basic
Public Property UpdatedTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated time.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.WFId Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..WFId Property
WFTrack Class See Also Send Feedback
Gets or sets the WF id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFId { get; set; }
Visual Basic
Public Property WFId As String
    Get
    Set
Visual C++
public:
property String^ WFId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The WF id.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.WFInstanceId Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..WFInstanceId Property
WFTrack Class See Also Send Feedback
Gets or sets the WF instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFInstanceId { get; set; }
Visual Basic
Public Property WFInstanceId As String
    Get
    Set
Visual C++
public:
property String^ WFInstanceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The WF instance id.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.WFtaskInstanceId Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..WFtaskInstanceId Property
WFTrack Class See Also Send Feedback
Gets or sets the W ftask instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFtaskInstanceId { get; set; }
Visual Basic
Public Property WFtaskInstanceId As String
    Get
    Set
Visual C++
public:
property String^ WFtaskInstanceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The W ftask instance id.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.WFTrackingPreviousStatus Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..WFTrackingPreviousStatus Property
WFTrack Class See Also Send Feedback
Gets or sets the WF tracking previous status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<WFTrackingStatus> WFTrackingPreviousStatus { get; set; }
Visual Basic
Public Property WFTrackingPreviousStatus As Nullable(Of WFTrackingStatus)
    Get
    Set
Visual C++
public:
property Nullable<WFTrackingStatus> WFTrackingPreviousStatus {
    Nullable<WFTrackingStatus> get ();
    void set (Nullable<WFTrackingStatus> value);
}

Property Value

Type: Nullable<(Of <(<' WFTrackingStatus >)>)>
The WF tracking previous status.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrack.WFTrackingStatus Property

[image]

A Sandcastle Documented Class Library
WFTrack..::..WFTrackingStatus Property
WFTrack Class See Also Send Feedback
Gets or sets the WF tracking status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFTrackingStatus WFTrackingStatus { get; set; }
Visual Basic
Public Property WFTrackingStatus As WFTrackingStatus
    Get
    Set
Visual C++
public:
property WFTrackingStatus WFTrackingStatus {
    WFTrackingStatus get ();
    void set (WFTrackingStatus value);
}

Property Value

Type: WFTrackingStatus
The WF tracking status.

See Also

WFTrack Class
WFTrack Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit Class

[image]

A Sandcastle Documented Class Library
WFTrackAudit Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WFTrackAudit
Visual Basic
Public Class WFTrackAudit
Visual C++
public ref class WFTrackAudit

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WFTrackAudit

See Also

WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit Members

[image] [image]

A Sandcastle Documented Class Library
WFTrackAudit Members
WFTrackAudit Class Constructors Methods Properties See Also Send Feedback

The WFTrackAudit type exposes the following members.

Constructors

 | Name | Description
Public method | WFTrackAudit | Initializes a new instance of the WFTrackAudit class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentStatus | Gets or sets the current status.
Public property | PreviousStatus | Gets or sets the previous status.
Public property | UpdatedTime | Gets or sets the updated time.
Public property | WfInstanceId | Gets or sets the wf instance id.
Public property | WfTaskInstanceRunId | Gets or sets the wf task instance run id.

See Also

WFTrackAudit Class
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit Constructor

[image]

A Sandcastle Documented Class Library
WFTrackAudit Constructor
WFTrackAudit Class See Also Send Feedback
Initializes a new instance of the WFTrackAudit class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFTrackAudit()
Visual Basic
Public Sub New
Visual C++
public:
WFTrackAudit()

See Also

WFTrackAudit Class
WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit Methods

[image] [image]

A Sandcastle Documented Class Library
WFTrackAudit Methods
WFTrackAudit Class See Also Send Feedback

The WFTrackAudit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFTrackAudit Class
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit Properties

[image] [image]

A Sandcastle Documented Class Library
WFTrackAudit Properties
WFTrackAudit Class See Also Send Feedback

The WFTrackAudit type exposes the following members.

Properties

 | Name | Description
Public property | CurrentStatus | Gets or sets the current status.
Public property | PreviousStatus | Gets or sets the previous status.
Public property | UpdatedTime | Gets or sets the updated time.
Public property | WfInstanceId | Gets or sets the wf instance id.
Public property | WfTaskInstanceRunId | Gets or sets the wf task instance run id.

See Also

WFTrackAudit Class
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit.CurrentStatus Property

[image]

A Sandcastle Documented Class Library
WFTrackAudit..::..CurrentStatus Property
WFTrackAudit Class See Also Send Feedback
Gets or sets the current status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFTrackingStatus CurrentStatus { get; set; }
Visual Basic
Public Property CurrentStatus As WFTrackingStatus
    Get
    Set
Visual C++
public:
property WFTrackingStatus CurrentStatus {
    WFTrackingStatus get ();
    void set (WFTrackingStatus value);
}

Property Value

Type: WFTrackingStatus
The current status.

See Also

WFTrackAudit Class
WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit.PreviousStatus Property

[image]

A Sandcastle Documented Class Library
WFTrackAudit..::..PreviousStatus Property
WFTrackAudit Class See Also Send Feedback
Gets or sets the previous status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<WFTrackingStatus> PreviousStatus { get; set; }
Visual Basic
Public Property PreviousStatus As Nullable(Of WFTrackingStatus)
    Get
    Set
Visual C++
public:
property Nullable<WFTrackingStatus> PreviousStatus {
    Nullable<WFTrackingStatus> get ();
    void set (Nullable<WFTrackingStatus> value);
}

Property Value

Type: Nullable<(Of <(<' WFTrackingStatus >)>)>
The previous status.

See Also

WFTrackAudit Class
WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit.UpdatedTime Property

[image]

A Sandcastle Documented Class Library
WFTrackAudit..::..UpdatedTime Property
WFTrackAudit Class See Also Send Feedback
Gets or sets the updated time.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedTime { get; set; }
Visual Basic
Public Property UpdatedTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated time.

See Also

WFTrackAudit Class
WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit.WfInstanceId Property

[image]

A Sandcastle Documented Class Library
WFTrackAudit..::..WfInstanceId Property
WFTrackAudit Class See Also Send Feedback
Gets or sets the wf instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WfInstanceId { get; set; }
Visual Basic
Public Property WfInstanceId As String
    Get
    Set
Visual C++
public:
property String^ WfInstanceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The wf instance id.

See Also

WFTrackAudit Class
WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAudit.WfTaskInstanceRunId Property

[image]

A Sandcastle Documented Class Library
WFTrackAudit..::..WfTaskInstanceRunId Property
WFTrackAudit Class See Also Send Feedback
Gets or sets the wf task instance run id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WfTaskInstanceRunId { get; set; }
Visual Basic
Public Property WfTaskInstanceRunId As String
    Get
    Set
Visual C++
public:
property String^ WfTaskInstanceRunId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The wf task instance run id.

See Also

WFTrackAudit Class
WFTrackAudit Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter Class

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WFTrackAuditSearchParameter
Visual Basic
Public Class WFTrackAuditSearchParameter
Visual C++
public ref class WFTrackAuditSearchParameter

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WFTrackAuditSearchParameter

See Also

WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter Members

[image] [image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter Members
WFTrackAuditSearchParameter Class Constructors Methods Properties See Also Send Feedback

The WFTrackAuditSearchParameter type exposes the following members.

Constructors

 | Name | Description
Public method | WFTrackAuditSearchParameter | Initializes a new instance of the WFTrackAuditSearchParameter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentStatus | Gets or sets the current status.
Public property | FromDate | Gets or sets from date.
Public property | PreviousStatus | Gets or sets the previous status.
Public property | RecordEnd | Gets or sets the record end.
Public property | RecordStart | Gets or sets the rocord start.
Public property | SetTotalCount | Gets or sets the set total count.
Public property | SortExpression | Gets or sets the sort expression.
Public property | SortString | Gets or sets the sort string.
Public property | TenantId | Gets or sets the tenant id.
Public property | ToDate | Gets or sets to date.
Public property | TotalCount | Gets or sets the total count.
Public property | WfInstanceId | Gets or sets the wf instance id.
Public property | WfTaskInstanceRunId | Gets or sets the wf task instance run id.

See Also

WFTrackAuditSearchParameter Class
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter Constructor

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter Constructor
WFTrackAuditSearchParameter Class See Also Send Feedback
Initializes a new instance of the WFTrackAuditSearchParameter class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFTrackAuditSearchParameter()
Visual Basic
Public Sub New
Visual C++
public:
WFTrackAuditSearchParameter()

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter Methods

[image] [image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter Methods
WFTrackAuditSearchParameter Class See Also Send Feedback

The WFTrackAuditSearchParameter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFTrackAuditSearchParameter Class
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter Properties

[image] [image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter Properties
WFTrackAuditSearchParameter Class See Also Send Feedback

The WFTrackAuditSearchParameter type exposes the following members.

Properties

 | Name | Description
Public property | CurrentStatus | Gets or sets the current status.
Public property | FromDate | Gets or sets from date.
Public property | PreviousStatus | Gets or sets the previous status.
Public property | RecordEnd | Gets or sets the record end.
Public property | RecordStart | Gets or sets the rocord start.
Public property | SetTotalCount | Gets or sets the set total count.
Public property | SortExpression | Gets or sets the sort expression.
Public property | SortString | Gets or sets the sort string.
Public property | TenantId | Gets or sets the tenant id.
Public property | ToDate | Gets or sets to date.
Public property | TotalCount | Gets or sets the total count.
Public property | WfInstanceId | Gets or sets the wf instance id.
Public property | WfTaskInstanceRunId | Gets or sets the wf task instance run id.

See Also

WFTrackAuditSearchParameter Class
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.CurrentStatus Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..CurrentStatus Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the current status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<WFTrackingStatus> CurrentStatus { get; set; }
Visual Basic
Public Property CurrentStatus As Nullable(Of WFTrackingStatus)
    Get
    Set
Visual C++
public:
property Nullable<WFTrackingStatus> CurrentStatus {
    Nullable<WFTrackingStatus> get ();
    void set (Nullable<WFTrackingStatus> value);
}

Property Value

Type: Nullable<(Of <(<' WFTrackingStatus >)>)>
The current status.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.FromDate Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..FromDate Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets from date.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic
Public Property FromDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
From date.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.PreviousStatus Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..PreviousStatus Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the previous status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<WFTrackingStatus> PreviousStatus { get; set; }
Visual Basic
Public Property PreviousStatus As Nullable(Of WFTrackingStatus)
    Get
    Set
Visual C++
public:
property Nullable<WFTrackingStatus> PreviousStatus {
    Nullable<WFTrackingStatus> get ();
    void set (Nullable<WFTrackingStatus> value);
}

Property Value

Type: Nullable<(Of <(<' WFTrackingStatus >)>)>
The previous status.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.RecordEnd Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..RecordEnd Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the record end.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordEnd { get; set; }
Visual Basic
Public Property RecordEnd As Integer
    Get
    Set
Visual C++
public:
property int RecordEnd {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The record end.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.RecordStart Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..RecordStart Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the rocord start.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int RecordStart { get; set; }
Visual Basic
Public Property RecordStart As Integer
    Get
    Set
Visual C++
public:
property int RecordStart {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The rocord start.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.SetTotalCount Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..SetTotalCount Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the set total count.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<bool> SetTotalCount { get; set; }
Visual Basic
Public Property SetTotalCount As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> SetTotalCount {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: Nullable<(Of <(<'Boolean>)>)>
The set total count.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.SortExpression Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..SortExpression Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the sort expression.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortExpression { get; set; }
Visual Basic
Public Property SortExpression As String
    Get
    Set
Visual C++
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort expression.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.SortString Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..SortString Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the sort string.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SortString { get; set; }
Visual Basic
Public Property SortString As String
    Get
    Set
Visual C++
public:
property String^ SortString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The sort string.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.TenantId Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..TenantId Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.ToDate Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..ToDate Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets to date.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ToDate { get; set; }
Visual Basic
Public Property ToDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
To date.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.TotalCount Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..TotalCount Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the total count.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<int> TotalCount { get; set; }
Visual Basic
Public Property TotalCount As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> TotalCount {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: Nullable<(Of <(<'Int32>)>)>
The total count.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.WfInstanceId Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..WfInstanceId Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the wf instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WfInstanceId { get; set; }
Visual Basic
Public Property WfInstanceId As String
    Get
    Set
Visual C++
public:
property String^ WfInstanceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The wf instance id.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackAuditSearchParameter.WfTaskInstanceRunId Property

[image]

A Sandcastle Documented Class Library
WFTrackAuditSearchParameter..::..WfTaskInstanceRunId Property
WFTrackAuditSearchParameter Class See Also Send Feedback
Gets or sets the wf task instance run id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WfTaskInstanceRunId { get; set; }
Visual Basic
Public Property WfTaskInstanceRunId As String
    Get
    Set
Visual C++
public:
property String^ WfTaskInstanceRunId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The wf task instance run id.

See Also

WFTrackAuditSearchParameter Class
WFTrackAuditSearchParameter Members
CelloSaaS.WorkFlow.Model Namespace


WFTrackingStatus Enumeration

[image]

A Sandcastle Documented Class Library
WFTrackingStatus Enumeration
See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum WFTrackingStatus
Visual Basic
Public Enumeration WFTrackingStatus
Visual C++
public enum class WFTrackingStatus

Members

Member name | Value | Description
Open | 0 |
Queued | 1 |
Completed | 2 |

See Also

CelloSaaS.WorkFlow.Model Namespace


WFUIModel Class

[image]

A Sandcastle Documented Class Library
WFUIModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WFUIModel : IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class WFUIModel
    Implements IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class WFUIModel : IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WFUIModel

See Also

WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel Members

[image] [image]

A Sandcastle Documented Class Library
WFUIModel Members
WFUIModel Class Constructors Methods Properties See Also Send Feedback

The WFUIModel type exposes the following members.

Constructors

 | Name | Description
Public method | WFUIModel | Initializes a new instance of the WFUIModel class

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Height |
Public property | Id |
Public property | OffsetLeft |
Public property | OffsetTop |
Public property | Width |

See Also

WFUIModel Class
CelloSaaS.WorkFlow.Model Namespace


WFUIModel Constructor

[image]

A Sandcastle Documented Class Library
WFUIModel Constructor
WFUIModel Class See Also Send Feedback
Initializes a new instance of the WFUIModel class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFUIModel()
Visual Basic
Public Sub New
Visual C++
public:
WFUIModel()

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel Methods

[image] [image]

A Sandcastle Documented Class Library
WFUIModel Methods
WFUIModel Class See Also Send Feedback

The WFUIModel type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFUIModel Class
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
WFUIModel..::..DeSerailizeFromXML Method
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
WFUIModel..::..SerailizeToXML Method
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel Properties

[image] [image]

A Sandcastle Documented Class Library
WFUIModel Properties
WFUIModel Class See Also Send Feedback

The WFUIModel type exposes the following members.

Properties

 | Name | Description
Public property | Height |
Public property | Id |
Public property | OffsetLeft |
Public property | OffsetTop |
Public property | Width |

See Also

WFUIModel Class
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.Height Property

[image]

A Sandcastle Documented Class Library
WFUIModel..::..Height Property
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.Id Property

[image]

A Sandcastle Documented Class Library
WFUIModel..::..Id Property
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.OffsetLeft Property

[image]

A Sandcastle Documented Class Library
WFUIModel..::..OffsetLeft Property
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int OffsetLeft { get; set; }
Visual Basic
Public Property OffsetLeft As Integer
    Get
    Set
Visual C++
public:
property int OffsetLeft {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.OffsetTop Property

[image]

A Sandcastle Documented Class Library
WFUIModel..::..OffsetTop Property
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int OffsetTop { get; set; }
Visual Basic
Public Property OffsetTop As Integer
    Get
    Set
Visual C++
public:
property int OffsetTop {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModel.Width Property

[image]

A Sandcastle Documented Class Library
WFUIModel..::..Width Property
WFUIModel Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

WFUIModel Class
WFUIModel Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary Class

[image]

A Sandcastle Documented Class Library
WFUIModelDictionary Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WFUIModelDictionary : Dictionary<string, WFUIModel>,
    IWFXMLSerializable
Visual Basic
Public Class WFUIModelDictionary
    Inherits Dictionary(Of String, WFUIModel)
    Implements IWFXMLSerializable
Visual C++
public ref class WFUIModelDictionary : public Dictionary<String^, WFUIModel^>,
    IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Dictionary<(Of <(<'String, WFUIModel >)>)>
CelloSaaS.WorkFlow.Model..::..WFUIModelDictionary

See Also

WFUIModelDictionary Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary Members

[image] [image]

A Sandcastle Documented Class Library
WFUIModelDictionary Members
WFUIModelDictionary Class Constructors Methods Properties See Also Send Feedback

The WFUIModelDictionary type exposes the following members.

Constructors

 | Name | Description
Public method | WFUIModelDictionary | Initializes a new instance of the WFUIModelDictionary class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)

See Also

WFUIModelDictionary Class
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary Constructor

[image]

A Sandcastle Documented Class Library
WFUIModelDictionary Constructor
WFUIModelDictionary Class See Also Send Feedback
Initializes a new instance of the WFUIModelDictionary class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFUIModelDictionary()
Visual Basic
Public Sub New
Visual C++
public:
WFUIModelDictionary()

See Also

WFUIModelDictionary Class
WFUIModelDictionary Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary Methods

[image] [image]

A Sandcastle Documented Class Library
WFUIModelDictionary Methods
WFUIModelDictionary Class See Also Send Feedback

The WFUIModelDictionary type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | DeSerailizeFromXML |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public method | SerailizeToXML |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)

See Also

WFUIModelDictionary Class
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
WFUIModelDictionary..::..DeSerailizeFromXML Method
WFUIModelDictionary Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

WFUIModelDictionary Class
WFUIModelDictionary Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
WFUIModelDictionary..::..SerailizeToXML Method
WFUIModelDictionary Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

WFUIModelDictionary Class
WFUIModelDictionary Members
CelloSaaS.WorkFlow.Model Namespace


WFUIModelDictionary Properties

[image] [image]

A Sandcastle Documented Class Library
WFUIModelDictionary Properties
WFUIModelDictionary Class See Also Send Feedback

The WFUIModelDictionary type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary<(Of <(<'String, WFUIModel >)>)>.)

See Also

WFUIModelDictionary Class
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput Class

[image]

A Sandcastle Documented Class Library
WFXmlInput Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WFXmlInput : WorkflowInput
Visual Basic
<SerializableAttribute>
Public Class WFXmlInput
    Inherits WorkflowInput
Visual C++
[SerializableAttribute]
public ref class WFXmlInput : public WorkflowInput

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowInput
CelloSaaS.WorkFlow.Model..::..WFXmlInput

See Also

WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput Members

[image] [image]

A Sandcastle Documented Class Library
WFXmlInput Members
WFXmlInput Class Constructors Methods Properties See Also Send Feedback

The WFXmlInput type exposes the following members.

Constructors

 | Name | Description
Public method | WFXmlInput | Initializes a new instance of the WFXmlInput class

Methods

 | Name | Description
Public method | ConvertElementToBoolean | Converts the element to boolean.
Public method | ConvertElementToDateTime | Converts the element to date time.
Public method | ConvertElementToDecimal | Converts the element to decimal.
Public method | ConvertElementToDouble | Converts the element to double.
Public method | ConvertElementToInt | Elements at.
Public method | ConvertElementToString | Converts the element to string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterId | Gets or sets the filter id. (Inherited from WorkflowInput.)
Public property | TenantId | Gets or sets the tenant id. (Inherited from WorkflowInput.)
Public property | XmlInput | Gets or sets the XML input.

See Also

WFXmlInput Class
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput Constructor

[image]

A Sandcastle Documented Class Library
WFXmlInput Constructor
WFXmlInput Class See Also Send Feedback
Initializes a new instance of the WFXmlInput class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFXmlInput()
Visual Basic
Public Sub New
Visual C++
public:
WFXmlInput()

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput Methods

[image] [image]

A Sandcastle Documented Class Library
WFXmlInput Methods
WFXmlInput Class See Also Send Feedback

The WFXmlInput type exposes the following members.

Methods

 | Name | Description
Public method | ConvertElementToBoolean | Converts the element to boolean.
Public method | ConvertElementToDateTime | Converts the element to date time.
Public method | ConvertElementToDecimal | Converts the element to decimal.
Public method | ConvertElementToDouble | Converts the element to double.
Public method | ConvertElementToInt | Elements at.
Public method | ConvertElementToString | Converts the element to string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WFXmlInput Class
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.ConvertElementToBoolean Method

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..ConvertElementToBoolean Method
WFXmlInput Class See Also Send Feedback
Converts the element to boolean.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool ConvertElementToBoolean(
    string node
)
Visual Basic
Public Function ConvertElementToBoolean (
    node As String
) As Boolean
Visual C++
public:
bool ConvertElementToBoolean(
    String^ node
)

Parameters

node
Type: System..::..String
The node.

Return Value

Type: Boolean

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.ConvertElementToDateTime Method

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..ConvertElementToDateTime Method
WFXmlInput Class See Also Send Feedback
Converts the element to date time.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime ConvertElementToDateTime(
    string node
)
Visual Basic
Public Function ConvertElementToDateTime (
    node As String
) As DateTime
Visual C++
public:
DateTime ConvertElementToDateTime(
    String^ node
)

Parameters

node
Type: System..::..String
The node.

Return Value

Type: DateTime

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.ConvertElementToDecimal Method

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..ConvertElementToDecimal Method
WFXmlInput Class See Also Send Feedback
Converts the element to decimal.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public decimal ConvertElementToDecimal(
    string node
)
Visual Basic
Public Function ConvertElementToDecimal (
    node As String
) As Decimal
Visual C++
public:
Decimal ConvertElementToDecimal(
    String^ node
)

Parameters

node
Type: System..::..String
The node.

Return Value

Type: Decimal

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.ConvertElementToDouble Method

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..ConvertElementToDouble Method
WFXmlInput Class See Also Send Feedback
Converts the element to double.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public double ConvertElementToDouble(
    string node
)
Visual Basic
Public Function ConvertElementToDouble (
    node As String
) As Double
Visual C++
public:
double ConvertElementToDouble(
    String^ node
)

Parameters

node
Type: System..::..String
The node.

Return Value

Type: Double

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.ConvertElementToInt Method

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..ConvertElementToInt Method
WFXmlInput Class See Also Send Feedback
Elements at.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ConvertElementToInt(
    string node
)
Visual Basic
Public Function ConvertElementToInt (
    node As String
) As Integer
Visual C++
public:
int ConvertElementToInt(
    String^ node
)

Parameters

node
Type: System..::..String
The node.

Return Value

Type: Int32

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.ConvertElementToString Method

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..ConvertElementToString Method
WFXmlInput Class See Also Send Feedback
Converts the element to string.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ConvertElementToString(
    string node
)
Visual Basic
Public Function ConvertElementToString (
    node As String
) As String
Visual C++
public:
String^ ConvertElementToString(
    String^ node
)

Parameters

node
Type: System..::..String
The node.

Return Value

Type: String

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput Properties

[image] [image]

A Sandcastle Documented Class Library
WFXmlInput Properties
WFXmlInput Class See Also Send Feedback

The WFXmlInput type exposes the following members.

Properties

 | Name | Description
Public property | FilterId | Gets or sets the filter id. (Inherited from WorkflowInput.)
Public property | TenantId | Gets or sets the tenant id. (Inherited from WorkflowInput.)
Public property | XmlInput | Gets or sets the XML input.

See Also

WFXmlInput Class
CelloSaaS.WorkFlow.Model Namespace


WFXmlInput.XmlInput Property

[image]

A Sandcastle Documented Class Library
WFXmlInput..::..XmlInput Property
WFXmlInput Class See Also Send Feedback
Gets or sets the XML input.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string XmlInput { get; set; }
Visual Basic
Public Property XmlInput As String
    Get
    Set
Visual C++
public:
property String^ XmlInput {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The XML input.

See Also

WFXmlInput Class
WFXmlInput Members
CelloSaaS.WorkFlow.Model Namespace


Workflow Class

[image]

A Sandcastle Documented Class Library
Workflow Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class Workflow
Visual Basic
<SerializableAttribute>
Public Class Workflow
Visual C++
[SerializableAttribute]
public ref class Workflow

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..Workflow

See Also

Workflow Members
CelloSaaS.WorkFlow.Model Namespace


Workflow Members

[image] [image]

A Sandcastle Documented Class Library
Workflow Members
Workflow Class Constructors Methods Properties See Also Send Feedback

The Workflow type exposes the following members.

Constructors

 | Name | Description
Public method | Workflow | Initializes a new instance of the Workflow class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | WorkflowId | Gets or sets the workflow id.

See Also

Workflow Class
CelloSaaS.WorkFlow.Model Namespace


Workflow Constructor

[image]

A Sandcastle Documented Class Library
Workflow Constructor
Workflow Class See Also Send Feedback
Initializes a new instance of the Workflow class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Workflow(
    string Id
)
Visual Basic
Public Sub New (
    Id As String
)
Visual C++
public:
Workflow(
    String^ Id
)

Parameters

Id
Type: System..::..String
The id.

See Also

Workflow Class
Workflow Members
CelloSaaS.WorkFlow.Model Namespace


Workflow Methods

[image] [image]

A Sandcastle Documented Class Library
Workflow Methods
Workflow Class See Also Send Feedback

The Workflow type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Workflow Class
CelloSaaS.WorkFlow.Model Namespace


Workflow Properties

[image] [image]

A Sandcastle Documented Class Library
Workflow Properties
Workflow Class See Also Send Feedback

The Workflow type exposes the following members.

Properties

 | Name | Description
Public property | WorkflowId | Gets or sets the workflow id.

See Also

Workflow Class
CelloSaaS.WorkFlow.Model Namespace


Workflow.WorkflowId Property

[image]

A Sandcastle Documented Class Library
Workflow..::..WorkflowId Property
Workflow Class See Also Send Feedback
Gets or sets the workflow id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WorkflowId { get; set; }
Visual Basic
Public Property WorkflowId As String
    Get
    Set
Visual C++
public:
property String^ WorkflowId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The workflow id.

See Also

Workflow Class
Workflow Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowAttributeMapper Class

[image]

A Sandcastle Documented Class Library
WorkflowAttributeMapper Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WorkflowAttributeMapper
Visual Basic
Public Class WorkflowAttributeMapper
Visual C++
public ref class WorkflowAttributeMapper

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowAttributeMapper
CelloSaaS.WorkFlow.Model..::..DefaultWorkflowAttributeMapper

See Also

WorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowAttributeMapper Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowAttributeMapper Members
WorkflowAttributeMapper Class Constructors Methods See Also Send Feedback

The WorkflowAttributeMapper type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowAttributeMapper | Initializes a new instance of the WorkflowAttributeMapper class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMapKeys | Gets the map keys.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowAttributeMapper Constructor

[image]

A Sandcastle Documented Class Library
WorkflowAttributeMapper Constructor
WorkflowAttributeMapper Class See Also Send Feedback
Initializes a new instance of the WorkflowAttributeMapper class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowAttributeMapper(
    IWorkflowInput workflowInput
)
Visual Basic
Public Sub New (
    workflowInput As IWorkflowInput
)
Visual C++
public:
WorkflowAttributeMapper(
    IWorkflowInput^ workflowInput
)

Parameters

workflowInput
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The workflow input.

See Also

WorkflowAttributeMapper Class
WorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowAttributeMapper Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowAttributeMapper Methods
WorkflowAttributeMapper Class See Also Send Feedback

The WorkflowAttributeMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMapKeys | Gets the map keys.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowAttributeMapper.GetMapKeys Method

[image]

A Sandcastle Documented Class Library
WorkflowAttributeMapper..::..GetMapKeys Method
WorkflowAttributeMapper Class See Also Send Feedback
Gets the map keys.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual List<string> GetMapKeys()
Visual Basic
Public Overridable Function GetMapKeys As List(Of String)
Visual C++
public:
virtual List<String^>^ GetMapKeys()

Return Value

Type: List<(Of <(<'String>)>)>

See Also

WorkflowAttributeMapper Class
WorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowAttributeMapper.GetValue Method

[image]

A Sandcastle Documented Class Library
WorkflowAttributeMapper..::..GetValue Method
WorkflowAttributeMapper Class See Also Send Feedback
Gets the value.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual List<MappedObjectKeyValue> GetValue(
    string key
)
Visual Basic
Public Overridable Function GetValue (
    key As String
) As List(Of MappedObjectKeyValue)
Visual C++
public:
virtual List<MappedObjectKeyValue^>^ GetValue(
    String^ key
)

Parameters

key
Type: System..::..String
The key.

Return Value

Type: List<(Of <(<' MappedObjectKeyValue >)>)>

See Also

WorkflowAttributeMapper Class
WorkflowAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition Class

[image]

A Sandcastle Documented Class Library
WorkflowDefinition Class
Members See Also Send Feedback
Workflow definitions

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowDefinition : IWFXMLSerializable
Visual Basic
<SerializableAttribute>
Public Class WorkflowDefinition
    Implements IWFXMLSerializable
Visual C++
[SerializableAttribute]
public ref class WorkflowDefinition : IWFXMLSerializable

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowDefinition

See Also

WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowDefinition Members
WorkflowDefinition Class Constructors Methods Properties See Also Send Feedback

The WorkflowDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowDefinition | Initializes a new instance of the WorkflowDefinition class.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | Des the serailize from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DefinitionId | Gets or sets the definition id.
Public property | DefinitionXml | Gets or sets the definition XML.
Public property | FilterId | Gets or sets the filter id.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | Version | Gets or sets the version.
Public property | WfId | Gets or sets the wf id.
Public property | WfModel | Gets or sets the Workflow Model.
Public property | WorkflowItemDefinitions | Gets or sets the workflow item definitions.

See Also

WorkflowDefinition Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition Constructor

[image]

A Sandcastle Documented Class Library
WorkflowDefinition Constructor
WorkflowDefinition Class See Also Send Feedback
Initializes a new instance of the WorkflowDefinition class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowDefinition()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowDefinition()

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowDefinition Methods
WorkflowDefinition Class See Also Send Feedback

The WorkflowDefinition type exposes the following members.

Methods

 | Name | Description
Public method | DeSerailizeFromXML | Des the serailize from XML.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SerailizeToXML | Serailizes to XML.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowDefinition Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.DeSerailizeFromXML Method

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..DeSerailizeFromXML Method
WorkflowDefinition Class See Also Send Feedback
Des the serailize from XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void DeSerailizeFromXML(
    string xml
)
Visual Basic
Public Sub DeSerailizeFromXML (
    xml As String
)
Visual C++
public:
virtual void DeSerailizeFromXML(
    String^ xml
) sealed

Parameters

xml
Type: System..::..String
The XML.

Return Value

Type:

Implements

IWFXMLSerializable..::..DeSerailizeFromXML(String)

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.SerailizeToXML Method

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..SerailizeToXML Method
WorkflowDefinition Class See Also Send Feedback
Serailizes to XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string SerailizeToXML()
Visual Basic
Public Function SerailizeToXML As String
Visual C++
public:
virtual String^ SerailizeToXML() sealed

Return Value

Type: String

Implements

IWFXMLSerializable..::..SerailizeToXML()()()()

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowDefinition Properties
WorkflowDefinition Class See Also Send Feedback

The WorkflowDefinition type exposes the following members.

Properties

 | Name | Description
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DefinitionId | Gets or sets the definition id.
Public property | DefinitionXml | Gets or sets the definition XML.
Public property | FilterId | Gets or sets the filter id.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | Version | Gets or sets the version.
Public property | WfId | Gets or sets the wf id.
Public property | WfModel | Gets or sets the Workflow Model.
Public property | WorkflowItemDefinitions | Gets or sets the workflow item definitions.

See Also

WorkflowDefinition Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.CreatedBy Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..CreatedBy Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.CreatedOn Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..CreatedOn Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.DefinitionId Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..DefinitionId Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the definition id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid DefinitionId { get; set; }
Visual Basic
Public Property DefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid DefinitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The definition id.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.DefinitionXml Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..DefinitionXml Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the definition XML.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string DefinitionXml { get; set; }
Visual Basic
Public Property DefinitionXml As String
    Get
    Set
Visual C++
public:
property String^ DefinitionXml {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The definition XML.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.FilterId Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..FilterId Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the filter id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilterId { get; set; }
Visual Basic
Public Property FilterId As String
    Get
    Set
Visual C++
public:
property String^ FilterId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The filter id.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.Status Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..Status Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowDefinitionStatus Status { get; set; }
Visual Basic
Public Property Status As WorkflowDefinitionStatus
    Get
    Set
Visual C++
public:
property WorkflowDefinitionStatus Status {
    WorkflowDefinitionStatus get ();
    void set (WorkflowDefinitionStatus value);
}

Property Value

Type: WorkflowDefinitionStatus
The status.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.TenantId Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..TenantId Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..UpdatedBy Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..UpdatedOn Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.Version Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..Version Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the version.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int Version { get; set; }
Visual Basic
Public Property Version As Integer
    Get
    Set
Visual C++
public:
property int Version {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The version.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.WfId Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..WfId Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the wf id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WfId { get; set; }
Visual Basic
Public Property WfId As Guid
    Get
    Set
Visual C++
public:
property Guid WfId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The wf id.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.WfModel Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..WfModel Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the Workflow Model.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowModel WfModel { get; set; }
Visual Basic
Public Property WfModel As WorkflowModel
    Get
    Set
Visual C++
public:
property WorkflowModel^ WfModel {
    WorkflowModel^ get ();
    void set (WorkflowModel^ value);
}

Property Value

Type: WorkflowModel
The Workflow Model.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinition.WorkflowItemDefinitions Property

[image]

A Sandcastle Documented Class Library
WorkflowDefinition..::..WorkflowItemDefinitions Property
WorkflowDefinition Class See Also Send Feedback
Gets or sets the workflow item definitions.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<IWorkflowItemDefinition> WorkflowItemDefinitions { get; set; }
Visual Basic
Public Property WorkflowItemDefinitions As List(Of IWorkflowItemDefinition)
    Get
    Set
Visual C++
public:
property List<IWorkflowItemDefinition^>^ WorkflowItemDefinitions {
    List<IWorkflowItemDefinition^>^ get ();
    void set (List<IWorkflowItemDefinition^>^ value);
}

Property Value

Type: List<(Of <(<' IWorkflowItemDefinition >)>)>
The workflow item definitions.

See Also

WorkflowDefinition Class
WorkflowDefinition Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowDefinitionStatus Enumeration

[image]

A Sandcastle Documented Class Library
WorkflowDefinitionStatus Enumeration
See Also Send Feedback
Status of the workflow defined

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public enum WorkflowDefinitionStatus
Visual Basic
Public Enumeration WorkflowDefinitionStatus
Visual C++
public enum class WorkflowDefinitionStatus

Members

Member name | Value | Description
Draft | 0 | Draft
Published | 1 | Published

See Also

CelloSaaS.WorkFlow.Model Namespace


WorkflowInput Class

[image]

A Sandcastle Documented Class Library
WorkflowInput Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowInput : IWorkflowInput
Visual Basic
<SerializableAttribute>
Public Class WorkflowInput
    Implements IWorkflowInput
Visual C++
[SerializableAttribute]
public ref class WorkflowInput : IWorkflowInput

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowInput
CelloSaaS.WorkFlow.Model..::..WFXmlInput

See Also

WorkflowInput Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInput Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowInput Members
WorkflowInput Class Constructors Methods Properties See Also Send Feedback

The WorkflowInput type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowInput | Initializes a new instance of the WorkflowInput class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterId | Gets or sets the filter id.
Public property | TenantId | Gets or sets the tenant id.

See Also

WorkflowInput Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInput Constructor

[image]

A Sandcastle Documented Class Library
WorkflowInput Constructor
WorkflowInput Class See Also Send Feedback
Initializes a new instance of the WorkflowInput class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowInput()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowInput()

See Also

WorkflowInput Class
WorkflowInput Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInput Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowInput Methods
WorkflowInput Class See Also Send Feedback

The WorkflowInput type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowInput Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInput Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowInput Properties
WorkflowInput Class See Also Send Feedback

The WorkflowInput type exposes the following members.

Properties

 | Name | Description
Public property | FilterId | Gets or sets the filter id.
Public property | TenantId | Gets or sets the tenant id.

See Also

WorkflowInput Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInput.FilterId Property

[image]

A Sandcastle Documented Class Library
WorkflowInput..::..FilterId Property
WorkflowInput Class See Also Send Feedback
Gets or sets the filter id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string FilterId { get; set; }
Visual Basic
Public Property FilterId As String
    Get
    Set
Visual C++
public:
virtual property String^ FilterId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
The filter id.

Implements

IWorkflowInput..::..FilterId

See Also

WorkflowInput Class
WorkflowInput Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInput.TenantId Property

[image]

A Sandcastle Documented Class Library
WorkflowInput..::..TenantId Property
WorkflowInput Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WorkflowInput Class
WorkflowInput Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInputAttributeMapper Class

[image]

A Sandcastle Documented Class Library
WorkflowInputAttributeMapper Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WorkflowInputAttributeMapper : Attribute
Visual Basic
Public Class WorkflowInputAttributeMapper
    Inherits Attribute
Visual C++
public ref class WorkflowInputAttributeMapper : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
CelloSaaS.WorkFlow.Model..::..WorkflowInputAttributeMapper

See Also

WorkflowInputAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInputAttributeMapper Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowInputAttributeMapper Members
WorkflowInputAttributeMapper Class Constructors Methods Properties See Also Send Feedback

The WorkflowInputAttributeMapper type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowInputAttributeMapper | Initializes a new instance of the WorkflowInputAttributeMapper class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MapType | Gets or sets the type of the map.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

WorkflowInputAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInputAttributeMapper Constructor

[image]

A Sandcastle Documented Class Library
WorkflowInputAttributeMapper Constructor
WorkflowInputAttributeMapper Class See Also Send Feedback
Initializes a new instance of the WorkflowInputAttributeMapper class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowInputAttributeMapper()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowInputAttributeMapper()

See Also

WorkflowInputAttributeMapper Class
WorkflowInputAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInputAttributeMapper Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowInputAttributeMapper Methods
WorkflowInputAttributeMapper Class See Also Send Feedback

The WorkflowInputAttributeMapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowInputAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInputAttributeMapper Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowInputAttributeMapper Properties
WorkflowInputAttributeMapper Class See Also Send Feedback

The WorkflowInputAttributeMapper type exposes the following members.

Properties

 | Name | Description
Public property | MapType | Gets or sets the type of the map.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

WorkflowInputAttributeMapper Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInputAttributeMapper.MapType Property

[image]

A Sandcastle Documented Class Library
WorkflowInputAttributeMapper..::..MapType Property
WorkflowInputAttributeMapper Class See Also Send Feedback
Gets or sets the type of the map.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Type MapType { get; set; }
Visual Basic
Public Property MapType As Type
    Get
    Set
Visual C++
public:
property Type^ MapType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
The type of the map.

See Also

WorkflowInputAttributeMapper Class
WorkflowInputAttributeMapper Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance Class

[image]

A Sandcastle Documented Class Library
WorkflowInstance Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowInstance
Visual Basic
<SerializableAttribute>
Public Class WorkflowInstance
Visual C++
[SerializableAttribute]
public ref class WorkflowInstance

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowInstance

See Also

WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowInstance Members
WorkflowInstance Class Constructors Methods Properties See Also Send Feedback

The WorkflowInstance type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowInstance | Initializes a new instance of the WorkflowInstance class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveTaskRouters | Gets or sets the active task routers.
Public property | ActiveTasks | Gets the active tasks.
Public property | CompletedTasks | Gets the completed tasks.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DefinitionId | Gets or sets the definition id.
Public property | Id | Gets or sets the id.
Public property | MapId | Gets or sets the map id.
Public property | RoutedTasks | Gets or sets the routed tasks.
Public property | StartedTasks | Gets the started tasks.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the Updated By.
Public property | UpdatedOn | Gets or sets the Updated On.
Public property | WFState | Gets or sets the state of the WF.
Public property | WorkflowDefinition | Gets or sets the workflow definition.
Public property | WorkflowElements | Gets or sets the workflow elements.
Public property | WorkflowInput | Gets or sets the workflow input.

See Also

WorkflowInstance Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance Constructor

[image]

A Sandcastle Documented Class Library
WorkflowInstance Constructor
WorkflowInstance Class See Also Send Feedback
Initializes a new instance of the WorkflowInstance class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowInstance()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowInstance()

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowInstance Methods
WorkflowInstance Class See Also Send Feedback

The WorkflowInstance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowInstance Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowInstance Properties
WorkflowInstance Class See Also Send Feedback

The WorkflowInstance type exposes the following members.

Properties

 | Name | Description
Public property | ActiveTaskRouters | Gets or sets the active task routers.
Public property | ActiveTasks | Gets the active tasks.
Public property | CompletedTasks | Gets the completed tasks.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | DefinitionId | Gets or sets the definition id.
Public property | Id | Gets or sets the id.
Public property | MapId | Gets or sets the map id.
Public property | RoutedTasks | Gets or sets the routed tasks.
Public property | StartedTasks | Gets the started tasks.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the Updated By.
Public property | UpdatedOn | Gets or sets the Updated On.
Public property | WFState | Gets or sets the state of the WF.
Public property | WorkflowDefinition | Gets or sets the workflow definition.
Public property | WorkflowElements | Gets or sets the workflow elements.
Public property | WorkflowInput | Gets or sets the workflow input.

See Also

WorkflowInstance Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.ActiveTaskRouters Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..ActiveTaskRouters Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the active task routers.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTaskRouter ActiveTaskRouters { get; set; }
Visual Basic
Public Property ActiveTaskRouters As WorkflowTaskRouter
    Get
    Set
Visual C++
public:
property WorkflowTaskRouter^ ActiveTaskRouters {
    WorkflowTaskRouter^ get ();
    void set (WorkflowTaskRouter^ value);
}

Property Value

Type: WorkflowTaskRouter
The active task routers.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.ActiveTasks Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..ActiveTasks Property
WorkflowInstance Class See Also Send Feedback
Gets the active tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<WorkflowTaskInstance> ActiveTasks { get; set; }
Visual Basic
Public Property ActiveTasks As List(Of WorkflowTaskInstance)
    Get
    Set
Visual C++
public:
property List<WorkflowTaskInstance^>^ ActiveTasks {
    List<WorkflowTaskInstance^>^ get ();
    void set (List<WorkflowTaskInstance^>^ value);
}

Property Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>
The active tasks.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.CompletedTasks Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..CompletedTasks Property
WorkflowInstance Class See Also Send Feedback
Gets the completed tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<WorkflowTaskInstance> CompletedTasks { get; set; }
Visual Basic
Public Property CompletedTasks As List(Of WorkflowTaskInstance)
    Get
    Set
Visual C++
public:
property List<WorkflowTaskInstance^>^ CompletedTasks {
    List<WorkflowTaskInstance^>^ get ();
    void set (List<WorkflowTaskInstance^>^ value);
}

Property Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>
The completed tasks.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.CreatedBy Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..CreatedBy Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.CreatedOn Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..CreatedOn Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.DefinitionId Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..DefinitionId Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the definition id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid DefinitionId { get; set; }
Visual Basic
Public Property DefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid DefinitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The definition id.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.Id Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..Id Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The id.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.MapId Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..MapId Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.RoutedTasks Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..RoutedTasks Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the routed tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<WorkflowTaskInstance> RoutedTasks { get; set; }
Visual Basic
Public Property RoutedTasks As List(Of WorkflowTaskInstance)
    Get
    Set
Visual C++
public:
property List<WorkflowTaskInstance^>^ RoutedTasks {
    List<WorkflowTaskInstance^>^ get ();
    void set (List<WorkflowTaskInstance^>^ value);
}

Property Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>
The routed tasks.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.StartedTasks Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..StartedTasks Property
WorkflowInstance Class See Also Send Feedback
Gets the started tasks.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<WorkflowTaskInstance> StartedTasks { get; set; }
Visual Basic
Public Property StartedTasks As List(Of WorkflowTaskInstance)
    Get
    Set
Visual C++
public:
property List<WorkflowTaskInstance^>^ StartedTasks {
    List<WorkflowTaskInstance^>^ get ();
    void set (List<WorkflowTaskInstance^>^ value);
}

Property Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>
The started tasks.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.Status Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..Status Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The status.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.TenantId Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..TenantId Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..UpdatedBy Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the Updated By.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The Updated by.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..UpdatedOn Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the Updated On.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The Updated On.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.WFState Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..WFState Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the state of the WF.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WFState WFState { get; set; }
Visual Basic
Public Property WFState As WFState
    Get
    Set
Visual C++
public:
property WFState^ WFState {
    WFState^ get ();
    void set (WFState^ value);
}

Property Value

Type: WFState
The state of the WF.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.WorkflowDefinition Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..WorkflowDefinition Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the workflow definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowDefinition WorkflowDefinition { get; set; }
Visual Basic
Public Property WorkflowDefinition As WorkflowDefinition
    Get
    Set
Visual C++
public:
property WorkflowDefinition^ WorkflowDefinition {
    WorkflowDefinition^ get ();
    void set (WorkflowDefinition^ value);
}

Property Value

Type: WorkflowDefinition
The workflow definition.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.WorkflowElements Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..WorkflowElements Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the workflow elements.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IWorkflowElement WorkflowElements { get; set; }
Visual Basic
Public Property WorkflowElements As IWorkflowElement
    Get
    Set
Visual C++
public:
property IWorkflowElement^ WorkflowElements {
    IWorkflowElement^ get ();
    void set (IWorkflowElement^ value);
}

Property Value

Type: IWorkflowElement
The workflow elements.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstance.WorkflowInput Property

[image]

A Sandcastle Documented Class Library
WorkflowInstance..::..WorkflowInput Property
WorkflowInstance Class See Also Send Feedback
Gets or sets the workflow input.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public IWorkflowInput WorkflowInput { get; set; }
Visual Basic
Public Property WorkflowInput As IWorkflowInput
    Get
    Set
Visual C++
public:
property IWorkflowInput^ WorkflowInput {
    IWorkflowInput^ get ();
    void set (IWorkflowInput^ value);
}

Property Value

Type: IWorkflowInput
The workflow input.

See Also

WorkflowInstance Class
WorkflowInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus Class

[image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class WorkflowInstanceStatus
Visual Basic
Public NotInheritable Class WorkflowInstanceStatus
Visual C++
public ref class WorkflowInstanceStatus abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowInstanceStatus

See Also

WorkflowInstanceStatus Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus Members
WorkflowInstanceStatus Class Fields See Also Send Feedback

The WorkflowInstanceStatus type exposes the following members.

Fields

Name | Description
Completed |
Created |
Started |
Suspended |

See Also

WorkflowInstanceStatus Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus Fields

[image] [image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus Fields
WorkflowInstanceStatus Class See Also Send Feedback

The WorkflowInstanceStatus type exposes the following members.

Fields

Name | Description
Completed |
Created |
Started |
Suspended |

See Also

WorkflowInstanceStatus Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus.Completed Field

[image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus..::..Completed Field
WorkflowInstanceStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Completed
Visual Basic
Public Const Completed As String
Visual C++
public:
literal String^ Completed

Field Value

Type: String

See Also

WorkflowInstanceStatus Class
WorkflowInstanceStatus Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus.Created Field

[image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus..::..Created Field
WorkflowInstanceStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Created
Visual Basic
Public Const Created As String
Visual C++
public:
literal String^ Created

Field Value

Type: String

See Also

WorkflowInstanceStatus Class
WorkflowInstanceStatus Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus.Started Field

[image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus..::..Started Field
WorkflowInstanceStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Started
Visual Basic
Public Const Started As String
Visual C++
public:
literal String^ Started

Field Value

Type: String

See Also

WorkflowInstanceStatus Class
WorkflowInstanceStatus Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowInstanceStatus.Suspended Field

[image]

A Sandcastle Documented Class Library
WorkflowInstanceStatus..::..Suspended Field
WorkflowInstanceStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Suspended
Visual Basic
Public Const Suspended As String
Visual C++
public:
literal String^ Suspended

Field Value

Type: String

See Also

WorkflowInstanceStatus Class
WorkflowInstanceStatus Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel Class

[image]

A Sandcastle Documented Class Library
WorkflowModel Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowModel
Visual Basic
<SerializableAttribute>
Public Class WorkflowModel
Visual C++
[SerializableAttribute]
public ref class WorkflowModel

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowModel

See Also

WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowModel Members
WorkflowModel Class Constructors Methods Properties See Also Send Feedback

The WorkflowModel type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowModel | Initializes a new instance of the WorkflowModel class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetActiveVersion | Sets the active version.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveVersion | Gets or sets the active version.
Public property | CategoryName | Gets or sets the name of the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the id.
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | WFInputFinderType | Gets or sets the type of the WF input finder.
Public property | WFXmlTransform | Gets or sets the WF XML transform.

See Also

WorkflowModel Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel Constructor

[image]

A Sandcastle Documented Class Library
WorkflowModel Constructor
WorkflowModel Class See Also Send Feedback
Initializes a new instance of the WorkflowModel class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowModel()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowModel()

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowModel Methods
WorkflowModel Class See Also Send Feedback

The WorkflowModel type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetActiveVersion | Sets the active version.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowModel Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.SetActiveVersion Method

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..SetActiveVersion Method
WorkflowModel Class See Also Send Feedback
Sets the active version.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public void SetActiveVersion(
    int version
)
Visual Basic
Public Sub SetActiveVersion (
    version As Integer
)
Visual C++
public:
void SetActiveVersion(
    int version
)

Parameters

version
Type: System..::..Int32
The version.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowModel Properties
WorkflowModel Class See Also Send Feedback

The WorkflowModel type exposes the following members.

Properties

 | Name | Description
Public property | ActiveVersion | Gets or sets the active version.
Public property | CategoryName | Gets or sets the name of the category.
Public property | CreatedBy | Gets or sets the created by.
Public property | CreatedOn | Gets or sets the created on.
Public property | Description | Gets or sets the description.
Public property | Id | Gets or sets the id.
Public property | Name | Gets or sets the name.
Public property | Status | Gets or sets the status.
Public property | TenantId | Gets or sets the tenant id.
Public property | UpdatedBy | Gets or sets the updated by.
Public property | UpdatedOn | Gets or sets the updated on.
Public property | WFInputFinderType | Gets or sets the type of the WF input finder.
Public property | WFXmlTransform | Gets or sets the WF XML transform.

See Also

WorkflowModel Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.ActiveVersion Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..ActiveVersion Property
WorkflowModel Class See Also Send Feedback
Gets or sets the active version.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ActiveVersion { get; private set; }
Visual Basic
Public Property ActiveVersion As Integer
    Get
    Private Set
Visual C++
public:
property int ActiveVersion {
    int get ();
    private: void set (int value);
}

Property Value

Type: Int32
The active version.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.CategoryName Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..CategoryName Property
WorkflowModel Class See Also Send Feedback
Gets or sets the name of the category.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CategoryName { get; set; }
Visual Basic
Public Property CategoryName As String
    Get
    Set
Visual C++
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name of the category.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.CreatedBy Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..CreatedBy Property
WorkflowModel Class See Also Send Feedback
Gets or sets the created by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CreatedBy { get; set; }
Visual Basic
Public Property CreatedBy As String
    Get
    Set
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The created by.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.CreatedOn Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..CreatedOn Property
WorkflowModel Class See Also Send Feedback
Gets or sets the created on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime CreatedOn { get; set; }
Visual Basic
Public Property CreatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime CreatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The created on.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.Description Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..Description Property
WorkflowModel Class See Also Send Feedback
Gets or sets the description.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The description.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.Id Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..Id Property
WorkflowModel Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The id.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.Name Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..Name Property
WorkflowModel Class See Also Send Feedback
Gets or sets the name.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The name.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.Status Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..Status Property
WorkflowModel Class See Also Send Feedback
Gets or sets the status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public bool Status { get; set; }
Visual Basic
Public Property Status As Boolean
    Get
    Set
Visual C++
public:
property bool Status {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
The status.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.TenantId Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..TenantId Property
WorkflowModel Class See Also Send Feedback
Gets or sets the tenant id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string TenantId { get; set; }
Visual Basic
Public Property TenantId As String
    Get
    Set
Visual C++
public:
property String^ TenantId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The tenant id.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.UpdatedBy Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..UpdatedBy Property
WorkflowModel Class See Also Send Feedback
Gets or sets the updated by.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string UpdatedBy { get; set; }
Visual Basic
Public Property UpdatedBy As String
    Get
    Set
Visual C++
public:
property String^ UpdatedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The updated by.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.UpdatedOn Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..UpdatedOn Property
WorkflowModel Class See Also Send Feedback
Gets or sets the updated on.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DateTime UpdatedOn { get; set; }
Visual Basic
Public Property UpdatedOn As DateTime
    Get
    Set
Visual C++
public:
property DateTime UpdatedOn {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
The updated on.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.WFInputFinderType Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..WFInputFinderType Property
WorkflowModel Class See Also Send Feedback
Gets or sets the type of the WF input finder.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFInputFinderType { get; set; }
Visual Basic
Public Property WFInputFinderType As String
    Get
    Set
Visual C++
public:
property String^ WFInputFinderType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The type of the WF input finder.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowModel.WFXmlTransform Property

[image]

A Sandcastle Documented Class Library
WorkflowModel..::..WFXmlTransform Property
WorkflowModel Class See Also Send Feedback
Gets or sets the WF XML transform.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string WFXmlTransform { get; set; }
Visual Basic
Public Property WFXmlTransform As String
    Get
    Set
Visual C++
public:
property String^ WFXmlTransform {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The WF XML transform.

See Also

WorkflowModel Class
WorkflowModel Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask Class

[image]

A Sandcastle Documented Class Library
WorkflowTask Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowTask
Visual Basic
<SerializableAttribute>
Public Class WorkflowTask
Visual C++
[SerializableAttribute]
public ref class WorkflowTask

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowTask

See Also

WorkflowTask Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowTask Members
WorkflowTask Class Constructors Methods Fields Properties See Also Send Feedback

The WorkflowTask type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowTask | Initializes a new instance of the WorkflowTask class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

 | Name | Description
Public field | TaskId |

Properties

 | Name | Description
Public property | TaskDefinition | Gets or sets the task definition.

See Also

WorkflowTask Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask Constructor

[image]

A Sandcastle Documented Class Library
WorkflowTask Constructor
WorkflowTask Class See Also Send Feedback
Initializes a new instance of the WorkflowTask class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTask()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowTask()

See Also

WorkflowTask Class
WorkflowTask Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask Fields

[image] [image]

A Sandcastle Documented Class Library
WorkflowTask Fields
WorkflowTask Class See Also Send Feedback

The WorkflowTask type exposes the following members.

Fields

 | Name | Description
Public field | TaskId |

See Also

WorkflowTask Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask.TaskId Field

[image]

A Sandcastle Documented Class Library
WorkflowTask..::..TaskId Field
WorkflowTask Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid TaskId
Visual Basic
Public TaskId As Guid
Visual C++
public:
Guid TaskId

Field Value

Type: Guid

See Also

WorkflowTask Class
WorkflowTask Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowTask Methods
WorkflowTask Class See Also Send Feedback

The WorkflowTask type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowTask Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowTask Properties
WorkflowTask Class See Also Send Feedback

The WorkflowTask type exposes the following members.

Properties

 | Name | Description
Public property | TaskDefinition | Gets or sets the task definition.

See Also

WorkflowTask Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTask.TaskDefinition Property

[image]

A Sandcastle Documented Class Library
WorkflowTask..::..TaskDefinition Property
WorkflowTask Class See Also Send Feedback
Gets or sets the task definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskDefinition TaskDefinition { get; set; }
Visual Basic
Public Property TaskDefinition As TaskDefinition
    Get
    Set
Visual C++
public:
property TaskDefinition^ TaskDefinition {
    TaskDefinition^ get ();
    void set (TaskDefinition^ value);
}

Property Value

Type: TaskDefinition
The task definition.

See Also

WorkflowTask Class
WorkflowTask Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance Class

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowTaskInstance : IWorkflowElement
Visual Basic
<SerializableAttribute>
Public Class WorkflowTaskInstance
    Implements IWorkflowElement
Visual C++
[SerializableAttribute]
public ref class WorkflowTaskInstance : IWorkflowElement

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowTaskInstance
CelloSaaS.WorkFlow.Model..::..AutoWorkflowTaskInstance
CelloSaaS.WorkFlow.Model..::..ManualWorkflowTaskInstance

See Also

WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowTaskInstance Members
WorkflowTaskInstance Class Constructors Methods Properties See Also Send Feedback

The WorkflowTaskInstance type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowTaskInstance | Initializes a new instance of the WorkflowTaskInstance class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id.
Public property | AffectedExecutionStatus | Gets or sets the affected execution status.
Public property | AffectedOutComes | Gets or sets the affected out comes.
Public property | CurrentExecutionStatus | Gets or sets the current execution status.
Public property | DateTimeCompleted | Gets or sets the date time completed.
Public property | DateTimeExpired | Gets or sets the date time expired.
Public property | DateTimeUpdated | Gets or sets the date time updated.
Public property | ExecutionOrder | Gets or sets the execution order.
Public property | ExecutionStatus | Gets or sets the execution status.
Public property | Id | Gets or sets the id.
Public property | InvokedTaskDefinitionRouterId | Gets or sets the invoked task definition router id.
Public property | MapId | Gets or sets the map id.
Public property | OutComes | Gets or sets the out comes.
Public property | PreviousExecutionStatus | Gets or sets the previous execution status.
Public property | StartTime | Gets or sets the start time.
Public property | Task | Gets or sets the task.
Public property | TaskDefinition | Gets the task definition.
Public property | WFId | Gets or sets the WF id.
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id.
Public property | WorkFlowInstanceId | Gets or sets the work flow instance id.

See Also

WorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance Constructor

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance Constructor
WorkflowTaskInstance Class See Also Send Feedback
Initializes a new instance of the WorkflowTaskInstance class.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTaskInstance(
    Guid taskInstanceId,
    int executionOrder
)
Visual Basic
Public Sub New (
    taskInstanceId As Guid,
    executionOrder As Integer
)
Visual C++
public:
WorkflowTaskInstance(
    Guid taskInstanceId,
    int executionOrder
)

Parameters

taskInstanceId
Type: System..::..Guid
The task instance id.
executionOrder
Type: System..::..Int32
The execution order.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowTaskInstance Methods
WorkflowTaskInstance Class See Also Send Feedback

The WorkflowTaskInstance type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowTaskInstance Properties
WorkflowTaskInstance Class See Also Send Feedback

The WorkflowTaskInstance type exposes the following members.

Properties

 | Name | Description
Public property | ActorId | Gets or sets the actor id.
Public property | AffectedExecutionStatus | Gets or sets the affected execution status.
Public property | AffectedOutComes | Gets or sets the affected out comes.
Public property | CurrentExecutionStatus | Gets or sets the current execution status.
Public property | DateTimeCompleted | Gets or sets the date time completed.
Public property | DateTimeExpired | Gets or sets the date time expired.
Public property | DateTimeUpdated | Gets or sets the date time updated.
Public property | ExecutionOrder | Gets or sets the execution order.
Public property | ExecutionStatus | Gets or sets the execution status.
Public property | Id | Gets or sets the id.
Public property | InvokedTaskDefinitionRouterId | Gets or sets the invoked task definition router id.
Public property | MapId | Gets or sets the map id.
Public property | OutComes | Gets or sets the out comes.
Public property | PreviousExecutionStatus | Gets or sets the previous execution status.
Public property | StartTime | Gets or sets the start time.
Public property | Task | Gets or sets the task.
Public property | TaskDefinition | Gets the task definition.
Public property | WFId | Gets or sets the WF id.
Public property | WorkFlowDefinitionId | Gets or sets the work flow definition id.
Public property | WorkFlowInstanceId | Gets or sets the work flow instance id.

See Also

WorkflowTaskInstance Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.ActorId Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..ActorId Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the actor id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string ActorId { get; set; }
Visual Basic
Public Property ActorId As String
    Get
    Set
Visual C++
public:
property String^ ActorId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The actor id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.AffectedExecutionStatus Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..AffectedExecutionStatus Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the affected execution status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> AffectedExecutionStatus { get; set; }
Visual Basic
Public Property AffectedExecutionStatus As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ AffectedExecutionStatus {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The affected execution status.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.AffectedOutComes Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..AffectedOutComes Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the affected out comes.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> AffectedOutComes { get; set; }
Visual Basic
Public Property AffectedOutComes As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ AffectedOutComes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The affected out comes.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.CurrentExecutionStatus Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..CurrentExecutionStatus Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the current execution status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string CurrentExecutionStatus { get; set; }
Visual Basic
Public Property CurrentExecutionStatus As String
    Get
    Set
Visual C++
public:
property String^ CurrentExecutionStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The current execution status.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.DateTimeCompleted Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..DateTimeCompleted Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the date time completed.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> DateTimeCompleted { get; set; }
Visual Basic
Public Property DateTimeCompleted As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DateTimeCompleted {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The date time completed.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.DateTimeExpired Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..DateTimeExpired Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the date time expired.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> DateTimeExpired { get; set; }
Visual Basic
Public Property DateTimeExpired As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DateTimeExpired {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The date time expired.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.DateTimeUpdated Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..DateTimeUpdated Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the date time updated.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> DateTimeUpdated { get; set; }
Visual Basic
Public Property DateTimeUpdated As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DateTimeUpdated {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The date time updated.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.ExecutionOrder Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..ExecutionOrder Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the execution order.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public int ExecutionOrder { get; set; }
Visual Basic
Public Property ExecutionOrder As Integer
    Get
    Set
Visual C++
public:
property int ExecutionOrder {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
The execution order.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.ExecutionStatus Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..ExecutionStatus Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the execution status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> ExecutionStatus { get; set; }
Visual Basic
Public Property ExecutionStatus As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ ExecutionStatus {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The execution status.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.Id Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..Id Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.InvokedTaskDefinitionRouterId Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..InvokedTaskDefinitionRouterId Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the invoked task definition router id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<Guid> InvokedTaskDefinitionRouterId { get; set; }
Visual Basic
Public Property InvokedTaskDefinitionRouterId As Nullable(Of Guid)
    Get
    Set
Visual C++
public:
property Nullable<Guid> InvokedTaskDefinitionRouterId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable<(Of <(<'Guid>)>)>
The invoked task definition router id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.MapId Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..MapId Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the map id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string MapId { get; set; }
Visual Basic
Public Property MapId As String
    Get
    Set
Visual C++
public:
property String^ MapId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The map id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.OutComes Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..OutComes Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the out comes.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public List<string> OutComes { get; set; }
Visual Basic
Public Property OutComes As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ OutComes {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List<(Of <(<'String>)>)>
The out comes.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.PreviousExecutionStatus Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..PreviousExecutionStatus Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the previous execution status.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public string PreviousExecutionStatus { get; set; }
Visual Basic
Public Property PreviousExecutionStatus As String
    Get
    Set
Visual C++
public:
property String^ PreviousExecutionStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The previous execution status.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.StartTime Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..StartTime Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the start time.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Nullable<DateTime> StartTime { get; set; }
Visual Basic
Public Property StartTime As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> StartTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

Property Value

Type: Nullable<(Of <(<'DateTime>)>)>
The start time.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.Task Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..Task Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the task.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTask Task { get; set; }
Visual Basic
Public Property Task As WorkflowTask
    Get
    Set
Visual C++
public:
property WorkflowTask^ Task {
    WorkflowTask^ get ();
    void set (WorkflowTask^ value);
}

Property Value

Type: WorkflowTask
The task.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.TaskDefinition Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..TaskDefinition Property
WorkflowTaskInstance Class See Also Send Feedback
Gets the task definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskDefinition TaskDefinition { get; private set; }
Visual Basic
Public Property TaskDefinition As TaskDefinition
    Get
    Private Set
Visual C++
public:
property TaskDefinition^ TaskDefinition {
    TaskDefinition^ get ();
    private: void set (TaskDefinition^ value);
}

Property Value

Type: TaskDefinition
The task definition.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.WFId Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..WFId Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the WF id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WFId { get; set; }
Visual Basic
Public Property WFId As Guid
    Get
    Set
Visual C++
public:
property Guid WFId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The WF id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.WorkFlowDefinitionId Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..WorkFlowDefinitionId Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the work flow definition id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WorkFlowDefinitionId { get; set; }
Visual Basic
Public Property WorkFlowDefinitionId As Guid
    Get
    Set
Visual C++
public:
property Guid WorkFlowDefinitionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The work flow definition id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskInstance.WorkFlowInstanceId Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskInstance..::..WorkFlowInstanceId Property
WorkflowTaskInstance Class See Also Send Feedback
Gets or sets the work flow instance id.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public Guid WorkFlowInstanceId { get; set; }
Visual Basic
Public Property WorkFlowInstanceId As Guid
    Get
    Set
Visual C++
public:
property Guid WorkFlowInstanceId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
The work flow instance id.

See Also

WorkflowTaskInstance Class
WorkflowTaskInstance Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter Class

[image]

A Sandcastle Documented Class Library
WorkflowTaskRouter Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkflowTaskRouter : IWorkflowElement
Visual Basic
<SerializableAttribute>
Public Class WorkflowTaskRouter
    Implements IWorkflowElement
Visual C++
[SerializableAttribute]
public ref class WorkflowTaskRouter : IWorkflowElement

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.Model..::..WorkflowTaskRouter
CelloSaaS.WorkFlow.Model..::..IfElseWorkflowTaskRouter

See Also

WorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowTaskRouter Members
WorkflowTaskRouter Class Constructors Methods Properties See Also Send Feedback

The WorkflowTaskRouter type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowTaskRouter | Initializes a new instance of the WorkflowTaskRouter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Gets or sets the definition.
Public property | RoutingTable | Gets or sets the routing table.

See Also

WorkflowTaskRouter Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter Constructor

[image]

A Sandcastle Documented Class Library
WorkflowTaskRouter Constructor
WorkflowTaskRouter Class See Also Send Feedback
Initializes a new instance of the WorkflowTaskRouter class

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowTaskRouter()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowTaskRouter()

See Also

WorkflowTaskRouter Class
WorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowTaskRouter Methods
WorkflowTaskRouter Class See Also Send Feedback

The WorkflowTaskRouter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates this instance.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowTaskRouter Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter.Evaluate Method

[image]

A Sandcastle Documented Class Library
WorkflowTaskRouter..::..Evaluate Method
WorkflowTaskRouter Class See Also Send Feedback
Evaluates this instance.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public virtual List<Guid> Evaluate(
    WorkflowInstance instance
)
Visual Basic
Public Overridable Function Evaluate (
    instance As WorkflowInstance
) As List(Of Guid)
Visual C++
public:
virtual List<Guid>^ Evaluate(
    WorkflowInstance^ instance
)

Parameters

instance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance

Return Value

Type: List<(Of <(<'Guid>)>)>

See Also

WorkflowTaskRouter Class
WorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter Properties

[image] [image]

A Sandcastle Documented Class Library
WorkflowTaskRouter Properties
WorkflowTaskRouter Class See Also Send Feedback

The WorkflowTaskRouter type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets or sets the definition.
Public property | RoutingTable | Gets or sets the routing table.

See Also

WorkflowTaskRouter Class
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter.Definition Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskRouter..::..Definition Property
WorkflowTaskRouter Class See Also Send Feedback
Gets or sets the definition.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public TaskRouterDefinition Definition { get; set; }
Visual Basic
Public Property Definition As TaskRouterDefinition
    Get
    Set
Visual C++
public:
property TaskRouterDefinition^ Definition {
    TaskRouterDefinition^ get ();
    void set (TaskRouterDefinition^ value);
}

Property Value

Type: TaskRouterDefinition
The definition.

See Also

WorkflowTaskRouter Class
WorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


WorkflowTaskRouter.RoutingTable Property

[image]

A Sandcastle Documented Class Library
WorkflowTaskRouter..::..RoutingTable Property
WorkflowTaskRouter Class See Also Send Feedback
Gets or sets the routing table.

Namespace: CelloSaaS.WorkFlow.Model
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public RoutingTable RoutingTable { get; set; }
Visual Basic
Public Property RoutingTable As RoutingTable
    Get
    Set
Visual C++
public:
property RoutingTable^ RoutingTable {
    RoutingTable^ get ();
    void set (RoutingTable^ value);
}

Property Value

Type: RoutingTable
The routing table.

See Also

WorkflowTaskRouter Class
WorkflowTaskRouter Members
CelloSaaS.WorkFlow.Model Namespace


CelloSaaS.WorkFlow.ServiceContracts Namespace

[image]

A Sandcastle Documented Class Library
CelloSaaS.WorkFlow.ServiceContracts Namespace
Send Feedback

Classes

 | Class | Description
Public class | BatchWorkFlowConstants |
Public class | DuplicateWorkflowNameException | Represents the workflow name already exsits.
Public class | WorkflowConstants |
Public class | WorkFlowException | Represents errors that occur during WorkFlow Service execution.
Public class | WorkFlowExecutionStatus |
Public class | WorkFlowPrivilegeConstants |
Public class | WorkFlowTrackingConstants |

Interfaces

 | Interface | Description
Public interface | IActivityService |
Public interface | IWFTrackAuditService |
Public interface | IWFTrackingService |
Public interface | IWorkFlowBatchService |
Public interface | IWorkflowDefinitionService |
Public interface | IWorkflowInstanceService |
Public interface | IWorkflowRequestService |
Public interface | IWorkflowService |
Public interface | IWorkflowTaskActorService |
Public interface | IWorkflowTaskInstanceService |


BatchWorkFlowConstants Class

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class BatchWorkFlowConstants
Visual Basic
Public NotInheritable Class BatchWorkFlowConstants
Visual C++
public ref class BatchWorkFlowConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.ServiceContracts..::..BatchWorkFlowConstants

See Also

BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants Members

[image] [image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants Members
BatchWorkFlowConstants Class Fields See Also Send Feedback

The BatchWorkFlowConstants type exposes the following members.

Fields

Name | Description
BulkCopyBatchSize |
BulkCopyTimeOut |
DefaultBulkCopyBatchSize |
DefaultParallelThreadSize |
DefaultWFProcessBlockSize |
DefaultWFQueueFillTime |
FillWorkFlowTime |
ParallelThreadSize |
WorkFlowProcessBlockSize |

See Also

BatchWorkFlowConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants Fields

[image] [image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants Fields
BatchWorkFlowConstants Class See Also Send Feedback

The BatchWorkFlowConstants type exposes the following members.

Fields

Name | Description
BulkCopyBatchSize |
BulkCopyTimeOut |
DefaultBulkCopyBatchSize |
DefaultParallelThreadSize |
DefaultWFProcessBlockSize |
DefaultWFQueueFillTime |
FillWorkFlowTime |
ParallelThreadSize |
WorkFlowProcessBlockSize |

See Also

BatchWorkFlowConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.BulkCopyBatchSize Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..BulkCopyBatchSize Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BulkCopyBatchSize
Visual Basic
Public Const BulkCopyBatchSize As String
Visual C++
public:
literal String^ BulkCopyBatchSize

Field Value

Type: String

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.BulkCopyTimeOut Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..BulkCopyTimeOut Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string BulkCopyTimeOut
Visual Basic
Public Const BulkCopyTimeOut As String
Visual C++
public:
literal String^ BulkCopyTimeOut

Field Value

Type: String

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.DefaultBulkCopyBatchSize Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..DefaultBulkCopyBatchSize Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultBulkCopyBatchSize
Visual Basic
Public Const DefaultBulkCopyBatchSize As Integer
Visual C++
public:
literal int DefaultBulkCopyBatchSize

Field Value

Type: Int32

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.DefaultParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..DefaultParallelThreadSize Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultParallelThreadSize
Visual Basic
Public Const DefaultParallelThreadSize As Integer
Visual C++
public:
literal int DefaultParallelThreadSize

Field Value

Type: Int32

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.DefaultWFProcessBlockSize Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..DefaultWFProcessBlockSize Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultWFProcessBlockSize
Visual Basic
Public Const DefaultWFProcessBlockSize As Integer
Visual C++
public:
literal int DefaultWFProcessBlockSize

Field Value

Type: Int32

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.DefaultWFQueueFillTime Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..DefaultWFQueueFillTime Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultWFQueueFillTime
Visual Basic
Public Const DefaultWFQueueFillTime As Integer
Visual C++
public:
literal int DefaultWFQueueFillTime

Field Value

Type: Int32

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.FillWorkFlowTime Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..FillWorkFlowTime Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string FillWorkFlowTime
Visual Basic
Public Const FillWorkFlowTime As String
Visual C++
public:
literal String^ FillWorkFlowTime

Field Value

Type: String

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.ParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..ParallelThreadSize Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ParallelThreadSize
Visual Basic
Public Const ParallelThreadSize As String
Visual C++
public:
literal String^ ParallelThreadSize

Field Value

Type: String

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


BatchWorkFlowConstants.WorkFlowProcessBlockSize Field

[image]

A Sandcastle Documented Class Library
BatchWorkFlowConstants..::..WorkFlowProcessBlockSize Field
BatchWorkFlowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WorkFlowProcessBlockSize
Visual Basic
Public Const WorkFlowProcessBlockSize As String
Visual C++
public:
literal String^ WorkFlowProcessBlockSize

Field Value

Type: String

See Also

BatchWorkFlowConstants Class
BatchWorkFlowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


DuplicateWorkflowNameException Class

[image]

A Sandcastle Documented Class Library
DuplicateWorkflowNameException Class
Members See Also Send Feedback
Represents the workflow name already exsits.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class DuplicateWorkflowNameException : Exception
Visual Basic
<SerializableAttribute>
Public Class DuplicateWorkflowNameException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class DuplicateWorkflowNameException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.WorkFlow.ServiceContracts..::..DuplicateWorkflowNameException

See Also

DuplicateWorkflowNameException Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


DuplicateWorkflowNameException Members

[image] [image]

A Sandcastle Documented Class Library
DuplicateWorkflowNameException Members
DuplicateWorkflowNameException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateWorkflowNameException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateWorkflowNameException | Initializes a new instance of the WorkFlowException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateWorkflowNameException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


DuplicateWorkflowNameException Constructor

[image]

A Sandcastle Documented Class Library
DuplicateWorkflowNameException Constructor
DuplicateWorkflowNameException Class See Also Send Feedback
Initializes a new instance of the WorkFlowException class with a specified error message.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public DuplicateWorkflowNameException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
DuplicateWorkflowNameException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

DuplicateWorkflowNameException Class
DuplicateWorkflowNameException Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


DuplicateWorkflowNameException Methods

[image] [image]

A Sandcastle Documented Class Library
DuplicateWorkflowNameException Methods
DuplicateWorkflowNameException Class See Also Send Feedback

The DuplicateWorkflowNameException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateWorkflowNameException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


DuplicateWorkflowNameException Properties

[image] [image]

A Sandcastle Documented Class Library
DuplicateWorkflowNameException Properties
DuplicateWorkflowNameException Class See Also Send Feedback

The DuplicateWorkflowNameException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DuplicateWorkflowNameException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


DuplicateWorkflowNameException Events

[image] [image]

A Sandcastle Documented Class Library
DuplicateWorkflowNameException Events
DuplicateWorkflowNameException Class See Also Send Feedback

The DuplicateWorkflowNameException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateWorkflowNameException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService Interface

[image]

A Sandcastle Documented Class Library
IActivityService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IActivityService
Visual Basic
Public Interface IActivityService
Visual C++
public interface class IActivityService

See Also

IActivityService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService Members

[image] [image]

A Sandcastle Documented Class Library
IActivityService Members
IActivityService Interface Methods See Also Send Feedback

The IActivityService type exposes the following members.

Methods

 | Name | Description
Public method | CreateActivity | Creates the activity.
Public method | DeleteActivity | Deletes the activity.
Public method | GetActivities | Gets the activities.
Public method | GetActivity(String, String) | Gets the activity.
Public method | GetActivity(String, String, String) | Gets the activity.
Public method | UpdateActivity | Updates the activity.

See Also

IActivityService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService Methods

[image] [image]

A Sandcastle Documented Class Library
IActivityService Methods
IActivityService Interface See Also Send Feedback

The IActivityService type exposes the following members.

Methods

 | Name | Description
Public method | CreateActivity | Creates the activity.
Public method | DeleteActivity | Deletes the activity.
Public method | GetActivities | Gets the activities.
Public method | GetActivity(String, String) | Gets the activity.
Public method | GetActivity(String, String, String) | Gets the activity.
Public method | UpdateActivity | Updates the activity.

See Also

IActivityService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.CreateActivity Method

[image]

A Sandcastle Documented Class Library
IActivityService..::..CreateActivity Method
IActivityService Interface See Also Send Feedback
Creates the activity.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Guid CreateActivity(
    ActivityDetails activityDetails
)
Visual Basic
Function CreateActivity (
    activityDetails As ActivityDetails
) As Guid
Visual C++
Guid CreateActivity(
    ActivityDetails^ activityDetails
)

Parameters

activityDetails
Type: CelloSaaS.WorkFlow.Model..::..ActivityDetails
The activity details.

Return Value

Type: Guid
The Guid

See Also

IActivityService Interface
IActivityService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.DeleteActivity Method

[image]

A Sandcastle Documented Class Library
IActivityService..::..DeleteActivity Method
IActivityService Interface See Also Send Feedback
Deletes the activity.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteActivity(
    string workflowId,
    string activityId
)
Visual Basic
Sub DeleteActivity (
    workflowId As String,
    activityId As String
)
Visual C++
void DeleteActivity(
    String^ workflowId,
    String^ activityId
)

Parameters

workflowId
Type: System..::..String
The workflow id.
activityId
Type: System..::..String
The activity id.

See Also

IActivityService Interface
IActivityService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.GetActivities Method

[image]

A Sandcastle Documented Class Library
IActivityService..::..GetActivities Method
IActivityService Interface See Also Send Feedback
Gets the activities.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ActivityDetails> GetActivities(
    string workflowId
)
Visual Basic
Function GetActivities (
    workflowId As String
) As List(Of ActivityDetails)
Visual C++
List<ActivityDetails^>^ GetActivities(
    String^ workflowId
)

Parameters

workflowId
Type: System..::..String
The workflow id.

Return Value

Type: List<(Of <(<' ActivityDetails >)>)>
List of ActivityDetails

See Also

IActivityService Interface
IActivityService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.GetActivity Method

[image] [image]

A Sandcastle Documented Class Library
IActivityService..::..GetActivity Method
IActivityService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetActivity(String, String) | Gets the activity.
Public method | GetActivity(String, String, String) | Gets the activity.

See Also

IActivityService Interface
IActivityService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.GetActivity Method (String, String)

[image]

A Sandcastle Documented Class Library
IActivityService..::..GetActivity Method (String, String)
IActivityService Interface See Also Send Feedback
Gets the activity.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ActivityDetails GetActivity(
    string workflowId,
    string activityId
)
Visual Basic
Function GetActivity (
    workflowId As String,
    activityId As String
) As ActivityDetails
Visual C++
ActivityDetails^ GetActivity(
    String^ workflowId,
    String^ activityId
)

Parameters

workflowId
Type: System..::..String
The workflow id(Mandatory).
activityId
Type: System..::..String
The activity id(Mandatory).

Return Value

Type: ActivityDetails
The ActivityDetails

See Also

IActivityService Interface
IActivityService Members
GetActivity Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.GetActivity Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IActivityService..::..GetActivity Method (String, String, String)
IActivityService Interface See Also Send Feedback
Gets the activity.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
ActivityDetails GetActivity(
    string workflowId,
    string typeName,
    string assemblyName
)
Visual Basic
Function GetActivity (
    workflowId As String,
    typeName As String,
    assemblyName As String
) As ActivityDetails
Visual C++
ActivityDetails^ GetActivity(
    String^ workflowId,
    String^ typeName,
    String^ assemblyName
)

Parameters

workflowId
Type: System..::..String
The workflow id(Mandatory).
typeName
Type: System..::..String
Name of the type(Mandatory).
assemblyName
Type: System..::..String
Name of the assembly(Mandatory).

Return Value

Type: ActivityDetails
The ActivityDetails

See Also

IActivityService Interface
IActivityService Members
GetActivity Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IActivityService.UpdateActivity Method

[image]

A Sandcastle Documented Class Library
IActivityService..::..UpdateActivity Method
IActivityService Interface See Also Send Feedback
Updates the activity.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateActivity(
    ActivityDetails activityDetails
)
Visual Basic
Sub UpdateActivity (
    activityDetails As ActivityDetails
)
Visual C++
void UpdateActivity(
    ActivityDetails^ activityDetails
)

Parameters

activityDetails
Type: CelloSaaS.WorkFlow.Model..::..ActivityDetails
The activity details.

See Also

IActivityService Interface
IActivityService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackAuditService Interface

[image]

A Sandcastle Documented Class Library
IWFTrackAuditService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWFTrackAuditService
Visual Basic
Public Interface IWFTrackAuditService
Visual C++
public interface class IWFTrackAuditService

See Also

IWFTrackAuditService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackAuditService Members

[image] [image]

A Sandcastle Documented Class Library
IWFTrackAuditService Members
IWFTrackAuditService Interface Methods See Also Send Feedback

The IWFTrackAuditService type exposes the following members.

Methods

 | Name | Description
Public method | SaveWFTrackAuditDetails | Saves the WF track audit details.
Public method | SearchWFTrackAuditDetails | Searches the wf track audit table from the specified search parameter.

See Also

IWFTrackAuditService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackAuditService Methods

[image] [image]

A Sandcastle Documented Class Library
IWFTrackAuditService Methods
IWFTrackAuditService Interface See Also Send Feedback

The IWFTrackAuditService type exposes the following members.

Methods

 | Name | Description
Public method | SaveWFTrackAuditDetails | Saves the WF track audit details.
Public method | SearchWFTrackAuditDetails | Searches the wf track audit table from the specified search parameter.

See Also

IWFTrackAuditService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackAuditService.SaveWFTrackAuditDetails Method

[image]

A Sandcastle Documented Class Library
IWFTrackAuditService..::..SaveWFTrackAuditDetails Method
IWFTrackAuditService Interface See Also Send Feedback
Saves the WF track audit details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveWFTrackAuditDetails(
    List<WFTrackAudit> wfTrackAuditDetails
)
Visual Basic
Sub SaveWFTrackAuditDetails (
    wfTrackAuditDetails As List(Of WFTrackAudit)
)
Visual C++
void SaveWFTrackAuditDetails(
    List<WFTrackAudit^>^ wfTrackAuditDetails
)

Parameters

wfTrackAuditDetails
Type: System.Collections.Generic..::..List<(Of <(<' WFTrackAudit >)>)>
The wf track audit details.

See Also

IWFTrackAuditService Interface
IWFTrackAuditService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackAuditService.SearchWFTrackAuditDetails Method

[image]

A Sandcastle Documented Class Library
IWFTrackAuditService..::..SearchWFTrackAuditDetails Method
IWFTrackAuditService Interface See Also Send Feedback
Searches the wf track audit table from the specified search parameter.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WFTrackAudit> SearchWFTrackAuditDetails(
    WFTrackAuditSearchParameter searchParameter
)
Visual Basic
Function SearchWFTrackAuditDetails (
    searchParameter As WFTrackAuditSearchParameter
) As List(Of WFTrackAudit)
Visual C++
List<WFTrackAudit^>^ SearchWFTrackAuditDetails(
    WFTrackAuditSearchParameter^ searchParameter
)

Parameters

searchParameter
Type: CelloSaaS.WorkFlow.Model..::..WFTrackAuditSearchParameter
The search parameter.

Return Value

Type: List<(Of <(<' WFTrackAudit >)>)>
List of WFTrackAudit

See Also

IWFTrackAuditService Interface
IWFTrackAuditService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService Interface

[image]

A Sandcastle Documented Class Library
IWFTrackingService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWFTrackingService
Visual Basic
Public Interface IWFTrackingService
Visual C++
public interface class IWFTrackingService

See Also

IWFTrackingService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService Members

[image] [image]

A Sandcastle Documented Class Library
IWFTrackingService Members
IWFTrackingService Interface Methods Properties See Also Send Feedback

The IWFTrackingService type exposes the following members.

Methods

 | Name | Description
Public method | GetWFTrackDetails(array<WFTrackingStatus>[]()[][], Int32) | Gets the WF track details.
Public method | GetWFTrackDetails(array<WFTrackingStatus>[]()[][], Int32, String) | Gets the WF track details.
Public method | SaveWFTracking | Adds the instance for tracking.
Public method | UpdateTrackingStatus | Updates the tracking status.

Properties

 | Name | Description
Public property | Repository | Gets or sets the repository.

See Also

IWFTrackingService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService Methods

[image] [image]

A Sandcastle Documented Class Library
IWFTrackingService Methods
IWFTrackingService Interface See Also Send Feedback

The IWFTrackingService type exposes the following members.

Methods

 | Name | Description
Public method | GetWFTrackDetails(array<WFTrackingStatus>[]()[][], Int32) | Gets the WF track details.
Public method | GetWFTrackDetails(array<WFTrackingStatus>[]()[][], Int32, String) | Gets the WF track details.
Public method | SaveWFTracking | Adds the instance for tracking.
Public method | UpdateTrackingStatus | Updates the tracking status.

See Also

IWFTrackingService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService.GetWFTrackDetails Method

[image] [image]

A Sandcastle Documented Class Library
IWFTrackingService..::..GetWFTrackDetails Method
IWFTrackingService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWFTrackDetails(array<WFTrackingStatus>[]()[][], Int32) | Gets the WF track details.
Public method | GetWFTrackDetails(array<WFTrackingStatus>[]()[][], Int32, String) | Gets the WF track details.

See Also

IWFTrackingService Interface
IWFTrackingService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService.GetWFTrackDetails Method (WFTrackingStatus[], Int32)

[image]

A Sandcastle Documented Class Library
IWFTrackingService..::..GetWFTrackDetails Method (array<WFTrackingStatus>[]()[][], Int32)
IWFTrackingService Interface See Also Send Feedback
Gets the WF track details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WFTrack> GetWFTrackDetails(
    WFTrackingStatus[] status,
    int maxCount
)
Visual Basic
Function GetWFTrackDetails (
    status As WFTrackingStatus(),
    maxCount As Integer
) As List(Of WFTrack)
Visual C++
List<WFTrack^>^ GetWFTrackDetails(
    array<WFTrackingStatus>^ status,
    int maxCount
)

Parameters

status
Type: array< CelloSaaS.WorkFlow.Model..::..WFTrackingStatus >[]()[][]
The status.
maxCount
Type: System..::..Int32
The max count.

Return Value

Type: List<(Of <(<' WFTrack >)>)>
List of WFTrack

See Also

IWFTrackingService Interface
IWFTrackingService Members
GetWFTrackDetails Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService.GetWFTrackDetails Method (WFTrackingStatus[], Int32, String)

[image]

A Sandcastle Documented Class Library
IWFTrackingService..::..GetWFTrackDetails Method (array<WFTrackingStatus>[]()[][], Int32, String)
IWFTrackingService Interface See Also Send Feedback
Gets the WF track details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WFTrack> GetWFTrackDetails(
    WFTrackingStatus[] status,
    int maxCount,
    string trackingId
)
Visual Basic
Function GetWFTrackDetails (
    status As WFTrackingStatus(),
    maxCount As Integer,
    trackingId As String
) As List(Of WFTrack)
Visual C++
List<WFTrack^>^ GetWFTrackDetails(
    array<WFTrackingStatus>^ status,
    int maxCount,
    String^ trackingId
)

Parameters

status
Type: array< CelloSaaS.WorkFlow.Model..::..WFTrackingStatus >[]()[][]
The status.
maxCount
Type: System..::..Int32
The max count.
trackingId
Type: System..::..String

Return Value

Type: List<(Of <(<' WFTrack >)>)>
List of WFTrack

See Also

IWFTrackingService Interface
IWFTrackingService Members
GetWFTrackDetails Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService.SaveWFTracking Method

[image]

A Sandcastle Documented Class Library
IWFTrackingService..::..SaveWFTracking Method
IWFTrackingService Interface See Also Send Feedback
Adds the instance for tracking.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveWFTracking(
    WFTrack wfTrack
)
Visual Basic
Sub SaveWFTracking (
    wfTrack As WFTrack
)
Visual C++
void SaveWFTracking(
    WFTrack^ wfTrack
)

Parameters

wfTrack
Type: CelloSaaS.WorkFlow.Model..::..WFTrack
The wf track.

See Also

IWFTrackingService Interface
IWFTrackingService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService.UpdateTrackingStatus Method

[image]

A Sandcastle Documented Class Library
IWFTrackingService..::..UpdateTrackingStatus Method
IWFTrackingService Interface See Also Send Feedback
Updates the tracking status.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateTrackingStatus(
    List<WFTrack> wfTracList
)
Visual Basic
Sub UpdateTrackingStatus (
    wfTracList As List(Of WFTrack)
)
Visual C++
void UpdateTrackingStatus(
    List<WFTrack^>^ wfTracList
)

Parameters

wfTracList
Type: System.Collections.Generic..::..List<(Of <(<' WFTrack >)>)>
The wf trac list.

See Also

IWFTrackingService Interface
IWFTrackingService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService Properties

[image] [image]

A Sandcastle Documented Class Library
IWFTrackingService Properties
IWFTrackingService Interface See Also Send Feedback

The IWFTrackingService type exposes the following members.

Properties

 | Name | Description
Public property | Repository | Gets or sets the repository.

See Also

IWFTrackingService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWFTrackingService.Repository Property

[image]

A Sandcastle Documented Class Library
IWFTrackingService..::..Repository Property
IWFTrackingService Interface See Also Send Feedback
Gets or sets the repository.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
BatchRepository Repository { get; set; }
Visual Basic
Property Repository As BatchRepository
    Get
    Set
Visual C++
property BatchRepository^ Repository {
    BatchRepository^ get ();
    void set (BatchRepository^ value);
}

Property Value

Type: BatchRepository
The repository.

See Also

IWFTrackingService Interface
IWFTrackingService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService Interface

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkFlowBatchService
Visual Basic
Public Interface IWorkFlowBatchService
Visual C++
public interface class IWorkFlowBatchService

See Also

IWorkFlowBatchService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowBatchService Members
IWorkFlowBatchService Interface Methods Properties See Also Send Feedback

The IWorkFlowBatchService type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits the specified batch repository.
Public method | CreateInstance(String, String, String, IWorkflowInput, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, String, String) | Creates the instance.
Public method | GetInstances(Dictionary<(Of <<'(Guid, IWorkflowInput>)>>)) | Gets the instance.
Public method | GetInstances(Dictionary<(Of <<'(String, IWorkflowInput>)>>)) | Gets the instance.

Properties

 | Name | Description
Public property | Repositary |

See Also

IWorkFlowBatchService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowBatchService Methods
IWorkFlowBatchService Interface See Also Send Feedback

The IWorkFlowBatchService type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits the specified batch repository.
Public method | CreateInstance(String, String, String, IWorkflowInput, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, String, String) | Creates the instance.
Public method | GetInstances(Dictionary<(Of <<'(Guid, IWorkflowInput>)>>)) | Gets the instance.
Public method | GetInstances(Dictionary<(Of <<'(String, IWorkflowInput>)>>)) | Gets the instance.

See Also

IWorkFlowBatchService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.Commit Method

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..Commit Method
IWorkFlowBatchService Interface See Also Send Feedback
Commits the specified batch repository.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void Commit()
Visual Basic
Sub Commit
Visual C++
void Commit()

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.CreateInstance Method

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..CreateInstance Method
IWorkFlowBatchService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInstance(String, String, String, IWorkflowInput, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, String, String) | Creates the instance.

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.CreateInstance Method (String, String, String, IWorkflowInput, String)

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..CreateInstance Method (String, String, String, IWorkflowInput, String)
IWorkFlowBatchService Interface See Also Send Feedback
Creates the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService CreateInstance(
    string tenantId,
    string workflowId,
    string mapId,
    IWorkflowInput input,
    string userId
)
Visual Basic
Function CreateInstance (
    tenantId As String,
    workflowId As String,
    mapId As String,
    input As IWorkflowInput,
    userId As String
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ CreateInstance(
    String^ tenantId,
    String^ workflowId,
    String^ mapId,
    IWorkflowInput^ input,
    String^ userId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
workflowId
Type: System..::..String
The workflow id.
mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
userId
Type: System..::..String
The user id.

Return Value

Type: WorkflowInstanceService

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
CreateInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.CreateInstance Method (String, String, String, IWorkflowInput, String, String)

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..CreateInstance Method (String, String, String, IWorkflowInput, String, String)
IWorkFlowBatchService Interface See Also Send Feedback
Creates the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService CreateInstance(
    string tenantId,
    string workflowId,
    string mapId,
    IWorkflowInput input,
    string userId,
    string filterId
)
Visual Basic
Function CreateInstance (
    tenantId As String,
    workflowId As String,
    mapId As String,
    input As IWorkflowInput,
    userId As String,
    filterId As String
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ CreateInstance(
    String^ tenantId,
    String^ workflowId,
    String^ mapId,
    IWorkflowInput^ input,
    String^ userId,
    String^ filterId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
workflowId
Type: System..::..String
The workflow id.
mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
userId
Type: System..::..String
The user id.
filterId
Type: System..::..String

Return Value

Type: WorkflowInstanceService

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
CreateInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.GetInstances Method

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..GetInstances Method
IWorkFlowBatchService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInstances(Dictionary<(Of <<'(Guid, IWorkflowInput>)>>)) | Gets the instance.
Public method | GetInstances(Dictionary<(Of <<'(String, IWorkflowInput>)>>)) | Gets the instance.

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.GetInstances Method (Dictionary(Guid, IWorkflowInput))

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..GetInstances Method (Dictionary<(Of <(<'Guid, IWorkflowInput>)>)>)
IWorkFlowBatchService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowInstanceService> GetInstances(
    Dictionary<Guid, IWorkflowInput> inputWithInstanceId
)
Visual Basic
Function GetInstances (
    inputWithInstanceId As Dictionary(Of Guid, IWorkflowInput)
) As List(Of WorkflowInstanceService)
Visual C++
List<WorkflowInstanceService^>^ GetInstances(
    Dictionary<Guid, IWorkflowInput^>^ inputWithInstanceId
)

Parameters

inputWithInstanceId
Type: System.Collections.Generic..::..Dictionary<(Of <(<'Guid, IWorkflowInput >)>)>

Return Value

Type: List<(Of <(<'WorkflowInstanceService>)>)>

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
GetInstances Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.GetInstances Method (Dictionary(String, IWorkflowInput))

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..GetInstances Method (Dictionary<(Of <(<'String, IWorkflowInput>)>)>)
IWorkFlowBatchService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowInstanceService> GetInstances(
    Dictionary<string, IWorkflowInput> inputWithMapId
)
Visual Basic
Function GetInstances (
    inputWithMapId As Dictionary(Of String, IWorkflowInput)
) As List(Of WorkflowInstanceService)
Visual C++
List<WorkflowInstanceService^>^ GetInstances(
    Dictionary<String^, IWorkflowInput^>^ inputWithMapId
)

Parameters

inputWithMapId
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, IWorkflowInput >)>)>

Return Value

Type: List<(Of <(<'WorkflowInstanceService>)>)>

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
GetInstances Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService Properties

[image] [image]

A Sandcastle Documented Class Library
IWorkFlowBatchService Properties
IWorkFlowBatchService Interface See Also Send Feedback

The IWorkFlowBatchService type exposes the following members.

Properties

 | Name | Description
Public property | Repositary |

See Also

IWorkFlowBatchService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkFlowBatchService.Repositary Property

[image]

A Sandcastle Documented Class Library
IWorkFlowBatchService..::..Repositary Property
IWorkFlowBatchService Interface See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
BatchRepository Repositary { get; set; }
Visual Basic
Property Repositary As BatchRepository
    Get
    Set
Visual C++
property BatchRepository^ Repositary {
    BatchRepository^ get ();
    void set (BatchRepository^ value);
}

Property Value

Type: BatchRepository

See Also

IWorkFlowBatchService Interface
IWorkFlowBatchService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService Interface

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowDefinitionService
Visual Basic
Public Interface IWorkflowDefinitionService
Visual C++
public interface class IWorkflowDefinitionService

See Also

IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService Members
IWorkflowDefinitionService Interface Methods See Also Send Feedback

The IWorkflowDefinitionService type exposes the following members.

Methods

 | Name | Description
Public method | AddActivityDefinition(String, String, ITaskActivityDefinition) | Adds the activity definition.
Public method | AddActivityDefinition(String, String, String, String, String, String) | Adds the activity definition.
Public method | AddRouter | Adds the router.
Public method | AddRouterConnections | Adds the router connections.
Public method | CanCopyDefinition | Determines whether this instance [can copy definition] the specified work flow id.
Public method | CopyDefinition | Copies the definition.
Public method | CreateTaskDefinition | Creates the task definition.
Public method | CreateTemporaryWorkflowDefinition | Creates the temporary workflow definition.
Public method | DeleteActivityDefinition | Deletes the activity definition.
Public method | DeleteRouter | Deletes the router.
Public method | DeleteTaskDefinition | Deletes the task definition.
Public method | DeleteWorkflowDefinition | Deletes the workflow definition.
Public method | DeleteWorkflowUIModel | Deletes the workflow UI model.
Public method | GetAllWorkflowDefinitions | Gets all workflow definitions.
Public method | GetAllWorkflowDefinitionsFromOwnSetting | Gets all workflow definitions from own setting.
Public method | GetDefaultDefinition | Gets the default definition.
Public method | GetTaskDefinitions(array<String>[]()[][]) | Gets the task definitions.
Public method | GetTaskDefinitions(String, array<String>[]()[][]) | Gets the task definitions.
Public method | GetWorkflowDefinition(String) | Gets the workflow definition.
Public method | GetWorkflowDefinition(String, String, String) | Gets the published workflow definition.
Public method | GetWorkflowDefinitionFromOwnSetting | Gets the published workflow definition.
Public method | GetWorkflowDefinitions | Gets the workflow definitions.
Public method | GetWorkflowDefinitionUnCached | Gets the workflow definition un cached.
Public method | GetWorkflowUIModel | Gets the workflow UI model.
Public method | PublishDefinition | Publishes the definition.
Public method | RemoveRouterConnections | Removes the router connections.
Public method | SaveWorkflowDefinition(WorkflowDefinition) | Saves the workflow definition.
Public method | SaveWorkflowDefinition(String, String) | Saves the workflow definition to db.
Public method | SaveWorkflowUIModel | Saves the workflow UI model.
Public method | SaveWorkflowUIModelToCache | Saves the workflow UI model to cache.
Public method | UpdateRouterDetails | Updates the router details.
Public method | UpdateTaskDefinition | Updates the task definition.

See Also

IWorkflowDefinitionService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService Methods
IWorkflowDefinitionService Interface See Also Send Feedback

The IWorkflowDefinitionService type exposes the following members.

Methods

 | Name | Description
Public method | AddActivityDefinition(String, String, ITaskActivityDefinition) | Adds the activity definition.
Public method | AddActivityDefinition(String, String, String, String, String, String) | Adds the activity definition.
Public method | AddRouter | Adds the router.
Public method | AddRouterConnections | Adds the router connections.
Public method | CanCopyDefinition | Determines whether this instance [can copy definition] the specified work flow id.
Public method | CopyDefinition | Copies the definition.
Public method | CreateTaskDefinition | Creates the task definition.
Public method | CreateTemporaryWorkflowDefinition | Creates the temporary workflow definition.
Public method | DeleteActivityDefinition | Deletes the activity definition.
Public method | DeleteRouter | Deletes the router.
Public method | DeleteTaskDefinition | Deletes the task definition.
Public method | DeleteWorkflowDefinition | Deletes the workflow definition.
Public method | DeleteWorkflowUIModel | Deletes the workflow UI model.
Public method | GetAllWorkflowDefinitions | Gets all workflow definitions.
Public method | GetAllWorkflowDefinitionsFromOwnSetting | Gets all workflow definitions from own setting.
Public method | GetDefaultDefinition | Gets the default definition.
Public method | GetTaskDefinitions(array<String>[]()[][]) | Gets the task definitions.
Public method | GetTaskDefinitions(String, array<String>[]()[][]) | Gets the task definitions.
Public method | GetWorkflowDefinition(String) | Gets the workflow definition.
Public method | GetWorkflowDefinition(String, String, String) | Gets the published workflow definition.
Public method | GetWorkflowDefinitionFromOwnSetting | Gets the published workflow definition.
Public method | GetWorkflowDefinitions | Gets the workflow definitions.
Public method | GetWorkflowDefinitionUnCached | Gets the workflow definition un cached.
Public method | GetWorkflowUIModel | Gets the workflow UI model.
Public method | PublishDefinition | Publishes the definition.
Public method | RemoveRouterConnections | Removes the router connections.
Public method | SaveWorkflowDefinition(WorkflowDefinition) | Saves the workflow definition.
Public method | SaveWorkflowDefinition(String, String) | Saves the workflow definition to db.
Public method | SaveWorkflowUIModel | Saves the workflow UI model.
Public method | SaveWorkflowUIModelToCache | Saves the workflow UI model to cache.
Public method | UpdateRouterDetails | Updates the router details.
Public method | UpdateTaskDefinition | Updates the task definition.

See Also

IWorkflowDefinitionService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.AddActivityDefinition Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..AddActivityDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | AddActivityDefinition(String, String, ITaskActivityDefinition) | Adds the activity definition.
Public method | AddActivityDefinition(String, String, String, String, String, String) | Adds the activity definition.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.AddActivityDefinition Method (String, String, ITaskActivityDefinition)

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..AddActivityDefinition Method (String, String, ITaskActivityDefinition)
IWorkflowDefinitionService Interface See Also Send Feedback
Adds the activity definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddActivityDefinition(
    string workflowDefinitionId,
    string taskDefinitionId,
    ITaskActivityDefinition activityDefinition
)
Visual Basic
Sub AddActivityDefinition (
    workflowDefinitionId As String,
    taskDefinitionId As String,
    activityDefinition As ITaskActivityDefinition
)
Visual C++
void AddActivityDefinition(
    String^ workflowDefinitionId,
    String^ taskDefinitionId,
    ITaskActivityDefinition^ activityDefinition
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
taskDefinitionId
Type: System..::..String
The task definition id(Mandatory).
activityDefinition
Type: CelloSaaS.WorkFlow.Model..::..ITaskActivityDefinition
The activity definition(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
AddActivityDefinition Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.AddActivityDefinition Method (String, String, String, String, String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..AddActivityDefinition Method (String, String, String, String, String, String)
IWorkflowDefinitionService Interface See Also Send Feedback
Adds the activity definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddActivityDefinition(
    string workflowDefinitionId,
    string taskDefinitionId,
    string assemblyName,
    string typeName,
    string activityDefAssemblyName,
    string activityDefTypeName
)
Visual Basic
Sub AddActivityDefinition (
    workflowDefinitionId As String,
    taskDefinitionId As String,
    assemblyName As String,
    typeName As String,
    activityDefAssemblyName As String,
    activityDefTypeName As String
)
Visual C++
void AddActivityDefinition(
    String^ workflowDefinitionId,
    String^ taskDefinitionId,
    String^ assemblyName,
    String^ typeName,
    String^ activityDefAssemblyName,
    String^ activityDefTypeName
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.
taskDefinitionId
Type: System..::..String
The task definition id.
assemblyName
Type: System..::..String
Name of the assembly.
typeName
Type: System..::..String
Name of the type.
activityDefAssemblyName
Type: System..::..String
Name of the activity def assembly.
activityDefTypeName
Type: System..::..String
Name of the activity def type.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
AddActivityDefinition Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.AddRouter Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..AddRouter Method
IWorkflowDefinitionService Interface See Also Send Feedback
Adds the router.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string AddRouter(
    string workflowDefinitionId,
    TaskRouterDefinition router
)
Visual Basic
Function AddRouter (
    workflowDefinitionId As String,
    router As TaskRouterDefinition
) As String
Visual C++
String^ AddRouter(
    String^ workflowDefinitionId,
    TaskRouterDefinition^ router
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
router
Type: CelloSaaS.WorkFlow.Model..::..TaskRouterDefinition
The router(Mandatory).

Return Value

Type: String
The Router Name

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.AddRouterConnections Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..AddRouterConnections Method
IWorkflowDefinitionService Interface See Also Send Feedback
Adds the router connections.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void AddRouterConnections(
    string workflowDefinitionId,
    string routerId,
    string inputTaskId,
    string outputTaskId,
    bool isVisible,
    string elseOutputTaskId = ""
)
Visual Basic
Sub AddRouterConnections (
    workflowDefinitionId As String,
    routerId As String,
    inputTaskId As String,
    outputTaskId As String,
    isVisible As Boolean,
    Optional elseOutputTaskId As String = ""
)
Visual C++
void AddRouterConnections(
    String^ workflowDefinitionId,
    String^ routerId,
    String^ inputTaskId,
    String^ outputTaskId,
    bool isVisible,
    String^ elseOutputTaskId = L""
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id (Mandatory).
routerId
Type: System..::..String
The router id (Mandatory).
inputTaskId
Type: System..::..String
The input task id.
outputTaskId
Type: System..::..String
The output task id.
isVisible
Type: System..::..Boolean
if set to true [is visible].
elseOutputTaskId (Optional)
Type: System..::..String
The else output task id.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.CanCopyDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..CanCopyDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Determines whether this instance [can copy definition] the specified work flow id.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool CanCopyDefinition(
    string workflowDefinitionId,
    string workFlowId,
    string tenantId,
    string filterId
)
Visual Basic
Function CanCopyDefinition (
    workflowDefinitionId As String,
    workFlowId As String,
    tenantId As String,
    filterId As String
) As Boolean
Visual C++
bool CanCopyDefinition(
    String^ workflowDefinitionId,
    String^ workFlowId,
    String^ tenantId,
    String^ filterId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.
workFlowId
Type: System..::..String
The work flow id(Mandatory).
tenantId
Type: System..::..String
tenant id(Mandatory).
filterId
Type: System..::..String
Filter Id.

Return Value

Type: Boolean
true if this instance [can copy definition] the specified work flow id; otherwise, false.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.CopyDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..CopyDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Copies the definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string CopyDefinition(
    string workflowDefinitionId,
    string filterId,
    string tenantId,
    string userId
)
Visual Basic
Function CopyDefinition (
    workflowDefinitionId As String,
    filterId As String,
    tenantId As String,
    userId As String
) As String
Visual C++
String^ CopyDefinition(
    String^ workflowDefinitionId,
    String^ filterId,
    String^ tenantId,
    String^ userId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.
filterId
Type: System..::..String
The filter id.
tenantId
Type: System..::..String
The tenant id.
userId
Type: System..::..String
The user id.

Return Value

Type: String
The Workflow Definition Id

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.CreateTaskDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..CreateTaskDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Creates the task definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
TaskDefinition CreateTaskDefinition(
    string workflowDefinitionId,
    string taskDefinitionId,
    WFTaskType taskType
)
Visual Basic
Function CreateTaskDefinition (
    workflowDefinitionId As String,
    taskDefinitionId As String,
    taskType As WFTaskType
) As TaskDefinition
Visual C++
TaskDefinition^ CreateTaskDefinition(
    String^ workflowDefinitionId,
    String^ taskDefinitionId,
    WFTaskType taskType
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.
taskDefinitionId
Type: System..::..String
The task definition id.
taskType
Type: CelloSaaS.WorkFlow.Model..::..WFTaskType
Type of the task.

Return Value

Type: TaskDefinition
The TaskDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.CreateTemporaryWorkflowDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..CreateTemporaryWorkflowDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Creates the temporary workflow definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowDefinition CreateTemporaryWorkflowDefinition(
    string workflowId,
    string filterId,
    string tenantId,
    string userId,
    bool isDefault
)
Visual Basic
Function CreateTemporaryWorkflowDefinition (
    workflowId As String,
    filterId As String,
    tenantId As String,
    userId As String,
    isDefault As Boolean
) As WorkflowDefinition
Visual C++
WorkflowDefinition^ CreateTemporaryWorkflowDefinition(
    String^ workflowId,
    String^ filterId,
    String^ tenantId,
    String^ userId,
    bool isDefault
)

Parameters

workflowId
Type: System..::..String
The workflow id.
filterId
Type: System..::..String
The filter id.
tenantId
Type: System..::..String
The tenant id.
userId
Type: System..::..String
The user id.
isDefault
Type: System..::..Boolean
if set to true [is default].

Return Value

Type: WorkflowDefinition
The WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.DeleteActivityDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..DeleteActivityDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Deletes the activity definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteActivityDefinition(
    string workflowDefinitionId,
    string taskDefinitionId
)
Visual Basic
Sub DeleteActivityDefinition (
    workflowDefinitionId As String,
    taskDefinitionId As String
)
Visual C++
void DeleteActivityDefinition(
    String^ workflowDefinitionId,
    String^ taskDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
taskDefinitionId
Type: System..::..String
The task definition id(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.DeleteRouter Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..DeleteRouter Method
IWorkflowDefinitionService Interface See Also Send Feedback
Deletes the router.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteRouter(
    string workflowDefinitionId,
    string routerId
)
Visual Basic
Sub DeleteRouter (
    workflowDefinitionId As String,
    routerId As String
)
Visual C++
void DeleteRouter(
    String^ workflowDefinitionId,
    String^ routerId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
routerId
Type: System..::..String
The router id(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.DeleteTaskDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..DeleteTaskDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Deletes the task definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTaskDefinition(
    string workflowDefinitionId,
    string taskDefinitonId
)
Visual Basic
Sub DeleteTaskDefinition (
    workflowDefinitionId As String,
    taskDefinitonId As String
)
Visual C++
void DeleteTaskDefinition(
    String^ workflowDefinitionId,
    String^ taskDefinitonId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.
taskDefinitonId
Type: System..::..String
The task definiton id.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.DeleteWorkflowDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..DeleteWorkflowDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Deletes the workflow definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteWorkflowDefinition(
    string workflowDefinitionId
)
Visual Basic
Sub DeleteWorkflowDefinition (
    workflowDefinitionId As String
)
Visual C++
void DeleteWorkflowDefinition(
    String^ workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.DeleteWorkflowUIModel Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..DeleteWorkflowUIModel Method
IWorkflowDefinitionService Interface See Also Send Feedback
Deletes the workflow UI model.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteWorkflowUIModel(
    string workflowDefinitionId
)
Visual Basic
Sub DeleteWorkflowUIModel (
    workflowDefinitionId As String
)
Visual C++
void DeleteWorkflowUIModel(
    String^ workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetAllWorkflowDefinitions Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetAllWorkflowDefinitions Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets all workflow definitions.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowDefinition> GetAllWorkflowDefinitions(
    string workflowId,
    string tenantId,
    string filterId = null
)
Visual Basic
Function GetAllWorkflowDefinitions (
    workflowId As String,
    tenantId As String,
    Optional filterId As String = Nothing
) As List(Of WorkflowDefinition)
Visual C++
List<WorkflowDefinition^>^ GetAllWorkflowDefinitions(
    String^ workflowId,
    String^ tenantId,
    String^ filterId = nullptr
)

Parameters

workflowId
Type: System..::..String
The workflow id(Mandatory).
tenantId
Type: System..::..String
The tenant id.
filterId (Optional)
Type: System..::..String
The filter id.

Return Value

Type: List<(Of <(<' WorkflowDefinition >)>)>
List of WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetAllWorkflowDefinitionsFromOwnSetting Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetAllWorkflowDefinitionsFromOwnSetting Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets all workflow definitions from own setting.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowDefinition> GetAllWorkflowDefinitionsFromOwnSetting(
    string workflowId,
    string tenantId,
    string filterId = null
)
Visual Basic
Function GetAllWorkflowDefinitionsFromOwnSetting (
    workflowId As String,
    tenantId As String,
    Optional filterId As String = Nothing
) As List(Of WorkflowDefinition)
Visual C++
List<WorkflowDefinition^>^ GetAllWorkflowDefinitionsFromOwnSetting(
    String^ workflowId,
    String^ tenantId,
    String^ filterId = nullptr
)

Parameters

workflowId
Type: System..::..String
The workflow id.
tenantId
Type: System..::..String
The tenant id.
filterId (Optional)
Type: System..::..String
The filter id.

Return Value

Type: List<(Of <(<' WorkflowDefinition >)>)>

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetDefaultDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetDefaultDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the default definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowDefinition GetDefaultDefinition(
    string workflowId,
    string filterId = null
)
Visual Basic
Function GetDefaultDefinition (
    workflowId As String,
    Optional filterId As String = Nothing
) As WorkflowDefinition
Visual C++
WorkflowDefinition^ GetDefaultDefinition(
    String^ workflowId,
    String^ filterId = nullptr
)

Parameters

workflowId
Type: System..::..String
The workflow id(Mandatory).
filterId (Optional)
Type: System..::..String
The filter id.

Return Value

Type: WorkflowDefinition
The WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetTaskDefinitions Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetTaskDefinitions Method
IWorkflowDefinitionService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTaskDefinitions(array<String>[]()[][]) | Gets the task definitions.
Public method | GetTaskDefinitions(String, array<String>[]()[][]) | Gets the task definitions.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetTaskDefinitions Method (String[])

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetTaskDefinitions Method (array<String>[]()[][])
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the task definitions.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, List<TaskDefinition>> GetTaskDefinitions(
    string[] workflowDefinitionIds
)
Visual Basic
Function GetTaskDefinitions (
    workflowDefinitionIds As String()
) As Dictionary(Of String, List(Of TaskDefinition))
Visual C++
Dictionary<String^, List<TaskDefinition^>^>^ GetTaskDefinitions(
    array<String^>^ workflowDefinitionIds
)

Parameters

workflowDefinitionIds
Type: array<System..::..String>[]()[][]
The workflow definition ids(Mandatory).

Return Value

Type: Dictionary<(Of <(<'String, List<(Of <(<' TaskDefinition >)>)>>)>)>
Dictionary of List of TaskDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
GetTaskDefinitions Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetTaskDefinitions Method (String, String[])

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetTaskDefinitions Method (String, array<String>[]()[][])
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the task definitions.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, TaskDefinition> GetTaskDefinitions(
    string workFlowDefId,
    string[] taskIds
)
Visual Basic
Function GetTaskDefinitions (
    workFlowDefId As String,
    taskIds As String()
) As Dictionary(Of String, TaskDefinition)
Visual C++
Dictionary<String^, TaskDefinition^>^ GetTaskDefinitions(
    String^ workFlowDefId,
    array<String^>^ taskIds
)

Parameters

workFlowDefId
Type: System..::..String
The work flow def id.
taskIds
Type: array<System..::..String>[]()[][]
The task ids(Mandatory).

Return Value

Type: Dictionary<(Of <(<'String, TaskDefinition >)>)>
Dictionary of TaskDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
GetTaskDefinitions Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowDefinition Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWorkflowDefinition(String) | Gets the workflow definition.
Public method | GetWorkflowDefinition(String, String, String) | Gets the published workflow definition.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowDefinition Method (String)

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowDefinition Method (String)
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the workflow definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowDefinition GetWorkflowDefinition(
    string workflowDefinitionId
)
Visual Basic
Function GetWorkflowDefinition (
    workflowDefinitionId As String
) As WorkflowDefinition
Visual C++
WorkflowDefinition^ GetWorkflowDefinition(
    String^ workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).

Return Value

Type: WorkflowDefinition
The WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
GetWorkflowDefinition Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowDefinition Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowDefinition Method (String, String, String)
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the published workflow definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowDefinition GetWorkflowDefinition(
    string workflowId,
    string tenantId,
    string filterId
)
Visual Basic
Function GetWorkflowDefinition (
    workflowId As String,
    tenantId As String,
    filterId As String
) As WorkflowDefinition
Visual C++
WorkflowDefinition^ GetWorkflowDefinition(
    String^ workflowId,
    String^ tenantId,
    String^ filterId
)

Parameters

workflowId
Type: System..::..String
The workflow id(Mandatory).
tenantId
Type: System..::..String
The tenant id.
filterId
Type: System..::..String
The filter id.

Return Value

Type: WorkflowDefinition
The WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
GetWorkflowDefinition Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowDefinitionFromOwnSetting Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowDefinitionFromOwnSetting Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the published workflow definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowDefinition GetWorkflowDefinitionFromOwnSetting(
    string workflowId,
    string tenantId,
    string filterId
)
Visual Basic
Function GetWorkflowDefinitionFromOwnSetting (
    workflowId As String,
    tenantId As String,
    filterId As String
) As WorkflowDefinition
Visual C++
WorkflowDefinition^ GetWorkflowDefinitionFromOwnSetting(
    String^ workflowId,
    String^ tenantId,
    String^ filterId
)

Parameters

workflowId
Type: System..::..String
The workflow id(Mandatory).
tenantId
Type: System..::..String
The tenant id.
filterId
Type: System..::..String
The filter id.

Return Value

Type: WorkflowDefinition
The WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowDefinitions Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowDefinitions Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the workflow definitions.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
Dictionary<string, WorkflowDefinition> GetWorkflowDefinitions(
    List<string> workflowDefinitionIds
)
Visual Basic
Function GetWorkflowDefinitions (
    workflowDefinitionIds As List(Of String)
) As Dictionary(Of String, WorkflowDefinition)
Visual C++
Dictionary<String^, WorkflowDefinition^>^ GetWorkflowDefinitions(
    List<String^>^ workflowDefinitionIds
)

Parameters

workflowDefinitionIds
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
The workflow definition ids.

Return Value

Type: Dictionary<(Of <(<'String, WorkflowDefinition >)>)>
Dictionary of WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowDefinitionUnCached Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowDefinitionUnCached Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the workflow definition un cached.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowDefinition GetWorkflowDefinitionUnCached(
    string workflowDefinitionId
)
Visual Basic
Function GetWorkflowDefinitionUnCached (
    workflowDefinitionId As String
) As WorkflowDefinition
Visual C++
WorkflowDefinition^ GetWorkflowDefinitionUnCached(
    String^ workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).

Return Value

Type: WorkflowDefinition
The WorkflowDefinition

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.GetWorkflowUIModel Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..GetWorkflowUIModel Method
IWorkflowDefinitionService Interface See Also Send Feedback
Gets the workflow UI model.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WFUIModelDictionary GetWorkflowUIModel(
    string workflowDefinitionId
)
Visual Basic
Function GetWorkflowUIModel (
    workflowDefinitionId As String
) As WFUIModelDictionary
Visual C++
WFUIModelDictionary^ GetWorkflowUIModel(
    String^ workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).

Return Value

Type: WFUIModelDictionary
The WFUIModelDictionary

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.PublishDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..PublishDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Publishes the definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void PublishDefinition(
    string workflowDefinitionId
)
Visual Basic
Sub PublishDefinition (
    workflowDefinitionId As String
)
Visual C++
void PublishDefinition(
    String^ workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.RemoveRouterConnections Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..RemoveRouterConnections Method
IWorkflowDefinitionService Interface See Also Send Feedback
Removes the router connections.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void RemoveRouterConnections(
    string workflowDefinitionId,
    string routerId,
    string inputTaskId,
    string outputTaskId,
    string elseOutputTaskId = ""
)
Visual Basic
Sub RemoveRouterConnections (
    workflowDefinitionId As String,
    routerId As String,
    inputTaskId As String,
    outputTaskId As String,
    Optional elseOutputTaskId As String = ""
)
Visual C++
void RemoveRouterConnections(
    String^ workflowDefinitionId,
    String^ routerId,
    String^ inputTaskId,
    String^ outputTaskId,
    String^ elseOutputTaskId = L""
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id (Mandatory).
routerId
Type: System..::..String
The router id (Mandatory).
inputTaskId
Type: System..::..String
The input task id.
outputTaskId
Type: System..::..String
The output task id.
elseOutputTaskId (Optional)
Type: System..::..String
The else output task id.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.SaveWorkflowDefinition Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..SaveWorkflowDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveWorkflowDefinition(WorkflowDefinition) | Saves the workflow definition.
Public method | SaveWorkflowDefinition(String, String) | Saves the workflow definition to db.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.SaveWorkflowDefinition Method (WorkflowDefinition)

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..SaveWorkflowDefinition Method (WorkflowDefinition)
IWorkflowDefinitionService Interface See Also Send Feedback
Saves the workflow definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveWorkflowDefinition(
    WorkflowDefinition workflowDefinition
)
Visual Basic
Sub SaveWorkflowDefinition (
    workflowDefinition As WorkflowDefinition
)
Visual C++
void SaveWorkflowDefinition(
    WorkflowDefinition^ workflowDefinition
)

Parameters

workflowDefinition
Type: CelloSaaS.WorkFlow.Model..::..WorkflowDefinition
The workflow definition.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
SaveWorkflowDefinition Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.SaveWorkflowDefinition Method (String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..SaveWorkflowDefinition Method (String, String)
IWorkflowDefinitionService Interface See Also Send Feedback
Saves the workflow definition to db.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveWorkflowDefinition(
    string workflowDefinitionId,
    string userId
)
Visual Basic
Sub SaveWorkflowDefinition (
    workflowDefinitionId As String,
    userId As String
)
Visual C++
void SaveWorkflowDefinition(
    String^ workflowDefinitionId,
    String^ userId
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
userId
Type: System..::..String
The user id(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
SaveWorkflowDefinition Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.SaveWorkflowUIModel Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..SaveWorkflowUIModel Method
IWorkflowDefinitionService Interface See Also Send Feedback
Saves the workflow UI model.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveWorkflowUIModel(
    string workflowDefinitionId,
    WFUIModelDictionary uiModel
)
Visual Basic
Sub SaveWorkflowUIModel (
    workflowDefinitionId As String,
    uiModel As WFUIModelDictionary
)
Visual C++
void SaveWorkflowUIModel(
    String^ workflowDefinitionId,
    WFUIModelDictionary^ uiModel
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
uiModel
Type: CelloSaaS.WorkFlow.Model..::..WFUIModelDictionary
The UI model(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.SaveWorkflowUIModelToCache Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..SaveWorkflowUIModelToCache Method
IWorkflowDefinitionService Interface See Also Send Feedback
Saves the workflow UI model to cache.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void SaveWorkflowUIModelToCache(
    string workflowDefinitionId,
    WFUIModelDictionary uiModelDict
)
Visual Basic
Sub SaveWorkflowUIModelToCache (
    workflowDefinitionId As String,
    uiModelDict As WFUIModelDictionary
)
Visual C++
void SaveWorkflowUIModelToCache(
    String^ workflowDefinitionId,
    WFUIModelDictionary^ uiModelDict
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
uiModelDict
Type: CelloSaaS.WorkFlow.Model..::..WFUIModelDictionary
The UI model dict(Mandatory).

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.UpdateRouterDetails Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..UpdateRouterDetails Method
IWorkflowDefinitionService Interface See Also Send Feedback
Updates the router details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRouterDetails(
    string workflowDefinitionId,
    string routerId,
    string routerName,
    string[] conditionExpression
)
Visual Basic
Sub UpdateRouterDetails (
    workflowDefinitionId As String,
    routerId As String,
    routerName As String,
    conditionExpression As String()
)
Visual C++
void UpdateRouterDetails(
    String^ workflowDefinitionId,
    String^ routerId,
    String^ routerName,
    array<String^>^ conditionExpression
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id(Mandatory).
routerId
Type: System..::..String
The router id(Mandatory).
routerName
Type: System..::..String
Name of the router.
conditionExpression
Type: array<System..::..String>[]()[][]
The condition expression.

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowDefinitionService.UpdateTaskDefinition Method

[image]

A Sandcastle Documented Class Library
IWorkflowDefinitionService..::..UpdateTaskDefinition Method
IWorkflowDefinitionService Interface See Also Send Feedback
Updates the task definition.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool UpdateTaskDefinition(
    string workflowDefinitionId,
    TaskDefViewModel taskDefVM,
    TaskActorDefViewModel actorDefVM,
    TaskConditionsViewModel conditionsVM
)
Visual Basic
Function UpdateTaskDefinition (
    workflowDefinitionId As String,
    taskDefVM As TaskDefViewModel,
    actorDefVM As TaskActorDefViewModel,
    conditionsVM As TaskConditionsViewModel
) As Boolean
Visual C++
bool UpdateTaskDefinition(
    String^ workflowDefinitionId,
    TaskDefViewModel^ taskDefVM,
    TaskActorDefViewModel^ actorDefVM,
    TaskConditionsViewModel^ conditionsVM
)

Parameters

workflowDefinitionId
Type: System..::..String
The workflow definition id.
taskDefVM
Type: CelloSaaS.WorkFlow.Model..::..TaskDefViewModel
The task def VM.
actorDefVM
Type: CelloSaaS.WorkFlow.Model..::..TaskActorDefViewModel
The actor def VM.
conditionsVM
Type: CelloSaaS.WorkFlow.Model..::..TaskConditionsViewModel
The conditions VM.

Return Value

Type: Boolean
true/false

See Also

IWorkflowDefinitionService Interface
IWorkflowDefinitionService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService Interface

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowInstanceService
Visual Basic
Public Interface IWorkflowInstanceService
Visual C++
public interface class IWorkflowInstanceService

See Also

IWorkflowInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowInstanceService Members
IWorkflowInstanceService Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | CreateInstance(String, String, String, IWorkflowInput, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, BatchRepository, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, BatchRepository, String, String) | Creates the instance.
Public method | GetInstance(Guid, IWorkflowInput) | Gets the instance.
Public method | GetInstance(String, IWorkflowInput) | Gets the instance.
Public method | GetInstance(WorkflowInstance, IWorkflowInput) | Gets the instance.
Public method | GetInstance(Guid, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, String, IWorkflowInput) | This method is used to Get the workflow instance service.
Public method | GetInstance(WorkflowInstance, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, String, IWorkflowInput, BatchRepository) | This method is used to Get the workflow instance service.

See Also

IWorkflowInstanceService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowInstanceService Methods
IWorkflowInstanceService Interface See Also Send Feedback

Methods

 | Name | Description
Public method | CreateInstance(String, String, String, IWorkflowInput, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, BatchRepository, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, BatchRepository, String, String) | Creates the instance.
Public method | GetInstance(Guid, IWorkflowInput) | Gets the instance.
Public method | GetInstance(String, IWorkflowInput) | Gets the instance.
Public method | GetInstance(WorkflowInstance, IWorkflowInput) | Gets the instance.
Public method | GetInstance(Guid, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, String, IWorkflowInput) | This method is used to Get the workflow instance service.
Public method | GetInstance(WorkflowInstance, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, String, IWorkflowInput, BatchRepository) | This method is used to Get the workflow instance service.

See Also

IWorkflowInstanceService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.CreateInstance Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..CreateInstance Method
IWorkflowInstanceService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInstance(String, String, String, IWorkflowInput, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, BatchRepository, String) | Creates the instance.
Public method | CreateInstance(String, String, String, IWorkflowInput, BatchRepository, String, String) | Creates the instance.

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.CreateInstance Method (String, String, String, IWorkflowInput, String)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..CreateInstance Method (String, String, String, IWorkflowInput, String)
IWorkflowInstanceService Interface See Also Send Feedback
Creates the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService CreateInstance(
    string tenantId,
    string workflowId,
    string mapId,
    IWorkflowInput input,
    string userId
)
Visual Basic
Function CreateInstance (
    tenantId As String,
    workflowId As String,
    mapId As String,
    input As IWorkflowInput,
    userId As String
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ CreateInstance(
    String^ tenantId,
    String^ workflowId,
    String^ mapId,
    IWorkflowInput^ input,
    String^ userId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
workflowId
Type: System..::..String
The workflow id.
mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
userId
Type: System..::..String

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
CreateInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.CreateInstance Method (String, String, String, IWorkflowInput, BatchRepository, String)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..CreateInstance Method (String, String, String, IWorkflowInput, BatchRepository, String)
IWorkflowInstanceService Interface See Also Send Feedback
Creates the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService CreateInstance(
    string tenantId,
    string workflowId,
    string mapId,
    IWorkflowInput input,
    BatchRepository batchRepository,
    string userId
)
Visual Basic
Function CreateInstance (
    tenantId As String,
    workflowId As String,
    mapId As String,
    input As IWorkflowInput,
    batchRepository As BatchRepository,
    userId As String
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ CreateInstance(
    String^ tenantId,
    String^ workflowId,
    String^ mapId,
    IWorkflowInput^ input,
    BatchRepository^ batchRepository,
    String^ userId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
workflowId
Type: System..::..String
The workflow id.
mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
batchRepository
Type: BatchRepository
The batch repository.
userId
Type: System..::..String

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
CreateInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.CreateInstance Method (String, String, String, IWorkflowInput, BatchRepository, String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..CreateInstance Method (String, String, String, IWorkflowInput, BatchRepository, String, String)
IWorkflowInstanceService Interface See Also Send Feedback
Creates the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService CreateInstance(
    string tenantId,
    string workflowId,
    string mapId,
    IWorkflowInput input,
    BatchRepository batchRepository,
    string userId,
    string filterId
)
Visual Basic
Function CreateInstance (
    tenantId As String,
    workflowId As String,
    mapId As String,
    input As IWorkflowInput,
    batchRepository As BatchRepository,
    userId As String,
    filterId As String
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ CreateInstance(
    String^ tenantId,
    String^ workflowId,
    String^ mapId,
    IWorkflowInput^ input,
    BatchRepository^ batchRepository,
    String^ userId,
    String^ filterId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
workflowId
Type: System..::..String
The workflow id.
mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
batchRepository
Type: BatchRepository
The batch repository.
userId
Type: System..::..String
The user id.
filterId
Type: System..::..String
The filter id.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
CreateInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method
IWorkflowInstanceService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInstance(Guid, IWorkflowInput) | Gets the instance.
Public method | GetInstance(String, IWorkflowInput) | Gets the instance.
Public method | GetInstance(WorkflowInstance, IWorkflowInput) | Gets the instance.
Public method | GetInstance(Guid, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, String, IWorkflowInput) | This method is used to Get the workflow instance service.
Public method | GetInstance(WorkflowInstance, IWorkflowInput, BatchRepository) | Gets the instance.
Public method | GetInstance(String, String, IWorkflowInput, BatchRepository) | This method is used to Get the workflow instance service.

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (Guid, IWorkflowInput)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (Guid, IWorkflowInput)
IWorkflowInstanceService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    Guid instanceId,
    IWorkflowInput input
)
Visual Basic
Function GetInstance (
    instanceId As Guid,
    input As IWorkflowInput
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    Guid instanceId,
    IWorkflowInput^ input
)

Parameters

instanceId
Type: System..::..Guid
The instance id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (String, IWorkflowInput)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (String, IWorkflowInput)
IWorkflowInstanceService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    string mapId,
    IWorkflowInput input
)
Visual Basic
Function GetInstance (
    mapId As String,
    input As IWorkflowInput
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    String^ mapId,
    IWorkflowInput^ input
)

Parameters

mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (WorkflowInstance, IWorkflowInput)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (WorkflowInstance, IWorkflowInput)
IWorkflowInstanceService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    WorkflowInstance wfInstance,
    IWorkflowInput input
)
Visual Basic
Function GetInstance (
    wfInstance As WorkflowInstance,
    input As IWorkflowInput
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    WorkflowInstance^ wfInstance,
    IWorkflowInput^ input
)

Parameters

wfInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The wf instance.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (Guid, IWorkflowInput, BatchRepository)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (Guid, IWorkflowInput, BatchRepository)
IWorkflowInstanceService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    Guid instanceId,
    IWorkflowInput input,
    BatchRepository batchRepository
)
Visual Basic
Function GetInstance (
    instanceId As Guid,
    input As IWorkflowInput,
    batchRepository As BatchRepository
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    Guid instanceId,
    IWorkflowInput^ input,
    BatchRepository^ batchRepository
)

Parameters

instanceId
Type: System..::..Guid
The instance id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
batchRepository
Type: BatchRepository
The batch repository.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (String, IWorkflowInput, BatchRepository)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (String, IWorkflowInput, BatchRepository)
IWorkflowInstanceService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    string mapId,
    IWorkflowInput input,
    BatchRepository batchRepository
)
Visual Basic
Function GetInstance (
    mapId As String,
    input As IWorkflowInput,
    batchRepository As BatchRepository
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    String^ mapId,
    IWorkflowInput^ input,
    BatchRepository^ batchRepository
)

Parameters

mapId
Type: System..::..String
The map id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
batchRepository
Type: BatchRepository
The batch repository.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (String, String, IWorkflowInput)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (String, String, IWorkflowInput)
IWorkflowInstanceService Interface See Also Send Feedback
This method is used to Get the workflow instance service.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    string mapId,
    string wfId,
    IWorkflowInput input
)
Visual Basic
Function GetInstance (
    mapId As String,
    wfId As String,
    input As IWorkflowInput
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    String^ mapId,
    String^ wfId,
    IWorkflowInput^ input
)

Parameters

mapId
Type: System..::..String
The map id.
wfId
Type: System..::..String
The wf id.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.

Return Value

Type: WorkflowInstanceService
The Workflow Instance Service

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (WorkflowInstance, IWorkflowInput, BatchRepository)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (WorkflowInstance, IWorkflowInput, BatchRepository)
IWorkflowInstanceService Interface See Also Send Feedback
Gets the instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    WorkflowInstance wfInstance,
    IWorkflowInput input,
    BatchRepository batchRepository
)
Visual Basic
Function GetInstance (
    wfInstance As WorkflowInstance,
    input As IWorkflowInput,
    batchRepository As BatchRepository
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    WorkflowInstance^ wfInstance,
    IWorkflowInput^ input,
    BatchRepository^ batchRepository
)

Parameters

wfInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowInstance
The wf instance.
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
batchRepository
Type: BatchRepository
The batch repository.

Return Value

Type: WorkflowInstanceService

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowInstanceService.GetInstance Method (String, String, IWorkflowInput, BatchRepository)

[image]

A Sandcastle Documented Class Library
IWorkflowInstanceService..::..GetInstance Method (String, String, IWorkflowInput, BatchRepository)
IWorkflowInstanceService Interface See Also Send Feedback
This method is used to Get the workflow instance service.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowInstanceService GetInstance(
    string mapId,
    string wfId,
    IWorkflowInput input,
    BatchRepository batchRepository
)
Visual Basic
Function GetInstance (
    mapId As String,
    wfId As String,
    input As IWorkflowInput,
    batchRepository As BatchRepository
) As WorkflowInstanceService
Visual C++
WorkflowInstanceService^ GetInstance(
    String^ mapId,
    String^ wfId,
    IWorkflowInput^ input,
    BatchRepository^ batchRepository
)

Parameters

mapId
Type: System..::..String
The map id.
wfId
Type: System..::..String
input
Type: CelloSaaS.WorkFlow.Model..::..IWorkflowInput
The input.
batchRepository
Type: BatchRepository
The batch repository.

Return Value

Type: WorkflowInstanceService
The Workflow Instance Service

See Also

IWorkflowInstanceService Interface
IWorkflowInstanceService Members
GetInstance Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowRequestService Interface

[image]

A Sandcastle Documented Class Library
IWorkflowRequestService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowRequestService
Visual Basic
Public Interface IWorkflowRequestService
Visual C++
public interface class IWorkflowRequestService

See Also

IWorkflowRequestService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowRequestService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowRequestService Members
IWorkflowRequestService Interface Methods See Also Send Feedback

The IWorkflowRequestService type exposes the following members.

Methods

 | Name | Description
Public method | CreateRequest | Creates the Wf request for batch processing by windows service.
Public method | FetchRequests | Fetches the Wf request model [FIFO].
Public method | UpdateRequestStatus | Updates the request status.

See Also

IWorkflowRequestService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowRequestService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowRequestService Methods
IWorkflowRequestService Interface See Also Send Feedback

The IWorkflowRequestService type exposes the following members.

Methods

 | Name | Description
Public method | CreateRequest | Creates the Wf request for batch processing by windows service.
Public method | FetchRequests | Fetches the Wf request model [FIFO].
Public method | UpdateRequestStatus | Updates the request status.

See Also

IWorkflowRequestService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowRequestService.CreateRequest Method

[image]

A Sandcastle Documented Class Library
IWorkflowRequestService..::..CreateRequest Method
IWorkflowRequestService Interface See Also Send Feedback
Creates the Wf request for batch processing by windows service.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CreateRequest(
    string tenantId,
    string workflowId,
    List<string> mapIds,
    string userId
)
Visual Basic
Sub CreateRequest (
    tenantId As String,
    workflowId As String,
    mapIds As List(Of String),
    userId As String
)
Visual C++
void CreateRequest(
    String^ tenantId,
    String^ workflowId,
    List<String^>^ mapIds,
    String^ userId
)

Parameters

tenantId
Type: System..::..String
The tenant id.
workflowId
Type: System..::..String
The workflow id.
mapIds
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
The map ids.
userId
Type: System..::..String
The user id.

See Also

IWorkflowRequestService Interface
IWorkflowRequestService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowRequestService.FetchRequests Method

[image]

A Sandcastle Documented Class Library
IWorkflowRequestService..::..FetchRequests Method
IWorkflowRequestService Interface See Also Send Feedback
Fetches the Wf request model [FIFO].

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WFRequestModel> FetchRequests(
    string tenantId,
    string workflowId,
    WFRecordStatus status,
    int count
)
Visual Basic
Function FetchRequests (
    tenantId As String,
    workflowId As String,
    status As WFRecordStatus,
    count As Integer
) As List(Of WFRequestModel)
Visual C++
List<WFRequestModel^>^ FetchRequests(
    String^ tenantId,
    String^ workflowId,
    WFRecordStatus status,
    int count
)

Parameters

tenantId
Type: System..::..String
The tenant id. [Nullable]
workflowId
Type: System..::..String
The workflow id. [Nullable]
status
Type: CelloSaaS.WorkFlow.Model..::..WFRecordStatus
The status.
count
Type: System..::..Int32
The count.

Return Value

Type: List<(Of <(<' WFRequestModel >)>)>
List of WFRequestModel

See Also

IWorkflowRequestService Interface
IWorkflowRequestService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowRequestService.UpdateRequestStatus Method

[image]

A Sandcastle Documented Class Library
IWorkflowRequestService..::..UpdateRequestStatus Method
IWorkflowRequestService Interface See Also Send Feedback
Updates the request status.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateRequestStatus(
    List<WFRequestModel> wfRequestModelList
)
Visual Basic
Sub UpdateRequestStatus (
    wfRequestModelList As List(Of WFRequestModel)
)
Visual C++
void UpdateRequestStatus(
    List<WFRequestModel^>^ wfRequestModelList
)

Parameters

wfRequestModelList
Type: System.Collections.Generic..::..List<(Of <(<' WFRequestModel >)>)>
The wf request model list.

See Also

IWorkflowRequestService Interface
IWorkflowRequestService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService Interface

[image]

A Sandcastle Documented Class Library
IWorkflowService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowService
Visual Basic
Public Interface IWorkflowService
Visual C++
public interface class IWorkflowService

See Also

IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowService Members
IWorkflowService Interface Methods See Also Send Feedback

The IWorkflowService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteWorkflowModel | This method is uesd to delete workflow
Public method | GetActiveTaskInstanceForActor(ITaskActor) | This method is used to get the active task instance for the Actor. This will return the task has the started, executed and errored status.
Public method | GetActiveTaskInstanceForActor(String, ITaskActor) | This method is used to get the active task instance for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetAllTaskInstanceForActor | Gets all task instance for actor.
Public method | GetMapIdsForActor(ITaskActor) | This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetMapIdsForActor(String, ITaskActor) | This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetTaskInstanceForActor | Gets the task instance for actor.
Public method | GetTotalCountSearchDetails | Gets the total count search details of WFInstance.
Public method | GetTotalCountWFTInstanceSearchDetails | Gets the total count search details of Workflow Task Instance.
Public method | GetUnAllocatedTaskInstances | Gets the un allocated workflow instances for the given task code and workflow id
Public method | GetWorkflow(String, String) | This method is used to get the workflow details for the given workflow id and tenant id.
Public method | GetWorkflow(String, String, String) | Gets the workflow.
Public method | GetWorkflowByName | This method is used to get the workflow details based on the workflow name
Public method | GetWorkflowExceptionDetails | Gets the workflow exception details.
Public method | GetWorkflows | Get the list of workflow details for the tenant
Public method | RestartWorkflowStep | This method is used to restart the particular errored step in the workflow.
Public method | SaveWorkflow | This method is used to save workflow details
Public method | SearchWorkFlowInstance | This method is used to get the workflow instance details based on the search parameter
Public method | SearchWorkFlowInstanceDeep | This method is used to Search the work flow instance deep.
Public method | SearchWorkFlowTaskInstance | This method is used to get the workflow task instance details based on the search parameter

See Also

IWorkflowService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowService Methods
IWorkflowService Interface See Also Send Feedback

The IWorkflowService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteWorkflowModel | This method is uesd to delete workflow
Public method | GetActiveTaskInstanceForActor(ITaskActor) | This method is used to get the active task instance for the Actor. This will return the task has the started, executed and errored status.
Public method | GetActiveTaskInstanceForActor(String, ITaskActor) | This method is used to get the active task instance for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetAllTaskInstanceForActor | Gets all task instance for actor.
Public method | GetMapIdsForActor(ITaskActor) | This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetMapIdsForActor(String, ITaskActor) | This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetTaskInstanceForActor | Gets the task instance for actor.
Public method | GetTotalCountSearchDetails | Gets the total count search details of WFInstance.
Public method | GetTotalCountWFTInstanceSearchDetails | Gets the total count search details of Workflow Task Instance.
Public method | GetUnAllocatedTaskInstances | Gets the un allocated workflow instances for the given task code and workflow id
Public method | GetWorkflow(String, String) | This method is used to get the workflow details for the given workflow id and tenant id.
Public method | GetWorkflow(String, String, String) | Gets the workflow.
Public method | GetWorkflowByName | This method is used to get the workflow details based on the workflow name
Public method | GetWorkflowExceptionDetails | Gets the workflow exception details.
Public method | GetWorkflows | Get the list of workflow details for the tenant
Public method | RestartWorkflowStep | This method is used to restart the particular errored step in the workflow.
Public method | SaveWorkflow | This method is used to save workflow details
Public method | SearchWorkFlowInstance | This method is used to get the workflow instance details based on the search parameter
Public method | SearchWorkFlowInstanceDeep | This method is used to Search the work flow instance deep.
Public method | SearchWorkFlowTaskInstance | This method is used to get the workflow task instance details based on the search parameter

See Also

IWorkflowService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.DeleteWorkflowModel Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..DeleteWorkflowModel Method
IWorkflowService Interface See Also Send Feedback
This method is uesd to delete workflow

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteWorkflowModel(
    string workflowId
)
Visual Basic
Sub DeleteWorkflowModel (
    workflowId As String
)
Visual C++
void DeleteWorkflowModel(
    String^ workflowId
)

Parameters

workflowId
Type: System..::..String
The workflow id.

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetActiveTaskInstanceForActor Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetActiveTaskInstanceForActor Method
IWorkflowService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetActiveTaskInstanceForActor(ITaskActor) | This method is used to get the active task instance for the Actor. This will return the task has the started, executed and errored status.
Public method | GetActiveTaskInstanceForActor(String, ITaskActor) | This method is used to get the active task instance for the Actor and the given task code. This will return the task has the started, executed and errored status.

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetActiveTaskInstanceForActor Method (ITaskActor)

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetActiveTaskInstanceForActor Method (ITaskActor)
IWorkflowService Interface See Also Send Feedback
This method is used to get the active task instance for the Actor. This will return the task has the started, executed and errored status.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowTaskInstance> GetActiveTaskInstanceForActor(
    ITaskActor actor
)
Visual Basic
Function GetActiveTaskInstanceForActor (
    actor As ITaskActor
) As List(Of WorkflowTaskInstance)
Visual C++
List<WorkflowTaskInstance^>^ GetActiveTaskInstanceForActor(
    ITaskActor^ actor
)

Parameters

actor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The task actor.

Return Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
GetActiveTaskInstanceForActor Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetActiveTaskInstanceForActor Method (String, ITaskActor)

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetActiveTaskInstanceForActor Method (String, ITaskActor)
IWorkflowService Interface See Also Send Feedback
This method is used to get the active task instance for the Actor and the given task code. This will return the task has the started, executed and errored status.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowTaskInstance> GetActiveTaskInstanceForActor(
    string taskCode,
    ITaskActor actor
)
Visual Basic
Function GetActiveTaskInstanceForActor (
    taskCode As String,
    actor As ITaskActor
) As List(Of WorkflowTaskInstance)
Visual C++
List<WorkflowTaskInstance^>^ GetActiveTaskInstanceForActor(
    String^ taskCode,
    ITaskActor^ actor
)

Parameters

taskCode
Type: System..::..String
The task code.
actor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The task actor.

Return Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
GetActiveTaskInstanceForActor Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetAllTaskInstanceForActor Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetAllTaskInstanceForActor Method
IWorkflowService Interface See Also Send Feedback
Gets all task instance for actor.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowTaskInstance> GetAllTaskInstanceForActor(
    ITaskActor actor
)
Visual Basic
Function GetAllTaskInstanceForActor (
    actor As ITaskActor
) As List(Of WorkflowTaskInstance)
Visual C++
List<WorkflowTaskInstance^>^ GetAllTaskInstanceForActor(
    ITaskActor^ actor
)

Parameters

actor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The actor.

Return Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetMapIdsForActor Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetMapIdsForActor Method
IWorkflowService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMapIdsForActor(ITaskActor) | This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.
Public method | GetMapIdsForActor(String, ITaskActor) | This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetMapIdsForActor Method (ITaskActor)

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetMapIdsForActor Method (ITaskActor)
IWorkflowService Interface See Also Send Feedback
This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetMapIdsForActor(
    ITaskActor actor
)
Visual Basic
Function GetMapIdsForActor (
    actor As ITaskActor
) As List(Of String)
Visual C++
List<String^>^ GetMapIdsForActor(
    ITaskActor^ actor
)

Parameters

actor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The task actor.

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
GetMapIdsForActor Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetMapIdsForActor Method (String, ITaskActor)

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetMapIdsForActor Method (String, ITaskActor)
IWorkflowService Interface See Also Send Feedback
This method is used to get the map ids for the Actor and the given task code. This will return the task has the started, executed and errored status.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetMapIdsForActor(
    string taskCode,
    ITaskActor actor
)
Visual Basic
Function GetMapIdsForActor (
    taskCode As String,
    actor As ITaskActor
) As List(Of String)
Visual C++
List<String^>^ GetMapIdsForActor(
    String^ taskCode,
    ITaskActor^ actor
)

Parameters

taskCode
Type: System..::..String
The task code.
actor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The task actor.

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
GetMapIdsForActor Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetTaskInstanceForActor Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetTaskInstanceForActor Method
IWorkflowService Interface See Also Send Feedback
Gets the task instance for actor.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowTaskInstance> GetTaskInstanceForActor(
    ITaskActor actor,
    List<string> status
)
Visual Basic
Function GetTaskInstanceForActor (
    actor As ITaskActor,
    status As List(Of String)
) As List(Of WorkflowTaskInstance)
Visual C++
List<WorkflowTaskInstance^>^ GetTaskInstanceForActor(
    ITaskActor^ actor,
    List<String^>^ status
)

Parameters

actor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The actor.
status
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
The status.

Return Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetTotalCountSearchDetails Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetTotalCountSearchDetails Method
IWorkflowService Interface See Also Send Feedback
Gets the total count search details of WFInstance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int GetTotalCountSearchDetails(
    WfSearchParameter wfSearchParameter
)
Visual Basic
Function GetTotalCountSearchDetails (
    wfSearchParameter As WfSearchParameter
) As Integer
Visual C++
int GetTotalCountSearchDetails(
    WfSearchParameter^ wfSearchParameter
)

Parameters

wfSearchParameter
Type: CelloSaaS.WorkFlow.Model..::..WfSearchParameter
The wf search parameter.

Return Value

Type: Int32

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetTotalCountWFTInstanceSearchDetails Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetTotalCountWFTInstanceSearchDetails Method
IWorkflowService Interface See Also Send Feedback
Gets the total count search details of Workflow Task Instance.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
int GetTotalCountWFTInstanceSearchDetails(
    WfSearchParameter wfSearchParameter
)
Visual Basic
Function GetTotalCountWFTInstanceSearchDetails (
    wfSearchParameter As WfSearchParameter
) As Integer
Visual C++
int GetTotalCountWFTInstanceSearchDetails(
    WfSearchParameter^ wfSearchParameter
)

Parameters

wfSearchParameter
Type: CelloSaaS.WorkFlow.Model..::..WfSearchParameter
The wf search parameter.

Return Value

Type: Int32
Search result count

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetUnAllocatedTaskInstances Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetUnAllocatedTaskInstances Method
IWorkflowService Interface See Also Send Feedback
Gets the un allocated workflow instances for the given task code and workflow id

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowInstance> GetUnAllocatedTaskInstances(
    string workflowId,
    string taskCode,
    string currentTaskCode,
    string tenantId,
    int recordStart = 0,
    int recordEnd = 0
)
Visual Basic
Function GetUnAllocatedTaskInstances (
    workflowId As String,
    taskCode As String,
    currentTaskCode As String,
    tenantId As String,
    Optional recordStart As Integer = 0,
    Optional recordEnd As Integer = 0
) As List(Of WorkflowInstance)
Visual C++
List<WorkflowInstance^>^ GetUnAllocatedTaskInstances(
    String^ workflowId,
    String^ taskCode,
    String^ currentTaskCode,
    String^ tenantId,
    int recordStart = 0,
    int recordEnd = 0
)

Parameters

workflowId
Type: System..::..String
The workflow id.
taskCode
Type: System..::..String
The task code.
currentTaskCode
Type: System..::..String
The current task code.
tenantId
Type: System..::..String
The tenant id.
recordStart (Optional)
Type: System..::..Int32
The record start.
recordEnd (Optional)
Type: System..::..Int32
The record end.

Return Value

Type: List<(Of <(<' WorkflowInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetWorkflow Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetWorkflow Method
IWorkflowService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWorkflow(String, String) | This method is used to get the workflow details for the given workflow id and tenant id.
Public method | GetWorkflow(String, String, String) | Gets the workflow.

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetWorkflow Method (String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetWorkflow Method (String, String)
IWorkflowService Interface See Also Send Feedback
This method is used to get the workflow details for the given workflow id and tenant id.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowModel GetWorkflow(
    string workflowId,
    string tenantId
)
Visual Basic
Function GetWorkflow (
    workflowId As String,
    tenantId As String
) As WorkflowModel
Visual C++
WorkflowModel^ GetWorkflow(
    String^ workflowId,
    String^ tenantId
)

Parameters

workflowId
Type: System..::..String
The workflow id [Mandatory].
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: WorkflowModel
The WorkflowModel

See Also

IWorkflowService Interface
IWorkflowService Members
GetWorkflow Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetWorkflow Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetWorkflow Method (String, String, String)
IWorkflowService Interface See Also Send Feedback
Gets the workflow.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowModel GetWorkflow(
    string workflowId,
    string tenantId,
    string filterId
)
Visual Basic
Function GetWorkflow (
    workflowId As String,
    tenantId As String,
    filterId As String
) As WorkflowModel
Visual C++
WorkflowModel^ GetWorkflow(
    String^ workflowId,
    String^ tenantId,
    String^ filterId
)

Parameters

workflowId
Type: System..::..String
The workflow id.
tenantId
Type: System..::..String
The tenant id.
filterId
Type: System..::..String
The filter id.

Return Value

Type: WorkflowModel

See Also

IWorkflowService Interface
IWorkflowService Members
GetWorkflow Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetWorkflowByName Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetWorkflowByName Method
IWorkflowService Interface See Also Send Feedback
This method is used to get the workflow details based on the workflow name

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
WorkflowModel GetWorkflowByName(
    string workflowName,
    string tenantId
)
Visual Basic
Function GetWorkflowByName (
    workflowName As String,
    tenantId As String
) As WorkflowModel
Visual C++
WorkflowModel^ GetWorkflowByName(
    String^ workflowName,
    String^ tenantId
)

Parameters

workflowName
Type: System..::..String
Name of the workflow.
tenantId
Type: System..::..String
The tenant id.

Return Value

Type: WorkflowModel

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetWorkflowExceptionDetails Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetWorkflowExceptionDetails Method
IWorkflowService Interface See Also Send Feedback
Gets the workflow exception details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<string> GetWorkflowExceptionDetails(
    string wfTaskInstanceId
)
Visual Basic
Function GetWorkflowExceptionDetails (
    wfTaskInstanceId As String
) As List(Of String)
Visual C++
List<String^>^ GetWorkflowExceptionDetails(
    String^ wfTaskInstanceId
)

Parameters

wfTaskInstanceId
Type: System..::..String
The wf task instance id.

Return Value

Type: List<(Of <(<'String>)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.GetWorkflows Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..GetWorkflows Method
IWorkflowService Interface See Also Send Feedback
Get the list of workflow details for the tenant

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowModel> GetWorkflows(
    string tenantId
)
Visual Basic
Function GetWorkflows (
    tenantId As String
) As List(Of WorkflowModel)
Visual C++
List<WorkflowModel^>^ GetWorkflows(
    String^ tenantId
)

Parameters

tenantId
Type: System..::..String
The tenant id.

Return Value

Type: List<(Of <(<' WorkflowModel >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.RestartWorkflowStep Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..RestartWorkflowStep Method
IWorkflowService Interface See Also Send Feedback
This method is used to restart the particular errored step in the workflow.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
bool RestartWorkflowStep(
    string wfId,
    string wfInstanceId,
    string mapId,
    string taskCode,
    string tenantId
)
Visual Basic
Function RestartWorkflowStep (
    wfId As String,
    wfInstanceId As String,
    mapId As String,
    taskCode As String,
    tenantId As String
) As Boolean
Visual C++
bool RestartWorkflowStep(
    String^ wfId,
    String^ wfInstanceId,
    String^ mapId,
    String^ taskCode,
    String^ tenantId
)

Parameters

wfId
Type: System..::..String
The wf id.
wfInstanceId
Type: System..::..String
The wf instance id.
mapId
Type: System..::..String
The map id.
taskCode
Type: System..::..String
The task code.
tenantId
Type: System..::..String

Return Value

Type: Boolean

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.SaveWorkflow Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..SaveWorkflow Method
IWorkflowService Interface See Also Send Feedback
This method is used to save workflow details

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
string SaveWorkflow(
    WorkflowModel workflowModel
)
Visual Basic
Function SaveWorkflow (
    workflowModel As WorkflowModel
) As String
Visual C++
String^ SaveWorkflow(
    WorkflowModel^ workflowModel
)

Parameters

workflowModel
Type: CelloSaaS.WorkFlow.Model..::..WorkflowModel
The workflow model.

Return Value

Type: String

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.SearchWorkFlowInstance Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..SearchWorkFlowInstance Method
IWorkflowService Interface See Also Send Feedback
This method is used to get the workflow instance details based on the search parameter

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowInstance> SearchWorkFlowInstance(
    WfSearchParameter wfSearchParameter
)
Visual Basic
Function SearchWorkFlowInstance (
    wfSearchParameter As WfSearchParameter
) As List(Of WorkflowInstance)
Visual C++
List<WorkflowInstance^>^ SearchWorkFlowInstance(
    WfSearchParameter^ wfSearchParameter
)

Parameters

wfSearchParameter
Type: CelloSaaS.WorkFlow.Model..::..WfSearchParameter
The wf search parameter.

Return Value

Type: List<(Of <(<' WorkflowInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.SearchWorkFlowInstanceDeep Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..SearchWorkFlowInstanceDeep Method
IWorkflowService Interface See Also Send Feedback
This method is used to Search the work flow instance deep.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowInstance> SearchWorkFlowInstanceDeep(
    WfSearchParameter wfSearchParameter
)
Visual Basic
Function SearchWorkFlowInstanceDeep (
    wfSearchParameter As WfSearchParameter
) As List(Of WorkflowInstance)
Visual C++
List<WorkflowInstance^>^ SearchWorkFlowInstanceDeep(
    WfSearchParameter^ wfSearchParameter
)

Parameters

wfSearchParameter
Type: CelloSaaS.WorkFlow.Model..::..WfSearchParameter
The wf search parameter.

Return Value

Type: List<(Of <(<' WorkflowInstance >)>)>
List of WorkflowInstance

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowService.SearchWorkFlowTaskInstance Method

[image]

A Sandcastle Documented Class Library
IWorkflowService..::..SearchWorkFlowTaskInstance Method
IWorkflowService Interface See Also Send Feedback
This method is used to get the workflow task instance details based on the search parameter

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<WorkflowTaskInstance> SearchWorkFlowTaskInstance(
    WfSearchParameter wfSearchParameter
)
Visual Basic
Function SearchWorkFlowTaskInstance (
    wfSearchParameter As WfSearchParameter
) As List(Of WorkflowTaskInstance)
Visual C++
List<WorkflowTaskInstance^>^ SearchWorkFlowTaskInstance(
    WfSearchParameter^ wfSearchParameter
)

Parameters

wfSearchParameter
Type: CelloSaaS.WorkFlow.Model..::..WfSearchParameter
The wf search parameter.

Return Value

Type: List<(Of <(<' WorkflowTaskInstance >)>)>

See Also

IWorkflowService Interface
IWorkflowService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService Interface

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowTaskActorService
Visual Basic
Public Interface IWorkflowTaskActorService
Visual C++
public interface class IWorkflowTaskActorService

See Also

IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService Members
IWorkflowTaskActorService Interface Methods Properties See Also Send Feedback

The IWorkflowTaskActorService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteDynamicTaskActors(String, String) | Deletes the dynamic task actors.
Public method | DeleteDynamicTaskActors(String, String, array<String>[]()[][]) | Deletes the dynamic task actors.
Public method | DeleteTaskActorDetails | Deletes the task actor details.
Public method | GetDynamicTaskActors | Gets the dynamic task actor ids.
Public method | GetTaskActors(ITaskActorDefinition, String) | Gets the task actors.
Public method | GetTaskActors(String, String, String) | Gets the task actors.
Public method | UpdateDynamicTaskActorDetails | Updates the dynamic task actor details.
Public method | UpdateDynamicTaskDetailsByWfInstanceId | Updates the dynamic task details by wf instance id.

Properties

 | Name | Description
Public property | Repository | Gets or sets the repository.

See Also

IWorkflowTaskActorService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService Methods
IWorkflowTaskActorService Interface See Also Send Feedback

The IWorkflowTaskActorService type exposes the following members.

Methods

 | Name | Description
Public method | DeleteDynamicTaskActors(String, String) | Deletes the dynamic task actors.
Public method | DeleteDynamicTaskActors(String, String, array<String>[]()[][]) | Deletes the dynamic task actors.
Public method | DeleteTaskActorDetails | Deletes the task actor details.
Public method | GetDynamicTaskActors | Gets the dynamic task actor ids.
Public method | GetTaskActors(ITaskActorDefinition, String) | Gets the task actors.
Public method | GetTaskActors(String, String, String) | Gets the task actors.
Public method | UpdateDynamicTaskActorDetails | Updates the dynamic task actor details.
Public method | UpdateDynamicTaskDetailsByWfInstanceId | Updates the dynamic task details by wf instance id.

See Also

IWorkflowTaskActorService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.DeleteDynamicTaskActors Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..DeleteDynamicTaskActors Method
IWorkflowTaskActorService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteDynamicTaskActors(String, String) | Deletes the dynamic task actors.
Public method | DeleteDynamicTaskActors(String, String, array<String>[]()[][]) | Deletes the dynamic task actors.

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.DeleteDynamicTaskActors Method (String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..DeleteDynamicTaskActors Method (String, String)
IWorkflowTaskActorService Interface See Also Send Feedback
Deletes the dynamic task actors.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteDynamicTaskActors(
    string wfInstanceId,
    string taskCode
)
Visual Basic
Sub DeleteDynamicTaskActors (
    wfInstanceId As String,
    taskCode As String
)
Visual C++
void DeleteDynamicTaskActors(
    String^ wfInstanceId,
    String^ taskCode
)

Parameters

wfInstanceId
Type: System..::..String
The wf instance id [Mandatory].
taskCode
Type: System..::..String
The task code [Mandatory].

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
DeleteDynamicTaskActors Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.DeleteDynamicTaskActors Method (String, String, String[])

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..DeleteDynamicTaskActors Method (String, String, array<String>[]()[][])
IWorkflowTaskActorService Interface See Also Send Feedback
Deletes the dynamic task actors.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteDynamicTaskActors(
    string wfInstanceId,
    string taskCode,
    string[] actorIds
)
Visual Basic
Sub DeleteDynamicTaskActors (
    wfInstanceId As String,
    taskCode As String,
    actorIds As String()
)
Visual C++
void DeleteDynamicTaskActors(
    String^ wfInstanceId,
    String^ taskCode,
    array<String^>^ actorIds
)

Parameters

wfInstanceId
Type: System..::..String
The wf instance id [Mandatory].
taskCode
Type: System..::..String
The task code [Mandatory].
actorIds
Type: array<System..::..String>[]()[][]
The actor ids.

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
DeleteDynamicTaskActors Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.DeleteTaskActorDetails Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..DeleteTaskActorDetails Method
IWorkflowTaskActorService Interface See Also Send Feedback
Deletes the task actor details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void DeleteTaskActorDetails(
    Dictionary<Guid, string> actorIdWithTaskInstanceId
)
Visual Basic
Sub DeleteTaskActorDetails (
    actorIdWithTaskInstanceId As Dictionary(Of Guid, String)
)
Visual C++
void DeleteTaskActorDetails(
    Dictionary<Guid, String^>^ actorIdWithTaskInstanceId
)

Parameters

actorIdWithTaskInstanceId
Type: System.Collections.Generic..::..Dictionary<(Of <(<'Guid, String>)>)>
The actor id with task instance id.

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.GetDynamicTaskActors Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..GetDynamicTaskActors Method
IWorkflowTaskActorService Interface See Also Send Feedback
Gets the dynamic task actor ids.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskActor> GetDynamicTaskActors(
    string wfInstanceId,
    string taskCode
)
Visual Basic
Function GetDynamicTaskActors (
    wfInstanceId As String,
    taskCode As String
) As List(Of ITaskActor)
Visual C++
List<ITaskActor^>^ GetDynamicTaskActors(
    String^ wfInstanceId,
    String^ taskCode
)

Parameters

wfInstanceId
Type: System..::..String
The wf instance id [Mandatory].
taskCode
Type: System..::..String
The task code [Mandatory].

Return Value

Type: List<(Of <(<' ITaskActor >)>)>
List of ITaskActor

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.GetTaskActors Method

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..GetTaskActors Method
IWorkflowTaskActorService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetTaskActors(ITaskActorDefinition, String) | Gets the task actors.
Public method | GetTaskActors(String, String, String) | Gets the task actors.

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.GetTaskActors Method (ITaskActorDefinition, String)

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..GetTaskActors Method (ITaskActorDefinition, String)
IWorkflowTaskActorService Interface See Also Send Feedback
Gets the task actors.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskActor> GetTaskActors(
    ITaskActorDefinition actorDefinition,
    string tenantId
)
Visual Basic
Function GetTaskActors (
    actorDefinition As ITaskActorDefinition,
    tenantId As String
) As List(Of ITaskActor)
Visual C++
List<ITaskActor^>^ GetTaskActors(
    ITaskActorDefinition^ actorDefinition,
    String^ tenantId
)

Parameters

actorDefinition
Type: CelloSaaS.WorkFlow.Model..::..ITaskActorDefinition
The actor definition.
tenantId
Type: System..::..String

Return Value

Type: List<(Of <(<' ITaskActor >)>)>
List of ITaskActor

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
GetTaskActors Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.GetTaskActors Method (String, String, String)

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..GetTaskActors Method (String, String, String)
IWorkflowTaskActorService Interface See Also Send Feedback
Gets the task actors.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
List<ITaskActor> GetTaskActors(
    string taskId,
    string workflowId,
    string tenantId
)
Visual Basic
Function GetTaskActors (
    taskId As String,
    workflowId As String,
    tenantId As String
) As List(Of ITaskActor)
Visual C++
List<ITaskActor^>^ GetTaskActors(
    String^ taskId,
    String^ workflowId,
    String^ tenantId
)

Parameters

taskId
Type: System..::..String
The task id.
workflowId
Type: System..::..String
The workflow id.
tenantId
Type: System..::..String

Return Value

Type: List<(Of <(<' ITaskActor >)>)>
List of ITaskActor

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
GetTaskActors Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.UpdateDynamicTaskActorDetails Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..UpdateDynamicTaskActorDetails Method
IWorkflowTaskActorService Interface See Also Send Feedback
Updates the dynamic task actor details.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDynamicTaskActorDetails(
    string mapId,
    Dictionary<string, List<string>> taskActorList,
    string tenantId
)
Visual Basic
Sub UpdateDynamicTaskActorDetails (
    mapId As String,
    taskActorList As Dictionary(Of String, List(Of String)),
    tenantId As String
)
Visual C++
void UpdateDynamicTaskActorDetails(
    String^ mapId,
    Dictionary<String^, List<String^>^>^ taskActorList,
    String^ tenantId
)

Parameters

mapId
Type: System..::..String
The map id [Mandatory].
taskActorList
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
The task actor list [Mandatory].
tenantId
Type: System..::..String
The tenant id [Mandatory].

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.UpdateDynamicTaskDetailsByWfInstanceId Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..UpdateDynamicTaskDetailsByWfInstanceId Method
IWorkflowTaskActorService Interface See Also Send Feedback
Updates the dynamic task details by wf instance id.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void UpdateDynamicTaskDetailsByWfInstanceId(
    string wfInstanceId,
    Dictionary<string, List<string>> taskActorList,
    string tenantId
)
Visual Basic
Sub UpdateDynamicTaskDetailsByWfInstanceId (
    wfInstanceId As String,
    taskActorList As Dictionary(Of String, List(Of String)),
    tenantId As String
)
Visual C++
void UpdateDynamicTaskDetailsByWfInstanceId(
    String^ wfInstanceId,
    Dictionary<String^, List<String^>^>^ taskActorList,
    String^ tenantId
)

Parameters

wfInstanceId
Type: System..::..String
The wf instance id [Mandatory].
taskActorList
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, List<(Of <(<'String>)>)>>)>)>
The task actor list [Mandatory].
tenantId
Type: System..::..String
The tenant id [Mandatory].

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService Properties

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService Properties
IWorkflowTaskActorService Interface See Also Send Feedback

The IWorkflowTaskActorService type exposes the following members.

Properties

 | Name | Description
Public property | Repository | Gets or sets the repository.

See Also

IWorkflowTaskActorService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskActorService.Repository Property

[image]

A Sandcastle Documented Class Library
IWorkflowTaskActorService..::..Repository Property
IWorkflowTaskActorService Interface See Also Send Feedback
Gets or sets the repository.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
BatchRepository Repository { get; set; }
Visual Basic
Property Repository As BatchRepository
    Get
    Set
Visual C++
property BatchRepository^ Repository {
    BatchRepository^ get ();
    void set (BatchRepository^ value);
}

Property Value

Type: BatchRepository
The repository.

See Also

IWorkflowTaskActorService Interface
IWorkflowTaskActorService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService Interface

[image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService Interface
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public interface IWorkflowTaskInstanceService
Visual Basic
Public Interface IWorkflowTaskInstanceService
Visual C++
public interface class IWorkflowTaskInstanceService

See Also

IWorkflowTaskInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService Members

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService Members
IWorkflowTaskInstanceService Interface Methods See Also Send Feedback

The IWorkflowTaskInstanceService type exposes the following members.

Methods

 | Name | Description
Public method | CompleteTask | Completes the task.
Public method | ExecuteTask | Executes the task.
Public method | GetActivity | Gets the activity.
Public method | Initialize | This method is used to initialize the workflow service, workflow task instance and task actor.
Public method | StartTask | Starts the task.

See Also

IWorkflowTaskInstanceService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService Methods

[image] [image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService Methods
IWorkflowTaskInstanceService Interface See Also Send Feedback

The IWorkflowTaskInstanceService type exposes the following members.

Methods

 | Name | Description
Public method | CompleteTask | Completes the task.
Public method | ExecuteTask | Executes the task.
Public method | GetActivity | Gets the activity.
Public method | Initialize | This method is used to initialize the workflow service, workflow task instance and task actor.
Public method | StartTask | Starts the task.

See Also

IWorkflowTaskInstanceService Interface
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService.CompleteTask Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService..::..CompleteTask Method
IWorkflowTaskInstanceService Interface See Also Send Feedback
Completes the task.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void CompleteTask(
    params Object[] inputObjects
)
Visual Basic
Sub CompleteTask (
    ParamArray inputObjects As Object()
)
Visual C++
void CompleteTask(
    ... array<Object^>^ inputObjects
)

Parameters

inputObjects
Type: array<System..::..Object>[]()[][]
The input objects.

See Also

IWorkflowTaskInstanceService Interface
IWorkflowTaskInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService.ExecuteTask Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService..::..ExecuteTask Method
IWorkflowTaskInstanceService Interface See Also Send Feedback
Executes the task.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void ExecuteTask(
    params Object[] inputObjects
)
Visual Basic
Sub ExecuteTask (
    ParamArray inputObjects As Object()
)
Visual C++
void ExecuteTask(
    ... array<Object^>^ inputObjects
)

Parameters

inputObjects
Type: array<System..::..Object>[]()[][]

See Also

IWorkflowTaskInstanceService Interface
IWorkflowTaskInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService.GetActivity Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService..::..GetActivity Method
IWorkflowTaskInstanceService Interface See Also Send Feedback
Gets the activity.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
IActivity GetActivity(
    ITaskActivityDefinition taskDefinition
)
Visual Basic
Function GetActivity (
    taskDefinition As ITaskActivityDefinition
) As IActivity
Visual C++
IActivity^ GetActivity(
    ITaskActivityDefinition^ taskDefinition
)

Parameters

taskDefinition
Type: CelloSaaS.WorkFlow.Model..::..ITaskActivityDefinition
The task definition.

Return Value

Type: IActivity

See Also

IWorkflowTaskInstanceService Interface
IWorkflowTaskInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService.Initialize Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService..::..Initialize Method
IWorkflowTaskInstanceService Interface See Also Send Feedback
This method is used to initialize the workflow service, workflow task instance and task actor.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void Initialize(
    WorkflowInstanceService workflowService,
    WorkflowTaskInstance workflowTaskInstance,
    ITaskActor taskActor
)
Visual Basic
Sub Initialize (
    workflowService As WorkflowInstanceService,
    workflowTaskInstance As WorkflowTaskInstance,
    taskActor As ITaskActor
)
Visual C++
void Initialize(
    WorkflowInstanceService^ workflowService,
    WorkflowTaskInstance^ workflowTaskInstance,
    ITaskActor^ taskActor
)

Parameters

workflowService
Type: WorkflowInstanceService
The workflow service.
workflowTaskInstance
Type: CelloSaaS.WorkFlow.Model..::..WorkflowTaskInstance
The workflow task instance.
taskActor
Type: CelloSaaS.WorkFlow.Model..::..ITaskActor
The task actor.

See Also

IWorkflowTaskInstanceService Interface
IWorkflowTaskInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


IWorkflowTaskInstanceService.StartTask Method

[image]

A Sandcastle Documented Class Library
IWorkflowTaskInstanceService..::..StartTask Method
IWorkflowTaskInstanceService Interface See Also Send Feedback
Starts the task.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
void StartTask(
    params Object[] objects
)
Visual Basic
Sub StartTask (
    ParamArray objects As Object()
)
Visual C++
void StartTask(
    ... array<Object^>^ objects
)

Parameters

objects
Type: array<System..::..Object>[]()[][]
The objects.

See Also

IWorkflowTaskInstanceService Interface
IWorkflowTaskInstanceService Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants Class

[image]

A Sandcastle Documented Class Library
WorkflowConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WorkflowConstants
Visual Basic
Public Class WorkflowConstants
Visual C++
public ref class WorkflowConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.ServiceContracts..::..WorkflowConstants

See Also

WorkflowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants Members

[image] [image]

A Sandcastle Documented Class Library
WorkflowConstants Members
WorkflowConstants Class Constructors Methods Fields See Also Send Feedback

The WorkflowConstants type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowConstants | Initializes a new instance of the WorkflowConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ConnectionString |
ModuleConfigurationId |

See Also

WorkflowConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants Constructor

[image]

A Sandcastle Documented Class Library
WorkflowConstants Constructor
WorkflowConstants Class See Also Send Feedback
Initializes a new instance of the WorkflowConstants class

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkflowConstants()
Visual Basic
Public Sub New
Visual C++
public:
WorkflowConstants()

See Also

WorkflowConstants Class
WorkflowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants Fields

[image] [image]

A Sandcastle Documented Class Library
WorkflowConstants Fields
WorkflowConstants Class See Also Send Feedback

The WorkflowConstants type exposes the following members.

Fields

Name | Description
ConnectionString |
ModuleConfigurationId |

See Also

WorkflowConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants.ConnectionString Field

[image]

A Sandcastle Documented Class Library
WorkflowConstants..::..ConnectionString Field
WorkflowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ConnectionString
Visual Basic
Public Const ConnectionString As String
Visual C++
public:
literal String^ ConnectionString

Field Value

Type: String

See Also

WorkflowConstants Class
WorkflowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants.ModuleConfigurationId Field

[image]

A Sandcastle Documented Class Library
WorkflowConstants..::..ModuleConfigurationId Field
WorkflowConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ModuleConfigurationId
Visual Basic
Public Const ModuleConfigurationId As String
Visual C++
public:
literal String^ ModuleConfigurationId

Field Value

Type: String

See Also

WorkflowConstants Class
WorkflowConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkflowConstants Methods

[image] [image]

A Sandcastle Documented Class Library
WorkflowConstants Methods
WorkflowConstants Class See Also Send Feedback

The WorkflowConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkflowConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Class

[image]

A Sandcastle Documented Class Library
WorkFlowException Class
Members See Also Send Feedback
Represents errors that occur during WorkFlow Service execution.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
[SerializableAttribute]
public class WorkFlowException : Exception
Visual Basic
<SerializableAttribute>
Public Class WorkFlowException
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class WorkFlowException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
CelloSaaS.WorkFlow.ServiceContracts..::..WorkFlowException

See Also

WorkFlowException Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Members

[image] [image]

A Sandcastle Documented Class Library
WorkFlowException Members
WorkFlowException Class Constructors Methods Properties Events See Also Send Feedback

The WorkFlowException type exposes the following members.

Constructors

 | Name | Description
Public method | WorkFlowException()()()() | Initializes a new instance of the WorkFlowException class.
Public method | WorkFlowException(String) | Initializes a new instance of the WorkFlowException class with a specified error message.
Public method | WorkFlowException(String, Exception) | Initializes a new instance of the WorkFlowException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

WorkFlowException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Constructor

[image] [image]

A Sandcastle Documented Class Library
WorkFlowException Constructor
WorkFlowException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WorkFlowException()()()() | Initializes a new instance of the WorkFlowException class.
Public method | WorkFlowException(String) | Initializes a new instance of the WorkFlowException class with a specified error message.
Public method | WorkFlowException(String, Exception) | Initializes a new instance of the WorkFlowException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

WorkFlowException Class
WorkFlowException Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Constructor

[image]

A Sandcastle Documented Class Library
WorkFlowException Constructor
WorkFlowException Class See Also Send Feedback
Initializes a new instance of the WorkFlowException class.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkFlowException()
Visual Basic
Public Sub New
Visual C++
public:
WorkFlowException()

See Also

WorkFlowException Class
WorkFlowException Members
WorkFlowException Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Constructor (String)

[image]

A Sandcastle Documented Class Library
WorkFlowException Constructor (String)
WorkFlowException Class See Also Send Feedback
Initializes a new instance of the WorkFlowException class with a specified error message.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkFlowException(
    string message
)
Visual Basic
Public Sub New (
    message As String
)
Visual C++
public:
WorkFlowException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

WorkFlowException Class
WorkFlowException Members
WorkFlowException Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Constructor (String, Exception)

[image]

A Sandcastle Documented Class Library
WorkFlowException Constructor (String, Exception)
WorkFlowException Class See Also Send Feedback
Initializes a new instance of the WorkFlowException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkFlowException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New (
    message As String,
    innerException As Exception
)
Visual C++
public:
WorkFlowException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The message that describes the error.
innerException
Type: System..::..Exception
The exception that is the cause of the current exception, or a null reference.

See Also

WorkFlowException Class
WorkFlowException Members
WorkFlowException Overload
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Methods

[image] [image]

A Sandcastle Documented Class Library
WorkFlowException Methods
WorkFlowException Class See Also Send Feedback

The WorkFlowException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

WorkFlowException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Properties

[image] [image]

A Sandcastle Documented Class Library
WorkFlowException Properties
WorkFlowException Class See Also Send Feedback

The WorkFlowException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

WorkFlowException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowException Events

[image] [image]

A Sandcastle Documented Class Library
WorkFlowException Events
WorkFlowException Class See Also Send Feedback

The WorkFlowException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

WorkFlowException Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus Class

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WorkFlowExecutionStatus
Visual Basic
Public Class WorkFlowExecutionStatus
Visual C++
public ref class WorkFlowExecutionStatus

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.ServiceContracts..::..WorkFlowExecutionStatus

See Also

WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus Members

[image] [image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus Members
WorkFlowExecutionStatus Class Constructors Methods Fields See Also Send Feedback

The WorkFlowExecutionStatus type exposes the following members.

Constructors

 | Name | Description
Public method | WorkFlowExecutionStatus | Initializes a new instance of the WorkFlowExecutionStatus class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Completed |
Errored |
Executed |
Expired |
Routed |
Skipped |
Started |

See Also

WorkFlowExecutionStatus Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus Constructor

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus Constructor
WorkFlowExecutionStatus Class See Also Send Feedback
Initializes a new instance of the WorkFlowExecutionStatus class

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkFlowExecutionStatus()
Visual Basic
Public Sub New
Visual C++
public:
WorkFlowExecutionStatus()

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus Fields

[image] [image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus Fields
WorkFlowExecutionStatus Class See Also Send Feedback

The WorkFlowExecutionStatus type exposes the following members.

Fields

Name | Description
Completed |
Errored |
Executed |
Expired |
Routed |
Skipped |
Started |

See Also

WorkFlowExecutionStatus Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Completed Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Completed Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Completed
Visual Basic
Public Const Completed As String
Visual C++
public:
literal String^ Completed

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Errored Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Errored Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Errored
Visual Basic
Public Const Errored As String
Visual C++
public:
literal String^ Errored

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Executed Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Executed Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Executed
Visual Basic
Public Const Executed As String
Visual C++
public:
literal String^ Executed

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Expired Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Expired Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Expired
Visual Basic
Public Const Expired As String
Visual C++
public:
literal String^ Expired

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Routed Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Routed Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Routed
Visual Basic
Public Const Routed As String
Visual C++
public:
literal String^ Routed

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Skipped Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Skipped Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Skipped
Visual Basic
Public Const Skipped As String
Visual C++
public:
literal String^ Skipped

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus.Started Field

[image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus..::..Started Field
WorkFlowExecutionStatus Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string Started
Visual Basic
Public Const Started As String
Visual C++
public:
literal String^ Started

Field Value

Type: String

See Also

WorkFlowExecutionStatus Class
WorkFlowExecutionStatus Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowExecutionStatus Methods

[image] [image]

A Sandcastle Documented Class Library
WorkFlowExecutionStatus Methods
WorkFlowExecutionStatus Class See Also Send Feedback

The WorkFlowExecutionStatus type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkFlowExecutionStatus Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants Class

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public class WorkFlowPrivilegeConstants
Visual Basic
Public Class WorkFlowPrivilegeConstants
Visual C++
public ref class WorkFlowPrivilegeConstants

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.ServiceContracts..::..WorkFlowPrivilegeConstants

See Also

WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants Members

[image] [image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants Members
WorkFlowPrivilegeConstants Class Constructors Methods Fields See Also Send Feedback

The WorkFlowPrivilegeConstants type exposes the following members.

Constructors

 | Name | Description
Public method | WorkFlowPrivilegeConstants | Initializes a new instance of the WorkFlowPrivilegeConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AddWorkflowDesign |
DeleteWorkflowDesign |
EditWorkflowDesign |
PublishWorkflowDesign |
ViewWorkflowDesign |

See Also

WorkFlowPrivilegeConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants Constructor

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants Constructor
WorkFlowPrivilegeConstants Class See Also Send Feedback
Initializes a new instance of the WorkFlowPrivilegeConstants class

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public WorkFlowPrivilegeConstants()
Visual Basic
Public Sub New
Visual C++
public:
WorkFlowPrivilegeConstants()

See Also

WorkFlowPrivilegeConstants Class
WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants Fields

[image] [image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants Fields
WorkFlowPrivilegeConstants Class See Also Send Feedback

The WorkFlowPrivilegeConstants type exposes the following members.

Fields

Name | Description
AddWorkflowDesign |
DeleteWorkflowDesign |
EditWorkflowDesign |
PublishWorkflowDesign |
ViewWorkflowDesign |

See Also

WorkFlowPrivilegeConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants.AddWorkflowDesign Field

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants..::..AddWorkflowDesign Field
WorkFlowPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string AddWorkflowDesign
Visual Basic
Public Const AddWorkflowDesign As String
Visual C++
public:
literal String^ AddWorkflowDesign

Field Value

Type: String

See Also

WorkFlowPrivilegeConstants Class
WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants.DeleteWorkflowDesign Field

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants..::..DeleteWorkflowDesign Field
WorkFlowPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string DeleteWorkflowDesign
Visual Basic
Public Const DeleteWorkflowDesign As String
Visual C++
public:
literal String^ DeleteWorkflowDesign

Field Value

Type: String

See Also

WorkFlowPrivilegeConstants Class
WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants.EditWorkflowDesign Field

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants..::..EditWorkflowDesign Field
WorkFlowPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string EditWorkflowDesign
Visual Basic
Public Const EditWorkflowDesign As String
Visual C++
public:
literal String^ EditWorkflowDesign

Field Value

Type: String

See Also

WorkFlowPrivilegeConstants Class
WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants.PublishWorkflowDesign Field

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants..::..PublishWorkflowDesign Field
WorkFlowPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string PublishWorkflowDesign
Visual Basic
Public Const PublishWorkflowDesign As String
Visual C++
public:
literal String^ PublishWorkflowDesign

Field Value

Type: String

See Also

WorkFlowPrivilegeConstants Class
WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants.ViewWorkflowDesign Field

[image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants..::..ViewWorkflowDesign Field
WorkFlowPrivilegeConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ViewWorkflowDesign
Visual Basic
Public Const ViewWorkflowDesign As String
Visual C++
public:
literal String^ ViewWorkflowDesign

Field Value

Type: String

See Also

WorkFlowPrivilegeConstants Class
WorkFlowPrivilegeConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowPrivilegeConstants Methods

[image] [image]

A Sandcastle Documented Class Library
WorkFlowPrivilegeConstants Methods
WorkFlowPrivilegeConstants Class See Also Send Feedback

The WorkFlowPrivilegeConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

WorkFlowPrivilegeConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants Class

[image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants Class
Members See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public static class WorkFlowTrackingConstants
Visual Basic
Public NotInheritable Class WorkFlowTrackingConstants
Visual C++
public ref class WorkFlowTrackingConstants abstract sealed

Inheritance Hierarchy

System..::..Object
CelloSaaS.WorkFlow.ServiceContracts..::..WorkFlowTrackingConstants

See Also

WorkFlowTrackingConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants Members

[image] [image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants Members
WorkFlowTrackingConstants Class Fields See Also Send Feedback

The WorkFlowTrackingConstants type exposes the following members.

Fields

Name | Description
DefaultParallelThreadSize |
DefaultWorkFlowTrackingBlockSize |
ParallelThreadSize |
WorkFlowTrackingBlockSize |

See Also

WorkFlowTrackingConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants Fields

[image] [image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants Fields
WorkFlowTrackingConstants Class See Also Send Feedback

The WorkFlowTrackingConstants type exposes the following members.

Fields

Name | Description
DefaultParallelThreadSize |
DefaultWorkFlowTrackingBlockSize |
ParallelThreadSize |
WorkFlowTrackingBlockSize |

See Also

WorkFlowTrackingConstants Class
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants.DefaultParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants..::..DefaultParallelThreadSize Field
WorkFlowTrackingConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultParallelThreadSize
Visual Basic
Public Const DefaultParallelThreadSize As Integer
Visual C++
public:
literal int DefaultParallelThreadSize

Field Value

Type: Int32

See Also

WorkFlowTrackingConstants Class
WorkFlowTrackingConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants.DefaultWorkFlowTrackingBlockSize Field

[image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants..::..DefaultWorkFlowTrackingBlockSize Field
WorkFlowTrackingConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const int DefaultWorkFlowTrackingBlockSize
Visual Basic
Public Const DefaultWorkFlowTrackingBlockSize As Integer
Visual C++
public:
literal int DefaultWorkFlowTrackingBlockSize

Field Value

Type: Int32

See Also

WorkFlowTrackingConstants Class
WorkFlowTrackingConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants.ParallelThreadSize Field

[image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants..::..ParallelThreadSize Field
WorkFlowTrackingConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string ParallelThreadSize
Visual Basic
Public Const ParallelThreadSize As String
Visual C++
public:
literal String^ ParallelThreadSize

Field Value

Type: String

See Also

WorkFlowTrackingConstants Class
WorkFlowTrackingConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace


WorkFlowTrackingConstants.WorkFlowTrackingBlockSize Field

[image]

A Sandcastle Documented Class Library
WorkFlowTrackingConstants..::..WorkFlowTrackingBlockSize Field
WorkFlowTrackingConstants Class See Also Send Feedback

Namespace: CelloSaaS.WorkFlow.ServiceContracts
Assembly: CelloSaaS.Workflow (in CelloSaaS.Workflow.dll) Version: 4.3.2.0 (4.3.2.0)

Syntax

C#
public const string WorkFlowTrackingBlockSize
Visual Basic
Public Const WorkFlowTrackingBlockSize As String
Visual C++
public:
literal String^ WorkFlowTrackingBlockSize

Field Value

Type: String

See Also

WorkFlowTrackingConstants Class
WorkFlowTrackingConstants Members
CelloSaaS.WorkFlow.ServiceContracts Namespace